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1 About rendering and 
renderers
About Rendering

Rendering is the final stage in the 3D computer graphics production 
process. 

Though the wider context of rendering begins with shading and texturing 
objects and lighting your scene, the rendering process ends when surfaces, 
materials, lights, and motion are processed into a final image or image 
sequence. 

Visualization vs. the final render

As you build your scenes (shade and texture objects, light scenes, position 
cameras, etc.), you’ll want to visualize your scene many times before you 
produce the final rendered image or image sequence. This process may 
involve (depending on your particular project) creating and setting up 
additional cameras.

Visualize a scene during early iterations to detect and correct image 
quality problems or to estimate and reduce the amount of time the final 
render takes before you spend time performing the final render. 

When you are satisfied with the results of your scene during test renders, 
you can perform the final render. 

You can visualize and final render a single frame, part of an animation 
(multiple frames), or an entire animation in Maya.
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1 | About rendering and renderers 
About > The key to successful rendering
The key to successful rendering

The key to rendering is finding a balance between the visual complexity 
required and the rendering speed that determines how many frames can 
be rendered in a given period of time.

Rendering involves a large number of complex calculations which can 
keep your computer busy for a long time. Rendering pulls data together 
from every sub-system within Maya and interprets its own data relevant 
to (for example) tessellation, texture mapping, shading, clipping, and 
lighting.

Producing rendered images always involves making choices that affect the 
quality (anti-aliasing and sampling) of the images, the speed with which 
the images are rendered, or both. 

The highest quality images typically take the most time to render. The key 
to working efficiently is to produce good-enough quality images in as 
little time as possible in order to meet production deadlines. In other 
words, choose only the most economical values for options that let you 
produce images of acceptable quality for your particular project. 

Hardware, software, and vector rendering

Software rendering

Software rendering produces images of the highest quality, letting you 
achieve the most sophisticated results. 

Computation occurs on the CPU, as opposed to hardware rendering, 
which relies on the machine’s graphics card. Because it is not restricted by 
the computer's graphics card, software rendering generally is more 
flexible. The trade-off, however, is that software rendering is generally 
more time consuming.

Exactly what you can render depends on which software renderer you use 
and its particular limitations. 

Maya has the following software renderers: 

• The Maya software renderer

To find out about Maya’s software renderer, see ”Maya Software 
renderer” on page 15.

• mental ray for Maya

To find out about mental ray for Maya, see ”mental ray for Maya 
renderer” on page 17.
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1 | About rendering and renderers

About > Hardware rendering
Hardware rendering

Hardware rendering uses the computer's video card and drivers installed 
on the machine to render images to disk. Hardware rendering is generally 
faster than software rendering, but typically produces images of lower 
quality compared to software rendering. In some cases, however, 
hardware rendering can produce results good enough for broadcast 
delivery. 

Hardware rendering cannot produce some of the most sophisticated 
effects, such as some advanced shadows, reflections, and post-process 
effects. To produce these kind of effects, you must use software rendering.

Maya has the following hardware renderer:

• The Maya hardware renderer

To find out Maya’s hardware renderer, ”Maya Hardware renderer” 
on page 16.

Vector rendering

Vector rendering lets you create stylized renderings (for example, cartoon, 
tonal art, line art, hidden line, wireframe) in various bitmap image 
formats and 2D vector formats. 

Maya has the following vector renderer:

• The Maya vector renderer

To find out Maya’s vector renderer, ”Maya Vector renderer” on 
page 22.

Renderers

Maya Software renderer

Maya’s software renderer is an advanced, multi-threaded renderer. It is 
based on a rendering technology that is built directly into Maya's 
dependency graph architecture, which means its feature nodes can be 
intimately connected with any other feature in Maya. It provides artists 
with an excellent general purpose rendering solution with very broad 
capabilities. 

Note For information about the Hardware Render Buffer, see 
”Hardware Render Buffer” on page 233. 
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1 | About rendering and renderers 
About > Maya Hardware renderer
It is a hybrid renderer, offering true raytracing plus the speed advantages 
of a scan-line renderer. The Maya software renderer, while not slow, tends 
to favor quality and wide breadth of capability over raw speed.

The Maya software renderer supports all of the various entity types found 
within Maya including particles, various geometry and paint effects (as a 
post render process) and fluid effects. It also has a robust API for the 
addition of customer-programmed effects. 

The Maya software renderer features IPR (Interactive Photo Realistic 
rendering), a tool designed to allow you to make interactive adjustments 
to the final rendered image, and which greatly enhances rendering 
productivity. Most importantly, the nature of Maya's integrated 
architecture allows complex interconnections, like procedural textures and 
ramps that govern particle emission and other unpredictable relationships 
that are capable of producing stunning visual effects.

Maya Hardware renderer 

Maya’s hardware renderer presents a seamlessly integrated rendering 
solution that leverages the ever increasing power of next-generation 
graphics cards to render frames.

Benefits include an intuitive workflow to generate hardware rendered 
images for previews, specific passes, and hardware rendered particles. 
You can render and display images using the Render View, which lets you 
compare images during the shading and lighting tasks. 

The user experience and the visual quality of the final images significantly 
surpass that of the Hardware Render Buffer. You can produce broadcast-
resolution images in less time than with software rendering. In some 
cases, the quality may be good enough for final delivery.

The hardware renderer uses Maya's existing interface and workflow for 
assigning shaders, textures, particles, light linking, and so on. 

To prevent the windows of other applications from interfering with the 
rendering of the image, you can perform off-screen batch rendering. 

Highlights of supported features

Supported features include:

• Integrated rendering workflow and interface.

• Polygons and NURBS geometry.

• Multiple textured channels.

• Advanced transparency.

• Hardware particles.
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1 | About rendering and renderers

About > Supported hardware and platforms
• Instancing.

• Point, Directional, Spot, and Ambient Light types.

• Any number of lights.

• Light linking.

• Per-vertex and per-pixel shading effects.

• Multi-pass and multi-sampling anti-aliasing.

• File textures for any supported channel.

• On-the-fly procedural and shading network conversions.

• Specular highlights.

• Bumps.

• Reflections.

• Shadows.

• Motion blur.

• RBG color, alpha matte (mask), and Z depth output.

• Command line rendering. 

• Render diagnostics. Warnings for unsupported primitives, shaders, 
and light types and light features are provided.

Supported hardware and platforms

Only specific hardware and platform combinations are supported by 
hardware rendering. For more information, see:

http://www.alias.com/qual_charts

mental ray for Maya renderer

mental ray for Maya offers all the features traditionally expected of 
photorealistic rendering and includes functionality not found in most 
rendering software.

mental ray for Maya allows interactive and batch mental ray rendering 
from within the Maya user interface. With the help of built-in shaders 
supporting almost any effect available in Maya, mental ray for Maya 
allows the rendering of scenes created within Maya or their export into 
the mental images file format (.mi). 

(For detailed information on the mental ray standalone application, see 
the mental ray reference User Manual and the mental ray Shaders Guide, 
available from the Maya help.)
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1 | About rendering and renderers 
About > Known differences
After you load the mental ray plug-in (and select mental ray as the 
renderer), the Render menu lists available menu items for mental ray for 
Maya. As well, the Attribute Editor contains a mental ray section in which 
you can edit attributes that are used exclusively when rendering with 
mental ray for Maya. 

To load the mental ray for Maya plug-in, see the note in ”Select a 
renderer” on page 25.

IFF File format

The IFF image support in mental ray permits both color and depth 
information written into a single file. This requires the proper parameters 
to be set in the Render Global Settings (Depth Channel [Z Depth] in the 
Image File Output section must be turned on).

File Export

mental ray for Maya can also be used in Maya as a file exporter. When 
you export a Maya scene file to the proprietary mental images (.mi) file 
type, the file export simply writes a .mi file to disk with the given name. 
Additional options are available in the user interface to control ascii or 
binary mode export and file-pre-frame creation for animations.

See ”Exporting .mi files” on page 72.

Geometry Types

Maya supports three types of geometry: polygonal (Polygon Mesh), free-
form objects (NURBS curves/surfaces), and subdivision surfaces.

Known differences 

The native Maya and mental ray renderers may produce different results 
in certain situations. For more details, see ”Troubleshoot:mental ray for 
Maya renders look different than Maya renders” on page 122.

Note In Maya 5.0, the Render Global settings were unified, so some of 
the mental ray for Maya derive from Maya’ settings (from 
versions previous to Maya 5.0) no longer exist. 

You may need to modify some older files for which ‘derive from 
Maya’ was set by setting the mental ray for Maya render global 
settings. See ”Open the Render Global Settings window” on 
page 92 for more information. 
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1 | About rendering and renderers

About > Shading Networks and Nodes
Shading Networks and Nodes

A shading group in Maya defines the material, volume, and displacement 
shaders, along with the list of lights used in the illumination calculation 
for renderable objects. Such a shading group can directly be translated 
into a .mi material. 

For more information on mental ray for Maya shaders, see “mental ray for 
Maya Shaders” in the Shading guide.

Global illumination, Caustics, Final Gather, and HDRI

For information and procedures, see ”Indirect (global) vs. direct 
illumination” on page 11 in the Lighting guide.

Global illumination

mental ray for Maya can render with Global illumination, the technique 
used to capture indirect illumination (the natural phenomenon where 
light bounces off anything in its path until it is completely absorbed). 

Caustics 

mental ray can render with Caustics, the light effects that caused by 
specularly reflected or refracted light, like the shimmering light at the 
bottom of a pool of water. 

Final gather

mental ray for Maya can render with Final gather (a method of global 
illumination) to create very (or purely) diffuse scenes where the indirect 
illumination changes slowly. 

Support for HDR images

mental ray for Maya supports HDR images as file textures. 

Direct light with mental ray for Maya Area Lights

The main purpose of area light sources is to generate more realistic 
lighting, resulting in soft shadows. This is achieved by using one of four 
primitives (rectangles, discs, spheres, and cylinders) as light sources with 
nonzero area. 

For more information about mental ray for Maya areas lights, see ”mental 
ray Area Light” on page 15 in the Lighting guide.

Scene rendering 

mental ray for Maya 6.0 is based on the mental ray 3.3 rendering core. 
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1 | About rendering and renderers 
About > Scene rendering
• The preview image output is visible in the Maya Render View 
window. For more information, see ”Render View rendering” on 
page 71.

• The rendering settings can be further manipulated using the Render 
Global Settings window. For more information, see ”Render Global 
Settings window” on page 159.

• The ongoing rendering can be interrupted at any time using the 
Escape key (as with Maya’s native renderer), and mental ray progress 
is printed in the Output Window (Windows) or the Console (IRIX and 
Linux). For more information, see ”Perform final renders from within 
Maya” on page 114.

• Batch rendering is supported. When Render > Batch Render is 
selected, the current scene is stored in a temporary Maya file and a 
background mental ray render process is launched. Interactive and 
batch rendering processes can run in parallel, if enough memory is 
available. For more information, see ”Batch render a still or 
animation” on page 115.

Parallelism

mental ray for Maya supports both host and network parallel rendering. It 
renders identical output on all common and widely-used platforms. For 
network rendering, it performs best in a client-server setup, where it takes 
care of load balancing and network communication reduction. 

For information on mental ray for Maya network rendering, see ”mental 
ray for Maya network rendering” on page 146.

Animations

When rendering animation files or previewing animations inside Maya, 
mental ray for Maya exploits incremental changes. This means it 
determines if scene elements actually have changed between frames and 
just processes those changes, thus accelerating the render cycle. The check 
is based on Maya information and includes both geometry (plus instances) 
and shading nodes. If no changes are detected, the corresponding object or 
shader is not updated in subsequent frames and do appear animated. 

Incremental changes are not used if animations are exported as file per 
frame.

mental ray object rendering flags

You can control how particular objects contribute to certain rendering 
stages by setting per-object rendering flags in the object’s Attribute Editor. 

Motion Blur

For information about mental ray for Maya motion blur, see ”mental ray 
for Maya motion blur” on page 29. 
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1 | About rendering and renderers

About > Customizations
Customizations

(For mental ray advanced users only.)

The Custom Text Editor can be used to create and attach custom text to 
certain scene entities. This replaces the internally created .mi output with 
the custom text. Using the Custom Text Editor you can integrate custom 
mental ray shaders into Maya. 

To use the Custom Text Editor, see ”Custom mental ray text” on page 45  the 
Shading guide. 

mental ray for Maya checks and reads special custom attributes on certain 
Maya nodes and uses them for customized scene processing. Additionally, 
it adds its own custom nodes to Maya for convenient handling of mental 
ray extensions. 

All of these customizations are located in the Custom Entities section of 
the Render Global Settings window. For descriptions of the mental ray for 
Maya Custom Entities attributes, see ”mental ray tab” on page 184.

Custom mental ray text

mental ray for Maya supports a method to produce custom text in the 
output stream written to the .mi file. This is for text-only integration of 
custom mental ray shaders within Maya; it allows for the creation of 
special-purpose Maya nodes that hold customized mental images (mi) 
text. 

Custom vertex data

mental ray for Maya checks Maya polygonal meshes for additional 
dynamic (custom) attributes that supply per vertex data. This data is 
exported as additional mental ray texture spaces for shader access. 

For more information about custom vertex data, see ”Custom vertex data” 
on page 49 in the Shading guide. 

Warning

To reduce the potential of unpredictable results, the processing 
of such entities is disabled by default for the integrated preview 
rendering in Maya. 

Turn on Custom Entities at your own risk. It is, however, 
enabled for the .mi file export to create customized scene files 
for external rendering. 
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1 | About rendering and renderers 
About > Error handling and diagnostics
Error handling and diagnostics

mental ray for Maya checks for errors in a Maya scene and recognizes 
various operating system errors. You can use diagnostics to help you 
diagnose issues with samples and photon maps. 

For more information on mental ray for Maya diagnostics, see ”mental ray 
for Maya error handling and diagnostics” on page 142.

Maya Vector renderer

(Windows and Mac OS X)

You can use the Maya Vector renderer to create stylized renderings (for 
example, cartoon, tonal art, line art, hidden line, wireframe) in various 
bitmap image formats (for example, IFF, TIFF, and so on) or in the 
following 2D vector formats:

• Macromedia Flash (non-interactive) version 3, 4 or 5 (SWF)

• Adobe Illustrator version 8 (AI)

• Encapsulated PostScript Level 2 (EPS)

• Scalable Vector Graphics (SVG).

To select the Maya Vector renderer, see ”Select a renderer” on page 25. 

To set options for the Maya Vector renderer, see ”Render Global Settings 
window” on page 159.

Example Animations

helicopter.swf flowers.swf
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boat.swf car.swf

Note The Maya Vector renderer cannot render certain Maya features 
(see ”Maya features that do not vector render” on page 24).

Note If you are rendering SWF or SVG files for online delivery make 
sure you read ”Strategies to decrease vector render file size” on 
page 140. Otherwise you may create files that are too large for 
online delivery.

Example Animations
Rendering

23



1 | About rendering and renderers 
About > Maya features that do not vector render
Maya features that do not vector render

The Maya Vector renderer cannot render the following Maya features.

Maya Feature Notes

Bump maps Not rendered.

Displacement maps Not rendered. Use Modify > Convert > 
Displacement To Polygons to convert 
displacement maps to polygons for 
rendering.

Fluid effects Not rendered. Use Modify > Convert > Fluid 
To Polygons to convert fluid effects to 
polygons for rendering.

Image planes Not rendered.

Lights Only point lights are used during rendering. 
Only the following light attributes are 
considered during rendering: light location, 
light color, Emit Specular, Use Depth Map 
Shadows, Use Ray Trace Shadows.

Maya Fur Not rendered.

Multiple UVs Not rendered.

Paint effects Not rendered. Use Modify > Convert > Paint 
Effects To Polygons to convert paint effects 
to polygons for rendering.

Some Paint Effects may not render as 
expected. Many Paint Effects brushes use a 
transparency texture on a single polygon to 
achieve an effect (for example, the outline of 
a leaf). However, the Maya Vector renderer 
only supports per object transparency.

Particles Not rendered.

Post-render effects Not rendered. (Post-render effects include 
motion blur, fog, glows, and so on.)
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How do I? Select a renderer

Select a renderer

To find out more about Maya renderers, see ”Renderers” on page 15.

When you select a renderer, Maya’s user interface is automatically 
configured to use the renderer. For example, if you render the current 
frame, Maya uses the renderer to process the image and display it in the 
Render View. Or, if you press the Display Render Globals Setting window 
button, the Render Global Settings window appears, showing the 
Common tab and tab that corresponds to the selected renderer. 

To choose the renderer

• Do one of the following:

• Click Render > Render Using, then choose the renderer.

• Select the renderer from the drop-down list in Render View 
(Rendering > Rendering Editors > Render View).

• Select the renderer from the drop-down list in the Render Global 
Settings window.

Shaders Anisotropic, Lambert, Blinn, Phong and 
Phong E shaders should produce expected 
results. Other Maya shaders may produce 
unexpected results.

mental ray shaders and custom shaders are 
not rendered.

Multiple shaders assigned to a single 
NURBS or subdivision surface are not 
rendered.

Textures Texture rendering is limited by the Fill Style 
and the number of polygons. Fill styles that 
fill individual polygons (Full Color and 
Mesh Gradient) render textures more 
accurately than other fill styles, and models 
that contain more polygons render textures 
more accurately than models with fewer 
polygons.

Maya Feature Notes
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To specify the default renderer

• Click Window > Settings/ Preferences > Plug-in Manager.

• Select the Rendering category, then set the Preferred Renderer option. 

mental ray Output window messages

The following messages appear in the Maya’s Output window at start-up:

• mental ray for Maya 6

identifies the version for mental ray for Maya. 

• mental ray: version 3.3.0.655, 29 Jan 2004 

Windows_NT_4.0_x86 
identifies the version of mental ray standalone libraries that mental 
ray for Maya is based 

Note The mental ray renderer and the Maya Vector renderer are plug-
ins that are loaded by default. If you do not see them listed in 
Render > Render Using, choose Window > Settings/Preferences 
> Plug-in Manager and make sure the Mayatomr and/or 
VectorRender plug-ins are loaded.
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About Cameras

Viewing cameras vs. rendering cameras

Whenever you look at your scene in Maya, whether you are building your 
scene or ready to render images, you are looking through a camera. Think 
of it as being a director on a movie set and looking through a camera lens. 
Your field of view is restricted to what you can see through that lens.

By default, Maya has four cameras that let you view your scene in a panel: 
the perspective camera and the three orthographic cameras (side, top, 
front) that correspond to the default scene views. You look through these 
cameras (panels) as you model, animate, shade, and texture objects. (For 
more information about views, see ”Main window” on page 18 in the Basics 
guide.)

Typically, you don’t use these default cameras to render a scene; you 
create one or more perspective cameras from which to render. The only 
difference between a rendering camera and any other camera (default or 
created) through which you can view your scene is a flag that allows it to 
render the scene. 

For more information on the kind of cameras you can create, see ”Maya 
camera types” on page 27. 

To create a camera, see ”Create a camera” on page 35.

Maya camera types

Maya cameras have certain advantages over real world cameras, giving 
you more creative freedom. For example, because Maya cameras are not 
restricted by size or weight, you can move cameras to any position in your 
scene, even inside the smallest objects. 

Static and animated cameras 

Three types of cameras help you create both static and animated scenes.

• Use a Basic camera for static scenes and for simple animations (up, 
down, side to side, in and out), such as panning out of a scene. See 
”Create > Cameras > Camera” on page 247 for more details.

• Use a Camera and Aim camera for slightly more complex animations 
(along a path, for example), such as a camera that follows the erratic 
path of a bird. See ”Create > Cameras > Camera and Aim” on 
page 252 to set its options.
Rendering

27



2 | Camera set up 
About > Focus and blur
• Use a Camera, Aim, and Up camera to specify which end of the 
camera must face upward. This camera is best for complex 
animations, such as a camera that travels along a looping roller 
coaster. See ”Create > Cameras > Camera, Aim, and Up” on page 252 
to set its options.

Motion blur and depth of field

Focus and blur

The process of recording what you see through a real-world camera is 
simple: you press the button that opens the shutter, which lets light 
through the aperture, which in turn exposes the film to light, recording 
what you see. 

A camera’s exposure settings determine depth of field (the region of sharp 
focus), and whether or not subject matter is crisp or blurred by motion. 

Especially if you using photography based images in your scene (such as 
live action footage), you may need to work with some camera settings. 
You set these and other settings, such as the film back or focal length, in:

• The selected camera’s Attribute Editor. See ”Adjust a camera’s 
attributes” on page 35.

• As options for a camera as you create it. See ”Create > Cameras > 
Camera > ” on page 247.

fStop (aperture) and shutter speed/angle

In real-world photography, together the fStop and shutter speed (or shutter 
angle for film cameras) determine how much light is exposed to film. 
However, fStop and shutter speed also determine what is in focus, to a 
certain extent, but for very different reasons.

The length of time light is allowed to pass through the camera lens to the 
film is determined by the shutter speed. The higher the speed, the shorter 
the exposure time, the less light exposed to the film. 

The amount of light that is allowed to pass through the camera lens to the 
film is determined by the camera’s aperture setting (also known as the 
fStop). The wider the aperture, the more light exposed to the film.
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Shutter speed/angle determines motion blur

Motion blur gives the feeling of motion. Motion blur is determined by the 
shutter speed. The slower the shutter speed (sometimes deliberately 
done), the harder motion is to stop. That is, fast motion (such as a moving 
car) appears motion blurred at slower shutter speeds. At higher speeds, 
the moving car is ‘stopped’ and therefore in focus. 

To set motion blur in Maya, see ”Motion blur” on page 30.

For information on mental ray for Maya’s motion blur, see ”mental ray for 
Maya motion blur” on page 29.

Aperture determines Depth of Field (DOF)

Depth of field is the region of sharp focus in a photograph. Depth of field 
is determined by the camera’s aperture setting. At wide aperture settings 
(for example, at fStop f/2), the depth of field is shallow, and more of the 
foreground and background (that brackets the area in sharp focus) is out 
of focus. At narrow aperture settings (for example, at fStop f/22), the 
depth of field is deep, and more of the foreground and background is in 
focus.

To adjust a camera’s fStop to affect the depth of field, see ”Adjust depth of 
field” on page 37. 

mental ray for Maya motion blur

In mental ray for Maya, you can choose between Linear and Exact Motion 
Blur. Motion Blur in mental ray for Maya blurs everything: shaders, 
textures, lights, shadows, reflections, refractions, and caustics.

The Linear mode results in instance motion; shape changes are not 
considered. The Exact Mode additionally exports motion vectors for every 
vertex of the moving object. Use it to motion blur objects with deforming 
shape. This mode requires more translation and render time. 

Note A still camera’s shutter speed performs the same function as a 
film camera’s shutter angle. The shutter angle is a metal disk that 
is missing a pie-shaped section. This disk sits between the lens 
and the film, and rotates at a constant rate. When the missing 
section is in front of the film, it allows light from the lens to pass 
through and expose the film. 

The larger the angle of the pie-shaped section, the longer the 
exposure time, and moving objects appear more blurry. For 
more information, see ”Shutter Angle” on page 250.
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The linear mode just exports instance motion performed on transform 
nodes, any shape changes (even linear movements) are not considered. 

The Shutter, Shutter Delay setting of the Maya camera determines the 
actual motion blur path length. You can modify other settings, such as 
Motion Blur By, to further control the final motion blur calculation. Find 
these settings in the ”Motion Blur” on page 190 (in the Render Global 
Settings window).

Motion blur

Motion blur can be turned on and off on a per-object basis. If some 
surfaces in the scene don’t move, or move only slightly, do not motion 
blur them. Being selective about what you motion blur can decrease 
rendering times. (See also 2D Motion Blur global attributes information 
about 2D motion blur.)

Framing objects with a camera

Camera aim 

Aim a camera to frame objects in your scene. 

To look through a camera, see ”Look through (select) a camera” on 
page 38.

To frame your scene in other ways, see ”Frame your scene” on page 39. 

Camera tools

Camera tools let you reposition the camera in different ways.

Tumble

Revolves the camera around a center of interest (such as a particular 
object), or the camera’s pivot point (which, by default, is the center). 

To adjust the way in which the Tumble tool works, see ”View > Camera 
Tools > Tumble Tool > ” on page 275.

Track

Slides the camera horizontally or vertically in space.

To adjust the way in which the Track tool works, see ”View > Camera 
Tools > Track Tool > ” on page 276.
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Dolly

Moves the camera into the view, or backs the camera out of the view. 
When you use the Dolly tool, you change the perspective; that is, objects 
far from the camera change in relative size at a slower rate than objects 
which are close to the camera. Compare to Zoom (see ”Zoom” on 
page 31).

You can use the Dolly tool in a perspective view or an orthographic view.

To adjust the way in which the Dolly tool works, see ”View > Camera 
Tools > Dolly Tool > ” on page 276.

Zoom 

Changes the focal length (viewing angle) on the camera. The Zoom tool 
does not change perspective like the Dolly tool does; all objects in the 
frame change size at the same rate. The camera doesn’t move, but the 
effect is similar. To move in or out of the view without changing the 
viewing angle, see Dolly.

To adjust the way in which the Zoom tool works, see ”View > Camera 
Tools > Zoom Tool > ” on page 277.

Roll

Rotates the camera around its horizontal axis, down the barrel of the lens.

To adjust the way in which the Roll tool works, see ”View > Camera Tools 
> Roll Tool > ” on page 277.

Azimuth Elevation

Revolves the camera around a point of interest in perspective view only.

The angle of a camera’s sight line relative to the ground plane is called its 
elevation; the angle of a camera’s sight line relative to a plane 
perpendicular to the ground plane is called its azimuth.

To adjust the way in which the Azimuth Elevation tool works, see ”View 
> Camera Tools > Azimuth Elevation Tool ” on page 278.

Yaw-Pitch

Points the camera up or down (pitch, also called tilt), or left or right (yaw, 
also called pan) without moving the camera. The scene in the camera’s 
view appears to move in the opposite direction. 

Tips You can also use platform-specific keyboard combinations for 
most camera tools. See ”Selection, tools, and actions” on page 17 in 
the Basics guide for details. 
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To move the camera up or down or side to side, use the Track tool. 

To adjust the way in which the Yaw-Pitch tool works, see ”View > Camera 
Tools > Yaw Pitch Tool > ” on page 278.

Fly

Flies the camera through the scene with no constraints. The Fly Tool lets 
you navigate your scene as if you were playing a 3D first-person 
perspective game. 

To use the Fly Tool, Ctrl+drag up to fly forward and down to fly 
backward. To change the camera direction, release the Ctrl key and drag.
 

Angle of view (focal length)

For every shot, you decide how big an object appears in the frame. For 
example, should a shot include an entire character or just its head and 
shoulders? There are two ways to make an object larger in the frame. You 
can either move the camera closer to the object (see ”Dolly” on page 31) or 
adjust the lens to a longer focal length (see ”Zoom” on page 31).

The focal length of a lens is the distance from the center of the lens to the 
film plane. The shorter the focal length, the closer the focal plane is to the 
back of the lens. 

Lenses are identified by their focal length. Focal length is expressed in 
millimeters or, on occasion, in inches (1 inch is approximately 25mm).

The object’s size in the frame is directly proportional to the focal length. If 
you double the focal length (keeping the distance from the camera to the 
object constant), the subject appears twice as large in the frame. The size of 

Tip Tumble, track, and dolly are available while the Fly Tool is 
active. 

focal 
length

angle 
of 
view
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the object in the frame is inversely proportional to the object’s distance 
from the camera. If you double the distance, you reduce the size of the 
object by half in the frame.

Angle of view

As you adjust the camera’s focal length, the angle of view narrows and 
expands. This is what causes objects to get larger or smaller in the frame. 
As you extend the focal length, the angle of view gets narrower. As you 
shorten the focal length, the angle of view gets larger.

Safe display regions for TV production

You can display a guideline that indicates a region within which you 
should keep all action or text if you plan to display the rendered images 
on a television screen. Action and text within these guidelines is visible on 
every television. 

Different TV manufacturers use different tubes and put them in different 
boxes, so there’s a difference in what gets displayed; safe action and text 
region are broadcast standards that assure action or text (respectively) is 
visible. Safe text is 80% of the screen because the sensitivity to logotypes 
(fonts) is much higher than the sensitivity to objects moving; that is, at the 
10% edge of the tube, text appears warped. Safe action is 90%.

To turn the safe action or safe title border on or off, see ”Turn scene view 
guidelines on or off” on page 36.

Safe action

The safe action view guide represents 90% of the rendering resolution (the 
resolution gate). 

Resolution
Gate.

Safe Action.
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Safe Title

The safe title view guide represents 80% of the rendering resolution (the 
Resolution Gate). For example, in this image, the title DANCER does not 
fit within the Safe Title area. Track the scene until the title fits within the 
border.

Clipping planes

Near and far clipping planes are imaginary planes located at two 
particular distances from the camera along the camera’s sight line. Only 
objects between a camera’s two clipping planes are rendered in that 
camera’s view. Any parts of objects in the scene closer to the camera than 
the near clipping plane, or farther from the camera than the far clipping 
plane, are not rendered.

If part of an object is in front of the near clipping plane, then only the part 
of the object beyond the near clipping plane is rendered. If part of an 
object is beyond the far clipping plane, the entire object is rendered, 
including the part beyond the far clipping plane.

Resolution
Gate.

Safe Title.

Image courtesy of 
The Art of Maya

Far clipping 
plane

Near clipping 
plane

Frustum
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A completely opaque object which is behind the far clipping plane is 
clipped. If that object’s transparency is greater than 0, the part behind the 
far clipping plane is clipped.

For more information on how to work with clipping planes, see ”Clipping 
planes” on page 34. 

How do I? Create and use a camera

Create a camera

To learn more about Maya cameras, see ”Maya camera types” on page 27.

To create a new camera

1 Select Create > Cameras > Camera Type > , where Type is the type of 
camera. 

To find out about the type of cameras, see ”Maya camera types” on 
page 27. 

The Create Camera Options window appears.
 

2 Set the camera options, then click Create. 

For a description of the camera options, see ”Create > Cameras > 
Camera” on page 247.

Adjust a camera’s attributes

A camera’s attributes describe various properties of the camera, including 
angle of view, focal length, and depth of field. 

Note For Maya software rendering, if refractions are toggled on, an 
object that intersects the far clipping plane is not clipped 
regardless of the transparency value. 

Note If you’ve previously set the options for the type of Camera you 
want to create, you can just select the camera type; you don’t 
have to set its options each time.
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To adjust a camera’s attributes

1 Select the camera. To select a camera, see ”Look through (select) a 
camera” on page 38.

The camera’s Attribute Editor appears (unless it’s been hidden). If it 
does not, click View > Camera attributes.

2 Set attributes. 

For a description of the attributes, see ”View > Camera Attribute 
Editor” on page 269. 

Make a camera renderable

By default, your scene has only one renderable camera (the original 
perspective camera) that can render all objects in your scene. 

If you add another camera to your scene and want to make it renderable 
(or you would like to make one of the default orthographic cameras 
renderable), you must set this camera to renderable. You can have 
multiple renderable cameras.

To learn more about rendering, see the Rendering book.

To make a camera renderable

1 In the selected camera’s Output Settings section of the Attribute 
Editor, turn on Renderable.

Turn scene view guidelines on or off 

You can turn view guidelines on or off so that you can correctly determine 
safety boundaries for certain types of information: safe action and text for 
TV broadcasts, or render borders. 

Note Alternatively, you can turn off Renderable in the Output Settings 
section of the Attribute Editor for the cameras you do not want 
to render from. 

Note For Maya software rendering, you can also select a camera (or 
several cameras) to render from when you render from a shell or 
command line. Use Render and the -cam option. 

See ”Command line renders” on page 72 for information about 
command line rendering. 
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To learn more about the safe action and safe title border or the resolution 
gate, see ”Safe display regions for TV production” on page 33.

To turn the safe action border on or off

• Click View > Camera Settings > Safe Action.

To turn the safe title border on or off

• Click View > Camera Settings > Safe Title.

To display the Resolution Gate view guide

• Select View > Camera Settings > Resolution Gate from the view’s 
menu bar. 

The resolution gate and the resolution values appear.

Adjust depth of field

You can view the calculated distance of the camera from the object and 
apply that value to the Focus Distance for the camera to achieve Depth of 
Field effects in the Camera’s Attribute Editor. 

For information on depth of field, see ”Focus and blur” on page 28.

Tip You can display several view guides at the same time by 
opening the camera’s Attribute Editor (View > Camera Attribute 
Editor), and turning on options in the Display Options section. 

Note To create an image that has wider depth of field (more area in 
front of and behind the subject that is in focus) use high fStop 
values, such as f16, f22, f32. To achieve narrow depth of field 
(less area in front and behind the subject that is in focus) use low 
fStop values such as f2.8, f4 or f5.6.

For more information on fStops, see ”fStop (aperture) and 
shutter speed/angle” on page 28.

Note Depending on the fStop and Focus Region Scale values, parts of 
the object may or may not be in focus.
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To ensure the center of an object is in focus for Depth of 
Field

1 Select the object in the view.

2 Make sure Object Details is turned on in the Heads Up Display menu. 
(Object Details is on by default). Notice the Distance to Camera value.

3 Use the Distance to Camera value as the Focus Distance value in the 
Depth of Field section for the current Camera.

If you select multiple objects, Maya uses the center of their bounding 
box to calculate the distance from the camera.

Look through (select) a camera

Select the current scene view’s camera

Select the current scene view’s camera to show the camera’s Attribute 
Editor (unless it’s been hidden) or to aim the camera while you are looking 
through it. 

For more information about scene views, which are in fact cameras, see 
”Viewing cameras vs. rendering cameras” on page 27.

To select the current view’s camera

• In the view, click View > Select Camera.

Look through another camera

If you have more than one camera, you can switch the camera with which 
you are viewing the scene to another one.

To look through a camera

• Do one of the following: 

• To look through a camera that is selected, click Panels > Look 
Through Selected.

• To look through another camera, click Panels, then select the 
camera name from either the Perspective or Orthographic 
submenus. 
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Frame your scene 

Move a camera to another location

You can display a camera as an object in a view and use the standard 
manipulators to move it. This is like holding a camera through which you 
are not looking and moving it from one place to another (from a bag to a 
table for example); your hands are the manipulator. Moving a camera this 
way is particularly useful if you want to see the camera’s path or adjust 
frustum or clipping planes, for example. 

To move a camera while looking through it, see ”Aim a camera” on page 39.

To move a camera

• Select the camera, then use the Move tool. For more information on 
the Move tool, see the Basics book. 

Aim a camera

You can aim the current view’s camera with camera tools. Aiming is like 
holding the camera up to your eye, then pointing up, down, or moving 
yourself around your subject matter to frame objects in the scene. To find 
out more about the ways in which you can aim a camera, see ”Aim a 
camera” on page 39.

To move a camera through which you are not looking, see ”Move a 
camera to another location” on page 39.

To use a camera tool

1 In the view, do one of the following:

• Click View > Camera Tool, select the tool you want to use, then 
drag the cursor to use the tool.

• Click View > Camera Tool > , set the options, then click close.

• For a description of the tool settings, see ”View > Camera Tools” 
on page 275. 

Tip You can use the keyboard combinations to Tumble, Track, and 
Dolly the camera. See ”Selection, tools, and actions” on page 17 in 
the Basics guide for details. 
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Look at selected objects

To look at selected objects

• Select View > Look At Selection. 

The camera moves to show selected objects in the center of the 
camera’s view.

Frame selected objects

To look at and fill the view with selected objects

• Select View > Frame Selection (or press the hotkey f). 

The camera moves to fill the camera’s view with selected objects

Frame all objects

To look at and fill the view with all objects in a scene

• Select View > Frame All (or press the hotkey a).

The camera moves to fill the camera’s view with all objects in the 
scene (including lights and cameras, if their icons are displayed in the 
view). 

Frame part of a scene

To look at and fill the view with a region of a scene

• Ctrl+Alt+drag over the region. 

The camera moves to fill the camera’s view with the selected region. 

Tips • If you change the default settings in the camera tool options 
windows, remember to press the Reset Tool button to reset 
the tool defaults for the next operation. 

• Select View > Default Home if you zoom and tumble the 
view repeatedly and then need to see the default camera’s 
view.
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Save sequential camera movements

You can write all camera movements to the Script Editor (the MEL 
Journal) to let you undo or redo camera movements or copy camera 
movements to use them for other cameras or scenes.

To turn the Journal on or off

• In the view panel, click View > Camera Settings > Journal.
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3 Tessellation and  
Approximation 
About Tessellation and approximation

Tessellation (called approximation in mental ray for Maya) is the process 
renderers use to convert NURBS surfaces (or displacement mapped 
polygon meshes) to triangles. Triangles determine how smooth an object 
looks at closer distances to you (the camera). When poorly tessellated 
objects are close to the camera, they appear faceted; when they are further 
away, they don’t. 

When to adjust tessellation

Because (most) renderers can only render triangles, tessellation is a 
necessary and automatic step that occurs at render time. However, you 
need to adjust tessellation settings when objects aren’t smooth enough, 
which typically happens as objects come close to the camera or if objects 
are displacement mapped. 

Tessellation settings determine how many triangles are used, where the 
triangles are concentrated, and what size they are. Numerous and 
concentrated triangles increase the memory requirements (which in turn 
decrease performance) of the renderer, so you must adjust tessellation 
settings to strike a balance between smooth edges (quality) on objects that 
are closer to the camera and renderer performance (the time it takes to 
render). 

Tessellation strategy always is to adjust the settings, per-object (not 
globally), only high enough to achieve a smooth surface. Distant and less-
important objects can have lower tessellation settings than objects closer to 
the camera. 
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Maya tessellation

Primary vs. secondary tessellation passes

Primary tessellation is a first pass through the geometry that creates a 
specific number of triangles in the U and V directions of the surface; it 
places triangles evenly all over the surface, regardless of curviness or 
displacement).

Secondary tessellation (also called Adaptive tessellation) is a second pass 
that creates more triangles only where needed.

With Maya software rendering and hardware you can set basic and 
advanced tessellation settings.

Basic tessellation (for novice users) performs both primary and secondary 
tessellation: 

• curvature tolerance affects the chord height ratio of the secondary 
attributes

• u/v divisions affects the number U/V, and uses per-span # of 
isoparms

If basic tessellation doesn’t provide you with the required results, choose 
advanced tessellation, and make adjustments accordingly. 

NURBS surface, poly, and subD tessellation

You don’t need to adjust tessellation for polygon meshes or subdivision 
surfaces unless those surfaces are displacement mapped. 

A NURBS surface is composed of one or more patches. (For more 
information on NURBS surfaces see ”NURBS” on page 13 in the NURBS 
Modeling guide.) During rendering, each patch is divided into an 
appropriate number of triangles to approximate the true shape of the 
surface. 

You can set NURBS tessellation on all or selected objects (see ”Render > 
Set NURBS Tessellation > ” on page 257), or on an individual basis by 
selecting an object and adjusting the settings in the object’s Attribute 
Editor. 

Surface patches CVs Isoparms
Rendering 

44



3 | Tessellation and Approximation

About > Approximation
Approximation in mental ray for Maya

Approximation

Approximation (called tessellation in Maya; see ”Tessellation and 
approximation” on page 43) is the process mental ray for Maya uses to 
convert NURBS surfaces (or displacement mapped polygon meshes) to 
triangles. Triangles determine how smooth an object looks at closer 
distances to you (the camera). When poorly tessellated objects are close to 
the camera, they appear faceted; when they are further away, they don’t. 

When rendering with mental ray for Maya, a set of approximation settings 
must be specified for each piece of geometry. 

By default mental ray for Maya derives approximation settings from 
Maya’s tessellation settings. This produces results close to the look of 
Maya software rendered scenes, and is useful for those familiar with the 
behavior of those settings. 

Alternatively, you can specify approximation settings more precisely for 
mental ray for Maya by using an approximation node.

Derive from Maya (default approximation) settings 

• If only Basic tesselation (see ”Primary vs. secondary tessellation 
passes” on page 44) is used, mental ray for Maya bases tessellation on 
the Curvature Tolerance attribute setting of the NURBS surface. 

• If the Advanced tessellation attributes are used but none of the 
secondary tessellation controls are active for an object. Parametric 
approximation is derived from Maya's primary tessellation controls. 
Otherwise, mental ray for Maya’s LDA approximation method is 
applied with values calculated from Maya secondary tessellation 
controls.

Primary tessellation creates a base triangulation, which is further 
tessellated until the secondary set of conditions are met. mental ray for 
Maya’s Parametric approximation method is comparable to Maya’s 
primary tessellation; the length/distance/angle (LDA) method is 
comparable to Maya’s secondary tessellation. 

Approximation nodes

Approximation nodes give you more precise control over all of mental ray 
for Maya approximation features, some of which Maya cannot access. For 
example, you can use Approximation nodes to specify separate 
tessellation settings for surfaces, trim curves, and displacement maps. 
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As an example, consider a simple flat NURBS surface with a complex trim 
curve. For such a case, you would specify a low-quality surface 
approximation in conjunction with a high-quality trim curve 
approximation. mental ray would then ensure that the surface is 
approximated with only a few triangles except around the trim curves, 
where many triangles would be used to ensure a smooth edge. 

The same analogy applies to a simple surface with a complex 
displacement map. For that case, you might apply a low-quality regular 
surface approximation in conjunction with a high-quality displacement 
approximation, to ensure that triangles are added only to areas where 
they are needed to capture the complexity of the displacement map. 

This node 
type...

Does this... To only this 
type of 
geometry...

Surface 
Approximation 

Determines how NURBS 
surfaces are tessellated into 
triangles for rendering.

NURBS surfaces

Trim Curve 
Approximation 

Controls the tessellation of trim 
curves on NURBS surfaces.

NURBS surfaces 
with trim curves

Displacement 
Approximations 

Controls the tessellation of 
displacement maps on a 
surface. Whereas ordinary 
Surface Approximations only 
tessellate based on the 
underlying surface, 
Displacement Approximations 
additionally take into account 
features of the displacement 
map when tessellating.

NURBS or 
polygonal surfaces 
with displacement 
maps

Subdivision 
Approximation 

Available only if 
the mental 
matter (tm) 
library is loaded. 

Control render-time smoothing 
of polymesh surfaces.

polygonal surfaces
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Approximation styles

An approximation style is the general subdivision scheme mental ray for 
Maya uses to break the surface into triangles. Some approximation styles 
work by repeatedly cutting the entire surface from end to end, while 
others are capable of adding triangles in a more localized fashion.

mental ray for Maya provides a few standard approximation styles (Grid, 
Tree, and Delaunay) and the Fine approximation style.

The standard approximation styles use as few triangles as possible to 
approximate a surface to achieve the quality you define in the 
approximation settings. 

Fine approximation

Fine approximation subdivides very complex surfaces (especially detailed 
displaced surfaces) into a large number of roughly uniformly-sized small 
triangles in order to guarantee a smooth result. To deal with the large 
number of triangles mental ray for Maya breaks the surface up into 
independent sub-objects that are each tessellated and cached separately, 
generating the triangles without consuming excessive amounts of 
memory. 

This approximation style only supports the Spatial approximation 
method, which specifies the size of triangles to be generated. 

Note Fine approximation cannot be used together with merging and 
connections (that is, when surfaces are stitched, there may be 
holes along the stitch.

Geometry type Can I use Fine 
approximation?

polygon displacement yes

NUBRS surface displacement yes

subdivision surface displacement yes
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How Fine Approximation works

To allow for Fine approximation, the granularity of mental ray for Maya’s 
cache manager is reduced, whereby smaller units are formed by splitting 
objects into smaller sets. These sets can be individually tessellated without 
excessive memory requirements. 

Fine approximations support a small subset of approximation techniques 
since the other styles exist only to trade off triangle counts vs. quality, 
which is no longer a problem for fine approximations: 

mental ray for Maya geometry types

Maya supports three types of geometry: polygonal (Polygon Mesh), free-
form objects (NURBS curves/surfaces), and subdivision surfaces. 

NURBS (free-form curves and surfaces)

Free-form NURBS curves and surfaces in Maya are supported by mental 
ray for Maya. These surfaces, which can have a boundary and several 
holes, are expressed as trim and hole curves in the mental images surface 
definition. 

Polygonal meshes

Maya polygonal meshes are exported as mental images polygon objects 
and support features like vertex sharing, holes, and displacement 
refinement. Displacement mapping can be applied to meshes. The special 
displacement properties for polygon surfaces are controlled in much the 
same way as NURBS surfaces. 

Polygonal meshes that consist only of triangles or quadrangles can be 
exported as a subdivision surface base mesh for mental ray rendering. 

NURBS surface approximations yes

curves no
(because they are not 
tessellated to triangles)

Geometry type Can I use Fine 
approximation?
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To export a polygonal mesh for rendering, you must create and attach a 
Subdivision approximation node to the mesh. This node lets you further 
control the subdivision process and quality. Additionally, you can create 
and attach a Displace Approximation node to support the displacement of 
the mesh. 

If mental ray for Maya encounters a Subdivision approximation node, it is 
exported as a mental images subdivision surface base mesh (including 
textures and motion vectors, but without normals) instead of a simple 
polygonal mesh. 

If the conversion fails (because other than triangles/quadrangles were 
found), an error message is printed and the mesh is exported as usual. 

Subdivision surfaces

Maya’s subdivision surfaces are supported in mental ray for Maya as long 
as the base mesh is made up of only quads. 

The support for subdivision surfaces includes hierarchical edits, 
hierarchical material assignments, edge and vertex full creases only, 
uncreases, texture reference objects, deformation motion blur, and 
derivatives (for bump mapping and texture filtering). Unlike Maya, 
however, mental ray for Maya can handle only quadrilateral base meshes 
(a number of Maya standard subdiv shapes are therefore rejected), and 
UV coordinates can only be specified on the base mesh (level 0). 

To prepare subdivision surfaces not directly supported (for example, 
where the base mesh does not contain only quads), see ”Obtain quads for 
subdivision surfaces” on page 61.

How do I? Tessellate objects

Tessellate NURBS surfaces

View Maya tessellation settings for an object

See ”Primary vs. secondary tessellation passes” on page 44 for information 
on Maya’s default tessellation settings.

To view Maya tessellation settings for an object

1 Select the object whose tessellation settings you want to view. 

2 Open the Attribute Editor (CTRL+a).

3 Click the shape tab (for example, nurbsSphereShape1). 
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The shape node’s attributes appear. 

4 Expand the Tessellation section. 

Adjust NURBS tessellation settings

Because the tessellation of NURBS surfaces has nothing to do with the 
material assigned to the surface (unless the surface is displacement 
mapped), you can start adjusting tessellation early in the process, anytime 
after the object is modeled. 

To adjust tessellation on NURBS objects 

1 Determine which objects in the scene you have to adjust tessellation 
settings. 

See ”Determine which objects to tessellate” on page 51. 

2 Display the tessellation triangles so you can visualize your 
adjustments. 

See ”Display NURBS tessellation triangles” on page 51.

3 Select the object(s) for which you want to adjust tessellation. 

If you want to apply settings to All surfaces, skip this step.

4 Select Render > Set NURBS Tessellation >   to open the Set NURBS 
Tessellation window. 

5 Choose either Selected Surfaces or All Surfaces (see Selected Surfaces, 
All Surfaces).

6 Switch the Tessellation Mode from Automatic (default) to Manual 
Mode.

(You can also adjust some of the Automatic tessellation settings to 
optimize the default settings. See ”Automatic Mode settings” on 
page 258.)

7 Select either Basic or Advanced tesselation. 

Always start with the Basic settings. Basic lets you adjust a smaller 
number of settings that automatically determine some of the more 
advanced settings. 

Note Some of the advanced tessellation parameters can dramatically 
increase rendering times.

Note Some of the advanced tessellation parameters can dramatically 
increase rendering times, so choose them wisely.
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8 Test render to see the results. 

9 Fine-tune the adjustments you’ve just set until you reach an adequate 
level of smoothness.

Determine which objects to tessellate

What models are going to be used are usually determined during the pre-
production phase of a project. Based on storyboards, you will know their 
positions in the scene and distance to the camera. 

Determine which objects never get close to the camera and which ones 
either are (for static images) or do (for animated objects). 

• If an object is far from the camera at all times, decrease the default 
settings. 

• If the object is middle distance away from the camera, leave the 
default settings.

• If the object gets close to the camera at some point during the scene, 
increase the tessellation settings a little more, but only enough to 
acheive an acceptable level of smoothness. 

Display NURBS tessellation triangles

To display tessellation triangles

1 Select the NURBS surface(s) you want to see.  

2 In the Tessellation section of the NURBS object’s Attribute Editor, turn 
on Display Render Tessellation.

Use span-based tessellation

To use span-based tessellation

• In the Tessellation section of the surface’s Attribute Editor, turn on 
Enable Advanced Tessellation and set Mode U and Mode V to Per 
Span # of Isoparms. Guidelines are as follows:

To use span-based tessellation

• Turn on Smooth Edge. Open the Options section of the Attribute 
Editor to access the Smooth Edge check box.

Tip To prevent overtessellation of objects, use the Use Smooth Edge 
attribute in the Render > Set NURBS Tessellation window to 
increase tessellation only along the edge of the object. 
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Tessellate polygonal surfaces

Adjust polygonal tessellation

To set polygonal tessellation

1 Select the polygonal object for which you want to set tessellation.

2 Click Window > Attribute Editor Tessellation section to adjust the 
attributes. 

Tessellate subdivision surfaces

Display subdivision surface tessellation 
triangles

To see subdivision surface tessellation triangles

1 Select the object

2 Click Modify > Convert > Subdiv To Polygons to convert the 
subdivision surface to a polygonal surface to use as a temporary 
visualization object.

Adjust subdivision surface tessellation

To set subdivision tessellation 

1 Select the subdivision object for which you want to set tessellation.

2 Click Window > Attribute Editor Tessellation section to adjust the 
attributes. 

Work with mental ray for Maya 
approximation

Create an approximation node

1 Select the geometry to which you want to assign an approximation 
node. 

For compatible geometry types, see ”Approximation nodes” on 
page 45.

2 Click Window > Rendering Editors > mental ray > Approximation 
Editor. 

The Approximation Editor opens. For more information on the 
Approximation Editor see, ”Approximation Editor” on page 62.
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3 Click the Create button for the type of approximation node you want 
to create.

For descriptions, see ”Approximation nodes” on page 45.

The approximation node is created and assigned to the selected 
geometry. 

Related topics

”Approximation nodes” on page 45

”Assign an approximation node” on page 53

”Edit an approximation node” on page 54

Assign an approximation node

1 Select the geometry to which you want to assign an approximation 
node. 

For compatible geometry types, see ”Approximation nodes” on 
page 45.

2 Click Window > Rendering Editors > mental ray > Approximation 
Editor. 

The Approximation Editor opens. For more information on the 
Approximation Editor see, ”Approximation Editor” on page 62.

3 From the dropdown list for the type of approximation node, select the 
node you want to assign. 

For descriptions, see ”Approximation nodes” on page 45.

4 Click Assign. 

The approximation node is assigned to the selected geometry. 

Related topics

”Approximation nodes” on page 45

”Create an approximation node” on page 52

”Edit an approximation node” on page 54

Note When you create an approximation node, it is automatically 
assigned to selected geometry. Use this procedure to assign 
already created approximation nodes to newly selected 
geometry.
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Edit an approximation node

1 Click Window > Rendering Editors > mental ray > Approximation 
Editor. 

The Approximation Editor opens. For more information on the 
Approximation Editor see, ”Approximation Editor” on page 62.

2 From the dropdown list for the type of approximation node, select the 
node you want to edit. 

For descriptions, see ”Approximation nodes” on page 45.

3 Click Edit. 

The approximation node’s Attribute Editor opens. 

4 Edit the attributes

Related topics

”Approximation nodes” on page 45

”Create an approximation node” on page 52

”Edit an approximation node” on page 54

Override approximation settings

For complex scenes, many different approximation nodes with unique 
settings may be needed to ensure accurate and efficient renderings. 

When previewing such scenes, you can temporarily lower the tessellation 
quality to produce low-quality renderings more quickly with global 
(scene-wide) overrrides.

To override approximation settings 

1 Click Window > Rendering Editors > Render Globals. 

The Render Globals Settings window opens. For more information, 
see ”Render Global Settings window” on page 159.

In the mental ray Options (Quality) settings, thee Overrides >Tessellation 
tab provides controls for specifying surface and displacement 
approximations to use for rendering. When specified, these settings 

Note When you create an approximation node, it is automatically 
assigned to selected geometry. Use this procedure to assign 
already created approximation nodes to newly selected 
geometry.
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override all approximation assignments in the scene. Selecting None will 
cause mental ray for Maya to once more respect the approximation 
assignments in the scene.  

Control Fine approximation triangles

Setting Fine approximation cache limit

Fine displacement critically depends on the specification of a cache size 
limit, because otherwise the fine tessellation results would not flow 
through the cache but accumulate until memory runs out. mental ray has 
a default cache limit of 512 MB. 

A good choice is half the amount of physical RAM, or 500-800 MB on 32-
bit machines, whichever is smaller. If the number is too large, the 
operating system may run out of virtual address space; if it is too small, 
mental ray will perform too many cache flush operations. 

Control Fine approximation triangles 

Choose one of the following techniques to control fine displacement. 
These help you avoid the risk of accidentally creating billions of triangles 
until memory runs out, without juggling a large number of displacement-
mapping parameters. 

When you use Fine approximation, you must choose one of these 
techniques: 

view length

Specifies that all triangles should be subdivided until they are smaller 
than edge pixel diagonals. The edge value is typically around 0.5, or 
0.25 or even 0.1 for very high quality. This technique is recommended 
for all fine approximations. 

length

Specifies that the triangle edge length should stay under edge units in 
the object's object space. The edge parameter needs more careful 
tuning than in the view-dependent case, and very high values defeat 
the purpose of fine approximation. 

parametric

Tessellates a free-form surface such that all microtriangles have the 
same size. This results in very regular meshes but is harder to 
optimize, and may use significantly more memory.

This lets you define triangle size as a fraction of the surface size, 
instead of in object or screenspace mode.   
Rendering

55



3 | Tessellation and Approximation 
How do I? > Tweak Approximation node settings
Tweak Approximation node settings

For each approximation setting, there are various settings, including 
tesselation method and style, that determine how the renderer tesselates 
objects at render time. You can manually change these settings or choose 
from a list of presets to simplify the process. 

Approximation method

Parametric 

approximation Subdivides each patch of the surface into equal-
sized pieces in the U direction and V direction. 
Regular parametric

Curves are subdivided into equal pieces by the 
parametric approximation and into subdiv equal 
pieces by the regular parametric approximation. 

For displacement mapped polygons and 
displacement mapped surfaces with a displace 
statement regular parametric has the same meaning 
as parametric in the approximation. For 
displacement mapped polygons the u_subdiv 
constant specifies that each edge in the triangulation 
of the original polygon is subdivided for the 
displacement 2u_subdivtimes. If a displace 
approximation is given for a displacement mapped 
surface, the initial tessellation of the underlying 
geometric surface is subdivided in the same way as 
for polygons. For example, a value of 2 leads to a 
fourfold subdivision of each edge. Non-integer 
values for the subdivision constant are admissible. 
Nothing is done if the expression above is smaller 
than 2 (if u_subdiv < 1). The v_subdiv constant is 
ignored for the parametric approximation of 
displacement maps. 

Length/distance/angle (LDA) approximation 

specifies curvature-dependent approximation according to the criteria 
specified by the Length, Distance, and Angle attributes. 

Spatial approximation

A special case of an LDA approximation that specifies only the length 
attribute and optionally the view attribute. 

Curvature
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A special case of LDA approximation, equivalent to the distance 
attribute, the angle attribute, and optionally the view attribute 
statement.  

Approximation Style

Tree, Grid, and Delaunay approximation algorithms are available for 
surface approximation only; they have no effect on curve 
approximations. Parametric approximation always uses the Grid 
algorithm; all other Approximation methods can any style but Tree is 
the default.

Grid  Tessellates on a regular grid of isolines in parameter 
space.

Tree Tessellates in a hierarchy of successive refinements 
that produces fewer triangles for the same quality 
criteria.

Delaunay Creates a successive refinement that maximizes 
triangle equiangularity. Delaunay triangulation 
creates more regular triangles but takes longer to 
compute. 

U Subdivisions, V Subdivisions

These values are used by the Parametric approximation and 
Subdivides each patch of the surface into equal-sized pieces in the U 
direction and V direction. Regular parametric approximation 
methods. They specify how many times each patch (for Parametric) or 
surface (for Regular Parametric) should be subdivided in the U and V 
directions

Min, Max

When using the Length/distance/angle (LDA) approximation 
adaptive approximation method, these attributes can be used to 
control the minimum and maximum number of times that triangles in 
the tessellation are subdivided. The Max Subdivisions parameter is 
especially useful for preventing runaway situations where the 
approximation method wants to add many triangles to an area where 
they will not greatly improve the quality of the tessellation. 

You can obtain good results with a Max Subdivisions value as low as 
3. Generally, each subdivision level can increase the triangle count by 
a factor of 4, so raising the Max Subdivisions from 3 to 4 can produce 
4 times as many triangles. Raising it to 5 can produce 16 times as 
many triangles, raising it to 6 can produce 64 times as many triangles, 
and so on. 
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Max triangles

This setting only applies to the Delaunay approximation type. It 
determines the maximum number of triangles that the final 
tessellation may contain.

Grading

Applies only to Delaunay Approximation style. 

Varies the density of triangles around the border of the surface, 
allowing for a smooth transition between a fine curve approximation 
and coarser surface approximation. It prevents a large number of tiny 
triangles at the trimming or hole curve to abruptly join very large 
triangles in the interior of the surface. 

The angle constant specifies a lower bound related to the degree of the 
minimum angle of a triangle. Values from 0.0 to 30.0 can be specified. 
Small values up to 20.0 are recommended. The default is 0.0. High 
grading values require you to specify a maximum number of triangles 
(see Max triangles) to prevent too many triangles or endless mesh 
refinement.

Length

Subdivides the surface or curve so that no edge length of the 
tessellation exceeds the edge parameter. Edge is given as a distance in 
the space the object is defined in, or as a fraction of a pixel diagonal in 
raster space if the view keyword is present. Small values such as 1.0 
are recommended. 

For Tree and Grid approximation the Min, Max and Min, Max values 
(if specified), specify the minimum and maximum number of 
recursion levels of the adaptive subdivision. Min enforces a minimal 
triangulation fineness with no tests. Edges are further subdivided 
until they satisfy the given criterion or the max subdivision level is 
reached. 

The defaults are 0 and 5, respectively; 5 is a very high number. Good 
results often occur with a maximum of 3 subdivisions. 

For Delaunay approximation, Min, Max specifies the maximum 
number of triangles of the surface tessellation. This number is 
exceeded only if required by trimming, hole, and special curves 
because every curve vertex must become part of the tessellation 
regardless of the specified maximum. 

For displacement mapped polygons and displacement mapped 
surfaces, length limits the size of the edges of the displaced triangles 
and ensures that at least all features of this size are resolved. 
Subdivision stops as soon as an edge satisfies the criterionor when the 
maximum subdivision level is reached. 
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Distance

Specifies the maximum distance between the tessellation and the 
actual curve or surface. The value of dist is a distance in the space the 
object is defined in, or a fraction of a pixel diagonal in raster space if 
the view statement is present. 

As a starting point, a small distance such as 0.1 is recommended. For 
Tree and Grid approximation the min and max parameters, if present, 
specify the minimum and maximum number of recursion levels of the 
adaptive subdivision. For Delaunay approximation, the number max 
following the keyword max specifies the maximum number of 
triangles of the surface tessellation. 

For displacement mapped polygons and displacement mapped 
surfaces with a displace approximation statement the distance 
criterion cannot be used in the same way because the displaced 
surface is not known analytically. Instead, the displacements of the 
vertices of a triangle in the tessellation are compared. The criterion is 
fulfilled only if they differ by less than the given threshold. 
Subdivision is finest in areas where the displacement changes. For 
example, if a black-and-white picture is used for the displacement 
map the triangulation will be finest along the borders between black 
and white areas but the resolution will be lower away from them in 
the uniformly colored areas. In such a case one could choose a 
moderately dense parametric surface approximation that samples the 
displacement map at sufficient density to catch small features, and use 
the curvature-dependent displace approximation to resolve the 
curvature introduced by the displacement map. Even if the base 
surface is triangulated without adding interior points, as if its trim 
curve defined a polygon in parameter space, it is still possible to 
guarantee a certain resolution by increasing the min subdivision level. 
Only the consecutive subdivisions are then performed adaptively. 

Angle

The angle statement specifies the maximum angle in degrees between 
normals of adjacent tiles of a displaced polygon or the tessellation of a 
surface or its displacement or between tangents of adjacent segments 
of the curve approximation. Large angles such as 45.0 are 
recommended. For tree and grid approximation the min and max 
parameters, if present, specify the minimum and maximum number of 
recursion levels of the adaptive subdivision. For Delaunay 
approximation, the number max following the keyword max specifies 
the maximum number of triangles of the surface tessellation. 
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Any Satisfied

View dependent

Controls whether the edge argument of the length and spatial 
statements and the dist argument of the distance and curvature 
statements are in the space the object is defined in or in raster space.

Turn this on to express the Length and Distance attribute values in 
pixels instead of object-space units (the default). The advantage of 
using view-dependent values is that objects that are close to the 
camera receive many triangles, while objects that are far away (or not 
visible at all) are approximated much more coarsely.

Length If the View Dependent attribute is turned on, this 
value is specified in pixels, otherwise it is specified 
in object-space units. The Length criterion is 
especially useful in conjunction with view 
dependency. For example, a view-dependent value 
of Length = 0.5 means subdivide until all triangles 
are no bigger than half a pixel in the resulting 
image. If the Length attribute is set to 0.0, this 
criterion is ignored by the tessellator.

Distance  If the View Dependent flag is turned on, this 
distance is expressed in pixels, otherwise it is 
expressed in object-space units. The lower the value, 
the more closely the tessellated surface will match 
the exact NURBS surface. Small values such as 0.1 
work well (with view dependency disabled). If the 
Distance attribute is set to 0.0, this criterion is 
ignored by the tessellator.

Spatial

The Spatial approximation method is the same as the Length criteria 
from the Length/Distance/Angle method. Using this method, the 
mesh will be subdivided until all triangles are less than a certain size, 
determined by the Length attribute. This value is expressed in either 
pixels or object-space units, as determined by the View Dependent 
flag. This method is the only one available when using the Fine 
approximation type.

Sharp

Controls normal-vector calculations. If set to 0.0, mental ray for Maya 
uses the interpolated normal, as specified by the base surface, 
modified by displacement if available. If set to 1.0, mental ray for 
Maya uses the geometric normal to achieve a sharp faceted look
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Create approximation nodes

Create, edit, assign approximation nodes

To create an approximation

1 Select Window > Rendering Editors > mental ray > Approximation 
Editor to open the Approximation Editor window.

2 Select the object.

3 Click the Create button next to the desired approximation type 
(Surface, Trim Curve, or Displace).

An approximation node is created and assigned to the selected object. The 
Attribute Editor is opened with the new approximation node’s attributes. 

To edit an approximation

1 Open the Approximation Editor if it’s not already open (Window > 
Rendering Editors > mental ray > Approximation Editor).

2 Select the object if it’s not already selected.

3 Click the Edit button in the Approximation Editor. 

To assign an approximation to another object

1 Open the Approximation Editor if it’s not already open (Window > 
Rendering Editors > mental ray > Approximation Editor).

2 Select the object if it’s not already selected.

3 Select the desired approximation from the approximation type drop-
down list and click the Assign button next to the approximation type 
drop-down list.

Obtain quads for subdivision surfaces

For more information about mental ray for Maya geometry types, see 
”mental ray for Maya geometry types” on page 48.

To get quads everywhere in a rejected subdivision surface

1 Select Subdiv Surfaces > Collapse Hierarchy >  .

2 Set Number of levels to 1. 

3 Click Apply.
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Reference Windows and Editors

Approximation Editor

Derive from Maya

The default setting for mental ray for Maya approximation (see also 
”Derive from Maya (default approximation) settings” on page 45). 
This setting uses the Fine displacement approximation setting. This 
advanced technique produces memory-efficient tessellations that 
capture extremely fine details in displacement maps. By default, the 
algorithm is set to use a view-dependent technique that tessellates 
details as small as 1 pixel across. 

Surface Approximation settings (Attribute 
Editor)

The following settings appear when an approximation node is 
selected in the Approximation Editor, or when an object to which an 
approximation node has been assigned is selected in the scene view.

Most of these settings are similar to other types of approximation 
nodes: trim curve, and displacement approximations. 

Presets

This dropdown list provides many useful preset tessellation settings. 

You can select an item from this list to load the preset values for the 
approximation node's attributes. You can use these settings as-is, or as 
a starting points for tweaking. By default, the Presets tab is set to 
Custom, which means that you have control over all approximation 
attributes. 

Parametric Grid 

(Low/Medium/

High Quality) Uses the Parametric approximation method to 
tessellate a surface into triangles. With this method, 
each patch (area between isoparms) is subdivided 
into a fixed number of triangles. 

Use this preset to produce tessellations where 
triangles are distributed roughly according to the 
spacing of isoparms on the surface, with closer 
isoparms producing higher triangle densities.
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Regular Grid 

(Low/Medium/

High Quality) Uses the Regular Parametric approximation method, 
where the surface as a whole is subdivided into a 
fixed number of triangles (instead of each patch, as 
is the case with the Parametric method). 

Use this preset to ensure an even triangulation over 
surfaces where the spacing of isoparms is uneven.

Angle Detailed 

(Low/Medium/

High Quality) Uses an adaptive tessellation method in which more 
triangles are added to areas of high curvature. The 
goal of this method is to add triangles where they 
are needed to capture sharp features, while at the 
same time using just a few triangles in large, flat 
areas where they are not needed.

Pixel Area (Low/

Medium/High 

Quality) Tessellates surfaces based on their size (in pixels) in 
the final rendered image. Surfaces that are close to 
the camera will be tessellated heavily, while surfaces 
that are far away from the camera will receive 
coarser tessellations. The goal of this preset is to 
focus the most attention on surfaces that are more 
significant to the final image.

Approx Style

Determines the general subdivision scheme that is used to break the 
surface into triangles. For examples, see ”Approximation styles” on 
page 47.

Grid Works on a grid of isolines that allows subdivision 
only by adding more isolines. Since isolines always 
run from one edge of the surface to the opposite 
edge, and since only whole isolines can be added, 
this produces regular triangle meshes which can 
sometimes contain many more triangles than 
necessary.

Tree Specifies a hierarchical subdivision style that allows 
local subdivisions without affecting other areas. The 
local subdivisions are similar to the Grid method, 
but do not cross over to other surface patches. 

Delaunay:  Specifies a mesh refinement technique based on 
Delaunay triangulation, which attempts to 
maximize triangle compactness and to avoid thin 
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triangles. Triangle vertices are generally not 
restricted to rectangular isoline grid points as in the 
Grid and Tree styles. The Delaunay style is 
supported only for free-form surfaces (NURBS), not 
for polygons. The "Max Triangles" and "Grading" 
attributes can be used to fine-tune tessellations 
using the Delaunay style.

Fine Subdivides surfaces into a large number of roughly 
uniformly-sized small triangles in order to 
guarantee a smooth result. To deal with the large 
number of triangles resulting from this 
approximation style, mental ray breaks the surface 
up into independent sub-objects that are each 
tessellated and cached separately. This allows the 
tessellator to generate a large number of triangles 
without incurring a huge memory cost. This 
approximation style is similar to the one used by 
Pixar's Renderman software, and only supports the 
"Spatial" approximation method, which specifies the 
size of triangles to be generated. 

Approx Method

Determines the criteria that the tessellator uses for determining when 
to subdivide a part of the surface. Some approximation methods 
simply break the surface into a fixed number of triangles, while others 
use adaptive criteria to iteratively add more and more triangles until 
some condition is satisfied. 

Parametric This method is driven solely by the "U Subdivisions" 
and "V Subdivisions" attributes. Each patch is 
subdivided into N triangles, where 

N = (U Subdivisions) * (V Subdivisions) * degree^2 * 
2

Thus, with U Subdivisions set to 1.333 and V 
Subdivisions set to 4 on a degree-3 NURBS surface, 
each patch will be subdivided into 1.333*4*3*3*2 = 
96 triangles.

Regular 

Parametric This method is also driven solely by the "U 
Subdivisions" and "V Subdivisions" attributes. With 
this method, though, the surface as a whole is 
subdivided into N triangles, where 

N = (U Subdivisions) * (V Subdivisions)
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With this method, the density of triangles will be 
constant over the entire surface, unlike the 
Parametric method, which tessellates each patch 
independently.

Length/

Distance/Angle This is an adaptive approximation method, meaning 
that the tessellator continually subdivides the 
surface until certain criteria are met. There are 3 
criteria:

Length: Subdivide until no triangle has an edge 
longer than a certain length. The Length attribute is 
used to specify this desired edge length. If the View 
Dependent attribute is turned on, this value is 
specified in pixels, otherwise it is specified in object-
space units. The Length criterion is especially useful 
in conjunction with view dependency, for example a 
view-dependent value of Length=0.5 means 
subdivide until all triangles are no bigger than half a 
pixel in the resulting image. If the Length attribute 
is set to 0.0, this criterion is ignored by the 
tessellator.

Distance: Subdivide until the resulting triangles are 
at no point further than a certain distance away 
from the exact NURBS surface. The Distance 
attribute is used to specify the desired distance. If 
the View Dependent flag is turned on, this distance 
is expressed in pixels, otherwise it is expressed in 
object-space units. The lower the value, the more 
closely the tessellated surface will match the exact 
NURBS surface. Small values such as 0.1 work well 
(with view dependency disabled). If the Distance 
attribute is set to 0.0, this criterion is ignored by the 
tessellator. 

Angle: Subdivide until the normals of neighboring 
triangles form an angle of less than a certain 
tolerance. The Angle attribute specifies the angular 
tolerance. The Angle value should be chosen 
carefully, as small values can cause the number of 
triangles to increase rapidly. 45 degrees is a good 
starting point. If this value is set to 0.0, then this 
criterion is ignored by the tessellator.

There are several other attributes that influence the 
Length/Distance/Angle approximation method:
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View Dependent: When enabled, means that the 
Length and Distance attribute values are assumed to 
be expressed in pixels. Otherwise, these values are 
assumed to be expressed in object-space units. The 
advantage of using view-dependent values is that 
objects that are close to the camera will receive 
many triangles, while objects that are far away (or 
not visible at all) will be approximated much more 
coarsely. 

Any Satisfied: When more than one of the Length/
Distance/Angle criteria are enabled, this flag 
determines when subdivision will stop. If Any 
Satisfied is enabled, then subdivision stops when 
any one of the criteria is satisfied (i.e. triangles are 
smaller than a certain size OR distance from the 
surface is less than a certain amount OR angles 
between triangles are less than a specified amount). 
If Any Satisfied is disabled, then subdivision 
continues until all criteria are satisfied (i.e. triangles 
are smaller than a certain size AND distance from 
the surface is less than a certain amount AND 
angles between triangles are less than a specified 
amount). 

Spatial The Spatial approximation method is the same as 
the Length criteria from the Length/Distance/Angle 
method. Using this method, the mesh will be 
subdivided until all triangles are less than a certain 
size, determined by the Length attribute. This value 
is expressed in either pixels or object-space units, as 
determined by the View Dependent flag. This 
method is the only one available when using the 
Fine approximation type.

Curvature This approximation method is the same as the 
Distance and Angle criteria from the Length/
Distance/Angle method. This method is included 
for backwards compatibility only. 
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Interactive Photorealistic Rendering (IPR)

IPR is available only for Maya software rendering.

IPR, a component of the Render View rendering, lets you preview and 
adjust lights, shaders, textures, and 2D motion blur quickly and efficiently. 

IPR is ideal for visualizing your scene as you work because it almost 
immediately shows the changes you make. You can also pause and stop 
IPR rendering and select several rendering options to be included or 
excluded from the IPR process. IRP works a little differently than regular 
software rendering; if you need to know more about how it works, see 
”How IPR works” on page 67.

IPR doesn't support all software renderable features (for example, 
raytracing or production quality anti-aliasing are not supported). See ”IPR 
Limitations” on page 69. 

How IPR works

When you start an IPR session, Maya computes the initial IPR image, 
which is a deep raster format that contains more than just the final picture. 
Maya performs all the visibility calculations (only once), and stores the 
results in a file in the iprImages directory. 

An IPR image is an IFF image with additional data. It is larger than a 
regular image file because it stores both visibility and shading data:

• Visibility calculations compute where items are located in the scene, 
or what is visible to the camera (or to the light, for depth maps for 
shadowing) at each pixel in the image.
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• Shading calculations compute what color is displayed at each pixel of 
the image.

The data in this format is used to efficiently adjust shading and lighting 
parameters in an interactive way.

To adjust IPR options, see ”IPR Options” on page 180. 

It takes longer to perform an IPR render than it does to perform a software 
render because more information is written to disk. The IPR image 
contains the information needed to perform the shading calculations for 
each pixel in the image as you adjust scene parameters. 

When you select a region to adjust, Maya loads all the necessary 
information into memory for all the pixels in the selected region.

As you modify scene attributes, Maya re-computes the shading 
calculations and the selected region in Render View updates. 

Since none of the visibility calculations have to be re-computed at this 
stage, tuning updates much faster than a full software rendering.

IPR images can be very large (for example, at NTSC Video resolution, a 
single IPR image could be up to 60MB). Make sure you have adequate 
disk space for your IPR image before you perform an IPR Render. 

Note An IPR image is not part of the scene file; it only represents 
what the scene looks like from a specific camera or light, at a 
specific time. You can re-use an IPR image as you work on the 
scene, but remember that the IPR image may be out of sync with 
the scene as you adjust it and move objects in the views.

Note For advanced users:

You can batch process IPR images ahead of time from the 
command line, so you can then adjust several frames of the same 
animation, in which the visibility data may vary from frame to 
frame. 

See ”To batch render IPR files” on page 109 for details.
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IPR Limitations

For more information on IPR, see ”Interactive Photorealistic Rendering 
(IPR)” on page 67.

Visibility limitations

Any change to an attribute that affects the visibility calculation, such as 
changing the camera angle, adding or removing a surface, or transforming 
CVs on a surface, requires another IPR render before you can see the effect 
of that change. Attributes that affect visibility are:

• Transformations applied to an object or camera (like moving an object 
or zooming the view, since moving an object or the camera may 
change what is visible at each pixel). This does not include lighting 
changes; they are supported. 

Adding or removing surfaces, UV mapping values

If you add surfaces to or remove surfaces from the scene, or if you change 
the UV mapping values for a texture, you must perform another IPR 
render before you see the change. Examples of these kinds of changes 
include: 

• When you select a new group of faces on a polygonal surface, even if 
the surface is already in the scene. In IPR, selecting a new group of 
faces to texture is equivalent to creating a new surface. 

• Turning Fix Texture Warp on/off changes how UV mapping values 
are generated in an IPR render. This situation is analogous to 
modifying polygon UVs by changing their placement.

• Editing UVs in the texture window.

Note An IPR default light source (created during IPR rendering) 
works in a similar way to the software renderer’s default, default 
light source. 

• The IPR default light source is removed from the scene as soon 
as the IPR session is terminated (for example, when you click the 
IPR stop button).

• The IPR default light source is not saved with the scene, 
preventing you from accidentally adding the IPR default light to 
the saved scene.

For more information, see ”Default lighting in Maya” on page 15 in 
the Lighting guide. 
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Changing image planes, shadow maps, background color

If you make changes to shadow map resolution, image planes, or 
background color, you must manually update the IPR tuning region 
(select IPR > Update Shadow Maps or IPR > Update Image Planes/
Background).

Features not supported by IPR

• raytracing effects (for example, transparency, reflection, refractions) 

• particles

• 3D motion blur

• anti-aliasing: adaptive shading, multi-pixel filtering

• global override of Enable Depth Maps attribute (in the Render Global 
Settings window) does not function properly

• output to IFF (deep raster)

Image plane limitations

• only supports file mode, not texture mode.

• Changes to file mode do not IPR render properly unless you turn on 
“Update Image Planes/Background” per change.

Shader and Texture limitations

• Use Background shader is not well supported because it relies on 
raytracing.

• Modifying, adding, or deleting a displacement map applied to the 
geometry requires re-rendering. 

• Turning on advanced filters (such as quadratic, cubic, or Gaussian) in 
the file texture requires re-rendering. Much more information needs to 
be stored into the IPR image, unless the render was originally 
generated with the advanced filter turned on.

Geometry changes that require IPR re-rendering

• Adding or deleting geometry.

• Transforming or morphing geometry.

• Changing tessellation.

• Turning on/off Fix Texture Warp for the surface, or modifying any 
Fix Texture Warp attributes.

Shadow changes that require IPR re-rendering 

If you move a light, the shadow does not update. 

Changes to the light’s attributes require the depth map to be regenerated 
if the shadows are to be correct in the following cases:
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• Transforming the light.

• Turning on/off Use Auto Focus.

• Changing a Spot light’s cone angle or penumbra attribute values.

Glow limitations

• Light glow intensity may appear different because the light glow 
occlusion is computed at the time of the IPR generation. If the light is 
moved where the light glow occlusion changes, an inaccurate glow 
intensity could result.

• Shader glow may look different because the IPR region (not covering 
the entire scene) produces a different auto-exposure normalization.

Others

• Changing blur-by-frame does not update the IPR unless you re-
render.

• 2D motion blur won’t be exactly right because you work on a smaller 
region. 

Render View rendering

If you want to render a single frame (or a single frame of an animation), 
render it in Render View. Advantages include the following:

• easy to use

• Maya UI

• you can see the render as it occurs

• you can interrupt the render at any time

To render in Render View, see:

• ”Test render a low-res still or frame” on page 111.

• ”Perform final renders from within Maya” on page 114.

Tip Consider using directional lights for preview rendering, 
especially when using IPR. These lights are easy to transform to 
get the initial light effect you need. Maya’s default light is the 
directional light.

Note Large scenes or image files may run out of memory. In this case, 
use batch rendering to reduce memory usage.
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Batch renders from within Maya (UI)

If you want to render an animation, start a batch render from within the 
Maya UI. (You can also render a single frame this way.) Advantages 
include the following:

• easy to use

• you can continue to use the Maya UI

• you can start a batch render while you continue to work within Maya

• you can interrupt the render at any time from within Maya

To start a batch render from within Maya, see ”Perform final renders from 
within Maya” on page 114.

For more detailed information on batch rendering, see ”Overview of batch 
rendering” on page 93 in the Rendering Utilities guide.

Command line renders

You can render from a command line if you want to render an animation 
or single frame. 

Advantages include the following:

• works with single images and animation

• uses less memory than having all of Maya (UI) running

• can be scripted

• can be integrated into a rendering pipeline (render farms)

• for Maya software rendering, you can override render globals using 
command flags (for other renderers, you must also write a MEL 
script).  

Exporting .mi files

Scene Export Optimization Controls

Several controls let you manually optimize the process of exporting scenes 
to .mi format. The translator now recognizes a specific set of dynamic 
attributes that you can add to nodes to control how they are exported. 

To export a .mi file, see ”To export a .mi file and render with mental ray” 
on page 118.

You can accelerate the process of exporting scenes to .mi format by 
disabling deformation checking for objects that are known to be static over 
an animation (buildings, for example), and by disabling tangent vector 
export for objects that do not use bump mapping or other tangent-based 
shading effects.
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miDeformation

Controls whether or not the translator tries to detect deformation of 
an object.

To support per-object control of deformation determination and 
motion vector calculation of shape nodes, this dynamic attribute of 
type boolean is recognized. It overrides the global Export Shape 
Deformation option and either marks the current shape for or 
excludes it from deformation motion blur. Two common scenarios are 
supported: 

• disable deformation globally but enable it for specific shapes

• enable deformation globally but disable it for specific shapes

miTangents

Controls export of tangent vectors on objects.

To support per-object control of tangent vector calculation for polygon 
meshes and NURBS surfaces, this dynamic attribute of type boolean is 
recognized. It overrides the global Export ... Derivatives options and 
marks or ignores the current shape accordingly for tangents 
computation. Two common scenarios are supported: 

• disable tangents globally but enable them for specific shapes

• enable tangents globally but disable them for specific shapes

The tangents are first order derivatives supplied as mental ray bump 
basis vectors. They are required for mayabase shader filtering and 
bump mapping purposes.

Render output

File formats

Maya can save rendered image files in several standard image file 
formats. 

Note The command, mayaexport_with_mr, which is available on all 
platforms via a shell, allows you to perform an export from a 
Maya scene to an .mi file for rendering with mental ray 
standalone.  For information on how to use the 
mayaexport_with_mr, type mayaexport_with_mr -h in a shell.
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By default, Maya saves rendered image files in the Maya Image File 
Format (Maya IFF). The Maya IFF is the most efficient format, in which no 
data loss occurs. All other file formats are translated from the Maya IFF 
format. 

For information about the File format syntax, see ”File name syntax” on 
page 78.

To set the file format, see ”Set the rendered image file format” on page 93.

Bitmap vs. vector

Maya can render and save an image in either bitmap or vector format. A 
bitmap image uses pixels (colored squares) arranged in a grid to describe 
the image. When you zoom into a bitmap image, you can see the jagged 
edges of individual pixels. Common bitmap formats include TIFF, GIF 
and BMP.

A vector image uses vectors (lines and curves) to describe the image. 
When you zoom into a vector image, lines and curves remain smooth. 
Common vector formats include SWF (Flash), AI (Adobe Illustrator) and 
SVG (Scalable Vector Graphics).

Details of supported file formats

Note If Image Format is SWF or SVG, an animation renders as a single 
file. Otherwise, an animation renders as a series of sequential 
files.

Note EPS files (generated by any application) do not import correctly 
into non-Adobe products (such as the Flash authoring 
application). EPS files import correctly into Adobe products. 
(SWF and AI files import correctly into the Flash authoring 
application.)

Adobe Illustrator 
(ai)

This file format is available on Windows and Mac OS X only, and only 
when using the Maya Vector renderer.

Adobe Illustrator (version 8) file format.

When rendering to Adobe Illustrator format, the background color is 
always white.
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Alias PIX This file format is available on IRIX, Linux and Windows only.

Alias pix file format. Maya saves the image, mask, and depth channels as 
separate files. 

AVI (avi) This file format is available on IRIX and Windows.

On IRIX, the support is limited to approximately five codecs that SGI 
licensed from Microsoft (or other vendors) around 1996.

On Linux, IMF does not support movie files. 

On Windows, IMF can handle only uncompressed AVI files. 

Microsoft Audio Video Interleaved movie file format. Maya can store a 
sequence of images in an AVI file. Maya only renders out uncompressed 
AVI files because anything else is lossy. 

Cineon (cin) This file format is available on IRIX, Linux and Windows.

Cineon image file format. Maya does not create a mask file or channel. 

This is a format typically used for digital film, however, Maya does not use 
the 10 bit log encoding standard.

Encapsulated 
PostScript (eps)

Encapsulated PostScript file format.

An EPS file can contain both bitmap and vector image information.

When using the Maya Vector renderer (Windows and Mac OS X only), the 
rendered EPS file consists of a vector image.

When using bitmap renderers, the rendered EPS file consists of a bitmap 
image. Maya saves the image and depth channels as separate files. (Maya 
does not create a mask file or channel.)

When rendering to EPS format with the Maya Vector renderer, the 
background color is always white.

GIF (gif) This file format is available on IRIX, Linux and Windows.

Graphics Interchange Format typically used for web. Maya saves the 
image and depth channels as separate files. (Maya does not create a mask 
file or channel.) GIF images may be up to 8 bits (256 colors) in depth and 
are always compressed. 

Animated GIFs are not supported.
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JPEG (jpg) Joint Photographic Experts Group file format. Maya saves the image and 
depth channels as separate files. (Maya does not create a mask file or 
channel.) The JPEG format is standard for compressed still images. JPEG 
uses DCT and offers data compression of between 5 and 100%. Three 
levels of processing are defined: baseline, extended, and lossless. Maya 
supports only JPEG formats containing RGB information; Maya does not 
support JPEG formats containing CMYK information.

Compression is controlled by the environment variable 
AW_JPEG_Q_FACTOR. Setting it to 1 gives the lowest quality (most 
compression) and setting it to 100 gives the highest quality (least 
compression). The default value is 75.

Macromedia 
Flash (swf)

This file format is available on Windows and Mac OS X only, and only 
when using the Maya Vector renderer.

Macromedia Flash Player (version 3, 4 or 5) file format (non-interactive).

Maya IFF (iff) Maya Image File Format with 8 bits per color and mask channel. 
Additional channels (e.g. depth, motion vector data) are stored as floating 
point data.

Maya saves the image, mask, and other channels in one file. 

Maya16 IFF (iff) Maya Image File Format with 16 bits per color and mask channel. 
Additional channels (e.g. depth, motion vector data) are stored as floating 
point data.

Maya saves the image, mask, and other channels in one file.

Not available when using the Maya Vector renderer.

MacPaint (pntg) Mac OS X only. 

Photoshop (ps) Mac OS X only. Adobe PhotoShop file. 

PNG (png) Mac OS X only. 

Quantel (yuv) This file format is available on IRIX, Linux and Windows.

Quantel image file format. Maya saves the image and mask channels in 
one file. The Quantel format outputs to YUV. Maya can only output 
Quantel format images at NTSC, PAL, or HDTV resolutions; if you select 
a different resolution, Maya saves rendered images in Maya IFF. 

QuickDraw (pict) Native Macintosh file format.
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QuickTime 
Image (mov)

This file format is available only on IRIX and Mac OS X. 

On Mac OS X, all QuickTime image formats are supported, including 
any user-written or user-added QuickTime plug-in formats. For the 
Maya software renderer and the Maya Hardware renderer, QuickTime 
output supports over 20 different compression codecs for batch 
rendering and Playblast.

Apple QuickTime movie file format. Maya can store a sequence of images 
in a QuickTime file.

RLA (rla) This file format is available on IRIX, Linux and Windows.

Wavefront image file format. Maya saves the image, mask, and depth 
channels in one file. 

Scalable Vector 
Graphics (svg)

This file format is available on Windows and Mac OS X only, and only 
when using the Maya Vector renderer.

Scalable Vector Graphics file format.

When rendering to SVG format, the background color is always white.

SGI (sgi) Silicon Graphics Image file format with 8 bits per color channel. Maya 
saves the image and mask channels in one file, and the depth channel as a 
separate file.

SGI16 (sgi) This file format is available on IRIX, Linux and Windows.

Not available when using the Maya Vector renderer.

Silicon Graphics Image file format with 16 bits per color channel. Maya 
saves the image and mask channels in one file, and the depth channel as a 
separate file. 

SGI Movie This file format is only available on IRIX and Linux.

SGI movie file format. Maya can store a sequence of images in an SGI 
Movie file. Maya only renders out uncompressed SGI Movie files as these 
are the most general for reading into other applications. 

SoftImage (pic) This file format is available on IRIX, Linux and Windows.

SoftImage image file format. Maya saves the image and mask channels in 
one file, and the depth channel as a separate file.

Targa (tga) Targa image file format. Maya saves the image and mask channels in one 
file, and the depth channel as a separate file.

Not all Targa formats are supported. 
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File name syntax

The name of rendered image files can consist of three separate 
components: file name prefix, frame number extension, and file format 
extension. A combination of these three components is referred to as the 
file name syntax. 

file name prefix

The base name for all image files in a scene. 

Tiff (tif) Tagged-Image File Format with 8 bits per color channel. Maya saves the 
image and mask channels in one file, and the depth channel as a separate 
file. Maya generates TIFF files that use TIFF 6.0 compression. To generate 
uncompressed TIFF files, set the environment variable 
IMF_TIFF_COMPRESSION = none before starting Maya. (For more 
information on environment variables, see ”Setting environment variables 
using Maya.env” on page 3 in the Basics guide.)

Use uncompressed TIFF files when you intend to read the images into an 
application that requires uncompressed images or that supports the TIFF 
4.0 standard.

Tiff16 (tif) Not available when using the Maya Vector renderer.

Tagged-Image File Format with 16 bits per color channel. Maya saves the 
image and mask channels in one file, and the depth channel as a separate 
file. Maya generates TIFF files that use TIFF 6.0 compression. To generate 
uncompressed TIFF files, set the environment variable 
IMF_TIFF_COMPRESSION = none before starting Maya. Use 
uncompressed TIFF files when you intend to read the images into an 
application that requires uncompressed images or that supports the TIFF 
4.0 standard.

Windows Bitmap 
(bmp)

Windows bitmap image file format. RGB only. Doesn’t support paletted 
images.

Maya saves the image and depth channels as separate files.

(Maya does not create a mask file or channel.)

name.001.iff file format extension

frame number extension

file name
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frame number extension

Represents the frame at which the image was rendered.

file format extension 

Represents the file format of rendered images (see also ”Set the 
rendered image file format” on page 93).

You can control how Maya names rendered image files in the Render 
Global Settings window. Whenever you change the file name, format of 
the frame number extension, or the file format extension, Maya updates 
the preview file name at the top of the Render Global Settings window. 
You can arrange the name, number extension, and format extension in 
different orders, with or without dot. 

To set the file name, the frame number extension, or the file format 
extension, see ”Set file name syntax” on page 93. 

File output location

By default, Maya saves rendered images to the images directory of the 
current project. You can, however, change the location to save in any 
directory.

To set the file output location, see ”Set rendered images output location” 
on page 95. 

Note Using “.” to delineate animated file texture names, may cause 
the wrong frame to be used for texture mapping. 

Maya parsable, animated file textures should be of the form 
XXX.ext.###, where XXX is the filename, ext is an optional file 
extension (sgi, tif, iff, and so on), and ### is the frame number. 

It is also possible to use file textures of the form XXX.###.ext. 
We do not support XXX###.ext (without the “.” between XXX 
and ###), nor XXX.YYY.###.ext (but XXX_YYY.###.ext is fine).

Note If you are rendering images with a mask or depth channel and 
the file format of rendered images does not support mask or 
depth channels, Maya may save the mask channel as a separate 
file in the mask directory of the current project, and the depth 
channel as a separate file in the depth directory of the current 
project.
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Pixel aspect ratio

A rendered bitmapped image file consists of numerous rectangular pixels 
(picture elements). The size of a rendered image is measured by the 
number of pixels it contains horizontally and vertically, and by the aspect 
ratio of individual pixels (whether pixels are square or rectangular).

Most display devices (for example, a computer monitor) have square 
pixels, and their Pixel Aspect Ratio is 1. Some devices, however, have non-
square pixels (for example, NTSC video has a Pixel Aspect Ratio of 0.9). 

To set the pixel aspect ratio, see ”Set the resolution and pixel aspect ratio” 
on page 95. 

Resolution

Image resolution is the total pixel size of a bitmap image. For example, 720 
x 486 for NTSC video output. Display resolution is the number of pixels in 
1 inch on the screen. Display resolution is measured in pixels per inch 
(ppi). Most monitors have a display resolution of about 72 ppi. If your 
output is for print, consider a display resolution of around 300 ppi.

To set the pixel aspect ratio, see ”Set the resolution and pixel aspect ratio” 
on page 95. 

Frames vs. Fields

Only the Maya software renderer supports field rendering.

Motion picture film and video simulate motion by displaying a 
continuous sequence of images or frames. There are, however, important 
differences in the way film and video systems display individual frames 
which may affect how you render images.

To render as frames or fields, see ”Specify frame or field rendering” on 
page 98. 

Note The terms pixels per inch (ppi), and dots per inch (dpi) are often 
interchanged freely. Pixels per inch, however, applies only to 
screen resolution, which display images in pixels. Dots per inch, 
applies only to paper-based images, which are printed with dots 
of color.
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About > Video system fields
Video system fields

Most video systems display an individual frame in two stages—by 
illuminating half of the phosphors on a television screen (in NTSC every 
odd row beginning with the first row), and then illuminating the 
remaining half of the phosphors (every even row beginning with the 
second row). These two half-frames are known as fields and the process of 
displaying the two fields alternately is called interlacing.

NTSC and PAL video systems both use interlaced fields. NTSC video 
systems display 30 frames per second, or 60 fields per second; PAL video 
systems display 25 frames per second, or 50 fields per second.

Because video systems display an individual frame in tw

o stages, if you render images as frames (that is, in one stage) and then 
display them on a video system, fast moving objects may appear jerky or 
choppy. If post-production process or final presentation formats involve 
interlaced video systems, render images as fields. (If your animation does 
not contain fast moving objects, you could try rendering images as 
frames.) 

To properly view a frame or an animation rendered as fields, you must 
interlace the two fields together.

Motion picture film frames

Motion picture film projectors display an entire frame in one brief instant 
by shining light through the film. Most motion picture film systems 
display 24 or 25 frames per second.

Image courtesy of
  The Art of Maya
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If your post-production process and final presentation format do not 
involve interlaced video systems, render images as frames. 

Color, Depth, and Mask (alpha) channels

Each pixel in a bitmap image contains three color channels, each of which   
represent the amount of red, green, or blue in the image. Each pixel might 
also have an alpha (mask) channel to achieve transparency and a depth 
channel that represents the distance from the camera. 

By default, Maya generates an image file with three color channels and a 
mask channel. 

To enable specific channels to rendered images, see ”Enable color, depth, 
and mask channels for rendered images” on page 96. 

Pre Render MEL and Post Render MEL scripts

In some situations, you may want Maya to run a specific MEL command 
or script before rendering each frame, and another MEL command or 
script after rendering. For instance, if your scene contains a very large 
complex surface, which you do not want to work on, you could run a 
MEL command before rendering to display the surface (so it renders), and 
run another MEL command after rendering to hide the surface.

Note Mask channels and depth channels are mainly used for 
compositing, so if you don’t plan on compositing rendered 
images, you don’t have to generate mask or depth channels (or 
files) during rendering. 

The file size increases if an image contains a mask or depth 
channel. The computation time may also increase.

For information about mask and depth channels and files, see 
”Mask and depth channels” on page 84.s 

Color channels Mask channels Depth channels
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About > Advantages and tips
To run Pre Render MEL scripts or Post Render MEL scripts, see ”Run Pre 
Render MEL or Post Render MEL scripts” on page 99. 

Layers and passes

Advantages and tips

You can render individual objects, groups of objects on layers, or 
attributes (passes) of your scene, then combine them using a compositing 
system. Compositing is the process of combining multiple images into 
one. 

(You can also render global illumination passes separately. )

To set up layers and passes, see ”Set up layers and passes” on page 105.

Advantages of rendering in layers and passes

Rendering separate objects in layers and passes takes more time and effort 
to plan, but it offers the following advantages:

• More creative freedom. 

For example, you can render different layers with different render 
options. You can then color correct or add special effects to each 
rendered layer in a compositing application.

• Flexibility to accommodate unanticipated requests for changes. 

For example, you can change a ceramic vase to a glass vase without 
re-rendering the entire scene.

• Increased speed to meet production schedules. 

For example, you can quickly render the foreground layer where most 
changes occur, instead of the whole scene or background, where 
objects tend to be static. You can also render smaller portions of large 
scenes, reducing the load on computer memory.

General tips for rendering for compositing

• Plan to separate a scene into elements early in the production process.

Note If you need to use multiple sets of quotations in the pre frame 
MEL or post frame MEL fields in Render Global Settings 
window, be sure to use \" for every quotation mark except the 
first and last. For example,

print("Time to render my Maya scene, called\"bingo.mb"\");
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About > Mask and depth channels
• If you plan on compositing rendered images, make sure the scene’s 
background is black. To change the color of the background, see the 
Lights and camera’s chapter. 

• Understand the type of image that compositors require: pre-
multiplied or not.

Premultiplied images

When an image is stored not only with the three basic color channels but 
also with the alpha channel, the presence of the alpha channel can modify 
the color channels to some degree. For example, typically the color 
channels have been multiplied by the value of the alpha channel to take 
transparency into consideration. 

Some compositors (as well as games engines) can use premultiplied 
images; others require separate image and alpha information, especially 
when they want to separate object color data from background color data. 
By default, Maya premultiplies images, but you can turn premultiplication 
off. 

To turn premultiplication on or off, see ”Premultiply” on page 176.

Mask and depth channels

During rendering, Maya software can generate an image file that contains 
color channels (RGB), a mask channel (RGBA), a depth channel (RGBZ) or 
a combination of the three (RGBAZ). For more information on color 
channels, see ”Color, Depth, and Mask (alpha) channels” on page 82.

Some image formats cannot include embedded mask or depth channels; in 
these cases, Maya generates a separate mask or depth file. 

By default, Maya generates an image file with three color channels and a 
mask channel. Mask channels and depth channels are mainly used for 
compositing. You can control the types of channels Maya includes in 
rendered image files. For instance, if you don’t plan on compositing 
rendered images, you don’t have to generate mask or depth channels 
during rendering. 
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About > Mask channels
To turn channels on or off, see ”Enable color, depth, and mask channels 
for rendered images” on page 96.

Mask channels

A mask channel (or alpha channel) defines where an image is opaque or 
transparent. Opaque regions of the objects are white, semi-transparent 
regions are gray, and transparent regions are black.

Use a mask channel to layer images for compositing software. For 
instance, you can use the mask channel of an image as a matte to 
composite an object (without its background) with another image.

Depth channels

A depth channel (or Z depth or Z buffer channel) provides 3D information 
about an image. It represents the distance of objects from the camera. 

Depth channels are used by compositing software. For instance, you can 
use the depth channel to correctly composite several layers while 
respecting the proper occlusions. 

Maya stores depth values as -1/z. These represent the near and far 
clipping values. 

Arranging objects in order in 3D space

When you render in layers the compositing application must be able to 
tell which part of which object goes behind or in front of another one. 
Alpha channels do not contain this information, so you can use the Black 
Hole mode of the Matte Opacity feature in Maya to produce cutout 
regions composite correctly. See ”Modify a mask channel” on page 97. 

Render layers

When you render in layers you render objects separately.

Rendering objects in layers is the process of separating objects into layers, 
then producing a different image for each layer. For example, the 
following scene was rendered as two separate elements—foreground and 
background character—and composited with a background image.

To set up layers and passes, see ”Set up layers and passes” on page 105.
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About > Display vs. Render Layers
Consider the following strategies:

• render each object separately.

• render static objects (once for the entire animation) and moving 
objects separately.

• render foreground objects and background objects separately.

• render groups of interacting objects separately.

• render objects and shadows separately.

• render surfaces and volumetric effects (environment fog, light fog, 
particle effects, and volume shaders) separately.

• render objects and shadows independently. For instance, you can 
render an object so it does not cast shadows, but can receive shadows 
cast by other objects.

Display vs. Render Layers

If you create your entire scene on one layer (default), you can separate 
objects onto different Render layers before you render. If, during the 
modeling and animation phases you divided your scene into display 
layers, you can render these display layers separately. 

Note If you are raytracing a scene, it may be difficult to render 
elements of a scene separately because objects need to reflect and 
refract other objects.

Foreground character Background characterBackground image 

Composited scene
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About > Render passes
To divide your scene into layers (or see if it already is divided), see ”Set 
up layers and passes” on page 105.

You can also select specific objects to render or you can use a clipping 
plane to render only near (foreground) objects or far (background) objects. 

For more information about clipping planes, see ”Clipping planes” on 
page 34 in the Rendering guide.

Render passes

When you render in passes, you render attributes of your scene 
differently. Rendering in passes gives you precise control over the color of 
objects and the shadows that fall on them. 

Typically you render in passes to render various attributes, such as color, 
shadows, highlights, of your scene separately. You can fine-tune a scene 
without re-rendering it by modifying different passes in a compositing 
program.

To set up render passes, see ”Set up layers and passes” on page 105. 

Beauty pass

This is the default pass. The Beauty image is automatically produced by 
the renderer if Render Passes is disabled in the Render/Layer Pass 
Control section of the Render Global Settings window.

It produces a complete rendering of the components produced by a 
shadow pass and a color pass. Because the color pass produces a complete 
rendering of the components produced by a diffuse pass and a specular 
pass, a beauty pass ends up producing a complete rendering of all 
possible components. 

Shadow Pass Color Pass

Diffuse Pass Specular Pass

Beauty Pass
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About > Color pass
If you need to tweak shadows independently in a compositing package or 
paint application, run the color and shadow passes separately.

Color pass

Produces only the color component of the image. No shadow information 
is produced.

A color pass is subdivided into a diffuse and specular pass.

Shadow pass

Produces only the shadow component of the image. No color information 
is produced. 

Diffuse pass

Only diffuse shading is performed. The diffuse pass contains the diffuse 
and ambient information and is modulated by color, transparency, and 
Diffuse Coeff (diffuse coefficient). 

Specular pass

Only specular shading is performed. The specular component is 
modulated differently depending on the type of material associated with 
the object. Phong, PhongE, Blinn, and Anisotropic materials produce 
specular contributions differently. On a Phong material, the specular pass 
can be modulated using cosine power, and specular color. 

Note No mask or alpha channel is produced for the Specular Pass, 
additively compositing a specular pass is recommended. 

In this example, Phong, PhongE, Blinn, and 
Anisotropic materials are used.
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How do I? > Custom shadow and reflection passes
Custom shadow and reflection passes

You can also create custom shadow and reflection passes with the 
useBackground material which catches shadow and/or reflections. When 
the shadow pass is rendered, a black image is created with mask channel 
that contains the shadow information. A compositor can work with this 
channel to blur, lighten, darken, etc., the look of the shadows. When the 
reflection pass is rendered, an RGB image is created with a white mask in 
the mask channel. 

To use the Use Background material to catch shadows and reflections, see 
”Catch shadows for an alpha channel” on page 73 in the Lighting guide.

How do I? Visualize scenes and render images

A typical rendering workflow

The exact workflow steps and the order in which you perform them vary. 
Rendering is an iterative process in which you tweak lights, textures, and 
cameras; adjust various scene and object settings; visualize your changes; 
then, when you are satisfied with the results, you render your final 
images.

Having shaded and textured objects in your scene (see ”Surface shading” on 
page 15 in the Shading guide), set up lights (see ”Light and shadow in the real 
world” on page 7 in the Lighting guide), and set up renderable cameras 
(optional, see ”Viewing cameras vs. rendering cameras” on page 27), 
generally you do the following:

To render a scene

1 Decide which renderer you want to use, and set scene options for it:

• For detailed information about each of Maya’s renderers, see 
”Renderers” on page 15.

• To select a renderer, see ”Select a renderer” on page 25.

• To learn more about some of the scene options you can set, see 
”Set scene options” on page 92. For detailed descriptions of the 
scene options, see ”Render Global Settings window” on page 159.

2 If you plan to composite your work, you can render your scene in 
layers and passes. 

See ”Set up layers and passes” on page 105.

3 Make any required per-object adjustments:
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• To adjust the surface quality (tessellation) of objects, see 
”Tessellate objects” on page 49.

• To adjust per-object settings; for example, settings for lights, 
cameras, objects, see information on the particular object you want 
to adjust. 

4 Test iterations of your scene to visualize your the changes you make 
materials, textures, lights, cameras, and objects. 

• To visualize your changes as you make them, see ”Visualize a 
scene” on page 107.

• To diagnose scene problems, see ”Diagnose scene problems” on 
page 141.

• To optimize rendering speed image quality, see ”Image quality 
and render speed” on page 131.

5 When you are satisfied with the results, render the final images. 

• See ”Perform final renders from within Maya” on page 114.

• See ”Perform command line rendering” on page 117.

Choose a rendering method

Visualize a scene

Though you can render a scene to see what it looks like, visualizing your 
scene in the following ways can be faster:

To... Do this...

See changes to a still image or a 
single frame of an animation as 
you make them. 

Use Interactive Photorealistic 
Rendering (IPR)

IPR updates the display to show 
your most recent change, but there 
are limitations to what you can see. 

For more information, see 
”Interactive Photorealistic 
Rendering (IPR)” on page 67.
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How do I? > Perform a final render
Perform a final render

See what a still image or single 
frame of an animation (or a region 
of it) looks like as the render 
occurs. 

Use Render View, especially 
Render Region.

Render View has fewer limitations 
than IPR, so you can see more, but 
it takes longer to render.

Render regions of a scene to reduce 
the amount of time you spend 
visualizing the scene. 

For more information, see ”Render 
View rendering” on page 71.

See lights, objects and textures in 
the scene view without rendering. 

Use hardware texturing.

This does not actually perform a 
render; it just lets you see an 
approximation of what your scene 
looks like when rendered. 

For more information, see ”See 
shading and lights in a scene view” 
on page 110.

See what a fully rendered still 
image, single frame of an 
animation, or an animation looks 
like quickly. 

Render at lower resolutions

For more information, see ”Test 
render a low-res still or frame” on 
page 111 and ”Test render a low-
res animation” on page 111.

To render... Do this... 

A still image or single 
frame of an animation

Use Render View.

For more information, see ”Render a single 
frame” on page 114.

A still image or single 
frame of an animation, or 
an animation

Batch render

For more information, see ”Batch render a 
still or animation” on page 115.

To... Do this...
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Set scene options

Open the Render Global Settings window

The settings you use to produce your final rendered image or sequence of 
images depend on a number of factors, including:

• the renderer you use

• the medium to which you are outputting

• whether you are rendering in layers and passes for compositing

• whether you are preview rendering or producing the final rendered 
image(s)

Render globals for the Hardware renderer, the mental ray for Maya 
renderer, the Maya software renderer, the Maya Vector renderer are 
available from the Render Globals Settings window. 

The Common tab of the Render Global Settings window contains the 
attributes common to most of the renderers, which decreases the number 
of parameters you need to modify when switching between renderers. 
Settings specific to the chosen renderer are available in a another tab.

For detailed descriptions of the settings in the Render Global Settings 
window, see ”Render Global Settings window” on page 159.

To open the Render Global Settings window

• Do one of the following:

• Click Window > Rendering Editors > Render Globals.

• Click the Display Render Globals Window button on the main 
toolbar or in Render View.

• Choose Options > Render Globals in Render View.

A still image or single 
frame of an animation, or 
an animation

Command line render

For more information, see ”Command line 
render” on page 117.

Note The changes you make in the Render Global Settings window 
affect the entire scene. Often, it makes sense to adjust settings on 
a per-object setting. 

To render... Do this... 
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How do I? > Render all or some objects from a camera
You can edit settings in the Common tab and the renderer-specific tab. 
For more information, see ”Render Global Settings window” on 
page 159. 

Render all or some objects from a camera

By default, your scene has only one renderable camera (the original 
perspective camera) that renders all objects in your scene. You can change 
this to render only selected (active) objects in your scene.

If you add another camera to your scene and want to make it renderable 
(or you would like to make one of the default orthographic cameras 
renderable), you must set this camera to renderable (see ”Make a camera 
renderable” on page 36(. 

To render only active objects in your scene

1 In the Image File Output section of the Render Global Settings 
window, select the camera from the Camera drop-down list.

2 Select Render Active from the Render Objects drop-down list.

Set the rendered image file format

Maya can save rendered image files in one of several standard image file 
formats. By default, Maya saves rendered image files in the Maya Image 
File Format (Maya IFF).

For a comprehensive list of supported file formats, see ”File formats” on 
page 73.

To set the file format of rendered images

In the Image File Output section of the Render Global Settings window, 
select the Image Format from the drop-down menu.

Set file name syntax

For information on the file name syntax, see ”File name syntax” on 
page 78.

Note For image formats that cannot include mask or depth channels, 
Maya generates a separate mask or depth file.
Rendering

93



4 | Visualize and render images 
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To set the file name (syntax) for rendered images

• In the Image File Output section of the Render Global Settings 
window, set:

• File name prefix, (for example, rocket)

• Frame/Animation Ext to the combination and order of base name 
(name). 

Note You can also set the file name of rendered files when you render 
from a shell or command line, using Render and the -im option. 

See ”Perform command line rendering” on page 117 for 
information about command line rendering. 

Option Example

name rocket

name.ext rocket.iff

name.#.ext rocket.1.iff

name.ext.# rocket.iff.1

name.# rocket.1

name#.ext rocket1.iff

Important

• If you select an option that does not contain #, Maya renders 
a single frame.

• If you select an option that does contain #, Maya renders an 
image sequence (animation). The top of the Render Global 
Settings window provides feedback for the output files.
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How do I? > Set rendered images output location
• File format extension (ext). 

• Frame number extension (#) you want rendered files to have.

• Start Frame to the first frame you want to render and End Frame 
to the last frame you want to render.

• By Frame to the increment between frames you want to render.

• Frame Padding to the number of digits you want in frame 
number extensions.

To use a custom file format extension for rendered images

The file format extension is the standard file format extension for the 
current Image Format setting. To change that, in the Modify Extension 
section of the Render Global Settings window, turn on Use Custom 
Extension and type the extension you want to use.

Set rendered images output location

For information on image file location, see ”File output location” on 
page 79.

To set the location where rendered images are saved

1 From the main Maya window, select File > Project > Edit Current.

2 In the Project Data Locations section of the Edit Project window, 
change the directory for Images and click Accept.

Set the resolution and pixel aspect ratio

You can select from a list of preset render resolutions, or set the resolution 
options manually. 

For details on resolution, see ”Resolution” on page 80.

For details on pixel aspect ratio, see ”Pixel aspect ratio” on page 80.

Tip You can also set the location where rendered files are saved 
when you render from a shell or command line using Render and 
the -rd option. 

See ”Perform command line rendering” on page 117 for 
information about command line rendering. 
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How do I? > Enable color, depth, and mask channels for rendered images
To set the resolution and pixel aspect ratio of rendered 
images

• In the Resolution section of the Render Global Settings window, select 
a preset Render Resolution (for example, 640 x 480). 

If you do not see an appropriate preset Render Resolution, you must 
set the following attributes manually to output to an unlisted device.

• Width, Height

• Pixel Aspect Ratio

Enable color, depth, and mask channels for 
rendered images

Color channels, depth and mask channels are generated by default. Each 
pixel in an image may consist of channels representing the amount of red, 
green, and blue, mask, depth in the image. If channels have been turned 
off, you can turn them back on.

For more information about mask channels, see ”Mask and depth 
channels” on page 84.

To enable a channel to rendered images

1 In the Image File Output section of the Render Global Settings 
window, select the camera from which you want to render from the 
Camera drop-down list. 

2 Do any of the following

• Turn on RBG Channel (Color) 

• Turn on Alpha Channel (Mask) 

• Turn on Depth Channel (Z Depth) 

Create and view depth files

The depth channel represents the distance of objects from the camera. 

Note During bump or displacement mapping, if an image file contains 
a mask channel, the mask channel is used for displacement and 
bump mapping. If the mask channel is absent, the luminance of 
the RGB is used to displace and/or bump map.

If you prefer to use the luminance information as the alpha, turn 
on the Alpha Is Luminance attribute (in the Color Balance 
section of the file texture’s Attribute Editor). 
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How do I? > Modify a mask channel
To create a Depth file

1 Turn on Depth Channel (Z Depth) in the Render Global Settings 
window.

2 Open the renderable camera’s Attribute Editor in which you want to 
create a depth file. 

Select View > Camera Attribute Editor from the current view. See 
”View > Camera Attribute Editor” on page 269.

3 In the camera’s Attribute Editor, select a Depth Type from the Output 
Settings section (Closest or Furthest Visible Depth).

To view depth channels

1 View the animation file using FCheck. 

See the ”Overview of FCheck” on page 63 in the Rendering Utilities 
guide for information on FCheck. 

• IRIX, Linux and Windows

2 Press z to see the depth channel.

• Mac OS X

 FCheck does not let you view the z-depth data of an .IFF file. To view 
z-depth data, use a non .IFF file format and then view the z-depth 
data stored in the separate file.

3 If the output format is not IFF or RLA, Maya writes a separate depth 
file containing a black RGBA image with depth values.

Modify a mask channel

For Maya software and mental ray for Maya. 

To increase or decrease the mask value for an object

• In the Matte Opacity section of an object’s material Attribute Editor, 
set Matte Opacity Mode to Opacity Gain and adjust the Matte Opacity 
value.

During rendering, Maya first generates the mask channel, then 
multiplies the mask values for the object by the Matte Opacity value. 
For example, if Matte Opacity is 1, the mask values for the object 
remains unchanged; if Matte Opacity is 0.5, the mask values for the 
object are half their original values.

To set the mask value for an object to a constant value

• In the Matte Opacity section of an object’s material Attribute Editor, 
set Matte Opacity Mode to Solid Matte and adjust the Matte Opacity 
value. 
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If the object is transparent, any objects behind it appear in the mask 
channel.

During rendering, Maya first generates the mask channel, then sets 
the mask values for the object to the Matte Opacity value. For 
example, if Matte Opacity is 1, the mask values for the object are 1; if 
Matte Opacity is 0.5, the mask values for the object are 0.5.

To set the mask value for an object to zero

• In the Matte Opacity section of an object’s materials Attribute Editor, 
set Matte Opacity Mode to Black Hole.

During rendering, Maya first generates the mask channel, then sets 
the mask values for the object to 0. If the object is transparent, any 
objects behind it will not appear in the mask channel.

Specify frame or field rendering

Motion picture film and video simulate motion by displaying a 
continuous sequence of images or frames. 

When you render images as frames, Maya generates one image file for 
each time frame of an animation. By default, Maya renders images as 
frames.

When you render images as fields, Maya generates two image files for 
each time frame of an animation, one for each field. Maya renders a frame 
at time “x” by rendering one field at time “x” and one field at time 
“x+0.5”.

For information on the differences between film and video systems see, 
”Frames vs. Fields” on page 80.

To properly view a frame or an animation rendered as fields, you must 
interlace the two fields together.

To render images as fields for Maya software rendering 

• Choose the Field option from the Maya Render Global Settings 
window. Interlacing is automatic. 

Tip The settings you use for rendering images as fields may depend 
on the video standard you are using for the images, and how 
fields interlace together (for example, NTSC or PAL).

Before you render an animation as fields, perform a test render 
and use the test rendered images through your entire post-
production process. 
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To render images as fields for anything other Maya software 
rendering 

1 In the Render Global Settings window, set the By Frame value to 0.5. 
This results in twice as many frames being rendered. 

2 Turn on the Renumber Frames Using option and set Start Number 
and By Frame values to 1.

3 Interlace the resulting images using a third-party solution.

To interlace two fields together on IRIX and Linux

See ”interlace” on page 83 in the Rendering utilities guide. 

Run Pre Render MEL or Post Render MEL 
scripts

To run a MEL command or script before or after rendering

In the Render Options section of the Render Global Settings window:

• Enter a MEL command or execute a script to run before rendering 
each frame in the Pre Render MEL attribute box.

• Enter a MEL command or execute a script to run after rendering each 
frame in the Post Render MEL attribute box.

Set scene rendering quality

Adjust anti-aliasing

For more information on aliasing artifacts and strategies on how to fix 
them, see ”Improve rendered image quality” on page 134.

Important!

When you render a scene from within Maya, make sure you do 
not specify a MEL command or script that includes delete 
operations or you may accidently delete objects in your scene.

Note You may not need to adjust quality settings for an entire scene. 
Adjusting settings on a per-object basis is often more efficient 
and has less of an impact on rendering speed. 
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mental ray rendering specifics

• Manually adjust the following:

• Quality.

• Sampling Quality.

• for production quality: 

• Min samples = 0 

• Max samples = 2

• Filter = Triangle or Gauss

Maya software rendering specifics

The options in the Presets drop-down list and the Edge Anti-aliasing 
drop-down list drive each other; when you change one, the other changes, 
and values for the Anti-aliasing subsections are automatically filled in. 
You can fine tune any of these settings.

Do one of the following:

• In the Anti-Aliasing Quality section of the Render Global Settings 
window, select a preset.

• In the Anti-Aliasing Quality section of the Render Global Settings 
window, select Custom, then manually adjust the settings in Number 
of Samples, Multi-pixel Filtering, and Contrast Threshold. 

Maya Hardware rendering specifics

The options in the Presets drop-down list drive values for other settings in 
the Quality section of the Render Global Settings window. You can fine 
tune any of these settings.

Do one of the following:

• In the Quality section of the Render Global Settings window, select a 
preset.

• In the Quality section of the Render Global Settings window, select 
adjust any of the settings in the section. 
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Adjust output image filtering

To fix a noisy procedural texture that appears to shift and 
swim during an animation

• Increase the Filter and/or Filter Offset values to achieve a slightly 
blurred effect and reduce the sharpness that causes the swimming.

• Create a file texture (see ”Convert a texture or shading network to a File 
Texture” on page 83 in the Shading guide),  then increase the Filter 
and/or Filter Offset values to achieve a slightly blurred effect and 
reduce the sharpness that causes the swimming. 

• Increase the Shading Samples value.

Create and load a plug-in multi-pixel filter

Maya software only.

To create a plug-in multipixel filter

The Plug-in Filter Weight attribute is connected with the plug-in filter 
node and its value will be used as the filter weight. The filter does not 
have to be normalized.

You can define a plug-in DG node with at least two input attributes and 
one output attribute with a float type. The input attributes require the 
short name X and Y. The output attribute has to be connected to the Plug 
In Filter Weight attribute in the renderQuality node.

When the plug in filter type is selected, the plug-in node is evaluated 
multiple times with different x and y weights, ranging in [-1..1]. The plug-
in filter should be defined in the normalized domain [-1..1,-1..1]. The filter 
width change only affects the mapping of the normalized filter to the pixel 
coverage.

Tips In most cases, you should test render a file texture in Render 
View when filtering because you may not be able to see the 
results in the views or in Attribute Editor swatches.

When bump mapping, set Filter to a low value (under 0.1). Filter 
is primarily used for anti-aliasing textures—distant surfaces are 
blurrier. This may cause a bump map to become smoother when 
further away. If you want the bumps to be smooth, use a small 
Filter Offset value for a constant blur. 
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To load a plug-in multipixel filter

The following assumes you have already created a multipixel filter plug-
in. 

1 Copy the filter plug-in .so (IRIX and Linux), or .mll (Windows), or .lib 
(Mac OS X) file to:

• IRIX and Linux: /maya/bin/plug-ins

• Windows: drive:\Program Files\Alias\Maya6.0\bin\plug-
ins

• Mac OS X: /Applications/Maya 6.0/Application Support/
plug-ins or to a directory where the Plug-in Manager 

can read them

2 In Maya, click Window > Settings/Preferences > Plug-in Manager.

3 Load the plug-in you created.

Connect a plug in multipixel filter

To connect a plug-in multipixel filter to the Plug In Filter 
Weight

1 In the Script Editor, create a plug-in node by typing:

createNode <yourPluginNodeType> 

A node will be created for the plug-in.

2 Select the plug-in node by typing in the script editor:

select <yourPluginNodeType>

3 With the plug-in node selected, open the Connection Editor 
(Windows > General Editors > Connection Editor). 

4 Load the plug-in node to the left side of the Connection Editor.

5 Repeat steps 1 and 2 to load the defaultRenderQuality or user-created 
renderQuality node to the right side of the Connection Editor.

6 Connect the plug-in node’s weight to the defaultRenderQuality Plug 
In Filter Weight attribute. You can now use the multipixel filter plug-
in.

Set raytracing quality

Set raytracing quality

Raytracing is a type of rendering where the path of individual light rays 
are calculated between the camera and the light source. To find out more 
about how to raytrace to produce shadows, see ”Raytraced shadows” on 
page 34 in the Lighting guide. 
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To find out more about how to raytrace to produce reflections, see ”True 
reflections” on page 283 in the Shading guide. 

To set raytracing quality, adjust the settings in the Raytracing Quality 
section of the Render Global Settings window.

Set motion blur

Set motion blur

When you render an animation, motion blur gives the effect of movement 
by blurring objects in the scene. For more information on motion blur, see 
”Focus and blur” on page 28.

Maya software rendering specifics

Only Maya software supports both 2D and 3D motion blur.

To set motion blur, work with the settings Motion Blur section of the 
Render Global Settings window. 

Maya hardware rendering specifics

Supports only 3D motion blur. 

To set motion blur, work with the settings Motion Blur section of the 
Render Global Settings window. 

mental ray rendering specifics

Supports only 3D motion blur. 

To set motion blur, in the Quality section of the Render Global Settings 
window set Quality to an option that includes Motion Blur, then work 
with the settings in the Motion Blur section of the Render Global Settings 
window.

Note You may not need to adjust quality settings for an entire scene. 
Adjusting settings on a per-object basis is often faster and has 
less of an impact on rendering speed. 

Note You may not need to adjust quality settings for an entire scene. 
Adjusting settings on a per-object basis is often faster and has 
less of an impact on rendering speed. 
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Set memory and performance options

Maya software

Set tessellation options 

Though tessellation is determined on a per-object basis, you can manage 
how Maya handles the tessellation settings for the scene. 

By default, Maya optimizes the tessellation settings for surfaces by storing 
(caching) geometry information to reduce the amount of memory used; 
tessellating identical surfaces only once to save time and disk space; 
reusing tessellation for the generation of depth maps; and calculating the 
bounding box scale that you define for all displacement-mapped surfaces 
to make rendering faster.

For more information on tessellation, see ”Tessellation and 
approximation” on page 43.

You can turn these optimization settings on or off in the Memory and 
Performance section of the Render Global Settings window. 

For tesselation settings for mental ray for Maya, see ”Approximation in 
mental ray for Maya” on page 45.

Example of motion blur
Image by Tim Rowlandson
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Set raytracing 

Though raytracing quality is set by the options in the Raytracing Quality 
section of the Render Global Settings window (see ”Set raytracing quality” 
on page 102), you can set scene optimization options in the Memory and 
Performance section of the Render Global Settings window. 

For more information on raytracing, see ”Raytraced shadows” on page 34 in 
the Lighting guide. 

Set multiple processors

You can control the number of processors for interactive rendering. To 
render with multiple processors, see ”Network render with Maya 
software” on page 148. 

Set IPR options (Maya software)

Set IPR options

You can control which elements are included in IPR renders in the IPR 
section of the Render Global Settings window. 

For more information IPR renders, see ”Interactive Photorealistic 
Rendering (IPR)” on page 67.

Set paint effects rendering options

Set paint effects rendering options

See ”Paint Effects Rendering Options” on page 234 in the Paint Effects, 
Artisan, and 3D Paint guide. 

Set up layers and passes

Create render layers 

To render objects separately in layers, you must first create render layers, 
then set them as renderable. You can render attributes of your entire scene 
or layers of your scene in separate passes too. 

For more information about layers and passes, see ”Layers and passes” on 
page 83. 
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To create a render layer in the Layer Editor

The Layer Editor is located under the Channel Box.

1 Select Render from the drop-down menu.

2 Select Layers > Create Layer.

To set whether a render layer is Renderable

1 Select a render layer from the Layer Editor, then choose Layers > Edit 
Selected Layer(s). 

The Edit Layer window appears for the selected render layer. 

2 In this window, you can rename the layer (in the Name box), click the 
check box to determine if it is Renderable (on by default), then save 
the setting. A check mark indicates what is rendered in Render View.

If Renderable is on:

• Objects that are not included in a renderable render layer are not 
rendered; each layer is treated as if it came from a separate scene. 
Use the Relationship Editor (Window > Relationship Editors > 
Render Layers) to see which objects are included in which render 
layer. 

• When you perform an IPR test render, all layers with renderable 
attributes turned on are rendered into Render View. 

• In batch mode, you can enable attributes so that each layer is 
rendered to a separate file for off-line compositing.

Create renderable passes

To determine which passes are renderable in a render layer

Note For Maya software rendering, you can also render an individual 
layer when you render from a shell or command line, using 
Render and the -l option. 

See ”Perform command line rendering” on page 117 for 
information about command line rendering. 
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1 Select a layer in the Layer Editor, then choose Layers > Layer 
Attributes. The Attribute Editor for the selected render layer appears.

2 Choose the Render Pass Options you want to render. 

3 Select Focus to switch the selection of the layers you created and 
change their render pass settings if necessary.

Visualize a scene

Visualize interactively with IPR

Maya software only.

When you drag a marquee (render region) around the entire scene or part 
of the scene, the IPR image begins to update. If you change lights, 
shadows, materials, textures, and post processes (special effects) such as 
glow and fog, you can see the results of your changes interactively. 

For detailed information on IPR rendering, see ”Interactive Photorealistic 
Rendering (IPR)” on page 67.

To visualize scene adjustments interactively

1 Do one of the following:

• Click the scene view you want to render, then click the IPR 
Render button (from the Status Line or from within Render View 
if it is open). The scene appears in Render View, and an IPR image 
is created.

• To load an existing IPR file, select File > Open IPR File, then select 
the file. 

2 Marquee select a region within the IPR rendered image in Render 
View. 

Note The amount of memory used during an IPR session may be 
considerable. The upper-right corner of Render View displays 
how much memory is being used for the current IPR tuning 
region. 

Note You must select a region to adjust before you start to modify 
rendering attributes. The region you select determines the 
amount of memory required by IPR to re-render the adjusted 
region.
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3 Adjust the scene, for example, add lights or modify materials and 
texture attributes. 

The selected region of the IPR image updates as you adjust the scene.

• To render another view instead, select IPR > IPR Render in 
Render View and select a view from the drop-down menu.

• If you change the view (such as tumble or zoom, or add new 
elements to the scene) and want to update the result, click the 
Redo Previous IPR Render icon in Render View or from the 
Render menu in Maya’s main menu bar.

• If you only want to change certain elements such as lighting or 
textures and do not change the view, simply drag a marquee 
around the object or part of the object you want to update. The 
results in Render View are immediate.

Pause, cancel or save an IPR render

To pause an IPR render

• Press the pause button.

To cancel an IPR render

• Press Esc. 

The IPR render stops. You cannot adjust a cancelled IPR Render; you 
must perform a complete IPR Render to adjust a region.

Tips After you marquee select a region, you can drag materials and 
textures onto objects within the region, just as you can make 
connections by dragging swatches from Hypershade onto 
surfaces in the views.

Drag a marquee around the area
you want to change.

Changes you make are shown
immediately.
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To save an IPR file

• Select File > Save IPR File. The Save IPR File window displays. Type 
the name of the file and click Save IPR File.

Batch render IPR files

You can batch render IPR files from the command line. 

For more information about batch rendering or command line rendering, 
see ”Batch renders from within Maya (UI)” on page 72 and ”Command 
line renders” on page 72.

To batch render IPR files

• In a shell or command line, type:

Render -r sw -ipr true <scene>

See ”Batch rendering from the command line” on page 93 in the Rendering 
Utilities guide for details about batch rendering.

Note Because an IPR file saves the deep raster information in addition 
to the visible color information, an IPR file can be very large. 
Ensure you have sufficient disk space. 

Notes • You cannot batch render IPR files from within Maya.

• Batch rendering to produce IPR files is not multi-threaded.
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See shading and lights in a scene view 

Hardware texturing, a Maya feature that you can easily turn on or off, lets 
you to see approximations textures, lights and objects in your scene in a 
scene view. 

What you see depends directly on the settings you make in the Render 
Global Settings window and per-object settings you change. What you see 
is not necessarily what appears in the final render, but it gives you a good 
idea. 

To see textures, lights, and objects in a view port

1 In the scene view, select Shading > Smooth Shade All.

2 Select Shading > Hardware Texturing (or press the hotkey 6).

• To use all lights in the scene, select Lighting > Use All Lights (or 
press the hotkey 7). 

Note If you are using a File texture that uses MirrorUV and the 
resolution of the hardware rendered texture in the viewport 
appears degraded, use the following environment variable:

MAYA_HW_FILE_TEXTURE_RESOLUTION_OVERRIDE

Tip To see the resolution boundaries in the scene view, turn on the 
Resolution Gate. For more information, see ”Turn scene view 
guidelines on or off” on page 36.

Hardware texturing off Hardware texturing on

Maya’s scene view
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• To see a more accurate preview result (which may take a little 
longer), adjust the Hardware Texturing attributes in the object’s 
material’s Attribute Editor. 

Test render a low-res still or frame

The time Maya takes to software render a scene is directly proportional to 
the resolution: the larger the resolution, the more time it takes. 

If you want to get a feel for the final rendered look quickly, you can 
render of a still image or single frame of an animation. Typically, a 
resolution half to a quarter of the size lets you get a good feel for the 
software rendered look.

To test render a still image 

1 From Render View (Window > Rendering Editors > Render View), 
click Options > Test Resolution, then select a resolution. 

2 Select the camera view you want to render from the Render > Render 
submenu.

Maya renders the scene and displays the image as it renders in Render 
View.

• To cancel the render, press Esc.

• To re-render the frame, select Render > Redo Previous Render.

Test render a low-res animation

If you want to get a feel for the final rendered look quickly, you can 
render of an entire animation (or a few selected frames) at a lower 
resolution. 

Note When you play an animation with just Hardware Texturing 
turned on, each of the necessary file textures are read in one at a 
time and the animation speed is choppy. 

Use Hardware Texture Cycling to load file textures into memory 
only once for faster interactive animation (but this uses a lot of 
memory).  

Note To ensure the best quality display of your rendered image, select 
the 1:1 (the real size) option in Render View before you render. 
Rendering

111



4 | Visualize and render images 
How do I? > Render selected objects
Typically, a resolution half to a quarter of the size lets you get a good feel 
for the software rendered look. (As you get closer to achieving the final 
look during an animation, test render a few specific frames at the final 
resolution too.)

To test render an animation with Maya software rendering

• From a shell or command line, type:

Render -r <renderer> <options> <scene>

using the following options:

For example, if an animation begins at frame 1 and ends at frame 100, and 
the final image resolution is 640 x 480, and you want to test render with 
Maya software the animation by rendering every ten frames, type:

Render -r sw -s 1 -e 100 -b 10

If you want to test render the animation by rendering with mental ray for 
Maya every frame at half the final resolution, type:

Render -r mr -s 1 -e 100 -b 1 -x 320 -y 240

For a complete list of Render options, in a shell or command line, type:

Render -r <renderer> -help

Render selected objects

-s <start_frame> The first frame of the animation to render.

-e <end_frame> The last frame of the animation to render.

-b <by_frame> The increment between frames to render.

-x <image_x_resolution> The horizontal resolution of the rendered 
images.

-y <image_y_resolution> The vertical resolution of the rendered 
images.

Tip Render at 1:1 resolution for fastest feedback.
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You can isolate specific objects to render. You cannot use this method when 
IPR rendering.

To render selected surfaces

1 Select the objects you want to render.

2 In the Image File Output section of the Render Global Settings 
window, set Renderable Objects to Render Active. 

3 Render the scene. 

Render a region of your scene

Tip You can display a wireframe snapshot of your scene to use as a 
guide to select a region of your scene to render.

In Render View, select Render > Snapshot > and select the 
camera (view) you want to capture. 

In the scene view, 
only the table cloth 
is selected.

In Render View, 
only the selected 
surface is 
rendered
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Render View lets you render a specific portion of your scene at any 
resolution so that you can get a feel for the changes you make as you 
shade, light, and texture objects.

Unlike rendering at a lower resolution, a process which reduces the size of 
the entire image, rendering a region can help you make changes more 
efficiently and quickly to the specific regions of interest at full resolution. 

To render a region of your scene

1 Marquee select the area that you want to render in Render View. 

2 If there is no representation of your scene in Render View for you to 
marquee select Render > Snapshot > and select the camera (view) you 
want to capture.

3 Click the Render region button or select Render > Render Region.

Perform final renders from within Maya

Render a single frame

When you render or re-render a single frame from Maya’s main window, 
the render appears in Render View. For more information about using 
Render View, see ”Render View rendering” on page 71.

The image is automatically saved to the images directory of the current 
project.

Tip If you turn on Auto Render Region (Options > Auto Render 
Region), the changes you make appear as you draw the marquee 
anywhere in Render View. Only the marqueed area of the 
surface re-renders showing the results of the adjustment.

Marquee select a region, 
make changes to the 
scene, then click the 
Render region button.

(Alternatively, set Auto Render Region to 
see the changes as you make them.)
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To render a frame from within Maya

• From the main Maya window, click the Render Current Frame button, 
or select Render > Render Current Frame.

Maya renders the scene from the current scene and displays the image 
as it renders in Render View. 

To cancel an in-progress render, press Esc.

To re-render a frame from within Maya

• From the main Maya window, select Render > Redo Previous Render.

Maya renders the scene from the previous camera and displays the image 
as it renders in the Render View window. 

To cancel the render

• Press Esc.

Batch render a still or animation

On IRIX and Linux you can select a remote host on which to render the 
current scene.

To batch render from within Maya

• Click Render > Batch Render to batch render.

• To cancel the render, click Render > Cancel Batch Render

• To show the image being rendered, click Render > Show Render.

Note Navigation in the Render View panel is like most other Maya 
view panels. You can zoom and track the view using the same 
keyboard shortcuts. 

Note By default, Maya renders the current frame of your scene. To 
render an animation, you must specify the start and end frames 
of the animation you want to render in the Render Global 
Settings window.

Note To set batch render options, select Render > Batch Render >  to 
open the Batch Render window. For a description of the batch 
render options, see ”Render > Batch Render > ” on page 255.
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Render with several processors

You can render a scene on a computer that has more than one processor 
and make use of some or all of its available processors.

To render on a computer with several processors from within 
Maya

1 From the Maya window, select Render > Batch Render > . 

The Batch Render window displays.

2 To use all available processors on your computer for rendering, turn 
on Use all available processors. 

3 To use only some of the available processors on your computer for 
rendering, turn off Use all available processors and set Number of 
Processors to Use to the number of processors you want to use.

4 Click Batch Render. 

Maya renders the animation.

To render on a computer with several processors from a shell 
or command line (Maya software rendering only)

• Type:

Render -r sw -n <# of processors to render on> 
<scene>

(If you do not use the -n option, only one processor is used for 
rendering.) 

Examples (for Maya software rendering only):

To use one processor for rendering, type:

Render <scene>

To use two processors for rendering, type:

Render -n 2 <scene>

To use all processors on your computer for rendering, type:

Render -n 0 <scene>

Note We recommend that you use a single processor when batch 
rendering a scene that contains a spotlight, material 
transparency, and raytrace shadows. 
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Perform command line rendering

Command line render

Your scene file determines whether you render a single frame or an 
animation. You can render from a shell or a command line. Before 
rendering, you may want to close all applications, including Maya, to 
maximize the amount of memory available for rendering. 

When you render from a command line, you can set flags that override 
some of the Render Global settings, saving time during test renders.

To get quick renderer-specific information, type

Render -r rendername -help

where rendername is the name of the renderer:

• mr = mental ray

• sw = software renderer

• hw = hardware renderer

• vr = vector renderer

• file = the file within which the renderer is specified

 

All flags are described with a short description. Each flag corresponds to 
the appropriate section of the Render Globals Settings Window. See the 
Render Globals Settings documentation for more detailed information on 
each option.

To obtain a complete list of command line Render options, 
from a shell or command line type:

Render -help

To render a scene with a specific renderer from a shell or 
command line

• Type:

Render -r <rendername> <options> scene

Note If you get help on a file (-r file -help), only the flags common to 
all renderers, not a specific renderer, are shown. If you want 
renderer-specific information, you must specify the renderer.
Rendering

117



4 | Visualize and render images 
How do I? > To export a .mi file and render with mental ray
To render a scene with the renderer specified in the file from 
a shell or command line

Whichever renderer is specified in the file is used to render the scene. 

• Type:

Render -r file

Export .mi files 

To export a .mi file and render with mental 
ray

To export a .mi file and render with mental ray

1 Select File > Export All.

2 Choose a file name and path and click Options. 

The Export All Options window appears.

3 Select mentalRay as the file type. 

There are File Type Specific Options in the Export All Options 
window you can use to control file naming schemes and other details. 

4 Click Export All.

5 From a IRIX or Linux shell, DOS window, or Terminal, type:

mentalrayrender mi file

Tip You may need to provide the -proj flag when issuing the render 
command to specify where the scene file is located. For example, 
type: 

Render <options> <projName> scene -proj 

Note Only the flags common to 

Note The command mayaexport_with_mr which is available on all 
platforms via a shell, command line, or terminal, allows you to 
perform an export from a Maya scene to an .mi file for rendering 
with mental ray standalone. For information on how to use the 
mayaexport_with_mr, type mayaexport_with_mr -h in a shell.
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where mi file the name of the file that was exported.

For information export options, see ”File > Export All, Export 
Selection (mental ray)” on page 245.

Render multiple scenes

Render multiple scenes

You can either write a batch script that starts renders in succession or use 
a third-party management solution. 

What 
went 
wrong?

Troubleshoot:Image plane displays black 
swatch

An Image plane not connected to a camera displays black swatch. Once 
connected to a camera, the swatch will function properly. 

Troubleshoot:Displacement is not displayed 

The Display render tessellation option does not display displacement 
mapping. 

In the main Maya window, select Shading > Displacement to Polygon to 
preview the effect of your tessellation and displacement together, then 
discard the generated polygon object when you are finished previewing.

Troubleshoot:Software-rendered is too bright

By default, Point and Spot lights have no decay. Open the light’s Attribute 
Editor and change the Decay Rate, or use Maya’s Decay Regions (for spot 
lights only) to control the decay.

Troubleshoot: Multi-UVs for NURBS don’t 
software render

Multi-UVs defined for NURBS are currently not respected when 
software rendering. 

Note The script prompts you to set your SPM_HOST, MAYATOMR, 
and RAY environment variables if they are not set already.
Rendering

119
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What went wrong? > Troubleshoot:Rendered image doesn’t match may not match 

interactive window display
Troubleshoot:Rendered image doesn’t match  
may not match interactive window display

In rare cases, a rendered image may not match what is displayed in the 
interactive window. This may be caused by different Dependency Graph 
solutions if nodes are evaluated in a different order. 

The most common occurrences are: renders that are divided among 
multiple machines produce inconsistent results; an arbitrary frame within 
an animation range is rendered alone; or rendering with motion blur 
produces different results than rendering without motion blur. 

Scene elements which may produce undesirable render matching include: 

• Any dependency graph cycle

• Animated nodeState on any node

• Animated transform limits

• The multi-chain IK solver

• Expressions that modify values based on a previous value. For 
example: tx = tx + 1

• Expressions that conditionally set values. For example: if (ty > 5) tx = 
ty

• Expressions that execute commands (or create or delete Maya nodes). 
For example: sphere

• Particle/softbody solutions (because of timestep changes)

• Geometry Constraint nodes (because they go to the point on the target 
geometry that is closest to the current point)

• Any constraint where the sum of the target weights is zero

• Aim, tangent, or normal constraint or lookAt nodes with the 
worldUpType attribute set to None

• Aim, tangent, or normal constraint or lookAt nodes with the upVector 
co-linear with the aimVector

• IK with an animated solverEnable value. 

Workaround

The renderer can invoke a MEL procedure just before you render a frame. 
(You specify this script in the Render Globals > Render Options > 
PreRender Mel text field.) You can use this procedure to force evaluation 
at the intervening skipped frames. 

To use a MEL script: 

1 Put the MEL script (named preFrameProc.mel) in your Maya scripts 
directory. 
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4 | Visualize and render images

What went wrong? > Troubleshoot: Projection texture swims over an animation
2 Under Render Globals > Render Options, type preFrameProc in the 
PreRender Mel field.

If motion blur is on, you may need to bake the animation.

Troubleshoot: Projection texture swims over 
an animation

Projection texture with useLocal, can swim over an animation. 

Turn on Use Local on all upstream textures to work around this.

Troubleshoot:Transparent blobby surface 
rendering anti-aliasing problem

With transparent blobby surface rendering, anti-aliasing may be poor, 
even at the highest-quality settings. Such cases include intersecting 
transparent blobby surfaces and transparent blobby surfaces behind 
transparent geometry. To fix this, increase the particle samples in Render 
Globals. 

Troubleshoot:memory exceptions

On some 32-bit machines (including Irix, Windows, and Linux) virtual 
memory is restricted to 1.6 Gbs (or thereabouts). It doesn't matter if you 
have hundreds of giga-bytes of physical memory or swap, no process can 
grow larger than this size. Maya may encounter a memory exception and 
report that there is still lots of memory available. 

Troubleshoot:mental ray for Maya renders 
look different than they did before

Some older derive from Maya settings no longer 
apply

Because of the (as of Maya 5.0) unified render global settings (see ”Open 
the Render Global Settings window” on page 92), some of the mental ray 
for Maya derive from Maya settings no longer exist. You may need to 
modify some older files for which derive from Maya was set by setting the 
mental ray for Maya render global settings. 

For known differences between mental ray for Maya and Maya, see 
”Troubleshoot:mental ray for Maya renders look different than Maya 
renders” on page 122.
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What went wrong? > Troubleshoot:mental ray for Maya renders look different than Maya 

renders
Troubleshoot:mental ray for Maya renders 
look different than Maya renders 

The following sections describe known differences between Maya and 
mental ray for Maya and provide hints on how to handle those cases: 

Scanline Only Rendering

Scanline only rendering is the default render mode in Maya. Since 
scanline rendering is limited in various aspects, it may show artifacts 
when used together with the following: motion blur, volume rendering, 
shadow tracing, and others. Raytracing should be turned on if render 
problems appear. 

Displacement

mental ray uses an adaptive tesselation approach to better fit the details of 
the displacement map. The initial tesselation (for NURBS: after surface 
approximation) is further subdivided to fit secondary criteria, controlled 
by the displace approximation settings. By default, mental ray for Maya 
creates appropriate settings that lead to curvature dependent subdivision 
of the triangles, one form of feature-based displacement mapping. You 
can change these settings by creating or selecting a custom displace 
approximation node in the Approximation Editor. For more information 
on Approximation Nodes, see ”Approximation nodes” on page 45). 

Shadow Mapping

If the mental ray shadow map attributes on Maya lights are disabled, 
mental ray for Maya derives most parameters for shadow maps from 
Maya's depthmap settings, although most control values are not 
comparable. This causes different results, especially when modifying the 
filter values to achieve soft shadows. For sharp shadows the Dmap Filter 
Size should be set to 0. Other controls, like Use Mid Dist Dmap and Use 
Dmap Auto Focus are not used to derive mental ray shadowmap values. 

For information about the way mental ray for Maya handles shadow 
mapping, see ”Shadow in Maya” on page 31 in the Lighting guide. 

Bump mapping

The bump mapping implementation in the mental ray shaders may 
handle the Filter settings in the bump nodes slightly differently compared 
to Maya. This filter usually produces view-dependent bump mapping 
details, but might not be appropriate in animations. As soon as the filter 
has been disabled by setting the Filter value to zero, the Filter Offset 
determines the bump map lookup, both in Maya and mental ray. This 
leads to comparable bump mapping render results that are not view-
dependent. 
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What went wrong? > Troubleshoot:mental ray for Maya renders look different than Maya

renders
Matte Opacity

Transparent objects produce an appropriate alpha channel in the final 
image according to Maya’s Matte Opacity settings. However, some 
restrictions apply: 

• The mental ray colorclip modes and the premultiply setting affect the 
matte result. The default colorclip mode Raw ensures best 
compatibility with Maya, especially when using the BlackHole opacity 
mode, or when sliding the Matte Opacity value towards zero in 
OpacityGain and SolidMatte modes. 

• The mental ray colorclip modes other than Raw may change the color 
or alpha value before storing it in the framebuffer, which can be used 
to produce nice effects. 

• The BlackHole opacity mode may cause different results in the color 
channel when rendered with mental ray; reflections may still show 
up. 

For more information on transparency, see ”Surface texture” on page 15 in 
the Shading guide. 

Depth-of-Field

This effect is supported with a mental ray lens shader, not as an output 
filter as in Maya. Therefore, it is dependent on the global sampling 
settings in mental ray. Raising the minimum or maximum sampling level 
improves quality and but slows down the rendering accordingly. On the 
other hand, as a true 3D effect, it won't show any artifacts with 
problematic scenes, where output filters are not able to produce correct 
depth-of-field blurring. 

Render Layers

When assigning a group to a render layer, mental ray for Maya assumes 
all the members of the group also belong to that layer and inherit its 
attributes. However, Maya allows members of the group to be assigned to 
different layers than the group parent.

Particle system translation and rendering

Particle types for software rendering are supported on all platforms for 
rendering with mental ray. To render particles, a new mayabase shader 
library is required, which is also provided for all platforms. Particle data 
are also exported to .mi files. These files cannot be rendered on machines 
with different byte ordering (big end or little end) than the machine where 
Maya has been used (for example, mixing IRIX and Windows). Particle 
translation and rendering is limited and may not be able to handle large 
particle counts. Light linking is not supported with particles. However, 
software particles and particle instancing should work together 
seamlessly. 
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What went wrong? > Troubleshoot:Highlight artifacts close to object edge
Troubleshoot:Highlight artifacts close to 
object edge

If you have tessellated an object with the Use Smooth Edge attribute and 
you get artifacts in highlights along curved parts of the surface close to an 
edge, don’t use this attribute. This caused the curvature in the surface to 
be slightly different closer to the edge, which doesn’t work for strong 
highlights.

Troubleshoot:Background surfaces show 
through

Especially in large scenes that have objects close together, background 
surfaces may appear to show through nearby surfaces. This is a result of 
how the camera’s clipping planes determine depth position of geometry. 
To fix this problem, see ”Clipping planes” on page 34.

Troubleshoot:Objects vibrate when an 
animation is rendered as fields

For Maya software rendering only.

The settings you use for rendering images as fields may depend on the 
hardware or software settings you are using with the images, and how 
they interlace fields together (for example, the interlace utility, 
compositing software, or frame buffer device). Before you render an 
animation as fields, perform a test render and use the test rendered 
images through your entire post-production process (see ”Batch render a 
still or animation” on page 115 and ”Test render a low-res animation” on 
page 111).

Even though Maya automatically sets these options depending on 
whether the Resolution is NTSC or PAL, if you encounter problems in the 
animation where objects vibrate up and down, change the Zeroth Scanline 
setting and test render the animation again. If this does not solve the 
problem, or if objects in the animation vibrate left to right, try different 
combinations of Field Dominance and Zeroth Scanline, and test render the 
animation until the problem is solved.

Troubleshoot:2D Motion Blur problems

For Maya software rendering only.
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4 | Visualize and render images

What went wrong? > If dark halos display around the objects
If dark halos display around the objects

Try the following:

• Make sure the background color is black

• Make sure Smooth Color is turned on if there is fog in the scene.

Moving transparent objects with a background

The background is also blurred in this case even though it should not be. 
The solution is to blur the transparent object separately and composite 
with the rest of the scene. This workaround can be difficult for complex 
scenes with lots of transparency, or for transparent particles. 

Detailed background behind moving objects

Some details may be lost because assumptions must be made about the 
background area occluded by the moving objects. The solution is to blur 
the moving objects without the background and then composite the 
results.

Rotating objects

May not look exactly right, because assumptions about what the back 
sides of these objects should look like must be made. Try using 3D motion 
blur. 

Objects entering from outside the image or leaving 
the image

The edges of frames may not get the correct detail, because assumptions 
must be made about the object color that is just outside a frame. The 
solution is to render a slightly larger image which covers the original 
image and then crop it to the desired size. 

Rendered results from 3D and 2D are quite different

Try not to mix the rendered images from two different kinds of blurring 
operations. 

Tuning 2D motion blur with IPR

When tuning 2D motion blur with IPR, automatic updates are not alway 
done correctly. Tune an attribute of a material or light to force a correct 
update, or marquee the tuning region to force an update.
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2D motion blur artifacts 

2D motion blur can cause artifacts when rendering in scenes with fog, or 
solid objects in front of transparent ones, or if the background color is not 
black.

There are three possible workarounds:

• Take out transparent objects, fog, glow, and background color from 
the scene. Render the 2D blur and composite those elements back into 
the scene.

• Set the Smooth Value to 0. In the command line, this is -m 0. This 
solution is to skip the smooth-mask operation. The image may look 
more aliased as a result.

• Turn on Smooth Color. In the command line, this is -r 1. This solution 
uses a different smoothing algorithm. The image may look more 
blurry as a result. 

Troubleshoot:Troubleshooting Surfaces 
(Maya software)

To fix faceted surface edges or profile

Do any of the following:

• Run Set NURBS Tesselation.

• Make sure Automatic is set in the Render > Set NURBS 
Tessellation window.

• Turn on Smooth Edge for the surface (or turn on Smooth Edge 
and increase Smooth Edge Ratio).

• Increase Curvature Tolerance for the surface and U Division 
Factor/ V Division Factor for the surface (to the lowest values that 
produce acceptable results).

To fix aliased surface edges or profile

For Maya software and mental ray for Maya. 
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What went wrong? > Troubleshoot:Troubleshooting Surfaces (Maya software)
If you do not plan to composite the rendered image, turn on 
Premultiply in the Render options section of the Render Global 
Settings window.

To fix flickering thin surfaces

For Maya software only. 

• Do the following: 

• In the Render Global Settings window, turn on Use Multi Pixel 
Filter.

• Turn on Geometry Antialiasing Override for the surface, and 
increase the Antialiasing Level (try 3, 4, or 5).

To fix flickering textures or popping displacements

For solid textures, make sure Use Min Screen is off for the surface and 
Mode U and Mode V are not set to Best Guess Based on Screen Size.

For image file textures or textures with noise, Increase Filter Offset (to the 
lowest value that produces acceptable results).

For image file textures, set Filter Type to Quadratic for the texture.

To fix outlines around 2D motion blurred surfaces

For Maya software only. 

• Do either of the following:

• Remove transparent objects, fog, and/or glow, and set the 
background color to black. Render the scene, then composite the 
elements you removed with the rendered image.

• In the Render Global Settings window, set Smooth Value to 0 and 
turn on Alpha/Color.
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What went wrong? > Troubleshoot:Edits in the Texture Editor don’t update in IPR
To fix grainy or flickering highlights

For Maya software only. 

• Do either of the following:

• Make sure “Use Min Screen” is off for the surface and Mode U 
and Mode V are not set to “Best Guess Based on Screen Size”.

• Use a Blinn material instead of a Phong or PhongE material.

To fix jagged edges or jagged or sharp textures on motion 
blurred surfaces

For Maya software only. 

• In the Anti-aliasing Quality section of the Render Global Settings 
window, set Presets to 3D Motion Blur Production.

To fix jagged surface edges, textures, or shadows in 
raytraced reflections or refractions

For Maya software only. 

• In Render Global Settings window, set the Anti-aliasing Quality to 
Contrast Sensitive Production (Highest) quality, then turn on Shading 
Samples Override for the reflecting/refracting surface, and increase 
Shading Samples (to the lowest value that produces acceptable results).

Troubleshoot:Edits in the Texture Editor don’t 
update in IPR

Edits you make in the texture editor don’t update in IPR. You must re-
render the scene. 
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4 | Visualize and render images

What went wrong? > Troubleshoot: Looping renders
Troubleshoot: Looping renders 

Cycles in a render node network cause the renderer to loop forever. A 
cycle is when two or more nodes mutually depend on each other for 
their information. 

Do not construct a render node network with cycles. If you create a 
cycling render node network accidentally, break one or more of the 
cycles using the Connection Editor before you render.
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5 Quality, render 
speed, diagnostics
About Image quality and render speed

The speed/quality tradeoff

Producing rendered images always involves making choices that affect the 
quality (anti-aliasing and sampling) of the images, the speed with which 
they are rendered, or both. 

Related topics

”Anti-aliasing and flicker” on page 131

”Artifacts” on page 132

”Render speed” on page 132

Anti-aliasing and flicker

Jagged or stair-cased edges in pixel-based images or flickering surfaces in 
an animation are aliasing artifacts. 

Aliasing artifacts result from point sampling, a process used in all computer 
graphics applications that determines the information about each pixel. 
Aliasing artifacts can result at various stages during any rendering 
process. 

Anti-aliasing is the process of removing or reducing these artifacts. 
Because there are many kinds of aliasing, such as grainy surfaces, 
flickering, and jagged edges, there are as many approaches to controlling 
or fixing these problems. You can make adjustments to a number of 
settings to decrease or eliminate aliasing artifacts and flicker. See ”Reduce 
artifacts and flicker” on page 134.

Most solutions to control aliasing are time-consuming and increase render 
times. Try to find the solution that gives you the best balance between 
image quality and performance.

Image courtesy of 
the Art of Maya
Rendering

131



5 | Quality, render speed, diagnostics 
About > Artifacts
Artifacts

Artifacts can show up as unintentional blotches, bands or cross-hatches on 
surfaces. Textures can flicker or crawl on surfaces from frame to frame 
during animations.

Clipping plane artifacts

Especially in large scenes that have objects close together, background 
surfaces may appear to show through nearby surfaces. This is a result of 
how the camera’s clipping planes determine the depth position of 
geometry; the problem results from the limited precision used to store 
depth information. it is mainly influenced by the following camera 
parameters: near clip distance, far clip distance, and camera angle.

Render speed

You can make adjustments to a number of settings to increase the speed 
with which the scene, surfaces, and/or shadows render, and the speed 
with which camera render the scene. To find out about strategies to 
increase rendering speed, see ”Increase render speed” on page 135.

Reduce memory

In some cases, you can also reduce the memory used by the render to 
decrease rendering times. See ”Reduce render memory usage” on 
page 139.

Images courtesy of The Art of Maya

Clipping plane artifacts Depth map shadow artifacts
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About > Reduce file size (Maya Vector renderer)
Reduce file size (Maya Vector renderer)

Complex scenes and certain Maya Vector Render Global Settings can 
produce very large SWF or SVG files that are unsuitable for online 
delivery. 

If you are using the Maya Vector renderer to create SWF or SVG files for 
online delivery, you can modify your scene and adjust the Maya Vector 
Render Global Settings to produce the best compromise between image 
quality and file size. See ”Decrease file size (Maya Vector renderer)” on 
page 140.

Maya render diagnostics

The Render Diagnostics tool lets you monitor how well you optimize the 
scene for rendering and watch for limitations and potential problems that 
may occur. For example, surfaces that are far away or blurred may not 
require the same level of visual accuracy or photo realism as surfaces close 
to the camera. You can speed render times and reduce memory usage if 
you know what the renderer is doing.

Run Render Diagnostics after you adjust objects and before you render to 
obtain valuable information about how you can improve performance and 
avoid limitations. You can run the diagnostics while experimenting with 
rendering settings, or before you start the final rendering.

Hardware render diagnostics

Hardware render diagnostics traverse the shading network and geometry 
to flag those features which are not supported in the same way as they are 
in software rendering. Render diagnostics also examines your graphics 
hardware to determine its level of support.

Related topics

”Run diagnostics” on page 141.

mental ray for Maya diagnostics

mental ray supports a number of diagnostic modes that help you visualize 
and optimize the rendering process. They modify the output image to 
include grid lines or dot patterns that indicate coordinate spaces or 
sampling or photon densities. These graphs help you detect insufficient or 
excessive sampling densities, and tune parameters such as numbers of 
photons or sampling and contrast limits. 

For more information, see ”Diagnostics” on page 197.
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How do I? > Adjust scene anti-aliasing parameters (Maya software)
How do I? Improve rendered image quality

Adjust scene anti-aliasing parameters (Maya 
software)

Maya separates edge aliasing parameters from shading aliasing 
parameters to give you more control over image quality and performance.

You can adjust anti-aliasing settings for edges, shading, multipixel 
filtering, and motion blur in the Anti-Aliasing Quality section in the 
Render Global Settings window. 

For details on the settings, see ”Set scene rendering quality” on page 99.

Adjust per-object anti-aliasing parameters

Maya software rendering

You can correct the flickering of very small objects by increasing the 
visibility samples in the selected object’s Attribute Editor. 

Reduce artifacts and flicker

Unlike anti-aliasing techniques, you cannot adjust the settings in the 
Render Global Settings window to reduce artifacts and flicker. Instead, 
you can fix shadow artifacts, clipping plane artifacts, or animation flicker 
independently. 

Shadow artifacts (Maya software rendering)

Raytraced shadows are susceptible to the terminator effect, a self-
shadowing error that results from tessellation (triangles that approximate 
a smooth surface). To fix raytraced shadow artifacts, increase the 
tessellation. 

For more information on tessellation, see ”Maya tessellation” on page 44.

Clipping plane artifacts (Maya software rendering)

Clipping planes help Maya to determine how far and near objects are 
relative to the camera. By default, cameras have Auto Render Clip Plane 
turned on so that Maya can sort geometry as accurately as possible. If 
objects seems to inter-penetrate each other, turn off Auto Render Clip 
Plane and set the Near Clipping Plane to 1.0. 

For more information on clipping planes and these settings, see ”Clipping 
planes” on page 34. 
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How do I? > Animation flicker
Animation flicker

For Maya software rendering and Maya hardware rendering

During rendering, Maya filters textures. If textures flicker or crawl along 
objects in your scene from frame to frame, consider using a lower 
resolution file texture, or, if you are not using a file texture, adjust the 
Filter settings in the Effects section of the texture’s Attribute Editor. 

For more information about texture filtering, see ”Texture filtering” on 
page 29 in the Shading guide. 

Increase render speed

Increase overall rendering speed

To make a scene render faster

• Diagnose the scene to find ways to render the scene faster using 
Render > Run render diagnostics. You can use this tool to monitor 
how well you optimize the scene and to search for limitations and 
potential problems that may occur. For more information on render 
diagnostics, see ”Diagnose scene problems” on page 141.

• Perform scene optimizations:

• Click File > Optimize Scene Size >  to turn options on or off to 
optimize everything in the scene and to remove unused or non-
valid elements. See ”File > Optimize Scene Size” on page 237 in the 
Basics guide for more information about this window. 

• For Maya software rendering, use Block ordered texture set up. 
See ”Cache texture tiles using BOT (block ordered texture)” on 
page 139.

• If the scene contains objects with construction history and you no 
longer need it, delete it. See the ”Construction history” on page 105 
in the Basics guide for details.

• Avoid memory swapping by:

• Closing all applications before rendering to maximize the amount 
of memory available for rendering (including Maya if rendering 
from a shell or command line).

• Setting the TEMP or TMPDIR variable as the location for 
temporary render cache files: -TMPDIR (IRIX and Linux) or - 
TEMP (Windows and Mac OS X) to make plenty of room for 
temporary rendered files. Make sure that the value of those 
variables points to a local, fast hard drive, not a network drive.
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How do I? > Use average BSP (mental ray for Maya) settings
• For Maya software and mental ray for Maya, Test Resolution 
(Render > Test Resolution) lets you select a reduced resolution to test 
render the scene. For more information on test rendering strategies, 
see ”Visualize a scene” on page 107. 

• For Maya software, if the scene contains several identical surfaces (for 
example, multiple spheres), use Optimize Instances in the Render 
Global Settings window to improve rendering performance. 

• Turn off motion blur if you don’t need it (the Vector renderer has no 
motion blur). For the Maya software renderer, use 2D motion blur 
instead of 3D motion blur when possible. See 2D Motion Blur global 
attributes and 3D Motion Blur in the Render Global Settings window 
for details. 

Use average BSP (mental ray for Maya) settings 

When mental ray for Maya raytraces, it calculates the effects using an 
average of the depth and the average of the leaf size settings of the BSP. 

To speed up subsequent renderings, you can render instead with the 
average settings (instead of your initial settings). 

Find the averages in Maya's Output Window after you render the scene 
the first time (with 'progress messages' turned on), then change the 
settings in the Memory and Performance section.

Example averages found in the Output Window

• RCI 0.2 info : main bsp tree statistics:

• RCI 0.2 info : max depth : 40

• RCI 0.2 info : max leaf size : 114

• RCI 0.2 info : average depth : 22

• RCI 0.2 info : average leaf size : 7

• RCI 0.2 info : leafnodes : 8185

• RCI 0.2 info : bsp size (Kb) : 393

Increase surface rendering speed

• Use single-sided instead of double-sided surfaces (which is the 
default) on the object’s Attribute Editor. The biggest speed gain is for 
the Maya hardware renderer.

• Tessellating large surfaces requires a lot of memory, so use several 
small surfaces instead of one large surface when you can. The 
renderer is more efficient with smaller surfaces.

• For Maya software rendering and Maya hardware rendering, use 
bump mapping instead of displacement mapping.
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How do I? > Increase shadow rendering speed
• For Maya software rendering, make bump maps flatter. To do this, 
reduce the value of the Alpha Gain attribute, which smooths the 
bump map and reduces the number of samples of adaptive shading. 
This technique only works when Edge Anti-aliasing is set to Highest 
Quality. The texture bump looks flatter when the Alpha Gain is lower. 

• For Maya software rendering, turn on Use Displacement Bounding 
Box when using displacement maps.

• For Maya software rendering, use layered textures when possible, 
instead of a Layered Shader. (See ”Layered shaders” on page 24 and ”2D 
and 3D textures” on page 25 in the Shading guide for details.)

• For Maya software rendering and mental ray for Maya, if you are 
raytracing the scene, set the Reflection Limit and Refraction Limit to 
the lowest values that produce acceptable results. 

• For Maya software rendering, in the Render Global Settings window 
on IRIX and Linux, Use File Cache avoids re-tessellation of the same 
surface during rendering. Turn on Use File Cache to store geometric 
data in a separate file in a location that you specify (the default 
location is /usr/tmp, but you can set a new location by typing setenv 
TMPDIR xxx, where xxx is the name of the directory where this file is 
output). 

Increase shadow rendering speed

To make shadows render faster

• For Maya software and mental ray for Maya, use depth map shadows 
instead of raytraced shadows. 

• For surfaces that do not need to cast shadows, turn off Casts Shadows.

To make depth map shadows render faster

• Set the Dmap Resolution to the lowest value that produces acceptable 
results. (For shadow casting spot lights, first reduce the Cone Angle to 
the lowest value that produces acceptable results.)

• Turn on Use Dmap Auto Focus (or set the Dmap Focus to the lowest 
value that produces acceptable results. See Dmap Focus, Dmap Width 
Focus) and set the Dmap Resolution to the lowest value that produces 
acceptable results.

• For Maya software rendering, set the light’s Dmap Filter Size to the 
lowest value that produces acceptable results. A Dmap Filter Size 
value of 2 or more is usually sufficient. For mental ray for Maya, 
adjust the Resolution, Samples, and Softness settings under the light’s 
Shadow Map section.  
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How do I? > Increase camera views render speed
• For Maya software rendering, Set Fog Shadow Samples to the lowest 
value that produces acceptable results. 

• For Maya software rendering, set Disk Based Dmaps to Reuse Existing 
Dmap(s).

• For Maya software rendering, if a point light does not have to produce 
shadows in the light’s positive or negative X, Y, or Z directions, turn 
off the appropriate Use Dmap attributes: Use X+ Dmap, Use X- Dmap, 
Use Y+ Dmap, Use Y- Dmap, Use Z+ Dmap, or Use Z- Dmap. S

• For Maya software rendering, if the scene contains NURBS surfaces, in 
the Memory and Performance Options section of the Render Global 
Settings window, make sure Reuse Tessellations is on (the default 
setting).

To make raytraced shadows render faster (for Maya software 
rendering and Maya hardware rendering)

• If the Light Radius (or the Light Angle for directional lights) is greater 
than 0, set Shadow Rays to the lowest value that produces acceptable 
results. See Shadow Radius, Light Radius, Light Angle for details.

• Set Ray Depth Limit to the lowest value that produces acceptable 
results.

Increase camera views render speed

For Maya software rendering. 

You can make camera views render faster by not selectively focusing the 
camera, or by selectively focusing the camera so more objects are in focus.

To make camera views render faster

• Turn off Depth Of Field, or increase the F Stop. 

Global illumination and caustics

Specify objects to participate in global illumination 
and caustics

By default all objects participate in photon tracing for global illumination 
and caustics. Typically, not all are required for you to achieve the look 
you want. You can specify exactly which objects cast and/or receive 
photons to reduce the rendering load.
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Final Gather

Final Gather is view dependent and is recalculated for each frame in a 
sequence. You can store final gather results so that later frames can use the 
results from a frame rendered earlier to speed up the Final Gather 
rendering process.

Reduce render memory usage
To reduce the memory used by the renderer, perform the following pre-
render optimizations to produce a smaller and more efficient file.

Cache texture tiles using BOT (block ordered 
texture)

For Maya software rendering only. (For mental ray for Maya search BSP in 
the online documentation.)

For more information on file textures, see ”File textures” on page 27 in the 
Shading guide.

When you render, scripts, scenes, textures, etc., are loaded into RAM. If all 
available RAM is used, the machine may hang or experience swapping 
problems. To reduce the load on RAM during render time, you can 
convert your textures to Block Ordered Textures (BOT), which are 
essentially tiles. (For more information on tileable images, see ”File 
textures” on page 27 in the Shading guide). With BOT files, a small cache of 
texture tiles are kept in RAM; when Maya needs more during render time, 
it goes to disk to find them. 

The BOT cache is a fixed amount of approximately 250KB in RAM and 
efficiently caches textures.

• BOT is not recommended for all texture files, but you notice the 
difference in speed when rendering high resolution textures.

Use the BOT pre-render setup

A new and optimized scene file is generated and is ready for the renderer 
when you use the BOT pre-render setup. 

For more information, type the following: 

maya -optimizeRender -help

maya -optimizeRender [options] mayaFile optimizedMayaFile

where mayaFile is the Maya file to be optimized and optimizedMayaFile 
is the name of the optimized Maya file.
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The following options can be used:

Delete information not relevant to the 
renderer

You can reduce memory in the Maya file by deleting information not 
relevant to the renderer. Sometimes extra information is only needed 
when editing the scene, or it contains currently unused items saved for 
future uses. 

Render parts of a scene separately

You can render parts of a scene separately and composite the rendered 
images. For more information on rendering in layers and passes for 
compositing, see ”Layers and passes” on page 83.

Decrease file size (Maya Vector renderer)

Strategies to decrease vector render file size

If you are using the Maya Vector renderer to create SWF or SVG files for 
online delivery, you may need to modify your scene and adjust the Maya 
Vector Render Global Settings to produce the best compromise between 
image quality and file size. Complex scenes and certain Maya Vector 
Render Global Settings can produce very large SWF or SVG files that are 
unsuitable for online delivery.

If you are using the Maya Vector renderer to create SWF or SVG files for 
delivery via CD-ROM, DVD, or network, or to create AI, EPS or bitmap 
images, then you do not usually need to be as concerned about file size.

Use the following guidelines as a starting point to help you reduce the 
size of rendered SWF and SVG files. See ”Maya Vector tab” on page 211 
for more information on how the various options affect file size.

-botRes ‘int’ Resolution for which BOT files are produced. If this 
flag is not used, a default botRes of 512x512 is used. 

-botLoca ‘name’ Directory in which BOT files reside (default is in the 
same directory as the original file).

-help Prints the help message.

-noBOT Avoid BOT creations.

-noCleanup Avoid cleaning up non-rendering related data.
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• Reduce the complexity of your scene: Consider removing minor 
elements of your scene. Reduce the number of triangles in polygonal 
and subdivision surfaces. Reduce the tessellation of NURBS surfaces.

• Reduce the number of frames in an animation.

• Reduce the Frame Rate of an animation.

• Choose an appropriate Fill Style based on the objects in your scene. 
Some fill styles produce results of equal quality, but different file 
sizes, for certain types of objects. Avoid using Full Color or Mesh 
Gradient as they always create large files.

• Turn on Combine Fills and Edges (SWF only).

• Increase the Curve Tolerance value.

• Set Svg Animation to Script (SVG only).

• Turn on Compressed (SVG only).

• Decrease the Detail Level.

• Set Edge Style to Outline instead of Entire Mesh. (For more edge 
detail, turn on Edge Detail.)

• Turn off Hidden Edges.

• Turn off Show Back Faces. If a surface does not render because it is 
facing away from the camera, manually reverse the surface’s normal.

Diagnose scene problems 

Run diagnostics

To run render diagnostics

• Do either of the following:

• From the main Maya window, select Render > Render 
Diagnostics.

• From the Render View window, select File > Render Diagnostics.

Maya opens the Script Editor and displays a list of potential problems in 
the scene.
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mental ray for Maya error handling and 
diagnostics

Error messages

mental ray for Maya checks for errors in a scene and recognizes various 
operating system errors. If an error is detected, a message appears in 
Maya's script editor. If a critical error is found, mental ray for Maya aborts 
the current process. 

The message verbosity can be changed by selecting a different Export 
Verbosity option in the Render Global Settings window. When using the 
interactive renderer mental ray for Maya prints messages to the Output 
Window (Windows) or the Console (IRIX and Linux). When batch 
rendering with mental ray for Maya, a log file is created. If severe errors 
are encountered during database access of mental ray, the final rendering 
doesn’t get started. 

Diagnostics

You can use diagnostics to help you diagnose issues with samples and 
photon maps. You can specify Diagnose Grid and Grid Size, as well as 
Diagnose Photon Density or Irradiance. See ”Diagnose scene problems” 
on page 141. 

Sample diagnostic messages

The following are some of the diagnostic messages Maya software 
rendering displays:

• Motion blur and raytracing are both turned on. (Reflections, 
refractions and shadows are not motion blurred.)

• You have motion blur turned on. Be aware that particles, lights and 
shadows do not motion blur. As well, motion blurred shadows may 
produce artifacts. 

• You have specified output to the Quantel format. In previous versions 
of Maya, this format only outputs to NTSC/PAL/HDTV resolutions, 
and does not output to fields. If the above restrictions are not met, 
rendering defaults to IFF image output.

• You have specified output to the Cineon format. This format does not 
render out a mask channel. 

• You have specified a fractional animation by-frame step. This results 
in images over-writing each other for fractional frame counts. Please 
remember to turn on the modify-extension.

• Near/far clipping values are too far apart. You may encounter 
numerical imprecision resulting in incorrect renders.
Rendering 

142



5 | Quality, render speed, diagnostics

How do I? > Sample diagnostic messages
• There are no renderable cameras in the scene.
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6 Network rendering
About Maya network rendering

Maya network rendering

Maya network rendering 

Network rendering is the distribution of the rendering process across 
more than one machine (sometimes called a render farm). For example, 
you can divide an animation into sequences and render each sequence on 
a different computer. You can also control when and on which computer 
to render. Rendering across a network of computers is often referred to as 
distributed rendering. 

You can manage network rendering in two ways: 

• Manually. See ”Render across a network” on page 148.

• Automated, provided by a third-party solution.

Related topics:

• ”Computer preparation” on page 145

• ”Network render with Maya software” on page 148

Computer preparation

Maya network rendering requires a network of properly configured 
computers.

File Access

All files, scenes, and textures you use must be stored in locations 
accessible to each render workstation. This can be achieved by doing 
either of the following:

• Providing the files to all the render workstations from a central file 
server. File permissions must be adjusted for your environment.

• Transferring the files to each render workstation’s local storage.

Tip Network rendering may read and write numerous files over the 
network simultaneously. Make sure your network bandwidth 
can handle the traffic. Consider rendering files locally on each 
render node, then transferring them to the final destination.
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Plug-ins

Make sure all render workstations used to render a scene containing plug-
ins have those plug-ins installed, and that each render workstation has a 
valid license for those plug-ins. If a render workstation does not have a 
license for a plug-in being used, you may find that every frame it 
processes fails. 

mental ray for Maya network rendering

Parallel network rendering

Parallel network rendering allows you to distribute the rendering of each 
frame in your scene across multiple machines on your network. This 
requires standalone mental ray rendering licenses and can be invoked 
while working within Maya (in the Render View or batch rendering) and 
also from the command line with Maya or the mental ray standalone 
renderer.

Related topics:

• ”Terminology” on page 146

• ”What do I need?” on page 147

• ”Configuration files” on page 147

• ”Before you begin (mental ray for Maya network rendering)” on 
page 149

Terminology

When using mental ray for Maya, master refers to the machine that is 
submitting the parallel network render requests interactively, via batch or 
command line, and slave refers to an individual machine with mental ray 
standalone on the network that receives and performs part of a parallel 
network render and sends the information back to the client.

Tip It’s a good idea to cache data in the scene to prevent unwanted 
differences between frames, computers, effects, and so on. 

Note There are numerous third-party solutions that provide solutions 
for network rendering. This guide gives a minimum workflow 
only. Please check our Conductor Partners for available 
solutions.
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Any machine with mental ray standalone can be a master, a slave or both at 
the same time.

You can also mix any combination of IRIX, Linux, Windows, and Mac OS 
X machines as clients and servers.

What do I need?

If you want to render Maya scenes (.mb or .ma) from within Maya or 
batch render with Maya, you need to install mental ray for Maya on all 
server machines and mental ray standalone on all slave machines. 

If you want to render native mental images (.mi) scenes from the 
command line using the mental ray standalone renderer, you need to 
install mental ray on all master and slave machines.

Configuration files

To specify which network render slave machines a master uses, mental 
ray for Maya and mental ray standalone use different configuration files:

• mental ray for Maya uses a file called maya.rayhosts

• mental ray standalone uses a file called rayhosts

maya.rayhosts

mental ray for Maya looks for maya.rayhosts in the following directories:

• user’s Maya preference directory

• user’s Maya application directory

• user’s home directory

maya.rayrc

mental ray for Maya looks for maya.rayrc in the following directories:

• user’s Maya preference directory

• user’s Maya application directory

• user’s home directory

• $MAYA_LOCATION/mentalray

Note While it is not recommended, you can mix and combination of 
IRIX, Linux, Windows, and Mac OSX machines as masters and 
slaves.
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• directory from which the plugin was loaded

How do I? Render across a network

Network render with Maya software

Network render with Maya software 

Before you begin, you must have networked workstations. See your 
system administrator if workstations are not networked.

To render on several computers

1 Install Maya on each machine. 

We recommend that you pare down the installation to the minimum 
requirements. For instance, you do not have to load all options on 
each machine when installing (for example, documentation).

2 Initiate render commands on each render workstation. 

This can be achieved manually by the Command Line Render 
command. To automate it, use simple scripting capabilities. See the 
Command Line Render Help (render -h) for more options.

For example,

If you have a 100-frame scene and want to distribute the rendering 
across 4 render workstations, type: 

Render -s 1 -e 25 filename for the first render workstation.

Render -s 26 -e 50 filename for the second render workstation.

Render -s 51 -e 75 filename for the third render workstation.

Render -s 76 -e 100 filename for the fourth render workstation.

Render on several IRIX and Linux computers

You can use Dispatcher to render on several IRIX and Linux computers. 
See ”Overview of Dispatcher” on page 15 in the Rendering Utilities guide for 
more information. 

Tip Using -rep 

You can use the -rep flag on the Render command to automate 
Maya software networked rendering. 
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How do I? > Before you begin (mental ray for Maya network rendering)
Related topics

• ”Maya network rendering” on page 145

Network render with mental ray for Maya

Before you begin (mental ray for Maya 
network rendering)

Before you begin, you must have networked workstations. See your 
system administrator if workstations are not networked.

You can set up masters using mental ray standalone or mental ray for 
Maya, using different method to specify which hosts to use as network 
render slaves.

Related topics

• ”Parallel network rendering” on page 146

• ”Submit a job to render over the network” on page 154

Set up a master machine with mental ray for 
Maya

To set up a master machine with mental ray for Maya

• Create a file called maya.rayhosts and put it in one of the following 
directories (They are searched in order and the first maya.rayhosts 
file that is found is used.):

• Maya 6.0 prefs folder:

(Windows) %USERPROFILE%\My Documents\maya\6.0\prefs/users/
fred/Library/Preferences/

(Mac OS X) /users/username/Library/Preferences/Alias/maya/6.0/
Prefs

Note If you have multiple versions of mental ray standalone installed 
(not recommended), each must have their own TCP port number 
in the services file to avoid conflict. 

For example:

mi_ray3_0maya4_0   7051/tcp

mi_ray3_1maya4_5   7052 and 7053/tcp

mi_ray3_2maya5_0   7054/tcp
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(IRIX and Linux) $HOME/maya/6.0/prefs

• Maya Application folder: 

(Windows) %USERPROFILE%\My Documents\maya

(IRIX and Linux) $HOME/maya  

(Mac OS X) /Applications/Alias/maya/6.0 

• User's home directory: 

(Windows) %USERPROFILE% or %HOMEDRIVE%\%HOMEPATH% (usually 
c:\)

(IRIX, Linux, and Mac OS X) $HOME

%USERPROFILE% or %HOMEDRIVE%\%HOMEPATH% (on Windows)

• Directory of Maya 6.0 installation folder. 

/usr/aw/maya6.0/mentalray (on IRIX and Linux) 

(Windows) C:\Program Files\Alias\maya6.0\

(Mac OS X) /applications/Alias/maya6.0/

Related topics

• ”Parallel network rendering” on page 146

• ”Submit a job to render over the network” on page 154

Verify which hosts file is being read 

To verify which hosts file is being read

1 Turn on Info Messages in the Translation section of the Render 
Globals Setting window (with the mental ray renderer selected). 
During a render, messages similar to the following are output to the 
Script Editor:

// Info: (mental ray) : loading startup file C:/
Program Files/Alias/Maya 6.0/mentalray/maya.rayrc

// mental ray for Maya: using rayhosts file C:/
Documents and Settings/user1/My Documents/maya//
maya.rayhosts

Related topics

• ”Parallel network rendering” on page 146

• ”Submit a job to render over the network” on page 154
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Change the set of slaves used for mental ray 
for Maya renders 

To change the set of slaves being used for mental ray for 
Maya renders

• Close Maya, modify the appropriate maya.rayhosts file, and restart 
Maya.

Related topics

• ”Parallel network rendering” on page 146

• ”Submit a job to render over the network” on page 154

Set up a master machine with mental ray 
standalone (method 1)

To set up a master machine with mental ray standalone - 
method 1

1 Create the file. Each line of the file should specify the name of a 
machine to be used as a network render slave.

2 Place the file in one of the following locations:

• Place a file called .rayhosts in the home directory of the current 
machine. On IRIX, Linux, and Mac OS, X the home directory is 
specified by the $HOME environment variable. On Windows 
machines, it is specified by %HOMEDRIVE%\%HOMEPATH% 
(on most machines, this is C:\).

• Place a file called .rayhosts in the current directory, for example, 
from where the render will be involked.  A .rayhosts file in the 
current directory overrides one in the machine's home directory .
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Related topics

• ”Parallel network rendering” on page 146

• ”Submit a job to render over the network” on page 154

• ”Set up a master machine with mental ray standalone (method 2)” on 
page 152

Set up a master machine with mental ray 
standalone (method 2)

To set up a master machine with mental ray standalone - 
method 2

• Use the -hosts option with the mentalrayrender command, for 
example: 

mentalrayrender -hosts machine1 machine2 sceneFile.mi 

Note To verify which hosts file (if any) is being read, and what 
network render slaves are being contacted, use the 
mentalrayrender command with a verbosity setting of 4 or 
higher. For example, running 

D:\> mentalrayrender -v 4 test.mi 

could produce the output:

MAIN .0 info : mental ray, version 3.2
MAIN .0 info :

[...]

MAIN .0 info :
MAIN 0.0 info : version 3.2, 4 Dec 2002
MAIN 0.0 info : compiled on: Windows NT 4.0, x86
MSG 0.0 info : reading hosts file C:\\.rayhosts
MSG 0.0 info : connecting host foobar1:7054 
JOB 0.0 info : started thread 0 on foobar1 now known as 
host 1
MSG 0.0 info : connecting host foobar2:7054 
JOB 0.0 info : started threads 0,1 on foobar2 now known as 
host 2
.....

This indicates that the hosts file C:\.rayhosts was read, and 
that it specified network render slaves foobar1 and foobar2 for 
use in this rendering. The started thread 0, 1... messages 
indicate that the slaves were successfully contacted.
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This uses machine1 and machine2 as render slaves. This overrides any 
.rayhosts files on the master machine.

Related topics

• ”Parallel network rendering” on page 146

• ”Set up a master machine with mental ray standalone (method 1)” on 
page 151

• ”Submit a job to render over the network” on page 154

Slave machine setup

All slave machines require mental ray standalone.

To set up a slave on Windows

When you install mental ray standalone, the installation automatically sets 
up your machine as a server to receive network render requests. If you are 
encountering problems with network rendering follow the steps below:

1 Ensure there is a rayrc file in the mental ray installation directory 
(C:\Program Files\mental images\mental ray). This file is 
automatically created during a default installation. 

2 Ensure that the Ray3_3maya6_0 Server service is installed and 
running.

To verify this, go to the Services window from the Administrative 
Tools and check to see if the Ray3_3maya6_0 Server service exists 
and is started.

If the Ray3_3maya6_0 Server service exists but is not started, go to 
step 5.

3 If the Ray3_3maya6_0 Server service does not exist, edit the services 
file located at C:\WINNT\system32\drivers\etc\services, and make 
sure the following line exists:

mi-ray3_3maya6_0 7054/tcp  

7054 represents the port number. Make sure the port number is the 
same on the master machine and all slave machines.

4 Open a command prompt window and type the following:

ray3_3maya6_0server /install

ray3_3maya6_0server should automatically be in your path and is 
located in the bin directory of the mental ray installation.

5 Double-click the Ray3_3maya6_0 Server service in the Services 
Window (Administrative Tools in the Control Panel) to start it. 
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When the service successfully starts, the machine is ready to receive 
network render requests.

To set up a slave on IRIX, Linux, and Mac OS X

The mental ray standalone installer does not set up your machine as a 
slave automatically. You need to follow the steps below on all IRIX, 
Linux, and Mac OS X machines with administrative privileges.

1 In a shell type:

/usr/local/mi33/bin/netsetup -s

You are prompted for the name of the SPM license server. It defaults 
to the local host. 

2 Type in the SPM license server name if it is other than the default local 
host and then press Enter.

The machine is now ready to receive network render requests.

Related topics

• ”Parallel network rendering” on page 146

• ”Submit a job to render over the network” on page 154

Submit a job to render over the network

Once you are set up, the process of rendering over the network is fully 
automatic so that every render you invoke from a client machine is 
automatically distributed over the network.

To network render a Maya scene within Maya on a master 
machine

Ensure that the maya.rayhosts file has the name of all mental ray 
network rendering slaves you wish to use (see ”Set up a master machine 
with mental ray standalone (method 1)” on page 151).

1 Start Maya, open a scene and select Render > Render using > mental 
ray Renderer.

2 Select Render > Render Frame.

3 To verify that the slave machines are being used, in the Render Global 
Settings window (Window > Rendering Editors > Render Globals), go 
to the mental ray tab and in the Translation section, select Progress 
Messages from the Export Verbosity drop-down list. 

You should see messages in the script editor telling you which slave 
machines were connected and which machine is being used to render 
particular tiles.
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file?
To network render a Maya scene with Maya from the 
command line on a master machine

Ensure that the maya.rayhosts file has the name of all mental ray 
network rendering slaves you wish to use (see ”Set up a master machine 
with mental ray standalone (method 1)” on page 151).

1 From a command prompt window, change to the directory where 
your Maya scene resides.

2 Type the following

Render -r mr sceneName.mb

To network render with a mental images (.mi) scene with 
mental ray standalone on a master machine

Ensure that the maya.rayhosts file has the name of all mental ray 
network rendering slaves you wish to use (see ”Set up a master machine 
with mental ray standalone (method 1)” on page 151).

1 From a command prompt window, change to the directory where 
your .mi file resides.

2 Type the following:

mentalrayrender myFile.mi

3 To get progress messages to show how the slave machines are being 
used, type the following command:

mentalrayrender -verbose 5 myFile.mi

Related topics

• ”Parallel network rendering” on page 146

What 
went 
wrong?

Network rendering with mental ray for 
Maya

Troubleshoot:Can't I install the rayserver 
service or edit the services file? 

Ensure you have administrator (or root) privileges on the machine.
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Troubleshoot:I have everything correctly set 
up, but I still can't network render

One possibility is that the network port number you are using is already 
being used by another service. Ensure that there is no other entry in the 
services file that is using port 7054. If that port number is already taken, 
you need to pick a new available port number and use that same number 
for all master and slave machines that are to work together.

You may need to edit the services file located at: 

(IRIX, Linux, and Mac OS X)  /etc/services 

(Windows) C:\WINNT\system32\drivers\etc

and make sure the following line exists:

mi-ray3_3maya6_0 7054/tcp

7054 is the port number. Make sure the port number is the same on the 
master machine and all slave machines. 

You may need to edit a file called the rayd file located in the mental ray 
3.3 installation bin directory. Fill in the name of your SPM License server 
and uncomment the setenv SPM_HOST line.

(IRIX and Linux with versions of Redhat prior to 7.2) You may need to 
edit the inetd.conf file located at /usr/etc/inetd.conf and make sure 
the following line exists:

mi-ray3_3maya6_0 stream tcp nowait nobody /usr/local/mi32/bin/rayd rayd

You may need to restart the inetd service by typing the following:

%  killall -v -HUP inetd

(Linux only with version of Redhat 7.2 and 7.3) You may need to edit the 
services in the xinetd.d directory. See “To check your xinetd configuration 
on Linux” below.

To check your xinetd configuration on Linux

1 In a Linux shell type:

ls /etc/xinetd.d 

There should be a file named mi-ray3_3maya6_0. 

2 If there is not, become root, create the file using a text editor and enter 
the following text:

# description: mental ray for maya network 
rendering service mi-ray3_3maya6_0
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{

    flags           = REUSE
    socket_type     = stream
    user            = nobody
    wait            = no
    server          = /usr/local/mi32/bin/rayd
    log_on_failure += USERID
}

3 Save the file.

4 In order for xinetd to find the newly configured service, you need to 
restart it or send it a signal. 

• Restarting xinetd can be undesirable because it affects a number 
of network services. To restart xinetd, type:

/etc/init.d/xinetd restart

• To reconfigure xinetd without restarting it, find out the process 
id of xinetd by executing:

ps -e | grep -v grep | grep xinetd

You should see a line similar to this:

980 ?        00:00:02 xinetd

The first number is the process id of xinetd.

If the system is RedHat 7.2, xinetd re-reads its configuration on 
receipt of the USR2 signal. For RedHat 7.3 it re-reads its configuration 
on receipt of the HUP signal. So for a RedHat 7.3 system where 
xinetd's process id is 980 you would execute:

kill -HUP 980

xinetd should have found the new service and you should be able to 
send it render requests from another node on the network. 

Troubleshoot:Mac OS X machines

On Mac OS X the Maya installer sets up your machine as a master for the 
user who installed Maya

To install settings on a Mac OS X machine for a user other 
than the user that installed mental ray

1 The user should log in to the Mac OS X machine. 

2 Open a Terminal window and type: 

sh /Applications/Alias/maya6.0/bin/setup defaults.sh install
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To remove settings on a Mac OS X machine for a user other 
than the user that installed mental ray

1 The user should log in to the Mac OS X machine. 

2 Open a Terminal window and type: 

sh /Applications/Alias/maya6.0/bin/setup defaults.sh remove
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7 Window, menu, and 
node descriptions
Reference Render Global Settings window

Render Global Settings window

Render globals (scene settings) for the Maya Hardware renderer, the 
mental ray for Maya renderer, the Maya Software renderer, the Maya 
Vector renderer are consolidated into one Render Globals Settings 
window. 

Use the settings in this window to set scene-wide render options. 
Especially when used in conjunction with per-object render settings (see 
the particular object or render subject matter for details), the render global 
settings give you a great deal of control over quality of rendered images 
and the speed with which they are rendered. 

To open the Render Global Settings window, see ”Open the Render Global 
Settings window” on page 92.

Common tab

The common tab contains settings that are common to all renderers. For 
information on the Common tab, see ”Common tab” on page 159.

Render-specific tabs

The other tab changes, depending on which renderer is selected. 

• For information on the Maya Software tab, see ”Maya Software tab” 
on page 165.

• For information on the Maya Hardware tab, see ”Maya Hardware 
tab” on page 207.

• For information on the mental ray for Maya tab, see ”mental ray tab” 
on page 184.

• For information on the Maya Vector tab, see ”Maya Vector tab” on 
page 211.

Common tab

For information on the render global settings, see ”Render Global Settings 
window” on page 159.

Not all options are available for all renderers. 
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Image File Output

The name of rendered image files can consist of three separate 
components: file name, frame number extension, and file format 
extension. A combination of these three components is referred to as the 
file name syntax. 

For more information about the file name syntax, see ”File name syntax” 
on page 78.

For more information about the file formats, see ”File formats” on page 73.

File Name Prefix

Lets you specify the base name for rendered images. 

Frame/Animation Ext

The format (syntax) of rendered image file names. 

Image Format

The format for saving rendered image files. See also “File formats”. 
The default setting is Maya IFF. 

Start Frame, End Frame

Specifies the first (Start Frame) and last (End Frame) frames to render. 
Start Frame and End Frame are only available if Frame/Animation 
Ext is set to an option containing # (see also Set file name syntax). The 
default value for Start Frame is 1; the default value for End Frame is 
10.

By Frame

The increment between the frames you want to render. By Frame is 
only available if Frame/Animation Ext is set to an option containing 
#. The default value is 1.

If you use a value less than 1, make sure the Renumber Frames Using 
option is turned on. Otherwise, many frames will appear to be 
missing when they are just being overwritten.

Note When choosing basic file names for an animation, avoid using 
periods; use underscores instead. For example, use:

xxx_yyy.iff.1

instead of 

xxx.yyy.iff.1
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Frame Padding

The number of digits in frame number extensions. For example, if 
Frame/Animation Ext is set to name.ext, and Frame Padding is 3, 
Maya names rendered image files name.001, name.002, and so on. The 
default value is 1.

Renderable Objects

Controls whether Maya renders all objects (Render All) or only 
selected objects (Render Active) for the camera selected in the Camera 
option’s drop-down list provided the selected camera has been set to 
renderable in the camera’s Attribute Editor. The default setting is Render 
All.

Camera

By selecting a camera from this list, you can turn on or off the RGB, 
Alpha, or Mask channels for that camera. 

• If your scene has only one renderable camera (for example, the 
perspective camera, which is by default the only renderable camera in 
a new scene), whatever camera is selected in this drop-down list 
becomes the renderable camera. In other words, the newly selected 
camera becomes the renderable one in your scene (the default 
perspective camera becomes unrenderable).

• If, however, you have more than one renderable camera in your scene 
(for example, if you’ve created a second perspective camera), by 
selecting another camera from this list, you do not automatically make 
the newly selected camera renderable. Selecting this other camera just 
lets you turn on or off the its RGB, Alpha, or Mask channels. 

You can make the second (or any number of cameras) renderable in 
the Output Settings section of the selected camera’s Attribute Editor. 
Any subsequent cameras you make renderable are shown as 
[renderable] in this list.

Channels

RGB Channel 

(Color) Controls whether rendered images contain a color 
channel. The default setting is on.

Alpha Channel 

(Mask) Controls whether rendered images contain a mask 
channel. The default setting is on.

Depth Channel 

(Z Depth) Controls whether rendered images contain a depth 
channel. The default setting is off.
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Custom Filename Extension

Use Custom Extension

You can use a custom file format extension for rendered image file 
names by turning on Use Custom Extension, and entering the 
extension in the field. This extension replaces the standard extension 
based on file format, such as .IFF, .GIF, etc.

Renumber Frames

Lets you change the numbering of rendered image files for an 
animation. The Renumber Frames attributes are only available if 
Frame/Animation Ext is set to an option with # (such as name.#.ext).

Renumber Frames Using

If on, Maya uses the frame number extensions beginning at Start 
Number and increasing by By Frame for rendered image file names.

Start Number

The frame number extension you want the first rendered image file 
name to have.

By Frame

The increment between frame number extensions you want rendered 
image file names to have. 

Resolution

The Resolution attributes control the resolution and pixel aspect ratio of 
rendered images.

For more information about resolution, see ”Resolution” on page 80.

Note The resolution limit for the Vector renderer is 1600x1600.

Note When rendering larger than 6k x 6k resolutions, Maya requires 
large amounts of memory if the saved output image is one of: 
tiff, SoftImage, Alias-PIX, JPEG, EPS, or Cineon.

In such cases, you can render to any other Maya supported 
image format, and use conversion tools (such as imgcvt) to 
convert those images to the desired format. 
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Presets

Select a film- or video-industry standard resolution. When you select 
an option from the Presets drop-down menu, Maya automatically sets 
the Width, Height, Device Aspect Ratio, and Pixel Aspect Ratio.

You can also add a Presets option to output to an unlisted device. 

Render Resolution Width Height Device 
Aspect 
Ratio

Pixel Aspect 
Ratio

Custom any any any any

320x240 320 240 1.333 1.000

640x480 640 480 1.333 1.000

1k Square 1024 1024 1.000 1.000

2k Square 2048 2048 1.000 1.000

3k Square 3072 3072 1.000 1.000

4k Square 4096 4096 1.000 1.000

CCIR PAL/Quantel PAL 720 576 1.333 1.066

CCIR 601/Quantel NTSC 720 486 1.333 0.900

Full 1024 1024 768 1.333 1.000

Full 1280/Screen 1280 1024 1.333 1.066

HD 720 1280 720 1.777 1.000

HD 1080 1920 1080 1.777 1.000

NTSC 4d 646 485 1.333 1.001

PAL 768 768 576 1.333 1.000

PAL 780 780 576 1.333 0.984

Targa 486 (tga) 512 486 1.333 1.265

Targa NTSC (tga) 512 482 1.333 1.255

Targa PAL (tga) 512 576 1.333 1.500
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Maintain Width/Height Ratio

When on, Maya automatically updates the Height when you set the 
Width (or the Width when you set the Height). If off, Maya updates 
the Device Aspect Ratio (if Lock Device Aspect Ratio is off and it does 
not update the Height or Width. Maintain Width/Height Ratio is on 
by default.

Width, Height

The width and height of the image you want to render, measured in 
pixels. The ratio of the width and height is the image aspect ratio. 

Lock Device Aspect Ratio

Not available for mental ray for Maya.

If off, Maya updates the Pixel Aspect Ratio. When on, Maya updates 
the Device Aspect ratio when changing the width or height. The 
default setting is off.

Device Aspect Ratio

The aspect ratio of the display device on which you view the rendered 
image. The device aspect ratio represents the image aspect ratio 
multiplied by the pixel aspect ratio. 

Pixel Aspect Ratio

The aspect ratio of the individual pixels of the display device on 
which you are viewing the rendered image. 

For more information about the pixel aspect ratio, see ”Pixel aspect 
ratio” on page 80. 

Pixel Aspect Ratio is not available when using the mental ray 
renderer. 

Render Options

Enable Default Light

Not available for Vector Rendering.

Turn the default lighting on or off during rendering. 

For more information about Maya’s default lighting, see ”Default 
lighting in Maya” on page 15 in the Lighting guide. 

Plug-in Format

If you are using an IMF plug-in (to render images in a format that is 
not supported by Maya), enter the plug-in name in the Plugin Format 
field.
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Pre Frame MEL, Post Frame MEL

A MEL command or script to run before rendering each frame (Pre 
Frame MEL), or after rendering each frame (Post Frame MEL). 

For more information Pre Frame MEL scripts and Post Frame MEL 
scripts, see ”Pre Render MEL and Post Render MEL scripts” on 
page 82. 

Maya Software tab

For information on the render global settings, see ”Render Global Settings 
window” on page 159.

Anti-aliasing Quality

Controls how Maya anti-aliases objects during rendering. 

For more information about anti-aliasing and image quality, see ”Anti-
aliasing and flicker” on page 131. 

Quality

Select a preset anti-aliasing quality from the drop-down list. When you 
select a preset, Maya automatically sets all Anti-aliasing Quality attributes. 
The default setting is Custom.

Custom When you change anti-aliasing attributes that do not 
match any of preset attribute values, Maya 
automatically sets Presets to Custom. 

Preview Quality When test rendering scenes (fastest).

Intermediate 

Quality When test rendering scenes to produce slightly 
better quality than preview quality.

Note If you need to use multiple sets of quotations in the pre frame 
MEL or post frame MEL fields in render globals, be sure to use 
\" for every quotation mark except the first and last. 

print("Time to render my Maya scene, called\"bingo.mb"\");

Note Do not enter the .mel extension when entering the name of the 
script. You get an error message similar to the following:

Error: Cannot link to "name.mel".  Check number and 
types of arguments expected on procedure definition.
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Production 

Quality When testing or final rendering scenes that do not 
contain 3D motion blur or low-contrast scenes.

Contrast 

Sensitive 

Production When testing or final rendering high-contrast scenes 
(such as when you raytrace a scene. Also useful for 
anti-aliasing noisy bump maps).

3D Motion Blur 

Production When testing or final rendering scenes that contain 
3D motion blur.

Edge Anti-aliasing

Controls how the edges of objects are anti-aliased during rendering. Select 
a quality setting from the drop-down menu. The lower the quality, the 
more jagged the object’s edges appear, but the faster the render; the higher 
the quality, the smoother the object’s edges appear, but the render is 
slower. 

When you select an Edge Anti-aliasing quality from the drop-down list, 
Maya automatically sets all Anti-aliasing Quality attributes (in the 
subsections).

Low Quality Fastest anti-aliasing setting. For each rendered pixel, 
two points are analyzed and used to determine 
which part of the object is visible, producing low 
quality edge anti-aliasing.

Medium 

Quality For each rendered pixel, eight points are analyzed 
and used to determine which part of the object is 
visible, producing medium quality edge anti-
aliasing.

Although a little slower, produces moderately good 
edge anti-aliasing. This can be good for test 
rendering moderately complex scenes.

High Quality For each rendered pixel, thirty-two points are 
analyzed and used to determine which part of the 
object is visible, producing high quality edge anti-
aliasing.

Can be used for testing as well as production 
rendering.

Highest Quality Highest Quality anti-aliasing computes the image in 
two passes, looking for color contrasts within pixels 
and in surrounding pixels, such as highlights. The 
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first pass is the High Quality computation—the 
second pass looks for color contrast in the results of 
the first pass. In the regions where color contrast is 
high (for example, in regions containing highlights), 
more shading samples are taken. 

Improves on the High Quality and is excellent for 
picking up highlights that may be missed by a 
single pass (when you use High Quality). 

Number of Samples

Shading

The number of shading samples for all surfaces. This option works in 
conjunction with Shading Samples, an attribute available from the 
Render Stats section of a surface’s Attribute Editor. Shading Samples 
sets the number of times Maya shades in a pixel. For details, see 
Render Stats and Shading Samples.

Max Shading

Not available if you choose Preview Quality from the Presets menu as 
the Anti-aliasing Quality. 

The maximum number of shading samples for all surfaces. This 
option works in conjunction with Max Shading Samples, an attribute 
available from the Render Stats section of a surface’s Attribute Editor. 
Max Shading Samples sets the maximum number of times a pixel is 
shaded during the second pass of a Highest Quality render. The 
higher the number, the longer the rendering takes, but the more 
accurate the resulting image. 

3D Blur Visib.

The number of visibility samples Maya takes to accurately compute a 
moving object’s visibility as it passes over another object 

Tips • 3D Blur Visib and Max 3D Blur Visib, are associated with 
Max Visib Samples available in the 3D Motion Blur section 
of a surface’s Attribute Editor. For details, see 3D Motion 
Blur.

• 3D Blur Visib. and Max 3D Blur Visib. are only available 
when you turn 3D Motion Blur on in the Motion Blur 
section of the Render Global Settings window.

• Max Visib Samples is the maximum number of times a pixel 
is sampled for visibility when Motion Blur is turned on. 
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Max 3D Blur Visib.

The maximum number of times a pixel is sampled for visibility when 
Motion Blur is turned on. 

Particles

The number of shading samples for particles. This option works with 
Shading Samples, an attribute available from the Render Stats section 
of a surface’s Attribute Editor. Shading samples sets the number of 
times Maya shades each fragment in a pixel. See Render Stats and 
Shading Samples for more details.

Multi-pixel Filtering

Multipixel filtering blurs or softens the entire rendered image to help 
eliminate aliasing or jagged edges in rendered images, or roping or 
flicking in rendered animations. 

These options are only available when the “Edge Anti-aliasing” quality is 
set to either High Quality or Highest Quality.

Use Multi Pixel Filter

If on, Maya process, filters, or softens the entire rendered image by 
interpolating each pixel in the rendered image with its neighboring 
pixels, based on the Pixel Filter Type and the Pixel Filter Width X, Y 
settings. 

Pixel Filter Type

Controls how much the rendered image is blurred or softened when 
Use Multi Pixel Filter is on. There are five preset filters to choose 
from—Box Filter (very soft), Triangle Filter (soft), Gaussian Filter 
(only slightly soft), Quadratic B-Spline Filter (the filter used in Maya 
1.0) and Plug-in Filter. The default is Triangle Filter.

To use a custom filter, select Plug-in Filter. 

To create a plug-in filter, ”Create and load a plug-in multi-pixel filter” 
on page 101. 

Note If you are rendering fields, Maya does not filter rendered 
images, even if Use Multi Pixel Filter is on.
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Pixel Filter Width X, Y

Controls the filter width used to interpolate each pixel in the rendered 
image when Use Multi Pixel Filter is on. If larger than 1, it uses 
information from neighboring pixels. The larger the value, the more 
the image is blurred. The valid range is 1 to 3. The default value is 2.2.

Contrast Threshold

Determines adaptive sampling. Controls the number of shading samples 
taken during the second pass computation when Edge Anti-aliasing is set 
to Highest Quality.

Red, Green, Blue

Each color channel is evaluated and if the contrast of the neighboring 
pixel exceeds the threshold, more samples are taken. The valid range 
is 0 to 1. The default values are 0.4 (Red), 0.3 (Green), and 0.6 (Blue). If 
Presets is set to Contrast Sensitive Production, the default values are 
0.2 (Red), 0.15 (Green), and 0.3 (Blue).

Coverage

Only available when 3D Motion Blur is on.

Controls number of Visibility Samples taken during 3D motion blur 
computation. If visibility variation exceeds the threshold, more 
samples are taken. For example, reducing this number helps the 
renderer detect the change of visible objects in a pixel (but also 
increases rendering times). The valid range is 0 to 1. The default value 
is 0.125.

Field Options

Use these options to control how Maya renders images as fields.

Tip The Pixel Filter Width X and Pixel Filter Width Y values do not 
need to be the same; however, to blur the rendered image 
equally in both directions, these values should be the same.

Tips • Reducing RGB values sometimes bring out interesting 
features in rendered images (for example, small highlights or 
shadow boundaries), but can also increase rendering times.

• In relatively colorless images that exhibit shading aliasing 
(for example, gray shadows that look ropy), try setting Red 
to 0.3, Green to 0.2, and Blue to 0.5.
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To find out more about frames and fields, see ”Frames vs. Fields” on 
page 80 and ”Specify frame or field rendering” on page 98. 

Render

Controls whether Maya renders images as frames or fields, which is useful 
for output to video.

Frames Renders regular frames.

Both Fields, 

Interlaced Renders both odd and even fields (for video) and 
automatically interlaces the results into a full frame.

Both Fields, 

Separate Same as above, except no interlacing occurs. The 
result is a sequence of odd and even field images.

Odd Fields Renders odd fields only.

Even Fields Renders even fields only.

Field Dominance

Controls whether Maya renders Odd Fields at time x and even fields at 
time x+0.5, or Even Fields at time x and odd fields at time x+0.5. 

Zeroth Scanline 

(For advanced users only.)

Controls whether the first line of the first field Maya renders is at the top 
of the image or at the bottom. 

Note You can use interlace (IRIX and Linux), or fieldAssembler 
(Windows), or a compositing or NLE application (Mac OS X) to 
interlace the fields. See ”interlace” on page 83 in the Rendering 
Utilities guide for details on interlacing.

Note If the Render Field Option is set to Frames, the Field Dominance 
options are not available. If set to Both Fields Interlaced, Maya 
sets the appropriate field dominance based on the format 
standard (NTSC or PAL).
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Reference > Raytracing Quality
At Top/At 

Bottom At Top is on by default. If you encounter problems 
in an animation where field order appears wrong 
(for example, objects vibrate up and down), change 
the Zeroth Scanline setting and render the 
animation again. If this does not solve the problem, 
or if objects in the animation vibrate left to right, try 
different combinations of Field Dominance and 
Zeroth Scanline, until the problem is solved.

No Field Extension

The attributes in this section do not take effect if the fields are 
interlaced automatically.

No extension is added to odd and even field file names.

Default Field Extension (o and e)

The attributes in this section do not take effect if the fields are 
interlaced automatically.

Maya saves the two field image files by adding an e (for even fields) 
and an o (for odd fields) onto the frame number extension or file 
name. For example, name.001e.iff and name.001o.iff. This is the 
default setting.

Custom Extension

The attributes in this section do not take effect if the fields are 
interlaced automatically.

Set on to specify custom extensions to add to odd and even field file 
names. For example, if you type x, the result is name.001x.iff.

Odd Field The extension to add to odd field file names.

Even Field The extension to add to even field file names.

Raytracing Quality

Controls whether a scene is raytraced during rendering, and controls the 
quality of raytraced images. When you change these global settings, the 
associated material attribute values also change. The resulting value is the 
smaller value of the two attribute settings.

Note If the Render Field Option is set to Frames or Both Fields, 
Interlaced, the Zeroth Scanline options are not available. Maya 
chooses the appropriate setting based on the format standard, 
NTSC or PAL.
Rendering

171



7 | Window, menu, and node descriptions 
Reference > Raytracing Quality
For more information about raytracing, see ”Depth map and raytraced 
shadows” on page 32 in the Lighting guide.

Raytracing

If on, Maya raytraces the scene during rendering. Raytracing can 
produce accurate reflections, refractions, and shadows (this can 
increase rendering times considerably, so try to use sparingly).

Reflections

The maximum number of times a light ray can be reflected. The valid 
range is 0 to 10. The default value is 1. For details, see Reflection 
Limit.

Refractions

The maximum number of times a light ray can be refracted. The valid 
range is 0 to 10. The default value is 6. For details, see Refraction 
Limit.

Shadows

The maximum number of times a light ray can be reflected and/or 
refracted and still cause an object to cast a shadow. A value of 0 turns 
off shadows. 

For example, if the Shadows value is 2, only light rays that have been 
reflected and/or refracted once cause an object to cast a shadow. The 
valid range is 0 to 10. The default value is 2. 

Bias

If the scene contains 3D motion blurred objects and raytraced 
shadows, you may notice dark areas or incorrect shadows on the 
motion-blurred objects. To solve this problem, set the Bias value 
between 0.05 and 0.1. If the scene does not contain 3D motion blurred 
objects or raytraced shadows, leave the Bias value as 0. The valid 
range is 0 to 1. The default value is 0.

Tip If refractions turn black, make sure the refraction limits is set to a 
high enough value and that Visible in Refractions is turned on 
for the object in the Attribute Spreadsheet (Window > General 
Editors > Attribute Spreadsheet) and the Rendering Flags 
window (Window > Rendering Editors > Rendering Flags).
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Motion Blur

When you render an animation, motion blur gives the effect of movement 
by blurring objects in the scene. You can turn Motion Blur on or off for 
objects. Maya uses the relationship between the Shutter Angle and Motion 
Blur attributes to determine how much blur is applied to an object. 

For information about how a camera’s shutter speed/angle affect motion 
blur, see ”Motion blur” on page 30 in the Cameras guide.

Motion Blur

If on, the 3D Motion Blur Type is enabled as well as Blur By Frame. 
This means that moving objects appear blurred. If off, moving objects 
appear sharp. Motion Blur is off by default.

Motion Blur Type

The method Maya uses to motion blur objects. 

2D 2D motion blur is a post-process; Maya blurs each 
object in the image after rendering the entire image 
based on the object’s motion vector (its speed and 
direction). 

3D 3D motion blur is similar to real-world motion blur, 
but takes longer to render than 2D motion blur. The 
default setting is 3D.

Blur By Frame

The amount moving objects are blurred. The higher the value the 
more motion blur is applied to objects. For example, if you motion 
blur by 1 frame, blur is calculated based on the motion of objects from 
one frame to the next; if you motion blur by 4 frames, blur is 
calculated based on the motion of objects every four frame lengths, 
during which time much motion is detected, and therefore much blur 
is applied. The default value is 1. The amount that moving objects are 
blurred is also based on the Shutter Angle of the camera. The length of 
the frame is determined by:

(Shutter Angle/360) * Blur by Frame

The Shutter Angle can be modified in the Special Effects section of the 
Camera’s Attribute Editor.

Blur Length

Scales the amount that moving objects are blurred.The valid range is 0 
to infinity. The default value is 1.
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Blur Sharpness

The sharpness of motion blurred objects. The larger the Blur 
Sharpness, the more spread out the blur. The valid range is 0 to 
infinity. The default value is 1.

Smooth

Alpha/Color Sometimes, anti-aliasing performed by the Smooth 
Value attribute can fail and produce artifacts 
corresponding to edges in the alpha channel of the 
unblurred image. For example, when bright opaque 
objects pass in front of dark light fog. Turning on 
Alpha or Color in such cases eliminates artifacts by 
additionally blurring the objects.

Smooth Value

The amount Maya blurs motion blur edges. The larger the value, the 
more the motion blur is anti-aliased.The valid range is 0 to infinity. 
The default value is 2. 

Keep Motion Vectors

If on, Maya saves the motion vector information for all visible objects 
with the rendered image but does not blur the image. This lets you 
blur the rendered images using the vector data with other 2D blur 
software (for example blur2d). 

If off, Maya blurs the rendered image but does not save the motion 
vector information. Keep Motion Vectors is off by default.

Use 2d Blur memory Limit

You can specify the maximum amount of memory used by the 2d blur 
operation. Maya uses whatever memory is available to finish the 2d 
blur operation.

Tips • Increasing the Smooth Value may also blur the edges of 
static objects, so if you do not want this effect, set Smooth 
Value to 0. 

• You may not want extra blurring all the time, so only use 
this attribute when necessary. You can also try setting 
Smooth Value to 0, which results in less anti-aliasing, but 
that may only be acceptable in some situations.

• For objects shaded with the Ramp Shader, 2D Motion Blur 
provides better results than 3D Motion Blur (artifacting), but 
the Smooth attribute must be set to Color, not Alpha. 
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2D Blur memory Limit

You can specify the maximum amount of memory the operation uses. 
If Motion Blur is on and the Motion Blur Type is set to 2D, the Use 2d 
Blur Memory Limit is on by default and provides a default memory 
limit of 200 MB. This default limit should be sufficient to eliminate 
most problems. However, you can specify the size of the memory cap 
(in MB) in the field provided.

Render Options

Post Processing

Environment Fog

Creates an environment fog node. Environment fog (a Volumetric 
material) is used to simulate the effect of fine particles (fog, smoke, or 
dust) in the air. These particles affect the appearance of the 
atmosphere and the appearance of objects in the atmosphere. See also 
Environment Fog.

For more information on Environment Fog, see ”Environment Fog” on 
page 148 in the Shading guide.

Apply Fog in Post

Only render the fog as a post-process. When on, you can set the Post 
Fog Blur.

Camera

Ignore Film Gate

If on, Maya renders the area of the scene visible in the Resolution 
Gate. If off, Maya renders the area of the scene visible in the Film Gate 
and the region outside is rendered background color. See Camera 
Settings and Film Gate for information on how to viewing the film 
gate boundary interactively. Ignore Film Gate is on by default.

Note The results of this option cannot be seen in IPR. 
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Lights and Shadows

Shadows Obey Light Linking

If on, shadow casting surfaces only cast shadows from shadow casting 
lights with which they are linked. If off, all shadow casting surfaces 
cast shadows from all shadow casting lights, even if they are not 
linked together. Shadows Obey Light Linking is on by default.

Enable Depth Maps

If on, Maya renders all depth map shadows for all lights which have 
depth map shadows turned on. If off, Maya does not render depth 
map shadows. Enable Depth Maps is on by default. 

Color/Compositing

Gamma Correction

Color corrects rendered images according to the following formulas. 
The default value is 1 (no color correction).

Clip Final Shaded Color

If on, all color values in the rendered image are kept between 0 and 1. 
This ensures that no parts of the image (for example, foreground 
objects) are overexposed. If off, color values in the rendered image 
may be greater than 1. Clip Final Shaded Color is on by default.

Jitter Final Color

If on, the image color is jittered to reduce banding. 

Premultiply 

If this option is on (default), premultiplication takes place (see 
”Premultiplied images” on page 84). If this option is off, the 
premultiply threshold option is enabled.

If on, Maya renders objects so that they are not anti-aliased against the 
background. For example, a pixel on the edge of an object is not mixed 
with the background color. (In TIFF terms, Maya generates 
unassociated alpha.) If off, Maya anti-aliases objects against the 
background. Premultiply is off by default.

R = 255 x
R

255

gamma_correction

( )

G = 255 x
G

255

gamma_correction

( )

B = 255 x
B

255

gamma_correction

( )

if R > 255, then R = 255

if G > 255, then G = 255

if B > 255, then B = 255
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Reference > Memory and Performance Options
Premultiply Threshold

If this option is enabled (when the default premultiply is turned off), 
per-pixel color values are output only if the pixel’s alpha channel 
value is above the threshold set here. 

Controls the amount of edge anti-aliasing in a matte if Premultiply is 
on. If you are rendering images for use in a video game, and you are 
using 8 or 16 bit color, set Premultiply Threshold to 1 for smooth 
matte edges, with no jagged edges. The default value is 0.

Memory and Performance Options

The Memory and Performance Options attributes help you optimize 
rendering to make scenes render faster.

For more information on render speed and image quality, see ”Image 
quality and render speed” on page 131.

Tessellation

Helps manage how Maya handles tessellation information for surfaces.

Use File Cache Enables the storing of geometry information into a 
“cache” file in the directory specified by the 
system’s TEMP (Windows and Mac OS X) or 
TMPDIR (IRIX and Linux) environment variable to 
reduce the amount of memory used to store 
geometric data. Turning on this option lets the 
renderer perform its own swapping.

Tip If you are rendering images for film or video, turn Premultiply 
off. If you are rendering images for a video game, turn 
Premultiply on.
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Optimize Instances

If on and the scene contains several identical surfaces (for example, 
instanced surfaces or identical surfaces created independently), Maya 
tessellates only one of them, saving time and disk space. Optimize 
Instances is on by default.

Reuse Tessellations

If on, Maya temporarily saves tessellation information to disk for each 
frame.

Note Use File Cache helps to prevent maxing out memory bandwidth 
and disk space when you are rendering a heavy scene on a 
multi-processor machine.

Before rendering very large, type: 

IRIX and Linux:

setenv TMPDIR NAMEOFDIR

Windows:

SET TEMP=NAMEOFDIR

where NAMEOFDIR is the location of a partition with a lot disk 
space.

Note In the Maya.env file, enter TEMP = defaultPath, where 
defaultPath is the pathname of the new temporary directory.

• (IRIX and Linux). If TMPDIR is set, Maya uses that directory 
unless it has write permission problems, in which case Maya 
defaults to /usr/tmp. If still not able to write to /usr/tmp, a 
warning message appears.

• (Windows). If TEMP is set, it uses that directory provided 
it’s writable. If it’s not writable, a warning message appears.

• (Mac OS X). If TEMP is set, Maya checks for write 
permissions, and the directory if not writable, it defaults to 
using the Documents/temp directory under your Home 
directory. If not able to write to Documents/temp, a warning 
message appears.

If the above still fails to find a temporary directory, a final 
attempt is made to set the current directory you are working in 
as the temporary directory.
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This is useful if a scene contains depth map shadows. For example, 
Maya tessellates surfaces when generating the depth map for a light 
(and saves the tessellation information to disk), and then re-uses the 
tessellation information when generating depth maps for other lights 
and when rendering the frame. (Maya removes the tessellation 
information from disk, and recalculates it for the next frame.) Reuse 
Tessellations is on by default.

Use Displacement Bounding Box

Rendering can take a long time when you use displacement mapping 
because before rendering tiles, Maya tessellates all the displacement-
mapped surfaces and calculates their bounding boxes. When you turn 
on Use Displacement Bounding Box, Maya calculates the bounding 
box scale that you define for all displacement-mapped surfaces. This 
makes rendering faster. When off, Maya pre-tessellates all the 
displacement-mapped objects before rendering. See Bounding Box 
Scale for details.

Ray Tracing

Helps control raytracing. For information on raytracing attributes, see 
Raytracing Quality.

For more information on raytracing, see ”Depth map and raytraced shadows” 
on page 32 in the Lighting guide.

Recursion Depth

Determines how many levels of recursion to use for the raytracing 
voxel data structure of the rendering. For very complex scenes, this 
should be set to 2 or 3. For less complicated scenes, a setting of 1 
should be fine. The default is 2.

Leaf Primitives

Determines the maximum number of triangles to allow in a voxel 
before going to the next recursive level. The default is 200.

Note Reuse Tessellations is an I/O-bound process that can max out 
the bandwidth when running multiple render jobs on the same 
machine. Reuse Tessellations is useful when running up to four 
jobs on a multi-processor machine. You can try turning off 
Render Globals > Use File Cache.
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Subdivision Power

Represents the power that the number of triangles in a voxel is raised 
to in order to calculate how many voxels should be created when 
recursion is required. The default is 0.2500, which should be 
appropriate for most scenes. For extremely complex scenes or scenes 
with complex parts, this value can be increased slightly.

Multi-Processing

Multi-threaded interactive rendering is available for the Render View. It 
provides the same kind of performance gain for the batch renderer. The 
number of CPUs to use for interactive rendering and IPR are set 
separately. Maya saves the value you set with the scene.

For more information, see ”Network render with Maya software” on 
page 148.

Use All Available CPUs

By default, all available CPUs are used. If off, the slider below the 
option is enabled.

Num. CPUs to use

The slider can be dragged from values 1 to 8, but larger values up to 
256 can be entered if needed. Entering a value of 0 or turning the 
option on enables all CPUs for interactive rendering.

IPR Options

These attributes determine which shading elements are saved to disk 
when you perform an IPR render. This can save time and disk space.

For more information on IPR, see ”Interactive Photorealistic Rendering 
(IPR)” on page 67.

Note If you want a Multi-Processor batch render, set the number of 
processors to use in the Batch Render window, or use the -n flag 
(for Maya software rendering), for command line rendering. 

Note If IPR is in use, the number of CPUs cannot be changed until the 
current IPR session is closed. The following warning appears:

// Warning: IPR will need to be closed before this 
change in CPUs will take effect. //
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Render Shading, Lighting and Glow

Determines whether to process shading, lighting and glow 
characteristics of the next IPR Render.

Render Shadow Maps

Depth map shadows are included in IPR renders.

Turn on to show depth map shadows in the scene and be able to 
update them when tuning. Because generating a depth map is a time-
consuming and processor-intensive operation (like a full rendering 
from the light’s point of view), IPR does not automatically generate 
depth maps when you adjust attributes. 

Render 2D Motion Blur

Turn on to adjust 2D motion blur for the next IPR Render. Only 2D 
motion blur is tunable. 

Render Layer/Pass Control

For more information on render layers and passes, see ”Layers and 
passes” on page 83.

Enable Render Layers

Tells the renderer to render only the layers for which renderable is 
turned on. In interactive mode, all layers with renderable turned on 
are rendered into a single image. In batch mode, each layer is output 
to a file named:

camera_filename_layername_passname.ext 

Notes Attributes in the first part of the Depth Map Shadow Attributes 
section of a light’s Attribute Editor affect how the depth map is 
created; you must select IPR > Update Shadow Maps to see the 
effect of changes you make to these attributes.

Attributes in the second part of the Depth Map Shadow 
Attributes section of a light’s Attribute Editor affect how the 
depth map is used; you can adjust these attributes, and see the 
results immediately in your IPR session.

Note For render layer and pass control, Maya Software rendering and 
mental ray for Maya rendering share settings. So, any changes 
you make here are automatically applied to the same section in 
the mental ray for Maya tab. 
Rendering

181



7 | Window, menu, and node descriptions 
Reference > Paint Effects Rendering Options
Enable Render Layer Passes

Available when Enable Render Layers is turned on. 

Allows you to render individual passes for each layer.

When you select this option, the Render Pass Management 
Spreadsheet appears, where you can type ‘on’ or ‘off’ to specify which 
passes you want to render. For information about passes, see ”Layers 
and passes” on page 83.

 

Enable Global Passes

Available when Enable Render Layers is turned off. 

Allows you to render passes for the entire scene. When you select this 
option, the Render Pass Management Spreadsheet appears, where you 
can type on or off to specify which passes you want to render. See 
Enable Render Layer Passes for a description of the types of passes.

Output to Subdirectories

Places files from each separate layer and/or pass into their own 
directory, and any given directory only contains files from the specific 
layer or pass. Files are named:

.../layerName/passName/camera_filename_layername_passname.ext

Paint Effects Rendering Options

For more information about Paint Effects, see ”Painting in Maya” on 
page 17 in the Paint Effects, Artisan, and 3D Paint guide. 

The following describes only render options for the Paint Tool.

Enable Stroke Rendering 

Turn on to render the Paint Effects strokes in the scene. If off, the 
scene renders without strokes. This option is turned on by default. 

Oversample

Renders the Paint Effects at double resolution for better anti-aliasing.

Oversample Post Filter

Applies a weighted filter to the oversampled image for better 
smoothing.
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Only Render Strokes 

Turn on to render only the Paint Effects strokes in the scene. You may 
want to render the strokes separately from the rest of the scene, then 
composite the strokes with the scene. See For more information about 
Paint Effects, see ”Painting in Maya” on page 17 in the Paint Effects, Artisan, 
and 3D Paint guide for details. 

Read This Depth File 

If compositing the rendered scene with rendered Paint Effects strokes, 
type the location and name of the depth file for the rendered scene. 
Use the absolute path name (for example, /h/username/
rainyday.iff (IRIX and Linux), or c:\username\rainyday.iff 
(Windows), or /username/rainyday.iff (Mac OS X)). 

If rendering an animation and have an animated input file, place the # 
character where the frame number is in the source input files. For 
example, for files foo1.iff, foo2.iff, and so on, enter foo#.iff. For 
files foo1, foo2, and so on, enter foo#. When you render, the # 
character is replaced with the current frame number. 

For more information about Paint Effects strokes, see ”Painting in 
Maya” on page 17 in the Paint Effects, Artisan, and 3D Paint guide. 

Note The Oversample and Oversample Post Filter options are 
particularly useful when rendering Paint Effects fur or hair. Also 
the new Mesh Brush Type requires oversample be used to anti-
alias the tube edges if you don’t convert the Paint Effects to 
polygons.

Note When you render strokes only, you must also specify an .IFF file 
in the Read This Depth File field (see next). The file can be 
empty. It does not have to have depth.
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mental ray tab

For information on render global settings, see ”Render Global Settings 
window” on page 159.

Presets

When you select a Preset here, settings in the applicable sections in the 
mental ray tab are automatically set (for example, PreviewGlobalIllum 
turns on Global Illumination and sets other defaults in the Caustics 
and Global Illumination section). 

Use these settings as a starting point for rendering your image at a 
given quality and with a certain effect.

Draft Gives you a relatively good indication as to what 
scene will look like while taking the least amount of 
processing time.

Draft motion 

blur Gives you a relatively good indication as to what 
scene will look like, with motion blur, while taking 
the least amount of processing time.

Preview Slightly better than Draft, takes a little more 
processing time, but achieves a good balance 
between quality and time. 

PreviewCaustics Slightly better than draft (but includes caustics), 
takes a little more processing time, but achieves a 
good balance between quality and time. 

PreviewFinalGat

her Slightly better than draft (but includes final gather), 
takes a little more processing time, but achieves a 
good balance between quality and time. 

Note It is best to supply a depth file and allow Maya Paint Effects to 
do the compositing rather than attempt to composite Paint 
Effects as a post process using a compositor. Maya Paint Effects 
uses a multi-layer depth and RGB buffers to perform the 
compositing with the scene and can achieve a much better 
composite than a post process compositor can achieve.

Also, if you do not supply a depth file (an .IFF file with depth 
information), Paint Effects strokes that are behind objects in 
your scene are rendered. Maya does not overwrite your existing 
images supplied as a depth file—the output is named as shown 
at the top of the Render Global Settings window.
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PreviewGlobalIll

um Slightly better than draft (but includes global 
illumination), takes a little more processing time, 
but achieves a good balance between quality and 
time. 

PreviewFur Slightly better than draft (but renders fur without 
motion blur), takes a little more processing time, but 
achieves a good balance between quality and time. 

If you want to render motion blur with fur, Filter 
Width and Filter Height. 

PreviewMotion

Blur Slightly better than draft (but includes motion blur), 
takes a little more processing time, but achieves a 
good balance between quality and time. 

Production Use this when testing the final rendering or 
rendering the final image(s) that do not contain 
motion blur.

ProductionMoti

onBlur Use this when testing the final rendering or 
rendering the final image(s) that contain motion 
blur.

Anti-Aliasing Quality

Controls how mental ray for Maya anti-aliases objects during rendering. 

For more information about anti-aliasing and image quality, see ”Anti-
aliasing and flicker” on page 131. 

Number of Samples

Min Sample Level

This is the guaranteed minimum number of samples per pixel used 
when processing an image. Based on Contrast Threshold (adaptive) 
settings, mental ray for Maya will increase these samples as needed. 

Max Sample Level

This is the absolute maximum number of samples per pixel used 
when processing an image. 
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Multi-pixel Filtering

Filter

This is processing performed on the results of the sampling to blend 
pixels into a coherent entity. Black and white = noisy. Filtering looks 
at neighboring info and unifies the two. 

Box Filter The fastest way to get relatively good results.

Triangle 

(default) More processor intensive than box, but offers even 
better results.

Gaussian Filter Produces the best results, but is the slowest to 
render.

Mitchell, 

Lanczos Mitchell (clip) and Lanczos (clip) are alternatives to 
Gaussian that offers slight variations in contrast 
(tends to increase). Mitchell increases less than 
Lanczos.

Because “plain” Lanczos and Mitchell may produce 
negative values the new filter types are “clipped” 
variants to ensure positive values. The filtered result 
samples are clipped to the min/max range of input 
samples. The final pixel in the image will therefore 
not contain any out-of-range values _produced by 
the filter_, as might be the case for regular Mitchell 
and Lanczos filters.

Filter Width 

Controls the filter width used to interpolate each pixel in the rendered 
image. The larger the value, the more info from neighboring pixels. 
The larger the value, the more the image is blurred. The value should 
be at least 1.

Filter Height 

A multiplier on the final value of the image.

Contrast Threshold 

Lowering these values increases sampling (up to the Max Sample 
Level), which results in higher quality but longer processing time. 
Depending on the actual contrast of the image, you may not be able to 
get better results (that is, results are limited by the amount of 
contrast). 
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Sample Options

Sample Lock 

Locks the location in which you sample within pixels. When turned 
on, this option ensures that the sub-pixel samples occur at the same 
location within in each pixel, which is important to help eliminate 
noise and flickering results. Turn it off only if you get sampling 
problems, such as moire patterns.

Jitter

Reduces artifacts by introducing systematic variations into sample 
locations. Without jittering, samples are taken at the corners of pixels 
or subpixels; jittering displaces the samples by an amount determined 
by lighting analysis.

Raytracing

Ray Tracing

If on, mental ray for Maya raytraces the scene during rendering. 
Raytracing can produce the most physically accurate reflections, 
refractions, shadows, global illumination, caustics and final gather.

Reflections

The maximum number of times a ray can be reflected off reflective 
surfaces.

See also Max Trace Depth.

Refractions

The maximum number of times a ray can be refracted through non-
opaque surfaces. 

See also Max Trace Depth.

Max Trace Depth

While the Reflections setting and Refractions setting each set the 
maximum number of times a ray can reflect or refract (respectively), 
this setting sets total number of penetrations that can occur regardless 
of whether the penetration is a result of reflection or refraction.  

Tip If refractions turn black, make sure Refraction is set to a high 
enough value. 
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example, if reflections = 5, refractions = 5, but max depth trace = 4, 
then any combination of reflection and refraction bounces can take 
place, up to a maximum of 4.

Shadow Trace Depth

The maximum number of times a shadow rays will penetrate a non-
opaque object.

Scanline

Scanline rendering is used as a faster way (in most cases) of rendering. 
By default, mental ray for Maya uses this option when possible; 
however, in some cases, you may want to turn it off to force mental 
ray for Maya to raytrace (such as when you want to use less memory).

On, Off  Turn scanline rendering on or off

OpenGL Attempts to optimize the rendering further with 
openGL graphics hardware in your workstation

Rapid A substantially faster motion blur algorithm 
alternative.

Faces

Determines whether to render double-sided or single-sided for the 
entire scene. 

Both Works especially well if volume effects are used. 

Front Only front-facing (that is, the side whose normal 
vectors face away from) are rendered. 

Back Only back-facing are rendered. 

Shadows

Shadow Method

Off Disables all shadows.

Simple Enables simple shadows, which are standard for the 
provided libraries. This is the most efficient of the 
three shadow modes. 

If shadows overlap because multiple objects obscure 
the light source, the order in which these objects are 
considered (and their shadow shaders are called) is 
undefined. If one object completely obscures the 
light, no other obscuring objects are considered. 

Sort Enables shadow sorting. 
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Similar to Simple, it ensures that the shadow 
shaders of obscuring objects are called in the correct 
order, object closest to the illuminated point first. 
This mode is slightly slower but allows custom 
shadow shaders to record information about 
obscuring objects. If no such custom shader is used, 
this mode offers no advantage over simple shadow 
on.

Segments Like Sort, the shadow shaders are called in order. 
Shadow rays are traced much like regular rays, 
passing from one obscuring object to the next, from 
the light source to the illuminated point; each such 
ray is a shadow segment. 

Use this mode if you want volume effects (like 
fluids, particles, fur and smoke) to cast shadows. 

This mode requires support from the shadow 
shader, which must use the mi_trace_shadow_seg 
function to cast the next shadow ray segment.

Shadow Maps

On/Off Turns shadow maps on or off.

Shadow map parameters are specified for each light 
source. The default is off because shadow maps, 
while often significantly faster, always assume 
opaque objects. 

opengl mode  Causes mental ray for Maya to use OpenGL 
acceleration (if available with your graphics 
hardware) when rendering shadow maps. 

The same limitations apply as mentioned with the 
Scanline option. Shadow maps rendered with this 
option contain slightly different information from 
those generated with the regular (On) algorithm, 
and the soft areas of shadows tend to be smaller. 
Some areas may incorrectly be determined to not be 
in shadow. 

When OpenGL rendering of shadow maps is 
enabled, only the local workstation (master) 
participates since the computation cost of the map is 
so small that the networking overhead would be 
more costly.

Rebuild Shadow Maps

Determines whether all shadow maps are recomputed. 
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If this option is off (the default) shadow maps are loaded from files or 
reused from previously rendered frames if possible. If this option is 
on, no shadow map is reused (that is, everything is recomputed). 

Motion Blur Shadow Maps

Determines whether shadow maps should be motion blurred so that 
moving objects cast shadows along the path of motion. 

Turning this option off (default is on) can cause shadow maps to 
render slightly faster. (Note that since shadow maps do not deal with 
transparent objects and motion blurring introduces a form of 
transparency at the edges, shadow map shadows can appear too large 
in the direction of motion if the object moves quickly.)

Motion Blur

See also ”mental ray for Maya motion blur” on page 29.

Calculation

See also ”mental ray for Maya motion blur” on page 29.

Motion Blur

Turns motion blur on (linear or exact) or off. Linear only considers the 
position of objects at the Shutter beginning and end point (open and 
close points), then does a linear interpolation based on the objects to 
simulate. It is fast but limited.

Exact is slower to render, but gives true (that is, exact) motion blur 
results.

Motion Blur By

This is a multiplier used to amplify the motion blur effect. Increasing 
this value reduces the realistic results achieved, but may produce an 
enhanced effect if that’s what you want to achieve. 

Linear motion blur Exact motion blur
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The higher the value, the longer the time interval used in the motion 
blur’s computation. 

Shutter, Shutter Delay

Defines the point at which the shutter closes within the frame interval. 
to control motion blurring. 

The camera shutter opens at time delay3.1 and closes at time shutter. 
The defaults are both 0.0. If shutter is equal to delay, motion blurring 
is disabled; if shutter is greater than delay, motion blurring is enabled. 
The normal range is (0, 1), which uses the full length of the motion 
vectors or motion vector paths3.1. It can be useful to set delay3.1 and 
shutter both to 0.5, which disables motion blurring but renders with 
an offset of one half frame, which allows bidirectional post-blurring in 
an output shader.

Time Contrast R

These settings determine a threshold for adaptive time sampling. 
Lower values cause more time samples, which result in more accurate 
motion blur but increased render times.

Motion Steps

See also diagram in ”Shutter, Shutter Delay” on page 191.

If motion blurring is enabled, mental ray can create motion paths from 
motion transforms, much like multiple motion vectors on vertices can 
create motion paths. 

Note The mental ray for Maya renderer draws its shutter setting from 
here in the Render Globals Settings window, unlike the Maya 
renderer (for which the shutter setting is on the camera). 

shutter delay shutter

motion blur 
(steps)

frame interval

motion blur 
(steps)
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This option specifies how many motion path segments should be 
created for all motion transforms in the scene. The number must be in 
the range 1 to 15. The default is 1. 

Caustics and Global Illumination

Caustics

Turn caustics on or off (default). Caustics are produced only by light 
sources for which photon emission is enabled. The material shader 
(which must have a non-zero diffuse component) that receives the 
caustics must be set to receive caustics. 

Caustic Accuracy

Controls the number of photons used to estimate the caustic 
brightness. The default is 64. Higher settings (up to 100 to start, tested 
in small increments) larger numbers make the caustic smoother. 

Caustic Radius

Controls the maximum distance at which mental ray for Maya 
considers photons for caustics. When left at 0 (the default), mental ray 
for Maya calculates an appropriate amount of radius, based on the 
bounding box size of the scene. If the result is too noisy, increasing 
this value (to 1 to start, then by small increments up to 2) decreases 
noise but gives a more blurry result. To reduce the blur, you must 
increase the number of caustic photons (Caustic Accuracy) emitted by 
the light source. 

Caustic Filter Type

Controls the sharpness of the caustics. 

Filtering increases the weight of photons that are close to the point of 
interest, and reduces the amount of blur at the edges of a caustic. 

Box  Generally makes caustics looks sharper. It is faster, 
but less precise. 

Cone Generally makes caustics looks smoother. It is more 
precise, but slower. 

Caustic Filter Kernel

The bigger the kernel, the softer the caustic.

Global Illumination

Use this to turn on or off (default) Global illumination, a process that 
allows for indirect lighting and effects like color bleeding. The default 
is off. 
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Global illumination is computed only for light sources for which 
photon emission is enabled. 

Global Illum Accuracy

Change the number of photons used to compute the local intensity of 
global illumination. The default number is 64; larger numbers make 
the global illumination smoother but increase render time. 

Global Illum Radius

Controls the maximum distance at which mental ray for Maya 
considers photons for global illumination. When left at 0 (the default), 
mental ray for Maya calculates an appropriate amount of radius, 
based on the bounding box size of the scene. If the result is too noisy, 
increasing this value (to 1 to start, then by small increments up to 2) 
decreases noise but gives a more blurry result. To reduce the blur, you 
must increase the number of global illumination photons (Global 
illumination Accuracy) emitted by the light source. 

Photon Volume Accuracy

Controls how the photon map is used to estimate the intensity of 
caustics or global illumination within a participating medium. It 
applies to photon volume shaders, which compute light patterns in 
3D space, such as volume caustics created by focused shafts of light 
cast by objects acting as lenses. 

Photon Volume Radius

Controls the maximum distance at which mental ray for Maya 
considers photons for a participating medium. 

Max Reflection Photons

Use this to limit the number of times a photon will reflect in a scene 
(after the first bounce, which is taken care of by direct illumination). It 
works in conjuction with Max Photon Depth. 

Max Refraction Photons

Use this to limit the number of times a photon will refract in a scene 
(after the first bounce, which is taken care of by direct illumination). It 
works in conjuction with Max Photon Depth. 

Max Photon Depth

Use this to limit the number of times a photon will bounce around 
(reflect or refract) after the first bounce (which is taken care of by 
direct illumination) in a scene. 
Rendering

193



7 | Window, menu, and node descriptions 
Reference > Final Gather
Default is 5, but correct value depends on how many surfaces the 
photon must go through or bounce off of before hitting a diffuse 
surface to stop. For example, if a photon goes through 6 transparent 
surfaces, the default 5 would produce incorrect results. After the 
depth trace limit has been met, photons are not reemitted and instead 
are absorbed.

Custom shaders may override these values. 

Photon Map File

Specify the photon map file that mental ray for Maya should use as 
the current photon map. It will be loaded and used without 
computing a new photon map. If the photon map file does not exist, 
one will be created and saved. 

Photon Map Rebuild

If a filename is specified for the photon map (in Photon Map File), the 
map is loaded and used (providing the file exists). If this option is 
turned on, any existing file will be ignored, and the photon map will 
be recomputed and an existing file will be overwritten. The default is 
off. In other words, if you want to build a map, turn this option on; if 
not, turn this option off and specify the file to be used in Photon Map 
File

Direct Illumination Shadow Effects

This should be turned ON if you use transparent shadows with 
Global illumination and/or caustics. 

Final Gather

Final Gather

Use this to turn Final gathering for global illumination on or off. The 
default is off. Final gathering is a different means of calculating 
indirect illumination. For more information, see ”Final gather” on 
page 27 in the Lighting guide.

Precompute Photon Lookup

This option (which also turns on Final Gather) causes photon tracing 
to compute and store an estimate of the local irradiance at every 
photon location. This means that far fewer final gathering points are 
required because the photon map carried a good approximation of the 
irradiance in the scene -- mental ray for Maya can estimate irradiance 
with a single lookup, instead of many photons. In this case, photon 
tracing takes longer than before and requires slightly more memory, 
but rendering is faster. 
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Final Gather Rays

Controls how many rays are shot in each final gathering step to 
compute the indirect illumination. The default is 1000 per sample 
point, but this tends to be high for test renders (renders can take 
hours). Test rendering at lower values, usually 100 or 200, is sufficient; 
higher values are required for final renders. Increasing the value 
reduces noise but also increases the rendering time. 

Min Radius, Max Radius

Max Radius and Min Radius control the size of the sampling region 
within which Final Gather rays search for irradiance information from 
other surfaces. 

With the default values, Maya calculates values that seem appropriate 
based on scene dimensions to speed up the render, but this calculation 
doesn’t allow for complex geometry. Generally, enter a value that is 
10% of scene’s overall dimension for the Max Radius, then enter 10% 
of that for Min Radius. Make further adjustments based on scene 
geometry detail, how the geometry is arranged in the scene, and how 
the render looks. For example, use these settings to achieve better 
diffuse detailing in nooks and crannies in your scene.

Filter

Use this to control how Final Gather uses a speckle elimination filter 
to prevent samples with extreme brightness from skewing the overall 
energy stored in a Final Gather sampling region. 

Neighboring samples are filtered so that extreme values are discarded 
in the filter size. By default, the filter size is 1. Setting this to 0 disables 
speckle elimination, which can add speckles but will better converge 
towards the correct total image brightness for extremely low accuracy 
settings. Size values greater than 1 eliminate more speckles and soften 
sample contrasts. Sizes greater than 4 or so are not normally useful. 

Note When the number of Final Gather rays is changed, the Final 
Gather File is always ignored and new Final Gather rays are 
emitted. 

You can see, in the Output window, when this happens: 

• RCFG 0.2 info: finalgMap/test1:final gather options differ 
from ones currently used, content ignored. 

• RCFG 0.2 info: overwriting final gather file "finalgMap/
test1" 
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Falloff Start, Falloff Stop

Use these settings to limit the reach of indirect light for Final Gather 
(but not photons). If no object is found within a distance of start, the 
ray defaults to the environment color. Objects farther away than stop 
from the illuminated point will not cast light. 

Trace Depth

Use this option to specify the number of subrays for the final gather 
render. The default is 0, which means that indirect illumination 
computed by final gathering cannot pass through glass or bounce off 
mirrors, for example. A depth of 1 would allow a single refraction or 
reflection. Typically, a depth greater than 2 is not necessary. 

Trace Reflection

Use this to limit the number of times subrays will reflect in a scene. It 
works in conjuction with Trace Depth. 

Trace Refraction

Use this to limit the number of times subrays will refract in a scene. It 
works in conjuction with Trace Depth. 

Final Gather File

This is the file that stores the Final Gather results that mental ray for 
Maya can use for irradiance lookups. You can re-use Final Gather 
results from a frame rendered earlier, or from a previous scene render:

• If no filename is specified and Final Gather Rebuild is turned on,   
rendered results are placed in a default file. 

• If you specify previously non-existent filename, the rendered 
results are placed in the file with that name.

• If you specify an existing filename here, and Final Gather Rebuild 
is turned on, the specified file is overwritten with the newly 
rendered Final Gather results.

• If you specify an existing filename here, and Final Gather Rebuild 
is turned off, the newly rendered results are appended to the 
existing file. (This means that the file may grow without bounds.)

Final Gather Rebuild

If this is on (default), any previously generated Final Gather file is 
ignored and all final gather points are recomputed. See Final Gather 
File for more information about the file. 
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If this file is off, Final Gather is forced to use the results from a 
previous Final Gather render. 

Preview Final Gather Tiles

If turned on, this setting lets you see tiles as they render. That is, you 
can see the image as it renders. 

Diagnostics

Diagnose Samples

Shows how spatial supersamples were placed in the rendered image, 
by producing a grayscale image signifying sample density. This is 
useful when tuning the level and the contrast threshold for spatial 
supersampling.

Diagnose Grid

Renders a grid on top of all objects in the scene, in object, camera, or 
world space. Gives you an idea of the scene scale and rough estimates 
of distances and areas.

Grid Size

Defines the size of the grid (in Diagnose Grid). 

Tip If you are rendering out a still image and are not changing the 
Final Gather settings, turn this attribute off to save rendering 
time.

Tip If you are rendering out a camera animation sequence, you may 
be able to use previous frames’ Final Gather results (that is, you 
can turn this attribute off), depending on how the irradiance 
changes during the animation.  

However, if objects in the scene move, this option must be on. 
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Diagnose Photon

Photon Density

Shows a false color rendering of photon density on all materials. This 
is useful when tuning the number of photons to trace in a scene, and 
to select the optimum accuracy settings for estimation of global 
illumination or caustics. It also works well in combination with the 
Grid Mode.

Diagnose BSP

Shows the cost of creating and traversing the BSP tree used for 
raytracing. Both the depth and the leaf size can be visualized. If the 
diagnostic image shows that mental ray has been operating near the 
limit in large parts of the image (indicated by red or white pixels), this 
helps tuning the BSP parameters in the options block.

Features

Turn these options off, to globally disable the following features in your 
scene. 

Overrides

Use these options to globally override per-object settings for tessellation, 
caustics, and global illumination.

Tessellation

Use these options to create and assign a Surface and/or Displace 
approximation globally to the scene. 

Caustics/Global Illumination

Turn caustics and global illumination generators and receivers on or off 
for the entire scene. 

Contours 

For more information about these options, see ”Integrated contour 
rendering” on page 272 in the What’s New guide for Maya 6.0. 

Custom shaders

Use these options to connect Contour Store and Contour Contrast shaders. 

Image Based Lighting

Create an IBL node to render sky-like (infinite distance) illumination and/
or reflection. 
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For more information on Image Based Lighting and the IBL node, see 
”Rendering Image-Based Lighting (sky-like illumination)” on page 282 in the 
What’s New guide for Maya 6.0.

Framebuffer Attributes

Data Type

Select the kind of information the framebuffer contains.

Gamma

Use this setting to apply gamma correction to rendered color pixels to 
compensate for output devices with a nonlinear color response. 

All R, G, B, and alpha component values are raised to 
1overgamma_factor. The default gamma factor is 1.0, which turns 
gamma correction off. 

Colorclip

Controls how colors are clipped into a valid range [0, 1] before being 
written to a non-floating point frame buffer or file. 

In all modes, the RGB components are clipped as specified by the 
desaturate option. The RGB and alpha modes ensure that the resulting 
color is a valid premultiplied color. 

RGB (default) RGB is first clipped to [0, 1] and alpha subsequently 
to [max(R, G, B), 1].  Use RGB if the alpha channel is 
considered less important than preserving the RGB 
color and intensity.

Alpha mode Alpha is first clipped to [0, 1] and RGB subsequently 
to [0, A]. Alpha mode is intended for alpha 
compositing, where the alpha channel is more 
important than the absolute color value to preserve 
correct transparencies.

Raw RGB and A are both clipped to [0, 1] independently 
of each other. Use Raw mode only if no layering 
based on alpha is going to take place. This mode 
turns Premultiply on, so use it with care because 
shaders might receive colors that cannot be 
composited in standard ways.

Interpolate Samples

Desaturate

If a color is output to a frame buffer that does not have 32-bit 
(floating-point) precision, and its RGB components are outside the 
range [0, max], mental ray clips the color to this legal range. 
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If desaturation is turned off (on by default), the individual 
components are simply clipped into range. Otherwise, mental ray tries 
to maintain the brightness of the color by moving it towards the 
grayscale axis of the color cube, until the RGB components are in the 
legal range. max is determined by the colorclip mode. 

Premultiply

If this option is on (default), premultiplication takes place (see 
”Premultiplied images” on page 84). 

If on, Maya renders objects so that they are not anti-aliased against the 
background. For example, a pixel on the edge of an object is not mixed 
with the background color. (In TIFF terms, Maya generates 
unassociated alpha.) 

The premultiply off option instructs mental ray to always store colors 
unpremultiplied into frame buffers and files. This option is ignored if 
the colorclip raw mode is in effect.

Dither

mental ray for Maya supports 8, 16, or 32 bits per color component. In 
some cases, 8 bits per pixel, as supported by all popular picture file 
formats, can cause visible banding when the floating-point color 
values calculated by the material shader are quantized to the 8-bit 
values used in the picture file. Dithering mitigates the problem by 
introducing noise into the pixel such that the round-off errors are 
evened out. Note that this can cause run-length encoded picture files 
to be larger than without dithering. Dithering is turned off by default

Memory and Performance

Contains options for managing memory and performance during mental 
ray for Maya rendering. 

Acceleration Method

BSP (default) 

Nested voxels

1

1

1

2

22

3
3 3
3
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The BSP (binary space partitioning) acceleration 
method recursively subdivides 3D space into a 
nested set of voxels, small boxes with triangles in 
them. It is efficient, but careful attention should be 
given to the size and depth parameters, which can 
have a large impact on speed and memory usage.

See also ”Use average BSP (mental ray for Maya) 
settings” on page 136.

Grid The Grid acceleration method subdivides on a 
regular grid in space. Its memory usage is more 
predictable, but it may be slower if the geometry is 
not evenly distributed in the scene.

BSP Size

Determines the maximum number of triangles in one bsp voxel. If you 
decrease this number, you will have more voxels and a heavier bsp 
structure, resulting in higher memory usage and better performance. 

BSP Depth

Determines the maximum number of voxel subdivisions. 

Grid Resolution

If the hierarchical grid algorithm is used, this option sets the number 
of grid voxels. 

mental ray for Maya can use subgrids to subdivide voxels with many 
triangles, so that scenes with dense concentrations in specific areas do 
not need force the increase of the global number of voxels just to 
capture the regions of high density. A grid resolution of 2 lets the grid 
algorithm degenerate to an octree algorithm. 

Grid Max Size

If the hierarchical grid algorithm3.1 is used, this option sets the 
maximum number of triangles in a grid voxel. If there are more, and 
the grid depth permits it, the voxel is subdivided into a subgrid. Note 
that size int must really be an integer; a floating-point value causes the 
statement to be ignored and a warning to be printed. 

Grid Depth

If the hierarchical grid algorithm3.1 is used, this option sets the 
number of recursion levels. If a voxel of a grid contains too much 
detail, it is subdivided by a subgrid for that voxel, which adds another 
level. The default is 2 for two levels (subdivided voxels cannot be 
subdivided again). 
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Task Size

Please refer to the mental ray User Manual, available from the Maya 
help, for more information about this setting.

Memory Limits

Physical Memory

Physical Memory defaults to 800 in mental ray for Maya. A guideline 
is to set it to 80% of physical memory. (In this case, we assume 1 GB. If 
you have more, increase this value accordingly.) 

Translation

Contains options for specifying the settings and items to be included 
when rendering a Maya scene with mental ray for Maya. 

Export Verbosity

Messages equal to or below the selected severity are displayed, both 
from the translation process (in the script editor) and mental ray (in 
the console window). If progress messages are enabled (at the very 
least), then the Maya progress bar updates accordingly during 
standard and lightmap rendering. 

Export Exact Hierarchy

Tries to preserve the DAG hierarchy during processing. This produces 
additional mental ray instgroup entities. There are certain unresolved 
material inheritance issues in this mode, but it works well in the 
general case. Deeply nested DAG hierarchies may be translated much 
faster compared to the standard Maya iterator mode that always 
flattens the DAG. Default is off.

Export Full Dagpath

Uses the full DAG path names instead of the shortest possible name 
for mental ray scene entities. This is not required to generate a valid 
scene, but ensures reproducible names even if DAG entity names are 
reused in Maya. On the other hand, with deeply nested DAG 
hierarchy names, you may exceed the maximum supported name 
length in mental ray. Default is off.

Export Textures First

Collects all file texture references in the scene first. This ensures that 
missing texture files are reported early in the process, but may slow 
down scene processing depending on the number of file textures 
being used. It may also write out textures references that are never 
used in the shading graph, because it doesn't perform a complete 
scene graph traversal for performance reasons. Default is on.
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Export Particles

Lets you export particles.

Export Particle Instances

Lets you export particle instances.

Export Fluids

Lets you export fluids.

Export Post Effects

Lets you export post effects.

Performance

(Performance options are within the Translation section.)

Please refer to the mental ray User Manual, available from the Maya 
help, for more information about this setting.

Prune Invisible Parts

Ignore invisible scene entities during processing completely. They are 
not part of the final mental ray scene. This option needs to be turned 
off to export primary invisible scene objects that contribute to 
rendering in other ways, for example, casting shadows. Default is on.

If you animate the visibility, this option must be turned off.

Optimize Vertex Sharing

This is to produce a more compact vertex representation (vertex lists) 
for meshes that exhibit a lot of vertex sharing. Only first-level sharing 
is exploited in mental ray for Maya. 

Export Shape Deformation

Compare actual geometry to determine any kind of shape 
deformation during animation and motion blur, required to produce 
exact motion blur information and support incremental changes in 
mental ray. If none of these conditions are true, turning this off may 
speed-up scene processing. Default is on.

Export Polygon Derivatives

Calculate and export first order derivatives for polygons. This is 
required for bump mapping and shader filtering to producer 
comparable results to Maya. Default is on.

Export Nurbs Derivatives

Enable calculation of first order derivatives for NURBS objects in 
mental ray. This is required for bump mapping and shader filtering to 
produce comparable results to Maya. Default is on.
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Customization

(Customization options are within the Translation section.)

Please refer to the mental ray User Manual, available from the Maya help, 
for more information about this setting.

Render Globillum Global Pass 

If this setting is enabled and if render pass enabled (in the last section 
of this tab), then mental ray for Maya can render global illumination 
and caustics in a separate pass from direct illumination.

Photons Obey Light Linking

Photon emission respects relationships between lights and objects 
defined by light linking. Default is off.

Optimize Raytrace Shadows

If global illumination or caustics is on, to be physically correct, any 
shadow shader in your scene is ignored. However, in cases where you 
need the shadow shader to work together with global illumination 
(for example, with colored or transparent shadows), enable this 
setting. 

Export State Shader

This should only be turned off when exporting to .mi file and only the 
standard mental ray base shaders are used exclusively (for example, 
when no Maya shaders are used). Default is on.

Export Light Linker

This controls the export of the Maya light linker node. Default is on.

Export Maya Options

This enables the export of special options as mental ray user data, to 
control several advanced Maya features performed in the mayabase 
shaders. Default is on.

Export Custom Colors

Common mental ray shaders often use 4-component RGBA color 
parameters instead of the usual 3-component Maya color compounds. 
With this option enabled all custom nodes are provided with full 
RGBA colors, with the alpha component set to 1.0 (fully opaque). 
Default is off.

Export Custom Text

This should only be turned on for .mi file export to recognize and 
translate Custom Text nodes. It is automatically turned off for the 
integrated rendering if Preview Custom has been turned off.
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Export Custom Data

If enabled, special custom attributes on polygon meshes are 
recognized and exported as vertex user vectors to mental ray. 

Export Custom Vectors

This option enables recognition of an optional miCustomMotion 
boolean dynamic attribute on geometry shape nodes. If such an 
attribute has been found then motion vectors are always generated 
and exported, even if they are of zero length. This is required for 
certain mental ray shaders that are allowed to perform motion blur 
calculation in the shader, for example for displacement motion blur. 

Export Custom Motion, Motion Object Output, Motion Back Offset

Allows adaptations of the start and end time steps where motion blur 
information is captured. The default corresponds to Maya, where the 
scene is evaluated half of the shutter interval times the Motion Blur By 
value moved back and forth from the current frame time. When this is 
turned on, you can set Motion Object Output and Motion Back Offset.

Preview

Contains options for specifying what to include in a preview render in 
Render View. 

Please refer to the mental ray User Manual, available from the Maya help, 
for more information about this setting.

Preview Animation

Render subsequent frames of the set animation range and preview all 
intermediate images inside Render View. 

Preview Motion Blur

Calculate and preview render motion blur if enabled in the Render 
Globals. The Preview Animation option doesn’t need to be turned on 
for this to work. 

Preview Render Tiles

Updates the Render Preview window in regular time intervals to 
show render progress. If this is turned off, only the final image is 
shown at the end of rendering. 

Preview Custom

Preview render custom text and vertex data. It requires custom 
shaders and its declarations to be loaded first. It's off by default. 
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Custom Entities

Contains controls for creating and managing custom global text, textures, 
and scene element text. 

Please refer to the mental ray Shaders Guide, available from the Maya help, 
for more information about this setting.

Custom Globals

These allow for the customized output of version, link, and include 
statements. If these text boxes are empty, mental ray for Maya generates 
the usual default statements that are required for rendering Maya scenes. 
Otherwise, it expects a space separated list of entries, which are exported 
in the appropriate section of the mi stream instead of the defaults. 

In the version text box, the first entry is written as the min version, the 
second entry as the max version statement. 

The include text 

base.mi mayabase.mi

in the text box results in: 

$include "base.mi"
$include "mayabase.mi"

in the final output. 

The same happens for the link text. 

Custom Scene

Custom Global Text 

Custom global text control is especially useful for adding custom link, 
$include and code statements. It can also be used to add texture and 
shader declarations.

Within a scene many types of text nodes can be created, but just the 
selected one gets exported. The contained text is written once at the 
beginning of the .mi stream right before the first option block gets 
written. Certain modes are available which determine how the custom 
text should be applied to the generated output. 

Note that incorrect .mi text could be introduced that cannot be 
recognized nor corrected by mental ray for Maya processing. 

Custom Options Text

Similar to Custom Global Text, Custom Options Text is provided to 
allow customized mental ray option settings. It offers the ability to 
extend or replace the generated option settings. For example, custom 
framebuffer statements should be added here. 
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Custom Lights, Cameras, and Scene Text

These enable custom text on certain sequentially exported sections like 
lights section, camera section, and scene section, in this order. Those 
sections can be extended or completely replaced, similar to the 
Custom Globals. For example, custom lights can be appended to the 
generated output. This would require that the scene section be 
extended with the incremental change of the new root instance group 
including the new light. 

Render Layer/Pass Control

Lets you enable render layers and render passes. 

Maya Hardware tab

For information on the render global settings, see ”Render Global Settings 
window” on page 159.

Quality

For more information about render speed and image quality, see ”Image 
quality and render speed” on page 131.

Presets

When you select a Preset here, settings in the applicable sections in the 
rest of the tab are automatically set. 

Use these settings as a starting point for rendering your image at a 
given quality and with a certain effect.

At higher quality settings, objects appear smooth, but may take more 
time to render. At lower quality settings, objects may appear a little 
more jagged, but render quickly. 

Custom Lets you specify the hardware quality settings 
independently. 

Preview 

Quality The Enable edge anti-aliasing is set to off.
The number of samples is set to 1. 
Color texture resolution is set to 128.
Bump texture resolution is set to 256. 

Intermediate

Quality  The Enable edge anti-aliasing is set to on.
The number of samples is set to 3. 
Color texture resolution is set to 256. 
Bump texture resolution is set to 512. 
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Production

Quality The Enable edge anti-aliasing is set to on.
The number of samples is set to 9. 
Color texture resolution is set to 512. 
Bump texture resolution is set to 1024. 

Number of Samples

Lets you select the exact number of samples per pixel used to control 
the anti-aliasing of objects during rendering. 

For software rendering, each pixel is sampled first in the center, then 
slightly off center for subsequent samples. For hardware, each pixel is 
sampled in the center. For subsequent samples, the image is then 
rerendered slightly offset, and each pixel is sampled in the center 
again. The images are then aligned to produce the final image. 

Transparent Shadow maps

Transparency sorting

The method by which sorting is performed prior to rendering to 
improve transparency.

Per object  Transparent objects are sorted and drawn from 
furthest to closest in distance. This option provides 
faster results buy may not render complex 
transparent objects correctly.

Per polygon  Each object's polygons are sorted and drawn from 
furthest to closest in distance from the viewer. This 
option provides more accurate transparency 
representation but may take longer to process.

Color Texture Resolution

If hardware rendering cannot directly evaluate a shading network, the 
shading network is baked to a 2D image that the hardware renderer 
can use. This option specifies the dimension of the baked image for 
supported mapped color channels on a material. Supported channels 
include color, incandescence, ambient, reflected color, and 
transparency. The default value is 128, which means that any baked 
color images have dimensions 128 by 128 pixels.

Bump Texture Resolution

If hardware rendering cannot directly evaluate a shading network, the 
shading network is baked to a 2D image that the hardware renderer 
can use. This option specifies the dimension of the baked image for 
supported bump maps, which typically must be of a higher resolution 
Rendering 

208



7 | Window, menu, and node descriptions

Reference > Render Options
than that used for mapped color channels. The default value for this 
option is 256, which means that any baked bump images have 
dimensions 256 by 256 pixels.

Render Options

For more information about render layers and passes, see ”Layers and 
passes” on page 83.

Culling

Lets you control the type of culling used for rendering.

Per object  The culling option is based on the per object settings 
found in the Render Stats section of the selected 
object’s Attribute Editor. The current options are:

Double Sided renders double sided lighting with the 
current normals on the object.

Single Sided renders with single sided lighting with 
the current normals on the object.

Opposite renders with single sided lighting with the 
reversed normals on the object. 

All Double 

sided 

Forces all objects to render using the Double Sided 
option, whether or not you set that option on the 
object. Single Sided offers better rendering 
performance than Double Sided.

All Single sided  

Forces all objects to render using the Singled Sided 
options whether or not you set that option on the 
object. If the Opposite suboption is enabled then 
that suboption is used. Single Sided offers better 
rendering performance than Double Sided.

Small Object Culling

When this performance-improving option is enabled (default), opaque 
objects that are smaller than the specified threshold are not drawn. 

This option provides the same functionality as the Occlusion Culling 
option found in High Quality Rendering mode in viewports. 
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Culling 

Threshold (% of 

image size) This is the threshold suboption for the Small Object 
Culling option. The threshold you provide is the 
percentage of the image size that an object occupies 
in the output image. 

If an object is less than that percentage in size then it 
is not drawn. Size is measure in pixels in screen 
space (relative to the camera used for rendering). 
The default percentage is 0 percent. 

This option ignores View->Camera Settings options 
(such as Gate and Fill options), which are used for 
image output only.

E.g. % = 10.0. Image size 100 by 100 (pixels). The 
threshold in pixels would be 100X100 * .10 = 1000 
pixels. If an object was less than 1000 pixels in size 
then it would not be drawn. 

E.g. % = 0.0 Image size 100 by 100 (pixels). The 
threshold in pixels would be 100X100 * 0 = 0 pixels. 
If an object was less than 0 pixels in size then it 
would not be drawn. This can occur when one 
opaque object completely obscures another object 
with respect to the current camera used for 
rendering.

Motion Blur

If this option is on, you can change Motion Blur by Frame option and 
the Number of Exposures option. 

Motion Blur by Frame 

In the hardware renderer, motion blur is achieved by rendering the 
scene at specific points in time and blending the resulting sample 
renders into a single image. 

Blur by frame represents the absolute time range, starting from the 
current frame, that is blurred. This determines the approximate start 
and end times of the blur. This time range is then adjusted in 
accordance with the camera’s Camera Shutter Angle attribute in the 
Attribute Editor.

Number of Exposures

The number of exposures divides the above time range determined by 
the Motion Blur by Frame option into discrete moments in time, 
where the entire scene is re-rendered. The final image is the 
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accumulated average of all the exposures. So to obtain a smooth blur, 
a larger number of exposures is desired. Similarly, for a motion trail, a 
smaller number of exposures is preferable.

Enable Geometry Mask

For hardware rendering. When this option is turned on, opaque 
geometry objects mask out particle objects, and transparent geometry 
is not drawn. This is especially useful when compositing particles 
over software-rendered geometry.

Render layers

Enable Render Layers

Tells the renderer to render only the layers for which renderable is 
turned on. In interactive mode, all layers with renderable turned on 
are rendered into a single image. In batch mode, each layer is output 
to a file named:

camera_filename_layername_passname.ext 

Maya Vector tab

To select a renderer to see the Maya Vector tab, see ”Select a renderer” on 
page 25. Render global settings that apply to all renderers are in the 
Common tab.

For information on the render global settings, see ”Maya Vector renderer” 
on page 22.

Image Format Options

Frame Rate (SWF and SVG only)

The frame rate of the Flash Player file or SVG file (measured in frames 
per second).

Flash Version (SWF only)

The version of the rendered Flash Player file: Flash 3, Flash 4, or 
Flash 5. The rendered Flash Player file plays back in any version of the 
Flash Player (and import into any version of the Flash authoring 
application) that is equal to or greater than the Flash Version.

Note This option is only available when Image Format is SWF or SVG.
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Open in Browser (SWF only)

Displays the vector image or animation in your default browser after 
it is rendered (using Render > Current Frame, Render > Batch Render, 
or mayaVectorRender.

Combine Fills and Edges (SWF only)

When Combine Fills and Edges is on, outlines and fills for a surface 
are a single object. If you import the file into the Flash authoring 
application, you cannot separate the outlines and fills unless you 
break apart the object. However, the size of the rendered file is smaller 
than when Combine Fills and Edges is off.

When Combine Fills and Edges is off, outlines and fills for a surface 
are separate objects. If you import the file into the Flash authoring 
application, you can separate the outlines and fills without breaking 
apart the object. However, the size of the rendered file is larger than 
when Combine Fills and Edges is on.

Note This option is only available when Image Format is SWF.

Note When Flash Version is Flash 4, and Fill Style is Area Gradient or 
Mesh Gradient, the rendered animation contains a dummy 
frame at its beginning. (This is to compensate for a limitation in 
the Flash 4 authoring application.) After importing your 
animation into the Flash 4 authoring application, delete this extra 
frame.

Note You must have the Flash browser plug-in installed on your 
system in order to display the rendered image or animation.

Note This option is only available when Image Format is SWF.

Note This option is only available when Image Format is SWF.
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Svg Animation (SVG only)

If Svg Animation is Native, Maya creates one SVG file containing the 
frames of your animation and the scripting that drives it.

If Svg Animation is Script, Maya creates an SVG file containing the 
frames of your animation and an HTML file containing the JavaScript 
that drives it.

If your animation is long (approximately 40 frames or more), file size 
increases when Svg Animation is Native.

Compress (SVG only)

Compresses the rendered SVG file, significantly reducing its file size.

If you plan to publish the SVG file directly to the web, you may want 
to turn on Compress. If you plan to import the SVG file into another 
application and edit it, turn off Compress. You cannot edit a 
compressed SVG file.

Appearance Options

Curve Tolerance

A value from 0 to 10 that determines how object outlines are 
represented with either curved lines or a series of straight line 
segments.

When Curve Tolerance is 0, object outlines are represented by a series 
of straight line segments (one segment for each polygon edge). This 
produces an outline that exactly matches the outline of polygons, but 
also produces larger file sizes.

When Curve Tolerance is 10, object outlines are represented by curved 
lines. This produces an outline that may appear slightly distorted 
compared to the original object’s outline, but also produces smaller 
file sizes.

You may need to adjust the Curve Tolerance setting on a scene by 
scene basis to produce the best compromise between outline accuracy 
and file size. Begin by setting Curve Tolerance to 7.5 (the default). If 

Note This option is only available when Image Format is SVG.

Note This option is only available when Image Format is SVG.
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the rendered file size is too large, try increasing Curve Tolerance. If 
object outlines appear distorted, or the animation appears jumpy 
where there are curved outlines, try decreasing Curve Tolerance.

Detail Level Preset, Detail Level

Determines the level of detail in the rendered image. A High Detail 
Level (30) produces a more detailed image and a more accurate render 
than a Low Detail Level (10), but takes longer to render and increases 
file size. (When the Detail Level is low, small polygons are combined 
with adjacent polygons.)

You may need to adjust the Detail Level on a scene by scene basis to 
produce the best compromise between image quality and file size. 
Begin by setting Detail Level to Low, and increase it as necessary to 
produce acceptable image quality.

Set Detail Level to Automatic to allow Maya to choose the appropriate 
level of detail for your scene.

Set Detail Level to Custom and use the numeric field or slider to set 
the Detail Level to any value between 1 and 50. (Setting Detail Level 
to 0 is the same as choosing the Automatic preset.)

Fill Options

Fill Objects

Surfaces are shaded based on the Fill Style. To render surfaces as 
unfilled outlines, turn off Fill Objects and turn on Include Edges.

Fill Style

The style of shading used to fill surfaces in the rendered image.

Note Adjusting the Curve Tolerance value may have no apparent 
effect on file size when another setting (for example, Fill Style) is 
the dominant factor affecting file size.

Note Doubling the Detail Level value produces twice as much detail 
in the rendered image.

Note Setting Detail Level less than 4 is not recommended.
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For all fill styles (except Single Color) the fill color is based on surface 
material color and lighting from point lights only; all other types of 
lights are ignored. If your scene does not contain point lights, a 
default point light (located at the camera) is automatically created 
during rendering (and removed after rendering).

Single Color

Fills each surface with one solid color based on the surface material 
color.

Single Color can produce nice cartoon-like results, especially when 
your model is composed of separate surfaces that each have a 
different colored material.

Two Color

Note Surface fills are re-calculated for each frame and may appear to 
change, shift or jump during an animation.

Note The Single Color fill color is actually based on the surface 
material color and an ambient light (located at the camera) that is 
automatically created during rendering (and removed after 
rendering). Therefore, the fill color may not exactly match the 
surface material color. The fill color should not change during an 
animation.

Tip For better definition of surface edges, turn on Edges.

1 KB

5 KB
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Fills each surface with two solid colors based on the surface material 
color and on scene lighting.

Two Color produces results that look slightly more 3D than Single 
Color, but also produces larger file sizes.

Four Color

Fills each surface with four solid colors based on the surface material 
color and on scene lighting.

Four Color produces results that look even more 3D than Two Color 
or Single Color, but also produces much larger file sizes.

Full Color

Fills each polygon on a surface with one solid color based on the 
surface material color and on scene lighting.

Full Color produces realistic 3D results, but also produces very large 
file sizes. (The greater the number of polygons in your model, the 
greater the file size.)

Tip For geometric objects that consist of many flat planes (for 
example, a cube), Two Color may produce unnatural looking 
results (that is, each flat surface is filled with two solid colors). 
For such objects Average Color is usually more appropriate.

Tip For geometric objects that consist of many flat planes (for 
example, a cube), Four Color may produce unnatural looking 
results (that is, each flat surface is filled with four solid colors). 
For such objects Average Color is usually more appropriate.

9 KB

124 KB
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Average Color

Fills each surface with one solid color based on the surface material 
color and on scene lighting.

Area Gradient (SWF and SVG only)

Fills each surface with one radial gradient based on the surface 
material color and on scene lighting.

Area Gradient can produce nice 3D effects with a small increase in file 
size.

Tip If you want to produce a high level of detail, and file size is not 
an issue, Mesh Gradient usually produces better results than Full 
Color.

Note Full Color is the highest quality fill style available when 
rendering to AI and EPS formats.

Tip For objects that are divided into surfaces with hard edges, 
Average Color often produces the best combination of 3D effect 
and modest file size, especially when the object is animated.

For smooth, organic objects that have few surfaces defined by 
hard edges, Average Color does not usually produce results that 
are any better than Single Color.

3 KB

4 KB
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Mesh Gradient (SWF and SVG only)

Fills each polygon on a surface with a linear gradient based on the 
surface material color and on scene lighting.

Mesh Gradient produces very realistic 3D results, but also produces 
very large file sizes. (The greater the number of polygons in your 
model, the greater the file size.)

Mesh Gradient is the highest quality fill style available when 
rendering to SWF and SVG formats.

Tip For scenes that contain faceted objects (objects composed of 
many distinctly defined surfaces), Area Gradient produces very 
good results.

For scenes that contain a combination of flat and smooth 
surfaces, Area Gradient produces a nice balance of fills. The 
smooth surfaces are filled with gradients, and the flat surfaces 
are filled with a more even color.

For scenes that contain only smooth surfaces, Area Gradient may 
produce an overwhelming number of gradient fills.

Note This option is only available when File Format is SWF or SVG.

Note This option is only available when File Format is SWF or SVG.

Note In certain rare situations shading may be incorrect when Fill 
Style is Mesh Gradient. For example, a plane having a ramp 
texture applied to it may render with an area of solid color. Try 
adjusting the texture very slightly and re-rendering.

294 KB
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Show Back Faces

Surfaces with normals facing away from the camera are rendered as if 
they were facing the camera. When Show Back Faces is off, surfaces 
with normals facing away from the camera are not rendered.

Shadows (SWF and bitmap formats only)

Object shadows are rendered (based only on shadow-casting point 
lights in your scene). Shadows can greatly enhance the 3D effect. 
However, shadows also increase file size and significantly increase 
render time.

Note Surfaces with normals facing away from the camera may not be 
visible, even if Show Back Faces is on, if another surface is 
between it and the camera.

Tip Turning off Show Back Faces may decrease rendering times and 
file size.

Note When Shadows is turned on, shadows are rendered for all 
objects. You cannot render shadows only on certain objects (for 
example, by turning off Casts Shadows or Receive Shadows for 
an object). 

Note Shadows are only rendered if there is a shadow-casting point 
light in your scene (that is, a point light that has Use Depth Map 
Shadows or Use Ray Trace Shadows turned on).

Note You cannot set the shadow color. 

Shadows ON Shadows OFF
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Highlights (SWF and bitmap formats only)

Specular highlights are rendered (based only on point lights in your 
scene and on surface material shininess). (When Fill Style is Single 
Color, specular highlights are based on the position of point lights in 
your scene. Changing the intensity or color of point lights does not 
change the appearance of highlights.)

Regions of surfaces that are close to being perpendicular to a point 
light are filled with a number of concentric solid color regions (based 
on surface material Specular Color and on the Highlight Level value) 
that are lighter than the rest of the surface.

Note Shadows are not cast onto surfaces with transparent materials. 

For this 
material...

Surface shininess is based only 
on...

Anisotropic Roughness

Blinn Eccentricity

Phong Cosine Power

Phong E Roughness

Note This option is only available when Fill Style is Single Color, 
Average Color and Area Gradient.

Note Highlights are only rendered if there is a point light in your 
scene that has Emit Specular turned on.

Highlights ON Highlights OFF
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Highlight Level (SWF and bitmap formats only)

The number of concentric solid color regions used to represent 
specular highlights. The valid range is 1 to 8. The default value is 4.

Reflections (SWF and bitmap formats only)

Surface reflections are rendered (based on the surface material 
Reflectivity).

Reflection Depth (SWF and bitmap formats only)

The maximum number of times a surface can inter-reflect with other 
surfaces. The valid range is 1 to 4. The default value is 2.

Note If a surface material’s Specular Color is mapped with a texture, 
the color of the highlight is based on the texture’s Default Color. 
If a surface material’s Specular Color is mapped with a utility 
node, the color of the highlight is white.

Note This option is only available when Highlights is on.

Note This option is only available when Reflections is on.

Highlight Level = 1 Highlight Level = 8

Reflections ON Reflections OFF
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Edge Options

Include Edges

Surface edges and silhouettes are rendered as outlines.

Edge Weight Preset, Edge Weight

The thickness of surface outlines (measured in points).

Tip To render surfaces as unfilled outlines, turn off Fill Objects and 
turn on Include Edges.

Note Edges are not rendered on surfaces with transparent materials. 

Note When File Format is SWF, changes in Edge Weight less than 1 
Point are not noticeable unless you zoom into the outline.

Include Edges ON Include Edges OFF

Edge Weight = 2 pt Edge Weight = 8 pt
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Edge Style

When Edge Style is Outline, surface edges and silhouettes are 
rendered as outlines. (Use Detail Edges to also render sharp polygon 
edges as outlines.)

When Edge Style is Entire Mesh, all polygon edges are rendered as 
outlines. Entire Mesh produces very large file sizes. (The greater the 
number of polygons in your model, the greater the file size.)

Edge Color

The color of surface outlines.

Hidden Edges

Surface edges that are behind another surface are visible in the 
rendered image. (This may make certain objects look transparent or 
make models appear as wireframes.)

Hidden Edges increases rendered file size because of the extra vector 
information.

Edge Detail

Sharp edges between polygons are rendered as outlines. The 
Min Edge Angle controls which polygon edges are rendered as 
outlines.

Tip If you are rendering a model with many polygons, avoid turning 
on Hidden Edges and setting Edge Style to Entire Mesh; too 
many lines will likely appear in the rendered image.

Edge Style = Outline Edge Style = Entire Mesh

Hidden Edges ON Hidden Edges OFF
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Edge Detail can help define the shape of a 3D object, especially when 
the object is composed of few surfaces, but also produces larger file 
sizes.

Min Edge Angle

Determines which polygon edges are rendered as outlines when 
Edge Detail is on. Min Edge Angle is the minimum angle (measured 
in degrees) that two adjacent polygons’ normals must have in order 
for their common edge to be rendered as an outline.

Decreasing the Min Edge Angle produces larger file sizes because of 
the extra vector information in the rendered file.

Render Layer Control

Enable Render Layers

Renders and saves each renderable render layer as a separate file 
(named filename_layername) when batch rendering.

Render View

Render View menu bar

You can access these items from pop-up menus by right-clicking in the 
panel. 

Note This option is only available when Edge Style is Outlines.

Note This option is only available when Edge Style is Outlines.

Note If Enable Render Layers is on, shadows and reflections are not 
cast between objects in different render layers.

Edge Detail OFF Edge Detail ON, Min Edge Angle = 10
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Some menu items are renderer-specific. For example, IPR menu items do 
not appear for Maya hardware rendering.

For more information on Render View, see ”Render View rendering” on 
page 71.

File menu

Open Image

Loads images from disk into Render View. Images usually end with 
suffixes indicating their image format.

Save Image

Saves the image to disk in the /images directory (as specified by your 
current project management settings). 

Open IPR File

Opens the file browser to the iprImages directory from where you 
can open a saved IPR file into Render View. 

Save IPR File

Saves the current IPR file to the iprImages directory. 

Close IPR File

Closes the IPR file on which you are working and ends the current 
IPR session. 

Render Diagnostics

The Render Diagnostics window appears providing you with valuable 
information about how to improve performance or avoid certain 
limitations. You can run the diagnostics while experimenting with 
different settings, or before you start final rendering.

Keep Image in Render View

Keeps the current image so you can view it later. When you keep 
more than one image, a slider displays at the bottom of the window 
letting you bring a specific image into view without loading the 
image. The images are lost when you end your Maya session.

Note Make sure the IPR file you load corresponds to the current scene 
file. If the name of a surface in the IPR file does not match a 
corresponding surface in the current scene, you are unable to 
adjust the shading characteristics of that surface.
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Remove Image from Render View

Releases the current image (and the memory needed by it) from 
Render View. Select the image that you want to remove using the 
slider. 

View menu

Frame Image

Frames the image you are rendering to fit Render View. 

Frame Region

Frames the region you marquee to fit Render View. 

Real Size

Automatically adjusts the view so the zoom factor is 1.0, and each 
pixel of the image occupies one pixel on the display. 

Show Region Marquee

Displays the red render region marquee.

Reset Region Marquee

Resets the render region marquee to surround the entire image.

Grab Swatch to Hypershade/ Visor

Use to customize Hypershade swatches. A customized swatch lets 
you quickly access a scene and all its associated attributes.

Render menu

Redo Previous Render

Renders the same view you last rendered. If you rendered a region the 
last time, Redo Previous Render renders the entire image. 

Select the option, drag a 
marquee around the region you
want to display on a swatch,
then middle-drag from the
Render View over the swatch
in Hypershade.
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Render Region

When you draw a marquee around an area in Render View, select this 
option to render only that area. This is useful if you’ve made a change 
to part of the surface on which you want to perform a quick test 
render. 

Render

Opens a menu from which you can choose the view to render. 

Snapshot

Does not work when IPR rendering. Opens a menu from which you can 
choose the view. A wireframe snapshot is taken of the view you select 
and loaded as a background into Render View. You can then marquee 
a region to render in front of the snapshot’s background and select the 
Render Region icon. 

IPR menu

For Maya software rendering only.

For details on IPR, see ”Interactive Photorealistic Rendering (IPR)” on 
page 67.

Redo Previous IPR Render

IPR renders the same view last IPR rendered.

IPR Render

Opens a menu, from which you can choose the view to IPR render. 

Update Shadow Maps

Regenerates shadow maps and updates the IPR image. You cannot 
interactively adjust shadow maps. 

Update Image Planes/Background

Updates the marquee IPR region with any changes you make to the 
image plane. If you don’t select this option after you make changes to 
an image plane, the effects of the changes are not visible in IPR until 
you either perform a new IPR render or marquee a new tuning region.

Tip Zoom into the view you select if you want to see the results up 
close.
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Refresh IPR Image

Completely updates (re-shades) the entire image based on all changes 
you have made. The refresh occurs a bit at a time because loading all 
samples for the entire image often uses too much memory.

IPR Tuning Options

Specifies what characteristics of the scene update interactively as you 
adjust. These options are related to the IPR Options in the Render 
Global Settings window. For example, if you turn off Render Shading, 
Lighting, and Glow in Render Global Settings window, you cannot 
adjust them.

Update Shading 

and Lighting If on, the IPR image updates whenever you adjust 
an attribute for shading networks, lights, or when 
you make shading group assignments or move 
lights.

Update Shader 

Glow If on, the IPR image updates whenever you adjust a 
shader glow (post-process) attribute. 

Update Light 

Glow If on, the IPR image updates whenever you adjust 
lighting or light glow attributes, or move a light.

Update Motion 

Blur If on, the IPR image updates whenever you adjust 
2D motion blur attributes. Modifying the scene’s 
animation (for example, to make an object move 
faster and increase the blur) does not affect the IPR 
image’s motion blur because modifying the 
animation changes the information that was 
generated during the initial IPR render (motion 
vectors are changed), which is a change to the 
visibility calculation. You have to perform a new 
IPR render to see the results.

Pause IPR Tuning

Pauses the updating of the selected IPR region in the Render View.

Options menu

Some menu items are renderer specific. For example, the Ignore Shadows 
menu item does not appear for Maya hardware rendering.

Render Globals

Opens the Render Global Settings window when test-rendering (not 
IPR).
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Test Resolution

Select the resolution at which you want to render the image. Use a 
reduced resolution to test render the scene if possible. See also ”Test 
render a low-res still or frame” on page 111 or ”Test render a low-res 
animation” on page 111

Auto Resize

Allows Render View to resize the image each time you render. When 
on, always displays the rendered image in the center of Render View, 
and at real size if the image fits (one to one pixel matching). When off, 
the image always displays in the same place according to the last 
view. 

Auto Render Region

When on, renders the image as soon as you finish dragging a marquee 
in Render View. This can make rendering a region a one-step process: 
drag a render region, and when you release the mouse button the 
region is immediately rendered.

Ignore Shadows/Ignore Glows

Tells Maya not to test-render any shadows or glows in the scene. This 
can speed up test-rendering.

Display menu

Red Channel, Green Channel, Blue Channel

Displays the red, green, or blue channels only.

All Channels

Displays RGB channels.

Luminance

Displays a weighted average of R, G, and B planes that define the 
luminance level of the image.

Mask Channel

Displays the mask channel only. 

Dithered

Turn off Dithered to display the best version of a image. Turn on 
Dithered to display a dithered image (does not flicker when 
displayed). Dithered is on by default.

Toolbar

Shows/hides the Render View toolbar. Toolbar is on by default.
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Render View toolbar

You can use the rendering buttons in the Status Line in Maya’s main 
window, or use the buttons in the Render View toolbar to perform various 
operations. 

Some tools are renderer specific. For example, the IPR tools appear only 
for Maya software rendering.

For more information on Render View, see ”Render View rendering” on 
page 71.

Redo Previous Render

Renders the same view you rendered last. If you rendered a region 
the last time, Redo Previous Render renders the entire image.

Render Region

Renders only the region with a marquee. This is useful if you’ve 
made a change to part of the surface on which you want to perform a 
quick test render. See ”Render a region of your scene” on page 113 for 
details.

Redo Previous IPR Render

IPR renders the same view last IPR rendered.

Refresh the IPR Image

Completely updates the entire image based on all changes you 
have made. The refresh occurs a bit at a time—loading all the samples 
for the entire image may use too much memory.

Open Render Globals Window

Opens the Render Global Settings window.

Display RGB Channel

Displays the image with RGB channels. This is the default display 
mode.

Display Alpha Channel

Displays the image’s alpha channel only. See Use Background and 
Matte Opacity for a few examples of how this option is used.

Display Real Size

Displays the image at its real resolution. See also ”Test render a 
low-res still or frame” on page 111.
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Keep Image

Keeps the current image so you can view it later. When you keep 
more than one image, a slider displays at the bottom of the window. 
Drag this slider to bring a specific image into view without loading 
the image. 

Remove Image

Releases the current image (and the memory it needs) from Render 
View. Select the image you want to remove using the slider at the 
bottom of the window.

Show Render Diagnostics in the Script Editor

Click the icon after you adjust objects, and before you re-render. 
The Script Editor that displays provides valuable information about 
how you can improve performance. You can run the diagnostics while 
experimenting with rendering settings, or before you start the final 
render. 

Pause IPR Tuning

Pauses the updating of the selected IPR region in the Render View.

Close IPR File and Stop Tuning

Closes the current IPR file and ends the current IPR session.

Rendering Flags window

Rendering Flags window

The Rendering Flags window (Window > Rendering Editors > Rendering 
Flags) lets you list the elements in your scene and provides you with a 
way to set the attributes for the nodes you select.

Note The extra images are lost when you end your Maya session.
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Rendering Flags Show list

Click the down arrow to display the Show menu, then select an item or 
items for which you want a list of attributes.

The attributes for these items are listed in the right panel where you can 
change and set them, much like in the Channel Box.

Rendering Flags window panels

The Rendering Flags window contains two panels. The left panel lists the 
items you select from the Show menu, and the right panel lists the 
attributes for the selected items. In the left panel, click the list item for 
which you want to change or set the attributes and the details display in 
the right panel. 

To set attributes for multiple nodes in the Rendering Flags 
window

You can change or set attributes for several related objects by selecting 
them in the left panel, and setting the attribute value in the right panel. 
For example, if you want to turn the visibility off for two NURBS spheres 
in the scene, select both spheres from the left panel and type off beside 
Visibility in the right panel.
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Reference > Use the hardware render buffer
Once you change an attribute for a selected item, the heading changes 
color in the list reminding you of the change.

Hardware Render Buffer

Use the hardware render buffer

The Hardware Render Buffer (Window > Rendering Editors > Hardware 
Render Buffer) lets you render an animation using your computer’s 
display graphics card. Hardware rendering is much faster than software 
rendering, although the result may be of lower quality. You can use the 
Hardware Render Buffer to preview animations, or to render specific 
types of particle effects. 

Note The Hardware renderer, with its greater capabilities, is now 
recommended to perform hardware rendering. See ”Maya 
Hardware renderer” on page 16.

Note Render Sequence will not render particles successfully if the 
Render Passes and “Motion Blur” options (found in the Multi-
Pass Render Options section of the Hardware Render Buffer 
Attribute section) are equivalent integers. For example, if Render 
Passes is set to 3 and Motion Blur is set to 3, hardware particle 
rendering will not work. 

Set them to non-equivalent values or to use the Disk Cache 
option (Solvers > Create Particle Disk Cache).
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To open the Hardware Render Buffer

• Select Window > Rendering Editors > Hardware Render Buffer.

To set options for the Hardware Render Buffer

• In the Hardware Render Buffer, click Render > Attributes. For a 
description of the options, see ”Hardware Render Buffer” on page 233

To determine hardware rendering quality

1 In the Shading menu in the view panel, make sure Smooth Shade All 
and Hardware Texturing are selected.

2 In Hypershade, double-click the material swatch you want to preview 
to open its Attribute Editor. 

3 In the Hardware Texturing section of the material’s Attribute Editor, 
the Textured channel menu contains the attributes you can hardware 
render. Select the Textured channel you want to view from the menu. 

Note When the overscan attribute of the camera is anything other than 
1.0, image planes are positioned incorrectly in the hardware 
render buffer (as can be seen compared to the correct placement 
in software rendering). 

To work around this limitation, temporarily set the overscan to 
1.0 when hardware buffer rendering. 

Important

The Hardware Render Buffer renders images based on your 
monitor’s display (using screen captures). Before rendering from 
the Hardware Render Buffer, make sure the Hardware Render 
Buffer fits on your monitor, make sure no other window 
overlaps the Hardware Render Buffer, and disable your 
computer’s screen saver.
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4 Select the resolution you want from the Texture resolution menu.

Use the flipbook

(IRIX, Linux, and Windows only) 

The Flipbook lets you play back a rendered sequence of images. The 
sequence is displayed using the fcheck utility. To use the Flipbook, see 
”Use the flipbook” on page 235.

To play back a rendered sequence of images

• Select the sequence from the Flipbooks menu. The sequence is 
displayed using the fcheck utility.

Notes • You can only view one channel at a time. 

• To view an attribute, it must be mapped to a texture. 
Attributes that are not mapped are dimmed.

• Some channels, such as Bump Map, do not provide 
hardware textured results. You must use Render View to see 
the results.

A file texture is mapped 
to a material’s Color Texture channel

At the Highest resolution
the result can take more
time to render, but it is
a good indication of
what the final scene
will look like.
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Hardware Render Buffer global settings

Image Output Files

File name

The base name for all hardware rendered image files. The default file 
name is im.

Extension

The format of the extension(s) added to the base name for all rendered 
image files. Options with ext include the Image Format in the 
extension. The default setting is name.001.

Start Frame, End Frame

The first and last frame to render. The default value for Start Frame is 
1. The default value for End Frame is 10.

By Frame

The increment between frames you want to render. For instance, if By 
Frame is set to 1, the Hardware Render Buffer renders frames 1, 2, 3, 
etc. If set to 2, it renders 1, 3, 5, etc. The default value is 1.

Image Format

The format for saving hardware rendered image files. The default 
setting is Maya IFF.

Resolution

The resolution of hardware rendered image files. Click the Select 
button to select a preset image resolution. 

Alpha Source

The type of alpha information saved with the hardware rendered 
images. Alpha information represents the opacity of each pixel, and is 
used for compositing images using compositor software. (Alpha 
information is also referred to as alpha channel, mask, matte, or alpha 
buffer.) If you do not plan to composite hardware rendered images, 
set Alpha Source Off. The default setting is Off. 

Write ZDepth

If Write ZDepth is on, the hardware rendered contains depth 
information (the distance of objects from the camera). Write ZDepth is 
off by default.
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Reference > Image Output Files
Alpha Source table

Tip Depth information is sometimes necessary when compositing 
images (for example, compositing hardware rendered particles 
that pass behind a software rendered transparent object). If you 
do not plan to composite hardware rendered images, or do not 
require depth information for compositing, turn off Write 
ZDepth. 

Off Alpha information is not included in hardware 
rendered images.

Hardware Alpha Assigns each pixel an alpha value based on its 
opacity, regardless of its brightness or color. The 
more opaque a pixel is, the more opaque it appears 
in the image’s alpha channel.

Setting Alpha Source to Hardware Alpha only has 
an effect if your computer has a hardware alpha 
buffer. If it does not have a hardware alpha buffer 
and you set Alpha Source to Hardware Alpha, the 
alpha channel of hardware rendered images is fully 
opaque.

Luminance Assigns each pixel an alpha value based on its 
brightness. The brighter a pixel is, the more opaque 
it appears in the image’s alpha channel.

Red Channel Assigns each pixel an alpha value equal to the value 
of its RGB red component. The higher a pixel’s red 
value is, the more opaque it appears in the image’s 
alpha channel.

Green Channel Assigns each pixel an alpha value equal to the value 
of its RGB green component. The higher a pixel’s 
green value is, the more opaque it appears in the 
image’s alpha channel.

Blue Channel Assigns each pixel an alpha value equal to the value 
of its RGB blue component. The higher a pixel’s blue 
value is, the more opaque it appears in the image’s 
alpha channel.
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Reference > Render Modes
Render Modes

Lighting Mode

Controls how objects are lit during hardware rendering. The default 
setting is Default Light.

Default Light

A default directional light illuminates the scene in the direction that 
the camera faces.

All Lights

The lights in the scene (up to a maximum of eight lights) illuminate 
the scene.

Selected Lights

The lights in the scene that you’ve selected (for example, in the 
Outliner) illuminate the scene.

Draw Style

Controls how objects are hardware rendered. (If Geometry Mask is on, 
Draw Style has no effect.) The default setting is Smooth Shaded.

Points

NURBS surfaces are rendered as points evenly spaced along surface, 
polygonal surfaces are rendered as points (corresponding to vertices), 
and particles are rendered as points.

Wireframe

Surfaces are rendered in wireframe.

Flat Shaded

Surfaces are rendered as flat shaded polygons.

Smooth Shaded

Surfaces are rendered as smooth shaded polygons using a Phong 
material.

Clamp Assigns each rendered pixel an alpha value of 1 (fully 
opaque), and each unrendered pixel an alpha value of 
0 (fully transparent).

Inverse Clamp Assigns each rendered pixel an alpha value of 0 (fully 
transparent), and each unrendered pixel an alpha 
value of 1 (fully opaque).
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Reference > Render Modes
Texturing

If on, textures are hardware rendered. Texturing is on by default.

Line Smoothing

If on, sharp, jagged edges on surfaces and streaks on Streak or 
MultiStreak particles are softened. Line Smoothing is off by default.

Full Image Resolution

If on and Resolution is greater than the monitor’s resolution (the 
hardware rendered images cannot fit on the screen), the Hardware 
Render Buffer divides the image into tiles, renders each tile separately, 
then assembles the tiles together when it saves the image to disk. If 
you are rendering an animation, the Hardware Render Buffer displays 
each tile as it renders it.

If off and Resolution is greater than the monitor’s resolution, the 
Hardware Render Buffer only renders the part of the image displayed 
on the monitor.

Geometry Mask

When off, surfaces are hardware rendered. When on, Maya masks out 
all geometry by setting the mask values to 0. Pixels of the rendered 
image belonging to any geometry have a zero opacity in the image’s 
alpha channel. Geometry Mask is off by default.

Display Shadows

Turn this on to display shadows from directional and spot lights for 
geometry (NURBS, polygons, subdivision surfaces) and particles 
(points, multipoints, and spheres only). This is available only when 
All Lights or Selected Lights are specified in the Lighting Mode drop-
down list. 

Note These hardware shadows can be calculated and displayed on 
graphics cards with drivers that support the ARB_multitexture 
and EXT_texture_env_combine OpenGL extensions (such as 
graphic cards with NVidia GeForce or Quadro GPU, or ATI 
Radeon 8800).
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Multi-Pass Render Options

Multi Pass Rendering

If off, the Hardware Render Buffer renders each frame using one pass. 
If on, the Hardware Render Buffer renders each frame using more 
than one pass (based on the Render Passes setting, next). This softens 
or blurs particles with a MultiStreak or MultiPoint Render Type. Multi 
Pass Rendering is off by default.

Render Passes

The number of passes the Hardware Render Buffer uses to render 
each frame. The more passes per frame, the greater the softening or 
blurring of particles with a MultiStreak or MultiPoint Render Type 
(and a longer rendering time). Render Passes is only available if Multi 
Pass Rendering is on. The default setting is 3.

Anti-Alias Polygons

If on, sharp, jagged surface edges are softened (anti-aliased) during 
hardware rendering. This option only works if Multi Pass Rendering 
is on and the computer hardware supports anti-aliasing. Anti-Alias 
Polygons is off by default.

Edge Smoothing

Controls how much sharp, jagged surface edges are softened (anti-
aliased) during hardware rendering when Anti-Alias Polygons is on. 
The higher the value, the softer the edges.

Set Edge Smoothing to 1 for clear, smooth edges. If Edge Smoothing is 
too large (for example, 5), surface edges are excessively blurred. An 
Edge Smoothing value of 0 has the same effect as turning off Anti-
Alias Polygons. The default value is 1.

Motion Blur

Controls how much objects are motion blurred. The higher the Motion 
Blur value, the greater the motion blur effect. A Motion Blur value of 0 
means no motion blur. A value of 0.5 means the shutter is open for 
half the frame duration. The default value is 0.

Tip If the Motion Blur value is greater than 0, set the Render Passes 
value to at least the Motion Blur value minus 1. For example, if 
the Motion Blur value is 4, set the Render Passes value to at least 
3.
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Reference > Display Options
Display Options

Controls which icons are hardware rendered, and the background color 
for hardware rendered images.

Grid

If on, the grid is hardware rendered. Grid is off by default.

Camera Icons

If on, any camera icons visible in the Hardware Render Buffer are 
rendered. Camera Icons is off by default.

Light Icons

If on, any light icons visible in the Hardware Render Buffer are 
rendered. Light Icons is off by default.

Emitter Icons

If on, any emitter icons visible in the Hardware Render Buffer are 
rendered. Emitter Icons is off by default.

Field Icons

If on, any field icons visible in the Hardware Render Buffer are 
rendered. Field Icons is off by default.

Collision Icons

If on, any collision icons visible in the Hardware Render Buffer are 
rendered. Collision Icons is off by default.

Transform Icons

If on, any transform icons (from the translate, rotate, or scale tools) 
visible in the Hardware Render Buffer are rendered. Transform Icons 
is off by default.

Background Color

The background color for hardware rendered images. The default 
color is black.

Tip If the Motion Blur value is greater than 0, set the Render Passes 
value to at least the Motion Blur value minus 1. (For example, if 
the Motion Blur value is 4, set the Render Passes value to at least 
3.) 
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Hardware Render Buffer menus

File menu

Contains the Close option. Either click the box at the top right of the 
window or select this option to close the Hardware Render Buffer 
window.

Render menu

Contains options for setting rendering attributes, rendering a frame or 
sequence of frames, and controlling the display of the Hardware 
Render Buffer.

Attributes Opens the Attribute Editor and displays Hardware 
Render Buffer Render Globals. For details, see 
”Hardware Render Buffer” on page 233.

Test Render Test-renders the current frame in the Hardware 
Render Buffer.

Render 

Sequence Select to render the current animation.

Scale Buffer Scales the size of the Hardware Render Buffer so the 
rendered image is 100%, 70%, 50%, 30%, or 10% of 
the Resolution. 

Tip If you plan to composite hardware rendered images, set the 
Background Color to black. 

Click on the rendered image 
to return to the view.
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Reference > Camera menu
Time Slider Displays the time slider and transport controls at the 
bottom of the Hardware Render Buffer. Click to turn 
the Time Slider at the bottom of the window on or 
off.

Camera menu

The view in the Hardware Render Buffer is actually a copy of the 
corresponding camera view. For example, if the camera view displays 
the resolution gate, the Hardware Render Buffer view also displays 
the resolution gate.

The Cameras menu contains a list of all cameras in the scene. Select a 
camera view by selecting it from the Cameras menu. For example, if 
you select camera 1, the Hardware Render Buffer displays the view as 
seen from the camera. If side, it displays the side view.

• You can select and move objects in the Hardware Render Buffer view 
just as you would in a regular view. You can also adjust the camera in 
the Hardware Render Buffer using the Alt (IRIX, Linux, and 
Windows) or Option (Mac OS X) key and the left, middle or right 
mouse buttons.  

Tips • Set Scale Buffer to 100% for the final render.

• Scaling down the size of the rendered image decreases the 
amount of rendering time required and increases the speed 
of playback.

• A dimmed Scale Buffer option (percentage) means that the 
rendered image would either be too large to display on the 
screen, or too small to see adequately.
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• When you playback an animation in the Hardware Render Buffer, it 
also plays back in the corresponding view. To make an animation play 
back only in the Hardware Render Buffer, click anywhere in the 
Hardware Render Buffer view while the animation is playing.

Flipbooks menu 

The Flipbooks menu contains the list of sequences you rendered in the 
Hardware Render Buffer (if you selected Render Sequence from the 
Render menu) as well as the Clear Flipbook Menu option and Flipbook 
Flags. 

The Flipbooks Options control how sequences of images rendered from 
the Hardware Render Buffer display and displays the Flipbook Options 
window.

Flipbook Options

These options control how sequences of images rendered from the 
Hardware Render Buffer are displayed. 

Important 

Make sure nothing on the screen covers any part of the 
Hardware Render Buffer during rendering. (Hardware 
rendering uses screen captures to create rendered frames.)
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Reference > Menus
Options

Enter fcheck options to be used when playing back a hardware 
rendered sequence of images (by selecting the sequence from the 
Flipbooks menu of the Hardware Render Buffer). 

Clear Flipbook Menu

Removes any rendered sequences of images from the Flipbooks menu.

Flipbook Flags

Displays the Flipbook Options window. This option in available for 
only IRIX, Linux and Windows.

See also “fcheck” in the Rendering Utilities online documentation for 
information on fcheck options.

Time slider and transport controls

The time slider and transport controls in the Hardware Render Buffer are 
similar to the time slider and transport controls in the main Maya 
window. See the ”Animate > Create Animated Sweep” on page 56 in the 
Animation guide for details about the Time Slider.

Menus

File

File > Export All, Export Selection (mental ray)

File > Export Selection, Export All  > 

File Type

When you select mentalRay from the File Type drop-down list, the many 
options appear. 

File Type Specific Options

File Format

In ASCII mode, all data in the exported .mi file will be human-
readable ASCII text. In binary mode, certain floating-point data 
(points, normals, texture coordinates, etc.) will be output in binary 
format to reduce the size of the exported file. The ASCII mode 
tabulator size determines the amount of indentation in the .mi file. 
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Output File Per Frame

When animation is enabled, Maya exports all data required to render 
all the frames specified by the Render Globals animation range 
settings. With Output File Per Frame off, data for all the frames is 
output to a single .mi file. With this option on, a separate file is 
output for each frame. 

Frame Extension

When Output File Per Frame is enabled, this option determines the 
convention for naming each frame’s output file. 

Frame Padding

When Output File Per Frame is enabled, determines the amount of 
padding applied to the frame numbers. Setting the padding to 2 
means each frame number is at least 2 characters long (01, 02, 03, ...), 
setting it to 3 means each frame number will be at least 3 characters 
long (001, 002, ...), etc. 

Export Selection Output

If objects do not change, reprocessing before exporting to .mi is not 
required, and the export process is significantly shortened as a result. 

Renderable 

Scene This is the default. 

Maya exports all scene entities (lights, cameras, 
shaders, globals, etc.) that are necessary to render 
the selected geometry. The resulting scene will be 
renderable using the mental ray standalone.

Scene 

Fragment Maya exports only the nodes that are selected. This 
mode can be used to export particular lights, 
cameras, shaders, or geometry. The resulting .mi 
file will most likely not be directly renderable, so it 
is called a Scene Fragment.

Export Materials

In addition to the selected nodes, this setting also exports any 
materials that they are connected to. This applies to selected geometry 
and shading nodes.

Export All Incoming Shaders

In addition to selected shading nodes, also exports all inputs to those 
nodes. For example, if a surface shader is selected, this mode causes 
any texture networks feeding into the shader to be exported along 
with the shader.
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Reference > Create > Cameras > Camera > 
Export Entire Child DAG

This option specifies that in addition to selected geometry, any 
children of that geometry should also be exported.

The standard export filters (enabled by turning on Export Selected Items 
Only) are also applied to the nodes identified for export. This allows you 
to prevent the export of unwanted node types. 

Export Includes Startup File

With this option enabled, the exported .mi file contains an $include 
directive for the maya.rayrc startup file that is used by the interactive 
mental ray renderer in Maya. Use this option to ensure that a 
consistent configuration is used for rendering both with the mental 
ray standalone and interactively in Maya. 

Export Selected Items Only

This option allows detailed control over precisely which mental ray 
entities are exported into the .mi file. See the mental ray User Manual, 
available from the Maya Help, for descriptions of the various entity 
types that can be exported. 

Predefined Export Filters

Provides several useful preset combinations of entity types for export.

Modify

Modify > Convert Displacement to Polygons

Lets you convert a displacement mapped subdivision surface to polygons 
to see the tessellation triangles.

Create

Create > Cameras > Camera

Creates a a one-node camera, which is a basic camera.

For more information on the types of cameras, see ”Maya camera types” 
on page 27.

Create > Cameras > Camera > 

Camera Properties

The camera viewing tools (tumble, track, and dolly) use this value to 
determine the “look at” point when the camera is a Basic camera.
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Center of Interest

The distance from the camera to the center of interest, measured in the 
scene’s linear working unit. 

Lens Properties

Focal Length

Also available in the camera’s Attribute Editor. The focal length of the 
camera, measured in millimeters. 

Increasing the Focal Length zooms the camera in and increases the 
size of objects in the camera’s view. Decreasing the Focal Length 
zooms the camera out and decreases the size of objects in the camera’s 
view. The valid range is 2.5 to 3500. The default value is 35. 

For more information about focal length in general, see ”Focus and 
blur” on page 28.

Lens Squeeze Ratio

The amount the camera’s lens compresses the image horizontally. 
Most cameras do not compress the image they record, and their Lens 
Squeeze Ratio is 1. Some cameras (for example, anamorphic cameras), 
however, compress the image horizontally to record a large aspect 
ratio (wide) image onto a square area on film. The default value is 1.

Camera Scale

Scales the size of the camera relative to the scene. For example, if 
Camera Scale is 0.5, the camera’s view covers an area half as large, but 
objects in the camera’s view are twice as large. If the Focal Length is 
35, the effective focal length for the camera would be 70.

Film Back Properties

Don’t edit these attributes unless you are bringing in live action footage.

Horizontal Film Aperture, Vertical Film Aperture

The height and width of the camera’s aperture or film back, measured 
in inches. The Camera Aperture attribute determines the relationship 
between the Focal Length attribute and the Angle of View attribute. 
The default values are 1.417 and 0.945.

Horizontal Film Offset, Vertical Film Offset

Vertically and horizontally offsets the resolution gate and the film 
gate relative to the scene. Changing the Film Offset attribute produces 
a two-dimensional track. Film Offset is measured in inches. The 
default setting is 0.
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Reference > Create > Cameras > Camera > 
Film Fit

Controls the size of the resolution gate relative to the film gate. If the 
resolution gate and the film gate have the same aspect ratio, then the 
Film Fit setting has no effect. The default setting is Fill.

You can also set Film Fit in the camera view’s View > Camera Settings 
submenu.

Film Fit Offset

Offsets the resolution gate relative to the film gate either vertically (if 
Film Fit is Horizontal) or horizontally (if Film Fit is Vertical). Film Fit 
Offset has no effect if Film Fit is Fill or Overscan. Film Fit Offset is 
measured in inches. The default setting is 0.

Overscan

Scales the size of the scene in the camera’s view only, not in the 
rendered image. Adjust the Overscan value to see more or less of the 
scene than will actually render. If you have view guides displayed, 
changing the Overscan value changes the amount of space 
surrounding the view guides, making them easier to see. The default 
value is 1.

Clipping Planes

For information on clipping planes, see ”Clipping planes” on page 34.

Fill Fits the resolution gate within the film gate.

Horizontal Fits the resolution gate horizontally within the film gate.

Vertical Fits the resolution gate vertically within the film gate.

Overscan Fits the film gate within the resolution gate.

1 The view guide fills the view. The edges of the view guide may be 
exactly aligned with the edges of the view, in which case the view 
guide is not visible.

> 1 The higher the value, the more space is outside the view guide.
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Reference > Create > Cameras > Camera > 
Near Clip Plane, Far Clip Plane

For Hardware rendering, Vector rendering, and mental ray for Maya 
rendering, this represents the distance of the near and far clipping 
planes of perspective or orthographic cameras. The default setting for 
Near Clip Plane is 0.1 and for Far Clip Plane is 1000.

For Maya software rendering, by default Auto Render Clip Plane is on 
(see ”Auto Render Clip Plane” on page 269), and the Near Clip Plane 
and Far Clip Plane values do not determine the position of the clipping 
planes. See ”Auto Render Clip Plane” on page 269.

If the distance between the near and far clipping planes is much larger 
than is required to contain all the objects in the scene, the image 
quality of some objects may be poor. Set the Near Clip Plane and Far 
Clip Plane attributes to the lowest and highest respective values that 
produces the desired result

.

Motion Blur

Shutter Angle

The Shutter Angle influences the blurriness of objects of motion 
blurred objects. The larger the Shutter angle setting, the more blurry 
objects. Shutter Angle is measured in degrees. The valid range is 1 to 
360. The default value is 144.

Tip The objects you want to render are usually within a certain range 
from the camera. Setting the near and far clipping planes just 
slightly beyond the limits of the objects in the scene can help 
improve image quality. 

Note The ratio of far:near clipping planes determines the depth 
precision. Try to keep that ratio as small as possible for better 
results. 

Since most of the depth precision is concentrated around the 
near clip plane, try to avoid a lot of detail on distant objects. 

This concept is crucial for hardware rendering because it has 
only 24 bits of depth precision, as opposed to software rendering 
which has 32 bits.
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Reference > Create > Cameras > Camera > 
The Camera Shutter Angle option is a multiplier for the time range of 
the blur. Similar to traditional film and video cameras, the camera 
shutter angle determines the length of the exposure. However, for the 
purposes of motion blur, it only alters the absolute time range of the 
exposure based on the following equation: 

Blur range = (Camera Shutter Angle / 360 degrees) x Blur by Frame

(In real-world film cameras, this is calculated at 180 degrees; during 
the other 180 degrees of rotation, the film is advanced to the next 
frame for exposure. Computer graphics cameras have no film.) 

For information on a real-world camera’s shutter angle and exposure 
in general, see ”Focus and blur” on page 28.

Orthographic Views

By default, when you create a camera from the Create menu, the view is 
perspective. If you want an orthographic camera view, click the 
Orthographic check box and change the Orthographic Width if necessary.

The Orthographic Views attributes control whether a camera is 
perspective or orthographic (top, front, or side), and also lets you control 
the field of view for orthographic cameras. See also ”Viewing cameras vs. 
rendering cameras” on page 27.

Orthographic

If on, the camera is an orthographic camera. If off, the camera is a 
perspective camera. Orthographic is off by default.

Note For the shutter angle setting to take effect (that is, for motion 
blur to appear), Motion Blur must be set for the following:

• for the scene in the Render Global Settings window (for the 
particular renderer you are using). 

• for at least one object in the object’s Render Stats section of 
the Attribute Editor.

Tip The default cameras are aligned to the major axis. You can create 
an off-axis orthographic camera by rotating the orthographic 
camera or changing the default tumble options and using the 
tumble tool.

To rotate an orthographic view, in the Tumble tool’s option 
window, make sure the Locked setting turned off. See ”View > 
Camera Tools > Tumble Tool > ” on page 275. 
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Reference > Create > Cameras > Camera and Aim > 
Orthographic Width

The width (in inches) of the orthographic camera. The width of an 
orthographic camera controls how much of a scene the camera can 
see. Changing the width of an orthographic camera has the same 
effect as zooming a perspective camera.

Create > Cameras > Camera and Aim

Creates a two-node camera, which is a basic camera plus an aim-vector 
control for aiming the camera at a specified “look at” point.

For more information on the types of cameras, see ”Maya camera types” 
on page 27.

Create > Cameras > Camera and Aim >  

See ”Create > Cameras > Camera > ” on page 247. 

Create > Cameras > Camera, Aim, and Up

Creates a three-node camera, which is a basic camera with the aim-
vector control plus an up-vector control for rotating the camera.

For more information on the types of cameras, see ”Maya camera types” 
on page 27.

Create > Cameras > or Camera, Aim, and Up >  

See ”Create > Cameras > Camera > ” on page 247. 

Window

Window > Rendering Editors > Render View 

Opens the Render View. 

For information about Render View, see ”Render View rendering” on 
page 71.

Tip If you want to create a new perspective camera and get out of 
orthographic view mode, select Edit > Reset Settings, then click 
the Apply button. 
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Reference > Create > Cameras > or Camera, Aim, and Up > 
Window > Rendering Editors > Hardware 
Render Buffer

Opens the Hardware Render Buffer. 

For information about Hardware Render Buffer, see ”Hardware Render 
Buffer” on page 233.

Window > Rendering Editors > Render 
Globals

Opens the Render Globals Settings window. 

For information about Render Globals, see ”Render Global Settings 
window” on page 159.

Window > Rendering Editors > Hypershade 

Opens the Hypershade. 

For information about Hypershade, see ”Hypershade” on page 99 in the 
Shading guide. 

Window > Rendering Editors > Rendering 
Flags

Opens the Rendering Flags window. 

For information about the Rendering Flags window, see ”Rendering Flags 
window” on page 231.

Window > Rendering Editors > Shading group 
attributes

Opens the Attribute Editor for the selected object. 

For information about the Attribute Editor, see ”Attribute Editor” on 
page 189 in the Basics guide. 

Window > Rendering Editors > Multilister

Opens the Multilister. 
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Reference > Create > Cameras > or Camera, Aim, and Up > 
Window > Rendering Editors > mental ray > 
Approximation Editor

Opens the mental ray for Maya Approximation Editor where you can set 
tessellation settings for mental ray for Maya.

Window > Rendering Editors > mental ray > 
Custom Text Editor

Opens the mental ray Custom Text Editor. 

For information about the Custom Text Editor, see ”Custom mental ray 
text” on page 45 in the Shading guide. 

Rendering menu set

Render
Some menu items are renderer-specific. For example, IPR menu items 
appear only for Maya software rendering.

Render > Render Current Frame

Opens Render View and renders the current scene.  

Render > Redo Previous Render

Opens Render View and re-renders the scene from the previous view. 

Render > IPR Render Current Frame

Opens Render View and IPR renders the current scene. See 
”Interactive Photorealistic Rendering (IPR)” on page 67 for more 
details.

Render > Redo Previous IPR Render

Opens Render View and re-IPR renders the scene from the previous 
view. See ”Interactive Photorealistic Rendering (IPR)” on page 67 for 
more details.

Render > Test Resolution

The resolution at which the image renders in Render View. Use a 
reduced resolution to test render the scene to increase rendering time.
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Reference > Render > Batch Render > 
Render > Render Diagnostics

Runs the Render Diagnostics tool. See ”Diagnose scene problems” on 
page 141 for more information. 

Render > Batch Render

Runs a batch render. For more information, see ”Batch renders from 
within Maya (UI)” on page 72.

opens the Batch Render option dialog box to let you set options to 
render an animation on a local or remote computer, or on a computer 
with several processors. For descriptions of these options, see ”Render 
> Batch Render > ” on page 255.

For more information on batch rendering, see ”Batch renders from 
within Maya (UI)” on page 72 in Rendering guide.

Render > Batch Render > 

For Windows

Use all available processors

If on, rendering uses all processors available on the local computer.

If off, rendering only uses the number of processors indicated by 
Number of Processors to Use. Use all available processors is off by 
default.

Camera Panel Renders at the resolution of the current view.

Render Globals Renders at the Resolution set in the Render Global 
Settings window. The default setting is 320x240.

50% Globals Renders at 50% of the Resolution set in the Render 
Global Settings window. The default setting is 
160x120.

25% Globals Renders at 25% of the Resolution set in the Render 
Global Settings window. The default setting is 
80x60.

10% Globals Renders at 10% of the Resolution set in the Render 
Global Settings window. The default setting is 
32x24.
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Reference > Render > Batch Render > 
Number of Processors to Use

The number or processors used for rendering when Use all available 
processors is off. The default value is 1.

For IRIX and Linux 

Rendering CPU

Determines whether rendering takes place on the local computer 
(Local) or on another computer across a network (Remote). If you 
select Remote, set Remote Machine name to the name of the computer 
you want to render on. The default setting is Local.

Remote Machine Name

When set to Remote, type the name of the computer on which the 
rendering takes place and press Enter. If you do not, the render occurs 
on the local machine.

Render > Cancel Batch Render

Cancels the batch render that was launched in the current Maya 
session. 

For more information on batch rendering, see ”Batch renders from 
within Maya (UI)” on page 72 in Rendering guide.

Render > Show Batch Render

Opens an fcheck display window and displays the last rendered 
image. 

For more information on batch rendering, see ”Batch renders from 
within Maya (UI)” on page 72 in Rendering guide.

Render > Save Distributed Render

(IRIX only)

Saves the current scene to a file and opens Dispatcher, which allows 
you to render across a network of computers (IRIX only). 

For more information on Dispatcher, see ”Overview of Dispatcher” on 
page 15 in the Rendering Utilities guide.

Render > Render Using > Maya Hardware

Changes the rendering mode to use the Maya Hardware renderer. 
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For more information about Maya’s Hardware renderer, see ”Maya 
Hardware renderer” on page 16.

Render > Render Using > Maya Software

Changes the rendering mode to use the Maya Software renderer. 

For more information about Maya’s Software renderer, see ”Maya 
Software renderer” on page 15.

Render > Render Using > Maya Vector

Changes the rendering mode to use the Maya Vector renderer. 

For more information about Maya’s Vector renderer, see ”Maya 
Vector renderer” on page 22.

Render > Set NURBS Tessellation

Render > Set NURBS Tessellation > 

With this window: 

• Maya can automatically optimize NURBS surface tessellation 
throughout an animation range (select Automatic (default)). 

This method is exceptionally powerful for scenes in which the 
distance between the camera and the object changes (animation), and 
lets you save memory (and time) and enhance performance by 
preventing overtessellation.

• You can manually adjust tessellation for objects that require non-
default settings (select Manual). 

Apply Tessellation 

Selected 

Surfaces,

 All Surfaces Lets you change the tessellation attributes for 
Selected Surfaces or All Surfaces at one time. 
Selected Surfaces is on by default.

Tessellation Mode

Maya automatically sets the optimal tessellation settings based on an 
object’s distance from the renderable camera(s), or lets you set them. 

To adjust tessellation settings, you need to switch to Manual Mode. 
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Automatic 

(default) Tessellation is based on the coverage and distance of 
the surface from the camera and the ”Automatic 
Mode settings” on page 258. 

Objects that are either close to the camera or occupy 
a significant amount of screen space are 
automatically tessellated with more triangles. 
Objects that are further from the camera or are 
smaller have fewer triangles. 

Maya takes into consideration that distance changes 
over time if the surface or camera is animated, and 
tessellation is computed for a the range of frames set 
in Use Frame Range. Tessellation is evaluated and 
optimized at each frame, and the worst-case 
tessellation scenario requirements are determined 
and applied.

In automatic mode, the tessellation can be computed 
for the current frame or the frame range from the 
render globals or time slider.

 Manual Tessellation is based whether you select Basic or 
Advanced in Manual Mode. This is the same as if 
you opened the Attribute Editor for each surface, 
and set the tessellation settings.

Automatic Mode settings

Some of these settings appear and work for the Basic settings of Manual 
Mode too. 

Use Frame Range

Available only in Automatic (default) Mode.

The tessellation computed by Automatic Tessellation depends on the 
distance of the surface from the camera. When the surface or camera is 
animated, this relationship changes over time.

Generally, when the surface is closest to the camera you need the best 
tessellation (the most triangles). If you know which frame this is, use 
“Current Frame”. Otherwise, Maya computes this for you by running 

Note Set the desired Resolution in Render Global Settings window 
before using the Automatic Tessellation mode. Maya uses the 
Resolution settings to determine what tessellation level is 
needed to avoid nickeling. 
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up the animation for a specified frame range, evaluates the tessellation 
at each frame, and sets the tessellation attributes to provide optimal 
tessellation.

A progress bar at the bottom left of Maya’s window indicates the 
runup progress. You can also interrupt the runup for the tessellation 
evaluation by pressing the Esc key. During the interruption, the 
tessellation values are set and are valid up until the frame at which it 
was interrupted.

Render Globals Maya uses the frame range set in Render Global 
Settings window.

Time Slider Use the time slider to adjust the frame range as 
necessary. 

Current Frame Evaluates the best tessellation for the current frame.

Compute From

Available only in Automatic (default) Mode.

All Renderable 

Cameras The default. Computes the automatic tessellation 
from the point of view of all renderable cameras.

Current View Computes the automatic tessellation from the 
current view only.

Curvature Tolerance

You can determine how smooth the nickeling of the tessellation needs 
to be. When you adjust this setting, Maya automatically sets the 
Chord Height Ratio (an Advanced setting that is hidden, but 
automatically set in both Automatic (default) Mode and Manual Basic 
Mode). 

In more complex scenes with many small objects, set the smaller 
objects to Low Quality. (This table applies only for manual mode; 
automatic mode sets thechord height, depending on the distance from 
the camera.)

Low Quality Chord Height ratio = 0.987

Medium Quality 

(default) Some nickeling may occur, but a significantly lower 
polygon count is produced. Chord Height ratio = 
0.990

High Quality Chord Height ratio = 0.994.

Highest Quality The result is very smooth edges with no nickeling. 
Chord Height ratio = 0.995.
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No Curvature 

Check No attempt to smooth out nickeling is made and 
only the initial sampling for the tessellation is done.

U Division Factor, V Division Factor

Before adjusting these settings, adjust Curvature Tolerance to get the 
results you want. 

When you adjust this setting, Maya automatically multiplies the 
values by the Per Surf # of Isoparms in 3D setting (an Advanced 
setting that is hidden, but automatically set in both Automatic 
(default) Mode and Manual Basic Mode). 

The higher the values, the more polygons produced. The U Divisions 
Factor and V Divisions Factor attributes should contain approximately 
the same value.

Use Smooth Edge

Use this to increase the number of triangles only along the boundary 
of an object. This lets you smooth the edges or prevent cracks between 
shared curves of adjacent surfaces without tessellating across the 
entire object, which incurs a high rendering time. 

The higher the ratio, the smoother the edges and the higher the 
polygon count.

If you get artifacts in highlights along curved parts of the surface close 
to an edge, don’t use this attribute. 

Smooth Edge Ratio

Adds more triangles where required in areas of curvature along the 
edges of the surface. The edge is the boundary of the NURBS surface, 
where one of the U or V parameters takes on its most extreme value. 
(This does not address the silhouette edges based on how the object is 
viewed from the camera.)

While extra triangles are primarily added along the edge, some are 
also added to the interior of the surface as needed to prevent cracking 
at T-junctions within the surface. 

The ratio is the length of the tessellated triangle and the curve of the 
boundary.

Edge Swap

Helps to divide quadrilateral surface spans into optimal triangles by 
swapping the two vertices on a quadrilateral used to create triangles. 
This is a secondary criteria, but it uses minimal resources. 
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Manual Mode

Basic Basic settings appear when you select this option. 
For descriptions of these settings, see Automatic 
Mode settings.

When you adjust Basic settings, Maya automatically 
sets the Advanced settings (which are hidden for 
simplicity) as follows (see ”Advanced Tessellation 
settings” on page 261 for details):

 

Advanced Advanced settings appear when you select this 
option. For descriptions of these settings, see 
”Advanced Tessellation settings” on page 261.

Advanced Tessellation settings

Available only in Manual Mode with the Advanced option selected. If 
you have set the Curvature Tolerance (in either Automatic (default) 
mode or Manual Basic mode) to the highest setting and the object is 
still not smooth enough, use these settings to have more control over 
tessellation. 

Mode U, Mode V

These are Primary Tessellation attributes (see ”Primary vs. secondary 
tessellation passes” on page 44). These settings tell Maya how to 
tessellate the surface. The U and V values represent the U and V 
parametric dimensions of the NURBS surface. You can set these 
values differently to produce tessellation for each direction of your 
surface.

Per Surf # of 

Isoparms Ignores the number of surface spans and lets you 
specify the number of subdivisions you want to 
create. The result is a sparser number of isoparms 
on the surface than number of spans. Essentially, 
this setting pretends that everything is equally 
spaced. 

Per Surf # of 

Isoparms in 3D Same as Per Surf # of Isoparms, but attempts to 
space the isoparms equally in 3D space (instead of 
parametric space). Good for converting NURBS to 
polygons. This mode produces more evenly 
distributed triangles than other modes. 
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Per Span # of 

Isoparms This is the most common mode. Divides each span, 
no matter how large or small, into the same number 
of subdivisions. Very small spans are divided into 
the same number of subdivisions as very large 
spans. The default setting is 3. Per span settings help 
to prevent cracks between joined surfaces where the 
spans match, which is particularly important for 
character building with multiple surfaces.

Best Guess 

Based on 

Screen Size Creates a bounding box around the NURBS surface, 
projects it into screen space, and calculates the 
number of pixels in the space. Maya uses this 
number to guess at the per surface # of isoparms. 
The maximum value is 40. With this mode, the more 
screen space the object uses, the higher the value.

This is not good for animation if the camera or the 
object is moving because the bounding box would 
change constantly. If the bounding box changes so 
does the tessellation and texture jitter as a result. 
(Problems with highlights may occur as well.)

Number U, Number V

The actual values associated with Mode U, Mode V.

Use Chord Height

Turn on to enable the Chord Height slider value. 

Chord Height

Chord height is a physical measurement based on object space units; 
it’s perpendicular distance at the centre of a triangle edge to the curve 
that defines the surface. If the actual distance measured is greater that 
the Chord Height value, the triangle is subdivided. Once it is 

Note If you have a complicated NURBS surface and have Display 
Render Tessellation turned on, this setting could delay the 
update of the display, so be patient. 

Note Use the Chord Height or Chord Height Ratio or Min Screen 
option, but not a combination of them.
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sudivided, it will be checked again against the same criteria and the 
process will continue until the criteria is met. Chord height is 
measured in Object Space. The default is 0.1.

Chord Height is based on a default unit and doesn’t always work well 
for very small models as the chord height values on a small model 
will be smaller still.

When chord heights are calculated, if any are larger than 0.1, Maya 
subdivides the triangles and recomputes. This subdivision process 
continues until all triangles meet this criteria. The smaller the chord 
height, the better the approximation of the triangle to the surface 
curve. (This may be useful for industrial designers concerned with the 
accuracy of a model in relation to a prototype model.) 

Specifies the maximum distance the center of a tessellated span can be 
from the actual NURBS surface. 

Use Chord Height Ratio

Turn on to enable the Chord Height Ratio slider value.

Chord Height Ratio

Specifies the maximum ratio between the length of a span and the 
distance the center of that span is from the actual NURBS surface. 

Takes the ratio between the chord height (d) and the Distance (D) 
between the two points where the triangle intersects the surface, and 
subtracts it from 1, as shown in the equation: 

Chord Height Ratio = 1 - d/D

A Chord Height Ratio value of 0.997 and above produces very smooth 
tessellated surfaces. The default is 0.9830, which means d is very small 
compared to D (i.e., 0.9830 = 1 - d/D). The closer to 1, the tighter the 
fit of the triangle to the surface.(This is best used in animations.) 

Note Do not build models too small. Chord height is measured in 
Object Space. If you build models on a very small scale and then 
scale them up, the chord length is always relative to the object, 
not to World Space, which means tessellation criteria can be very 
expensive on small objects. For small or scaled objects, select 
“Use Chord Height Ratio”. 

d

D

chord height
curve, intersecting triangle at points 0 and 1
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Use Min Screen

Turn on to enable the Min Screen box.

Min Screen

Bases tessellation on a minimum screen size (default, 14 pixels). All 
triangles created during tessellation must fit within this screen size. If 
they don’t, the are further subdivided until they do. This option is 
good for still images with a setting off 11.0. This option is not 
recommended for animations because the tessellation will constantly 
change when an object is moving, causing textures to jitter or jump 
because the shading for a particular pixel will have different 
tessellations to deal with on each frame. 

Tessellates a surface based on how far it is from the camera and uses 
the screen space to determine how much tessellation is required 
(instead of object or world space). 

All triangles must fit within the specified area. The default is 14 pixels, 
which means all triangles must fit within a 14X14 pixel area on the 
screen. Triangles that do not meet this criteria are subdivided 
iteratively until they fall within the specified area. The smaller you set 
this value, the smaller the triangles must be to satisfy the criteria. 
Lowering this value can dramatically increase memory, so use 
caution. 

Note Use the Chord Height or Chord Height Ratio or Min Screen 
option, but not a combination of them.

Note Don’t turn on Use Min Screen for surfaces that are moving 
toward or away from the camera during an animation. 

Min Screen causes the tessellation to change over time and can 
cause unwanted displacement or texture ‘popping’. 

Note If you have a complicated NURBS surface and have Display 
Render Tessellation turned on, this setting could delay the 
update of the display, so be patient. 
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Render > Render Using > mental ray

Changes the rendering mode to use the mental ray for Maya renderer. 

For more information about the mental ray for Maya renderer, see 
”mental ray for Maya renderer” on page 17.

Panel menus

View

View > Select Camera

Selects the view’s corresponding camera. The attributes for this camera 
appear in the Channel Box and the Attribute Editor. 

View > Camera settings 

Perspective

If on, the camera is a perspective camera. For more information on 
perspective cameras, see ”Maya camera types” on page 27.

Journal

If on, all camera movements, such as tumble, track, and zoom, are 
written to the Script Editor (MEL journal) which lets you undo or redo 
camera movements or copy camera movements to use them for other 
cameras or scenes. 

Journal is off by default, but you can still use [ and ] to undo and redo 
camera moves.

No Gate

Turns off the Film Gate and Resolution Gate display.

Displays no frustum (viewable volume) when not you are not looking 
through the camera. This is the default.

The frustum is the area or space the camera can see. Any object within 
the camera’s frustum shows up in images rendered from that camera’s 
view. See ”Clipping planes” on page 34 for an diagram of the frustum.

Tip Selecting the camera is useful if you want to edit the look-at and 
camera up nodes associated with the camera.
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Film Gate

Displays a border indicating the area of the camera’s view a real-
world camera records on film. The dimensions of the film gate 
represent the dimensions of the camera aperture. 

The film gate does not represent the render region. The Camera 
Aperture, Film Fit, rendering Resolution, Lock Device Aspect Ratio, 
and Device Aspect Ratio attributes, all affect what Maya renders.

The film gate view guide indicates the area of the camera’s view that 
renders only if the aspect ratios of the camera aperture and rendering 
resolution are the same. 

Displays the viewable frustum according to the film back size. The 
aspect ratio of the window (or rendering resolution) determines what 
you actually see. Also sets the camera Overscan attribute to 1.5. The 
following illustration shows the film gate representing the maximum 
viewable (or renderable) area.

Horizontal and Vertical Film Aspect Ratio 
adjusted in Channel Box to view almost 
the entire scene in Render View.

Resolution settings in
Render Globals.
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Resolution Gate

The dimensions of the Resolution Gate represent the rendering 
resolution (the region to be rendered). The rendering resolution values 
are displayed above the Resolution Gate in the view. You can change 
these dimensions in the Resolution section of the Render Global 
Settings window.

Enabling this option displays the renderable area for the current 
resolution specified in Render Global Settings window. This often 
specifies a more exact rendered image than the Film Gate option. Also 
sets the camera Overscan attribute to 2.0, so that more area outside the 
specified resolution can be viewed.

Note If the aspect ratio between the film back and the resolution is the 
same, then the two resulting rendered images match.

Film Back Gate

Resolution values. 
Change these values in the Render Global Settings 
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Field Chart

Turn Field Chart on to display a grid that represents the twelve 
standard cell animation field sizes. The largest field size (number 12) 
is identical to the rendering resolution (the resolution gate). Render 
Resolution must be set to NTSC dimensions for this option to be 
meaningful.

Safe Action

Turn this option on to display a box defining the region that you 
should keep all of your scene’s action within if you plan to display the 
rendered images on a television screen. 

For more information on Safe Action, see ”Safe display regions for TV 
production” on page 33.

Safe Title

Turn this option on to display a box defining the region that you 
should keep all of your scene’s text (titles) within if you plan to 
display the rendered images on a television screen. 

Render Resolution must be set to NTSC or PAL dimensions for this 
option to be meaningful.

For more information on Safe Title, see ”Safe display regions for TV 
production” on page 33.

Fill, Horizontal, Vertical, Overscan (for advanced users)

The following options control the size of the Resolution Gate relative 
to the Film Gate. If the resolution gate and the film gate have the same 
aspect ratio, these settings have no effect. The default setting is Fill.

Fill Fits the resolution gate within the film gate.

Automatically selects a horizontal or vertical fit so 
that the selected image fills the render frame. 

Horizontal  Fits the resolution gate horizontally within the film 
gate.

Selects a horizontal fit for the selected image in the 
render frame.

Vertical  Fits the resolution gate vertically within the film 
gate.

Selects a vertical fit for the selected image in the 
render frame.

Overscan Fits the film gate within the resolution gate.
Rendering 

268



7 | Window, menu, and node descriptions

Reference > Camera attributes
Selects a slightly larger fit for the selected image in 
the render frame.

View > Camera Attribute Editor

Opens the camera’s Attribute Editor. 

Camera attributes

Controls

See ”Maya camera types” on page 27 for information about the type of 
cameras: Camera; Camera and Aim; and Camera, Aim, and Up. 

Angle of view

For more information on angle of view and how it’s affected by the 
focal length of the camera, see ”Angle of view (focal length)” on 
page 32.

Focal length

See ”Focal Length” on page 248.

Camera scale

See ”Camera Scale” on page 248.

Auto Render Clip Plane

For Maya software only. If this is on, the near and far clipping planes 
are automatically set so they enclose all objects within the camera’s 
view. (For the hardware renderer and mental ray for Maya renderers, 
you must set the near clip plane and far clip plane manually. You can 
set the planes manually for Maya software rendering too.) 

Tip If you click the boxes at the right of some of the attributes in this 
editor, the Create Render Node window appears, which means 
you can map certain render nodes to the camera attributes. For 
more information on the Create Render Node window, see 
”Create > Create Render Node” on page 107 in the Shading 
guide. 

Tip Try to avoid using a perspective camera with a very small angle 
(less than 5 degrees). Doing so may result in a much decreased 
depth precision, resulting in depth-fighting artifacts. Instead, try 
using an orthographic camera for a similar look. 
Rendering

269



7 | Window, menu, and node descriptions 
Reference > Film Back
All objects render and depth precision problems are eliminated. Clipping 
planes are not visible in the views.

If off, the near and far clipping planes are set to the Near Clip Plane and 
Far Clip Plane attribute values.

Auto Render Clip Plane is on by default.

Turn off Auto Render Clip Plane (and set the Near Clip Plane and Far Clip 
Plane) in the following cases:

• to limit which objects render based on their distance from the camera 
if you are compositing based on depth

Near Clipping Plane, Far Clipping Plane

See ”Near Clip Plane, Far Clip Plane” on page 250.

Film Back

The Film Back attributes control the basic properties of a camera (for 
example, the camera’s film format: 16mm, 35mm, 70mm). 

Film Gate

Lets you select a preset camera type. Maya automatically sets the 
Camera Aperture, Film Aspect Ratio, and Lens Squeeze Ratio. To set 
these attributes individually, set Film Gate to User. The default setting 
is User.

Camera Aperture

The height and width of the camera’s Film Gate setting, measured in 
inches. The default values are 1.417 and 0.945. This setting has a direct 
effect on the camera’s angle of view (see Angle of view).

Film Aspect Ratio

The ratio of the camera aperture’s width to its height. Maya 
automatically updates the Film Aspect Ratio (and vice versa). The 
valid range is 0.01 to 10. The default value is 1.5.

Lens Squeeze Ratio

See ”Lens Squeeze Ratio” on page 248.

Film Fit

”Film Fit” on page 249.

Note The Camera Aperture setting has no effect on the fStop. For 
more information on fStop, see ”Focus and blur” on page 28.
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Film Fit Offset

”Film Fit Offset” on page 249.

Film Offset

Vertically and horizontally offsets the resolution gate and the film 
gate relative to the scene. Changing the Film Offset produces a two-
dimensional track. Film Offset is measured in inches. The default 
setting is 0.

Overscan

”Overscan” on page 249.

Depth of Field

These attributes provide control over the camera’s focus.

For more information on depth of field, see ”Aperture determines Depth 
of Field (DOF)” on page 29.

Depth Of Field

If on, some objects in the scene are sharply focused and others are 
blurred or out of focus, based on their distance from the camera. If off, 
all objects in the scene are sharply focused. Depth Of Field is off by 
default.

Focus Distance

The distance from the camera at which objects appear in sharp focus, 
measured in the scene’s linear working unit. Decreasing the Focus 
Distance also decreases the depth of field. The valid range is 0 to ∞. 
The default value is 5.

1 The view guide fills the view. The edges of the view guide may be 
exactly aligned with the edges of the view, in which case the view 
guide is not visible.

> 1 The higher the value, the more space is outside the view guide.

Tip The more out of focus an image is, the longer it takes to generate 
the final rendered image (that is, the post-render blur takes 
longer.)
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F Stop

The range of Camera Aperture settings which affect the Depth of 
Field. The lower the fStop (for example, f4) the lower amount of 
Depth of Field. The higher the fStop value (for example, f32) the 
greater amount of Depth of Field. 

For more information about fStop, see ”fStop (aperture) and shutter 
speed/angle” on page 28.

Focus Region Scale

Scales the Focus Distance value. The valid range is 0 to ∞. The default 
value is 1.

Output Settings

Controls whether the camera generates an image during rendering, and 
what types of images the camera renders.

Renderable

If on, the camera can create an image file, mask file, and/or depth file 
during rendering; that is, it is able to render. By default, Renderable is 
on for the default perspective camera, and off for all other cameras.

This option is affected by the Camera option in the Image File Output 
section of the Render Global Settings window. For more information 
on the Render Global Settings window, see ”Render Global Settings 
window” on page 159.

Image

If on (and Renderable is on), the camera creates an image file during 
rendering. The default setting is on.

Mask

If on (and Renderable is on), the camera creates a mask during 
rendering. A mask is an 8-bit channel (the alpha channel) in the image 
file that represents objects in shades of gray. Black areas represent 
areas where there are no objects (or fully transparent objects), and 
white areas represent areas where there are (solid) objects. Masks are 
used primarily for compositing.

For image formats that do not support mask channels, the mask is 
stored as a separate image. 

For more information on mask channels, see ”Mask and depth 
channels” on page 84. 
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Depth

If on (and Renderable is on), the camera creates a depth file during 
rendering. A depth file is a type of data file that represents the 
distance of objects from the camera. 

Depth files are used primarily for compositing. When on, the Depth 
Type attributes (next) are enabled.

For image formats that do not support depth channels, the depth is 
stored as a separate image. 

For more information on mask channels, see ”Mask and depth 
channels” on page 84. 

Depth Type

Determines how to compute the depth of each pixel.

Closest Visible 

Depth Uses the closest object to the camera. When 
transparent objects are located in front of other 
objects, turn on “Transparency Based Depth” to 
ignore the transparent object.

Furthest Visible 

Depth Most often used when a particle effect is occluded 
by an opaque object. Maya uses the Furthest Visible 
Depth to create a Depth file.

Transparency Based Depth

Turns on Threshold, which determines which object is closest to the 
camera, based on transparency. Transparency Based Depth is only 
enabled when you select Closest Visible Depth. 

Threshold

Used when compositing multiple layers of transparency (which varies 
from 0 to 1).

Environment

Control the appearance of the scene’s background as seen from the 
camera. Different cameras can use different backgrounds.

Background Color

The color of the scene’s background. The default color is black.
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Image Plane

For Maya software and mental ray for Maya rendering.

Creates an image plane and attaches it to the camera. Clicking the 
Create button automatically changes the focus of the Attribute Editor 
to include attributes for an image plane.

For more information on image planes, see ”Create, edit, or position an 
image plane” on page 265 in the Shading guide.

Special Effects

Shutter Angle

See ”Shutter Angle” on page 250.

Display Options

Controls the display of view guides in the camera’s view, and provides 
options for moving the camera. You can also access most of these 
attributes in any panel’s View > Camera Settings menu.

Display Film Gate

”Film Gate” on page 266.

Display Resolution

”Resolution Gate” on page 267.

Display Field Chart

”Field Chart” on page 268.

Display Safe Action

”Safe Action” on page 268.

Note The background color of a camera cannot be texture mapped. If a 
procedural background is required, use an image plane instead.

Note Motion Blur must be on in the Render Global Settings window. 
For Maya software rendering, motion blur must also be set in at 
least one object’s Attribute Editor for the Shutter Angle to have 
any effect.
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Display Safe Title

”Safe Title” on page 268.

Journal Command

”Journal” on page 265.

Center of Interest

The distance from the camera to the center of interest, measured in the 
scene’s linear working unit. 

Tumble Pivot

The point the Tumble tool pivots the camera about when Tumble 
Camera About is set to Tumble Pivot in the Tumble Tool settings 
window.

View > Camera Tools

Selects one of the camera tools. For information on the camera tools, 
see ”Camera tools” on page 30. 

View > Camera Tools > Tumble Tool >  

For a description of the Tumble tool, see ”Tumble” on page 30.

Tumble scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

Tumble camera about

Center of 

Interest The camera tumbles about its center of interest. 
Tumble camera about is set to Center of interest by 
default.

Tumble Pivot The camera tumbles about its pivot point. This 
tumble pivot can also be set in the camera’s 
Attribute Editor (see “Tumble Pivot” for details). 
These values are stored in world space coordinates. 

View operations such as Frame Selection, Frame All, 
Look at Selection, Default Home, and Bookmarks all 
set the tumble pivot.

Orthographic views

Locked If on, you cannot tumble an orthographic camera. If 
off, you can tumble an orthographic camera. Locked 
is on by default.
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Reference > View > Camera Tools > Track Tool > 
Stepped If on, you can tumble an orthographic camera in 
discrete steps. The Stepped operation lets you easily 
return to the Default Home positions. If off, you can 
tumble an orthographic camera smoothly. Stepped 
is only available if Locked is off. Stepped is on by 
default.

Ortho step The angle of steps (in degrees) that you can tumble 
an orthographic camera when Locked is off and 
Stepped is on. The valid range is 0.01 to 180. The 
default value is 5.

View > Camera Tools > Track Tool >  

For a description of the Track tool, see ”Track” on page 30.

Track Geometry

If off, as the camera moves an object moves at a speed that may be 
different than the speed of the cursor. This problem occurs with 
objects far from the camera. Track Geometry is off by default.

If on, as the camera moves, an object moves at the same speed as the 
cursor. The object selected at the beginning of the Track operation 
remains under the cursor. Tracking is slower (especially if there are 
many objects in the scene) if Track Geometry is on. 

Track Scale

Scales the speed of the camera movement. The slider range is 0 to 100. 
The default value is 1.

View > Camera Tools > Dolly Tool >  

For a description of the Dolly tool and tips on how to use it, see ”Dolly” 
on page 31.

Scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

Tip You can also press Alt+middle-drag to use the Track tool. Press 
the Shift key to constrain movement in horizontal or vertical 
directions.
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Reference > View > Camera Tools > Zoom Tool > 
Dolly

Local If on, drag in the camera’s view to move the camera 
toward or away from its center of interest. If off, 
drag in the camera’s view to move both the camera 
and its center of interest along the camera’s sight 
line. Local is on by default.

Center of 

Interest If Center of Interest is on, middle-drag in the 
camera’s view to move the camera’s center of 
interest toward or away from the camera. If off, drag 
in the camera’s view to move the camera toward or 
away from its center of interest. drag a region and 
snap the center of interest to the center of those 
objects. Center of Interest is off by default.

If Center of Interest (and/or Local) and Bounding 
box are on, when you drag in the views, a red line 
with a small x at the end points to indicate the 
Center of Interest. 

Snap box dolly to

A box dolly moves the center of interest to the marquee region when 
you use the Ctrl+Alt+drag method to dolly the camera.

Surface

If on, when you perform a box dolly (Ctrl+drag) on an object, the 
center of interest moves onto the surface of the object. Calculating the 
surface point is slower if Smooth Shade mode is off (and especially if 
there are many visible objects in the scene). 

Bounding box

If on, when you perform a box dolly (Ctrl+drag) on an object, the 
center of interest moves to the center of the object’s bounding box. 
Bounding Box is on by default.

View > Camera Tools > Zoom Tool >  

For a description of the Zoom tool, see ”Zoom” on page 31.

Zoom Scale

Scales the speed of the camera movement. The slider range is 0.01 to 3. 
The default value is 1.

View > Camera Tools > Roll Tool >  

For a description of the Roll tool, see ”Roll” on page 31.
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Reference > View > Camera Tools > Azimuth Elevation Tool 
Roll Scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

View > Camera Tools > Azimuth Elevation Tool  

For a description of the Azimuth tool, see ”Azimuth Elevation” on 
page 31.

Scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

Rotation type

Controls whether the camera movement is an Azimuth Elevation 
movement or a Yaw Pitch movement.

View > Camera Tools > Yaw Pitch Tool >  

For a description of the YawPitch tool, see ”Yaw-Pitch” on page 31.

Scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

Rotation type

Controls whether the camera movement is a Yaw Pitch movement or 
an Azimuth Elevation movement.

View > Image plane

Provides you with options to import a file to use an image plane and 
access the Image Plane’s attributes.

For more information on image planes, see ”Create, edit, or position an image 
plane” on page 265 in the Shading guide. 

Import Image Import a file to use as an image plane.

Image plane 

attributes Access the image plane’s attributes.

Tip Press Shift to constrain the camera’s movement.

Tip Press Shift to constrain the camera’s movement.
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Reference > Nodes
Nodes

Object-specific render attributes (Attribute 
Editor)

Render Stats

Find this section in some selected objects’ Attribute Editor, from the 
Attribute Spreadsheet (Window > General Editors > Attribute 
Spreadsheet) or the Rendering Flags window (Window > Rendering 
Editors > Rendering Flags).

The Render Stats section lets you turn on or off various rendering options 
for selected objects. 

Casts Shadows

Turns on the shadow casting ability of the surface. To make shadows 
render faster, for surfaces that do not need to cast shadows, turn off 
Casts Shadows. 

• If you want the object’s shadow to render—the shadow the object 
casts onto other objects—make sure Casts Shadows is on. 

• If you do not want the object’s shadow to render—the shadow the 
object casts onto other objects—turn Casts Shadows off.

Receive Shadows

Turns on the shadow-catching ability of the surface.

Motion Blur

Turns on motion blur for the surface. You must also turn on Motion 
Blur in the Render Global Settings window. 

Primary Visibility

When on, the surface is visible in the view and renders. 

Notes • If you render shadows separately, use the mask channel of 
the rendered shadow image in your compositing software to 
reduce the brightness of another image. 

• When you render from the Render View window, you can 
render active objects only by setting Renderable Objects to 
Render Active in the Render Global Settings window.
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Reference > Render Stats
Smooth shading

If this is on, each vertex uses its own normal vector - meaning 
smoother transition between two faces. If this is off, one normal vector 
is used for a face ; 3 vertices in a triangle uses a same normal vector, 
resulting flat looking shading. 

Visible in Reflections

When on, the surface reflects in reflective surfaces.

Visible in Refractions

When on, the surface refracts in transparent surfaces.

Double Sided

Determines if the surface is double-sided. If single-sided, you can 
decrease memory use and use the Opposite option. 

Opposite

Opposite flips the surface normals. Double-Sided must be off to set 
Opposite. 

Geometry Antialiasing Override

When on, the surface overrides the geometry anti-aliasing settings. 

Antialiasing Level

Level 1 The default. It takes 32 visibility samples. 

Level 2 Takes 96 visibility samples. 

Level 3 Takes 288 visibility samples. 

Level 4 Takes 512 visibility samples. 

Level 5 Takes 800 visibility samples. Level 5 gives the best 
edge anti aliasing quality, but it is also the most 
expensive (in both memory and speed). 

Tip A surface’s shadow renders, however, if its Primary Visibility is 
off and Cast Shadows is on. This also applies to reflections and 
refractions.

Tip Motion-blurred objects ignore any changes to the Geometry 
Antialiasing Override settings. The blur generally hides any 
aliasing artifacts. 
Rendering 

280



7 | Window, menu, and node descriptions

Reference > Render Stats
Shading Samples Override

When on, the surface overrides the global shading sample settings in 
the Render Global Settings window. 

Shading Samples

Sets the minimum number of times Maya samples each pixel. For 
example, if set to 1, Maya samples each pixel once; if set to 8, Maya 
samples each pixel 8 times. The number of shading samples taken per 
pixel is limited by the number of visibility samples performed by the 
Edge Anti-Aliasing computation. So, if you use Medium Quality 
(which performs 8 visibility samples per pixel), you cannot get more 
than 8 shading samples regardless of the Shading Samples attribute 
setting.

Since Shading Samples computation is very expensive, you should try 
adjusting the Max Shading Samples first. See Max Shading Samples. 

Max Shading Samples

Sets the maximum number of times a pixel is sampled during the 
second pass of a Highest Quality render (adaptive shading pass). The 
higher the number, the longer the rendering takes, but the more 
accurate the resulting image is.

Max Shading Samples has an effect only when used in conjunction 
with Highest Quality edge anti-aliasing. Also, depending on the 
requirements to compute an accurate solution, the number of Shading 
Samples taken can be less than the number of Max Shading Samples.

Volume Samples Override

When on, the object overrides the global volume shading settings and 
you can turn on the Depth Jitter option in Render Global Settings 
window.

Tip Occasionally, when an object is moving, the object’s textured 
edges look distorted. To resolve this, try increasing the number 
of Max Shading Samples.

Tip Sometimes, skinny highlights can exhibit roping or flickering 
artifacts. Try increasing the Max Shading Samples setting. You 
may also need to increase the Shading Samples setting, but you 
can set it on a per-object basis. 
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Reference > NURBS objects tessellation
Volume samples

Adjusts the number of samples placed inside the fog volume.

Depth Jitter

If you set Volume Sample Override on, you can turn on Depth Jitter 
option. Randomizes the samples of the volume with depth which 
replaces banding artifacts in volume renders with noise. The noise can 
be dramatically reduced by increasing the volume samples and anti-
aliasing levels.

Tessellation

NURBS objects tessellation

Display render tessellation

Shows or hides (default) the tessellation triangles so that you can have 
more control while adjusting settings. 

Refresh tessellation

When advanced tessellation with min screen is on, the tessellation 
only updates when refresh is pressed.

Triangle count

This is the number of render triangles in the surface when a 
tessellation is displayed.

Curvature tolerance

See ”Curvature Tolerance” on page 259.

U Division Factor, V Division Factor

See ”U Division Factor, V Division Factor” on page 260.

Note This option does not display displacement mapping

In the main Maya window, select Shading > Displacement to 
Polygon to preview the effect of your tessellation and 
displacement together, then discard the generated polygon 
object when you are finished previewing.
Rendering 

282



Index
Symbols
.mi files

exporting . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72, 118

.mi format
exporting to  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Numerics
2D Blur memory Limit attribute  . . . . . . . . . . . . . . 175

2D motion blur
artifacts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
rendering problems . . . . . . . . . . . . . . . . . . . . . . 124

3D Blur Visib attribute  . . . . . . . . . . . . . . . . . . . . . . 167

3D Motion Blur. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

3D Motion Blur Production attribute  . . . . . . . . . . 166

A
Acceleration Method attribute . . . . . . . . . . . . . . . . 200

Advanced Tessellation
for surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 261

Alias Pix format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

aliasing. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126

All Channels
Render View . . . . . . . . . . . . . . . . . . . . . . . . . . . . 229

All Double sided attribute  . . . . . . . . . . . . . . . . . . . 209

All Renderable Cameras
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 259

All Single sided attribute  . . . . . . . . . . . . . . . . . . . . 209

All Surfaces
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 257

Alpha Channel (Mask)  . . . . . . . . . . . . . . . . . . . . . . 161

alpha channels
enabling. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
premultiplication . . . . . . . . . . . . . . . . . . . . . . . . . 84

Alpha mode attribute  . . . . . . . . . . . . . . . . . . . . . . . 199

Alpha Source attribute  . . . . . . . . . . . . . . . . . . . . . . 236

Angle of view . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

angle of view, cameras  . . . . . . . . . . . . . . . . . . . . . . . 32

Animation
mental ray for Maya  . . . . . . . . . . . . . . . . . . . . . . 20

animation
batch render . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115
batch rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . 72
command line rendering  . . . . . . . . . . . . . . 72, 117
low-res rendering  . . . . . . . . . . . . . . . . . . . . . . . 111
rendering single frame . . . . . . . . . . . . . . . . . . . . 71
swimming . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121
troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . 121

animations
test render . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

Anti-alias
Anti-aliasing Quality, Render Globals . . . . . . 165
Hardware Render Globals . . . . . . . . . . . . . . . . 240

anti-aliasing
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 131
adjusting . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99, 134
blobby surfaces  . . . . . . . . . . . . . . . . . . . . . . . . . 121

Antialiasing Level
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

aperture (fstop). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Apply Fog in Post
Render Options  . . . . . . . . . . . . . . . . . . . . . . . . . 175

Apply tessellation, NURBS. . . . . . . . . . . . . . . . . . . 257

approximation
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43, 45
controling fine  . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
default settings. . . . . . . . . . . . . . . . . . . . . . . . . . . 45
fine . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47
vs. tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Approximation Editor
attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

approximation node
assigning . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
assigning to geometry. . . . . . . . . . . . . . . . . . . . . 53
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52, 61
editing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54, 61

approximation nodes  . . . . . . . . . . . . . . . . . . . . . . . . 45

Approximation settings  . . . . . . . . . . . . . . . . . . . . . . 56

approximation settings . . . . . . . . . . . . . . . . . . . . . . . 45
overriding . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54

approximation styles . . . . . . . . . . . . . . . . . . . . . . . . . 47

Area Gradient (SWF and SVG only) . . . . . . . . . . . 217
Rendering

283



Index
Area Lights
mental ray . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

artifacts
2D motion blur . . . . . . . . . . . . . . . . . . . . . . . . . . 126
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132
clipping plane. . . . . . . . . . . . . . . . . . . . . . . . . . . 132
fixing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 124

aspect ratio
image . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 164
pixel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80, 95, 96

At Top/At Bottom attribute . . . . . . . . . . . . . . . . . . 171

atmosphere . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 175

Attribute Editor
Rendering Flags . . . . . . . . . . . . . . . . . . . . . . . . . . 20
surface settings. . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Attributes
option in Hardware Render Buffer . . . . . . . . . 242

Auto Render Region
in Render View  . . . . . . . . . . . . . . . . . . . . . . . . . 229

Auto Resize
in Render View  . . . . . . . . . . . . . . . . . . . . . . . . . 229

Automatic
tessellation mode . . . . . . . . . . . . . . . . . . . . . . . . 258

Average Color  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 217

AVI image format  . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

azimuth
description  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

B
Back attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

background
rendering problems . . . . . . . . . . . . . . . . . . . . . . 124

Background Color
Display Options . . . . . . . . . . . . . . . . . . . . . . . . . 241

Background Color attribute
Environment attributes. . . . . . . . . . . . . . . . . . . 273

Basic camera . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

Batch Render. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 255
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72
advantages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72
and IPR . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
animation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115
cancel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 256
error handling  . . . . . . . . . . . . . . . . . . . . . . . 22, 142
show  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 256
still image . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

Batch Render Frame window. . . . . . . . . . . . . . . . . 115

Best Guess Based on Screen Size
primary tessellation. . . . . . . . . . . . . . . . . . . . . . 262

Bias
Raytracing Quality  . . . . . . . . . . . . . . . . . . . . . . 172

bitmap
image file format . . . . . . . . . . . . . . . . . . . . . . . . . 78

blobby surface
anti-aliasing problem  . . . . . . . . . . . . . . . . . . . . 121

block ordered textures  . . . . . . . . . . . . . . . . . . . . . . 139

Blue Channel
Render View. . . . . . . . . . . . . . . . . . . . . . . . . . . . 229

Blur
By Frame, Motion Blur . . . . . . . . . . . . . . . . . . . 173
Length, 2D Motion Blur . . . . . . . . . . . . . . . . . . 173
Sharpness, 2D Motion Blur  . . . . . . . . . . . . . . . 174

blur . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Blur by Frame attribute . . . . . . . . . . . . . . . . . . . . . . 210

BOT  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139

BOT files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139

Both attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Both Fields
Interlaced  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170
Separate. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170

Bounding Box
Dolly camera setting . . . . . . . . . . . . . . . . . . . . . 277

Box attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 192

Box Filter attribute . . . . . . . . . . . . . . . . . . . . . . . . . . 186

BSP (default) attribute . . . . . . . . . . . . . . . . . . . . . . . 200

BSP Depth attribute . . . . . . . . . . . . . . . . . . . . . . . . . 201

BSP settings. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136

BSP Size attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 201

Bump mapping  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122

Bump Texture Resolution . . . . . . . . . . . . . . . . . . . . 208

Bump Texture Resolution attribute. . . . . . . . . . . . 208
Rendering 

284



Index
By Frame
Hardware Render Globals . . . . . . . . . . . . . . . . 236
Image File Output . . . . . . . . . . . . . . . . . . . . 95, 160
Renumber Frames, Render Globals  . . . . . . . . 162

C
cache size limit, for approximation . . . . . . . . . . . . . 55

Calculation attribute  . . . . . . . . . . . . . . . . . . . . . . . . 190

Camera
attributes in Render Globals  . . . . . . . . . . . . . . 161
optimizing, render faster  . . . . . . . . . . . . . . . . . 138
Select Camera option  . . . . . . . . . . . . . . . . . . . . 265

camera
Center of Interest option. . . . . . . . . . . . . . 248, 275

Camera and Aim  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

Camera Aperture . . . . . . . . . . . . . . . . . . . . . . . . . . . 270

Camera Icons attribute  . . . . . . . . . . . . . . . . . . . . . . 241

Camera Properties attributes . . . . . . . . . . . . . . . . . 247

Camera Settings option, View menu  . . . . . . . . . . 265

camera tools  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Camera Tools option, View menu. . . . . . . . . . . . . . 39

Camera, Aim, and Up . . . . . . . . . . . . . . . . . . . . . . . . 27

cameras
adjusting attributes . . . . . . . . . . . . . . . . . . . . . . . 35
aiming . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30, 39
azimuth . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
changing settings . . . . . . . . . . . . . . . . . . . . . . . . 265
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
dollying . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
elevation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
field chart  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268
fill . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268
film gate  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 266
fly . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
frustrum  . . . . . . . . . . . . . . . . . . . . . . . . . . . 265, 266
gate. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265
horizontal  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268
journal . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265
looking through . . . . . . . . . . . . . . . . . . . . . . . 38, 40
making renderable. . . . . . . . . . . . . . . . . . . . . . . . 36
oversan  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268
perspective . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265
resolution gate . . . . . . . . . . . . . . . . . . . . . . . . . . 267
rolling  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

safe action . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268
safe title . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34, 268
save movements  . . . . . . . . . . . . . . . . . . . . . . . . . 41
selecting current. . . . . . . . . . . . . . . . . . . . . . . . . . 38
tilt . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
tracking . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
tumbling . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
types of  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
viewing vs. rendering . . . . . . . . . . . . . . . . . . . . . 27
yaw  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
zoom  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Cancel Batch Render . . . . . . . . . . . . . . . . . . . . . . . . 256

cancelling
IPR . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108

Casts Shadows
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 279

Casts Shadows attribute
Render Stats attributes . . . . . . . . . . . . . . . . . . . 279

Caustic
Rendering Flag. . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Caustic Accuracy attribute . . . . . . . . . . . . . . . . . . . 192

Caustic Filter Kernel attribute . . . . . . . . . . . . . . . . 192

Caustic Filter Type attribute. . . . . . . . . . . . . . . . . . 192

Caustic Radius attribute . . . . . . . . . . . . . . . . . . . . . 192

caustics
troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . 138

Caustics attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 192

Caustics/Global Illumination attribute  . . . . . . . . 198

Center of interest . . . . . . . . . . . . . . . . . . . . . . . 248, 275

channels
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82, 84
premultiplication . . . . . . . . . . . . . . . . . . . . . . . . . 84

Channels attribute . . . . . . . . . . . . . . . . . . . . . . . . . . 161

Chord Height . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 262

Chord Height Ratio attribute . . . . . . . . . . . . . . . . . 263

Chord Height Ratio, Use. . . . . . . . . . . . . . . . . . . . . 263

Cineon format. . . . . . . . . . . . . . . . . . . . . . . . . . . 75, 142

client. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146

client setup  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149

Clip Final Shaded Color attribute . . . . . . . . . . . . . 176

clipping plane
artifacts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132

clipping planes
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Rendering

285



Index
Close IPR File
Render View window . . . . . . . . . . . . . . . . . . . . 225

Close option
Hardware Render Buffer  . . . . . . . . . . . . . . . . . 242

Closest Visible Depth
Depth Type . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 273

Collision Icons attribute  . . . . . . . . . . . . . . . . . . . . . 241

color channels
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
enabling. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

Color Texture Resolution . . . . . . . . . . . . . . . . . . . . 208

Color Texture Resolution attribute . . . . . . . . . . . . 208

Colorclip attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . 199

Combine Fills and Edges (SWF only) . . . . . . . . . . 212

command line rendering. . . . . . . . . . . . . . 72, 117, 154

common tab
Render Globals. . . . . . . . . . . . . . . . . . . . . . . . . . 159

Composite
Threshold  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 177

compositing
arranging objects . . . . . . . . . . . . . . . . . . . . . . . . . 85
rendering tips . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

Compress (SVG only)  . . . . . . . . . . . . . . . . . . . . . . . 213

Compute From
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 259

Cone Angle . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Cone attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 192

Console  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22, 142

contours
custom shaders  . . . . . . . . . . . . . . . . . . . . . . . . . 198

Contrast Sensitive Production attribute . . . . . . . . 166

Coverage attribute
Anti-aliasing Quality attributes. . . . . . . . . . . . 169

CPUs
multi-thread rendering . . . . . . . . . . . . . . . . . . . 180
use all available for multi-thread rendering . 180

Culling attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . 209

Culling Threshold attribute  . . . . . . . . . . . . . . . . . . 210

Current Frame
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 259

Current View
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 259

Curvature Tolerance
Set NURBS Tessellation  . . . . . . . . . . . . . . . . . . 259

Curve Tolerance . . . . . . . . . . . . . . . . . . . . . . . . . . . . 213

Custom  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207

Custom attribute  . . . . . . . . . . . . . . . . . . . . . . . 165, 207

Custom Cameras Text . . . . . . . . . . . . . . . . . . . . . . . 207

Custom Extension attribute . . . . . . . . . . . . . . . . . . 171

Custom Global Text. . . . . . . . . . . . . . . . . . . . . . . . . 206

Custom Global Text attribute. . . . . . . . . . . . . . . . . 206

Custom Globals  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Custom Globals attribute . . . . . . . . . . . . . . . . . . . . 206

Custom Lights attribute  . . . . . . . . . . . . . . . . . . . . . 207

Custom Lights Text . . . . . . . . . . . . . . . . . . . . . . . . . 207

Custom Options Text  . . . . . . . . . . . . . . . . . . . . . . . 206

Custom Options Text attribute  . . . . . . . . . . . . . . . 206

Custom Scene . . . . . . . . . . . . . . . . . . . . . . . . . . . 21, 206

Custom Scene attribute . . . . . . . . . . . . . . . . . . . . . . 206

Custom Scene Text. . . . . . . . . . . . . . . . . . . . . . . . . . 207

Custom shaders, contours  . . . . . . . . . . . . . . . . . . . 198

Custom Textures  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Custom Vertex Data  . . . . . . . . . . . . . . . . . . . . . . . . . 21

Customization attribute  . . . . . . . . . . . . . . . . . . . . . 204

customizations
mental ray for Maya . . . . . . . . . . . . . . . . . . . . . . 21

D
Data Type attribute . . . . . . . . . . . . . . . . . . . . . . . . . 199

Default Field Extension (o and e) attribute  . . . . . 171

Depth attribute
Output Settings attributes  . . . . . . . . . . . . . . . . 273

depth channel
description  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Depth Channel (Z Depth) . . . . . . . . . . . . . . . . . . . . 161

depth channels
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82, 84
enabling. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

depth file
description, for cameras . . . . . . . . . . . . . . . . . . 273

depth files
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

depth information
IFF files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Rendering 

286



Index
Depth Jitter
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 282

depth map shadows
optimizing. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Depth Of Field  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 271

Depth of Field
rendering. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

Depth Of Field attribute  . . . . . . . . . . . . . . . . . . . . . 271

Depth Type
Closest Visible Depth  . . . . . . . . . . . . . . . . . . . . 273
Furthest Visible Depth  . . . . . . . . . . . . . . . . . . . 273
Output Settings attributes  . . . . . . . . . . . . . . . . 273

Depth-of-field . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123

derive from Maya. . . . . . . . . . . . . . . . . . . . . 18, 45, 121

Desaturate attribute . . . . . . . . . . . . . . . . . . . . . . . . . 199

Detail Level . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Detail Level Preset . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Device Aspect Ratio attribute. . . . . . . . . . . . . . . . . 164

Diagnose BSP attribute . . . . . . . . . . . . . . . . . . . . . . 198

Diagnose Grid. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

Diagnose Grid attribute  . . . . . . . . . . . . . . . . . . . . . 197

Diagnose Photon  . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

Diagnose Photon attribute  . . . . . . . . . . . . . . . . . . . 198

Diagnose Photon Density . . . . . . . . . . . . . . . . . . . . 142

Diagnose Samples  . . . . . . . . . . . . . . . . . . . . . . . . . . 142

Diagnose Samples attribute  . . . . . . . . . . . . . . . . . . 197

diagnosing
scenes. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

Diagnostics  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

differences
mental ray for Maya  . . . . . . . . . . . . . . . . . . . . . . 18

Diffuse
Render Layer Pass . . . . . . . . . . . . . . . . . . . . . . . . 88

Direct Illumination Shadow Effects attribute  . . . 194

Disk Based Dmaps . . . . . . . . . . . . . . . . . . . . . . . . . . 138

displacement. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122

displacement mapping
performance . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 127

Display Alpha Channel button
Render View window . . . . . . . . . . . . . . . . . . . . 230

Display Field Chart attribute . . . . . . . . . . . . . . . . . 274

Display Film Gate attribute  . . . . . . . . . . . . . . . . . . 274

Display menu
Render View window . . . . . . . . . . . . . . . . . . . . 229

Display Options attributes
cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274
Hardware Render Globals . . . . . . . . . . . . . . . . 241

Display Real Size button
Render View window . . . . . . . . . . . . . . . . . . . . 230

Display Resolution attribute  . . . . . . . . . . . . . . . . . 274

Display RGB Channels button
Render View window . . . . . . . . . . . . . . . . . . . . 230

Display Safe Action attribute . . . . . . . . . . . . . . . . . 274

Display Safe Title attribute . . . . . . . . . . . . . . . . . . . 275

Display Shadows attribute . . . . . . . . . . . . . . . . . . . 239

Distributed Render (Save)  . . . . . . . . . . . . . . . . . . . 256

distributed rendering  . . . . . . . . . . . . . . . . . . . . . . . 145

Dither attribute. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 200

Dithered option
Render View window . . . . . . . . . . . . . . . . . . . . 229

Dmap Filter Size. . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Dmap Focus attribute  . . . . . . . . . . . . . . . . . . . . . . . 137

Dmap Resolution . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Dolly
Bounding Box camera setting  . . . . . . . . . . . . . 277
camera settings  . . . . . . . . . . . . . . . . . . . . . . . . . 277
Local camera setting . . . . . . . . . . . . . . . . . . . . . 277
Snap box dolly to camera settings  . . . . . . . . . 277
Surface camera setting  . . . . . . . . . . . . . . . . . . . 277

dollying, cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Double Sided
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

Draft attribute. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

Draft motion blur attribute. . . . . . . . . . . . . . . . . . . 184

Draw Style attribute  . . . . . . . . . . . . . . . . . . . . . . . . 238

E
Edge Anti-aliasing attribute . . . . . . . . . . . . . . . . . . 166

Edge Color  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 223

Edge Detail . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 223

Edge Smoothing attribute. . . . . . . . . . . . . . . . . . . . 240

Edge Style . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 223

Edge Swap
Set NURBS Tessellation  . . . . . . . . . . . . . . . . . . 260
Rendering

287



Index
Edge Weight . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 222

Edge Weight Preset . . . . . . . . . . . . . . . . . . . . . . . . . 222

edges
rendering problems . . . . . . . . . . . . . . . . . . . . . . 124
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 126

elevation
description, for azimuth elevation tool  . . . . . . 31

Emitter Icons attribute. . . . . . . . . . . . . . . . . . . . . . . 241

Enable Default Light . . . . . . . . . . . . . . . . . . . . . . . . 164

Enable Default Light attribute . . . . . . . . . . . . . . . . 164

Enable Depth Maps attribute . . . . . . . . . . . . . . . . . 176

Enable Global Passes attribute . . . . . . . . . . . . . . . . 182

Enable Render Layer Passes attribute. . . . . . . . . . 182

Enable Render Layers . . . . . . . . . . . . . . . . . . . 211, 224

Enable Render Layers attribute . . . . . . . . . . . . . . . 181

Enable Stroke Rendering attribute  . . . . . . . . . . . . 182

End Frame attribute
Image File Output attributes . . . . . . . . . . . 95, 160
Image Output Files attributes  . . . . . . . . . . . . . 236

Environment attributes . . . . . . . . . . . . . . . . . . . . . . 273

Environment Fog attribute . . . . . . . . . . . . . . . . . . . 175

error handling
mental ray for Maya  . . . . . . . . . . . . . . . . . . 22, 142

errors, rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . . 141

Even Field . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170, 171

Exact . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20, 29

export
to mi . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118

Export All Incoming Shaders . . . . . . . . . . . . . . . . . 246

Export Custom Colors attribute. . . . . . . . . . . . . . . 204

Export Custom Data attribute  . . . . . . . . . . . . . . . . 205

Export Custom Motion attribute . . . . . . . . . . . . . . 205

Export Custom Text attribute. . . . . . . . . . . . . . . . . 204

Export Custom Vectors attribute . . . . . . . . . . . . . . 205

Export Entire Child DAG . . . . . . . . . . . . . . . . . . . . 247

Export Exact Hierarchy attribute. . . . . . . . . . . . . . 202

Export Full Dagpath attribute  . . . . . . . . . . . . . . . . 202

Export Light Linker attribute . . . . . . . . . . . . . . . . . 204

Export Maya Options attribute  . . . . . . . . . . . . . . . 204

Export Nurbs Derivatives attribute. . . . . . . . . . . . 203

Export Polygon Derivatives attribute . . . . . . . . . . 203

Export Shape Deformation attribute . . . . . . . . . . . 203

Export State Shader attribute . . . . . . . . . . . . . . . . . 204

Export Textures First attribute . . . . . . . . . . . . . . . . 202

Export Verbosity attribute  . . . . . . . . . . . . . . . . . . . 202

exporting
.mi files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72, 118
optimizing .mi format. . . . . . . . . . . . . . . . . . . . . 72

Extension attribute. . . . . . . . . . . . . . . . . . . . . . . . . . 236

extension, image. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

F
F Stop attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 272

Faces attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Falloff Start attribute . . . . . . . . . . . . . . . . . . . . . . . . 196

Falloff Stop attribute . . . . . . . . . . . . . . . . . . . . . . . . 196

Far Clip Plane attribute . . . . . . . . . . . . . . . . . . . . . . 250

far clipping plane . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34

Field
options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170

Field Chart option . . . . . . . . . . . . . . . . . . . . . . . . . . 268

Field Dominance
Even Fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170
Odd Fields  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170
render options  . . . . . . . . . . . . . . . . . . . . . . . . . . 170

Field Dominance attribute  . . . . . . . . . . . . . . . . . . . 124

Field Icons attribute . . . . . . . . . . . . . . . . . . . . . . . . . 241

Field Options attributes  . . . . . . . . . . . . . . . . . . . . . 169

field rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

fields. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
description  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Even . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 171
interlacing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98
rendering problems. . . . . . . . . . . . . . . . . . . . . . 124
vs. frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

File Export . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

file format, image . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

file formats
bitmap vs. vector . . . . . . . . . . . . . . . . . . . . . . . . . 74
rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

File menu
Render View window . . . . . . . . . . . . . . . . . . . . 225

File Name Prefix attribute  . . . . . . . . . . . . . . . . . . . 160
Rendering 

288



Index
file name, image . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

Filename attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . 236

files
rendering output location  . . . . . . . . . . . . . . . . . 79

Fill Objects. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Fill option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268

Fill Style . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Film Aspect Ratio attribute. . . . . . . . . . . . . . . . . . . 270

Film Back attributes . . . . . . . . . . . . . . . . . . . . . . . . . 270

Film Back Properties attributes  . . . . . . . . . . . . . . . 248

Film Gate attribute . . . . . . . . . . . . . . . . . . . . . . . . . . 270

Film Gate option. . . . . . . . . . . . . . . . . . . . . . . . . . . . 266

Film Offset attribute  . . . . . . . . . . . . . . . . . . . . . . . . 271

Filter attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 195

Filter Height attribute . . . . . . . . . . . . . . . . . . . . . . . 186

Filter Width attribute. . . . . . . . . . . . . . . . . . . . . . . . 186

final gather
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 139

Final Gather attribute  . . . . . . . . . . . . . . . . . . . . . . . 194

Final Gather File attribute. . . . . . . . . . . . . . . . . . . . 196

Final Gather Rays attribute. . . . . . . . . . . . . . . . . . . 195

Final Gather Rebuild attribute . . . . . . . . . . . . . . . . 196

Fine Approximation  . . . . . . . . . . . . . . . . . . . . . . . . . 56

fine approximation  . . . . . . . . . . . . . . . . . . . . . . . . . . 47
controling triangles . . . . . . . . . . . . . . . . . . . . . . . 55
setting cache limit  . . . . . . . . . . . . . . . . . . . . . . . . 55

Fine Displacement . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Fix Texture Warp
description  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Flash
rendering. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

Flash Version (SWF only) . . . . . . . . . . . . . . . . . . . . 211

flicker
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 131
fixing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134

flickering animations
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 127

Flipbook Options . . . . . . . . . . . . . . . . . . . . . . . . . . . 244

Flipbooks menu
Hardware Render Buffer  . . . . . . . . . . . . . . . . . 244

Fly Tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

fly, cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

focal length . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Focus Distance attribute . . . . . . . . . . . . . . . . . . . . . 271

Focus Region Scale attribute  . . . . . . . . . . . . . . . . . 272

focus, vs. motion blur  . . . . . . . . . . . . . . . . . . . . . . . . 28

fog
motion blur artifacts . . . . . . . . . . . . . . . . . . . . . 126

Fog Shadow Samples  . . . . . . . . . . . . . . . . . . . . . . . 138

format, image file
setting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

Four Color . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 216

frame
rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Frame All option
Maya View menu  . . . . . . . . . . . . . . . . . . . . . . . . 40

Frame Image option
Render View window . . . . . . . . . . . . . . . . . . . . 226

Frame Padding attribute . . . . . . . . . . . . . . . . . . 95, 161

Frame Range, Use
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 258

Frame Rate (SWF and SVG only)  . . . . . . . . . . . . . 211

Frame Region option
Render View window . . . . . . . . . . . . . . . . . . . . 226

Frame Selection  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Frame/Animation Ext attribute. . . . . . . . . . . . 94, 160

Frames
render  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170

frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
batch rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . 72
command line rendering  . . . . . . . . . . . . . . 72, 117
low-res rendering  . . . . . . . . . . . . . . . . . . . . . . . 111
rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98
rendering single . . . . . . . . . . . . . . . . . . . . . . . . . 114
test render . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111
vs. fields  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Front attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

frustrum  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265, 266
renderable . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 267

fstop . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Full Color  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 216

Full Image Resolution attribute . . . . . . . . . . . . . . . 239

Furthest Visible Depth
Depth Type . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 273
Rendering

289



Index
G
Gamma attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . 199

Gamma Correction attribute  . . . . . . . . . . . . . . . . . 176

gate . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265

Gaussian Filter attribute . . . . . . . . . . . . . . . . . . . . . 186

geometry
assigning approximation to . . . . . . . . . . . . . . . . 53
mental ray approximation . . . . . . . . . . . . . . . . . 48
NURBS  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

Geometry Antialiasing Override
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

Geometry Mask attribute  . . . . . . . . . . . . . . . . . . . . 239

geometry types
mental ray for Maya  . . . . . . . . . . . . . . . . . . . . . . 48

gGlobal illumination
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 138

GIF format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

Global Illum Accuracy attribute  . . . . . . . . . . . . . . 193

Global Illum Radius attribute  . . . . . . . . . . . . . . . . 193

Global Illumination attribute . . . . . . . . . . . . . . . . . 192

Globillum
Rendering Flag . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Grab Swatch to Hypershade & Visor button
Render View window . . . . . . . . . . . . . . . . . . . . 226

Green attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 169

Green Channel option
Render View . . . . . . . . . . . . . . . . . . . . . . . . . . . . 229

Grid attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . 201, 241

Grid Depth attribute  . . . . . . . . . . . . . . . . . . . . . . . . 201

Grid Max Size attribute . . . . . . . . . . . . . . . . . . . . . . 201

Grid Resolution attribute  . . . . . . . . . . . . . . . . . . . . 201

Grid Size  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

Grid Size attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . 197

guidelines, in scene views. . . . . . . . . . . . . . . . . . . . . 36

H
hardware rendering. . . . . . . . . . . . . . . . . . . . . . . . . . 15

Render Globals. . . . . . . . . . . . . . . . . . . . . . . . . . 207

HDR images  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

HDRI  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

HDTV. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

Height attribute
Resolution attributes . . . . . . . . . . . . . . . . . . 96, 164

Hidden Edges . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 223

High Quality attribute. . . . . . . . . . . . . . . . . . . . . . . 166

Highest Quality attribute . . . . . . . . . . . . . . . . . . . . 166

Highlight Level (SWF and bitmap formats only) 221

highlights
troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . 128

Highlights (SWF and bitmap formats only)  . . . . 220

Horizontal Film Aperture attribute
see Camera Aperture attribute

Horizontal Film Offset attribute
see Film Offset attribute

Horizontal option. . . . . . . . . . . . . . . . . . . . . . . . . . . 268

I
IBL attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 198

IFF image
depth information . . . . . . . . . . . . . . . . . . . . . . . . 18

Ignore Film Gate attribute  . . . . . . . . . . . . . . . . . . . 175

Ignore Glows
Render View. . . . . . . . . . . . . . . . . . . . . . . . . . . . 229

Ignore Shadows
Render View. . . . . . . . . . . . . . . . . . . . . . . . . . . . 229

image
filtering . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101

image aspect ratio  . . . . . . . . . . . . . . . . . . . . . . . . . . 164

Image attribute
Output Settings  . . . . . . . . . . . . . . . . . . . . . . . . . 272

Image Based Lighting attributes . . . . . . . . . . . . . . 198

image file formats
setting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

Image File Output attributes  . . . . . . . . . . . . . . . . . 160

Image Format attribute
Image File Output attributes . . . . . . . . . . . 93, 160
Image Output Files attributes  . . . . . . . . . . . . . 236

Image Output Files attributes  . . . . . . . . . . . . . . . . 236

Image Plane attribute
Environment attributes. . . . . . . . . . . . . . . . . . . 274
Rendering 

290



Index
images
aspect ratio . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 164
directory  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
extension . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
fields  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
file format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
file name . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
name  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
pixel aspect ratio  . . . . . . . . . . . . . . . . . . . . . . . . . 95
premultiplied . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84
rendering quality . . . . . . . . . . . . . . . . . . . . . . . . 131
rendering speed . . . . . . . . . . . . . . . . . . . . . . . . . 131
resolution  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95

images, keeping rendered
Render View . . . . . . . . . . . . . . . . . . . . . . . . . . . . 231

Include Edges . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 222

Interactive Photorealistic Rendering. See IPR . . . . 67

interactive rendering, multi-threaded  . . . . . . . . . 180

interlacing
description  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Intermediate . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207

Intermediate Quality attribute . . . . . . . . . . . . . . . . 165

Interpolate Samples attribute . . . . . . . . . . . . . . . . . 199

IPR
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67
batch rendering  . . . . . . . . . . . . . . . . . . . . . . . . . 109
canceling . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
cancelling  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108
how it works. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67
limitations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105
pausing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
rendering with . . . . . . . . . . . . . . . . . . . . . . . . . . 107
saving  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 128

IPR default light . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

IPR menu
Render View window . . . . . . . . . . . . . . . . . . . . 227

IPR Render Current Frame . . . . . . . . . . . . . . . . . . . 254

IPR Render option
Render View window . . . . . . . . . . . . . . . . . . . . 227

IPR Tuning Options
Render View window . . . . . . . . . . . . . . . . . . . . 228

IRIX setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149

IRP
troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . 125

J
Jitter attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187

Jitter Final Color attribute. . . . . . . . . . . . . . . . . . . . 176

Journal . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41

Journal Command attribute . . . . . . . . . . . . . . . . . . 275

Journal option. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265

JPEG format  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

K
Keep Image

Render View. . . . . . . . . . . . . . . . . . . . . . . . . . . . 231

Keep Image in Render View option
Render View window . . . . . . . . . . . . . . . . . . . . 225

Keep Motion Vectors
2D Motion Blur  . . . . . . . . . . . . . . . . . . . . . . . . . 174

L
Lanczos attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 186

Layer Editor  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Layered Shader
performance . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

layers
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85
advantages of . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105
Display vs. Render  . . . . . . . . . . . . . . . . . . . . . . . 86

Leaf Primitives attribute . . . . . . . . . . . . . . . . . . . . . 179

lens . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Lens Properties attributes . . . . . . . . . . . . . . . . . . . . 248

Light Icons attribute  . . . . . . . . . . . . . . . . . . . . . . . . 241

Lighting Mode attribute . . . . . . . . . . . . . . . . . . . . . 238

Line Smoothing attribute  . . . . . . . . . . . . . . . . . . . . 239

Linear . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20, 29

Linux setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149

Local
Dolly camera setting . . . . . . . . . . . . . . . . . . . . . 277

Lock Device Aspect Ratio attribute . . . . . . . . . . . . 164
Rendering

291



Index
Locked
Tumble camera setting . . . . . . . . . . . . . . . . . . . 275

Logfile  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22, 142

Look At Selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Look Through Selected option, Panels menu  . . . . 38

Low Quality attribute  . . . . . . . . . . . . . . . . . . . . . . . 166

Luminance option
Render View window . . . . . . . . . . . . . . . . . . . . 229

M
Maintain Width/Height Ratio attribute . . . . . . . . 164

Manual
tessellation mode . . . . . . . . . . . . . . . . . . . . . . . . 258

mask
description, for cameras . . . . . . . . . . . . . . . . . . 272

Mask attribute
Output Settings attributes  . . . . . . . . . . . . . . . . 272

Mask Channel
or alpha channel. . . . . . . . . . . . . . . . . . . . . . . . . . 85
Render View . . . . . . . . . . . . . . . . . . . . . . . . . . . . 229

mask channels
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84
about, alpha channels
about82

enabling. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
modifying . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97

matte opacity  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123

Matte Opacity attribute . . . . . . . . . . . . . . . . . . . . . . . 97

Matte Opacity Mode attribute . . . . . . . . . . . . . . 97, 98

matte transparency, see Matte Opacity  . . . . . . . . . 97

Max 3D Blur Visib attribute . . . . . . . . . . . . . . . . . . 168

Max Photon Depth attribute. . . . . . . . . . . . . . . . . . 193

Max Radius attribute . . . . . . . . . . . . . . . . . . . . . . . . 195

Max Reflection Photons attribute  . . . . . . . . . . . . . 193

Max Refraction Photons attribute . . . . . . . . . . . . . 193

Max Sample Level attribute . . . . . . . . . . . . . . . . . . 185

Max Shading attribute . . . . . . . . . . . . . . . . . . . . . . . 167

Max Shading Samples
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 281

Max Shading Samples attribute . . . . . . . . . . . . . . . 167

Max Trace Depth attribute . . . . . . . . . . . . . . . . . . . 187

Max Visib Samples attribute  . . . . . . . . . . . . . . . . . 167

Maya Hardware
Render Globals. . . . . . . . . . . . . . . . . . . . . . . . . . 207

Maya IFF format. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Maya Vector
Render Globals. . . . . . . . . . . . . . . . . . . . . . . . . . 211

maya.rayhosts. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 147

maya.rayrc  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 147

Maya16 IFF format. . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Medium Quality attribute  . . . . . . . . . . . . . . . . . . . 166

MEL commands
run at render time . . . . . . . . . . . . . . . . . . . . . . . . 82
running after rendering  . . . . . . . . . . . . . . . . . . . 99
running before rendering . . . . . . . . . . . . . . . . . . 99

Memory and Performance Options. . . . . . . . . . . . 180

Memory and Performance Options attributes. . . 177

memory exceptions . . . . . . . . . . . . . . . . . . . . . . . . . 121

mental ray . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 147
approximation . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
Area Lights . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
BSP settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136
configuration files . . . . . . . . . . . . . . . . . . . . . . . 147
exporting .mi files . . . . . . . . . . . . . . . . . . . . . . . 118
exporting files  . . . . . . . . . . . . . . . . . . . . . . . . . . . 72
motion blur . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
network rendering. . . . . . . . . . . . . . . . . . . . . . . 146
output window messages  . . . . . . . . . . . . . . . . . 26
Render Globals. . . . . . . . . . . . . . . . . . . . . . . . . . 184
rendering problems. . . . . . . . . . . . . . . . . . 121, 122
rendering with . . . . . . . . . . . . . . . . . . . . . . . . . . 118

mental ray for Maya
Animation. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
customizations . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
differences  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
error handling  . . . . . . . . . . . . . . . . . . . . . . . 22, 142
geometry types  . . . . . . . . . . . . . . . . . . . . . . . . . . 48
NURBS surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . 48
polygonal meshes  . . . . . . . . . . . . . . . . . . . . . . . . 48
shading networks  . . . . . . . . . . . . . . . . . . . . . . . . 19
subdivision surfaces . . . . . . . . . . . . . . . . . . . . . . 49

mentay ray
approximation . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

Mesh Gradient (SWF and SVG only)  . . . . . . . . . . 218

miDeformation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Min Edge Angle . . . . . . . . . . . . . . . . . . . . . . . . . . . . 224
Rendering 

292



Index
Min Radius attribute . . . . . . . . . . . . . . . . . . . . . . . . 195

Min Sample Level attribute  . . . . . . . . . . . . . . . . . . 185

Min Screen attribute
Secondary Tessellation Attributes  . . . . . . . . . 264

miTangents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Mitchell attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 186

Mode U attribute
Tessellation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 261

Mode V attribute
Tessellation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 261

Modify Extensions attributes . . . . . . . . . . . . . . . . . 162

moire patterns. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187

Motion Back Offset attribute  . . . . . . . . . . . . . . . . . 205

Motion Blur . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20, 29
2D troubleshooting . . . . . . . . . . . . . . . . . . . . . . 124
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
diagnostics  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 279
Tips  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 174

motion blur
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
artifacts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 128

Motion Blur attribute. . . . . . . . . . . . . . . . 173, 190, 210
Multi-Pass Render Options  . . . . . . . . . . . . . . . 240

Motion Blur attributes
Create Camera Options  . . . . . . . . . . . . . . . . . . 250
Render Globals window . . . . . . . . . . . . . . . . . . 173

Motion Blur By attribute . . . . . . . . . . . . . . . . . . . . . 190

Motion Blur Shadow Maps attribute  . . . . . . . . . . 190

Motion Blur Type attribute. . . . . . . . . . . . . . . . . . . 173

motion blur, vs. focus  . . . . . . . . . . . . . . . . . . . . . . . . 28

Motion Object Output attribute . . . . . . . . . . . . . . . 205

motion picture
rendering fields  . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Motion Steps attribute . . . . . . . . . . . . . . . . . . . . . . . 191

Multi Pass Rendering attribute  . . . . . . . . . . . . . . . 240

Multi Processing. . . . . . . . . . . . . . . . . . . . . . . . . . . . 180

Multi-Pass Render Options attributes. . . . . . . . . . 240

multi-pixel filter . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101

multiple processors . . . . . . . . . . . . . . . . . . . . . . . . . 105

multi-processor rendering  . . . . . . . . . . . . . . . . . . . 116

multi-thread interactive rendering . . . . . . . . . . . . 180

N
name

images, setting . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

Near Clip Plane attribute  . . . . . . . . . . . . . . . . . . . . 250

near clipping plane  . . . . . . . . . . . . . . . . . . . . . . . . . . 34

network rendering . . . . . . . . . . . . . . . . . . 145, 146, 154
troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . 155

No Field Extension attribute  . . . . . . . . . . . . . . . . . 171

No Gate option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265

nodes
approximation . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
creating approximation  . . . . . . . . . . . . . . . . . . . 52

NTSC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 124

NTSC video. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81, 142

Number of CPUs to use  . . . . . . . . . . . . . . . . . . . . . 180

Number of Exposures attribute . . . . . . . . . . . . . . . 210

Number of Processors to Use attribute. . . . . 116, 256

Number of Samples . . . . . . . . . . . . . . . . . . . . . . . . . 208

Number of Samples attribute . . . . . . . . . . . . . . . . . 208

Number U attribute
Tessellation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 262

Number V attribute
Tessellation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 262

NURBS
approximation . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
display tessellation  . . . . . . . . . . . . . . . . . . . . . . . 51
surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

NURBs
multi-uv rendering problems  . . . . . . . . . . . . . 119
tessellation settings . . . . . . . . . . . . . . . . . . . . . . . 50

NURBS surfaces
mental ray for Maya . . . . . . . . . . . . . . . . . . . . . . 48

O
objects

framing with camera. . . . . . . . . . . . . . . . . . . . . . 40
mental ray approximation . . . . . . . . . . . . . . . . . 48
rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
tesselation settings. . . . . . . . . . . . . . . . . . . . . . . . 49
vibrating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 124
when to tessellate  . . . . . . . . . . . . . . . . . . . . . . . . 51

Odd Field attribute  . . . . . . . . . . . . . . . . . . . . . . . . . 171
Rendering

293



Index
Odd Fields. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170

Only Render Strokes attribute . . . . . . . . . . . . . . . . 183

Open Image option
Render View window . . . . . . . . . . . . . . . . . . . . 225

Open in Browser (SWF only) . . . . . . . . . . . . . . . . . 212

Open IPR File
Render View window . . . . . . . . . . . . . . . . . . . . 225

Open Render Globals Window  . . . . . . . . . . . . . . . 230

OpenGL attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

opengl mode attribute . . . . . . . . . . . . . . . . . . . . . . . 189

Opposite
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

Optimize Instances  . . . . . . . . . . . . . . . . . . . . . . . . . 136

Optimize Instances attribute  . . . . . . . . . . . . . . . . . 178

Optimize Raytrace Shadows attribute  . . . . . . . . . 204

optimizing
cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 138
scenes. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
shadows  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Options attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . 245

Options menu
Render View window . . . . . . . . . . . . . . . . . . . . 228

Ortho step
Tumble camera setting . . . . . . . . . . . . . . . . . . . 276

Orthographic Camera . . . . . . . . . . . . . . . . . . . . . . . 251

orthographic camera
width of . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 252

Orthographic views
camera settings. . . . . . . . . . . . . . . . . . . . . . . . . . 275

Orthographic Width  . . . . . . . . . . . . . . . . . . . . . . . . 252

Output Settings attributes. . . . . . . . . . . . . . . . . . . . 272

Output to Subdirectories attribute  . . . . . . . . . . . . 182

Output Window . . . . . . . . . . . . . . . . . . . . . . . . . 22, 142

Overscan camera attribute . . . . . . . . . . . . . . . . . . . 267

Overscan option . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268

P
PAL  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 124

PAL video . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81, 142

parallel rendering. . . . . . . . . . . . . . . . . . . . . . . . . . . 146

particle rendering
mental ray . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123

Particles attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 168

passes
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87
advantages of . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Pause IPR Tuning
Render View window . . . . . . . . . . . . . . . . . . . . 228

Per object attribute . . . . . . . . . . . . . . . . . . . . . . 208, 209

Per polygon attribute  . . . . . . . . . . . . . . . . . . . . . . . 208

Per Span # of Isoparms
primary tessellation. . . . . . . . . . . . . . . . . . . . . . 262

Per Surf # of Isoparms
primary tessellation. . . . . . . . . . . . . . . . . . . . . . 261

Per Surf # of Isoparms in 3D
primary tessellation. . . . . . . . . . . . . . . . . . . . . . 261

Performance attribute . . . . . . . . . . . . . . . . . . . . . . . 203

Perspective option . . . . . . . . . . . . . . . . . . . . . . . 38, 265

Photon Density attribute. . . . . . . . . . . . . . . . . . . . . 198

Photon Map File attribute. . . . . . . . . . . . . . . . . . . . 194

Photon Map Rebuild attribute . . . . . . . . . . . . . . . . 194

Photon Volume Accuracy attribute. . . . . . . . . . . . 193

Photon Volume Radius attribute . . . . . . . . . . . . . . 193

Photons Obey Light Linking attribute  . . . . . . . . . 204

Photoshop format  . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Physical Memory attribute . . . . . . . . . . . . . . . . . . . 202

Pix format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

pixel aspect ratio  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Pixel Aspect Ratio attribute  . . . . . . . . . . . . . . . 96, 164

Pixel Filter Type attribute . . . . . . . . . . . . . . . . . . . . 168

Pixel Filter Width X attribute . . . . . . . . . . . . . . . . . 169

Pixel Filter Width Y attribute . . . . . . . . . . . . . . . . . 169

pixels  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68, 80, 82

Plugin Format attribute. . . . . . . . . . . . . . . . . . . . . . 164

plug-ins
multi-pixel  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101

PNG format. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

polygonal meshes
mental ray for Maya . . . . . . . . . . . . . . . . . . . . . . 48

polygonal surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

polygons
approximation . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Rendering 

294



Index
port number
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 155

Post Fog Blurt
Render Options  . . . . . . . . . . . . . . . . . . . . . . . . . 175

Post Frame MEL attribute. . . . . . . . . . . . . . . . . . . . 165

Post Render MEL attribute . . . . . . . . . . . . . . . . . . . . 99

Pre Frame MEL attribute  . . . . . . . . . . . . . . . . . . . . 165

Pre Render MEL attribute . . . . . . . . . . . . . . . . . . . . . 99

Precompute Photon Lookup attribute  . . . . . . . . . 194

preemultiplied images, defined . . . . . . . . . . . . . . . . 84

Premultiply attribute . . . . . . . . . . . . . . . . . . . . . . . . 200

Presets
Render Resolution . . . . . . . . . . . . . . . . . . . . . . . 163

Presets attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

Preview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207

Preview Animation attribute . . . . . . . . . . . . . . . . . 205

Preview attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

Preview Custom attribute. . . . . . . . . . . . . . . . . . . . 205

Preview Final Gather Tiles attribute . . . . . . . . . . . 197

Preview Motion Blur attribute . . . . . . . . . . . . . . . . 205

Preview Quality attribute . . . . . . . . . . . . . . . . . . . . 165

Preview Render Tiles attribute  . . . . . . . . . . . . . . . 205

preview, renders  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

PreviewCaustics attribute. . . . . . . . . . . . . . . . . . . . 184

PreviewFur attribute . . . . . . . . . . . . . . . . . . . . . . . . 185

PreviewGlobalIllum attribute  . . . . . . . . . . . . . . . . 185

previewing
Resolution Gate . . . . . . . . . . . . . . . . . . . . . . . . . . 37

PreviewMotionBlur attribute . . . . . . . . . . . . . . . . . 185

Primary Tessellation
Best Guess Based on Screen Size . . . . . . . . . . . 262
Per Span # of Isoparms . . . . . . . . . . . . . . . . . . . 262
Per Surf # of Isoparms. . . . . . . . . . . . . . . . . . . . 261
Per Surf # of Isoparms in 3D  . . . . . . . . . . . . . . 261

primary tessellation . . . . . . . . . . . . . . . . . . . . . . . . . . 44

Primary Visibility
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 279

problems
messages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142
rendering. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141

processor, multiple  . . . . . . . . . . . . . . . . . . . . . . . . . 105

Production. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 208

Production attribute  . . . . . . . . . . . . . . . . . . . . . . . . 185

Production Quality attribute  . . . . . . . . . . . . . . . . . 166

ProductionMotionBlur attribute . . . . . . . . . . . . . . 185

projection textures
troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . 121

Prune Invisible Parts attribute . . . . . . . . . . . . . . . . 203

Q
quality

raytracing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Quantel format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

QuickDraw format. . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Quicktime image format (UNIX only)  . . . . . . . . . . 77

R
Ramp Shader

Motion Blur tips. . . . . . . . . . . . . . . . . . . . . . . . . 174

Rapid attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Raw attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 199

Ray Depth Limit. . . . . . . . . . . . . . . . . . . . . . . . . . . . 138

Ray Tracing attribute. . . . . . . . . . . . . . . . . . . . . . . . 187

rayserver
troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . 155

raytraced shadows
optimizing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 138

Raytracing
description  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

raytracing
setting quality  . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Raytracing attribute . . . . . . . . . . . . . . . . . . . . . . . . . 172

Raytracing Quality attributes. . . . . . . . . . . . . . . . . 171

Real Size option
Render View window . . . . . . . . . . . . . . . . . . . . 226

Rebuild Shadow Maps attribute  . . . . . . . . . . . . . . 189

Receive Shadows
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 279

Recursion Depth attribute  . . . . . . . . . . . . . . . . . . . 179

Red attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 169

Red Channel option
Render View. . . . . . . . . . . . . . . . . . . . . . . . . . . . 229
Rendering

295



Index
Redo Previous IPR Render option
Maya Render menu . . . . . . . . . . . . . . . . . . . . . . 254
Render View window . . . . . . . . . . . . . . . . . . . . 227

Redo Previous Render. . . . . . . . . . . . . . . . . . . . . . . 115

Redo Previous Render option
Maya Render menu . . . . . . . . . . . . . . . . . . . . . . 254
Render View window . . . . . . . . . . . . . . . . . . . . 226

Reflection Depth. . . . . . . . . . . . . . . . . . . . . . . . . . . . 221

Reflection Limit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Reflections attribute . . . . . . . . . . . . . . . . . . . . . 172, 187

Refraction Limit . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Refractions attribute
Raytracing Quality attributes  . . . . . . . . . 172, 187

Refresh IPR Image
Render View window . . . . . . . . . . . . . . . . . . . . 228

Remote Machine Name attribute. . . . . . . . . . . . . . 256

Remove Image from Render View option
Render View window . . . . . . . . . . . . . . . . . . . . 226

Render 2D Motion Blur attribute. . . . . . . . . . . . . . 181

Render Current Frame  . . . . . . . . . . . . . . . . . . . . . . 254
Maya Render menu . . . . . . . . . . . . . . . . . . . . . . 115

Render Diagnostics  . . . . . . . . . . . . . . . . . . . . . 141, 255

Render Diagnostics attribute . . . . . . . . . . . . . . . . . 225

Render Globals
common tab  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 259
settings window. . . . . . . . . . . . . . . . . . . . . . 92, 159

Render Globals option
Render View window . . . . . . . . . . . . . . . . . . . . 228

Render Globillum Global Pass attribute. . . . . . . . 204

Render Layer Options
Renderable  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Render menu
Render View window . . . . . . . . . . . . . . . . . . . . 226

Render Modes attributes. . . . . . . . . . . . . . . . . . . . . 238

Render option
Render View window . . . . . . . . . . . . . . . . . . . . 227

Render Options attributes  . . . . . . . . . . . . . . . 164, 175

Render Passes attribute . . . . . . . . . . . . . . . . . . . . . . 240

Render Region option
Render View window . . . . . . . . . . . . . . . . 227, 230

Render Resolution . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

Render Shading, Lighting and Glow attribute  . . 181

Render Shadow Maps attribute . . . . . . . . . . . . . . . 181

Render Stats  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 279

Render utility . . . . . . . . . . . . . . . . . . 112, 116, 117, 118

Render View
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Render View window
menus  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 224

Renderable
Render Layer options . . . . . . . . . . . . . . . . . . . . 106

Renderable attribute  . . . . . . . . . . . . . . . . . . . . . 36, 272

renderable cameras . . . . . . . . . . . . . . . . . . . . . . . . . 143

Renderable Objects attribute  . . . . . . . . . . . . . 161, 279

Renderable Scene . . . . . . . . . . . . . . . . . . . . . . . . . . . 246

renderer
choosing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
setting default  . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

renderers
Maya hardware . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Maya software . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
mental ray for Maya . . . . . . . . . . . . . . . . . . . . . . 17
selecting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
vector . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

rendering
active objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
at low-res  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111
background problems . . . . . . . . . . . . . . . . . . . . 124
BOT files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139
cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
command line. . . . . . . . . . . . . . . . . . . . . . . . . . . 154
depth of field  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
errors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141
exporting .mi files . . . . . . . . . . . . . . . . . . . . 72, 118
fields  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98
file formats . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73
file output location  . . . . . . . . . . . . . . . . . . . . . . . 79
final rendering . . . . . . . . . . . . . . . . . . . . . . . . . . . 91
final renders . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Flash  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98, 114
global settings window. . . . . . . . . . . . . . . . . . . . 92
hardware. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Rendering 

296



Index
hardware render globals  . . . . . . . . . . . . . . . . . 207
image output location . . . . . . . . . . . . . . . . . . . . . 95
image resolution  . . . . . . . . . . . . . . . . . . . . . . . . . 80
layers and passes . . . . . . . . . . . . . . . . . . . 83, 85, 87
looping forever. . . . . . . . . . . . . . . . . . . . . . . . . . 129
MEL scripts. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
mental ray BSP settings  . . . . . . . . . . . . . . . . . . 136
mental ray problems . . . . . . . . . . . . . . . . . 121, 122
mental ray render globals. . . . . . . . . . . . . . . . . 184
multiple scenes. . . . . . . . . . . . . . . . . . . . . . . . . . 119
multi-processor  . . . . . . . . . . . . . . . . . . . . . . . . . 116
network . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145
network (mental ray)  . . . . . . . . . . . . . . . . . . . . 146
object vibration in  . . . . . . . . . . . . . . . . . . . . . . . 124
over a network . . . . . . . . . . . . . . . . . . . . . . . . . . 154
previewing . . . . . . . . . . . . . . . . . . . . . . . . . . . 13, 67
problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141
regions of scene, Render View
render region113

resolution  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
running MEL commands before/after. . . . . . . 99
safe region for TV  . . . . . . . . . . . . . . . . . . . . . . . . 33
single frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . 114
software. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
specific surfaces . . . . . . . . . . . . . . . . . . . . . . . . . 112
speed . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132
speed vs. quality  . . . . . . . . . . . . . . . . . . . . . . . . 131
test animation. . . . . . . . . . . . . . . . . . . . . . . . . . . 111
test frames. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111
testing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13, 67
tips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
typical workflow . . . . . . . . . . . . . . . . . . . . . . . . . 89
vector . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15, 22
vector render globals. . . . . . . . . . . . . . . . . . . . . 211
with command line . . . . . . . . . . . . . . . . . . . . . . 117
with IPR  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67
with Maya . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 154
with mental ray  . . . . . . . . . . . . . . . . . . . . . 118, 154
with Render View . . . . . . . . . . . . . . . . . . . . . . . . 71
with the command line . . . . . . . . . . . . . . . . . . . . 72

Rendering CPU attribute  . . . . . . . . . . . . . . . . . . . . 256

Rendering Flags
Attribute Editor . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Rendering Flags window . . . . . . . . . . . . . . . . . . . . 231

Renumber Frames attributes  . . . . . . . . . . . . . . . . . 162

Renumber Frames Using attribute  . . . . . . . . . . . . 162

Reset Region Marquee option
Render View window . . . . . . . . . . . . . . . . . . . . 226

resolution
image . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
low-res rendering, Render View
low-res rendering111

of rendered images . . . . . . . . . . . . . . . . . . . . . . . 80

Resolution attribute . . . . . . . . . . . . . . . . . . . . . . . . . 236

Resolution attributes . . . . . . . . . . . . . . . . . . . . . . . . 162

Resolution Gate attribute  . . . . . . . . . . . . . . . . . . . . . 37

Resolution Gate option . . . . . . . . . . . . . . . . . . . . . . 267

Reuse Existing Dmap(s)  . . . . . . . . . . . . . . . . . . . . . 138

Reuse Tessellations attribute  . . . . . . . . . . . . . . . . . 178

RGB  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84

RGB (default) attribute . . . . . . . . . . . . . . . . . . . . . . 199

RGB Channel (Color) attribute  . . . . . . . . . . . . . . . 161

RGBA . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84

RGBAZ  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84

RLA format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

Roll Scale setting  . . . . . . . . . . . . . . . . . . . . . . . . . . . 278

rolling, cameras  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Rotation type setting . . . . . . . . . . . . . . . . . . . . . . . . 278

S
Safe Action option . . . . . . . . . . . . . . . . . . . . . . . . . . 268

Safe Title option . . . . . . . . . . . . . . . . . . . . . . . . . 34, 268

Sample Lock attribute . . . . . . . . . . . . . . . . . . . . . . . 187

Save Distributed Render . . . . . . . . . . . . . . . . . . . . . 256

Save Image option
Render View window . . . . . . . . . . . . . . . . . . . . 225

Save IPR File
Render View window . . . . . . . . . . . . . . . . . . . . 225

Save IPR File option. . . . . . . . . . . . . . . . . . . . . . . . . 109

Scale setting  . . . . . . . . . . . . . . . . . . . . . . . . . . . 276, 278

Scanline attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Scanline Only Rendering  . . . . . . . . . . . . . . . . . . . . 122

Scene Fragment  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 246

scene views
guidelines . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
selecting camera. . . . . . . . . . . . . . . . . . . . . . . . . . 38
view lighting  . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
view shading  . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
Rendering

297



Index
scenes
diagnosing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
diagnosing (mental ray) . . . . . . . . . . . . . . . . . . 133
finding problems
Render Diagnostics133

framing with camera . . . . . . . . . . . . . . . . . . . . . . 40
optimizing. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
rendering multiple  . . . . . . . . . . . . . . . . . . . . . . 119
rendering region  . . . . . . . . . . . . . . . . . . . . . . . . 113

secondary tessellation . . . . . . . . . . . . . . . . . . . . . . . . 44

Segments attribute . . . . . . . . . . . . . . . . . . . . . . . . . . 189

Select Camera . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265

Selected Surfaces
tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 257

server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146

server setup. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149

service file
troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . 155

Set NURBS Tessellation  . . . . . . . . . . . . . . . . . . . . . . 50

setting. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

setup
client  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149
server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149

SGI format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

SGI Movie format (UNIX only) . . . . . . . . . . . . . . . . 77

SGI16 format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

shaders. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Shading attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . 167

shading networks
mental ray for Maya  . . . . . . . . . . . . . . . . . . . . . . 19

Shading Samples
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 281

Shading Samples attribute  . . . . . . . . . . . . . . . 167, 168

Shading Samples Override
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 281

Shading Samples Override attribute . . . . . . . . . . . 128

Shadow  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

shadow mapping . . . . . . . . . . . . . . . . . . . . . . . . . . . 122

Shadow Rays attribute  . . . . . . . . . . . . . . . . . . . . . . 138

Shadow Trace Depth attribute . . . . . . . . . . . . . . . . 188

shadows
optimizing. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Shadows (SWF and bitmap formats only) . . . . . . 219

Shadows attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . 172

Shadows Obey Light Linking attribute  . . . . . . . . 176

Show Back Faces  . . . . . . . . . . . . . . . . . . . . . . . . . . . 219

Show Batch Render . . . . . . . . . . . . . . . . . . . . . . . . . 256

Show menu
Rendering Flags window . . . . . . . . . . . . . . . . . 232

Show Region Marquee option
Render View window . . . . . . . . . . . . . . . . . . . . 226

Shutter Angle
description, for cameras . . . . . . . . . . . . . . . . . . 250

shutter angle . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Shutter Angle attribute . . . . . . . . . . . . . . . . . . . . . . 274

Shutter attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . 191

Shutter Delay attribute . . . . . . . . . . . . . . . . . . . . . . 191

shutter setting
mental ray vs. Maya  . . . . . . . . . . . . . . . . . . . . . 191

shutter speed  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Simple attribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Single Color  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 215

Small Object Culling attribute . . . . . . . . . . . . . . . . 209

Smooth
2D Motion Blur  . . . . . . . . . . . . . . . . . . . . . . . . . 174

Smooth Alpha
2D Motion Blur  . . . . . . . . . . . . . . . . . . . . . . . . . 174

Smooth Color
2D Motion Blur  . . . . . . . . . . . . . . . . . . . . . . . . . 174

Smooth Edge Ratio
Set NURBS Tessellation  . . . . . . . . . . . . . . . . . . 260

Smooth Value
2D Motion Blur  . . . . . . . . . . . . . . . . . . . . . . . . . 174
tip, Motion Blur . . . . . . . . . . . . . . . . . . . . . . . . . 174

Snap box dolly to
camera settings  . . . . . . . . . . . . . . . . . . . . . . . . . 277

Snapshot
in Render View  . . . . . . . . . . . . . . . . . . . . . 113, 114

Snapshot option
Render View window, Render menu . . . . . . . 227

SoftImage format . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

software rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . 14
memory and performance . . . . . . . . . . . . . . . . 104

Sort attribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Special Effects attributes
cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274
Rendering 

298



Index
specific surfaces
rendering. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112

Specular
Render Layer Pass . . . . . . . . . . . . . . . . . . . . . . . . 88

Start Frame attribute
Image File Output attributes . . . . . . . . . . . 95, 160
Image Output Files attributes  . . . . . . . . . . . . . 236

Start Number attribute  . . . . . . . . . . . . . . . . . . . . . . 162

Stepped
Tumble camera setting . . . . . . . . . . . . . . . . . . . 276

Subdivision Power attribute. . . . . . . . . . . . . . . . . . 180

subdivision surfaces
mental ray for Maya  . . . . . . . . . . . . . . . . . . . . . . 49

subDs
approximation . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
display tessellation  . . . . . . . . . . . . . . . . . . . . . . . 52
obtaining quads for approximation  . . . . . . . . . 61

Surface
Dolly camera setting . . . . . . . . . . . . . . . . . . . . . 277

surfaces
background showing through . . . . . . . . . . . . . 124
identical. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136
mental ray approximation . . . . . . . . . . . . . . . . . 48
performance . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136
polygonal  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
single-sided. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136
tessellation settings . . . . . . . . . . . . . . . . . . . . . . . 49
troubleshooting  . . . . . . . . . . . . . . . . . . . . . 126, 128

Svg Animation (SVG only) . . . . . . . . . . . . . . . . . . . 213

syntax, file name  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78

T
Targa format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

Task Size attribute . . . . . . . . . . . . . . . . . . . . . . . . . . 202

television
safe region rendering  . . . . . . . . . . . . . . . . . . . . . 33

tessellate
strategies . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
adjust for polygons . . . . . . . . . . . . . . . . . . . . . . . 52
adjusting settings. . . . . . . . . . . . . . . . . . . . . . . . . 50
display for NURBs  . . . . . . . . . . . . . . . . . . . . . . . 51
display for subDs. . . . . . . . . . . . . . . . . . . . . . . . . 52
memory and performance . . . . . . . . . . . . . . . . 104
primary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
problems with  . . . . . . . . . . . . . . . . . . . . . . . . . . 124
secondary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
span-based  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
strategies for . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
surface types. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
viewing settings . . . . . . . . . . . . . . . . . . . . . . . . . . 49
vs. approximation . . . . . . . . . . . . . . . . . . . . . . . . 43
when to adjust . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Tessellation attribute . . . . . . . . . . . . . . . . . . . . . . . . 198

Tessellation Mode  . . . . . . . . . . . . . . . . . . . . . . . . . . 257

tessellation passes
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

test render . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Test Resolution . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 229

Test Resolution option  . . . . . . . . . . . . . . . . . . . . . . 254
Render View window . . . . . . . . . . . . . . . . . . . . 111

Texture resolution menu. . . . . . . . . . . . . . . . . . . . . 235

Textured channel menu  . . . . . . . . . . . . . . . . . . . . . 234

textures
popping. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 264
troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . 121

Texturing attribute. . . . . . . . . . . . . . . . . . . . . . . . . . 239

Threshold
Output Settings attribute . . . . . . . . . . . . . . . . . 273

Tiff format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78

Tiff16 format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78

tilt, cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Time Contrast
Motion Blur  . . . . . . . . . . . . . . . . . . . . . . . . . . 20, 29

Time Contrast R attribute . . . . . . . . . . . . . . . . . . . . 191

Time Slider
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 259

Time slider
Hardware Render Buffer  . . . . . . . . . . . . . . . . . 245

Toolbar option
Render View window . . . . . . . . . . . . . . . . . . . . 229
Rendering

299



Index
Trace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Trace Depth attribute  . . . . . . . . . . . . . . . . . . . . . . . 196

Trace Reflection attribute . . . . . . . . . . . . . . . . . . . . 196

Trace Refraction attribute . . . . . . . . . . . . . . . . . . . . 196

Track Geometry setting. . . . . . . . . . . . . . . . . . . . . . 276

Track Scale setting . . . . . . . . . . . . . . . . . . . . . . . . . . 276

tracking, cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Transform Icons attribute . . . . . . . . . . . . . . . . . . . . 241

transparency
channels  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
matte, see Matte Opacity  . . . . . . . . . . . . . . . . . . 97
premultiplication . . . . . . . . . . . . . . . . . . . . . . . . . 84

Transparency Based depth
Output Settings attributes, for cameras . . . . . 273

Transparency sorting attribute  . . . . . . . . . . . . . . . 208

transparent objects
motion blur problems . . . . . . . . . . . . . . . . . . . . 126

Transparent Shadow maps attribute. . . . . . . . . . . 208

Triangle (default) attribute . . . . . . . . . . . . . . . . . . . 186

troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 155
caustics  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 138
displacement maps . . . . . . . . . . . . . . . . . . . . . . 127
edges  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
final gather . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139
flickering . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
global illumination  . . . . . . . . . . . . . . . . . . . . . . 138
highlights  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128
image quality and render speed  . . . . . . . . . . . 131
motion blur . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128
surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128

Tumble
Locked camera setting  . . . . . . . . . . . . . . . . . . . 275
Ortho step camera setting  . . . . . . . . . . . . . . . . 276
Orthographic views camera settings  . . . . . . . 275
Stepped camera setting . . . . . . . . . . . . . . . . . . . 276
Tumble camera about camera settings . . . . . . 275
Tumble pivot camera setting . . . . . . . . . . . . . . 275
Tumble scale camera setting  . . . . . . . . . . . . . . 275

Tumble camera about
camera settings. . . . . . . . . . . . . . . . . . . . . . . . . . 275

Tumble pivot
Tumble camera setting . . . . . . . . . . . . . . . . . . . 275

Tumble Pivot attribute  . . . . . . . . . . . . . . . . . . . . . . 275

tumble, cameras . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

tuning
region  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

TV production
safe region rendering  . . . . . . . . . . . . . . . . . . . . . 33

Two Color . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 215

U
U Divisions Factor

Set NURBS Tessellation  . . . . . . . . . . . . . . . . . . 260

U Divisions Factor attribute . . . . . . . . . . . . . . . . . . 126

Update Image Planes/Background option
IPR menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
Render View window . . . . . . . . . . . . . . . . . . . . 227

Update Light Glow
on or off for IPR . . . . . . . . . . . . . . . . . . . . . . . . . 228

Update Motion Blur
on or off for IPR . . . . . . . . . . . . . . . . . . . . . . . . . 228

Update Shader Glow
on or off for IPR . . . . . . . . . . . . . . . . . . . . . . . . . 228

Update Shading and Lighting
on or off for IPR . . . . . . . . . . . . . . . . . . . . . . . . . 228

Update Shadow Maps option
IPR menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
Render View window . . . . . . . . . . . . . . . . . . . . 227

Use 2d Blur memory Limit
2D Motion Blur  . . . . . . . . . . . . . . . . . . . . . . . . . 174

Use all available CPUs  . . . . . . . . . . . . . . . . . . . . . . 180

Use all available processors attribute . . . . . . 116, 255

Use Chord Height attribute . . . . . . . . . . . . . . . . . . 262

Use Chord Height Ratio . . . . . . . . . . . . . . . . . . . . . 263

Use Custom Extension attribute  . . . . . . . . . . . 95, 162

Use Displacement Bounding Box attribute  . . . . . 179

Use Dmap Auto Focus  . . . . . . . . . . . . . . . . . . . . . . 137

Use File Cache attribute  . . . . . . . . . . . . . . . . . . . . . 177

Use Frame Range
for tessellation  . . . . . . . . . . . . . . . . . . . . . . . . . . 258

Use Min Screen attribute
Secondary Tessellation Attributes  . . . . . . . . . 264

Use Multi Pixel Filter attribute  . . . . . . . . . . . . . . . 168

Use Smooth Edge
Set NURBS Tessellation  . . . . . . . . . . . . . . . . . . 260

Use X- Dmap attribute  . . . . . . . . . . . . . . . . . . . . . . 138
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Use X+ Dmap attribute . . . . . . . . . . . . . . . . . . . . . . 138

Use Y- Dmap attribute  . . . . . . . . . . . . . . . . . . . . . . 138

Use Y+ Dmap attribute . . . . . . . . . . . . . . . . . . . . . . 138

Use Z- Dmap attribute  . . . . . . . . . . . . . . . . . . . . . . 138

Use Z+ Dmap attribute . . . . . . . . . . . . . . . . . . . . . . 138

UVs. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

V
V Divisions Factor

Set NURBS Tessellation  . . . . . . . . . . . . . . . . . . 260

V Divisions Factor attribute . . . . . . . . . . . . . . . . . . 126

vector file formats, bitmap file formats  . . . . . . . . . 74

vector renderer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

vector rendering . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Render Globals. . . . . . . . . . . . . . . . . . . . . . . . . . 211

verbosity  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22, 142

Vertical Film Aperture attribute
see Camera Aperture attribute

Vertical Film Offset attribute
see Film Offset attribute

Vertical option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268

video  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80
frame rendering . . . . . . . . . . . . . . . . . . . . . . . . . . 80

video fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

View menu
Render View window . . . . . . . . . . . . . . . . . . . . 226

Visible  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Visible in Reflections
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

Visible in Refractions
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

visualization
IPR rendering . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
rendering  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

visualization, renders  . . . . . . . . . . . . . . . . . . . . . . . . 13

Volume Samples
Render Stats . . . . . . . . . . . . . . . . . . . . . . . . . . . . 282

Volume Samples Override . . . . . . . . . . . . . . . . . . . 281

voxels, example of . . . . . . . . . . . . . . . . . . . . . . . . . . 201

W
walk throughs. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Width attribute
Resolution attributes . . . . . . . . . . . . . . . . . . 96, 164

Windows Bitmap
image file format . . . . . . . . . . . . . . . . . . . . . . . . . 78

Windows setup  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149

Write ZDepth attribute . . . . . . . . . . . . . . . . . . . . . . 236

Y
yaw, cameras  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Z
Z buffer channel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Z depth channel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Zeroth Scanline attribute  . . . . . . . . . . . . . . . . 124, 170

Zoom Scale setting . . . . . . . . . . . . . . . . . . . . . . . . . . 277

zooming, cameras  . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
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