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1 | Background

About > Brief history of splines
1 Background

About NURBS

Brief history of splines

Splines are types of curves, originally developed for ship-building in the 
days before computer modeling. Naval architects needed a way to draw a 
smooth curve through a set of points.

The solution was to place metal weights (called knots) at the control 
points, and bend a thin metal or wooden beam (called a spline) through 
the weights.

The physics of the bending spline meant that the influence of each weight 
was greatest at the point of contact, and decreased smoothly further along 
the spline. To get more control over a certain region of the spline, the 
draftsman simply added more weights.

This scheme had obvious problems with data exchange! People needed a 
mathematical way to describe the shape of the curve. Cubic Polynomials 
Splines are the mathematical equivalent of the draftsman’s wooden beam. 
Polynomials were extended to B-splines (for Basis splines), which are sums 
of lower-level polynomial splines.

� ”Mathematical representations of curves” on page 12

Then B-splines were extended to create a mathematical representation 
called NURBS, which are used by Maya.

� ”NURBS” on page 13

Weights

Spline
NURBS Modeling
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About > Mathematical representations of curves
Mathematical representations of curves

Polynomial equations

Starting with the simplest mathematical representation, we all remember 
from geometry class that we can represent a (two dimensional) line with 
an equation like y = 2x. For each value of x, we multiply it by 2 to get the 
value of y, and plot the two values on a graph.

The generalized form of this type of equation is ax + by = c. The expression 
to the left of the equals sign is called a polynomial (“poly” means many. It 
refers to the fact that the expression has more than one term).

We can make more complicated expressions where x is multiplied by 
itself, as y = x * x * x. Instead of writing out all the xs in a term, we usually 
just count them and write the count as a superscript. The superscript is 
called “the exponent”. So the expression above is written as y = x3. 

We can write polynomials with exponents, such as:
y = ax2 + bx + c 
(You may recall from math class that this is a quadratic equation). The 
exponent (the 2) on the first occurrence of x means that the graph of this 
function is curved rather than straight.

Degree

The degree of a polynomial equation is the largest exponent in the 
equation. Recall that the largest exponent on the equation for a line was 1. 
(When a term has no visible exponent, that is the same as an exponent of 
1.)

• The degree of a linear equation is 1. 

• A quadratic equation, which has a term x2, is degree 2. 

• A cubic equation, which has a term x3, is degree 3, and so on.

Parametric representations

There are two general ways to write an equation for a curve. The implicit 
representation combines every variable in one long, non-linear equation, 
such as:
ax3 + by2 + 2cxy + 2dx +2ey +f = 0.

In this representation, to calculate the x and y values to plot them on a 
graph, we must solve the entire non-linear equation.

The parametric representation rewrites the equation into shorter, easily 
solved equations that translate one variable into values for the others:
x = a + bt + ct2 + dt3 + ...
y = g + ht + jt2 + kt3 + ...
NURBS Modeling 
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About > NURBS
Using this representation, the equations for x and y are simple. We just 
need a value for t, the point along the curve for which we want to 
calculate x and y.

You can visualize parametric curves as being drawn by a point moving 
through space. At any time t, we can calculate the x and y values of the 
moving point.

This is a very important point, because the concept of associating a 
parameter number with every point on the line is used by many tools. 
This corresponds to the U dimension of the curve.

Creating complex curves

The lower the degree of a curve equation, the simpler the curve described. 
What if we want to represent complex curves? The simple answer might 
be to increase the degree of the curve, but this is not very efficient. The 
higher the degree of the curve, the more computations are required. Also, 
curves with degree higher than 7 are subject to wide oscillations in their 
shape, which makes them impractical for interactive modeling.

The answer is to join relatively low-degree (1 to 7) curve equations 
together as segments of a larger, more complex composite curve. The 
points at which the curve segments, or spans, join together is called an edit 
point.

Higher degree curves should not be completely discounted, however. 
Degree 5 and 7 curves have certain advantages such as smoother 
curvature and more “tension”. They are often used in automotive design.

Smooth joins

The degree of the curve determines the smoothness of the joins between 
spans. Degree 1 (linear) curves give positional continuity at the join. 
Degree 2 (quadratic) curves give tangent continuity. Degree 3 (cubic) 
curves give curvature continuity.

NURBS

NURBS stands for Non-Uniform Rational B-Splines.

• Non-Uniform refers to the parameterization of the curve. Non-Uniform 
curves allow, among other things, the presence of multi-knots, which 
are needed to represent Bezier curves.

• Rational refers to the underlying mathematical representation. This 
property allows NURBS to represent exact conics (such as parabolic 
curves, circles, and ellipses) in addition to free-form curves. 

• B-splines are piecewise polynomial curves that have a parametric 
representation.
NURBS Modeling
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About > Degree
Related topics

� ”Curves” on page 21

� ”Surfaces” on page 25

� ”Object properties” on page 14

Object properties
Explains the properties common to NURBS objects.

Degree

Degree is a mathematical property of a curve or of a surface that controls 
how many CVs per span are available for modeling. Degree is the curve or 
surface’s degree of freedom to bend. A degree 1 curve connects its edit 
points with straight lines. A degree 2 curve can have one bend between 
edit points, and so on.

The default degree in Maya is 3, which has four CVs for the first curve 
span. This is sufficient for almost any modeling task.

Surfaces can have different degrees across their width and length. For 
example, a surface could be degree 3 along its width, and degree 5 along 
its length.

The degree of your curves can affect data transfer to other software 
packages. Some other packages cannot accept curves with degree higher 
than 3.

Parameters and parameterization

What are parameters?

Parameters are the unique numeric values (like coordinates) of points on a 
curve or surface. Parameters let you refer to specific points along the 
length of a curve. The higher the parameter, the further is the point along 
the curve.

1

2
3

4

parameter = 0.0

parameter = 2.3
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About > Parameters and parameterization
Just as points in space have three dimensions, called X, Y, and Z, the 
parameters of a point are measured along the one internal dimension 
(length) of the curve. We call this dimension U.

Since surfaces have two internal dimensions (length and width), we need 
another parameter (in addition to U) to specify a point on a surface. We 
call this parameter V.

Just as every point along the length of a curve has a U parameter, every 
point across a surface has U and V parameters.

What is parameterization?

The method the application uses to number the points along a curve is 
called the curve’s parameterization. There are two parameterization 
methods available: uniform and chord-length.

Each method has advantages and disadvantages depending on how the 
curve will be used. You can choose which parameterization method to use 
when you create a new curve, and you can rebuild existing curves to use a 
specific parameterization.

Different actions can create curves or surfaces with different 
parameterization methods, often as a user-configurable option. For 
example, the CV Curve Tool and EP Curve Tool use uniform knot spacing 
by default. The Pencil Tool uses chord length knot spacing. 

Uniform

Uniform parameterization assigns integral parameter values to the edit 
points, and evenly distributes parameters along the spans between edit 
points. So the first edit point is always parameter 0.0, the second edit point 
is always 1.0, the third is always 2.0, and so on.

A bonus feature of uniform parameterization is that the parameter value 
of the last edit point is the also the number of spans in the curve. 
However, unlike chord-length parameterization, the parameters of a 
uniform curve have nothing to do with the actual length of the curve.

Though the default values for uniform parameterization range from 0 to 
the total number of spans, you can use Rebuild Curve/Rebuild Surface to 
change the range to 0 to 1. (The 0 to 1 scheme is common in other 
computer graphics packages. Some users may want to use it for the sake 
of familiarity.)

0.0

1.0 2.0

3.0

1.5
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About > Parameters and parameterization
Chord-length

Chord-length parameterization assigns parameter 0.0 to the start of the 
curve, then increases the parameter value proportionally to the chord 
length, or the shortest linear distance, between the surrounding edit 
points.

Unlike uniform parameterization, the parameters of a chord-length curve 
are irregularly spaced between the edit points, and the edit points do not 
have integral parameters.

Comparison

Each parameterization method has advantages and disadvantages, 
depending on how you will use the curve or surface.

Type Pros Cons

Chord-length • Parameter value 
gives some 
indication of the 
point’s relative 
position along the 
curve.

• Distributes 
curvature better.

• Minimizes 
stretching and 
squeezing of 
textures.

• Parameters are not 
obvious.

• Surfaces built from 
chord-length curves 
can be more complex 
because of cross-knot 
insertion.

Uniform • Easy to reckon 
parameters (for 
example, 1.5 is 
about half-way 
between edit points 
at 1.0 and 2.0).

• In many cases, 
interpolation between 
edit points is not as 
good.

• Can lead to 
unpredictable 
stretching of textures 
during rendering.

0.0

2.1 5.7

7.7

3.8
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About > Normals
Just as with degree, surfaces can have different parameterization methods 
for their U and V dimensions. For example, the U isoparms of a surface 
can be degree 3 with uniform parameterization, while the V isoparms are 
degree 1 with chord-length parameterization.

To avoid problems manipulating and texturing a joined surface, make 
sure the joined surfaces use the same parameterization (uniform or chord 
length). If both surfaces use uniform parameterization, make sure that 
both use the same parameter range (0 to 1 or 0 to total number of spans).

Viewing parameters

When you select a curve or surface point, the U and V (for surfaces) 
values are shown in the status line as you drag.

Normals

Normals are imaginary lines perpendicular to each point on a curve or 
surface.

The direction of U and V isoparms on a surface determines the direction 
of the surface’s normals.

Normals are a mathematical side-effect of NURBS.They are often used as a 
way of specifying which side of a surface points “inside” or “outside” (for 
example, when creating shells).

Normals are also an indirect indicator of the shape of a curve or surface. 
Since they are always perpendicular to the curve or surface, the way 
normal lines point toward or away from each other can reveal subtle 
curvature.

Periodic, closed, and open

A NURBS curve or surface has a periodic, closed, or open form. The form 
affects the how the object deforms.
NURBS Modeling
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About > Periodic, closed, and open
Curves

• An open curve usually has its start and end edit points in different 
positions—it typically doesn’t form a loop. If you snap the start and 
end edit points of an open curve to the same position, it’s still an open 
curve, because you can still drag these points away from each other.

• A closed curve is a loop with coinciding start and end edit points. 
Where start and end edit points meet is also called a seam. If you move 
the start edit point, the end edit point moves with it (and vice versa).

• A periodic curve is also a loop with a seam, but it has two unseen 
spans at the end of the curve that overlap the first two spans. The 
unseen spans help maintain continuity along the seam.

For example, suppose you create a circle primitive with four spans 
(sections). A circle primitive is a periodic curve. If you display the 
circle’s edit points, you’ll see only four spans. There are actually six 
spans, but the last two overlap the first two.

In contrast to a periodic curve, a closed curve can have a sharp corner at 
the seam because it lacks the extra spans.

The figure below shows similar closed and periodic curves, both 
originally circles. For each, we moved the CV next to the seam inward. 
The periodic curve keeps its continuity, but the closed curve’s tangency is 
broken.

Span 2 and hidden span

Span 1 and
Span 3

 

 hidden span 

Span 4
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About > Periodic, closed, and open
To see whether a curve is periodic, closed, or open, select the object, 
display the Attribute Editor, and examine the contents of the Form text 
box.

Note that if you use Edit Curves > Open/Close Curves to “close” an open 
curve, you create a periodic rather than a closed curve. To create a closed 
curve, use Edit Curves > Detach Curves on any edit point of a periodic 
curve.

NURBS surfaces

Periodic and closed surfaces work like their curve counterparts, except they 
have two parametric directions (U and V) instead of one (U).

If you create a surface from a periodic curve, the surface is periodic in one 
direction (U or V).

To see whether a surface is periodic, closed, or open, select the object, 
display the Attribute Editor, and examine the contents of the Form U and 
V text boxes. A surface is considered periodic whether it’s periodic in U, 
V, or both.

If you use Edit NURBS > Open/Close Surfaces on an open surface, you 
create a periodic rather than a closed surface. To create a closed surface, 
use Edit NURBS > Detach Surfaces on an isoparm of a periodic surface.

Seam

Closed curve Periodic curve
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About > Curvature
Modeling concepts

Curvature

Curvature is a measure of how much a curve curves.

Curvature is measured by fitting a circle into the curve, then taking the 
reciprocal of the circle’s radius. In this figure, at point x the curve is best 
described by a circle with radius r. At this point, the curvature is 1/r.

(We use the reciprocal, 1/r, instead of just r because a flat line has an 
infinite radius. Taking the reciprocal gives us 0 instead of infinity.)

Continuity

Continuity is a measure of how well two curves or surfaces “flow” into 
each other where they meet.

Types of continuity

Continuity is a mathematical indication of the smoothness of the flow 
between two curves or surfaces.

Positional (G0)

The endpoints of the two curves meet exactly. Note that two curves that 
meet at any angle can still have positional continuity.

x 

r 

A curvature
plot Quill

Outline
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About > Curve components
Tangent (G1)

Same as positional continuity, plus the end tangents match at the common 
endpoint. The two curves will appear to be travelling in the same 
direction at the join, but they may still have very different apparent 
“speeds” (rate of change of the direction, also called curvature).

For example, in this figure, the two curves have the same tangent (the 
double-arrow line) at the join (the dot). But the curve to the left of the join 
has a slow (low) curvature at the join, while the curve to the right of the 
join has a fast (high) curvature at the join.

Curvature (G2)

Same as tangent continuity, plus the curvature of the two curves matches 
at the common endpoint. The two curves appear to have the same 
“speed” at the join.

Curves

Curve components

The easiest way to display and select a curve component is to press the 
right mouse button on an object, choose the component type, then select 
the component.
NURBS Modeling
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About > Curve components
CVs

CVs (control vertices) control how the curve is “pulled” from a straight line 
between edit points. They are the most basic and important means for 
controlling the shape of a curve. Lines between consecutive CVs form the 
control hull.

The number of CVs is equal to the degree of the curve plus one. So, for 
example, a degree 3 curve has four CVs per span. To increase the number 
of CVs to gain more control over curve shape, you can increase the 
number of spans by inserting edit points or increase the curve’s degree.

Maya draws CVs differently to let you tell the difference between the start 
and the end of a curve. The first CV (at the start point of the curve) is 
drawn as a box. The second CV is drawn as a small “U”, to show the 
increasing U dimension from the start point. All other CVs are drawn as 
small dots.

Multiple spans

Longer and more complex curves require more than a single span curve. 
As you draw what appears to be a single long curve, the application is 
actually adding several curve spans together.

Edit points

You can tell when a curve is made from multiple spans in several ways. 
One is to look for edit points on the curve. Edit points mark the connection 
point between two spans. Maya draws edit points as small Xs.

Unlike the on-curve control points of Bezier curves (used in many 2D 
illustration programs), NURBS edit points are not usually used for editing 
curves. CVs control the shape of a NURBS curve, and edit points are just 
indicators of how many spans a curve has.

1st CV
2nd CV

CV
CV

Edit points
NURBS Modeling 

22



1 | Background

About > Moving edit points vs. moving CVs
There are, however, a few tasks that use edit points:

• If you want more control in a curve, you can insert an edit point to 
increase the number of spans in the curve and give you more CVs to 
work with.

• You can also delete edit points to decrease the number of spans in a 
curve (and probably change the shape of the curve).

• It is possible to move edit points to change the shape of a curve, but 
you should avoid doing this except for minor adjustments.

Hulls

As a curve gets more spans/edit points, you might lose track of the order 
of the CVs. To show the relationship between CVs, Maya can draw lines 
between them. These lines are called hulls.

Hulls are useful:

• To show the order of CVs in a crowded scene.

• To show the shape of the CVs.when your object is so crowded with 
CVs that you can’t determine exactly which adjacent CVs will be 
affected when you tweak part of a model.

• To select an entire row of CVs at once.

Moving edit points vs. moving CVs

In theory, moving edit points would be an excellent way to edit a curve, 
since they lie on the curve itself. Unfortunately, it doesn’t work out that 
way. This is because the shape of the curve determines the positions of 
edit points, not the other way around.

Maya does allow you to move edit points by “reverse engineering” the 
curve from the edit point. When you move an edit point, the Move tool 
tries to find a curve which passes through the new edit point location.

Because this process is time-consuming and has an infinite number of 
solutions, the tool must place constraints on how moving the edit point 
affects the curve. Because of these constraints, you usually cannot make 
major changes well by moving edit points. Moving edit points is best for 
small scale reshaping.

Even though it is slightly less intuitive, the only way to reshape the curve 
with complete power is by moving CVs.

Hull
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About > Multi-knots and CV multiplicity
Multi-knots and CV multiplicity

A multi-knot is multiple edit points at the same location in space.

CV multiplicity is multiple CVs at the same location in space.

Multi-knots and CV Multiplicity achieve similar effects (sharper bends in 
curves), even though they are different mathematically.

Multi-knots are usually the result of curve or surface editing operations 
that require a sharp turn in a curve.

Multi-knots and CV multiplicity are generally undesirable. Some tools 
cannot work with them, they do not build very good surfaces or animate 
predictably, and some other software packages will not accept models 
with multi-knots.

Constructing quality curves

To create quality surfaces you need quality curves. These guidelines will 
help you create good curves.

Simple curves

Use the simplest curves that can describe the shape you want. Simpler 
curves mean simple, faster rendering surfaces.

One effective method for achieving simple curves is:

1 Begin a curve by drawing a single span.

2 Move the CVs to achieve the shape you want.

3 If you can’t achieve the shape, add an edit point to create more CVs.

4 Continue until you have the shape you need.

This iterative process ensures your curve only has as many spans as are 
absolutely necessary.
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About > Constructing quality curves
You can also use the Rebuild curve tool to simplify existing curves. The 
tool can simplify a curve while maintaining its shape within a tolerance 
you set.

Parameterization

It is often best to build curves with uniform parameterization, because it 
makes inserting edit points and detaching curves at exact locations easier.

• When drawing Edit point curves with Uniform parameterization, the 
resulting CVs may be placed awkwardly. To fix this, move the CVs to 
prevent crossing hull lines.

• Try to consistently use either Uniform or Chord length 
parameterization when drawing curves. If you mix and match curve 
styles, it could result in cross knot insertion when the curves are used 
to build a surface.

Planning for surfaces

When creating curve, plan ahead to the surfaces that you want. Try to 
have the same number of spans in all the construction curves for building 
a surface. A simple way to achieve this is to start with one curve, then 
duplicate it to create more construction curves.

When you create a surface from curves with different numbers of spans, 
the new surface will have an extra isoparametric curve corresponding to 
every extra edit point. This is known as cross knot insertion. It makes the 
new surface more difficult to edit and more complex.

Surfaces
Describes how isoparametric curves, U and V coordinates, and possible 
trims combine to form a surface.

Matched and unmatched curves
NURBS Modeling
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About > Surface components: CVs, isoparms, and patches
Surface components: CVs, isoparms, and 
patches

The easiest way to display and select a surface component is to press the 
right mouse button on an object, choose the component type, then select 
the component.

Isoparms

Isoparametric curves (or isoparms) are lines running along the surface in 
the U and V directions, showing the shape of the surface as defined by the 
CVs.

Patches

The area enclosed by four adjacent isoparms is called a patch.

CVs

Like curves, NURBS surfaces have CVs that control the shape of the 
surface. Each patch has a certain number of CVs, controlled by the degree 
of the curve. To increase the number of CVs you can insert extra isoparms 
or increase the degree of the surface.
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How do I? > Draw curves
2 Creating curves

How do I? Create and edit models

Create curves

Draw curves

To draw a NURBS curve by placing CVs

1 Select Create > CV Curve Tool.

2 Click to place the CVs.

• The first CV looks like a hollow box. The second CV looks like a 
letter U. Maya draws hulls between the CVs as you place them.

• For each CV after the third one you place, Maya draws the shape 
of the curve.

• To remove the last CV you placed, press Delete.

• To switch to editing CVs, press Home or Insert. A manipulator 
appears on the previous CV. Use the manipulator to move the CV, 
press Delete to delete a segment, or click another CV to edit it. 
Press Home or Insert again to return to adding CVs.

3 Press Enter to finish the curve.

To draw a NURBS curve by placing edit points

Use this tool if you want the curve to pass through certain points. It 
calculates the positions of CVs based on where you want the edit points.

1 Select Create > EP Curve Tool.

2 Click to place the edit points.

• For each edit point after the first one you place, Maya draws the 
shape of the curve.

• To switch to editing edit points, press Home or Insert. A 
manipulator appears on the previous point. Use the manipulator 
to move the point, press Delete to delete a segment, or click 
another point to edit it. Press Home or Insert again to return to 
adding point.

3 Press Enter to finish the curve.
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How do I? > Create a curve from a surface edge, isoparm, or curve-on-surface
Draw a NURBS curve freehand

1 Select Create > Pencil Curve Tool.

2 Drag to sketch a curve. When you release the mouse button Maya 
creates the curve.

3 The Pencil Curve tool creates a curve with a large number of data 
points. Use Edit Curves > Rebuild Curve to simplify the curve.

• As you draw the curve, Maya puts points in the view if they are at 
least five screen pixels from the previous point.

• If you sketch in an orthographic view (front, top, or side), Maya 
creates the curve on the view plane at the origin. If you sketch in the 
perspective view, Maya creates the curve on the grid plane.

What if...?

I want the curve to form a closed loop?
� ”Make a curve or surface open or closed” on page 119

Related topics

� ”Create arcs” on page 29

� ”Create > CV Curve Tool” on page 32

� ”Create > EP Curve Tool” on page 33

� ”Create > Pencil Curve Tool” on page 34

Create a curve from a surface edge, isoparm, 
or curve-on-surface

To create a new curve from a surface component curve

1 Select an edge, isoparm, or curve-on-surface.

2 Select Edit Curves > Duplicate Surface Curves.

When construction history is on, the curve remains linked to the 
original surface. Transformation is relative to the original surface, and 
changes to the component curve from which it was created change the 
duplicated curve.

Tip You can duplicate an isoparm and use it as a wire deformer for 
the surface.
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How do I? > Create arcs
Create arcs

To create a two-point arc

This tool allows you to create up to 180 degrees of arc by specifying two 
endpoints and then manipulating the center point/radius.

1 Select Create > Arc Tools > Two Point Arc Tool.

2 Click to place the first endpoint, an on-curve point, and the second 
endpoint of the arc.

Maya shows a manipulator for the new arc.

3 Do any of the following:

• Drag any of the points to move them.

• Press Enter to finish the arc.

To create a three-point arc

1 Select Create > Arc Tools > Three Point Arc Tool.

2 Click to place the three endpoints of the arc.

Maya shows a manipulator for the new arc.

3 Do any of the following:

• Drag the endpoints or center point to move them.

• Click the circle to switch the direction the arc travels between 
endpoints.

• Press Enter to finish the arc.

Edit an arc after creation

1 In the channel box, select the CircularArc node associated with the arc 
you want to change.

2 In the toolbox, click the Show Manipulator tool.

The arc manipulator will appear.

Notes

• You cannot create a complete circle with the Arc Tools.

• Points in the arc cannot have the exact same position.

What if...?

I want to create a circle?

Use Create > NURBS Primitives > Circle.
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2 | Creating curves 
How do I? > Create a fillet curve between two existing curves
Related topics

� ”Create a fillet curve between two existing curves” on page 30

� ”Create > Arc Tools > Three Point Circular Arc, Two Point Circular 
Arc” on page 34

Create a fillet curve between two existing 
curves

You can create a circular or freeform fillet. The freeform fillet offers more 
position and shape control.

To create a circular fillet curve between two curves

1 Select curve points on each curve about where you want the fillet to 
begin and end. (The radius you enter for the fillet will determine the 
actual start and end points.)

2 Select Edit Curves > Curve Fillet > �.

3 Click Circular and enter the Radius for the fillet.

4 To trim the curves back to the fillet end points, turn on Trim. When 
Trim is on, you can also turn on Join to join the curves together into 
one new curve.

5 Click Apply.

Circular curve fillet Freeform curve fillet

For a circular fillet, select 
curve points on this side of 
the intersection to place 
the fillet here.
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2 | Creating curves

How do I? > Create a degree 3 curve to match degree 1 (scan) data
To create a freeform fillet curve between two curves

1 Select a curve point on each curve to specify the start and end points 
of the fillet.

2 Select Edit Curves > Curve Fillet > �.

3 Click Freeform.

4 To trim the curves back to the fillet end points, turn on Trim. When 
Trim is on, you can also turn on Join to join the curves together into 
one new curve.

5 Click Apply.

What if...?

Maya does not create a fillet curve?
• Maya may not create a curve if it’s not possible to fillet the selected 

curve with the radius you entered. Try entering a different radius and 
click Apply again.

• Try reshaping the curves so they intersect.

Related topics

� ”Create arcs” on page 29

� ”Edit Curves > Curve Fillet” on page 35

Create a degree 3 curve to match degree 1 
(scan) data

1 Select the degree 1 curve.

2 Choose Edit Curves > Fit B-Spline.

Related topics

� ”Edit Curves > Fit B-spline” on page 37

Note You cannot create a fillet using a curve-on-surface.
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Reference > Create > CV Curve Tool
Reference Menus

Create

Create > CV Curve Tool

Lets you draw a NURBS curve by placing CVs.

Related topics

� ”Curve components” on page 21

� ”Draw curves” on page 27

� ”Create > EP Curve Tool” on page 33

� ”Create > Pencil Curve Tool” on page 34

Create > CV Curve Tool > �

Curve Degree

The higher the Curve Degree, the smoother the curve. The default 
setting (3 Cubic) works well for most curves. You must create at least 
one more CV than the Curve Degree number. For example, you need 
at least six CVs to complete a degree 5 curve:

See ”Degree” on page 12 for more details.

Knot Spacing

The type of knot spacing sets how Maya assigns U position values to 
edit point (knots). Chord length knot spacing distributes curvature 
better. If you use the curve to build a surface, the surface might 
display textures better.

Uniform knot spacing creates curve U position values that are easier 
for you to predict. See ”Parameters and parameterization” on page 14 
for details.

Multiple End Knots

When turned on, the curve’s end edit points (knots) are superimposed 
on the end CVs. Generally, this makes the curve’s end region easier to 
control.

1 2 3 4

5

6
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Reference > Create > EP Curve Tool
If you create a pair of curves with Multiple End Knots off, you can use 
Snap to Points to align the second CVs (next to the end CVs) of each curve 
to create tangent continuity between the two curves.

Create > EP Curve Tool

Lets you draw a NURBS curve by placing edit points.

Related topics

� ”Curve components” on page 21

� ”Draw curves” on page 27

� ”Create > CV Curve Tool” on page 32

� ”Create > Pencil Curve Tool” on page 34

Create > EP Curve Tool > �

Curve Degree

The higher the Curve Degree, the smoother the curve. The default 
setting (3 Cubic) works well for most curves. 

Knot spacing

The knot spacing specifies how Maya assigns U positioning values to 
knots. Chord length knot spacing distributes curvature better. If you 
use the resulting curve to build a surface, the surface might display 
texture mapping better.

Uniform knot spacing produces curve U positioning values that are 
easier for you to predict. 

Note As with all tools in Maya, you can change the options after you 
create an object. Select the curve and open the Channel Box or the 
Attribute Editor.

Multiple End Knots on Multiple End Knots off

Notice how the
curve does not
go through the
end CVs.
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Reference > Create > Pencil Curve Tool
Create > Pencil Curve Tool

Lets you draw a freehand NURBS curve.

Related topics

� ”Curve components” on page 21

� ”Draw curves” on page 27

� ”Create > CV Curve Tool” on page 32

� ”Create > EP Curve Tool” on page 33

Create > Pencil Curve Tool > �

Curve Degree

The 1 Linear option creates jagged curves known as polylines. The 
default setting (3) creates smooth curves. 

Create > Arc Tools > Three Point Circular Arc, 
Two Point Circular Arc

Lets you create arcs by specifying points and then using a manipulator.

Related topics

� ”Create arcs” on page 29

Create > Arc Tools > Two/Three Point Circular Arc > �

Circular Arc Degree

1 Linear creates jagged curves. The default setting (3) creates smooth 
curves. 

Sections

Sets the number of curve segments of the arc.

Modeling menu set

Edit Curves

Edit Curves > Duplicate Surface Curves

Creates a new NURBS curve from the selected surface edge, isoparm, or 
curve-on-surface.
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Reference > Edit Curves > Curve Fillet
Related topics

� ”Create a curve from a surface edge, isoparm, or curve-on-surface” on 
page 28

� ”Edit Curves > Offset > Offset Curve, Offset Curve on Surface” on 
page 126

Edit Curves > Duplicate Surface Curves > �

Group With Original

Creates the duplicated curve as a child of the surface from which it 
was created. This affects transformations applied to the curve (or 
surface). 

For example, duplicate a cylinder isoparm, move the middle CV of the 
resulting curve in X, then rotate the cylinder 90 degrees about Z. If 
this option is turned on, the center CV of the curve is moved in X. If 
off, the center CV is moved in Y.

Visible Surface 

Isoparms

Lets you duplicate all isoparms of an object in the U, V, or U and V 
directions. This option works only when the entire surface is selected. 

U specifies all isoparms in the U direction.

V specifies all isoparms in the V direction.

Both specifies both U and V directions (all isoparms).

Edit Curves > Curve Fillet

Trim

Keeps only the parts of the original curves that flow toward the fillet 
curve ends. Other parts are deleted.

Freeform fillet with Trim turned off Same fillet with Trim turned on
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Reference > Edit Curves > Curve Fillet
Join

Joins the trimmed curves to the fillet curve, thereby creating a single 
curve. Available only when Trim is on.

Keep Original

Retains the original curves used to create the fillet. This allows you to 
create a curve fillet again for the curves but with different settings.

Construction

Circular creates a semicircular arc. 

Freeform creates a curve that’s determined by the curve points you 
selected before the Curve Fillet operation. 

Radius

Sets how sharply a circular fillet arcs. 

Freeform Type

Tangent puts the freeform fillet’s apex near the intersection corner.

Blend puts the freeform fillet’s apex near the midpoint between the 
curve points you selected before the Curve Fillet operation. 

Blend Control

Adjusts the fillet shape curvature by enabling Depth and Bias. Note 
that if Blend Control is on for a circular fillet, the fillet will not be 
circular. 

Depth

The higher the Depth, the deeper the fillet curve is positioned in the 
intersection corner.

When Join is 
turned off, the
trimmed curves 

When turned on, 
the trimmed curves
and the fillet curve

are not joined to 
the fillet curve.

are joined.
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Reference > Edit Curves > Fit B-spline
Bias

Controls whether the fillet curve warps in the direction of one curve 
or the other. A value of 1 warps the fillet curve toward one curve, -1 
toward the other curve. A value of 0 puts the fillet curve evenly 
between the two. (You can use a value below 0 in the Attribute Editor, 
not in the options window.)

Input Curve

Gives you access to the history of the curves you used to create the 
fillet. Click the arrow buttons to select one of these curves if you want 
to edit it.

Curve Parameters

The Curve Parameter1 and Curve Parameter2 define the region 
between the two curves where the fillet curve is created.

Edit Curves > Fit B-spline

Fits a degree 3 (cubic) curve to a degree 1 (linear) curve. Typically you use 
Fit B-spline after you import curves, surfaces, and digitized data from 
other products in which the curves have curve degree 1. 

Related topics

� ”Create a degree 3 curve to match degree 1 (scan) data” on page 31

Depth = 0.25 Depth = 0.75

Bias = -1 Bias = 0 Bias = 1
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Reference > Edit Curves > Fit B-spline
Edit Curves > Fit B-spline > �

Use Tolerance

The tolerance sets how much accuracy is maintained between the 
original and fit of interpolated curves. 

If set to Global, the fit is accurate to within 0.010 units, by default. 

Local lets you change the tolerance value in the Positional Tolerance 
box.

Input Curve

The Input Curve information is read-only. You can click the arrow 
button to select the curve and edit it with the Attribute Editor.

Tolerance

See Use Tolerance above for details.
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3 | Creating NURBS surfaces

How do I? > Create a flat surface inside a curve
3 Creating NURBS 
surfaces

How do I? Create and edit models

Create NURBS surfaces

Create a flat surface inside a curve

The Planar action creates a flat, trimmed NURBS surface inside a curve.

1 Select a closed, planar curve, or multiple curves that form a closed, 
planar region.

You can select multiple curves that form an enclose region by 
overlapping. They do not need to be connected end-to-end.

2 Choose Surfaces > Planar.

Original curves

Planar Trimmed surface
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3 | Creating NURBS surfaces 
How do I? > Skin a surface across profile curves
Notes

• You can use the Keep Outside attribute to create a trimmed surface 
with a hole cut of the enclosed region instead of a trimmed surface 
inside the enclosed region.

• You can edit the input curves to change the shape of the surface, but 
the surface must remain planar.

• Although a planar surface can include cut-out areas and holes, all 
curves must be co-planar even if they appear to create separate parts 
of the surface.

Related topics

� ”Skin a surface across profile curves” on page 40

� ”Create a surface within bounding curves” on page 44

� ”Surfaces > Planar” on page 65

Skin a surface across profile curves

You can use the Loft action to create a surface between a series of cross-
section or “profile” curves. The profile curves can be normal 3D curves, 
surface isoparms or edges, trim edges, or curves-on-surface.

To make a surface between profile curves

1 Pick the profile curves in order.

2 Select Surfaces > Loft.
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How do I? > Skin a surface across profile curves
To add additional curves to a lofted surface

1 Select one of the curves you used to create the lofted surface.

Maya displays the lofted surface in the construction history color to 
show its connection to the curve.

2 Select the curve you want to add, then select Surfaces > Loft.

Related topics

� ”Sweep a profile curve along a path curve” on page 42

� ”Sweep one or more profile curves along two path curves (birail)” on 
page 43

� ”Surfaces > Loft” on page 61

Tip If you need a uniform transition of the surface as it lofts through 
each profile curve (for example, a boat hull), space the curves 
evenly.
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3 | Creating NURBS surfaces 
How do I? > Sweep a profile curve along a path curve
Sweep a profile curve along a path curve

The Extrude action creates a surface by sweeping a cross-section (or 
“profile”) curve along a path curve. The curves can be normal 3D curves, 
surface isoparms or edges, trim edges, or curves-on-surface. The ends of 
the extruded surface are open; however, you can create caps at each end 
using Surfaces > Planar.

To extrude a profile curve along a path curve

1 Select the profile curve or curves. Then select the path curve.

Maya uses the key curve (the last curve you select) as the path.

2 Select Surfaces > Extrude.

3 Select the extrude node and choose the Show Manipulators tool to 
manipulate the extrude.

Tip If the path curve changes direction abruptly, the cross section may 
twist around the path.

If this happens, insert edit points in the path curve so its direction 
change is spread out across more CVs.

Path curve

Profile curve
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How do I? > Sweep one or more profile curves along two path curves (birail)
To cap the end of an extruded surface

1 Select the isoparm at the end of the extruded surface.

To do this, press the right mouse button on the extruded surface, and 
choose Isoparm from the marking menu. Then click the end of the 
extruded surface.

2 Select Surfaces > Planar to create a cap.

Related topics

� ”Create a flat surface inside a curve” on page 39

� ”Skin a surface across profile curves” on page 40

� ”Sweep one or more profile curves along two path curves (birail)” on 
page 43

� ”Surfaces > Extrude” on page 67

� ”Surfaces > Planar” on page 65

Sweep one or more profile curves along two 
path curves (birail)

1 Select Surfaces > Birail > Birail n Tool based on how many profile 
curves you want to use (1, 2, or 3-or-more).

2 Click the curve(s) you want to use a profile curves, then click the two 
rail curves.

Instructions appear on the help line at each step.
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3 | Creating NURBS surfaces 
How do I? > Create a surface within bounding curves
Related topics

� ”Skin a surface across profile curves” on page 40

� ”Sweep a profile curve along a path curve” on page 42

� ”Surfaces > Birail > Birail 1 Tool, Birail 2 Tool, Birail 3+ Tool” on 
page 73

Create a surface within bounding curves

1 Select the boundary curves.

If you select only three curves, Maya will create a “three-sided” 
surface (see notes below).

Profile curve

Rail curves

Birail 1 Tool

Birail 2 Tool

Birail 3+ Tool
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3 | Creating NURBS surfaces

How do I? > Create a surface within bounding curves
2 Choose Surfaces > Boundary.

If you turn on the Partial option to use a subsection of the curves, you 
can control which part of each curve Maya revolves by selecting the 
subcurve node in the channel box and editing the minValue and 
maxValue attributes. If you have the Show Manipulator tool selected, 
handles appear on the curves to allow you to drag the values.

Notes

• The order you select the input curves does not matter to the shape of 
the surface. However, order can affect parameterization of the curves 
and the resulting surface.

Some of the curves may be reversed to make sure their start and end 
points match. The first curve you select is used for the surface U 
parameters.

If you select opposing pairs of curves in order (that is select the first 
curve, then select the curve on the opposite side, then the third curve, 
then the curve opposite it), you can determine which curves will 
control which parameters.

• A three-sided surface is actually a 4-sided surface with one side 
collapsed to a zero length multi-knot (sometimes called a degenerate 
surface). These kinds of surfaces can sometimes be problematic in 
rendering and data transfer.

If the end points of two side curves do not meet exactly, a short 
straight line segment will result instead of a zero length line.

• For a three-sided boundary surface, the zero-length side always 
appears where the first curve meets the second curve.

Related topics

� ”Create a surface from four boundary curves that maintains 
continuity (square)” on page 46

� ”Create a surface between two sets of boundary curves” on page 52

� ”Surfaces > Boundary” on page 76
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How do I? > Create a surface from four boundary curves that maintains continuity 

(square)
Create a surface from four boundary curves 
that maintains continuity (square)

Square creates a three or four-sided surface that maintains continuity with 
adjacent surfaces (where you use an isoparm, edge, or curve-on-surface as 
an input curve).

1 Make sure the boundary curves intersect.

2 Select the curves in order (clockwise or counterclockwise).

The first curve you select sets the U direction for the surface and the 
second curve sets the V direction.

3 Select Surfaces > Square.

4 In the toolbox, click Show Manipulators to view the continuity 
indicators.

Click the indicator on a side to set the requested continuity, or open 
the channel box and set the square surface’s continuityTypeN 
attribute (the numbers indicate the order you clicked the curves).

If even Maya cannot create the requested continuity, it will create a 
surface.

What if...?

I can’t achieve the continuity I want?
• Make sure your curves intersect.

• You can’t create a surface inside boundary curves with sharp corners, 
CV multiplicity, or multi-knots.

• Try selecting the curves in a different order.

Related topics

� ”Create a surface within bounding curves” on page 44

� ”Surfaces > Square” on page 78

Sweep out a surface by rotating a curve 
around an axis

1 Draw a curve representing the cross-section (or “profile”) of the 
surface you want to create.

2 Select the curve and choose Surfaces > Revolve > ❐.

3 Set the revolve options:

• Choose the initial axis around which to sweep the surface.
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3 | Creating NURBS surfaces

How do I? > Extrude and bevel a surface from a curve
• If you only want to revolve a subsection of the curve, set Curve 
Range to Partial.

4 In the toolbox, click the Show Manipulator tool to manipulate the 
surface.

If you turn on the Partial option to revolve a subsection of the curve, 
you can control which part of the curve Maya revolves by selecting 
the subcurve node in the channel box and editing the minValue and 
maxValue attributes. If you have the Show Manipulator tool selected, 
handles appear on the curve to allow you to drag the values.

Tips

• If you move the axis endpoints, the axis direction is modified. 
However, if you move the axis midpoints, the radius of the revolved 
surface is modified without affecting the axis direction.

Related topics

� ”Create a flat surface inside a curve” on page 39

� ”Surfaces > Revolve” on page 57

Extrude and bevel a surface from a curve

Use Surfaces > Bevel to create an extruded surface with a beveled edge 
from any curve, including text curves and trim edges. For example, to 
create a ledge on a building, or the rolled edges on an upholstered chair.

Create a simple extrude and bevel

1 Select the curve.

You can create beveled surfaces from normal 3D curves, isoparms, 
and surface edges.

2 Choose Surfaces > Bevel.

AxisMidPoint

AxisEndPoint

AxisStartPoint

CircleSweep
NURBS Modeling

47



3 | Creating NURBS surfaces 
How do I? > Extrude and bevel a surface from a curve
3 In the toolbox click the Show Manipulators tool to manipulate the 
beveled surface.

If you turned on the Partial option, click the curve or isoparm heading 
in the channel box to show additional attributes for using only a 
subsection of the curve.

Bevel Plus

Bevel Plus has various features beyond Surfaces > Bevel operation:

• Creates a completely solid surface, including a cap on either end of 
the beveled curve. The surface will not break when you deform it, 
which is ideal for flying logos.

• Gives you various style options for the bevel shape.

• Gives you more control over the tessellation of the surface.

Bevel Plus is useful for creating solid letters and logos.

Click to display
Start and End
manipulators
NURBS Modeling 

48



3 | Creating NURBS surfaces

How do I? > Create a new surface from patches of an existing surface
To bevel with Bevel Plus

1 Select a single curve. For shapes with a hole (such as a letter a), select 
the outer curve first and the inner curve second.

2 Choose Surfaces > Bevel Plus > ❐.

3 Set the options.

4 Click Bevel.

Related topics

� ”Sweep a profile curve along a path curve” on page 42

� ”Round off the meeting point between two edges” on page 50

� ”Create a fillet between two surfaces” on page 51

� ”Surfaces > Bevel” on page 79

� ”Surfaces > Bevel Plus” on page 82

Create a new surface from patches of an 
existing surface

To duplicate surface patches

1 Select patch or patches.

2 Select Edit NURBS > Duplicate NURBS Patches.

Select outer 
curve...

...then inner 
curve
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3 | Creating NURBS surfaces 
How do I? > Round off the meeting point between two edges
Create NURBS transition surfaces

Round off the meeting point between two 
edges

1 Select Edit NURBS > Round Tool.

2 Drag a selection box across the common edges between surfaces.

3 When you click a common edge, a radius manipulator appears. Drag 
the handles at the ends of the manipulator arms to change the 
rounding radius.

To deselect an edge, click the manipulator on the edge and press 
Delete.

4 When you are done marking edges to be rounded, press Enter.

You can edit the radii of the fillets after you create them by selecting the 
Round node and using the channel box, attribute editor, or Show 
Manipulator tool.

If a fillet cannot be built with the current radius, the manipulator for that 
edge is drawn in red.
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How do I? > Create a fillet between two surfaces
Notes

• Overlapping radii will fail or create unpredictable results.

You can correct this by editing the radii with the Show Manipulator 
tool after the fillets are created. If the angle between the two surfaces 
is less than 15 degrees or greater than 165 degrees, the fillets produced 
might be inadequate.

• The edges you round must be from separate surfaces.

• If the edges have different lengths, a fillet surface will be created only 
for the shorter edge.

• Corners are points where pairs of edges meet. You cannot use the 
Round Tool on more than three pairs of corners.

For example, you can use the Round Tool on all edges of a cube, but 
you can not use it on the tip of a pyramid, where four edge pairs meet 
at the top.

• Acute corners may fail as the fillets begin to self-intersect.

• The radius manipulator approximates the profile of the fillet only 
when the surfaces meet at an angle of nearly 90 degrees.

Related topics

� ”Extrude and bevel a surface from a curve” on page 47

� ”Create a fillet between two surfaces” on page 51

� ”Edit NURBS > Round Tool” on page 88

Create a fillet between two surfaces

Create a circular fillet

1 Select two intersecting surfaces.

2 Select Edit NURBS > Surface Fillet > Circular Fillet > �.

3 Do any of the following:

• Use the channel box, attribute editor, or Show Manipulator tool to 
change the radii.

• Select one of the surfaces and choose Edit NURBS > Reverse 
Surface Direction to change which side of the surface the fillet is 
built on.

Create a freeform fillet

1 Select an isoparm or curve-on-surface on each surface as the start and 
end points of the fillet.

2 Select Edit NURBS > Surface Fillet > Freeform Fillet.
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3 | Creating NURBS surfaces 
How do I? > Create a surface between two sets of boundary curves
3 Do any of the following:

• Use the channel box, attribute editor, or Show Manipulator tool to 
edit the fillet.

• To manipulate the isoparms used to create the fillet, select the one 
of the curveFromSurface nodes.

Related topics

� ”Round off the meeting point between two edges” on page 50

� ”Create a surface between two sets of boundary curves” on page 52

� ”Edit NURBS > Surface Fillet > Circular Fillet” on page 88

� ”Edit NURBS > Surface Fillet > Freeform Fillet” on page 91

Create a surface between two sets of 
boundary curves

You can build a blend between two boundaries defined by sets of surface 
curves. For example, you can use this tool to create a surface that forms a 
smooth juncture between a creature’s arm and torso.

1 Select Edit NURBS > Surface Fillet > Fillet Blend Tool.

2 Click the surface curves that form the first boundary, then press Enter. 
You can use isoparms, edges, or curves-on-surface. 

3 Click the surface curves that form the second boundary, then press 
Enter.
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3 | Creating NURBS surfaces

Reference > Create > NURBS Primitives
If you edit the surfaces that provided the input curves for the blend, 
the blend updates automatically.

What if...?

The blend surface is twisted?
• Reverse the direction of the surface curves at one end of the blend.

• If reversing the curves is undesirable, use the Reverse Direction Left/
Right attribute to reverse the surface after it is created.

Related topics

� ”Round off the meeting point between two edges” on page 50

� ”Create a fillet between two surfaces” on page 51

� ”Edit NURBS > Surface Fillet > Fillet Blend Tool” on page 91

Reference Menus

Create

Create > NURBS Primitives

Create various geometric primitive shapes using NURBS surfaces or 
curves. Most of the options are shared between primitive types.

Note If you use the manipulator handles to adjust a fillet blend 
between straight lines (such as the edges of two planes), twisting 
and unexpected results may occur.
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3 | Creating NURBS surfaces 
Reference > Create > NURBS Primitives
Create > NURBS Primitives > Type > �

Sphere

You can create a sphere as the starting point for an assortment of rounded 
objects, for instance, eyeballs, planets, and human heads.

Pivot

By default, the Pivot is set to Object, and the primitive is created at the 
origin. Specifically, its rotate and scale pivots are at the origin.

If you set Pivot to User Defined, you can enter values in the Pivot 
Point X, Y, and Z boxes to position the pivots (and the primitive). 

Axis

Select X, Y, or Z to specify a preset axis direction of the object.

Select Free to enable the X, Y and Z Axis Definition boxes. Enter new 
values to select your own axis direction.

Select Active View to create the object perpendicular to the current 
orthographic view. The Active View option has no effect when the 
current modeling view is a camera or perspective view.

Start and End 

Sweep Angles

These options let you create a partial sphere by specifying a degree of 
rotation. Degree values can range from 0 to 360 degrees. The 
following example shows the top view of a sphere with an End Sweep 
Angle of 180 degrees.

Radius

Sets the width and depth of the primitive.

Surface Degree

A Linear surface has a faceted appearance; a Cubic surface is rounded. 
For details on surface degree, see ”Degree” on page 12.

Default = 360 End Sweep Angle = 180
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Reference > Create > NURBS Primitives
Use Tolerance

You can use this option to improve the precision of the primitive’s 
shape. If set to Global tolerance, the Positional tolerance value in the 
Settings part of the Preferences window is used (Window > Settings/
Preferences > Preferences). Lower values increase surface precision.

If set to Local, you can enter a value in the options window to 
override the Positional tolerance value in the Preferences window.

If set to None, tolerance is ignored and the sphere is created with the 
specified number of sections and spans (see below). 

Number of Sections

Sets the number of surface curves created on the sphere in one 
direction. Surface curves, also called isoparms, show the outline of the 
surface shape. The more sections (and spans) a surface has, the more 
precisely it shows surface deformations.

The following figure shows two spheres, the left with 8 sections and 
the right with 16 sections. A value less than 4 gives a crude sphere. 

Subsequent chapters explain how to use isoparms to create new 
surfaces.

Cubic Linear

Sections = 8 (default) Sections = 16
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Reference > Create > NURBS Primitives
Number of Spans

Sets the number of surface curves created on the sphere in the 
direction that crosses the Section direction. A value less than 4 gives a 
crude sphere.

Cube

A cube has six sides, each selectable. You can select a side of the cube in 
the view, or click its heading in the Outliner. For example, if you select 
leftnurbsCube in the Outliner, you select a single side of the cube. To 
select the whole cube, marquee-select the cube and press the keyboard’s 
up arrow.

Options unique to cubes follow:

Width, Length, Height

Sets the cube dimensions.

U/V patches

Sets the number of U and V Patches between the edges that make up 
the cube. This value changes the number of spans and sections. 

Cylinder

You can create a cylinder with or without end caps. The options unique to 
cylinders pertain to end caps. You can create caps for either, both, or no 
ends of the cylinder. You can also create caps as separate transform nodes 
so you can manipulate them independently of the cylinder. 

Cone

You can create a cone with or without a cap on its base. Its other options 
are similar to those of other NURBS primitives.

Plane

A plane is a flat surface made up of a specified number of patches. Its 
options are similar to other NURBS primitives.

Number of Spans = 4 (default) Number of Spans = 16
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Reference > Surfaces > Revolve
Torus

A torus is a 3D ring. It has options similar to other NURBS primitives.

Circle

A circle is a curve, not a surface. Its options are similar to a sphere.

Square

A square is a group of four curves, not a surface. A square is useful in 
various modeling operations, for instance, trimming window shapes from 
buildings. Its options are similar to other NURBS primitives.

Modeling menu set

Surfaces

Surfaces > Revolve

Sweeps out a surface by revolving a profile curve around a pivot point.

Related topics

� ”Sweep out a surface by rotating a curve around an axis” on page 46

Surfaces > Revolve > �

Axis Preset

Specifies the revolution axis. The default is Y. In the following figure, 
a profile curve (drawn in the front view) is revolved using each 
revolution axis in the perspective view.
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Reference > Surfaces > Revolve
If you set the Axis Preset to Free, you can enter values in the Axis X, 
Y, or Z boxes to specify the axes about which the profile curve is 
revolved. The following figure shows a surface resulting from a value 
of 1 for Axis X, Y, and Z.

Pivot

If you set Pivot to Object, the revolve is performed from the default 
pivot location (0,0, 0). This is the default.

If you select Preset, you can change the X, Y, or Z location of the pivot 
point by entering values in the Pivot Point boxes. 

Revolved in XProfile curve

Revolved in Y (default) Revolved in Z
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Reference > Surfaces > Revolve
The following figure shows how a revolved surface is created with 
default pivot values and with values of 5 for X, Y, and Z.

Surface Degree

The Surface Degree options determine whether the V parameter 
direction of the surface is created with linear (degree 1) or cubic 
(degree 3) geometry.

If you select Linear, the surface is constructed with flat facets all 
around.

If you select Cubic, the smooth profiles are defined by the original 
profile curve. This is the default.

Start and End

Sweep Angle

Use the Start Sweep Angle and End Sweep Angle values to specify the 
angle of revolution in degrees. The default is 360, with a valid range of 
0 to 360. 

Use Tolerance

The Use Tolerance options control the accuracy of the resulting 
revolved surface. You can apply tolerance globally or locally.

If you select None you can change the segments value. 

If you select Global tolerance, Maya uses the Positional and Tangential 
values in the Settings part of the Preferences window.

0, 0, 0 

5, 5, 5

by default

CubicLinear
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Reference > Surfaces > Revolve
If you select Local tolerance, you can directly enter a new value that 
overrides the Positional tolerance of the Preferences window. This lets 
you create the revolved surface closer to the actual surface of 
revolution.

Segments

The Segments value determines how many sections are used to create 
the surface of revolution. With a sweep of 360 degrees, six or eight 
sections are usually sufficient. In the following figure, the left surface 
shows the revolve with eight segments. The right shows 20 segments.

If Use Tolerance is not set to None, the Segments value is 
automatically computed so that the result differs from the default 
revolved surface by less than the specified tolerance value.

If Local is set as the Use Tolerance option, the tolerance value of the 
revolved surface is closer to the actual surface of revolution.

Curve Range

Select Complete as the Curve Range to create the revolved surface 
along the entire profile curve. This is the default.

Select Partial if you want to use a segment of the curve for the revolve.

Tip If animating the sweep angle, change the Segments value instead 
of the tolerance value to change the numbers of CVs of the surface. 
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Reference > Surfaces > Loft
If you set the Curve Range to Partial before you create the revolved 
surface, a subCurve is created. By lessening the length of the 
subCurve, you lessen the length of the revolved surface.

To edit the length of the subCurve, select the revolved surface, select 
the subCurve in the Channel Box, select the Show Manipulator Tool, 
then drag the curve segment manipulator or edit the Min and Max 
Value in the Channel Box.

For more details on editing subCurves, see ”Editing the subCurve 
attributes” on page 61.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.) 

Input Curve 

The Input Curve information is read-only. It gives you access to the 
history of the curve you used to create the revolved surface. 

Editing the subCurve attributes

If you set the Curve Range to Partial in the options window when the 
revolve was created, you can edit the length of the curve. Select the 
revolved surface, then use the Show Manipulator tool or Channel Box to 
edit the subCurve attributes. 

Surfaces > Loft

Skins a surface along a series of profile curves.

Related topics

� ”Skin a surface across profile curves” on page 40
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Reference > Surfaces > Loft
Surfaces > Loft > �

Parameterization

This modifies the parameterization of the lofted surface (see 
”Parameters and parameterization” on page 14).

Uniform knot spacing makes the profile curves run parallel to the V 
direction. The parameter values of the resulting surface in the U 
direction are equally spaced. The first profile curve corresponds to the 
isoparm on the surface at U[0], the second to U[1], and so on. 

Chord Length spacing causes the parameter values on the resulting 
surface in the U direction to be based on the distance between the start 
points of the profile curves.

Auto Reverse

If Auto Reverse is off, the curves are used as they are, which may 
result in a twisted surface. If on, the curves are automatically 
reversed. 

In the following example, the two top curves and the two bottom 
curves are going in different directions.

If Auto Reverse is off, the result is a twisted lofted surface. If on, the 
curves are automatically reversed.

Tip If the curves have the same curve degree and number of edit 
points, the lofted surface will have the same number of spans in 
the U direction. The surface will be easier to manipulate and 
texture. A convenient way to accomplish this is to make copies of a 
single curve and transform CVs on the copies as necessary to get 
the desired profile curves.

If the parameterization of the curves differs, the lofted surface 
might have more spans than any of the profile curves. If you create 
the curves as Edit Point curves with Chord Length, the surface will 
be more complex and harder to work with. 
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Reference > Surfaces > Loft
If Auto Reverse is off, you can use the Show Manipulator Tool to 
reverse the curve direction of the original profile curves as needed. 
Simply click the manipulator handle to reverse the curve direction.

Close

The Close option sets whether the created surface is periodic in one 
dimension (U or V). Close is off by default. See ”Periodic, closed, and 
open” on page 17.

Surface Degree

You can set the Surface Degree to either Linear or Cubic. This sets the 
lofted surface to linear or cubic in the U direction. Linear creates 
surfaces that appear faceted. Cubic creates smooth surfaces.

Section Spans

This option sets the number of spans between the lofted curves. 
Higher numbers give finer control of surface deformations at the 
expense of extra processing time.

Curve Range

If you select Partial, you can use the Show Manipulator Tool after the 
loft operation to change the length of the subCurves used to create the 
surface. This changes the length of the surface.

Auto Reverse onAuto Reverse off

Cubic Linear
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Reference > Surfaces > Loft
Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.) 

Input Curves

The options in the Loft History section of the Attribute Editor gives 
you access to the history of the lofted surface you constructed. This 
information is read-only. Click the arrow buttons to select the surface, 
isoparms, or curves, then open its section of the editor.

Reverse Curve

If you turned Auto Reverse off when you lofted the surface, a Reverse 
Curve option is displayed for each curve, primitive, or surface 
isoparm you used to create the lofted surface. Select the Show 
Manipulator Tool to display the reverse manipulators. Click the 
options to reverse the direction of the input curves, or click the 
manipulators.

In the following illustration, the first curve used to create the lofted 
surface is selected for reversal.

Select the subCurve

Drag the manipulators
or enter values in the
Min/Max boxes.

heading and the Show
Manipulator Tool to
display the manipulators

 

for a specific subCurve.
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Reference > Surfaces > Planar
Editing the subCurves in the Attribute Editor

If you set the Curve Range to Partial in the options window when the loft 
was created, you can use the Attribute Editor for the resulting subCurves. 

Surfaces > Planar

Creates a planar (flat) surface within a boundary curve.

Related topics

� ”Create a flat surface inside a curve” on page 39

Surfaces > Planar > �

Degree

Select either Linear (degree 1) or Cubic (degree 3) for the Degree if the 
output is a NURBS surface. Cubic is the default.

Curve Range

Complete creates the planar surface along the entire curve. 

Partial lets you display manipulators on the planar surface with the 
Show Manipulator Tool and edit the resulting planar surface along 
part of the input curve. Click the input curve or isoparms’s heading in 
the Channel Box to display the options.
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Reference > Surfaces > Planar
Output Geometry

Specifies the type of geometry created. 

Creating trimmed surfaces from open curves

You do not necessarily need a single boundary curve to create a trimmed 
surface, however, you do need an enclosed region. This can be created by 
intersecting several curves. You can create trimmed surfaces using curves 
with overlapping boundaries. Select the curves and use Surfaces > Planar 
to create the trimmed surfaces.

 Limitations Although the boundary of a planar surface can be 
manipulated to change the shape of the surface, the surface must 
remain planar at all times.

Although a planar surface can include cut-out areas or holes, the 
curves that define the holes must be co-planar with the main 
surface. 
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Reference > Surfaces > Extrude
Surfaces > Extrude

Creates a surface by sweeping a profile curve along a path curve.

Related topics

� ”Sweep a profile curve along a path curve” on page 42

Surfaces > Extrude > �

Style

Flat maintains the orientation of the cross section as it moves along 
the extrusion path.

Tube sweeps the cross section along the path with the reference vector 
staying tangent to the path. 

Original curves

Planar Trimmed surface
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Reference > Surfaces > Extrude
Distance extrudes the profile in a straight line. Do not select a path 
curve when you turn on this option. When Distance is on, the options 
window provides extra options: Extrude Length, Direction, and 
Surface Degree.

Extrude Length

Specifies how far the extrusion goes. 

Direction

Profile Normal sets the direction of the path to the normal of the 
profile curve. If the profile curve is not planar, the average normal is 
used.

With Tube, the extrusion
sweeps along the
profile curve and
pushes out as it
follows the path.

Length = 1.0 Length = 5.0
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Reference > Surfaces > Extrude
Specify lets you choose a Direction Vector for the extrusion: X Axis, Y 
Axis, Z Axis, or Free. For example, if you click the Z Axis button, the 
extrusion will be linear in the Z direction.

If you select Free, you can enter values in the X, Y, and Z boxes to 
specify a vector as the direction for the extrusion. 

Surface Degree

Linear gives the surface sharp edges between isoparms. Cubic gives 
smooth edges. 

Result Position

This option is available only if you set Style to Flat or Tube.

At Profile creates the extruded surface at the location of the profile 
curve.

At Path creates the extruded surface at the location of the path curve.

Normal direction Resulting surface

x = 1.0
y = 0.0
z = 0.0

x = 0.0
y = 0.0
z = 1.0
NURBS Modeling

69



3 | Creating NURBS surfaces 
Reference > Surfaces > Extrude
Pivot

The Pivot options are available only if you set the Style to Tube. If you 
select At Path as the Result Position, you can choose the profile curve 
then position it at the pivot point on the extrusion path.

If you select Closest End Point, the path end point closest to the center 
of the bounding box of the profile curves is used. This end point is 
used as the pivot point for all the profile curves. If you are doing a 
multiple extrusion, the resulting surfaces are offset from the path. 

If you select Component, the pivot point of each individual profile 
curve is used to extrude the profile curve. The extrusion occurs along 
the components of the profile curve.

Path and profile curves

Closest End Point

Component
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Reference > Surfaces > Extrude
Orientation

The Orientation options are only available if Style is set to Tube.

If you choose Path Direction, the direction of the extrusion is set by 
the direction of the path curve. By default, the direction of the 
extrusion is set by the Profile Normal direction—the normal of the 
profile curve.

Orientation examples

In the following example, Result Position is set to At Profile and 
Orientation is set to Profile Normal. The path curve is moved and rotated 
to match the profile curve. This is the default setting.

In this following example, Result Position is set to At Path and Orientation 
is set to Path Direction.
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In the following example, Result Position is set to At Profile and 
Orientation is set to Profile Normal. The profile curve is moved and 
rotated to match the path curve.

Rotation

Rotates the profile curve as it is extruded along the path curve. Higher 
values cause the surface to stray from the path, especially with 
scaling.
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Reference > Surfaces > Birail > Birail 1 Tool, Birail 2 Tool, Birail 3+ Tool
Scale

Scales the profile curve as it is extruded along the path curve. Higher 
values cause the surface to stray from the path, especially with 
rotation.

Curve Range

Complete extrudes the entire profile along the entire path. 

Partial extrudes only part of the profile along part of the path. If 
construction history is turned on, this creates a subCurve node that 
you can edit to change the extruded surface. See ”Editing the extruded 
surface using manipulators” on page 73.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.) 

Note that the Profile Curve and Path Curve boxes let you access the input 
curves as well as statistical information about these curves. Click the 
arrows beside the boxes to select the input curves. Click the tab to open 
the Attribute Editors for them.

Editing the extruded surface using manipulators

After you extrude the surface, select the surface, display the Channel Box, 
and select the Show Manipulator Tool. Click each of the subCurve nodes 
in the Channel Box to display the different manipulators available.

Experiment with the manipulators to see their effect on the surface. They 
let you change the length and sweep of the extrusion.

Surfaces > Birail > Birail 1 Tool, Birail 2 Tool, 
Birail 3+ Tool

Creates a surface by sweeping between a series of profile curves along two 
path curves. The resulting surface can maintain continuity with other 
surfaces.
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Reference > Surfaces > Birail > Birail 1 Tool, Birail 2 Tool, Birail 3+ Tool
Related topics

� ”Sweep one or more profile curves along two path curves (birail)” on 
page 43

Surfaces > Birail > Birail 1/2/3+ Tool > �

Transform Control

Select Proportional or Non Proportional to choose how to scale the 
profile curve sweep along the rails. 

Example of using Transform Control

Construct rail curves in the XZ plane. Construct the profile curve so that 
the internal CVs are at some constant Y. By scaling nonproportionally, the 
internal CVs of the birail surface also preserve the constant Y as the 
profile.

1 In the top view, create the two rail curves. Select Display > NURBS 
Components > Edit Points to display the edit points on the curves.

2 Click the Snap to points icon on the Status Line, place the first point of 
the profile curve, and click Snap to points again to turn snapping off.

3 In the front view, continue to place the points to create the profile 
curve. Select the Snap to points icon to snap the last point to the last 
rail curve (remember to turn snapping off afterward).
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Reference > Surfaces > Birail > Birail 1 Tool, Birail 2 Tool, Birail 3+ Tool
4 Build the birail surface. While it is active, click the Transform Mode 
box of the Channel Box and select Non Proportional, then 
Proportional. The following figure shows the birail surface for each 
transform mode.

Profile Blend Value

(Birail 2 only)

This option sets the influence the profile curves have on the 
intermediate profiles of the created surface. A value of 1.0 means the 
first selected profile curve has a greater influence than the second 
profile curve. A value of 0 has the opposite effect. By default, both 
selected profiles have an equal influence value of 0.5. This option is 
available only for a surface created with the Birail 2 Tool.

Continuity

This makes the resulting surface tangent continuous to the surface 
underlying the profile curve. 

Because you use multiple profile curves for the Birail 2 and 3+ Tools, 
the Continuity option has Profile and Rail options for each curve you 
use.

Rebuild

Turn on one of the Rebuild options to rebuild the profile or rail curves 
before they are used to create the surface. Because you use multiple 
profile curves for the Birail 2 and 3+ Tools, the Rebuild option has 
Profile and Rail options for each curve you use.

Profile rebuilds the profile curve.

First Rail rebuilds the first rail curve you select when you build the 
surface. Second Rail refers to the second curve you select.

When you turn on any of the Rebuild options, Maya displays the 
Rebuild Curve options explained in ”Edit Curves > Rebuild Curve” 
on page 136.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.) 

Non-proportional Proportional
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Reference > Surfaces > Boundary
Tool Behavior

Exit On Completion ends tool usage after you create the birail surface. 
If off, you can do another birail operation without having to select the 
tool again.

Auto Completion displays prompts at each step of the birail tool’s 
usage. If off, you must pick the curves in the correct order then select 
the birail tool to complete the operation. Pick the profile curve first, 
then the two rail curves.

Input Profile &

Input Rail

The Input Profile and Input Rail information boxes list the curves you 
used as profile and rail curves. Click the arrow buttons next to the 
curve names if you want to edit the curves.

Tangent Continuity 

Profile

The Tangent Continuity Profile options let you turn tangent 
continuity on or off for the input profile curve. This option is valid if 
the profile curve is a surface curve (isoparm, trimmed edge, curve-on-
surface).

Surfaces > Boundary

Creates a surface by filling between boundary curves.

Related topics

� ”Create a surface within bounding curves” on page 44

Surfaces > Boundary > �

Curve Ordering

Automatic creates the boundary with an internal decision process. As 
Selected causes the curve selection order to determine the resulting 
surface.

In the following figure, the first surface is created by selecting the 
curves while Automatic is selected. The second surface is created 
when As Selected is the option setting and you select the curves in a 
different order.
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Reference > Surfaces > Boundary
Common End Points

The Common End Points options let you decide whether the end 
points should match before the boundary surface is created.

If you select Optional, the surface is created even if the ends of the 
curves don’t match. This is the default.

If you select Required, the boundary surface is only built if the end 
points of the curves match exactly. 

To make sure the end points match, remember to select a snap mode 
from the Status Line when drawing your curves. 

To match the end points after you draw the curves:

1 Turn on a snap mode, for instance, as Snap to grids.

2 Select the edit point or CV you want to move.

3 Select the Move Tool and drag to snap to the same position.

If Automatic is on 
and you select the

1

2

3

4

If As Selected is selected,
pick the curves in a
different order to get
a different result.

curves, you get this result.

Notice how
the curve
end points
are matched.
NURBS Modeling

77



3 | Creating NURBS surfaces 
Reference > Surfaces > Square
End Point Tolerance

If you select Required as the Common End Point option, you can 
change the End Point Tolerance value of the end points to set how 
close they must be in order to be considered coincident.

Global tolerance causes Maya to use the Positional value in the 
Settings part of the Preferences window. 

Local tolerance lets you enter a new value to override the value in the 
Preferences window.

Surfaces > Square

Creates a surface by filling between four boundary curves. The resulting 
surface can maintain continuity with surrounding surfaces.

Related topics

� ”Create a surface from four boundary curves that maintains 
continuity (square)” on page 46

Surfaces > Square > �

Continuity Type

Sets the type of surface tangency created. 

Fixed Boundary does not ensure continuity at the surface curves.

Tangent builds a smooth, continuous surface from the selected surface 
curves. When Tangent is on, the Curve Fit Checkpoints option 
becomes available. It specifies how accurately the Square surface will 
be built.

Implied Tangent creates a surface tangency based on the normal of the 
plane where the selected curve resides.
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Reference > Surfaces > Bevel
Curve Fit 

Checkpoints

Sets how many isoparms are used to achieve continuity across the 
surface curve. Larger values might create continuity with more 
precision, but the surfaces might be less useful. This is especially 
likely when the surface curves intersect acutely.

End Point Tolerance

Global tolerance means the Positional value you set in the Preferences 
window is used. Positional tolerance sets how close the end points 
need to be in order to be considered coincident. 

Local tolerance lets can enter a new value to override the Positional 
tolerance value you set in Preferences.

Rebuild

Rebuild provides an option to rebuild the surface curves used to 
generate the Square surface. This can improve curve parameterization 
in some cases.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.) 

Surfaces > Bevel

Creates beveled transition surfaces from a profile curve.

Related topics

� ”Extrude and bevel a surface from a curve” on page 47

� ”Surfaces > Bevel Plus” on page 82

Surfaces > Bevel > �

Attach Surfaces

This option attaches each part of the bevel surface. If off, the surfaces 
are not attached. For example, if Attach Surfaces is off and you create 
a bevel with Bevel set to Both, three surfaces are created. These 
surfaces are independent and can be selected and modified as such.
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Reference > Surfaces > Bevel
Bevel

Specifies whether the beveled surface area is applied to the top, 
bottom, or both sides of the original curve or isoparm. The following 
example uses a NURBS circle primitive curve using each method.

Attach Surfaces on Attach Surfaces off

The bevel is created from the top of the circle.

Top Side

The bevel is created from the bottom of the circle.

Bottom Side

The bevel is created from both the top and
bottom of the circle. This is the default method.

Both

Only the extrude part of the bevel
surface is created.

Off
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Reference > Surfaces > Bevel
Bevel Width

The Bevel Width value specifies the initial width of the bevel as 
viewed from the front of the curve or isoparm.

Bevel Depth

The Bevel Depth value sets the initial depth of the bevel part of the 
surface. The combination of Bevel Width and Bevel Depth sets the 
bevel angle.

Extrude Height

The Extrude Height value specifies the height of the extruded portion 
of the surface, not including the bevel surface area. 

Bevel Corners

The Bevel Corners options specify how corners in the original 
construction curves are handled in the beveled surface. Note that if 
the curves are degree 1 or 2, the bevel’s surface is cubic (degree 3).

Bevel Cap Edge

The Bevel Cap Edge options set the shape of the beveled part of the 
surface. 

Note Selecting the Bevel Off option disables the bevel option controls 
(Width, Depth, Corners, and Cap Edge). If you do this, you can use 
Bevel for simple extrusions.

Straight

The bevel is created with linear, or straight, corners.

Circular Arcs

The bevel is created with rounded, or circular arc corners.

Convex

The bevel is created with a convex edge.
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Reference > Surfaces > Bevel Plus
Use Tolerance

The Use Tolerance options let you create a bevel within a specified 
tolerance of the original input curves. 

Global tolerance causes Maya to use the Positional value in the 
Settings part of the Preferences window.

Local tolerance lets you enter a new value to override the value in the 
Preferences window.

Curve Range

Use the Curve Range options if you are creating a bevel from a curve.

Complete uses the entire curve for the bevel operation. 

Partial lets you use a segment of the curve for the bevel. 

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.) 

Input Curve

The Input Curve information is read-only. It gives you access to the 
history of the curves or isoparms you used to create the bevel surface. 
Click the arrow buttons to select the curve and open its section of the 
editor.

Surfaces > Bevel Plus

Lets you create beveled transition surfaces with a much higher degree of 
control than regular Bevel.

Concave

The bevel is created with a concave edge.

Straight

The bevel is created with a straight edge.
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Reference > Surfaces > Bevel Plus
Related topics

� ”Extrude and bevel a surface from a curve” on page 47

� ”Surfaces > Bevel” on page 79

Surfaces > Bevel Plus > �

As you edit the Bevel Plus options, refer to the following figure, showing 
the parts of the surface created by Bevel Plus:

Attach Surfaces

This option is enabled if you set the Output Geometry option to 
NURBS. When Attach Surfaces is on, Maya attaches the beveled areas 
and the extruded area together to form one NURBS surface. When it is 
off, Maya creates separate NURBS patches for each area. 

For example, you might turn off Attach Surfaces so you can easily 
apply a different material to the patches in the beveled area than the 
patch in the extruded area. 

Create Bevel: At Start, At End

Turns beveling on or off at either end of the resulting surface. At Start 
controls the portion closest to the curve and At End controls the 
portion furthest from the curve. 

Bevel Width

Specifies the width of the beveled area as viewed from the front of the 
resulting surface.

Bevel Depth

Specifies the depth of the beveled area as viewed from the top or side of 
the resulting surface.

Extrude Distance

Specifies the distance of the extruded portion of the geometry, excluding 
the beveled areas. 

Cap (area 
in center)

Beveled 
areas

Extruded 
area
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Create Cap: At Start, At End

Turns on or off the creation of surfaces that cap the center area on either 
end of the beveled surface. At Start controls the portion closest to the 
curve and At End controls the portion furthest from the curve. 

Outer Bevel Style, 

Inner Bevel Style

The bevel style controls the overall look of the beveled surface. For 
example, Straight Out creates a straight beveled edge extending 
outward from the original curve. 

You can switch between styles and compare the results by accessing 
the outerStyleCurve or innerStyleCurve attribute from the Attribute 
Editor or Channel Box. 

The following figure illustrates some of the terms used in the bevel 
style names:

Same as Outer Style

The Outer and Inner style are for letters or art that have an outer 
curve and an inner curve, such as the letter O. By default, they share 
the same bevel style, but you can make them different by turning off 
the Same As Outer Style option. 

Use Tolerance

This option is enabled if you set the Output Geometry option to NURBS. 
Tolerance determines the degree of accuracy that is maintained between 
the original curve and the beveled surface. Choose from the following 
options:

Convex Out Concave Out Straight Side Edge Straight Front Edge
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Global Maya uses the Positional value in the Settings 
section of the Preferences window (Window > 
Settings/Preferences > Preferences > Settings).

Local Lets you enter a new value to override the value set 
in the Preferences window.

Tolerance

If you choose Local, set the degree of accuracy between the original curve 
and the beveled surface. A low value creates a surface that closely follows 
the curve. A high value creates a surface that loosely follows the curve. 

Output Options

Click the Output Options tab to specify the resulting geometry type and 
topology. 

Output Geometry

Specifies whether to use NURBS or polygons for the resulting beveled 
surface. 

Tessellation Method

Controls the smoothness of the resulting beveled surface using two 
different methods. Count lets you specify the number of polygons; see 
”Count tessellation method” on page 85. Sampling lets you specify 
different degrees of tessellation in different areas of the beveled surface; 
see ”Sampling Controls” on page 86.

Count tessellation method

By setting Tessellation Method to Count, you can specify the number of 
faces created in the resulting beveled surface. 

Face Count

Enter a face count and Maya tessellates the surface to match or 
approximate the count. For optimum performance, set a value that gives 
enough smoothness while maintaining a low polygon count. 

Note If you choose NURBS, Maya creates trimmed surfaces for the cap 
areas of the beveled surface. Some external applications, such as 
game exporters, may not handle trimmed surfaces.
NURBS Modeling

85



3 | Creating NURBS surfaces 
Reference > Surfaces > Bevel Plus
Sampling Controls

If the Tessellation Method is set to Sampling (the default), the following 
options are available. Sampling lets you specify different degrees of 
tessellation in different areas of the beveled surface.

Along Extrusion

Use these settings to control the tesselation along the direction of the 
extrusion. 

Section Use this option if you want the space between 
tessellated subdivisions to be different for the 
beveled areas versus the extruded area. With Section 
turned on, the tessellation occurs separately for each 
section of the beveled surface: the front beveled 
area, the back beveled area, and the non-beveled 
extruded area. Each section will have the same 
number of subdivisions, as specified in the Samples 
setting. 

Complete Use this option if you want the tessellated 
subdivisions to be more evenly spaced across the 
surface. With Complete turned on, the tessellation 
occurs along the entire beveled surface, from one 
surface cap to the other. 

Samples

The number of subdivisions in the resulting tessellation. 

Along Curve

Use these settings to control the tesselation along the direction of the 
source curve. 

Span Use this option if you want the space between 
tessellation subdivisions to be different for long 
spans versus short spans. (A span is the part of a 
curve between two edit points.) With Span turned 
on, the tessellation occurs between each span of the 
source curve. Each span will have the same number 
of subdivisions, as specified in the Samples setting. 

Note The actual number of faces will be higher than the Face Count 
value, because number of faces created for the beveled areas and 
caps are not included. 
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Complete Use this option if you want the tessellation 
subdivisions to be evenly spaced across the surface. 
With Complete turned on, the tessellation occurs 
along the entire beveled surface, from the curve's 
start point to the end point. 

Samples

The number of subdivisions in the resulting tessellation. 

Secondary Controls

If the Tessellation Method is set to Sampling (the default), the following 
options are available. 

These options are mainly useful for industrial designers concerned with 
the accuracy of a model in relation to a prototype model.

Use Chord Height,

Chord Height

The smaller the Chord Height value, the better Maya’s approximation 
of the beveled surface to the original curve. Chord height is the 
maximum distance from the original curve to the edge of the resulting 
polygon. 

Use Chord Height Ratio,

Chord Height Ratio

The Chord Height Ratio is calculated by dividing the chord height 
(maximum distance from the original curve to the edge of the 
resulting polygon) by the chord length (distance between two polygon 
vertices).

For example, the default value, 0.1, means that the chord height must be 
larger than 1/10 of the chord length before additional edit points are 
created. 

Edit NURBS

Edit NURBS > Duplicate NURBS Patches

Creates new surfaces from the selected NURBS patches.

Note If you scale the beveled surface, avoid using the Chord Height 
setting, because the chord length will always be relative to the 
object, not to world space. Use Chord Height Ratio instead. 
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Related topics

� ”Create a new surface from patches of an existing surface” on page 49

Edit NURBS > Duplicate NURBS Patches > �

Group With Original

If on, the duplicate surface is parented under the original object that 
contains the patches. If off, the resulting surface is independent of the 
original object.

Edit NURBS > Round Tool

Creates rounded transition surfaces along the edges between existing 
surfaces.

Related topics

� ”Round off the meeting point between two edges” on page 50

Edit NURBS > Round Tool > �

Radius

Specifies the fillet radius the tool uses when you select edge pairs.

Tolerance Value

Override tolerance means the Positional value you set in the 
Preferences window is used. Positional tolerance is used to determine 
how close the end points need to be to be considered coincident. The 
default is Override.

User Preferences tolerance lets you enter a new value to override the 
Positional tolerance value you set in Preferences.

Edit NURBS > Surface Fillet > Circular Fillet

Creates a circular fillet surface between two existing surfaces.

Related topics

� ”Create a fillet between two surfaces” on page 51

ImportantUnlike polygonal facets, you cannot move, rotate, or scale a 
NURBS patch that is a component of an object. You can move, 
rotate, or scale a NURBS patch that is a new object created with 
Duplicate NURBS Patches.
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� ”Edit NURBS > Surface Fillet > Freeform Fillet” on page 91

� ”Edit NURBS > Surface Fillet > Fillet Blend Tool” on page 91

Edit NURBS > Surface Fillet > Circular Fillet > �

Create Curve On Surface

Turn on Create Curve On Surface to create curves-on-surface when 
the fillet is constructed. The curves are placed on the surface at the 
point where they intersect with the fillet. 

When Create Curve On Surface is off, curves-on-surface are not 
constructed on the original surface. The default is off.

Reverse Surface Normals

During the fillet construction, the surfaces are offset in the direction of 
the normals by the Radius value you specify. By reversing the surface 
normals, you can construct the desired fillet. Click the Show 
Manipulator icon to see the surface normals.

Before you create the fillet, choose to reverse either the primary 
surface normal (the first selected surface), or the second surface 
normal (the second selected surface). The following examples show 
both primary and secondary reverse methods with a radius value of 
0.75. 

circular fillet Reverse Primary 

Reverse Secondary Reverse Primary, Secondary 
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To reverse surface normals by selecting surface points:

You can also reverse surface normals by selecting points on the surfaces 
and constructing the fillet. For example, the normals on the secondary 
surface are reversed if the point selected on the primary surface does not 
lie on the same side as its surface normal.

1 Select a point then Shift-select another point.

2 Select either Reverse Primary Surface Normal or Reverse Secondary 
Surface Normal, then click the Fillet button. Click the Show 
Manipulator icon to see the surface normals.

Editing the circular fillet normals using manipulators

1 To display the surface normals and radius manipulator after you 
create the fillet, select the fillet surface and display the Show 
Manipulator Tool.

2 Drag a radius manipulator handle. 
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Use Tolerance

The Use Tolerance options let you apply a circular fillet within a 
specified tolerance value. You can apply tolerance globally or locally.

Global tolerance causes Maya to use the Positional and Tangential 
values from the Settings part of the Preferences window.

Local tolerance lets you enter a new value to override the values in the 
Preferences window.

Edit NURBS > Surface Fillet > Freeform Fillet

Creates a fillet surface with configurable bias between two existing 
surfaces.

Related topics

� ”Create a fillet between two surfaces” on page 51

� ”Edit NURBS > Surface Fillet > Circular Fillet” on page 88

� ”Edit NURBS > Surface Fillet > Fillet Blend Tool” on page 91

Edit NURBS > Surface Fillet > Freeform Fillet > �

Bias

The Bias value scales the end tangents across the two surface curves.

Depth

The Depth value controls the curvature of the filleted surface.

Use Tolerance

The Use Tolerance options let you reapply a free-form fillet within a 
specified tolerance value.

Global tolerance causes Maya to use the Positional and Tangential 
values from the Settings part of the Preferences window.

Local tolerance lets you enter a new value to override the values in the 
Preferences window.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.) 

Edit NURBS > Surface Fillet > Fillet Blend Tool

Creates a fillet surface between two existing surfaces.
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Related topics

� ”Create a fillet between two surfaces” on page 51

� ”Edit NURBS > Surface Fillet > Circular Fillet” on page 88

� ”Edit NURBS > Surface Fillet > Freeform Fillet” on page 91

Edit NURBS > Surface Fillet > Circular Fillet > �

Auto Normal Dir

Turns on automatic orientation of the blended surface’s junctures with 
the original objects. If off, you must choose the surface orientation. For 
example, suppose you create the following fillet-blended surface (the 
middle object) from a pair of planes:

Where the blended surface meets the top plane, notice how the 
curvature curls towards the left-most part of the plane. If you rotate 
the top plane 180 degrees around its z-axis, the curvature still curls 
towards the same part of the plane.

If Auto Normal Dir is off, the curl of your surface may point in the 
opposite direction after the rotation. In the above example, the 
blended surface would curl toward the left end (former right end) of 
the top plane.
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In most cases, turning on Auto Normal Dir creates the desired 
orientation automatically when you rotate the surfaces. 

Auto Normal Dir is called Auto Normal in the Channel Box and 
Attribute Editor.

Multiple Knots

When on, Maya creates the blended surface with multiple knots at 
each knot position. This displays the surface with greater precision. Be 
aware that using multiple knots might break the tangency between 
the blended and original surfaces as you deform the surface. For 
example, you might see a sharp break in curvature on the surface as 
you deform it.

If you’re uncertain how to set this option, leave it off. If you will not 
be deforming the blended surface, turn this option on to create a 
better fit with the surfaces. Also, if you select Bezier as the output 
geometry, you can leave this option on because the conversion creates 
multiple knots anyway. 

Note that the number of multiple knots increases with a lower 
Positional Tolerance number. See “Use Tolerance” on page 96.

Reverse Normal Left/Right

If Auto Normal Dir is off, you can turn on Reverse Normal Left or 
Reverse Normal Right to correct a situation where the blended surface 
curls towards one of the original surfaces improperly. Reverse Normal 
Left reverses the curl towards the first surface you selected when you 
used the Fillet Blend tool. Reverse Normal Right reverses the curl 
towards the second surface. 

ImportantIf Multiple Knots is on, Auto Normal Dir is off regardless of its 
setting. If Multiple Knots is off, Auto Normal Dir is on regardless 
of its setting.
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If you’re uncertain about how to use these settings, use the Attribute 
Editor to experiment with different settings for Left or Right (or both) 
until you get the desired result. 

The Reverse Normal Left/Right attributes are named Flip Left/Right 
Normal in the Channel Box and Attribute Editor.

Reverse Direction Left/Right

If Auto Normal Dir is off, you can use these options to correct a 
blended surface that has an undesired twist after creation. If you turn 
on either of these options, the blended surface responds as though 
you were reversing the direction of a curve that joins the blended 
shape to the surface. (The curves are not actually reversed.) By 
experimenting with these settings in the Attribute Editor, you can 
untwist the blended surface. 

The Reverse Direction Left/Right attributes are named Reverse Left/
Right in the Channel Box and Attribute Editor.

Auto Closed Rail Anchor

This option prevents a blended surface from twisting when you rotate 
the original surface. The Auto Closed Rail Anchor option is relevant 
mainly for working with a blended surface created from periodic 
curves.

For instance, suppose you’ve created a blended surface from a pair of 
cylinders as shown in the following figure. The blended surface is the 
curving cylinder sandwiched between the top and bottom cylinders:

Note Left means the first surface you selected. Right is the second 
surface. The two terms do not refer to spatial placement in the 
workspace.
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If Auto Closed Rail Anchor is off and you rotate the top or bottom 
cylinder around its Y-axis, the blended surface (middle cylinder) 
twists as if it’s glued to the cylinders:

If Auto Closed Rail Anchor is on and you rotate the top or bottom 
cylinder, the middle cylinder slides along the bordering rings. No 
twisting occurs, so the middle cylinder retains its original shape. The 
middle cylinder will rotate if you rotate the top or bottom cylinders.

The Auto Closed Rail Anchor attribute is named Auto Anchor in the 
Channel Box and Attribute Editor.
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Use Tolerance

Global tolerance causes Maya to use the Positional and Tangential 
values from the Settings part of the Preferences window.

Local tolerance lets you enter a new value in the options window to 
override the values in the Preferences window.

Positional tolerance sets how snugly the blended surface fits the 
original surfaces. Tangential tolerance sets how precisely the tangency 
at the edges of the blended surface merge with the tangency at the 
edges of the original surfaces. 

For Positional and Tangential tolerance, lower values increase 
accuracy at the expense of longer rendering time.

Unless you’re modeling for manufacturing output, it’s probably 
unimportant to display the surfaces in the workspace with perfect fit. 
They’ll still likely render well. To enhance the rendering quality, you 
can adjust the Tessellation options of the blended surface shape node. 

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.) 

Tip To set your own anchor point for the adjoining surfaces, turn off 
Auto Closed Rail Anchor when you use the Fillet Blend tool. 
Display the ffBlendSrf node in the Attribute Editor to edit the Left/
Right Anchor, Left/Right Start, or Left/Right End.

Left/Right Anchor sets an anchor position (in U) for the curve 
from which the blended shape was created. This is used with the 
Left/Right Start or Left/Right End to specify a range of curve 
length along which the blended surface joins the adjacent surfaces. 
Note that you also can use the Show Manipulator Tool to adjust 
this option. Be aware that twisting will still occur when you rotate 
the adjoining surfaces.

Left Anchor = 0

Left Start = 0.6

Left End = 0.8
NURBS Modeling 

96



3 | Creating NURBS surfaces

Reference > Edit NURBS > Surface Fillet > Fillet Blend Tool
Tool Behavior

If you turn off Exit On Completion, Maya remains focused on the 
Fillet Blend tool after each usage. Turn off Exit On Completion if you 
want to use the tool repeatedly.
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4 Editing NURBS

How do I? Create and edit models

Reshape NURBS curves and surfaces

Reshape a curve or surface manually

To move CVs on a curve or surface

1 Choose the Move tool.

2 Press the right mouse button on the curve or surface and choose 
Control Vertex.

3 Select the CVs you want to edit and use the manipulator to move 
them.

Tip With a CV selected you can press the up and down keys to select 
the next/previous CV in the row. On a surface, press the left and 
right keys to select the next/previous CV in the column.

Note Avoid tweaks (moving CVs) on objects with history. If you 
tweak an object with history, the tweak is applied to a specific 
component ID. Subsequent changes to the object’s history can 
cause the component IDs to change, altering the effect of the 
tweak.

For example, if you revolve a curve to create a surface, then 
tweak CV number 3 on the surface, the tweak will always apply 
to CV number 3. If you later change the revolve node attributes 
to reduce the number of segments on the surface, the CV that 
you tweaked will now have a new number, and the tweak will 
no longer be applied to it. The tweak will be applied to the CV 
that is now number 3, which may be in a different location on 
the surface.
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To reshape a curve with the Curve Editing tool

1 Select Edit Curves > Curve Editing Tool. 

2 Click the curve.

3 Do any of the following:

• Drag the parameter position handle to move the manipulator 
along the curve.

• Drag the point position handle to move this point. The curve will 
reshape so the curve passes through the point as you move it.

• Drag the tangent direction handle to change the direction of the 
curve at this point.

• Drag the tangent scale handle to change the “speed” of the curve 
at this point.

• Click a dashed line to align the tangent at this point with one of 
the axes.

To reshape a surface with the Surface Editing tool

1 Select Edit NURBS > Surface Editing > Surface Editing Tool.

2 Click the surface.

Parameter Position

Point Position

Tangent Scale

Tangent Direction
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3 Do any of the following:

• Drag the parameter position handle to move the manipulator 
across the surface.

• Drag the point position handle to move this point. The surface 
will reshape so the surface touches the point as you move it.

• Click the tangent direction toggle (the double circle) to switch 
between editing the U, V, and Normal tangent.

• Drag the tangent direction handle (the box) to change the tangent 
of the surface at this point. 

• Drag the tangent scale handle to change the “speed” of the 
tangent at this point.

• Click a dashed line to align the tangent at this point with one of 
the axes.

To reshape a curve or surface with the Soft Modification tool

See Use the Soft Modification Tool in the Character Setup book.

Tips The Surface Editing Tool deforms a region within two spans of 
the manipulator. Deformation decreases with distance from the 
tool position.

You can use Snap to curve to snap the manipulator to an 
isoparm, or Snap to grid to snap to a patch corner. The snapping 
occurs to the isoparms or patch corners that appear when you 
display the object with Display > NURBS Smoothness > 
Rough—not the isoparms or patch corners that appear only with 
finer Smoothness settings. 

Parameter position

Point position

Tangent direction toggle

Tangent direction handle

Tangent scale manipulator

Tangent world axis selector
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Related topics

� ”Smooth a curve” on page 105

� ”Extend a surface” on page 108

� ”Push or pull a surface with the Sculpt Surfaces tool” on page 198

� Use the Soft Modification Tool

� ”Display > NURBS Components > Custom” on page 121

� ”Edit Curves > Curve Editing Tool” on page 140

� ”Soft Modification tool” on page 120

� Deform > Soft Modification 

Align a curve with a curve or surface

Make a curve tangent or curvature continuous with a surface

1 Select the surface and then the curve.

2 Select Edit Curves > Project Tangent > ❐.

3 Set Construction to Tangent or Curvature.

4 Click Project.

Select the project tangent node and click the Show Manipulator tool to 
manipulate curvature scale, tangent scale, or tangent rotation.

To make a curve tangent or curvature continuous with a 
curve intersection

1 Choose Edit Curves > Project tangent > ❐.

2 Click the curve or surface edge you want to modify, near the end 
which intersects the surface.

3 Click two intersecting curves that define a plane.
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To make a curve tangent or curvature continuous with 
another curve

1 Make sure the endpoint of the curve you want to make tangent 
intersects the curves that define the plane.

2 Select the curve you want to reshape first, then select the other curves.

The projected tangent is based on the key curve (the curve you select 
last, highlighted in green). 

3 Select Edit Curves > Project Tangent > ❐.

4 Set Construction to Tangent or Curvature.

5 Click Project.

Edit a project tangent action

Select the project tangent node and click the Show Manipulator tool to 
manipulate curvature scale, tangent scale, or tangent rotation.

To align the ends of two curves

1 Select the points on the curves (or isoparms) where you want to align 
the curves.

2 Select Edit Curves > Align Curves.

Tip When construction history is on, you can select the align node 
and use the Show Manipulator tool to edit the tangent scale and 
curve points.

Intersection point
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What if...?

I can’t project tangents at both ends of a curve?
The project tangent action “takes over” a few CVs at the end of the curve 
to maintain continuity. If there aren’t enough interior CVs to avoid 
overlap, you can’t use project tangent at both ends. Try inserting edit 
points to increase the number of CVs on the curve.

Related topics

� ”Continuity” on page 20

� ”Align surface edges” on page 104

� ”Join two curves or surfaces together (attach)” on page 110

� ”Edit Curves > Align Curves” on page 131

� ”Edit Curves > Intersect Curves” on page 134

� ”Edit Curves > Project Tangent” on page 141

Align surface edges

To align surfaces

1 Select an edge on the first surface.

2 Shift-select an isoparm on the other surface. You can align the edge of 
the first surface to any isoparm on the second surface.

3 Select Edit NURBS > Align Surfaces.

Limitations

• You cannot align edges that are closed or periodic. 

• You cannot align a surface to itself.

• Exact tangency or curvature continuity cannot be guaranteed if 
surfaces are rational.

• You cannot align to a trimmed edge. Align Surfaces uses the original 
surface edge, not its trimmed shape.

Related topics

� ”Align a curve with a curve or surface” on page 102

� ”Join two curves or surfaces together (attach)” on page 110

� ”Edit NURBS > Align Surfaces” on page 153
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Smooth a curve

The Smooth Curve action smooths out sharp changes in direction in a 
curve. This can be especially useful for curves created with the Pencil 
Curve tool and curves created from scan or translated data.

You cannot smooth a closed curve, surface isoparm, or curve-on-surface. 
Smooth Curves doesn’t change the number of CVs.

To smooth a curve or a selection of CVs

1 Select the curve, or select only the CVs you want to smooth.

2 Select Edit Curves > Smooth Curve.

To control the amount of smoothing, choose Edit Curves > Smooth 
Curve > � and set the Smoothness option. Lower values do less 
smoothing. The default value is 10.

Related topics

� ”Smooth a surface with the Sculpt Surfaces tool” on page 198

� ”Display > NURBS Smoothness” on page 121

� ”Straighten, smooth, curl or bend a curve” on page 106

� ”Edit Curves > Smooth Curve” on page 139

Lock or unlock the length of a curve

You can lock the length of a curve so that it maintains a constant hull 
length, even when you edit the curve (for example, by moving a CV).

To lock/unlock the length of a curve

1 Select the curve (or CVs).

2 Press and hold down the l (lower case L) key.

3 Modify the curve, and it will maintain a constant hull length.

4 To unlock the length, release the l (lower case L) key.

Note You can also lock/unlock the length of a curve by selecting the 
curve (or CVs), and selecting Edit Curves > Modify Curves > 
Lock Length or Edit Curves > Modify Curves > Unlock Length, 
but be careful you don’t forget to unlock the length. Using the 
hotkey is better, because you’re not likely to forget to unlock the 
length.
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Related topics

� ”Edit Curves > Modify Curves > Lock Length” on page 142

� ”Edit Curves > Modify Curves > Unlock Length” on page 143

Straighten, smooth, curl or bend a curve

Related topics

� ”Edit Curves > Modify Curves > Straighten” on page 143

Note When you first lock the length of a curve, a Lock Length 
attribute is added to the curveShape node. You can thereafter 
lock/unlock the length of the curve by turning on/off the Lock 
Length attribute.

To... Do this

Straighten a curve. Select the curve (or CVs) and choose Edit 
Curves > Modify Curves > Straighten.

Smooth a curve. Select the curve (or CVs) and choose Edit 
Curves > Modify Curves > Smooth.

Curl a curve. Select the curve (or CVs) and choose Edit 
Curves > Modify Curves > Curl.

Bend a curve. Select the curve (or CVs) and choose Edit 
Curves > Modify Curves > Bend.

Reduce or exaggerate a 
curve’s curvature.

Select the curve (or CVs) and choose Edit 
Curves > Modify Curves > Scale 
Curvature.

Tip Because Straighten, Smooth, Bend, and Scale Curvature are 
actions that you apply to curves, you cannot interactively adjust 
their effect as you would with a tool. However, you can set the 
scaling of the tool very low (for example, set Straightness to 0.1) 
and repeatedly apply the action until the curve has the desired 
shape.
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� ”Edit Curves > Modify Curves > Smooth” on page 144

� ”Edit Curves > Modify Curves > Curl” on page 145

� ”Edit Curves > Modify Curves > Bend” on page 145

� ”Edit Curves > Modify Curves > Scale Curvature” on page 146

Extend a curve

Add CVs or edit points to the end of a curve

1 Select the curve to add CVs, or select the last edit point to add edit 
points.

2 Select Edit Curves > Add Points Tool. 

3 Click in the view to add new CVs or edit points.

4 Press.

Extend a curve or curve-on-surface a certain distance

1 Select the curve.

2 Choose Edit Curves > Extend > Extend Curve > � or Edit Curves > 
Extend > Extend Curve On Surface > �.

3 Click Distance (or Parametric Distance for a curve-on-surface) and 
enter the distance you want to extend the curve. You can interactively 
change the distance in the channel box or attribute editor after you 
extend.

For curves-on-surface the Parametric Distance sets a fraction of the 
surface length in the direction the curve runs. For instance, a value of 
0.5 extends the curve length by roughly half the length of the surface 
in the direction the curve runs.

4 Do one of the following:

• Click Linear to extend the curve in a straight line.

• Click Circular to extend the curve in an arc.

• Click Extrapolate to maintain tangent continuity with the current 
shape of the curve.

5 Set Extend Curve At to choose which end (or Both ends) to extend 
from.

Click to add 
a new CV.
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6 To make the extension part of the current curve, turn on Join to 
Original. Turn this option off to make the extension a new curve.

7 Click Extend.

Extend one end of a curve or curve-on-surface out to exact 
coordinates

1 Select the curve.

2 Choose Edit Curves > Extend > Extend Curve > � or Edit Curves > 
Extend > Extend Curve On Surface > �.

3 Click Point (or UV Point for a curve-on-surface).

4 Set Extend Curve At to choose which end to extend from.

5 To make the extension part of the current curve, turn on Join to 
Original. Turn this option off to make the extension a new curve.

6 Click Extend.

Related topics

� ”Extend a surface” on page 108

� ”Edit Curves > Extend > Extend Curve” on page 123

Extend a surface

Extend a surface a certain distance

1 Select the surface.

2 Choose Edit Curves > Extend > Extend Surfaces > �.

3 Enter the distance you want to extend the curve. You can change the 
distance interactively in the attribute editor after you extend.

4 Do one of the following:

• Click Tangent to add new isoparms as you extend.

• Click Extrapolate to extend the shape without adding isoparms.

5 Choose which edge(s) you want to extend from.

• Set Extend Side to Start, End, or Both.

• Set Extend Direction to U, V, or Both.

Tip When Keep Original is on in the Extend Curve option box, Maya 
will create an extend node on the curve. You can select the 
extend node in the channel box or attribute editor to tweak the 
extend operation, including distance, interactively.
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You can change the side controls interactively in the channel box or 
attribute editor after you extend.

6 Turn off Join to Original.

7 Click Extend.

Notes

• You cannot extend a trimmed surface.

Related topics

� ”Extend a curve” on page 107

� ”Edit NURBS > Extend Surfaces” on page 148

Select curve CVs: first, last or all

Related topics

� ”Edit Curves > Selection > Select Curve CVs” on page 147

� ”Edit Curves > Selection > Select First CV on Curve” on page 147

� ”Edit Curves > Selection > Select Last CV on Curve” on page 147

To... Do this

Select all CVs on a curve. Select the curve and choose Edit Curves 
> Selection > Select Curve CVs (or press 
Ctrl + the right mouse button and choose 
To CVs).

Select the first CV on a 
curve.

Select the curve and choose Edit Curves 
> Selection > Select First CV on Curve (or 
press Ctrl + the right mouse button and 
choose To First CV).

Select the last CV on a 
curve.

Select the curve and choose Edit Curves 
> Selection > Select Last CV on Curve (or 
press Ctrl + the right mouse button and 
choose To Last CV).
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Edit NURBS curves and surfaces

Join two curves or surfaces together (attach)

Related topics

� ”Align surface edges” on page 104

� ”Split a curve or surface (detach)” on page 111

� ”Edit Curves > Attach Curves” on page 128

� ”Edit NURBS > Attach Surfaces” on page 150

To... Do this

Join two curves at the ends 
that are closest.

Select the curves and choose Edit Curves 
> Attach Curves.

Join two surfaces at the 
edges that are closest.

Select the surfaces.

• To move the surfaces together, 
choose Edit NURBS > Attach 
Surfaces.

• To fill the distance between the 
surfaces with new surface area, 
choose Edit NURBS > Attach 
Without Moving.

Join two curves at specific 
points.

Select a curve point on each curve where 
you want them to join and choose Edit 
Curves > Attach Curves.

Join two surfaces at specific 
isoparms.

Select an isoparm on each surface where 
you want them to join and choose Edit 
NURBS > Attach Surfaces.
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Split a curve or surface (detach)

Related topics

� ”Join two curves or surfaces together (attach)” on page 110

� ”Edit Curves > Detach Curves” on page 130

� ”Edit NURBS > Detach Surfaces” on page 151

Insert additional edit points/isoparms in a 
curve or surface to add more CVs

To... Do this

Split a curve at some point. Select the curve point at which you want 
to split the curve and choose Edit Curves 
> Detach Curves.

When construction history is on, you can 
select the detach node and use the Show 
Manipulator tool to edit the detach point.

Split a surface at an 
isoparm.

Select the isoparm at which you want to 
split the surface and choose Edit NURBS > 
Detach Surfaces.

You can select multiple isoparms to split 
the surface into multiple parts.

Split a curve wherever it 
crosses another curve in a 
view.

Select the curves in the view where they 
overlap, then choose Edit Curves > Cut 
Curve.

You cannot split a curve with an isoparm 
or curve-on-surface. Use Edit Curves > 
Duplicate Surface Curves to create an 
new curve from the isoparm or curve-on-
surface you want to use.

To... Do this

Insert an edit point in a 
curve to add more CVs.

Select the curve point at which you want 
to insert the edit point and choose Edit 
Curves > Insert Knot.
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When the Keep Original option is on in the option box (Edit Curves > 
Insert Knot > ❐ or Edit NURBS > Insert Isoparms > ❐) you can select the 
Show Manipulator tool to reposition the new edit point or isoparm after 
you insert it.

Related topics

� ”Edit Curves > Insert Knot” on page 135

� ”Edit NURBS > Insert Isoparms” on page 161

Create an offset copy of a curve or surface

Creates a copy of a curve or surface that is offset from the original (every 
point on the copy is a specific distance from the corresponding point on 
the original).

Create an offset copy of a curve

1 Do one of the following:

• Select a curve or isoparm, then choose Edit Curves > Offset > 
Offset Curve.

• Select a curve-on-surface, then choose Edit Curves > Offset > 
Offset Curve On Surface.

2 An offset curve is created at a default offset distance of 1.0. 

3 In the toolbox, click the Show Manipulator tool and use the 
manipulator to change the offset distance.

Insert an isoparm in a 
surface to add more CVs.

Select the isoparm at which you want to 
insert a new patch isoparm and choose 
Edit NURBS > Insert Isoparms.

You can select multiple isoparms to 
insert at once.

To... Do this

Duplicate Offset
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Create an offset copy of a surface

1 Select the surface.

2 Select Edit NURBS > Offset Surfaces > �.

3 Do one of the following:

• To preserve surface curvature, set Method to Surface Fix.

• To preserve CV layout, set Method to CV Fix.

4 Enter a distance to offset. You can change the distance interactively in 
the channel box or attribute editor after you offset.

5 Click Extend.

Related topics

� ”Edit Curves > Offset > Offset Curve, Offset Curve on Surface” on 
page 126

� ”Edit NURBS > Offset Surfaces” on page 149

Reverse the direction of a curve or surface 
normals

To... Do this

Reverse the direction of a 
curve.

Select the curve and choose Edit Curves > 
Reverse Curve Direction.

Reverse the direction(s) 
and normals of a surface.

Select the surface and choose Edit NURBS 
> Reverse Surface Direction > ❐ and 
choose the surface direction to reverse, or 
swap to swap U and V.
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Related topics

� ”Normals” on page 17

� ”Curve components” on page 21

� ”Edit Curves > Reverse Curve Direction” on page 136

� ”Edit NURBS > Reverse Surface Direction” on page 163

Reduce the complexity of a curve or surface

Reduce the complexity of a curve

1 Select the curve.

2 Choose Edit Curves > Rebuild Curve > ❐.

3 Set Rebuild Type to Reduce.

4 To use the global tolerance set in the preferences, click Global. To set a 
tolerance manually, click Local and enter a tolerance value.

The tolerance controls how close points on the reduced curve must be 
to the original. Higher numbers allow more reduction by loosening 
how closely the reduced curve must match the original.

5 Click Rebuild.

Reduce the complexity of a surface

1 Select the curve.

2 Choose Edit NURBS > Rebuild Surfaces > ❐.

3 Set Rebuild Type to Reduce.

4 To use the global tolerance set in the preferences, click Global. To set a 
tolerance manually, click Local and enter a tolerance value.

The tolerance controls how close points on the reduced curve must be 
to the original. Higher numbers allow more reduction by loosening 
how closely the reduced curve must match the original.

5 Click Rebuild.

Related topics

� ”Control multi-knots and CV hardness” on page 115

� ”Automatically add spans to areas of a curve with high curvature” on 
page 117

� ”Edit Curves > Rebuild Curve” on page 136

� ”Edit NURBS > Rebuild Surfaces” on page 164
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Control multi-knots and CV hardness

Multi-knots are multiple edit points at the same location that create a 
sharp bend or corner in a curve. For example, the Create > Text tool 
creates curves with multi-knots to represent letters with sharp corners.

To set the hardness of a CV

“Hardening” a CV creates multiknots that make the curve take a sharp 
turn at the CV.

1 Select the CVs.

You can only harden a CV if the previous and next CVs on the curve 
are not hardened.

2 Select Edit Curves > CV Hardness > �.

3 Do one of the following:

• Click Full to make this a hard CV, resulting in a sharp bend in the 
curve.

• Click Off to make this a normal CV, resulting in a normal (softer) 
bend of the curve.

4 If you turn on Keep Original, Maya will create a new curve with the 
hardness applied to the CV. In the dependency graph, you can see a 
node that takes the original curve, hardens the CV, and outputs a new 
curve.

You can select this node and turn the hardness on or off using the 
Multiplicity slider in the attribute editor.

If you turn off Keep Original, the operation applies to the CV on the 
original curve and is not editable.

5 Click Harden.

To add or remove a tangent break at an isoparm

A tangent break inserts multi-knots along an isoparm to break tangent 
continuity. This lets you make a sharp bend in the surface along the 
isoparm. The shape of the surface doesn’t immediately change.

To... Do this

Break tangency along an 
isoparm.

Select the isoparm and choose Edit 
Surfaces > Surface Editing > Break 
Tangent.
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To remove multi-knots from a curve

1 Select the curve.

2 Choose Edit Curves > Rebuild Curve > ❐.

3 Set Rebuild Type to No Multiple Knots.

4 Click Rebuild.

To remove multi-knots from a surface

1 Select the curve.

2 Choose Edit NURBS > Rebuild Curve > ❐.

3 Set Rebuild Type to No Multiple Knots.

4 Click Rebuild.

Related topics

� ”Edit Curves > CV Hardness” on page 139

� ”Edit NURBS > Rebuild Surfaces” on page 164

� ”Edit NURBS > Surface Editing > Surface Editing Tool, Break 
Tangent, Smooth Tangent” on page 168

Break tangency along 
isoparms in both 
directions.

Select a surface point and choose Edit 
Surfaces > Surface Editing > Break 
Tangent.

Break an arbitrary tangent. Use the Surface Editing tool to select the 
tangent direction, then choose Edit 
Surfaces > Surface Editing > Break 
Tangent.

� ”Reshape a curve or surface 
manually” on page 99

Smooth a broken a tangent. Select the isoparm and choose Edit 
Surfaces > Surface Editing > Smooth 
Tangent.

Note Edit Surfaces > Surface Editing > Break Tangent sometimes 
doesn't work for U direction isoparm of closed surface. 

If this happens, use Edit NURBS > Move Seam first.

To... Do this
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Automatically add spans to areas of a curve 
with high curvature

This action inserts more edit points/CVs in areas of high curvature. This 
gives you finer control for reshaping the curve.

1 Select the curve.

2 Choose Edit Curves > Rebuild Curve > ❐.

3 Set Rebuild Type to Curvature.

4 Click Rebuild.

Related topics

� ”Edit Curves > Rebuild Curve” on page 136

Convert a curve or surface to uniform 
parameterization

Convert a curve to uniform parameterization

1 Select the curve.

2 Choose Edit Curves > Rebuild Curve > ❐.

3 Set Rebuild Type to Uniform.

4 Click Rebuild.

Convert a surface to uniform parameterization

1 Select the surface.

2 Choose Edit NURBS > Rebuild Surfaces > ❐.

3 Set Rebuild Type to Uniform.

4 Click Rebuild.

Related topics

� ”Parameters and parameterization” on page 14

� ”Edit Curves > Rebuild Curve” on page 136

� ”Edit NURBS > Rebuild Surfaces” on page 164

Convert a surface to non-rational geometry

Convert a surface to non-rational geometry

1 Select the surface.

2 Choose Edit NURBS > Rebuild Surfaces > ❐.
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3 Set Rebuild Type to Non-Rational.

4 Click Rebuild.

Related topics

� ”Edit Curves > Rebuild Curve” on page 136

� ”Edit NURBS > Rebuild Surfaces” on page 164

Change a curve or surface’s degree or number 
of spans/patches

Change a curve’s degree or overall number of spans

1 Select the surface.

2 Choose Edit NURBS > Rebuild Curve > ❐.

3 Set Rebuild Type to Uniform.

4 Set the Number of Spans and Degree options.

Change a surface’s degree or overall number of patches

1 Select the surface.

2 Choose Edit NURBS > Rebuild Surfaces > ❐.

3 Set Rebuild Type to Uniform.

4 Set the Number of Spans U, Number of Spans V, Degree U, and 
Degree V options.

Divide surface patches by inserting isoparms

� ”Insert additional edit points/isoparms in a curve or surface to add 
more CVs” on page 111

Related topics

� ”Degree” on page 14

� ”Curve components” on page 21

� ”Surface components: CVs, isoparms, and patches” on page 26

� ”Edit Curves > Rebuild Curve” on page 136

� ”Edit NURBS > Rebuild Surfaces” on page 164
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Make a curve or surface open or closed

Related topics

� ”Periodic, closed, and open” on page 17

� ”Edit Curves > Detach Curves” on page 130

� ”Edit Curves > Open/Close Curves” on page 132

� ”Edit Curves > Move Seam” on page 133

To... Do this

Join the ends of a curve 
together to make a periodic 
(closed) curve.

Select an open curve and choose Edit 
Curves > Open/Close Curves.

Make a periodic (closed) 
curve non-periodic.

Select the start CV (the CV that looks like 
a hollow box) and choose Edit Curves > 
Detach Curves.

Separate the ends of a 
periodic (closed) curve.

Select a closed curve and choose Edit 
Curves > Open/Close Curves. Maya 
opens the curve and reshapes it so its 
endpoints are separated.

Join edges of a surface to 
make a periodic (closed) 
surface.

Select an open surface and choose Edit 
NURBS > Open/Close Surfaces > �.

Click U, V, or Both to choose which edges 
to join.

Move the seam of a closed 
(periodic) curve.

Select an curve point on the curve and 
choose Edit Curves > Move Seam. The 
seam will move to the edit point nearest 
your selected point.

Move the seam of a closed 
(periodic) surface.

Select an isoparm on the surface and 
choose Edit NURBS > Move Seam. The 
seam will move to the patch isoparm 
nearest your selected isoparm.

Change the direction in 
which a surface is periodic.

Select the surface and choose Edit 
NURBS > Open/Close Surfaces > �.

Click U, V, or Both to choose which edges 
are periodic.
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� ”Edit NURBS > Detach Surfaces” on page 151

� ”Edit NURBS > Open/Close Surfaces” on page 159

� ”Edit NURBS > Move Seam” on page 161

Match the topology of one curve to another

1 Select the curve you want to rebuild and then the curve it should 
match.

2 Choose Edit Curves > Rebuild Curve > ❐.

3 Set Rebuild Type to Match Knots.

4 Click Rebuild.

Related topics

”Edit Curves > Rebuild Curve” on page 136

Reference Tools

Toolbox

Soft Modification tool

The Soft Modification tool lets you push and pull geometry as a sculptor 
would push and pull on a piece of clay.

By default, the amount of deformation is greatest at the center of the 
push/pull, and gradually falls off further away from the centre. However, 
you can control the falloff of the deformation to create various types of 
effects.
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The Soft Modification tool is located in the Toolbox. The corresponding 
action is Deform > Soft Modification.

You can use the Soft Modification tool on NURBS surfaces, polygonal 
surfaces, subdivision surfaces, curves, particles or any object with 
components.

Related topics

� Deform > Soft Modification

� Use the Soft Modification Tool

Menus

Display

Display > NURBS Components > Custom

You can specify the scope of which NURBS objects display their 
components using the Scope pull-down menu. The scope can be active 
objects, all objects, new curves, or new surfaces.

Display > NURBS Smoothness

Hull

Shows hulls only. 

Soft Modification Tool
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Rough, Medium, Fine

Displays objects at preset levels of quality. Selecting Medium or Fine 
slows the display and interactivity, but improves image precision. 

Custom

Lets you customize the display quality.

In the following figure, an object’s smoothness is changed from a default 
medium level of quality to a custom hull quality level.

Setting custom NURBS smoothness options

Select Display > NURBS Smoothness > Custom > �.

Geometry

To display all geometry, select Full. To display hulls only, select Hull.

Surface Div per Span U

Surface Div per Span V

Together, these settings subdivide the NURBS patches for display 
purposes to give it the appearance of a finer mesh. The range is from 0 to 
32. 

Curve Div per Span

Specifies the number of curve divisions per span to give the curves a 
rougher or smoother appearance. The range is from 1 to 128.

Tip The hotkeys for these settings are: 1 (Rough), 2 (Medium), and 3 
(Fine). 
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Display Render Tessellation Geometry

Turn on to see the pattern of tessellation that the renderer will use for the 
surface. You must be in shade mode to see this pattern.

Surface Div per Span

Specifies the number of surface divisions per span in shaded mode. The 
range is from 0 to 32.

Hull Simplification U

Hull Simplification V

If you have the Geometry set to Hull, you can use these settings to control 
the number of hull divisions displayed. 

Modeling menu set

Edit Curves

Edit Curves > Extend > Extend Curve

Related topics

� ”Extend a curve” on page 107

� ”Edit Curves > Add Points Tool” on page 126

Edit Curves > Extend > Extend Curve > �

Extend Method

Distance lets you enter a value for the length of the Extension Type.

Point extends to a world space position you specify in Point To 
Extend To.

Extension Type

Linear extends the curve in a straight line:

Circular extends the curve as an arc:
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Extrapolate maintains the tangent of the selected curve.

Extend Curve At

Start extends the curve from its start point.

End extends the curve from its end point. 

Both extends the curve at both ends.

Join to Original

Attaches the curve extension to the original curve. If off, the input 
curve and the curve extension are independent objects. You can 
transform the extension separately. 

Remove Multiple 

Knots

Removes the multiple knots that Maya creates when Join To Original 
is turned on. 

End methodConstruction curve

end

start

Start method

Join to Original on Join to Original off
Original curve
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Keep Original

Keeps the original curve after the extension is created. If both Keep 
Original and Join to Original are off, the extension curve replaces the 
original curve.

Input Curve

Input Curve information is read-only. It gives you access to the input 
curve you extended. Click the arrow button to select the curve and 
open that section of the Attribute Editor.

Input Point

This is the same as Point To Extend To in the options window.

Edit Curves > Extend > Extend Curve on 
Surface

Related topics

� ”Extend a curve” on page 107

� ”Edit Curves > Extend > Extend Curve” on page 123

Extend Method

Specifies how to extend the curve in the surface’s UV space:

Parametric 

Distance  Linear extends the curve in a straight line.

Circular extends the curve in an arc direction.

Extrapolate extends the curve by deducing the 
direction and tangency of the curve.

The Parametric Distance value specifies the length 
of the extension. The value specifies a percentage of 
the surface length in the direction the curve runs. 
For instance, a value of 0.5 extends the curve length 
by roughly half the length of the surface in the 
direction the curve runs.

UV Point  Lets you specify an extend position in the UV Point 
To Extend To entry box. To use actual UV values 
rather than estimates, select Create > Measure Tools 
> Parameter Tool, drag on the surface, and release 
the mouse button to display the UV coordinates at 
the pointer.
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Edit Curves > Add Points Tool

Lets you add points to the end of the selected curve.

Related topics

� ”Extend a curve” on page 107

� ”Edit Curves > Extend > Extend Curve” on page 123

Edit Curves > Offset > Offset Curve, Offset 
Curve on Surface

Creates an copy of the selection, offset from the original by a certain 
distance.

Related topics

� ”Create an offset copy of a curve or surface” on page 112

Edit Curves > Offset > Offset Curve/Curve on Surface 
> �

Normal Direction

The Geometry Average and Active View options select the method 
Maya uses to position the offset. It’s easiest to learn how each works 
by simply creating the offset and adjusting its positioning with the 
Show Manipulator Tool.

Geometry Average is the more intuitive method. For a planar curve, 
imagine you are standing at the start point of the curve looking in the 
direction of the initial curve direction. Geometry Average puts the 
offset curve to the left of the curve. It scales down the curve where it 
arcs left, and scales up the curve where it arcs right. 

For a 3D curve, Geometry Average takes into account the normals of 
the average plane in which the points of the curve are located. 

For both planar and 3D curves, Active View takes into account the 
camera viewing direction. 

Offset Distance

Specifies the distance between the original curve and the offset curve. 

Connect Breaks

If you create an offset curve from a curve that has multiple knots or 
CVs with multiplicity greater than 1, Maya might create the offset 
curve with sharp corners or it might break the curve into multiple 
discontinuous curves. 
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Circular creates a continuous curve by inserting circular arcs at the 
break points.

Linear creates a continuous curve by connecting the break points with 
a straight line.

Off leaves the offset curve broken into multiple discontinuous curves. 

If you select Circular or Linear, Maya inserts multiple knots on the 
curve to preserve the curve shape. If you adjust the curve near the 
multiple knot locations, tangent breaks might occur on the curve.

Loop Cutting

Sets whether any loops in a planar curve are trimmed. Looping occurs 
if the distance from the original curve exceeds the minimum bend 
radius (curvature) of the curve being offset. For example, if a curve 
has a 20 cm radius and you try to offset more than 20 cm inward, the 
offset curve crosses over itself and creates a loop. Use Circular to 
insert arcs at trimmed loops.

Cutting Radius

When Loop Cutting is on, the Cutting Radius value is used. If the 
Cutting Radius value is greater than 0, instead of getting a sharp 
corner at the point where the loop has been cut, you get an arc of the 
specified radius.

Loop Cutting onLoop Cutting off

Cutting Radius = 0 Cutting Radius = 0.4
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Max Subdivision 

Density

Specifies the maximum number of times the offset geometry may be 
subdivided within the current tolerance. The default is 5, which 
means any single span on the curve may be subdivided up to 5 times.

Use Tolerance

If you select Global tolerance, Maya uses the Positional value you set 
in the Settings part of the Preferences window.

If you select Local tolerance, you can directly enter a new value that 
overrides the Positional tolerance value of the Preferences window.

Tolerance

Specifies the accuracy in which the offset curve is placed at a specified 
distance. The default is accurate to within 0.05 units. The default unit 
is in centimeters. Offsetting is an iterative process that continues until 
the current offset comes within the tolerance value or the maximum 
subdivision limit.

Curve Range

Complete creates the offset curve for the entire original curve.

Partial lets you create an offset curve for only part of the original 
curve. It creates a subCurve node you can edit to alter the offset 
distance after creation. 

Input Curve

Lists the history node of the offset curve or isoparm. Click the arrow 
button next to the Input Curve name to edit the length of the curve.

Edit Curves > Attach Curves

Joins curves together at their endpoints to form a new curve.

Related topics

� ”Join two curves or surfaces together (attach)” on page 110

Edit Curves > Attach Curves > �

Attach Method

Connect joins the curves with minimal curvature smoothing at the join 
point.

Blend smooths the curvature at the join point based on the Blend Bias 
value.
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Multiple Knots

Keep creates multiple knots at the join point. This lets you break the 
curvature continuity at the join point.

Remove discards multiple knots at the join point. This creates smooth 
curvature at the join point.

Blend Bias

Tunes the continuity at the join point. 

Insert Knot

This option is available only when you use the Blend option. In 
conjunction with the Insert Parameter value, Insert Knot lets you 
match the blend region to the original curves more closely. 

This option has significant effect only if the original curves are not 
aligned precisely (they approach each other at an angle) and have 
lengthy distances between the last two knots on each original curve 
near the join point. 

Insert Knot creates two extra knots near the join point. Each is within 
one span of the points being joined from the original curves. You can 
adjust the positioning of the extra knots with the Insert Parameter 
value. 

Insert Parameter

Adjusts the positioning of the knots added when you turn on Insert 
Knot. The closer the value is to 0 (without reaching 0), the closer the 
blend shape resembles the curvature of the original curves at the join 
point. This occurs because the added knots are inserted closer to the 
end knots nearest the blend point. Valid values are from 0 to 1.

The following figures show the same blended curve resulting from 
two identical input curves. The top blended curve has Insert Knot 
turned off. The bottom blended curve has Insert Knot turned on with 
an Insert Parameter value of 0.3. The closer Insert Parameter is to 0, 
the closer the blended curve resembles the end shape of the original 
curves. 
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To adjust this option interactively, create the blended curve with 
Insert Knot turned on. Then select the curve, display the Channel Box, 
select attachCurve in the INPUTS section, and edit the Parameter 
option.

Keep Originals

Keeps the original curves after creating the attached curve. Do not 
turn this option off if construction history is on; the attached curve 
might deform oddly if you scale or otherwise modify it.

If you want to scale the attached curve without altering its basic 
shape, make sure construction history and Keep Original are both off, 
or both on.

Editing the resulting curve attributes

To view and edit the options of an attached curve, select the curve, 
display the Channel Box, and select attachCurve in the INPUTS section. 
The following option is the only one not available in the options window:

Reverse1 & 2

Attach Curves attaches the two ends of the curves that are closest. You 
can use these options to change which ends are attached. Turn the 
options on and off in various combinations until you get the desired 
result. 

Edit Curves > Detach Curves

Splits a curve into two new curves.

Related topics

� ”Split a curve or surface (detach)” on page 111

Insert Knot off

Insert Knot off
Insert Parameter = 0.3
NURBS Modeling 

130



4 | Editing NURBS

Reference > Edit Curves > Align Curves
Edit Curves > Detach Curves > �

Keep Original

Retains the original curve when you detach part of it. 

Edit Curves > Align Curves

Aligns the endpoints of curves.

Related topics

� ”Align a curve with a curve or surface” on page 102

Edit Curves > Align Curves > �

Attach

Joins the curves. If you turn this option on, turn Construction History 
off or the curve might deform oddly when you transform it.

Multiple Knots

Keep creates multiple knots at the attached region, which lets you 
break the curvature continuity there.

Remove deletes as many knots as possible without changing the shape 
of the attached region.

Continuity

Position causes the two points to meet exactly. 

Tangent causes the tangency at the two points to match.

Curvature causes the two points to meet with the same arch in 
curvature. When this option is selected, the curvature scale sliders are 
available.

End point of curves

curve 1

curve 2
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Modify Position

First moves the entire first curve to the second curve.

Second moves the entire second curve to the first curve.

Both moves both curves halfway.

Modify Boundary

First moves the selected point of the first curve to the second curve.

Second moves the selected point of the second curve to the first curve.

Both moves the selected points of both curves halfway.

Modify Tangent

First adjusts the tangent of the first curve selected.

Second adjusts the tangent of the second curve selected.

Tangent Scale

First and Second

First increases or decreases the tangent magnitude of the first curve 
selected.

Second increases or decreases the tangent magnitude of the second 
curve selected.

Curvature Scale

First and Second

First increases or decreases the curvature of the first curve selected.

Second increases or decreases the curvature of the second curve 
selected.

Keep Original

Retains the original curves and aligns copies of the curves.

Edit Curves > Open/Close Curves

Converts a curve between open and closed/periodic.

Related topics

� ”Periodic, closed, and open” on page 17

� ”Make a curve or surface open or closed” on page 119
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Edit Curves > Open/Close Curves > �

Shape

Ignore does not preserve the shape of the original curve.

Preserve adds or deletes control vertices as necessary to preserve the 
shape of the original curve. This is the default setting.

Blend tries to create continuity on the resulting curve. It uses the 
Blend Bias for the amount of smoothing. 

Blend Bias

Alters the amount of continuity for the resulting curve. Large values 
might distort the tangency of the original curve.

Insert Knot

Inserts a knot at the join point and lets you set a value for the Insert 
Parameter. This option is available only if you select Blend.

Insert Parameter

Sets the amount of influence the inserted knot has on the curve shape.

Keep Original

Retains the original curve after opening or closing the curve.

Edit Curves > Move Seam

Moves the join point of a closed/periodic curve to the selected edit point.

Related topics

� ”Make a curve or surface open or closed” on page 119

Edit Curves > Cut Curve

Splits curves wherever they cross a cutting curve in the view.

Related topics

� ”Split a curve or surface (detach)” on page 111

Edit Curves > Cut Curve > �

Cut

At All Intersections cuts curves at all intersecting points of selected 
curves. 

Using Last Curve cuts only the last curve selected. 
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Keep

Longest Segments deletes all but the longest piece of each cut curve.

All Curve Segments keeps all curves after the cut.

Segments with Curve Points keeps all curve segments that have curve 
points selected on them. If no curve points are selected for a curve, no 
segments are discarded.

Keep Original

Keeps the original curves and creates new curves from the cut. 

Edit Curves > Intersect Curves

Use Edit Curves > Intersect Curves to create curve point locators where 
two or more independent curves touch or cross one another in a view or 
direction. Intersect Curves is commonly used with Cut Curve, Detach 
Curve, and Snap to Point.

Related topics

� ”Align a curve with a curve or surface” on page 102

Edit Curves > Intersect Curves > �

Find Intersections

In 2D and 3D creates intersection points where the curves cross one 
another in the active view.

In 3D Only creates intersections only where curves actually touch one 
another.

Use Direction

Specifies which axis or view to use to create intersection points.

X, Y, and Z create intersections along the direction of the axis chosen.

Active View create intersections in the active camera view.

Free lets you specify the axis of intersection in the Direction boxes.

Intersect

All Curves creates intersections for all selected curves.

With Last Curve Only creates intersections for only the last curve 
selected. Turn this on to create intersections where several curves 
overlap one curve.
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Use Tolerance

Global uses the Positional Tolerance value in the Settings part of the 
Preferences window.

Local lets you enter a value to override the value in the Preferences 
window.

Edit Curves > Insert Knot

Inserts an edit point at the selected curve point.

Related topics

� ”Insert additional edit points/isoparms in a curve or surface to add 
more CVs” on page 111

Edit Curves > Insert Knot > �

Insert Location

At Selection inserts the knot exactly at the selected curve point.

Between Selections inserts the knot halfway between a pair of selected 
curve points.

Multiplicity

Set to inserts an absolute number of knots according to the 
Multiplicity value. For example, if Multiplicity is 3 and At Selection is 
on, three knots will be inserted at the point whether or not it has an 
existing knot. Multiple knots at any position lets you create a sharp 
corner there.

Increase by adds extra knots to the point according to the Multiplicity 
value.

If you turn on Between Selections and set Multiplicity higher than 1, 
Maya creates multiple knots at each knot, with even spacing between 
the positions.

Note Several NURBS menu items provide Use Tolerance as way to 
increase how precisely Maya creates a curve or surface. For 
example, you can create a revolved surface with a preset number 
of sections or you can enter a low Tolerance value to create more 
surface sections.
NURBS Modeling

135



4 | Editing NURBS 
Reference > Edit Curves > Reverse Curve Direction
Keep Original

Keeps the original curve in addition to creating the curve with new 
knots.

Edit Curves > Reverse Curve Direction

Reverses the direction of the selected curve(s).

Related topics

� ”Reverse the direction of a curve or surface normals” on page 113

Edit Curves > Reverse Curve Direction > �

Keep Original

Retains the original curve after the Reverse Curve operation. If you 
turn on Keep Original (and construction history is on), you can use 
the Show Manipulator Tool to click a manipulator to reverse the curve 
direction. 

Edit Curves > Rebuild Curve

Performs various operations to transform the selected curve.

Related topics

� ”Reduce the complexity of a curve or surface” on page 114

� ”Control multi-knots and CV hardness” on page 115

� ”Automatically add spans to areas of a curve with high curvature” on 
page 117

� ”Convert a curve or surface to uniform parameterization” on page 117

� ”Convert a surface to non-rational geometry” on page 117

� ”Change a curve or surface’s degree or number of spans/patches” on 
page 118

� ”Match the topology of one curve to another” on page 120

Tip You can drag a manipulator to reposition a new knot after you 
insert it. Select the Show Manipulator Tool and turn on Keep 
Original before using Insert Knot. 
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Edit Curves > Rebuild Curve > �

Rebuild Type

Uniform rebuilds a curve with uniform parameterization. With this 
option, you can change the Number of Spans and Degree of the curve. 

Reduce removes knots if their removal does not cause any remaining 
knots to move by a distance greater than the tolerance setting. A 
higher tolerance setting removes more knots. 

Match Knots rebuilds a curve by matching the curve degree, knot 
values, and number of spans of another curve. Before you rebuild the 
curve, select the curve to be rebuilt first and Shift-select the curve to 
be matched. The Keep options become available when you select 
Match Knots.

No Multiple Knots removes any extra knots created during the 
rebuild operation. The curve has the same curve degree as the 
original. The Keep options are not available when you select this 
option.

Curvature inserts more knots in the areas of higher curvature. The 
curve is the same degree as the original. The Keep options are not 
available when you select this option, however, the Use Tolerance 
options are displayed. 

End Conditions rebuilds the positioning of the curve’s end CVs and 
knots. If you select End Conditions, two extra options appear for the 
End Conditions: No Multiple knots and Multiple knots. 

With No Multiple Knots turned on, the rebuilt curve doesn’t pass 
through the end CVs. This makes the curve harder to control in some 
cases, but makes other operations easier. For example, it’s easier to 
create smooth joins between adjacent curves. (If you rebuild both 
curves with No Multiple knots, you can snap CVs together to get 
exact tangency across the boundary.)
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If you turn on Multiple Knots, the curve touches the end CVs, making 
it easier to control the curve boundaries and related tangency.

A curve rebuilt with End Conditions has the same degree as the 
original.

Parameter Range

0 to 1 sets the resulting curve’s parameter range from 0 to 1.

Keep matches the rebuilt curve’s parameter range to the original 
curve. 

0 to # spans creates integer knot values that make numerical input 
easier. If you are using the Uniform Rebuild Type, 0 to # spans always 
creates integer knot values. This is useful if you’ll be entering knot 
parameter values with curve options. For example, if you enter a knot 
value for the Detach Surfaces operation, it’s easier to type the number 
2 than a number like 0.362.

Keep

Turn on Ends, Tangents, CVs, or NumSpans if you want the rebuilt 
curve to have the original’s end points, tangents, CVs, or number of 
spans. NumSpans is available only with the Uniform option.

Number of Spans

Specifies the number of spans in the resulting curve. 

Degree

The higher the Degree, the smoother the curve. The default setting (3 
Cubic) works well for most curves. 

Number of Spans = 10
Number of Spans = 4
(default)

Cubic, degree 3 (default) Linear, degree 1
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Keep Original

Keeps the original curve and creates a new curve as the rebuilt curve. 
This is useful for comparing various curves with different options. 

Use Tolerance

If the Rebuild Type is Reduce or Curvature, the Use Tolerance options 
appear in the options window. These options let you rebuild the curve 
within a specified tolerance of the original curve. Global uses the 
tolerance setting from the Maya’s Preferences window. Local lets you 
enter a tolerance directly in the options window.

Input Curve

The Input Curve information is read-only. It gives you access to the 
history of the original curve you rebuilt. Click the arrow button to 
select the curve and open its section of the editor.

Match Curve

The Match Curve read-only information is available only if there is 
more than one curve and Match Knots was selected in the options 
window.

Edit Curves > Smooth Curve

Smooths out kinks in the selected curve(s). Select the command again to 
smooth more.

Related topics

� ”Smooth a curve” on page 105

Edit Curves > CV Hardness

Sets the multiplicity of the selected CVs.

Related topics

� ”Control multi-knots and CV hardness” on page 115

Edit Curves > CV Hardness > �

Multiplicity

By default, when you create a cubic curve, the end knots have a 
multiplicity factor of 3 and the arcs in between have a multiplicity 
factor of 1.
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Full changes the multiplicity of the interior CVs from 1 to 3. To change 
a multiplicity factor from 1 to 3, there must be at least two CVs on 
each side of the CV being modified that have a multiplicity factor of 1.

Off changes the multiplicity of the interior CVs from 3 to 1.

The following figure shows a text object before and after using CV 
Hardness > ❒  with Multiplicity turned off. The text loses its hard 
edges.

Keep Original

Keeps the original curve after you change the multiplicity setting.

hardenPointCurve node

If you turned on Keep Original when you adjusted CV hardness, you can 
use the Attribute Editor to edit the CV hardness any time later. See also 
hardenPointCurve.

Input Curve

The Input Curve information is read-only. It gives you access to the 
history of the curve you changed. Click the arrow button to select the 
curve and open its section of the editor.

Multiplicity

Enter a value in the Multiplicity box, or use the slider, to specify the 
number of knots you want to insert when adjusting the CVs. 

Edit Curves > Curve Editing Tool

Shows a manipulator on the curve you click that lets you change the 
position and direction at arbitrary points along the curve.

Related topics

� ”Reshape a curve or surface manually” on page 99
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Edit Curves > Project Tangent

Makes the end of a curve tangent or curvature continuous with another 
curve or surface.

Related topics

� ”Align a curve with a curve or surface” on page 102

Edit Curves > Project Tangent > �

Tangent modifies the curve by projecting its tangent vector where it 
intersects the surface onto the tangent plane of the surface. This means 
that only necessary modifications are made to the start or end of the curve 
where it intersects the surface. 

Curvature makes the curve tangent and the curvature continuous with the 
surface in the direction of the tangent vector. An extra manipulator is 
displayed on the curve to let you adjust the Curvature Scale value. (The 
Curvature Scale slider is also displayed in the options window when this 
option is selected).

Tangent Align Direction

The Tangent Align Direction options provide a convenient way to 
either:

• Reverse the direction of the curve’s tangent vector.

• Aligns the tangent vector with the U or V parameter directions of the 
intersecting surface or two curves.

U and V pick the tangent you want to use for the adjustment. U is the 
U direction of the surface, or it’s the second selected curve. V is the V 
direction of the surface, or it’s the third selected curve.

Normal is the normal vector of the tangent plane. Select the Normal 
option to make a curve normal to or perpendicular to a surface or two 
curves. When selected, the curve is no longer tangent to the surface 
since it is perpendicular to the surface.

When you select Normal, it becomes the mode you are working in for 
the current curve modification. To return to the general project 
tangent operation, select either the U or V tangent align direction.

Reverse Direction

Turn Reverse Direction on or off to change the direction of the tangent 
vector so that it points in the opposite direction. Reverse Direction 
simply multiplies the current tangent scale factor by -1.0. 
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Tangent Scale

The Tangent Scale slider displays the current tangent scale factor. 
Scaling the tangent adjusts the length of the tangent vector without 
changing its direction. A negative scale factor reverses the direction of 
the tangent vector. 

Tangent Rotation

The Tangent Rotation slider displays the current tangent rotation 
angle. Adjusting the rotation rotates the tangent vector on the tangent 
plane defined by the surface intersection. 

Tangent rotation is not available when the Tangent Align Direction is 
Normal. If you change the Tangent Rotation value, the curve is no 
longer tangent to the surface or two other curves.

Curvature Scale

Project tangent works by selecting a curve to modify then by selecting 
a surface or two other curves that intersect with either of its end 
points. The curve is modified by projecting its tangent vector where it 
intersects the surface onto the tangent plane of the surface. 

If Curvature is selected as the construction type, the curve is made 
tangent and the curvature is made continuous with the surface or 
curves in the direction in which the tangent vector is going.

Adjusting the Curvature Scale value modifies the curve in such a way 
that the tangent or curvature doesn’t change at the curve or surface 
intersection point. For example, if you modify a curve at its end point, 
the curvature slider moves the third CV from the end of the curve 
along a line that joins the end two CVs of the curve (for instance, 
along the tangent vector line). Such a modification doesn’t change the 
curvature at the end of the curve, it just adjusts the tangent vector.

Keep Original

Keeps the original curve after the projection is performed.

Edit Curves > Modify Curves > Lock Length

When you select Edit Curves > Modify Curves > Lock Length, the selected 
curve (or selected CVs) will maintain a constant hull length. If you then 
modify the curve, for example, by moving a CV, the shape of the curve 
will adjust so that it maintains a constant hull length (that is, CVs other 
than the one you move will also move).

When you select Edit Curves > Modify Curves > Lock Length, a Lock 
Length attribute is added to the curveShape node.
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Notes

• You can use the l (lower-case L) key as a momentary hotkey. Press 
and hold down the l key to lock the length of the selected curve. 
Release the l key to unlock the length of the curve.

• Lock Length is useful for modeling purposes. Because modifying a 
curve with Lock Length turned on behaves similar to a dynamic 
simulation, animating a curve in this way (with keyframes) may 
produce unexpected results.

• If you turn on Lock Length, move a CV and then select Undo, only the 
CV you moved will return to its original position.

• If you turn on Lock Length and modify the curve, the curve’s first CV 
will not move (unless you explicitly move the first CV). For example, 
if you move the curve’s first CV, the curve will respond differently 
than if you move the curve’s last CV.

Related topics

� ”Lock or unlock the length of a curve” on page 105

� ”Edit Curves > Modify Curves > Unlock Length” on page 143

Edit Curves > Modify Curves > Unlock Length

When you select Edit Curves > Modify Curves > Unlock Length, the 
selected curve (or selected CVs) will no longer maintain a constant hull 
length. If you then modify the curve, for example, by moving a CV, the 
curve’s hull length will not remain constant (and only the CV you move 
will actually move).

When you select Edit Curves > Modify Curves > Unlock Length, the 
curveShape’s Lock Length attribute is turned off.

Related topics

� ”Lock or unlock the length of a curve” on page 105

� ”Edit Curves > Modify Curves > Lock Length” on page 142

Edit Curves > Modify Curves > Straighten

Makes the selected curves (or selected CVs) straighter (in the direction of 
the curve’s first segment). The curve’s first CV will maintain its original 
position.

Related topics

� ”Straighten, smooth, curl or bend a curve” on page 106
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Edit Curves > Modify Curves > Straighten > �

Straightness

Determines how much each segment of the selected curves will be 
straightened. The higher the Straightness, the greater the effect. The 
effect will be greater on a curve with many CVs than on a curve with 
few CVs because the Straightness affects each segment.

When Straightness is 0, selected curves will not be straightened at all. 
When Straightness is 1, selected curves will become entirely straight. 
When Straightness is 2, selected curves will be flipped so they have 
the opposite curvature.

Preserve Length

The selected curve will remain the same length after straightening. 
The curve’s first CV will maintain its original position, but its last CV 
will change position. (If you are applying Straighten to selected CVs 
with Preserve Length on, then some non-selected CVs may also be 
affected.)

If preserve Length is off, the curve’s first and last CVs will both 
maintain their original positions.

Edit Curves > Modify Curves > Smooth

Makes the selected curves (or selected CVs) smoother. The curve’s first 
and last CVs will maintain their original positions.

Related topics

� ”Straighten, smooth, curl or bend a curve” on page 106

Curve after Straighten with Preserve Length OFF
Curve after Straighten with Preserve Length OFF

Original Curve

Curve after Straighten with Preserve Length ON

Curve after Straighten with Preserve Length ON
NURBS Modeling 

144



4 | Editing NURBS

Reference > Edit Curves > Modify Curves > Curl
Edit Curves > Modify Curves > Smooth > �

Smooth Factor

Determines how much each segment of the selected curves will be 
smoothed. The higher the Smooth Factor, the greater the effect. The 
effect will be greater on a curve with many CVs, than on a curve with 
few CVs, because the Smooth Factor affects each segment.

Edit Curves > Modify Curves > Curl

Makes the selected curves (or selected CVs) curly so they resemble a helix. 
The curve’s first CV will maintain its original position.

Related topics

� ”Straighten, smooth, curl or bend a curve” on page 106

Edit Curves > Modify Curves > Curl > �

Curl Amount

Determines how much each segment of the selected curves will be 
curled. The higher the Curl Amount, the greater the effect. The effect 
will be greater on a curve with many CVs than on a curve with few 
CVs because the Curl Amount affects each segment.

Curl Frequency

Determines how many curls the selected curves will be curled into.

Edit Curves > Modify Curves > Bend

Makes the selected curves (or selected CVs) bend in one direction. The 
curve’s first CV will maintain its original position.

Related topics

� ”Straighten, smooth, curl or bend a curve” on page 106

Tip Do not apply Curl to a curve twice. The second Curl will 
produce poor results because it is trying to curl a curve that is 
already curly.
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Edit Curves > Modify Curves > Bend > �

Bend Amount

Determines how much each segment of the selected curves will be 
bent. The higher the Bend Amount, the more the curve will be bent. A 
curve with many CVs will be bent more than a curve with few CVs 
because the Bend Amount affects each segment.

Twist

Controls the direction in which the selected curves will be bent.

Edit Curves > Modify Curves > Scale 
Curvature

Makes the selected curves (or selected CVs) straighter or exaggerates their 
existing curvature, depending upon the Scale Factor and Max Curvature 
values.

Related topics

� ”Straighten, smooth, curl or bend a curve” on page 106

Edit Curves > Modify Curves > Scale Curvature > �

Scale Factor

Determines how much each segment of the selected curves will be 
straightened or have their existing curvature exaggerated. The higher 
the Scale Factor, the greater the effect. The effect will be greater on a 
curve with many CVs than on a curve with few CVs because the Scale 
Factor affects each segment.

If Scale Factor is less than 1, the selected curves will become 
straighter.

If Scale Factor is greater than 1, the selected curves will have their 
existing curvature exaggerated (by exaggerating the curvature of each 
segment in the same direction as its existing curvature).

Max Curvature

Controls the maximum angle allowed between adjacent segments.

If Max Curvature is 1, then the maximum angle allowed between 
adjacent segments is 180 degrees. If Max Curvature is 0.5, then the 
maximum angle allowed between adjacent segments is 90 degrees.
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Edit Curves > Selection > Select Curve CVs

Selects all CVs on the selected curves.

Related topics

� ”Select curve CVs: first, last or all” on page 109

Edit Curves > Selection > Select First CV on 
Curve

Selects the first CV on the selected curve.

Related topics

� ”Select curve CVs: first, last or all” on page 109

Edit Curves > Selection > Select Last CV on 
Curve

Selects the last CV on the selected curve.

Note If the selected curve already has adjacent segments with an angle 
greater than that allowed by the Max Curvature value, and you 
apply Scale Curvature with a Scale Factor greater than 1 (that is, 
to exaggerate the curvature of the curve), the curve may actually 
become straighter. This is because the Max Curvature value is 
reducing the angle between adjacent segments.

Tip You can also access this command by pressing Ctrl + the right 
mouse button and choosing To CVs.

Tip You can also access this command by pressing Ctrl + the right 
mouse button and choosing To First CV.

Tip You can also access this command by pressing Ctrl + the right 
mouse button and choosing To Last CV.
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Related topics

� ”Select curve CVs: first, last or all” on page 109

Edit Curves > Selection > Cluster Curve

Creates a cluster for each CV on the curve, for example, when building a 
character’s back with spline IK.

Related topics

� Pose joints with spline IK curves in the Animation book

Edit NURBS

Edit NURBS > Extend Surfaces

Extends an edge of a surface.

Related topics

� ”Extend a surface” on page 108

Edit NURBS > Extend Surfaces > �

Extension Type

Tangent adds new isoparms to the extended surface.

Extrapolate rebuilds the surface according to the direction and 
distance specified, but without adding new isoparms.

Distance

Sets the length of extension.

Extend Side

Specifies the sides that will be extended; the start is the U0 and V0 
location on the surface. This option is available in the Channel Box 
after you extend the surface. Select the extendSurfacen node to display 
the option.

Tip You can also access this command by pressing Ctrl + the right 
mouse button and choosing Cluster.
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Extend Direction

Specifies the U, V, or U and V directions for the extension to be built. 
This option is available in the Channel Box after you extend the 
surface. Select the extendSurfacen node to display the option.

Join to Original

You can turn off this option only when the Extend Side and Extend 
Direction options are not set to Both. Maya disables the selection of 
Both for Extend Side and Direction, and causes Extend Surfaces to 
create an unattached and separate surface.

Keep Original

This option causes Extend Surfaces to keep the original surface when 
it builds the new one. Turn this off if you prefer to discard the original 
surface.

Edit NURBS > Offset Surfaces

Creates a copy of the selected surface, offset a certain distance.

Related topics

� ”Create an offset copy of a curve or surface” on page 112

Edit NURBS > Offset Surfaces > �

Method

Surface Fit creates an offset surface that preserves the surface 
curvature.

CV Fit will create an offset surface that represents the offset of the CV 
positions along their normals.

Offset Distance

This is the distance that the new surface will be offset. Concave 
surfaces might produce overlapping and intersecting areas. 

Edit NURBS > Selection > Select Surface 
Border

Selects CVs along the surface borders. The borders are defined by U and V 
values. By default, this operation selects CVs along all borders. In the 
options window for this operation, you can choose which border CVs you 
want to select: First U, Last U, First V, or Last V. 
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Edit NURBS > Attach Surfaces

Joins two surfaces together into a single surface.

Related topics

� ”Join two curves or surfaces together (attach)” on page 110

Edit NURBS > Attach Surfaces > �

Attach Method

Connect attaches the selected surfaces without distorting them.

Blend creates a continuous surface joining the original surfaces. It 
yields a less obvious attachment, but also might add some distortion 
as the blend tries to achieve continuity across the attachment.

Multiple Knots

The Multiple Knots options are used to specify whether the multiple 
knots at the join point are kept or removed after the attach is done. 

Use Keep to keep the multiple knots created at the join point as a 
result of the attach. This is the default.

Use Remove to remove the multiple knots at the join point. The shape 
of the geometry can be changed if required.

Blend Bias

Use Blend Bias to alter the amount of continuity for the new surface; 
high values may distort the tangency of the original surfaces. 

Insert Knot

This option is available only if you select the blend method of 
attachment. In conjunction with the Insert Parameter value, Insert 
Knot lets you make the blend region match the original surface 
curvature more closely. 

This option has significant effect only if the original surfaces are not 
aligned precisely and have lengthy distances between the last two 
spans on each original surface near the attachment area. 

Insert Knot creates two additional spans near the attachment area. 
Each is within one span of the points being joined from the original 
surfaces. You can adjust the positioning of the extra spans with the 
Insert Parameter value. 
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Insert Parameter

This option adjusts the positioning of the spans added when you turn 
on Insert Knot. The closer the value is to 0 (without reaching 0), the 
closer the blend shape resembles the curvature of the original spans in 
the attachment area. This occurs because the added spans are inserted 
closer to the spans closest to the blend points. Valid values are from 0 
to 1.

To adjust this option interactively, first create the blended surface 
with Insert Knots turned on. Next, select the blended surface, display 
the Channel Box, and select attachSurface in the INPUTS section. Try 
different values for Parameter until you see the desired surface 
curvature. 

Keep Original

Retains the original surface after the attach is performed. Do not turn 
this option off if construction history is turned on. If you do, the 
attached surface might deform oddly if you manipulate it later.

Edit NURBS > Attach Without Moving

Attaches the selected curves or surfaces by reshaping their ends, rather 
than moving the objects.

Related topics

� ”Join two curves or surfaces together (attach)” on page 110

� ”Edit NURBS > Attach Surfaces” on page 150

Edit NURBS > Detach Surfaces

Splits a surface into multiple surfaces at the selected isoparms.

Related topics

� ”Split a curve or surface (detach)” on page 111

Tip If you create the initial surfaces carefully, an attach usually gives 
the desired results without knot insertion. If you do an attach with 
Multiple Knots set to Remove but need more local control, you can 
undo and repeat the attach with Keep turned on.
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Edit NURBS > Detach Surfaces > �

Keep Original

If Keep Original is on when you perform the detach, the original 
curve or surface is retained. 

Input Surface

The Input Surface information is read-only. It gives you access to the 
history of the surface you detached. Click the arrow button to select 
the surface and open its section of the editor.

Direction

Use the Direction pop-up menu items to specify the direction of the 
detachment.

Keeping the geometry in U or V

The Keep section lets you specify whether original geometry is kept in U 
or V when you perform the detachment.

Changing the detach direction and position

You can change the direction of the detachment by selecting U or V from 
the Direction pop-up menu in the Channel Box or Attribute Editor. You 
can also enter a parameter value to change where the detachment occurs.

In the following figure, a V isoparm is selected, moved, then detached 
twice. The first detachment moves the seam of the cone, which is periodic 
in V. 

If you change the parameter value, the detachment area is increased or 
decreased. In the following example, the parameter value is increased to 
1.5.
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To change the detach direction, select U from the Direction pop-up menu 
to detach the isoparm from a parameter value of 1.5 in the U direction.

Note that you can edit the area of detachment with the Show Manipulator 
Tool. Select the detached curve and the detachSurface node in the Channel 
Box, then select the Show Manipulator Tool.

Edit NURBS > Align Surfaces

Makes the edges of surfaces tangent or curvature continuous.

Related topics

� ”Align surface edges” on page 104

Edit NURBS > Align Surfaces > �

Attach

Select Attach if you want to attach the surfaces as well as align.

Multiple Knots

When objects are joined, Multiple Knots are created at the Join 
Parameter. Select Keep to retain these knots.

Select Remove to remove as many knots as possible without changing 
the shape of the object when the attach is performed.
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Continuity

Continuity means that two surfaces share a boundary. Continuity 
options let you specify how to achieve continuity for the two surfaces. 

Positional continuity means that the ends of two surfaces meet 
exactly. The following figure shows a side view of how surfaces are 
aligned with each Modify Position option (First, Second, and Both). 
The alignment occurs depending on which surface is selected first 
(white) and last (green).

Tangent continuity exists when two surfaces are placed end to end, 
and the tangents at the endpoints also match. An example side view 
of aligned surfaces follows:

Both First (default)

Second

End points
NURBS Modeling 

154



4 | Editing NURBS

Reference > Edit NURBS > Align Surfaces
Curvature continuity exists when two surfaces that meet with tangent 
continuity also have the same curvature at the joint. When this option 
is selected, the curvature scale sliders are enabled. 

Modify Position, Modify Boundary, Modify Tangent

You can choose the order you want the surface modified. The 
following tables show what is modified with the different Modify 
options.

Modify Position Surfaces

First

Only the shape of the first surface you 
select is modified.

The entire first surface moves so its end 
boundary coincides with the start 
boundary of the second surface. Some 
adjustments are made to the first surface 
end boundary CVs.

Second

Only the shape of the second surface 
you select is modified.

The entire second surface moves so its 
start boundary coincides with the end 
boundary of the first surface. Some 
adjustments are made to the second 
surface start boundary CVs.

Both

The shapes of both the first and second 
surfaces you select are modified.

The entire first and second surfaces 
move so that the end boundary of the 
first surface and the start boundary of 
the second surface coincide. The 
adjacent boundary CVs move halfway 
along the line of minimum distance.

Modify Boundary Surfaces

First

Only the shape of the first surface you 
select is modified.

All the end boundary CVs of the first 
surface move to coincide with the 
adjacent start boundary CVs of the 
second surface.

Second

Only the shape of the second surface 
you select is modified.

All the start boundary CVs of the second 
surface move to coincide with the 
adjacent end boundary CVs of the first 
surface.
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Tangent Scale, Curvature Scale

The values in the Tangent Scale and Curvature Scale boxes increase or 
decrease the tangent magnitude or curvature at the end of the surface. 
You can enter a value in the box or drag the slider bar. The following 
table shows what happens when the tangent and curvature is scaled. 

Both

The shapes of both the first and second 
surfaces you select are modified.

All the end boundary CVs of the first 
surface and the start boundary CVs of 
the second surface move to coincide 
with each other. The adjacent CVs move 
halfway along the line of minimum 
distance.

Modify Boundary Surfaces

Modify Tangent Surfaces

First

Only the shape of the first surface you 
select is modified.

The tangents at the end boundary of the 
first surface adjust to coincide with the 
tangents at the start boundary of the 
second surface.

Second

Only the shape of the second surface 
you select is modified.

The tangents at the start boundary of the 
second surface adjust to coincide with 
the tangents at the end boundary of the 
first surface.

Note Curvature continuity is applied to the surface that is modified for 
tangent continuity (see the table above).

Tangent Scale Surfaces

First

Only the shape of the first surface you 
select is scaled.

The tangent magnitude at the end 
boundary of the first surface adjusts.

Second

Only the shape of the second surface 
you select is scaled.

The tangent magnitude at the start 
boundary of the second surface adjusts.
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Keep Originals

If Keep Originals is off, the original surfaces are replaced with the 
aligned surfaces. If on, two new surfaces are created and the originals 
are retained. 

Input Surface

The Input Surface information is read-only. It gives you access to the 
history of the surfaces you aligned. Click the arrow buttons to select 
an input surface and open its section of the editor.

Join Parameter

The Join Parameter slider becomes available depending on the 
Positional Continuity Type you select. Use Join Parameter to define 
the parameter on the first/second surface at which the alignment is 
performed.

Reverse/Swap

The Reverse and Swap options for surfaces define whether the 
surfaces have to be reversed and or swapped before performing the 
alignment (remember, align uses the end of the first surface and the 
start of the second). The reverse is done in the direction defined by 
Direction U (on or off) in the Channel Box. 

Twist

If Twist is turned on, the second surface is also reversed in the 
opposite direction of Direction U. Turn this on if your aligned surface 
is twisted.

For example, if you align the surfaces and the surface boundaries are 
going in different directions, the following results.

Curvature Scale Surfaces

First

Only the shape of the first surface you 
select is scaled.

The curvature at the end boundary of 
the first surface adjusts.

Second

Only the shape of the second surface 
you select is scaled.

The curvature at the start boundary of 
the second surface adjusts.
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When you select the surfaces, the align result is twisted. Turn Twist 
on either from the Attribute Editor or in the Channel Box to correct 
the problem.

The other alternative is to check the surface U/V direction before you 
align the surfaces. Use Edit NURBS > Reverse Surfaces to reverse the 
surface directions if necessary.

Surface boundaries are not going in the same direction.

Twist off Twist on
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Interior Blending

The Interior Blending sections are the same as the Tangent Scale 
options in the options window. The sliders become available 
depending on which type of continuity you select.

Edit NURBS > Open/Close Surfaces

Converts a surface between open and closed/periodic.

Related topics

� ”Make a curve or surface open or closed” on page 119

Edit NURBS > Open/Close Surfaces > �

Surface Direction

The Surface Direction options, U, V, and Both, let you choose the 
direction in which a surface is open or periodic. The following figure 
shows how these options are used to close a beveled curve.

Note Align Surfaces computes the twist values for edges, so you do not 
need to align surfaces then turn on the twist attribute to get a clean 
join.

Reverse the surface boundary on one of the surfaces. 

Align result
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Shape

Ignore does not preserve the shape of the original selection.

Preserve adds or deletes control points as necessary to preserve the 
shape of the original surface. This option is the default setting.

Blend tries to impose continuity on the input surfaces, using the Blend 
Bias setting to determine the amount of smoothing that will take 
place. 

Blend Bias

Alters the amount of continuity for the new surface; higher values 
may result in increased distortion of the tangency of the original 
surfaces.

Insert Knot

This option is available only when you select the Blend option for 
Shape. It inserts a knot along the join seam and lets you set a value for 
the Insert Parameter.

Insert Parameter

Controls the amount of influence the inserted knot has on the blended 
shape.

Keep Original

Sets whether the original curves or surfaces are retained after Open/
Close.

Note If the ends are touching and you close them with the Preserve 
setting on, you might get CVs that cross over each other and cause 
a loop in the surface when you move the CVs. In these situations, 
turn on the Blend setting instead. 

U V Both
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Selecting an isoparm to change the periodic direction 

You can select the direction in which you want the surface to be periodic 
from the options window, or you can click to select isoparms on the 
surface. When you do this, you override the Surface Direction setting in 
the options window.

Edit NURBS > Move Seam

Moves the seam of a closed/periodic surface to the selected isoparm.

Related topics

� ”Make a curve or surface open or closed” on page 119

Edit NURBS > Insert Isoparms

Adds an edit point isoparm at the selected isoparm.

Related topics

� ”Insert additional edit points/isoparms in a curve or surface to add 
more CVs” on page 111

U V U/V
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Edit NURBS > Insert Isoparms > �

Insert Location

At Selection lets you create isoparms at the current position, 
effectively creating a subdivision of the surface. This option enables 
the Multiplicity options.

Between Selections creates isoparms between your choice of selected 
isoparms, or between all U or V isoparms. For instance, if you select a 
pair of isoparms and turn on Between Selections, Maya creates the 
isoparm halfway between the pair. 

Note that if you turn on Between Selections and set Multiplicity (see 
the following option) to a value greater than 1, Maya creates the 
multiple isoparms spaced out evenly between the selected isoparms.

Use all Surface Isoparms

If you select the entire surface and select Between Selections, you must 
turn on U or V for the Use all Surface Isoparms option. U creates 
isoparms between all U isoparms; V creates isoparms between all V 
isoparms. If you select a pair of specific isoparms rather than the 
entire object, Maya ignores whether you choose U or V. Isoparms will 
be inserted only between the selected isoparms. 

Multiplicity

Lets you insert multiple isoparms at the selected positions as 
described in the following paragraphs. The new isoparms do not 
change the shape of the surface. 

The Set to option lets you insert an absolute number of isoparms 
according to the Multiplicity value. For example, if Multiplicity is 3 
and At Selection is turned on, three isoparms will be inserted at the 
position regardless of whether it already has an isoparm.

The Increase by option lets you add an additional number of isoparms 
to the position according to the Multiplicity value.

Keep Original

Turn on Keep Original if you want to keep the original surface in 
addition to the surface with new isoparms. 

Tip To use a manipulator to reposition the new isoparm(s) after you 
insert it, turn on Keep Original. Click the Insert button in the Insert 
Isoparms options window, then select the Show Manipulator Tool 
and reposition the large yellow square. When you finish 
positioning the isoparm, deselect the curve. 
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Input Surface

This information is read-only. It shows the surface for which you 
inserted the isoparm. The Insert Between and Add Knots attributes 
affect the location of inserted knots.

Direction 

This positions the isoparm in U or V.

Parameter

This sets a value that repositions the isoparm on the surface.

Number of Knots

This specifies how many isoparms you want to insert. This is the same 
as the Multiplicity option in the options window.

Edit NURBS > Reverse Surface Direction

Reverses or swaps the U and V directions of the selected surface.

Related topics

� ”Reverse the direction of a curve or surface normals” on page 113

Edit NURBS > Reverse Surface Direction > �

Surface Direction

Select U to reverse the CVs along the U parametric direction. U is the 
default surface direction.

Select V to reverse the CVs along the V parametric direction. 

Select Swap to exchange U and V parameterization. Selecting an item 
a second time using the same direction restores the original CV 
sequence. Reversing the sequence of CVs for a surface reverses the 
surface normals.

Select Both to reverse the CVs and normals along both U and V 
parametric directions.
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Keep Original

Turn Keep Original on to keep the original curves after reversing the 
surface.

Edit NURBS > Rebuild Surfaces

Performs various operations on the selected surface.

Related topics

� ”Reduce the complexity of a curve or surface” on page 114

� ”Control multi-knots and CV hardness” on page 115

� ”Convert a curve or surface to uniform parameterization” on page 117

� ”Convert a surface to non-rational geometry” on page 117

� ”Change a curve or surface’s degree or number of spans/patches” on 
page 118

Edit NURBS > Rebuild Surfaces > �

Rebuild Type

The Rebuild Surface options window displays different options 
depending on the Rebuild Type option you select:

Uniform

Use the Uniform option to rebuild the surface with uniform 
parameterization. With this option, you can change the Number of 
Spans and Degree of the surface. 

Reduce

If you select the Reduce option, Maya removes knots if their removal 
does not cause any remaining knots to move by a distance greater 
than the Tolerance setting. A higher Tolerance setting removes more 
knots.

Match Knots

Rebuilds a surface by matching the curve degree, knot values, and 
number of spans and sections of another surface. Before you rebuild 
the surface, select the surface to be rebuilt first and Shift-select the 
surface to be matched. The Keep options become available when you 
select Match Knots. 

Setting Rebuild Method to Match can produce better quality surfaces.
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No Multiple Knots

Removes any extra knots created during the rebuild operation. The 
resulting surface has the same curve degree as the original. The Keep 
options are not available when you select this option.

Non-Rational

Select Non-Rational to rebuild a rational surface into a nonrational 
surface. The CVs of a rational surface have weights that are not all 
equal to 1. The CVs of a nonrational surface all have weights equal to 
1. The resulting surface has the same degree as the original surface. 
The Keep options are not available when you select this option.

Maya creates surfaces with all CVs weighted at 1 by default. Other 
software packages, especially design packages, might create surfaces 
with CVs not weighted at 1. The Non-Rational option is useful if you 
import surfaces from such packages.

The reason some design packages use weights not equal to 1 is 
because they allow finer surface precision. As Maya is used mainly for 
entertainment, extreme precision is typically not essential. If you 
rebuild an imported surface to have equal weighting, Maya processes 
your subsequent work on the surface faster, while still providing 
accurate precision.

End Conditions

Rebuilds the positioning of the surface’s end CVs and knots. If you 
select End Conditions, two extra options appear for the End 
Conditions: No Multiple knots and Multiple knots. 

With No Multiple Knots turned on, the rebuilt surface doesn’t pass 
through the end CVs. This makes the surface harder to control in 
some cases, but makes other operations easier. For example, it’s easier 
to create smooth joins between adjacent surfaces. (If you rebuild both 
surfaces with No Multiple knots, you can snap CVs together to get 
exact tangency across the boundary.)

If you turn on Multiple Knots, the surface touches the end CVs, 
making it easier to control the surface boundaries and related 
tangency.

A surface rebuilt with End Conditions has the same degree as the 
original.

Trim Convert

Rebuilds a single-region trimmed surface (with four boundary curves) 
into a non-trim surface.
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Bezier

Rebuilds the surface as a Bezier surface. If you prefer working with 
Bezier surfaces rather than NURBS surfaces, consider using this 
option to convert the surface.

Parameter Range

The three Parameter Range options are used to specify how U and V 
parameters are affected during the rebuild.

Select 0 to 1 if you want the resulting surface’s U and V parameters to 
run from 0 to 1.

Select Keep if you want the rebuilt surface’s U and V parameter 
ranges to match those of the original surface. 

Select 0 to #Spans if you want the resulting surface’s spans to give you 
integer knot values. These values make it easier for numerical input. If 
using the Uniform rebuild type, this option always gives you integer 
knot values. For example, if you want to use Detach and you prefer to 
type a value, it is easier to enter the number 2 than something like 
0.362.

Direction

The Direction options, U, V, U and V, are used to determine the 
parametric direction of the surface for which knots will be removed. 
For example, if U is selected and the rebuild type is No Multiple 
Knots, only the multiple knots in the U direction are removed when 
the surface is rebuilt. U and V is the default.

Keep

Rebuilding a surface may change the surface in 3D. Use the Keep 
options to ensure the rebuilt surface conforms to the input (or 
original) surface.

Turn Corners on to ensure that the corners of the new surface are at 
the same 3D point as the original corners. Turn on CVs to specify 
whether or not you want to keep the CVs of the original surface. 

NumSpans gives the rebuilt surface the same number of spans as the 
original.

Note Performing uniform surface rebuild on a periodic surface will 
always rebuild the surface to uniform in both direction, 
regardless of the setting for the surface direction. 
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Rebuild Method

Setting Rebuild Method to Match can produce better quality surfaces, 
especially if the rebuild or reference surface is periodic or if either 
surface does not have multiple knots at the ends.

Setting Rebuild Method to Classic produces the same results as in 
Maya 5.0 and earlier.

Number of Spans U/V

If Uniform is the rebuild type, the number of spans in the resulting 
surface can be set by the value you enter in the Number of Spans U/V 
boxes. 

Degree U/V

The degree of the resulting surface is determined by the Degree U or 
Degree V you select. 

If you turn on Original, the U/V degree of the rebuilt surface is the 
same as the original surface.

Note that you can turn on Degree U/V Original and Keep NumSpans 
to create a uniform rebuild for several surfaces that have a different 
number of spans.

Keep Original

Retains the original surface after it is rebuilt. If Keep Original is on, 
you can see the deviation of the resulting surface from the original 
surface.

Use Tolerance

This option is available only when you turn on Non-Rational or 
Reduce. It sets the longest distance between any point on the original 
and rebuilt surfaces. The smaller the tolerance, the more the rebuilt 
surface resembles the original. A small tolerance might create many 
patches, which slows processing time as you work with the surface.

Global uses the Positional value in the Preferences window. Local lets 
you enter the tolerance directly in the window.

Default 3 Cubic in U U Degree changed to 2
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Tangent
Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision 
surfaces.)

Input Surface

The Input Surface information is read-only. It gives you access to the 
history of the surfaces you rebuilt. Click the arrow buttons to select 
the surface, then open the appropriate section of the Attribute Editor.

Match Surface

If there is more than one surface and Match Knots was turned on 
when you rebuilt the surface, you can also access the Match Surface 
rebuilt surface.

Edit NURBS > Surface Editing > Surface 
Editing Tool, Break Tangent, Smooth Tangent

Attaches a manipulator to the surface you click that lets you set the 
position and shape at arbitrary points on the surface.

Related topics

� ”Reshape a curve or surface manually” on page 99

Edit NURBS > Surface Editing > Surface Editing Tool 
> �

Tangent Manip. Size

Controls the length of the tangent direction handle on the 
manipulator.

Edit NURBS > Selection

Grow CV Selection

Expands your CV selection in all directions around the surface. 

Shrink CV Selection

Subtracts from your CV selection in all directions around the surface.

Select CV Selection 

Boundary

Keeps the outer CVs you have selected and deselect the inner CVs.
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Select Surface 

Border

Selects CVs along the surface borders. The borders are defined by U 
and V values. By default, this operation selects CVs along all borders. 
In the options window for this operation, you can choose which 
border CVs you want to select: First U, Last U, First V, or Last V. 
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About > Curves-on-surface
5 Trimming

About NURBS

Curves-on-surface

Curves-on-surface are special curves that are drawn in the UV space of a 
surface, rather than in the XYZ space of the scene.

You can create curves-on-surface by:

• Drawing directly on the surface. Click the magnet icon on the toolbar 
to make a surface “live”, then use the curve creation tools to draw a 
curve-on-surface directly on the surface.

• Projecting existing curves onto a surface.

• Intersecting existing geometry with a surface.

Curves-on-surface are usually used to trim surfaces, or to form an edge of 
new surfaces.

Curves on surface (along with their edit points) have a special Move 
manipulator. When you move a curve on surface, the manipulator 
constrains the curve on surface to the surface and allows movement across 
the surface in U and V.

Related topics

� ”Create a curve-on-surface” on page 172

� ”Trim or untrim a NURBS surface” on page 174

Move curve on surface manipulator
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Trimming

Since NURBS surfaces are intrinsically four-sided and do not allow holes, 
you need a way to visually simulate irregular shapes and holes when 
using NURBS. The answer is trimming.

Trimming lets you visually cut or divide a surface along a curve-on-
surface so it appears to have holes or missing pieces. The trimmed surface, 
however, is not actually cut. It exists in a hidden form that does not render 
or affect modeling. You can recover the trimmed part of a surface using 
the Untrim tool.

Creating curves-on-surface and then trimming is the most common way 
to combine NURBS surfaces in industrial design.

Related topics

� ”Create a curve-on-surface” on page 172

� ”Trim or untrim a NURBS surface” on page 174

How do I? Create and edit models

Trim a NURBS surface

Create a curve-on-surface

Draw a curve-on-surface directly

1 Select the surface on which you want to draw a curve-on-surface.

2 In the toolbar, click the “Make the selected object live” icon.

3 Choose Create > CV Curve Tool or Create > EP Curve Tool.

4 Draw a curve on the live surface.

5 When the curve is finished, click the “Make selected object live” icon 
again.

Project a curve onto a surface along the view direction

1 Select a surface and one or more curves.

Select the objects in a view pointing in the direction you want to 
project. For example, if you want to project along Y, select the objects 
in the Top view.
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2 Select Edit NURBS > Project Curve on Surface > ❐ and set Project 
Along to Active View.

3 Click Project.

Project a curve onto a surface along the surface’s normals

1 Select a surface and one or more curves.

2 Select Edit NURBS > Project Curve on Surface > ❐ and set Project 
Along to Active View.

3 Click Project.

Create curves on surface where two surfaces intersect

1 Select two surfaces.

2 Select Edit NURBS > Intersect Surfaces.

The default is to create curves-on-surface on both surfaces. To only 
create curves-on-surface on the first or second surface, open the 
option box (Edit NURBS > Intersect Surfaces > ❐) and set the Create 
Curves For option.

Related topics

� ”Trim or untrim a NURBS surface” on page 174

� ”Edit NURBS > Project Curve on Surface” on page 177

� ”Edit NURBS > Intersect Surfaces” on page 179
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Trim or untrim a NURBS surface

Trimming removes (actually hides) any part of a surface bounded by 
curves-on-surface. This lets you create complex edges and holes in NURBS 
surfaces. You must create curves-on-surface before you can trim the 
surface.

Trim a surface

1 Choose Edit NURBS > Trim Tool.

2 Click the surface you want to trim.

A “trim grid” appears on the surface.

3 Click the regions (defined by curves-on-surface) of the surface you 
want to keep (you do not need to hold Shift to click multiple regions).

As you click, regions that will be trimmed away are dotted, and 
regions that will be kept are solid.

If you want to change the tool so you click the parts of the surface you 
want to trim off, open the option box (Edit NURBS > Trim Tool > ❐) 
and set Selected State to Discard.

4 Press Enter to trim.

Untrim a surface

1 Select the surface or surfaces you want to untim.

2 Choose Edit NURBS > Untrim Surfaces.

The default is to remove all trims from the surface, restoring it to its 
original state. To only reverse the most recent trim operation, open the 
option box (Edit NURBS > Untrim Surfaces > ❐) and set Untrim to 
Last.

If you turned on the Shrink Surface option when you trimmed the surface, 
Untrim cannot restore the original shape of the surface.

Tip A seam can divide a region in two. Make sure when you click a 
region bisected by the seam that both sides are marked.
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Related topics

� ”Trimming” on page 172

� ”Create a curve-on-surface” on page 172

� ”Perform boolean operations on surfaces” on page 175

� ”Edit NURBS > Trim Tool” on page 180

� ”Edit NURBS > Untrim Surfaces” on page 181

Perform boolean operations on surfaces

These actions trim surfaces to create the appearance of the union, 
intersection, or subtraction of two objects.

To perform boolean operations on surfaces

1 Choose an action from the Edit NURBS > Booleans submenu.

• Union trims the surfaces so they appear to be merged.

• Subtract trims the surfaces so that the volume of the second 
surface appears to be subtracted from the first.

• Intersect trims the surfaces so that only their shared volume 
remains.

2 Click the first surface and press Enter. Then click the second surface.

The order in which you click the surfaces only matters for the Subtract 
tool. Maya subtracts the second surface you click from the first.

Maya groups the combined surfaces.

You can make the following adjustments after creating the Boolean shape:

Sphere selected first Subtract tool result

Torus selected first

1

2

2

1

Subtract tool result
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• To change the Boolean operation, such as changing Subtract to 
Intersect, select the boolean node in the Channel Box and change the 
Operation option.

• You can select the node of one of the original objects in the outliner or 
hypergraph.

What if...?

I get a “node a valid NURBS shell” error?
This means the boolean tool cannot create meaningful geometry from the 
surfaces you clicked.

For example, in the following illustration, the horizontal cylinder does not 
enclose a space that can be combined with the vertical cylinder. If you 
move the horizontal cylinder up, the boolean actions will work.

Related topics

� ”Trim or untrim a NURBS surface” on page 174

� ”Edit NURBS > Booleans > Union Tool, Subtract Tool, Intersect Tool” 
on page 181

Original objects After Subtract Cone node and 
Move tool selected

Cone moved upAfter Subtract

Note The only way to retrieve the original objects after a Boolean 
operation is to use Undo.

Boolean impossible Boolean possibleBoolean possible
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Reference Menus

Modeling menu set

Edit NURBS

Edit NURBS > Project Curve on Surface

Creates curves-on-surface by projecting a 3D curve onto a surface.

Related topics

� ”Create a curve-on-surface” on page 172

Edit NURBS > Project Curve on Surface > �

Project Along

Specifies whether the projection will be normal to the active view or to 
the surface normal direction.

Active View, the default, means that the projection occurs in the 
direction of the normals in the active view. For example, if the front 
view is active, the curve is projected along the Z axis (the axis normal 
to the front view). 

Making sure the projection works in the active view 

If you project curves using the Active View option, you have to decide 
which view you want active before you use Project Curve On Surface. It is 
important to make sure the selected curve (or set of curves) is projected 
along the perpendicular (normal) axis of the current view. 

In the following figure, the projection was attempted while the 
perspective view was active. As you can see, the curve is not projected 
correctly. 
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Projecting while the front view is active works because the perpendicular 
direction of the projection is relative to the surface normals of the front 
view. 

Surface Normal lets you project a curve onto the selected surface in one 
view and then use the same curve to project onto additional surfaces in 
any other view. The active view is not important if you project while this 
option is selected.

If you select Surface Normal, make sure you move the curve to the outside 
of the surface. 

The curve lies on the axis of revolution inside the surface. If the curve is 
inside the surface, the projection will either take a long time to complete 
or it will fail.

Use Tolerance

The Use Tolerance options let you project the curve within a specified 
tolerance of the original curve. You can apply tolerance globally or 
locally.

Global tolerance causes Maya to use the Positional value in the 
Settings part of the Preferences window.
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Local tolerance lets you enter a new value to override the value in the 
Preferences window.

Curve Range

Complete projects the entire curve onto the surface. 

Partial lets you project only part of the curve onto the surface. This 
creates a subCurve (initially the whole curve) that can then be edited 
using the Show Manipulator Tool. 

Editing projected curves in the Channel Box

Click the projectCurve heading in the INPUTS section of the Channel Box 
to display the projected curve’s attributes.

Enter values in the boxes to change the X, Y, Z direction of the projection, 
or adjust the local tolerance value. You can type on to set the projection 
along the surface normals instead of in the active view. These options are 
also available in the options window and the Attribute Editor. 

Input Surface & Input Curve

The Input Surface and Input Curve information is read-only. It gives 
you access to the history of the surfaces and curves you used to 
project the curve. Click the arrow buttons to select the surface or curve 
then click the tab to open its section of the editor.

Use Normal

Turn on Use Normal if you choose to project the curve along the 
surface normals.

Edit NURBS > Intersect Surfaces

Creates curves on surface wherever two surfaces intersect.

Related topics

� ”Create a curve-on-surface” on page 172

Edit NURBS > Intersect Surfaces > �

Create Curves for

First Surface causes only the first surface selected (the target surface) 
to receive a curve-on-surface.

Note If the Project Along mode is set to Surface Normal, the Direction 
values in the Channel Box have no effect.
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Both Surfaces causes the target surface and the surface selected as the 
intersecting surface to both receive curves-on-surface. This is the 
default.

Curve Type

Curve On Surface creates a curve-on-surface as the intersection curve. 
This is the default.

3D World creates a NURBS curve in 3D world space. The curve is not 
a curve-on-surface and cannot be used to trim the surface later on.

Use Tolerance

The Use Tolerance options let you intersect within a specified 
tolerance of the default intersection. You can apply tolerance globally 
or locally.

Global tolerance causes Maya to use the Positional value in the 
Settings part of the Preferences window.

Local tolerance lets you enter a new value to override the value in the 
Preferences window.

Edit NURBS > Trim Tool

Hides parts of the surface defined by curves-on-surface.

Related topics

� ”Trim or untrim a NURBS surface” on page 174

Edit NURBS > Trim Tool > �

Selected State

If you want to keep the region you trimmed away, select Keep. To 
discard the region you trimmed away, select Discard. The default is 
Keep.

Note If you select many surfaces, the last selected is the target surface. 
For example, if you select 10 surfaces, the first nine are intersected 
with the tenth.

Note Text cannot be intersected with a target surface because text is a 
collection of curves. You cannot intersect a surface and curve. To 
intersect text, you must create the text as trim surfaces. 
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Shrink Surface

Causes the underlying surface to shrink to just cover the retained 
regions. This permanently changes the surface geometry and cannot 
be restored by untrimming, but Undo will still work.

Fitting Tolerance

Specifies how precisely the Trim Tool uses the shape of the curve-on-
surface when it trims the surface. The default value works well in 
most cases, but you can use a smaller value to increase precision. 

Keep Original

The original surface is retained after the trim is performed. If the 
surface and the curve-on-surface were created with construction 
history turned on, you must keep the original geometry. 

Edit NURBS > Untrim Surfaces

Undoes the last trim or all trims to a surface.

Related topics

� ”Trim or untrim a NURBS surface” on page 174

Edit NURBS > Untrim Surfaces > �

Keep Original

If you set Keep Original to On, the untrimmed surface is created and 
the original trimmed surface is retained. If you select Off, the 
untrimmed surface replaces the trimmed surface. 

Untrim

Select All to remove all trimming information from the surface. All 
curves-on-surface are also redisplayed. All is the default.

Select Last to cancel the last trim operation. For example, if a surface 
had been trimmed three times, this option shows the result as if it had 
only been trimmed the first two times.

Edit NURBS > Booleans > Union Tool, 
Subtract Tool, Intersect Tool

Trims two surfaces to create the appearance of boolean operations.

Related topics

� ”Perform boolean operations on surfaces” on page 175
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Edit NURBS > Booleans > Union/Subtract/Intersect 
Tool > �

Delete Inputs

Maya can keep a construction history input from the original surfaces 
so you can transform them to change the resulting boolean surface. If 
you do not want to keep this history input, turn on Delete Inputs. 
Also, construction history must be turned off in the scene. If 
construction history is on, Maya keeps the history inputs, regardless 
of this option. 

Tool Behavior

Exit On Completion, when turned on, takes you out of the Boolean 
tool after the Boolean operation is calculated. If turned off, the boolean 
tool remains the current tool so you can continue to perform other 
Boolean operations. 

The Hierarchy Selection option ensures that you can successfully 
perform a Boolean on the result from a prior Boolean operation. When 
on, Maya selects and performs the Boolean operation on the root of 
any given hierarchy. You must turn off Hierarchy Selection if you 
want to perform a Boolean operation on objects that are within the 
same group. 
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6 Stitching

How do I? Create and edit models

Lock points or edges on NURBS surfaces 
together (stitching)

Automatically stitch multiple surfaces 
together

The global stitch action automatically stitches any of the selected surfaces 
together wherever their edges touch.

You can use Global Stitch to close gaps in adjacent surfaces or to prevent 
adjacent surfaces from splitting when deformation pulls the edges apart.

For example, if you create a human face from multiple surfaces, then use 
clusters and lattices to deform facial characteristics. You can prevent the 
surfaces from splitting apart as you deform the face with Global Stitch.

To stitch surfaces together

1 Model your surfaces to surface edges and corners are touching. Avoid 
overlapping corners with other surfaces. If necessary, you can have 
the surface normals face opposite directions.

2 Select the surfaces.

3 Select Edit NURBS > Stitch > Global Stitch > ❐.

4 Set the options.

5 Click Global Stitch.
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Notes

• If the surfaces to be joined have position gaps or dissimilar tangency, 
the stitched surface might be wavy in the stitch region.

• If the parameter range on surfaces is small, there may be problems 
when applying a global stitch to such surfaces. 

Rebuild the surfaces to have a parameter range running from 0 to the 
number of spans. 

Lock a stitched surface to its original shape

You can “lock” certain surfaces so they won’t deform (the surfaces 
stitched to them will deform more to maintain stitching).

1 Make note of the name of the surface you want to lock.

2 Select the stitch node.

3 In the attribute editor, find the “input surface” number that 
corresponds to the surface you want to lock.

4 In the Lock Surfaces section, click the checkbox for the surface number 
you want to lock.

Related topics

� ”Manually stitch surface edges together” on page 185

� ”Manually stitch surface points together” on page 186
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� ”Edit NURBS > Stitch > Global Stitch” on page 191

Manually stitch surface edges together

To stitch surface edges

1 Select Edit NURBS > Stitch > Stitch Edges Tool.

2 Select the edge isoparms on each surface you want to stitch together.

A temporary stitch surface is created.

3 You can drag the manipulators to edit the extent of the stitching.

4 Press to finish the stitch.

Related topics

� ”Automatically stitch multiple surfaces together” on page 183
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� ”Manually stitch surface points together” on page 186

� ”Edit NURBS > Stitch > Stitch Edges Tool” on page 188

Manually stitch surface points together

To stitch surfaces together at individual points

1 Select the points on the first surface.

2 Select the points on the second surface.

3 Select Edit NURBS > Stitch > Stitch Surface Points.

You can control how much each surface pulls toward the stitched point on 
the other surface. Select the stitchSrf node attached to the surface you 
want to control. Edit the bias attribute to control how much the surface is 
pulled to the other surface. Higher values pull toward the meeting point 
with the other surface more. A value of 1 touch the other surface. A value 
of 0 means the stitching doesn’t affect the surface at all.

Related topics

� ”Automatically stitch multiple surfaces together” on page 183

� ”Manually stitch surface edges together” on page 185

� ”Edit NURBS > Stitch > Stitch Surface Points” on page 186

Reference Menus

Modeling menu set

Edit NURBS

Edit NURBS > Stitch > Stitch Surface Points

Related topics

� ”Manually stitch surface points together” on page 186
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Edit NURBS > Stitch > Stitch Surface Points > �

Keep Original

If Keep Original is on, the stitch surface is created on top of the 
original input surfaces. This lets you move the resulting surface if you 
are not satisfied with the result. You can restitch a new surface with 
different option settings.

Assign Equal Weights

If Assign Equal Weights is on, a weighted average of the selected 
points is performed both in position and normal using an average 
NurbsSurfacePoint node. 

If turned on, all the points are assigned a weight of 0.5. When turned 
off, the first selected point is assigned a weight of 1.0 and the rest 0. 
The default is on.

Cascade Stitch Node

If Cascade Stitch Node is on, the stitch operation ignores any prior 
stitch operations on the surface. If turned off and the surface has had a 
stitch operation performed on it, the stitch node from the previous 
operation is used. The default is on.

Input Surface

The Input Surface is a read-only attribute that lists the original object 
that was stitched.

Bias

Use the Bias value to blend the CVs between the input surface to the 
stitch node and the result from the stitch operation. A value of 0 has 
no effect.

Fix Boundary

You can use the Fix Boundary option only if the Cascade Stitch Nodes 
option and tangent continuity were on during the stitch operation.

While Maya creates tangent continuity across all four edges, the 
position of eight CVs might be modified (two boundary CVs next to 
each of the four surface corners). This might cause position 
discontinuity.

To prevent this, turn on Fix Boundary to ensure the eight CVs stay 
unmodified.
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Setting point constraint options for stitched edit points

If you stitched edit points together, the Point Constraints options are 
available.

Parameter U/V

Enter values in the Parameter U and Parameter V boxes to adjust the 
U or V parameters of the edit points you used to stitch the surface.

Position/Normal

The Position and Normal information is read-only. These values 
indicate in which XYZ direction the edit points and surface normals 
are located.

Setting CV positions for stitched CVs

If CVs are stitched together, the Override CV Position options are 
available.

CV Index boxes

The CV Index boxes in the Override CV position section let you 
override the default position of the CVs you used to stitch a surface 
together.

CV Position

The CV Position values indicate in which XYZ direction the CVs are 
located.

Edit NURBS > Stitch > Stitch Edges Tool

Related topics

� ”Manually stitch surface edges together” on page 185

Edit NURBS > Stitch > Stitch Edges Tool > �

Blending

Position stitches the surfaces with position continuity.

Tangent stitches the surfaces with tangent continuity.

Note Other attributes displayed in the Attribute Editor depend on the 
type of surface points you stitched. Information on the possible 
attributes follows.
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Weighting on Edge

Before stitching the edges, the two selected isoparms are averaged in a 
weighted mode. The two surfaces are modified to meet along this 
averaged isoparm with tangent continuity. You can assign weights to 
the selected isoparms. 

By default, weights of 1.0 and 0.0 are assigned to the first and second 
selected isoparms. In effect, this modifies the CVs on the second 
surface so the surface has tangent continuity with the first surface. If 
you assign a nonzero weight to the two selected isoparms, the CVs on 
both surfaces are modified to achieve tangent continuity. 

You can modify the weights after creating the stitch with construction 
history turned on. Select the avgCurve node created during stitching, 
then display the Attribute Editor. 

You can drag the manipulators to selectively alter the portions along 
the isoparms to be weighted together. These are the portions on the 
two surfaces that will be stitched together.

Note The Stitch Tool does not change the number of CVs or the UV 
parameterization. It modifies the CV positions to have as much 
position and tangent continuity as possible.

Tip To see the curve computed by the average node, select the Show 
Manipulator Tool on the average node. This manipulator provides 
a visual clue only and cannot be edited.

weight = 1.0 (default) weight = 0.5
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Samples Along Edge

The CVs for the stitched surface are determined by sampling the edge 
along the surface that needs to be modified for tangent continuity. 
You can explicitly set Samples Along Edge to close any position gaps 
on the stitched surface. The higher the count, the slower the 
performance. This is the same as Step Count for the stitchSrf node in 
the Channel Box and Attribute Editor.

Cascade Stitch Node

If Cascade Stitch Node is on, the stitch operation ignores any prior 
stitch operations on the surface. If turned off and the surface has had a 
stitch operation performed on it, the stitch node from the previous 
operation is used. The default is on.

Keep Original

If Keep Original is on, the stitch surface is created on top of the 
original input surfaces. This way, you can move the resulting surface 
if you are not satisfied with the result and restitch a new surface with 
different option settings. 

If off, the stitch operation replaces the surface being stitched. 

Continuity

Type on or off in the Continuity boxes to set position or tangent 
continuity for the stitch surface. 

Step Count

Step Count is the same as Samples Along Edge in the options 
window. 

Bias

Use the Bias value to blend the CVs between the input surface to the 
stitch node and the result from the stitch operation. A value of 0 has 
no effect.

Fix Boundary

You can use the Fix Boundary option only if the Cascade Stitch Nodes 
option and tangent continuity were on during the stitch operation. 
While Maya creates tangent continuity across all four edges, the 
position of eight CVs might be modified (two boundary CVs next to 
each of the four surface corners). This might cause position 
discontinuity. To avert this, turn on Fix Boundary to ensure the eight 
CVs stay unmodified.
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Tolerance Controls

If Toggle Tolerance is off (the default setting), the Step Count 
(Samples Along Edge) is used as the tolerance value. If on, you can set 
a specific tolerance value.

Edit NURBS > Stitch > Global Stitch

Related topics

� ”Automatically stitch multiple surfaces together” on page 183

Edit NURBS > Stitch > Global Stitch > �

Stitch Corners

The Stitch Corners options specify where a surface corner is stitched 
to an adjacent corner or surface edge. Regardless of which option you 
choose, stitching occurs only if the points are within the Max 
Separation distance.

Stitching occurs at a point between two corners or between a corner 
and a point on the surface edge. Where a corner would stitch to a 
point on an edge rather than a corner, the following options are 
available.

Closest Point stitches a corner to the closest point on the edge. 

Closest Knot stitches a corner to the closest knot on the edge.

Off does no explicit corner stitching. 

Stitch Edges

The Stitch Edges options specify where adjacent edges are stitched 
together. Regardless of which option you choose, stitching occurs only 
if the edges are within the Max Separation distance. Stitching occurs 
along an imaginary line midway between the edges. 

Surfaces before 
Global Stitch

Closest Point Closest Knot
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Closest Point stitches the closest points on the edges while ignoring 
parameterization differences between the edges. Because the number 
of patches may differ, an exact join might not occur. 

Equal Params stitches points on the surface edges that have 
equivalent UV increments along each edge. The number of spans is 
ignored. To achieve the best possible fit with this type of stitching, 
make sure the two edges have the same UV values, the same number 
of spans, and lined-up knots.

Off does no explicit edge stitching. If you turn on one of the Stitch 
Corners options (other than Off) and set Stitch Edges to Off, the 
corners will be stitched together, but not the edges.

Stitch Smoothness

Tangents bends isoparms so they are perpendicular where they meet 
the stitched edge. This yields the best continuity between the surfaces. 

Normals does not require the isoparms to be perpendicular, though 
the surfaces still join smoothly.

Off turns off smoothing and doesn’t ensure tangency of the edge 
regions. 

Surfaces before 
Global Stitch

Closest Point Equal Params

Surfaces before 
Global Stitch

Tangents Normals
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Stitch Partial Edges

If this option is on, Maya joins any parts of an edge pair that are 
within the Max Separation distance. The same pair of edges may 
therefore join and separate a number of times along their length. If 
this option is off, no part of the edge pair will be stitched if any points 
along the edges exceed the Max Separation distance. 

Do not turn on Stitch Partial Edges when unnecessary. This option 
takes extra processing time.

Max Separation

Specifies how close surface edges and corners must be for them to be 
stitched. High values might stitch more points than you want. Low 
values might cause the stitch operation to fail.

Note You can use Stitch Corners, Stitch Edges, and Stitch Smoothness in 
any combination to create a variety of stitching results. If Stitch 
Smoothness is Off but one of the Stitch Edges options is on, the 
edges will touch, but the stitched region between the edges might 
not be smooth.

Stitch Partial Edges 

turned on.

Surfaces before 

Global Stitch

Only points near the 

left edges are within 

the Max Separation 

distance.

Most points along 

the edges are within 

the Max Separation 

distance.
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Modification Resistance

Specifies how much the surface CVs hold their positions when you 
stitch the surfaces. Increase this value to smooth waviness in the 
stitched surface. Don’t increase the value too much or the surface joins 
might not be smooth.

Sampling Density

Sets how many points along each edge Maya samples during the 
stitch operation. Increasing the Sampling Density might improve the 
fit, but it slows the stitch operation. Start with the lowest value (1) and 
increase it only if the fit is poor. Values over 5 are typically 
unnecessary.

Lock surfacen

The Lock Surfaces section of the Attribute Editor displays two or more 
attributes named Lock surface n. Each represents one of the surfaces 
stitched. 

If you turn on this option for any of the surfaces, that surface doesn’t 
change shape in the resulting stitched surface. Instead, the surface 
stitched to this surface is altered. 

If you turn on this option for two adjacent stitched surfaces, they 
might appear unstitched. They’re still part of the globalStitchn node, 
so you can turn off Lock surface for either surface and the stitching is 
displayed again.

Note After you stitch surfaces, you can move the original surfaces 
outside the Max Separation range without breaking the stitch. Loss 
of continuity and distortion might occur if you separate the 
surfaces too much.

If the original surfaces are far apart and you edit attributes on the 
globalStitchn node, the stitch will be recomputed based on the new 
positions of the surfaces. Edges formerly stitched may fail to 
produce results. Return surfaces to their original positions before 
editing attributes that specify how the surfaces are stitched.
NURBS Modeling 

194



7 | The Sculpt Surfaces tool
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7 The Sculpt Surfaces 
tool

About NURBS

The Sculpt Surfaces tool

Using the Sculpt Surfaces Tool, you can move CVs quickly with the stroke 
of a brush. You simply paint the surface with the Sculpt Surfaces Tool to 
push and pull CVs to achieve the shape you want.

You can perform four different operations using the Sculpt Surfaces Tool: 
push, pull, smooth, and erase.

Push/pull

You can push or pull a surface in a configurable direction in the shape of 
the tool.

Transforming vertices using the Sculpt 
Surfaces Tool.

Push Pull
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Reference surface

All sculpting you do pushes or pulls CVs from their initial positions on 
the reference surface. The Maximum Displacement options controls how far 
CVs can get from the reference surface.

In this example, the two strokes both raise the surface to the maximum 
displacement distance, but not beyond it.

If you update the reference surface, the current state becomes the 
reference, and further sculpting will displace CVs from it.

In this example, after the first stroke, the user updates the reference 
surface. The second stroke then applies the maximum displacement to it, 
going over the first stroke, which is now “baked onto” the reference 
surface.

You can update the reference surface manually, or set the Update on Each 
Stroke option to bake each stroke onto the reference as you finish the 
stroke.

Smoothing

You can paint over bumps to smooth them out.

Second strokeFirst stroke

First stroke. Second stroke.

Before smoothing After smoothing
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About > The Sculpt Surfaces tool
Erasing

You can save the state of a surface and then later “erase” changes to the 
surface back to the saved state.

You can also turn on an option to save erase state after every stroke, 
which allows you to erase only the last stroke you made.

Surface density

Generally you should try to minimize the number of isoparms in your 
surfaces. However, when using the Sculpt tool, the more isoparms a 
surface has, the more precisely it deforms to the shape of the sculpting 
brush.

Sculpting and construction history

• When you sculpt surfaces that have construction history, Maya’s 
performance can slow down.

• Editing the history of a surface that has been sculpted can give 
unexpected results.

If you don’t need to keep the history of the surface, consider deleting the 
history (select the surface and choose Edit > Delete by Type > History).

The Sculpt Surfaces Tool does not create construction history of its own.

Sculpting across seams and surface edges

In Maya, you can stitch two surfaces so they maintain their common 
edges. You can then sculpt across the surfaces and Maya will keep the 
seam together.

� ”Sculpt across seams and surface edges” on page 200

High isoparm densityLow isoparm density
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How do I? Create and edit models

Reshape NURBS surfaces with the Sculpt 
Surfaces tool

Push or pull a surface with the Sculpt 
Surfaces tool

To sculpt surfaces by pushing and pulling CVs with a brush

1 Select the surface, surfaces or CVs you want to sculpt.

2 Choose Edit NURBS > Sculpt Surfaces Tool > ❐.

3 Under Operation, click Push or Pull.

4 Use the options under Sculpt Parameters to control how brushing 
pushes or pulls the surface.

5 Do any of the following:

• Brush across the surface to push or pull CVs.

• Hold b and drag left or right to change the brush radius.

• Hold m and drag left or right to change how far the tool moves 
the surface.

To apply a push/pull action to the entire surface at once

1 In the Sculpt Surfaces option panel, set the options you want to apply 
to the entire surface.

2 Under Sculpt Parameters, click the Flood button.

Tips

• To retain control while sculpting, keep the Opacity and Max 
Displacement low and build up sculpting gradually.

Smooth a surface with the Sculpt Surfaces 
tool

To smooth surfaces with a brush

1 Select the surface, surfaces or CVs you want to sculpt.

2 Choose Edit NURBS > Sculpt Surfaces Tool > ❐.

3 Under Operation, click Smooth.

4 Use the options under Sculpt Parameters to control how brushing 
smooths the surface.
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5 Do any of the following:

• Brush across the surface to push or pull CVs.

• Hold b and drag left or right to change the brush radius.

• Hold m and drag left or right to change how much the tool moves 
the surface as it smooths.

To apply a smooth action to the entire surface at once

1 In the Sculpt Surfaces option panel, set the options you want to apply 
to the entire surface.

2 Under Sculpt Parameters, click the Flood button.

Tips

• To progressively smooth a model, use the Flood button with Smooth 
as the selected operation, and set the opacity low.

Selectively erase back to a previous state with 
the Sculpt Surfaces tool

To save a state and then erase back to it

1 Make sure the Update on Each Stroke option next to Erase Surface (at 
the bottom of the Sculpt Parameters section) is off.

2 When you want to save the current state of a sculpted surface, click 
the Update button next to Erase Surface.

3 When you want to paint back to the saved state, set Operation to 
Erase.

To be able to paint out only the effects of your last stroke

1 Turn on the Update on Each Stroke option next to Erase Surface (at 
the bottom of the Sculpt Parameters section).

2 When you want to paint out part of the last stroke, set Operation to 
Erase.

Sculpt according to an attribute map

When you import an attribute map to a surface using the Sculpt Surfaces 
tool, Maya applies the tool settings to the CVs, mapping the greyscale 
values to the Opacity value set for the tool.

In the following example, the Sculpt Surfaces Tool is set to Pull with a 
stroke displacement of 2.
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Sculpt across seams and surface edges

Maya can keep the seam of a closed surface and common edges of 
adjacent surfaces (that have been stitched with Edit NURBS > Stitch > 
Global Stitch) together as you sculpt across them.

Keyframe sculpting changes

1 Select the CVs you want to keyframe.

2 Rewind to the first frame of the animation.

3 In the Preferences window (Window > Settings/Preferences > 
Preferences), click the Keys category and turn on Auto Key.

4 Set a key.

5 Move to the end frame of the sculpting animation.

6 Select the surface and choose Edit NURBS > Sculpt Surfaces Tool. 
Sculpt the surface into the shape you want.

The Auto Key option will set keyframes for the CVs the Sculpt 
Surfaces tool moves.

You can repeat this process at other frames to morph from one sculpted 
state to another.

Mapped surface.

U

V

U

V Attribute map.
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Reference > Edit NURBS > Sculpt Surfaces Tool
Reference Menus

Modeling menu set

Edit NURBS

Edit NURBS > Sculpt Surfaces Tool

Use this tool to sculpt NURBS surfaces. See “How Artisan brush tools 
work” in the Paint Effects, Artisan, and 3D Paint guide.

Related topics

� ”The Sculpt Surfaces tool” on page 195

� ”Push or pull a surface with the Sculpt Surfaces tool” on page 198

� ”Smooth a surface with the Sculpt Surfaces tool” on page 198

� ”Selectively erase back to a previous state with the Sculpt Surfaces 
tool” on page 199

� ”Sculpt according to an attribute map” on page 199

� ”Sculpt across seams and surface edges” on page 200

Polygons > Sculpt Surfaces Tool > �

Lets you specify the settings for the Sculpt Surfaces Tool in the Tool 
Settings editor. There are attributes unique to the Sculpt Surfaces Tool in 
the Sculpt Parameters sections. These unique attributes are described 
below. For descriptions of all other attributes in all other sections, see 
“Common Artisan Brush Tool Settings” in the Paint Effects, Artisan, and 
3D Paint guide.

Sculpt Parameters

These are descriptions of the attributes in the Sculpt Parameters section.

Operation

Select Push, Pull, Smooth, or Erase. A letter appears within the brush 
stamp to reflect the operation: Ps (Push), Pl (Pull), Sm (Smooth) or E 
(Erase).

To remove the letters from the brush stamp, open the Sculpt Surface 
Tool Settings window, click the Display section, and turn off Draw 
Brush Feedback.
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Reference > Edit NURBS > Sculpt Surfaces Tool
Auto Smooth

If you selected Push or Pull as the brush operation, turn Auto Smooth 
on to smooth the surface automatically after every brush stroke. 

Auto Smooth Strength

Sets the number of times the Sculpt Surface Tool smooths the surface 
for each push, pull, or smooth stroke. Higher numbers speed the 
smoothing.

Reference Vector

The reference vector controls the direction the CVs move when you 
push or pull. The brush arrow represents the reference vector.

Normal moves CVs in the direction of the surface normal. 

First Normal moves CVs in the surface normal direction at the 
beginning of the stroke.

View moves CVs parallel to the camera view direction. 

Tip To select a brush operation from a marking menu, press your 
keyboard’s u key while dragging the mouse.
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Reference > Edit NURBS > Sculpt Surfaces Tool
X Axis moves CVs in the direction of the X axis only, not the Y or Z 
axis. 

Y Axis moves CVs in the direction of the Y axis only, not the X or Z 
axis.

Z Axis moves CVs in the direction of the Z axis only, not the X or Y 
axis.

U moves CVs in the direction of the U isoparm.

Tumble the view 
to see the effect
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Reference > Edit NURBS > Sculpt Surfaces Tool
V moves CVs in the direction of the V isoparm.

Max Displacement

Sets the maximum possible depth or height of the brush stroke. (The 
actual displacement of the brush stroke is based on how hard you 
press with the stylus and on the Opacity value.)

Seam/Pole Tolerance

Set how close the vertices must be along an edge, and how close the 
edges on the same surface must be to each other before they are 
detected as common. This is most commonly used to detect poles on 
surfaces like spheres.

Flood

Applies the Operation to all selected vertices.

When Operation is Push or Pull, Flood applies the maximum 
displacement to all selected vertices.

When Operation is Smooth, Flood smooths all selected vertices.

When Operation is Erase, selected vertices are restored to their last 
saved state.

Tip To avoid overlapping isoparms when you sculpt along the U or V 
isoparms, use a softer brush shape and keep the displacement 
small.
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Reference > Edit NURBS > Sculpt Surfaces Tool
Reference Surface

Update on each stroke bakes or updates the surface automatically on 
each stroke. For a description of reference surfaces, see ”Reference 
surface” on page 196. To update the reference surface manually, click 
Update.

Erase Surface

Update on each stroke updates the erase surface automatically on 
each stroke. To update the erase surface manually, click Update.
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Reference > Edit NURBS > Sculpt Surfaces Tool
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How do I? > Switch NURBS operations between actions and tools
8 Customization

How do I? Customize Maya

Switch NURBS operations between actions 
and tools

Almost all items under the Edit Curves, Surfaces, and Edit NURBS menus 
can be converted from actions to tools (or vice versa). You can distinguish 
tools from actions by the names of menu items. Tools have Tool in the 
menu entry title. Actions do not. For example, the Curve Editing Tool is a 
tool, but the Attach Curves menu item is an action. 

If you change an action to a tool, Maya adds Tool to its name in the main 
menu and option window. If you change the tool back to an action, Tool is 
removed from the name. Regardless of whether a feature is a tool or 
action, the order in which you select objects or components stays the 
same.

You can change actions to tools throughout Maya or individually. To 
change the preference throughout Maya, choose Window > Settings/
Preferences > Preferences. In the Categories list of the Preferences 
window, click Modeling, then turn on Everything is a Tool. 

Afterwards, you’ll notice more NURBS menu items have Tool in their 
names. To return to action-based behavior, turn on Everything is an 
Action in the same Preferences window.

If you turn on Mixed, a setting within each option box specifies whether 
the menu item is a tool or action.

To convert a single menu item from action to tool, open its options 
window and select Edit > As Tool. To return to action-based behavior, 
select Edit > As Action. If the options window doesn’t have an Edit menu 
or the As Tool and As Action items are dim, the action (or tool) can’t be 
converted.

The setting in the Options window takes precedence over the Preferences 
window. Changing from actions to tools or vice versa works immediately.

When you use an action converted to a tool, Maya sets an object and 
component selection mask appropriate for the tool. Maya returns to the 
prior selection mask after you finish using the tool.
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Tool options

If you change an action to a tool, the options window for that tool displays 
two extra options:

• Exit Upon Completion

If this option is off, Maya’s focus remains on the tool after you finish 
using it. You can use the tool repeatedly without selecting it again. 

If this option is on, Maya exits the tool. The following menu items, 
when used as tools, have Exit Upon Completion as the default option.

• Edit Curves > Cut Curve Tool

• Edit Curves > Intersect Curves Tool

• Edit NURBS > Stitch > Global Stitch Tool

All other tools, including actions converted to tools, use Auto 
Completion as the default.

• Auto Completion

If this option is on, you don’t have to press to finish a modeling task. 
The tool completes its task as soon as you select enough objects or 
components.
NURBS Modeling 

208



Index
Numerics
0 to # spans

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 166
0 to 1 spans

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 166
3D text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
3D World

Intersect Surfaces option  . . . . . . . . . . . . . . . . . 180

A
actions

changing to tools . . . . . . . . . . . . . . . . . . . . . . . . 207
Active View

Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 126
Project Curve On Surface option. . . . . . . . . . . 177

Add Points Tool (Edit Curves menu) . . . . . . . . . . 126
Align Curves (Edit Curves menu) . . . . . . . . . . . . . 131
align surfaces  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104
Align Surfaces (Edit NURBS menu)  . . . . . . . . . . . 153
align the ends of two curves. . . . . . . . . . . . . . . . . . 103
All Curves

Intersect Curves option. . . . . . . . . . . . . . . . . . . 134
Along Curve

Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 86

Along Extrusion
Bevel Plus options . . . . . . . . . . . . . . . . . . . . . . . . 86

animating
sculpting changes  . . . . . . . . . . . . . . . . . . . . . . . 200

arc
edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
three-point, create . . . . . . . . . . . . . . . . . . . . . . . . 29
two-point, create  . . . . . . . . . . . . . . . . . . . . . . . . . 29

Arc Tools (Create menu) . . . . . . . . . . . . . . . . . . . . . . 34
As Selected

Boundary option  . . . . . . . . . . . . . . . . . . . . . . . . . 76
As Tool

NURBS action or tool option . . . . . . . . . . . . . . 207

Assign Equal Weights
Stitch Surface Points option . . . . . . . . . . . . . . . 187

At All Intersections
Cut Curve option . . . . . . . . . . . . . . . . . . . . . . . . 133

At End
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 83

At Path
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

At Profile
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

At Start
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 83

Attach
Align Curves option . . . . . . . . . . . . . . . . . . . . . 131
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 153

Attach Curves (Edit Curves menu) . . . . . . . . . . . . 128
attach curves or surfaces together . . . . . . . . . . . . . 110
Attach Method

Attach Curves option . . . . . . . . . . . . . . . . . . . . 128
Attach Surfaces option . . . . . . . . . . . . . . . . . . . 150

Attach Surfaces
Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 83

Attach Surfaces (Edit NURBS menu) . . . . . . . . . . 150
Attach Without Moving (Edit NURBS menu) . . . 151
Attribute Editor

viewing loft history . . . . . . . . . . . . . . . . . . . . . . . 64
attribute map

sculpt according to  . . . . . . . . . . . . . . . . . . . . . . 199

Auto Anchor
Fillet Blend attribute . . . . . . . . . . . . . . . . . . . . . . 95

Auto Closed Rail Anchor
Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 94

Auto Completion
Birail option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
tool option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 208

Auto Normal
Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 93

Auto Normal Dir
Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 92

Auto Reverse
Loft option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Auto Smooth
Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 202

Auto Smooth Strength
Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 202

Automatic
Boundary option . . . . . . . . . . . . . . . . . . . . . . . . . 76
NURBS Modeling

209



Index
Axis
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

axis
primitive, change direction of . . . . . . . . . . . . . . 54
rotate curve around to create a surface  . . . . . . 46

Axis Preset
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

B
Bend (Modify Curves tool) . . . . . . . . . . . . . . . . . . . 145
Bend Amount . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146
Bevel (Surfaces menu) . . . . . . . . . . . . . . . . . . . . . . . . 79
bevel a surface from a curve. . . . . . . . . . . . . . . . . . . 47
Bevel Cap

Bevel options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Bevel Corners

Bevel options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Bevel Depth

Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 83

Bevel Plus
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48

Bevel Plus (Surfaces menu)  . . . . . . . . . . . . . . . . . . . 82
Bevel Style

Bevel Plus options . . . . . . . . . . . . . . . . . . . . . . . . 84
Bevel Width

Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 83

Bezier
Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 166

Bias
Curve Fillet option. . . . . . . . . . . . . . . . . . . . . . . . 37
Freeform Fillet option . . . . . . . . . . . . . . . . . . . . . 91

Stitch Edges Tool option. . . . . . . . . . . . . . 187, 190
Birail (Surfaces menu) . . . . . . . . . . . . . . . . . . . . . . . . 73
Birail action . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Blend
Attach Curves option  . . . . . . . . . . . . . . . . . . . . 128
Attach Surfaces option  . . . . . . . . . . . . . . . . . . . 150
Curve Fillet option. . . . . . . . . . . . . . . . . . . . . . . . 36
Open/Close Surfaces option . . . . . . . . . . . . . . 160

Blend Bias
Attach Curves option . . . . . . . . . . . . . . . . . . . . 129
Attach Surfaces option . . . . . . . . . . . . . . . . . . . 150
Open/Close Curve option . . . . . . . . . . . . . . . . 133

Open/Close Surfaces option . . . . . . . . . . . . . . 160
Blend Control

Curve Fillet option  . . . . . . . . . . . . . . . . . . . . . . . 36

Blend Shape
Open/Close Curve option . . . . . . . . . . . . . . . . 133

Boolean operations
perform on surfaces  . . . . . . . . . . . . . . . . . . . . . 175

Booleans (Edit NURBS menu) . . . . . . . . . . . . . . . . 181
Both

Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80
Reverse Surface Direction option . . . . . . . . . . 163

Both Surfaces
Intersect Surfaces option  . . . . . . . . . . . . . . . . . 180

Bottom Side
Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Boundary (Surfaces menu) . . . . . . . . . . . . . . . . . . . . 76
boundary curves

create surface from  . . . . . . . . . . . . . . . . . . . . . . . 46

create surface within . . . . . . . . . . . . . . . . . . . . . . 44

fillet between  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Break Tangent. . . . . . . . . . . . . . . . . . . . . . . . . . 115, 116
brush

sculpt surfaces with. . . . . . . . . . . . . . . . . . . . . . 198
smooth surfaces with  . . . . . . . . . . . . . . . . . . . . 198

brush stamps
selecting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 201

brushes
stamps . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 201

B-splines
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
fitting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

C
cap, extruded surface  . . . . . . . . . . . . . . . . . . . . . . . . 43
caps

bevels. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
for cones  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
for cylinders . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
NURBS Modeling 

210



Index
Cascade Stitch Node
Stitch Edges Tool option. . . . . . . . . . . . . . . . . . 190
Stitch Surface Points option . . . . . . . . . . . . . . . 187

Chord Height
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 87

Chord Length
knot spacing for Loft option  . . . . . . . . . . . . . . . 62

knots for CV curves . . . . . . . . . . . . . . . . . . . . . . . 32
knots for edit point curves . . . . . . . . . . . . . . . . . 33
parameterization, about . . . . . . . . . . . . . . . . . . . 15

circle
create . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Circular
Curve Fillet option. . . . . . . . . . . . . . . . . . . . . . . . 36
Extend Curve on Surface option . . . . . . . . . . . 125

Extend Curve option . . . . . . . . . . . . . . . . . . . . . 123
Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 127

Circular Arcs
Bevel corner option . . . . . . . . . . . . . . . . . . . . . . . 81

circular fillet
create . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
curve, create . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Circular Fillet (Edit NURBS > Surface Fillet) . . . . . 88
Close

Loft option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

closed curves
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119

closed surfaces
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119

Closest End Point
Extrude pivot option . . . . . . . . . . . . . . . . . . . . . . 70

Closest Knot (Corners)
Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 191

Closest Point (Corners)
Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 191

Closest Point (Edges)
Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 192

Cluster Curve . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148
Common End Points

Boundary options  . . . . . . . . . . . . . . . . . . . . . . . . 77

Complete curve range
Bevel  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 128
Planar option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Project Curve On Surface . . . . . . . . . . . . . . . . . 179
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

complex curves. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
complexity, reduce for a curve or surface  . . . . . . 114
Component

Extrude pivot option . . . . . . . . . . . . . . . . . . . . . . 70
components

curves  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
of surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

Concave
Bevel cap option  . . . . . . . . . . . . . . . . . . . . . . . . . 81

cones
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Connect
Attach Curves option . . . . . . . . . . . . . . . . . . . . 128
Attach Surface option . . . . . . . . . . . . . . . . . . . . 150

Connect Breaks
Offset Curve options . . . . . . . . . . . . . . . . . . . . . 126

Construction
Curve Fillet options. . . . . . . . . . . . . . . . . . . . . . . 36

construction history
and sculpting . . . . . . . . . . . . . . . . . . . . . . . . . . . 197

Continuity
Align Curves option . . . . . . . . . . . . . . . . . . . . . 131
Align Surfaces options  . . . . . . . . . . . . . . . . . . . 154
Birail option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Stitch Edges Tool option. . . . . . . . . . . . . . . . . . 190

continuity
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
curvature. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
maintain for Square operation. . . . . . . . . . . . . . 46
positional, change for stitch . . . . . . . . . . . . . . . 188

tangent, change for stitch . . . . . . . . . . . . . . . . . 188

Continuity Type
Square options . . . . . . . . . . . . . . . . . . . . . . . . . . . 78

control hull . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
control vertices (CVs)  . . . . . . . . . . . . . . . . . . . . . . . . 22
Convex

Bevel cap option  . . . . . . . . . . . . . . . . . . . . . . . . . 81
NURBS Modeling

211



Index
copy and offset a curve or surface . . . . . . . . . . . . . 112
Corners

Rebuild Surfaces option, keep . . . . . . . . . . . . . 166

Create Bevel
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 83

Create Cap
Bevel Plus options . . . . . . . . . . . . . . . . . . . . . . . . 84

Create Curve On Surface
Circular Fillet option . . . . . . . . . . . . . . . . . . . . . . 89

Create Curves for
Intersect Surfaces option  . . . . . . . . . . . . . . . . . 179

Create menu
Arc Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
CV Curve Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
EP Curve Tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
NURBS Primitives . . . . . . . . . . . . . . . . . . . . . . . . 53
Pencil Curve Tool  . . . . . . . . . . . . . . . . . . . . . . . . 34

cross knot insertion . . . . . . . . . . . . . . . . . . . . . . . . . . 25
cubes

creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
Cubic

Planar option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
primitive sphere option  . . . . . . . . . . . . . . . . . . . 54

Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

surface degree Extrude option. . . . . . . . . . . . . . 69
cubic curves  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Cubic surface degree

Loft option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Curl (Modify Curves tool)  . . . . . . . . . . . . . . . . . . . 145
Curl Amount. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145
Curl Frequency . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145
Curvature

about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Align Curves option . . . . . . . . . . . . . . . . . . . . . 131
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 155
Project Tangent option . . . . . . . . . . . . . . . . . . . 141
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 137

curvature (G2) continuity . . . . . . . . . . . . . . . . . . . . . 20

curvature continuity  . . . . . . . . . . . . . . . . . . . . . . . . . 13
align curves with . . . . . . . . . . . . . . . . . . . . . . . . 131

align surfaces with. . . . . . . . . . . . . . . . . . . . . . . 155

curvature continuous
make a curve with a curve intersection . . . . . 102
make a curve with a surface  . . . . . . . . . . . . . . 102

make a curve with another curve . . . . . . . . . . 103
Curvature Scale

Align Curves option . . . . . . . . . . . . . . . . . . . . . 132
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 156
Project Tangent option . . . . . . . . . . . . . . . . . . . 142

Curve Div per Span option  . . . . . . . . . . . . . . . . . . 122

Curve Editing tool
options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
reshape curve with  . . . . . . . . . . . . . . . . . . . . . . 100

Curve Fillet (Edit Curves menu) . . . . . . . . . . . . . . . 35
Curve Fit Checkpoints

Square options . . . . . . . . . . . . . . . . . . . . . . . . . . . 79
Curve Parameters

Curve Fillet option  . . . . . . . . . . . . . . . . . . . . . . . 37

Curve Range
Bevel options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Extrude options . . . . . . . . . . . . . . . . . . . . . . . . . . 73
Loft option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Offset Curve options . . . . . . . . . . . . . . . . . . . . . 128
Planar options  . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Project Curve On Surface options . . . . . . . . . . 179
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

curve segments
change for Arc Tools . . . . . . . . . . . . . . . . . . . . . . 34

curve-on-surface
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 172
creating with intersection . . . . . . . . . . . . . . . . . 179
definition. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 171
extend a certain distance  . . . . . . . . . . . . . . . . . 107
extend to exact coordinates . . . . . . . . . . . . . . . 108
use to create a curve  . . . . . . . . . . . . . . . . . . . . . . 28
NURBS Modeling 

212



Index
curves
add spans  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117
add to a lofted surface. . . . . . . . . . . . . . . . . . . . . 41
align ends . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
align with a curve or surface . . . . . . . . . . . . . . 102
attach . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

bounding, create surface from . . . . . . . . . . . . . . 44

change degree, for edit point . . . . . . . . . . . . . . . 33
change degree, number of spans/patches . . . 118
circles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
closed . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
complex . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
convert to uniform parameterization . . . . . . . 117

create from a surface component curve . . . . . . 28
create from Degree 1 curve  . . . . . . . . . . . . . . . . 31
create on intersection of surfaces  . . . . . . . . . . 173
creating trimmed surfaces  . . . . . . . . . . . . . . . . . 66
cubic. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
detach  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

divisions per span . . . . . . . . . . . . . . . . . . . . . . . 122
draw by placing CVs. . . . . . . . . . . . . . . . . . . . . . 27
draw by placing edit points . . . . . . . . . . . . . . . . 27
draw freehand  . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
extend a certain distance  . . . . . . . . . . . . . . . . . 107
extend to exact coordinates  . . . . . . . . . . . . . . . 108
extend with move CVs . . . . . . . . . . . . . . . . . . . 107
extrude and bevel a surface from  . . . . . . . . . . . 47

fillets, create from two curves . . . . . . . . . . . . . . 30
fillets, trim. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

intersecting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134

linear  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
make open or closed . . . . . . . . . . . . . . . . . . . . . 119
match end points . . . . . . . . . . . . . . . . . . . . . . . . . 77
match topology  . . . . . . . . . . . . . . . . . . . . . . . . . 120

mathematical representations . . . . . . . . . . . . . . 12
multiple end knots. . . . . . . . . . . . . . . . . . . . . . . . 32
of components  . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
offset copy. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112
open . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

periodic . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
planning for surfaces. . . . . . . . . . . . . . . . . . . . . . 25
profile, used to make surfaces . . . . . . . . . . . . . . 40
project on surface along surface normals. . . . 173
projecting on surface . . . . . . . . . . . . . . . . . . . . . 172
quadratic . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
quality . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
reduce complexity . . . . . . . . . . . . . . . . . . . . . . . 114

reshape  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
resulting, editing attributes . . . . . . . . . . . . . . . 130
reverse normals . . . . . . . . . . . . . . . . . . . . . . . . . 113
rotate around an axis to create a surface . . . . . 46
seam. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

simplest . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
smoothing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105
square  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
trimming . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134
uniform knot spacing . . . . . . . . . . . . . . . . . . . . . 32

Curves On Surface
Intersect Surfaces option  . . . . . . . . . . . . . . . . . 180

Custom
NURBS Smoothness option . . . . . . . . . . . . . . . 122

customizing menus to tools . . . . . . . . . . . . . . . . . . 207
Cut Curve . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111
Cut Curve (Edit Curves menu)  . . . . . . . . . . . . . . . 133
Cutting Radius

Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 127
CV Curve Tool (Create menu) . . . . . . . . . . . . . . . . . 32
CV Hardness (Edit Curves menu). . . . . . . . . . . . . 139
CV Index

Stitch Surface Points option . . . . . . . . . . . . . . . 188

CV Position
Stitch Surface Points option . . . . . . . . . . . . . . . 188

CVs
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
add more by inserting edit points/isoparms  111
add to end of curve . . . . . . . . . . . . . . . . . . . . . . 107
control multiplicity . . . . . . . . . . . . . . . . . . . . . . 115
manipulate to sculpt surfaces  . . . . . . . . . . . . . 198
move on a curve or surface  . . . . . . . . . . . . . . . . 99
multiplicity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

Rebuild Curve, Keep option  . . . . . . . . . . . . . . 138

Rebuild Surfaces option, keep . . . . . . . . . . . . . 166

surface component  . . . . . . . . . . . . . . . . . . . . . . . 26
use to draw a curve . . . . . . . . . . . . . . . . . . . . . . . 27
versus edit points  . . . . . . . . . . . . . . . . . . . . . . . . 23

cylinders
create . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
NURBS Modeling

213



Index
D
Degree

Planar option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 138

degree
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
change for Arc Tools . . . . . . . . . . . . . . . . . . . . . . 34
change for curves. . . . . . . . . . . . . . . . . . . . . . . . . 32
change for curves, surfaces  . . . . . . . . . . . . . . . 118
change for edit point curve  . . . . . . . . . . . . . . . . 33
change for pencil curve. . . . . . . . . . . . . . . . . . . . 34
of a polynomial equation . . . . . . . . . . . . . . . . . . 12

Degree 1 (linear) curves  . . . . . . . . . . . . . . . . . . . . . . 13
Degree 2 (quadratic) curves . . . . . . . . . . . . . . . . . . . 13
Degree 3 (cubic) curves . . . . . . . . . . . . . . . . . . . . . . . 13
Degree 3 curve

create to match scan data . . . . . . . . . . . . . . . . . . 31
degree type

geometry, changing. . . . . . . . . . . . . . . . . . . . . . . 54
Degree U/V

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 167
Delete Inputs

Booleans option . . . . . . . . . . . . . . . . . . . . . . . . . 182
density of isoparms, changing . . . . . . . . . . . . . . . . 197

Depth
Curve Fillet option. . . . . . . . . . . . . . . . . . . . . . . . 36
Freeform Fillet option . . . . . . . . . . . . . . . . . . . . . 91

Detach Curves (Edit Curves menu)  . . . . . . . . . . . 130
detach curves or surfaces . . . . . . . . . . . . . . . . . . . . 111
Detach Surfaces (Edit NURBS menu) . . . . . . . . . . 151
Direction

Detach Surfaces option . . . . . . . . . . . . . . . . . . . 152

Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Insert Isoparms option  . . . . . . . . . . . . . . . . . . . 163
Rebuild Surfaces options  . . . . . . . . . . . . . . . . . 166

Direction Vector
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Discard
Trim Tool option . . . . . . . . . . . . . . . . . . . . . . . . 180

Display menu
NURBS Smoothness  . . . . . . . . . . . . . . . . . . . . . 121

display quality, customize  . . . . . . . . . . . . . . . . . . . 122

Display Render Tesselation Geometry
NURBS Smoothness option . . . . . . . . . . . . . . . 123

Distance
Extend Curve option . . . . . . . . . . . . . . . . . . . . . 123
Extend Surfaces . . . . . . . . . . . . . . . . . . . . . . . . . 148
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

divisions per span, curve  . . . . . . . . . . . . . . . . . . . . 122
drawing curves. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Duplicate NURBS Patches (Edit NURBS menu) . . 87
Duplicate Surface Curves (Edit Curves menu) . . . 34

E
edges

lock on surfaces (stitch)  . . . . . . . . . . . . . . . . . . 183
round off meeting point between . . . . . . . . . . . 50

sculpt across . . . . . . . . . . . . . . . . . . . . . . . . . . . . 200
use to create a curve  . . . . . . . . . . . . . . . . . . . . . . 28

Edit Curves menu
Add Points Tool. . . . . . . . . . . . . . . . . . . . . . . . . 126
Align Curves  . . . . . . . . . . . . . . . . . . . . . . . . . . . 131
Attach Curves  . . . . . . . . . . . . . . . . . . . . . . . . . . 128
Curve Editing Tool  . . . . . . . . . . . . . . . . . . . . . . 140
Curve Fillet . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
customizing tools. . . . . . . . . . . . . . . . . . . . . . . . 207
Cut Curve . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
CV Hardness  . . . . . . . . . . . . . . . . . . . . . . . . . . . 139
Detach Curves . . . . . . . . . . . . . . . . . . . . . . . . . . 130
Duplicate Surface Curves . . . . . . . . . . . . . . . . . . 34
Extend . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123

Fit B-spline . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Insert Knot  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
Intersect Curves . . . . . . . . . . . . . . . . . . . . . . . . . 134
Move Seam . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

Offset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
Open/Close Curves  . . . . . . . . . . . . . . . . . . . . . 132
Project Tangent  . . . . . . . . . . . . . . . . . . . . . . . . . 141
Rebuild Curve  . . . . . . . . . . . . . . . . . . . . . . . . . . 136
Reverse Curve Direction  . . . . . . . . . . . . . . . . . 136

Smooth Curve  . . . . . . . . . . . . . . . . . . . . . . . . . . 139
NURBS Modeling 

214



Index
Edit NURBS menu
Align Surfaces  . . . . . . . . . . . . . . . . . . . . . . . . . . 153
Attach Surfaces  . . . . . . . . . . . . . . . . . . . . . . . . . 150
Attach Without Moving . . . . . . . . . . . . . . . . . . 151
Booleans  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 181
customizing tools. . . . . . . . . . . . . . . . . . . . . . . . 207
Detach Surfaces . . . . . . . . . . . . . . . . . . . . . . . . . 151
Duplicate NURBS Patches . . . . . . . . . . . . . . . . . 87
Extend Surfaces . . . . . . . . . . . . . . . . . . . . . . . . . 148
Insert Isoparms  . . . . . . . . . . . . . . . . . . . . . . . . . 161
Intersect Surfaces . . . . . . . . . . . . . . . . . . . . . . . . 179
Move Seam . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 161

Offset Surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . 149
Open/Close Surfaces  . . . . . . . . . . . . . . . . . . . . 159
Project Curve on Surface  . . . . . . . . . . . . . . . . . 177
Rebuild Surfaces  . . . . . . . . . . . . . . . . . . . . . . . . 164
Reverse Surface Direction  . . . . . . . . . . . . . . . . 163

Round Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88
Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 201
Selection  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 168

Stitch  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 186

Surface Editing . . . . . . . . . . . . . . . . . . . . . . . . . . 168
Surface Fillet > Circular Fillet  . . . . . . . . . . . . . . 88
Surface Fillet > Fillet Blend Tool . . . . . . . . . . . . 91
Surface Fillet > Freeform Fillet  . . . . . . . . . . . . . 91
Trim Tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 180
Untrim Surfaces . . . . . . . . . . . . . . . . . . . . . . . . . 181

edit points
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
add to a curve. . . . . . . . . . . . . . . . . . . . . . . . . . . 111
add to end of curve . . . . . . . . . . . . . . . . . . . . . . 107
moving  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

use to draw a curve . . . . . . . . . . . . . . . . . . . . . . . 27
editors

Curve Editing Tool  . . . . . . . . . . . . . . . . . . . . . . 140
Curve Editing tool . . . . . . . . . . . . . . . . . . . . . . . 100
Surface Editing tool . . . . . . . . . . . . . . . . . . . . . . 100

End Conditions
Rebuild Curve type . . . . . . . . . . . . . . . . . . . . . . 137
Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 165

End Point Tolerance
Boundary option  . . . . . . . . . . . . . . . . . . . . . . . . . 78
Square options . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

end points
match for Boundary surfaces . . . . . . . . . . . . . . . 77

End Sweep Angle
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

Ends
Rebuild Curve, Keep option  . . . . . . . . . . . . . . 138

EP Curve Tool (Create menu)  . . . . . . . . . . . . . . . . . 33
Equal Params

Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 192
equation for a curve. . . . . . . . . . . . . . . . . . . . . . . . . . 12
erase

back to previous state . . . . . . . . . . . . . . . . . . . . 199
brush stamp . . . . . . . . . . . . . . . . . . . . . . . . . . . . 201

erase surface
Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 197

Erase Surface update
Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 205

Exit On Completion
Birail option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Exit Upon Completion
Tool option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 208

extend
curves with more CVs  . . . . . . . . . . . . . . . . . . . 107
surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108

Extend Curve (Edit Curves > Extend)  . . . . . . . . . 123
Extend Curve At

Extend Curve options . . . . . . . . . . . . . . . . . . . . 124
Extend Curve on Surface (Edit Curves > Extend)125
Extend Direction

Extend Surfaces option . . . . . . . . . . . . . . . . . . . 149
Extend Method

Extend Curve on Surface option . . . . . . . . . . . 125

Extend Curve option . . . . . . . . . . . . . . . . . . . . . 123
Extend Side

Extend Surfaces option . . . . . . . . . . . . . . . . . . . 148
Extend Surfaces

Edit NURBS menu. . . . . . . . . . . . . . . . . . . . . . . 148
Extension Type

Extend Curve option . . . . . . . . . . . . . . . . . . . . . 123
Extend Surfaces option . . . . . . . . . . . . . . . . . . . 148

Extrapolate
Extend Curve on Surface option . . . . . . . . . . . 125

Extend Curve option . . . . . . . . . . . . . . . . . . . . . 124
Extrude (Surfaces menu)  . . . . . . . . . . . . . . . . . . . . . 67
extrude a surface from a curve  . . . . . . . . . . . . . . . . 47
Extrude action  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
NURBS Modeling

215



Index
Extrude Distance
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 83

Extrude Height
Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Extrude Length
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

F
Face Count

Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 85

faceted surfaces  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
fillet

between two surfaces  . . . . . . . . . . . . . . . . . . . . . 51
blend  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

circular. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
curve, create from two curves . . . . . . . . . . . . . . 30
for curves  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
freeform. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

Fillet Blend Tool (Edit NURBS > Surface Fillet)  . . 91
Find Intersections

Intersect Curves option. . . . . . . . . . . . . . . . . . . 134
Fine display

NURBS Smoothness option . . . . . . . . . . . . . . . 122
First Normal

Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 202
First Rail

Birail Rebuild option . . . . . . . . . . . . . . . . . . . . . . 75
First Surface

Intersect Surfaces option  . . . . . . . . . . . . . . . . . 179

Fit B-spline (Edit Curves menu)  . . . . . . . . . . . . . . . 37
Fitting tolerance

Trim Tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 181
Fix Boundary

Stitch Edges Tool option. . . . . . . . . . . . . . 187, 190
Flat

Extrude style option  . . . . . . . . . . . . . . . . . . . . . . 67
flat surfaces, create. . . . . . . . . . . . . . . . . . . . . . . . . . . 39
Flip Left/Right Normal

Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 94

flying logos
creating . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48

Free
change axis definition . . . . . . . . . . . . . . . . . . . . . 54

Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
freeform

Curve Fillet option  . . . . . . . . . . . . . . . . . . . . . . . 36

drawing of a curve  . . . . . . . . . . . . . . . . . . . . . . . 28
fillet curve, create  . . . . . . . . . . . . . . . . . . . . . . . . 31

fillet, create . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
Freeform Fillet (Edit NURBS > Surface Fillet) . . . . 91
Freeform Type

Curve Fillet options. . . . . . . . . . . . . . . . . . . . . . . 36

G
G0, G1, G2 continuity  . . . . . . . . . . . . . . . . . . . . . . . . 20
Geometry

NURBS Smoothness option . . . . . . . . . . . . . . . 122

geometry
non-rational, convert to  . . . . . . . . . . . . . . . . . . 117

Geometry Average
Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 126

Global Stitch
change options . . . . . . . . . . . . . . . . . . . . . . . . . . 183

Global Stitch (Edit NURBS > Stitch) . . . . . . . . . . . 191
Global tolerance

Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
boundary option  . . . . . . . . . . . . . . . . . . . . . . . . . 78
Circular Fillet option . . . . . . . . . . . . . . . . . . . . . . 91
Fillet Blend option . . . . . . . . . . . . . . . . . . . . . . . . 96

Fit B-spline option . . . . . . . . . . . . . . . . . . . . . . . . 38

Freeform Fillet option . . . . . . . . . . . . . . . . . . . . . 91

Intersect Surfaces option  . . . . . . . . . . . . . . . . . 180

Project Curve On Surface option. . . . . . . . . . . 178
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Square option . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Group With Original
Duplicate NURBS Patches option . . . . . . . . . . . 88
Duplicate Surface Curves option  . . . . . . . . . . . 35

Grow CV Selection
NURBS selection option . . . . . . . . . . . . . . . . . . 168
NURBS Modeling 

216



Index
H
Height

cube option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

holes
create by trimming  . . . . . . . . . . . . . . . . . . . . . . 172

Hull Simplification
NURBS Smoothness options  . . . . . . . . . . . . . . 123
options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123

hulls
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
control . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

I
Ignore

Open/Close Surfaces option . . . . . . . . . . . . . . 160
Ignore Shape

Open/Close Curve option . . . . . . . . . . . . . . . . 133

implicit representation  . . . . . . . . . . . . . . . . . . . . . . . 12

In 2D and 3D
Intersect Curves option. . . . . . . . . . . . . . . . . . . 134

In 3D Only
Intersect Curves option. . . . . . . . . . . . . . . . . . . 134

Increase by
Insert Isoparms option  . . . . . . . . . . . . . . . . . . . 162
Insert Knots option  . . . . . . . . . . . . . . . . . . . . . . 135

Inner Bevel Style
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 84

Input Curve
Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Curve Fillet option. . . . . . . . . . . . . . . . . . . . . . . . 37
CV Hardness option . . . . . . . . . . . . . . . . . . . . . 140
Extend Curve option . . . . . . . . . . . . . . . . . . . . . 125
Fit B-spline option . . . . . . . . . . . . . . . . . . . . . . . . 38

Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 128
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 139

Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 61

Input Curves
Loft History options  . . . . . . . . . . . . . . . . . . . . . . 64

Input Point
Extend Curve option . . . . . . . . . . . . . . . . . . . . . 125

Input Profile/Input Rail
Birail option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Input Surface
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 157
Detach Surfaces option . . . . . . . . . . . . . . . . . . . 152

Insert Isoparms option . . . . . . . . . . . . . . . . . . . 163
Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 168
Stitch Surface Points option . . . . . . . . . . . . . . . 187

Input Surface/Input Curve
Project Curve On Surface option. . . . . . . . . . . 179

Insert Isoparms (Edit NURBS menu)  . . . . . . . . . . 161
Insert Knot

Attach Curves option . . . . . . . . . . . . . . . . . . . . 129
Attach Surfaces option . . . . . . . . . . . . . . . . . . . 150
Open/Close Curve option . . . . . . . . . . . . . . . . 133

Open/Close Surfaces option . . . . . . . . . . . . . . 160
Insert Knot (Edit Curves menu). . . . . . . . . . . . . . . 135
Insert Location

Insert Isoparms option . . . . . . . . . . . . . . . . . . . 162
Insert Knot options . . . . . . . . . . . . . . . . . . . . . . 135

Insert Parameter
Attach Curves option . . . . . . . . . . . . . . . . . . . . 129
Attach Surfaces option . . . . . . . . . . . . . . . . . . . 151
Open/Close Curve option . . . . . . . . . . . . . . . . 133

Open/Close Surfaces option . . . . . . . . . . . . . . 160
Interior Blending

Align Surfaces option . . . . . . . . . . . . . . . . . . . . 159
interpolated curves, fit  . . . . . . . . . . . . . . . . . . . . . . . 38
Intersect Curves (Edit Curves menu) . . . . . . . . . . 134
Intersect Surfaces (Edit NURBS menu)  . . . . . . . . 179
intersection of objects  . . . . . . . . . . . . . . . . . . . . . . . 175
irregular shapes, create with trimming  . . . . . . . . 172

isoparms
add to a surface  . . . . . . . . . . . . . . . . . . . . . . . . . 111
changing number. . . . . . . . . . . . . . . . . . . . . . . . 197
definition. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
insert  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 161
surface component  . . . . . . . . . . . . . . . . . . . . . . . 26
use to create a curve  . . . . . . . . . . . . . . . . . . . . . . 28

J
Join

Curve Fillet option  . . . . . . . . . . . . . . . . . . . . . . . 36

join
curves or surfaces together  . . . . . . . . . . . . . . . 110
smooth. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
NURBS Modeling

217



Index
Join Parameter
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 157

Join to Original
Extend Curve option . . . . . . . . . . . . . . . . . . . . . 124
Extend Surfaces option . . . . . . . . . . . . . . . . . . . 149

K
Keep

Align Curves multiple knots option . . . . . . . . 131
Align Surfaces multiple knots option . . . . . . . 153
Attach Curves option  . . . . . . . . . . . . . . . . . . . . 129
Attach Surfaces multiple knots option . . . . . . 150
Cut Curve options . . . . . . . . . . . . . . . . . . . . . . . 134
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 138

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 166
Trim Tool option . . . . . . . . . . . . . . . . . . . . . . . . 180

Keep Original
Align Curves option . . . . . . . . . . . . . . . . . . . . . 132
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 157
Attach Curves option  . . . . . . . . . . . . . . . . . . . . 130
Attach Surfaces option  . . . . . . . . . . . . . . . . . . . 151
Cut Curve options . . . . . . . . . . . . . . . . . . . . . . . 134
CV Hardness option . . . . . . . . . . . . . . . . . . . . . 140
Detach Curves option . . . . . . . . . . . . . . . . . . . . 131

Detach Surfaces option . . . . . . . . . . . . . . . . . . . 152

Extend Curve option . . . . . . . . . . . . . . . . . . . . . 125
Extend Surfaces option . . . . . . . . . . . . . . . . . . . 149

Fillet Curve option. . . . . . . . . . . . . . . . . . . . . . . . 36
Insert Isoparms option  . . . . . . . . . . . . . . . . . . . 162
Insert Knot option . . . . . . . . . . . . . . . . . . . . . . . 136
Open/Close Curve option . . . . . . . . . . . . . . . . 133

Open/Close Surfaces option . . . . . . . . . . . . . . 160
Project Tangent option . . . . . . . . . . . . . . . . . . . 142
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 139

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 167
Reverse Curve Direction option  . . . . . . . . . . . 136
Reverse Surface Direction option  . . . . . . . . . . 164
Stitch Edges Tool option. . . . . . . . . . . . . . . . . . 190
Stitch Surface Points option . . . . . . . . . . . . . . . 187

Trim Tool option . . . . . . . . . . . . . . . . . . . . . . . . 181
Untrim Surfaces option. . . . . . . . . . . . . . . . . . . 181

keyframe
sculpting changes  . . . . . . . . . . . . . . . . . . . . . . . 200

knot spacing
chord length . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

uniform . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

knot values
integer values, Rebuild Surface . . . . . . . . . . . . 166
match, with Rebuild Surfaces  . . . . . . . . . . . . . 164

knots
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
cross insertion  . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

in fillet blends. . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
remove in specific direction . . . . . . . . . . . . . . . 166

L
Last

Untrim Surfaces option  . . . . . . . . . . . . . . . . . . 181

Length
cube option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Linear
Extend Curve on Surface option . . . . . . . . . . . 125

Extend Curve option . . . . . . . . . . . . . . . . . . . . . 123
Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 127
Planar option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
primitive sphere option  . . . . . . . . . . . . . . . . . . . 54
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
surface degree Extrude option  . . . . . . . . . . . . . 69

linear curves . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Linear surface degree

Loft option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Local tolerance
Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Boundary option . . . . . . . . . . . . . . . . . . . . . . . . . 78
Circular Fillet option . . . . . . . . . . . . . . . . . . . . . . 91
Fillet Blend option . . . . . . . . . . . . . . . . . . . . . . . . 96

Fit B-spline option . . . . . . . . . . . . . . . . . . . . . . . . 38

Freeform Fillet option . . . . . . . . . . . . . . . . . . . . . 91

Intersect Surfaces option  . . . . . . . . . . . . . . . . . 180

Project Curve On Surface option. . . . . . . . . . . 179
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 60
Square option . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Lock Length  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

lock points or edges on NURBS surfaces . . . . . . . 183
Lock surface

Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 194
Loft (Surfaces menu) . . . . . . . . . . . . . . . . . . . . . . . . . 61
NURBS Modeling 

218



Index
Loft action . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Loop Cutting
Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 127

M
Match Curve

Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 139

match end points
for Boundary surfaces . . . . . . . . . . . . . . . . . . . . . 77

Match Knots
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 137

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 164
Match Surface

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 168
Max Curvature

Scale Curvature tool  . . . . . . . . . . . . . . . . . . . . . 146
Max Separation

Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 193
Max Subdivision Density

Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 128
Maximum Displacement

options, about. . . . . . . . . . . . . . . . . . . . . . . . . . . 196
Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 204

Maya
customizing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207

Medium display
NURBS Smoothness option . . . . . . . . . . . . . . . 122

menus
creating tools from. . . . . . . . . . . . . . . . . . . . . . . 207

Method
Offset Surfaces option . . . . . . . . . . . . . . . . . . . . 149

Modification Resistance
Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 194

Modify Boundary
Align Curves option . . . . . . . . . . . . . . . . . . . . . 132

Modify Position
Align Curves option . . . . . . . . . . . . . . . . . . . . . 132
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 154

Modify Tangent
Align Curves option . . . . . . . . . . . . . . . . . . . . . 132

Move Seam (Edit Curves menu)  . . . . . . . . . . . . . . 133
Move Seam (Edit NURBS menu) . . . . . . . . . . . . . . 161

Multiple Knots
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Align Curves option . . . . . . . . . . . . . . . . . . . . . 131
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 153
Attach Curves option . . . . . . . . . . . . . . . . . . . . 129
Attach Surfaces option . . . . . . . . . . . . . . . . . . . 150
control . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115
CV curves option . . . . . . . . . . . . . . . . . . . . . . . . . 32
Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 93

remove, with Rebuild Surface . . . . . . . . . . . . . 165
multiple spans  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Multiplicity

about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
control . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115
CV Hardness option . . . . . . . . . . . . . . . . . . . . . 139
Insert Isoparms option . . . . . . . . . . . . . . . . . . . 162
Insert Knot options . . . . . . . . . . . . . . . . . . . . . . 135

N
No Multiple Knots

Rebuild Curve type . . . . . . . . . . . . . . . . . . . . . . 137
Rebuild Curves option . . . . . . . . . . . . . . . . . . . 137
Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 165

Non Proportional
Birail transform option . . . . . . . . . . . . . . . . . . . . 74

Non-Rational
Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 165

non-rational geometry, convert to. . . . . . . . . . . . . 117
Non-Uniform Rational B-Splines

see NURBS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Normal

Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 192
Project Tangent option . . . . . . . . . . . . . . . . . . . 141
Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 202
Stitch Surface Points option . . . . . . . . . . . . . . . 188

Normal Direction
Offset Curve options . . . . . . . . . . . . . . . . . . . . . 126

normals
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
reverse direction for curves or surfaces . . . . . 113
reverse, with Circular Fillet . . . . . . . . . . . . . . . . 89
surface, project curve along . . . . . . . . . . . . . . . 173

Number of Knots
Insert Isoparms option . . . . . . . . . . . . . . . . . . . 163
NURBS Modeling

219



Index
Number of Sections
primitive sphere option  . . . . . . . . . . . . . . . . . . . 55

Number of Spans
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 138

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 167
sphere primitive option  . . . . . . . . . . . . . . . . . . . 56

NumSpans
Rebuild Surfaces options  . . . . . . . . . . . . . . . . . 166

NURBS
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
introduction to splines  . . . . . . . . . . . . . . . . . . . . 11

NURBS Primitives (Create menu) . . . . . . . . . . . . . . 53
NURBS Smoothness (Display menu)  . . . . . . . . . . 121
NURBS Smoothness Custom Options  . . . . . . . . . 122
NURBS surface

see surface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

O
Object

pivot point option, primitives . . . . . . . . . . . . . . 54
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

Off
Bevel type . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Offset Curve, no connection. . . . . . . . . . . . . . . 127
Offset (Edit Curves menu)  . . . . . . . . . . . . . . . . . . . 126
offset copy of a curve or surface  . . . . . . . . . . . . . . 112
Offset Curve/Curve on Surface (Edit Curves > 

Offset)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
Offset Distance

Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 126
Offset Surfaces option . . . . . . . . . . . . . . . . . . . . 149

Offset Surfaces (Edit NURBS menu) . . . . . . . . . . . 149
open curves

about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
creating trimmed surfaces from  . . . . . . . . . . . . 66

making. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
open surfaces

making. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
Open/Close Curves (Edit Curves menu). . . . . . . 132
Open/Close Surfaces (Edit NURBS menu) . . . . . 159
Operation

Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 201

Optional
Boundary option . . . . . . . . . . . . . . . . . . . . . . . . . 77

Orientation
examples . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
Extrude options . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Outer Bevel Style
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 84

Output Geometry
Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Birail option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 96

Freeform Fillet option . . . . . . . . . . . . . . . . . . . . . 91

Loft option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64

Planar option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 168
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Square option . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Output Options
for Bevel Plus . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Override CV Position
Stitch Surface Points option . . . . . . . . . . . . . . . 188

Override tolerance value
Round Tool option  . . . . . . . . . . . . . . . . . . . . . . . 88

P
painting

out the effects of your last stroke  . . . . . . . . . . 199
Parameter

Insert Isoparms option . . . . . . . . . . . . . . . . . . . 163
Parameter Range

Rebuild Curve options . . . . . . . . . . . . . . . . . . . 138
Rebuild Surfaces options  . . . . . . . . . . . . . . . . . 166

Parameter U/V
Stitch Surface Points option . . . . . . . . . . . . . . . 188

parameterization
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15, 25
convert to uniform. . . . . . . . . . . . . . . . . . . . . . . 117

Loft options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62
uniform, for rebuild curve . . . . . . . . . . . . . . . . 137

parameters
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

Parametric Distance
Extend Curve on Surface option . . . . . . . . . . . 125
NURBS Modeling 

220



Index
parametric representations . . . . . . . . . . . . . . . . . . . . 12
Partial curve range

Bevel  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Loft options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 128
Planar option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Project Curve On Surface . . . . . . . . . . . . . . . . . 179
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

patches
divide by inserting isoparms . . . . . . . . . . . . . . 118
surface component  . . . . . . . . . . . . . . . . . . . . . . . 26
use to create a surface . . . . . . . . . . . . . . . . . . . . . 49

Path Direction
Extrude orientation option . . . . . . . . . . . . . . . . . 71

Pencil Curve Tool (Create menu)  . . . . . . . . . . . . . . 34
periodic curves . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
periodic surfaces  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Pivot

Extrude options . . . . . . . . . . . . . . . . . . . . . . . . . . 70
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

pivot point
primitive . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54

Planar (Surfaces menu) . . . . . . . . . . . . . . . . . . . . . . . 65
Planar action . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

planes
create . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
NURBS  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

planning for surfaces . . . . . . . . . . . . . . . . . . . . . . . . . 25
Point

Extend Curve option . . . . . . . . . . . . . . . . . . . . . 123
Point Constraints

Stitch Surface Points option . . . . . . . . . . . . . . . 188

points
individual, stitch surfaces at  . . . . . . . . . . . . . . 186
lock on surfaces (stitch). . . . . . . . . . . . . . . . . . . 183

polynomial equations  . . . . . . . . . . . . . . . . . . . . . . . . 12
polynomial splines. . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Position

Align Curves option . . . . . . . . . . . . . . . . . . . . . 131
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 154
Stitch Edges Tool option. . . . . . . . . . . . . . . . . . 188

Position/Normal
Stitch Surface Points  . . . . . . . . . . . . . . . . . . . . . 188

positional (G0) continuity . . . . . . . . . . . . . . . . . . . . . 20
positional continuity

align curves with . . . . . . . . . . . . . . . . . . . . . . . . 131

align surfaces with  . . . . . . . . . . . . . . . . . . . . . . 154

change for stitch. . . . . . . . . . . . . . . . . . . . . . . . . 188
Positional tolerance

Fillet Blend option . . . . . . . . . . . . . . . . . . . . . . . . 96

Preserve Length . . . . . . . . . . . . . . . . . . . . . . . . . . . . 144

Preserve Shape
Open/Close Curve option . . . . . . . . . . . . . . . . 133

Open/Close Surfaces option . . . . . . . . . . . . . . 160
Preset

Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
primitives

circle curves  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
cones  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
cubes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
cylinders . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
plane  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
planes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
spheres  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54
square curves . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
torus. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Profile
Birail Rebuild option . . . . . . . . . . . . . . . . . . . . . . 75

Profile Blend Value
Birail 2 Tool option  . . . . . . . . . . . . . . . . . . . . . . . 75

profile curves
skin a surface across  . . . . . . . . . . . . . . . . . . . . . . 40
sweep along a path curve. . . . . . . . . . . . . . . . . . 42
sweep along two path curves  . . . . . . . . . . . . . . 43

Profile Normal
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Extrude orientation option. . . . . . . . . . . . . . . . . 71
Project Along

Project Curve on Surface options  . . . . . . . . . . 177
Project Curve On Surface

change in Channel Box . . . . . . . . . . . . . . . . . . . 179
Project Curve on Surface (Edit NURBS menu) . . 177
project tangent

edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
Project Tangent (Edit Curves menu). . . . . . . . . . . 141
Proportional

Birail transform option . . . . . . . . . . . . . . . . . . . . 74
NURBS Modeling

221



Index
Pull brush stamp  . . . . . . . . . . . . . . . . . . . . . . . . . . . 201

push and pull a surface . . . . . . . . . . . . . . . . . . . . . . 195
Push brush stamp  . . . . . . . . . . . . . . . . . . . . . . . . . . 201

Q
quadratic curves . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
quality curves . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

R
Radius

Curve Fillet option. . . . . . . . . . . . . . . . . . . . . . . . 36
primitive sphere option  . . . . . . . . . . . . . . . . . . . 54

Round Tool manipulator  . . . . . . . . . . . . . . . . . . 51
Round Tool option  . . . . . . . . . . . . . . . . . . . . . . . 88

Rebuild
Birail option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
curve tool, about  . . . . . . . . . . . . . . . . . . . . . . . . . 25
Square option . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Rebuild Curve (Edit Curves menu). . . . . . . . . . . . 136
Rebuild Method . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Rebuild Surfaces (Edit NURBS menu) . . . . . . . . . 164
Rebuild Type

Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 137

Rebuild Surfaces options  . . . . . . . . . . . . . . . . . 164
Reduce

Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 137

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 164
Reference Srf update option . . . . . . . . . . . . . . . . . . 205

reference surface  . . . . . . . . . . . . . . . . . . . . . . . . . . . 196

updating on each stroke . . . . . . . . . . . . . . . . . . 205
Remove

Align Curves Multiple Knots option  . . . . . . . 131

Align Surfaces Multiple Knots option  . . . . . . 153
Attach Curves Multiple Knots option  . . . . . . 129

Attach Surfaces Multiple Knots option  . . . . . 150

Extend Curve Multiple Knots option . . . . . . . 124

Required
Boundary option  . . . . . . . . . . . . . . . . . . . . . . . . . 77

reshape curves or surfaces . . . . . . . . . . . . . . . . . . . . 99
Result Position

Extrude options . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Reverse
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 157

Reverse 1 & 2
Attach Curves option . . . . . . . . . . . . . . . . . . . . 130

Reverse Curve
Loft option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64

Reverse Curve Direction (Edit Curves menu) . . . 136
Reverse Direction

Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 94

Project Tangent option . . . . . . . . . . . . . . . . . . . 141
Reverse Normal Left/Right

Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 93

reverse normals for a curve or surface . . . . . . . . . 113

Reverse Surface Direction (Edit NURBS menu) . 163
Reverse Surface Normals

Circular Fillet option . . . . . . . . . . . . . . . . . . . . . . 89
revolution axis

specify . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Revolve (Surfaces menu)  . . . . . . . . . . . . . . . . . . . . . 57
ring, 3D  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Rotation
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Rough Display
NURBS Smoothness option . . . . . . . . . . . . . . . 122

Round Tool
Edit NURBS menu. . . . . . . . . . . . . . . . . . . . . . . . 88
using  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

S
Same as Outer Style

Bevel style option  . . . . . . . . . . . . . . . . . . . . . . . . 84

Samples Along Edge
Stitch Edges Tool option. . . . . . . . . . . . . . . . . . 190

Sampling Controls
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 86

Sampling Density
Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 194

Scale
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Scale Curvature  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146
Scale Factor

Scale Curvature tool . . . . . . . . . . . . . . . . . . . . . 146
NURBS Modeling 

222



Index
Sculpt Surfaces Tool
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 195
erase surface . . . . . . . . . . . . . . . . . . . . . . . . . . . . 205
maximum displacement . . . . . . . . . . . . . . . . . . 204
options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 201

sculpting
across seams and surface edges. . . . . . . . . . . . 200
and construction history. . . . . . . . . . . . . . . . . . 197
and stitched surfaces . . . . . . . . . . . . . . . . . . . . . 197
keyframing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 200
with attribute map. . . . . . . . . . . . . . . . . . . . . . . 199

seams
curve  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
move  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 161
sculpt across . . . . . . . . . . . . . . . . . . . . . . . . . . . . 200

Second Rail
Birail Rebuild option . . . . . . . . . . . . . . . . . . . . . . 75

Section Spans
Loft option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Sections
option for Arc Tools  . . . . . . . . . . . . . . . . . . . . . . 34
Segments Revolve option . . . . . . . . . . . . . . . . . . 60

Segments
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

Select Curve Cvs  . . . . . . . . . . . . . . . . . . . . . . . . . . . 147
Select CV Selection Boundary

NURBS selection option . . . . . . . . . . . . . . . . . . 168

Select First CV on Curve . . . . . . . . . . . . . . . . . . . . . 147
Select Last CV on Curve . . . . . . . . . . . . . . . . . . . . . 147
Select Surface Border

NURBS selection option . . . . . . . . . . . . . . . . . . 169

Select Surface Border (Edit NURBS > Selection) . 149
Selected State

Trim Tool options  . . . . . . . . . . . . . . . . . . . . . . . 180
Selection (Edit NURBS menu) . . . . . . . . . . . . . . . . 168
Set to

Insert Isoparms option  . . . . . . . . . . . . . . . . . . . 162
Insert Knots option  . . . . . . . . . . . . . . . . . . . . . . 135

Shape
irregular, create with trimming . . . . . . . . . . . . 172
Open/Close Curve options . . . . . . . . . . . . . . . 133
Open/Close Surfaces option . . . . . . . . . . . . . . 160

Shrink CV Selection
NURBS selection option . . . . . . . . . . . . . . . . . . 168

Shrink Surface
Trim Tool option . . . . . . . . . . . . . . . . . . . . . . . . 181

simplification, hull . . . . . . . . . . . . . . . . . . . . . . . . . . 123
skin a surface  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
Smooth

Modify Curves tool . . . . . . . . . . . . . . . . . . . . . . 144
Smooth brush stamp . . . . . . . . . . . . . . . . . . . . . . . . 201
Smooth Curve (Edit Curves menu). . . . . . . . . . . . 139
Smooth Factor. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145
smooth joins . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
smoothing

curves  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105
Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 196

spans
add to areas of a curve  . . . . . . . . . . . . . . . . . . . 117
change number for primitives . . . . . . . . . . . . . . 56
change number of spans/patches . . . . . . . . . . 118
multiple . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
NURBS Smoothness options . . . . . . . . . . . . . . 122

Specify
Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

splines
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

split curves or surfaces . . . . . . . . . . . . . . . . . . . . . . 111
Square (Surfaces menu)  . . . . . . . . . . . . . . . . . . . . . . 78
Square action  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46

square, create  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
Start and End Sweep Angles

primitive sphere option  . . . . . . . . . . . . . . . . . . . 54
Start Sweep Angle

Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Step Count

Stitch Edges Tool option. . . . . . . . . . . . . . . . . . 190
Stitch Corners

Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 191
Stitch Edges

Global Stitch . . . . . . . . . . . . . . . . . . . . . . . . . . . . 191

Stitch Edges Tool (Edit NURBS > Stitch) . . . . . . . 188
Stitch Partial Edges

Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 193
Stitch Smoothness

Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 192
Stitch Surface Points (Edit NURBS > Stitch)  . . . . 186
NURBS Modeling

223



Index
stitching
automatic  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 183
manual. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 185
surfaces, Sculpt Surfaces Tool . . . . . . . . . . . . . 197

Straight
Bevel cap option. . . . . . . . . . . . . . . . . . . . . . . . . . 81
Bevel corner option . . . . . . . . . . . . . . . . . . . . . . . 81

Straighten  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 143

Straightness . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 144
Style

Extrude option . . . . . . . . . . . . . . . . . . . . . . . . . . . 67

subtraction of objects . . . . . . . . . . . . . . . . . . . . . . . . 175
Surface Degree

change, with Rebuild Surfaces. . . . . . . . . . . . . 167
Extrude options . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Loft options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
primitive sphere option  . . . . . . . . . . . . . . . . . . . 54

Revolve options . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Surface Direction

Open/Close Surfaces option . . . . . . . . . . . . . . 159
Reverse Surface Direction option  . . . . . . . . . . 163

Surface Div per Span
NURBS Smoothness option . . . . . . . . . . . . . . . 123
NURBS Smoothness options  . . . . . . . . . . . . . . 122

Surface Div per Span options . . . . . . . . . . . . . . . . . 122
Surface Editing (Edit NURBS menu)  . . . . . . . . . . 168
Surface Editing tool . . . . . . . . . . . . . . . . . . . . . . . . . 100
Surface Normal

Project Curve On Surface option. . . . . . . . . . . 178
surface normals

reversing, with Circular Fillet . . . . . . . . . . . . . . 89
surface patches

duplicate . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

surfaces
align . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104
attach . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

Boolean operations on  . . . . . . . . . . . . . . . . . . . 175

change degree, number of spans/patches . . . 118
change density . . . . . . . . . . . . . . . . . . . . . . . . . . 197

combine with trimming  . . . . . . . . . . . . . . . . . . 172
components  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
convert to non-rational geometry . . . . . . . . . . 117

convert to uniform parameterization . . . . . . . 117

create by rotating a curve . . . . . . . . . . . . . . . . . . 46
create flat, inside a curve  . . . . . . . . . . . . . . . . . . 39
create from four boundary curves  . . . . . . . . . . 46
create from patches . . . . . . . . . . . . . . . . . . . . . . . 49
create within bounding curves  . . . . . . . . . . . . . 44
detach  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

erase with Sculpt Surfaces Tool. . . . . . . . . . . . 197
extend a certain distance  . . . . . . . . . . . . . . . . . 108
extrude and bevel from a curve  . . . . . . . . . . . . 47

faceted . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

fillet between intersecting  . . . . . . . . . . . . . . . . . 51

fillet between two sets of boundary curves . . . 52
flat plane . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
intersecting, create curves at . . . . . . . . . . . . . . 173
make open or closed . . . . . . . . . . . . . . . . . . . . . 119

offset copy. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112
periodic and closed . . . . . . . . . . . . . . . . . . . . . . . 19

planning for  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
push and pull the entire . . . . . . . . . . . . . . . . . . 198
push or pull parts  . . . . . . . . . . . . . . . . . . . . . . . 195
reduce complexity . . . . . . . . . . . . . . . . . . . . . . . 114
reference . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 196
reshape  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
reverse normals . . . . . . . . . . . . . . . . . . . . . . . . . 113
sculpt with a brush . . . . . . . . . . . . . . . . . . . . . . 198
skin across profile curves . . . . . . . . . . . . . . . . . . 40
smoothing with Sculpt Surfaces Tool . . . . . . . 196
stitch and sculpt. . . . . . . . . . . . . . . . . . . . . . . . . 197
stitch together. . . . . . . . . . . . . . . . . . . . . . . . . . . 183
trim  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 174
NURBS Modeling 

224



Index
Surfaces menu
Bevel  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79
Bevel Plus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Birail. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73
Boundary  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

customizing tools. . . . . . . . . . . . . . . . . . . . . . . . 207
Extrude  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67
Loft. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Planar. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Revolve . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
Square  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78

Swap
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 157
Reverse Surface Direction option  . . . . . . . . . . 163

sweep
angle, set . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
change start and end sweep angle, primitives 
option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54

profile curve along a path curve . . . . . . . . . . . . 42

profile curves along two path curves . . . . . . . . 43

T
Tangent

Align Curves option . . . . . . . . . . . . . . . . . . . . . 131
Align Surfaces option . . . . . . . . . . . . . . . . . . . . 154
Curve Fillet option. . . . . . . . . . . . . . . . . . . . . . . . 36
Project Tangent option . . . . . . . . . . . . . . . . . . . 141
Stitch Edges Tool options . . . . . . . . . . . . . . . . . 188

tangent
break at an isoparm, add or remove . . . . . . . . 115
breaking  . . . . . . . . . . . . . . . . . . . . . . . . . . . 115, 116

continuity, align curves with . . . . . . . . . . . . . . 131

continuity, align surfaces with  . . . . . . . . . . . . 154

edit projected . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
make a curve with a curve intersection . . . . . 102
make a curve with a surface. . . . . . . . . . . . . . . 102
make a curve with another curve . . . . . . . . . . 103

tangent (G1) continuity . . . . . . . . . . . . . . . . . . . . . . . 20
Tangent Align Direction

Project Tangent option . . . . . . . . . . . . . . . . . . . 141
Tangent Continuity Profile

Birail option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
Tangent Manip. Size

surface editing option . . . . . . . . . . . . . . . . . . . . 168

Tangent Rotation
Project Tangent option . . . . . . . . . . . . . . . . . . . 142

Tangent Scale
Align Curves options  . . . . . . . . . . . . . . . . . . . . 132
Align Surfaces options  . . . . . . . . . . . . . . . . . . . 156
Project Tangent option . . . . . . . . . . . . . . . . . . . 142

Tangents
Global Stitch option. . . . . . . . . . . . . . . . . . . . . . 192
Rebuild Curve, Keep option  . . . . . . . . . . . . . . 138

tessellation
NURBS Smoothness options . . . . . . . . . . . . . . 123

Tessellation Method
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 85

Three Point Circular Arc (Create > Arc Tools)  . . . 34
Tolerance

Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 84
Fit B-spline option . . . . . . . . . . . . . . . . . . . . . . . . 38

Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 128
primitive sphere option  . . . . . . . . . . . . . . . . . . . 55
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

Tolerance Controls
Stitch Edges Tool . . . . . . . . . . . . . . . . . . . . . . . . 191

Tolerance Value
Round Tool options. . . . . . . . . . . . . . . . . . . . . . . 88

Tool Behavior
Birail option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
Booleans option . . . . . . . . . . . . . . . . . . . . . . . . . 182

Fillet Blend Tool option  . . . . . . . . . . . . . . . . . . . 97

tools
about . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207
changing to actions . . . . . . . . . . . . . . . . . . . . . . 207
creating from menus . . . . . . . . . . . . . . . . . . . . . 207

Top Side
Bevel option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

topology
match from one curve to another . . . . . . . . . . 120

torus
create . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Transform Control
Birail option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74

transition surfaces
Fillet Blend tool  . . . . . . . . . . . . . . . . . . . . . . . . . . 52
fillet tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
higher control with Bevel Plus  . . . . . . . . . . . . . 82
Round tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
NURBS Modeling

225



Index
Trim
Curve Fillets option . . . . . . . . . . . . . . . . . . . . . . . 35

trim
curves  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134
definition. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 172
surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 174
surfaces from open curves . . . . . . . . . . . . . . . . . 66

Trim Convert
Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 165

Trim Tool (Edit NURBS menu)  . . . . . . . . . . . . . . . 180
Tube

Extrude style option  . . . . . . . . . . . . . . . . . . . . . . 67
Twist

Align Surfaces option . . . . . . . . . . . . . . . . . . . . 157
Twist attribute

Bend tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146
twisted blend surface. . . . . . . . . . . . . . . . . . . . . . . . . 53
Two Point Circular Arc (Create > Arc Tools)  . . . . 34

U
U dimension of a curve . . . . . . . . . . . . . . . . . . . . . . . 13
U/V

direction, Sculpt Surfaces Tool  . . . . . . . . . . . . 203
patches, cube option . . . . . . . . . . . . . . . . . . . . . . 56
Project Tangent option . . . . . . . . . . . . . . . . . . . 141
Reverse Surface Direction option  . . . . . . . . . . 163

Uniform
knot spacing, Loft option . . . . . . . . . . . . . . . . . . 62
knots for CV curves . . . . . . . . . . . . . . . . . . . . . . . 32
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 137

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 164
uniform knots

for edit point curves  . . . . . . . . . . . . . . . . . . . . . . 33
uniform parameterization

about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
convert to  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117

union of objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 175
Unlock Length  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 143

Untrim
Untrim Surfaces options . . . . . . . . . . . . . . . . . . 181

untrim surfaces
about  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 174
cancel last trim . . . . . . . . . . . . . . . . . . . . . . . . . . 181

Untrim Surfaces (Edit NURBS menu). . . . . . . . . . 181
Use all Surface Isoparms

Insert Isoparms option . . . . . . . . . . . . . . . . . . . 162
Use Chord Height

Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 87
Use Direction

Intersect Curves options. . . . . . . . . . . . . . . . . . 134
Use Normal

Project Curve On Surface option. . . . . . . . . . . 179
Use Preferences tolerance value

Round Tool option  . . . . . . . . . . . . . . . . . . . . . . . 88

Use Tolerance
Bevel options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Bevel Plus option . . . . . . . . . . . . . . . . . . . . . . . . . 84
Circular Fillet option . . . . . . . . . . . . . . . . . . . . . . 91
Fillet Blend option . . . . . . . . . . . . . . . . . . . . . . . . 96

Fit B-Spline option. . . . . . . . . . . . . . . . . . . . . . . . 38
Freeform Fillet options . . . . . . . . . . . . . . . . . . . . 91
Intersect Surfaces option  . . . . . . . . . . . . . . . . . 180

Intersecting Curves option. . . . . . . . . . . . . . . . 135
Offset Curve option. . . . . . . . . . . . . . . . . . . . . . 128
Project Curve On Surface option. . . . . . . . . . . 178
Rebuild Curve option . . . . . . . . . . . . . . . . . . . . 139

Rebuild Surfaces option . . . . . . . . . . . . . . . . . . 167
Revolve option . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

User Defined
pivot point, reposition  . . . . . . . . . . . . . . . . . . . . 54

Using Last Curve
Cut Curve option. . . . . . . . . . . . . . . . . . . . . . . . 133

UV Point
Extend Curve on Surface option . . . . . . . . . . . 125

V
View

Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 202
Visible Surface Isoparms

Duplicate Surface Curves option  . . . . . . . . . . . 35

W
Weighting on Edge

Stitch Edges Tool option. . . . . . . . . . . . . . . . . . 189
Width

cube option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
NURBS Modeling 

226



Index
With Last Curve Only
Intersect Curves option. . . . . . . . . . . . . . . . . . . 134

X
XYZ Axis

Sculpt Surfaces Tool  . . . . . . . . . . . . . . . . . . . . . 203
NURBS Modeling

227



Index
NURBS Modeling 

228


	Table of contents
	1 Background
	About
	NURBS
	Brief history of splines
	Mathematical representations of curves
	NURBS
	Object properties
	Degree
	Parameters and parameterization
	Normals
	Periodic, closed, and open

	Modeling concepts
	Curvature
	Continuity

	Curves
	Curve components
	Moving edit points vs. moving CVs
	Multi-knots and CV multiplicity
	Constructing quality curves

	Surfaces
	Surface components: CVs, isoparms, and patches




	2 Creating curves
	How do I?
	Create and edit models
	Create curves
	Draw curves
	Create a curve from a surface edge, isoparm, or curve-on-surface
	Create arcs
	Create a fillet curve between two existing curves
	Create a degree 3 curve to match degree 1 (scan) data



	Reference
	Menus
	Create
	Create > CV Curve Tool
	Create > EP Curve Tool
	Create > Pencil Curve Tool
	Create > Arc Tools > Three Point Circular Arc, Two Point Circular Arc

	Modeling menu set
	Edit Curves
	Edit Curves > Duplicate Surface Curves
	Edit Curves > Curve Fillet
	Edit Curves > Fit B-spline





	3 Creating NURBS surfaces
	How do I?
	Create and edit models
	Create NURBS surfaces
	Create a flat surface inside a curve
	Skin a surface across profile curves
	Sweep a profile curve along a path curve
	Sweep one or more profile curves along two path curves (birail)
	Create a surface within bounding curves
	Create a surface from four boundary curves that maintains continuity (square)
	Sweep out a surface by rotating a curve around an axis
	Extrude and bevel a surface from a curve
	Create a new surface from patches of an existing surface

	Create NURBS transition surfaces
	Round off the meeting point between two edges
	Create a fillet between two surfaces
	Create a surface between two sets of boundary curves



	Reference
	Menus
	Create
	Create > NURBS Primitives

	Modeling menu set
	Surfaces
	Surfaces > Revolve
	Surfaces > Loft
	Surfaces > Planar
	Surfaces > Extrude
	Surfaces > Birail > Birail 1 Tool, Birail 2 Tool, Birail 3+ Tool
	Surfaces > Boundary
	Surfaces > Square
	Surfaces > Bevel
	Surfaces > Bevel Plus

	Edit NURBS
	Edit NURBS > Duplicate NURBS Patches
	Edit NURBS > Round Tool
	Edit NURBS > Surface Fillet > Circular Fillet
	Edit NURBS > Surface Fillet > Freeform Fillet
	Edit NURBS > Surface Fillet > Fillet Blend Tool





	4 Editing NURBS
	How do I?
	Create and edit models
	Reshape NURBS curves and surfaces
	Reshape a curve or surface manually
	Align a curve with a curve or surface
	Align surface edges
	Smooth a curve
	Lock or unlock the length of a curve
	Straighten, smooth, curl or bend a curve
	Extend a curve
	Extend a surface
	Select curve CVs: first, last or all

	Edit NURBS curves and surfaces
	Join two curves or surfaces together (attach)
	Split a curve or surface (detach)
	Insert additional edit points/isoparms in a curve or surface to add more CVs
	Create an offset copy of a curve or surface
	Reverse the direction of a curve or surface normals
	Reduce the complexity of a curve or surface
	Control multi-knots and CV hardness
	Automatically add spans to areas of a curve with high curvature
	Convert a curve or surface to uniform parameterization
	Convert a surface to non-rational geometry
	Change a curve or surface’s degree or number of spans/patches
	Make a curve or surface open or closed
	Match the topology of one curve to another



	Reference
	Tools
	Toolbox
	Soft Modification tool


	Menus
	Display
	Display > NURBS Components > Custom
	Display > NURBS Smoothness

	Modeling menu set
	Edit Curves
	Edit Curves > Extend > Extend Curve
	Edit Curves > Extend > Extend Curve on Surface
	Edit Curves > Add Points Tool
	Edit Curves > Offset > Offset Curve, Offset Curve on Surface
	Edit Curves > Attach Curves
	Edit Curves > Detach Curves
	Edit Curves > Align Curves
	Edit Curves > Open/Close Curves
	Edit Curves > Move Seam
	Edit Curves > Cut Curve
	Edit Curves > Intersect Curves
	Edit Curves > Insert Knot
	Edit Curves > Reverse Curve Direction
	Edit Curves > Rebuild Curve
	Edit Curves > Smooth Curve
	Edit Curves > CV Hardness
	Edit Curves > Curve Editing Tool
	Edit Curves > Project Tangent
	Edit Curves > Modify Curves > Lock Length
	Edit Curves > Modify Curves > Unlock Length
	Edit Curves > Modify Curves > Straighten
	Edit Curves > Modify Curves > Smooth
	Edit Curves > Modify Curves > Curl
	Edit Curves > Modify Curves > Bend
	Edit Curves > Modify Curves > Scale Curvature
	Edit Curves > Selection > Select Curve CVs
	Edit Curves > Selection > Select First CV on Curve
	Edit Curves > Selection > Select Last CV on Curve
	Edit Curves > Selection > Cluster Curve

	Edit NURBS
	Edit NURBS > Extend Surfaces
	Edit NURBS > Offset Surfaces
	Edit NURBS > Selection > Select Surface Border
	Edit NURBS > Attach Surfaces
	Edit NURBS > Attach Without Moving
	Edit NURBS > Detach Surfaces
	Edit NURBS > Align Surfaces
	Edit NURBS > Open/Close Surfaces
	Edit NURBS > Move Seam
	Edit NURBS > Insert Isoparms
	Edit NURBS > Reverse Surface Direction
	Edit NURBS > Rebuild Surfaces
	Edit NURBS > Surface Editing > Surface Editing Tool, Break Tangent, Smooth Tangent
	Edit NURBS > Selection





	5 Trimming
	About
	NURBS
	Curves-on-surface
	Trimming


	How do I?
	Create and edit models
	Trim a NURBS surface
	Create a curve-on-surface
	Trim or untrim a NURBS surface
	Perform boolean operations on surfaces



	Reference
	Menus
	Modeling menu set
	Edit NURBS
	Edit NURBS > Project Curve on Surface
	Edit NURBS > Intersect Surfaces
	Edit NURBS > Trim Tool
	Edit NURBS > Untrim Surfaces
	Edit NURBS > Booleans > Union Tool, Subtract Tool, Intersect Tool





	6 Stitching
	How do I?
	Create and edit models
	Lock points or edges on NURBS surfaces together (stitching)
	Automatically stitch multiple surfaces together
	Manually stitch surface edges together
	Manually stitch surface points together



	Reference
	Menus
	Modeling menu set
	Edit NURBS
	Edit NURBS > Stitch > Stitch Surface Points
	Edit NURBS > Stitch > Stitch Edges Tool
	Edit NURBS > Stitch > Global Stitch





	7 The Sculpt Surfaces tool
	About
	NURBS
	The Sculpt Surfaces tool


	How do I?
	Create and edit models
	Reshape NURBS surfaces with the Sculpt Surfaces tool
	Push or pull a surface with the Sculpt Surfaces tool
	Smooth a surface with the Sculpt Surfaces tool
	Selectively erase back to a previous state with the Sculpt Surfaces tool
	Sculpt according to an attribute map
	Sculpt across seams and surface edges
	Keyframe sculpting changes



	Reference
	Menus
	Modeling menu set
	Edit NURBS
	Edit NURBS > Sculpt Surfaces Tool





	8 Customization
	How do I?
	Customize Maya
	Switch NURBS operations between actions and tools



	Index

