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ABOUT INSTANT
MAYA

Instant Maya describes the fundamentals of Maya in a set of brief tutorials. If
you are new to Maya, this book is your fastest starting point. If you are an
existing user, it’s also the fastest starting point for learning any feature you
haven’t had time to learn yet.

There is one chapter for each major feature group. It is essential that you
understand the material in the first chapter of this book before reading other
chapters. Thereafter, you can read chapters in any order.

The lessons guide you through fundamental concepts rather than advanced
techniques. To learn technique, visit www.aliaswavefront.com for details on
training courses, videos, and Web-based tutorials.

With Maya, you can complete most tasks with one of several techniques. To
speed up your learning, this book shows the quickest technique to learn.

For comprehensive coverage of the features you learn in Instant Maya, see
the online Using Maya documentation. The chapters in Instant Maya have
corresponding sections in the online Using Maya. If you prefer reading Using
Maya on paper, see the Maya 4.5 Documentation and Lessons CD for
corresponding PDF files formatted for printing.

For a list of keyboard shortcuts (hotkeys), see the Maya Quick Reference card.

Software requirement
Maya 4.5 on any operating system

or

Maya 4.5 Personal Learning Edition
INSTANT MAYA
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Files for lessons
To do some of the more advanced lessons, you need to use Maya files we
created for your use in the lessons.

If you are using Maya Complete or Unlimited, you’ll find the lesson files on
the Maya Documentation and Lessons CD, which is included in the Maya
package.

If you are using Maya Personal Learning Edition, you’ll find the lesson files
in PLEInstallDirectory\tutorialData where PLEInstallDirectory is the directory
where you installed. By default, the installation path is Drive:\Program
Files\AliasWavefront\Maya 4 Personal Learning Edition.

Documentation conventions
In this book, the following conventions apply:

• UNIX means IRIX or Linux.

• Windows means Windows 2000 Professional or Windows XP Professional.

Important notes for Personal Learning Edition
• The screen shots in these lessons do not show the watermarking that is used

in your Personal Learning Edition.

• Your screen should be set at a minimum of 1280 x 1024 resolution so that
windows are not cut off. To change it for the Windows operating system,
open the control panel, double-click Display, and then click on the Settings.
For Mac OS X, go into your system preferences and double-click Displays.

Printing the Tutorials
To allow you to print copies of the online tutorials, we’ve provided PDF
files. These files require Adobe Acrobat Reader, which you can download
from www.adobe.com. PDF files for Using Maya and the Reference Library
are not included.

To print the online tutorials:

1 Open the tutorial you want to print in your browser.

2 Click the Printable Version link.

3 When the file is loaded into Adobe Acrobat Reader, click the printer icon.
INSTANT MAYA
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Before you do the lessons
If you have already used Maya 4.5 or have a prior version of Maya installed,
consider restoring the default factory settings before you begin the lessons.
This will ensure the lessons work as described. To restore the factory settings
without losing any custom settings you’ve created, do these steps:

1 Make sure Maya is not running.

2 Rename your existing user prefs directory to a new name, such as myprefs.
The prefs directory path is:

• (UNIX) ~username/maya/4.5/prefs

• (Windows)
drive:\Documents and Settings\username\My Documents\maya\4.5\prefs

If you have a previous version of Maya installed, such as 4.0, also rename
that prefs directory to a new name, such as myprefs.

3 Start Maya and do the desired lessons.

4 To restore your custom settings after doing the lessons, exit Maya, rename
the directory back to prefs, and start Maya again.
INSTANT MAYA
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1 ESSENTIALS
A QUICK TOUR OF MAYA

The lesson in this chapter teaches fundamental skills. You’ll learn how to
model simple shapes, change the camera view of objects, and work with
important elements of the Maya interface. By completing the lesson, you’ll
develop foundational skills for working with various features of Maya.
Before you do other lessons in this book, it’s important to understand the
material in this one.

PREPARING FOR THE LESSON

To ensure the lesson works as described, do the following steps:

1 Start Maya by either double-clicking the Maya desktop icon or by typing
maya at a command prompt. On Windows, you can also start Maya from the
Start > Programs > AliasWavefront menu.

When Maya opens, take a moment to scan the menu bar. The menus from
File to Window include general operations. The rest of the menus are
pertinent to animation only and are called the Animation menu set.

2 Click the Animation box (see the prior figure) to open a different menu set.
From the choices that appear, select Modeling.

General operations Animation menu set

Click here to select a menu set
INSTANT MAYA
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ESSENTIALS A QUICK TOUR OF MAYA | 1
Lesson: Creating and editing objects
A set of Modeling menus replaces the Animation menus. Each menu set
includes operations specific to a major part of the 3D animation process:
Animation, Modeling, Dynamics, Rendering. (Maya Unlimited has extra
menu sets for the additional features it includes.)

Notice the menus from File to Window remain the same because they are
common to all menu sets. In this lesson, you’ll use only these common
menus, so it doesn’t matter which menu set you chose.

LESSON: CREATING AND EDITING OBJECTS

In this lesson you will be introduced to some of the fundamental skills
required for creating, naming, viewing, and editing of objects within
Maya...you’ll start by building a door. This is not a modeling exercise. It is a
quick encapsulation of the Maya essentials.

Create a cube and manipulate the camera view
The first skill you’ll need is to move the camera view in various ways so you
can look around your scene. Before you move the camera, you’ll create a
cube so you have something to look at.

1 Select Create > Polygon Primitives > Cube.

The cube appears in a scene view, which is a window into your 3D scene. It
is also called the workspace. The cube is one of several ready-made shapes
known as primitives. Maya centers the cube around the origin, the center
point in the scene.
INSTANT MAYA
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ESSENTIALS A QUICK TOUR OF MAYA | 1
Lesson: Creating and editing objects
2 To see a closer view of the cube, dolly into the view. Hold down Alt and
drag to the right holding down the right mouse button. (For Unix users you
must hold down Alt and drag to the right holding both the left and middle
mouse buttons). Dollying moves a virtual camera forward (drag right) or
backward (drag left).

3 To view the scene from a higher camera position, track the view downward.
Hold down Alt and drag down with the middle mouse button. Tracking
moves the view in the direction you drag the mouse: up, down, left, or right.

L M

Alt R
+

+

Windows
+
Macintosh

Alt
Unix

M
Alt +
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Lesson: Creating and editing objects
4 To view the cube from the grid level, tumble the view down. Hold down Alt
and drag up with the left mouse button. Tumbling revolves the camera view
around the center of the scene view, in whichever direction you drag.

5 Practice using the preceding tools until you are good at changing the view.
As you work with objects, you change the view regularly to check your work
from various angles.

Additional camera tools are available from the View > Camera Tools menu
on the panel menu bar. You won’t use them in this lesson because they are
not as commonly used.

Use the Scale Tool to shape the cube into a door
There are three fundamental transformation tools for moving, rotating, and
scaling an object. Icons for these tools appear in the tool box. In the next
steps, you will scale the cube.

1 Move the pointer over any transformation tool
icon and leave it there until you see the name of
the tool appear next to the pointer.

The name of the tool also appears in the Help
Line at the bottom of the Maya window. The
Help Line has an additional purpose. It displays
summary instructions as you use tools that
require several steps.

2 Click the Scale Tool icon to select it. An icon
with handles appears over the cube. (If handles
do not appear, click an edge of the cube.)

L
Alt +

Transformation
tools:
Move

Rotate

Scale
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ESSENTIALS A QUICK TOUR OF MAYA | 1
Lesson: Creating and editing objects
The handles point in the three fundamental axis directions of 3D space: X, Y,
and Z. The handles control the direction of the transformation. Clicking a
handle means the transformation is isolated to that direction.

3 Click the green, upward-facing handle and drag it up until the cube is about
twice its original height.

The XYZ handles are colored red, green, and blue to help distinguish them.
When you select a handle, it turns yellow to indicate it is selected.

4 Click the blue handle and drag it toward the center until the cube has the
approximate thickness of a door (see the figure in the next step).

5 Click the center handle and drag right until the cube is about three times
larger. If necessary, dolly the camera view so you can see the entire object.

Dragging the center handle scales in all directions. This maintains the
proportions you created in the previous step.

6 Click the Move Tool icon. Notice the manipulator handles look different. If
you’re ever not sure which tool is selected, look at the handles for a visual
cue.

Scale handle
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ESSENTIALS A QUICK TOUR OF MAYA | 1
Lesson: Creating and editing objects
7 Drag the cube up until the bottom is roughly on the grid.

The grid is a measuring tool in Maya, with each grid line representing a unit.
You can use the grid as an imaginary floor or ground to make sure several
objects lie on the same plane.

Use a front view to position the cube more accurately
You’ll now display other view panels that are more useful for placing the
cube precisely on the grid.

1 From the menu above the scene view, select Panels > Layouts > Four Panes.

You can divide the workspace into two, three, or four view panels. The
perspective and orthographic (top, front, and side) views are a typical
layout.

2 In the front view, dolly in for a closer look. You can dolly and track in all the
orthographic views, but tumbling the camera works only in the perspective
view.

3 To enlarge the front view panel, place your cursor over the front view and
tap the spacebar quickly.

You can use this key for any panel that your cursor is on. If you hold the
spacebar down instead of tapping it, you’ll activate a menu feature called the
Hotbox, which is introduced at the end of the lesson.

4 Position the bottom of the cube even with the dark center grid line, which
coincides with the grid plane in the perspective view.

Move Tool
handles
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Lesson: Creating and editing objects
In general, the flat orthographic view helps with accurate positioning and
selection of objects or parts of objects.

5 Tap the spacebar again to return to the four-panel view.

6 Now that you have finished moving the cube, click the Select Tool. By
switching to the Select Tool, you can avoid moving the cube unintentionally.

Some tools in Maya revert back to the
selection mode when you finish an operation,
but not the transformation tools. You must
specifically click the Select Tool when you are
done with a transformation tool.

Be careful not to click the hide button above
the Select Tool. Otherwise, the Tool Box will
disappear. If you accidentally click a hide
button here or elsewhere, select Display > UI Elements > Restore UI
elements.

Create and name an object to be used as a doorknob
In this section, you’ll do several common editing tasks with new objects.

1 Select Create > NURBS Primitives > Sphere to create a NURBS sphere at the
origin of the scene.

NURBS surfaces are one of three types of object surfaces in Maya. The other
surface types are polygons, like the cube you created, and subdivision
surfaces. Each type of surface has unique benefits and modeling techniques.

2 Maya gives the sphere a default name, which appears to the right in a
vertical box called the Channel Box.

Select Tool

Hide button
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Lesson: Creating and editing objects
The name is nurbsSphere1 or, if you created a
polygon in the last step, pSphere1. Click the name
and type a new one: Knob.

It is important to give objects meaningful names
because many tools require you to identify an object
by its name rather than by selecting it in the scene
view. It is important to remember that Maya is
sensitive to whether you use upper or lower case
when naming objects. The Channel Box is a
convenient place to rename objects. You’ll learn more
about the Channel Box later.

Note that the Channel Box ends where the Layer
Editor begins (see figure). The Layer Editor is beyond
the scope of this lesson.

3 Select the cube by clicking it in the scene view.
Rename it Door.

4 In the perspective view, select Knob again and select
View > Frame Selection to zoom your view on it.

Notice that “f” is displayed next to the View > Frame menu item to indicate
the corresponding keyboard shortcut, called a hotkey.

5 Click the Scale Tool and move the blue Z axis handle inward until Knob is
about half its original width. Check the side view to confirm the width. Note
that each view panel has an icon in the lower-left corner that shows the
orientation of the view. This icon is known as the View Axis.

This creates the shape of the outer part of a doorknob. Leave all other scaling
the same; you will scale down Knob later to fit with Door’s size.

Channel Box:

Layer Editor:
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Lesson: Creating and editing objects
Create and transform a base for the knob
In the next steps, you will create a cylinder and make it the base of the
doorknob. You also will learn about the Channel Box and the Outliner.

1 To create a cylinder, click the cylinder icon that is just above the scene view:

This set of icons is called the Shelf. Clicking the cylinder icon is equivalent to
the menu item Create > Polygon Primitives > Cylinder.

If your Shelf is not displayed, select Display UI Elements > Shelf. If the tabs
are not displayed at the top of your Shelf, select the downward pointing
arrow on the left side of the Shelf and select Shelf Tabs.

Along with Polygons, there are several other shelf tabs you can use. Also,
you might want to add other menu items to the shelf. If so, hold down Shift-
Ctrl-Alt and select the menu item.

2 Rename pCylinder1 to Base.

3 In the Channel Box, type 90 in the Rotate X box and press Enter. This rotates
the cylinder 90 degrees so it points in the correct direction for the knob.

Rotate X is one of the object’s attributes. Almost every aspect of an object’s
display, shape, or behavior is defined by attribute settings. The Channel Box
shows the most commonly used attributes. Such attributes are also known as
channels.

You could have changed Rotate X to 90 using the Rotate Tool. By using the
Channel Box, the transformation is quick and exact. When you type entries
in the Channel Box, it’s important to press the Enter or Tab key to make the
entry take effect.

Shelf
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ESSENTIALS A QUICK TOUR OF MAYA | 1
Lesson: Creating and editing objects
4 For the next steps, tumble the perspective view so that you see Knob from
the side. Make sure the Z axis of the View Axis icon points to the left like the
following figure.

5 In the perspective view, use the center handle of the Scale Tool to scale down
Base until it fits within the edges of Knob. This is roughly the proportion of a
doorknob base.

6 Move Base to the right (using the Move Tool), keeping a small portion of it
within the edge of Knob. Don’t be concerned with precision; estimate the
position.

7 Select Window > Outliner.
INSTANT MAYA
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Lesson: Creating and editing objects
The Outliner lists all objects in your scene. It is commonly used to select
objects that are hard to select in the scene view, such as overlapping objects.
To select an item in the Outliner, you click its name. You can also Shift-click
to select adjacent items and Ctrl-click to select nonadjacent items.

The Outliner is also useful for parenting one object to another. Any changes
to the parent’s transformations (translate, rotate, and scale) are propagated
to the child. For example, if you move a parent, the child moves with it. Note
that changes to a child do not affect the parent. This relationship is called a
hierarchy.

8 In the Outliner, use the middle mouse button to drag Base onto Knob. This
makes Knob the parent of Base, which becomes the child.

Later, you’ll transform both objects as one unit.

9 Close the Outliner.

Change the underlying structure of the doorknob
Next, you’ll work with the underlying structure of the doorknob base to
taper its shape. First, you need to change the view’s shading mode to see the
doorknob surface better.

1 In the perspective view, select Shading > Smooth Shade All.
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Lesson: Creating and editing objects
Smooth shading is useful when you want to see a solid exterior for objects in
the active view. The default display, Wireframe, is useful for seeing and
selecting parts of an object that would otherwise be hidden by the surface.
You can easily switch between wireframe and smooth shaded display modes
by pressing either the 4 or 5 hotkeys when the object is selected.

2 Select Door and select Display > Hide > Hide Selection so you can see the
doorknob better. When you create complex scenes, hiding is a convenient
way to control clutter.

Edit the components of Base

In the next steps, you will flare the Base where it
joins the Knob. To do this, you will edit its
components. The most important components for
editing objects are called vertices.

1 In the side view, dolly in for a closer view of Knob
and Base.

The side view shows the components better and
makes it easier to edit them. This view panel is still
in wireframe mode, which is easier for viewing
components than smooth shaded mode.

2 Right-click the wireframe of Base and select Vertex from the pop-up menu.

The menu is a marking menu for quickly selecting operations relevant to the
object where you right-click the mouse. In this case, the main choices pertain
to the display of the object’s components.

3 Drag a selection box around the column of vertices on the end of Base that is
facing Knob.

You will flare the Base
where it joins the Knob
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Lesson: Creating and editing objects
4 Select the Scale Tool. Use the center scale handle to scale the vertices
outward as illustrated below. (Ignore the warning message at the bottom of
the window.) In the perspective view, you can see how transforming the
vertices alters the shape of the object.

In addition to vertices, you can transform other component types to reshape
surfaces, such as polygon faces. Not all components can be transformed,
though; some are used only in more advanced operations.

Other surface types have different components. For example, NURBS
surfaces have control vertices (CVs) instead of vertices, and they operate a
little differently. You can learn more about CVs in Chapter 3, “NURBS
Modeling.”

5 To quit the component display mode and select the whole object, right-click
Base again and choose Select.

The wireframe on Base turns green, identifying it as a selected object. You
must select an object using either the Select or Object Mode methods of
selection before you can transform it as a whole object. It is important to
understand the differences between selecting items as components or
objects. If you ever have problems selecting an object, you can always select
it in the Outliner.
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Examine the creation-related attributes of Base
Another way to alter the structure of an object is to change the attribute
settings that were in effect when you created the object.

1 With Base selected, click the heading polyCylinder1 at the bottom of the
Channel Box under the Inputs section. The attributes that appear, such as
Radius and Height, were automatically created and given values when you
created the Cylinder.

These attributes are part of the object’s construction history. As you apply
certain menu items and operations to an object, the number of attributes that
make up the construction history grows. Maya keeps a construction history
in case you need to modify these settings. Different objects have different
attributes in their construction history.

2 Change the Subdivisions Axis to 30 and check the perspective view to see
how the shape of Base changed.

Subdivisions Axis controls the number of structural curves on the cylinder.
Increasing the number makes a smoother surface, but it also creates warps in
the shape. The warps occur because you have already altered the shape by
moving the vertices. To avoid unexpected results like this, do not make
construction history changes after you have transformed an object’s vertices
(or other components).

3 Change Subdivision Axis back to 20 so that Base no longer has warps.

In this example, changing construction settings is impractical. As you
become more proficient with Maya, you’ll find many situations where it’s
useful to modify attributes that were established at some point in the object’s
construction history.
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4 To see the effect of deleting Base’s construction history, select Edit > Delete
by Type > History. As a result, the attributes under polyCylinder1 are
removed.

One of the main reasons for deleting history is to improve Maya’s processing
speed as you work with objects. Deleting history can also aid in
troubleshooting a problem with an object by simplifying its history list. In
this case, there is no noticeable improvement, but you need to note that it
can make a difference with complex objects or scenes.

Use caution before deleting history. If you have done a number of modeling
operations, you can no longer change the settings of those operations after
you delete history. You can always modify an object’s shape in other ways,
such as moving vertices, but you’ll have less versatility after you delete
history.

If the concept of construction history seems initially complex, don’t be
concerned. The power of construction history will become increasingly
apparent as you gain experience with Maya. For now, the most important
concept is that you can click some of the headings in the Channel Box to
display more attributes that affect the selected object.

Position the doorknob
Now you’ll scale the doorknob and move it into proper position with the
door.

1 Select Display > Show > Show Last Hidden to see the door again.

2 Select Knob. By selecting Knob, Base is also selected because it is the child.

3 In the perspective view, scale down Knob in all directions to a size
appropriate for the door. The transformation applies to both Knob and Base
because of the parent-child relationship.

4 Move Knob forward, up, and to the edge of the door, as pictured below. You
may want to keep a small portion of the doorknob base within the door’s
surface so it looks like they’re connected.
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Duplicate the doorknob
Next, you will learn how to duplicate objects and use options windows.

1 With Knob selected, select the Edit menu and select the square box (❒ ) next
to Duplicate. A window appears with several duplication options.

The Duplicate Options window is an example of an options window. This type
of window contains attributes and other options pertinent to the menu item
selected, in this case, Edit > Duplicate.

You can alter many of the options later in the Channel Box. However, some
options, such as Number of Copies, cannot be changed later in the Channel
Box.
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Note that you can skip using an options window altogether, for instance, by
selecting the menu item Edit > Duplicate rather than Edit > Duplicate > ❒ . If
you skip the options window, that menu operation will use the settings that
existed in the options window the last time you used it. If you’ve never used
the menu operation, you get the default settings.

2 Turn on Instance.

When you create an instance, you do not create an independent copy of the
selected object’s geometry. The instance uses the geometry definition of the
original. Changes to the original geometry are therefore propagated to the
instance.

An instanced object uses less memory than a copy. The only disadvantage is
that you cannot change the instance’s components, such as vertices, to be
different from the original.

3 Click the Duplicate button. Maya creates a duplicate named Knob1 in the
same position as the original.

4 In the Channel Box, with Knob1 selected, change Rotate X to -180 and move
it to the opposite side of Door. Now you have two doorknobs—a complete
door.

Important

We wrote all lessons in this book with the assumption that you are starting
with the original default settings in options windows. If a step gives
unexpected results after you select a menu item with options, undo the
step, reset the options to the defaults, and then repeat the step.

In some windows, you’ll see a Reset Tool button that has the same effect as
the Edit > Reset Settings menu item.
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5 Select Edit > Duplicate > ❒ to open the Duplicate options window again.
(You won’t use the duplicate operation at this time, you’ll just examine and
reset its contents.)

Notice that the Instance option is still turned on for Geometry Type. Maya
retains any prior option settings you applied. Maya does this as a
convenience so that you can select Edit > Duplicate without having to open
the options window.

Because Maya retains option settings, you might get unexpected results if
you select Duplicate later and forget that you had set the options a certain
way. It’s a good habit to check options window settings if you’ve used the
options window before.

6 In the Duplicate options window, select Edit > Reset Settings. The Geometry
type reverts to the Copy option, which is the original default. Click Close to
dismiss the options window.

Group the parts of the door
One way to transform the door as one unit is to parent the knobs (Knob and
Knob1) to Door. Another way is to group the objects.

A group is like an invisible parent object. You use them for the same reasons
you parent objects: to organize objects in a hierarchy and to transform
objects together. In this case, parenting the knobs to Door is an acceptable
approach. But, suppose you have 10 doors that you want to move as a unit.
Rather than parenting nine of the doors to one other door, it is easier to
group them under a group object.

1 In the perspective view, Shift-click Knob, Door, and Knob1 to select them all.

2 Select Edit > Group to group the objects you selected.
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The three grouped objects become children of a parent group object that
exists in the Outliner but is invisible in the scene views. You can transform
all three objects by transforming the group.

3 Rename group1 to DoorGroup.

4 Click Door so that DoorGroup is not selected.

How do you select the group again? Use the Outliner or do the next step.

5 Press the up arrow key to select DoorGroup again. The up arrow moves the
selection from the current object to its parent.

Change the point of rotation to make the door swing open
Suppose you want the door to swing open as if on hinges. An easy way to
do this is to move the door’s pivot point and then rotate the door. In this
section you learn about working with pivots.

1 With DoorGroup selected, select the Rotate Tool. The Rotate Tool
manipulator appears at the origin of the scene, the default location for a
group pivot.

With the pivot in its current position, you cannot rotate the door in a
conventional door motion. Instead, the door would swivel around its center
like a revolving door.

2 Press the Insert key to enter the pivot point edit mode. Dolly in so you can
see the pivot manipulator.

The manipulator that appears is like the Move Tool, but it affects the pivot
point, not the object itself.

3 Looking at the wide side of the door, click the red handle (X axis) and drag
the manipulator to the left until it is aligned with the left edge of the door.
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You can optionally move the pivot up along the door frame’s edge to where
a real hinge would be. There is no benefit to doing this in this example.

4 Press Insert again to quit the pivot point edit mode. The Rotate Tool is
activated again.

5 In the perspective view, click the Rotate Tool’s green handle and drag left
and right. The door swings as you rotate DoorGroup. If the door rotates
differently from what you expect, simply select Edit > Undo to undo the
operation and select the appropriate handle and try again.

6 The pivot point affects the operation of the Move and Scale Tools also. Click
the Move Tool and then the Scale Tool to see that the pivot point is in the
same location for these transformation tools.

By default, changing the pivot point affects the pivots for all three
transformation tools. If needed, you can change the rotation and scale pivots
individually. To do this, you would open the Attribute Editor. This editor is
discussed next.

One other useful feature for pivots is the Center Pivot operation, under the
Modify menu. Suppose you want to scale DoorGroup in all directions. A
logical place for the pivot would be the exact center. In this situation, you
can use the Center Pivot operation rather than positioning the pivot directly.
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Display all attributes that affect an object
This final exercise introduces the Attribute Editor and the concept of nodes.

1 With DoorGroup selected, click the following icon in the upper right to open
the Attribute Editor:

The Attribute Editor replaces the Channel Box. (The icon to the far right
redisplays the Channel Box.)

The Channel Box contains the most commonly used attributes, while the
Attribute Editor includes all attributes, some of which are rarely used. For
example, you can set an object’s Shear, which slants an object, only in the
Attribute Editor.
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2 In a scene view, click Door. The Attribute Editor now displays Door’s
attributes.

The attributes that affect the Door appear under various tabs. Each tab
represents a node. In its simplest sense, a node is a collection of related
attributes. The nodes are interconnected to one another and their attributes
influence the display and behavior of the currently selected object. The
concept of nodes is important to unleashing the power of Maya.

For experienced users, the input and output connections between nodes can
be useful. For example, you can connect the rotation attribute of one sphere
to a second sphere, so the first sphere’s rotation serves as the input that
drives the second sphere’s rotation. Experienced users also examine input
and output connections to help identify problems in a scene.

3 Click the Door tab to see its attributes.

The first tab, Door, is known as a transform node, because the most
important attributes on the tab control Door’s transformation. Every visible
object has a transform node, including cameras and lights. The attributes in
the sections below the Transform Attributes section are less commonly used.
You don’t need to learn about them for this lesson.

4 Click the DoorShape tab to see its attributes.

This tab is called the shape node because the attributes establish the object’s
geometric shape or physical properties. Most objects have shape nodes, but
some do not, such as a group. The shape node also includes other types of
attributes, such as object display attributes.

5 Click the polyCube1 tab to see its attributes.

This is an input node that includes attributes similar to the construction
history attributes you examined for Base. The attributes of an input node are
passed to another node subsequent in the construction history—in this case,
to the DoorShape node. The polyCube1 node would not appear if you
deleted Door’s construction history.
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6 The last two nodes are initialShadingGroup and lambert1. If you can’t see
them, click the display arrow (Windows) or click over the hidden tabs and
select one of the nodes from the pop-up list (UNIX).

The initialShadingGroup and lambert1 nodes are default nodes that you
normally do not need to use. Maya uses them to establish the initial color of
objects and other settings related to shading. If you create your own shading
for the door, such as a wood pattern, these nodes would be replaced by the
new shading nodes you create.

You’ll encounter transform, shape, input, and shading nodes throughout
your work with Maya. There are also other types of nodes that you’ll learn
about as you advance your Maya skills.

As a new Maya user, it’s unnecessary to know the differences between each
type of node. It is important to understand that each node in an object’s
construction history has attributes that affect the object’s display and
behavior.

Save the scene
Do these final steps to save the work you created in this lesson.

1 Select File > Save Scene As.

A file browser lists a default directory where you can save the scene. If you
would prefer to save the scene in a location other than the default location,
for instance, an alternate hard drive on your network, you’ll need to cancel
the Save window and set up a new project first. See “About projects” on page
41.

2 For the name of the scene, type: DoorLesson. It is unnecessary to type a file
extension because Maya adds it automatically.

3 Click the Save button.

Windows UNIX
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Maya saves the file as DoorLesson.mb. The .mb extension indicates that you
saved the scene as a Maya binary file—the default file type for a Maya scene.

(If you have Maya Personal Learning Edition, Maya saves the file as
DoorLesson.mp, which is specifically designed for the Personal Learning
Edition and is the only file type available.)

The file browser has an option for saving the scene as a Maya binary file
(extension .mb) or as a Maya ASCII file (extension .ma). The Maya binary file
is often the preferred choice for many users, because it is more compact in
size than the ASCII version. Some experienced users prefer the ASCII file
type because it contains commands that can be troubleshot and edited
directly as an alternative to using the Maya interface.

Most lessons in this book do not include instructions for saving scenes. As
the emphasis of the lessons is on education rather than artistic prowess,
saving your work is optional but highly recommended.

Beyond the lesson
This lesson has provided the basic skills you’ll need to continue with the rest
of Instant Maya. There is much more to learn about the user interface,
including features that speed up your workflow.

Tip

The default directory for scenes is at the end of a long path under your
user directory. This directory does not always appear as the default when
you save or open files. To quickly point the browser to the directory where
scenes are kept, do one of the following:

(Windows) From the top of the Save window, select Current scenes.

(UNIX) Select File > Go to Current scenes.

Click here to select
Current scenes from
the pull-down menu.
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For example, to quickly select menu items without rolling the mouse pointer
up to the main menu bar, hold down the spacebar and a pop-up menu
display appears. This is the Hotbox.

The Hotbox puts the main menu items in easy reach of your mouse pointer.
By default, it includes the menus from the main menu bar and the panel
menus. Once the Hotbox is displayed, you select a menu item the same way
you select a regular menu item. For details on the Hotbox and other handy
features, see Using Maya: Essentials.

About projects
In the lesson, when you selected File > Save Scene As, the file browser
provided a default directory location for saving the scene. This scenes
directory is one of several directories Maya creates automatically for you. All
these directories are under your user directory, as established by your
system administrator.

Maya organizes scenes and other files into project directories. You
automatically have a default project directory, called default, but you will
probably create many more as you work with Maya. Many users prefer to
organize a collection of related scenes into a single project. For example, if
you plan to create several animation segments for a talking dog cartoon, you
might create a project named Dog.

If you look at the default project’s contents, you’ll see several directories
similar to the following figure. The contents depend on whether you use
Maya Complete, Unlimited, or Personal Learning Edition.
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The scenes directory contains the scenes you create. Depending on the types
of objects and effects you create in a scene, the other directories might
contain files used by the scene. You’ll learn more about some of these
directories and their contents in other lessons.

As a new Maya user, it’s initially unnecessary to understand the contents of
every directory. However, if you want to move a scene to a different
location, be aware that you must move the entire project rather than just the
scene. By moving the entire project, Maya will still be able to locate any files
referenced by the scene.

To save a scene in a location other than the default location:

1 Select File > Project > New.

2 In the Name box, enter a suitable name for the project, for instance,
my_lessons.

3 In the Location box, enter a new directory path. You can also click Browse.

4 Click the Use Defaults button.

5 Click the Accept button.

6 Select File > Save Scene As. The new default location will be under the
project directory you just created.

For further information and related techniques, refer to the online book
Using Maya: Essentials.
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Modeling is the process of creating the creatures and furnishings of your
scene. The goal of modeling is to create convincing three dimensional
surfaces, as computer-generated objects lack the internal substance of real
objects. There are three types of surfaces in Maya: polygons, NURBS, and
subdivision surfaces. Each has unique benefits and modeling techniques.

Polygonal modeling is useful for creating virtually any type of surface shape.
It excels for surfaces that include hard edges or facets, for instance, a
gemstone, jagged mountain, or hammer. It can also be used to create forms
with soft edges. If you need to create a surface that stays perfectly smooth as
you alter its shape, NURBS is a better choice. Creating a polygonal object is
simple, as you’ll soon see in the following lesson.

PREPARING FOR THE LESSON

To ensure the lesson works as described, do these steps before beginning:

1 Select File > New Scene to create a new scene.

2 Make sure the Construction History icon (below the menu bar) is on: . (If
it is turned off, it has a large X across it.)

3 Select the Modeling menu set. Unless otherwise noted, the directions in this
chapter for making menu selections assume you’ve already selected the
Modeling menu set.

4 Make sure Display > UI Elements > Help Line is turned on. You will use the
Help Line while modeling.
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LESSON: MODELING A SURFACE

In this lesson, you’ll learn simple polygonal modeling techniques. You’ll
create a hammer starting from a polygonal cube.

Create the foundation shape from a primitive
You begin the lesson by creating and scaling a cube into the rough shape of a
hammer handle. You’ll extrude a face of the handle to create a small box
shape that you will use as the foundation for the head of the hammer.

1 Select Create > Polygon Primitives > Cube > ❒ . In the options window,
select Edit > Reset Settings and click the Create button.

2 With the pointer in the perspective view, press 5 (for Shading > Smooth
Shade All).

3 Scale the cube into the general shape of a hammer handle. You’ll enhance
the shape later.

4 Move the cube so that its bottom lies on the grid
(see illustration).

5 Right-click the cube and select Face from the
marking menu.

Maya displays small squares at the centers of the
faces. To select a face, you select the small square.

6 Select the face center at the top of the cube.
Whenever you select a face, tumble the view in
several directions to check that you’ve selected only the desired face.

7 Select Edit Polygons > Extrude Face.

Maya creates a new face in the same position as the previously selected one.
The extrusion manipulator works like a combined Move, Rotate, and Scale
Tool, but it modifies the new face rather than the whole object.
INSTANT MAYA

44



POLYGONAL MODELING | 2
Lesson: Modeling a surface
8 Drag the blue arrow up a little to extrude the face (see the following figure).
The blue arrow turns yellow when selected. The resulting extension to the
surface will become the middle section of the hammerhead between the claw
end and the pounding end.

9 Examine the parts of this manipulator, as shown in the following illustration.
It is called the Show Manipulator Tool and appears for various operations
throughout Maya.
INSTANT MAYA

45



POLYGONAL MODELING | 2
Lesson: Modeling a surface
Note that if you cancel the selection of the face, the manipulator disappears
from the face. To display the manipulator again, select the face, select
Modify > Transformation Tools > Show Manipulator Tool, then click the
polyExtrudeFace# in the Channel Box.

Extrude claws
Now you’ll split one of the faces of the extruded shape into two parts. From
these two parts, you’ll create the claw end of the hammerhead.

1 Select Edit Polygons > Split Polygon Tool.

2 Click one of the top, narrow edges as shown.

3 Middle-drag the point roughly to the edge’s midpoint. If you are a
perfectionist, examine the Help Line as you drag the point. When you see
Percentage: 50%, the point is at the midpoint.

4 Click the bottom edge of the face and similarly drag the pointer to its
midpoint. Press Enter to divide the face into two.

Move handle

Scale handle

Rotate handle
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5 Right-click the cube and select Vertex from the marking menu.

6 Select the vertices at the top and bottom of the edge that divides the two
faces. (If the vertices are hard to see, press 4 to select wireframe display
mode.) Examine the object from several camera views to make sure you
haven’t accidentally selected extra vertices.

7 Select Edit Polygons > Split Vertex. The reason for splitting the vertices is
explained later.

8 Select the two split faces. (To display the face centers, right-click the cube
and select Face from the marking menu.)

9 Select Edit Polygons > Extrude Face > ❒ . In the options window, enter 6 for
Divisions, then click the Extrude Face button. You may need to scroll the
option window to access the Divisions option.

A manipulator appears on one of the faces. Because two faces were selected
when you selected Extrude Face, the manipulator controls the extrusion of
both faces.

A single face
split into two faces

Select and split these vertices
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10 Drag the blue arrow outward to extrude the faces to a length appropriate for
a hammer claw.

When you extrude the faces, the length of the
extruded surface will have six subdivisions
rather than the default single subdivision.
With the extra subdivisions, it will be easier
to modify the extrusion into a claw shape in
a later step.

11 Drag the red scale manipulator (the small
cube) inward to narrow the blades, then drag
the green scale manipulator up to flatten the
blades at their tips. (See the next figure.)

This creates the preliminary shape of the hammer’s claw.

In a prior step, you split the vertices at the top and bottom of the edge that
divided the two faces. This created two additional, overlapping vertices at
each split vertex (a total of six vertices). The extra vertices were necessary to
create a gap between the blades. Without the extra vertices, the two blades
would be a solid single blade.

Note that if you had extruded each face individually to create the two
blades, you would not have needed to split the vertices to create the gap.
However, it would have been harder to make the two blades exactly the
same length, width, depth, and so on.

When you extrude two or more faces at the same time, the manipulators
influence both identically. Symmetry is ensured.
INSTANT MAYA

48



POLYGONAL MODELING | 2
Lesson: Modeling a surface
Adjust the claw’s shape
Now you’ll enhance the curvature of the claw’s blades and split the blades
apart more. You will use the same extrude manipulator. If the manipulator is
not displayed because you mistakenly cancelled the selection of the faces,
select the extruded faces of the claw, select Modify > Transformation
Tools > Show Manipulator Tool, and click polyExtrudeFace2 in the Channel
Box.

1 Click the large circle surrounding the manipulator to display the rotate
manipulators. Drag the red circular manipulator down a bit to rotate the
extrusion (see the following figure).

Rotating the angle of extrusion will help you to shape the claws downward
in the next few steps.

2 Drag down the green and blue arrows a short distance to begin shaping the
claw downward.
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3 Right-click any part of the surface and select Vertex from the marking menu.
Each subdivision of the claw has a group of vertices that separate it from the
adjacent subdivision (see the following figure). Move each of these groups
down or up a small distance to make the claw arch downward. (Drag one
group of the vertices at a time.) You can shift-drag to constrain the
movement of the vertices to a straight line.

Two views of a completed example follow:

Extrude the pounding head
In the next steps, you’ll extrude a face to create the pounding end of the
hammerhead.

1 Select the back face of the polygonal hammerhead.

2 Select Edit Polygons > Extrude Face > ❒ . In the options window, set
Divisions to 1 and click the Extrude Face button. Move the face outward a
short distance.

Move these groups of
vertices to shape the claw
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Also scale the extrusion inward along all three axes. To do this, click any of
the scale manipulators to display a general scale manipulator at the center of
the manipulator axes. Drag the center manipulator left to shrink the overall
scale. This tapers the middle section of the pounding end of the head.

3 Select Edit Polygons > Extrude Face again and move the face outward again.
Scale the extrusion outward along all three axes.

4 Select Edit Polygons > Extrude Face one more time and move the face
outward. Leave the scale the same as the last extrusion.
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Create a depression at the top of the head
Now you’ll extrude the top of the hammerhead inward and down to create a
pit or depression. Hammers often have such pits where the handle is
fastened to the head.

1 Select the face at the center top of the hammerhead.

2 Select Edit Polygons > Extrude Face and scale the extrusion inward along all
three axes.

3 Select Edit Polygons > Extrude Face and drag the extrusion down. This
creates the pit in the hammerhead.
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Taper the handle
A real hammer handle is narrower near the head than at the base. In the next
steps, you’ll adjust the width of the handle. First, you need to subdivide the
faces of the handle to add extra vertices.

Currently the handle has only four vertices, one at each corner. With vertices
only at the corners, you can taper the ends of the handle but not other
regions. By creating extra vertices throughout the handle, you can tune the
shape wherever you choose.

1 Select the faces of the handle, including the bottom face.

2 Select Edit Polygons > Subdivide > ❒ . In the options window, enter 2 for
Subdivision Levels, then click the Subdivide button.

This divides the selected faces into multiple faces with corresponding extra
vertices. You can then make fine alterations to the handle’s shape.

While writing this lesson for your use, we learned that a Subdivision Levels
value of 2 worked well only after trying an entry of 1. The 1 entry didn’t
provide enough vertices and faces to allow for subtle shaping of the handle.

Note that you could have subdivided the handle faces using the Split
Polygons Tool described earlier in the lesson. Subdivide is easier to use
because you merely select the face you wish to subdivide. You don’t need to
select exact positions on the faces. The disadvantage is that you might end
up with more faces and vertices than you want to work with.

The advantage of the Split Polygons Tool is that you create only the number
of faces and vertices you want, which makes the surface simpler to edit and
faster for Maya to process.
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3 To see the vertices, right-click the hammer and select Vertex from the
marking menu. Display the hammer in wireframe mode by clicking the 4
hotkey.

4 Scale each row of vertices on the handle inward as desired. A row refers to
the vertices that are at the same height along the edges of the handle. If a few
vertices lie at an odd location, that is, they lie a little above or below a row,
move them into a position even with the row.

Besides scaling a row of vertices, you can also move a row of vertices up or
down the handle to alter the contours.

5 In the next part of the lesson, you’ll smooth the edges of the hammer so it
looks more authentic. Before doing this, you might want to tune the
hammer’s shape by modifying your prior extrusions or by moving or scaling
vertices.

To modify an extrusion, first select the face or faces, and then select
Modify > Transformation Tools > Show Manipulator Tool. Next, click each
polyExtrudeFace# in the Channel Box until the extrude manipulator appears
on the desired extrusion.

Be aware that you can move and scale a face with the standard Move Tool
rather than the Show Manipulator Tool. However, the Show Manipulator
Tool moves the face in the direction of the surface normal rather than in a
direction along the View Axis. This surface normal direction is usually the
desired direction.

Row of vertices
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Smooth the edges and make final adjustments
Now you’ll smooth the edges of the hammer. Smoothing the edges adds
more vertices, which means it will be harder to select vertices when you
reshape the surface thereafter. Generally it’s best to hone the shape as much
as possible before you smooth edges.

1 Decide which edges you want to smooth. For each edge to be smoothed,
select the faces that lie on each side of it. For example, to smooth all edges
except those on the claw, select the faces as shown in the following
illustration.

2 Select Polygons > Smooth. After smoothing, you may see some vertices at
improper positions. For example, you might see a vertex jutting out at the
base of the handle.

3 Select each improperly positioned vertex and
move it to a position where the surface looks
symmetrical. Strive for uniform, regular vertex
and edge positions.

If there are improperly positioned edges or extra
edges that make the hammer lumpy, you can
either select them and move them or delete the
unwanted edges by using the
Edit Polygons > Delete Edge tool. If you need to
add an edge, do so with Edit Polygons > Split
Polygons Tool as shown previously in the lesson.

Improper vertex position
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4 Notice how the pounding end of the hammerhead
has a rounded shape. On a real hammer, this end
is flat. To flatten the end, select the vertices there.
It’s easiest to do this in a front view by dragging a
selection box around the vertices.

5 In the Toolbar double-click the Move Tool so the
tool settings window is displayed.

6 Turn off Retain Component Spacing under the
Move Snap Settings section. This will ensure that
the following steps work as described.

7 Turn on Snap to Grids:

8 Move the vertices straight out from the head until they snap to a position
while working in an orthographic view. This makes the vertices lie on the
same plane, though maybe not the plane you want. Turn off Snap to Grids,
then drag the vertices back toward the hammerhead to the desired position.

9 Feel free to enhance the positioning of other vertices anywhere on the
hammer. Be aware that you can smooth edges more than one time. For
example, if you want a rounder pounder, select the faces surrounding the
edges of the pounder and use Polygons > Smooth again.
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The hammer will look smoother when you render an image from the scene
as compared to displaying it in the scene view. Examples of rendered images
follow:

Beyond the lesson
You can create extravagant polygonal models with surprisingly few
techniques. Starting from a primitive surface such as a cube, you extrude,
split, scale, move, and rotate faces of the primitive to create a rough likeness
of the object. You then adjust vertices to tune the shape, and finally smooth
the edges between faces where desired.

Polygonal modeling has many timesaving features not covered in the lesson.
For example, Boolean operations are a popular way to create a new object
from the intersection of two existing objects.

If you’re planning to use your polygonal surfaces where the poly count is
constrained, such as with computer games, be aware that Maya has plenty of
tools for minimizing the number of polygonal faces of an object. Fewer faces
means simpler geometry— critical for computer games, where fewer
polygons means faster play speed.

“Lesson 2 Sculpting a surface” on page 63 describes how to use the Sculpt
Surfaces Tool. With this tool, you can drag your mouse to push, pull, and
smooth a surface without first selecting vertices. Though that lesson shows
how to shape a NURBS surface, you can apply most of the same techniques
to polygonal surfaces with its polygonal counterpart, the Polygons > Sculpt
Polygons Tool > ❒ .

For further information and related techniques, refer to the online book,
Using Maya: Polygonal Modeling.
INSTANT MAYA

57



POLYGONAL MODELING | 2
Lesson: Modeling a surface
INSTANT MAYA

58



3 NURBS MODELING

NURBS modeling is best-suited to creating organic, flowing surfaces such as
animals, human bodies, and fruit. NURBS (Non-Uniform Rational B-Spline)
also excel for creating industrial surfaces, for instance, automobiles, clocks,
and toasters.

This chapter includes these lessons:

• “Lesson 1 Revolving a curve to create a surface” on page 60

• “Lesson 2 Sculpting a surface” on page 63

• “Lesson 3 Lofting curves to create a surface” on page 75

PREPARING FOR THE LESSONS

To ensure the lessons work as described, do these steps before beginning:

1 Select File > New Scene to create a new scene before starting each lesson.

2 Make sure the Construction History icon (below the menu bar) is on: . (If
it is turned off, it has a large X across it.)

3 Select the Modeling menu set. Unless otherwise noted, the directions in this
chapter for making menu selections assume you’ve already selected the
Modeling menu set.
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LESSON 1 REVOLVING A CURVE TO CREATE A SURFACE

In this lesson, you’ll learn simple NURBS modeling
techniques. First you’ll create a curve in the shape of an egg
holder’s profile. Then you’ll use a revolve operation on the
curve to create the egg holder’s surface.

Create and revolve a profile curve
Revolve is a common modeling technique similar to shaping a vase on a
spinning potter’s wheel. With Maya, you draw a profile curve and use the
revolve operation on the curve to create a surface.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 59.

2 Select Panels > Layouts > Four Panes so you can see multiple views of the
scene.

3 Select Create > CV Curve Tool. This is the most commonly used tool for
drawing curves.

4 In the front view, click the numbered
positions as shown in the figure. Make sure
the first and last positions are on the grid’s Y-
axis (the thickest vertical line of the front
view’s grid).

Also, click three times in the same spot for
positions 9, 10, and 11. This is necessary to
create a sharp point or corner in the curve.

To change the position of the most recent
point clicked, you can middle-mouse drag it.

5 After you click position 13, press Enter to
complete the curve’s creation.

The points you clicked in the scene view
become the control vertices (CVs) of the
completed curve. CVs are points you
manipulate to alter the shape of a curve (or
surface). These points often lie away from the curve.

1
2

3

4

5

6

7

8

9, 10, 11
1213

Origin
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It takes a little practice to be able to predict exactly where a curve will be
positioned when you click CV positions with the CV Curve Tool. Once
you’ve learned the technique, you’ll be able to create and edit curves with
graceful symmetry. By default, you must click at least four points to create a
curve with the CV Curve Tool.

Also note that, for some advanced operations in Maya, you need to know the
meaning of the start of a curve and the curve direction. The start of a curve is
the first CV you create when you draw the curve. It is indicated by a small
hollow box at the first CV, visible as you create the curve. Curve direction is
shown on the second CV after the start of the curve, indicated by a small u
icon as you create the curve.

6 With the curve selected, select Surfaces > Revolve. This creates the egg
holder surface from the revolved profile curve. Examine the results in the
perspective view.

Maya does not delete the profile curve. In a subsequent step, you’ll edit the
profile curve to alter the shape of the surface.

7 With the surface selected, name it Eggholder.

8 With the pointer in the perspective view, press 5 (for Shading > Smooth
Shade All). This displays the egg holder as a shaded surface rather than a
wireframe in the perspective view.

9 Press 1, 2, and 3 to switch between the different degrees of display
smoothness. (These hotkeys correspond to the menu items under
Display > NURBS Smoothness.)

The finer the smoothness, the greater the impact on interactive performance.
Although you probably cannot notice the impact in a small scene like, you
might if you had a complex model.

The smoothness display only affects the scene view. Rendered images
display with high quality smoothness regardless of this setting.
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Edit a revolved curve

After you create a surface from a revolved
curve, you can reshape the curve to reshape the
surface. This is possible because Maya’s
Construction History feature was turned on
before you did the revolve operation.

1 Select the curve you revolved, curve1, in the
Outliner. The curve becomes highlighted in the
scene views.

2 In the front view, right-click exactly on the
curve and select Control Vertex from the
marking menu.

3 Select and move one or more CVs to adjust the
curve shape as desired. If you have trouble
selecting one of the CVs in the front view, select it in the perspective view
after dollying and tumbling the camera as necessary.

This modifies the shape of the egg holder because it is linked to the shape of
the curve by its construction history.

4 If desired, save the scene for future examination.

Revolved curve
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Beyond the lesson
Revolving a curve is the easiest way to create surfaces with radially
symmetrical forms—vases, flying saucers, glasses, pillars, and so on.
Surfaces are webs of interconnected curves. The curves help you create and
modify surfaces. Proficiency at drawing and editing curves is an important
part of NURBS modeling.

You cannot render curves, so your work with them is always an adjunct to
creating and editing surfaces. Besides moving a curve’s CVs to alter its
shape, you can cut, attach, extend, close and smooth curves. After you create
a surface from a revolved curve, you can move CVs or scale groups of CVs
on that surface to customize the shape of the surface.

LESSON 2 SCULPTING A SURFACE

This lesson shows how to sculpt a cartoon face and
head. You’ll create the head from a NURBS sphere and
sculpt facial features with the Sculpt Surfaces Tool.

Prepare a sphere for sculpting
Because a head is roughly spherical, you can create a
primitive sphere as a quick starting point for creating a
head and face.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 59.

2 Select Create > NURBS Primitives > Sphere > ❒ . In the options window,
select Edit > Reset Settings, enter the following values, then click the Create
button:

Radius: 6
Number of Sections: 30
Number of Spans: 30
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The Radius sets the sphere’s size in grid units. A
value of 6 creates a sphere big enough to use the grid
for size comparison.

The Number of Sections sets the number of vertical
curves, called isoparms, for the sphere. Isoparms
show the outline of the surface shape. The more
isoparms a surface has, the more CVs it has. (By
default, CVs are not displayed.) More CVs means
better precision as you edit a surface. The Number of
Spans sets the number of horizontal isoparms.

The drawback to having too many CVs is that you’ll have a harder time
making smooth shape changes to broad regions. Lots of CVs also means
slower processing time as you work with the surface. It’s best to make
surfaces with as few CVs as necessary.

We chose 30 Sections and Spans for this lesson because experience has
shown that this allows adequate facial subtlety without slowing Maya
operation on a workstation of modest processing power.

3 Name the sphere Egghead.

4 Rotate the sphere so that its Rotate Z attribute is 90. This positions the
sphere’s CVs well for modeling a simple head and face. You’ll learn why
later in this lesson.

5 To give Egghead an oval shape, increase its
ScaleX to 1.3 or so. Optionally, you can move
Egghead above the grid so the grid doesn’t
interfere with your view of Egghead. Also,
position the camera view so the Z-axis of the
View Axis points toward you.

Note

In wireframe display mode, if you select Display > NURBS Smoothness >
Fine or Medium, more isoparms appear than there are actual spans and
sections. The surface is visually displayed with extra precision, but the
extra isoparms have no CVs and cannot be edited.
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Increase surface highlights for easier sculpting
Because you will do subtle surface modeling in this lesson, it’s helpful to
display Egghead with bright highlights so you can clearly see the effects of
the changes you make. In the next steps, you’ll assign a Blinn material to
Egghead to give its surface bright highlights. The steps have no
explanations, as the shading subject matter is the focus of a later lesson.

1 With Egghead selected, press 5 to display the surface with smooth shading.

2 Right-click Egghead and select Materials > Assign New
Material > Blinn.

The Attribute Editor will immediately be displayed for
the Blinn material.

3 Drag the Color attribute slider roughly 3/4 of the way to
the right, set Eccentricity to 0, and close the window.

Practice sculpting with basic features
In the next steps, you’ll become familiar with features of the Sculpt Surfaces
Tool. With this tool, you use your mouse or stylus to push, pull, or smooth a
surface’s shape without selecting or displaying CVs. After you practice
sculpting the surface, you’ll erase your practice strokes then begin sculpting
Egghead’s features.

1 With Egghead selected, select Edit NURBS > Sculpt Surfaces Tool > ❒ . In the
Tool Settings window, click Reset Tool, and make sure the Sculpt tab is
displayed.

In the Operation section, there are four operations for sculpting the surface.
Each affects the region of the surface where you drag (stroke) your mouse or
stylus relative to the surface normals:

Operation Effect

Push Depresses the surface

Pull Raises the surface

Smooth Diminishes bumps or ridges
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2 Experiment with each of the four operations on the surface. Don’t be
concerned with the results. Just become familiar with the response to your
mouse strokes.

By default, Push and Pull strokes deform the surface in a direction normal
(perpendicular) to the surface. To create the resulting deformation more
accurately, use Push and Pull strokes in a front, side, or top view while
examining the results in a separate perspective view. Tumble the perspective
view regularly for best visual feedback.

When you position the mouse pointer on the surface, it changes to a red
sculpt icon that shows an abbreviation for the name of the operation you are
performing. For instance, Ps stands for Push.

The red icon also displays the radius of the region affected by the stroke. The
Radius(U) value changes the radius.

3 Select the Erase operation and click the Flood button. This erases all your
changes.

4 Select the Pull operation and enter a Radius(U) of
0.25, then drag between a pair of horizontal
isoparms without crossing either.

This has no effect because the stroke radius
didn’t make contact with the CVs of either
isoparm. Regardless of which operation you use,
only CVs are affected by the strokes.

Erase Eliminates the effects of the other three
operations. The Erase operation works up to
the last time you saved the scene or clicked
the Update button to the right of Erase Srf.

Operation Effect
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5 Change the Radius(U) to 2 and repeat the prior strokes.

The strokes alter the surface because the radius
overlaps the CVs. As this example shows, you
need to make sure the radius is big enough to
influence the desired CVs. It’s common to change
the radius many times during a sculpting session.

Note that if you prefer to affect a small region
without increasing the radius, you can add CVs to
the region by inserting more isoparms. You’ll do
this later in the lesson.

6 Flood-erase the changes to the surface as you did
previously.

7 Select the Pull operation with a Radius(U) of 0.5. Drag along a vertical
isoparm. For comparison, drag along a horizontal isoparm.

The vertical stroke creates a thinner ridge than the horizontal stroke because
the density of vertical isoparms is greater. The number of underlying CVs
and their positioning affects the outcome of your strokes.

Tip

You can alternatively adjust the radius of the sculpting tool using a
Hotkey. Move the tool over the object, press and hold the b Hotkey and
drag left or right. The circle on the object with numerical radius value
represents the size of your tool. Stroke on the object to try out a new size

Before taking the snapshot for this figure, we set the
Wireframe on Shaded on the Display tab to None
(Window > Setting/Preferences > Preferences). This
turned off highlighting of the surface isoparms,
making surface alterations easier to see. Consider
switching between the off and on settings for Show
Wireframe as you learn the Sculpt Surfaces Tool.
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8 Flood-erase the changes to the surface as you did previously.

9 Rotate the camera view so the X axis of the View Axis points toward you.
Draw a vertical Pull stroke again.

As your stroke nears the center of Egghead, a kink occurs. It’s challenging to
alter a surface symmetrically in a region where many isoparms converge at a
single point, called a pole. Always consider the position of isoparms as you
sculpt a surface. In general, sculpt where isoparms are evenly, regularly
distributed.

10 Erase all changes again, then reposition the camera view so the Z-axis of the
View Axis points toward you.

Practice additional techniques
Now that you’ve learned the basic features, you’ll learn other useful
techniques before starting to model the facial features.

Tip

If the Sculpt Surfaces Tool is selected but not the surface you want to work
on, right-click the surface and select Select from the marking menu.
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1 In the Tool Settings window of the Sculpt
Surfaces Tool, enter 2 for the Max Displacement.
Draw a vertical Pull stroke. Change the Max
Displacement to 1 and draw another vertical
stroke nearby.

The Max Displacement sets the maximum
distance the surface’s CVs are pushed (or pulled)
with a single stroke.

2 Erase the changes to the surface.

3 Enter 2 for Max Displacement. Draw a vertical
Pull stroke. Change Opacity from the default
value of 1 to a value of 0.2, then draw another vertical stroke nearby.

One ridge is higher than the other. The Opacity value scales the influence of
Max Displacement. For example, with an Opacity of 0.2, each stroke has only
roughly 0.2 times the effect of the Max Displacement setting.

It’s generally best to use a low Opacity value as you Push or Pull. You can
increase the deformation gradually with multiple strokes.

If you want to affect only a small region of a surface, use your mouse to click
rather than stroke the region. If the Radius(U) and Opacity of the brush is
small, you might need to click the nearest intersection point of two isoparms.

4 With Opacity set to 1, erase all changes to the surface again.

Tip

Consider using an electronic tablet with pen stylus. A pen stylus is more
natural for stroking surface changes as it feels like a pen. With a stylus, you
can set an option that causes the Radius or Opacity to vary with stylus
pressure. For example, you can have heavy strokes create a bigger Radius
than light strokes.

To do this, display the Stroke tab of the Sculpt Surfaces Tool. For Stylus
Pressure, select Opacity, Radius, or Both. Radius is a common choice. If
you select Radius, the Radius(U) value on the Sculpt tab sets the maximum
radius, while Radius(L) is the minimum. Explore various settings.

If you use a mouse, set the Stylus Pressure to None. The Radius(U) sets a
fixed radius. Radius(L) is ignored.
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Create a nose
Now you’ll begin sculpting Egghead’s face, starting with a simple nose.

1 Position the perspective view so the Z-axis of the View Axis points toward
you.

2 Reset the Sculpt Surfaces tool.

3 Select the Pull operation and set the following options:

Radius(U): 1
Opacity: 0.2

4 Select this Shape setting so your strokes have a soft, faded edge:

5 Above the midpoint of Egghead, stroke vertically downward from the top of
the nose to the tip—about the distance between two horizontal isoparms (see
the following illustration). Use several strokes to build up the bridge of the
nose. Create nostrils by stroking horizontally to the right of the tip of the
nose a few times, then to the left of the tip a few times.

To build up a small area, position the stroke icon there and click the mouse
rather than drag. Tumble the view to examine your results after each stroke
or click.

If the strokes create a bumpy surface, turn on the Smooth operation and click
Flood once or twice to smooth all strokes on the surface. Because Opacity is
0.2, the Smooth operation is subtle. Alternatively, you can smooth a selected
region by stroking just that area. It’s common to smooth a surface regularly
while using pull and push strokes.

Because there are relatively few isoparms in the nose
area, you can only create a simple nose that’s broad
and rounded. If you want to create sharper features, for
instance, depressed nostrils or sharp ridges, you’ll need
to insert isoparms in the nose region. “Create a mouth”
on page 71 describes how to insert isoparms.

Create eye sockets
Eye sockets provide an inset and backdrop for eyes.

1 Select the Push operation.
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2 Leave other settings the same as for the nose.

3 To make a pair of identical eye sockets, display the Stroke tab of the Tool
Settings window and turn on Reflection. Position the sculpt icon on
Egghead. A pair of identical Push icons appears on Egghead.

4 Adjust the positioning as desired for the sockets. Click the mouse many
times in the desired location.

In your future work, keep in mind that on some
surfaces, the position of the mirrored stroke icons
might appear vertically or diagonally opposite one
another rather than horizontally. There’s a simple
technique for adjusting the positioning. With
Reflection and U Dir turned on, try various slider
positions for U Dir. If the positioning isn’t correct,
turn on V Dir and try various slider positions for V
Dir. Make subtle adjustments by moving the brush
icon.

Create eyebrows
Eyebrows help define how stern or pleasant a face appears.

1 Select the Pull operation. Use the same option settings as for the eye sockets,
including Reflection.

2 Position the sculpt icons above the eyes and draw
horizontal strokes. If necessary, click positions
where you need to build up the eyebrows. Smooth
the eyebrows as necessary.

Create a mouth
With the 30 Sections and 30 Spans specified for the
original sphere in this lesson, the large space
between isoparms in the mouth region makes it
impossible to create a subtle shape for the lips.
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To overcome this problem, you must insert isoparms
in the mouth region before sculpting.

1 Right-click Egghead and select Isoparm from the
marking menu.

2 Select the Select Tool.

3 Click the horizontal isoparm below the nose and
shift-click the next two below it.

4 Select Edit NURBS > Insert Isoparms > ❒ . In the options window, turn on
Between Selections, enter a value of 2 for # Isoparms to Insert, then click
Insert.

This inserts two extra isoparms between each pair of
selected isoparms, for a total of four extra isoparms.
This provides enough CVs to create subtlety in the
mouth.

You might want to add vertical isoparms at the lips in a
similar way. The extra isoparms would also be useful if
you were to later enhance the shape of the nose. Insert
isoparms only where needed. More isoparms means
slower processing speed.

In any case, do not change the number of isoparms by editing the original
number of Sections and Spans in the makeNurbSphere history node. This
will reshape your sculpted surface undesirably.

5 Select the Sculpt Surfaces Tool again.

6 Select the Push operation. Enter 0.2 for Radius(U). In the Stroke tab, make
sure Reflection is turned on.

Too few isoparms
for subtle shape
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7 Starting at the center of the area appropriate for the indentation between the
lips, stroke outward from the center. It’s best to start the stroke with the dual
icons on top of one another (in other words, only one icon is displayed).

8 Select the Pull operation and set the Radius(U) to 0.3. Using a similar
technique as for the prior step, stroke the upper lip. Repeat for the lower lip.

It might be easier to push or pull the lips with the Ref.
Vector set to Z Axis. This moves the region you stroke
in the world Z-Axis direction. The default Normal
setting moves the region in a direction normal
(perpendicular) to the surface. Because the normal
direction on a lip might be up, down, or straight out,
depending on the part of the lip you stroke, there’s
more possibility of undesired results when you use the
Normal setting.

Create other facial features
You can now optionally add other facial features. Consider these tips:

• For facial features such as the chin, cheeks, and forehead, use a Radius(U)
larger than 1 and start with a Maximum Displacement between 0.5 and 1.

• Insert isoparms wherever you want to add extra detail with the Sculpt
Surfaces Tool.

• To create eyeballs for the sockets, create a sphere and scale it as necessary to
fit the socket. You might want to increase the eyeball’s Scale X value to make
it oblong. To duplicate the eyeball, and make a mirrored copy of the original
you’ll first need to set the pivot point for the eyeball to be at the origin 0, 0, 0
using the following steps. With the sphere selected, select the insert key so
that the sphere’s pivot point is displayed. Next move the pivot point to the
origin using the X hotkey so that the pivot snaps to the grid at 0, 0, 0. Select
insert to turn off the pivot point display. Finally, use Edit > Duplicate > ❒

and set the Scale setting to -1, 1, 1. This makes the new eyeball a mirrored
duplicate of the original on the opposite side of Egghead’s face. Position the
eyeballs in the sockets. Parent the eyeballs to Egghead.

• To create simple, unadorned ears, you can create, scale, and squash a sphere.
Create ridges and valleys by pulling CVs or by using the Sculpt Surfaces
Tool. Duplicate the ear by first setting its pivot point to the origin and with
the Scale option set to -1, 1, 1. Parent the ears to Egghead.
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Beyond the lesson

Primitives

The NURBS sphere you sculpted in the lesson is one of Maya’s built-in
geometric shapes known as primitives. Other primitives include spheres,
cubes, cylinders, circles, and planes.

After you create a primitive, you typically sculpt, scale, trim, or otherwise
alter the object into a more complex shape. Though most primitives are
surfaces rather than curves, they still derive their shape from curves.

You can alter the shape of primitives with the same techniques you use with
NURBS curves and surfaces. You don’t need to learn specialized component
details for different types of NURBS objects.

Sculpt Surfaces Tool

The Sculpt Surfaces Tool is indispensable for quickly shaping a variety of
surfaces. As you do your own projects, pay special attention to the position
and density of isoparms before you begin sculpting.

For example, when you created the original sphere in this lesson, you
rotated it 90 degrees around its Z-axis. With this orientation, isoparms
converge at a single point (the pole) roughly where each ear would be
positioned. Because pole regions are hard to sculpt, it’s best to avoid using
the Sculpt Surfaces Tool there. If you want the head to have ears, it’s easiest
to model a pair of ears and parent them to the head.
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If you hadn’t rotated the sphere 90 degrees in Z, the isoparms would have
converged at the crown of the head and the base of the head. This might
pose problems if you needed to shape the crown of the head, for instance to
create a pointy head. If necessary, you can create a hat and cover the head.
As you gain NURBS modeling experience, you’ll learn how to use the
density and orientation of isoparms to your advantage.

In general, a sphere makes a convenient foundation for creating a simple
head, but it’s not ideal if you plan to animate an expressive, talking head.
Many 3D artists start with a cylinder or a lofted surface. The procedures for
doing this are more complex than starting with a sphere and beyond the
scope of this lesson.

Another useful modeling technique:

If you saved the Eggholder scene in the prior lesson, you can
import the egg holder into this Egghead scene, then position
Egghead into the egg holder. To import the egg holder into
the Egghead scene, use File > Import and select the name of
the scene that contains Eggholder. Importing a scene
imports all objects from that scene. Increase (or decrease) the
scale of the egg holder (or Egghead) as necessary for a snug
fit.

LESSON 3 LOFTING CURVES TO CREATE A SURFACE

In this lesson, you’ll create the body of a salt shaker by lofting
several profile curves. Lofting is like stretching a canvas over a
series of contour curves. Later in the lesson, you’ll create the cap
of the salt shaker by modifying the shape of a sphere.

Create curves as a foundation for a surface
You begin the lesson by creating a pair of profile curves. Later,
you’ll create several copies of these curves to form the skeletal contours of
the salt shaker’s surface.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 59.
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2 Select Create > NURBS Primitives > Circle > ❒ . In the options window,
select Edit > Reset Settings, enter the following values, then click the Apply
button:

Radius: 4
Number of Sections: 24

The Radius sets the size of the circle in grid units. A value of 4 creates a
circle with enough size so that you can use the grid for convenient size
comparison.

The Number of Sections sets the number of CVs in the circle. By using 24
CVs, you can create a circle with the subtle contours required in this lesson.
Display the CVs of the circle to see the 24 CVs.

A circle is a curve that loops back on itself. The CVs work the same way as
for any other curve. The more CVs you create for a curve or surface, the
more detail you can give its shape.

The drawback to using many CVs is that you’ll have a harder time making
smooth shape changes to broad regions. Also, more CVs means slower
processing time as you work with the curve. It’s best to make curves with as
few CVs as necessary. With experience, you’ll learn how many CVs to use in
a situation.

3 Create another circle, this time with these options:

Radius: 2
Number of Sections: 24

This creates a smaller circle inside the prior circle. A
top view of the circles follows:

4 Right-click the inner circle and select Control Vertex
from the marking menu. Repeat for the outer circle.

5 Turn on Snap to Points (below the menu bar).

6 As shown in the following figure, move CVs from the outer circle to the
corresponding inner circle positions. As you drag a CV near its destination,
the Snap to Points mode causes the CV to jump to the exact CV position.
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7 Turn off Snap to Points. Turn off the display of CVs on both circles.

Duplicate curves to be lofted into the surface
In the next steps, you’ll create several copies of the previously created circles
(also called curves) to form the skeletal contours of the salt shaker’s surface.

1 Right-click the outer curve and select Select from the marking menu.

2 Select Edit > Duplicate > ❒ . In the options window, select Edit > Reset
Settings, enter the following values, then click Duplicate:

Translate: 0, 3, 0
Scale: 0.93, 1, 0.93
Number of Copies: 4

This creates 4 copies of the original curve, each translated 3
units above the last, and each scaled smaller than the last.

3 Move the inner circle to 0, 13, 0 by entering these translate
values in the Channel Box. Increase its Scale attributes to 1.33,
1.33, 1.33.

4 Use Edit > Duplicate > ❒ with the following options:

Translate: 0, 2, 0
Scale: 1.05, 1, 1.05
Number of Copies: 3

and
so on
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This creates three copies of the circle, each translated 2 units
above the last, and each bigger than the last.

Loft the curves into the surface
You’ve created a total of nine curves. In the next steps, you
loft these curves into a surface that matches the contours of
their perimeters. Above the midpoint of the surface, the
shape will change from a flower-shaped perimeter to a
circular perimeter.

1 Shift-select all circles, one at a time. The order of selection is
vital when shift-selecting for a loft operation. You must start with the bottom
flower-shaped circle and end with the top circular-shaped circle.
Alternatively you can drag a selection box around the circles. The surface to
be lofted will be based on the selection order of the curves.

2 Select Surfaces > Loft.

This creates the salt shaker’s body.

3 Name the surface shakerBody. Press 5 to display the view with smooth
shading.

Note

Many of the surface creation tools also have the option of outputting
polygon or subdivision surface versions of a surface with the same input
curves. You do this by setting the appropriate Output Geometry option for
that particular surface tool.
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Create and modify a sphere to create a surface
To create a simple cap for the salt shaker, you’ll create a sphere, alter its
shape, and position it above the body.

1 Select Create > NURBS Primitives > Sphere > ❒ . In the options window,
select Edit > Reset Settings, and click the Create button. Maya puts the
sphere at the origin, its display currently obstructed by the salt shaker body.

2 Name the sphere Cap.

3 Move the cap to the top of the body.

4 Scale the cap size so that its diameter fits snugly at the top of the
body.

5 Adjust the cap position as desired.

6 In a side view, make sure the cap is displayed as a wireframe.
Select the top row of CVs and drag them down until the top of
the cap is flattened:

Check that the bottom half of the cap isn’t poking through the visible surface
of the body. You can scale the bottom CVs inward to avoid this problem.
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7 Parent the cap to the body. (Middle-mouse drag Cap onto
Body in the Outliner.) By doing this, you can move, rotate, or
scale the cap and the body as a single entity by selecting only
the body.

Notice that the salt shaker displays horizontal curves that
wrap around the body. The curves are the original circles you
used to loft the surface. Because these curves are part of the
surface’s construction history, you can alter their shape if you
decide you want to alter the shape of the body and the body
will update based on the construction history.

If you prefer not to see the curves in the scene view, select the
curves and select Display > Hide > Hide Selection. The curves won’t appear
when you render an image of the scene. Maya displays only surfaces, not
curves, in rendered images.

Beyond the lesson
In this lesson you made a salt shaker with two surfaces: a body made from
lofted curves and a cap made from an altered sphere. An advantage of
creating a separate surface for the cap and base is that you can easily give
each a different color or texture, for instance, one chrome one marble.
Another advantage of creating a separate cap is that you can pop it off the
base if you choose to animate the objects in the future.

You used a Loft operation rather than a Revolve operation to create the
body. The vertical corrugations on the surface would be impossible to create
by revolving a curve.

If you’re certain you won’t change the body’s shape by editing the shape of
the lofted curves, you can delete the body’s construction history to quicken
Maya’s processing of your interaction with the surface. For a surface as
simple as the salt shaker, deleting the history won’t boost processing much.

There are many other useful tools for creating and editing surfaces. For a
glimpse of the possibilities, take a look at the Surfaces menu and the Edit
NURBS menu.

For further information and related techniques, refer to the online book,
Using Maya: NURBS Modeling.
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Modeling with subdivision surfaces is an easy way to create intricate objects
such as human hands. It offers the best techniques of NURBS and polygonal
modeling, and includes several unparalleled features.

Like NURBS surfaces, subdivision surfaces are smooth and can be shaped
using relatively few control vertices. Like polygonal surfaces, you can
extrude areas of a surface to add appendages or other irregular shapes. For
instance, you can extrude four fingers and a thumb from a palm-shaped
object.

An important distinction of subdivision surfaces is that you can build a
perfectly smooth, complex object, for instance a dog, from a single primitive.
There’s no need to create separate pieces and stitch them together, as is often
necessary with NURBS surfaces. There are no seams that can break apart
during animation.

With a subdivision surface, you can modify its shape at various levels of
detail to suit your needs. If you are creating a thumb, for instance, you alter
its entire diameter by scaling a small number of vertices. If you next want to
create a lumpy knuckle, you switch to a higher number of vertices at the
desired region and drag vertices into the desired shape. You can switch
between the different levels of detail as often as necessary.

PREPARING FOR THE LESSON

To ensure the lesson works as described, do these steps before beginning:

1 Consider reading Chapter 2, “Polygonal Modeling.” Working with
polygonal modeling tools is essential to becoming proficient in subdivision
surface modeling.

2 Create a new scene.
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3 Select the Modeling menu set. Unless otherwise noted, the directions in this
chapter for making menu selections assume you’ve already selected the
Modeling menu set.

LESSON: MODELING A HAND

In the following lesson, you’ll create a cartoon character’s hand.

Create a subdivision surface from a polygonal cube
You begin the lesson by creating a polygonal cube. You’ll convert this cube
to a subdivision surface that will be the foundation of the hand. The reason
for starting with a polygonal surface and converting it to a subdivision
surface is that you can thereafter edit the object’s shape with more
versatility. You can edit with subdivision surface tools and polygonal tools.

1 Select Create > Polygon Primitives > Cube > ❒ . In the options window,
select Edit > Reset Settings. Then enter the following values and click the
Create button.

Width: 8
Height: 2.5
Depth: 8

The resulting polygonal cube is
roughly proportional to the palm of a
hand.

2 Rename the cube, pCube1, as
LeftHand.
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3 To convert the polygonal cube to a subdivision surface, select
Modify > Convert > Polygons to Subdiv.

4 Press 3 on your keyboard (to select Display > Subdiv Surface
Smoothness > Fine).

Also press 5 (to select Shading > Smooth Shade All).

With the Smoothness set to Fine, you can see that the conversion to a
subdivision surface creates a rounded, smooth shape. By pressing 3, the
subdivision surface is displayed more precisely in the scene view. This gives
a closer approximation of what the surface will look like when you create a
rendered image of the scene.

As an alternative, you could have chosen a rough smoothness (press 1) so
that Maya processes your editing changes in the scene view more quickly.
Regardless of the smoothness in the scene view, surfaces always are
displayed precisely in rendered images of the scene.

5 Select Subdiv Surfaces > Polygon Proxy Mode.
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The wireframe cube looks the same as the original polygonal cube. The new
cube is called a polyToSubd1 for the subdivision surface as a result of the
conversion. Rename it LeftHand. You can use polygonal modeling tools to
edit the shape of the polygonal proxy, which indirectly alters the shape of
the subdivision surface. Unlike working with an actual polygonal object,
your modifications result in perfectly smooth surface changes rather than
faceted changes.

Create faces to be extruded as fingers
Next, you’ll use polygonal modeling techniques to split a face into multiple
faces to be extruded as fingers.

1 With LeftHand still selected, select Edit Polygons > Split Polygon Tool.

You’ll use this tool to split the front face of the proxy into several faces to be
extruded into fingers.

2 In the front view, click the point on the top edge as shown in the following
figure, then click the corresponding point directly below it on the bottom
edge. If the line between the points isn’t perfectly straight, use the middle
mouse to drag the second point to the correct position. Press Enter.

Click these points
and press Enter
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This splits the face into two faces. You’ll extrude the left face into a finger
later.

3 Repeat the preceding two steps as necessary to split the face as follows:

Notice how splitting the face into multiple faces alters the shape of the
subdivision surface. The front part of the subdivision surface now resembles
the proxy shape more. If you were to split the front face several more times,
especially near the outer edges, the subdivision surface would sharpen and
resemble the proxy shape even more. More faces means finer control, often
at the expense of making the surface harder to work with.

With the added faces, the subdivision surface looks a bit like the palm of a
hand. You’ll build upon this shape to create a left hand with palm facing
downward and fingers extruded outward. You’ll extrude the wide faces into
fingers, and you’ll leave the narrow faces as webbing between the fingers.

Repeat the steps for these points.
Then repeat for the remaining faces.

Fingers will be
extruded outward
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Extrude the faces as fingers
Next, you’ll extrude faces into fingers.

1 In a perspective view, right-click LeftHand and select Face from the marking
menu. This lets you select faces.

2 Select the right-most face by dragging a selection box around the tiny box at
its center. (The subsequent illustration shows which face to select.)

3 Select Edit Polygons > Extrude Face.

4 Drag the blue arrow manipulator outward a little to create the lowest
segment of the smallest finger. (The blue arrow turns yellow when selected.)

5 Repeat the prior two steps to create the middle segment of the smallest
finger. Then repeat the prior two steps once again to create the top segment
and complete the finger.

By creating three segments for a finger, you mimic a real finger’s natural
structure. The borders between the segments have vertices (not displayed
currently) that let you reshape those regions, for instance, to create knuckles.
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6 Similarly, extrude the ring, middle, and index fingers from the appropriate
wide faces. Don’t extrude the three small faces that lie between the wide
spaces. Leave them in position to allow for webbing between the fingers.

Create the thumb
Next, you’ll extrude a thumb as you did for the fingers. The following steps
are abbreviated. See the preceding pages for details on the described tools, if
necessary.

Tip

Do not be concerned if the hand you create does not match the lesson’s
illustrations. Your goal in this lesson is to learn the workflow of
subdivision surfaces, not to perfect your modeling technique.

If you are intent on making the hand somewhat realistic, you can create
fingers with natural proportions easily. You will need to view the hand
model so it faces you and compare it to your own hand. First, select the top
camera in the Outliner. In the Channel Box, set the top camera’s Rotate X,
Y, and Z attributes to -90, 180, and 0. This changes the direction that the top
camera views the hand model.

In the top view, dolly until the size of the subdivision surface roughly
matches your palm. With your palm against the screen, drag each
extrusion to the end of the corresponding finger segment of your hand.
When complete, and before proceeding with the next steps, ensure that
you reset the top camera back to -90, 0, 0.
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1 Select LeftHand. (Make sure it is highlighted in green in the scene view. If it
is not green, select LeftHand in the Outliner.)

2 Use Edit Polygons > Split Polygon Tool to split the side face in the thumb
region into three faces. While splitting, make sure the middle face is larger
than the outer faces:

3 Extrude the middle face and drag it directly outward. Click the surrounding
blue circle and use the rotate manipulator to aim it in a direction appropriate
for a thumb.

4 Extrude three times more to create each segment of the thumb. Use the
extrusion manipulator to rotate, move, and scale each extrusion to create the
desired shape of a thumb. Use the following figure as a guideline. Again, it’s
unnecessary to match the illustration or create a realistic thumb for this
lesson.

The extrusion manipulator is easy to figure out by clicking and dragging its
various elements. If necessary, you can also use the conventional Move,
Scale, and Rotate Tools to reshape the faces that control the thumb’s shape.

This face must be larger than
the faces on each of its sides
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5 In the scene view, right-click LeftHand and select Vertex from the marking
menu. The purple vertices at the corners of the faces control the adjacent
region of the hand.

6 Make coarse adjustments to various parts of the hand by repositioning the
vertices with the Move, Scale, and Rotate Tools. The Move Tool works on
individual vertices or groups of vertices. Rotate and Scale works on two or
more vertices. Undo any changes you don’t like using Ctrl-Z.

Try to create the approximate thickness, length,
and curvature of a cartoon character’s hand
and fingers. There’s no need for perfection.
You’ll refine the fingers later. An example hand
follows. (You might be satisfied with a simpler
shape.)
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Adjust the overall shape and cut an arm hole at the wrist
In the next steps, you’ll cut a hole in the wrist where you might choose to
attach an arm. Though you won’t create and attach an arm in this lesson, it’s
useful to learn the technique for future use.

1 Select the face at the wrist and press Delete to create a hole where you could
attach an arm.

2 Scale the four vertices that surround the hole and scale them inward to
narrow the wrist region of the hand.

Refine the fingers
Now you’ll refine the shape of the fingers by working at a level of detail not
possible in Polygon Proxy mode.

1 Select LeftHand.

2 Select Subdiv Surfaces > Standard Mode. This switches to a mode that lets
you modify the surface at various levels of detail to suit your needs.

3 In the scene view, right-click LeftHand and select Vertex from the marking
menu.
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This displays 0s on the surface in the same
positions as the vertices in Polygon Proxy
mode. In fact, the 0s are vertices.

The number 0 refers to the level of detail
you are capable of editing. The 0 level is
identical to the coarse control possible in
Polygon Proxy mode by manipulating the
vertices. You can move, rotate, and scale
the 0s to alter the shape of the surface just
as you did for vertices in Polygon Proxy mode.

4 Right-click the surface and select Display Level > 1.

Though the 1s are displayed in the same
regions as the 0s were previously, there
are many more 1s displayed. The 1s are
also vertices, and their increased presence
means you can refine the shape with more
subtlety.

5 Refine the shape of the fingers, thumb,
and hand as desired by selecting various
level 1 vertices and moving, scaling, and rotating them with the
transformation tools. (Scaling and rotating has effect only if you select two or
more vertices.)

It’s essential to tumble the camera from various perspectives to make sure
you’ve selected only the desired vertices.
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To return to level 0 to alter the shape with fewer vertices, right-click the
surface and select Display Level > 0. Each level has advantages. Level 1
allows finer control because there are more vertices. Level 0 allows control of
broader regions, and it’s often easier to select the desired vertices since there
are fewer of them. It’s common to switch back and forth between levels
repeatedly in a work session.

The hand has level 2 vertices at various locations, for instance, at the
webbing between the fingers. You can also work at that level of detail if
desired (select Display Level > 2).

Create more precision in the fingernail region
By default, a subdivision surface displays up to three levels of detail (0, 1,
and possibly 2). The 0 level is the least refined. You can increase the level of
detail for a selected region to at most 13 levels. Though increasing the
number of levels allows more precision, it also slows Maya processing.
You’ll accomplish most of your modeling needs at levels 0, 1, and 2.

If you display level 2 vertices on the hand, you’ll notice that there are no
level 2 vertices near the fingertips. To create the indentation of a finger nail,
you need more vertices than levels 0 and 1 provide. In the next steps, you’ll
add level 2 vertices at a fingertip so you can create a fingernail.

1 Switch to level 1.

2 Right-click the surface and select Edge from the marking menu.

3 Shift-click to select the edges that surround the region where you’ll shape a
nail.

Shift-select the edges that
surround the fingernail region
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4 To increase the amount of detail at the selected edges, select Subdiv Surfaces
> Refine Selected Components. Additional surface curves appear in the
fingernail area, indicating you can edit with more precision.

5 In the scene view, right-click LeftHand and select Vertex from the marking
menu. This displays additional level 2 vertices in the fingertip region.

6 Select Modify > Transformation Tools > Move Tool > ❒ . In the Tool Settings
window, turn on Normal, then close the window. You can thereafter use the
Move Tool manipulator to move vertices in a direction normal
(perpendicular) to the surface.

7 Select the vertices in the nail region.

8 Drag the Move Tool’s N manipulator down slightly to form the depression
of a fingernail bed.
INSTANT MAYA

93



SUBDIVISION SURFACES | 4
Lesson: Modeling a hand
Crease the edge of the nail
One of the unique features of subdivision surfaces is that it’s easy to create a
crease or ridge on a smooth surface. You’ll do this in the next steps.

1 Switch to Edge selection mode and shift-click the edges around the nail to
select them. (It might be easier to see the desired edges by first selecting
Shading > Wireframe.)

2 After you select the edges, select Subdiv Surfaces > Full Crease Edge/Vertex.

Drag the N manipulator
downward to create the
depression of a nail bed
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Once you crease an edge, it displays with a dashed line as a visual reminder
that the edge has been creased. If you change your mind, you can remove
the crease using Subdiv Surfaces > Uncrease Edge/Vertex.

3 To create a ridge at the edge of the nail, switch to Vertex selection mode and
select the level 2 vertices on the skin at the perimeter of the previously
selected edges. Move them up so that the skin’s juncture with the nail forms
a slight ridge.

4 Now experiment on your own by moving individual vertices to shape the
nail and surrounding region as desired. A few suggestions follow:

• In Smooth Shade display mode (Shading > Smooth Shade All), certain
vertices might be below the shaded surface and therefore impossible to
select and move. To display and select such vertices, switch to wireframe
shading (Shading > Wireframe). After selecting the vertices, return to
Smooth Shade display mode so you will be able to more easily see the
results of moving them.

• You might get better results using the Move Tool’s default World setting
rather than the Normal setting made in a prior step. To return to the default
setting, select Modify > Transformation Tools > Move Tool > ❒ . In the Tool
Settings window, click Reset Tool, and then close the window.

• To extend the front of the nail past the skin with a sharp edge, add a second
crease on the edges below the tip of the nail. (With the appropriate edges
selected, select Subdiv Surfaces > Full Crease Edge/Vertex.)

You might also want to add an additional level of vertices at the edges.
(With the appropriate vertices selected, select Subdiv Surfaces > Refine
Selected Components.)

After you crease the edges and add the extra vertices, you can make the
nail’s edge overhang the skin below it by dragging the vertices at the nail tip
out and away from the finger. Then tuck the row of vertices below the
overhanging vertices in the opposite direction.

An example of a completed nail follows:
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5 If you want more practice, repeat the procedure for the rest of the nails.

6 When finished, select Modify > Transformation Tools > Move Tool > ❒ . In
the Tool Settings window, click Reset Tool, and then close the window. This
returns the Move Tool to its default settings. This will avoid confusion if you
do other lessons in this book.

Beyond the lesson
Modeling with subdivision surfaces is an easy way to create intricate,
smooth objects such as human hands and faces. The ability to create
extrusions, subtle surface alterations, and sharp edges means there are
innumerable types of objects you can model.

There are many features not covered in this lesson. For instance, you can:

• convert a NURBS surface to subdivision surface.

• convert a subdivision surface to a polygonal surface.

• convert a subdivision surface to a NURBS surface.

• create subdivision surface primitive shapes from the Create > Subdiv
Primitives menu: Sphere, Cube, Cylinder, Cone, Plane, and Torus. With
these shapes, you can quickly start your subdivision surface model without
converting from polygons or NURBS surfaces.

• attach two subdivision surfaces to form a single surface, for instance, to
merge a hand and an arm.

• create a mirrored copy of a subdivision surface.
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With animation, you bring action to your scene. The animation lessons in
this chapter cover common techniques as well as features that highlight
Maya’s leading technology:

• “Lesson 1 Keyframing and the Graph Editor” on page 97

• “Lesson 2 Set Driven Key” on page 112

• “Lesson 3 Path animation” on page 116

• “Lesson 4 Trax Editor” on page 123

PREPARING FOR THE LESSONS

To ensure the lessons work as described, do these steps before beginning:

1 Select Window > Settings/Preferences > Preferences. Click the Settings
category and set the Time option to Film (24 fps) so your animation plays at
the rate of 24 frames per second. Click the Save button.

2 Select the Animation menu set. Unless otherwise noted, the directions in this
chapter for making menu selections assume you’ve already selected the
Animation menu set.

LESSON 1 KEYFRAMING AND THE GRAPH EDITOR

When you set a keyframe (or key), you assign a value to an object attribute at
a specific time e.g. translate, rotate, scale, color etc. When you set several
keys at different times with different values, Maya generates the attribute
values between those times as the scene plays. The result is the movement or
change over time of those objects and attributes.

In this lesson, you’ll use simple keyframing techniques to make a ball fly
over a fence and bounce off the ground.
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Later in the lesson, you’ll use the Graph Editor to tune the motion of the ball
as it bounces off the ground.

Open the scene and set the playback range
In this lesson, you’ll work with a scene we created for your use. In the
following steps, you’ll open the scene and set how long the animation will
play.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 97.

2 Open the scene named Keyframing from the location specified in the
following table:

Maya Package File Location

Maya Complete or
Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD
and find:

InstantMaya/Anim/Keyframing.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 
4.5 Personal Learning Edition\

and then to:

tutorialData\MayaPLE\Anim\Keyframing.mp
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3 Look over the animation controls, as shown in the next figure:

The Time Slider displays the playback range and keys you’ve set for a
selected object. Keys are displayed as red lines. The box at the right of the
Time Slider lets you set the current frame (time) of the animation.

The Playback Controls control animation playback. You’ll undoubtedly
recognize the conventional buttons for play and rewind (return to the start
time). The stop button appears only when the animation is playing. To find
out which operation a button represents, hold the mouse pointer over it.

The Animation Preferences button displays a window for setting animation
preference settings such as the playback speed.

The Range Slider controls the range of frames that play when you click the
play button.

The above items will make sense as you work through this lesson. After you
complete the lesson, experiment with these items to learn what they do.

4 In the Playback End Time box (see above), enter 72.

The default playback range, 1 to 24, affords only one second of animation at
the default rate of 24 frames per second. A frame rate of 24 frames per
second (fps) is the frame rate used for motion picture film. For video the
frame rate can be 30 fps (NTSC) or 25 fps (PAL) depending on the format
being used.

With a playback range of 1 to 72, you’ll be able to create three seconds of
animation. (72 frames divided by 24 frames per second = 3 seconds.) This is
enough time for the short animation you’ll create in this lesson.

Time Slider Playback Controls

Range Slider
Animation Preferences

Playback End TimePlayback Start Time
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Set beginning and ending keys
In the following steps, you’ll key the starting and ending positions of the
ball’s movement.

1 Click the rewind button to go to the start of the playback range. This changes
the current frame to 1.

2 Select the ball, then select Animate > Set Key. (Keyboard shortcut: s).

This sets a key at frame 1 for all transform attributes of the ball. Although
you’ll animate only the translate X and Y attributes of the ball in this lesson,
keying all transform attributes saves you time having to choose specific
attributes to be keyed.

At frame 1 in the Time Slider, notice the red marker at frame 1, known as a
tick. This tick appeared when you set the key. With the ball selected, ticks in
the Time Slider indicate where you’ve set keys.

3 Go to frame 72. A convenient way to do this is to click the desired position in
the Time Slider.

4 With the Move Tool, drag the ball’s X-axis handle to position the ball at the
right edge of the ground as shown in the image below.

5 Set a key at frame 72. (Press s.)

6 Go the start time and play the animation.

From the two keys you’ve set, Maya creates motion between the positions.
By default, the animation plays in a loop from frame 1 to 72. Stop the
animation after you watch a few repetitions. Note that the ball travels
through the fence at this stage.
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You can drag the mouse back and forth (scrub) in the Time Slider to see the
animation play back and forth at the speed you drag the mouse.

Note that if you were to display the scene with Panels > Layouts > Four
Panes, only the active panel would show the ball moving.

Add intermediate keys
To make the ball fly over the fence rather than pass through it, you need to
position the ball above the fence and set a key there.

1 Go to frame 33 or so—at the moment where the ball sits in the middle of the
fence.

2 With the Move tool, drag the Y-axis handle of the ball until it sits slightly
above the fence. Throughout this lesson, tumble the perspective view or
examine a front view to make sure the positioning is correct.

3 Set a key. (Press s.)

4 Play the animation. The ball now flies
off the ground, over the fence, and
back to the ground in a smooth arc
between the keyed start, middle, and
end positions.

In subsequent steps, play the animation after each key you set. It’s generally
useful to check your work in progress after each key, especially if you are
learning.

Add keys to make a ball bounce
In the next steps, you’ll set keys to bounce the ball in the middle of the right
half of the ground.

1 Go to frame 50. At this moment, the ball sits in a position above the middle
section of the right half of the ground.

2 Move the ball so it sits on the ground.
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3 Set a key.

4 Go to frame 60.

5 Move the ball up again, but not as high as its peak height above the fence.

6 Set a key. When you play the animation, the ball sails over the fence and
bounces on the other side.

If you have a fast computer, you might notice that the animation plays too
fast. By default, Maya plays the animation as fast as it can be processed
Because this scene is simple, the animation might play faster than the default
film rate (24 frames per second).

To play the animation at the actual film rate, click the Animation Preferences
button at the far right of the Range Slider. In the Playback section, change
the Playback Speed from Play Every Frame to Real-time (24 fps). Click Save.
Now when you play the animation, it plays at exactly 24 frames per second
rate.

Do not be concerned that the animation plays with a halting or jerky motion.
When you render all the frames of your animation for final production, the
animation will be smooth. If you want to preview the animation at the
smooth production speed (or nearly so), use Window > Playblast.
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Improve the motion with the Graph Editor
Next, you’ll bounce the ball more sharply off the ground and speed up the
ball’s horizontal movement. You’ll use the Graph Editor to make both
modifications.

1 With the ball selected, select Window > Animation Editors > Graph Editor.

The Graph Editor displays several animation curves, one for each keyed
attribute of the ball. Specifically, it displays the attributes of the selected
transform node of the ball.

Each curve graphs how an attribute changes value during the animation.
The column of numbers at the left represents attribute values that can be
animated, while the row of numbers at the bottom represents time (frame)
values. At each point on the curve, you can see the value of an attribute at a
particular time. The small black squares on the curves represent points
where you’ve set keys.

2 Shift-Select the Translate X and Translate Y attributes in the left side of the
Graph Editor. Now only the animation curves for Translate X and Translate
Y appear in the Graph Editor.

This simplifies the display. With too many curves present, it’s hard to see
specific curves. When you use the Graph Editor, you usually focus on one or
a few curves.
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3 To center the display of the animation curves, select View > Frame Selection
(in the Graph Editor window). If you want to see more detail in the graph,
use your mouse to dolly and track the graph view.

The green curve represents Translate Y, while the red represents Translate X.
The color of each curve matches its attribute name. This color scheme is
consistent throughout Maya for X, Y, and Z (red, green, blue) so is easy to
remember.

If you’ve never used a graph editor before, the relationship between a
curve’s shape and the animation it represents might be hard to understand.
With experience, you’ll quickly recognize how curve shape affects
animation.

In the above graph, the straight curve of Translate X indicates that the ball
moves horizontally across the ground at a constant rate over time.

The wavy curve of Translate Y indicates that the ball increases its height
steadily until frame 33, dips more quickly until frame 50, then rises and dips
again until frame 72.

When the ball first bounces off the ground at frame 50, it seems to float and
slip rather than rebound. The shape of the Translate Y curve illustrates why.
Near frame 60, the curve is soft and rounded. The Translate Y values
gradually decrease to the low point then gradually increase. The transition
from decreasing to increasing values is smooth.

The Graph Editor’s usefulness lies in the fact that you can edit the shape of
the animation curves to edit the animation of any keyed attribute. To create a
sharp bounce, you can edit the curve so that the transition from decreasing
to increasing values is abrupt at frame 50. Specifically, you’ll create a corner
at that key point rather than a rounded curve.
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4 Select the point on the Translate Y (green) curve at frame 50. This causes a
pair of tangent handles to appear at the point. Each end point of the newly
displayed straight line is a tangent handle. The handles let you control the
curvature near the key point.

Animation curves have a few control structures for curve editing. You can
do any of these operations:

• Use the Move tool and middle mouse button to move a key point. You can
alternatively use your keyboard to enter precise values for a selected key’s
frame and value in the boxes above the graph area.

• Use the Move tool and middle mouse button to drag the tangent handles
and change the adjacent curvature.

(You can shift-drag with the Move tool to constrain a move operation to a
single direction.)

• Use the Scale tool and middle mouse button to scale selected key points
closer together or further apart.

• Use the Graph Editor’s Tangent menu items to change the adjacent
curvature. This is the operation you’ll use in the next step.

5 In the Graph Editor, select Tangents > Linear. This changes the curvature
around the key point from rounded to cornered. Specifically, the setting you
select specifies how the key point tangent handles lie at this key point. This
affects the type of interpolation between key points.

Play the animation and you’ll see the ball bounce more sharply. To sharpen
the bounce more, you will edit the positioning of the tangent handles to
steepen the curvature approaching the key point.
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6 Select one of the tangent handles. Use the Move Tool and the middle mouse
button to drag it upwards a little so you can see the how the curvature at the
key point changes.

By default, when a pair of tangent handles share a key point, they work as a
unit. Move one and you move the other in an opposing direction. This is
often desirable in an animation curve, because it ensures the curvature at
that point stays symmetrical. Symmetrical curvature often helps prevent
unusual animation shifts.

In this case, however, you want to steepen the curvature’s approach toward
the curve point in the same direction on both sides. You therefore need to
break the interdependency between the two tangents.

7 Undo your previous move of the tangent handle. Select the key point at
frame 50 (not a tangent handle). In the Graph Editor, select Keys > Break
Tangents. This lets you move each tangent handle independently.

8 Select the right tangent handle and use the Move Tool to move it up a little.
Do the same for the left tangent handle. Be careful not to select the key point.

This sharpens the bounce to simulate the effect of gravity and elasticity.

Speed up the animation
The ball seems to move too slowly in its journey. In the following steps,
you’ll use the Graph Editor to hasten its movement. Specifically, you’ll cause
the ball’s animation to finish its journey in two seconds (48 frames) rather
than three (72 frames).

1 Drag a selection box around all key points of both curves.

2 Select the Scale tool.
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3 Click and hold the middle mouse button anywhere in the graph at frame 1
(slightly to the right of 0). Notice the question mark icon. The location of this
icon indicates the point from which scaling occurs. (Because you need to
scale the animation inward toward frame 1, you need to start your drag
operation at frame 1.)

Without releasing the mouse button, drag to the left until the right-most key
points on both curves are positioned roughly at frame 48. (When selected,
the right-most key points are yellow.)

This pulls the curves symmetrically
towards frame 1. The animation of
the ball now plays from frame 1 to 48
rather than 1 to 72. The ball traverses
the scene in less time, which, of
course, means it moves faster.

Note that if you had started your
drag operation from the middle of
the frame range, the scale operation
would have pulled the curves toward the middle of the frame range. You
may also wish to consider snapping the keypoints to whole values to keep
the keyframes on a consistent timing

4 Widen the Graph Editor window as necessary to see the graph clearly. Also,
dolly the view or select View > Frame Selection (in the Graph Editor
window).

Tune the animation curve
Now improvise adjustments on your own. For example, you might choose to
speed the ball’s horizontal movement up to the first bounce but not
thereafter. You might also decide to raise the peak height of the ball’s motion
so that it doesn’t seem to hover over the fence unrealistically.

Whatever you choose to do, you’ll likely need to edit both the Translate X
and Translate Y curves, not just one of them. Play the animation after each
adjustment.
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The following two figures show examples of curves after modification.The
two graphs are identical, except the curve points are selected in the second
figure. The second graph shows the position of the tangent handles.

If you want your curves to match the shape of the curves in the above figure,
here’s what you would need to do:

1 On the Translate X curve, delete the three key points between the two key
points at the end. (The preceding figures show the curve after the points
were deleted.) To delete the points, drag a selection box around them and
press Delete.

With fewer key points on the curve, it’s easier to maintain the curve’s
smoothness for larger distances as you edit its shape. Small kinks in an
animation curve can ruin an otherwise perfect animation, so it’s useful to
remove key points that you aren’t using.

2 On the Translate X curve, select the left-most key point and move its right
tangent handle down slightly. (Remember to use the middle mouse button
when moving a handle or point.) Select the right-most key point and move
its left tangent handle up slightly.

Translate X

Translate Y
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Notice that the slope of the Translate X curve increases slightly in the early
part of the animation, then tapers off toward the end. This causes the ball to
accelerate slightly at the beginning of the animation, then decelerate after its
first bounce.

3 On the Translate Y curve, remove the key point at frame 22. (The preceding
figures show the curve after the point was removed.) This point wasn’t
essential to the curve shape.

4 On the Translate Y curve, select the left-most key point and move its right
tangent handle up slightly.

5 At the key point where the bounce occurs on the Translate Y curve, move the
left tangent handle up a bit. This raises the high part of the curve left of that
key point, which makes the ball rise higher over the fence.

6 If you want to change the shape of Translate Y curve but lack adequate
control with the existing key points, you can add a key point at the position
of your choice. (No key points were added in the prior figures.) To add a
key, click the Add Keys Tool icon, select the curve, and middle-click the
desired position on or off the curve.

Remove static channels and excess keys
As you set keys, you often create many unintended keys. For example, when
you used the Set Key operation on the ball, Maya created keys on all
transform node attributes of the ball, for instance Rotate Z, not just the
intended Translate X and Translate Y attributes. The curves representing
such attributes have unchanging values. The attributes are known as static
channels.

You can identify static channels by examining animation curves in the Graph
Editor. If a curve is horizontally flat its whole length, the value of the
attribute it represents isn’t changing. The attribute is a static channel.

Static channels slow Maya processing, so it’s beneficial to remove them in
complex scenes. From the main menus, select Edit > Delete All by
Type > Static Channels.

Add Keys Tool
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This deletes all unnecessary keys for all objects in the scene. Alternatively,
you can remove the static channels for a selected object with Edit > Delete by
Type > Static Channels.

In addition to static channels, you’ll often create excess keys—keys that
aren’t being used to control the shape of a curve. Whenever you see three
key points that lie in a straight line, the one in the middle is unnecessary. For
example, in this lesson’s original Translate X curve, there were four
redundant keys:

To delete keys, select the key points and press Delete. When you remove
redundant key points, the shape of the curve doesn’t change and you speed
up Maya processing.

Preview the animation with better speed and quality
When you play a scene, you see a rough approximation of the animation.
The playback speed and quality is imprecise as compared to rendering each
frame and playing the frames in sequence with a playback program such as
Silicon Graphics’ MediaPlayer. The reason for this is that Maya processes the
animation of each frame before display, while a playback program simply
plays previously processed and rendered images.

The more detail that Maya needs to process, the slower the playback. For
example, playback will likely be slow for any scene that has several complex
objects displayed with Smooth Shade All and Hardware Texturing.
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To preview the animation with more accurate speed and quality, select
Window > Playblast. For the next several seconds, Maya processes the entire
animation frame by frame. When the process is complete, a playback
window appears. Click the play button in this window to watch the
animation. Close the window when you’ve seen enough.

Beyond the lesson
In keyframe animation, you typically set keys for attributes, then use the
Graph Editor to refine the animation and remove unnecessary keys.

You can animate any attribute in Maya, not just the Translate, Rotate, and
Scale attributes of a surface. For example, you can animate the intensity of a
light, the transparency of a surface, the rotation of a camera view, or the
position of CVs.

The Graph Editor is the best tool for editing keyed animation by reshaping
animation curves. You can use it to change key positions, add or remove
keys, and alter the fluidity and symmetry of animation.

Each key point on an animation curve has a Tangent setting that specifies the
curvature leading into that point. The default Tangent setting, Spline, creates
rounded curvature—useful for animating attributes that change smoothly
over time. The Linear setting creates angular curvature, useful for a bounce
effect or any other abrupt change in attribute value. Other Tangent settings
are available for different animation effects. For example, a Stepped setting
lets you make an instantaneous leap in value, useful, when you want to flash
a light off and on.

Although the Graph Editor is a popular animation tool, be aware that you
can also cut, copy, paste, and delete keys directly in the Time Slider to edit
animation. Simply select a key position in the Time Slider, then right-click to
select the desired operation from a pop-up menu.

There are alternative object display modes that quicken the display of
animation in the scene view. For example, if you select Shading > Bounding
Box (from the menu directly above the scene view), Maya displays simple
box-shaped geometry in place of the actual objects in your scene. The
simpler shapes enables Maya to respond to any camera and object
movement faster. The drawback is that you cannot edit the shape of the
objects in this display mode.
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Finally, be aware that it’s generally better to animate a group node rather
than objects themselves. By animating a group node, you can avoid
problems that occur when the animation of one object in a hierarchy conflicts
with the animation in another part of the hierarchy.

LESSON 2 SET DRIVEN KEY

With regular animation keys, you key an attribute value to a time in the
Time Slider. You repeat this with different values at different times to
animate the object.

With driven keys, you key an attribute value to the current value of another
attribute. You repeat this with different values to create a dependent link
between a pair of attributes. A change in a driver attribute alters the value of
the driven attribute. You can use driven keys, for example, to make a door
open when a person walks in front it.

In the following lesson, you’ll use driven keys to
slide a door upwards when a ball moves toward
it.

Set the playback range and create the
objects

In the following steps, you set a playback range
that’s long enough to see the animation clearly.
You also create the ball and the door, and position
them in the scene view in preparation for the
animation.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 97.

2 Create a new scene.

3 Go to the start frame.

4 Create a polygonal cube and name it Door. Scale and position it roughly as
shown in the prior figure. Have the bottom edge of the door lie roughly
along the X-axis.

5 With the pointer in the perspective view, press 5 (for Shading > Smooth
Shade All).

The ball’s translation
towards the door drives the
door’s upward translation.
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6 Create a small polygonal sphere and name it Ball. Scale and position it
roughly as shown in the prior figure. Have it sit roughly at 0, 1, 10.

Use the default color for the door and the ball. There’s no need to color them
for this lesson.

Link attribute behavior with Set Driven Key
The following steps link the door’s movement to the ball’s movement.

1 Select the door and choose Animate > Set Driven Key > Set > ❒ . The Set
Driven Key window appears with the door in the Driven list.

2 Click translateY in the Driven list.
This is the attribute to be driven by
the ball’s movement.

3 Select the ball. In the Set Driven Key
window, click the Load Driver
button. The ball appears in the
Driver list.

4 Click translateZ in the Driver list.
This is the attribute that will drive
the door’s movement. You can set a
driven key only after you select an attribute in the Driver list and in the
Driven list.

5 In the Set Driven Key window, click Key. This sets a driven key that links
the current Translate Z value of the ball to the current Translate Y value of
the door. Whenever the ball’s Translate Z is at this position, the door’s
Translate Y will be at its current position.

The Time Slider is not involved in a driven key relationship and displays no
red markers for keys.

6 Move the ball to the door’s position and move the door above the ball.
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7 Click Key.

This sets another driven key that links the current Translate Z value of the
ball to the Translate Y value of the door.

8 Move the ball to the right of the door. Lower the door to its previous
position as shown in the following picture.

9 Click Key. This sets another driven key that links the attributes.

You’ve set three driven keys that link the attribute values at different
positions. Maya interpolates the linked values to generate the values
between the keys.

If you drag the ball toward the door from either side, the door rises
smoothly. Playing the animation doesn’t move the ball or the door. Driven
keys link one attribute to another. They don’t link attributes to times in the
Time Slider.
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Examine the driven key animation curve
In the next steps you’ll examine the animation curve resulting from the
driven keys you’ve set. If you are unfamiliar with animation curves and the
Graph Editor, see “Lesson 1 Keyframing and the Graph Editor” on page 97.

1 Select the door. To display the animation curve for a driven key in the Graph
Editor, you must select the object containing the driven attribute, not the
object containing the driving attribute.

2 Select Window > Animation Editors > Graph Editor.

3 From the Graph Editor, select View > Frame All. The Graph Editor shows
the driven keys that link the door’s TranslateY value to the ball’s Translate Z
value. An example follows:

The column of numbers on the left lists the driven attribute values. The row
at the bottom lists driver attribute values. The animation curve shows the
relationship between the values—the door’s Translate Y value rises as the
ball’s Translate Z value approaches 0.

You can use the Graph Editor to edit the shape of the curve to make the door
rise faster, slower, and higher as the ball approaches it.

Beyond the lesson
Driven keys link one attribute’s values to another. A driven attribute is not
directly affected when you play the animation. It is linked to a driving
attribute’s value, not animation time. However, you can use regular
animation keys, expressions, motion paths, or other techniques to animate
the driving attributes. This indirectly animates the driven attribute.
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In the lesson, suppose you had additionally set regular keys to animate the
ball moving back and forth along the Z-axis from frames 1 to 24. The door
would move up and down in response to the ball’s time-based animation
during frames 1 to 24.

Be aware that you can set driven keys to control a driven attribute with
multiple driving attributes. For instance, you can have a muscle bulge when
an elbow rotates, and have the bulge increase when the wrist rotates.

After you set driven keys, you cannot animate a driven attribute with
regular keys, expressions, motion paths, or other techniques. You can control
an attribute with only one technique.

LESSON 3 PATH ANIMATION

With path animation, you animate an object along a path specified by a
curve. This is useful for animating objects such as trains, boats, airplanes,
and moving cameras. To do this with keyframe animation would require
you to laboriously create and edit many keys for the motion. By having the
object move along a curve, you can easily adjust the camera’s path by editing
the curve.

In the following lesson, you’ll make a train follow a path on a surface. We
provide a scene for your use in the following lesson so you can concentrate
on learning about path animation rather than creating the setup.

Open the scene and examine its contents
In this lesson, you’ll work with a scene we created for your use.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 97.

2 Open the scene named PathAnim from the location specified in the following
table:
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The scene contains objects named Train, Desert, and Path_curve.

Train is a group node that contains all the surface parts that make up the
train. The train is currently parked above the center of the desert. The desert
is a polygonal plane.

Path_curve is a curve we drew in the valley of the desert. If you want to
draw a curve on a surface in your own work, select the surface, select
Modify > Make Live, select Create > EP Curve Tool, then click points to
draw an outline of where you want the curve to be. After you complete the
curve, cancel the selection of all objects and select Modify > Make Not Live.

3 For the Playback End Time, enter 480. This provides the time needed for the
animation you’ll create in this lesson.

Maya Package File Location

Maya Complete or
Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD
and find:

InstantMaya/Anim/PathAnim.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 
4.5 Personal Learning Edition\

and then to:

tutorialData\MayaPLE\Anim\PathAnim.mp

Path_curve
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Specify the path and frame range of the animation
Now you’ll select the curve as the path and specify how long it will take for
the train to complete its travel.

1 Go to the start of the animation, which is the time the train’s animation
begins.

2 In the Outliner, select Train and Ctrl-select Path_curve.

Note that if you create a curve on a NURBS surface rather than a polygonal
surface, the curve is listed in the Outliner under the shape node of the
surface. (Select Display > Shapes from the Outliner menu, then click the +
icon to the left of the surface and surface’s shape node.)

3 Select Animate > Motion Paths > Attach to Motion Path > ❒ . In the options
window, turn on Start/End then enter a Start Time of 1 and End Time of
480. Click the Attach button.

The Start and End Times set how long it takes the train to complete the
journey along the path curve. 480 frames (20 seconds) provides a slow chug
across the desert.

The start and end times are displayed at the ends of the curve.

When you clicked the Attach button, the train moved to one end of the
curve. Specifically, it moved to the start of the curve—the first point we
drew when we created the curve for your use in the scene. When you create
a curve for path animation for your own projects, remember to draw the
curve in the direction you want the object to move.

4 Play the animation. The train chugs along the path, though it faces the
wrong direction and is partly below the desert.

Change the orientation of the train on the path
In the next steps, you’ll correct the train’s orientation to face forward while
travelling along the path.

1 Select Train in the Outliner.

2 From the main menu, select Display > Component Display > Local Rotation
Axes. This displays the local axes of the train (the group node, Train), which
will be useful when you subsequently fix the train’s orientation on the path.

3 Select Path_curve.
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4 Select Window > Attribute Editor, then click its motionPath1 tab to display
attributes of the path animation.

By default, an object attached to a path is oriented so that its local positive X-
axis faces down the path (In the Attribute Editor, Front Axis is set to X.)

5 To reverse the train’s orientation, select Inverse Front.

There are several other attributes for controlling the orientation, including
Follow, Front Axis, Up Axis. A fast way to get a particular orientation is to
try various settings until you get the results you want.

6 To make the train lean at the curvy parts of the path, turn on Bank. Banking
is useful for motorcycles, planes, trains and other vehicles that tilt as they
change direction at high speeds.

In this lesson you’ll use the default Bank Scale and Limit values. Bank Scale
sets the magnitude of the tilt, while Bank Limit sets the maximum allowable
tilt in degrees.

Raise the train above the path
In the next steps, you’ll raise the train so its wheels lie above the desert.

1 Select Train in the Outliner.

2 Select the Move Tool.

3 Press the Insert key so you can move the train’s pivot.

4 Drag the Y-axis of the pivot down, which raises the train above the desert. If
necessary, select Shading > Wireframe to see the pivot manipulator more
clearly.
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5 Play the animation a few times and adjust the pivot until the wheels stay
above the desert for the entire animation. When satisfied, press Insert again
to leave pivot manipulation mode, then exit the Move Tool by selecting the
Select Tool.

6 Select the train then Display > Component Display > Local Rotation Axes.
This turns off the display of the local axes of the train.

Change the train’s speed along the path
By default, an object moves along an animation path curve at a constant
speed. To have the train go faster until it comes to the bend, you must cause
it to arrive near the bend at an earlier time in the Time Slider.

1 Go to frame 280, where the train is at a point near the bend.

2 Select Path_curve.

3 In the Channel Box, click motionPath1.

Notice the entry for the U Value, which controls the position of the train on
the path. A value of 0 is the start point, a value of 1 is the end point. A value
of 0.582 is a position approximately 58% of the length of the path.
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4 Middle-click frame 220 in the Time Slider. This changes the current time
without updating the train’s position on the path.

5 Click U Value in the Channel Box to select it.

6 Right-click the U Value and select Key Selected from the pop-up menu. This
keys the U value of 0.582 to the frame 220, an earlier time in the Time Slider.

By keying the U Value of 0.582 to an earlier time, the train arrives at that
point sooner, which means it’s faster up to that point. The train slows down
after that point, because it still completes the entire path by frame 480.

There are two other keys in the Time Slider that were automatically created
when you used the Attach to Path menu item: The key at frame 1 has a U
Value of 0, while the key at frame 480 has a U Value of 1. You can key
different U Values at any of the three existing keys.

In the scene view, the numbers next to the curve, 1, 220, and 480, are path
markers. As shown in the next step, you can move a path marker to alter the
speed of the train.

7 Play the animation to move the train away from path marker 220.

8 Click the path marker number 220. (Don’t also click the curve.) Use the
Move Tool to drag it closer to the beginning of the path:

When you play the animation, the train moves slowly at the first part of the
path, then travels much faster the rest of the way.

Reverse the train’s course and play the animation at real speed
In the next steps, you’ll cause the train to reverse course along the path. As a
final step, you’ll play the animation at a more accurate speed.
INSTANT MAYA

121



ANIMATION | 5
Path animation
1 Drag the 220 path marker roughly to the bend near the end of the curve
again. (See the illustration below.) When you later play the animation, the
train will move faster up to the 220 marker than it did previously. This
occurs because the train travels further along the curve in 220 frames than it
did previously.

2 Go to the start time and play the animation until the train moves to a
position a short distance in front of the 220 marker. (This should occur at
frame 175 or so.)

3 Middle-click frame 300. This changes the current time without updating the
train’s position on the path.

4 In the Channel Box, click motionPath1, then click U Value to select it.

5 Right-click U Value and select Key Selected from the pop-up menu.

This keys the current U value (roughly 0.56) to frame 300.

When you play the animation, the train chugs to marker 220, reverses
direction to marker 300, then reverses again toward the end of the path.

6 To preview the animation with smoother, more accurate speed, select
Window > Playblast. You might first want to hide Path_curve. (Select it and
then select Display > Hide > Hide Selection.)

Beyond the lesson
Animating an object along a curve-on-surface is useful for simulating an
object moving on a terrain or track. It’s also useful to make an object float on
a surface.

For example, suppose you model a raft, a wavy plane (for a sea surface),
then create a curve-on-surface on the sea as the path. You can create the
illusion of the raft bobbing on the sea. To do this, turn on the motionPath’s
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Follow option and select Normal as the World Up Vector. Set the Front Axis,
Up Axis, and Inverse options as necessary. To also have the water seem to
move, use similar options for a camera that follows the same path as the raft.

In your own work, you’ll also animate objects moving along independent
curves, for instance, to simulate the flight of a bird or plane. The technique is
the same as for a curve-on-surface.

Although not shown in the lesson, you can use the Graph Editor to edit the
timing of keys you’ve set for the path. The graph plots U Values in the left
column against the path’s frame range at the bottom. You can also alter the
in-between key motion by selecting the type of tangents used at each key.
See “Lesson 1 Keyframing and the Graph Editor” on page 97 for a lesson on
the Graph Editor.

LESSON 4 TRAX EDITOR

The Trax Editor lets you position, scale, cycle, and mix animation sequences
known as clips. You create a clip by selecting a menu item that extracts a
span of animation from an animated character, for instance a walk cycle.
Once created, a clip is like a time-independent unit of animation that you
can edit as necessary.

You can create a clip from keyed animation, including motion capture data.
The most commonly used clips are reusable spans of animation that are easy
to sequence or blend with other clips.

The ability to change the sequence of clips is a prime feature of the Trax
Editor. For example, suppose you create three clips: a karate punch, tumble,
and kick. You can run the clips in any order, for example, tumble, punch,
and kick, and you can repeat clips or blend the motion between them.

Because it’s easy to alter the start time of clips, they’re useful for
synchronizing the interaction between objects. For example, suppose you
animate a car narrowly escaping collision with a train. If you create a clip for
the train’s animation and another for the car’s animation, you can adjust the
speed of either without worrying about ruining the timing of the near-
collision. You simply move either clip to a different position in the timeline.
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About the lesson
This lesson shows how to use clips and the Trax Editor to control the keyed
animation of an object—a simple sphere. The lesson is intentionally simple
so you can focus on Trax Editor workflow and features without being
distracted by technique issues.

First, you’ll create a clip that moves the sphere in an arcing motion. Next,
you’ll create another clip that modifies the sphere’s motion by making it dip
near its peak. You’ll then cycle the arcing motion to make the sphere bounce
repeatedly as it moves sideways.

Set up the scene view for best viewing
You begin the lesson by setting a playback range that’s long enough to see
the animation clearly. You’ll also display the Trax Editor in a panel rather
than in an obstructing floating window.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 97.

2 Create a new scene.

3 Set the Start and End Times to 0 and 170.

4 Select Window > Settings/Preferences > Preferences. Click the Timeline
category under Settings and set the Playback Speed to Real-time [24 fps].
(The default setting, Play Every Frame, would cause the animation in this
lesson to play too quickly to provide good visual feedback.) Click Save.

5 Select Panels > Layouts > Two Panes Stacked.

6 Display the perspective view in one panel and the Trax Editor in the other.
(To display the Trax Editor, select Panels > Panel > Trax Editor.)

Create the character set
To use the Trax Editor, you need to create at least one character set. A
character set doesn’t necessarily mean a human, animal, or other animated
creature. It’s merely a collection of attributes you’ve chosen to group
together for keyframing convenience.

The following steps show how to create a character set from a pair of sphere
attributes.
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1 Create a default polygonal sphere.

It’s unnecessary to apply a striped texture to the sphere
as shown in the figure. It has been applied only for the
purposes of visual clarity.

2 With the pointer in the perspective view, press 5 (for Shading > Smooth
Shade All).

3 With the sphere selected, select the Translate X and Translate Y attributes in
the Channel Box. (Drag through the attribute names to select them.)

4 Select Character > Create Character Set > ❒ from the Animation menu set.

5 In the options window, enter Bouncer in the Name box, turn on From
Channel Box for the Character Attributes option, and click the Create
Character Set button.

6 Select Character > Select Character Set Node > Bouncer.

The prior two steps create and select a character set named Bouncer. Bouncer
contains only the sphere’s Translate X and Translate Y attributes. The From
Channel Box setting specifies that only the selected attributes in the Channel
Box will be used to create the character set. Translate X and Translate Y are
the only attributes you’ll work with in this lesson.

In the Channel Box, check that pSphere1.tx and pSphere1.ty are the only two
attributes listed under the Bouncer character you just created.

Animate the character set attributes for an arcing motion
After you create and select a character set, you animate it with keys.

1 Go the start of the animation. Make sure the Start Time is 0, not 1.

2 With Bouncer in the Channel Box, make sure pSphere1.tx and pSphere1.ty
are set to 0.

3 Select Animate > Set Key > ❒ . In the options window, select Edit > Reset
Settings and click the Set Key button.

This sets a key for Bouncer’s attributes, pSphere1.tx and pSphere1.ty.
Whenever you set a key, a red key marker (tick) appears in the Time Slider
at the location of the key.

4 Go to frame 20 in the Time Slider.
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5 Enter these values in the Channel Box:

pSphere1.tx: 5
pSphere1.ty: 6

6 Select Animate > Set Key (or press s) to set another key for Bouncer’s
attributes. The Trax Editor displays the range of keyed frames in blue.

7 Go to frame 40 in the Time Slider.

8 Enter these values in the Channel Box, then set another key (press s):

pSphere1.tx: 10
pSphere1.ty: 0

9 Play the animation to see Bouncer arc along the X-axis.

Create a clip for the arcing animation
Now you’ll create a clip for Bouncer’s arcing animation.

1 Click the stop playback button to stop the animation.

2 In the Trax Editor (the panel below the perspective view), select
Create > Clip > ❒ .

3 In the options window, enter Arc for the Name, then click Create Clip.

Maya creates a clip for the selected character, Bouncer, for the range of its
keys (0-40). Whenever you create a clip, Maya removes the red key ticks
from the Time Slider and puts them in the clip. Although the keys are no
longer in Bouncer, the animation is the same as before because, by default,
the clip is applied to the character set from which the keys were taken.

Maya positions the clip in a track next to the character from which it was
created. A track is simply a slot for positioning animation clips. The clip is
displayed as a bar that represents the frame range of the clip. When you
click the clip to select it, it turns yellow.
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If the clip is too small to read its name, select View > Frame All, or dolly into
the view. Later, if you want to see the Time Slider’s entire frame range in the
Trax Editor, select View > Frame Timeline Range. This makes it easier to see
the length of a clip relative to the size of the entire Time Slider.

4 Drag the clip in the track so that it starts at a different time, for instance, at
frame 20. (Don’t drag the right edge of the clip. This has a different effect
than moving the clip.)

5 When you play the animation from the start time, Bouncer’s movement is
delayed until frame 20. With clips and the Trax Editor, you can easily move
the beginning of an animation to the time of your choice.

6 Drag the clip back to its prior position at frame 0.

Modify the motion with a new clip
In the next steps, you’ll modify Bouncer’s arcing motion by adding new keys
to it. This is known as motion warping. Currently, Bouncer arcs from frame 0
to 40. You’ll use keys to make the arcing motion dip at frames 10 to 30.
You’ll create a clip from the new keys to make the animation more versatile.

1 Select Character > Select Character Set Node > Bouncer.

2 At frames 10 and 30, set a key using existing attribute values.

This sets bounding keys for the span of animation you’ll modify. In other
words, these keys ensure that the animation at frames 0 to 10 and 30 to 40
will remain the same, regardless of how you key the motion between 10 and
30.

3 At frame 20, set pSphere1.ty to 2, then set a key. When you play the
animation, Bouncer’s arcing motion dips at frame 10 to 30.
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4 In the Trax Editor, select Create > Clip > ❒ .
In the options window, enter Dip for the
Name, then click Create Clip.

Maya creates another clip, Dip, for the
range of the keys 10 through 30. The clip
appears under Arc.

Be aware that the options window has options that let you specify a partial
range of keys from the Time Slider rather than the full range. This would be
useful if you wanted to create only a small clip of animation from a lengthy
animation sequence.

5 Click the Dip clip to select it.

6 With the Dip clip selected, select Modify > Enable/Disable in the Trax
Editor. The clip dims, indicating it’s disabled.

When you play the animation, Bouncer returns to its original arc without
dipping in the middle. This shows that you can modify your original
animation and easily disable the modification without fear of ruining your
original results.

7 Select Modify > Enable/Disable again to enable the Dip clip again.

8 Select the Arc clip and disable it instead with Modify > Enable/Disable.
When you play the animation, Bouncer moves straight down and up.

This motion, when added to Arc’s arcing motion at frame 10 to 30, is
responsible for the brief dip in the motion.
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9 Select Modify > Enable/Disable again so that the combined effect of Arc and
Dip occur.

Merge the clips and edit attributes in the resulting clip
In the next steps, you’ll merge the clips into one clip. You’ll also edit clip
attributes for additional motion effects.

1 Select the two clips. (Click one, then shift-click the other.)

2 From the Trax Editor panel, select Edit > Merge > ❒ . In the Options window,
enter ArcWithDip as the Name, then click Merge Clip.

The Trax Editor replaces the Arc and Dip clips with a merged clip,
ArcWithDip1. The Arc clip and Dip clip still exist in the scene, though they
no longer appear in the Trax Editor. You’ll learn where they are stored in a
subsequent step.

3 Play the animation and you’ll see that the merged clip has the same effect as
the overlapping individual clips.

4 Double-click ArcWithDip1 to display its attributes in the Channel Box.

5 In the Channel Box, enter 3 for the Cycle attribute.

When you play the animation, Bouncer repeats the motion of ArcWithDip1
three times.

6 Select View > Frame Timeline Range to see the entire clip. The clip lengthens
in the Trax Editor for the increased duration. The clip also displays vertical
lines at the points where each cycle starts.

At the beginning of each cycle, Bouncer jumps back to the start position of
ArcWithDip1 because the attribute values in a clip are, by default,
interpreted as absolute values.

7 With ArcWithDip1 in the Channel Box, change the Offset from absolute to
relative.

8 Go to the start of the animation and play it again. (Dolly the camera view
away from the grid so you can see the entire motion of Bouncer.)

At the beginning of the second cycle, Bouncer continues moving relative to
the final position of the first cycle. At the beginning of the third cycle,
Bouncer continues moving relative to the final position of the second cycle.
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9 Set Scale to 0.5.

This contracts the time range of the clip to 60 frames, so when you play the
animation, Bouncer completes its animation in half the time.

Reuse a clip previously removed from the Trax Editor
The first clip you created, Arc, caused Bouncer to arc sideways without
dipping. When you merged Arc with Dip, it disappeared from the Trax
Editor. You’ll now bring Arc back into the Trax Editor and add it after the
ArcWithDip1 motion.

1 In the Trax Editor, select File > Visor. Whenever you create a clip for a
character set but it’s not currently in the Trax Editor, Maya stores it in the
Visor.

2 Display the Character Clips tab of the Visor.

The three icons displayed are ArcSource, ArcWithDip, and DipSource. When
you create a clip, Maya stores the animation of the selected character set in a
source clip in the Visor. A clip in the Trax Editor is a playback instance of a
source clip in the Visor. ArcSource, DipSource, and ArcWithDip are the
source clips you’ve created in the scene.

When you created the merged clip ArcWithDip, Maya no longer used the
ArcSource and DipSource source clips for Bouncer’s animation. However,
you can reapply either or both of the source clips to Bouncer’s animation.

3 Use the middle mouse button to drag ArcSource from the Visor to the right
of the ArcWithDip1 clip in the Trax Editor. Move the clip so that it starts at
frame 60.
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When you play the animation, ArcWithDip1 plays, followed by the original
Arc. Because the Arc clip has its Offset set to absolute, Bouncer jumps to the
scene view origin immediately when Arc plays at frame 60.

4 Double-click the Arc clip to display its attributes in the Channel Box, then set
Offset to relative. Make sure Arc rather than ArcSource is displayed in the
Channel Box before you set Offset to relative.

When you play the animation, you’ll see the Arc clip animate Bouncer
starting at the last position it had at the end of the ArcWithDip clip. The
motion is continuous and smooth.

5 Use the middle mouse button to drag ArcSource from the Visor to the right
of the Arc clip (frame 100) in the Trax Editor. Double-click the Arc1 clip to
display its attributes in the Channel Box. Set the Arc1 clip’s Offset to relative.
(Make sure Arc1 rather than ArcSource is displayed in the Channel Box
before you set Offset to relative.)

When you play the animation, Arc1 repeats the Arc motion a second time.
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The Arc and Arc1 clips are instances of the ArcSource clip. Instancing a
source clip lets you repeat a clip’s animation without using the Cycle
attribute. Although each instance uses the same animation, you can
individualize clip attribute settings. For instance, you can have Arc cycle five
times though Arc1 doesn’t cycle at all.

Beyond the lesson
The general tasks of working with the Trax Editor follow:

1 Create a character set.

2 Animate a character set.

3 Create one or more clips for the character set’s animation.

4 Position the clip(s) in the Trax Editor as desired.

5 Edit clip attributes for motion effects.

With the Trax Editor, you can experiment with animation without losing
work. This is important in various types of animation. For instance, suppose
you create a soldier walking, but decide you want to lift the legs higher to
make him march rather than walk. If you make the walk cycle a clip, you can
set additional keys that adjust the leg motion without affecting the rest of the
soldier’s motion.

If you create a clip from the added leg motion, you can blend it with the old
motion, or you can disable, modify, or delete it. By creating several clips
with different leg motion, you can try them all until you get the desired
result. No prior animation is destroyed in the process.

If you use motion captured data in your animations, the Trax Editor is a
valuable asset. Because the many animation curves resulting from the data
are complex and laden with keys, it’s hard to work with the curves in the
Graph Editor to edit the motion.

A better alternative is to create a clip from the motion capture data, set
bounding keys at the end of the part you want to modify, then set new keys
to modify that part. When satisfied, you can create a clip for the modified
motion. With this approach, you won’t destroy your original motion capture
data. You can edit the simple curve in the new clip easier than trying to
work with the complex animation curves.
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Although not covered in the lesson, you can use the Graph Editor to edit an
attribute’s animation curve in a source clip. Furthermore, you can copy a clip
to other characters, and you can import clips from other scenes.
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6 CHARACTER SETUP

Character setup is a general term for preparing 3D characters and other
models for animation. A model consists of one or more surfaces created from
NURBS, polygons, or subdivision surfaces. The following lessons show how
to use the most popular character setup features:

• “Lesson 1 Skeletons and kinematics” on page 135

• “Lesson 2 Smooth skinning” on page 148

• “Lesson 3 Clusters and Blend Shape” on page 158

• “Lesson 4 Aim constraints” on page 174

PREPARING FOR THE LESSONS

To ensure the lessons work as described, select the Animation menu set.
Unless otherwise noted, the procedures in this chapter assume the
Animation menu set is selected.

LESSON 1 SKELETONS AND KINEMATICS

After you model the surfaces that make up a human, animal, or other
character, you can create a skeleton and bind it to the character’s surface
(called skin). A skeleton provides a structure for animating the character. The
character’s skin deforms naturally as the skeleton moves. In this lesson,
you’ll create a simple skeleton for a human character. Binding a character to
a skeleton is described in the next lesson.
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Open the scene

In this lesson, you’ll work with a scene that we
created for your use. The scene contains a
human character. In the remainder of the
lesson, you’ll create and animate a skeleton for
the character.

1 Make sure you’ve done the steps in “Preparing
for the lessons” on page 135.

2 Open the scene named Skeletons from the
location specified in the following table:

The character displayed in the scene, jackie, is a template, so you cannot
unintentionally select it during the lesson. Jackie was modeled in the Da
Vinci pose, the position that’s easiest for creating a skeleton.

Create joints for the legs
A skeleton is made of bones and joints. When you create a skeleton in Maya,
you create a series of joints in the skeletal locations where you want the
character to bend or twist.

Maya Package File Location

Maya Complete or
Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD
and find:

InstantMaya/CharSetup/Skeletons.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 
4.5 Personal Learning Edition\

and then to:

tutorialData\MayaPLE\CharSetup\Skeletons.mp
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A common technique for creating a skeleton is to create several independent
joint chains—one for each arm, one for each leg, one for the spine/head—
then group the chains together to create a single skeletal hierarchy. In the
next steps you’ll create the joints for the legs.

1 Select Window > Settings/Preferences > Preferences. In the Preferences
window, click the Kinematics Category. Enter 0.4 for the Joint Size, then click
the Save button.

This displays the joints smaller when you create them in the next steps. At
the default size, 1.0, the size of the joints makes them hard to position
accurately for this character.

2 Select Skeleton > Joint Tool. This is the tool for creating the joint chains that
make up a skeleton.

3 In a side view, click at the hip, knee, ankle, ball
of foot, and toe to create joints at these positions
(see the following figure). Make sure the knee
joint is in a position that creates a slight forward
bend. The forward bend ensures that you will
be able to animate the leg easily in a direction
natural for a leg. Press Enter after creating the
toe joint. This completes the joint chain.

4 Select Window > Hypergraph.

The Hypergraph is a convenient place to select,
rename, and parent objects. It is similar to the
Outliner, but it has features tailored for
character setup. For example, it depicts all
parent-child relationships in an easy-to-read
indented format.

The Hypergraph shows the default names given
to the joints just created: joint1, joint2, and so on.
The joints have a hierarchical relationship.
Joint1 is the parent of joint2, which is the parent of joint3, and so on. Joint1 is
the root of the hierarchy. If you reposition joint1, you reposition the whole
joint chain.

In the scene view, joints are represented by spherical icons. Bones separate
the joints, and are represented by elongated pyramid icons. The narrow part
of a bone points in the downward direction of the hierarchy.

Click
here:
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The reason you create the hip joint first and the toe joint last is to have the
hip at the top of the hierarchy and the toe at the bottom. You’ll usually want
the toe (and other joints) to move whenever you move the hip, but not
necessarily vice versa. In general, joint chains emanate from the interior of
the character outward.

5 Rename the joints as left_hip, left_knee, left_ankle, left_ball, and left_toe. To
rename a joint, press Ctrl and double-click the joint name in the Hypergraph
and enter the new name.

6 In the front view, click the left_hip joint to select it.
Move it along the X-axis to the center of the top of the
left leg. (In this lesson, left and right refer to directions
from jackie’s point of view, not from your view of the
scene.)

As mentioned before, when you move a joint, all joints
lower in the hierarchy move with it. If you press Insert
while a joint is selected, you can move the joint without
moving joints below it in the hierarchy. (To exit this
mode, press Insert again.)

7 Rotate left_hip so that the skeleton fits inside the leg. It’s unnecessary to fit
the skeleton perfectly inside the character, as it won’t be displayed when you
render an image from the scene.

8 To create the joints for the other leg, you can save time and ensure symmetry
by duplicating the existing leg joint chain with mirroring. With left_hip
selected, select Skeleton > Mirror Joint > ❒ . In the options window, turn on
YZ for Mirror Across, and then click the Mirror button.
INSTANT MAYA

138



CHARACTER SETUP | 6
Skeletons and kinematics
Jackie’s legs straddle the YZ plane, so mirroring
the joint chain across the YZ plane positions the
duplicate joint chain in the desired location. This
operation illustrates that jackie’s original position
affects the ease with which you can create the
skeleton. Had jackie been positioned away from
the origin you would not have been able to use
Mirror Joint conveniently to duplicate the leg’s
joint chain.

9 Rename the joints as right_hip, right_knee,
right_ankle, right_ball, and right_toe.

Create joints for the spine and jaw

In the next steps, you create a joint chain for the spinal
column. You’ll also extend a joint from the upper neck
region of the joint chain so that you can animate the
jaw.

1 In the side view, use the Joint Tool to create a series of
joints at the locations shown in the figure. Start at the
base of the spine near the existing hip joints and end at
the top of the head. Make sure you create the first joint
a little bit away from the existing hip joint displayed in
the front view. Otherwise the first joint will be
connected to the hip joint. Remember to press Enter
when you are done creating the joint chain.

With the exception of the joints at each end of the joint
chain, the joints are located where the character is
likely to bend or twist at the spine and neck.

The S-shaped curvature of the joint chain resembles
jackie’s spinal curvature. This makes it easier to
animate the character’s torso and neck naturally.

2 From bottom to top, name the joints back_root, pelvis,
lower_back, mid_back, upper_back, lower_neck,
upper_neck, crown.
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3 To set up the skeleton for jaw movement, extend a joint from the upper_neck
joint. With the Joint Tool selected, click the upper_neck joint, click to create a
new joint near the lips, and press Enter. Name the new joint as jaw.

Create joints for the arms
Creating joints for the arms is similar to creating joints for the legs.

1 In the front view, create a series of joints at the locations shown in the figure.
Start at the pectoral region (near the upper_back joint) and end at the wrist.

2 Name the joints left_arm_root, left_shoulder, left_elbow, and left_wrist.

3 In the top view, select the left_elbow joint, select the Move tool, press Insert,
then move the joint to the back of the arm. Press Insert again.
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Moving the joint to the back of the arm creates a bend at the elbow. This will
make it easier to animate the character’s arm in the direction an arm
naturally bends.

4 In the perspective view, select left_arm_root. Select Skeleton > Mirror Joint.
This creates a copy of the left arm’s joint chain for the right arm.

5 Name the joints of the right arm’s joint chain right_arm_root, right_shoulder,
right_elbow, and right_wrist.

Add ribs to the skeleton
When you bind a character to a skeleton (described in the next lesson), the
skeleton provides a structure for the character’s skin and prevents the skin
from collapsing as you pose the skeleton.

It’s useful to add extra joints in areas of the character where you want the
surface to keep its volume upon deformation. In the next steps, you’ll add
ribs to jackie’s skeleton. Although you will not bind the character in this
lesson, the technique of adding ribs is important to learn so that when you
do bind a character, the skin in the torso area will not collapse as you pose
shoulder and spinal rotations. The rib joints are for structure only, not for
posing the skeleton.
INSTANT MAYA

141



CHARACTER SETUP | 6
Skeletons and kinematics
1 In the Hypergraph, click the mid_back joint to highlight the joint in the front
view. Remember the location of the joint in the front view so you can select it
later (step 3).

2 Select Skeleton > Joint Tool.

3 In the front view, click on the mid_back joint to select it again.

4 Click to the side of the joint to add a rib bone, then press Enter.

5 With the same technique as in the prior steps, create five more ribs as
follows. The ribs extend from the mid_back, lower_back, and pelvis joints.

6 For easy identification in the Hypergraph, you can optionally name the ribs
as desired. For instance, name them left_top_rib, left_mid_rib,
left_bottom_rib, and so on.
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Parent the arm and leg joint chains to the spine
So far you have created five separate joint chains: one for the spine, and one
for each arm and each leg. You need to create a single hierarchy from the
five joint chains so you can move all of them as a single unit. To create the
single hierarchy, you parent the arms and legs to the nearest joint in the
spine.

1 In the Hypergraph, use the middle mouse button to drag left_arm_root to
upper_back.

When you parent one joint to another, Maya creates a bone that connects the
parent to the child. In this case, the bone connects upper_back to
left_arm_root.

2 Use the middle mouse button to drag right_arm_root to upper_back.

3 Use the middle mouse button to drag left_hip to back_root.

4 Use the middle mouse button to drag right_hip to
back_root.

Now if you need to move the entire skeleton, you
can move back_root—the root of the hierarchy.
The completed skeleton is shown in the following
figure (with jackie hidden):

About posing a skeleton
There are two techniques for posing a skeleton:
forward kinematics and inverse kinematics.

Forward Kinematics (FK)
To pose a character with forward kinematics, you
move each joint individually until you get the
desired positioning. For example, to move a hand to some location, you
must rotate several arm joints to reach the location.

When you animate a skeleton posed with forward kinematics, Maya
interpolates the joint rotations starting with the root joint, then the root’s
child joints, and so on down through the skeleton’s action hierarchy. Maya
proceeds forward through the action hierarchy, starting at the root joint.
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Forward kinematics is intuitive for creating simple arc motions, but it’s
tedious if you are animating a complex skeleton. It’s also not intuitive for
specifying goal-directed motion. For example, to move a hand to some
location, it’s not obvious how to rotate the joints in an arm.

Inverse Kinematics (IK)
With IK, you create an extra control structure, an IK handle, for certain joint
chains such as arms and legs. An IK handle lets you pose and animate an
entire joint chain by moving a single manipulator.

As you pose the IK handle, it automatically rotates all the joints in the joint
chain. For example, if you move a hand to a doorknob, the other joints in the
arm rotate to accommodate the hand’s new positioning.

IK is more intuitive than forward kinematics for goal-directed motion
because you can focus on the goal rather than on how you need to rotate
each joint.

Posing and animating the character
Next, you’ll create IK handles that you’ll later use to pose the arms and legs.
Before creating the IK handles, do these steps:

1 Select the root of the hierarchy, back_root, and then select Skeleton > Set
Preferred Angle.

This sets the current joint angles throughout the skeleton as the preferred
angles. This is a useful step after you complete a skeleton. Maya thereafter
uses the current bend in the knees and elbows as the preferred initial
rotation direction of these joints during inverse kinematics (IK) posing. This
makes it easier to pose the character with motion that is natural for a human
character.

2 Select jackie in the Outliner and select Display > Hide > Hide Selection. (You
must select and hide jackie from the Outliner because jackie is a template
object.) By hiding jackie, you’ll lessen scene clutter as you pose the skeleton
in the following steps.

Create, pose, and animate IK handles for the legs
1 Select Skeleton > IK Handle Tool > ❒ . In the Tool Settings window, make

sure Current Solver is set to ikRPsolver.
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2 In the perspective view, click left_hip and left_ankle. This creates an IK
handle that lets you control all joints from left_hip through left_ankle. The
handle’s main manipulator is at the left_ankle.

The IK handle is the selected object after you create it. If you unintentionally
cancel the selection of the handle, you can select it again by clicking the
left_ankle—the last joint you clicked after using the IK Handle Tool.
Whenever you select a handle, make sure you do not select joints or other
objects along with the handle. You can check the Outliner to confirm your
selection.

3 Go to the start of the playback range. With the IK handle selected, select
Animate > Set Key to key the leg’s current position at the first frame.

4 Go to frame 12.

5 In the side view, use the Move tool to drag the IK handle
up and to the left (see illustration), as if jackie were
stepping up a staircase. The foot and knee move while
the hip stays in place.

6 Set another key for the IK handle.

7 Go to frame 24. Move the IK handle back to its prior
position. Set another key.

8 Play the animation to see the leg step up and down
during the first 24 frames. This completes a simple
animation of the leg using an IK handle to control its
position.

9 Go the start of the animation.

10 In a perspective view, practice posing the leg in various
directions by moving the IK handle.

No matter how far you drag the handle manipulator, the
joints of the leg will not stretch beyond the straight leg
position. This is desirable; you do not want the size of a
skeleton to change as you pose it. However, if you drag a leg joint, the bone
hierarchically above that joint will lengthen. This is why it’s important to
check that you haven’t selected a joint with the IK handle before you move
the handle.
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As you drag the handle to some positions, you might notice the leg joints flip
abruptly (see the next figure for an example position). It’s therefore hard to
control the leg positioning in this region.

The default IK handle (IK Rotate Plane handle) has manipulators you can use
to avoid joint flipping. With the handle selected, select Modify >
Transformation Tools > Show Manipulator Tool. Move the Pole Vector XY Z
manipulator to a slightly different position (see the following figure).

If this doesn’t solve the problem, rotate the Twist manipulator to rotate the
leg. You can key the Pole Vector XYZ and Twist attributes to fixed values to
avoid the flipping as the character moves.

A more precise way to avoid joint flipping, which requires some initial
setup, is to use a Pole Vector Constraint. See the online Using Maya: Character
Setup for details.

11 Repeat the preceding steps for the right leg. (Create an IK handle for the
right_hip to right_ankle, then practice posing and animating the handle.)

Important

If you want to move the entire skeleton, group the back_root and all IK
handles under a single node, select the group node, and then use the Move
tool. With this grouping, the motion of the entire skeleton won’t conflict
with the keys you set for the handles.

Twist
Pole Vector
XYZ
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Create, pose, and animate IK handles for the arms
1 Select Skeleton > IK Handle Tool.

2 Click left_shoulder, and then click left_wrist. This creates an IK handle for
the left arm.

3 Select Skeleton > IK Handle Tool.

4 Click right_shoulder, then click right_wrist. This creates an IK handle for the
right arm.

5 Practice posing and animating the handles.

Pose and animate joints with forward kinematics
As the last part of the lesson, you can optionally practice posing and
animating the character by rotating joints that are not controlled by IK
handles—the ball joints of the feet, and joints from the back_root through the
upper_neck. Rotating such joints is forward kinematics.

With the exception of the back_root, you’ll invariably rotate rather than
move the joints that aren’t part of an IK handle. If you move the joints, the
bones lengthen. This deforms bound skin undesirably unless you are
creating cartoon-like distortions.

Because you’ve already set keys for IK handles, some joint rotations on non-
IK handle joints will be restrained by the IK handle positioning. If this
interferes with the intended poses, you can remove all prior animation from
an IK handle by selecting Edit > Keys > Delete Keys. You can also use Delete
Keys to remove all animation from keys you’ve set with forward kinematics.

Beyond the lesson
When you create a skeleton, you can animate a character bound to it to
produce natural skin deformations. Although you animated an unskinned
skeleton in this lesson, it’s more common to animate a skinned skeleton.
Binding a character is the topic of the next lesson.

It’s typically best to animate the entire skeleton from pose to pose at desired
frames. It’s hard to get desired results by animating one limb for a frame
range, another limb for a frame range, and so on.
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There are many ways to work with skeletons not described in this lesson.
For example, you can switch between IK and forward kinematics on joints
controlled by an IK handle. Furthermore, there are other types of IK handles
that provide different controls for manipulating parts of a skeleton.
Especially noteworthy is the IK spline handle, which makes it easy to
animate the twisting, wavy motion in tails, necks, spines, snakes, and so on.
You’ll find details on these and other features in Using Maya: Character Setup.

As you created the skeleton in the lesson, you ended the arm’s joint chain at
the wrist. This prevents you from animating hand motion. If you need to
animate hand motion or even finger motion, you would need to make
additional joints and IK handles. The same applies to foot and toe motion.

The appropriate number of joints in a skeleton depends on the anatomical
parts of the character you want to manipulate. More joints means finer
control at the expense of greater complexity.

LESSON 2 SMOOTH SKINNING

After you create a skeleton, you bind it with a character’s surface to cause
the surface to move with the skeleton during animation. Binding is also
called skinning, and a character’s surface after binding is called skin. Near
joints, the skin bulges or indents when you rotate the joints. This is useful for
animating elbows, shoulders, necks, and so on.

The skin deforms because the surface’s vertices (or CVs) move in response to
the rotation of adjacent joints. The vertices are known as skin points. By
default, the distance a skin point moves depends on how close it is to a joint.
You can edit skin point weighting to change the default movement.
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Open the scene

In this lesson, you’ll work with a scene we
created for your use. The scene contains a
human character and skeleton. Each leg and arm
of the skeleton has an IK handle that lets you
pose the limbs conveniently. If you completed
the prior lesson, the character, skeleton, and IK
handles will be familiar.

1 Make sure you’ve done the steps in “Preparing
for the lessons” on page 135.

2 Open the scene named SmoothSkin from the
location specified in the following table:

The character in the scene, jackie, is displayed with transparency so you can
see the skeleton beneath the surface.

3 Select Window > Settings/Preferences > Preferences. In the Preferences
window, click the Kinematics Category. Enter 0.4 for the Joint Size, then click
the Save button.

This displays the joints smaller. At the default size, 1.0, the large size of the
joints obstructs the view of the skin.

Maya Package File Location

Maya Complete
or Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD and
find:

InstantMaya/CharSetup/SmoothSkin.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 4.5 
Personal Learning Edition\

and then to:

tutorialData\MayaPLE\CharSetup\SmoothSkin.mp
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Bind the skeleton with smooth skin
You’ll use jackie as the surface to be bound to the skeleton.

1 Select jackie.

2 Shift-select the back_root joint.

The back_root joint is at the base of jackie’s spine. If you are not sure which
joint it is, select it in the Hypergraph (Window > Hypergraph).

3 Select Skin > Bind Skin > Smooth Bind > ❒ . Set Max Influences to 3, then
click Bind Skin.

A Max Influences value of 3 specifies that three joints influence each skin
point. By default, the joint closest to the point has the most influence. The
second most influential joint is that joint’s parent or child joint, whichever is
closest to the point. The third most influential joint is the nearest parent or
child of the second joint. The influence drops with the distance from the
joints. The amount of influence each joint has on any skin point is the skin
weight.

The default skin weights create smooth deformations of the skin at elbows,
knees, and elsewhere as the nearby joints rotate.

4 Select and move any or all of the four IK handles to pose the arms and legs
in various positions in order to get used to posing with the IK handles.

To select an IK handle, drag a selection box around a wrist or ankle joint. To
move a handle, use the Move tool to drag the handle in the desired direction.

Note that you can also select the IK handles in the Hypergraph. The handles
are indented under jackieSkeleton. Each is named for a leg or arm, for
example, ikHandleLeftLeg. For more details on IK handles, see “Lesson 1
Skeletons and kinematics” on page 135.

5 If you prefer to turn off the skin’s transparency so you can see the skin more
clearly, turn off Shading > Shade Options > X-Ray. Do not be concerned that
the skeleton pokes through the skin, as the skeleton is not displayed in a
rendered image.

As you pose the arms and legs, examine the skin in the regions where joints
bend. For many poses, the skin looks natural. For others, the skin folds,
compresses, or bulges unnaturally. The pelvis, shoulders, and torso are
common problem areas for various poses. For example, if you move an arm
straight up, the shoulder compresses as in the following figure.
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There are two ways to improve the smooth skin deformations:

• Add an influence object to eliminate collapsing regions or to create muscle
bulge. For example, you can use an influence object to make the shoulder
region look more natural in the prior pose.

• Edit skin weights—to remove minor lumps or indented regions. For
example, you can fill out an undesirable concave region at the chest that
appears when you move the arm to certain poses.

The following procedures explain the techniques.

See how skin weights influence the skin’s deformation
In the next steps, you’ll learn how joints and skin weights influence
deformations at jackie’s chest. In a subsequent section, you’ll improve
uneven deformations.

1 Pose the left arm similar to the following figure. The left breast becomes
irregularly shaped.

Unnatural deformation
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2 Select jackie.

3 Select Skin > Edit Smooth Skin > Paint Skin Weights Tool > ❒ .

4 In the Influence list of the Tool Settings window, select any joint, for
instance, pelvis. The grayscale color of jackie’s skin indicates how much
influence that joint has on the skin’s deformation.

White means the skin is maximally influenced by the joint. Black means the
skin is not influenced by the joint. Gray means the influence is partial. The
lighter the gray, the more the influence.

Each point on the surface is influenced by three joints, as specified by the
Max Influence setting in a prior step. However, one or two of the three joints
might have so little influence as to be insignificant.

In general, a white region of skin is influenced nearly entirely by the joint
selected in the Influence section of the Tool Settings window. A gray region
is influenced significantly by one or two additional joints.

5 The reason the left breast becomes irregularly shaped as you pose the arm is
that some joint is exerting too much or to little influence on the breast.

Breast collapses
in this pose
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6 Select each entry in the Influence list to determine which joints are
influencing the irregular region of the breast. The region will be a shade of
gray (or white) when you select the appropriate joints. The left_arm_root is
the main influence. The upper_back, mid_back, and left_top_rib also have
influence, though not exactly in the same region.

Modify skin weights
You can modify the skin weights for any of the influencing joints to alter the
irregular region. If you don’t get the desired results when you change the
skin weights of one of the influencing joints, you can undo your changes and
try another influencing joint.

In general, it’s best to modify the skin weights of the most influential joint
first, then work with less influential joints if you don’t get the desired
results. Modifying skin weights requires experimentation.

In the next steps, you’ll modify the skin weights for the left_arm_root joint.

1 Select left_arm_root in the Influence list.

2 In the Paint Weight Menu section of the window, set Value to 0.1 and turn
on Add.

3 Drag the mouse pointer to paint the irregular region of the breast. Each
stroke adds 0.1 (10%) to the skin weight. The weight for a skin point has a
maximum value of 1 (fully white).

Repeat the strokes several times until the irregular region becomes
smoother. The jagged, asymmetrical wireframe at the breast becomes more
symmetrical as the skin becomes smoother. The region whitens, which
indicates increased influence from the left_arm_root joint. Note that
increasing the influence of one joint lessens the influence of the other
influencing joints.

4 To check the shape with full-color shading, click the Select Tool. (You might
also prefer to cancel the selection of jackie to eliminate the display of the
highlighted wireframe.)
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5 To continue modifying the skin weights with the Paint Skin Weights Tool,
select jackie and once again select Skin > Edit Smooth Skin > Paint Skin
Weights Tool.

There are several additional tool settings you might find useful as you
modify skin weights:

• The Smooth operation smooths the weights of points by averaging the
stroked points with the weights of the surrounding region. This is useful if
you add to the weight values in some region but the points become
unevenly weighted. Uneven weights are indicated by mottled gray skin.

• You can use the Scale operation with a Value less than 1 to scale down the
point weights of a stroked region.

• As you stroke a region, the red circle icon displays the radius of the region
affected by the stroke. The Radius(U) value changes the radius.

• You can select any of the Profile icons to specify the region affected by
strokes. The two leftmost icons are the most commonly used shapes.

6 After you eliminate the irregular region from the left breast, move the arm to
different positions to see if the breast’s shape stays natural in various poses.
It is common for a surface to look good in one pose but not in another. Strive
to make the surface look good in the poses that you are likely to use during
animation.
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7 If you want more practice, pose the right arm as you posed the left arm and
fix the corresponding irregular region in the right breast. This time, fix the
region by modifying the weights for the upper_back joint rather than the
right_arm_root. As mentioned previously, you can modify point weights of
alternative joints to get a similar effect.

Enhance skin deformation with an influence object
You can create an object and use it to influence the shape of smooth skin.
The object, called an influence object, acts like a surgical implant against
which the skin deforms. For example, you can create a sphere and use it to
simulate a muscle or bone that bulges as you pose the character in certain
positions. You can also use an influence object to smooth deformation and
maintain volume in regions that collapse while bending.

In the next steps, you’ll use a sphere as an influence object to simulate an
elbow jutting out as jackie’s arm bends. To use an influence object, the
skeleton must be in the bind pose—the original pose at which the skin was
bound to jackie.

Return the skeleton to the bind pose
1 Click the Select Tool and cancel the selection of jackie.

2 Turn off Modify > Evaluate Nodes > IK Solvers.

After you use an IK handle to pose a character, you must do this step before
you can return the skeleton to the bind pose.

3 Select back_root, the root of the skeleton.

4 Select Skin > Go to Bind Pose.
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5 Select the ikHandleLeftArm in the Hypergraph. Use the Move Tool to move
the handle manipulator slightly in any direction. When you release the
mouse, note that the arm does not move and that the IK handle manipulator
snaps back to the desired position at the end of the joint chain. Repeat this
step for any other IK handles you posed previously.

6 Turn on Modify > Evaluate Nodes > IK Solvers.

You must do this step to enable the IK solvers so you can manipulate IK
handles in the scene again.

Position a sphere to be used as an influence object
1 Right-click jackie’s surface (anywhere but on the skeleton) and select

Actions > Template from the marking menu. By making jackie a template,
you won’t accidentally select jackie in subsequent steps.

2 Select Create > Polygonal Primitives > Sphere, and name the sphere
elbow_influence.

3 Scale the sphere to be slightly smaller than any of jackie’s joints (see
illustration below).

4 Move the sphere so that its surface is positioned where the elbow would jut
out, but still within the skin. You can optionally reshape the sphere’s
curvature to resemble the tip of an elbow jutting out from a bent arm. For
example, you can scale the sphere in one dimension to squash its shape or
you can move individual vertices. A top view of the sphere’s shape and
position follows:

The exact position and scale of the sphere is unimportant. You can make
slight position and scale adjustments later to enhance the deformations that
result from its use.

Make the sphere an influence object
1 In the Hypergraph, select jackie and Shift-select elbow_influence.

sphere (elbow_influence)
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2 To make the sphere an influence object, select Skin > Edit Smooth
Skin > Add Influence. Maya completes the operation within a few moments.

3 In the Hypergraph, parent elbow_influence and elbow_influenceBase to the
left_shoulder joint. This ensures the influence object stays in the correct
position at the elbow whenever the arm moves to a new position.

The elbow_influenceBase is known as a base object. It stores vertex position
information for the influence object. The reason for parenting the base object
to the left_shoulder joint is so that the influence object’s vertices stay in the
correct position at the elbow whenever the elbow moves to a new position.
Other than this step, you do not work with the base object.

4 Right-click jackie and select Actions > Untemplate. It is easier to see
subsequent skin deformations when jackie is displayed with smooth shading
rather than as a template.

5 From the menus at the top of the top view, turn off Show > Joints to avoid
having the joints obstruct your view of the skin.

6 Use each arm’s IK handle (ikHandle1 and ikHandle2) to pose the arms in the
following position.

The left elbow looks more natural than the right elbow. To tune the elbow’s
deformation during bending, change the position, scale, and rotation of
elbow_influence.

Do not be concerned if the influence object pokes through the skin. It won’t
be displayed when you render the animation.

Beyond the lesson
This lesson showed how to bind a skeleton to a single surface. Be aware that
you can bind a skeleton to multiple surfaces or even to a selection of
polygonal vertices or NURBS CVs or subdivision surfaces.

Influence object makes the
left elbow fuller and sharper
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The lesson also showed how to use the Paint Skin Weights Tool to prevent a
region from collapsing upon deformation. To control skin weights with more
precision than shown in the lesson, you can modify skin weights
numerically with the General Editors > Component Editor. Note also that if
you smooth skin multiple surfaces seamed together, there are many tool
settings for the Paint Skin Weights Tool that make the task easier.

The lesson explained how to use an influence object to make an elbow stick
out upon bending. Another common use of an influence object is to simulate
a muscle bulging during joint rotation. The technique requires use of Set
Driven Key to link the bulging influence object’s scale values to the rotation
of the appropriate joint. A brief example of this technique is in the online
user guide documentation for Smooth Skin.

Skin weights and influence objects cannot overcome all modeling problems.
For instance, if you spread jackie’s legs sideways, you will see an unsightly
fold at the hips. This occurs because of the asymmetrical arrangement of
polygonal edges in the hip region of the original model. To fix the problem,
you would need to detach the skin, alter the original model, then smooth
bind the model again.

Maya has an alternative skinning method, rigid skinning, which gives
results similar to smooth skinning but requires use of different enhancement
tools: flexor and lattice deformers. In general, smooth skinning gives more
natural deformations with less effort than rigid skinning. If you skin
multiple seamed surfaces, however, processing is faster with rigid skinning
than with smooth skinning.

Smooth skinning is just one of the techniques for perfecting a character’s
deformations during animation. You can use Maya’s other deformers alone
or in addition to smooth skinning to achieve the results you desire.

LESSON 3 CLUSTERS AND BLEND SHAPE

Facial animation demands attention to detail. People are keenly aware of
changes in facial expression because of a lifetime of experience looking at
faces. Maya has two deformation tools that ease character setup for facial
animation: clusters and blend shape.
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In this lesson, you use a cluster to shape a character’s unsmiling mouth into
a smile. Next, you’ll use the blend shape feature to animate from the
unsmiling position to the smiling position.

Open the scene

In this lesson, you’ll work with a scene we created for your use.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 135.

2 Open the scene named ClusterBS from the location specified in the following
table:

The scene contains a man’s head.

Maya Package File Location

Maya Complete
or Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD and
find:

InstantMaya/CharSetup/ClusterBS.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 4.5 
Personal Learning Edition\

and then to:

tutorialData\MayaPLE\CharSetup\ClusterBS.mp
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3 Press 7 on your keyboard. (This has the same effect as selecting these three
menu items: Shading > Smooth Shade All, Shading > Hardware Texturing,
and Lighting > Use All Lights.)

Duplicate the face
In the next steps, you’ll duplicate the face of the head. Later in the lesson,
you’ll apply a cluster to the duplicate face so you can create a smile.

1 Select the face, which is the head without the eyes, ears, and hair. In the
Outliner, the face is named baseFace and is indented under head.

2 Select Edit > Duplicate > ❒ . In the options window, select Edit > Reset
Settings, turn on World for the Group Under option, then click the Duplicate
button. By grouping the duplicate under the world, you create an object
independent of the original.

3 Move the duplicate face to a position where both faces are visible for
comparison, for instance, to the right side of head.

created by Ken Yao
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4 Rename the duplicate face as smilingFace.

Create a cluster
In the next steps, you’ll create a cluster deformer to reshape the unsmiling
baseFace into a smiling face. A cluster deformer creates a set whose
members consist of selected points (CVs, vertices, or lattice points). You
assign a percentage weight to each point, indicating how much you want
each point to be affected by any translation, rotation, or scale of the cluster
set. When you transform the cluster, the points are transformed according to
the percentages you have specified. A cluster is useful for stretching,
moving, or compressing part or all of a surface.

1 Position the pointer over the face. Right-click to select Vertex, then select the
smilingFace vertices shown in the following illustration, which are roughly
the vertices at the chin, cheeks, and lips:

duplicate facehead
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The region of selected vertices does not need to be exact. The objective is to
select all vertices where a smile might deform the face. You might want to
look in a mirror to see which parts of a face move while smiling. It’s better to
select too many vertices than too few. It’s easier to work with too many
vertices than too few.

An easy way to select the vertices is to use the Paint Selection Tool. First,
right-click smilingFace in the scene view and select Vertex from the marking
menu. Select Edit > Paint Selection Tool > ❒ . In the resulting options
window, set Radius(U) to 0.2. Drag the mouse on the desired vertices. Ctrl-
drag to cancel the selection of inadvertently selected vertices. Close the Tool
Settings window when you are done.

Make sure you don’t select vertices at the back of the head inadvertently.
Also make sure you don’t inadvertently miss a few vertices in the region you
select.

2 Select Deform > Create Cluster.

This puts the vertices into a cluster—a set of points you can move as single
entity. The cluster’s handle appears in the view as a C icon.

3 In the Outliner, make sure the cluster2Handle is selected.

4 Use the Move tool to drag the cluster handle up along its Y-axis a small
amount until smilingFace is deformed as follows:

Side view Persp view
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Edit cluster weights
As you saw in previous steps, the points in a cluster move when you move
the cluster handle. The distance a particular point moves depends on its
weight. Lower weights cause less movement, while higher weights cause
exaggerated movement. In the next steps, you create a smile by editing the
weights.

1 Select smilingFace.

2 Select Deform > Paint Cluster Weights Tool > ❒ . This displays the
smilingFace in grayscale.

Before dragging After dragging
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The white area shows the points that make up the cluster. The whiteness
also indicates the weights—how much the points move in response to the
movement of the cluster handle. White indicates a cluster weight of 1—the
points move the same distance as the handle. By default, each point has a
weight of 1.

Black indicates a cluster weight of 0. The points do not move in response to
cluster handle movement. Note that regions that are not part of the cluster
are also black.

Although there are no gray regions currently, gray means the movement is
partial. The lighter the gray, the more the movement. Gray regions indicate a
cluster weight between 0 and 1.

3 In the Paint Attribute Section of the Tool Settings window, enter a Value of
0.5, make sure the Replace Operation is turned on, and click the Flood
button. This gives all the cluster points a weight of 0.5. The white region is
now gray:

The selected vertices move down a bit, as the weight of 0.5 lessens the effect
of the prior movement of the cluster by 50%.

4 To check the shape with full-color shading, click the Select Tool. (You might
also prefer to cancel the selection of smilingFace to eliminate the display of
the highlighted wireframe.)

5 To return to the Paint Cluster Weights Tool, select smilingFace and
Deform > Paint Cluster Weights Tool > ❒ again.

6 In the Tool Settings window, make these settings:
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Radius(U): 0.1
Value: 1
Opacity: 0.3
Operation: Replace

7 Paint the region at the corners of the mouth with repeated strokes until the
face looks roughly like the following figure. If your results differ from the
figure significantly, undo the strokes and try again.

After you finish, consider the settings you made in the previous step.

A Radius(U) of 0.1 sets the radius of the region affected by the stroke. The
red circle icon on the face displays the radius.

A Value of 1 sets the weight value you paint on the points.

An Opacity of 0.3 scales down the effect of painting weight values so you
can build up values gradually with repeated strokes.

A Replace Operation paints the Value specified on the points stroked.

While painting weights, it’s useful to intermittently check the shape with
with full-color shading rather than with the grayscale shading. To do this,
click the Select Tool to turn off the Paint Cluster Weights Tool. (You might
also prefer to cancel the selection of smilingFace to eliminate the display of
the highlighted wireframe.)

Value = 1
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8 Enter a Value of 0.25 and paint the central region above and below the lips
as follows:

Because the corners of the mouth have a high weight and the central region
around the lips have a low weight, the corners move up more in response to
the prior positioning of the cluster handle. This creates a smiling mouth. The
cheeks and chin have a medium weight, so they also move up slightly also.
(For many people, skin at the chin and neck moves during smiling.)

9 In the Tool Settings window of the Paint Cluster Weights Tool, turn on the
Smooth operation. Then paint any region where the surface has become
irregular. Irregular regions are typically indicated by jagged wireframe
curves (isoparms) or where a grayscale color makes an abrupt change to a
lighter or darker color. Smoothing averages the weights of the stroked points
with the weights of the surrounding region. The Value setting has no effect
on smoothing.

10 Replace and smooth weights in other regions of the face until you are
satisfied with the smile. For example, you might want to reduce the weight
values at the side of the nose and immediately below the nose.

Create a blend shape
A blend shape deformer is ideal for facial animation, where you need a
number of facial positions to be readily available for use in an animation
sequence. With a blend shape deformer, you can set up a character’s face to
blend between a smile, frown, smirk, and so on.

Value = 0.25
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In the next steps, you create a blend shape deformer to change the baseFace
into the smile of smilingFace.

1 In the perspective view, select smilingFace and Shift-select baseFace,
specifically in this order.

The smilingFace (the first selection) is called the target object, while baseFace
(the second selection) is called the base object. The objective of a blend shape
operation is to morph the base into the target.

2 Select Deform > Create Blend Shape.

3 Select Window > Animation Editors > Blend Shape. This displays the Blend
Shape editor, which has a slider for changing the base into the target shape,
and buttons for setting keys.

4 Cancel the selection of the faces so you can see the surfaces without the
obscuring highlighted wireframe.

5 Drag the slider from 0 to 1 to morph the baseFace into the target,
smilingFace.

Note that you can click the Key button below the slider to set an animation
key for the shape of the face at the current frame. By setting a few keys with
different slider values at different points in the timeline, you can animate
from the neutral expression to a full or partial smile or vice versa.

When you key the shape, Maya applies the key to the blendShape node that
was created when you selected Window > Animation Editors > Blend Shape.
If you need to select the blendShape node, for instance, so you can see or
delete the keys in the Time Slider, click the Select button in the Blend Shape
editor.
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Tune deformation effects
The combination of a cluster and blend shape is ideal for facial animation
because it lets you tune various subtle deformations. A few common
techniques follow.

• In the box below the slider of the Blend Shape editor, you can enter a
numerical value below 0 to invert the deformations, or above 1 to amplify
the deformations. For example, -1 creates a frown, while 1.6 creates a
brimming smile:

• With or without changing the Blend Shape slider, you can move, rotate, and
scale the cluster handle to modify the blend shape. The following figure
shows some examples. The face you created will be slightly different because
your original smile is different.

Slider value = -1 Slider value =1.6
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• You can use the Paint Cluster Weights tool again to change cluster weights
when the cluster and blend shape editing deforms certain regions
undesirably or doesn’t give the exact look you desire. You can also use Ctrl -
Z to undo any undesired changes.

Add another facial expression to the blend shape
In the next steps, you’ll duplicate the face again and reshape the duplicate
into a new facial expression. You’ll then add the new face to the blend shape
node to create another slider in the Blend Shape Editor.

1 Set the Blend Shape editor slider value to 0 to return baseFace to the position
it had at the beginning of the lesson.

2 Make a duplicate of baseFace, name it raisedBrow, and move it to the left of
baseFace so that all three faces are visible for comparison.

Slider value = 0.75

Translate XYZ = 0, 0.2, 0.6
Rotate XYZ = -25,0,0
Scale XYZ= 1.3, 1, 1.6

Stuffed mouth

Cluster handle:

Slider value = 1

Translate XYZ = 0, 0.1, 0.25
Rotate XYZ = -10,0,-8
Scale XYZ= 0.7, 1.1, 0.8

Cluster handle:

Smirk
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3 Make sure raisedBrow is selected.

4 In the perspective view, select Show > Isolate Select > View Selected. Select
this menu item again in the front view.

This displays only the selected object (raisedBrow) in the views. This is
necessary to avoid selecting unwanted vertices in the next steps.

5 In the front view, position the pointer over the face, right-click and select
Vertex. Drag a selection box around the vertices in the region of the
eyebrows and forehead as shown below.

raisedBrow baseFace smilingFace

Drag a selection box
around these vertices
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For these vertices, you need to select the vertices by dragging a selection box
rather than by using the Paint Selection Tool. The eyebrows have vertices
that lie behind its outer surface. The Paint Selection Tool selects only vertices
at the outer surface. Dragging a selection box selects all vertices in the boxed
region, including vertices that lie behind the outer surface.

6 In the side view, hold down the Ctrl key and drag a selection box around the
vertices at the side of the head to turn off their selection (see the following
figure).

7 Switch to wireframe display mode and dolly the camera from various close-
up views to make sure you select all the vertices on and under the eyebrow.
If you miss a few vertices, subsequent deformations will not work correctly.
Also, make sure you don’t select vertices at the side or back of the head.

8 Select Deform > Create Cluster.

9 In the perspective view, turn off the selection of Show > Isolate Select > View
Selected. Do this again in the front view.

By turning off these menu selections, Maya displays all objects in the views
again.

10 In the perspective view, drag the cluster up along its Y-axis a small amount
until raisedBrow looks like the face on the left:

Hold down the Ctrl key
and drag a selection box
around these vertices to
cancel their selection.
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11 In the perspective view, select raisedBrow and Shift-select baseFace. The
raisedBrow is the target, while baseFace is the base object.

12 Select Deform > Edit Blend Shape > Add > ❒ . In the options window, turn
on Specify Node and enter blendShape1 in the BlendShape Node box. Click
the Apply and Close button.

When you created the blend shape for the smile, Maya created a node
named blendShape1 that contains the slider attributes that adjust the blend
into the smilingFace target. The Add operation creates a blend shape for the
raisedBrow and adds it to the blendShape2 node. This adds a slider to the
node’s Blend Shape editor for adjusting the raised brow deformations.

13 To display the Blend Shape editor, select Window > Animation
Editors > Blend Shape.

Additional slider for raisedBrow
INSTANT MAYA

172



CHARACTER SETUP | 6
Clusters and Blend Shape
14 You can use the sliders alone or in combination to create a smile with raised
eyebrows, a frown with lowered eyebrows, and so on.

15 You can optionally select raisedBrow and edit the cluster weights to tune the
deformation of the eyebrow region as desired. See “Edit cluster weights” on
page 163 for details. An example weighting follows:

Tip

After you create a blend shape, you can optionally hide or delete a target
object (in this lesson, smilingFace and raisedBrow). If you delete a target,
you improve Maya processing time but lose the capability to manipulate
the cluster handle. For versatility, many animators hide the target rather
than delete it. Hiding the target is necessary when you render the scene. It
is also useful when you want to unclutter the scene view.
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Beyond the lesson
In the lesson, you used two clusters and a blend shape deformer to
manipulate facial expressions. In professional productions, it’s common to
create several more clusters with a blend shape deformer for finer control of
facial expressions. For example, you can create clusters for a number of
mouth positions that you can use to simulate the phonemes of speech.

When you used certain blend shape slider values, you might have noticed
that the face looked good in all regions except for a few vertices. To fix such
regions, delete the cluster, move the problem vertices of the target face to a
better position, then create a blend shape for the improved target face.

To prevent this problem, use a target shape that’s not extremely different
from the base shape. If you need to use an extremely different target shape,
create a blend shape with multiple targets. Each of the multiple targets must
have a shape that is progressively more like the extreme target shape. Before
you create the blend shape, turn on In-Between in the Create Blend Shape
options window, and select the multiple targets in this order: least extreme
shape difference first, most extreme shape difference last.

Although the lesson showed how to blend individual objects, you can also
blend hierarchies of objects. See Using Maya: Character Setup for details.

A few useful cluster features not explained in the lesson follow:

• You can add or remove vertices from a cluster with Deform > Paint Set
Membership Tool.

• You can use the Component Editor to edit weight values more precisely than
by painting.

• Do not change the number of vertices (or CVs) for a surface after you apply
a cluster or other deformer. Unexpected deformations will likely occur.

LESSON 4 AIM CONSTRAINTS

It’s often useful to constrain an object’s position, orientation, or scale to
another object. For example, you might want to have the eyes of a frog
follow a fly wherever it flies. In this lesson, you’ll learn how to use an aim
constraint to do this.
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Open the scene
To begin the lesson, you’ll open a scene containing a frog and a fly.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 135.

2 Open the scene named AimConstrain from the location specified in the
following table:

3 Play the scene and you’ll see the fly flying in a figure-eight pattern. The fly
was animated with path animation. You do not need to understand path
animation to complete this lesson.

Maya
Package

File Location

Maya
Complete or
Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD and
find:

InstantMaya/CharSetup/AimConstrain.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning
Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 4.5 
Personal Learning Edition\

and then to:

tutorialData\MayaPLE\CharSetup\AimConstrain.mp

created by Emanuel Druckmann
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Create the aim constraint
In the next steps, you’ll create an aim constraint to keep the frog’s eyes
focused on the fly.

1 In the Hypergraph, select flyControl, which is the group node for the
surfaces and other items that make up the fly.

2 Shift-select right_eye_aim, which is indented under frog in the Hypergraph.
The right_eye_aim is the group node for the elements of the right eye.

3 Select Constrain > Aim.

This locks the orientation attributes of right_eye_aim so that the eye points at
flyControl wherever it moves. More specifically, the positive X-axis of the
local rotation axis of right_eye_aim points at flyControl’s pivot point, by
default.

After you use the Constrain > Aim operation, the right eye points in a
slightly different direction than it did before the operation. This occurs
because the orientation changes to match the position of the fly at the current
frame.

You must select the objects in the correct order before you use
Constrain > Aim. You select the controlling object first and the constrained
object second (i.e. fly then the eye). If you forget the correct order, try to
remember that you select the master object first, slave object second.

4 Cancel the selection of the prior objects, then play the scene to see the eye
follow the fly.

5 To constrain the left eye, again use the Hypergraph to select flyControl and
Shift-select left_eye_aim, then select Constrain > Aim.

6 Cancel the selection of the prior objects and play the scene again to watch
both eyes follow the fly. Adjust the view as necessary to see the movement
of the pupils.

Adjust the orientation of the eyes
The frog’s eyes point in the general direction of the fly. In the next steps,
you’ll adjust the eyes to point more directly at the fly:

1 At frame 0, select right_eye_aim.

2 Turn on Display > Component Display > Local Rotation Axes.
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As mentioned before, the positive X-axis of right_eye_aim always points at
the fly. With the local rotation axes displayed, you can see the X-axis so you
know exactly which part of the eye points at the fly. The X-axis does not
point directly out of the pupil, so the pupil does not point directly at the fly.
You’ll next adjust the orientation of the eye.

3 In the Hypergraph, select right_eye_geom, which is indented under
right_eye_aim.

The right_eye_geom is a group node that contains the surfaces that make up
the eye. It is the child of the top of the hierarchy, right_eye_aim, and can
therefore be rotated independently of right_eye_aim. This means you can
rotate right_eye_geom to put the eye in the desired starting position, and the
eye follows the fly’s motion based on that starting position.

The use of two group nodes in this way is generally good animation
technique because it enables you to control the transformation and
animation of an object independently with two different techniques.

Had we used no group nodes for the eye’s surfaces, tuning its starting
orientation would have been more difficult because you would have had to
use the Attribute Editor to enter Aim Vector coordinates of the
aimConstraint node associated with the eye.

4 In the scene view, dolly closer to the right eye until you can see the pupil
clearly and the position of the fly.
INSTANT MAYA

177



CHARACTER SETUP | 6
Aim constraints
5 Use the Rotate manipulator to make the pupil face more directly at the fly.

6 Cancel the selection of right_eye_geom.

7 Play the animation and check that the pupil doesn’t roll entirely behind the
eyelid at any time in the animation. If not, rotate right_eye_geom to a
slightly different position and check the animation again.

8 Repeat the preceding steps to reorient the left eye.

9 To view the eyes with less clutter when finished, turn off the Local Rotation
Axes display for right_eye_aim and left_eye_aim.

Beyond the lesson
Although not described in the lesson, there are a few useful constraint
options you can specify in the options window (Constraint > Aim > ❒ )
before you create the constraint. For example, you can use the Aim Vector,
Up Vector, and World Up Vector to overcome unexpected flipping or rolling
as the constrained object undergoes extreme rotations. After creation, these
options are available in the Attribute Editor for the aimConstraint.

In your own work, if you constrain a group node containing several surfaces
to an object, make sure you first center the pivot of the group node within
the child surfaces. To do this, select the group node and select
Modify > Center Pivot. By default, a group node has its pivot centered at the
origin. The constrain operation typically gives undesired results if you do
not center the pivot of the group node.

The Constrain menu also has selections for constraining:

• the Orientation, Scale, or position (Point) between objects
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• an object to a surface (Geometry)

• the aim of an object to the tangency of a curve (Tangent), useful for pointing
an object along a path

• the rotations of an IK Rotate Plane handle (Pole Vector), useful for
preventing joint flipping during animation

• the orientation of an object to the normal vectors of a surface (Normal)

Also be aware that you can constrain an object to a weighted or unweighted
average of the positions of several objects.
INSTANT MAYA

179



CHARACTER SETUP | 6
Aim constraints
INSTANT MAYA

180



7 RENDERING

In general terms, rendering is the process of displaying or visualizing
something in a certain way. In 3D animation, rendering typically refers to
the act of creating a high-quality image snapshot for each frame of an
animation sequence. After rendering the images, you play them in sequence
to create a film or video clip.

This chapter includes the following lessons:

• “Lesson 1 Rendering a scene” on page 181

• “Lesson 2 Shading surfaces” on page 196

• “Lesson 3 Lights, shadows, and cameras” on page 214

PREPARING FOR THE LESSONS

To ensure the lessons work as described, select the Rendering menu set.
Unless otherwise noted, the directions in this chapter for making menu
selections assume you’ve already selected the Rendering menu set.

LESSON 1 RENDERING A SCENE

The first lesson provides an overview of rendering in Maya. More detailed
discussions of rendering topics are in the remaining lessons.

Open and examine a scene
In this lesson, you’ll use a scene we’ve created for your use.

1 Open the scene named RenderIntro from the location specified in the
following table:
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The scene contains a ring animated in a motion similar to a coin spinning on
a table. The ring sits on a plane that’s slightly smaller than the grid.

As an alternative to using the scene RenderIntro.mb, you can create a similar
scene with objects you create.

2 Select Window > Settings/Preferences > Preferences. Click the Settings
category and make sure the Time option is set to Film (24 fps) so your
animation plays at the default rate of 24 frames per second.

3 Play the scene to examine the animation. In the remainder of the lesson,
you’ll color the ring and plane, then render the animation to disk.

Maya Package File Location

Maya Complete
or Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD and
find:

InstantMaya/Rendering/RenderIntro.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 4.5 
Personal Learning Edition\

and then to:

tutorialData\MayaPLE\Rendering\RenderIntro.mp
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Create shading for the ring and plane
In the next steps, you will color the ring and plane by creating materials. A
material is a collection of attributes that control how a surface appears,
including its color and shininess.

The scene RenderIntro.mb displays the ring and floor as wireframes
(Shading > Wireframe). This is the default display mode for objects in a
scene view.

1 In the perspective view, select Shading > Smooth Shade All (Hotkey: 5).

This displays the ring and plane with default smooth shading and default
lighting. The default shading is gray. The default lighting is provided by an
imaginary light fixture. It emanates light infinitely from a point above and
behind the active scene view camera.

It’s necessary to turn on Smooth Shade All so that the scene view displays
the shading (colors and textures) you’ll apply to the ring and plane later.

2 Right-click the ring and select Materials > Assign New Material > Blinn. The
Attribute Editor appears for the Blinn material.

The Blinn material gives the ring a shiny appearance. You will learn more
about materials and their attributes in a later lesson.

3 Click the gray box to the right of Color.

This displays the Color Chooser.
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4 Click inside the color wheel (hexagon) and drag the pointer to a gold color.
The exact color is unimportant for this lesson. The ring becomes the same
color you select in the Color Chooser. Click Accept to close the chooser.

5 Right-click the plane and select Materials > Assign New Material > Lambert.
A Lambert material is useful for creating a dull surface without shiny
highlights.

The Attribute Editor appears for the Lambert material.

6 Click the checkered icon to the right of the Color slider.

This displays the Create Render Node window, which lists various texture
patterns you can apply (or connect) to the color of the Lambert material and
therefore to the plane.

7 Click Cloth.

8 To have the scene view display the cloth texture you just assigned to the
plane, select Shading > Hardware Texturing (Hotkey: 6).

This provides an approximation of how the final rendered image will
appear.

9 Turn off Display > Grid so that the grid doesn’t interfere with your view of
the plane.
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The plane has a dull Lambert surface with a default cloth texture. There are
many other attributes you can set to change the look of these objects, but this
basic appearance suffices for this lesson. Again, you’ll learn more about
shading objects in a later lesson.

Render a single frame and adjust shader values
So far, you’ve examined the shading of the ring and plane in the scene view.
In this view, Maya uses your computer’s graphics hardware to display the
shading quickly but crudely. To examine the shading with sharper colors
and textures, you must select a menu item that uses a Maya software process
to render the scene. This process is called software rendering.

Software rendering can take seconds or minutes to render a single frame
from your scene, depending on the complexity of shaders, lighting and other
visual elements present.

There are two ways to software render a frame of animation:

• Interactive Photorealistic Rendering (IPR)

• Maya’s standard renderer

In the next steps, you’ll work with IPR. The advantage of IPR over Maya’s
standard renderer is that, after you render a frame with IPR, you can adjust
the shading and lighting characteristics of the scene and see quick updates of
part or all of a rendered image. Updates are not always instantaneous, but
they are always high quality.
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The standard renderer takes longer than IPR to update an image but creates
the images of highest quality. You use the standard renderer for final
rendering.

1 Go to the first frame of the animation. You’ll render the first frame using the
perspective camera view.

2 You need to specify the exact region of the perspective view you want to
render. To see the border of the region to be rendered, you’ll need to adjust
the camera’s attributes. To start, select View > Camera Attribute Editor.

3 In the Attribute Editor, open the Display Options section and turn on
Display Resolution. A rectangular border shows the region that will be
rendered.

4 In the Film Back section of the Attribute Editor, enter 1.1 for Overscan. By
increasing the Overscan value, the view displays more of the scene that will
not be rendered. In other words, the view displays more of the region
outside the rectangular border.

By displaying a small part of the scene that lies outside the rendered part,
you can plan future camera movement more easily, especially if the scene
has objects that move in and out of view.

Note that the rendered image is the same regardless of the Overscan value.

With the border visible, you can rotate and dolly the perspective camera for
a closer view of the ring without unintentionally omitting any of the plane:

Border of region to
be rendered from
scene view
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5 Select Render > IPR Render Current Frame. This renders the scene from the
perspective camera view. The rendered image is displayed in its own
window.

The Render View differs from the scene view (persp) in a few ways, even
though both use the same camera:

• The colors and textures are sharper in the Render View.

• The background of the scene view is gray by default. The background of the
Render View is black.

• Only modeled surfaces are displayed in the Render View. Items that are not
surfaces, for example, the grid, NURBS curves, and object manipulators, are
displayed in the scene view but not in the Render View. Note that Maya
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ignores your scene view display settings when you render the scene.
Rendering uses different option settings, and the resulting display quality is
superior though slower for Maya to process.

6 The Render View does not display the border of the region that is actually
rendered. To see the border in the Render View, drag a corner of the Render
View to increase the window’s size slightly, then select View > Show Region
Marquee (from the Render View menu).

In the Render View, the green border shows the resolution of the rendered
image. By default, the resolution is 320 by 240 pixels. The advantage of this
relatively small resolution is that it renders quickly. A drawback about the
resolution is that it is often not large enough for you to distinguish items in
the scene adequately.

7 To use a larger resolution, select Options > Render Globals. In the Resolution
section of the Render Globals window, select 640x480 from the Presets pull-
down menu. Drag a corner of the Render View to roughly double the
window size. Select IPR > Redo Previous Render.

With the Render View displaying an IPR-rendered view of the scene, you
can see immediate updates to the view when you alter the shader, texture, or
other visual characteristics such as lighting.

8 Drag a selection box around a small area surrounding the ring and plane as
follows:

Border of region to
be rendered
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This region will be updated as you alter the shader and texture
subsequently. You can instead drag a box around the entire plane, but
selecting a smaller region quickens the update process.

9 In the scene view, right-click the ring and select Materials > Material
Attributes to display the Attribute Editor for the Blinn shader you applied to
the ring.

10 Click the Color box and change the color to red. Maya updates the boxed
region immediately as you alter the color—the ring turns red.

Notice that when you drag the mouse in the color wheel of the Color
Chooser, the updates occur repeatedly as you drag.

IPR updates the specified region of the image as you modify any number
attributes that affect the shading of the objects visible within the region. You
won’t alter any other attributes in this lesson. The purpose of the lesson is to
learn the process of rendering rather than perfecting the results.
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So far, you’ve used IPR to see changes you made to a shader. Be aware that
if you had added lights to the scene rather than use default lighting, you
would have used IPR to adjust the lighting also.

Use the standard renderer to check important frames
You are nearly ready to render the entire animation to disk. Rendering the
entire animation takes lots of time, so it is useful to first use Maya’s standard
renderer to render a few frames to your monitor and examine the results. As
mentioned before, the standard render creates different (better) results than
IPR. After you are satisfied with the quality of a few rendered frames, you
can render the entire animation to disk.

1 In the Render View window, select Options > Render Globals.

2 In the Anti-aliasing Quality section of the Render Globals window, select
Production Quality from the Presets menu. When you subsequently render,
this setting smooths any jagged surface edges. You can make anti-aliasing
enhancements only with the standard renderer.

3 In the Render View window, select Render > Render > Current (persp). This
menu item uses the standard renderer to render the same animation frame
that you rendered with IPR previously.

Because the camera view is not close to the ring, you might not see a big
improvement in quality as compared to the IPR-rendered image. If you were
to dolly the camera closer to the ring and render once with IPR and once
with the standard rendering, you would see an improvement at the edges of
the ring as follows:

Notes

If you are using Maya on Windows, rendering the scene displays an
Output Window, typically behind other windows on your desktop. The
Output Window lists statistics about the image just rendered. You can
ignore and close the window. It contains information that you will
appreciate more as you gain experience using Maya.
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4 Go to frame 16 of the animation, where the ring is rotated in a different
position.

5 In the Render View window, select Render > Render > Current (persp).

The rendered image looks good at this frame also. Now that you’ve checked
a pair of rendered frames that satisfactorily represent the entire animation,
you are ready to render the entire animation sequence. Be aware that in your
own projects, you might want to test render many more frames, particularly
where new shading and lighting elements occur in the animation.

IPR rendering
(Anti-aliasing

Standard rendering
with production quality
anti-aliasing not available)
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Batch render the frame sequence to disk
After you model, animate, and color your scene, you set several Render
Global options and then use the standard renderer to batch render part or all
of the scene’s frame range to files on disk. The files are a permanent
recording of each frame of the animation.

1 In the Render View window, select Options > Render Globals to display the
Render Globals window. Set these options:

File Name
Prefix Enter the name SpinRing. This name will be the base of

the filenames created by batch rendering.

Frame/
Animation Ext Select name.#.ext. This specifies that the filenames will

have the format prefix.frameNumber.fileFormat. For
example, batch rendering the entire 48-frame animation
will create SpinRing.0001.iff, SpinRing.0002.iff, and so on
through SpinRing.0048.iff.

Start Frame Enter 1, the first frame of the animation sequence to be
batch rendered.

End Frame Enter 48, the last frame to be batch rendered.

Frame Padding Enter 4. This causes the frameNumber part of the filenames
to be four digits prefixed with 0s. For example, the
filenames will be SpinRing.0001.iff through
SpinRing.0048.iff instead of SpinRing.1.iff through
SpinRing.48.iff.

The four-digit padded filename is compatible with many
image playback programs, for instance, Maya’s fcheck
utility. Image playback programs let you view rendered
animation sequences on your monitor at actual production
speed.

For the remaining options in the Attribute Editor, you’ll use the default
settings. By default, Maya will render using the camera (persp), resolution
(640x480), and anti-aliasing quality (Production Quality) that you specified
earlier in the lesson.
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After you set the Render Global options, the top of the Render Globals
window shows the correct path and filenames for the files to be created
during batch rendering. Check that this information is correct.

2 It’s a good practice to save the scene before batch rendering. This is useful if,
after batch rendering, you need to change any display settings and batch
render again. By saving the scene right before batch rendering, you can
examine the scene to learn which option settings were in effect at the time
you batch rendered. For this lesson, saving the scene is optional.

3 From Maya’s main menus, select Render > Batch Render > ❒ . Turn on Use
all Available Processors, then click Batch Render to start batch rendering.

Batch rendering 48 frames of a scene of this simplicity takes a few minutes.
A complex scene may take hours per frame, depending on the speed of your
computer.

4 While Maya is rendering, select Window > General Editors > Script Editor.
Expand the size of the Script Editor window. The window shows a
completion log for the frames being rendered.

Maya puts the resulting files in a default images directory. The files have the
following names:

SpinRing.0001.iff
SpinRing.0002.iff
SpinRing.0003.iff
...
...
...
SpinRing.0048.iff

The images directory is located in the same path as the scenes directory. You
can have Maya save to a different path by changing the project setting. See
“About projects” on page 41.

The image format, extension .iff, is Maya’s standard format. You can use the
.iff format for any further work you need to do, including previewing and
compositing the animation. If you require a more widely accepted format,
you can specify it instead of .iff in the Render Globals.

5 Close the Script Editor when the following message appears:

// Result: Rendering Completed. See mayaRenderLog.txt for 
information. //
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The mayaRenderLog.txt file contains rendering statistics for advanced users.

Play the rendered frame sequence
Next you’ll use Maya’s fcheck rendering utility to examine the batch-
rendered images at a speed that approximates video or film. The steps differ
depending on which operating system you use:

UNIX

1 In the directory that contains the rendered images, enter the following
command:

fcheck -n 1 48 1 SpinRing.#.iff 

The rendered animation sequence plays in a loop.

2 Close the window after viewing the animation.

Windows

1 In the directory that contains the rendered images, double-click the filename
SpinRing.0001.iff. This displays the image SpinRing.0001.iff in an FCheck
window.

2 From the FCheck window, select File > Open Animation.

3 In the file browser that appears, open SpinRing.0001.iff to play the rendered
animation sequence in a loop.

4 Close the window after viewing the animation.

Beyond the lesson
In general, a rendered image is the result of these combined elements:

Note

The fcheck rendering utility has playback, display, and other options you
can select from your keyboard. On a Windows computer, details are
available from the Help menus of the FCheck window. On an UNIX
computer, enter fcheck -help at a Shell prompt.
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As you render scenes, consider the following issues:

Using IPR
Be aware that there are a few limitations to using IPR for fast visual feedback
as you adjust shading and lighting. Besides being unable to provide
production-quality anti-aliasing, IPR cannot display several other advanced
display characteristics, for instance, surface reflections (raytracing) and 3D
motion blur. If an advanced display characteristic seems mysteriously
missing from an IPR-rendered frame, try rendering the frame with the
standard renderer.

If you change the camera view, turn Depth Map Shadows on or off, or
reposition shadows, IPR does not update the rendered image. You must
refresh the image again. From the Render View window, select IPR >
Refresh IPR Image.

Batch rendering
In the lesson, you used Maya’s standard renderer to check the image quality
at two frames before starting batch rendering. When you create scenes with
sophisticated animation, it’s useful to batch render with low-quality
resolution to check the animation accuracy before batch rendering with
production-quality resolution. For instance, you might preview your
animation with the frames resulting from batch rendering at a small image
size (320 by 240) with Preview Quality anti-aliasing.

You don’t need to use the batch renderer to render single frames from your
scene to disk. From the Render View window, select File > Save Image.

Avoiding slow interaction in the scene view
If your scene contains a complex object or lots of objects, display the scene
view in Wireframe mode (rather than Smooth Shade All mode). Also turn off
Shading > Hardware Texturing. These option settings make your interaction
with Maya much quicker in the scene view. To check the shading of the
objects, render the desired frame with IPR or the standard renderer.

Modeled
Geometry

Camera
View

LightsMaterials &
Other Surface
Characteristics

Rendering
Method
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Hardware rendering
You can use another type of rendering method, hardware rendering, by
selecting Window > Rendering Editors > Hardware Render Buffer.
Hardware rendering uses your computer’s graphics hardware to render a
scene to disk or monitor much faster than software rendering.

Hardware rendering is essential for certain particle effects that you cannot
render with software rendering. However, hardware rendering cannot
display some visual effects, for instance, ray-traced shadows. Hardware
rendering displays surface shading and textures less sharply than software
rendering, so most individuals use it only to render particle effects. Some
individuals intentionally use hardware rendering for its less precise shading
and textures, though this usage is uncommon.

Because hardware rendering is fast, consider using it to create an animation
sequence on disk prior to software rendering the same sequence. You can
play the sequence, for instance, with fcheck, to check the quality of motion in
your animation.

Rendering in layers
It’s often useful to render objects in your scene in different layers and
combine them using compositing software. Rendering in layers can be faster
than rendering an entire scene, and it enables you to replace individual
objects quickly if the need arises. To set up layers, use the Layer Editor,
which appears below the Channel Box by default.

LESSON 2 SHADING SURFACES

You shade surfaces to simulate the way they look in the real world or in
your imagination. Shading involves color, surface relief, shininess, and many
other attributes to create a certain look. In this lesson, you’ll use basic
shading features to turn a sphere into an orange.

Open and examine a scene
In this lesson, you’ll work with a scene we created for your use.

1 Open the scene named ShadeOrange from the location specified in the
following table:
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This scene contains a sphere modeled to resemble an orange.

The scene’s perspective view also has two settings turned on—Shading >
Smooth Shade All and Shading > Hardware Texturing—which let you see
the shading changes you are about to make.

Assign a shader material and set basic attributes
In the next steps, you’ll create a material and assign it to the surface. A
material is a collection of attributes that define color, shininess, and other
surface characteristics.

1 Before you create a new material, right-click the sphere and select
Materials > Material Attributes. The default material attributes appear in the
Attribute Editor.

Maya Package File Location

Maya Complete or
Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD
and find:

InstantMaya/Rendering/ShadeOrange.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 
4.5 Personal Learning Edition

and then to:

\tutorialData\Rendering\ShadeOrange.mp
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The default material assigned to the sphere (and all other surfaces) is a type
of material called Lambert. The material displays the surface with gray
shading. It is not intended for editing.

2 Right-click the sphere and select Materials > Assign New Material > Blinn to
create a new material for the sphere. The new material’s attributes appear in
the Attribute Editor.

A Blinn material gives a surface a shinier look than a Lambert material. Blinn
is a good choice for creating a variety of surface appearances. Knowing
which material type to use for a particular surface comes with practice.
Fortunately, you can change the material type later on, so you do not need to
make a decision now. You will learn more about material types later in the
lesson.

3 In the Attribute Editor, click the gray box to the right of Color to open the
Color Chooser.

4 In the Color Chooser, click inside the color wheel (hexagon) and drag the
pointer to an orange-colored area, as illustrated. The sphere becomes the
same color you select in the Color Chooser. Also drag up the slider to the left
of the hexagon to get a brighter shade.

5 Click Accept to close the Color Chooser.

If you compare the color in the Color attribute box with the sphere’s color in
the scene view, you’ll notice some difference.
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The color you assigned is only one aspect of surface appearance. The
appearance also depends on how the surface reacts with light. The main
attributes that control the reaction to light are under the Common Material
Attributes heading. As an example of these attributes, you will change the
Diffuse setting.

6 In the Attribute Editor, drag the Diffuse slider to its right to increase the
color brightness as viewed in the scene view. This will help create the
illusion of a bright orange.

In practical usage, the Diffuse setting makes a surface appear brighter. The
name diffuse comes from a property in physics that describes how light
spreads after it strikes a surface. A surface with a high diffuse property
spreads the light that strikes it, making the object appear brighter.

Like the Diffuse attribute, the other Common Material Attributes also refer
to general characteristics of light and the way a surface reacts to light.

The next section in the Attribute Editor, Specular Shading, contains
attributes that control the appearance of shiny highlights on the surface.

Change specular highlights
Next, you’ll alter the surface specularity—the amount of light that reflects off
a surface, resulting in shiny highlights.

1 In the Specular Shading section of the Attribute Editor, move the Eccentricity
slider back and forth to change the size of the shiny highlights.

2 Move the Specular Roll Off slider to change the blend between highlighted
and other areas of the surface.

Diffuse = .8 Diffuse = .95
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Changes to this attribute do not alter the surface in the scene view, so you
need to check the Material Sample in the Attribute Editor (see the following
illustration). You can also render a test image (Render > IPR Render Current
Frame).

As you work with shading, you’ll find many attributes that have no effect in
the scene view, for instance, Ambient Color and Translucence. Generally, the
scene view is a rough approximation of how the scene will render.

The IPR renderer is ideal for testing shading. It shows the results of all
changes you make to shading and shows them immediately. There is only
one attribute change the IPR renderer does not show—reflectivity. See the
next step for details.

3 Move the Reflectivity slider to see what happens.

Neither the Material Sample nor the scene view are affected. Changes to
Reflectivity and Reflected Color will show only when you have set up the
scene to have reflections. Also, reflections do not appear in the IPR renderer;
you must use the standard renderer instead (Render > Render Current
Frame).

Change to a different material
From the settings you’ve made so far, you may decide you want to give the
orange a different look than possible with the Blinn material. You will now
change to a different material for comparison.

1 Next to the Type attribute near the top of the Attribute Editor, pull down the
menu and select Phong E.

Phong and Phong E are variations of the Lambert material type, with
specular highlights added. The main difference between materials is the way
each handles specularity. By switching between the material types, you can
compare which material gives you the specularity you need.

Attribute Editor IPR in Render View
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Your settings for the Color and Diffuse attributes are maintained because
they are common to all material types. The Specular Shading and all other
attribute settings do not convert when you change the material, so it’s best to
choose your material before you make many changes.

2 In the Specular Shading section, you can leave Roughness and Highlight
Size at the default settings. The default highlight settings give the orange a
waxy look.

These attributes are similar to the Blinn attributes,
Eccentricity and Specular Roll Off. Unlike the Blinn
counterparts, these highlights do not appear in the
scene view. You can see the highlights only in a
rendered image and in the Material Sample.

3 The Phong E material type has a Whiteness attribute
not available with Blinn. Change Whiteness to a light
gray to accentuate the highlights.

This change is subtle, so drag the slider back and forth while watching the
effect in the Material Sample or in an IPR region. Look for the entire
highlighted area to become whiter. Again, a strong highlight will create a
waxy look.

Assign a texture image
For an orange, one color may be all that you need. In this section, you will go
a step further by making a logo stamp appear on the orange skin. For this
and other color effects, you need to apply a texture to your material.

In visual arts, a texture is any kind of surface detail, both visual and tactile.
In Maya, a texture is a collection of attributes that creates surface detail.
Textures have a more specialized display purpose than materials. For
example, you can use textures to create the appearance of a marbled pattern,
bumps, or a logo image on the side of a can.

In the documentation, a texture is also called a texture node. A node is a
collection of attributes (or actions) with a common purpose. A shader is
sometimes called a shader node or material node.

To display a texture on a surface, you apply a texture node to an attribute of
the surface material. In the next steps, you will apply a texture to the Color
attribute of the Phong E material.

Rendered image
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1 Click the checker icon next to the Color slider. This is a quick way of
applying a texture to an attribute. This is also called mapping a texture.

The Create Render Node window displays a list of
the textures you can apply.The texture names and
their icons help you to decide which texture is
appropriate for the effect you want.

To create the logo stamp effect, you will use the
File texture. A File texture uses an image file that
you or someone else created separately, such as a
drawing from a paint program. For this lesson,
you’ll use an image we created for you.

2 Before you create the texture, make sure Normal
is selected in the options above the texture
swatches.

The Normal option means Maya will stretch the
texture evenly around the surface. The other
settings—Projection and Stencil—are other ways you can apply a texture.
You will learn about these settings at the end of the lesson.

3 In the 2D Textures list, click the File button once. At this point the system
will prompt you with the warning that “The IPR file does not have enough
information to support your most recent change”. Select “Close the IPR file
and stop tuning”. The file1 node appears in the Attribute Editor.

The file texture also causes the sphere to turn white in the scene view and
black in a rendered view. This is a temporary color until you specify the
actual file name of the file texture.

4 Click the folder icon to the right of the Image Name attribute. A browser
window opens with the path set to a default directory called sourceimages.

Maya looks for source images in a default sourceimages directory. However,
Maya can use file texture images anywhere on your workstation or local
network. For example, you could have them on a central disk drive that is
shared among your coworkers.
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5 Navigate to the Rendering directory and open mayakist.iff. (This is the same
directory where you obtained the ShadeOrange scene file.)

6 In the Render View window select IPR > Redo Previous IPR Render.

The file texture with a Mayakist logo now appears on the sphere. The logo is
somewhat jagged, which will simulate the look of an ink stamp on rough
orange skin.

7 In the Attribute Editor, click the place2dTexture1 tab.

The place2dTexture1 tab is a node with attributes that control the texture’s
position on the surface.

Note that if you select another object and the Attribute Editor no longer
displays the file texture attributes, it’s easy to restore the display. Right-click
the sphere, select Materials > Material Attributes, and click the texture map
icon next to the Color attribute.

8 As an example of the place2dTexture1 placement controls, move the Rotate
UV slider slightly to the right, to a value about 5.9. This rotates the Mayakist
logo on the surface.

In this case, the texture placement needs almost no adjustment. For the ease
of this lesson, we created a file texture that conforms to the sphere’s shape
by default. In practice, placing file textures requires more adjustment. For
details, see “Beyond the lesson” on page 212.
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Examine and edit your work in Maya’s Hypershade editor
After you create a texture node, you’ll likely want to return to the associated
material node to make changes. Because material and texture nodes do not
have icons that represent them in your scene view, you need a special editor,
called Hypershade, to select them and edit their attributes. In this section,
you will learn how to work with Hypershade.

1 In the perspective view, select Panels > Saved Layouts > Hypershade/Persp.

This layout is convenient because it’s common practice to drag and drop
items from Hypershade into the perspective view. Note that you can also
open Hypershade as a separate window (Window > Rendering Editors >
Hypershade).

2 At the top of Hypershade, click the Materials tab to make sure the tab is
displayed. If the material swatches are too small to see clearly, dolly into the
view using the same keyboard and mouse shortcuts you would use in the
scene view.

This tab shows all the materials currently in your scene. It is especially
useful when you have a complex scene and you need to locate a material to
edit it. The materials you will recognize are the default Lambert material and
the Phong E material. You can ignore the others. They exist in all scenes, by
default, for use with other Maya features.

In addition to the Materials tab, Hypershade includes other tabs to help you
keep track of textures, lights, and other nodes related to rendering.
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3 With the middle mouse button, drag the lambert1 swatch into the scene view
and over the sphere. When you release the mouse, the Lambert material
appears on the sphere instead of the Phong E material you previously
created.

4 Now drag the phongE1 swatch onto the sphere to reapply that material.
Hypershade is designed for quick, drag-and-drop operations such as this.

5 Select the sphere.

6 From the menus in Hypershade, select Graph > Graph Materials on Selected
Objects. A graph appears in the Work Area tab in the bottom section.

This graph shows all material and texture nodes applied to this object. While
the Materials tab shows a catalog of your materials, the Work Area tab
shows whatever material, texture, or other node you are currently working
on. The Graph menu has several menu items that change the contents of the
Work Area display.
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Note that the Shader Library tab shown in the above illustration might not
be a part of your Maya installation. It is an optional feature, discussed at the
end of this lesson.

7 Notice the Work Area shows connection lines between the nodes. The lines
have arrows that all point in one direction. For a closer look at these arrows,
dolly into the view using the same keyboard and mouse shortcuts you
would use in the scene view.

The arrows depict Maya’s internal information input and output, called a
stream. The next step shows the importance of this connection stream.

8 Click the line between the file1 and phongE1 nodes (it turns yellow) and
press the Delete key.

The sphere reverts to the default gray color because you have broken the
connection between these nodes and the texture is no longer assigned to it.
This is a simple illustration of how the connection stream works. The file1
texture node is upstream from the connection you deleted, so it no longer
inputs data into the material; Maya ignores it.

In practical terms, this is an example of how you can disconnect a texture
from a material without actually deleting the texture. For example, you may
want to remove the file texture from this material and connect it to another
material instead. In a later step, you will learn about using Hypershade to
make connections between textures and materials.

9 Select Edit > Undo to restore the file texture connection you deleted.

10 In Hypershade, right-click the center of the phongE1 swatch and select
Rename. Type Orange.

Renaming is not as important in this scene as it would be in more complex
scenes with several materials.

The Rename operation is one of several useful menu items that appear when
you right-click a material swatch. Another handy menu item is Assign
Material to Selection. You can use this operation to assign a material to
multiple selected objects rather than assign it one object at a time.
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Create a bump map texture within Hypershade
To mimic the skin of an orange, you will add a bump map texture. A bump
map creates the illusion that the surface has bumps or other types of surface
relief. You will map the texture using the Create Bar in Hypershade.

The Create Bar is similar to the Create Render Node
window you have used already. It is built into
Hypershade for greater convenience.

Notice Create Textures appears at the top, by default.
Next to the heading is an arrow icon. If you were to
click this icon, you would switch to the Create
Materials mode or another mode. In this case, leave
the Create Texture selection turned on.

1 In the Create bar, scroll down to the 3D Textures
heading.

The Mayakist logo file texture is a 2D texture—now you will create a 3D
texture. With a 2D texture, Maya wraps the texture evenly around the
surface. A 3D texture is for making objects appear to have been carved out of
a solid substance, such as marble or wood.

For this bump effect, you’ll use a Brownian 3D texture. Experience has
shown that a Brownian texture is the best texture for approximating the
bumps on an orange skin. Becoming skillful with textures is a matter of
experimentation and experience.

2 With the middle mouse button, drag the Brownian texture (under 3D
Textures) onto the Orange material swatch in the Work Area tab and release
the mouse button.

3 From the menu that appears, choose bump map. Maya applies Brownian to
the Orange material’s bump map attribute.
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The pop-up menu shows a list of common material attributes. Although you
can map textures to any material attribute, these are the most commonly
mapped attributes.

The color attribute is in italics because you have already assigned a texture
to it. By default, you can assign only one texture per attribute. (For a
discussion about assigning multiple textures to an attribute, see “Layered
textures” on page 213.)

This drag-and-drop method of applying a texture is essentially the same as
clicking the map icon next to a material’s attribute. Using Hypershade offers
a faster, more graphical alternative to using the Attribute Editor.

4 Select Graph > Show Upstream and Downstream to view the node
connections for the new texture you created.

Also notice that bumps from the bump map appear in the Orange swatch.
The Orange material swatch is the same as the Material Sample that appears
in the Attribute Editor for the material node. (The bumps also appear in a
rendered image, but not in the scene view.)
INSTANT MAYA

208



RENDERING | 7
Shading surfaces
5 Double-click the bump3d1 swatch (the checkered cube) to display its
attributes in the Attribute Editor.

This node is the link between the texture and the material. It converts visual
information, such as the mottled Brownian pattern, into the appearance of
surface relief.

The most important attribute in the bump3d1 node is Bump Depth, which
controls the intensity of the bumps.

6 Change Bump Depth to 0.150. In the Orange swatch or a rendered image,
you’ll see that this diminishes the bumps as compared to the default value
1.0.

7 Click the brownian1 texture swatch to reveal its attributes. Set the following:

Increment: 0.3
Octaves: 4.0

These values produce a rendered image closer to real orange skin. Our
recommendation for these values is based on experimentation. For Brownian
and some other textures, it’s usually faster to get desirable results by
experimenting with the settings rather than trying to understand the
meaning of each attribute.

Note

If you select Render > IPR Render Current Frame while Hypershade is
selected, a message appears: Please select the view you want to render. Either
select the perspective view before choosing IPR Render Current Frame, or,
in the Render View window, select IPR > Redo Previous IPR Renderer.
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Change the bump texture pattern by transforming it
The bump texture is too crater-like to be a convincing orange. The bumps are
too numerous and too deep. A quick way to fix this problem is to scale up
the entire texture.

1 Click the place3dTexture1 swatch, to the left of the Brownian swatch. This
node controls the 3D texture’s position, scale, and rotation. The visual
display of this node is a large cube that surrounds the sphere in the scene
view. This is the texture placement cube.

2 Click the Interactive Placement button in the Attribute Editor. A manipulator
appears for the texture placement cube.

3 In the scene view, click on the center scale box to activate the center scale
option. Scale the whole texture placement cube to about twice the original
size (until the Scale attribute values are about 2).
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Now when you render, the bumps on the surface appear wider and
smoother, like the bumps on an orange skin. For example, the bumps in the
area surrounding the highlight do not appear to be as deep as they were
before you scaled the texture.

Scaling a texture placement cube is a common way to tune the texture’s
display. Scaling does not actually change the pattern, but enlarges or shrinks
it relative to the surface.

4 Now that you’ve changed the surface texture through scaling, move the
texture placement cube above the sphere (drag the green arrow up), to see
how that affects the texture.

Before scaling After scaling
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In the rendered image, notice that the bumps still remain on the sphere.
Objects do not need to be within the texture placement cube, because it
merely represents an imaginary texture volume, which is infinite.

However, movement of the texture placement cube does shift the surface
texture pattern. The difference is hard to notice on a uniform texture like
Brownian. Transforming the cube would be more noticeable with a texture
such as Marble, where the veins within the pattern would be repositioned.

Movement of the object itself also shifts the surface texture. For example, if
you were to animate the orange rolling and then render an image sequence,
the texture would shift each frame rather than roll with the surface. To
prevent this undesirable effect, you need to parent the texture placement
cube (also called the place3dTexture node) to the object. For more
information on parenting, refer to the online manual Using Maya: Essentials.

Beyond the lesson
This lesson covered a few of the many features available for shading
surfaces. Important features not covered in this lesson follow:
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Placement of textures

When you put the Mayakist logo on the surface, the
letters appeared straight. If you were to look at the
file texture image itself, you would see the letters
are actually skewed. We skewed the logo for your
use in this lesson so that it looks straight when
stretched onto the surface.

In your own work, skewing the texture image
would be too difficult and impractical. A more
practical Maya technique for assigning and positioning file textures is to use
texture projection. With this feature, you project the texture onto the surface
as if you are projecting cinematic film onto screen. The texture is positioned
where the projection strikes the surface. Instead of a skewed Mayakist logo,
you can use a straight logo and project it onto the sphere. You can tune the
angle of projection so that the curvature of the surface skews the logo
similarly to the lesson. To assign textures as projections, you turn on the As
Projection option at the top of the Create Render Node.

The placement of texture projections is similar to the placement you
performed for the bump map (3D) texture. Like the bump map texture, you
need to parent the texture projection (the place3dTexture node) to the object
in order to avoid the texture placement changing when the object moves.

Layered textures
Suppose you want to add a scarred pattern to the clean orange skin. The
problem is you can only have one texture assigned to the Color attribute. In
this situation, you can use a Layered Texture to combine two or more
textures together.

A Layered Texture is a texture node that you assign to a material’s attribute
just like other textures. Within the Layered Texture, you can connect other
textures and control how they blend together. For example, the bottom layer
could be the logo image you used in the lesson, and a top layer could be an
image of streaking lines that resemble scars. The combined logo and scars
would give the orange an aged look.
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Shader Library
As an option, you can install a Shader Library with Maya to help you
quickly create common materials, such as bricks, fabrics, foods, and many
other surface types. If installed, a Shader Library tab appears in Hypershade.
To use a material, find the type of shading you want, drag and drop it into
Hypershade, then drag and drop it onto a surface in your scene. The Shader
Library is not available to users of Maya Personal Learning Edition.

LESSON 3 LIGHTS, SHADOWS, AND CAMERAS

Directors of live-action film use camera and lighting techniques to enhance
the dramatic impact of a scene. As a 3D artist, lighting and camera
techniques are perhaps even more crucial because you are working with
artificial characters and objects.

A prerequisite to creating effective 3D animation is to study the lighting and
camera effects used in live-action film. Your goal is to create the desired
scene ambience while keeping the lights and camera view as unobtrusive as
possible. In the following lesson, you’ll learn basic techniques for working
with lights, shadows, and cameras.

Create a directional light
In this lesson, you’ll work with a scene we created for your use. In the first
steps, you will open the scene and create a directional light. You will
compare the directional light’s effect to the scene’s default lighting.

1 Open the scene named Lights from the location specified in the following
table:

Maya Package File Location

Maya Complete or
Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD
and find:

InstantMaya/Rendering/Lights.mb

(You can also copy these files to your hard drive.)
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The scene contains a room with two walls and a floor. Sitting in the room is
a drafting table and lamp, both grouped under the name tableGroup. All
object surfaces have default gray shading.

When you open the scene, Maya lights the scene with default lighting
provided by an imaginary light fixture. It emanates light infinitely from a
point above and behind the active scene view camera. There is no icon that
represents the light in the scene view. Maya has many types of lights that
simulate natural and artificial lighting. In the next steps, you’ll create your
own light for the scene.

2 Select Create > Lights > Directional Light. This creates a light at the center of
the grid.

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 
4.5 Personal Learning Edition

and then to:

\tutorialData\MayaPLE\Rendering\Lights.mp

Maya Package File Location
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A directional light is similar to the sun. Its parallel rays strike all objects in
the scene from a single direction as indicated by the arrow icon representing
the light.

When you create a light, the scene view does not display its effect, by
default. The scene view instead uses default lighting.

3 Select Lighting > Use All Lights (Hotkey: 7). This lights up the scene view
only with lights you’ve created, not with default lighting. (If you later want
to see the scene view with default lighting again, select Lighting > Use
Default Lighting.)

Note that when you render the scene to your monitor or disk, by default,
Maya uses all lights you’ve created. If there are no lights, Maya creates a
temporary default directional light for you and then deletes it when the
render is complete.

Edit the directional light
Next, you’ll manipulate the direction of the directional light and edit the
light’s most important attributes.

1 With the directional light selected, rotate the light in various directions.
Notice how the shading of surfaces changes as you rotate the light. The more
directly the light points at a surface, the brighter the shading. A directional
light is affected by its rotation, not its position. As you’ll see later, the
position of other lights affects the lighting.

2 Rotate the light as follows:

Rotate X: -40
Rotate Y: 25
Rotate Z: -20

With this orientation, all object surfaces in the scene show the effect of the
light in the current camera view.

3 With the light still selected, open the Attribute Editor (under the Window
menu). Drag the Intensity slider to various values to see the effects of
intensity. Higher values brighten the surfaces. For example, an Intensity of
1.6 brightens the lighting so much that the gray default shading of some
surfaces are bleached to white.
INSTANT MAYA

216



RENDERING | 7
Lights, shadows, and cameras
Rendering creates this result:

4 In the Attribute Editor, click the white Color box above the Intensity box.
This displays the Color Chooser.

5 Click inside the color wheel (hexagon) and drag the pointer to a red color.
The lighting imparts a red hue to the surfaces in the scene.

6 Change the color back to white and set the Intensity to 1.2 or so. You’ll use
these settings for the basic lighting of the scene.

Create a spotlight
Maya offers several types of lights to simulate natural and artificial lighting.
In the next steps, you’ll light up part of the desk by creating a spotlight.

1 Select Create > Lights > Spotlight. This creates the spotlight’s icon at the
center of the grid. The light points toward the back wall.

2 Move the spotlight above the lamp. (Drag the light up along its local Y-axis.)

Notes

Several of the following illustrations in this lesson are snapshots of the
scene after rendering. To render the scene, select Render > Render current
frame. To avoid confusion in the rest of this lesson, do not use IPR
rendering because it does not automatically update the image for some
changes you will make to the scene.
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If you look at the spotlight icon from several angles, you’ll notice that it is
shaped like a cone with an arrow pointing out of it. The cone symbolizes the
fact that a spotlight emits a beam of light that gradually widens with
distance.

3 Select Modify > Transformation Tools > Show Manipulator Tool. With the
spotlight selected, this tool provides two manipulators that you can move to
position the light precisely.

The look-at point specifies where the light focuses. The eye point defines the
position of the light source. All types of lights have an eye point, but not
necessarily a look-at point.

4 Move the look-at point to the top of the table, and move the eye point
roughly to the center of the lamp housing.

Eye point

Look-at point
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You can also use the Rotate tool to center the eye-point more accurately in
the lamp housing.

An alternative way to position a spotlight is to select the light and then select
Panels > Look Through Selected. You can then dolly and pan the view to
focus on the desired surface. The area of focus is where the light strikes the
surface. To return to the perspective view select Panels > Perspective >
persp.

5 If you render the scene, you’ll notice that the spotlight lights up a circular
region on both the desk and the floor.

By default, light passes through and lights up each surface in its path. The
circular region of light is wider on the floor than the desk because a spotlight
emits a beam of light that widens with distance.

Only the floor, not the desk, will be lit by the spotlight in the scene view.
You’ll see the desk lit up only if you render the scene.
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6 You can prevent the light from passing through the table. With the light
selected, display the Attribute Editor. Open its Shadows section and then the
Depth Map Shadow Attributes section, then turn on Use Depth Map
Shadows. Rendering creates this result:

By turning on Use Depth Map Shadows, the spotlight’s lighting is blocked
by the first surface it hits (the desk). The floor is in the shadow of the desk so
it receives no light. You’ll learn more about Depth Map Shadows later in the
lesson.

Note that if you were to render the scene with IPR rather than the standard
renderer, the image would not automatically remove the lighting of the
spotlighting from the floor when you turn on Use Depth Map Shadows. You
would need to refresh the image again in the Render View window by
selecting IPR > Refresh IPR Image.)

Tune the spotlight’s effect
Spot lights, directional lights, and other types of lights have Intensity and
Color attributes. Each type of light has several unique attributes. In the next
steps, you’ll set several attributes of a spotlight.

1 The spotlight’s default Cone Angle is 40 degrees. In the Attribute Editor, set
Cone Angle to 20. The circle of light narrows. Then set Cone Angle to 60. The
circle of light widens. Rendering creates this result:
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2 Set Dropoff to 10. This attribute sets how much the light intensity diminishes
from the center of the circular region out to the edge. Finding the right value
is a matter of experimentation. When you increase the Dropoff, the light’s
intensity diminishes, so you need to increase the Intensity. For example,
increase the Intensity to 1.6. Rendering creates this result:

In some situations, you might want to select a Decay Rate to diminish the
light’s intensity as the light gets further from its source. The Linear setting
diminishes light with the least abruptness, Quadratic with the most
abruptness. Cubic is between the two other settings.

The default setting is No Decay, which means the light remains at full
intensity regardless of distance. If you use a setting other than No Decay,
you likely will need to increase the Intensity. For this lesson, leave the Decay
Rate set to No Decay.

Cone Angle = 20 Cone Angle = 60

Dropoff = 10
Intensity = 1

Dropoff = 10
Intensity = 1.6
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3 Set the Penumbra Angle to 10. This attribute causes a region at the edge of
the light to fade. Again, finding the right value is a matter of
experimentation. You can also use negative numbers to fade inward from
the circle’s edge. Be aware that the viewing angle of the camera influences
the appearance of the fading at the edge. Rendering creates this result:

4 In the Light Effects section of the Attribute Editor, click the map button to
the right of the Light Fog box.

This gives the appearance of the light beams illuminating dust in the air.
Rendering creates this result:

Be aware the fog is more noticeable when you view (render) the light beam
from a side angle rather than from above the light fixture

When you clicked the Light Fog map button, Maya creates a light fog node
and displays its attributes in the Attribute Editor. The Color and Density are
useful for altering the fog’s hue and transparency. These attributes affect
only the light on its way to the surface, not the light on the surface.

Penumbra Angle = 10 Penumbra Angle = -10
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In the scene view, you’ll also notice a Light Fog icon extending from the
spotlight icon. When highlighted, it looks like this:

The icon displays the region of the potential illumination. You won’t see
light fog under the table. The table blocks the light fog because you
previously turned on spotlight’s Depth Map Shadows attribute. You can use
the Scale tool on the icon to expand or contract the region of illumination.

Create shadows
Next, you’ll create a shadow on the floor from the light cast by the spotlight.
To do this, you must edit a few of the spotlight’s attributes.

1 Select the spotlight and click the spotLightShape1 tab in the Attribute Editor.

2 Set the Cone Angle to 105. When you render the scene, you’ll see the
spotlight has widened its beam to light up a small part of the back wall. The
table and light fixture block light and create shadows.

The shadows occur because you turned on Use Depth Map Shadows for the
spotlight earlier in the lesson.

Light Fog icon
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Depth Map Shadows refers to the algorithm Maya uses to produce shadows.
For basic shadowing, you don’t need to know about the algorithm, but you
do need to make sure you turn on Use Depth Map Shadows.

3 To sharpen the shadow’s edges, open the Attribute Editor’s Shadows section
and then the Depth Map Shadow Attributes section. Set the Dmap
Resolution to 1024. Rendering creates this result:

Increasing the Dmap Resolution increases rendering time. Use a higher
value only if it makes a noticeable difference on the shadows. In this case,
the difference is so subtle that you might prefer to use the default value 512.
In your future projects, keep in mind that higher Dmap Resolution values
can make a big difference in the quality.

A related attribute, Dmap Filter Size, is useful for blurring and anti-aliasing
shadow edges that seem too sharp. Increase the value to increase the blur.
Again, higher values increase rendering time.

Shadow on wall

Sharpen shadow edges with
Dmap Resolution = 1024
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If you are intent on perfecting shadows in your future projects, try various
combinations of values for Dmap Resolution and Dmap Filter Size. For this
lesson, the default values are satisfactory because the shadow edge has
minimal contrast. If you create shadows with sharp contrast at the edges,
altering the default values will be more desirable.

Create a camera and frame the view of the table
Elsewhere in this book, you’ve used the default perspective camera to
examine and render your modeling and animation work in progress. In
some situations, it is convenient to create and use an additional camera.

For example, you might want to render the scene from two different camera
views to compare the results. Alternatively, you might want to use the
default camera for interactive modeling and animation and the new camera
strictly for rendering the scene. In the next steps, you’ll create a camera and
manipulate its view of the scene.

1 Select Create > Cameras > Camera. This creates a perspective camera with an
icon representing it at the center of the grid.

2 In the Channel Box, change the name of the camera to myCamera.

Even though you’ve created a new camera, you are still looking at the scene
through the default perspective camera named persp. You will view the
scene through myCamera after you position it in the next step. If you were to
view the scene through myCamera now, you would see a disorienting view
of the back wall and floor. The camera’s icon points in the direction of the
camera’s view.

Be aware that the scene’s default persp camera has no icon. An icon is
displayed only for a camera you create.

3 Use the Show Manipulator Tool to position myCamera roughly in this
position:
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With a camera selected, the Show Manipulator Tool provides the same two
manipulators that you used to position the spotlight: eye point and look-at
point. The look-at point sets where the camera aims. The eye point sets the
position of the camera.

Note that you can select a camera by selecting View > Select Camera.

4 Select Panels > Perspective > myCamera to view the scene from myCamera.

If your camera view is not similar to the above illustration, select tableGroup
in the Outliner and select View > Frame Selection. This centers the view of
myCamera on the table.

Note that you can return to the view of the persp camera by selecting
Panels > Perspective > persp.

5 While working with a camera, it’s useful to know the exact region of the
myCamera view that is displayed in rendered images. To see the border of
the render region, select View > Camera Attribute Editor. In the Attribute
Editor, open the Display Options section and turn on Display Resolution. A
rectangular border shows the region that will be rendered.

6 In the Film Back section of the Attribute Editor, enter 1.2 for Overscan.
INSTANT MAYA

226



RENDERING | 7
Lights, shadows, and cameras
By increasing the Overscan value, the view displays more of the scene that
will not be rendered. In other words, the view displays more of the region
outside the rectangular border.

By displaying a small part of the scene that lies outside the rendered part,
you can plan future camera movement more easily, especially if the scene
has objects that move in and out of view.

Animate the camera movement
You can dolly, track, and tumble the view provided by myCamera with the
same Alt-mouse combinations available for the default persp camera. You
can also set keys for the camera the same as for other objects. In the next
steps, you’ll set keys to do a simple animation of the camera’s movement.

1 Go to the start of the playback range.

2 Dolly, tumble, and track myCamera to create a view similar to this:
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3 With myCamera selected, set a key for the camera’s current view at the first
frame. To set a key, select the Animation menu set, and then select
Animate > Set Key. (For details on setting keys and animation technique, see
“Lesson 1 Keyframing and the Graph Editor” on page 97.)

4 Go to frame 150 or so.

5 Dolly myCamera to create a view similar to this:

6 Set another key.

7 Play the animation to see the camera dolly toward the table for the first 150
frames.

At this point, feel free to experiment with keying changes in the view
resulting from tumbling and tracking the camera. Be aware that excessive
animation of tumbling and tracking creates a dizzying effect that is a
common mistake of inexperienced artists. In general, it’s best to keep camera
animation simple except when you are striving for an unusual effect.

Beyond the lesson

Lights

In addition to the directional light and spotlight you created in the lesson,
Maya has several other types of lights for creating nearly any type of natural
or artificial lighting. You might use as few as two lights or as many as 10 to
get the look you want. Be aware that the more lights you create, the longer
that rendering takes.
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Besides the light fog effect you created in the lesson, you can also create
Glow, Halo, and Lens Flare light effects with a similar workflow. To see
these effects, the light must point toward the camera view.

In some situations, you might want to prevent a light from striking a surface
in its path. For example, your scene shows a person leaning against a wall in
an outdoor night setting. You might want to light the wall with dark,
shadowy spotlights, and the person’s face only with a brighter, soft
spotlight. Because the face and the wall are near each other, all the spotlights
currently strike both objects. You can use Maya’s light-linking capability to
segregate the lighting.

Shadows

Maya has two types of shadows: Depth Map Shadows and Ray Trace
Shadows. In the lesson, you created Depth Map Shadows, which are less
realistic than Ray Trace shadows but much faster to render.

Ray Trace Shadows are mainly useful in scenes where the audience is
focusing on the shadow region, for instance, a close-up of a still setting. Ray
Trace Shadows are also useful if you want to cast shadows more accurately
for transparent objects. To lessen rendering time, use Ray Trace Shadows
only when necessary.

Cameras

If you are an experienced photographer, you’ll recognize the names of
various camera attributes displayed in the Attribute Editor while a camera is
selected. Feel free to modify the attribute values as desired.

If you lack photography experience, it’s best only to track, dolly, and tumble
a camera until you learn more about camera operation. Consider getting a
book on photography.

You can undo and redo view changes such as dolly, track, and tumble by
selecting either the [ or ] brackets respectively. You can click on these a
number of times to undo or return to a particular view orientation.

The values for certain camera attributes, for instance, Film Aspect Ratio,
might cause a rendered image to not match the region bounded by the
Resolution Gate. In such cases, you can display the Film Gate to see the
region that will be rendered.
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Be aware that you can animate a camera along a path, for instance, to create
the illusion of flying through mountainous terrain. This type of animation
involves the use of Animate > Motion Paths > Attach to Motion Path (from
the Animation menu set). If you additionally want the motion path-
animated camera to focus on a stationary or moving object, you need to use
Create > Cameras > Camera and Aim. If you want the camera to move in a
looping path, for instance a roller coaster, you need to use
Create > Cameras > Camera, Aim, and Up.

Before you batch render a scene, you must select the camera you want to use
for rendering. Select Window > Rendering Editors > Render Globals to
display the Render Globals window. In the Image File Output section, select
the camera from the Camera option.
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With Dynamics, you can simulate forces, motions, and events of nature that
are hard to achieve with traditional keyframe animation. For instance, you
can create the illusion of smoke rising, rain falling, or a bowling ball crashing
through pins.

This chapter contains the following lessons:

• “Lesson 1 Particles, Emitters, and Fields” on page 231

• “Lesson 2 Rigid Bodies and Constraints” on page 248

PREPARING FOR THE LESSONS

Do these steps to ensure the lessons in this chapter work as described:

1 Select File > New Scene to create a new scene before you start each lesson.

2 Select Window > Settings/Preferences > Preferences. Click Timeline under
Categories and make sure the Playback Speed is set to Play every frame.
Dynamic animation plays more accurately with this setting.

3 Select the Dynamics menu set. Unless otherwise noted, the directions in this
chapter for making menu selections assume you’ve already selected the
Dynamics menu set.

LESSON 1 PARTICLES, EMITTERS, AND FIELDS

Particles are points that you create and display as dots, streaks, spheres, or
other shapes. You can create particles by clicking positions in the scene view,
or you can create them with an emitter that shoots particles into view.

To animate particles, you typically apply fields such as gravity or wind. By
combining emitters, particles, and fields, you can create natural phenomena
such as smoke, fireworks, or rain.
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In this lesson, you’ll use particles, emitters, and volume fields to create a
fountain-like effect. Then you’ll use a color ramp to add colors to the
particles.

Create an emitter
Emitters create particles as an animation plays. The emitter controls the
position, direction, quantity, and initial velocity of the emitted particles
when they are born. After particles are born, the attributes of the particle
object control their appearance.

You can make an emitter stand alone, or you can make a surface, curve, and
even another particle an emitter. You move an emitter the same way you
move any geometry, such as setting keys or parenting it to a moving object.

In the next steps, you’ll create a circle and emit particles from it.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 231.

2 Set the start frame to 1 and end frame to 120.

3 Select Create > NURBS Primitives > Circle > ❒ . In the options window, set
the following options and click Create:

Radius 4

Number of Sections 25
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With Radius set to 4, the circle will be wide enough to see the particle
emission clearly. With Number of Sections set to 25, the emission will be
distributed evenly from points around the circle.

Note that the illustrations in this chapter show the grid with a custom blue
color and numbered lines so that the shape and size of the objects you create
are easier to distinguish. (If you want to change the grid color in your scene,
select Display > Grid > ❒ .)

4 With the circle selected, select Particles > Emit from Object.

By default, this creates an Omni emitter. If you dolly toward the center of the
grid, you can see a tiny icon that represents the emitter. When you create an
Omni emitter on a NURBS object, for instance, a circle, each control vertex
(CV) of the object emits particles in all directions.

5 Play the animation for a few seconds to see the emission.

Notice the particles that are created. When you create any type of emitter, a
particle object is automatically created and connected to it.

The connected particle object originally has no particles and is therefore
invisible. As the animation plays and the emitter generates particles, the
particle count of the connected particle object increases. When you go to the
start of the animation, the particle count returns to 0.
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Note that if you had created the circle with a smaller Number of Sections,
there would be fewer CVs for the circle and therefore bigger gaps between
the emission points on the circles.

6 Display the Outliner and select particle1.

This is the particle object. A particle object is a collection of particles that
share the same attributes. You can create particle objects containing a single
particle or millions of particles. Each particle in a scene belongs to some
particle object.

The particle object’s attributes define the appearance and other characteristics
of the emitted particles. The emitter’s attributes control the initial position,
direction, quantity, and velocity of the emitted particles.

Create volume axis fields
Fields are forces that you use to animate the motion of particles. With a
Volume Axis field, you can move particles in various directions within the
volume of a cube, sphere, cylinder, cone, or torus. With clever use of this
type of field, you can create effects such as particles flowing around
obstacles, solar flares, explosions, tornadoes, and rocket exhaust.

In the next steps, you’ll use a volume axis field to move the particles up a
conical path. When the particles exit the top of a conical region, you’ll use
another volume axis field to give them a downward arcing motion within a
torus. The result resembles a fountain of light.

Create a cone volume axis field
1 With the particle object still selected, select Fields > Volume Axis > ❒ .

2 Set the following Volume Axis options and click Create.

Magnitude 50

Volume Shape Cone

Away From Axis 0

Along Axis -1
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This creates a conical Volume Axis field that affects the motion of particles
that enter or exist within its volume. Particles move in relation to a central
axis within the volume. For a Cone Volume Shape, the central axis is the
positive Y axis:

Using the axis attributes, you can specify that the particles:

• move in a direction roughly parallel to the axis toward or away from the
point of the cone (Along Axis)

• radiate outward or inward relative to the axis (Away From Axis)

• swirl around the axis (Around Axis)

• move in a direction based on a combination of these directions

By setting Along Axis to -1, the particles move toward the point of the cone.
(A positive value would move particles in the opposite direction.) In the next
step, you’ll flip the cone 180 degrees so the aim of the cone and particles is
upward.

By using 0 for the Away From Axis value rather than the default value of 1,
the particles will not radiate away from the axis.

Note that you can use larger or smaller values for the Axis attributes to
intensify or diminish movement.

Magnitude specifies the strength of the volume axis field. The greater the
value, the more force is exerted on the particles.

Central Axis
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You’ll typically need to experiment with various Volume Axis field attribute
values to achieve a desirable motion for particles. Be aware that small arrow-
shaped icons within the Axis Field icon show which direction the particles
will go.

3 With the Volume Axis field still selected, set the following values in the
Channel Box:

This positions, rotates, and scales the volume axis field so that its base lies on
the same plane as the circle emitter. Even though the circle emits particles in
random directions, the volume axis field will redirect their motion up the
cone.

4 Go to the start of the playback range and play the animation for a few
seconds.

Translate Y 13

Rotate Z 180

Scale X 5

Scale Y 13

Scale Z 5
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When the particles move out of the conical region, they continue in the same
direction, mirroring the pattern of movement within the conical region. The
volume axis field no longer controls the motion, but the particles continue
with the same speed and direction they had at the moment they exit.

Create a torus volume axis field
1 Select the particle object and then Fields > Volume Axis > ❒ .

2 Set the following Volume Axis options and click Create.

The Torus Volume Shape creates a volume shaped like a doughnut.

Magnitude 25

Volume Shape Torus

Section Radius 1.5

Away From Axis -0.7

Along Axis 0.0

Around Axis 2
INSTANT MAYA

237



DYNAMICS | 8
Particles, Emitters, and Fields
Section Radius defines the thickness of the torus.

A value of 2 for Around Axis causes the particles to swirl around the central
axis. For a torus, the central axis is the ring in the center of the solid part of
the torus.

A value of -0.7 for Away From Axis cause the particles to move the radially
toward the central axis.

When you later play the animation, the combination of these values cause
the particles to loop up then down as if guided along the inner walls of a
torus.

Again, achieving the desired motion for particles within a volume axis field
requires experimentation with attribute values. Examine the arrows and
other small icons within the axis volume field to help get the desired results.

Torus Volume shape

Central axis

Section Radius
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Note that the field’s effect is pervasive enough that all particles passing
through the hole of the torus are influenced by the field. You can cause
particles to pass through the hole by altering the Max Distance and
Attenuation.

3 With the torus volume field still selected, enter the following values in the
Channel Box:

This moves the torus volume field up 15 units and scales it larger. Finding
the appropriate position for the volume axis field is a matter of
experimentation.

4 Go to the start of the playback range and play the animation.

When the particles move through the top of
the cone region, they spread outward
somewhat but do not follow the shape of the
torus volume field as specified in the prior
steps. You’ll correct this situation in the next
steps.

Adjust the velocity of the moving particles
The torus volume axis field doesn’t guide the
motion of the particles as expected because the
initial emission velocity of the particles
dominates the motion of the particles rather
than the field. You can use a particle object’s
Conserve attribute to scale down the emission
velocity’s influence and increase the field’s influence.

1 Select the particle object and set the Conserve attribute to 0.8 in the Channel
Box.

Translate Y 15

Scale X 3.6

Scale Y 3.6

Scale Z 3.6
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By changing the Conserve value from the default value, 1, to 0.8, the
emission velocity’s influence on the particle motion decreases and the field’s
influence increases.

2 Go to the start of the playback range and play the animation. Notice how the
particle movement now conforms to the shape of the torus volume field.

Set the render type
The particle render type of a particle object determines how the particles look
when rendered. For example, you can display particles as small spheres,
streaks, or 2D images (known as sprites) of your favorite snapshot. Once you
select the particle render type, you can add attributes specific to the render
type to adjust the appearance.

1 With the particle object still selected, display the Attribute Editor and set the
Particle Render Type to Streak. To display the attribute, scroll down to the
Render Attributes section.

2 Go to the start of the playback range and play the animation.
INSTANT MAYA

240



DYNAMICS | 8
Particles, Emitters, and Fields
The Streak render type displays moving particles with an elongated tail. This
render type enhances the display of objects such as meteors, and it’s often
used to create rain. The streak length is based on the velocity of the particle,
so if the particles are stationary or moving slowly and the render type is set
to streak, you won’t see the particles.

Add dynamic attributes
To maximize the display versatility of particle render types, you need to add
built-in dynamic attributes to the particle object. When you add a dynamic
attribute to an object, the attribute appears in the Attribute Editor for the
selected object.

1 In the particle Attribute Editor, click Add Attributes for Current Render
Type. Notice the attributes that are added.

2 Set the following attributes:

Click here Dynamic attributes
appear here
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You can play around with these settings to change the look of the particles.

Add per particle attributes
Particle objects have two different kinds of attributes: per object and per
particle.

A per object attribute lets you set the attribute value for all particles of the
object collectively with a single value. For instance, the per object color
attribute lets you set a single color for all the particles in the object.

A per particle attribute lets you set the value of the attribute individually for
each particle of the object. For example, the per particle rgbPP attribute lets
you set a unique color for each particle. Though there is only one rgbPP
attribute in a particle object, the attribute holds the value for each particle’s
color value. The attribute holds the values in an array. In simple terms, an
array is a list.

Although per particle attributes are best for creating complex effects, you
can’t keyframe them. You can keyframe per object attributes.

In this lesson, you’ll add a per particle color attribute so you can give
different particles different colors.

1 In the Attribute Editor, expand the Add Dynamic Attributes section, if
necessary.

2 Click the Color button. The Particle Color box is displayed,

3 Turn on the Add Per Particle Attribute and click Add Attribute. Notice the
rgbPP attribute that is added to the Per Particle (Array) Attributes section of
the Attribute Editor.

Line Width 2 This sets the width of each streak.

Tail Fade 0.5 This sets the opacity of the tail fade; it can range
from 0 to 1. A value of 1 makes the tail completely
opaque; a value of 0 makes the tail transparent.

Tail Size 2 This scales the length of the tail. A value of 1 is the
default length. Values less than 1 shorten the tail;
values greater than 1 lengthen the tail.
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Add color to the particles with a color ramp
A ramp texture is a patterned 2D image in which the color blends from one
shade to another. In the next steps, you will use a color ramp to color the
particles as they age.

1 In the Attribute Editor, right-click the rgbPP data box and select Create
Ramp. This causes a default color ramp to color the particles as follows:

As each particle ages from its time of birth (emission), its color changes
according to the ramp’s color in an upward vertical (V) direction. The
horizontal (U) direction of the ramp’s color is unused in this lesson.

V

U (unused)
age = 0

age = lifespan

Default color ramp

Color ramp applied to emitted particles

age = 0

age = lifespan
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When you create the ramp, Maya adds a lifespan attribute and sets it to 1
second, by default. Each particle changes from red to green to blue over its
lifespan of 1 second. The particle then disappears (dies).

2 Select Shading > Smooth Shade All. This enables you to see the colors of the
particles the next time you play the animation.

3 Go to the start of the playback range and play the animation. Notice the
particles never reach the end of the cone volume.

This is because the Lifespan is set to the default of 1, which is the number of
seconds the particles exist in the animation.

4 In the Channel Box, set Lifespan to 3. Go to the start of the playback range
and play the animation.
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Because the particles live longer, they pass all the way through the cone and
part of the way through the torus. The particles change from red to green to
blue and disappear as they are born, age, and die.

Hardware render the particles
In 3D animation, rendering typically refers to the act of creating a sequence
of high-quality image snapshots for each frame of an animation sequence.
After rendering the images, you play them in sequence to create a film or
video clip. If the concept of 3D animation rendering is new to you, consider
doing the lesson “Rendering a scene” on page 181 before completing this
section.

You cannot render most particle render types, including streaks, with
Maya’s standard rendering method, known as software rendering. You must
hardware render the particles.

Hardware rendering uses your computer’s graphics hardware to render a
scene to disk and monitor faster than software rendering. Hardware
rendering displays surface shading and textures less sharply than software
rendering, so most people use it only to render particle effects.

In the following steps, you will test render the last frame of the scene to
make sure the particles look satisfactory. Next, you will render the entire
frame sequence to disk and then play the rendered images with the flipbook
feature.
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Test render the scene
1 Select Window > Rendering Editors > Hardware Render Buffer. This

displays a window from which you hardware render the scene.

2 In the Hardware Render Buffer, go to the start frame and click the play
button. Stop the animation at frame 75.

You must play the particle animation from the beginning in order for
particle effects to be displayed correctly at each frame. You cannot go
directly to an arbitrary frame in the Time Slider and see correct results. Maya
calculates particle animation sequentially frame-by-frame.

3 In the Hardware Render Buffer, select
Render > Test Render.

The streaks look smoother than they do in the
scene view. You can improve the streaks even more
as shown in the next steps.

4 In the Hardware Render Buffer window, select
Render > Attributes.

5 In the Attribute Editor’s Render Mode section, turn on Line Smoothing. This
softens jagged edges when you hardware render Streak or MultiStreak
render types.

6 To see the softened edges, select Render > Test Render.

Be aware that if you click in the Hardware Render Buffer window, the
rendered image disappears. If this occurs, select Render > Test Render again
to redisplay the image.

Render the entire frame sequence and play the results
1 In the Hardware Render Buffer window, select Render > Attributes and edit

the attribute settings as follows:

Filename Emit This name will be the base of the filenames created
when you render all frames to images on disk.

Start Frame 1 This specifies the first frame of the animation
sequence to be hardware rendered.

End Frame 75 This specifies the last frame to be hardware
rendered.
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Other attributes in the Attribute Editor specify the image resolution, file
format, lighting, and other display characteristics.

2 Make sure that no other windows overlap the Hardware Render Buffer or
that your screensaver may accidentally launch while you use this feature.
When you hardware render a frame sequence to disk, Maya renders
whatever exists within the borders of the Hardware Render Buffer window.

3 In the Hardware Render Buffer window, select Render > Render Sequence.
This creates a series of files named Emit.0001, Emit.0002, and so on, through
Emit.0075. These files are the rendered frames 1 through 75. Maya puts the
files in your current project’s images directory.

4 To play the hardware-rendered sequence, select Flipbooks > Emit.1-75.

5 Close the Fcheck window when you are finished examining the animation.

Beyond the lesson

Fields

With volume axis fields, you can funnel or swirl particles within the
boundaries of common volumetric shapes. Although the lesson showed how
to use a pair of volume axis fields to control the motion of particles, Maya
has several other types of fields such as Gravity and Turbulence for
simulating natural phenomena. You can use the fields to animate the motion
of curves and surfaces in addition to particles.

Ramps

You can also change ramp colors by editing other ramp attributes, such as
Noise and Noise Frequency. Right-click the attribute box for rgbPP, then
select <- arrayMapper1.outColorPP > Edit Ramp. See Using Maya: Rendering
for details on the ramp attributes. You can also control other particle
attributes with ramps, for instance, opacity. See Using Maya: Dynamics.

Rendering

The majority of particle rendering types are visible only when you hardware
render. Software rendering does not display them. If you use a particle
render type of Blobby Surface, Cloud, or Tube, you must software render the
particles. Hardware rendering does not display them.
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If you create a scene that includes particles and geometric surfaces, you
therefore might need to render the scene twice, once with hardware
rendering and once with software rendering. In such cases, you’ll need to
composite the two sets of rendered images using a compositing software
package.

LESSON 2 RIGID BODIES AND CONSTRAINTS

A rigid body is a polygonal or NURBS surface converted to an unyielding
shape. Unlike conventional surfaces, rigid bodies collide rather than pass
through each other during animation. To animate rigid body motion, you
can use fields, keys, expressions, rigid body constraints, or collisions with
particles or other rigid bodies.

Rigid body constraints restrict the motion of rigid bodies. The constraints
simulate the behavior of real-world items you’re familiar with: pins, nails,
barriers, hinges, and springs.

In this lesson, you’ll use a Hinge constraint to constrain some planks to a
position in your scene, drop a ball on the planks and watch the constraints
and rigid bodies in action.
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Create the geometry
You can create rigid bodies from NURBS surfaces and polygonal surfaces. In
the following steps, you’ll create some polygonal surfaces to be used for the
rigid bodies.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 231.

2 Set the start frame to 1 and end frame to 200.

3 Select Create > Polygon Primitives > Cube > ❒ .

4 In the Polygon Cube Options window, select Edit > Reset Settings (to make
sure the tool is set to its default. Set the following options and click Create:

5 With the polygon still selected, select Edit > Duplicate > ❒ .

6 In the Duplicate Options window, select Edit Reset
Settings. Then set the following and click Duplicate.

This creates five copies of the polygon, each one
placed 3 units above the lower one.

Position the geometry

Place the geometry as shown in the side view in the
next illustration. To position the planks precisely,
select each plank individually and use the Channel
Box to enter the appropriate value from this table.

Width 2

Height 4

Depth 0.25

Axis Z

Translate 0, 3, 0

Number of copies 5
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Create Hinge constraints
A Hinge constraint constrains rigid bodies
along a specified axis. You can use a Hinge
constraint to create effects such as a door on
a hinge, a link connecting train cars, or a
pendulum of a clock. In this example, the
Hinge constraint constrains the plank to a position in the scene view.

In the following steps, you’ll add Hinge constraints to the center of the
planks, which automatically turns the plank into a rigid body. You will do
this for each plank. By default, Maya automatically creates a rigid body
when you use a field or rigid body constraint to control its motion.

1 Select Soft/Rigid Bodies > Create Constraint > ❒ .

2 In the Constraint Options window, set the following options:

By default, the initial orientation is set to 0, 0, 0, which orients the hinge
constraint to lie parallel to the Z-axis in world space. By setting the
orientation to 90 in the Y-axis, the hinge constraint is rotated 90 degrees
around the Y-axis, which orients the constraint parallel to the X-axis.

pCube1 Translate Z 0

pCube2 Translate Z 2

pCube3 Translate Z 0

pCube4 Translate Z 2

pCube5 Translate Z -1

pCube6 Translate Z 1

Constraint Type Hinge

Initial Orientation
X
Y
Z

0
90
0
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By leaving the Set Initial Position at its default setting, the hinge constraint is
created at the rigid body’s center of mass.

3 Select pCube1 and click Apply in the Constraint Options. Select pCube2 and
click Apply in the Constraint Options. Repeat this until each of the six
planks has a constraint applied to it. Close the Constraint options window.

Add a ball and gravity
In the next steps, you’ll create a ball and add gravity to make the ball drop
and hit the planks.

1 Select Create > Polygon Primitives> Sphere > ❒ .

2 Set Radius to 0.2 and click Create.

3 In the Channel Box, set the Sphere’s Translate Y value to 18.

4 With the sphere still selected, select Fields > Gravity. When you connect
Gravity to the sphere, it automatically makes the sphere an active rigid
body.

Gravity affects only the object that was selected when you add the Gravity
field.

5 Play the animation.

The ball falls and collides with the planks, which rotate about the hinge
constraint.

Change an active rigid body to passive
Maya has two kinds of rigid bodies—active and passive. An active rigid body
is animated by dynamics—fields, collisions, and springs—not by keys.

Constraint
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Because the ball and planks are all active rigid bodies, gravity pushes it
down and it rebounds after colliding with the planks.

A passive rigid body can have active rigid bodies collide with it. You can key
its Translate and Rotate attributes, but dynamics have no effect on it.

In the previous steps, all the planks were active rigid bodies and reacted to
the collision of the ball. In the following steps, you’ll change the bottom
plank to be a passive rigid body so the ball bounces off the plank but the
plank doesn’t react to the collision.

1 Select pCube1 and display the Attribute Editor.

2 Click the rigidBody tab to display the rigid body attributes.

3 In the Rigid Body Attributes section,
turn off Active to make pCube1 a
passive rigid body. Click Close to close
the Attribute Editor.

4 Go to the start of the playback range
and play the animation. Notice how
pCube1 no longer reacts to the impact of
the ball, but the ball continues to bounce
off it.

Beyond the lesson

Active and passive rigid bodies

This lesson showed some of the
differences between active and passive rigid bodies. When a rigid body is
passive, rigid bodies will collide with it but will not move it. You can control
its movement by setting keys.

When the rigid body is active, you control its movement using dynamic
forces, specifically fields and collisions. You can change the active and
passive state of the rigid body to achieve various effects. For example, you
can roll a ball off a table using keys (passive rigid body) then cause the ball
to fall using gravity (active rigid body).
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Constraints

In this lesson, you used a hinge constraint between an active rigid body and
a position in the scene view. You can also create a hinge constraint between:

• a passive rigid body and a position in the scene view

• two active rigid bodies

• an active and passive rigid body

Other types of constraints include:

• a Nail constraint, which nails a single active rigid body to a position in the
scene view

• a Pin constraint, which links two rigid bodies at a specified position

• a Spring constraint, which simulates an elastic cord

• a Barrier constraint, which creates an infinite barrier plane beyond which the
center of mass of the rigid body will not move
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Maya makes it easy to paint natural and surrealistic effects. You can create a
background for your scene, a subtle texture for a 3D surface, or a dynamic
paint effect such as a wind-blown tree—all at the drag of your mouse or
tablet pen.

This chapter includes the following lessons:

• “Lesson 1 Painting on a 2D canvas with the Paint Effects Tool” on page 256

• “Lesson 2 Painting 3D effects with the Paint Effects Tool” on page 268

• “Lesson 3 Painting textures on a surface with the 3D Paint Tool” on page 277

PREPARING FOR THE LESSONS

To ensure the lessons work as described, do these steps before beginning:

1 Consider doing the lessons in Chapter 7, “Rendering.” Familiarity with Maya
rendering concepts is important to understanding the following lessons.

2 Select File > New Scene to create a new scene.

3 To use all available screen space, maximize the Maya window.

4 From a panel menu bar, select Panels > Layouts > Single Pane.

5 Select the Rendering menu set. Unless otherwise noted, the directions in this
chapter assume the Rendering menu set is selected.
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LESSON 1 PAINTING ON A 2D CANVAS WITH THE
PAINT EFFECTS TOOL

With the Paint Effects Tool, you can paint colors, patterns, and textures on a
2D canvas image. You can use the image as an independent piece of art, a
background image in your scene, or a texture to be applied to a 3D surface.

In this lesson, you’ll learn how to paint on a 2D canvas, exploring a few of
the many preset brushes. You’ll also learn how to modify brush colors and
other settings to customize your painting.

Paint a few strokes
In the following steps, you’ll display the 2D canvas and use preset brushes
to paint a few strokes.

Although not covered in this lesson, you can use a tablet and pen to paint
with pressure sensitivity. The harder you press down, the more paint is
applied.

1 Do the steps in “Preparing for the lessons” on page 255.

2 If you want to create maximum space in the Maya window, turn off Display
> UI Elements > Channel Box/Layer Editor, Tool Settings, and Attribute
Editor.

3 On the view menu bar, select Panels > Panel > Paint Effects (hotkey 8). The
panel displays a Paint Effects toolbar and menus.

4 From the Paint Effects menus, select Paint > Paint Canvas to display the 2D
canvas. You’re ready to start painting. Be aware that you can’t display a grid
on the canvas.

5 Paint a stroke by dragging across the canvas.
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When you first display the Paint Effects panel, your strokes use the default
brush—a solid black stroke similar to an airbrush.

6 Now paint with various preset brushes. To select a preset brush, select
Brush > Get Brush or click the following button in the toolbar:

The Visor window opens. The Visor organizes the hundreds of Paint Effects
brushes into category folders. In the Visor, click a folder, then click a brush
icon in the area to the right of the folders. (The name of each preset brush
has the extension .mel because each is a MEL script that establishes the
brush’s operation characteristics.) You can dolly within the Visor window to
enlarge the viewable size of the brush icons and read the names more
clearly.

Note that you can copy a brush or all brushes within a folder to the Shelf.
Use the middle mouse button to drag the brush or folder to the Shelf. Use
the shelf editor (available from the arrow menu at the left of the shelf) to
remove items from the shelf.
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Some brushes apply paint directly along the paint path, while others
produce added effects. For example, the pens folder includes brushes such
as ballpointRed.mel that work like pens, while the flowers folder includes
brushes such as dahliaPink.mel that grow flowers as you drag the mouse.
Brushes like dahliaPink.mel use Paint Effects tubes.

7 With the dahliaPink.mel brush, drag the mouse slowly for one stroke, then
quickly for the next stroke.

When you paint a stroke slowly, the density of flowers is higher than when
you paint quickly. The effect of stroke speed on density works the same for
all brushes that use tubes.

8 To erase your last stroke, select Canvas > Canvas Undo. Note that when
displaying the 2D canvas, you can undo only a single stroke. Edit > Undo
(on the main menu) doesn’t undo strokes.

9 To erase the entire canvas, select Canvas > Clear or click this button on the
toolbar:
INSTANT MAYA

258



PAINTING | 9
Painting on a 2D canvas with the Paint Effects Tool
Modify settings of the default brush
When you select a preset brush, Maya copies its brush settings to a template
brush. A template brush is a holder for the attribute settings of the next
strokes you paint. When you change the settings of the template brush, they
affect only the next strokes, not previous strokes.

1 Select Brush > Reset Template Brush to select the default brush, then paint
on the canvas so you remember the brush effect.

2 Select Brush > Edit Template Brush or click the following button in the
toolbar:

You can edit various brush settings, for example, the brush width, in the
window that appears.

3 To resize the brush, change the Global Scale value. Alternatively, you can
move the brush over the canvas, press and hold the b Hotkey and drag left
or right. The circle on the canvas represents the size of your brush. Paint on
the canvas to try out a new size.

4 Close the Paint Effects Brush Settings window.

5 On the toolbar, click the swatch to the right of C (color) to display the Color
Chooser. Select a color from the Color Chooser and paint on the canvas.
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6 On the toolbar, slide the T (transparency) slider to the right until the T box is
a light gray. Paint on the canvas. When you paint over existing paint strokes
you will notice that your paint is transparent allowing the previous strokes
to show through.

Note that the Toolbar color boxes, for example, C and T, are also available in
the Paint Effects Brush Settings window. (Select Brush > Edit Template
Brush > Shading.)

Modify the canvas
In the next steps you’ll change a few canvas options, including color and
size.

1 Clear the canvas (Canvas > Clear).

2 Select Canvas > Set Size and set the canvas size to 512 x 512—the width and
height in pixels. When you are prompted to save, click No, then close the Set
Canvas size window.

Although you’ll often use the default maximum canvas size to take
advantage of the available screen space, you might need to use a smaller or
larger size in many circumstances. For instance, if you plan to use the image
as a background in a computer game, you might need to use a small canvas
size such as 256 by 256.
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3 Turn on the wrap buttons on the toolbar:

4 Paint strokes past the edges of the canvas. The strokes wrap around to the
opposing side. This feature is useful for creating patterned texture images to
be applied to surfaces. When you tile or repeat the image on the surface, the
wrapped strokes help make the borders between the images unnoticeable.

5 Select Canvas > Clear > ❒ . In the options window, slide the Clear Color
slider all the way to the left. Click Apply.

This clears existing strokes and turns the canvas black. Before you paint
strokes on the black canvas, be aware that some brushes seem to have no
effect. If this occurs, it’s because the paint is black or because it is transparent
enough to prevent the color from showing.

Modify colors of a preset brush
In the following steps, you alter leaf and bud colors of a preset brush,
ferns1.mel.

1 In the Visor (Brush > Get Brush), click the ferns1.mel preset brush in the
plants folder. Paint on the canvas to see the default display. Because
ferns1.mel uses tubes, ferns grow along the path of your stroke.

2 Resize the brush to a Global Scale of about 0.5 (Brush > Edit Template Brush)
and paint on the canvas.

3 On the toolbar, click the L1 color box (Leaf Color 1), select a shade of blue
from the Color Chooser, and leave the Color Chooser open. L1 sets the color
of the tips of the leaves.

4 Click the L2 color box (Leaf Color 2) and select a shade of red from the Color
Chooser. L2 sets the color of the base of the leaves.

Tip

When using the ferns1.mel brush, if any of the sliders are cut off on the
right, you need to increase the resolution on your monitor to 1152 x 870.
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5 Click the B color box (Bud Color) and select a shade of yellow from the Color
Chooser. B sets the color of the flower buds.

6 Paint on the canvas and note how the changes you’ve made affect the final
paint effect.

7 Clear the canvas (Canvas > Clear).

Tip

You can change the path width of ferns1.mel without changing the width
of the leaves and stems. Select Brush > Edit Template Brush to display the
Brush Settings window, then change the value of Brush Width in the Brush
Profile section. Similarly, you can alter the path width for any other preset
strokes with tubes.
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Specify which elements grow from a stroke with tubes
Now you’ll edit the attributes that specify the foliage that grows along the
path with ferns1.mel.

1 To edit brush settings, select Brush > Edit Template Brush.

2 Open the Tubes section, then open Growth.

By default, only Leaves and Buds are created as you paint. You can also
create Branches, Twigs, and Flowers to simulate a fern in various stages of
its natural life cycle.

3 Turn on Flowers. Paint on the canvas to see the result.

4 Open the Leaves section, change Leaves in Cluster to 4, then paint on the
canvas. Leaves are created in radial clusters around a branch or twig. This
setting defines how many leaves are in each cluster. The higher the number,
the denser the foliage.

5 To make the flowers point in a different direction, open the Behavior section
and then the Forces section. Set Path Follow to 0.1.

6 Paint to see the result.
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Save the new brush settings as a preset brush
When you first selected the preset brush ferns1.mel previously, Maya copied
it to the template brush. You then edited the color and various other
attributes of the template brush to create a unique ferns brush. The next
steps show how to save the current settings of the template brush for future
use.

1 On the main menu bar, select Paint Effects > Save Brush Preset. This is the
menu item you use to save the template brush as a preset brush.

2 Enter the name blueFern in the Label box and the Overlay Label box. This
name appears in icons on the Shelf or Visor after you save the brush.

3 For the Save Preset option, turn on To Shelf. This means you’ll put the brush
on the Shelf but not in the Visor.
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4 Click Grab Icon and drag a selection box around a part of the image that is
representative of the brush’s result. A swatch appears in the window for the
selected region. Repeat this step until you are satisfied with the icon.

5 Click Save Brush Preset. An icon for the new preset brush appears on the
Shelf.

6 To check that the blueFern brush works, select a different preset brush and
paint on the canvas, then select the blueFern from the Shelf and paint on the
canvas.

7 Clear the canvas and close the Save Brush Preset window.

Blend brushes
Next, you’ll blend brushes. Before beginning, display the Visor, click
gold.mel in the metal folder, and paint on the canvas so you know gold’s
effect. Do the same for grassOrnament.mel from the grasses folder.

1 Click grassOrnament.mel in the grasses folder.

2 From Maya’s main menus, select Paint Effects > Preset Blending.

The options in the resulting window set how much the previous preset
brush is influenced by the next preset brush you select. This affects only the
template brush (your subsequent painting), not the preset brushes in the
Visor.

3 Change the Shading value to 80 and the Shape value to 0.

When you select the next brush (gold.mel), Maya uses 80% of its shading
and 0% of its shape. Conversely, the stroke uses 20% of the
grassOrnament.mel brush’s shading and 100% of its shape.

4 To confirm the effect, select gold.mel (in the metal folder), then paint on the
canvas.

5 Repeat the preceding steps, experimenting with different preset brushes,
Shading, and Shape values. As a first try, blend fire1.mel from the fire folder
with the existing template brush. Set Shading to 60 and Shape to 30.

If the Brush Preset Blend window is open, each time you select a preset
brush, its Shading and Shape values will be blended with the template
brush.

6 Close the Brush Preset Blend window when you are done blending brushes.
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7 Do not clear the canvas. You’ll use your existing strokes in the next steps.

Smear, blur, and erase paint
Now you’ll work with brush types that smear, blur, and erase paint.

1 Select Brush > Reset Template Brush to select the default brush.

2 On the Brush menu, try the Smear, Blur, and Erase menu items and paint on
the strokes already on the canvas. You can also change these settings using
the Brush Type setting in the Paint Effects Brush Settings window (Brush >
Edit Template Brush).

3 If compositing is part of your job, be aware that you can view the image’s
alpha channel by clicking this button:

White regions represent full opacity. Black represents full transparency.
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4 If you turned on the alpha channel (Display > Alpha Channel), return to the
display of full color by selecting Display > All Channels.

5 Clear the canvas and restore the canvas color to white (Canvas > Clear > ❒ ).

6 To quit the canvas display and return to a scene view, select Panels >
Perspective > persp (Hotkey 8).

7 To quit the Paint Effects Tool, click the Select Tool.

Beyond the lesson
In this lesson, you learned how to edit, blend, and save preset brushes. You
worked on a 2D canvas, which is useful when you need to create a texture to
be applied to a surface. For example, suppose you paint a repeating brick
pattern on the canvas and save the canvas as an image file. You can create a
material, for instance, a Blinn material, then apply the image file as a file
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texture to the color of the Blinn material. You can then apply the Blinn
material to a 3D wall you’ve modeled, which creates the illusion of a brick
wall.

Painting a 2D canvas is also useful for creating a background image for a
scene. For instance, you might create lush foliage on the canvas, put it on a
camera’s image plane, then use it as the backdrop for animated jungle
animals in the foreground.

Although not covered in this lesson, you can use a tablet and pen to paint
with pressure sensitivity. Pressure sensitivity allows you to more realistically
simulate the effects of traditional drawing media (pens, pencils, markers etc.)

Also be aware that you can use Maya’s standard mouse and keyboard
combinations to dolly and track the canvas.

LESSON 2 PAINTING 3D EFFECTS WITH THE PAINT EFFECTS
TOOL

With the Paint Effects Tool, you can paint directly in your scene or on an
object’s surface. You can use hundreds of preset brushes in categories such
as plants, fire, metal, oil paints, pastels, and watercolors. For example, you
can use the preset plant brushes to paint a tropical fern garden around a
walking character in your scene. You can additionally animate brush strokes
to create dynamic effects, for example, to have the ferns shake in the wind.

In this lesson, you’ll explore several brushes and apply strokes to a 3D
object.

Create a sphere and light
You start the lesson by creating a sphere upon which you’ll paint. You’ll also
create a light to light up the paint strokes.

1 Do the steps in “Preparing for the lessons” on page 255.

2 Create a NURBS sphere with a radius of roughly 10.

You use a NURBS sphere because you cannot paint 3D strokes on polygons
or subdivision surfaces.

3 Select Create > Lights > Directional Light.
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A directional light shines evenly in one direction, as if from a distant source
such as the sun. To see paint from the Paint Effects Tool on a 3D object in the
scene view, you must create at least one light in the scene.

Paint on a sphere
You can paint strokes directly on objects, whether stationary or animated. In
the next steps, you’ll paint on the stationary sphere you just created.

1 With the sphere selected, select Paint Effects > Make Paintable.

You must make an object paintable before you can paint on it. If you make
an object paintable but you try to paint on one that is not paintable, no
stroke occurs. If you don’t make any objects in your scene paintable, your
strokes are placed on the grid plane.

2 Press 8 to switch to the Paint Effects panel.

Later, if you want to select, move, or otherwise manipulate objects in the
scene view, you must press 8 again to exit the Paint Effects panel.

3 Select Paint > Paint Scene to switch to the scene painting view. This lets you
paint in 3D rather than on a 2D canvas.

4 Select Shading > Shaded.

5 Select Shading > Use All Lights. This is necessary to have the directional
light you created light the sphere in the scene view.

6 Select Brush > Get Brush to display the preset brushes in the Visor.

7 In the pens folder of the Visor, select goopInkRed.mel. In the toolbar, click
the C box to display the Color Chooser. Select a yellow color, then close the
Color Chooser.

8 Hold down your keyboard’s b key and drag to the right along the surface.
This increases the size of a spherical icon that represents the stroke width.
Dragging left lessens the width. Make the width about as wide as a pencil.

Write hot on the surface of the sphere as shown in the following illustration.
Use two strokes, the second to cross the t. If you don’t like a stroke, select
Edit > Undo (on the main menu). When you paint in a 3D scene rather than
on the 2D canvas, you can undo multiple strokes.
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9 Tumble the camera in any direction.

The hot strokes are now displayed as wireframes. This is the default display
mode after you alter the camera view or edit a stroke or brush. Maya has a
Paint Effects panel setting, Stroke Refresh > Rendered, in which strokes
appear fully rendered after each alteration. You may wish to use this setting
selectively to minimize the time waiting for frequent renderings. For this
lesson, use the default setting, Stroke Refresh > Wireframe.
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10 To see the stroke rendered, click this button to redraw the view:

The paint appears raised on the surface. Other preset brushes work
differently. For example, with a watercolor brush, the paint lies flat on the
surface.

Modify a stroke’s attributes and copy to another stroke
After you paint a stroke, you can modify stroke attributes to change the
paint’s appearance. You can also copy such changes to other strokes.

1 In the Outliner, select the first stroke you painted, strokeGoopInkRed1.

2 In the Attribute Editor, click the goopInkRed1 tab. The tab name is based on
the original preset brush’s name.

3 In the Shading section, click the Color1 box and select a new color, for
instance, a light green, from the Color Chooser. Redraw the view to see the
change.

4 In the Texturing section (within the Shading section), turn on Map Color.
Redraw the view.
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By default, a Checker texture type is mapped to the color. The checker
pattern has two colors: black, and the color you selected in the prior step,
green.

5 You can copy the settings from this stroke to the other. With the stroke
strokeGoopInkRed1 selected, select Paint Effects > Get Settings from Selected
Stroke. In the Outliner, select the other stroke, strokeGoopInkRed2, and
select Paint Effects > Apply Settings to Selected Strokes. Redraw the view.
INSTANT MAYA

272



PAINTING | 9
Painting 3D effects with the Paint Effects Tool
Create realistic shadows
The brush you used in this lesson creates a simple (fake) shadow effect, by
default. While the default shadows look good for most 2D work, you’ll likely
want more realistic shadowing in your 3D scenes.

1 To see the fake shadows more clearly, move the strokes off the surface: With
strokeGoopInkRed2 selected in the Outliner, display the Attribute Editor. In
the strokeShapeGoopInkRed2 tab, enter 1.5 in the Surface Offset box. Repeat
this for the first stroke (strokeShapeGoopInkRed1).

If necessary, rotate the sphere so that it points in a direction that makes the
shadows easily visible: Exit the Paint Effects panel (press 8), then select and
rotate the sphere. The strokes rotate along with the sphere. Return to the
Paint Effects panel (press 8) and redraw the view.

2 With the first stroke selected, display the goopInkRed1 tab in the Attribute
Editor. Scroll down and open the Shadow Effects section. Select None for
Fake Shadow. Redraw the view.

The first stroke no longer casts a fake shadow. The second stroke still casts a
fake shadow under the cross of the t. In the next steps, you’ll add realistic
shadows to the first stroke. Leave the second stroke’s fake shadows turned
on for comparison.

3 With the first stroke selected, display the goopInkRed1 tab in the Attribute
Editor. In the Shadow Effects section, turn on Cast Shadows.
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4 In the Outliner, select the directional light you added to the scene. Display
the Attribute Editor. Open the Shadows section and turn on Use Depth Map
Shadows. Depth map shadows provide realistic, quickly rendered shadows.

5 Select Render > Render Current Frame to test render the scene.

To see Depth Map Shadows, you must
render the scene rather than redraw the
scene view. Notice that the shadow under
the cross of the t looks implausible, while
the other stroke looks authentic.

Have the second stroke share the first
stroke’s brush

By default, each stroke has a unique brush
attached to it, so you can give each stroke
a different look. You can have two or more strokes share a single brush, so
that any changes you make to the brush affect the strokes. The next steps
show how to make the second stroke share the first stroke’s brush.

1 In the Outliner, select strokeGoopInkRed2.

2 Shift-select strokeGoopInkRed1.

3 Select Paint Effects > Share One Brush. This causes strokeGoopInkRed2 to
share the brush attached to strokeGoopInkRed1. The last stroke selected is
the one whose brush is shared by other stroke(s) selected in this operation.

4 Select Render > Render Current Frame to test render the scene. The
goopInkRed1 brush is now used by both strokes. The Cast Shadows option
in goopInkRed1 is therefore applied to the cross of the t. All other options of
goopInkRed1 are likewise used by both strokes.

Make the strokes glow
You can add glow to the brush so the strokes look like they’re lit from inside.

1 Select strokeGoopInkRed1 and display the Attribute Editor. Click the
goopInkRed1 tab and expand the Glow section.

2 Set the Glow value to 1. This sets the brightness of the glow. 0 means no
glow. Higher values increase the brightness.

3 Click the Glow Color box and select a blue color for the glow.
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4 Set a Glow Spread value of 4. This sets how much glow spreads past the
paint. The size is a multiplier of the width of the paint’s width on the path.
For instance, 1 produces no spread while 1.5 makes a halo 1.5 times as big as
the width.

5 Redraw the view.

The second stroke glows because it uses the same brush as the first.

Apply a different brush to the strokes
You can change the look of the strokes by applying a different preset brush.
In the following steps, you’ll apply a preset brush that creates grass.

1 Select both strokes in the Outliner.

2 In the grasses folder of the Visor (Brush > Get Brush), select
grassOrnament.mel. When you select a preset brush, Maya copies its settings
to the template brush. From here, you can apply the settings to selected
strokes.

3 Select Paint Effects > Apply Settings to Selected Strokes. The template brush
settings are copied to the brush attached to the first and second strokes.
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4 Redraw the view.

Animate strokes to make the paint advance along a path
You can animate stroke attributes that cause the grass to advance from the
beginning to the end of the stroke as the animation plays.

1 Go to the first frame of the Time Slider.

2 Select the first stroke, strokeGoopInkRed1.

3 Display the Attribute Editor. On the strokeShapeGoopInkRed tab, open the
End Bounds section and set Max Clip to 0.

Min Clip specifies the start of the stroke along the path. Max Clip specifies
the end of the stroke along the path. The range of values possible for both
attributes is 0 to 1. By default, Min Clip is 0 and Max Clip is 1, which means
you see the paint along the entire path.

If you use a value higher than 0 for Min Clip, the paint starts further along
the path. If you use a value lower than 1 for Max Clip, the paint ends before
the end of the path.

4 Right-click the Max Clip box and select Set Key from the pop-up menu. This
keys the attribute to 0 at the start of the animation. With Min Clip and Max
Clip set to 0, the start and end of the stroke is at 0, so you’ll see virtually no
paint on the path.
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5 Go to the last frame and set the Max Clip value to 1. Right-click the Max Clip
box and select Set Key from the pop-up menu. With Max Clip at 1, you’ll see
the paint throughout the length of the path.

6 Repeat the steps for the second stroke, strokeGoopInkRed2.

7 Step through the playback one frame at a time to watch the grass advance
along the path. Note that the

Note that you can prevent grass from appearing until the second frame.
Select a stroke and key its Min Clip to -1 at the first frame and 0 at the
second frame.

Beyond the lesson
In this lesson, you learned how to edit, copy, and shadow strokes on a 3D
surface. You also learned how to cause strokes to share a single brush, make
strokes glow, and animate the movement of strokes. You can use these
techniques to decorate and enhance the objects and creatures in your scene.
By applying the techniques to 3D space rather than to a surface, you can
create natural or fantastic scenery, backdrops, and atmospheres.

Paint Effects has many other useful techniques not covered in the lesson. For
example, you can modify existing conventional textures applied to surfaces,
or you can paint on existing images and textures. You can attach a brush to
an existing curve; you don’t need to paint a curve.

In addition to making Paint Effects strokes appear to grow, you can create
many other animation effects. For instance, you can add spring-like behavior
to strokes with tubes, or you can make the tubes react to dynamic forces
such as wind. You can also create animated textures, for instance, falling
rain.

LESSON 3 PAINTING TEXTURES ON A SURFACE WITH THE
3D PAINT TOOL

With the 3D Paint Tool, you paint textures directly on a model’s surface. In
this lesson, you’ll paint colors and various patterns on a dinosaur model.
You’ll also use paint to create the illusion of bumps.
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Open and save the scene
You will paint a dinosaur model we prepared for this lesson.

1 Do the steps outlined in “Preparing for the lessons” on page 255.

2 Open the scene named 3DPaint from the location specified in the following
table:

The scene contains a model named
Dino. Although Dino is a polygonal
model, the 3D Paint Tool works on
all surface types: polygonal, NURBS,
and subdivision surfaces.

To prepare the model for your use in
this lesson, we assigned Dino a Blinn
material named DinoSkin. You can
paint a surface only if it has a
material assigned to it. We also gave
the Blinn material a green color. A color is optional, but it provides a base
color for the texture you will paint.

Maya Package File Location

Maya Complete or
Unlimited

Obtain the Maya 4.5 Documentation and Lessons CD
and find:

InstantMaya/Paint/3DPaint.mb

(You can also copy these files to your hard drive.)

Maya Personal
Learning Edition

Go to the installation directory:

Drive:\Program Files\AliasWavefront\Maya 
4.5 Personal Learning Edition

and then to:

\tutorialData\MayaPLE\Paint\3DPaint.mp
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Finally, we made other preparations to Dino so you can use the 3D Paint
Tool successfully. You’ll learn about the preparations in “Preparing UVs for
painting” on page 289.

3 Save the scene in your default scenes directory (File > Save Scene As).

This lesson works best when you start with a saved scene. When you use the
3D Paint Tool, Maya automatically creates a directory to store the file texture
that will be created from your painting. By saving the scene, you ensure that
Maya can locate the directory and file texture that it creates automatically.

4 Select Display > UI Elements > Tool Settings. This displays a Tool Settings
panel where the Channel Box is normally located. You will be working with
this panel throughout the lesson.

Prepare for painting
1 Select Dino. You can paint only on selected objects. Be aware that while you

use the 3D Paint Tool, the wireframe of a selected object is not highlighted.
You can check the Outliner to be sure the object is selected.

2 Select Texturing > 3D Paint Tool. The following warning appears on the
Command Feedback line:

Warning: Some surfaces have no file texture assigned to the 
current attribute.

The 3D Paint Tool requires that the material assigned to your model has a
file texture applied to it. Because there is no file texture yet assigned, the
warning appears.

Also, if you move the cursor over Dino, you’ll
see a circle-X icon that indicates you cannot
paint on the model.

3 To make sure you have the default settings for
the 3D Paint Tool, click Reset Tool at the top of
the 3D Paint Tool settings panel.

4 In the File Textures section of the 3D Paint Tool settings panel, make sure
that Color is the selection for Attribute to Paint, then click Assign Textures.

This step and the next two steps assign a texture to Dino. (Note that you can
also paint over an existing texture that you assigned from Hypershade.)
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5 Enter 512 in the Size X box, which is the height of the new file texture in
pixels.

By increasing the file texture size, you will see finer detail and resolution in a
rendered image of your painting. The number 512 is twice the default size,
256. You could use a higher resolution, but sizes larger than 512 slow the
interactive speed as you paint. Notice that Size Y automatically changes to
512. This is because Keep Aspect Ratio is turned on, ensuring that the
proportions of the texture are maintained.

6 Click Assign Textures in the Assign File Textures window.

Maya creates a file texture and assigns it to the Color attribute of the
DinoSkin material. You will learn at the end of the lesson about the name
and location of the file texture that is created.

You are now ready to paint.

Paint with an Artisan brush
In the following steps, you’ll paint various colors on the texture you just
assigned. You’ll also change the size of the brush strokes.

There are two types of brushes you can use. The default is the Artisan brush,
which you’ll use in the next steps. (Artisan refers to a group of painting tools
in Maya that share common tool settings.) The other brush is based on the
Paint Effects brushes; you’ll use it later in the lesson.

1 If you have a tablet and pen, you can experiment with pressure sensitivity as
you paint. Open the Stylus Pressure section and turn on Stylus Pressure.
(You do not need to have a tablet and pen to complete the lesson.)

By default, when you paint with Artisan brushes, the pressure you apply to
the pen affects the Opacity setting of the 3D Paint Tool. The harder you
press, the more opaque the stroke.

2 In the Color section of the Tool Settings, click the box next to Color and
select a color in the Color Chooser. Leave the Color Chooser open. You’ll use
it in the next few steps.

3 Paint a stroke by dragging on the model.

4 Select another color from the Color Chooser and paint over your first stroke.
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The new color paints over the first color by default. Note that you can blend
the colors by choosing a different Blend Mode setting, under the Paint
Operations heading. You won’t blend the colors in this lesson.

5 Move the brush onto Dino, hold down the b key and drag to the left to make
the brush smaller. Drag until the number at the brush icon changes to about
0.5. You don’t need to be precise.

Use this hotkey when you need to change the brush width. To make the
brush wider, drag to the right. You can also change the width by changing
the Radius (U) setting.

6 Experiment with different colors
and brush sizes on Dino.

To undo a brush stroke, choose
Edit > Undo. The number of
strokes you can undo is specified
by the Queue Size in the Undo
category of the Preferences
window (Window > Settings/
Preferences > Preferences).

7 To remove paint, turn on Erase in the Paint Operations section and stroke
the desired region.

Reflect your paint strokes
You can reflect painted strokes along an invisible axis so that when you
paint, the stroke is mirrored on the opposite side of the axis. Reflection is
useful for creating symmetrical effects.

1 In the 3D Paint Tool settings panel, open the Stroke section and turn on
Reflection X.

Notice that there are now two brush outlines that run along an axis. The
reflection axis is positioned around a point at the center of the object.
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2 Paint on one side of Dino, such as
one of the legs.

As you paint, the strokes are
reflected along the axis and appear
on the other side of Dino. Tumble
to see the reflected stroke on
Dino’s other side.

Flood the model with a single color
You can apply a single color to the entire texture without painting individual
strokes.

1 In the Color section of the 3D Paint Tool settings, click the Flood Color box
and select a pale green color from the Color Chooser.

2 Click Flood All. The Flood Color overwrites all other painting you’ve done.

3 You can also use Flood All to erase painting. In the Paint Operations section,
turn on Erase, then click Flood All again. Maya eliminates all brush strokes,
leaving you with the last saved version of the texture. (To save the texture,
click the Save Textures button in the File Textures section.)

Paint with different brush shapes
You can paint with different brush shapes to produce paint strokes with
hard edges, soft edges, or completely different patterns. You can choose
from four standard Artisan brush shapes, plus 40 preset brush shapes.

1 At the top of the 3D Paint Tool settings, click Reset Tool. Reset Tool cancels
the Reflection X and other settings from the previous steps. While painting,
it’s useful to reset the tool settings from time to time so previous settings do
not interfere with your next strokes.

If you are using a tablet and pen, you’ll need to turn on Stylus Pressure
again to see the effect of your pressure as you paint.

2 Change the Color setting to dark red or another color that contrasts with the
current green color.

3 At the top of the 3D Paint Tool settings, click the following icon and paint a
stroke:
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By changing to the square brush shape, your brush stroke has a straight
edge. Along with the shapes available from the icons, you can choose from
many other unusual brush shapes that are based on image files. You’ll do
this in the next step. Before you do the next step, undo the brush stroke you
just made so it doesn’t distract from the next paint strokes.

4 In the Brush section, click the Browse button. A browse window opens with
a list of various image files. Each file represents a different brush shape.

5 Select dapple.jpg and click Open.

6 Click on Dino’s hump and barely move the brush to create a single spot of
paint.

Instead of a solid color, a pattern appears on Dino. The pattern is a result of
using the dapple.jpg file for the brush shape. Undo the stroke.

7 Now drag the mouse over Dino to paint a single, continuous stroke.

The brush shape pattern overlaps itself as you paint, resulting in a striped
pattern. Undo the stroke.
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8 To avoid the overlapping pattern of the prior step, increase the Stamp
Spacing (in the Stroke section) to a value just under 1, such as 0.8. Paint on
Dino with a continuous stroke and you’ll see the brush pattern without it
overlapping.

The Stamp Spacing setting defines how paint is applied when you stroke the
surface. If you set Stamp Spacing to 1, the edges of the brush shape pattern
just touch each other. If you set the spacing to be greater than 1, there will be
spaces between the brush shape pattern. If you set the spacing to be less than
1, the brush shape pattern will overlap.

Paint with a Paint Effects brush
You can use the 3D Paint Tool with the preset brushes available with Paint
Effects. Paint Effects brushes include not only patterns but also images such
as flowers, feathers, hair, and fire.

In the following steps you’ll paint on Dino with a Paint Effects brush. Before
you begin, consider first becoming familiar with the Paint Effects brushes, as
taught in “Lesson 1 Painting on a 2D canvas with the Paint Effects Tool” on
page 256.

1 In the Brush section of the 3D Paint Tool settings, click the following icon
(Get Brush) to select from the preset Paint Effects brushes:

The Visor window opens. The Visor organizes the hundreds of Paint Effects
brushes into category folders.

2 Scroll to the watercolor folder and click it. To the right, swatch pictures of
the Paint Effects brushes appear for this category. Select the spatter2.mel
brush. (To see the names of the swatches, drag the pointer over them.)

Leave the Visor window open, but move it so you can see Dino again.
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3 If you are using a tablet and pen, you’ll need to turn on Stylus Pressure
again to see the effect of your pressure as you paint. Stylus Pressure is off
because you changed from the Artisan brush to a Paint Effects brush.

For Paint Effects brushes, the pressure you apply to the pen affects three
different settings. If you change the settings, it affects only the selected
brush. The settings for each brush are separate from each other.

4 Paint on Dino.

5 In the Brush section of the 3D Paint Tool settings, click the following icon
(Edit Template Brush) to modify other brush settings:

The Paint Effects Brush Settings window opens. Any changes you make to
the settings in this window affect the display of your next stroke. As an
example, you’ll increase the brush’s incandescence.

6 Open the Shading section in the Paint Effects Brush Settings window. For the
Incandescence1 setting, move the slider to the right and stop midway.

7 Close the Paint Effects Brush Settings window and paint on Dino. Now the
paint has an incandescent glow.
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Smearing and blurring with Paint Effects brushes
In the next steps you’ll smear and blur the paint on Dino. Smearing with a
Paint Effects brush blends adjacent colors together along the stroke path.
Blurring softens the edges of adjacent colors by averaging their color values.

1 Move the Visor window back into view.

2 Click the wetInWet folder and then click the watersmear3.mel brush. Close
the Visor window.

In the 3D Paint Tool settings, notice that the Paint Operation is now set to
Paint Effects Smear. The brush you selected, watersmear3, has settings that
turn on the Smear setting automatically for you.

3 Paint across the side of Dino. The paint smears and produces an effect
similar to dripping wet paint.

4 In the Paint Operations section of the 3D Paint Tool settings, select Paint
Effects Blur. This option selects the default Paint Effects Blur brush.

5 Paint across the side of Dino to see the effect of Blur.
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Paint a bump map texture
Next, you’ll paint a bump pattern on Dino.

1 Click Reset Tool to return to the default settings.

2 In the File Textures section, select BumpMap as the Attribute to Paint and
click Assign Textures.

Previously in this lesson, your painting affected only the Color attribute. To
paint bumps, it’s necessary to select a BumpMap as the new attribute you
want to paint, and then assign a new texture for the bumps you’ll create.

3 Set both Size X and Size Y to 512 and then click Assign Textures. Maya
creates a file texture and applies it to the Bump Map attribute of the
DinoSkin material.

In the scene view, Dino’s color changes to white. Bump map textures are
based on grayscale colors. By default, when you create a rendered image,
bumps will appear in the areas of the surface where there is significant
grayscale color contrast. For instance, if a region has black and white stripes,
you’ll see grooves there. Regions with little or no contrast display no bump.

The bumps will not show in the scene view; you must create a rendered
image in order to see them. The same is true when you paint certain other
attributes, such as Transparency and Incandescence.

Before you paint bumps on Dino, you’ll set up the Maya panels so you can
interactively see the results of your strokes in a rendered image.

4 Select Panels > Layouts > Two Panes Stacked. In the bottom panel, select
Panels > Panel > Render View. Maya now displays the perspective view, the
Render View, and the 3D Paint Tool settings. With this arrangement, you’ll
be able to see your strokes render as you paint.

5 In the perspective view, move the camera to a close-up view of Dino’s side.

6 In the Render View, select IPR > IPR Render > persp. This renders an image
of Dino in the Render View.
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7 In the Render View, drag a selection box
around Dino’s midsection and hump.

This region will update when you paint.

8 For the IPR renderer to render bumps as
you paint, you must update the bump
map texture after each stroke. To have
this occur automatically, scroll to the File
Texture section of the 3D Paint Tool
settings and turn on Update on Stroke.

9 For a grooved bump effect, you’ll change the brush shape. At the top of the
3D Paint Tool settings, click the Browse button. Select the hatch.jpg brush
and click Open.

10 Paint on Dino’s side. Watch the Render View update with each stroke.

The bumps appear as grooves in Dino’s surface because you painted
contrasting black stripes on the white texture. In general, gray or black over
a white background results in bumps that appear indented.

If you wanted bumps that appear raised on the surface, you could start with
a black background and paint gray or white over it. For example, you could
flood the texture with a black Flood Color, then paint white or gray strokes
rather than the default black.

Note that greater contrast between the background color and the color you
paint results in deeper-looking bumps. Less contrast results in more subtle
bumps. In the previous step, you painted using a black color, resulting in
prominent bumps. If you change the Color setting to a light gray and paint
on the white background, only subtle bumps will appear.

Scene view Render View
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11 This concludes the lesson. Before doing other lessons, restore the Channel
Box in the Maya window. Select Display > UI Elements > Channel Box/
Layer Editor.

Beyond the lesson
In this lesson, you used a few of the basic 3D Paint Tool settings. There are
several other capabilities in the Paint Operations section, such as the Clone
option for Artisan brushes. With the Clone option, you can duplicate the
color and pattern from an area of the texture and then paint that pattern
elsewhere on the texture. For details on these options and other 3D Paint
Tool techniques, refer to the online book, Using Maya: Painting
(Help > Library).

Location of 3D Paint Tool file textures
If you need to move or rename a file texture that Maya creates from your
painting, look in the 3dPaintTextures directory under the current project
directory. If you paint an existing file texture that you created previously, for
example, with a paint program, Maya creates a copy and stores it in the
3dPaintTextures directory.

Preparing UVs for painting
To paint successfully on a polygonal or subdivision surface, you must set up
the surface UVs beforehand. UVs are points positioned around the surface
like vertices. They control how Maya stretches a texture around a surface.
For polygons and subdivision surfaces, you must arrange the UVs so that
textures—including the ones you paint with the 3D Paint Tool—look correct
when applied to the surface material. (The UVs on NURBS surfaces are
automatically arranged for you, so you do not have to change them.)

You arrange UVs using the UV Texture Editor, available from the Window
menu. If you’ve never edited UVs, you can learn more online in Using Maya:
Polygonal Modeling and Using Maya: Subdivision Surface Modeling.
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If you already have experience with
editing UVs, remember these two
requirements for 3D painting:

• UVs must not overlap.

• UVs must fit with the 0 to 1 texture
coordinates.

The side illustration shows the UV
Texture Editor with the UVs for the
Dino model used in this lesson. These
UVs meet the above two
requirements. Notice that the UVs
form several meshes; they do not
need to be one solid mesh.

Painting in Screen Projection mode
When you paint on a model, the brush follows the contours of the surface.
This typically produces the most desirable results. However, this default
behavior leads to uneven paint application in some situations. A common
example is along the line where two surfaces join together. It can also occur
if the UVs are not arranged correctly, as described previously.

The solution to these situations is to turn on Screen Projection in the 3D
Paint Tool settings. Screen Projection applies paint as if you are projecting
cinematic film onto a screen. Paint appears where the projection strikes the
surface.

The following figure shows an example of this situation with a Paint Effects
brush.

Uneven paint stroke with
Screen Projection off

Screen Projection on
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Expressions are formulaic instructions you create to control keyable
attributes and commands to occur at specific times within your animations.
Although you can create an expression to animate attributes for any
purpose, they’re ideal for attributes that you want to change incrementally,
randomly, or rhythmically over time. In addition, it is possible to create
custom attributes for objects and control them in conjunction with
expressions. You can use an expression to animate only attributes that are
not animated with another technique, for instance, with keys.

This chapter has the following lessons:

• “Lesson 1 Creating a simple expression” on page 292

• “Lesson 2 Controlling attributes conditionally” on page 299

• “Lesson 3 Controlling particle attributes” on page 308

PREPARING FOR THE LESSONS

To ensure the lessons work as described, do these steps before beginning:

1 Select File > New Scene to create a new scene.

One way to use an expression
is to link attributes in different
objects—so a change in one
attribute alters the behavior of
the other.
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2 Select Window > Settings/Preferences > Preferences. Click the Settings
category and set the Time option to Film (24 fps) so your animation plays at
the default rate of 24 frames per second. Click the Timeline category and
enter 0 and 300 for the Playback Start/End values. (Press the Enter key as
necessary.) Set the Playback Speed to Play every frame. Click the Save
button in the Preferences window.

At this playback speed and frame range, the animation results of the
expressions you’ll create in the lessons will be easier to examine and
understand.

3 With the pointer in the perspective view, press 5 (for Shading > Smooth
Shade All). It’s easier to see the expression effects on shaded objects than
wireframe objects in the following lessons.

LESSON 1 CREATING A SIMPLE EXPRESSION

This lesson shows how to use a simple expression to manipulate:

• a single attribute of a sphere

• multiple attributes of the sphere

• various attributes of a sphere and cone

By completing this lesson, you’ll understand the basics of creating and
editing expressions to control attributes of objects in your scene.

Create an expression to control a single attribute
In the following steps, you’ll create a default sphere and write an expression
to increase its Scale Y attribute as the animation time increases during
playback.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 291.

2 Create a NURBS or polygonal sphere with an X scale, Y scale, and Z scale of
1. Name the sphere Ball.
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3 With Ball selected, choose Window > Animation
Editors > Expression Editor.

4 In the Expression Name box, you can optionally
enter an expression name, for instance,
ScaleBallHeight.

If you write several expressions in the same
scene, giving each a name might make it easier
to find the desired expression if you decide to
alter it later. If you don’t provide a name, the expression receives a default
name, for instance, expression1.

Note that the Attributes list displays Ball’s keyable, unlocked attributes—the
attributes you’ll most likely want to animate with an expression. Use the
scroll bar to see the entire list.

5 Enter this expression in the expression text area:

Type all characters exactly as shown above. Entries are case sensitive. The
semicolon (;) signifies the end of the expression statement. End each
statement in an expression with a semicolon.

An error message appears in the Script Editor and Command Line’s
response area if the expression has incorrect syntax or typing mistakes.

6 Click Create to create the expression.

Creating the expression checks it for syntax errors and converts it to a form
Maya can execute when you return to the start time or play the animation.
Clicking this button also executes the expression for the current frame.

Ball.scaleY = time + 1;
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The expression sets Ball’s scaleY attribute to the value of time + 1. Ball.scaleY
is the full name of the attribute. A period separates the name of the object
and attribute. Note that you must spell the object and attribute with
uppercase and lowercase letters as they appear in the Expression Editor’s
Objects and Attributes lists.

The word time is a commonly used predefined variable that updates as an
animation plays. It contains the elapsed number of seconds from the first
frame to the current frame. The value increases with the increasing frame
number.

At the default animation playback rate of 24 frames per second, time has
these values (rounded to four decimal places):

You can find the time elapsed in the animation at any frame by calculating
this formula with a desktop calculator:

For example, if the frame rate is 24 frames/second and the animation is at
frame 1, the elapsed time is 1 divided by 24, or 0.0417. At frame 6, the
elapsed time is 6 divided by 24, which equals 0.25. Note that if your frame
rate was 30 frames/second the calculated values would be different.

7 Go to the start time and play the animation. Ball’s scaleY attribute increases
as the time increases:

Frame Time
(seconds)

0 0

1 0.0417

2 0.0833

3 0.125

24 1.0

240 10.0

time
frame
rate

---------------=
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Maya executes the expression each frame. This causes the object size to scale
along its Y-axis, stretching its height during playback.

To see the value of Ball’s scaleY attribute at any
particular frame, select Ball, display the Channel
Box, and stop the animation at the desired frame.
The Channel Box updates its values after you stop
the animation.

The scaling is smooth because the geometry
stretches in synch with the small time increments
of the animation playback.

8 Close the Expression Editor window.

Edit the expression
To edit an expression after you’ve created it and
closed the window, you must know how to find
the expression in the Expression Editor. The next steps show how to find
and edit the expression. Specifically, you’ll change the expression to alter
how quickly the scaleY value changes.

1 To display the Expression Editor again, select Window > Animation
Editors > Expression Editor.

Frame Time (seconds) Ball.scaleY (time + 1)

0 0 1

1 0.0417 1.0417

2 0.0833 1.0833

3 0.125 1.125

24 1.0 2.0

240 10.0 11.0
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2 To find the expression, make sure the Ball is selected. In the Attributes list of
the Expression Editor, select scaleY, the attribute controlled by the
expression. If you don’t see the scaleY attribute, scroll through the Attributes
list as necessary. Note that you can also use the Select Filter menu option to
customize how you search for your expressions within the Expression
Editor.

The expression you created previously appears in the expression text field:

Ball.scaleY = time + 1;

3 Change the expression to this:

Ball.scaleY = time/5 + 1;

By dividing time by 5, you’ll make the Y scaling increase one-fifth as fast as
with the previous version of the expression.

Note that you can use the keyboard commands Ctrl+c, Ctrl+x, and Ctrl+v to
copy, cut, and paste text in the Expression Editor and elsewhere in Maya.

4 Click Edit to update the modified expression. Clicking the Edit button does
the same action as clicking the Create button. The Create button exists only
for new expressions. The Edit button replaces the Create button when you
display an existing expression.

5 Play the animation to see the results of the new expression. Stop the
animation and go to the start time.

6 At this point and in subsequent steps, save the scene if you think you’ll want
to examine it at a later date.

Control multiple attributes of an object
You can change the expression to control two or more attributes of Ball as in
this example:

Ball.scaleX = time + 1;
Ball.scaleY = time + 2;
Ball.scaleZ = time + 5;

Maya scales the Ball at different rates for the X, Y, and Z dimensions.

Link multiple attributes of the same object
You can change the expression to link the value of one attribute to another as
in this example:
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Ball.scaleX = time + 1;
Ball.scaleY = Ball.scaleX;
Ball.scaleZ = Ball.scaleX;

The second statement sets Ball.scaleY to the value of Ball.scaleX. Because
you’ve set Ball.scaleX to the value of time + 1, Ball.scaleY also has the value
of time + 1. You’re linking one attribute’s value to another. The third
statement also sets Ball.scaleZ to the value of the attribute Ball.scaleX.

The advantage of this expression is that if you assign a different value to
Ball.scaleX in the first statement, the second and third statements
automatically receive the new value.

Control attributes in two objects
You can add an object to the scene and use the expression to control any of
its attributes also. For example, suppose you added a default NURBS or
polygonal cylinder named Drum to the scene. You could control attributes of
Ball and Drum with the same expression as in this example:

Ball.scaleY = time/2 + 1;
Drum.scaleX = time + 1;
Drum.scaleY = time + 1;

You can link attributes in different objects—so a change in one attribute
alters the behavior of the other. For example, you could cause Drum’s scaleY
value to always equal two times Ball’s scaleY value as in this example:

Ball.scaleY = time + 1;
Drum.scaleY = Ball.scaleY * 2;

If you decide to control attributes in two (or more) objects, you can select
either object to write the expression. In fact, any object or node in a scene can
be selected when you write an expression to control an object other than a
particle object.

Alternatively, you can write two (or more) expressions, for instance, one that
controls Ball.scaleY and one that controls Drum.scaleX and Drum.scaleY.

The advantage of creating separate expressions is that you’ll have two
expression names, each presumably named after the object and attribute
you’re controlling. Having two expression names makes it easier to find the
expression that controls the desired attribute.
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The advantage of using a single expression to control the attributes is that all
statements are in a single expression. You don’t need to edit two
expressions.

Beyond the lesson
When you write expressions, it is common to assign the built-in time variable
to an attribute so the attribute value predictably increases as the animation
plays. It’s also useful to link an attribute’s value to the value of another, such
as setting the ball’s scale Y and Z attributes to equal the scale X value.

Your expressions can control multiple attributes of the same object or of
multiple objects. You can alternatively write a single expression for each
attribute or object.

For more information on the various mathematical operators that are
possible with expressions, please refer to the online book Using Maya:
Expressions.

Behind the lesson
Although not shown in the lessons, you can decrease an attribute value
during playback by subtracting time from some number. Example:

Ball.scaleY = 3 - time;

This decreases the value of Ball’s scaleY attribute for the first three seconds
of playback.

When you use the predefined time variable, also be aware of the animation
start frame value. The lessons in this chapter use a start time of 0. In your
work, you might create an animation with a start time of 1. With Maya’s
default frame rate of 24 frames per second, time is 0.0417 at frame 1.

Because of this small time offset from 0, the prior lesson would have
required more steps and instructions to work with frame 1 as the start time.
For instance, suppose you use following expression with the start time at 1.

Ball.scaleY = time + 1;

If you go to the start time, the expression sets the initial value of Ball’s scaleY
attribute to time + 1, which equals 0.0417 + 1, or 1.0417. Because Ball’s scaleY
attribute was 1 when you created it, going to the start time sets scaleY to a
value 0.0417 larger than its initial value.
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This discrepancy means the Ball scaleY is larger than its scaleX and scaleZ
attributes in the first frame of the animation. Although the difference is
minor in this example, other cases might be more significant.

To start your animation at frame 1 and get the same result as the example,
you can subtract 0.0417 from the attribute:

Ball.scaleY = (time - 0.0417) + 1;

When you go to the start time, the expression sets Ball’s scaleY value to
(0.0417 - 0.0417) + 1. This equals 1, its original scaleY value.

LESSON 2 CONTROLLING ATTRIBUTES CONDITIONALLY

An expression can cause different actions to occur based on the current value
of an attribute or variable. In this lesson, you’ll use an expression to increase
the scale of a sphere for the first two seconds of animation, then stop scaling
and move it in a global Y-axis direction for the remainder of the animation.

Create an expression to conditionally control an
attribute

In the following steps, you’ll create a default sphere and
write an expression to increase its Scale Y attribute based on
the animation playback time. In the first two seconds of the
animation time, Scale Y increases with the value of the time. At two seconds
and thereafter, Scale Y no longer increases.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 291.

2 Create a NURBS or polygonal sphere at the origin with an X scale, Y scale,
and Z scale of 1. Name the sphere Balloon.

3 Go to the start time.

4 With Balloon selected, choose Window > Animation Editors > Expression
Editor.

5 Enter this expression:

if (time < 2)
Balloon.scaleY = time;
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This expression is an if statement. The if keyword causes the expression to
make a decision based on a comparison of two or more items. In this case,
the expression compares the value of time to the value 2.

The expression checks whether the value of time is less than two seconds. If
so, it does the assignment Balloon.scaleY = time. If time is not less than two
seconds, the assignment doesn’t occur.

Notice how the assignment Balloon.scaleY = time has been formatted so it
appears indented under if (time < 2). Maya ignores all indentation, extra
spaces, and blank lines between statements. We used the indentation to
make the expression easier to read. You could have also written the
expression as follows:

if (time < 2) Balloon.scaleY = time;

This isn’t as easy to read. Consistent, organized spacing is a good habit to
develop. This book shows examples of good spacing style.

6 Click Create to compile the expression.

Note that Balloon flattens in your scene view.

The expression executes when you click the Create button.
Because the animation is at frame 0, animation time is 0.
Because time is less than 2, Maya sets Balloon.scaleY equal
to the value of time, which equals 0.

A scaleY value of 0 flattens the object in the Y dimension.

7 Play the animation. The flattened Balloon’s scale increases along its Y-axis. It
inflates as the animation plays.

Important

When you compare the value of time to a number in an expression, Maya
interprets time as seconds rather than milliseconds, minutes, or any other
unit of time. In the example, Maya interprets 2 as two seconds.
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At 2 seconds and thereafter, Balloon no longer inflates.

When time equals 2 or more, the if condition is no longer
true. The statement that follows it, Balloon.scaleY = time,
no longer executes. The value of the scaleY attribute stays
at the last value it had before time became 2, specifically,
1.9583.

Recall that this example uses a frame rate of 24 frames per
second. The time and Balloon.scaleY have these values at
various frames:

The if statement’s condition, (time < 2), is a comparison. The condition must
be surrounded by parentheses to isolate it from assignment that follows it.

The < in the condition is a relational operator. A relational operator tests
how one value relates to another. In the example, the < tested whether time
is less than 2.

Besides the < operator shown in this example, there are several other
relational operators such as >, >=, ==, and so on. See Using Maya: Expressions
for details.

Frame Time
(seconds)

Balloon.scaleY
(time)

0 0 0

1 0.0417 0.0417

2 0.0833 0.0833

3 0.125 0.125

24 1.0 1.0

47 1.96 1.9583

48 2.0 1.9583

49 2.04 1.9583
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8 Stop the animation and go to the start time. Balloon flattens again because
the scaleY attribute becomes 0 when you go to the start time. Time is 0, so
scaleY is 0.

Add other conditional statements to the expression
You can make Balloon rise after it inflates by adding another if statement to
the expression.

1 Change the expression to this:

if (time < 2)
Balloon.scaleY = time;

if (time >= 2)
Balloon.translateY = time;

2 Click Edit to compile the expression.

3 Play the animation. Balloon inflates for two seconds. After two seconds,
Balloon stops inflating and its position skips from a Y-axis position of 0 to 2.
You’ll eliminate the motion skip in a later step.

The new if statement increases the translateY position of Balloon after the
animation time rises above two seconds. The >= symbols mean greater than
or equal to. Whenever time is greater than or equal to 2, the expression
assigns Balloon’s translateY the value of time. The translateY value therefore
increases for the rest of your animation’s playback range.

Notice that a semicolon ends each statement for a particular condition.
Forgetting a semicolon after each statement causes a syntax error, and the
changes you’ve made to the expression won’t take effect.

Important

Always examine the Script Editor for error messages after you edit an
expression and click the Create button. If you alter a previously successful
expression and a syntax error occurs, Maya executes the previous
successful expression when you play the animation. This might make you
believe your changes took effect. Error messages are preceded by the
text // Error:.
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4 Stop the animation and go to the start time. Balloon flattens but doesn’t
return to the origin. (If Balloon has risen out of view, adjust your camera to
see it.)

Balloon doesn’t return to the origin because the expression doesn’t assign
Balloon a starting point for the beginning of the animation.

5 To make Balloon return to the origin, change the expression to this:

if (time < 2)
Balloon.translateY = 0;

if (time < 2)
Balloon.scaleY = time;

if (time >= 2)
Balloon.translateY = time;

The new first statement sets Balloon.translateY to 0 whenever time is less
than 2.

Note that you can put the three statements in any order in this example.
When Maya plays each frame, it executes each statement in the expression in
the order listed. In this example, the statements work independently, so their
order doesn’t matter.

We put the statements in the order of time execution because it’s easier to
see the logic of the expression. If you ever need to change the expression,
you’ll be able to grasp the expression’s actions more quickly.

6 Click Edit.

7 Stop the animation and go to the start time.
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The flattened Balloon returns to its correct position at the
origin.

8 Play the animation. Balloon inflates for two seconds, then
rises.

Fix a problem in the expression
As mentioned before, Balloon skips from Y-axis position 0 to 2 after two
seconds of animation play. You can eliminate the skipping and make Balloon
rise smoothly from the origin.

1 Stop the animation and go to the start time.

2 Change the expression as follows. (Changes are displayed in bold print.)

if (time < 2)
Balloon.translateY = 0;

if (time < 2)
Balloon.scaleY = time;

if (time >= 2)
Balloon.translateY = time - 2;

3 Click Edit.

Play the animation. Balloon inflates for 2 seconds, then rises slowly with
time from its position at the origin.

When time is greater than or equal to 2, the
translateY position of Balloon becomes 2 minus
2, which is 0. As time increases beyond 2
seconds, the translateY position increases in the
same increments that time increases.

4 Stop the animation and go to the start time.

Use an else statement instead of multiple if
statements

The expression achieved the desired result, but with unnecessary
complexity. You can use an if-else statement to make the statement more
compact and easier to read.

1 Change the expression to this:
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if (time < 2)
Balloon.translateY = 0;

if (time < 2)
Balloon.scaleY = time;

else
Balloon.translateY = time - 2;

2 Click Edit.

3 Play the animation.

This additional variation on the if conditional statement includes the else
statement. It is used as an option when the if statement condition is not true.
The else keyword sets Balloon.translateY to time - 2 when (time < 2) is false.
In English terms, the combination of the if and else statements says: If time is
less than two seconds, set Balloon.scaleY to the value of time. Otherwise (when time
is greater than or equal to two seconds), set Balloon.translateY to time minus two.

At any instant in the animation’s playback, either Balloon.scaleY = time
executes or Balloon.translateY = time - 2 executes. Under no circumstances
can they both execute. The else statement executes only when the if
condition that precedes it is false.

The first if statement executes whenever time equals 0. It is unrelated to the
if-else statements.

Using else statements instead of multiple if statements makes an expression
simpler to read. If you use an if-else construction instead of a lengthy list of
if statements, you’ll also improve the execution speed of the expression. This
improves your animation’s playback and rendering speed.

Either expression is valid. If using the if-else construction seems confusing,
stick with multiple if statements.

You can accomplish most expression animation tasks with several if
statements strung after one another.

4 Stop the animation and go to the start time.

Make the expression easier to read
You can refine the expression to make it easier to read.

1 Change the expression to this:

if (time < 2)
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{
Balloon.translateY = 0;
Balloon.scaleY = time;
}

else 
Balloon.translateY = time - 2;

We removed the second if statement:

if (time < 2)

In its place, we enclosed the remaining statements with braces { and }. Maya
evaluates both the statements between the braces if the condition (time < 2)
is true. Setting Ball.translateY to 0 here instead of in a separate if statement
makes the expression easier to read and comprehend. Reducing the
statement in this way also makes it more efficient for Maya to process and
easier to troubleshoot if you encounter a problem.

Note that you can put multiple statements between braces for an else
statement, just as you do for an if statement.

2 Click Edit.

3 Play the animation. The animation plays exactly as before with the new
expression.

4 Stop the animation and go to the start time.

Refine the animation
You can further refine the animation by expanding Balloon more slowly.

1 Change the expression to this:

if (time < 2)
{
Balloon.translateY = 0;
Balloon.scaleY = time * 0.6;
}

else 
Balloon.translateY = time - 2;

The asterisk (*) multiplies time by 0.6.

2 Click Edit.

3 Play the animation.
INSTANT MAYA

306



EXPRESSIONS | 10
Controlling attributes conditionally
The scaleY attribute increases at 60% of the value
of time, so Balloon expands slower during
playback. (The number 0.6 equals 60%.) By the
time Balloon starts to rise, it has expanded to the
size of a typical balloon.

To know whether to multiply time by 0.6 or some
other number, you need to experiment.

For example, you might multiply by various percentages such as 0.2, 0.5,
0.75, and finally 0.6. The 0.6 creates a life-like balloon shape at two seconds.

4 Stop the animation and go to the start time.

Further refine the animation
You can further refine Balloon’s appearance by eliminating the flattened
Balloon that appears at the origin when you go to the start time. You can
also scale Balloon at different rates along each of its three axes.

1 Change the expression to this:

if (time < 2)
{
Balloon.translateY = 0;
Balloon.scaleY = time * 0.6;
Balloon.scaleX = time * 0.5;
Balloon.scaleZ = time * 0.5;
}

else 
Balloon.translateY = time - 2;

2 Click Edit. At frame 0, Balloon disappears from view because its scale
attributes are 0.

The scaleX, scaleY, and scaleZ attributes are 0 at frame 0 because time is 0.
Any number multiplied by 0 is 0.

3 Play the animation. As time increases, the value of Balloon’s scale attributes
increase.
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Because the expression sets scaleX and scaleZ to
50% of the value of time, these dimensions scale
slower than scaleY, which is set to 60% of the
value of time. Balloon scales faster in height
than in width or depth. This is true for many
real balloons.

4 Stop the animation and go to the start time.

5 Save the scene if you plan to examine it later.

Beyond the lesson
You can accomplish many expression tasks with several if statements strung
after one another. However, using else statements instead of multiple if
statements makes an expression simpler to read.

If statements and else statements are two of the most common programming
features available in expressions. If you’re familiar with programming, be
aware that you can write expressions with an extensive syntax similar to the
C language.

LESSON 3 CONTROLLING PARTICLE ATTRIBUTES

You can use an expression to control attributes of particle objects. Particle
expressions may be more complex than other types of expressions. For
example, you can write an expression to control all particles in an object the
same way, or you can control each particle differently. The following lesson
describes how to control color attributes of a particle object.

Create a particle object
In the following steps, you’ll create a particle object made of 100 randomly
positioned particles displayed as tiny spheres. You’ll also dynamically add
an attribute to the particles. To color particles with an expression, Maya
requires you to dynamically add the appropriate attribute.

1 Make sure you’ve done the steps in “Preparing for the lessons” on page 291.

2 From the Dynamics menu set, select Particles > Particle Tool > ❒ .
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3 In the Tool Settings window, click Reset Tool. For the Particle Name, enter
Bubbles. For the Number of Particles, enter 100. Specify a Maximum Radius
of 5. Click in the scene view (roughly in the center) to create the 100-particle
object.

4 Select the Selection Tool so that particles become selected.

5 With Bubbles selected, display the Attribute Editor. To display the particles
as small spheres, select Spheres for the Particle Render Type (in the Render
Attributes section). Click the Current Render Type button. Adjust the Radius
of the spherical particles as desired.

6 In the Add Dynamic Attributes section of the Attribute Editor, click the
Color button. A window appears that prompts you to choose whether to add
the attribute per object, per particle, or connected to a shader.

7 Turn on Add Per Particle Attribute, then click the Add Attribute button. This
adds an rgbPP attribute to the particle shape node for Bubbles. Because
you’re adding this attribute as a per particle attribute, you can give each
particle a different color.

Use a creation expression to set a constant color
To set an attribute that doesn’t change during the animation (the particle
color), you’ll use a creation expression. A creation expression executes when
you go to the start time. It doesn’t execute while the animation plays. (For
emitted particles, a creation expression executes for a particular particle
when it is emitted.)
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1 In the Per Particle (Array) Attributes section of the Attribute Editor, right-
click the rgbPP box and select Creation Expression from the pop-up menu.
Note that the shape node of Bubbles (BubblesShape) is displayed in the
Expression Editor.

When you use an expression to control particle attributes, make sure the
selected object in the Expression Editor is a particle shape node, not the
transform node of the particle object. If a particle object’s transform node is
selected, move the mouse pointer to the scene view and press the down
arrow key to select the particle shape node.

2 Enter this expression:

BubblesShape.rgbPP = <<1,0,0>>;

When you click the Create button in the Expression Editor, Maya checks the
syntax of the expression. Assuming you made no typing errors, the
expression executes once for each of the 100 particles.

The expression colors all particles in the object red. The double angle
brackets << and >> enclose a vector that sets the red, green, and blue
components of the rgbPP attribute to 1, 0, and 0. In the RGB color scheme,
this gives the object a red color.

If the particles are uncolored, check that you’ve turned on Shading > Smooth
Shade All. This shading mode is necessary for particles to show the color
assigned in an expression.

3 Play the animation. The particles remain red.
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Use a runtime expression to change color during playback
There is one other type of expression you can create for a particle object
(shape node)—a runtime expression. By default, a runtime expression
executes each frame during playback. A runtime expression does not execute
when you go to the start time (or at the time in which a particle is emitted).

You’ll often create both types of expressions for a particle object—a creation
expression that initializes an attribute value in the first frame, and a runtime
expression that controls the attribute value in subsequent frames.

The following steps show how to create a runtime expression to change
particle color during playback.

1 In the Per Particle (Array) Attributes section of the Attribute Editor, right-
click the rgbPP box and select Runtime Expression from the pop-up menu.

2 Enter this runtime expression:

BubblesShape.rgbPP = sphrand(1);

3 Click the Create button to compile the expression.

4 Play the animation.

The runtime expression controls the rgbPP attribute during playback.
Because rgbPP is a per particle attribute, the runtime expression executes for
each particle in the object each frame. For each particle, the expression
assigns the rgbPP attribute the output from the execution of the sphrand
function with an argument of 1. The sphrand function is one of Maya’s many
built-in mathematical functions that are useful in expressions.

The sphrand function with an argument of 1 assigns each particle’s rgbPP
color a random vector. The vector represents a random point in a spherical
region of radius 1. The left, middle, and right rgbPP color components get a
value no less than -1 and no greater than 1. (R, G, and B values less than 0
are treated as 0—a black color).
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The sphrand function returns a different random
vector each execution, so each particle receives a
different random rgbPP value, and therefore, a
different color. The color changes each frame.

5 Rewind and play the animation again. The
particles become red when you go to the start time,
and random colors during playback.

Slow the change of color
You might have trouble seeing the color of a particle in any instant because
the color changes so quickly. You can slow the change of colors to create a
flashing Christmas light effect. The following steps make the particles
change colors every second of animation.

1 Change the runtime expression to this:

if ((frame % 24) == 0)
BubblesShape.rgbPP = sphrand(1);

This expression uses the modulus operator (%) to control when the rgbPP
attribute of the particles receives a random color. The modulus operator
returns the remainder after division. For example, 24 divided by 24 returns
0, but 25 divided by 24 returns 1. (Dividing 25 by 24 equals 1 with a
remainder of 1.)

If the value of frame divided by 24 is equal to any number with a remainder
of 0, the assignment to BubblesShape.rgbPP occurs. In other words, the
assignment occurs when frame equals 24, 48, 72, and so on. At an animation
rate of 24 frames/second, the assignment happens once each second.

Note

You can use only one creation and one runtime expression per particle
object (shape node) in your scene. To control multiple attributes of a single
particle object, you must do so within one creation expression and one
runtime expression. You can’t create a separate expression for each
attribute as you can for other types of objects. You therefore don’t need to
select an attribute from the Expression Editor’s Attributes list.
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The == symbols mean is equal to. In conditional statements, be careful to type
== rather than =. The = symbol means assign the value to.

2 Rewind and play the animation again. When you go to the start time, the
particles turn red because the creation expression executes. When the
animation plays, the particles receive a random color once each second.

Note that you can change the beginning red color to random colors by
changing the creation expression to this:

BubblesShape.rgbPP = sphrand(1);

This is the same expression as the runtime expression.

3 Save the scene if you plan to examine it later. This concludes the lesson.

Beyond the lesson
For a particle object, you typically create two expressions—a creation
expression that initializes an attribute value in the first frame, and a runtime
expression that controls the attribute value in subsequent frames. (Creation
and runtime expressions exist only for particle objects, not for other types of
objects.)

Although this lesson described how to color stationary particles as a simple
way to describe creation and runtime expressions, it’s more typical to use
particle expressions to create:

• sophisticated particle motion and lifespan, for instance, the movement and
fading of exploding fireworks

• complex colors for emitted particles, for instance, rocket exhaust flames

• complex colors and movement of particles following collision with
geometry, for instance, sparks resulting from fired bullets

1 second 3 seconds2 seconds
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Creating such effects requires experience and experimentation. Expression
writing can be as complex as computer programming. A detailed
understanding of expression execution and syntax is essential. You also need
to become familiar with the built-in mathematical functions such as the
sphrand function introduced in this lesson.

For further information and related techniques, refer to the online book,
Using Maya: Expressions.
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MEL (Maya Embedded Language) is a powerful command and scripting
language that gives you direct control over Maya's features, processes, and
workflow. This chapter includes a lesson that describes techniques available
in MEL, Maya’s command language. As you select menu items or otherwise
use the interface, Maya performs the operations by internally running MEL
commands. In fact, much of Maya’s user interface is built using MEL scripts
and procedures. You can type the same MEL commands directly as a quick
alternative to selecting menu items or doing other actions.

You can organize MEL commands into reusable script files that let you:

• automate tasks you might otherwise do more slowly or tediously with the
user interface

• use additional Maya features

• create custom user interfaces

• perform specialized workflows

• create new effects

For example, you can write a MEL script that creates several lights to be
used as the primary lighting for a number of indoor scenes. Whenever you
create a new scene with an indoor environment, you run the script to create
the primary lights. You can even put a button on the shelf so you can run the
script at the click of the mouse.

Although MEL is technically a scripting language, MEL has features that are
worthwhile and easy to learn even if you have no programming experience.

Note

Some MEL commands are not available within Maya Personal Learning
Edition. You will not be able to fully complete this tutorial if you are a
Maya Personal Learning Edition user.
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PREPARING FOR THE LESSON

To ensure the lessons work as described, do these steps before beginning:

1 Create a new scene.

2 Use a computer that has an Internet connection and Web browser. Part of the
lesson requires that you download material from our Web site at
www.aliaswavefront.com.

LESSON: MEL BASICS

In this lesson, you’ll learn MEL techniques to speed workflow. Specifically,
you’ll learn how to:

• Enter MEL commands in place of selecting menu items.

• Create a Shelf button to run a series of commands.

• Run and create scripts that execute a series of commands.

Use MEL commands
In the first part of the lesson, you’ll learn how to type a MEL command as a
substitute for selecting a menu item.

1 Select Window > General Editors > Script Editor.

History

Command input
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The top part of the Script Editor shows the command history—a running list
of commands that you or Maya have executed. The results of the commands
are listed between pairs of “//” characters. The meaning of the results will
be obscure until you become familiar with MEL scripting.

The bottom (white) part of the window is the input section where you enter
commands or scripts. If you make a typing mistake while entering
commands, an error message appears in the history section.

In the input section, type the following command exactly as shown. Entries
are case sensitive. The semicolon (;) signifies the end of the command.

sphere;

To execute the command, press Enter on the numeric part of your keyboard.
The Enter key you normally use does not execute a command. It starts a new
line so you can type several commands before executing them.

After you execute the command, Maya creates a NURBS sphere at the origin.

2 Enter the following command to delete the sphere.

delete;

This deletes the selected object, which, by default, is the last object you
created.

Note that you can alternatively enter individual MEL commands in the
Command Line near the lower-left corner of the Maya window. This saves
you the time it takes to display the Script Editor. In addition, the Command
Line keeps a history of commands which can be readily accessed using the
up and down arrow keys when working in it.

3 Create a bigger sphere:

sphere -radius 5 -name Planet;

The sphere, named Planet, has a radius of 5 grid units.

4 Move Planet to a new position:

move -relative 3 0 0;

This moves the selected object to a position 3 units in an X-axis direction
(and 0 in Y and Z), relative to its current position. The option -relative is
known as a flag (or argument).
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5 Select Help > MEL Command Reference to see a list of commands sorted by
name. Find the move command and click its link to see the command
description.

Maya includes command reference material that describes how to use each
command and its flags. Alternatively, you can get quick help on a particular
command directly in the Script Editor by typing the word help followed by
the name of the command you wish to obtain more information about. For
example, typing help move in the Script Editor will provide information
about the various flags available to modify the move MEL command.

In the Flags section, you will see -r/-relative and a description of the flag.
The slash between -r and -relative means that you have a choice of typing -r
or -relative. So you could have typed the following command instead of the
prior one:

move -r 3 0 0;

6 Delete Planet.

Create a Shelf button for a sequence of commands
In the next steps, you’ll create a Shelf button that executes three commands.
The commands create a pair of lights that you can use for a default simple
lighting arrangement in your scenes.

1 In the Script Editor, select Edit > Clear History. This removes all text from
the history section of the Script Editor to lessen clutter.

2 Select Create > Lights > Directional Light. A directional light is similar to the
sun. Its parallel rays strike all objects in the scene from a single direction.

3 Use the Rotate Tool to rotate the light’s Rotate X value to -35 or so. To ensure
that the Shelf button works correctly, use the Rotate Tool, not the Channel
Box or Attribute Editor. This rotational change gives the light a downward
sloping direction.

Do not use the Channel Box or Attribute Editor when changing attributes for
the purpose of creating custom Shelf buttons as these editors set attributes
for uniquely named nodes vs. executing the commands for whatever is
currently selected.
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4 In the history section of the Script Editor, highlight the following command
text:

defaultDirectionalLight(1, 1,1,1, "0", 0,0,0);
rotate -r -os -35.048621 0 0 ;

5 Middle-mouse drag the text to the input section of the Script Editor.

6 Select Create > Lights > Ambient Light. An ambient light emits light
uniformly in all directions. It’s useful for simulating low-intensity indirect
lighting, like lighting reflected off the walls of a room.

7 In the history section of the Script Editor, drag through the following text to
highlight it:

defaultAmbientLight(1, 0.45, 1,1,1, "0", 0,0,0, "1");

8 Middle-mouse drag the text to the line below the existing two lines in the
input section. It will appear as follows:

defaultDirectionalLight(1, 1,1,1, "0", 0,0,0);
rotate -r -os -35 0 0 ;
defaultAmbientLight(1, 0.45, 1,1,1, "0", 0,0,0, "1");

If the dragged text is positioned to the right of the second line rather than on
its own line, position the cursor to the left of defaultAmbientLight and press
Enter on the alphanumeric part of the keyboard.

With the desired statements in the input section, you could execute them by
pressing Enter (numeric pad). Instead, you’ll create a button on the shelf so
you can execute the commands now or later, in any scene you create.

9 Select the General Tab on the Shelf so it is displayed. The shelf is the row of
icons immediately above the scene view.
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10 Highlight the three lines of text in the input section and select
File > Save Selected to Shelf in the Script Editor.

A button named MEL appears on the shelf.

11 Click the MEL button. The command text executes and creates the lights.

If you later decide to remove the button from the shelf, you can middle-
mouse drag it to the Trash icon on the shelf.

If you forget the purpose of a button, move the pointer over it. A pop-up box
lists the first command or two that the button executes. For easier
recognition, you can optionally customize the display of a button by adding
an overlay label to it.

You can edit the contents of Shelf items by selecting Window > Settings/
Preferences > Shelves. See Using Maya: Essentials for further details.

Observe the effect of the MEL button
Now you’ll use the MEL button to create the lights and observe their effect
on a sphere.

1 Delete the lights from the scene or create a new scene.

2 Create a polygonal sphere.

3 In the perspective view, press 5 on your keyboard (for Shading > Smooth
Shade All).

The new MEL button
will appear here.

Directional light icon

Ambient light icon
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4 Click the MEL button to create the directional and ambient lights. Maya
creates the lights at the origin. The icons representing them are hidden by
the surface of the sphere.

5 By default, Maya lights the scene with a single invisible directional light that
points in the same direction as the scene view. To light the scene with the
lights you created, select Lighting > Use All Lights. To return to the default
lighting for comparison, select Lighting > Use Default Lighting.

Obtain a MEL script from www.aliaswavefront.com
A MEL script is a file containing a collection of MEL procedures and
commands. As mentioned in the lesson’s introduction, you can extend
Maya’s capabilities with scripts. In the next steps, you’ll obtain a free script
available on our customer Web site.

1 Create a new scene before starting the next part of the lesson.

2 Select Help > Alias|Wavefront on the Web to point your Web browser to the
the Alias|Wavefront web site. Alternatively you can launch your Web
browser. Go to www.aliaswavefront.com/maya/mel.

Tips

To create a shelf button for a single menu item, for instance,
Display > Grid, hold down Shift-Ctrl-Alt while selecting the menu item.

Default lighting Lighting from MEL button
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3 The resulting page provides an overview of MEL scripts and a list of scripts
available on this site. (Be sure to read the Terms and Conditions of Use
document available from this page.)

4 In the Modeling section of the page, shift-click spiral.mel to obtain a script
that creates a spiral curve based on values you supply for height, radius, and
number of revolutions (“rounds”).

5 In the file browser that appears, select the appropriate destination directory
for the scripts file. For example:

(UNIX) ~username/maya/scripts

(Windows)
drive:\Documents and Settings\username\My Documents\maya\scripts

Note that you would substitute your specific hard drive letter and login
name where username and drive appears in the above paths.

Examine the MEL script contents and execute the scripts
To see how to execute the script, you need to examine the contents of the
spiral.mel script for comments and clues.

1 In the Script Editor, select File > Open Script. In the resulting browser, open
spiral.mel. The script appears in the Input area of the Script Editor.

2 Read the comments in the file—the text following the // characters. The
comments describe the purpose of the script in addition to copyright and
disclaimer information.

Notice the following line in the script:

global proc string spiral( float $ht, float $radius, float $numRounds)

Note

In the dynamic world of the Internet, Web site contents are subject to
modifications to suit customer needs. The following instructions were
accurate at the time this document was published. If the instructions seem
incorrect, peruse our Web site for likely alternative routes to the free MEL
scripts area.
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The three variables within the parentheses, $ht, $radius, and $numRounds
are arguments to the procedure spiral. They represent values that you must
enter when you execute the spiral.mel script in a later step. The variables
specify the height, radius, and number of rounds for the spiral curve that
will be created when you execute the script.

The entry float is short for floating point—the data type of an argument. A
floating point number is a number with a decimal point rather than an
integer.

3 To execute the script, enter the following text in the input section of the
Script Editor. Remember to press the numeric Enter key after the text.

spiral 5 2 10;

4 Maya finds the spiral.mel script in the scripts directory and executes the
script contents to create the following spiral curve of height 5, radius 2, and
10 rounds:

The script file must be in the appropriate scripts directory or your script will
not execute when you enter its name in the input section of the Script Editor.

Create and execute a script that creates a user interface

In the next steps, you’ll create a MEL script, save it to disk, and execute it.
The script creates a user interface slider for controlling an attribute value.
The advantage of creating a script file rather than a MEL button is that a
script is portable. You can copy a script to another user’s scripts directory
easily.
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1 In the Script Editor, select Edit > Clear All to erase all text from the history
and input sections of the Script Editor.

2 In the input section of the Script Editor, type the following text. In the text
after the dotted line, use the exact lowercase and uppercase letters shown:

// Creation Date: <Date>
// Author: <Your Name Here>
//
// Description: This script creates a custom slider that 
// controls the Translate Y attribute of an object named 
// pSphere1.
// -----------------

global proc MySliderMaker()
{

window -title "Slider for pSphere1.ty" SliderTest;
columnLayout;
attrFieldSliderGrp

-min 0
-max 10
-at "pSphere1.ty";

showWindow SliderTest;
}

Statements that follow a pair of backslash characters (//) are comments for
other people who might read the script later to extend its capability. Maya
ignores these statements. The remaining text is a procedure—a collection of
MEL commands and operations contained in braces and given a name.

The procedure’s name is MySliderMaker. In technical terms, the procedure is
a global procedure, which means it can be executed from any other script in
Maya.

3 Drag through the entire text to highlight it.

Note

The Script Editor - File > Save Selected option is not available to users of
Maya Personal Learning Edition.
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4 From the Script Editor menus, select File > Save Selected. In the file browser
that appears, enter the name MySliderMaker.mel. By default, Maya
automatically saves the text as a script file in the appropriate destination
directory. This is the same directory where you copied a MEL script from
aliaswavefront.com previously in the lesson.

Also, the base name of the script file must be the same as the name of a
global procedure in the script. In this example, the script file has only one
global procedure, MySliderMaker, so you must name the script file
MySliderMaker.mel. (Script files always end with the extension .mel.)

If the system reports an error with your procedure it may mean you’ve made
an error when typing. You will need to either correct the error or delete the
global procedures name and start again. If you are new at writing MEL
scripts, it’s best to position the global procedure (the one with the same
name as the script file) as the last procedure in the script. Your script will be
more likely to run without error.

The first line of the MySliderMaker.mel script is a procedure declaration. It
informs the software that the lines between curly braces ({ }) are a related
series of operations.

In general, a global procedure has this form:

global proc procedureName ( )
{
commands
}

Maya executes the commands within the curly braces every time you enter
the corresponding MEL script filename in the Script Editor. Be aware that
using global procedures might cause errors if another script contains an
identical procedure name. There are techniques involving the use of local
procedures for avoiding such errors. See Using Maya: MEL for details.

5 Select Create > Polygon Primitives > Sphere. By default, this creates a sphere
named pSphere1. Press 5 to display the sphere with smooth shading.

6 Type MySliderMaker in the input section of the Script Editor and press Enter
on the numeric keypad. Do not type the .mel extension. Unlike the script you
copied from www.aliaswavefront.com earlier in the lesson, you do not type
any arguments (for instance, -5) after the script name. Some scripts require
you to type arguments. Others do not.
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The MySliderMaker.mel script executes. It displays a custom slider that
controls the translateY attribute of the object named pSphere1. (Drag the
right edge of the slider window, if necessary, to see the entire slider.) Drag
the slider back and forth to move the sphere up and down.

Next, you’ll learn about the four commands that make up the
MySliderMaker procedure on a line-by-line basis. The commands are listed
below:

window -title "Slider for pSphere1.ty" SliderTest;
columnLayout;
attrFieldSliderGrp -min 0 -max 10 -at "pSphere1.ty";
showWindow SliderTest;

The first command creates a window with a title bar (the -title flag) that
contains the text string Slider for pSphere1.ty. The internal name of the
window is SliderTest. The window is displayed only when the fourth
command executes.

The second command creates the window layout in a column format.

The third command creates a slider group that consists of the label, text
entry field, and slider. The slider value can range from a minimum of 0 to a
maximum of 10. The entry -at pSphere1.ty specifies that the slider controls
the translate Y attribute (ty) of pSphere1.

Beyond the lesson
If you have never used a scripting or programming language, a few concepts
in this lesson might seem foreign. With a little study and experimentation
with MEL, you’ll quickly find ways to work more productively with Maya.

To become a successful MEL user, you need to learn the basics of the
language. For details on the language and example scripts, see Using Maya:
MEL online. Also be aware that the online MEL command reference includes
examples of command usage at the bottom of most command descriptions.

If you have used a scripting or programming language before, you’ll have
little difficulty working with MEL. If you’ve worked with the C language,
you’ll have a head start; MEL uses many of the language elements of C,
including data types and flow control methods.
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Behind the lesson
Early in the lesson, you moved the following three lines of text from the
Script Editor to a MEL button:

defaultDirectionalLight(1, 1,1,1, "0", 0,0,0);
rotate -r -os -35 0 0 ;
defaultAmbientLight(1, 0.45, 1,1,1, "0", 0,0,0, "1");

For brevity, we referred to the three lines as MEL commands. Actually, only
the second is a command. The other two lines are procedures.

When you use Maya’s interface, the history section of the Script Editor lists
commands and procedures as they execute. The listed procedures are part of
the Maya software created by Alias|Wavefront programmers.

Although the procedures often have similar results to MEL commands, the
syntax is different and you won’t find documentation of how to use them in
the online MEL command reference.

If you want to know whether a statement you see in the Script Editor is a
command or procedure, enter the command whatIs in the Script Editor as in
the following example:

whatIs defaultDirectionalLight;

Depending on your computer platform and version of Maya you’ll see a
response in the Script Editor similar to this:

// Result: Mel procedure found in: drive:/aw/Maya4.5/
scripts/others/defaultDirectionalLight.mel

This means that defaultDirectionalLight is a procedure in a script named
defaultDirectionalLight.mel. You can tell that the script is part of the Maya
software based on its location. The custom scripts you create instead must
reside at .../username/maya/scripts. Be cautious if you decide to modify the
supplied Maya software scripts in case you accidentally change one by
mistake. You may wish to first duplicate and rename it before modification.
Create and modify only your own scripts.

If you want to create lights with a MEL button, you don’t need to use
internal procedures such as defaultDirectionalLight. You can instead use
MEL commands such as directionalLight. As usual with Maya, there are
several ways to get the results you want.

You are not required to use the command history in the Script Editor when
you create a MEL button. It’s there for convenience.
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By default, not all Maya operations appear in the command history as you
use the interface. Maya filters out many of the actions you usually don’t
need to see. To see all operations, select Script > Echo All Commands (from
the Script Editor window). This might be necessary if you are having
difficulty getting the desired result from a text you copy to a MEL button.

Note

There is no guarantee that the history text you copy to a MEL button will
have the same result as the user interface actions from which the text was
generated. There are subtle issues in MEL command sequences that make
them work in one workflow, but not in another. You need to check the
results and make modifications as necessary.
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Polygon Proxy Mode 83
Polygonal modeling 43
Polygons to Subdiv 83
primitives 74
printing tutorials 14
procedure

global MEL 324
MEL 324

Push or Pull
Sculpt Surfaces Tool 65

R
Radius 281

Circle 76
Sphere 63

Radius(L) 69
Radius(U) 66

Paint Cluster Weights
Tool 165

Paint Skin Weights Tool 154

raft
floating on sea 122

rain 241
ramps 243, 247
Range Slider 99
Real-time (24 fps) 102
Refine Selected Components 93,

95
Reflection

3D Paint Tool 281
Sculpt Surfaces Tool 71

Reflection X 281
relative

clip attribute values 129
Render Globals window 188
Render Sequence 247
render types, setting for

particles 240
Render View 287
Render View window 187
rendering

lights and cameras 214
overview 181
shading surfaces 196
software 185
standard 185
view region to be
rendered 186

rendering particles 247
Replace

cluster weights 164
Paint Cluster Weights
Tool 165

resolution
changing 188

return to start time 99
revolve

curve into surface 60
rewind 99

rgbPP attribute 242
use in expressions 309

ribs
joints 140, 141

ridges
subdivision surface 95

rigid bodies 248
active 251, 252
collisions 248
constraints 248
passive 252

rigid skinning 158
root

skeleton 143
Rotate Tool 35
runtime expressions 311

assigning rgbPP in 311

S
Save As 279
Save Selected

MEL 325
Scale 130

Paint Skin Weights Tool 154
Scale Tool 20
scale, multiplying by

percentage 307
scene view vs Render View 187
Script Editor 316

opening script 322
scripts

directory location 322
executing 323
MEL 315
obtaining free 321

scrub 101
Sculpt Polygons Tool 57
Sculpt Surfaces Tool 63, 65
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INDEX
Section Radius 238
Select Character Set Node 125
semicolon terminator

expressions 293
MEL 317

Set Driven Key 113
Graph Editor 115

Set Initial Position 251
Set Key 100
Set Preferred Angle 144
shading surfaces 196
Shape

Sculpt Surfaces Tool 70
Shelf button

create 318
Show Manipulator Tool

extruding polygons 46
Show Region Marquee 188
Size X, Size Y 280, 287
skeletons 135

moving group node 146
posing and animating 144
root 143

skin 148
skin weights 150, 151

modify 153
Smear, 3D Paint 286
Smooth

Paint Cluster Weights
Tool 166

Paint Skin Weights Tool 154
polygons 55
Sculpt Surfaces Tool 65

Smooth Bind 150
Smooth Shade All 183
smooth skin 150

influence object 155
unnatural deformation 151

Snap to Grids 56

Snap to Points 76
software rendering 185
source clip 130

Graph Editor 133
spans, displaying 64
Spheres

Particle Render Type 309
sphrand function, use with

random color 311
spinal column

joint chain 139
spine

parenting arms and legs 143
spiral.mel 322
Split Polygon Tool 46
Split Vertex 47
Spring constraint 253
Stamp Spacing 284
Standard Mode 90
Start Time 99
statements

expression order 303
static channels

remove 109
Streak render type 241
Stylus Pressure 69, 280
Subdivide

polygons 53
subdivision surfaces 81

converting polygons 82
cutting 90
Extrude Face 86
extrusion manipulator 88
selecting faces 86
selecting vertices 89
Split Polygon Tool 84

surface
normals 66
pole 68

syntax, errors 302

T
Tail Fade 242
Tail Size 242
Tangent

Graph Editor 111
handles in Graph Editor 106

target
blend shape 167

template 136
Test Render 246
ticks

red key 100
time

expressions 300
predefined variable 294
value at different frames 294

Time option 182
Time Slider 99
Tool Settings 279
track 126
transform nodes

not used for particle
expressions 310

transparency, skin 150
Trash icon

Shelf 320
Trax Editor 123

general workflow 132
Twist 146
Two Panes Stacked 124, 287

U
U Dir

Sculpt Surfaces Tool 71
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INDEX
U Value
path animation 120

UI Elements 279
Update on Stroke 288
Use All Lights 321
Use Default Lighting 321

V
V Dir

Sculpt Surfaces Tool 71
Value

Paint Cluster Weights
Tool 165

velocity
controlling in particles 239

vertices
selecting 47
subdivision surface 89

Visor
Trax Editor 130

volume axis field 234
Volume Shape 235

W
whatIs command 327

X
X-Ray 150
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