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About

Animation Basics

The animation basics chapter contains a general overview of the fundamental
concepts, terms, and modules associated with animation in Alias® Maya® .

Animation in Maya

Maya animation provides you with the powerful tools you need to bring the
characters and objects in your scenes to life. These tools give you the freedom to
animate any attribute of an object and the control you need to successfully
transform joints and bones, IK handles, and models over time.

In this guide, you can find information on the various animation techniques in
Maya, how to use the different types of animation, and how to preview, playback,
and save your animations.

This book focuses on the following types of animation in Maya:

e Keyframe animation lets you transform objects or skeletons over time by
setting keyframes. For example, you can keyframe the joints and IK handles
of a character’s arm to create an animation of its arm waving. For more
information, see "Keyframe Animation” on page 67.

e Driven key animation lets you link and drive the attributes of one object with
those of another object by setting driven keys. For example, you can key a
character’s X and Z translations as driver attributes and a door model’s
Y rotation as the driven attribute to create an animation of a character and a
swinging door. For more information, see “Driven keys” in Chapter 2.

e Nonlinear animation lets you split, duplicate, and blend animation clips to
achieve the motion effects that you want. For example, you can use nonlinear
animation to create a looping walk cycle for one of your characters. For more
information, see "What is nonlinear animation?” on page 177.

e Path animation lets you set a curve as an animation path for an object. When
you attach an object to a motion path, it follows the curve during its
animation. For example, when you assign a car model to a motion path that
follows a road in your scene, the car follows the road when you play the
animation. For more information, see "Path Animation” on page 259.

e Motion capture animation lets you use imported motion capture data to apply
realistic motion to the characters in your scene. For example, you can use
the captured motion of a horse to animate the skeleton of a quadruped
model. For more information, see "Motion Capture Animation” on page 281.

e Dynamic animation lets you create realistic motion by using the rules of
physics to simulate natural forces. For example, you can use
Maya® Dynamics™ to create effects such as sparks spraying from a welding
torch or hail falling from the sky. For more information, see the Dynamics
guide.

Animation
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e Expressions are instructions that you can type to animate attributes. For
example, you can write an expression formula that animates the flapping of a
birds wings. For more information, see the Expressions guide.

Controlling animation

With Maya's animation controls, you can key objects, manage your scene’s
timeline, and play back animation. See "Playback controls” on page 52.

Previewing animation

As you work on an animation, you will want to preview the playback at a speed
close to final production speed. To save time while previewing, you need to
balance the quality of graphics with playback performance. You can also turn on
display options, such as ghosting and motion trail, to help you visualize the flow
of a character’s motion.

Playback

Ideally, you should be able to click the Play button and your animation would play
back full-screen, fully shaded, and in real-time without dropping any frames.
Although this is possible with smaller animations, the more complex a scene is,
the more computations required before displaying each frame. For tips that can
improve playback performance, see "Optimize your scene for playback” on

page 37.

You can customize that playback of your animation by setting the Timeline,
Playback, Animation, and Sound preferences. To edit these options, go to the
Playback options in Window > Settings/Preferences > Preferences. See "Edit
animation preferences” on page 31.

Note If you want to view your object’s manipulators during playback, do
one of the following:

e Select Display > Component Display > Local Rotation Axes to
turn on the display of local axes.

® Use the play -record MEL™ command to see your object’s
actual manipulator during playback.

Ghosting animated objects

Ghosting simulates a technique in classical animation where an animator rapidly
flips through a handful of cell drawings to get a feel for the timing of the action
he is working on. You can use ghosting to sketch out and visualize the flow of a
character’s motion through an animation, and to solve problems with the timing
of the motion.
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Using the Ghosting feature in Maya, you display an animated object for specified
frames before and after the current frame. Ghosts refer to character images
displayed at a time other than the current one. Ghosting can be controlled locally
on each object in your scene, and you can ghost entire skeletons, object
hierarchies, or specific parts of an object. See "Animate > Ghost Selected” on
page 58.

Note You cannot ghost animation that is based on expressions or
simulations, such as Dynamics or Maya® Cloth™ animations.

You can control how ghosts look in the scene view. You can set the color of
ghosts and the number that is displayed. See "To set the number of ghosts that
are drawn” on page 35 and "To change the color of ghosts” on page 35.

Also, the color of ghosts before and after the current frame/keyframe
automatically lighten according to their distance from the current frame/keyframe.
This is visible only when scene view Shading is set to Wireframe. See the
following examples.

Examples

In the example below, the sphere’s Type of Ghosting is Custom Frame Steps. The
sphere’s ghost options are set to the following: Steps before Current Frame is
set to 3, Steps after Current Frame is O, and the Step Size is 3.

Object

Animation
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In the next example, the cube’s Type of Ghosting is Custom Frames. The cube’s
ghost options are set to the following: frame numbers 20, 40, 60, and 80 are
present in the Frames to Display field and Hierarchy is on. The cylinder is the

child of the cube.
The cube also has a Motion Trail with frame numbers.

Object Ghosts

Motion Trails

With Motion Trail, you can display the trajectory of an object. Motion Trail works
with objects that are animated by keyframe animation, deformers, motion
capture, and expressions. You can create the Motion Trail before you animate an
object or after. See "To create a Motion Trail” on page 36 and "Animate > Create

Motion Trail” on page 61.

Motion Trail with a Line Draw Style
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Playblast

The Playblast window lets you preview an animation quickly by performing a
screen grab of the view at each frame then “blasting” the resulting images to the
specified image viewer. The images can be saved either as a movie file or as a
sequence of images in various formats. For more information, see "Window >
Playblast” on page 56 and "Playblast animation” on page 41.

Muting animation

You can now mute animation channels. Muting temporarily disables the
animation on the selected channel without disconnecting its curve from the
animated object.

Note Muted channels appear brown in the Channel Box.

Example

Muting lets you isolate and focus on a specific motion. When working with a
model whose arms and legs are animated, you can use muting to turn off the
animation of either the arms or legs.

Mute in the Channel Box

In the Channel Box, you can right-click selected channels and select the following
options from the menu that appears.

Mute Selected
Mute the selected animation channels.
Unmute Selected
Removes muting from the selected animation channels.
Mute All
Mutes all channels for the current object(s).
Unmute All

Removes muting from all the channels of the current object(s).

Mute node in the Channel Box

When you mute the animation channels of an object, a mute node is
automatically created in the dependency graph for each muted channel.

The mute node in the Channel Box has the following format:
mute_objectn_channel. Example mute node names include:
mute_pCubel_translateX, mute_joint1_rotateZ and so on.

Animation
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When the mute is set to on, all animation nodes that connect to the mute node
are muted. When the mute is set to off, all animation nodes that connect to the
mute node are not muted. Setting the mute node to off in the Channel Box does
not remove it from the dependency graph.

Mute in the Graph Editor and Dope Sheet
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Edit Wiew Select Curves Keys T
ﬁw t£|‘ Stats I I_
&
R
[T
Vi |
@ Fransiaie X'
Fransisie ¥
2 Fransisiel

When you mute an animated object’s keys or channels, a Mute channel is
generated for each animation channel. You can view, manipulate, and add keys
to this Mute channel or curve in the Dope Sheet or Graph Editor. This is useful
when you want to isolate and review specific parts of your animation.

When you edit a Mute channel or curve, its corresponding animation curve
automatically updates in the Dope Sheet and Graph Editor view areas.

A red icon appears beside a channel’s name when it is muted.

A green icon appears beside a channel’s hame when it is not muted, but is still
connected to a mute node. When the mute node is set to off in the Channel Box,
the green icon still appears beside the channel’s name in the Graph Editor.

Related topics

R/

+ 7"Change the status of a mute node from the Channel Box” on page 36

7

% "Mute or unmute a channel in the Dope Sheet or Graph Editor” on page 99

R/

«» "Mute keys in the Dope Sheet or Graph Editor” on page 87

Adding sound to your animation

When creating an animation, you may want to hear the soundtrack to aid in
synchronizing the placement of keys with points in the soundtrack. Keys are
markers that specify timing and motion for animations. For more information on
keys, see “Keys” in Chapter 2.

Note Playback Speed must be set to Real-time in order to play sound
properly.
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Importing sound

Maya supports the following audio file formats:

Platform Audio file format

Linux® .aiff, .wav

Microsoft® Windows® .aiff

Apple® Mac 0S® X .aiff, .wav, .mp3

Note e On Mac OS X, you can only drag and drop .mp3 files onto the

Time Slider. You cannot import them using File > Import. See
"To display sound on the Time Slider” on page 43 and "Time
Slider” on page 50.

e On Windows, you can’t import sound files that have the .wav
Apple file format. However, you can convert your .wav sound
files to Windows compatible file formats like IMA ADPCM or
PCM.

When a sound file is loaded into a scene, an audio node is created with the
same name as the filename. This node has a reference to the location of the
sound file. If you move the sound file to a different location, you will have to
make sure that you change the filename referenced by your audio node. For more
information, see "To load an audio file into your scene” on page 43.

Baking simulations

Baking a simulation allows you to generate a single animation curve for an object
whose actions are being provided by simulation rather than by keys and
animation curves (keysets). Many types of animation in Maya are not represented
by, and therefore not available for, keyset editing. Examples include objects
animated with inverse kinematics, expressions, or along motion paths.

Baking a simulation is useful when you want to edit a single animation curve
instead of all the contributing attributes that affect the behavior of a single
attribute. For examples, an object affected by a driven key or an expression.

When baking, you can first set the bake key options (Edit > Keys > Bake
Simulation > ) or you can immediately bake (Edit > Keys > Bake Simulation)
with the currently set options.

Animation
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Animation Snapshot and Animated Sweep

You can create path-driven geometry from animated curves and objects using
Animate > Create Animation Snapshot and Animate > Create Animated Sweep.

Animation Snapshot creates copies of animated objects at intervals of a playback
range. Animation Snapshot works on NURBS or polygonal geometry. You can’t
use Animation Snapshot on objects animated with dynamics and Inverse
Kinematics. For more information, see "To use animation snapshot” on page 46
and "To use animated sweep” on page 47.

Animation Snapshot-generated geometry

When Construction History is on during an Animation Snapshot, you can edit the
animation to affect the generated geometry. See "To use animation snapshot” on
page 46 and "Animate > Create Animation Snapshot” on page 63.
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Tip To create geometry using Animation Snapshot from animation types
such as Expressions or Inverse Kinematics, you can convert the
object’s animation type to animation curves using Edit > Keys >
Bake Simulation.

Because Animation Snapshot and Animated Sweep evaluate the animation and
create geometry for each By Time position, considerable processing time occurs
for complex objects and animation. For more information, see "To enable
Animation Snapshot and Animated Sweep calculations” on page 49 and "To
disable Animation Snapshot and Animated Sweep calculations” on page 49.

Animated Sweep

Use Animated Sweep to create surface geometry from an animated curve.
Animated Sweep operates on animated object transformations that have explicit
connections to all the nodes connected to the geometry. Geometry animated by
dynamics, inverse kinematics, and self-referencing expressions, for example,
cannot be used to generated Animation Snapshot geometry. Animated sweep is
similar to performing an Animation Snapshot of a curve and a subsequent Loft.
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A simple example of an Animated Sweep would be to create a spiraling tube that
decreases in size, much like an animal’s horn. See "To use animated sweep” on
page 47 and "Animate > Create Animated Sweep” on page 64.

Snapshot and Sweep Construction History

Animation Snapshot and Animated Sweep create construction history. This
means you can edit the animation used to generate the Animation Snapshot and
Animated Sweep geometry.

Note You can save considerable processing time in complex Animation
Snapshot and Animated Sweep operations by turning off
construction history.

Animated rotation in Maya

When you keyframe an object’s rotations, Maya calculates the object’s
orientations between keys by interpolating the rotation values from one key to the
next. In Maya, there are two methods of rotation interpolation: Euler (pronounced
‘oi-l&r’) and Quaternion. For each animated rotation in your scene, you can specify
a rotation interpolation method. The rotation interpolation method you choose for
an animated object determines how Maya calculates its rotations. For more
information on Euler angles and Quaternions, see "Euler angles” on page 27,
"Quaternions” on page 29, and "Which type of interpolation is right for your
animated rotations?” on page 31.

Euler rotation is the default method of rotation interpolation unless otherwise
specified. You can set the default rotation interpolation method for new curves
from the Maya Preferences window (Window > Settings/Preferences >
Preferences > Keys) or you can set the rotation interpolation method of existing
rotation curves from the Graph Editor. See "To set rotation interpolation for new
curves” on page 95 and "To change rotation interpolation in existing curves” on
page 96.

Euler angles

When interpolating the animated rotations of an object using the Euler method,
Maya uses Euler angles to determine the object’s axis-specific orientations over
time. Euler rotations are calculated using three separate angles representing
rotations about the X, Y, and Z axes, and an order of rotation.

The rotation order specifies the order in which an animated object is rotated
about its X, Y, and Z axes. Changing an animated object’s rotation order changes
its final orientation. You can specify the order of rotation for an object by setting
its Rotate Order attribute. For example, if you set an animated object’s Rotate
Order to YZX, the object will first rotate in Y, then Z, and finally X. You can use
the Rotate Order attribute to match the rotation order of imported, animated

Animation
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objects to the co-ordinate systems (for example, XZY opposed to Maya’s default
XYZ) of the 3D software packages from which they came. This is important if you
want the animated rotations of your imported objects to appear as intended.

In Maya, the default method of rotation interpolation is Euler.

Euler rotation interpolation

There are 2 kinds of Euler rotation interpolation in Maya: Independent and
Synchronized. You can set the Euler rotation interpolation type for your curves
from the Graph Editor. See "Change Rotation Interp” on page 148.

For Independent Euler curves, interpolation is calculated from key to key on each
individual curve, independent of the their neighboring rotation curves. Use
Independent Euler curves when you want to keyframe a single rotation channel or
when you need to add additional keyframes (and thus detail) to a single rotation
curve. Independent Euler curves are ideal for simple, animated rotations.

All the keyframes on Synchronized Euler curves are locked together in time. This
means that if an object has Synchronized Euler rotation curves, interpolation is
calculated from key to key on all of its rotation curves simultaneously. Use
Synchronized Euler curves when you want to keyframe multiple rotation channels
(X, Y, and Z) or when you need to add additional keyframes (and thus detail) to all
the rotation curves of an animated object. Synchronized Euler curves are ideal for
more complex animated rotations.

The main difference between Independent and Synchronized Euler curves are
their keyframes. For example, moving a key in time on an Independent Euler
Rotate X curve moves only the key on the Rotate X curve, whereas moving a key
in time on a Synchronized Euler Rotate X curve will also move the corresponding
keys on the Y and Z curves. Similarly, if you key only the Rotate X channel for an
animated object, and the rotation interpolation type is set to Independent Euler,
then only the Rotate X channel is keyed. However, if the rotation interpolation
type is set to Synchronized Euler, then all three (X, Y, and Z) Rotate channels are
keyed.

When Euler angles are used to interpolate the animated rotations of an object,
the object’s orientation about its individual axes is evaluated one axis at a time.
This is why Euler-angled rotation is prone to artifacts such as gimbal lock and
flipping. Gimbal lock occurs when rotations about a single axis cause unwanted
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rotations about complementary axes or when axes become coincident. Flipping
occurs when angles unexpectedly wrap around positive or negative 180 degrees
during Euler-angled rotation interpolation between keyframes.

If gimbal lock or flipping occurs, you may be able to correct this behavior using
the Euler Filter. For example, you can use the Euler Filter to normalize the
mangled rotation curves from corrupted motion capture animation data. You can
access the Euler Filter from the Curves menu in the Graph Editor or Dope Sheet.
For more information on the Euler filter, see "Euler angle filtering” on page 71
and filterCurve.

When should | use Euler rotation interpolation?

Use Euler rotation interpolation when you want specific control over the numerical
values of your rotations and when you want smooth tangents for your rotation
curves. In most cases, you should only use Euler rotation interpolation for
rotation animation curves that you need to manipulate extensively in the Graph
Editor. Unlike Quaternion curves, Euler curves support all tangent types and their
keys possess tangent handles that let you easily tweak the curves.

Quaternions

Quaternions provide smooth interpolation of animated rotations and always
produce the most efficient path between keyframes in comparison to Euler
angles. Quaternions store the overall orientation of an object rather than a series
of individual rotations. This means that a single Quaternion stores the same
amount of rotation data as three Euler angles. Since Quaternions store only
orientation values, they can be used to calculate the shortest rotation from one
orientation to another.

When animating an object’s rotations with Quaternions, Maya first stores the
keyed orientation values for the object as Euler angles, converts them to
Quaternions for interpolation, and then converts the interpolated Quaternion
rotation values back to Euler angles for display in the Channel Box and Graph
Editor.

In Maya, Quaternions are displayed as Synchronized Euler curves and values.
When an object’s rotation curves are synchronized, the keyframes on its X,Y, and
Z Rotate curves are locked together in time. When you add, delete, or move a
keyframe on one of the object’s rotation curves, the corresponding keys are also
updated on the related rotation curves. This eliminates unexpected interpolation
problems that can occur when keyframes are deleted from one of the axes, or
when keys are moved independently in time.

The tangent settings for Quaternion curves affect how an object’s animated
rotations are interpolated. For more information on tangent types, see "Tangents
menu” on page 151. Maya uses the following types of tangents and interpolation
to calculate the shortest rotation from one key to the next:

* Quaternion curves with clamped tangents use stepped interpolation
¢ Quaternion curves with linear tangents use spherical linear interpolation
(also known as SLERP)

Animation
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* Quaternion curves with spline tangents use cubic interpolation

Warning Setting the tangents of a Quaternion curve to spline will produce
unpredictable results.

For best results when using Quaternions, set the tangents of your
Quaternion curves to linear.

When blending animation clips in the Maya® Trax™ Editor, you can select one of
the following types of Quaternion rotation interpolation: Quaternion Shortest or
Quaternion Longest. Quaternion Shortest interpolation uses Quaternion
interpolation to find the shortest path between rotations from one clip to the
next. Quaternion Longest interpolation uses Quaternion interpolation to find the
longest path between rotations from one clip to the next. This path is in the
opposite direction of Quaternion Shortest.

Longest
Shortest

Quaternions —
Origin of Quaternion sphere

A - Orientation before rotation
B - Orientation after rotation

Quaternion rotation interpolation

You can specify a clip blend’s Quaternion rotation interpolation type from the
Attribute Editor by setting the blend’s Rotation Blend attribute.

When should | use Quaternions?

Use Quaternions when you want smooth interpolation between two keys.
Quaternions produce the most efficient paths of interpolation and they do not
generate artifacts such as gimbal lock and flipping.

Warning e |t is difficult to isolate, view, and edit Quaternion curves in the
Graph Editor.

e Quaternion curves do not support tangent handles and only
work well with linear tangents.
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Which type of interpolation is right for your animated

rotations?

Each method of rotation interpolation has its advantages and disadvantages. It is
up to you to select the type of interpolation that best suits your animation. See

"When should | use Euler rotation interpolation?” on page 29 and "When should |
use Quaternions?” on page 30.

Euler angles

Quaternions

Advantages ®

Easily create simple
rotations around a
single, primary axis.
Support spin (rotation
>360°)

Treat IN and OUT
tangents independently

Smoothly interpolate
rotation from one
orientation to the next

Do not suffer from
Gimbal Lock or flipping

Disadvantages | °®

Are prone to Gimbal Lock
and flipping

Create rotations that are
difficult to predict
because interpolation is
calculated separately for
each rotation axis

Do not support spin
(rotations >360°)

Curves are difficult to
visualize

Do not support tangent
handles

Tangents are difficult to
view and edit in the
Graph Editor and are not
treated independently

Note

Whether your object’s rotations use Quaternions or Euler angles,

the Channel Box will always display Euler angle values.

Edit animation preferences

To edit preferences related to the Animation module of Maya

1 Click the Animation Preferences button. See "Animation Preferences button”

on page 52.

The Preferences window appears.

2 Do one of the following:

Animation
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e To set the timeline and playback preferences, select Timeline from the
Categories box and edit the settings.

See “Timeline preferences” in the Preferences and Customization chapter of
the Basics guide.

e To set the time preferences, select Settings from the Categories box and
edit the Working Units settings.

See “Settings preferences” in the Preferences and Customization chapter of
the Basics guide.

e To set the ghosting preferences, select Animation (under Display) from
the Categories box and edit the settings.

See “Animation (Display) preferences” in the Preferences and Customization
chapter of the Basics guide.

e To set the sound preferences, select Sound from the Categories box and
edit the settings.

See “Sound preferences” in the Preferences and Customization chapter of
the Basics guide.

Use the animation controls

The following procedures describe how to use the animation controls.

To display the Time Slider

You can hide or display the Time Slider by selecting Display > Ul Elements > Time
Slider.

Hiding the Time Slider provides more Maya view space. See "Time Slider” on
page 50.

To display the Range Slider

You can hide or display the Range Slider by selecting Display > Ul Elements >
Range Slider, or by using the range slider display toggle.

Range slider display toggle

|;'; ‘u F 10 15 20 25 30 35 40 45 50 55 60
| i | | ‘ | | | | | |

Hiding the Range Slider also hides the Animation Preferences button and the
Auto Key button. For more information, see "Range Slider” on page 51.

To change the current time

1 Click anywhere on the Time Slider.

Where you click with your mouse becomes the current time and the scene
jumps to that time in the animation.

2 Do one of the following:
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e Drag the mouse in the Time Slider.

e Hold down your keyboard’s k key as you drag horizontally in any view.
The scene updates with your mouse action.

e Middle-click in the Time Slider.

* Hold down the k key and middle-drag horizontally in any view.

Your scene does not update, but the Current Time Indicator moves to show
your new current time. This is useful, for example, if you want to key an
object at some frame based on a prior position of other objects. For more
information, see "Time Slider” on page 50.

Note The k key operations work the same in all Maya windows that

display a timeline, for instance, the Graph Editor.

To change the playback range with the Range Slider

The Range Slider bar lets you control the playback range of your animation up to
the limits of the Animation Start/End settings. For more information, see "Range
Slider” on page 51.

Do one of the following:

Drag the Range Slider bar to move it.
Drag the boxes at the ends of the Range Slider to scale the playback range.

Double-click the Range Slider bar to set the playback range to the range
values in the Animation Start/End fields of the Preferences window. To return
to the prior playback range, double-click the Range Slider bar again. See
“Timeline preferences” in the Preferences and Customization chapter of the
Basics guide.

To move and scale a range of animation with the Time Slider

1 Shift-drag along the Time Slider to select a range of time or double-click the

Time Slider to select the entire range.

The selected time range is red, with start and end frames shown in white
numbers at the ends of the selection block. See "Time Slider” on page 50.

2 Do one of the following:

e To scale the keys in the selected range of the Time Slider, drag the black
arrows at either end of the selected range.

e To move the keys in the selected range along the Time Slider, drag the
black double arrows at the center of the selection.
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Set the appearance of key ticks in the Time Slider

To set the thickness of your keyframes in the Time Slider

1 Select Window > Settings/Preferences.> Preferences.
The Maya Preferences window appears.
2 In the Timeline section, set the Key Tick Size preference setting.

Key thickness is measured in pixels. The minimum key thickness is 1 pixel
and the maximum is 63 pixels.

To set the color of a curve’s keyframes in the Time Slider

1 In the Graph Editor graph view, select a curve.
2 In the Graph Editor menu bar, select Curves > Spreadsheet.

The spreadsheet for the selected animation curve appears in the Attribute
Editor.

3 Choose a Curve Color and turn on Use Curve Color.

All the curve’s keyframes in the Time Slider are now the Curve Color you
selected.

To set the color of individual keyframes in the Time Slider

1 Select Window > Settings/Preferences > Colors > Animation.
2 Choose a Time Slider Tick Special color and click Save.

3 In the Graph Editor, select the keyframe(s) you want drawn in the Time Slider
Tick Special color.

4 In the Command Line or Script Editor, enter the keyframe MEL command
with the -tickDrawSpecial (-tds) flag as follows:

keyframe -tds on

and then press Enter on the number pad.

The keyframes you selected and set the -tds flag for are now drawn with
Time Slider Tick Special color in the Time Slider.

For more information on this flag, see keyframe in the MEL Command
Reference documentation.
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Note e The Time Slider Tick Special color preference overrides the key
color set by the Curve Color attribute.

e |f you have multiple keys at the same time in the Time Slider,
and one of those keys has its -tds flag set to on, then the
Time Slider Tick Special color will take precedence over the
other key colors.

Preview your animation

Ghost an object

To ghost an object

1 Select the object or the root of the hierarchy that you want to ghost.
2 Select Animate > Ghost Selected > .
The Ghost Options window appears.
3 Set the ghosting options. See "Animate > Ghost Selected” on page 58.
4 Do one of the following:

e Click Ghost to apply the Ghost Options settings to the current object. The
Ghost Options window closes.

e Click Apply to apply the Ghost Options settings to the current object,
overriding any other ghosting settings on the object. The Ghost Options
window remains open.

e Click Close to disregard any changes made to the ghosting options and
close the Ghost Options window.

To set the number of ghosts that are drawn

1 Select Window > Settings/Preferences > Preferences and select the
Animation category under Display.

2 In the Ghosts section, set the ghosting preferences. See “Animation (Display)
preferences” in the Preferences and Customization chapter of the Basics
guide.

To change the color of ghosts

1 Select Window > Settings/Preferences > Color.
2 Under the General tab, expand Ghosts.
3 Select a color with the color sliders.

To unghost an object

1 Select the object.
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2 Select Animate > Unghost Selected > .

The Unghost Options window appears. See "Animate > Unghost Selected” on
page 61.

3 Set the Unghost options.
You have the option of unghosting only the selected object, or the selected
object and all its children. See "Animate > Unghost Selected” on page 61.

To unghost all objects in your scene

1 Select Animate > Unghost All.

To turn off the ghost display during object transform

1 Select Window > Settings/Preferences >Preferences and select the Display
category.

2 In the Performance section, turn on Fast Interaction.

Change the status of a mute node from the
Channel Box

To turn the mute node on or off

1 Select the mute node in Hypergraph.

2 In the Channel Box, click in the Mute field and enter the following:
e Type on or 1 and press Enter to turn the mute node on.
e Type off or O and press Enter to turn the mute node off.

Note You can mute a time range by animating the status (on/off) of the
mute node.

Apply Motion Trails to an object

To create a Motion Trail

1 Select the object and select Animate > Create Motion Trail > 0.
The Motion Trails Options window appears.

2 Set the options.

3 Do one of the following:

e Click Create Motion Trail to create a motion trail with the current settings
for the selected object. The Motion Trail Options window closes.

e Click Apply to create a motion trail with the current settings for the
selected object. The Motion Trail Option window remains open.
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e Click Close to disregard any changes made to the motion trail options
and close the Motion Trail Options window.

To snap objects to their Motion Trail positions

e C(Click Snap to Points in the animation toolbar.

Playback animation

Display the frame rate of an animation

To display the frame rate of an animation in scene view

e Select Display > Heads Up Display > Frame Rate.
The frame rate appears in the lower right-hand side of your current view.

View object manipulators during playback

To view your object’s manipulators during playback

e Do one of the following:

e Select Display > Component Display > Local Rotation Axes to turn on the
display of local axes.

e Use the play -record MEL command to see your object’s actual
manipulator during playback.

Optimize your scene for playback

This section describes in detail various ways you can easily increase the
interactive and playback speeds of your Maya scene.

Display and Ul Elements

Tip Hiding any of the components (selection handles, locators, entire
objects and so on) of your Maya scene will increase the scene’s
interactive speed. To hide components of your scene, use the
options in the Display > Hide menu.
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Close any unnecessary
windows

Hide Ul Elements

Use alternate shading
modes for your view

Use default lighting

Turn off hardware texturing
and back face culling

Turn on fast interaction

Animation
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e Close all Maya editors and windows you are
not currently working with, especially the
Graph Editor and Dope Sheet (which update
during playback).

e Close all windows from other applications.
e Close any DOS windows or Terminals.

Select Display > Ul Elements >
Hide Ul Elements.

This hides all panes in the Maya main window
except for the scene views.

In the Panel menu bar, select alternate shading
modes from the Shading > Interactive Shading
menu.

The performance of different shading modes
from best to worst is:

e Bounding Box
e Points

e Wireframe

e Normal

In the Panel menu bar, turn on Lighting >
Use Default Lighting.

When Use Default Lighting is on, a checkmark
appears beside its menu item.

In the Panel menu bar, do the following:

e Turn off Shading > Hardware Texturing
e Turn off Shading > Back Face Culling

When Hardware Texturing and Back Face Culling
are off, checkmarks do not appear beside their
menu items.

Turn on Display > Fast Interaction.

When Fast Interaction is on, a checkmark
appears beside its menu item. In this mode,
objects are drawn at a resolution that is based
on their screen size. In other words, the further
an object is from the camera, the lower its
drawn resolution.
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1 Select the non-moving object you want to
template.

2 Select Display > Object Display > Template.

Templated objects are not redrawn during
playback. Also, templated objects will always be
drawn in wire mode, even when the current view
is shaded.

It is therefore useful to put large, currently
insignificant objects in the scene into template
mode while working on other objects in the
scene.

Select Display > Grid.

When the Grid menu item is off (no checkmark),
the grid does not appear in the scene view.

Select Display > Ul Elements > Time Slider.

When the Time Slider menu item is off
(no checkmark), the Time Slider does not appear
in Maya’s main interface.

3 Select Window > Settings/Preferences >
Preferences.

The Maya Preferences windows appears.
4 In the Categories column, select Timeline.
5 In the Timeline section, set Key Ticks to
None.
6 Select Window > Settings/Preferences >
Preferences.
The Maya Preferences windows appears.
In the Categories column, select Timeline.

8 In the Playback section, set Update View to
Active.

~

1 Select File > Optimize Scene Size > .

The Optimize Scene Size Options window
appears.

2 Turn on NURBS Surfaces + Curves, and then
click the Optimize now button next to the
option.
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Remove unused geometry

Reduce evaluations of
NURBS objects

Skeletons

Turn off joint display

Skinning

Remove unused skin
influences

Disable deformation of
skin’s user normals

Display skinned geometry
as wireframes

Animation
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3 Select File > Optimize Scene Size > .

The Optimize Scene Size Options window
appears.

4 Turn on NURBS curves and Locators, and
then click the Optimize button.

Use the Display > NURBS smoothness menu to
reduce the number of evaluations along each
span of a NURBS object.

Hull mode is the fastest to draw. The Rough,
Medium, and Fine modes can be quickly
accessed using the 1, 2, and 3 keyboard
hotkeys. For more information, see the Maya
NURBS Modeling Guide.

Select Display > Hide > Hide Kinematics >
Joints.

1 Select your skinned object.

2 In the Animation menu set, select Skin >
Edit Smooth Skin > Remove Unused
Influences.

This disconnects all zero-weighted skin
influences from your skinned geometry.

3 Select your smooth skinned object and open
the Attribute Editor.

4 Select the skinCluster node’s tab.
5 In the Smooth Skin Attributes section, turn
off the Deform User Normals attribute.

In the Panel menu bar, select Shading >
Wireframe.

This is useful when your skinned object is
not triangle based.
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Remove unused animation 1 Select File > Optimize Scene Size > 0.

components The Optimize Scene Size Options window
appears.

2 Turnon:

Animation Curves
Animation Clips
Poses

Cached Data
Deformers
Expressions
Constraints

Pair Blends

3 Click the Optimize button.

Delete all flat animation Select Edit > Delete by Type > Static Channels.
curves

Playblast animation

Warning e Playblast creates a movie by screen-grabbing your animation
one frame at a time during playback.

If an open window obscures the area where the screen will be
grabbed, the first frame of your movie will display part of the
window. This also occurs when a screensaver appears partway
through playblasting a long animation.

When playblasting an animation, make sure that the area you
want to playblast is not obscured by any windows.

¢ Playblast uses $TEMP directory on Windows even if “Save To
File” specifies a different directory. Make sure there is enough
disk space to hold the playblast file in your $TEMP directory.

To playblast an animation

1
2

Create or open an animation.
Select Window > Playblast > .

The Playblast Options window opens.

Select a Viewer.
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41



1 | Animation Basics

How do I? > Playblast animation

Animation
42

4 If you selected Movieplayer or Apple® QuickTime® as your viewer, select a
Compression method.

Note Playblast AVI creation calls upon the system movie libraries to
generate the selected compression scheme. Alias cannot guarantee
the reliability or success of all the compressors available to your
operating system.

5 Set Display Size to From Window.
6 Click in a view to make it active.
7 Click the Playblast button.

The scene plays in the active view for the playback range in the Time Slider.
After each time frame is drawn, Maya takes a screen grab of the active view.

The Movieplayer window (Windows), the FCheck utility, or QuickTime window
(Mac OS X only) opens and previews the playblast animation. For more
information, see "Window > Playblast” on page 56.

Note If a sound file is displayed in the Time Slider while Playblast is
running and the Output Format is set to Movie, the sound file is
included in the resulting saved file.

To output single frames of your animation to Playblast
e Use the -frame flag with the playblast MEL command.
For example:

playblast -frame 1 -frame 4 -frame 7
outputs frames 1, 4, and 7 of your current animation to Playblast.

For more information, see Help > MEL Command Reference.

Note The -frame flag overrides any -startFrame/-endframe flags.

To cancel a playblast

e Press the Esc key.

To run Playblast when Maya is minimized on your screen (Linux only)

e Use the -os/offScreen flag with the playblast MEL command.
For more information, see Help > MEL Command Reference.

Related topics

R/

s "Previewing animation” on page 20



1 | Animation Basics
How do I? > Add sound to your animation

7

< "Window > Playblast” on page 56
Add sound to your animation

Add sound to your animation

Although you can import as many sound files into a scene as desired, only one
soundtrack can be displayed and played at a time in the Time Slider.

Import an audio file

Warning On Windows, you can’t import sound files that have the .wav Apple
file format. However, you can convert your .wav sound files to
Windows compatible file formats like IMA ADPCM or PCM.

To load an audio file into your scene
Do one of the following:

e Use File > Import. A file browser lets you select the name of the sound file to
import.

e Locate the file on the desktop and middle-drag the file into one of the Maya
modeling views.

e Locate the file on the desktop and drag the file onto the Time Slider.

The peaks of the sound waves are visible in the Time Slider, and the Time
Slider is ready to play or scrub the sound.

To display sound on the Time Slider
1 Right<click the Time Slider.
A pop-up menu appears.

2 In the pop-up menu, select the audio file you want to hear from Sound >
audio file.

L e e e e e e s

The audio file’s waveform appears in the Time Slider and it plays during
playback.

To use contiguous audio files with animation

Suppose you create an animation that begins with a flash of lightning, then plays
the sound of thunder, then ends with the sound of rainfall. You have two different
sound files, thunderstorm.aiff and rainstorm.aiff.
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The following example describes how to import and play the two sound files after
the animation.

1 Create a lightning animation.

2 To import the sound files, open the window where you've put your sound file,
and then drag the thunderstorm.aiff file onto the Time Slider.

A thunderstorm audio node is created, and you will see the sound waves in
the Time Slider.

3 Drag the rainstorm.aiff file onto a scene view.

A rainstorm audio node is created. The Time Slider continues to display the
thunderstorm sound. The animation starts with 3 seconds of lightning. The
thunderstorm sound starts after 3 seconds of play.

4 Select Display > Sound > thunderstorm > (0 and change the Start Time to 72
(3 seconds at the default Time Unit of 24 frames per second).

You will now see the sound waves representing the thunderstorm sound
appear in the Time Slider starting at time 72.

5 To play your animation with sound, open the Animation Preferences window
and ensure that Playback Speed is set to Realtime (24 fps) and click Play.

The rain sound begins at 5 seconds (or time 120 on the Time Slider).

6 Open the Display > Sound > rainstorm > O window and set the Start Time to
120.

7 Press Play to view (and hear) your animation.

To view your animation with both soundtracks (the thunderclap sound
followed by the rain sound), you will have to render your animation to video
and overlay each of the soundtracks onto tape.

Play an audio file

To play an audio file

1 Import the audio file. See "To load an audio file into your scene” on page 43.

2 Verify that the audio node corresponding to the audio file is displayed in the
Time Slider.

3 Set the animation playback speed.

In order to hear sound during the playback of an animation, the playback
speed must be set to a constant rate so that Maya can determine how slowly
or quickly to play the soundtrack.

4 Select a Playback Speed of Real-time (24 fps) to play the soundtrack (and the
animation) in real-time.

Now when you play your animation, you will here the audio file that you
imported.
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To scrub sound
Drag in the Time Slider— the soundtrack will play as you drag it.

Scrubbing can be useful for locating a specific time at which a particular sound or
portion of sound begins. For example, if your soundtrack includes, “Hi Dave,” you
may want to locate the exact frame at which the “D” sound begins so you can
synchronize the character’s mouth forming a “D” sound with the soundtrack.

Tip It may be easier to find the beginning of a sound by having the
sound repeat until you drag the Current Time Indicator to the next
time in the Time Slider. To use this feature, open the Animation
Preferences window and turn on the Repeat Sound option.

Set the audio playback settings

To change the playback range to the duration of the current sound file
1 Rightclick the Time Slider.

A pop-up menu appears.
2 In the pop-up menu, select Set Range To > Sound Length.

To set the audio playback speed

1 Click the Animation Preferences button.
The Preferences window appears.

2 Set the Playback Speed option.
Sound will play back as long as the speed setting is not set to Play every
frame.

To disable sound during playback

Right-click the Time Slider to access the Time Slider Key Edit menu and select
Sound > Off.

To access the sound options for audio nodes

Right-click the Time Slider to access the Time Slider Key Edit menu, and select
Sound > filename > .

Delete audio from your scene

If you import a sound file into your scene, and decide later that you no longer
need that soundtrack, you can delete the audio node from the Script Editor
window or the Outliner.

Select the node using Edit > Delete > filename. Alternatively, use Edit > Delete
All by Type > Sounds.

Animation
45



1 | Animation Basics

How do I? > Set Animation Snapshot and Animated Sweep

Animation
46

Set Animation Snapshot and Animated Sweep

Set Animation Snapshot and Animated Sweep

With Animation Snapshot or Animated Sweep, you can generate a new shape
from an animated object such as a plane or curve. See "Animation Snapshot and
Animated Sweep” on page 26.

Note The Animation Snapshot option for updating On Demand frequently
causes the snapshot geometries to disappear. Use the AnimCurve
option instead.

Apply animation snapshot

To use animation snapshot

The following example illustrates how to use animation snapshot to create a
model that resembles a staircase.

1 In the Modelling menu set, select Create > NURBS Primitives > Plane.
A a simple planar surface appears in your scene.

/)<<’

This will be the bottom step of the staircase. If desired, scale the plane and
move its CVs to make the plane look more like a step.

e

2 Select the Animation menu set from the drop-down menu in the Maya tool bar
or press F2.

[tems in the Maya main menu switch to the Animation menu set.
3 Translate the step so that one of its narrow edges touches the world origin.

4 Press your keyboard’s Insert (Linux and Windows) or Home (Mac OS X) key to
display the step’s pivot point.

5 Translate the pivot point to the world origin.
6 Press the Insert or Home key again to exit pivot point mode.

7 Rewind the animation and select Animate > Set Key to set a key at the start
time.

8 Specify a short playback range for your scene. For example, 24 frames.
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9 Drag the Current Time indicator to the end of the playback range.

10 Translate the step upwards along the Y-axis about 10 units, then set a key.
This creates the end position of the step’s vertical travel.

11 Enter 720 for Rotate Y in the Channel Box, and set a key (Ctrl+s).
This creates the end position of the step’s rotation.

12 Rewind and play the animation to observe the step’s movement.

13 Select the step.

14 Select Animate > Create Animation Snapshot > 1.
The Animation Snapshot Options window opens.

15 For Time Range, turn on Time Slider, then set By Time to 1.

These settings will create snapshot copies of the animated geometry at a
regular intervals for the entire Time Slider range. The By Time value sets the
time interval when snapshots are taken.

If, instead, you turn on Start/End for the Time Range option, you can enter a
Start Time and End Time (time range) for the animated geometry.

16 In the Animation Snapshot Options window, click the Snapshot button to
create the staircase.

Wait several moments for the operation to complete.

Tip You can escape out of a long Snapshot computation by pressing
the Esc key.

The original object and animation is unchanged. In the Outliner, the copies of
the steps exist under a new group, snapshotGroup.

Apply animated sweep

To use animated sweep

The following example illustrates how to use animation sweep to create a model
that resembles a spiraled animal’s horn.

1 In the Modeling menu set, select Create > NURBS Primitives > Circle.
A circle appears in your scene view.
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Move the circle 8 units along the Z axis.
Scale the circle until it has a radius of approximately 3 units.
Rotate the circle 90 degrees (so that it is now perpendicular to the grid).

Move the circle’s pivot to the origin, so that it will rotate around the origin in
the animation.

Press your keyboard’s Insert (Linux and Windows) or Home (Mac OS X) key to
display the circle’s pivot point.

Enter the values 0 O O in the Transform Attributes entry field, or drag the
pivot point to the origin.

Press the Insert or Home key again to exit pivot point mode when the pivot is
positioned.

Select the Animation menu set from the drop-down menu in the Maya tool bar
or press F2.

Iltems in the Maya main menu switch to the Animation menu set.

Ensure that the Current Time Indicator is at the start of the Time Slider, and
set a key for the circle’s transforms (Animate > Set Key).

This is the starting position of the circle for this animation.

Move the Current Time Indicator to the end of the playback range.
Set Rotate X to 720 to rotate the circle approximately two revolutions.
Move the circle up the Y axis approximately 10 units.

Scale the circle to O.

Set a key for the transformations (Ctrl+s).

You have now established the end state for the circle.

Press Play to view the animation of the circle.

Select Animate > Create Animated Sweep > 0.

The Create Animation Sweep Options menu appears.

Ensure that the Time Range is set to Time Slider, and that the By Time value
is setto 1.

Click the Anim Sweep button.
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Turn Animation Snapshot and Animated Sweep on
or off

To enable Animation Snapshot and Animated Sweep calculations

Turn on Modify > Evaluate Nodes > Snapshots. A checkmark appears beside the
Snapshot menu item when it is on.

To disable Animation Snapshot and Animated Sweep calculations

Turn off Modify > Evaluate Nodes > Snapshots. When a checkmark does not
appear beside the Snapshot menu item, it is off.

Delete Animation Snapshot or Animated Sweep
construction history

You can delete the construction history of animated snapshot or animation
sweep by selecting Edit > Delete by Type > History.

Tools

Animation controls

Animation controls

Maya’s controls for developing the timing of animations include the Time Slider,
Range Slider, and Playback Controls. You can also quickly access and edit
animation preferences from the animation controls area.
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49



1 | Animation Basics
Reference > Animation controls

Time Sllder Playback Controls

| Animation Preferences button
Range Slider

Between the Range Slider and the Animation Preferences button are the current
character control features and the automatic keyframing (Auto Key) button. For
details on automatic keyframing, see "Auto Key” on page 67.

Time Slider

The Time Slider controls the playback range, keys, and breakdowns within the
playback range.

Current time indicator Current time field
| \
|0 5 10 15 20 25 30 35 40 45 50 585 G0
| N T
Time slider display toggle Key ticks

The Current Time Indicator is a gray block on the Time Slider. You can drag it to
move forward and backward in your animation.

By default, dragging in the Time Slider updates only the active view. All views can
be set to update by changing Playback settings to Update View All in the Timeline
Preferences window (Window > Settings/Preferences > Preferences and select
Timeline in the Categories window).

Key ticks

Key Ticks are red (by default) marks in the Time Slider that represent the keys
you set for the selected object. Breakdowns are a special type of key displayed
as green marks in the Time Slider. See “Breakdowns” in Chapter 2.

The visibility of Key Ticks can be turned off or on in the Preferences window. You
can also set the size and color of the key ticks displayed in the Time Slider. See
"Set the appearance of key ticks in the Time Slider” on page 34.

Time Units

The ruler markings and associated numbers on the Time Slider display time. To
define the playback rate, select the desired Time from the Settings Category of
the Preferences window. Maya defaults to measuring time as 24 frames per
second, the standard frame rate for film.

Animation
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Note By default, Maya plays your animation in seconds. You can change
the Time setting without affecting your animation’s key-based
behavior. However, expressions that use the frame variable might
not work correctly if you change the Time setting. It's good practice
to specify the Time setting before you begin animating your scene.

Current time field

The entry field to the right of the Time Slider indicates the current time expressed
in the current Time unit. You can change the current time by entering a new
value. Your scene moves to that location in time, and the Current Time Indicator
updates accordingly.

Range Slider

The Range Slider controls the playback range reflected in the Time Slider.

Animation Start Time Animation End Time

Playback Start Time Range Slider bar Playback End Time

Animation Start Time

This field sets the start time of the animation.

Animation End Time
This field sets the end time of the animation.

Playback Start Time

This field shows the current start time for the playback range. You can change it
by entering a new start time, including a negative value. If you enter a value that
is greater than the Playback End Time, the Playback End Time is adjusted to one
time unit greater than the Playback Start Time.

Playback End Time

This field shows the current end time for the playback range. You can change it
by entering a new end time. If you enter a value less than the Playback Start
Time’s value, the Playback Start Time is shifted to one time unit less than the
Playback End Time.

You can also edit the preceding settings from the animation Preferences window.
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Playback controls

The

Playback Controls are buttons for playing and stepping through your

animation. The playback range is displayed in the Time Slider.

EE EBEE BEEE EBE

Playback Controls

Press Go To Start button to go to start of playback range.

Press Step Back Frame button to step back one time.
Default hotkey: Alt+, (comma) key (Linux and Windows) or Option+, (comma)
key (Mac OS X).

Press Step Back Key button to step back one key.
Default hotkey: , (comma) key.

Press Play Backwards button to play backwards.
Pressing Esc key stops playback.

Press Play Forwards button to play forwards.
Default hotkey: Alt+v (Linux and Windows) or Option+v (Mac OS X). Pressing
Esc key stops playback.

Press Step Forward Key button to step forward one key.
Default hotkey: . (period) key.

Press Step Forward Frame button to step forward one time (or frame).
Default hotkey: Alt+. (period) (Linux and Windows) key or Option+. (period)
(Mac OS X).

Press Go To End button to go to end of playback range.

Press Stop button to stop playback. This button is displayed only when an
animation is playing, replacing either the Play forwards or Play Backwards
buttons. Default hotkey: Esc key.

Animation Preferences button

This button launches the Preferences window. From this window, you can set the
Timeline, Playback, Animation, and Sound preferences for your Maya session.

Related topics

“Interface preferences” in the Preferences and Customization chapter of the
Basics guide.

“Ul Elements preferences” in the Preferences and Customization chapter of
the Basics guide.

“Help preferences” in the Preferences and Customization chapter of the
Basics guide.
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“Display preferences” in the Preferences and Customization chapter of the
Basics guide.

“Kinematics preferences” in the Preferences and Customization chapter of
the Basics guide.

“Animation (Display) preferences” in the Preferences and Customization
chapter of the Basics guide.

“Manipulators preferences” in the Preferences and Customization chapter of
the Basics guide.

“NURBS preferences” in the Preferences and Customization chapter of the
Basics guide.

“Polygons preferences” in the Preferences and Customization chapter of the
Basics guide.

“Subdivs preferences” in the Preferences and Customization chapter of the
Basics guide.

“Settings preferences” in the Preferences and Customization chapter of the
Basics guide.

“Animation (Settings) preferences” in the Preferences and Customization
chapter of the Basics guide.

“Cameras preferences” in the Preferences and Customization chapter of the
Basics guide.

“Dynamics preferences” in the Preferences and Customization chapter of the
Basics guide.

“Files/Projects preferences” in the Preferences and Customization chapter of
the Basics guide.

“Modeling preferences” in the Preferences and Customization chapter of the
Basics guide.

“Rendering preferences” in the Preferences and Customization chapter of the
Basics guide.
“Selection preferences” in the Preferences and Customization chapter of the
Basics guide.

“Snapping preferences” in the Preferences and Customization chapter of the
Basics guide.

“Sound preferences” in the Preferences and Customization chapter of the
Basics guide.

“Timeline preferences” in the Preferences and Customization chapter of the
Basics guide.

“Undo preferences” in the Preferences and Customization chapter of the
Basics guide.

“Web browser preferences” in the Preferences and Customization chapter of
the Basics guide.

“Modules preferences” in the Preferences and Customization chapter of the
Basics guide.
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Animation controls menu

If you right-click anywhere in the Time Slider, a menu is displayed for animation
control operations. These operations work on keys of the currently selected
objects.

Copy, Cut, Paste, and Delete

Cut, Copy, and Delete affect the keys at the current time or in the selected
ranges. Cut and Copy place the selected keys on an internal clipboard for
pasting, and Delete removes the selected keys from the timeline. Copy, Cut, and
Delete also operate on integer time ranges. For example, if your current time is 5,
these items act on the range of 5 up to 6, but not including any keys at time 6.

Paste puts any copied or cut keys from the clipboard at the current time. Paste >
Paste Connect pastes copied keys the same as if you select Edit > Keys > Paste
with the Connect option turned on.

There are two ways to paste keys into the Time Slider:

e Click the time where you want the pasted keys to start. Existing keys beyond
that time will be shifted by the time range of the pasted keys.

e To fit the keys into a particular time range, Shift-click the Time Slider to
select a time range. The keys will be scaled to fit that range. Existing keys in
the selected area are removed.

Delete FBIK Keys

You can access the Time Slider context sensitive menu by right-clicking in the
Time Slider.

Delete All FBIK Keys

For the current character, deletes all the keys at the Current Time Indicator
from its FBIK effectors and FK joints.

Delete Body Part Keys

For the current body part, deletes all the keys at the Current Time Indicator
from its FBIK effectors and FK joints.

Delete Selected
For the selected FBIK effectors, deletes all their keys at the Current Time
Indicator as well as those on their FK joints.

Snap

Use Snap to force selected keys to snap in time to the nearest whole time units.

Keys

e Convert to Key will convert selected Breakdowns to normal keys.
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e Convert to Breakdown will convert normal keys to Breakdowns.
e Add Inbetween will add a single Inbetween.
e Remove Inbetween will remove a single Inbetween.

Tangents

The Tangents item will set the tangent of the keys at the current time, or all the
keys in a selected time range.

Playback Looping

To select playback looping options, right-click the Timeline and select Playback
Looping > Once, Oscillate, or Continuous. These are the same options as those
in the Preferences window.

Set Range To

e Start/End sets the playback range to the Start and End values set in the
Playback Range numeric input fields.

e Min/Max sets the playback range to the first and last keys of the scene.

e Selected sets the playback range to the range defined by the current
selection on the Time Slider.

e Sound Length sets the playback range to the duration of a sound currently
loaded into the Time Slider.

e Preferences sets the playback range to the values in the Preferences window.

Sound

This menu lets you select an imported sound to be displayed on the Time Slider.

Time Slider Key Edit menu
Select > Sound > filename > 0.
Sound File

This is the name of the file referenced by this audio node. When the Time
Slider displays this sound, it looks for the soundtrack to play in this file. If
you move this file to another location or it is renamed, you can update the
new location of the file here.

Start Time

This is the time the soundtrack starts to play, in current time units. For
example, if the selected Time Units is Film (24 fps), a Start Time of 48 starts
the soundtrack after two seconds of animation.
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Playblast

Selecting this opens the Playblast window. Selecting the option box () opens
the Playblast options window.

Menus

Window >

Window > Playblast

Previews the current animation. When you Playblast an animation, the Playblast
outputs a series of individual frames in the format specified in the Image File
Output settings of Render Settings. For more information, see the Rendering
guide. The default Playblast image formats are the following: .avi (Windows), .iff
(Linux), and .qt (Mac OS X).

Related topics

R/

s "Previewing animation” on page 20

7

% "Playblast animation” on page 41

Window > Playblast > 0

By default, Playblast previews the animation using the active view and the current
time range in the time slider to determine the animation range. The default scale
is 0.5, which makes the Playblast image resolution one-quarter the size of the
active view.

Note e Source images for the movie file are taken directly from the
screen display. If the display area has other windows on top of
it, the resulting movie file is affected.

e Playblast AVI creation calls upon the system movie libraries to
generate the selected compression scheme. Alias cannot
guarantee the reliability or success of all the compressors
available to your operating system.

View

If turned on, Playblast displays the images using the specified viewer. If
turned off, blasted images are saved to file according to the Movie file setting
in the Playblast Options window.

Show Ornaments

This displays the camera name and the axes at the origin and bottom left of
the view.
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Viewer

Movieplayer
(Windows only)

fcheck

QuickTime
(Mac OS X only)

Compression

Windows

(Linux)

(Mac 0S X)

Display Size

1 | Animation Basics
Reference > Window > Playblast

If on, Playblast uses the desktop video playback
application specified in your Windows environment to
view the Playblasted images.

If on, the fcheck utility is used to preview the Playblasted
images.

If on, the QuickTime player is used to preview
Playblasted images.

Compression is only available if the current Viewer is
Movieplayer. Opens the Video Compression window. This
window lets you define the compression method for the
animation you want to Playblast. The list of available
compression methods depends on the video codecs you
have installed on your system.

Since you can only Playblast animation with the FCheck
utility on Linux, Compression for Playblast is not
available.

Compression is only available if the current Viewer is
QuickTime. Opens the QuickTime Compression Settings
window. This window lets you define the compression
method for the animation you want to Playblast. The list
of available compression methods depends on
QuickTime’s built-in video codecs. For more information
on compression methods for QuickTime, search for
Compressors at www.apple.com/quicktime.

There are three options for controlling the resolution of the playblast images
that are created. In each of these three cases, the final size of the images
will be further scaled by the amount in the Scale option.

From Window

From Render
Settings

Custom

Makes the Playblast images the same size as the Active
view.

Makes the Playblast images the size specified by the
Width and Height attributes in the default Resolution tab
of the Window > Render Settings window.

Activates two fields below the Display Size option that
allow you to specify the Width and Height of the Playblast
images.
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Scale

Whereas the Display Size option gives you control over the size as well as the
aspect ratio of the images, the Scale option lets you further refine the size of
the Playblast images by applying a scale factor to the resolution specified in
the Display Size option.

The default is 0.5, which is one-quarter the size of the Display Size (0.5 of
the width and 0.5 of the height).

Remove Temporary Files

Turn on this option to delete the temporary files created by playblasting when
you end your Maya session. Temporary files are written to the c: \temp
directory on Windows, and /var/tmp/ or

/tmp/ on Linux, and under Documents/temp in your Home folder on Mac OS
X.

Save to File

Turn this on to save a movie file or image sequence to disk. If turned on, an
entry field lets you enter a filename. You can also click a Browse button to
locate an appropriate directory. If the Output Format selection is Movieplayer,
the file saved is in movieplayer format. If the format is fcheck, the format is
read from the Image Format attribute in the defaultRenderGlobals tab of the
Render Settings window.

Movie File

If you use the Browse button to specify the file name for your Playblast
image(s), a full path name will be specified.

If a filename with no path is specified for the movie file, the location of the
file image(s) is set by your current project setting. If the Images location is
specified in the current project window (File > Project > Edit Current), the
Playblast image(s) is created in the Images location. Otherwise, the images
are created in the default location of the project.

Playblasting FCheck files
See “Overview of FCheck” in the FCheck chapter of the Rendering Utilities guide.

Animation menu set

Animate >

Animate > Ghost Selected

Turns ghosting on for all selected objects. See "Ghosting animated objects” on
page 20 and "To ghost an object” on page 35.
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Animate > Ghost Selected > 0

Note You can also set local ghosting options with the Ghosting
Information attributes. To access these attributes, select Attribute
Editor > objectShape > Object Display.

Type of Ghosting

Global

Preferences Uses the ghosting settings from Windows > Settings/
Preferences > Preferences > Animation.

Custom Frames Generates ghosts at the frames specified in the Frames

To Display field.

Custom Frame

Steps Controls the number and spacing of ghosts for frames.

Custom Key

Steps Controls the number and spacing of ghosts for
keyframes.

Keyframes Generates ghosts at the range of keyframes defined by

the Frame Range options.
Frames to Display

Lets you define a list of frames at which ghosts are generated for the current
object. When entering frame numbers, use the following syntax:

#, #, #, #
For example: 1, 5, 10, 15. This field is available only when the ghosting type
is Custom Frames.

Steps Before Current Frame

Only available when the ghosting type is Custom Frame Steps or Custom Key
Steps.

When the ghosting type is set to Custom Frame Steps, this field sets the
number of ghosts that appear before the current frame. Spacing of these
ghosts is defined by the Step Size field.

When the ghosting type is set to Custom Key Steps, this field sets the
number of ghosts that appear before the current frame. Spacing of these
ghosts is defined by the number of keyframes on an object and the Step
Size.

Steps After Current Frame

Only available when the ghosting type is Custom Frame Steps or Custom Key
Steps.
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For Custom Frame Steps, this field sets the number of ghosts that appear
after the current frame. Spacing of these ghosts is defined by the Step Size
field.

For Custom Key Steps, this field sets the number of ghosts that appear after
the current frame. Spacing of these ghosts is defined by the number of
keyframes on an object and the Step Size.

Step Size

Only available when the ghosting type is Custom Frame Steps or Custom Key
Steps.

For Custom Frame Steps, Step Size determines the number of frames
between each ghost. For example, if the Step Size is 10, every tenth frame is
ghosted.

For Custom Key Steps, Step Size and the number of keyframes control the
spacing of ghosts. For example, if the Step Size is 2, then every other key is
ghosted.

Frame Range
These options are available only when the ghosting type is Keyframes.

Timeslider Generates a ghost of the current object at every
keyframe on the timeline.

Start/End Generates a ghost of the current object at the keyframes
between the specified Start Frame and End Frame.

Start Frame

The frame at which the ghosting of keyframes begins. This field is available
only when Start/End under Frame Range is selected.

End Frame

The frame at which the ghosting of keyframes ends. This field is available
only when Start/End under Frame Range is selected.

Hierarchy

The specified ghost options are applied to the entire hierarchy below the
selected joint or object. If Hierarchy is not selected, only the selected object
is affected by the Ghost Options.

Note e Hierarchy can seriously affect performance. We recommend
that you use Hierarchy sparingly.

e For Custom Key Steps and Keyframes, ghosts only appear for
objects in the hierarchy that possess keyframes, unless Ghost
Driver is on.
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Use Ghost Driver

Note Ghost Driver is relevant for only keyframe-based ghosting.

When on, the specified keys from the first selected object drive the ghosting
for the rest of the selected objects. When off, all the selected objects use
their own keys for ghosting. Use Ghost Driver is useful for comparing timing.

Object Type

Lets you specify which parts of a character are ghosted. See "Previewing
animation” on page 20.

When ghosting hierarchical characters, turn on Hierarchy in the Ghost
Selected Options window if you want to limit which parts of a character’s
children are ghosted.

Geometry Only the geometry of the current object is ghosted.

Locator Only the locators for the current object are ghosted.

Joint Only the joints and bones for the current object are
ghosted.

All Other Types Only the parts of the current object that are not
geometry, locators, or joints are ghosted.

Animate > Unghost Selected

Unghost Selected turns ghosting off for all selected objects. See "Ghosting
animated objects” on page 20 and "To unghost an object” on page 35.

Animate > Unghost Selected > o
The Unghost Selected menu item turns ghosting off for selected objects.
Hierarchy

When on, the selected object and its child bones or objects are unghosted.
When off, only the selected object is unghosted.

Animate > Unghost All

Turns off ghosting for all objects in the scene.

Animate > Create Motion Trail

Creates a motion trail for the current object. See "To create a Motion Trail” on
page 36.
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Animate > Create Motion Trail > 0

Time Range

Time Slider Creates a Motion Trail for all the frames in the time
slider.

Start/End Creates a Motion Trail for the frames specified by the
Start Time and End Time.

Start Time The time at which the motion trail begins. This field is
available only when Start/End under Time Range is
selected.

End Time The time at which the motion trail ends. This field is
available only when Start/End under Time Range is
selected.

Increment Specifies the number of frames between which the
Motion Trail is drawn.

Update
On Demand Updates the Motion Trail only when you select Animate >

Update Motion Trail/Snapshot.

Fast (Update

Only When

Keyframes

Change) Updates the Motion Trail when you add or change a
keyframe for the object with the Motion Trail. It won’t
update if you change an expression.

Slow (Always

Update) Updates the Motion Trail if you change anything in the
shape or animation of the object with the Motion Trail.
This includes translating or deforming the object.

Draw Style

Sets how the Motion Trail is drawn. Select Line, Locator, or Point.

Motion Trail - locator draw style Motion Trail - point draw style
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Frames

Turn on Show Frame Numbers to see the number of the frame at which the
Motion Trail is drawn.

Animate > Create Animation Snapshot

Creates an animation snapshot for the current object. See "To use animation
snapshot” on page 46.

Animate > Create Animation Snapshot > 0

Time Range
Start/End Creates an Snapshot for the frames specified by the
Start Time and End Time.
Time Slider Creates an Snapshot for all the frames in the time
slider.
Increment

Specifies the number of frames between which the Snapshot is drawn.
Update

On Demand Updates the snapshot only when you select Animate >
Update Motion Trail/Snapshot.

Fast (Update

Only When

Keyframes

Change) Updates the snapshot when you add or change a
keyframe for the object with the snapshot.Won't update
if you change an expression.
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Slow (Always

Update) Updates the snapshot if you change anything in the
shape or animation of the object with the snapshot. This
includes translating or deforming the object.

Animate > Update Motion Trail/Snapshot

Recalculates the Motion Trails and Animation Snapshots in your scene.

Animate > Create Animated Sweep

Creates an animated sweep for the selected objects. See "To use animated
sweep” on page 47.

Animate > Create Animated Sweep > O

Time Range
Time Slider Creates an animated sweep for the length of time
defined by the length of the time slider.
Start/End Lets you set a specific a Start time and End Time for the
animated sweep.
By Time

Evaluates the animation and create geometry for each By Time position.
Parameterization

Uniform knot Makes the profile curves run parallel to the V direction.
The parameter values of the resulting surface in the U
direction are equally spaced. The first profile curve
corresponds to the isoparm on the surface at U[O], the
second to U[1], and so on.

Chord Length Causes the parameter values on the resulting surface in
the U direction to be based on the distance between the
start points of the profile curves.

Surface Degree

Sets the lofted surface to linear or cubic in the U direction.

Linear Creates surfaces that appear faceted.
Cubic Creates smooth surfaces.
Surface

Specifies whether an open or closed surface is created. See the Maya
NURBS Modelling Guide for more information.
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Output Geometry

Specifies the type of geometry created. You can choose form NURB or
Polygons.

Nodes

Animation nodes

mute

Mute in the Channel Box
mute_objectn_channel

The mute node as it appears in the Channel Box. Example mute node names
include: mute_pCubel_translateX, mute_joint1_rotateZ and so on.

When the Mute attribute is set to on, all animation nodes that connect to the
mute node are muted. When the mute node is set to off, all animation nodes that
connect to the mute node are not muted. Setting the mute node to off in the
Channel Box does not remove it from the scene hierarchy.

Hypergraph

A mute node is generated for each channel that is muted. The muted channels
input to the mute node, and the mute node outputs to the object.

All other
Object

animation
channels
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About

Keyframe Animation

The Keyframe Animation chapter contains a complete discussion of the menus,
windows, editors, and procedures you use when animating objects with
keyframes in Maya.

Keys

Setting keys is the process of creating the keys that specify timing and motion.
Animation is the process of creating and editing the properties of objects that
change over time. Keys are arbitrary markers that designate the property values
of an object at a particular time.

Once you create an object you want to animate, you set keys that represent when
the attributes of that object change during your animation. Setting a key involves
moving to the time where you want to establish a value for an attribute, setting
that value, then placing a key there. In effect, you are recording a snapshot of the
attribute at that time.

You can rearrange, remove, and duplicate keys and sequences of keys. For
example, you can copy the animated properties of one object onto another, or
you can stretch a chunk of animation over a longer period of time than you
originally keyed.

Auto Key

Auto Key automatically sets keys on attributes when you change the current time
and attribute value. A key must already exist for an attribute before you use Auto
Key. For more information, see "Use Auto Key” on page 89.

= or  [E on

Keys in the Attribute Editor

The Attribute Editor displays attributes you can edit and key (animate). You can
key attributes by right-clicking them in the Attribute Editor, and then selecting Set
Key from the pop-up menu. This menu is not available for attributes you cannot
key. See "To add keys” on page 74.

Certain attributes are assigned a keyable status by default in Maya. For example,
all objects are assigned the following keyable attributes:

e Rotate X, Y,and Z
e Scale X,Y,and Z
e Translate X, Y, and Z
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e Visibility

Keys in the Channel Box, Graph Editor, and Dope
Sheet

You can use the Channel Box for keying operations on attributes of selected
objects.

You can also use the Graph Editor to edit and key animation curves for previously
animated objects, and you can use the Dope Sheet to set timing and keys for
objects.

Cutting, copying, and pasting keys between scenes

You can cut, copy, and paste animations of characters, skeletons, and other
objects to objects in another scene.

One way is to export and import animation using the animimportExport plug-in.
However, if you copy an animation to the keys clipboard, it stays on the clipboard
when you do File > New and File > Open. This means you can retrieve a scene
with animation, select a character and copy the animation, then retrieve another
scene (with the same character in it) and paste the animation into it.

In summary, animation on the keys clipboard is persistent across File > New and
File > Open selections, which means you could retrieve a scene with animation
and copy it, and then retrieve another scene with the same character and paste
the animation onto it. See "Cutting, copying, and pasting keys between scenes”
on page 68.

Keys clipboard

The keys clipboard is a temporary storage area for keys and animation curve
segment information. Storing new information on the keys clipboard replaces any
information previously on the keys clipboard.

The same keys clipboard in Maya is available throughout all editors and windows.
For example, information placed on the keys clipboard with a Cut operation in the
Graph Editor may be pasted onto an object in the scene view using Edit > Keys >
Paste Keys.

The keys clipboard is not an editor nor is it viewable in any window in Maya.
Exiting Maya clears the clipboard.

Driven keys

Maya has special driven keys that link one attribute value to another. In regular
animation keys, an attribute has values keyed to times in the Time Slider. For a
driven key, an attribute has values keyed to the value of a driving attribute.
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A change in a driver attribute alters the value of the driven attribute. For instance,
you can set driven keys to make a door open when a person walks in front of the
door.

An attribute can be driven by multiple attributes. For instance, you can make a
muscle bulge when an elbow rotates. You can make the muscle bulge even more
when the wrist rotates.

When you set driven keys, Maya creates a Graph Editor curve that shows the
relationship between the linked attributes. For regular animation keys, the Graph
Editor’'s vertical axis lists attribute values, and the horizontal axis lists animation
time values.

For driven keys, the Graph Editor’s vertical axis lists driven attribute values, and
the horizontal axis lists driver attribute values. For each attribute value of the
driver, the curve shows the associated value of the driven attribute. You can edit
the curve to alter the relationship. You can’t animate driven attributes with
regular keyframes.

The Time Slider is not involved in a driven key relationship and displays no red
markers for the keys. Playing or scrubbing the animation alters the value of a

driven attribute only if you animate the value of the driving attribute over time.
See "Set Driven Keys” on page 91.

Linking multiple attributes

You can use two or more driver attributes to control a single driven attribute. You
can also drive more than one driven attribute with the same driver attribute. The
technique is similar to linking two attributes, with the following exceptions:

e Load all appropriate objects into the Set Driven Key window. For example,
select all driver objects in the workspace, then click Load Driver.

e You can set a key for only one driver attribute at a time in the Set Driven Key
window. You can’t select two driver attributes at the same time. You must
key each driver attribute to a driven attribute separately. You can select and
key multiple attributes in a driven object.

e When you load two or more objects into the Driver or Driven lists of the Set
Driven Key window, no attributes appear for the objects. Click an object in
either list to select it and see its attributes.

Breakdowns

Breakdowns are special keys that maintain proportional time relationships with
adjacent keys. Use Breakdowns to adjust the timing of an animation while holding
attribute values at points on the animation curve. Breakdowns are green ticks on
the time slider and green points in the Graph Editor.

Breakdowns that do not have adjacent keys are unbounded. These work like
regular keys when you place, edit, and move them. Breakdowns have editable
tangents. When one or more Breakdowns are bounded by regular keys, the
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Breakdowns modify their position in time to reflect any changes to the time
positions of the regular, bounding, keys. For more information, see ”Set
Breakdowns” on page 90.

The key at time 11 is moved;
the breakdown at time 17 modifies its position proportionately.

Inbetweens

Inbetweens offer a way to adjust animation timing by adding or removing one
frame or time unit. Keys and Breakdowns preserve their tangent characteristics,
resulting in a minimal change to existing animation curves. See "Set Inbetweens”

on page 91.

Using Add Inbetween

Using Remove Inbetween

Using Add Inbetween will cause the animation’s keys to be shifted by one whole
time unit forward from the current time.
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Using Remove Inbetween will cause the animation’s keys to be shifted by one
whole time unit backward from the current time.

Graph Editor overview

With the Graph Editor, you can edit visual representations of keys and animation
curves.

Animation curves

Use the Graph Editor to manipulate animation curves. The animation curves
appear in the graph view. See "Graph Editor” on page 118. Animation curves are
of keys represented as points, curve segments between keys, and tangents that
control how curve segments enter and exit a key.

The Graph Editor is available as a panel in the scene view or as an independent
window. To place the Graph Editor in a scene view, select the scene view in which
you want the Graph Editor to appear, and then select Panels > Panel > Graph
Editor. To open the Graph Editor as an independent window, select Window >
Animation Editors > Graph Editor.

The Graph Editor has the following components:
e Menu bar

e Toolbar

e Qutliner

e Graph view

The Graph Editor works only with keys and animation curves, so certain types of
animation are not viewable here. Expressions and inverse kinematics are not
available for editing in the Graph Editor.

Note Use Show Results to produce a representational animation curve
from animation that is not normally viewable as animation curves.
Show Results does not enable editing of these curves, however.

Euler angle filtering

When you import motion capture data into Maya as animation curves, the curves
might be mangled when the rotation values are restricted to a specific range. You
can filter the curves to correct the mangling.

Euler angles calculate the rotation interpolation using three separate vectors: the
X, Y, and Z axes.

In the Graph Editor, select the mangled animation curves (for example, Rotate X,
Y, and Z), then select Curves > Euler Filter. The filtering is always applied to
entire curves, not to selected curve segments within some time range.
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Quaternion Rotation

Maya provides smooth quaternion interpolation of animated rotations.
Quaternions calculate rotation interpolation using four vectors: the X, Y, and Z
axes and an angle of rotation (W). This prevents the gimbal lock and flipping
problems that are sometimes encountered with Euler angle interpolation. Maya
also supports Euler angle interpolation for cases where you prefer Euler
interpolation, and for pre-Maya 5 scene files.

The quaternion curves are synchronized, which means the keyframes on the XYZ
curves that determine the rotation stay locked together in time. When you add,
delete, or move a keyframe on one curve, the corresponding key is also updated
in the related curves. This eliminates unexpected interpolation problems that can
occur when keyframes are deleted from only one of the axes, or vertices are
moved independently in time.

Maya also has an option for creating Synchronized Euler-Angle Curves. In this
mode, the keyframes are locked together in Quaternion but the interpolation
between keyframes is in Euler angles.

You can change the rotation interpolation type of existing curves using the Curves
> Change Rotation Interp menu in the Graph Editor and Dope Sheet. "To set
rotation interpolation for new curves” on page 95 and "To change rotation
interpolation in existing curves” on page 96.

Regardless of whether the rotation is Quaternion or Euler angles, the Channel
Box displays Euler angle values.

Set IK/FK Key curves in the Graph Editor

When you use Set IK/FK Key to animate between IK and FK (and vice versa), the
Graph Editor displays the animation curves of the IK handle and its joints partly
as solid lines and partly as dotted lines.

For example, when you display an animation curve for the IK handle’s Translate
X, Y, or Z channels, the curve is displayed as a solid line when Ik Blend is 1.000
and as a dotted line when Ik Blend is 0.000. In other words, the solid line shows
where the IK handle controls the joint chain’s animation and the dotted line
shows where FK (keyed joint rotations) controls the animation.
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Note Animating the |k Blend attribute directly does not cause your IK/FK
blended curves to display as solid/dotted lines. IK/FK blended
curves only appear as solid and dotted lines in the curve view when
you use Set IK/FK Key to key your animation channels.

For more information on the Ik Blend attribute or Set IK/FK Key, see “IK/FK
blending” and Animate > IK/FK Keys > Set IK/FK Key in the Character Setup and
Deformers guide.

Dope Sheet

The Dope Sheet lets you edit event and sound synchronization and timing.

Use the Dope Sheet to manipulate key times, represented as colored rectangles
in the view area. The blocks represent integer time units along the horizontal
axis. The vertical axis represents the items currently loaded into the Dope Sheet
outliner. The Dope Sheet consists of:

e Dope Sheet outliner
e Menu bar

e Toolbar

e \View area

See "Dope Sheet” on page 145.

Set keys

Set key preferences

To edit key preferences

1 Click the Animation Preferences button.

2 In the Categories box, select Keys. For more information, see "Channel
Control Editor” on page 116.

3 Do one of the following:
e Click Save to save the current key preferences for your scene.
The Preferences window closes.

e Click Close to disregard any changes to the key settings and closes the
Preferences window.
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Add keys

To add keys

1 Select the objects that have the attributes you want to key.
2 Select Animate > Set Key.

A key is set based on the Set Key options. For more information, see "Keys”
on page 67 and "Animate > Set Key” on page 171.

Set key options

To set key options

1 Select Animate > Set Key > 0.
The Set Key Options window appears.
2 Set the options. See "Animate > Set Key” on page 171.
3 Do one of the following:
e Click Set Key to add an animation key to your object.
The Set Key Options window closes.
e Click Apply to add an animation key to your object.
The Set Key Options window remains open.

e Click Close to disregard any changes made to the Set Key options and
close the Set Key Options window.

Modify key attributes

To set key attributes

e The Animate menu has entries for setting and controlling keys.
e Path animation uses 3D curves to set the direction of animated objects.

e The Attribute Editor and Channel Box have menu items for setting keys for
the attributes displayed.

e You can use keyboard hotkeys to set keys for transformation node attributes.
e You can use marking menus to edit keys.

e The Graph Editor lets you set and edit keys for existing animation.

e The Dope Sheet lets you set and edit keys for existing animation.
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Edit the keyability of an object

To make a channel keyable or nonkeyable from the Channel Box

1 Select the object that has the channel you want to make keyable or
nonkeyable.

2 In the Channel Box, select the channel you want to make keyable or
nonkeyable.

3 Do one of the following:
e Right-click the channel.
The Channel Box’s Channels pop-up menu appears.
e Select Channels in the Channel Box's menu bar.
The Channel Box’s Channels menu appears.

4 Do one of the following:

e If you want to make the selected channel keyable, select Make Selected
Keyable.

e |f you want to make the selected channel nonkeyable, select
Make Selected Nonkeyable.

The selected channel now appears light gray in the Channel Box.

To make a channel keyable or nonkeyable from the Channel Control Editor

1 Select the object that has the channel you want to make keyable or
nonkeyable.

2 In the Maya main menu bar, select Window > General Editors > Channel
Control.

The Channel Control Editor appears with all the selected object’s channels
loaded. See "Channel Control Editor” on page 116.

3 Select the channel you want to make keyable or nonkeyable.

4 Click the | Move >> | or | < Move | button to do one of the
following;:

e To make a channel keyable, and have it appear in the Channel Box, move
the selected channel to the Keyable column.

e To make a channel nonkeyable, and have it not appear in the Channel
Box, move the selected channel to the Nonkeyable Hidden column.

e To make a channel nonkeyable, and have it appear in the Channel Box,
move the selected channel to the Nonkeyable Displayed column.
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Disable the editability of attributes without deleting
them

Note When attributes are locked they are unavailable for editing and they
appear gray in the Attribute Editor and the Channel Box.

To lock a channel in the Channel Box

1 In the Channel Box, select the channel.
2 Right-click the channel.

The Channels menu appears.
3 Choose Lock Selected from the menu.

To lock a channel in the Channel Control menu

1 Select Window > General Editors > Channel Control.
The Channel Control window appears.
2 Click the Locked tab to reveal the Locked and Non Locked lists.
3 Select the channel and click << Move to change its status to Locked.

866 Channel Control - nurbsSphere2
Object Help

[ Keyable [ Lacked |

Locked Non Locked
caching m
displayHandle

displaylLocalAxis

displayRotatePivot
displayScalePivot
ghosting
identification
inheritsTransform
intermediateOhject

layerOverrideColor

D Change all selected ohjects of the same type

Move ‘ Close |

The process of managing attributes in the Locked tab of the Channel Control
window is the same as that used in the Keyable tab.

Note Locked attributes may also be unlocked in the Attribute Editor by
right-clicking in the field of the locked attribute.
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To unlock a channel in the Channel Box

1 In the Channel Box, select the channel.
2 Right-click the channel.

The Channels menu appears.
3 Choose Unlock Selected from the menu.

To unlock a channel in the Channel Control menu

1 Select Window > General Editors > Channel Control.
The Channel Control window appears.
2 Click the Locked tab to reveal the Locked and Non Locked lists.
3 Select the channel and click Move >> to change its status to Non Locked.

Edit keys

The following procedures describe how to manage and manipulate the keys in
your scene.

Cut keys

Cutting a keyset is essentially the same as copying keys to the keys clipboard
then deleting them.

Note e When cutting and pasting keys that include multiple animation
curves to multiple attributes, pay particular attention to the
order that you select them, as this will impact the order in
which they are pasted.

e When cutting keys from multiple attributes in the Graph Editor
or Dope Sheet, select the attributes from the outliner—not the
view area—of the respective editor.

To cut keys

1 Set the Cut Keys options. See "To set Cut Keys options” on page 78.
2 Do one of the following:
e To select a single key, click the key in the Timeline.

The Current Time Indicator moves to the clicked position and the key is now
selected.

e To select multiple keys, Shift-drag over the range of keys in the Timeline.
The range of keys is now selected and highlighted in red.

3 Do one of the following:
e Rightclick and select Cut from the menu that appears.
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e Select Edit > Keys > Cut Keys.

If Time Range-All is on in the Cut Keys options, all keys for the current object
are cut. If Time Range-Start/End is on in the Cut Key options, only keys
between the specified Start and End time are cut. If Time Range-Time Slider

is on in the Cut Keys options, only the keys between the Range Slider’s Start
and End times are cut.

e Press Shift+s-click and select Cut Keys from the marking menu that
appears.

To set Cut Keys options

1

Select Edit > Keys > Cut Keys > 0.

The Cut Keys Options window appears.

Set the Cut Keys options. See "Edit > Keys > Cut Keys” on page 160.
Do one of the following:

e Click Cut Keys to set the Cut Keys options and cut the current key(s).
The Cut Keys Options window closes.

e Click Apply to set the Cut Keys options and cut the current key(s).
The Cut Keys Options window remains open.

e Click Close to disregard any changes made to the Cut Keys options and
close the Cut Keys Options window.

Copy keys

You can copy keys to the keys clipboard.

Note e When copying and pasting keys that include multiple animation

curves to multiple attributes, pay particular attention to the
order that you select them, as this will impact the order in
which they are pasted.

e When copying keys from multiple attributes in the Graph Editor
or Dope Sheet, select the attributes from the outliner—not the
view area—of the respective editor.

1
2

To copy keys

Set the Copy Keys options. See "To set Copy Keys options” on page 79.
Do one of the following:
e To select a single key, click the key in the Timeline.

The Current Time Indicator moves to the clicked position and the key is now
selected.

e To select multiple keys, Shift-drag over the range of keys in the Timeline.
The range of keys is now selected and highlighted in red.
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3 Do one of the following:

e Rightclick and select Copy from the menu that appears.
e Select Edit > Keys > Copy Keys.

If Time Range-All is on in the Copy Keys options, all keys for the current
object are copied to the clipboard. If Time Range-Start/End is on in the Copy
Keys options, only keys between the specified Start and End time are copied
to the clipboard. If Time Range-Time Slider is on in the Copy Keys options,
only the keys between the Range Slider’'s Start and End times are copied to
the clipboard.

e Press Shift+s-click and select Copy Keys from the marking menu that
appears.

To set Copy Keys options

1

Select Edit > Keys > Copy Keys > (.

The Copy Keys Options window appears.

Set the Copy Keys options. See "Edit > Keys > Copy Keys” on page 158.
Do one of the following:

e Click Copy Keys to set the Copy Keys options and copy the current key(s)
to the clipboard.

The Copy Keys Options window closes.

e Click Apply to set the Copy Keys options and copy the current key(s) to
the clipboard.

The Copy Keys Options window remains open.

e Click Close to disregard any changes made to the Copy Keys options and
close the Copy Keys Options window.

Paste keys

You can paste cut keys, or keys copied to the clip board, from one object in your
scene to another object.

To paste keys

1
2

Set the Paste Keys options. See "To set Paste Keys options” on page 80.
Do one of the following:

e To paste a single key, click in the Timeline.

The Current Time Indicator moves to the clicked position.

e To paste multiple keys, Shift-drag over the range of keys in the Timeline
that you want the pasted keys to be added to, to replace, or to merge
with.

The range of time is now selected and highlighted in red.
Do one of the following:
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e Rightclick and select Paste from the menu that appears.
e Select Edit > Keys > Paste Keys.

e Shift+s-click and select Paste Keys from the marking menu that appears.

To set Paste Keys options

1

Select Edit > Keys > Paste Keys > (.

The Paste Keys Options window appears.

Set the Paste Keys options. See "Edit > Keys > Paste Keys” on page 161.
Do one of the following:

e Click Paste Keys to set the Paste Keys options and paste the current cut
or copied key(s).

The Paste Keys Options window closes.

e Click Apply to set the Paste Keys options and paste the current cut or
copied key(s).

The Paste Keys Options window remains open.

e Click Close to disregard any changes made to the Paste Keys options
and close the Paste Keys Options window.

Delete keys

Deleting a keyset is removing the keyset from animated objects without saving
the keyset to the keys clipboard.

Note There is no deleteKeys MEL command. The related MEL command

for deleting keys is cutKey -Clear.

To delete keys

1
2

Set the Delete Keys options. See "To set Delete Keys options” on page 81.
Do one of the following:
e To select a single key, click the key in the Timeline.

The Current Time Indicator moves to the clicked position and the key is now
selected.

e To select multiple keys, Shift-drag over the range of keys in the Timeline.
The range of keys is now selected and highlighted in red.

Do one of the following:

e Rightclick the key and select Delete from the pop-up menu that appears.
e Select Edit > Keys > Delete Keys.
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If Time Range-All is on in the Delete Keys options, all keys for the current
object are deleted. If Time Range-Start/End is on in the Delete Keys options,
only keys between the specified Start and End times are deleted. If Time
Range-Time Slider is on in the Delete Keys options, only the keys between
the Range Slider’s Start and End times are deleted.

e Shift+s-click and select Delete Keys from the marking menu that
appears.

To set Delete Keys options

1 Select Edit > Keys > Delete Keys > .

The Delete Keys Options window appears.
2 Set the Delete Keys options. See "Edit > Keys > Delete Keys” on page 163.
3 Do one of the following:

e C(Click Delete Keys to set the Delete Keys options and delete the current
key(s).

The Delete Keys Options window closes.

e Click Apply to set the Delete Keys options and delete the current key(s).

The Delete Keys Options window remains open.

e Click Close to disregard any changes made to the Delete Keys options
and close the Delete Keys Options window.

Scale keys

You can scale keys to change the duration of a range of keys and animation
curve segments.

Warning If tangents of the fixed type (see "Tangents menu” on page 136 for
a description of the fixed tangent type) are within the range of keys
and animation curve segments to be scaled, the shape of the
animation curve may not be preserved.

To scale keys

1 Set the Scale Keys options. See "To set Scale Keys options” on page 82.
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Tips e You can cut the duration of a range of animation in half using

the Time Scale/Pivot option.

e To scale the animation without affecting the curves of the
animation before and after this range, select the Scale/Pivot
Method.

Keys and animation curve segments adjacent to the scaled
region will be shifted in time by the amount the scaled range
has been compressed or expanded, but their shapes are be
preserved.

2 Do one of the following:

e To select a single key, click the key in the Timeline.

The Current Time Indicator moves to the clicked position and the key is now
selected.

e To select multiple keys, Shift-drag over the range of keys in the Timeline.
The range of keys is now selected and highlighted in red.

Do one of the following:

e Rightclick and select Scale from the menu that appears.

e Select Edit > Keys > Scale Keys.

If Time Range-All is on in the Scale Keys options, all keys for the current
object are scaled.

If Time Range-Start/End is on in the Scale Keys options, only keys between
the specified Start and End times are scaled.

If Time Range-Time Slider is on in the Scale Keys options, only the keys
between the Range Slider’'s Start and End times are scaled.

To set Scale Keys options

1

Select Edit > Keys > Scale Keys > .

The Scale Keys Options window appears.

Set the Scale Keys options. See "Edit > Keys > Scale Keys” on page 165.

Do one of the following:

e C(Click Scale Keys to set the Scale Keys options and scale the current
key(s).

The Scale Keys Options window closes.

e Click Apply to set the Scale Keys options and scale the current key(s).

The Scale Keys Options window remains open.

e Click Close to disregard any changes made to the Scale Keys options
and close the Scale Keys Options window.
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Snap keys

Use Snap Keys when you wanted selected keys to snap in time to the nearest
whole time unit values or attribute values.

To snap keys

1 Set the Snap Keys options. See "To set Snap Keys options” on page 83.
2 Do one of the following;:
e To select a single key, click the key in the Timeline.

The Current Time Indicator moves to the clicked position and the key is now
selected.

e To select multiple keys, Shift-drag over the range of keys in the Timeline.
The range of keys is now selected and highlighted in red.
3 Do one of the following:
e Right-click and select Snap from the menu that appears.
e Select Edit > Keys > Snap Keys.

If Time Range-All is on in the Snap Keys options, all keys for the current
object are scaled. If Time Range-Start/End is on in the Snap Keys options,
only keys between the specified Start and End times are scaled. If Time
Range-Time Slider is on in the Snap Keys options, only the keys between the
Range Slider's Start and End times are scaled.

Note If multiple keys can be snapped to the same value, those keys are
skipped. A warning message indicates the number of skipped keys.

To find unsnapped keys

If you want to identify the keys on a curve that are not at whole time units, you
can perform a search for all unsnapped keys.

1 In the Graph Editor’s graph view, select an animation curve.

2 Rightclick the animation curve and from the menu that appears select Edit >
Select unsnapped.

To set Snap Keys options

Note These settings affect the Snap button on the Graph Editor, but not
the Time Slider Edit Keys > Snap menu item (which snaps the time
values of selected keys only).

1 Select Edit > Keys > Snap Keys > .
The Snap Keys Options window appears.
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2 Set the Snap Keys options. See "Edit > Keys > Snap Keys” on page 167.
3 Do one of the following:

e Click Snap Keys to set the Snap Keys options and snap the current
key(s).

The Snap Keys Options window closes.
e Click Apply to set the Snap Keys options and snap the current key(s).
The Snap Keys Options window remains open.

e Click Close to disregard any changes made to the Snap Keys options and
close the Snap Keys Options window.

Bake keys

To create keys for an IK joint by baking

While animation curves and key information exist for an IK handle, there is no
information available for an IK joint because its position is determined by the
animation on the IK handle. To view and edit the animation information of an IK
joint, perform a bake simulation.

1 Select the IK joint.

Select Keys  Tangents

View Bookmarks Graph Rendering Options

2 Select Edit > Keys > Bake Simulation > .
The Bake Simulation Options window appears.
3 Set the Sample By value. See "Edit > Keys > Bake Simulation” on page 169.

4 Verify that the Disable Implicit Controls option is turned on to retain the
animation imparted by the first joint in the IK chain.
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5 Click the Bake button.

Maya steps through the animation. It evaluates the scene for each time
interval specified in the Sample By field and places a key at each time.
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Edit  View

Rendering  Options

To bake a keyset

1 Select the keyset that you want to bake.

Select Edit > Keys > Bake Simulation.

To create animation curves for a driven key using Bake Channel

1
2
3

Select the driven object from scene view or the Outliner.
In the Dope Sheet window, select Curves > Bake Channel > 0.

Select Time Slider as the range to be processed or specify a range by clicking

the Start/End option and entering values in the Start Time and End Time
fields.

Enter a value in the Sample By field.
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The Sample By value is based on the Time Unit setting. It represents the
frequency with which Maya analyzes the object’s animation and generates a
key. A value of 1 creates a key for and at each time unit. High values will
decrease the frequency of generated keys, and low values increase the
number of keys created.

5 Click the Bake button.

Note Bake Channel operates only on animation that can be evaluated

explicitly. You can not use Bake Channel for Inverse Kinematics
systems, Dynamics, and some Expressions.

To generate animation curves for these animation types, select Edit
> Keys > Bake Simulation.

To set Bake Simulation options

1
2

Select the key(s) or keyset that you want to bake.
Select Edit > Keys > Bake Simulation > .
The Bake Simulation Options window appears.

Set the bake simulation options. See "Edit > Keys > Bake Simulation” on
page 169.

The Bake Simulation Options window appears.
Do one of the following:

e C(Click Bake to set the Bake Simulation options and bake the current
key(s) or keyset.

The Bake Simulation Options window closes.

e Click Apply to set the Bake Simulation options and bake the current
key(s) or keyset.

The Bake Simulation Options window remains open.

e Click Close to disregard any changes made to the Bake Simulation
options and close the Bake Simulation Options window.

Mute keys in the Dope Sheet or Graph Editor

To mute keys

1
2

3

Open the Dope Sheet or Graph Editor.

In the outliner, select the animation channel that has the key you want to
mute.

In the view, select the key you want to mute.
Do one of the following:
e |f the current key is not muted, select Keys > Mute Key On.
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The current key now no longer contributes to the animation on its channel. In
the Graph Editor or Dope Sheet, Mute appears under the current animation
channel’s name in the outliner and a Mute curve with keys appears in the
view area.
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The Mute curve has the same number of keys and they are positioned the
same as those on its animation channel.

e |f the current key is muted, select Keys > Mute Key Off.

The current key now contributes to the animation on its channel. Unmuting a
key does not remove the Mute curve. To remove the Mute curve from the
current animation channel, see "Mute or unmute a channel in the Dope
Sheet or Graph Editor” on page 99.
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Use Auto Key

Use Auto Key

Note Automatic keyframing may generate extra keys for ikHandles if their

solverEnable attributes are turned off.

For example, if solverEnable is off but snapEnable is on for an
ikHandle, the handle will move to the position of the end-effector.
This allows you to create an arm skeleton with an IK handle, set
solverEnable to off, rotate the shoulder joint, and have the ikHandle
snap to the wrist position. If auto keyframe is on, and you already
have an animCurve for the ikHandle translation, then the auto
keyframer will notice that the handle has moved and will generate
more keyframes for it.

To avoid this problem, turn off snapEnable or auto keyframing.

To Auto Key an animation

1

2
3
4

Turn on Auto Key on the Range Slider.

Set a key on any attribute of an object.

Go to a new time in the timeline.

Change the value of the previously keyed attribute.

A key is created for the attribute. You can create another key by going to a

new time and changing the value of the attribute again. For more information,
see "Auto Key” on page 67.

To hold Current Keys with Auto Key

1
2

3

Turn on Auto Key.

Select the attributes you wish to use Hold Current Keys on; set a key at the
starting position.

Create a walk cycle where a foot touches the ground at time 30.

Later in the walk cycle, for example, at time 60, another key is needed for
this position.

Instead of figuring out exactly which attributes are being keyed, move to 60
and select Animate > Hold Current Keys.
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Set Breakdowns

Set Breakdowns

Breakdowns are set using Animate > Set Breakdown. The options available for
Breakdowns are identical to Animate > Set Key > (. For more information, see
"Windows and Editors” on page 115 and "Breakdowns” on page 69.

Convert keys to Breakdowns

To convert regular keys to Breakdowns

1 Select the animation attribute or channel.
2 Do one of the following:

e Right-click the key in the Timeline and select Keys > Convert to
Breakdown.

e Select the key and Shift+s-click, then select Convert to Breakdown from
the marking menu.

To convert all the keys on a curve to Breakdowns

1 In the Graph Editor, select the animated attribute in the Graph Outliner or
select the curve from the graph view.

2 Select Keys > Convert to Breakdown.

Convert Breakdowns to keys

To convert a Breakdown to a key

1 Select the animation attribute or channel.
2 Do one of the following:
e Rightclick the key in the Timeline and select Keys > Convert to Key.

e Select the key and press Shift+s-click, then select Convert to Key from
the marking menu.

To convert all the Breakdowns on a curve to keys

1 In the Graph Editor, select the animated attribute in the Graph Outliner or
select the curve from the graph view.

2 Select Keys > Convert to Key.
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Set Inbetweens

Set Inbetweens

Tip You can also add and remove Inbetweens using the marking menu
(press Shift+s-click).

To add an Inbetween

1 Select the animation attribute or channel.
2 Do one of the following:

e Right-click in the Time Slider and select Keys > Add Inbetween from the
menu that appears to insert an Inbetween at the current time.

e In the Graph Editor, select Keys > Add Inbetween to insert an Inbetween
at the current time.

To remove an Inbetween
1 Select the animation attribute or channel.

2 Do one of the following;:

e Right-click in the Time Slider and select Keys > Remove Inbetween from
the menu that appears to delete the Inbetween at the current time.

¢ In the Graph Editor, select Keys > Remove Inbetween to delete the
Inbetween at the current time.

When using Remove Inbetween, the space between keys is decreased. This may
cause keys to conflict and act unpredictably.

Set Driven Keys

Set Driven Keys

Driven Keys link the attributes—single or multiple—of one object to the attributes
of another object. You can use Driven Keys when you want the attributes of one
object to drive those of another object. See "Driven keys” on page 68.

Set a driven key relationship

To link two attribute values

1 Select Animate > Set Driven Key > Set > .
The Set Driven Key window appears.
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Note If you select an object before making the menu selection, the Set

Driven Key window lists and selects it as the driven object by
default.

2
3

In the scene view, select the driver object.
In the Set Driven Key window, click the Load Driver button.

8Oe Set Driven Key
Load Options Key Select  Help
Driver
nurbsSphere2 visibility
translateX
translatey
translateZ
rotateX
rotateY
rotateZ
scaleX
~ Driven
nurbsSpherel visibility
translateX
translateY
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rotateX
rotateY
rotateZ x
scaleXx b §
| Key || Load Driver ” Load Driven ” Close |

The object and its attributes appear in the Driver section of the window.

4 In the Set Driven Key window, select an attribute from the driver.
This attribute will drive the attribute that is selected from the driven object.
5 In the scene view, select the driven object.
Note The driven and driver objects can be the same object.
6 In the Set Driven Key window, click Load Driven.
The object and its attributes appear in the Driven section of the window.
7 Select the driven attribute.
8 In the Channel Box or elsewhere, set values for the driver and driven
attributes.
9 Click the Key button in the Set Driven Key window.
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Maya creates a key that links the selected attributes at the current values.
The object with the driven attribute turns magenta in the workspace. The
color indicates that the object has a driven attribute.

10 Set new values for the driver and driven attributes.
11 Click Key again.

Maya creates a key that links the attributes at their new values. You can link
the attributes with as many keys as necessary. The default interpolation
between the keys is linear. To fine tune the relationship between the driver
attribute and driven attribute, use the Graph Editor.

To view driven objects

You can examine the state of objects at their driven keys. This is helpful when
you're editing the Graph Editor curve or setting more driven keys.

1 In the scene view, select the object with the driven attribute.

2 From the Set Driven Key window, select Key > Go To Next or Key > Go To
Previous.

With these menu items you can loop through all the keys for the driven
attribute and view the state of the object at each of these keys.

To list the keyable or nonkeyable attributes for an object in the Set Driven Key
window

1 Select the object in the scene view or Outliner.

2 Do one of the following;:

e To list keyable attributes, turn on Options > List Keyable Attributes for
driven in the Set Driven Key window.

e To list nonkeyable attributes, turn off Options > List Keyable Attributes
for driven in the Set Driven Key window.

3 Click Load Driven.

The Set Driven Key window displays the keyable or nonkeyable attributes for
the object. You can use the Channel Control editor (Window > General Editors
> Channel Control) to control whether an attribute is keyable or nonkeyable.

To add an object to the existing Driver or Driven list

1 Select the object in the scene view or Outliner.
2 In the Set Driven Key window, turn off Options > Clear On Load.
3 Click Load Driver or Load Driven.

The current object is added to the Driver or Driven list.

To load the driver linked to a loaded driven object

1 Select the driven object in the scene view or Outliner.
2 Click Load Driven.
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3 In the Set Driven Key window, select Load > Current Driver.
The driver of the current driven object appears in the Driver list.

To load only shape nodes for an object
1 Select the object from the scene view or Outliner.
2 In the Set Driven Key window, turn on Options > Load Shapes.
3 Click Load Driver or Load Driven.
Only the current object’s shape node appears in the Driver or Driven list.

Use the Graph Editor and Dope Sheet

Display the Graph Editor and Dope Sheet

To open the Graph Editor

e Select Window > Animation Editors > Graph Editor.
The Graph Editor appears. See "Graph Editor overview” on page 71.

To open the Dope Sheet

e Select Window > Animation Editors > Dope Sheet.
The Dope Sheet appears. See "Dope Sheet” on page 145.

To place the Dope Sheet in a view

1 Select the view. For example, a pane in the scene view.
2 Select Panels > Panel > Dope Sheet.

Navigate the Graph Editor graph view or Dope

Sheet view area

e To scroll the graph view vertically and horizontally, hold down the Alt (Linux
and Windows) or Option (Mac OS X) key and middle-drag.

e To scale the graph view uniformly, hold down the Alt (Linux and Windows) or
Option (Mac OS X) key and drag or middle-drag the cursor.

e To scale the graph view along the horizontal or vertical axis, hold down the Alt
(Linux and Windows) or Option (Mac OS X) and Shift keys and drag or middle-
drag horizontally or vertically.
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Edit curves

View curves while editing

To view the original and result animation when editing curves

1 Before editing the curve, select it in the Graph Editor.
2 Do one of the following:

e Select Curves > Buffer Curve Snapshot from the menu bar.

See "Buffer Curve Snapshot” on page 133.

e Click the Buffer Curve Snapshot button in the toolbar.

A gray curve representing the current curve appears in the graph view.
3 Edit the colored curve.

4 You can switch between the edited curve and the original curve (buffer
snapshot) by clicking the following;:

e Select Curves > Swap Buffer Curve from the menu bar.
e C(Click the Swap Buffer Curve button in the toolbar.

Set curve behavior

To set curve behavior

1 In the Graph Editor, select the curve.
2 Select Curve > Pre Infinity > or Curve > Post Infinity > in the menu bar.

The Pre Infinity or Post Infinity menu appears. Each Infinity menu contains a
list of curve behaviors.

3 From the lists that appear, select a pre or post infinity behavior option. See
"Pre and Post Infinity animation curves options” on page 147.

For Pre Infinity, the option you select sets the behavior of the curve before its
first key.

For Post Infinity, the option you select sets the behavior of the curve after its
last key.

Set rotation interpolation for curves

To set rotation interpolation for new curves

1 Select Window > Settings/Preferences > Preferences and select the Keys
Category under Settings.

2 Under Rotation Interpolation, set New Curve Default.
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To change rotation interpolation in existing curves

1

In the Graph Editor or Dope Sheet, select the curve whose rotation
interpolation you want to change.

You can change the rotation interpolation type only on rotation channels that
have keyframes on all three channels (rotateX, rotateY, rotateZ). In addition,
because the rotateX, rotateY and rotateZ channels always share the same
interpolation type, changing interpolation for a single channel such as
rotateX, will automatically change rotateY and rotateZ as well.

In the Graph Editor or Dope sheet, select one of the interpolation types from
the Curves > Change Rotation Interp menu. See "Change Rotation Interp” on
page 148.

Example

To change the Euler interpolated rotation curves of a sphere to Quaternion
interpolation

1 Select the sphere that has animated rotation curves with Independent Euler
interpolation. For this example, the Euler rotation animation occurs from
frames 1-200 (O to 1020 degrees).

2 Select Window > Animation Editors > Graph Editor.

The Graph Editor appears.

3 Select the sphere’s rotation curves.

4 In the Graph Editor’'s menu bar, select Curves > Change Rotation Interp >
Synchronized Quaternion.

The rotation interpolation of the selected curves changes to Quaternion.

Note If you switch the rotation curves back to Independent Euler, the

curves will not return to what they were when they were Euler.
Instead, the resulting curves will be the Euler versions of the
Quaternion solution. Since Quaternions solve for the shortest
solution to a position, the multiple rotations that existed with the
original Euler interpolation were deleted when you switched to
Quaternion. Therefore, switching back to Euler doesn't return the
rotations to 1020,1020,1020, it returns the curves to the Euler
equivalent of the Quaternion solution (which in this example is 60,
60, 60).
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Smooth curves

To smooth a curve

Note This setting only affects how curves appear in the graph view.

1 In the Graph Editor, select the animation curve.

2 Select Curve > Curve Smoothness > in the menu bar.
The Curve Smoothness menu appears.

3 Select a curve smoothness option. See "Curve Smoothness” on page 127.
This option controls the smoothness resolution of curves in the graph view.

Simplify curves

To simplify a curve

1 In the Graph Editor, select the curve.

2 Select Curves > Simplify Curve > O in the menu bar.
The Simplify Curve Options window appears.

3 Set the options. See "Simplify Curve” on page 130.

Note You may have to experiment with the Value Tolerance and Time
Tolerance values to achieve the result you want.

4 Do one of the following:

e Click Simplify to set the Simplify Curve options and apply these settings
to the current curve.

The Simplify Curve Options window closes.

e Click Apply to set the Simplify Curve options and apply these settings to
the current curve.

The Simplify Curve Options window remains open.

e Click Close to disregard any changes made to the Simplify Curve options
and close the Simplify Curve Options window.

The keys on the current curve within the specified time range are averaged.

Resample curves

To resample curves

1 In the Graph Editor, select the curve.
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Select Curves > Resample Curves > O in the menu bar.

The Resample Curves Options window appears. See "Resampling curves” on
page 148.

Set the options.
Do one of the following:

e Click Resample to set the Resample Curve options and apply these
settings to the current curve.

The Resample Curve Options window closes.

e Click Apply to set the Resample Curve options and apply these settings
to the current curve.

The Resample Curve Options window remains open.

e Click Close to disregard any changes made to the Resample Curve
options and close the Resample Curve Options window.

The keys on the current curve are made uniform and their number are
reduced.

Scale curves

To scale a region of curves using Manipulator Scaling

1
2
3
4

Select the scale tool.

In the Scale Tool Settings window, set the scaling type to Manipulator.
Close the Scale Tool Settings window.

In the Graph Editor’s graph view, drag around the region you want to scale.

A white box with handles at its corners (the manipulator box) appears in the
graph view, bounding the selected region.

If you want to reposition the region, middle-drag the manipulator box.

Drag the manipulator box by the corner handles to stretch and compress the
contents of the region.
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Note e The curve segments adjacent to the region being scaled are

altered as you use the manipulator.

e You can move blocks of keys by middle-dragging within the
region of the manipulator box.

To scale a region of curves using Gestural Scaling

1

2
3
4
5

Select the scale tool.

In the Scale Tool Settings window, set the scaling type to Gestural.

Close the Scale Tool Settings window.

In the Graph Editor’s graph view, drag around the region you want to scale.

Middle-click where you want to insert the scaling pivot point. Drag the cursor
horizontally to scale the time values of the region. Drag vertically to scale the
value information of the region.

A horizontal and vertical solid line intersect in a box to indicate the pivot point
of the scaling action.

N ‘—— T A R ]

Mute or unmute a channel in the Dope Sheet or
Graph Editor

To mute or unmute channels in the Dope Sheet or Graph Editor

1
2

3

Open the Dope Sheet or Graph Editor.

In the Dope Sheet or Graph Editor’s outliner, select the channel you want to
mute.

Do one of the following:

e If the current animation curve is not muted, select Curves > Mute
Channel.

In the Graph Editor or Dope Sheet, Mute appears under the current animation
channel’s name in the outliner and a Mute curve or channel appears in the
view area.

The muted animation curve now appears as a dotted line in the graph view.
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e If the current animation curve is muted, select Curves > Unmute
Channel.

The current animation curve’s Mute node is deleted, and all occurrences of

Mute are removed from the Graph Editor’s and Dope Sheet’s outliners and
views.

Fix my curves when they have been corrupted

When you import motion capture data into Maya as animation curves, the curves

might be mangled when the rotation values are restricted to a specific range. To
correct this, you must filter your curves.

To filter your Euler curves

1 In the Graph Editor, select the mangled animation curves (for example,
Rotate X, Y, and Z).

2 Select Curves > Euler Filter.

The filtering is always applied to entire curves, not to selected curve
segments within some time range.
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Manipulate curves with the lattice manipulator

To deform animation curves with the lattice manipulator

1 Select the Lattice Deform Keys Tool from the Graph Editor’s toolbar.
2 Set the Lattice Deform Keys Tool options from the tool settings window.
See "Lattice Settings” on page 121.

3 Select keys on the curves you want to deform to define the target curve
region.

The lattice appears in the curve view. The lattice forms a bounding box
around the selected keys.

Lattice edge

Lattice
point

Lattice cell

4 Select the lattice points, lattice edge, or lattice cell you want to manipulate
by clicking them.

Shift-click lattice points to include them in or remove them from your
selection. You can not select more than one lattice edge or cell at a time.

5 Do one of the following:

e For lattice edges, cells, or single points, drag to deform the target curve
region.
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Select lattice
component

Drag lattice
component

Resulting deformed
curves

e For groups of lattice points, middle-drag to deform the target curve
region.
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Select lattice points

Middle-drag lattice
points

Resulting deformed
curves

If you want to scale a region of the lattice, turn on the Middle Button
Scales option in the Lattice Deform Keys Tool and then middle-drag to
scale the selected lattice region. Scaling the lattice deforms the affected

curves.

Animation
103



2 | Keyframe Animation
How do I? > Manipulate curves with the lattice manipulator

Select lattice
components

Middle-drag to
scale the lattice
component(s)

Resulting deformed
curves

® You can also use the Lattice Deform Keys Tool to deform keys that lie
along a single (horizontal or vertical) graph view axis.

Horizontal lattice

Column of

control points Row of
control
points

Vertical lattice

When using the Lattice Deform Keys Tool to deform keys that lie on a single
axis, selecting one lattice point in a row (vertical) or column (horizontal)
selects all the points in that row or column.
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For example, if you select a lattice control point on a horizontal lattice, all of
the lattice points in the selected point’s column are also activated.
Depending on your current dolly-view scale in the Graph Editor, not all the
selected lattice points may be visible. The visibility of the selected lattice
points does not affect the functioning of this tool.

Customize animation curve colors

You can specify custom colors for the animation curves that appear in the Graph
Editor. With Use Curve Color and Curve Color attributes you can set the colors for
individual curves or use more global operations such as coloring a curve based
on which characters they drive to color groups of curves at a time. This type of
global operation can be achieved through MEL scripts. For a sample MEL script,
see “Example MEL procedure for customizing the color of multiple animation
curves” later in this section.

All user-defined color settings for animation curves appear in both the Graph
Editor’s Outliner and Curve View. The Use Curve Color checkbox and Curve Color
swatch are located in the Anim Curve Attributes section of each animation curve
node (for example, animCurven).

Note The maximum number of custom colored curves that can be
displayed at any one time is 20. When this number is exceeded,
curves are displayed using their default colors.

To toggle between custom colors and the default curve colors
Turn the Use Curve Color attribute on or off.

Use Curve Color is located in the Anim Curve Attributes section of each animation
curve node (for example, animCurven). See the following procedure.

To set custom animation curve colors

1 Select the animated object.
2 Open the Graph Editor.
3 In the graph view, select the animation curve.
4 Select Curves > Spreadsheet.
The Attribute Editor opens.

5 In the Anim Curve Attributes section of the animCurven tab, turn on Use Curve
Color.

6 Double-click the color swatch to launch the Color Chooser.
7 In the Color Chooser, select a custom color for the curve and click Accept.
The color you selected with the Color Chooser appears in the Curve Color swatch.

In the Graph Editor's Curve View, the animation curve is now the color of the
Curve Color swatch.
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Example MEL procedure for customizing the color of
multiple animation curves

+
;;************************************************************************

//

// Synopsis:

// global proc int colourSelectedCurves ( int $how, float Sr,

// float $g, float $b )

//

// Description:

// This MEL procedure assigns a curve display color to all

// selected curves and curves connected to selected nodes. The curve display

// color is used for drawing curves in the Graph Editor and for labelling

// curves in the Dope Sheet.

// The following example creates a cube, torus, and sphere, animates them by

// creating translation curves for each, then selects the cube and sphere and
// sets their curve colors as magenta.

// If you then select all three objects and open the Graph Editor, the curves
// associated with the cube and sphere appear magenta and the curves

// associated with the torus appear their default colours.

// Parameters:

// int Show : (in) Specifies how the "useCurveColour"
// attribute is set for each curve.
// If 1, curves will display with the
// newly assigned colour; if 0, curves
// will display in default colour.
// float Sr : (in) Red component of colour to assign.
// float Sg : (in) Green component of colour to assign.
// float Sb : (in) Blue component of colour to assign.
//
// Returns:
// int numCurves : Returns the number of curves a colour
// was assigned to.
//
//************************************************************************
//=
global proc int colourSelectedCurves ( int $how, float $r, float $g,
float $b )

{

int Scount;

int S$i;

int $Js

// Get the list of selected nodes.
//

string $selectionlList[] = "1ls -sl°;
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// Assign colours based on the selected set of nodes.

//
Scount = 0;
for ( $i = 0; $i < size( $selectionList ); Si++ ) {
string $s = $selectionList[$i];
string $isCurve[] = "1ls -type "animCurve" $s’;
if ( size( $isCurve ) != 0 ) {
// A curve is selected: assign it the specified colour.
//
setAttr (Ss + ".useCurveColor") Show;
setAttr (Ss + ".curveColorR") Sr;
setAttr ($s + ".curveColorG") $g;
setAttr ($s + ".curveColorB") $b;
Scount++;
} else {

// A non-curve node is selected: assign all curves which
// are directly connected to it the specified colour.

//

string S$connectedNodes[] = “listConnections $s°;

for ( $J = 0; $3J < size( $connectedNodes ); $j++ ) {
string $c = S$connectedNodes[$]];
string $isCurve[] = “1ls —-type "animCurve" $c’;
if ( size( $isCurve ) != 0 ) {

// We are connected to a curve; assign it the
// specified curve colour.

//

setAttr (Sc + ".useCurveColor") Show;
setAttr ($c + ".curveColorR") Sr;
setAttr ($c + ".curveColorG") $g;
setAttr (Sc + ".curveColorB") S$b;

Scount++;
// Return the number of curves we set the colour on.

//

return( Scount );
Here is an example of how to test the above procedure:
// Create three animated objects
//
string $c[] = ‘polyCube’;
move 10 2 3;
setKeyframe ($c[0]+".t");
currentTime 16;
move 10 -2 3;
setKeyframe ($c[O0]+".t");

string $t[] = “torus’;
currentTime 1;
move -10 -2 -3;
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setKeyframe
currentTime
move 10 -2
setKeyframe

string $s/]
currentTime
move -10 -2
setKeyframe
currentTime
move 10 -2
setKeyframe

// Set the colour of the cube

//

select $c[0]
colourSelectedCurves (
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(Ss[0]+".t");
16;
-3;
($s0]+".t");

and sphere to magenta,

$s[0]1;

1, 1.0, 0.0, 1.0 );

Normalize curves

To normalize your animation curves

1 Select the animated objects whose curves you want to normalize.
2 Open the Graph Editor.

The Graph Editor appears with all the animation curves for the selected
objects displayed in the curve view.

3 Do one of the following:
e In the Graph Editor menu bar, select Curves > Normalize Curves.

e In the Graph Editor tool bar, click the Normalize Curves button ( [}=—|).

All the curves currently displayed in the Graph Editor’s graph view are scaled
to fit within a range of -1 to 1. Only the displayed curves are scaled, not the
underlying animation.

To turn off curve normalization

1 Select the animated objects whose curves you want to revert back to their
non-normalized states.

2 Open the Graph Editor.

The Graph Editor appears with all the animation curves for the selected
objects displayed in the curve view.

3 In the Graph Editor Outliner, select the channels for which you want to turn
off curve normalization.

4 Do one of the following:
e |n the Graph Editor menu bar, select Curves > Denormalize Curves.
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e In the Graph Editor tool bar, click the Denormalize Curves button ( ;?.{ ).

All the curves currently displayed in the Graph Editor’s graph view are
returned to their original appearance.

Edit keys from curves

Add keys to a curve

To add keys to an animation curve

1 In the Graph Editor, select the curve.
2 Do one of the following:
e Select the Add Keys tool from the toolbar.
See "Add Keys Tool” on page 154.
e Select the Insert Keys tool from the toolbar.
See "Insert Keys Tool” on page 154.
3 Do one of the following:
e For Add Keys, middle-click the curve where you want to insert the key.

e For Insert Keys, middle-drag along the curve and release the mouse
button to place the key.

Note All keys added to the curve will have the same tangent type as
adjacent keys.

Once you add a key to the current animation curve, you can select the key
and adjust its settings. See "Animate > Set Key” on page 171.

Move keys on a curve

To move keys along an animation curve

1 In the Graph Editor, select the curve.

2 Select the key you want to move.

3 Select the Move Nearest Picked Key tool from the toolbar.
See "Select Keyframe Tool” on page 153.

4 Middle-drag the key along the curve and release the mouse button to place
the key.
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Delete keys from a curve

To delete keys from animation curves

1 In the Graph Editor, select the curve.
2 Select the key you want to delete.
3 Do one of the following:

e Press Delete on the keyboard.

e Right-click the key and select Edit > Delete from the pop-up menu that
appears.

Edit tangents

Edit tangents

Related topics
% "Tangents menu” on page 136
«  ”"Non-Weighted and Weighted Tangents” on page 149

To set the tangent type

1 In the Graph Editor, do one of the following;:
e Select the curve.
e Select a key on the curve.
2 Select an option from the Tangents menu in the menu bar.

The default type for tangents is Clamped. See "Tangents menu” on
page 136.

3 If you selected a curve, all the tangents in the curve acquire the specified
tangent type.

If you selected a key on a curve, only the curve segments before and after
the current key acquire the specified tangent type.

Note If you want to set the tangent type for a curve segment before or
after a key, use Tangents > In Tangent > (before) or Tangents > Out
Tangent > (after) in the Graph Editor. See ”"In Tangent” on
page 151 and "Out Tangent” on page 151.

To set the tangent’s level of influence

1 In the Graph Editor, select the curve.
Curves are non-weighted by default.
2 Do one of the following:
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e |n the menu bar, select Curves > Non-Weighted Tangents.

Non-weighted tangents have short tangent handles that only control the angle
of the tangent.

* |n menu bar, select Curves > Weighted Tangents.

Weighted tangents have long tangent handles that control the angle and
weight of the tangent. Weighted tangents provide finer control over your
animation curves.

Tangent weights dictate the amount of influence a tangent has over a a curve
segment. See "Non-Weighted and Weighted Tangents” on page 149.

If your tangents are weighted, you can do the following;:

e To affect only your tangent’s angle when moving the handles, select
Tangents > Free Tangent Weight.

See "Free Tangent Weight” on page 134.

e To affect both your tangent’s angle and weight when moving the handles,
select Tangents > Lock Tangent Weight.

See "Lock Tangent Weight” on page 134.

Use the Dope Sheet Manipulator

Copy, cut, paste, scale, move, or mute a range of
time and keys with the Dope Sheet Manipulator

Note e When using the Edit > Cut and Edit > Paste Dope Sheet menu

items with the Dope Sheet Manipulator, their options affect how
the time and keys selected by the manipulator are removed
from and inserted into your animation.

e When using the Copy (default: Ctrl+c), Cut (default: Ctrl+x) and
Paste (default: Ctrl+v) hotkeys with the Dope Sheet
Manipulator, the hotkeys do not use the settings in their
respective Dope Sheet menu option windows. Instead, they
always shift your animation to accommodate the removal or
insertion of time and keys.

e The Dope Sheet Manipulator does not support the Delete key
on your keyboard. To select keys for deletion, use the regular
Select Tool.

To use the Dope Sheet Manipulator

1

Select Window > Animation Editors > Dope Sheet.
The Dope Sheet appears.

Select the objects in your scene whose animation timing you want to
manipulate with the Dope Sheet Manipulator.
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The selected objects and their keyframes appear in the Dope Sheet.

3 In the Dope Sheet toolbar, select the Select Keyframe Tool ( @ ).

4 In the Dope Sheet, drag around the region of time you want to manipulate for
one or several of your objects.

The Dope Sheet Manipulator appears around the region you selected with the
Select Keyframe Tool.

Dope Sheet Manipulator

Click or drag to expand the
manipulator on the vertical

Click or drag to expand the
manipulator on the
horizontal

Drag to move the manipulator

5 Use the Dope Sheet Manipulator in the following ways to manipulate the
selected region of time and keys:

e Copy, cut and paste a region of time and keys.

Copy

Press Ctrl+c to copy the region of time and keys defined by the
manipulator.

Drag the manipulator to the location in time where you want to paste the
copied time and keys.
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Cut

Insertion point

The copied time and keys are pasted or inserted at the start of the
manipulator.

If time and keys are present at the insertion point, they are moved
forward in time to accommodate the insertion of the copied range of time
and keys.

Press Ctrl+x to cut or delete the region of time and keys defined by the
manipulator.

Drag the manipulator to the location in time where you want to paste the
cut time and keys.

Insertion point

The cut time and keys are pasted or inserted at the start of the
manipulator.

If time and keys are present at the insertion point, they are moved
forward in time to accommodate the insertion of the cut range of time
and keys.

Move or scale a region of time and keys.
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Move

Scale

Mute

Insertion point

Shift-drag the middle of the Dope Sheet Manipulator to move the region
of time and keys within the bounds of the manipulator.

If time and keys are present at the location to which you dragged the
range of time and keys, they are moved forward in time to accommodate
the insertion of the moved range of time and keys and the moved range
of time and keys is placed or inserted at the start of the manipulator.

Shift-drag the left or right hand edge of the Dope Sheet Manipulator to
scale the region of time and keys within the bounds of the manipulator.

The time and keys outside of the manipulator move to accommodate the
expansion or compression of the scaled region of time and keys.

Mute a region of time and keys.

In the Dope Sheet menu bar, select Keys > Mute Keys to mute the
selected region of keys and time or select Keys > Unmute Keys to
unmute the selected region of keys and time.
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Windows and Editors

Set Driven Key window

With the Set Driven Key window, you can link objects so that one object’s
attributes can drive or dictate the attributes of another object. See "Driven keys”
on page 68 and "Set Driven Keys” on page 91.

Driver list

This list consists of a left column and a right column. The driver object’s name
appears in the left column, and the object’s keyable attributes appear in the right
column. Select one of the attributes in the right column as the driver attribute.

Driven list

This list consists of a left column and a right column. The driven object’s name
appears in the left column, and the object’s keyable attributes appear in the right
column. Select one of the attributes in the right column as the driven attribute.

Load menu
Selected as Driver

Sets the current object as the driver object. Selected as Driver performs the
same function as clicking the Load Driver button in the Set Driven Key
window.

Selected as Driven

Sets the current object as the driven object. Selected as Driven performs the
same function as clicking the Load Driven button in the Set Driven Key
window.

Current Driver

Deletes the current driver from the driver list.

Options menu
Clear on Load

When on, loading a driver or driven object deletes the Driver or Driven list's
current contents. When off, loading a driver or driven object adds the current
object to the Driver or Driven list.

Load Shapes

When on, only the shape node attributes of the object being loaded appear in
the right-hand columns of the Driver or Driven lists. When off, only the
transform node attributes of the object being loaded appear in the Driver or
Driven lists.
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Auto Select

When on, selecting an object in the Set Driven Keys window automatically
selects it in the scene view. When off, selecting an object in the Set Driven
Keys window does not select it in the scene view.

List Keyable Driven Attributes

When on, only the keyable attributes of the object being loaded appear in the
right-hand columns of the Driver or Driven lists. When off, all attributes—
keyable and non-keyable—of the object being loaded appear in the right-hand
columns of the Driver or Driven lists. See "To make a channel keyable or
nonkeyable from the Channel Box” on page 75 and "To make a channel
keyable or nonkeyable from the Channel Control Editor” on page 75.

Key menu
Set

Links the selected Driver and Driven object’s attributes at their current
values. Performs the same function as clicking the Load button in the Set
Driven Key window.

Go to Previous and Go to Next

Cycle through the keys for the driven attributes of the current object and view
the objects state at each of these keys. See "To view driven objects” on
page 93.

Select menu
Driven Iltems

Selects the current object in the Driven list in the scene view. For example, if
cone 1 is selected in the Driven list, Select menu > Driven Items selects conel
in the scene view.

Channel Control Editor

The Channel Control Editor has two tabs. The Keyable tab is used to edit the
keyability of attributes, and the Locked tab is used to edit attribute locks.

When keying an object, the state of its channels affects which of the object’s
channels are animated. The keyable and nonkeyable channel states let you
specify which of an object’s channels are (keyable) or are not (nonkeyable) keyed
when using the following methods to animate your object: Autokey and Animate >
Set Key (shortcut: S key).

The Keyable tab of the Channel Control Editor consists of three columns:
Keyable, Nonkeyable Hidden, and Nonkeyable Displayed. These columns list the
attributes of the current, selected object. An attribute’s keyability depends on
which column it is listed in. When an attribute’s name is in the Keyable or
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Nonkeyable Displayed column, the attribute appears in the Channel Box. When an
attribute’s name is in the Nonkeyable Hidden column, the channel does not
appear in the Channel Box.

With the Channel Control Editor, you can manage multiple objects (even of
different types) and their attributes simultaneously. For more information, see "To
make a channel keyable or nonkeyable from the Channel Box” on page 75 and
"To lock a channel in the Channel Box” on page 76.

;m!l:hannel Control - nurbsSpherel [_ (O] x| I
Object  Help

Kevable | Locked |

Kepable Monkeyable Hidden Monkeyable Displayed
rotatel caching a [ translatey’
ratate’y’ dizplayHandle =
rotate” dizplayLocalbxiz
scaler dizplayR atateFivot
scaley displayScalePivat —
scalesd ghiostPostSteps
translates ghiostPreSteps
translates ghiostR angeEnd
wizibility ghostR angeStart
ghostStepSize
ghiosting
ghostingContral
identification
inheitsTransform
intermediatel bject
layerdverrideColor
laverBenderable h

[V Change all selected obiects of the same type

fave > Close i << Move
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Graph Editor

Graph Editor

Scene view

Menu bar
Toolbar —L_|3

Outliner Graph view

Graph Editor menu bar

The Graph Editor menu bar contains tools and operations for manipulating
animation curves and keys within the graph view of the Graph Editor. Note that
you still have access to the main menu bar while working with the Graph Editor.

Edit menu

Many of these menu items appear and behave in a similar fashion to the main
Edit menu in the scene view. However, as the Graph Editor works directly with
animation curves and attributes, there are no hierarchy options available within
the settings windows for the edit operations.

Undo/Redo

Undo cancels the last operation. Redo does the last undone operation again.

Animation
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Cut

Cut removes existing keys from a selected attribute and places a copy of that
information on the keys clipboard. If a curve segment is selected in the graph
view, this area will be removed when you choose Edit > Cut. If no curve segment
is selected, Cut will operate on the item selected in the Outliner portion of the
Graph Editor. See "Edit > Keys > Cut Keys” on page 160.

Copy

Copy copies existing keys from a selected attribute and places that information
on the keys clipboard. If you select a curve segment in the graph view, this area
will be removed when you choose Edit > Copy. If no curve segment is selected,
Copy will operate on the item selected in the Outliner portion of the Graph Editor.
See "Edit > Keys > Copy Keys” on page 158.

Paste

Paste adds keys from the keys clipboard to an attribute. Pasted keys can be
merged with existing keys, inserted at a time (displacing existing keys), or used
to replace keys at a time. See "Edit > Keys > Paste Keys” on page 161.

Delete

Delete removes existing keys from an attribute. It works the same way as Cut
except it doesn’t put a copy of the removed keys on the keys clipboard. See "Edit
> Keys > Delete Keys” on page 163.

Scale

Scale expands or compresses a selected range of keys and curve segments to fit
a specified time range. If a channel is selected in the Graph Editor Outliner, and
a curve segment is not selected, then Scale adjusts all the keys for the selected
channel. Also, you can scale keys that are in a selected region of the Graph
Editor when the Only Scale Specified Keys option is on. For more information on
Scale, see "Edit > Keys > Scale Keys” on page 165.

Select Transformation Tools > Move Keys Tool

You can manipulate groups of keys proportionally or in relation to a selected key
using the Move Keys Tool.

The Move Tool’s Move Key Settings are only available when the Graph Editor is
active.

Move Option

The Move Option settings are identical to those of the Move Nearest Picked
Key Tool’s Direct Key Settings. See "Move Nearest Picked Key Tool” on
page 139.

Move Falloff

Constant Moves all keys the same amount in the direction of the
mouse movement.

Animation
119



2 | Keyframe Animation
Reference > Graph Editor menu bar

Linear Moves all keys based on the distance they are from the
mouse down location. The amount a key moves
decreases linearly as its distance from the mouse down
location increases.

Exponential Moves all keys based on the distance-squared they are
from the mouse down location. The amount a key moves
decreases exponentially as its distance from the mouse
down location increases.

Direction of mouse movement

Selected keys

Result with Linear falloff Result with Exponential falloff

Select Transformation Tools > Scale Keys Tool

Use the Scale Tool to scale a region of animation curve segments and the
positions of keys in the graph view.

In the Scale Tool Settings window, you can select two ways to scale keys in the
graph view. To display the Scale Tool Settings window, double click the Scale
Tool icon when the Graph Editor is the active window.

For more information, see "Scale keys” on page 81 and ”Scale curves” on

page 98.

ScaleKey Options
Manipulator Lets you scale keys by using a manipulator box style.
Gestural Changes the way keys are scaled in the graph view so

the mouse position determines the scaling vectors.
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Select Transformation Tools > Lattice Deform Keys Tool

You can manipulate curves in the Graph Editor with the Lattice Deform Keys tool.
The Lattice Deform Keys tool lets you draw a lattice deformer around groups of
keys, so that you can manipulate many keys at once. This tool gives you a high-
level of control over your animation curves.

Once you draw a lattice around a group of keys, you can then move the control
points of the lattice to deform the affected animation curves or scale the lattice
points around a picked point to transform the affected curves.

You can also use the Lattice Deform Keys Tool to deform keys that lie along a
single (horizontal or vertical) graph view axis.

For more information, see "Manipulate curves with the lattice manipulator” on
page 101.

Lattice Settings

Columns Specifies the number of columns for the current lattice
manipulator. The minimum number of columns is 2 and
maximum number is 20.

Rows Specifies the number of rows for the current lattice
manipulator. The minimum number of rows is 2 and the
maximum number is 20.

Falloff Specifies the lattice manipulator’s level of influence or
falloff value.

Middle Button

Scales When on, you can scale the active control points around
the current lattice point.

Snap

Snap causes selected keys to snap in time to the nearest whole time unit values
or attribute values. Use Select Unsnapped to check for keys not at whole time
units. The default is to snap to nearest time units. Select Edit > Keys > Snap
Keys > [ to view the options window and edit the settings. See "Edit > Keys >
Snap Keys” on page 167.

Select Unsnapped

Selects all keys from the selected channel, or any keys in the Graph View if no
objects or attributes are selected that are not at a whole time unit.

View menu

This menu controls which components are visible, and therefore editable, in the
graph view of the Graph Editor. This is useful for controlling the amount of
information displayed in the graph view, as well as specifying which of the
animation curve components are available for editing.
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Note When framing the desired range, the Graph Editor may scale the
area in the graph view horizontally and vertically to display the
desired range.

Clip Time

Clip Time lets you view the clip animation curves at their position and scale in the
Trax editor.

Frame All

Frame All adjusts the graph view to fit all animation curves in the window.

Frame Selected

Frame Selected adjusts graph view to fit selected animation curves or curve
segments in the window.

Frame Playback Range

Frame Playback Range adjusts the graph view to fit the playback range in the
window.

Center Current Time

If you change the view in the Graph Editor and want to shift the view so the
current time is in the middle of the editor, select Center Current Time from the
View menu.

Auto Frame
This option automatically adjusts the graph view to fit the display of the
animation curves associated with a selected object or objects.

Show Results Options window

When types of animation that do not create animation curves (such as motion
paths and Expressions) are part of your animation, you can use Show Results to
see a graphic representation of the behavior of these animation types.

Any numeric attribute can drive Show Results. This is useful for looking at
animations driven by anything other than a single animation curve.

Note To edit these types of animation, you must transform them into
animation curves by performing a Bake Channel.
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Screen Based samples the result of what one pixel represents in time. This may
not accurately reflect the actual animation (especially if you are zoomed out).
However, by adjusting the sampling rate, you can choose between curve accuracy
and update time. A higher sampling rate means more accurate representation but
longer computation time.

Samples

When screen based sampling is turned on, the sample rate specifies the
number of pixels per sample. When it’'s turned off, the sample rate specifies
the number of frames or current time units per sample.

Performance options
These options are used to specify when the result curves are updated.
Delayed Result curves are updated when the mouse is released.

Interactive Result curves are updated as the mouse is moved.

Show Buffer Curves

Turning this on will cause the Graph View to display the original shape of edited
curves.

Keys menu

In order to operate on a component of an animation curve, you must make it
viewable by loading it into the Graph Editor. By default, objects selected in a
scene view are automatically loaded in the Graph Editor.

Keys are represented in the graph view as black points, and when selected, they
are highlighted yellow.

Always

Setting the viewable status of keys to Always results in keys being visible at
all times in the graph view of the Graph Editor.

Never

Setting the viewable status of keys to Never hides keys in the graph view.
Because keys are no longer available for picking, you can no longer edit
them.

Active Only
When the viewable status of keys is set to Active Only, keys are available
only when you select the curve they are associated with.

Tangents menu

In order to operate on a component of a tangent, you must make it available by
being designated as viewable.

Tangents are represented in the graph view as brown handles tangential to the
curve segment of the animation curve. When selected, they are highlighted green.

Animation
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Note that if Unify Tangents has been turned on for a curve segment (see page
138), the handles on both sides of the key will be adjusted uniformly when you
edit the selected handle. If Break Tangent is in effect, each tangent handle
operates independently of the other.

Always

Setting the viewable status of tangents to Always results in tangents being
visible at all times in the graph view of the Graph Editor.

Note If you wish to operate on tangents and you’ve disabled curves and
keys in the Select menu of the Graph Editor, set the visibility of
tangents to Always so they are available for selection.

Never

Setting the viewable status of tangents to Never hides tangents in the graph
view. Because tangents are no longer available for selection, you can no
longer edit them.

Active Only
When the viewable status of tangents is set to Active Only, tangents are
available only when you select their associated curve or curve segment.
Infinity

Infinity turns on or off the display of the animation curve extrapolated outside
the first and last keys of the curve.

Note that the curves before the first key and after the last key will be
constant by default (see page 131).
Select menu

These options control which components of an animation curve are available for
selection and editing.

Note When you select components of an animation curve in the graph
view of the Graph Editor, a box appears in the Outliner
corresponding to the attribute whose components are currently
selected.

All

All enables selection of any of the components of an animation curve.

Curve

Curve constrains your selection to animation curve segments.
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Key

Key constrains your selection to keys.

In Tangent

In Tangent constrains your selection to the in tangents of a key. In tangents are
the tangents that describe the shape of the curve segment entering a key.

Out Tangent

Out Tangent constrains your selection to the out tangents of a key. Out tangents
are the tangents that describe the shape of the curve segment leaving a key.

Note To select a tangent when the Key and Curve selections are
disabled, you must select View > Tangents > Always.

Curves menu
The Curves menu items process entire animation curves.

Animation curves are extrapolated outside the first and last keys of the curve.
Curves before the first key and after the last key will be flat (no change in value
over time) unless you set the pre and post infinity controls to anything other than
constant. You can use these options to automatically generate specific types of
repeating animation.

Note If you want to create editable animation of a repetitious or cyclical
nature, you can bake a channel with Infinity turned on (see page
128).

Pre and Post Infinity

The Pre and Post settings define the behavior of an animation curve before and
after the first key of that curve.

Cycle

The Cycle setting repeats the animation curve as a copy infinitely.

A

N / S Cycle
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Cycle with Offset

The Cycle with Offset setting repeats the animation curve infinitely, except it
appends the cycled curve’s last key’s value to the value of the first key's
original curve.

) / Cycle with Offset

\/

Oscillate

The Oscillate setting repeats the animation curve by reversing its values, and
therefore shape, with each cycle, creating an alternating backwards and
forwards effect.

A

Oscillate

\

Linear

The Linear setting extrapolates the value of the first key using its tangent
information. It projects a linear curve infinitely beyond.

A

Linear

\

Constant

The Constant setting maintains the value of the end keys. This is the default
setting for animation curves in Maya.

Animation
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Curve Smoothness

This setting controls the smoothness resolution of curves in the graph view.
Decreasing the resolution lessens the time to display the graph view.

Note that this setting has no impact on the behavior of animation curves, and it
affects only the display of the curves in the graph view.

Bake Channel Options window

This operation calculates a new animation curve for an attribute using the input
nodes that contribute to its properties. This is different from the Edit > Keys >
Bake Simulation operation. This operation is useful when you want to:

e edit a single animation curve instead of all the contributing attributes that
affect the behavior of a single attribute. For example: an object affected by a
driven key or an Expression.

e add keys to an existing curve

Note Bake Channel operates only on animation that can be evaluated
explicitly. Inverse Kinematics systems, Dynamics, and some
Expressions cannot be operated on with Bake Channel.

To create animation curves from these animation types, you will
need to perform Edit > Keys > Bake Simulation.

Time Range
Specifies what keys will be baked.

Time Slider All keys present in the region between the Playback Start
and End times in the Timeline are baked into a new
channel.

Start/End All keys within the specified time range (start time/end

time) are baked into a new channel.

Start Time Specifies the start of the time range. This is available
only if Start/End is on.

End Time Specifies the end of the time range. This is available
only if Start/End is on.

Animation
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Sample By Specifies the frequency with which Maya will evaluate the
animation and generate keys. Increasing this value
decreases how often Maya sets keys for the animation.
Decreasing has the opposite effect.

The Sample By value is based on the Time Unit setting.
It represents the frequency with which Maya will analyze
the object’s animation and generate a key. A value of 1
creates a key at each time unit. Greater values decrease
the frequency of generated keys, and smaller values
increase the frequency.

Keep Unbaked

Keys This is on by default. This option preserves the keys that
are outside the baked time range and only applies to
directly connected animation curves.

When turned on, bake simulation does not remove keys
that are outside the bake range.

When turned off, only the keys created within the
specified time range during the bake will be present on
the animation curve after the operation.

Sparse Curve

Bake This option operates only on directly connected
animation curves. It produces bake results that create
only enough keys to represent the shape of the
animation curve.

Normalize Curves

This setting scales down large key values or scale up small key values to fit
within a -1 to 1 range. When animation curves are normalized, they are adjusted
to fit within the range of normalization. Curve normalization is useful when you
want to view, compare, or edit animation curves that are related (such as rotation
and translation curves), but have drastically different ranges. For example, with
curve normalization you can compare all the translation and rotation animation
curves for an object.

Note Animation curves that are normalized appear thicker than other
curves in the Graph Editor.

Limitations
Curve normalization does not work with the following types of curves:

e Rotation curves that use quaternion rotation interpolation
e Referenced animation curves
e |ocked animation curves.
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Denormalize Curves

This setting turns off curve normalization for the selected animation curves. When
the curves are reverted back to their non-normalized states, the animation curves
are returned to their original ranges.

Change Rotation Interp

Change Rotation Interp lets you can change the rotation interpolation type of
existing curves.

You can change the rotation interpolation type only on rotation channels that
have keyframes on all three channels (rotateX, rotateY, rotateZ). In addition,
because the rotateX, rotateY and rotateZ channels always share the same
interpolation type, changing interpolation for a single channel such as rotateX,
will automatically change rotateY and rotateZ as well.

For more information on rotation interpolation, see "Animated rotation in Maya”
on page 27.

Independent Euler

Calculates the rotation using three separate angles representing rotations
about the X, Y, and Z axes, and an order or rotation. In this mode, the curves
that define the rotation for a given node are represented in Euler-angles,
interpolation is performed on each curve independently in Euler space, and
keyframes may occur at your discretion—they are not synchronized with the
other sibling rotation curves at the node. You can also animate a single
rotation ordinate. This is the default setting.

Synchronized Euler

Creates curves that have keyframes on sibling curves locked together as in
Synchronized Quaternion Curves but the interpolation between keyframes in
performed in Euler-space.

It’s useful to keep rotation keyframes synchronized because rotation is a
composition of the three separate rotate values. Deleting just one key on a
curve can have a dramatic and unexpected effect on the interpolation.

Synchronized
Quaternion

Calculates rotation interpolation using three orientations about the X, Y, and
Z axes, and an angle of rotation. The interpolation between keyframes is
defined using quaternion interpolation. Keyframes on related curves are
locked together. When you add, delete, or move a keyframe on one curve, the
corresponding key is also updated in the sibling curves.

For example, if you drag a keyframe on the X curve to frame 14, the
corresponding keys on the Y and Z curves also move to frame 14. The Graph
Editor displays a quaternion key as a solid diamond shape.

Animation
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Simplify Curve

Use this operation to remove keys that are not necessary to describe the shape
of an animation curve. Excess keys may accumulate on an animation curve as a
result of adding keys manually or performing operations such as Bake Channel.
You may need to remove keys from an animation curve to reduce the graph
complexity and provide larger spans for adjusting curve tangents.

Time Range
Specifies the time range where the curve will be simplified.
All Simplifies the curve for the entire time range.

Time Slider Simplifies the curve for the time range defined by the
Playback Start and End times of the Timeline.

Start/End All keys within the specified time range (start time/end
time) are simplified.

Start Time Specifies the start of the time range. This is available
only if Start/End is on.

End Time Specifies the end of the time range. This is available
only if Start/End is on.

Simplify Method

Classic Removes excess keys using the algorithm used in
previous versions of Maya. Use this method on light data
sets, such as keyframe animations, which don’t have
keys on every frame.

Dense Data Removes excess keys using an algorithm designed for
dense data sets, such as motion capture data, which
have a key on every frame. This method may also work
well if the Classic method doesn’t give you the desired
results.

Time Tolerance

The amount (in seconds) that the timing for the keys is averaged when the
selected curve is simplified. The higher the Time Tolerance, the sparser your
keys and the less your resulting curve resembles the original curve. The
default Time Tolerance is 0.05.

Value Tolerance

The amount (in your current working units) that the values of the keys are
averaged when the selected curve is simplified. The default Value Tolerance
to 0.01.

Euler Filter

See "Euler angle filtering” on page 71.
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Resample Curve Options window
Resampling creates a periodic frame rate by placing keys at uniform intervals.

To resample a curve, you select a sampling filter, which is an algorithm defining
how the keys in the curve are resampled. Tangent and curve values are ignored.
The filter converts animation curves with keys at either uniform or non-uniform
intervals to curves with keys at a uniform interval that you specify.

Tip The resampling filters are designed to reduce the number of keys in
dense data curves. It may not produce the desired results when
used on curves with few keys.

Time Range

Specifies the range of time in where keys are resampled.

All Resamples the curve for the entire time range.

Start/End All keys within the specified time range (start time/end
time) are resampled.

Time Slider Resamples the curve for the time range defined by the
Playback Start and End times of the Timeline.

Start Time Specifies the start of the time range. This is available
only if Start/End is on.

End Time Specifies the end of the time range. This is available

only if Start/End is on.

Resample Type

Specifies the resampling filter, which is an algorithm that defines how the
keys in the curve are resampled. Choose one of the following:

Closest Sample Uses the value of the sample that is closest to the
nearest time step.

Linear

Interpolation Uses linear interpolation between two samples closest
to the nearest time step.

Box Filter Sums up all the samples in the filter area with an equal
weight.

Filter weight Box Filter

A

» Sample distance
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Triangle Filter Uses a linear curve that affects the keys so that the
least filtering happens at the edges of the sampled area.

Filter weight Triangle Filter

f \ » Sample distance

Gaussian2 Uses a sloped curve that weights the sampling gently at
the top of the peak and toward the edge of the sampled
area. This is the default.

Filter weight Gaussian? Filter

i » Sample distance

Gaussian4 Similar to the Gaussian2 filter but with a narrower base.

Filter weight Gaussian4 Filter

» Sample distance

Time Step

Sets the period for resampling. If you set Time Step to 4, then a key frame
will be placed every four frames. Resampling works best when the Time Step
period is greater than the frequency of keyframes on the curve.

. |
Before resampling |= // ™

[ 2 4 B 5 10 12 14 18 15 20 22 24 26 28 30 32 34 3B 38
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Spreadsheet

This menu selection lets you edit the values and attributes of the selected
animation curves in a spreadsheet format in the Attribute Editor.

Buffer Curve Snapshot

Takes a snapshot of your curve. Use Swap Buffer Curve to switch between your
curve snapshot and the current curve. See ”"Swap Buffer Curve” on page 133 and
"To view the original and result animation when editing curves” on page 95.

Swap Buffer Curve

Toggles between the original curve (the buffer curve snapshot) and the current,
edited curve. Lets you view and play both the curves animations. See "Buffer
Curve Snapshot” on page 133, "Swap Buffer Curve” on page 142, and "To view
the original and result animation when editing curves” on page 95.

Non-Weighted Tangents

The default setting is non-weighted tangents, which provide simple handles for
manipulating the tangent’s angle. To change the weighting of an animation curve,
use Curves > Weighted to change the curve’s tangent type to weighted.

Note You cannot mix weighted and non-weighted tangents in the same
curve.

Weighted Tangents

Weighted tangents represent the amount of influence a tangent’s length has on
an animation curve segment. By turning on Free Tangent Weight (see "Free
Tangent Weight” on page 134), it is possible to simultaneously edit the influence
and angle of the tangent quickly and intuitively. Users of desktop illustration
packages will recognize the familiar Bezier-style behavior when in this mode.

Tangent weights are represented by the length of the tangent handle, and
editable tangent weights are manipulated by dragging the handle’s length.

Animation
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Tangents of weighted animation curves have not only an angle but also a weight.
The higher the weight of a tangent, the more influence it has on the shape of the
curve segment compared with the tangent at the other end of the curve segment.

Keys menu

Break Tangents

Break Tangents allows manipulation of the in and out tangent handles individually
so you can edit the curve segment entering or exiting the key without affecting its
opposite handle.

Unify Tangents

Unify Tangents causes the manipulation of an in or out tangent handle to affect
its opposite handle equally. Unify Tangents retains the relative position of the
tangent handles even after tangents are individually adjusted (by editing tangents
separately after choosing Keys > Break Tangents).

Lock Tangent Weight

Lock Tangent Weight specifies that when you move a tangent, only its angle can
be changed. This forces the associated curve segment to retain the weight of the
tangent. This applies only to weighted curves.

Free Tangent Weight

Free Tangent Weight specifies that when you move a tangent, its angle and
weight can be changed. This allows the weight of a tangent to be adjusted as well
as the angle. This only applies to weighted curves.

Convert to Key

Converts selected breakdowns to keys.

Convert to Breakdown

Converts selected keys to breakdowns.

Add Inbetween

Inserts an inbetween at the current time.

Remove Inbetween

Removes an inbetween at the current time.

Mute Key On

Mutes the selected keys. Keys that are muted do not contribute to the animation
on their channels.

When keys are muted, the following occurs:
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e A green + symbol appears next to the names of the muted keys channels in
the Graph Editor Outliner.

e Mute curves with keys appear under the muted keys curves in the Graph
Editor.

Mute curves have the same number of keys as the muted keys animation
curves, and their keys are positioned the same as those on the muted keys
animation curves.

{1 Graph Editor

Edit Wiew Select Curves Keys Tangents List Show Help.
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Mute Key Off

Unmutes the selected keys. Keys that are not muted contribute to the animation
on their channels. Unmuting keys disables their Mute curves (indicated by the red
x symbol next to the names of the muted keys curves in the Graph Editor
Outliner) but does not remove them.

Animation
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indicates that the
channel has a

disabled Mute node
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To remove Mute curves, see "Mute or unmute a channel in the Dope Sheet or
Graph Editor” on page 99.

Tangents menu

Tangents describe the entry and exit of curve segments from a key. This menu
operates on the shape of curve segments around selected keys. Note that these
settings affect only existing animation curves segments’ tangents.

Tip If the Graph Editor is displayed in a panel, you can also edit
tangents using the marking menu. In the Graph Editor, press
Shift+s+middle-click to display the marking menu.

Spline

Specifying a spline tangent creates an animation curve that is smooth between
the key before and the key after the selected key. The tangents of the curve are
co-linear (both at the same angle). This ensures that the animation curve
smoothly enters and exits the key. When animating fluid movement, a spline
tangent is an excellent place to start. You use a minimum number of keys to
achieve your look.

When animating fluid movement, a spline tangent is an excellent place to start.
You use a minimum number of keys to achieve your look.

Linear

Specifying a linear tangent creates an animation curve as a straight line joining
two keys. If the in tangent type is linear, the curve segment before the key is a
straight line. If the out-tangent type is linear, the curve segment after the key is a
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straight line. When animating the color of a heating element on a stove, you
would use linear to achieve that gradual change in color from charcoal gray to
burning hot red.

Clamped

Specifying a clamped tangent creates an animation curve that has the
characteristics of linear and spline curves.

The keys’ tangents will be splines unless the value of two adjacent keys are very
close. In this case, the out tangent of the first key and the in tangent of the
second key will be interpolated as linear.

When animating a skeleton in a walk-cycle, you may notice a slipping of the pelvic
and foot joint position. This occurs because the value of the keys on the curve
are either the same or close to (within tolerance of) the value of the other. Maya
assigns a default spline tangent to describe what occurs between these keys.
This is why you get the joint positions slipping.

By setting the tangent type to clamped for these keys, the slipping is corrected
and the tangents becomes a combination of linear and spline.

In the Maya environment preferences, Clamped is the default tangent type.

Stepped

Specifying a stepped tangent creates an animation curve whose out tangent is a
flat curve.

The curve segment is flat (horizontal), so the value changes at the key without
gradation.

The light from a strobe light turns on and off. To create a strobing effect, you
would use a step tangent.

Stepped Next

FBIK animation keys use the stepped next tangent type by default. This tangent
type differs from regular Stepped tangents in that its interpolation values jump
immediately to that of the next key, rather than holding the value of the current
key until the next key is reached. For more information on Stepped Next tangents
and FBIK, see How do | manage my full body IK keys? in the “Pose and animate
your character with full body IK” section of the Character Setup guide.

Flat

Sets the in and out tangents of the key to be horizontal (with a slope of O
degrees). When a ball reaches its ascent, it hangs in the air for a brief time
before starting its descent. You can create this effect by using a flat tangent.

Fixed

Specifying a fixed tangent allows a key’s tangents to remain unchanged as the
key is edited.

Animation
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When animating a ball, you may find the ball isn’t falling from a desired height,
yet its impact with the floor and everything else is perfect. Using a fixed tangent
lets you change the height of the ball while retaining the tangent’s angle. This is
somewhat different from Edit > Keys > Bake Simulation.

This process is useful when you want to:

e Edit a single animation curve instead of all the contributing attributes that
affect the behavior of a single attribute, for example, an object affected by a
driven key or an Expression.

e Add keys to an existing curve

Plateau

Specifying a plateau tangent forces your animation curves to not go beyond the
positions of their keyframes so that their maximum and minimum values (‘hills
and valleys’) do not extend past or overshoot their keyframes. Plateau tangents
are useful when you want the positions of your keyframes to be exact because
they stop your animation curves from wandering beyond the boundaries set by
the values of their keyframes.

For example, if you animate a ball rolling off a table, falling to the floor, and then
rolling on the floor; the resulting animation will look different with spline tangents
than with plateau tangents. With spline tangents, the ball will fall through the
floor and then come back up to the floor. With plateau tangents, the ball will not
fall through the floor.

Plateau tangents are similar to spline and clamped tangents. Plateau tangents
ease animation curves in and out of their keyframes like spline tangents, but also
flatten curve segments that occur between equal-valued keyframes like clamped
tangents. Plateau tangents also have two unique characteristics: they flatten
keyframes at the points in their curves where hills and valleys occur and they
flatten the first and last keyframes on their curves.

In Tangent menu

With this menu you can specify a type of tangent for the In Tangent only. The In
Tangent defines the type of curve segment that comes before a key. For
descriptions of the tangent type options in this menu, see "Tangents menu” on
page 136.

Out Tangent menu

With this menu you can specify a type of tangent for the Out Tangent only. The
Out Tangent defines the type of curve segment that comes after a key. For
descriptions of the tangent type options in this menu, see "Tangents menu” on
page 136.



2 | Keyframe Animation
Reference > Graph Editor toolbar

List menu

Auto Load Selected Objects

When Auto Load is turned on, the objects that appear in the Outliner will change
every time you make a selection to show the currently selected objects. If Auto
Load is turned off, it locks the objects currently in the Outliner so you can
continue to edit their animation curves even if you make a new selection in a
scene view.

Load Selected Objects

You can use this item only when Auto Load is off. When Auto Load is off, the
objects appearing in the Outliner may be out of synch with what is currently
selected in a scene view. To reload the Outliner with the current selection,
choose Option > Reload List.

Add Selected Objects

To work on the animation of one object in the Graph Editor and another object not
loaded in the Outliner, select that object and choose Options > Add Selected to
List. This will add the selected object to the Graph Editor Outliner without
disrupting the layout of the objects and animation curves currently in the Graph
Editor.

Bookmarks

To save the view of the animation of one or more objects in the Graph Editor,
create a bookmark.

Bookmark Current Objects window

When invoked, Bookmark Current Objects provides an option box so you can
name bookmarks.

Bookmarks appear as a list in the Bookmarks menu as they are created.

Show menu

This menu is the same as its counterpart in the Outliner. See “Outliner” in the
Basics guide.

Graph Editor toolbar

Move Nearest Picked Key Tool

g This tool lets you manipulate individual keys and tangents with a single
mouse action.

This tool differs from the Move Tool. It works on one key at a time, or on the
closest selected key of an active curve without you having to precisely select a
key point or tangent handle in the graph view.

Animation
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Move Nearest Picked Key Tool options window

If you double-click the Move Nearest Picked Key Tool icon. This opens the Tool
Settings window for this tool.

Direct Key settings

MoveOnly Disables the Move Nearest Picked Key tool’s ability to
sweep throughout a curve’s keys (see moveOver, below).

MoveOver The default setting lets the tool sweep through an active
curve along the curve’s keys. This expedites the fine-
tuning of animation curves.

Insert Keys Tool

w Choose the Insert Keys Tool to place new keys on an existing animation
* curve. Click to select the curve to which you will add a new key.

Middle-drag to set the location of the new key. Releasing the mouse button
places the key. The new key will have tangents that preserve the original
animation curve segment’s shape.

Add Keys Tool

P The Add Keys Tool lets you add keys to a selected animation curve
+ anywhere in the graph view.

Middle-drag to set the location of the new key. Releasing the mouse button
places the key. The new key’s tangents will be of the same type as the adjacent
keys’ types.

Key Stats fields

The Key Stats fields numerically represent a selected key’s time and value. You
can edit them by entering values from the keyboard, or relatively by using the
following operators in the input:

Operator Function

+=value the entered value is added to the existing value
*=value the entered value multiplies the existing value

-=value the entered value is subtracted from the existing value
/=value the entered value divides the existing value
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Lattice Deform Keys Tool

You can manipulate curves in the Graph Editor with the Lattice Deform
Keys Tool. The Lattice Deform Keys tool lets you draw a lattice deformer
around groups of keys, so that you can manipulate many keys at once.
This tool gives you a high-level of control over your animation curves.

See "Select Transformation Tools > Lattice Deform Keys Tool” on page 121.

Spline Tangents
1": This icon provides easy access to the Graph Editor menu bar item Tangents
&~ > Spline. See "Spline” on page 136.
Clamped Tangents
This icon provides easy access to the Graph Editor menu bar item Tangents
> Clamped. See "Clamped” on page 137.
Linear Tangents
A This icon provides easy access to the Graph Editor menu bar item Tangents
A4 & > linear. See "Linear” on page 136.
Flat Tangents
This icon provides easy access to the Graph Editor menu bar item Tangents
> Flat. See "Flat” on page 137.
Step Tangents
This icon provides easy access to the Graph Editor menu bar item Tangents
> Stepped. See "Stepped” on page 137.
Plateau Tangents

This icon provides easy access to the Graph Editor menu bar item
™| Tangents > Plateau. See "Plateau” on page 138.

Buffer Curve Snapshot

-+ To take a snapshot of a curve, select the animation curve and use Curves >
—— Buffer Curve Snapshot or the Buffer Curve Snapshot button. See "Buffer
Curve Snapshot” on page 133.

Use Buffer Curve Snapshot and Swap Buffer Curves to compare changes to the
current animation curve with its previous shape. Note that a gray curve
representing the original curve is visible.
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Swap Buffer Curve

—— To swap the buffer curve with the edited curve, use Curves > Swap Buffer
XL Curve or the Swap Buffer Curve button. See "Swap Buffer Curve” on
page 133.

Use Buffer Curve Snapshot and Swap Buffer Curves to compare changes to the
current animation curve with its previous shape. Test your animation by toggling
back and forth between these curves freely.

Break Tangents

This icon provides easy access to the Graph Editor menu bar item Tangents
> Break Tangents. See "Break Tangents” on page 134.

A broken tangent displays in blue.

Unify Tangents

This icon provides easy access to the Graph Editor menu bar item Tangents
> Unify Tangents. See "Unify Tangents” on page 134.

Free Tangent Weight

\' This icon provides easy access to the Graph Editor menu bar item Tangents
> Free Tangent Weight. See "Free Tangent Weight” on page 134.

Lock Tangent Weight

.\ This icon provides easy access to the Graph Editor menu bar item Tangents
> Lock Tangent Weight. See "Lock Tangent Weight” on page 134.

You can visually identify locked or broken tangents and weight locked tangents.

The Graph Editor displays the status of locked or broken tangents.By default, an
unlocked tangent displays in green. When locked, both tangents display in the
same color.

Time Snap
(,_ Using the Time Snap Tool forces keys moved in the graph view to the

wu nearest integer time unit value. This is on by default.S

Value Snap

Using the Value Snap Tool forces keys in the graph view to the nearest
] integer value.

Note Snap settings have no effect on tangent manipulation.
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Normalize curves

; This icon provides easy access to the Graph Editor menu bar item Curves >
4==| Normalize Curves. See "Normalize Curves” on page 128.

Denormalize curves

; This icon provides easy access to the Graph Editor menu bar item Curves
-17‘{ > Denormalize Curves. See "Denormalize Curves” on page 129.

The Graph Editor outliner

The Graph Editor Outliner has many characteristics in common with the main
Outliner. For more information, see Outliner in the Basics guide.

Features specific to the Graph Editor Outliner follow.

An animation curve is associated with a node in the Outliner portion of the Graph
Editor. Selecting a node causes all of its animation curves to be displayed in the
graph view.

Each item in the Graph Editor Outliner contains special additional information in
the form of a small icon that collapses and expands the hierarchy of viewable
channels.

Channels in the Graph Editor outliner

If an object is animated by simple keyframe animation, for each attribute of the
object you select, there will be one animation curve driving that attribute. In this
case, each of the animated attributes (channels) of that object will be listed
indented below the object.

Graph Editor outliner split control

You can split the Graph Editor’s outliner so you can look at two different listings
at the same time. This makes it a lot easier for you to go back and forth between
working on different sets of animation curves.

To split the outliner, move the cursor towards the bottom of the outliner. You will
notice that the cursor icon changes into an “up-down” icon. You can now drag the
cursor to move the outliner separator, which creates a second outliner space.

Muting icons in the graph outliner

You can mute animation channels in the Graph Editor. When a channel is muted,
an icon appear beside the channels name in the graph outliner. See "Mute in the
Graph Editor and Dope Sheet” on page 24.
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Graph Editor graph view

The graph view of the Graph Editor displays animation curve segments, keys, and
key tangents.

Right-clicking anywhere in the Graph Editor causes a pop-up menu containing the
Graph Editor menu bar items to appear.

In addition to the Graph Editor tools in the toolbar, you can use the Select Tool,
Move Tool, and Scale Tool to manipulate keys in the graph view of the Graph
Editor.

Select Tool

Use the Select Tool to select curves, segments, tangents, and keys in the
) graph view.

Sweep with the mouse button down to select the contents of an area. You
can click an animation curve, tangent handle, or key point to select the individual
item.

Move Keys Tool

‘ Use the Move Keys Tool to select and manipulate components of the graph
s view.

The Move Tool's Move Key Settings are only available when the Graph
Editor is active.

See "Select Transformation Tools > Move Keys Tool” on page 119.

Scale Keys Tool

m Use the Scale Tool to scale a region of animation curve segments and the
*» positions of keys in the graph view.

See "Select Transformation Tools > Scale Keys Tool” on page 120.
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Dope Sheet menu bar

Edit menu

Many of these menu items appear and behave in a similar fashion to the

main

Edit menu in the scene view. However, as the Dope Sheet works directly with

animation curves and attributes, there are no hierarchy options available
the settings windows for the edit functions.

within

Note The Dope Sheet, the Edit > Keys menu selection, and Time Slider
all share a common keys clipboard. Keys copied or cut to the

clipboard using one tool are available to the other tools.

Undo/Redo

Undo cancels the last operation. Redo does the last undone operation again.

Cut

Cut removes existing keys from a selected attribute and places a copy of
information on the keys clipboard. If a curve segment is selected in the g

that
raph

view, this area will be removed when you choose Edit > Cut. If no curve segment
is selected, Cut will operate on the item selected in the Outliner portion of the

Dope Sheet. See "Edit > Keys > Cut Keys” on page 160.
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Copy

Copy copies existing keys from a selected attribute and places that information
on the keys clipboard. If you select a curve segment in the graph view, this area
will be removed when you choose Edit > Copy. If no curve segment is selected,
Copy will operate on the item selected in the Outliner portion of the Dope Sheet.
See "Edit > Keys > Copy Keys” on page 158.

Paste

Paste adds keys from the keys clipboard to an attribute. Pasted keys can be
merged with existing keys, inserted at a time (displacing existing keys), or used
to replace keys at a time. See "Edit > Keys > Paste Keys” on page 161.
Delete

Delete removes existing keys from a selected attribute. It works the same as Cut
except it does not place a copy of the removed keys on the keys clipboard. See
"Edit > Keys > Delete Keys” on page 163.

Scale

Scale operates on a selected range of keys, expanding or compressing the
animation to correspond to a new time range. Note that Scale will operate on the
entire range of keys if an attribute is selected in the Dope Sheet outliner and a
curve segment is not selected. See "Edit > Keys > Scale Keys” on page 165.

Snap

Use Snap to force selected keys to snap in time to the nearest whole time units.
Use Select Unsnapped to check for keys not at whole time units. See "Edit >
Keys > Snap Keys” on page 167.

Select Unsnapped

Selects all keys from the selected channel. If no objects or attributes are
selected, it selects any keys in the View Area.

View menu

This menu controls the layout of the Dope Sheet view area.

Note When framing the desired range, the Dope Sheet may scale the
area within the graph view horizontally and vertically to display the
desired range.

Frame All

Frame All adjusts the graph view to fit all animation in the window.
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Frame Selected

Frame Selected adjusts graph view to fit selected animation in the window.

Frame Playback Range

Frame Playback Range adjusts the graph view to fit the playback range in the
window.

Center Current Time

If you want to shift the view so the current time is in the middle of the editor,
select Center Current Time from the View menu.

Auto Frame

This adjusts the graph view to fit the display when new curves associated with a
selected object are loaded into the Dope Sheet.

Note Auto Frame works differently in the Dope Sheet than in the Graph
Editor.

Dope Sheet Summary

This option loads the Dope Sheet Summary into the Dope Sheet outliner. See
"Dope Sheet outliner” on page 155 for more information about summary objects.
Scene Summary

This option loads the Scene Summary into the Dope Sheet outliner.

Curves menu

The Curves menu items are functions for processing animation curves.

Pre and Post Infinity animation curves options

In Maya, animation curves are extrapolated outside the first and last keys of the
curve. Curves before the first key and after the last key will be flat (no change in
value over time) unless you set the pre and post tangent controls to anything
other than constant. You can use these options to automatically generate
specific types of repeating animation. For definitions of the pre and post infinity
curve types, see "Pre and Post Infinity” on page 125.

Note If you want to create editable animation of a repetitious or cyclical
nature, you can bake a channel with Infinity turned on.

Animation
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Bake Channel

This operation calculates a new animation curve for an attribute using the input
nodes that contribute to its properties. See "Bake Channel Options window” on
page 127. Bake Channel is useful to:

e Edit a single animation curve instead of all the contributing attributes that
affect the behavior of a single attribute, for example, an object affected by a
driven key or an Expression.

e Add keys to an existing curve

Change Rotation Interp

Change Rotation Interp lets you can change the rotation interpolation type of
existing curves.

You can change the rotation interpolation type only on rotation channels that
have keyframes on all three channels (rotateX, rotateY, rotateZ). In addition,
because the rotateX, rotateY and rotateZ channels always share the same
interpolation type, changing interpolation for a single channel such as rotateX,
will automatically change rotateY and rotateZ as well.

See "Change Rotation Interp” on page 129.

Simplify Curve

Use this operation to remove keys that are not necessary to describe the shape
of an animation curve. Excess keys may accumulate on an animation curve as a
result of adding keys manually or performing operations such as a Bake Channel.
You may need to remove keys from an animation curve to reduce the complexity
of the graph view. You might also need to provide larger spans for adjusting curve
tangents.

See "Simplify Curve” on page 130.

Euler Filter
See "Euler Filter” on page 130.

Resampling curves

You can resample dense data curves with the Curve > Resample Curves option in
the Graph Editor or Dope Sheet. Resampling creates a periodic frame rate by
placing keys at uniform intervals.

To resample a curve, you select a sampling filter, which is an algorithm defining
how the keys in the curve are resampled. Tangent and curve values are ignored.
The filter converts animation curves with keys at either uniform or non-uniform
intervals to curves with keys at a uniform interval that you specify. See
"Resample Curve Options window” on page 131.
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Tip The resampling filters are designed to reduce the number of keys in
dense data curves. It may not produce the desired results when
used on curves with few keys.

Spreadsheet

This menu selection lets you edit the attributes of the selected animation curves
in the Attribute Editor spreadsheet.

Non-Weighted and Weighted Tangents

Specify the tangent weighting for selected keys. The default setting is
non-weighted tangents, which provide simple handles for manipulating the
tangent’s angle.

Weighted tangents represent the amount of influence a tangent has on an
animation curve segment. By turning on Free Tangent Weight, it is possible to
simultaneously edit the influence and angle of the tangent quickly and intuitively.
Users of desktop illustration packages will recognize the familiar Bezier-style
behavior when in this mode.

Keys menu

Convert to Key

Converts selected keys to breakdowns.

Convert to Breakdown

Converts selected breakdowns to keys.

Add Inbetween

Inserts an inbetween at the current time.

Remove Inbetween

Removes an Inbetween at the current time.

Mute Keys

Mutes the selected keys. Keys that are muted do not contribute to the animation
on their channels.

When keys are muted, the following occurs:

e A green + symbol appears next to the names of the muted keys channels in
the Dope Sheet Outliner.

e Mute channels with keys appear under the muted keys channels in the Dope
Sheet.

Animation
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Green + symbol
indicates that the
channel has an

active Mute node = |

Mute channel name ——

Mute channel

Mute channels have the same number of keys as the muted keys animation
channels, and their keys are positioned the same as those on the muted
keys animation channels.
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Unmute Keys

Unmutes the selected keys. Keys that are not muted contribute to the animation
on their channels. Unmuting keys disables their Mute channels (indicated by the

red

x symbol next to the names of the muted keys channels in the Dope Sheet

Outliner) but does not remove them.

Red x symbol

indicates that the
channel hasa —
disabled Mute node
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To remove Mute channels, see "Mute or unmute a channel in the Dope Sheet or
Graph Editor” on page 99.

Animation
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Tangents menu

Tangents describe the entry and exit of curve segments from a key. This menu
operates on the shape of curve segments around selected keys. Note that these
settings affect only existing animation curves segments’ tangents. See "Tangents
menu” on page 136.

Spline
See "Spline” on page 136.
Linear

See "Linear” on page 136.

Clamped
See "Clamped” on page 137.

Stepped
See "Stepped” on page 137.

Flat
See "Flat” on page 137.

Fixed
See "Fixed” on page 137.

Plateau
See "Plateau” on page 138.

In Tangent

See "In Tangent menu” on page 138.
Out Tangent

See "Out Tangent menu” on page 138.

List menu

Hierarchy Below

Use Hierarchy Below to turn on/off the display of objects acting as summary
objects for objects beneath them.

Animation
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For example, in the following diagram, a cone with a Translate X channel is under
a group with no animation on it. With Hierarchy Below on, the groupl node
displays the animation information of its child node, the cone, acting therefore as
a summary group. With Hierarchy Below off, only the summary objects
(Dopesheet Summary, Scene Summary) display summary information.
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Auto Load Selected Objects

When List > Auto Load Selected Objects is on, the objects that appear in the
Dope Sheet outliner will change every time you make a selection to show the
currently selected objects. If List > Auto Load Selected Objects is off, it locks the
objects currently in the Dope Sheet outliner so you can continue to edit their
animation curves even if you make a new selection in a scene view.

Load Selected Objects

You can use this item only when List > Auto Load Selected Objects is off. When
Auto Load Selected Objects is off, the objects appearing in the Dope Sheet
outliner may be out of synch with what is currently selected in a scene view. To
load the currently selected objects, select List > Load Selected Objects.

Add Selected Objects

To work on the animation of one object in the Dope Sheet and another object not
loaded in the Dope Sheet outliner, select that object and choose Options > Add
Selected to List. This will add the selected object to the Dope Sheet outliner
without disrupting the layout in the Dope Sheet.

Bookmarks

To work with the animation of an object or a collection of objects in the Dope
Sheet and save that current editing environment, create a bookmark.
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Bookmark Current Objects

When invoked, Bookmark Current Objects provides an option box so you can
name bookmarks. Bookmarks appear as a list in the Bookmarks menu as
they are created.

Note When bookmarks are loaded into the Dope Sheet, List > Auto Load
Selected Objects is automatically turned off.

Show menu

This menu is the same as its counterpart in the Outliner.

Dope Sheet toolbar

Select Keyframe Tool

=] You can manage time in the Dope Sheet using the Select Keyframe Tool.
With the Select Keyframe Tool, you can place and create the

Dope Sheet Manipulator. The Dope Sheet Manipulator lets you select,
move and scale, as well as copy, cut and paste blank regions of time and regions
of time that contain keys in the Dope Sheet. This is useful when you want to
move, scale, mute, add or delete regions of time and keyframes and have the
rest of your animation shift to accommodate the addition or removal of time and
keyframes. For example, when a region of time and keys are cut, the rest of the
time and keys in the animation will shift to fill in the gap created by the cut.
When the time and keys are then pasted, the animation will shift to make room
for the pasted time and keys.

Move Nearest Picked Key Tool

g This tool lets you quickly manipulate individual keys and tangents with a
single mouse action.

This tool differs from the Move Tool in that it will only operate on one key at a
time. It will also operate on the closest selected key of an active curve without
you having to precisely select a key point or tangent handle in the graph view.
Move Nearest Picked Key Tool Settings window

Double-click the Move Nearest Picked Key Tool icon to open the Tool Settings
window for this tool.

DirectKey Options (Move Option)

MoveOnly Disables the Move Nearest Picked Key tool’s ability to
sweep throughout a curve’s keys (see MoveOver, below).
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MoveOver The default setting enables the tool to sweep through an
active curve along the curve’s keys, which expedites the
fine-tuning of animation curves.

Insert Keys Tool

w Choose the Insert Keys Tool to place new keys on an existing animation
*+ curve. To select the curve you want to add a new key to, click the curve.

The location of the new key is determined by middle-dragging along the animation
curve. The key is placed when you release the mouse button.

The new key will possess tangents that preserve the original animation curve
segment’s shape.

Add Keys Tool

‘p The Add Keys Tool lets you add keys to a selected animation curve
+ anywhere in the graph view.

Middle-click the location on the curve where you want to place the new key.
Releasing the mouse button places the key.

The new key’s tangents will be of the same type as the adjacent keys’ types.

The Add Keys Tool places a new key on the curve at the time where you middle-
clicked. It works like the Add Keys tool in the Graph Editor with an important
exception. Because the Dope Sheet view area does not display values, using the
Add Key tool in this window results in keys being placed with their value set to
the current value of the attribute.

Stats fields

The Stats fields numerically represents a selected key’s time and value. You can
edit them explicitly by entering values from the keyboard, or relatively by
incorporating operators into the input. These operators are the same as those
employed in the Channel Box. For more information, see the Basics guide.

Operator Function

+=value the entered value is added to the existing value
*=value the entered value multiplies the existing value

-=value the entered value is subtracted from the existing value
/=value the entered value divides the existing value
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Hierarchy below/none

This button toggles the Hierarchy Below option available in the List menu.
i See "Hierarchy Below” on page 151 for more information.

Auto Load Dope Sheet buttons

c This button toggles the Auto Load Selected Objects option from the List
menu. See "Auto Load Selected Objects” on page 152 for more
information.

« This button loads selected objects into the Dope Sheet View Area when
Auto Load Selected Objects is not enabled. See "Load Selected Objects” on
page 152 for more information.

Dope Sheet outliner

The Dope Sheet outliner hierarchically represents the attributes of selected
objects. The Dope Sheet outliner organizes attributes in groups according to type
and object. This lets you manipulate entire collections of attributes at once. For
example, all of the rotation attributes of objects listed in the outliner are
summarized and available for manipulation in the Summary group Rotate. The
organization of this grouping descends as follows:

@& Dopesheet Summary Summary
@5 nurbsSpherel .
@g nurbsSphere2 ObJeCtS
Fraifrir e
® Translate | Compound attributes
@ Rotate
= Scale

Attributes

Seafe X
S ¥
Sedde &
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Outliner groupings

Summary
All keys all selected objects by attribute type.

Objects

All the keyed attributes for the selected objects in the Dope Sheet outliner.

Animation
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Compound attributes

All the individual attributes of a particular type, such as translation, rotation, and
so on.

Attributes

Individual attributes are the lowest level of the Dope Sheet outliner hierarchy.

Note When Summary, object, and compound attribute groups are
collapsed in the Dope Sheet outliner, attributes within a collapsed
hierarchy are not selected and therefore not edited when you do
actions in the view area.

Dope Sheet view area

The view area of the Dope Sheet displays keys hierarchically along the vertical
axis. It displays time along the horizontal axis as cells or blocks.

Note The time blocks represented in the view area of the Dope Sheet are
integer value divisions of time; that is, the block at time 2 includes
the range of animation information from 2 to 3, excluding
information at time 3.

Animated attributes are bounded by solid lines to indicate their extents. The
colors of the blocks define the placement of an attribute or group of attributes
within the hierarchy of the Dope Sheet.

Editing ranges of time and keys with the Dope Sheet
Manipulator

See "Copy, cut, paste, scale, move, or mute a range of time and keys with the
Dope Sheet Manipulator” on page 111.

Key and Curve colors

Blue
All keys of all displayed objects (Summary object).

Dark green

All of the keyable attributes for the selected object in the Dope Sheet outliner
(object groups).
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Light green

All of the individual attributes of a particular type, such as translation, rotation,
and so on (compound attributes).

Black

Keys for unselected individual attributes.

Yellow
Selected keys.

Gray

Keys with a value of O.

The Dope Sheet pop-up menu bar

Right-clicking anywhere in the view area causes a pop-up menu containing the
Dope Sheet menu bar items to appear.

Sound in the Dope Sheet

Sounds will appear in the Dope Sheet view area according to the settings in the
Preferences window.

Select Tool, Move Tool, and Scale Tool

In addition to the Dope Sheet tools in the toolbar, the Select Tool, Move Tool,
and Scale Tool also are used to manipulate keys in the view area of the Dope
Sheet. Because of the hierarchical nature of the Dope Sheet outliner, you can
edit groups of attributes by type. This lets you perform powerful timing editing on
large numbers of objects at once. See "Select Tool” on page 144, "Move Keys
Tool” on page 144, and "Scale Keys Tool” on page 144.

Navigating the view area

You can scroll the graph view of the Dope Sheet horizontally by holding down the
Alt (Linux and Windows) or Option (Mac OS X) key on the keyboard and middle-
dragging.

To scale the graph view uniformly, hold down the Alt or Option key and drag or
middle-drag the cursor.

To scale the graph view along either the horizontal or vertical axis, hold down the
Alt or Option and Shift key, and right-drag the cursor horizontally or vertically.

Animation
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Menus

Edit >

Keys >

Edit > Keys > Copy Keys

Copies the current keys to the virtual clipboard.

Edit > Keys > Copy Keys > O
Opens the Copy Keys Options window. See "To copy keys” on page 78. and "To

cut keys” on page 77.
Hierarchy

Specifies how a group of keys will be cut from a hierarchy of grouped or

parented objects.
Selected

Below

Channels

Specifies that the group of keys will include only the
animation curves of the currently selected object. Default
is on.

Specifies that the group of keys will include the
animation curves of the selected object and all the
objects below it in the hierarchy. The keys clipboard
keeps track of the hierarchical relationships of the keys
and animation curves in the keyset. You can paste the
keyset to a hierarchy of objects whose hierarchical
structure is the same as the one the keyset was cut
from. If the hierarchical structure is not the same, Maya
will paste the keys in a way that best matches the
keyset’'s hierarchical relationships to the hierarchical
structure of the objects. Default is off.

Specifies the channels (keyable attributes) whose animation curves will be
included in the keyset.

All Keyable

From Channel
Box

Specifies that the keyset will include the animation
curves of all keyable attributes of the selected object.
Default is on.

Specifies that the keyset will include the animation
curves of only those channels currently selected in the
Channel Box. Default is off.
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Driven Channels

Specifies that the keyset will include any driven keys. The driven keys enable
the values of keyable attributes (channels) to be driven by the values of other
attributes. See "Driven keys” on page 68. Default is off.

Control Points

Specifies whether the keyset to be copied includes all the animation curves
of the selected deformable object’s control points. Control points include
NURBS control vertices (CVs), polygonal vertices, and lattice points. For
instance, if you select a NURBS surface’s transform node and then select
Edit > Keys > Copy Keys with the Control Points option on, the animation
curves for the surface’s CVs will be cut along with the animation curves for
the surface’s translation, rotation, scaling, and so on. Turning Control Points
on is useful when you are doing a lot of animation at the control point level
(for instance, CV-intensive animation) and don’t want to have to select each
control point. Control Points is off by default.

Note If you select individual CVs and then select Edit > Keys > Copy
Keys with Control Points on, only the animation curves for the
selected CVs are copied.

Shapes

Specifies whether the keys will include the animation curves of a selected
object’s shape node as well as its transform node. Typically, when you select
an object in the workspace, the object’s transform node is selected. To cut
the animation curves of the object’s shape node as well as its transform
node, be sure Shapes is on. To cut the animation curves of the transform
node only, turn Shapes off. Default is on.

Time Range

Specifies the time range of the keyset’s animation curves.

All Specifies no limit on the time range.

Start/End Specifies a time range from Start Time to End Time.

Time Slider Specifies a time range defined by the Playback Start and
End times of the Timeline.

Start Time Specifies the start of the time range (available if Start/
End is on).

End Time Specifies the end of the time range (available if Start/
End is on).

Help Images

Displays an image in the Cut Keys Options window that illustrates cutting to
the keys clipboard within a specified time range.
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Method

Specifies whether the keyset will include keys only or keys and animation
curve segments (available if Start/End or Time Slider is on).

Keys

Segments

Range

Adjustment

Specifies that the keyset will include only keys.

Specifies that the keyset will include keys and animation
curve segments. This is useful when you want to cut the
segments of animation curves that lie between keys. For
instance, you might not have any keys in the time range
you’ve selected, but you want to cut the animation curve
action in the time range. To preserve the shape of the
animation curve segments, Maya will create keys at the
time range’s start and end times if keys do not already
exist at those times.

Prevents keys that lie at the beginning or end of a
selected range of keys or time and keys from being
included in the cut or copy operations. Range also
causes your animation in the Dope Sheet to shift to
accommodate the removal or insertion of keys or time
and keys.

Specifies how the keyset is copied to the keys clipboard after it has been cut
(available if Segments is on).

None

Collapse

Connect

Specifies cutting keys within the specified range. If there
are keys remaining adjacent to both ends of the deleted
area, the animation curve(s) produced will retain the out
tangent and in tangent of the key in the cut area.

Specifies removing keys within the specified range. Any
keys preceding the cut are moved to the start time of the
cut area, effectively “shuffling forward” the animation
curve to fill the resulting gap.

Adjusts the keys clipboard curves in value and adjusts the segment of the
original curve following the pasted segment. This prevents discontinuity in the
animation (available if Collapse is on).

Edit > Keys > Cut Keys

Cuts the current keys form the scene and stores them in the virtual keyboard.

Edit > Keys > Cut Keys > O

Opens the Cut Keys Options window. The Copy Keys and Cut Keys options
windows have the same options. See "Edit > Keys > Copy Keys > 0" on

page 158.
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Edit > Keys > Paste Keys

Pastes the keys currently in the virtual clipboard to the time line where the
current time indicator is located.

Edit > Keys > Paste Keys > O

Opens the Paste Keys Options window. See "To paste keys” on page 79.

Time Range

Specifies the time range of the keyset’s animation curves.

Start transfers the animation information to the selected objects so that the
animation starts at the time specified in the Start Time field.

Start/End

Current

Clipboard

Start Time

End Time

Time Offset

Transfers the animation information to the selected
object or objects, scaling the animation to fit into the
specified time range as entered in the Start Time and
End Time fields. Animation information from the keys
clipboard is either scaled or clipped depending on the
setting of the Clipboard Adjustment option.

For example, if the animation information on the keys
clipboard consists of two keys four frames apart,
specifying a start/end time range of 8 to 18 will scale
the pasted keys across 10 frames.

Transfers the animation information to the selected
objects so that the animation starts at the current time
as displayed in the Animation Controls.

Transfers the animation information to the selected
object or objects, preserving the duration and timing of
the animation information on the keys clipboard.

Specifies the start of the time range (available if Start/
End is on).

Specifies the end of the time range (available if Start/
End is on).

Adds the number entered in the numeric input field to the time values on the
keys clipboard prior to pasting.

Value Offset

Adds the number entered in the numeric input field to the attribute values on
the keys clipboard prior to pasting.

Copies

To facilitate replication of animation information, use the Copies field to enter
a value that represents the number of times the animation will be copied.

Animation
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Multiple copies are appended sequentially. For example, you could create the
repetitious animation of a rotating lamp assembly of a lighthouse by keying
one rotation of the lamp, copying the animation information, and then pasting
multiple copies back onto the lamp.

Help Images

Enabling Help Images provides illustrations of the effects of the various paste

settings.
Clipboard

Adjustment Preserve

Pastes the contents of the clipboard into their new positions on the curve
without any changes.

Scale

Fit

Paste Method

Insert

Replace

Merge

Replace Region

Becomes enabled when Start/End is selected. The
complete contents of the clipboard curves are stretched
or compressed to fit into the specified paste Time
Range.

Becomes enabled when Start/End is selected. The
contents of the clipboard are preserved (that is, not
stretched or compressed) and as much as will fit into the
specified time range is pasted into the new area.

Places the clipboard contents before any existing keys in
the specified time range. The keys from the original
curve that were after the specified time range are shifted
in time by the pasted range times.

Becomes enabled when Start/End or Clipboard is
selected. The clipboard contents overwrite any existing
keys in the specified time range.

Adds the clipboard contents to any existing keys on the
curve. In the case where a clipboard key is at the same
time as an existing key, the clipboard key replaces the
existing key.

These fields are enabled when Paste Method is set to Replace.

Time Range

Entire Curve

Animation
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Replaces keys and curve segment information in the
specified time range with the contents of the keys
clipboard.

Is available only when the Time Range setting is
Clipboard. The Entire Curve setting replaces the
animation curve(s) on the pasted attributes with the
contents of the keys clipboard, in effect deleting any
existing animation curves on these attributes and
applying the new curves from the keys clipboard.
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This option adjusts the keys clipboard curves in value so there’s no
discontinuity in the animation at the start of the pasted segment.

Edit > Keys > Delete Keys

Deletes the current keys.

Edit > Keys > Delete Keys > O

Opens the Delete Keys Options window. See "To delete keys” on page 80.

Objects

Selected

All

Hierarchy

Specifies to delete keys only from the currently selected
objects.

Deletes keys for all objects, including objects that you
can’t usually select from the scene view (such as
construction history nodes).

Specifies how a keyset will be deleted from a hierarchy of grouped or

parented objects.

Selected

Below

Channels

Specifies that the keyset to be deleted will include only
the animation curves of the currently selected object.
Default is on.

Specifies that the keyset to be deleted will include the
animation curves of the selected object and all the
objects below it in the hierarchy. Default is off.

Specifies the channels (keyable attributes) whose animation curves will be
included in the deleted keyset.

All Keyable

From Channel
Box

Driven Channels

Specifies that the keyset will include the animation
curves of all keyable attributes of the selected object.
Default is on.

Specifies that the keyset will include the animation
curves of only those channels currently selected in the
Channel Box. Default is off.

Specifies that the keyset to be deleted will include any driven keys. The
driven keys enable the values of keyable attributes (channels) to be driven by
the values of other attributes. See "Driven keys” on page 68. Default is off.
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Control Points

Specifies whether the keyset to be deleted will include all the animation
curves of a selected deformable object’s control points. Control points
include NURBS control vertices (CVs), polygonal vertices, and lattice points.

Default is off.
Shapes

Specifies whether the keyset to be deleted will include the animation curves
of a selected object’s shape node as well as its transform node. Typically,
when you directly select an object in the workspace (for instance, in the
perspective view), what is selected is the object’s transform node. To delete
the animation curves of the object’s shape node as well as its transform
node, be sure Shapes is on. To delete the animation curves of the transform
node only, turn Shapes off. Default is on.

Time Range

Specifies the time range of the keyset’s animation curves.

All
Start/End

Time Slider
Start Time
End Time

Help Images

Specifies no limit on the time range.
Specifies a time range from Start Time to End Time.

Specifies a time range defined by the Playback Start and
End times of the Timeline.

Specifies the start of the time range (available if Start/
End is on).

Specifies the end of the time range (available if Start/
End is on).

Displays an image in the Delete Keys Options window that illustrates deleting
within a specified time range.

Method

Keys

Segments

Specifies whether the keyset to be deleted will include
keys only or keys and animation curve segments
(available if Start/End or Time Slider is on).

Specifies that the keyset will include only keys.

Specifies that the keyset to be deleted will include keys
and animation curve segments. This is useful when you
want to delete the segments of animation curves that lie
between keys. For instance, you might not have any keys
in the time range you’ve selected, but you want to delete
the animation curve action in the time range. To preserve
the shape of the animation curve segments, Maya will
create keys at the time range’s start and end times if
keys do not already exist at those times.
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Adjustment

Specifies how the keyset is copied to the keys clipboard after it has been
deleted (available if Segments is on).

None Specifies deleting keys within the specified range. If
there are keys remaining adjacent to both ends of the
deleted area, the animation curve(s) produced will retain
the out tangent and in tangent of the key in the cut area.

Collapse Specifies removing keys within the specified range. Any
keys preceding the cut are moved to the start time of the
cut area, effectively “shuffling forward” the animation
curve to fill the resulting gap.

Connect

Adjusts the keys clipboard curves in value and adjusts the segment of the
original curve following the pasted segment. This prevents discontinuity in the
animation (available if Collapse is on).

Edit > Keys > Scale Keys

Scales the current keys using the settings in the Scale Keys Options window.

Related topics
« ”Scale keys” on page 81

Edit > Keys > Scale Keys > 0O

Opens the Scale Keys Options window.

Objects

Selected Sets that only the selected object’s keys are scaled.

All Sets that the keys from all objects are scaled, including
objects that you can’t select from the scene view (such
as construction history nodes).

Hierarchy

Specifies how the keysets from a hierarchy of grouped or parented objects

are scaled.

Selected Sets that the keyset to be scaled includes only the
animation curves of the selected object. Selected is on
by default.

Below Sets that the keyset to be scaled includes the animation

curves of the selected object and all the objects below it
in the hierarchy. Below is off by default.
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Channels

Specifies which channel’s (keyable attributes) animation curves are included
in the keyset to be scaled.

All Keyable

From Channel
Box

Driven Channels

Sets that the keyset to be scaled includes the animation
curves of all the keyable attributes from the selected
object. All Keyable is on by default.

Sets that the keyset to be scaled includes only the
animation curves of those channels currently selected in
the Channel Box. From Channel Box is off by default.

Sets that the keyset to be scaled includes all the driven keys from the
selected objects. See "Driven keys” on page 68. Driven Channels is off by

default.

Control Points

Sets that the keyset to be scaled includes all the animation curves of a
selected deformable object’s control points. Control points include NURBS
control vertices (CVs), polygonal vertices, and lattice points. Control Points is

off by default.

Shapes

Sets that the keyset to be scaled includes the animation curves of a selected
object’s shape node as well as its transform node. Typically, when you
directly select an object in the scene view, only the object’s transform node

is selected.

To scale the animation curves of the object’s shape node as well as its
transform node, turn Shapes on. To scale the animation curves of the
object’s transform node only, turn Shapes off. Shapes is on by default.

Time Range

Specifies the time range of the keyset’s animation curves.

All
Start/End

Time Slider

Start Time

End Time

Sets no limit on the time range.
Sets a time range from Start Time to End Time.

Sets a time range defined by the Playback Start and End
times of the Timeline.

Sets the start of the time range. Start Time is only
available when Start/End is on.

Sets the end of the time range. End Time is only
available only when Start/End is on.
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Method

Scale/Pivot Applies multipliers to the selected range for time and
value. This also sets a pivot point from which the scaling
takes place on each axis.

When on, the animation is scaled without affecting the
curves of the animation before and after the specified
range. Also, the keys and animation curve segments
adjacent to the scaled region are shifted in time by the
amount the scaled range has been compressed or
expanded, and their shapes are preserved.

Start/End Compresses or expands the selected range to fit in the
range specified by the New Start/End Times fields.

Only Scale Specified Keys

When on, Scale Keys only affects selected keys. When off, Scale Keys
affects all keys.

Time Scale/Pivot

Sets the time multiplier. The first field sets the value that multiplies all the
times of the keyset. The second field sets the pivot point from which the
scaling takes place.

Tip You can cut the duration of a range of animation in half using the
Time Scale/Pivot option.

Value Scale/Pivot

Sets the value multiplier. The first field sets the value that multiplies all the
values of the keyset. The second field sets the pivot point from which the
scaling takes place.

New Start/End Times

Sets the time range into which the keyset is compressed or expanded. New
Start/End Times is only available when Start/End is on.

Edit > Keys > Snap Keys

Snaps the current keys using the setting in the Snap Keys Options window.

Edit > Keys > Snap Keys > O
Opens the Snap Keys Options window. See "To snap keys” on page 83.
Objects

Selected Specifies to snap keys only from the currently selected
objects.
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All Specifies to snap keys on all objects, including objects
that you can’t usually select from the scene view (such
as construction history nodes).

Hierarchy

Specifies how keys in the selected keyset will be snapped from a hierarchy of
grouped or parented objects.

Selected Specifies that the keys to be snapped will include only
the keys on the currently selected object. Default is on.

Below Specifies that the keys to be snapped will include the
keys on the selected object and all the objects below it
in the hierarchy. Default is off.

Channels

Specifies the channels (keyable attributes) whose keys will be snapped.

All Keyable Specifies that the keyset will include the animation
curves of all keyable attributes of the selected object.
Default is on.

From Channel

Box Specifies that the keyset will include the animation
curves of only those channels currently selected in the
Channel Box. Default is off.

Driven Channels

Specifies that the keyset to be deleted will include any driven keys. The
driven keys enable the values of keyable attributes (channels) to be driven by
the values of other attributes. See "Driven keys” on page 68. Default is off.

Control Points

Specifies whether the keyset to be deleted will include all the animation
curves of a selected deformable object’s control points. Control points
include NURBS control vertices (CVs), polygonal vertices, and lattice points.
Default is off.

Shapes

Specifies whether the keyset to be deleted will include the animation curves
of a selected object’s shape node as well as its transform node. Typically,
when you directly select an object in the workspace (for instance, in the
perspective view), what is selected is the object’s transform node. To delete
the animation curves of the object’s shape node as well as its transform
node, be sure Shapes is on. To delete the animation curves of the transform
node only, turn Shapes off. Default is on.

Time Range
Specifies the time range of the keyset’s animation curves.

All Specifies no limit on the time range.
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Specifies a time range from Start Time to End Time.

Specifies a time range defined by the Playback Start and
End times of the Timeline.

Specifies the start of the time range (available if Start/
End is on).

Specifies the end of the time range (available if Start/
End is on).

Snaps keys along the time axis only. This is the default
setting.

Snaps keys along the value axis only.

Snaps keys along both the time and value axes.

Snap Times to Multiples of

This value defines multiples of the time unit to snap to.

Snap Values to Multiples of

This value defines multiples of whole number attribute values to snap to.

Edit > Keys > Bake Simulation

Bakes the current simulation. See "Bake keys” on page 84.

Edit > Keys > Bake Simulation > 0

Opens the Bake Simulation Options window. See "To set Bake Simulation

options” on page 87.

Hierarchy

Specifies how a keyset will be baked from a hierarchy of grouped or parented

objects.
Selected

Below

Channels

Specifies that the keyset to be baked will include only
the animation curves of the currently selected object.
Default is on.

Specifies that the keyset to be baked will include the
animation curves of the selected object and all the
objects below it in the hierarchy. Default is off.

Specifies the channels (keyable attributes) whose animation curves will be
included in the keyset.

All Keyable

Specifies that the keyset will include the animation
curves of all keyable attributes of the selected object.
Default is on.
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From Channel

Box Specifies that the keyset will include the animation
curves of only those channels currently selected in the
Channel Box. Default is off.

Driven Channels

Specifies that the keyset will include any driven keys. The driven keys enable
the values of keyable attributes (channels) to be driven by the values of other
attributes. See "Driven keys” on page 68. Default is off.

Control Points

Specifies whether the keyset will include all the animation curves of a
selected deformable object’s control points. Control points include NURBS
control vertices (CVs), polygonal vertices, and lattice points. Default is off.

Shapes

Specifies whether the keyset will include the animation curves of a selected
object’s shape node as well as its transform node. Default is on.

Time Range

Specifies the time range of the keyset’s animation curves.

All Specifies no limit on the time range.

Start/End Specifies a time range from Start Time to End Time.

Time Slider Specifies a time range defined by the Playback Start and
End times of the Timeline.

Start Time Specifies the start of the time range (available if Start/
End is on).

End Time Specifies the end of the time range (available if Start/
End is on).

Sample By

Specifies the frequency with which Maya will evaluate the animation and
generate keys. Increasing this value decreases how often Maya sets keys for
the animation. Decreasing has the opposite effect.

The Sample By value is based on the Time Unit setting. It represents the
frequency with which Maya will analyze the object’s animation and generate a
key. A value of 1 creates a key at each time unit. Greater values decrease
the frequency of generated keys, and smaller values increase the frequency.

Keep Unbaked
Keys

This option preserves the keys that are outside the baked time range and
only applies to directly connected animation curves. When on, bake
simulation does not remove keys that are outside the bake range. When off,
only the keys created within the specified time range during the bake will be
present on the animation curve after the operation.
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Sparse Curve Bake

This option operates only on directly connected animation curves. It produces
bake results that create only enough keys to represent the shape of the
animation curve.

Disable Implicit Control

This option disables the effect of controls such as IK handles once the bake
simulation has been performed.

Animation menu set

Animate

Animate > Set Key

Inserts a key in the time line at the time where the current time indicator is
positioned.

Animate > Set Key > 0
Opens the Set Key Options window.
Set Keys on
Specifies which attributes will have keys set on them.

All Manipulator

Handles and

Keyable

Attributes Sets a key for the current manipulator, and if there is
none, then the current object. This is the default.

All Keyable

Attributes Sets keys on all attributes of the selected object(s).

All Manipulator

Handles Sets keys on attributes affected by the selected
manipulator. For example, when using the Move Tool,
keys will be set on the Translate X, Y, and Z attributes

only.

Current

Manipulator

Handle Sets keys on attributes affected by the selected
manipulator handle. For example, when using the Move
Tool’s X translation handle, keys will be set on the
Translate X attribute only.

Set Keys at

Specifies on what time the keys are set.
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Current Time Sets keys at the current time only.
Prompt Maya prompts for the times when setting keys.
Set IK/FK Keys

When keying an Ik handle or joint chain, Set IK/FK Keys adds keys for all
attributes of the handle and all joint of the chain. This lets you create smooth
IK/FK animations. This option is available only when “All Keyable Attributes”
is on. For more information, see Set IK/FK Keys and Switching IK/FK.

Hierarchy
Specifies which objects in a parent-child hierarchy will have keys set on them.
Selected Sets keys only on attributes of the selected object.

Below Sets keys on attributes of the selected object and its
child objects.

Channels

Specifies what channels will have keys set on them.

All Keyable Sets keys on all the channels of the selected object.

From Channel

Box Sets keys on the selected channels of the selected
object.

Control Points

Sets keys on the control points of the selected objects. Control points are
NURBS CVs, polygonal vertices, or lattice points. Be aware that if Control
Points is on and you key an object with many control points, for example, a
complex NURBS surface, you'll set a large number of keys. This slows Maya
operation. If you also set Hierarchy to Below, you might slow Maya operation
even more. Turn on these options only when necessary.

If you delete the construction history of an object with keyed CVs, the
animation will no longer work correctly.

Shapes

If on, sets keys on the attributes of an object’s shape node and transform
node. If off, keys will be set only on the attributes of the transform node.

Animate > Set Breakdown

For more information on Breakdowns, see "Breakdowns” on page 69.

Note Breakdowns that do not have adjacent keys are unbounded. These
breakdowns work like regular keys when you place, edit, and move
them.
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Animate > Set Breakdown > 0
Opens the Set Breakdown Options window.
Set Breakdowns on
Specifies which attributes will have breakdowns set on them.

All Keyable
Attributes Sets breakdowns on all attributes of the selected
object(s).

All Manipulator

Handles Sets breakdowns on attributes affected by the selected
manipulator. For example, when using the Move Tool,
breakdowns will be set on the Translate X, Y, and Z
attributes only.

Current

Manipulator

Handle Sets breakdowns on attributes affected by the selected
manipulator handle. For example, when using the Move
Tool’s X translation handle, breakdowns are set on the
Translate X attribute only.

Set Breakdowns at

Specifies on what time the breakdowns are set.

Current Time Sets breakdowns at the current time only.
Prompt Maya prompts for the times when setting breakdowns.
Hierarchy
Specifies which objects in a parent-child hierarchy will have breakdowns set
on them.
Selected Sets breakdowns only on attributes of the selected
object.
Below Sets breakdowns on attributes of the selected object
and its child objects.
Channels

Specifies what channels will have breakdowns set on them.

All Keyable Sets breakdowns on all the channels of the selected
object.

From Channel
Box Sets breakdowns on the selected channels of the
selected object.
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Control Points

Sets breakdowns on the control points of the selected objects. Control points
are NURBS CVs, polygonal vertices, or lattice points. Be aware that if Control
Points is on and you add breakdowns to an object with many control points,
such as a complex NURBS surface, you'll set a large number of breakdowns.
This slows Maya operation. If you also set Hierarchy to Below, you might slow
Maya operation even more. Turn on these options only when necessary.

If you delete the construction history of an object with CVs that have
breakdowns or keys, the animation will no longer work correctly.

Shapes

If on, sets breakdowns on the attributes of an object’s shape node and
transform node. If off, breakdowns will be set only on the attributes of the
transform node.

Animate > Hold Current Keys

Hold Current Keys sets keys for all animated attributes of a selected object at
the current time. This menu item is most useful with Auto Key because Auto Key
sets keys only for attributes that change value. For more information, see "To
hold Current Keys with Auto Key” on page 89.

For example, suppose you are animating a character’s walk cycle. When a foot is
on the ground, its position must be held for a number of frames. If you were to
use Auto Key alone, a value must change before a key can be set. Hold Current
Keys sets a key for the foot even though the values do not change.

Set Driven Key >

Animate > Set Driven Key > Set

Sets a driven key for the selected attributes. See "Set Driven Keys” on page 91.

Animate > Set Driven Key > Set > O

Opens the Set Driven Keys window. See "Set Driven Key window” on page 115.

Animate > Set Driven Key > Go to Previous and Go
to Next

See "Go to Previous and Go to Next” on page 116.
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Reference > Animate > Set Driven Key > Set Transform Keys menu

Animate > Set Driven Key > Set Transform Keys

menu

Translate

Adds a regular key at the current time on the X, Y, and Z translation channels of

the selected object.

Rotate

Adds a regular key at the current time on the X, Y, and Z rotation channels of the

selected object.

Scale

Adds a regular key at the current time on the X, Y, and Z scaling channels of the

selected object.

Hotkeys

Animation hotkeys

Hotkey Action

s Sets a key as Animate > Set Key
Shift+w Sets keys for translation; as Move Tool
Shift+e Sets keys for rotation; as Rotate tool
Shift+r Sets keys for scale; as Scale tool

Animation
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Nonlinear Animation

What is nonlinear animation?

After animating a character with keyframes or motion capture, you can collect its
animation data into a single, editable sequence. This animation sequence is
called an animation clip.

In Maya, there are two types of clip: source clips and regular clips. Maya
preserves and protects a character’s original animation curves by storing them in
source clips. You do not use source clips to animate your characters. Instead, you
use copies or instances of source clips called regular clips to animate your
characters nonlinearly. See "Animation clips” on page 181.

Moving, manipulating, and blending regular clips to produce a smooth series of
motions for a character is the basis of nonlinear animation. The tool with which
you manage all these aspects of a character’s nonlinear animation is the Trax
Editor. See "What is the Trax Editor?” on page 177.

Nonlinear animation tools in Maya

What is the Trax Editor?

A o«

Trax Editor window

The Trax Editor is a high-level animation tool that lets you select and control
characters and their animation clips, layer and blend animation sequences,
synchronize your animation and audio clips, and

drag-and-drop animation clips between mapped characters. See “Mapping
animation between characters” in the Character Setup and Deformers guide. You
can work with any type of animation in the Trax Editor—except motion path
animation.

Animation
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For example, suppose you keyframed a character’s walk and you now want to
turn it into a walk cycle. You can create a clip for the keyframe animation
sequence, scale and trim the clip to get it to be the right length and to have
similar start and end poses, and then cycle the clip to create a proper walk cycle.
If you wanted to change the walk cycle’s pace or rhythm, you can then create a
time warp curve for the clip, or if you wanted to turn the walk into a march, you
can manipulate the character and key into the clip directly. You can do all this to
the character’s walk sequence without destroying the original keyframe animation
because you are working with clips.

Related topics
+ "Trax Editor” on page 226

7

* "Nonlinear animation components in Trax” on page 181

What is the Character Mapper?
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Character Mapper window

With the Character Mapper window you can create a correspondence between a
source and target character’s nodes or attributes so that you can import and
export or copy and paste animation clips between mapped characters in the Trax
Editor.

Related topics

7

+» Character > Character Mapper in the Character Sets chapter of the Character
Setup and Deformers guide
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% “Map one character to another” in the Character Sets chapter of the
Character Setup and Deformers guide

< “Mapping animation between characters” in the Character Setup and
Deformers guide

What are the Visor, Outliner, and Clip Library?

When working with nonlinear animation, there are three ways you can access your

clips:

e Drag and drop source clips from the Visor to the Trax Editor

e Drag and drop regular or source clips from the Outliner to the Trax Editor

e |Insert source clips into their respective characters in the Trax Editor using the
Clip Library

See "Source clips” on page 182 and "Regular clips” on page 182

Note Before you can drag and drop or copy and paste clips from one
character to another, the characters must first be mapped. See
“Mapping animation between characters”in the Character Setup and
Deformers guide.

Visor

=0l x|

File View Tabs Help
Fluid Examplesl Fluid Initial States ~ Character Clips |EharaclErF‘ 3

Group.

T4 ) b d b dobdbddbidl

The Visor lists all the source clips in your scene as icons. You can select a clip
icon in the Visor, and then middle-drag the clip onto a character in the track view
area. Dragging a clip from the Visor onto a character in Trax adds a copy of the
selected clip to that character. See “Use the Visor with Trax” and Visor in the
Basics guide.

The Visor has four tabs that let you view your scene’s nonlinear animation data.
You can access all source clips and poses in your scene from the Character Clips,
Character Poses, Unused Clips, and Unused Poses tabs. All the clips that are used

Animation
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by characters in your scene appear in the Character Clips and Character Poses
tabs. All the clips and poses that are present in your scene, but are not used by
a character, appear in the Unused Clips and Unused Poses tabs.

Outliner
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The Outliner lists all the source and regular clips that are in your scene as text.
You can select a clip name in the Outliner, and then middle-drag the clip onto a
character in the track view area. Dragging a clip from the Outliner onto a
character in Trax adds a copy of the selected clip to that character. See "To view
clips in the Outliner” on page 189, "Use the Visor with Trax” on page 191, and
Visor in the Basics guide.

Clip Library

{xl Trax Editor

DancingSourcel [ g

‘WalkingSource

WalkingSourcel
‘WalkinglSource
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The Clip Library is a menu in the Trax Editor that lets you create copies of source
clips and poses for all the characters loaded in Trax. When you select a source
clip or pose from the Library, a copy of the selected clip or pose is created and
inserted into its respective character in Trax. For more information, see "Copy
source clips to a character” on page 219 and clipLibrary.
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Nonlinear animation components in Trax

In Maya, animating characters nonlinearly involves working with many different
animation components and levels of animation hierarchy. These chunks and
layers of animation data are what give you the freedom to mix, manipulate, edit,
and separate your character’s animation into any sequence you desire. The tool
with which you manage all these aspects of your character’s nonlinear animation
is the Trax Editor. See "Trax Editor” on page 226.

[ Character [ Summary Clip |
Track | Regular Clip
e Group | Summary Clip | |
Track ‘ Constraint Clip |
Track | Expression Clip ‘
[w Subcharacter | Summary Clip | l
Track ‘ Regular Clip ‘
Track | Regularcip |
[% Soundtrack
Audio Track Audio Clip |
Audio Track Audio Clip

Animation clips

Clips are the basic components of nonlinear animation in Maya. A clip is a
collection of animation curves for a character. If you create a clip for an animated
object that is not already part of a character set, then the Trax Editor
automatically creates a character for the clip. See "Characters, groups, and
subcharacters” on page 186.

Clips let you gather a character’s keyframe or motion capture animation curves
into one bundle, so that you can manipulate the character’s animation data
nonlinearly.

When you create a clip, two kinds of clips are generated: a source clip and a
regular clip.

The source clip is added to the character’s scene and the regular clip is inserted
under its character in the Trax Editor. For low-level information on what occurs in
Maya’s dependency graph (DG) when you create a clip, see "animClip” on

page 254. See also Dependency graph in the Basics guide.

Animation
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Source clips
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Source clip in the Visor, Outliner, and Library

The source clip contains the original, unmanipulated keyframe animation data
from the time when you turned that data into a clip. The source clip does not
appear in the Trax Editor. Instead, Maya saves the source clip outside of the Trax
Editor to protect the original animation curves from being accidentally modified
and ensures that you have an unmodified clip to revert back to should the need
arise.

Each regular clip is an instance of a source clip. When you change an attribute of
a source clip, each of its regular clips in the Trax Editor are also modified.

You can access your source clips from the Visor, Outliner, or the Library menu in
Trax. See "What are the Visor, Outliner, and Clip Library?” on page 179. You can
edit source clips by modifying their attributes in the Channel Box. See "Edit
source clips” on page 219.

Regular clips

1 3 40
Danzing
10 100% 49
Regular clip

The regular clip is an animation clip that is the child or instance of its source clip.
The playback range of the regular clip can be part or all of the range stored in the
source clip. See "Source In/Out” on page 243. The animation clips that appear
in the Trax Editor are regular clips.

You can access your regular clips from the Trax Editor or Outliner. See ”Outliner”
on page 180. You can edit regular clips by modifying them in the Trax Editor or by
changing their attributes in the Attribute Editor.
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Expression and Constraint clips

Expression clip

Constraint clip

You can create special clips for animations with expressions or constraints.
Expression and constraint clips can contain only expression or constraint
channels. By keeping expressions and constraints separate from regular
animation clips, Maya gives you more control over when in their character’s
animation they take effect as well as the range of the expressions or constraints
that are included in their clips.

For example, if your animated character has both keyframe animation channels
and expression channels, then you need to create a regular clip for the keyframe
channels and a separate expression clip for the character’s expression channels.
See "Create expression or constraint clips” on page 197.

In the Trax Editor, you can access and edit your expression and constraint clips
just like regular animation clips.

Summary clips

Summary clip

A summary clip represents the cumulative range of all a character’s clips and it
lets you move all the clips in a character at the same time. See "Summaries” on
page 242.

What can you do with animation clips?
You can do the following with clips:

e Move a clip to a different playback time
e Cycle a clip to repeat animation. See "Cycle clips” on page 205.

e Hold a clip to freeze its animation at a specific pose for a specified number
of frames. See "Hold clips” on page 206.

e Split, trim, duplicate, or merge clips to create new animation clips. See "Split
clips” on page 206, "Merge clips” on page 207, and "Duplicate clips” on
page 200.

e Blend animation clips to create smooth transitions between clips. See
"Create and edit blends” on page 211.

Animation
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e Key into clips to change or add to the animation curves in the clips. See "Key
into a clip from the Trax Editor” on page 217, "Key into a clip from outside of
the Trax Editor” on page 217, and "Active/inactive clips” on page 247.

e Synchronize clips of a single character or of several characters

e Create time warps for clips to change their timing without modifying their
animation curves. See "Create and edit time warps” on page 214.

e Copy clips between mapped characters. See “Mapping animation between
characters” in the Character Setup and Deformers guide.

e Import and export clips. See "Import or export animation data” on page 223.

e Drag and drop source clips from the Visor or Outliner into the Trax Editor. See
"Use the Visor with Trax” on page 191.

See "Clip interaction controls” on page 243 and "Clip states” on page 246.

Audio clips

L e

Audio clip

Audio clips are clips that contain audio file data. When you import .wav or .aiff
files into the Trax Editor, these audio files appear as audio clips under the
Soundtrack. See "Soundtrack” on page 242. You can use audio clips in Trax to
set-up the timing of your animation data and their respective audio files.

During animation playback, only one audio clip at a time plays and the play
priority of audio clips goes from the top-most clip to the bottom-most clip. For
example, if you have multiple audio tracks and clips that overlap in time, then the
audio clip in the top-most track will always play instead of other audio clips on
other tracks that are at the same position on the Trax timeline.

You can not manipulate (trim, scale, split and so on) audio clips in Trax. You can
only move audio clips along the Trax timeline. See "Work with audio” on
page 225.

Note If you want to hear the audio clips present in your Soundtrack
during animation playback, see "To hear audio clips present in
Trax” on page 226. When your audio clips are audible during
playback, their positions and lengths are represented by horizontal
green lines in the Time Slider.

Poses

You can store a snapshot of a character’s current position for any moment in its
animation. This snapshot is called a pose. See "Create poses” on page 197.
Poses are essentially clips that capture only one frame of a characters animation.
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You can access your poses from the Visor, Outliner, or the Library menu in Trax.
See "Visor” on page 179, "Outliner” on page 180, and "Clip Library” on

page 180. In the Trax Editor, you can scale, cycle, and hold poses just like
regular animation clips. See "What can you do with animation clips?” on

page 183. However, clip attributes (Frame In, Frame Out, and so on) do not
appear on poses in Trax since poses are only one frame in length by default. To
edit a pose’s attributes, you must modify its attributes in the Attribute Editor.

What can you do with poses?
Poses are useful in the following ways:

e You can use poses to compare the various positions of your character as you
animate. For example, if you animate a character walking in a circle, you can
display the pose of the character at its first step so that you know where it
must return to complete its circular route.

e You can create poses for a Blend Shape deformer to create combinations of
blendShape sliders. For example, if you define blendShape sliders for all
your character’s facial muscles, you can then create poses of the face
mouthing various phonemes.

e Lead animators can create various key poses for a lengthy character
animation sequence and then give the other animators on their team the
creative freedom to animate the character’'s motion between the poses.

Tracks
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Tracks

When you create a clip or pose for a character, the clip or pose is placed in a
track under its character. Tracks are cells in the track view area that span the
Trax timeline and can contain multiple clips. The clips in a track play from left to
right as the scene plays.

You can use tracks to align, separate, or group your character’s animation
sequences. You can also control the state of your tracks using the buttons (Lock,
Mute, and Solo) in the track control area. You can create and remove tracks
using the context-sensitive menu or by dragging clips upward or downward in the
track view area. See "To add a track to a character, group, or subcharacter” on
page 220.

Tracks appear under characters, groups, and subcharacters. See "Characters,
groups, and subcharacters” on page 186. Each character, group, or subcharacter
in Trax can have multiple tracks.

Related topics

7

« "Track view area” on page 240

Animation
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7

« "Track control area” on page 239
%+ "Track hierarchy” on page 241

Characters, groups, and subcharacters

Note You can change the names of characters, groups, and
subcharacters in the Trax Editor by double-clicking their names, and
then entering their new names.

Characters in Trax

{xl Trax Editor
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- '!-_‘,El 1= ple | 5% [ 5T 3T R 5P

Character sets or characters are collections of animated objects, parts of objects,
or attributes. If you create a clip for an animated object that is not already part of
a character set, then the Trax Editor automatically creates a character for the
clip. In the Trax Editor, characters appear as the first level of track hierarchy. This
means that characters are the parents or top-level groups for all their tracks,
groups, and subcharacters. See "Track hierarchy” on page 241.

Note When you delete a character, you also delete all its regular clips.
However, all the source clips for a deleted character remain in its
scene.

Related topics

%  “What are character sets?” in the Character Sets chapter of the Character
Setup and Deformers guide

«  “Animating Character Sets” in the Character Sets chapter of Character Setup
and Deformers guide

« “character” in the Character Sets chapter of the Character Setup and
Deformers guide
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Groups in Trax

itrl, Trax Editor

Groups are arbitrary collections of clips for a single character. You can use
groups to separate and isolate specific sequences of your character’s animation.
See "Create groups” on page 221. A character or subcharacter can have multiple
groups, but you can not have groups within groups.

Subcharacters in Trax

it Trax Editor

Subcharacter sets or subcharacters are bundles of related character set
attributes. You can use subcharacters to simultaneously key and manipulate
groups of attributes. See “Create subcharacter sets” in the Character Setup and
Deformers guide.

Animation
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How do 1I?
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Subcharacters are on the same level of the track hierarchy as character groups.
See "Subcharacters” on page 241. In the Trax Editor, subcharacters always
appear below a character’s groups. Characters can have muitiple subcharacters.

When working with subcharacters in the Trax Editor, note the following:

e |f you load a character that contains subcharacters into Trax, all that
character’s subcharacters automatically appear in the track view area.

e |f you create a subcharacter for a character that has existing clips, the
subcharacter inherits the existing clips so that no animation is lost.

e |f you turn on Include Subcharacters in Clip when you create a clip, Maya
creates a single source clip that includes all animation curves for the
character and all its subcharacters. See "Include Subcharacters in Clip” on
page 253.

Open and view the Trax Editor

Open the Trax Editor

To open the Trax Editor

In the Maya main menu, select Window > Animation Editors > Trax Editor.

Set the Trax Editor view

To view all clips present in the visible tracks

Do one of the following:

¢ In the Trax toolbar, click the Frame All | .| button.

e |n the Trax menu bar, select View > Frame All.

The Trax view scales so that all the clips in the visible tracks can be seen in the
track view area.

To view the clips within the Time Slider’s current playback range

Do one of the following:

¢ In the Trax toolbar, click the Frame Playback Range |BLE putton.

* |n the Trax menu bar, select View > Frame Playback Range.
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Set the Time Slider’s playback range to reflect the
range of clips in Trax

To set the Time Slider’s playback range to the range of the clips in Trax

1 Right<click in the Time Slider.
A pop-up menu appears.
2 Select Set Range to > Enabled Clips.

The Time Slider’s playback range now coincides with the current range of
clips in Trax.

Use the Outliner and Visor with Trax

Use the Outliner with Trax

To view clips in the Outliner

1 In the Maya main menu, select Window > Outliner.
The Outliner appears.

2 In the Outliner, turn off Display > DAG Objects Only.

3 Turn on Show > Objects > Clips.

All the animation clips in your scene (source and regular clips) are now listed
in the Outliner.

To copy a clip in the Outliner and paste it to a character in the Trax Editor

1 In the Maya main menu, select Window > Outliner.
The Outliner appears.

2 Display your scene’s source and regular clips in the Outliner. See the above
procedure.

All the animation clips in your scene (source and regular clips) are now listed
in the Outliner.

3 Middle-click the clip you want to copy and drag it from the Outliner to the
desired character, track, and position.

A white box representing the instance of the clip you are inserting appears
under your mouse pointer in the track view area. This white box is the same
length as the clip you are copying.

Also, if your mouse pointer is between tracks, a black line appears indicating
that a new track will be created between the tracks to house the clip you are
copying. See "To add a track to a character, group, or subcharacter” on

page 220.

Animation
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When you release the mouse button, an instance of the clip appears at the
location (track and point in Trax timeline) of the white box.

If you paste the clip to a character from the same character set, then Maya
creates an instance of the clip. See "Duplicate clips” on page 200.

If you paste the clip to a different character set, and a character map exists
between the clip’s character set and the character set you dragged the clip to,
then Maya pastes the clip using the character map. See “Mapping animation
between characters” in the Character Setup and Deformers guide.

Otherwise, Maya pastes the clip in the character using the By Node Name paste
method. If you want to paste using a different method, such as By Attribute
Name, then select the desired method in the Paste Clip Options window (Edit >
Paste > ).

To filter clips by name in the Outliner

In the Outliner’s Text Filter field, type the full name or parts of names you want
the listing of clips restricted to in the Outliner.

ol

Display Show  Help

Text Filter field

w2
et

For example, if you only want clips that begin with the letter D to appear in the
Outliner, type D* in the Outliner’s Text Filter field and press Enter.



3 | Nonlinear Animation
How do I? > Use the Visor with Trax

JRT=TEY JRT=TEY

DjefTay ~ghow  Help Display Show Help
Sigp; 2ig

ﬂ [ancing
DancingSource _> DancingSource
DancingSourcel DancingSourcel
Clip_*alkingl Source

Falling

Jogging

Running

Wwalking

‘whalkingl Source
Walking2
Walking2Source
Walking3

WalkingSource
WwalkingSourcel LI

Note The Outliner’s Text Filter field is case sensitive.

Use the Visor with Trax

To open the Visor from the Trax Editor

1

Do one of the following:
e In the Trax menu bar, select File > Visor.

e |n the Trax toolbar, click the Visor button.

Do one of the following:

e C(Click the Character Clips or Character Poses tab to display clips or poses
that have been applied to characters in the scene.

e C(Click the Unused Clips or Unused Poses tab to display clips or poses
that have not been applied to characters in the scene.

For example, if you imported a clip from another scene, you can access it
through the Unused Clips tab in the Visor.

To copy a source clip in the Visor and paste it to a character in the Trax Editor

1

Open the Visor.

See Visor in the Basics guide.

Click the Character Clips or Unused Character Clips tab.
Do one of the following:

e Middle-click the source clip you want to copy and drag it from the Visor to
the desired character, track, and position.

Animation
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A white box representing the clip you are inserting appears under your mouse
pointer in the track view area. This white box is the same length as the
source clip you are copying.

Also, if your mouse pointer is between tracks, a black line appears indicating
that a new track will be created between the tracks to house the clip you are
copying. See "To add a track to a character, group, or subcharacter” on

page 220.
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When you release the mouse button, an instance of the source clip appears
at the location (track and point in Trax timeline) of the white box.

e |n the Visor, right-click the source clip you want to copy.
e From the pop-menu that appears, select Copy.

e |n the track view area of Trax, right-click anywhere under the character to
which you want to paste the clip and select Paste Clip from the menu
that appears.

An instance of the selected source clip appears under the character in the
track where you clicked.

If you paste the clip to a character from the same character set, then Maya
creates an instance of the clip. See "Duplicate clips” on page 200.

If you paste the clip to a different character set, and a character map exists
between the source clip’s character set and the character set you dragged the
clip to, then Maya pastes the clip using the character map. See “Mapping
animation between characters” in the Character Setup and Deformers guide.

Otherwise, Maya pastes the clip in the character using the By Node Name paste
method. If you want to paste using a different method, such as By Attribute
Name, then select the desired method in the Paste Clip Options window (Edit >
Paste > 0O).

Animation
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To import clips from your disk to the Visor

1

In the Visor, select File > Import.
The Import file browser appears.

Navigate to the .ma or .mb file that contains the clip or clips you want to
import into Visor, select the file, and click Import.

The clips appear in the Unused Clips tab of the Visor.

To export clips from Visor to your disk

1

In the Visor, select File > Export Selected Network or right-click a clip or a
group of selected clips and select Export from the pop-up menu that appears.

The Export file browser appears.

Navigate to the folder on your disk you want to export you clips to and click
Export.

The clips you selected in the Visor are placed in a .ma or .mb file and are
exported to the directory and folder on your disk you specified.

To copy clips from your disk to your scene

See "To copy clips from your operating system’s file browser to your Maya scene”
on page 200.

Create, load, and highlight character sets

Create character sets

Note You do not have to manually create character sets in the Trax

Editor. When you create a clip for an animated object, a
character set is automatically created in the Trax Editor for the
object’s clip.

To create a character set from the Trax Editor

1
2

3

Select the object you want to add to a new character set.
In the Trax menu bar, select Create > Character Set > (3.

The Create Character Set Options window appears. See "Character Set” on
page 237.

Set the options and click Create Character Set.

A character set is created, and the selected object is made a member of that
set.

Animation
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Load character sets

To load characters into the Trax Editor

1 Select your character in the scene view or from the Current Character Set
drop-down list.

2 Do one of the following;:

e |n the Trax toolbar, click the Load Selected Characters +ﬂ button.

e In the Trax main menu bar, select List > Load Selected Characters. See
"Load Selected Characters” on page 238.

Your character appears in the track view area.

Note When List > Auto Load Selected Characters is on, all selected
characters are automatically loaded into Trax. See "Autoload
Selected Characters” on page 238.

Rename character sets in the Trax Editor

To change the name of a character in the Trax Editor

1 Double-click the name of the character you want to change.
2 Type in a new name for the character and then press Enter.

Highlight characters, groups, or subcharacters in
Trax

To highlight a character, group, or subcharacter in the Trax Editor

Select any clip that is under the character, group, or subcharacter you want to
select.

Note When a character is highlighted in Trax, its summary is outlined in
orange.

Highlighted
character

Animation
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Collapse, expand, and edit summaries

Expand and collapse a summary track

Summaryso izl

Arrow

Collapsed set of tracks for a character

To collapse or expand a summary track

In the Trax Editor, click the triangular arrow to the left of a character, group, or
subcharacter name.

If you collapsed the summary track, all the multiple tracks under the character,
group, or subcharacter now display as a single blue clip and track. If you move
this track to a different location, you move all clips within it.

If you expanded the summary track, all the multiple tracks under the character,
group, or subcharacter are now visible in the track view area.

Edit the summary clip

To edit the summary clip attributes

_ Start and End frame numbers
‘ for the summary clip

summary | I () . (e
| 2]

Summary clip

Collapsed set of tracks for a character

Do one of the following:

e You can move all the clips in all the tracks under a character, group, or
subcharacter by dragging the summary clip.

* You can scale a summary clip by dragging its beginning or end, or by editing
its Start and End frame numbers.

When you scale a summary clip, all the clips under its character,
subcharacter, or group are also scaled.

Related topics

7

% "Summaries” on page 242
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Create clips and poses

Create clips

Note e To quickly create a clip for an animated object, select the

object in the scene view and click the Create Clip | .| button.

e You can create clips for animations with expressions or
constraints. See "Create expression or constraint clips” on
page 197.

To create a clip for an animated object

1

2

Select the animated (keyframe or motion capture) objects whose animation
curves you want to put in a clip.

In the Trax Editor, select Create > Clip > .
The Create Clip Options window appears. See Animate > Create Clip.
Set the options and click Create Clip.

A clip is created for the selected objects animation channels and Maya
automatically creates a new character set to house the clip in Trax.

To create a clip for a character

1

2

Select the character set you want to create a clip for from the scene view or
from the Current Character Set drop-down list.

In the Trax Editor, select Create > Clip > 0.

The Create Clip Options window appears. See Animate > Create Clip.
Set the options.

Do one of the following:

e In the Create Clip Options window, click Create Clip.

Maya creates a clip for the selected character’s animation channels and
places it under the character in the track view area.

e Drag a clip from the Visor or Outliner to the character in the track view
area. See "To copy a source clip in the Visor and paste it to a character
in the Trax Editor” on page 191 or "To copy a clip in the Outliner and
paste it to a character in the Trax Editor” on page 189.

An instance of the clip you selected appears at the current time under the
character in the track view area.

e |n the Trax menu bar, select Library > Insert Clip > sourceClip.

An instance of the source clip you selected appears at the current time under
its character in the track view area.
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Create expression or constraint clips

To create an expression or constraint clip

1 Select an object or character that is constrained or is animated by an
expression from the scene view or from the Current Character Set drop-down
list.

2 In the Trax menu bar, select either Create > Constraint Clip or Create >
Expression Clip.

If the character has any constraint channels, then a constraint clip is created
for those channels.

If the character has any expression channels, then an expression clip is
created for those channels.

Related topics

7

« "Expression and Constraint clips” on page 183

R/

+» "Constraint Clip” on page 236

7

« "Expression Clip” on page 236

Create poses

To create a pose
1 Select the object or the character set you want to create a pose for from the
scene view or from the Current Character Set drop-down list.

2 Move the current time indicator to the frame in the Trax timeline or in the
Time Slider where the character pose you want to capture occurs.

3 Do one of the following:
e In the Trax Editor, select Create > Pose > .
¢ In the Maya main menu bar, select Animate > Create Pose > 0.
The Create Pose Options window appears. See Animate > Create Pose.
4 Enter a name for the pose in the Name box and click the Create Pose button.

Maya takes a snapshot of the character set’s position at the current time
and stores it as a pose in the Unused Poses tab of the Visor. You can also
access this pose from the Outliner. For information on how to copy a pose
from the Outliner or Visor to the Trax Editor, see the next procedure.

To copy a pose in the Outliner or Visor and paste it to a character in the Trax
Editor

You copy a pose from the Outliner or Visor to Trax the same way as you copy a
clip from the Outliner or Visor to Trax.
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For instructions on how to copy a pose from the Outliner or Visor to Trax, see "To
copy a source clip in the Visor and paste it to a character in the Trax Editor” on
page 191 and "To copy a clip in the Outliner and paste it to a character in the
Trax Editor” on page 189.

To move a character to a pose

1 In the Trax toolbar, click the Visor button.
The Visor appears. See Visor in the Basics guide.

2 Select the Character Poses tab.

All the poses present in the current scene appear.
3 Rightclick the desired pose.

A pop-up menu appears.
4 Select Apply Pose from the pop-up menu.

The character moves to the pose’s starting position without you having to
change the current scene time.

To return a character to its actual animation position from a pose

Play the animation or click a frame in the Trax timeline that is different from the
pose.

Related topics

R/

+ "Poses” on page 184

Cut, copy, and paste clips

You can cut or copy a clip in the Trax Editor, or you can copy a clip from the Visor
or Outliner to the Trax Editor. See "To copy a source clip in the Visor and paste it
to a character in the Trax Editor” on page 191 and "To copy a clip in the Outliner
and paste it to a character in the Trax Editor” on page 189.

After you cut or copy a clip, you can paste it to the same character set, or to a
different character set that has similar attributes.

Note Before you can copy and paste clips between characters, they must
first be mapped. See “Mapping animation between characters” in
the Character Setup and Deformers guide.

To copy a clip
In the Trax Editor, do one of the following:

e Select the clip you want to copy.
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e In the Trax menu bar, select Edit > Copy.

e Right-<click the clip you want to copy, and select Copy Clip from the menu that
appears.

A copy of the clip is placed in your system’s clipboard.

To cut a clip
In the Trax Editor, do one of the following:

e Select the clip you want to cut.
e |n the Trax menu bar, select Edit > Cut.

e Right-click the clip you want to cut, and select Cut Clip from the menu that
appears.

The clip is removed from its character and is placed in your system’s clipboard.

To paste a clip to the same character
Do one of the following:

e In the Trax Editor, highlight the character to which you want to paste the clip.
See "Highlight characters, groups, or subcharacters in Trax” on page 194.

e |n the Trax menu bar, select Edit > Paste.

e Right<click the track where you want to paste the clip, and select Paste Clip
from the menu that appears.

To paste a clip to a different character set

Note You should only copy and paste clips between characters if they
have been mapped. See “Mapping animation between characters”
in the Character Setup and Deformers guide.

1 In the Trax Editor, highlight the character to which you want to paste the clip.
See "Highlight characters, groups, or subcharacters in Trax” on page 194.

2 Do one of the following:

e Right-click the track where you want to paste the clip, and select Paste
Clip from the menu that appears.

e In the Trax menu bar, select Edit > Paste > .
The Paste Clip Options window appears. See "Paste” on page 230.

3 If the Paste Clip Options window is open, set the options and click the Paste
Clip button.
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To copy a clip from the Visor or Outliner and paste it in the Trax Editor

See "To copy a source clip in the Visor and paste it to a character in the Trax
Editor” on page 191 or "To copy a clip in the Outliner and paste it to a character
in the Trax Editor” on page 189.

To copy clips from your operating system’s file browser to your Maya scene

1 In your operating system’s file browser, navigate to the .ma or .mb file that
contains the clips you want to copy to your Maya scene.

2 Drag the file containing the clips from the operating system’s file browser to
the Maya scene view.

The clips in the file you dragged are copied to your current Maya scene file
and they appear in the Unused Clips tab of the Visor and in the Outliner.

You can now copy these clips from the Visor or Outliner to a character in the Trax
Editor. See the previous procedure.

Duplicate clips

You can duplicate a clip to create a dependent—also known as an instance—or
independent copy of the original source clip. If you create an independent
duplicate, you can modify the animation of the original source clip without
affecting the duplicate. If you create a dependent duplicate, then any
modifications you make to the animation of the original source clip propagates to
the dependent clip. The benefit of creating dependent clips is that you can
change all the dependent clips on multiple characters with just one edit to their
parent clip.

To duplicate a clip

1 In the Trax Editor, select the clip that you want to duplicate.
2 Do one of the following:
e In the Trax menu bar, select Edit > Duplicate > .

e Right-click the clip and select Duplicate Clip > O from the menu that
appears.

The Duplicate Clip Options window appears. See "Duplicate” on page 233.

3 Turn on Duplicate Input Curves to create an independent duplicate clip, or
turn off Duplicate Input curves to create a dependent duplicate clip.

4 Turn on Duplicate Time Warp Curve to create independent copies of the
selected clip’s time warp curves for the duplicate clip, or turn on Instance
Time Warp Curve to create dependent copies of the selected clip’s time warp
curves for the duplicate clip.

5 Set the rest of the Duplicate Clip options and click the Duplicate Clip button.

If you turned on Put Copy in Trax Editor and Visor, the duplicate clip appears
in a new track below the original clip’s track and in the Visor.



3 | Nonlinear Animation
How do I? > Edit a clip’s weighting

If you turned on Put Copy in Visor Only, then the duplicate clip is placed only
in the Visor.

Manipulate clips

Edit a clip’s weighting

To edit a clip’s weighting

1
2

In the Trax Editor, select the clip whose weighting you want to edit.
In the Maya main menu, select Display > Ul Elements > Channel Box.
The Channel Box appears, displaying the clips channels.

In the Channel Box, animate the clip’s Weight channel over time to increase
or decrease its influence in its character’s overall animation.

When you animate a clip’s Weight, a weight curve is created for the clip.
Do one of the following:

e |n the Trax toolbar, click Graph Weight Curves LQ button.

e In the Trax menu bar, select View > Graph Anim Curves.

The Graph Editor appears with all the selected clip’s animation curves framed

in its graph view.

e Select Weight in the Graph Editor’s outliner and press f to frame the
clip’s weight curve in the graph view.

e Right-click the clip and select Graph Weight from the menu that appears.

The Graph Editor appears with the selected clip’s weight curve framed in its

graph view.

Adjust the shape of the curve to alter the amount the clip’s animation
contributes to its character’s overall animation sequence by doing one of the
following;:

* Move the keys or the key’s tangents.

Select the Move Tool from the Maya toolbox, and middle-drag the keys or
their tangents to change the shape of the curve.

e Add keys to the weight curve.

Select the Insert Keys Tool or Add Keys Tool from the Graph Editor’s toolbar,
and middle-click the weight curve to insert additional keys that you can use to
change the shape of the curve.

To create a weight curve for a clip without manually keying the Weight
attribute

1

In the Trax Editor, select the clip for whom you want to create a weight curve.
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2 Right-click the clip and select Create Weight Curve from the menu that
appears.

A weight curve is created for the selected clip.

Move clips

To move a single clip

Drag clips to move them in the track view area.

{E}— The Move mouse pointer appears when you are moving a clip.

You can drag single clips upward and downward, or from side to side.

When you drag a clip upward or downward, and your mouse pointer is between
tracks, a black line appears indicating that a new track will be created between
the tracks to house the clip you are dragging. See "To add a track to a character,
group, or subcharacter” on page 220.

You can also move multiple clips at a time. See the following procedure.

Note When you move or scale clips in the Trax Editor, the edges of the
clips snap to the edges of neighboring clips. This is useful when
working with clips that begin or end with a value that is not a whole
number or if you are viewing many frames and require accuracy.

To move multiple clips in time

You can select multiple clips (Shift-click) in one or more characters and move
(from side to side) them all at once along the Trax timeline using the translate
handle of the clip manipulator.

10 30 40
‘ialking

M 30 40
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Trim clips

To trim a clip from the Trax Editor

Drag the top corner clip hotspots to trim clips.

See "Clip interaction controls” on page 243.

The Trim mouse pointer appears when you are trimming a clip.

You can omit segments from the beginning and end of an animation clip by
trimming it. This changes a clip’s Source In and Source Out times, but does not
affect the source clip itself. The segments that you omit from a clip using Trim
are not deleted, and can be reinstated if the clip’s original length is restored.

To trim the part of a clip that comes before the Trax current time indicator
1 Position the Trax current time indicator as desired.
2 Do one of the following:
e Right-click the clip and select Trim Before from the menu that appears.

e Select the clip you want to trim, and in the Trax menu bar select Edit >
Trim Before.

The part of the clip that comes before the Trax current time indicator is
removed from the clip. See "Trim Before” on page 250.

To trim the part of a clip that comes after the Trax current time indicator
1 Position the Trax current time indicator as desired.
2 Do one of the following:
e Right-click the clip and select Trim After from the menu that appears.

e Select the clip you want to trim, and in the Trax menu bar select Edit >
Trim After.

The part of the clip that comes after the Trax current time indicator is
removed from the clip. See "Trim After” on page 250.

To trim a clip from the Channel Box

1 In the Trax Editor, select the clip you want to trim.

2 In the Maya main menu, select Display > Ul Elements > Channel Box.
The Channel Box appears, displaying the selected clip’s channels.

3 In the Channel Box, set the Source Start and Source End channel values.
See "Source Start” on page 255 and "Source End” on page 256.
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Scale clips

To scale a clip from the Trax Editor

Drag the lower corner clip hotspots to scale clips.

See "Clip interaction controls” on page 243.

— The Scale mouse pointer appears when you are scaling a clip.

When you reduce (<100% of the original clip length) or scale down a clip, you are
actually compressing the animation on the clip, so that the resulting animation
appears faster or sped up.

When you scale (>100% original clip length) up a clip, you are actually extending
the animation on the clip, so that the resulting animation appears to be slower.

Note When you move or scale clips in the Trax Editor, the edges of the
clips snap to the edges of neighboring clips. This is useful when
working with clips that begin or end with a value that is not a whole
number or if you are viewing many frames and require accuracy.

To scale multiple clips at a time

You can select multiple clips (Shift-click) in one or more characters and scale
them all at once using the scale handles of the clip manipulator.

Scale handles

JoeCZh

N30 40

L=

Jogging
94

10 30 40

Runining

Clip manipulator

To scale a clip from the Channel Box

1 In the Trax Editor, select the clip you want to scale.

2 In the Maya main menu, select Display > Ul Elements > Channel Box.
The Channel Box appears, displaying the selected clip’s channels.

3 In the Channel Box, set the Scale channel value.
See "Scale” on page 255.
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Cycle clips

To create cycles for a clip from the Trax Editor

Shift-drag the lower corner clip hotspots of a clip to create cycles before (pre-
cycle) or after (post-cycle) clips.

See "Clip interaction controls” on page 243.

@H |l The Cycle mouse pointer appears when you are creating a cycle for a clip.

You can repeat an animation contained in a clip by extending the clip with
duplicate animation sequences called cycles. You can create whole or partial
cycles. The end of the original clip, and the beginning of the first cycle, is marked
by a small vertical line. The end of each cycle sequence for a clip is marked by a
small cycle tick or marker.

Cycles are represented by the letter C and appear a lighter blue than the rest of
the clip.

Cycle
|
10 30 40 I
ialking
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End of original clip/start of # of cycles Cycle marker

End frame for clip

To create cycles for a clip from the Channel Box

1 In the Trax Editor, select the clip you want to cycle.
2 In the Maya main menu, select Display > Ul Elements > Channel Box.
The Channel Box appears, displaying the selected clip’s channels.

3 In the Channel Box, set the Pre Cycle channel value to create a cycle before
the clip, and set the Post Cycle channel value to create a cycle after the clip.

See "Pre Cycle” on page 255 and "Post Cycle” on page 255.

To edit the number of cycles for a clip

1 Double-click the number beside the C on the cycled part of the clip.

2 Type a new number for how many times the clip is cycled before (Pre Cycle)
or after (Post Cycle) the main clip and press Enter.

For example, if the cycled part of the clip appears after the main clip and its
number of cycles is 2, then the animation in the main clip is repeated twice
after the main part of the clip.
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Hold clips

To create holds for clips from the Trax Editor
Shift-drag the upper corner clip hotspots to create holds after clips.

See "Clip interaction controls” on page 243.

The Hold mouse pointer appears when you are creating a hold for a clip.

A hold is a part or an extension of a clip where the last pose is held for a
specified period of time. Holds are represented by the letter H.

Hold
End of original clip/start of Hold ' |

10 30 40 @
Running
a0 100% 120 140
I

# of frames held

End frame for Hold

To create a hold for a clip from the Channel Box

1 In the Trax Editor, select the clip you want to scale.

2 In the Maya main menu, select Display > Ul Elements > Channel Box.
The Channel Box appears, displaying the selected clip’s channels.

3 In the Channel Box, set the Hold channel value to create a hold after the clip.
See "Hold” on page 255.

Split clips
You can split a clip to divide a character’s animation into multiple, reusable clips.

For example, suppose you have the following animations in the same clip: a
karate punch, a swinging leg kick, and a tumble. You can split the clip into the
three moves, and then rearrange their order to form a different animation
sequence.

Note You can not split a cycled clip. You need to first merge the cycled
clip before you can split it. See "Merge clips” on page 207.

To split a clip
1 In the Trax Editor, select the clip that you want to split.
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2 Drag the Trax current time indicator to the position on the clip where you want
it to be split.
3 Do one of the following:
e Right-click the clip and select Split Clip > O form the menu that appears.
See "Context-sensitive menu” on page 249.
* In the Trax menu bar, Select Edit > Split > 0.
The Split Clip Options window appears.
4 Set the options and click Split Clip.
The clip is split at the current time indicator’s current frame, and two clips
appear replacing the selected clip.
Tip Renaming these clips will help you remember their original order.
Merge clips

You can merge two or more clips into a single clip. The clips to be merged can be
positioned sequentially in a track or can be located on different tracks.

The benefits of merging clips are as follows:

There are fewer clips to manage

If you merge a pair of blended clips, the resulting source clip has keys for the
blended animation. You can activate the merged clip and edit its animation in
the Graph Editor.

You can merge a single clip into a new clip. This is useful for creating an
absolute clip from a relative clip, or for splitting a cycled clip. See "Split
clips” on page 206.

Note If you don’t want to merge clips, you can still manage multiple clips

at a time by grouping them. See "Create groups” on page 221.

To merge clips

1

In the Trax Editor, select the clips that you want to merge.

You can select multiple clips from the same or different tracks.
Select Edit > Merge > 0.

The Merge Clip Options window appears. See "Merge” on page 232.
Set the options and click the Merge Clip button.

The selected clips merge into a single clip.
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Note When clips merge, any gaps or overlapping between the animation
clips are interpolated or blended.

Enable or disable clips

You can disable a clip to stop it from playing during the playback of its
character’s animation in Trax. If you later decide you want the clip to play again,
you can then enable the clip.

Note A useful animation technique is to create many clips for a
combination of motions, and then control which clips apply in a
situation by disabling and enabling the clips to help analyze the
motion.

To disable or enable clips

1 In the Trax Editor, select the clip you want to disable or enable.
2 Do one of the following:

e Right-click the clip and select Enable Clip from the menu that appears.
See "Enable Clip” on page 250.

e In the Trax menu bar, select Modify > Enable/Disable.

When a clip is enabled, a appears beside the Enable Clip option in the
Trax context-sensitive menu for the clip. When a clip is disabled, the clip
appears dark blue.

Related topics
« See "Enabled/disabled clips” on page 247.

Activate or deactivate clips

You can activate a clip to edit the keys it contains from the Time Slider. Also,
when a clip is active, all the keys you set for the channels in the active clip are
automatically placed in that clip. See "Active/inactive clips” on page 247 and
"Key into a clip” on page 217.

When a clip is active (Activate Keys in on), Maya ignores clip settings such as
Weight, Offset, and so on.

If you set new keys on the clip that extend past the end of the active clip’s
duration, the keys play while the clip is activated, but won’t be included in the
deactivated clip unless you adjust its Source In/Source Out channel values or
modify the source clip’s duration in the Channel Box. See "To edit a clip’s keys in
the Time Slider” on page 218.
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To activate or deactivate a clip

1 In the Trax Editor, select the clip you want to activate or deactivate.
2 Do one of the following:

e Rightclick the clip and select Activate Keys from the menu that appears.
See "Activate Keys” on page 250.

e In the Trax menu bar, select Modify > Activate/Deactivate Keys.
When a clip is active, a appears beside the Activate Keys option in the

Trax context-sensitive menu for the clip. When a clip is disabled, the clip
appears purple.

Offset clip channels

You can offset the channels within an animation clip to change how Maya
interprets channel values within that clip. Clip channels can have an absolute or
relative offset. You can set a clip’s channel offsets with the Channel Offsets
controls. See "Channel Offsets” on page 256.

Note If two clips overlap in a pair of tracks for the same character set,
Maya adds the values of any redundant attributes, regardless of
whether you use Absolute or Relative. This compounding effect is
typically undesirable unless you blend the clips. See "To blend
animation clips” on page 212.

Absolute channels

Absolute channels do not accumulate motion. This means that when the offset of
a clip channel is absolute, then that channel does not add the motion of the
equivalent channel in the previous clip to its own animation. This is useful when
you want to create a sequence of cycled animation.

For example, if you want to create a walk cycle, the cycle should have relative
translation channels (so that your character doesn’t jump back to its initial
position at the end of each cycle) and absolute rotation channels.

Relative channels

Relative channels accumulate motion. This means that when the offset of a clip
channel is relative, then that channel adds the motion on the equivalent channel
in the previous clip to its own animation.

For example, suppose you've created two clips that play sequentially in the
Timeline. The first clip is a character walking away from the origin along the
X-axis, the second clip is the character running away from the origin along the X-
axis.

If the clip’s translation channels are relative, the character walks away from the
origin and then starts running from the position where the walking clip ends and
the running clip begins. If the clip’s translation channels are absolute, then
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character walks away from the origin andwhen the walking clip ends and the
running clip begins, the character moves instantly to the origin and starts running
from that position.

To offset a clip’s animation channels

1 Select the clip whose channels you want to offset.
2 Open the Attribute Editor.
3 Select the clip’s tab (animClip node).
4 Expand the Channel Offsets section.
See "Channel Offsets” on page 256.
5 Do the following:

e Turn on the Absolute settings for channels that you want to offset as
absolute.

e Turn on the Relative settings for channels that you want to offset as
relative.

e Click All Absolute to set the offsets of all the channels in the current clip
to absolute.

e C(Click All Relative to set the offsets of all the channels in the current clip
to relative.

¢ Click Restore Defaults to set the offsets of all the channels in the current
clip back to their original settings.

To copy the channel offset settings from one clip to another clip

1 Select the clip that has the channel offset settings you want to copy. This clip
is the source clip.

2 Shift+click the clip to which you want to apply the source clip’s channel offset
settings. This clip is the destination clip.

Note e The source and destination clips must belong to the same
character.

e The source and destination clips must have common channels.

e You cannot copy clip channel offset settings from one source
clip to multiple destination clips.

3 In the Trax menu bar, select Edit > Copy Channel Offsets.

The destination clip now has the same channel offset settings as the source
clip.
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Create and edit blends

You can create a blend between two animation clips that share common
attributes and are part of the same character set. A blend creates a smooth
transition from the motion of one clip to another.

When blending animation clips, you will get the best results if you blend clips that
have similar motion. For example, creating a blend between a Walk animation clip
and a Run animation clip. In comparison, blending dissimilar motion may not
produce desirable results. For example, creating a blend between a Run
animation clip and a Tumble animation clip may create an awkward transition.

You can create the following types of blends:

Blend between overlapping clips on different tracks

e For blends between overlapping clips, Maya blends only the animation in the
overlapping clip regions.

Blend between non-overlapping clips on the same track

Blend between non-overlapping clips on different tracks

e For blends between non-overlapping clips, Maya interpolates the animation in
the space between the clips from the last frame of the first clip to the first
frame of the second clip.

After creating a blend, you can edit its blend curve and weight value. The Weight
attribute on the blend determines the amount of influence each clip has during
the blend. For example, when a blend’s weight is 0.0, the first clip in the blend
has all of the influence and when a blend’s weight is 1.0, the second clip in the
blend has all the influence.

Note When you blend two overlapping clips that start at the same time in
the Trax timeline, Maya uses the first clip you select for the blend
operation as the initial 200% controlling clip.
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To blend animation clips

1 Select the clips you want to blend.

The clips must have one or more common attributes or the blend operation
will fail.

2 Do one of the following:

]
e |n the Trax toolbar, click the Create Blend | “E| button.

e In the Trax menu bar, select Create > Blend > 0.
The Blend Clip Options window appears. See "Blend” on page 236.

3 If the Blend Clip Options window is open, set the options and click Create
Blend.

The blend is created, and a green arrow representing the blend appears
between the selected clips.

For overlapping clips, make adjustments to the clip positions in the track view
area so that the animation transitions smoothly from one clip to the other.

Warning If you move the first clip in a blend to a position where it plays later
than the second clip, you will get an undesirable blend as the
result. The blend operation is intended for blending a clip that plays
first with the clip that plays second.

To select a blend region

Select the blend’s green arrow.

Selected
blends

To delete a blend

1 Select the blend that you want to remove. See the above procedure.
2 Press Delete.
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To edit a blend’s values

1 Select the blend that you want to edit. See "To select a blend region” on
page 212.

2 In the Maya main menu, select Window > Attribute Editor or press Ctrl+a.
The Attribute Editor appears, displaying the attributes of the selected blend.

3 Set the blend’s Weight attribute and select a rotation interpolation type from
the Rotation Blend drop-down list.

See "Rotation Blend” on page 236.

To edit a blend’s weighting

1 Select the blend whose curve you want to open in the Graph Editor.
See "To select a blend region” on page 212.
2 Do one of the following:

e In the Trax toolbar, click Graph Anim Curves EE button.
e In the Trax menu bar, select View > Graph Anim Curves.

The Graph Editor appears with the weight curve for the selected animation
blend present and framed in its graph view.

oI
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Blend’s weight curve

By default, the blend’s weight curve has a range from O-1 and is linear. See
"Blend” on page 236.

At the first frame where clips overlap, the top clip controls the motion 100%
and the bottom clip controls the motion 0%. At the last frame where clips
overlap, the bottom clip controls the motion 100% while the top clip controls
the motion 0%.

During playback, the control of the first clip in a blend decreases as the
second clip’s control increases.

Animation
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3 Before you can add keys to the blend weight curve, you must first turn off

Time snap and Value snap in the Graph Editor’s toolbar.

Otherwise, Maya will not allow keys on the blend weight curve to have floating
point values.

Adjust the shape of the curve to alter the percentage of control each clip has
during the blend by doing one of the following:

* Move the keys or the key’s tangents.

Select the weight curve’s keys or tangents, select the Move Tool from the
Maya toolbox, and middle-drag the keys or their tangents to change the
shape of the curve. For example, you can reshape the default blend weight
curve to make it resemble the following:

With this curve, the first clip in the blend starts with 100% control at the start
of the blend, decreases to 0% at the middle, then increases to 100% control
at the end of the blend. The bottom clip changes correspondingly from 0% to
100% to 0% control during the blend.

e Add keys to the blend curve.

Select the Insert Keys Tool or Add Keys Tool from the Graph Editor’s toolbar,
and middle-click the curve to add additional keys to the curve. You can then
use these new keys to alter the shape of the weight curve.

e |f you want to change the weight curve’s type, delete the blend and add a
new blend of the desired type. See "To delete a blend” on page 212.

e |f the blend doesn’t provide the exact transition you want, add motion
warping to fine tune the transition. See "Key on top of clips” on
page 216.

Create and edit time warps

You can change the timing of a clip without modifying the clip’s animation curves
using time warps. Typically, you use time warps to reverse the animation in a clip,
or to ease in or ease out of a clip’s animation.

You can create time warps automatically when you create or duplicate a clip, or
you can select an existing clip and create a time warp for it. See "Animate >
Create Clip” on page 251. By default, time warps are not created when a clip is
created.

Animation
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When you create a time warp for a clip, a time warp curve is added above the clip
in its hierarchy and a green bar appears on the clip. See "Time warps” on

page 248. You can manipulate this time warp curve to adjust how the time warp
affects the animation in its clip.

Note

Multiple time warps can slow performance, so you should use them

sparingly.

To create a time warp for a clip

1 Select the clip for which you want to create a time warp.
2 Do one of the following:

e In the Trax menu bar, select Create > Time Warp.

e Right-click the clip, and select Create Time Warp from the menu that
appears.

1
1
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The Time Warp Enable attribute is turned on for the clip node, and a new
time warp curve appears in the clip. By default, the time warp curve extends
from O to 100 and represents a percentage of its animation clip. The time of
0 is the start of the clip and the time of 100 is the end of the clip.

In the track view area, a green bar appears on the clip to indicate that the

clip is now affected by a time warp.

To edit a time warp

1 Select the clip that has the time warp.

2 In the Trax toolbar, click the Graph Anim Curves

All

button or press f to frame the time warp curve.

bl

button.
3 In the Graph Editor outliner, select the time warp curve and click the Frame

4 In the graph view, use the Insert Keys Tool to insert keys and use the Move
Tool to adjust the curve.

When working in the graph view with these tools, use the middle mouse

button

To create a time warp when creating a clip

1 Select the character whose animation you want to put in a clip.

2 In the Trax menu bar, select Animate > Create Clip > 0.
The Create Clip Options window appears.

Animation
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3 Turn on Create Time Warp Curve.

A clip appears containing its character’s animation curves and an active time
warp curve. Now every time you create a clip, an active time warp curve is
created for each clip.

To enable or disable a time warp curve

1 Select the clip that has the time warp curve you want to enable or disable.

2 In the Attribute Editor or Channel Box, set the Time Warp Enable attribute to
on or off.

To turn off automatic time warps on clip creation

1 In the Trax menu bar, select Animate > Create Clip > 0.
The Create Clip Options window appears.
2 Turn off Create Time Warp Curve.

Key on top of clips

You can set keys on a character set that already has an animation clip to affect
the character set relative to the existing clip animation. This lets you layer
keyframe animation on top of your nonlinear (clip) animation. The technique of
applying keyframe animation on top of existing clip animation is nondestructive.

Placing keys on top of clips is useful in the following situations:

e You want to add new motion to your character.

e You're satisfied with an existing clip but want to make subtle changes
without destroying your work.

e You've created animation clip instances for various characters (for example,
a street gang walking down an alley), but want to apply a unique walking
motion to each character.

e You've created dense key data for a character (for example, with motion
capture), and you want to adjust the motion without altering the keys.

To add additional keys to a character on top of its clip animation

1 Select the character you want to key.

2 Set keys—without changing any attribute values—at the start and end of the
clip region you want to modify.

These bounding keys delimit the start and end of the region where you will
add keys to your character.

3 Set keys within the delimited region.
These keys create add to your character’s overall animation.

4 Play the animation to make sure that the keys you added have the desired
effect.
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5 When you're satisfied with the keys you added, create a clip for them. See
"To create a clip for a character” on page 196.

6 Modify the clip’s Weight attribute and curve to fine tune its motion. See "To
edit a clip’s weighting” on page 201.
Layering keys on top of clips may have undesirable results if you create them
over top relative clips, including cycled clips. If you want to create keys over a
relative or cycled clip, make the clip absolute by merging it. See "To merge
clips” on page 207.

Example

Suppose you have a clip of a soldier marching and you like the general motion,
but you want to raise the soldier’s foot higher during the march. First, set
bounding keys at both frames where the foot is on the ground, without changing
any attribute values. Then, where the foot is raised, move it a little higher and set
a key at this position. Create a clip for the keys and try different Weight values to
tune the animation.

Key into a clip

You can set keys on a character set that already has animation clips so that the
keys are automatically placed on the curves in its current, active clip. The
technique of inserting keyframes into an existing animation clip is destructive.

Tip If you need to place many keys in a clip at a time, key into the clip
from outside of the Trax Editor.

Key into a clip from the Trax Editor

1 Select the clip in which you want to place keys.

2 In the scene view, select and transform the objects whose animation curves
are in the clip you selected in Trax.

3 In the Trax toolbar, click the Key into Clip Ll_liill button.

Keys are placed at the current time on all the pertinent animation curves in the
selected clip. If you key into a clip (original) that has duplicates (dependent
copies), those keys are also inserted into the duplicate clips.

Key into a clip from outside of the Trax Editor

1 Select the clip in which you want to place keys.

2 Rightclick the clip, and select Activate Keys from the menu that appears. See
"Activate Keys” on page 250.

The clip turns purple to indicate that now when you set keys for the objects
whose animation curves are in the clip, all those keys are automatically
placed in the clip.
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3 In the scene view, transform and key the objects whose animation curves are
in the clip you selected in Trax.

All keys automatically appear on the animation curves in the selected clip in
the Trax Editor.

Edit clip attributes

To edit clip attributes

1 In the Trax Editor, select the clip you want to edit.

2 In the Maya main menu, select Display > Ul Elements > Channel Box.
The Channel Box appears, displaying the selected clip’s attributes.

3 Modify the clip’s attribute values as desired.
See "animClip” on page 254.

Edit a clip’s animation curves

To view and edit the animation curves of a clip

1 Select the clip you want to edit.
2 Do one of the following;:

e In the Trax toolbar, click the Graph Anim Curves & button.

e In the Trax menu bar, select View > Graph Anim Curves.

The Graph Editor appears, displaying the animation curves contained in the
selected clip.

To edit a clip’s keys in the Time Slider

1 Select the clip you want to edit.
2 Do one of the following:
e In the Trax menu bar, select Modify > Activate/Deactivate Keys.

e |n the track view area, right-click the clip and select Activate Keys from
the menu that appears.

The keys in the selected clip appear in the Time Slider and are now available
for editing.

Select and edit source clips

Select source clips

Do one of the following:

Animation
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e |n the Visor, select the source clip’s icon.

e |n the Outliner, turn off Display > DAG Objects Only and turn on Show >
Objects > Clips.

e Select the source clip’s name.

e In the Trax Editor, right-click an instance of the source clip you want to select,
and select Select Source Clip from the menu that appears.

¢ |In the Maya dependency graph (DG), select the clipnameSource node for the
source clip you want to select. See Dependency graph in the Basics guide.

Copy source clips to a character

To create instances of a source clip in the Trax Editor
Do one of the following:

e In the Outliner, select a source clip and middle-drag it to a character in Trax.
See "To copy a clip in the Outliner and paste it to a character in the Trax
Editor” on page 189

e In the Visor, select a source clip and middle-drag it to a character in Trax.
See "To copy a source clip in the Visor and paste it to a character in the Trax
Editor” on page 191.

e In the Trax Editor, highlight a character and from the Trax menu bar select
Library > Insert Clip > sourceClip.

An instance of the source clip you selected appears at the current time under its
character in the track view area.

Note Before you can copy and paste clips between characters, the
characters must first be mapped. See “Mapping animation between
characters” in the Character Setup and Deformers guide.

Edit source clips

To edit source clip attributes

1 Select the source clip whose attributes you want to edit.
See "Select source clips” on page 218.

2 Open the Channel Box.
The source clip and its attributes display in the Channel Box.

3 Modify the values of the source clip attributes as you desire.
See "animClip” on page 254.
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To view and edit the animation curves of a source clip

1 Do one of the following:

e In the Visor, click the Character Clips or Unused Clips tab and then
select the source clip you want to edit.

e |n the Outliner, view the clips in your scene and then select the source
clip you want to edit. See "To view clips in the Outliner” on page 189.

2 In the Maya main menu, select Window > Animation Editors > Graph Editor.

The Graph Editor appears, displaying the animation keys and curves
contained in the selected source clip.

Select, create, and remove tracks

Select tracks

To select a track

Select a clip in the track you want to select.

Add tracks

To add a track to a character, group, or subcharacter

1 Select a clip in your character, subcharacter, or group.
2 Do one of the following:
e Drag the clip upwards or downwards.

A black line appears above or below the selected clip’s track. This line
indicates that Maya will insert a single track above or below the selected
clip’s track when you release the mouse button.

D e
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Black line indicates where Maya will insert the track

e Rightclick a track, and select one of the following options from the menu
that appears: Insert Track Above or Insert Track Below.

These options insert a track above or below the selected clip’s track. See
"Context-sensitive menu” on page 249.
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Remove tracks

To remove a track from a character, group, or subcharacter

e Right<click the track you want to remove, and select Remove Track from the
menu that appears.

The track you clicked on and all its clips are deleted from its character,
group, or subcharacter.

To remove all the empty tracks from a character

1 Highlight the character from which you want to remove all its empty tracks
2 In the Trax menu bar, select Modify > Remove Empty Tracks.

All the empty tracks are deleted from the highlighted character.

To remove all the empty tracks from all the characters in Trax

1 Make sure that there are no characters highlighted in Trax.
2 In the Trax Editor, select Modify > Remove Empty Tracks.

All the empty tracks are deleted from all the characters in Trax.

Group and ungroup clips

Create groups

To create a group of clips

1 Select the clips you want to group by Shift-clicking them or by dragging around
them.

2 Do one of the following:

e In the Trax toolbar, click the Group button.

e In the Trax menu bar, select Edit > Group.

e Right-click one of the clips you selected, and select Group from the menu
that appears.

A new group containing the clips you selected appears under their respective
character.

Warning A character or subcharacter can have multiple groups, but you can
not have groups within groups.

Animation
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Rename groups

To change the name of a group in the Trax Editor

1 Double-click the group name you want to change.
2 Type in a new name for the group and then press Enter.

Ungroup clips

To ungroup a group of clips

1 Select one of the clips that is part the group you want to ungroup.
2 Do one of the following:

-

e |n the Trax toolbar, click the Ungroup | =| button.

e In the Trax menu bar, select Edit > Ungroup.
e Right-<click the clip, and select Ungroup from the menu that appears.

The clip’s group is removed from its character or subcharacter and all the group’s
tracks and clips are placed directly under its character or parent group.

Work with subcharacter sets in Trax

Create a source clip for subcharacter set curves

To create a source clip that contains only the animation curves for a single
subcharacter set

1 Select the subcharacter set you want to create the clip for from the Current
Character Set drop-down list.

2 In the Trax menu bar, select Create > Clip.

A clip appears under the subcharacter in Trax containing all the animation
curves for the selected subcharacter.

A source clip can be used by only one subcharacter set. You can’t create
instances from the same source clip to multiple subcharacter sets.

To animate several subcharacter sets simultaneously

Copy and paste clips from one subcharacter set to another.

Note Before you can copy and paste clips between characters, the
characters must first be mapped. See “Mapping animation between
characters” in the Character Setup and Deformers guide.




3 | Nonlinear Animation
How do I? > Rename subcharacter sets in the Trax Editor

Rename subcharacter sets in the Trax Editor

To change the name of a subcharacter in the Trax Editor

1 Double-click the name of the subcharacter you want to change.
2 Type in a new name for the subcharacter and then press Enter.

Import or export animation data

Import or export animation data

Tip You can import single or multiple clips into your scene or character
from your system’s disk by dragging them from an operating system
file browser to the Maya scene view or to a character in the Trax
Editor. See "To copy clips from your operating system’s file browser
to your Maya scene” on page 200.

Warning Before importing animation data, always check your current Maya
Playback preferences. Playback preferences can affect the import of
animation data. See “Timeline preferences” in the Preferences and
Customization chapter of the Basics guide.

To import a clip or pose to a scene

1 In the Trax menu bar, select File > Import Clip.
The Import file browser window appears.

2 In the file browser window, select the file that contains the clip(s) or pose(s)
you want to import.

Note You can only import clip or pose files that have valid (.ma, .mb, or
.mov) file extensions.

3 Click Import.

If you import a clip, it appears in the Visor under Unused Clips. If you import
a pose, it appears in the Visor under Unused Poses.

4 Do one of the following:

e Middle-click the clip or pose in the Visor and drag it to a character in the
track view area.

Animation
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e Select the clip or pose in the Visor and then copy and paste it to a
character set in the Trax Editor. See "Cut, copy, and paste clips” on
page 198.

To import clips or poses to a character

1

Do one of the following:
e Select the character in the Maya scene view.

e Make the character current by selecting it from the Current Character Set
drop-down list.

e |n the track view area, highlight the desired character. See "Highlight
characters, groups, or subcharacters in Trax” on page 194.

In the Trax menu bar, select File > Import Clip to Character.
The Import file browser window appears.

In the file browser window, select the file that contains the clip(s) or pose(s)
you want to import.

Click Import.

By default, the clip is placed in the Visor and directly under the selected
character in the Trax Editor.

To import clips or poses to a character without placing it in Trax

1

Do one of the following:
e Select the character in the Maya scene view.

e Make the character current by selecting it from the Current Character Set
drop-down list.

e In the track view area, highlight the desired character. See "Highlight
characters, groups, or subcharacters in Trax” on page 194.

In the Trax menu bar, select File > Import Clip to Character > .
The Import Clip To Character Option window appears.

Turn on Put Clip in Visor Only.

Click Import Clip.

In the file browser window, select the file that contains the clip(s) or pose(s)
you want to import.

Click Import.

If you import a clip, it appears in the Visor under Character Clips. If you
import a pose, it appears in the Visor under Character Poses.

You can now middle-drag the imported clips or poses in the Visor or Outliner
and drag them to the character in Trax. See "Use the Visor with Trax” on
page 191 or "Use the Outliner with Trax” on page 189.

To export clips or poses from your current scene

1

Select the clips or poses you want to export.
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2 In the Trax menu bar, select File > Export Clip.
The Export file browser window appears.

3 In the Export file browser window, enter the file name for the clips or poses,
select a file type (mayaAscii, mayaBinary, move), and click Export.

Note When exporting clips or poses, you must assign them valid (.ma,

.mb, or .mov) file extensions. Otherwise, you will not be able to
import the clips or poses into a Maya scene.

The clips or poses are exported and saved under the name your entered and
as the specified file type.

To export clips or poses from the Visor

1

In the Visor, open the section where the clip you want to export is stored by
clicking the appropriate tab (Character Clips, Character Poses, Unused Clips,
or Unused Poses).

Right-click the clip or pose you want to export, and select Export from the
menu that appears.

In the Export file browser window, enter a file name for the clips or poses,
select a file type (mayaAscii, mayaBinary, move), click Export again.

The clip is exported and saved under the name your entered and as the
specified file type.

Work with audio

Work with audio

To create an audio clip

Do one of the following:

In the Trax Editor, select File > Import Audio.

The Import File browser appears.

e Browse for the .wav or .aiff file you want to place in Trax.

e Select the desired audio file and click Import.

The selected audio file appears as an audio clip under the Soundtrack.

Import (Maya main menu > File > Import) or drag the desired audio file from
your desktop to the Time Slider.

The audio file automatically appears as a waveform in the Time Slider and as
an audio clip under the Soundtrack in Trax.

See "Soundtrack” on page 242.
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To hear audio clips present in Trax

Right-click in the Time Slider, and select Sounds > Use Trax Sounds from the
menu that appears.

The audio clips in the Trax Editor now play during animation playback. Also, only
one audio clip at a time plays and the play priority of audio clips goes from the
top-most clip to the bottom-most clip. See "Audio clips” on page 184.

Note When Use Trax Sounds is on, green horizontal lines appear in the
Time Slider indicating the order and duration of the audio clips in
Trax.

To remove audio clips from the Soundtrack

Select the audio clip you want to remove and press Delete.

Windows and Editors

Trax Editor

Trax Editor

The Trax Editor is Maya’s premiere nonlinear animation tool. With the Trax Editor,
you can manipulate and arrange your animation sequences from a higher level
than from the Graph Editor or Dope Sheet. See "What is the Trax Editor?” on
page 177.
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Trax timeline

The Trax Editor window has four work areas:

Trax menu bar

Contains character and clip related options that let you perform all required
actions for creating and editing your animation nonlinearly. See "Trax menu
bar” on page 227.

Trax toolbar

Contains a selection of buttons that let you quickly access some of the
functionality contained in the Trax menu bar. See "Trax toolbar” on page 238.

Track control area

Contains buttons that let you control the playback of each track’s animation.
See "Track control area” on page 239.

Track view area

Contains all the tracks, animation clips, and audio clips for your loaded
characters. See "Track view area” on page 240.

Trax menu bar

File >

Import Clip

Opens the Import file browser. This window lets you browse for clip files to
import. Import Clip imports the selected clip to the current, highlighted character.
You can import clips that have one of the following file formats:

mayaAscii (.ma)
mayaBinary (.mb)

Animation
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e mel (mel)

e OBJ (.0bj)

e audio (.wav, .aif, .aiff)

* move (.mov)

e EPS (.eps)

e Adobe® lllustrator® (.ai)

Import Clip to Characters

Opens the Import file browser. This window lets you browse for the clip files you
want to import to your loaded characters. Import Clip to Character imports the
selected clip to all the loaded characters in Trax. You can import clips that have
one of the following file formats:

e mayaAscii (.ma)

e mayaBinary (.mb)

e mel (mel)

e OBJ (.0bj)

e audio (.wav, .aif, .aiff)
* move (.mov)

e EPS (.eps)
e Adobe® lllustrator® (.ai)
Clip
Put Clip in Visor
Only Adds the clip you are importing to the Visor.

Put Clip in Trax
Editor and Visor Adds the clip you are importing to the Trax Editor and
Visor.

Note When you put a clip in the Visor, you can then access it from the
Outliner. See "To view clips in the Outliner” on page 189.

Import Audio

Opens the Import file browser. This window lets you browse for audio files to
import to your Soundtrack for the current scene. You can import audio files that
have the following file formats:

e WAV (.wav)
e Audio Interchange File Format (.aif, .aiff)

For information on the Import Options window, see File > Import in the Basics
guide.
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Export Clip

Opens the Export file browser. This window lets you browse for the location to
which you want to export your clip. You can export your clips as the following file
types:

e mayaAscii (.ma)
e mayaBinary (.mb)
* mov (.mov)

Character Mapper

Opens the new Character Mapper window. See Character > Character Mapper.

Export Character Map

Opens the Write file browser. This window lets you browse for the character set to
which you want to export your character map. You can export character maps as
the following file types:

e maya Ascii (.ma)
e mayaBinary (.mb)
e move (.mov)

e mel (.mel)

Map Method

Sets the format of the character map you want to export. The Map Method

option you choose depends on which map you expect will be the easiest to
edit. Before you select a Map Method, you first need to know the attributes
(and their order) of both character sets.

By Attribute

Name Creates a map where the current character set’s attribute
values are mapped to the attribute names of the target
character set.

By Attribute

Order Creates a map where the current character set’s attribute

values are mapped to the target character set based on the
order (descending) of attributes in the Channel Box.

By Node Name Creates a map where the current character set’s attribute
values are mapped to the corresponding object and attribute
names of the target character set.

By Current Map Creates a map using the current mapping for the selected
character sets. This is useful if you have already exported a
map to fix character mapping, then later need to add new
attributes to the character set. If you use By Current Map,
you will only be able to edit the attribute mappings you
have added since the last time you corrected the mapping.
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This option works only if you have already exported a
character map and executed the resulting MEL script. See
“Mapping animation between characters” in the
Character Setup guide.

Visor

Opens the Visor window. See "What are the Visor, Outliner, and Clip Library?” on
page 179.

Edit >
Undo

Deletes your last action in the Trax Editor.

Redo

Repeats the last action you previously deleted in the Trax Editor.

Cut

Removes the selected clip from the Trax Editor and stores it in your system’s
virtual clipboard. See "Cut, copy, and paste clips” on page 198.

Copy

Copies the selected clip in the Trax Editor and stores the copy in your system’s
virtual clipboard.

Paste

Pastes the copied or cut clip from your system’s virtual clipboard to the
highlighted Character in the Trax Editor.

Paste Method

Select a Paste Method if you want to paste the copied or cut animation clip
to a different character.

Note You should only copy and paste clips between characters if they
have been mapped. See “Map one character to another” in the
Character Setup and Deformers guide.

By Attribute
Name Pastes attribute values to the matching attribute names
of the target character set. Object names are ignored.

Animation
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Pastes attribute values to the target character set based
on the descending order of attributes in the Channel
Box.

Pastes attribute values to the matching object and
attribute names of the target character set.

Select this option only if you plan on exporting the target
character’s character map. See "Import or export
animation data” on page 223.

Specifies where the copied clip will be pasted.

Current Time

Timeline Start

Clipboard Start

Split

When on, the copied clip will be pasted in the source
clip’s track at the position of the Trax current time
indicator. For example, if the Trax current time indicator
is at frame 40, then when you paste the clip it will
appear at frame 40.

If a clip already occupies the time specified by the
current time indicator, then a new track is created and
the copied clip is inserted there.

When on, the copied clip will be pasted at the current
scene’s Playback Start Time. For example, if the current
scene’s Playback Start Time is frame 10, then the
copied clip will be pasted at frame 10.

When on, the copied clip will be pasted in a new track at
the start frame of its source clip. For example, if you
copied a clip whose start frame is frame 15, then a new
track would be created and the copied clip would be
inserted in that track at frame 15.

Splits the selected clip into two separate clips. See "Split clips” on page 206.

By default, the first new clip that is generated is named Start and the second new
clip is named End. Also, the two new source clips are named clipnStartSource

and clipnEndSource.

Source Clip

Specifies the status of the selected clip’s source clip after it is split.

Delete Original
Source

When on, the selected clip’s source clip will be deleted
from the Visor. Use this option if you know you have no
further use for the source clip.
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Keep Original
Source When on, the selected clip’s source clip will be retained
in the Visor. Use this option if you know you will need to
use the source clip sometime in the future.
Split Time

Sets where to split the clip.

Current Time  When on, the selected clip will be split at the position of the
Trax current time indicator.

Specify Time  When on, the selected clip will be split at the time you
specify in the Split Time field.

Note You cannot split a cycled clip. You need to first merge the clip (with
no other clips) before you can split the clip. See "Merge clips” on
page 207.

Split Time

Lets you specify a custom time at which the clip will be split. This field is only
available when Specify Time in on.

Merge

Merges the selected clips. See "Merge clips” on page 207.

Clips can be merged within a track, or clips from separate tracks can be merged.
The clip that begins first becomes the first section of the merged clip. When clips
that overlap in time are merged, their animation is blended automatically.

Name
Lets you enter a name for the merged clip.
Merged Clip

Add to Trax Merges the clips selected in the track view
area. You can only merge clips from the
same character.

Add to Visor Only

(Keep Originals

in Trax) Merges the clips selected in the track view
area, stores this merged clip in the Visor,
and retains the selected clips in Trax.

Trim Before

Removes the segment of the selected clip that comes before the Trax current
time indicator’s position.
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Trim After

Removes the segment of the selected clip that comes after the Trax current
time indicator’s position.

Duplicate

When you duplicate a clip, a new track is generated and the copy of the clip
is added to this track.

Duplicate Input Connections

When on, creates a copy of the selected clip whose duplicate animation is
independent of the original clip’s source animation. This means you can edit
the animation on this new clip and it won’t affect the animation on your
original clip—it will only affect the duplicate.

When off, creates a copy of the selected clip whose duplicate animation is
dependent on the original clip’s source animation. This means any
modifications made to the original clip’s animation are propagated to the
duplicate clip.

Duplicate Input Connections is off by default.
Copy

Put Copy in Visor
Only Places the duplicate clip in the Visor only.

Put Copy in Visor Only is available only when Duplicate
Input Connections is on.

Note When you place clips in the Visor, you can then view and access
them from the Outliner. See "To view clips in the Outliner” on
page 189.

Put Copy in Trax
Editor and Visor Places the duplicate clip in both the Trax Editor and the
Visor.

Put Copy in Trax Editor and Visor is available only when
Duplicate Input Connections is on.

Time Warp

Duplicate Time

Warp Curve When on, an independent copy of the selected clip’s
time warp curve is created for the duplicate clip. This is
useful, for example, when you want a group of characters
to all have the same run cycle animations, but you want
each of the characters to run at a different speeds.
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Instance Time

Warp Curve When on, a dependent copy of the selected clip’s time
warp curve is created for the duplicate clip. Any changes
you make to the original clip’s time warp curve are
propagated to the duplicate time warp curve.

Instance Time Warp Curve is on by default.

No Time Warp
Curve When on, the selected clip’s time warp curve is not
copied to the duplicate clip.

Copy Channel Offsets

Lets you apply the current channel offset settings from one clip to another. This
is useful when you want multiple clips to have the same offset settings.

Note e The source and destination clips must belong to the same
character.

e The source and destination clips must have common channels.

e You cannot copy clip channel offset settings from one source
clip to multiple destination clips.

Quick Select Sets

Lets you select a Quick Select Set. When you select a Quick Select Set in Trax,
the clips that are part of the set you select are quickly loaded and displayed in
the track view area.

For information on creating a Quick Select Set of clips, see "Quick Select Set” on
page 237.

Group

Creates a group under the current character and places the selected clips in
tracks under that group.

Ungroup

Removes the selected group from its character and places the group’s tracks
directly under its character or parent group.

View >

Frame All

Frames all clips in the track view area so that each clip’s start and ends are
visible.
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Frame Selection

Frames the selected clips in the track view area.

Frame Playback Range

Frames the current playback range in the track view area.

Center Current Time

Centers the track view area on the current time.

Graph Anim Curves

Launches the Graph Editor and displays the animation curves of the current,
selected clip.

Modify >
Attribute Editor

Opens the Attribute Editor and displays the current character or clip’s nodes and
attributes.

Enable/Disable

Turns the selected clip’s animation curves on or off. See "Enabled/disabled
clips” on page 247.

Activate/Deactivate Keys

Turns Activate Keys on or off for the selected clip. The Activate Keys mode lets
you key into a clip. See "Active/inactive clips” on page 247.

Add Track

Adds a track to the current character. The new track appears at the bottom of the
character’s stack of tracks.

Remove Track

Removes the selected clip’s track from its character.

Create >
Clip

Creates a clip for the current character. See ”"Animation clips” on page 181 and
Animate > Create Clip.
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Constraint Clip

The options in the Create Constraint Clip Options window are the same as those
in the Create Clip Options window, with the exception that the Create Constraint
Clip Options window does not contain the Time Range Animation Curve option. For
information on the options in the Create Constraint Clip Options window, see
Animate > Create Clip.

Expression Clip

The options in the Create Expression Clip Options window are the same as those
in the Create Clip Options window, with the exception that the Create Expression
Clip Options window does not contain the Time Range Animation Curve option. For
information on the options in the Create Expression Clip Options window, see
Animate > Create Clip.

Pose

Creates a pose for the current character. See "Poses” on page 184.

For information on the Create Pose Options window, see "Animate > Create
Pose” on page 253.

Blend

Blends the selected clips. You can only create a blend between two clips at a
time.

See "Blends” on page 247 and "To blend animation clips” on page 212.
Initial Weight Curve

Sets how the blend is interpolated at the beginning, middle, and end of the

clip.

Linear Changes attribute values at a constant rate from the
beginning to the end of the clip.

Ease In Changes attribute values slowly at the beginning and
quickly at the end.

Ease Out Changes attribute values quickly at the beginning and
slowly at the end.

Ease In Out Changes attribute values slowly at the beginning and
end, and quickly in the middle.

Rotation Blend
Specifies how to blend between the rotations in clips.

Quaternion

Shortest Uses quaternion interpolation to find the shortest path
between rotations from the first clip to the second clip in
the blend. Quaternion Shortest is on by default.
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Quaternion

Longest Uses quaternion interpolation to find the longest path
between rotations from the first clip to the second clip in
the blend. This path is in the opposite direction from
Quaternion Shortest.

Linear Creates a linear interpolation between clips that blends

the values at a constant rate.

Character Set

Creates a character set for the current object. See "Characters, groups, and
subcharacters” on page 186.

For more information on the Create Character Set Options window, see Character
> Create Character Set > (.
Time Warp

Creates a time warp curve for the current clip. See "Time warps” on page 248
and "Create and edit time warps” on page 214.

Time Warp
Enabled Time
Warp Curve Activates the time warp curve for the current clip.
Disabled Time
Warp Curve Deactivates the time warp curve for the current clip.

Quick Select Set

Creates a Quick Select Set for the current clips. Quick Select Set lets you create
a selection set for multiple clips from various clips and characters. The selection
sets you create with this option appear under Trax menu bar > Edit > Quick
Select Sets.

You can edit the membership of an existing quick select set with the Relationship
Editor. See Relationship Editor.

Library >
Insert Clip

Lets you insert a clip into the current track. The list of clips contains the names
of all the clips in your scene.

Insert Pose

Lets you insert a pose into the current track. The pose list contains the names of
all the poses in your scene.
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List >

Autoload Selected Characters

When on, any characters you select in either the scene view or the Time Slider’s
Current Character drop-down list are automatically loaded into Trax. Also, when
you cancel your selection, all characters are automatically removed from Trax.
Load Selected Characters

Loads all selected characters into Trax. If you used Load Selected Characters,
cancelling your selection does not remove the characters from Trax.

Only available when Autoload Selected Characters is off.

Add Selected Characters

Loads the selected characters into Trax. Use this menu item to add characters to
Trax when there is already a number of characters loaded in Trax.

Only available when Autoload Selected Characters is off.

Bookmarks
Bookmark Current Characters

Creates a bookmark for the current, highlighted character in Trax. Character
bookmarks let you quickly load characters into Trax.

Use the Bookmark Current Character option box to name your bookmarks.

All the character bookmarks you create appear as a list under List >
Bookmarks.

Remove All Bookmarks

Deletes all the current scene’s character bookmarks.

Trax toolbar

The Trax toolbar lets you quickly access the most commonly used menu bar
options in Trax.

| Create Clip Creates a clip with the keyframe animation of the
current character.
= Create Blend  Creates a blend between two, selected clips. See
= "Blends” on page 247.
Get Clips Launches the Visor. For more information, see Visor
in the Basics guide.
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Makes all clips in Trax visible in the track view area.
This button can also be found in the Graph Editor
and Dope Sheet toolbars.

Frames all the track view area contents within the
selected timeline range. This button can also be
found in the Graph Editor and Dope Sheet toolbars.

Displays the current clip’s animation curves in the
Graph Editor. See Graph Editor in the Animation
guide.

Adds the character selected in the scene view to
Trax.

Displays the selected clip’s weight curve in the
Graph Editor.
See "Group” on page 234.

See "Ungroup” on page 234.

See "Trim Before” on page 232.

See "Trim After” on page 233.

Sets a key at the current position of the Trax current
time indicator for the selected clip.

Track control area

The track control area in the Trax Editor lets you lock, solo, or mute all the

animation clips in a track.
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239



3 | Nonlinear Animation
Reference > Track view area

Lock The Lock button freezes the current animation track. When a
track is locked, you can not edit its clips, but its animation is
present during playback.

JoeCh

E Solo  The Solo button isolates the clips on the current track so that
they are the only animation sequences that are played during
playback for the character. Soloing is useful when you want to
isolate and review a specific animation sequence for a
character. You can solo single or multiple tracks at a time.

JoeCh

Mute The Mute button mutes all the clips on the current track. Muting
= suppresses or hides the animation on a track without removing
it from the Trax Editor. Muting is useful when you want to
suppress a specific animation sequence for a character during
playback. See “Muting animation” in the Animation guide.

JoeCh

&1 2]
&l (/2]

&l | 2]

Track view area

You manage and manipulate the animation clips for your characters in the track
view area of the Trax Editor.

7

« "Track hierarchy” on page 241
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¢ "Information displayed on Clips” on page 243
% "Clip interaction controls” on page 243
« "Clip states” on page 246

Track hierarchy

The hierarchical relationships between tracks are shown by their positions in the
track view area. You can organize your scene and create a hierarchy of clips by
manipulating this relationship.

w Character
Track

w Group
| Track |

| Track |

W Subcharacter

| Track |

| Track |

w Soundtrack
Audio Track

Audio Track

Characters

The top-most level of each track hierarchy is always the character. A character in
Trax can contain multiple tracks, subcharacters, or groups.

Groups

Groups contain arbitrary collections of clips for a single character. You can
collapse and expand groups just like you would a character.

Subcharacters

When you add or display a character in Trax, all of its subcharacters are
automatically placed under the character. Subcharacters and Groups exist on the
same level under the character, and can be controlled in a similar manner. You
do not need to have subcharacters to be able to work with a character’s
animation in Trax.
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Summaries

Each level in the Trax hierarchy has a summary. A summary gives you a high level
of control over the collection of tracks under a character, group, or subcharacter.

You can collapse and expand summaries for characters, subcharacters, or groups
by clicking the arrow that is beside each of their names in their respective
summaries.

Start and End frame numbers
for the summary clip —‘

P P

Summary—[ Becky-Lee
Arrow Summary clip

Collapsed set of tracks for a character

The summary clip represents all the clips under your character, group, or
subcharacter. You can drag the summary clip to move all the clips in all the
tracks under a character, group, or subcharacter. You can also scale a summary
clip by Shift-dragging its beginning and end or by editing its Start and End frame
numbers.

Soundtrack

You can display and play multiple audio waveforms in Trax. The Soundtrack lets
you import .wav or .aiff audio files as clips. Once you import an audio file into
Trax, you can then move and rename its audio clip.

The play priority of audio clips goes from the top-most clip to the bottom-most
clip. Also, you can play only one audio clip at a time and any new audio clips that
you add to your scene appear at the bottom of the stack of audio clips in the
Soundtrack.

Plays frames 0-97
I

[ |
T T
Does not play Plays frames 98-168

For example, if you have multiple audio tracks and clips that overlap in time, then
the audio clip in the top-most track will always play instead of other audio clips
on other tracks that are at the same position on the Trax timeline.

If you want to hear the audio clips that are present in your Soundtrack, see "To
hear audio clips present in Trax” on page 226.
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Information displayed on Clips

Duration
|
Source In 1 30 40H- Source Out
ualking————
Frame In —4 1 00 =1 i Frame Out

|
Scale Clip Name

Source In/Out

Start and end frame numbers for the range of frames from the source clip
contained in this animation clip.

When you create an animation clip, a source clip is automatically generated in
addition to the clip that is created in the track view area. The source clip is
placed in the Visor, and can only be modified from that location. This protects the
source clip from being accidentally modified. Any modifications you make to a
source clip are reflected in all the clips that originate from that source clip.
Source clips are useful if you want to access or revert back to the original
animation for a character.

When you trim a clip in Trax, you are excluding sections of animation from the
beginning or end of a clip. This changes a clip’s Source In and Source Out times,
but does not affect the source clip itself.

Frame In/Out

Current start and end frame numbers for a clip. These numbers control when a
clip takes effect.

Duration

Number of frames over which the current clip’s source clip takes place. This value
is affected by any modifications to the source clip’s trimming values. This value
is read-only. See "Source clips” on page 182.

Scale

The scale percentage for the current clip. The scale percentage is the multiplier
on the length of the original animation clip. See "Scale” on page 245.

Editable Clip attributes

You can change any attributes (for example, name, duration, scale and so on)
displayed on clips by double-clicking on the attributes and entering a new value.

Clip interaction controls

Clips have hotspots which you can drag to produce various effects. For example,
if you drag the top-right corner of a clip, you Trim a clip.
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Drag to Trim
Drag to Trim Shift-drag to create a Hold

Drag to Scale Drag to Scale
Shift-drag to create a Cycle Shift-drag to create a Cycle

When you move your mouse pointer over a clip, white outlines appear around its
hotspots when the pointer passes over them.

"Move” on page 244

"Trim” on page 244

"Scale” on page 245

"Hold” on page 245

"Cycle” on page 245

"Multiple clip manipulator” on page 246

e
0.0

5

%

e
0.0

5

%

e
0.0

5

%

Move

Drag clips to move them in the track view area.

@ The Move mouse pointer appears when
you are moving a clip.

You can drag single clips upward and downward, or from side to side. When you
drag a clip upward or downward, and there is no track present above or below the
clip you are dragging, then Maya creates a new track for the clip. See "Add
tracks” on page 220.

You can also move multiple clips at a time. See "Multiple clip manipulator” on
page 246.

Trim

Drag the top corner clip hotspots to trim clips.

The Trim mouse pointer appears
when you are trimming a clip.
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You can omit segments from the beginnings and ends of animation clips by
trimming clips. This changes a clip’s Source In and Source Out times, but does
not affect the source clip itself. The segments that you omit from a clip using
Trim are not deleted, and can be reinstated if the clip’s original length is
restored.

Scale

Drag the lower corner clip hotspots to scale clips.
— The Scale mouse pointer appears when you are scaling a clip.

When you reduce (<100% of the original clip length) or scale down a clip, you are
actually compressing the animation on the clip, so that the resulting animation
appears faster or sped up.

When you scale (>100% original clip length) up a clip, you are actually extending
the animation on the clip, so that the resulting animation appears to be slower.

Hold

Shift-drag the upper corner of clips to create holds after the original clip. You can
also create and edit holds for a clip from the Attribute Editor. See "Hold clips” on
page 206.

The Hold mouse pointer appears when you are creating a hold for a clip.

You can create holds for you animation clips. A hold is a part or an extension of a
clip where the last pose is held for a specified period of time. Holds are
represented by the letter H.

Hold
End of original clip/start of Hold L |

10 30 40
Funning
90 100% 1208 140
I

# of frames held

End frame for Hold

Cycle

Shift-drag the lower corners of clips to create cycles before (pre-cycle) or after
(post-cycle) the original clip. You can also create and edit cycles for a clip from
the Attribute Editor. See "Cycle clips” on page 205.

@ﬂ —— The Cycle mouse pointer appears when you are creating a cycle for a clip.
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You can repeat an animation contained in a clip by extending the clip with
duplicate animation sequences called cycles. You can create whole or partial
cycles. The end of the original clip, and the beginning of the first cycle, is marked
by a small vertical line. The end of each cycle sequence for a clip is marked by a
small cycle tick or marker.

Cycles are represented by the letter C and appear a lighter blue than the rest of
the clip.

Cycle
|

End of original clip/start of cycle(s) # of cycles Cycle marker

End frame for clip

Multiple clip manipulator

You can select multiple clips (Shift-click) in one or more characters and move or
scale them all at once using the clip manipulator.

30

Jogging
4 94

10 30
Funning

Translate handle

Scale handles

For information on how to use the clip manipulator, see "Move clips” on
page 202.

Clip states

"Enabled/disabled clips” on page 247
"Active/inactive clips” on page 247
"Blends” on page 247

"Time warps” on page 248
"Weighting” on page 248

7 e 7 e
L X X IR X 4

e
L X4
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Enabled/disabled clips

When a clip is disabled, its animation is suppressed during playback. Enabling
and disabling a clip is just like muting or unmuting a track. In the Trax Editor,
disabled clips appear dark blue in color.

To enable/disable a clip, right-click a clip and select Enable Clip from the context-
sensitive menu that appears. See "Context-sensitive menu” on page 249.

JoeCh

Disabled clip

Active/inactive clips

When a clip is active, manipulating and keying the objects whose curves are in
that clip from the scene view automatically places all those keys in the active
clip. Also, all an active clip’s keys appear in the Time Slider.

An active clip appears purple to indicate that you can key into it from outside the

Trax Editor.

You can activate or deactivate clips by turning on or off Activate Keys from the
context-sensitive menu or Modify > Activate/Deactivate Keys menu in the Trax
Editor. See "Context-sensitive menu” on page 249 and "Key into a clip from
outside of the Trax Editor” on page 217.

Blends

You can blend the common attributes of two animation clips of a character set.
This creates a region of mixed animation between the motion of each clip called
a blend. Blends provide smooth transitions between one animation clip and
another. See "Create and edit blends” on page 211. You can control how much
influence each clip has in a blend by manipulating the animBlend node’'s Weight
attribute.

When you apply a blend to clips, a visual cue appears on (if clips are overlapping)
or between (if there is a gap in time between the clips) the blended clips. Also,
the parts of clips that overlap in blends are colored differently than the rest of the
clips.

Blends between animation clips are indicated by green arrows and the regions of
overlap between blended clips appear green.
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If clips that participate in a blend do not overlap in time, then only a green arrow
appears connecting the blended clips. The green arrow is drawn from the end of
the first clip in the blend to the beginning of the second clip in the blend.

Overlapping clips on different tracks with a blend

e —
|

Non-overlapping clips on the same track with a blend

Non-overlapping clips on different tracks with a blend

Time warps

Time warps let you change the timing of a clip without modifying the clip's
animation curves. See "Create and edit time warps” on page 214.

When you create a time warp for a clip, a visual cue appears on the respective
clip to indicate that it is influenced by a time warp curve. This visual cue appears
as a green colored bar at the top of the clip.

Green bar

Weighting

Weight is a clip attribute. You can change a clip’s weighting to increase or
decrease its influence in its character’s overall animation. See "Edit a clip’s
weighting” on page 201 and "Weight” on page 254.

When you animate the weight of a clip, a new visual representation of the Weight
attribute’s curve appears on the clip.
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Weight curve

Context-sensitive menu

The Trax context-sensitive menu appears when you right-click a summary, track,
or clip. The options that are displayed in this menu depends on what your mouse
pointer is over when the menu is invoked. Many of the options in the Trax
context-sensitive menu can also be found in the Trax menu bar. See "Trax menu
bar” on page 227.

Summaries
Paste Clip

Places the clip copy present in your system’s clipboard at the current time in
the track, group, or character you are clicking on.

Import Clip to Character

Lets you import a clip from your disk to the character or group you are
clicking on. Opens the Import file browser window.

Tracks
Paste Clip

See "Paste” on page 230.
Import Clip to Character

See the above section.
Insert Track Above

Creates a single, empty track above the track you are clicking on.
Insert Track Below

Creates a single, empty track below the track you are clicking on.
Remove Track

Deletes the track—including all the clips it contains—you are clicking on.
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Clips
Enable Clip

Lets you turn the animation curves on or off for the clip you are clicking on.

When on (indicated by ), the selected clip is enabled. When off, the
selected clip is disabled. See "Enabled/disabled clips” on page 247.

Activate Keys

Lets you activate or deactivate the clip you are clicking on. When on

(indicated by ), the selected clip is active. When off, the selected clip is
inactive. See "Active/inactive clips” on page 247.

Group

See "Group” on page 234.
Ungroup

See "Ungroup” on page 234.
Cut Clip

See "Cut” on page 230.
Copy Clip

See "Copy” on page 230.
Paste Clip

See "Paste” on page 230.
Split Clip

See "Split” on page 231.
Duplicate Clip

See "Duplicate” on page 233.
Merge

Only available when you are clicking on a cycled clip or when you have two
clips selected. See "Merge” on page 232.

Trim Before

See "Trim Before” on page 232.
Trim After

See "Trim After” on page 233.
Attribute Editor

Opens the Attribute Editor and displays the nodes and attributes of the clip
you are clicking on.
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Graph Weight

Opens the Graph Editor and displays the weight curve of the clip you are
clicking on. Select this option only when your clip possesses a weight curve.

Select Character Set Members

Selects in the scene view all the objects that are members of the character
you are clicking on.

Key Into Clip

See "Key into clip” on page 239.
Create Time Warp

See "Time Warp” on page 237.
Create Weight Curve

Creates a weight curve for the clip you are clicking on. You can manipulate
and key this curve to create various animation effects. See "Weighting” on
page 248.

Select Source Clip

Selects the source clip of the clip you are clicking on. The source clips
attributes appear in the Channel Box. See "Edit source clips” on page 219.

Menus

Animation menu set

Animate >

Animate > Create Clip

Creates a clip. See "Animation clips” on page 181 and "Create clips” on
page 196.

Animate > Create Clip > 0
Opens the Create Clip Options window.

Name field

Specifies a name for the clip. Default is clipn. If you rename a clip, the
associated source clip is automatically renamed to match the new clip name.
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Keys

Leave Keys in
Timeline

Clip

When on, the current character set’s keys are

not removed from the Time Slider when you create a clip
for the current character’s animation curves. This is
useful if you do not want to use the clip right away, but
want to store it for future use. By leaving the keys in the
Time Slider, you can create another clip with the keys.

If you turn on Leave Keys in Timeline, the

Put Clip in Trax Editor and Visor option is dim to prevent
keys in the Time Slider from adding to the clip animation
in the Trax Editor. This would have a doubling effect on
the animation. If you create a clip for a character set and
later key the character set, the animation keys are then
added to the clip animation. See "Key on top of clips”
on page 216.

When off, the current character set’s keys are removed
from the Time Slider when you create a clip for the
current character’s animation curves.

If you want to create several clips for different time
ranges of a character set’s animation, turn off Leave
Keys in Timeline and turn on Put Clip in Trax Editor and
Visor. Create a clip with the entire range of desired keys,
then split the clip into the desired animation segments.
See "To split a clip” on page 206.

Specifies where to put the clip you’'re creating:

Put Clip in Visor
Only

Put Clip in Trax
Editor and Visor

Time Range

This setting is useful if you won't use the clip currently
but want to store it for future use.

Lets you work on the clip in the Trax Editor now. This is
the default setting.

Specifies the clip’s time range in the Trax Editor:

Selected

Time Slider

Animation
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Uses a time range you’ve selected in the Timeline for the
clip. To select a time range, Shift-drag through the
desired times in the Time Slider’s Timeline.

Uses a time range defined by the Playback Start and End
times of the Timeline.
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Start/End
Start Time

End Time

Subcharacters

Include
Subcharacters in
Clip

Timewarp

Create Timewarp
Curve

Include

Hierarchy
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Reference > Animate > Create Pose

Uses a time range that spans the range of the character
set’s animation curves. That is, the start time is the time
of the first key on the character set, and the end time is
the time of the last key.

Specifies a time range from Start Time to End Time.

Specifies the start of the time range (available if Start/
End is on).

Specifies the end of the time range (available if Start/
End is on).

When on, creates a single source clip that includes all
animation curves for the character set and all its
subcharacter sets.

Creates a time warp curve for the selected clip. See "To
create a time warp for a clip” on page 215.

When Include Hierarchy is turned on (the default), the
hierarchy below the selected objects are included in the
clip. When Include Hierarchy is turned off, only the
selected objects themselves are included in the clip.
Only animated attributes are included in the clip; non-
animated objects are ignored.

Animate > Create Pose

Creates a pose of the current character. See "Poses” on page 184 and "Create

poses” on page 197.

Animate > Create Pose > 0

Opens the Create Pose Options window.

Name field

Defines the name of the pose as it is displayed in the Visor. See "To create a

pose” on page 197.
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Nodes

Animation nodes

animClip

For more information on the clip node, see animClip in the Help > Node and
Attributes Reference. For information on source or regular clips, see ”"Animation
clips” on page 181.

When you create a clip, the animated channels for the character are
disconnected from the character node or object and are then connected to a
clipLibrary node instead. The clip library node manages and keeps track of all
the source clips for the character. The clip library and all the regular clips for the
character connect to the cl1ipScheduler node. The clip scheduler manages and
keeps track of all the regular clips for a character.

CAnimation channel)

animClip (Source clip)

CAnimation channel

clipLibrary

animClip (Regular clip) )

(Animation channel )

clipScheduler

Animation
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animClip (Regular clip) )

character

In the dependency graph, source clips and their instances (regular clips) are
represented by various animClip nodes.

Anim Clip Attributes
Enable

Disabling a clip turns off the animation controlled by the clip. Enabling turns
on normal animation. It’s often useful to disable clips you're not working on
to lessen visual distraction.

Weight

Scales up or down the value of each attribute in the clip by the specified
percentage. The scaling occurs for the entire animation of the clip, and pivots
around the clip’s start value. For example, suppose an object’s translateX
attribute increases in value from 10 to 20 in 30 frames. If you set Weight to
0.5, the translateX attribute rises from 10 to 15 in 30 frames.

All attribute data types are effected by Weight except Boolean (on/ off)
attributes.
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Weight Style
Sets what a Weight of O does to the channel values controlled by the clip.

From Start When on, a Weight value of O moves all the clips
channels to the values they had at start of the clip. For
example, if the clip is a walk cycle, a Weight value of O
moves the character to the first frame of the walk cycle.
Weight values between O and 1 cause the clip channels
to interpolate between their start frame value and the
current clip value.

From Zero When on, all the channels in the clip go to O when the
Weight value is 0. Weight values between O and 1 cause
the clip channels to interpolate between O and the
current clip value.

Rotation From

Zero When on, a Weight value of O causes the rotation
channels in the clip to go to O, and moves all the other
animation channel values to the values they had at the
start of the clip.

Start Frame

Specifies the starting time of the clip’s playback. You can alternatively drag a
clip left or right in the Trax Editor to change the Start Frame.

Pre Cycle

Specifies the number of cycles that come before the current animation clip.
See "Cycle” on page 245.

Post Cycle

Specifies the number of cycles that come after the current animation clip.
See "Cycle” on page 245.

Scale

Expands or contracts the time range of the clip. If you increase the scale, the
attributes animate slower. Decreasing the scale has the opposite effect.

You can alternatively drag the upper right edge of a clip to change the Scale
value.

Hold

Specifies the number of frames to hold the last frame of the current clip’s
animation.

Source Start

Specifies the start frame number for the range of frames from the source clip
contained in this animation clip.

Animation
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Source End

Specifies the end frame number for the range of frames from the source clip
contained in this animation clip.

Time Warp Enable

When on, the time warp curve for the current animation clip is active. See
"Time Warp” on page 237.

Time Warp
Sets the current weight of the time warp curve.

Only available when Time Warp Enable is on.

Channel Offsets

The Channel Offsets settings let you set the offsets (absolute or relative) for each
channel in a clip. See "Offset clip channels” on page 209.

Absolute and Relative radio buttons

The Absolute and Relative radio buttons let you set the offsets for each clip’s
channels. When an Absolute radio button is turned on, the offset of the
channel beside the radio button is absolute. When a Relative radio button is
turned on, the offset of the channel beside the radio button is relative.

Note Rotation channels are the only clip channels that have absolute
offsets by default.

Each channel name beside the radio buttons has a prefix. This prefix is the
name of the object to which the animation channels belong. For example, if
the animation in a clip belongs to an object named Sam, then the prefix Sam.
appears before each of the clip’s channels in the Channel Offsets.

All Absolute

The All Absolute button lets you set the offsets of all the channels for the
current clip to absolute.

All Relative

The All Relative button lets you set the offsets of all the channels for the
current clip to relative.

Restore Defaults

The Restore Defaults button lets you revert the current clip’s Channel Offsets
to their original settings.

Animation
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Source Clip Attributes
Pose

If you created a pose for the character set rather than a clip, the Attribute
Editor displays the Pose option as turned on. For details on creating poses,
see "To create a pose” on page 197. This option simply lets you know that
this clip is a pose rather than an animation clip.

Node Behavior

Contains rarely used, general attributes. See the Basics guide for details.

Extra Attributes

Cycle Specifies how many times the clip repeats. For example,
suppose your clip originally plays for 10 frames. A value
of 2 causes the clip to play twice in 20 frames. A value
of 0.5 causes the clip to play half its animation in 5
frames. If you use a Cycle value over 1, the clip displays
a small rulertype marker to indicate where each
additional cycle begins.

Tip As an alternative to using menu items at the top of the Trax Editor,
you can right-click a clip to display menus applicable to that clip
only.

clipLibrary

See clipLibrary.

clipScheduler

See clipScheduler.
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About

Path Animation

Path animation is a way of animating an object’s translation and rotation
attributes by specifying a NURBS curve as the object’s trajectory. The object
automatically rotates from side to side as the curve changes directions. If the
object is geometry, it can be automatically deformed to follow the contours of the
curve.

What is path animation?

A path animation controls the position and rotation of an object along a curve. A
NURBS curve cannot be designated as a motion path. An object must first be
attached to the curve for it to become a path curve. See "To create a motion path
by attaching an object to a curve” on page 261. You can also generate motion
paths by animating objects using motion path keys. See "To create a motion path
using motion path keys” on page 262.

Positioning your object on a path curve

The point at which your object attaches to the path animation curve is the rotate
pivot. Move the rotate pivot of the object to the area of your object that you would
like to rest on the curve during the path animation. See "To position an object on
a path” on page 267 and “The pivot point” in the Transforming Objects chapter of
the Basics guide.

Orienting your object on a path curve

When orienting your object on a motion path curve, we recommend that you use
the object’s local rotation axes. Use these axes to control the front and up of
your object on the path. See "Orient an object on a path” on page 268 and
“World space, object space, and local space” in the Transforming Objects
chapter of the Basics guide.

Manipulating your object on the motion path

If you have animated geometry (a NURBS or polygonal shape) on a path curve,
you may choose to have the object deform as it travels along the path curve,
matching the contours of the curve.

The Flow Path Object function creates a lattice around an object that is animated
with path animation. There are two ways you can create the lattice: around the
object, or around the path curve. Both methods will achieve the same result.
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However, you may find that one or the other is more convenient if you want to
add deformations to the lattice afterwards to achieve some layered deformation
effects. See "Deform an object along a motion path curve” on page 269.

By default, the lattice is created around the object.

Motion path markers

When you create a path animation, you’ll notice that markers with numbers are
drawn along the path curve. These are motion path markers, and each one
represents a key of an animation curve. The time of the key is the number drawn
on the marker.

There are two types of motion path markers: position markers and orientation
markers. Position markers are created when you select Motion Paths > Attach to
Motion Path or when you use motion path keys. Orientation markers can be
created to refine the automatic rotations that are computed for the object when
the Follow option is used.

Position marker Orientation marker

The value of a position marker is the U parameter value (or percentage of the
curve, if the path animation is in Fraction Mode,) of the marker’s position on the
curve. The value of an orientation marker is the amount of rotation for its Twist
parameter.

Markers display in both the scene view and graph editor. This is very useful for
editing the timing of path animation, and this saves having to open the Graph
Editor to edit the timing of the path animation’s curve.

Position markers

After creating the path animation, you may find that you would like the object to
travel a little further or not so far along the curve at a given marker time. You can
make this adjustment by changing the position of the marker along the curve.
See "To position an object on a path” on page 267.
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Orientation markers

Orientation markers represent keys for the Front, Side, and Up Twist attributes of
the motion path node. These Twist attributes are rotations that are added to the
default rotations computed by the path animation when you use the Follow (and
optionally Bank) option.

Creating your own orientation markers is useful if you want to refine the default
rotations computed by the path animation. See "Orient an object on a path” on
page 268.

Marker timing

After creating the path animation, you may find that the object reaches a marker
a little too early or late in time. You can make this adjustment by changing the
time of the marker. See "To change the timing of a marker” on page 271.

Create a motion path animation

Create a motion path using a curve

To create a motion path by attaching an object to a curve

1 Create a NURBS curve.

The curve is the path along which the object moves. The direction you create
the curve is the direction the object moves.

2 Select the object you want to animate on the path, and then Shift-select the
curve.

Note You can animate many objects along the same path curve by first
selecting the objects, and then selecting the curve. You must select
the curve to be used as the path curve last.

3 Select Animate > Motion Paths > Attach to Motion Path.

The object moves to the point on the curve where it is positioned for the
current time. Also, two motion path markers with numbers appear at each
end of the curve. These markers indicate the position and time at which the
object moves to those marker positions.

4 To view the animation of the object, click the Play button in the Playback
controls.
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Tip

If your object does not follow the motion path, it may be due to
existing transforms on the parent of the object. To move force the
object to follow the path, attach the parent of the object o the
motion path instead of the object, and then move the parent’s pivot
until the object (its child) is on the path.

Create a motion path using keys

To create a motion path using motion path keys

1
2
3

Select the object that you want to follow the motion path.
Animate the object using motion path keys.

Translate your object and select Animate > Motion Paths > Set Motion Path
Key until your motion path animation is complete.

A line is drawn from one motion path key to the next to form the motion path
curve.

Edit motion paths

Detach an object from a motion path

To detach objects from a motion path in the Hypergraph

1
2

Select the object that you want to remove from the motion path.

Select Window > Hypergraph.

The Hypergraph appears.

Click the Input and Output Connections button in the Hypergraph tool bar.
The object’s node and all its connections appear in the Hypergraph.

Select each connection between the object and the motion path related
nodes and press Delete.

To detach objects from a motion path in the scene view

1

2

Select the motion path that you want to delete, and select Edit > Duplicate.
A duplicate of the motion path appears.
Select the original motion path and press Delete.

Delete motion paths

To delete a motion path

Do one of the following:



4 | Path Animation
How do I? > Create a path animation

Select the motion path and press Delete.

Select an object on the motion path that you want to delete and select Edit >
Delete by type > Motion Paths.

To delete all motion paths in your scene

Select Edit > Delete All by type > Motion Paths.

Animate along a motion path

Create a path animation

To create a path animation

The following procedure uses Animate > Motion Paths > Set Motion Path Key to
create a motion path animation. Alternately, you can also use Animate > Motion
Paths > Attach to Motion Path to create motion path animation.

1

2
3

Select the object you want to animate with the motion path and move it to its
starting position.

Set the current time to the start time of your path animation.
Select Animate > Motion Paths > Set Motion Path Key.

A single-CV curve is created with a position marker at time specified start
time.

Increase current time and move the object to a new position.
Select Animate > Motion Paths >Set Motion Path Key again.

A single-span curve is drawn from the marker at the start time to the current
position of the object, where a new marker is placed.

Continue changing the time and position by selecting Animate > Motion Paths
> Set Motion Path Key for as long as you wish to animate the object’s
position.

The time at which the last motion path key is set is end time of your motion
path animation.
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Note that once you have created a path animation using the Animate > Motion
Paths > Set Motion Path Key, you can use all of the other path animation tools
as described in the previous sections to refine the basic path animation.

Similarly, you can select the object that was animated along a pre-existing path
curve, and extend the length of its animation (and thus the path curve) by using
Animate > Motion Paths >Set Motion Path Key.

Tip If you decide you don’t like the position of the object at a particular
marker time, then change the current time to that marker’s time,
and move the object to its new position. Select Motion Paths >Set
Motion Path Key, and the shape of the curve will change so that the
marker is now at the object’s new position.

You can change the shape of an existing path curve by changing the
current time, moving the object to a new position, and selecting
Animate > Motion Paths > Set Motion Path Key. An example of
animation before and after this menu item follows:

Create a path animation using the Motion Path
Manipulator tool

1 Select the object you want to animate along a motion path curve.
2 Draw the curve for the object.

3 Select the object, Shift-click the curve, and select Animate > Motion Paths >
Attach to Motion Path > .

The Attach to Motion Path Options window appears. See "Animate > Motion
Paths > Attach to Motion Path” on page 272.

4 Set the options. Ensure that the Follow option is on. See "Follow” on
page 273.

5 Do one of the following:

e C(Click Attach to bind the current object to the selected curve with the
current Attach Motion Path options.

The Attach Motion Path Options window closes.

e Click Apply to bind the current object to the selected curve with the
current Attach Motion Path options.

The Attach Motion Path Options window remains open.
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e Click Close to disregard any changes made to the Attach Motion Path
options and close the window.

6 Select the object only, and view the INPUTS section of the channel box.

Notice that one of the items listed is named motionPathl. This is the node
that is controlling the path animation.

7 Select this node in the Channel Box.

Its attributes appear in the bottom part of the INPUTS section of the Channel
Box.

INPUTS
maotionPathl
polySpherel

U value O

Front Twist G

Up Twvist ]

Side Twist G

8 Select the Show Manip Tool from the Maya tool bar.

ELYLVE

A manipulator appears around the object.

9 Use the Motion Path Manipulator in one of the following ways:

e Use the handle in the center of the manipulator to position the object
along its path.

e Use the handle on the circle to control the front twist attribute of the path
animation, that is, the amount it twists around its front axis. This latter
handle can be used to manually set the banking of the object.

10 The object is currently positioned at the start of the curve.Click in the time
slider and move the time to that of the next motion path key.

11 To move the object to the position of the next motion path key, click the light
blue centre handle of the manipulator, and drag the object along the path.

12 To set a key for this object at this position, set a key for the U Value attribute
of the motionPath1 node.

13 Set a key from either the Keys menu, or by clicking on the U Value attribute
of the motionPath1 node in the Channel Box and selecting Channels > Key
Selected.
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INPUTS
mationPathl
polySpherel

Uvalue 0818
Front Twist o}
Up Twist 4]
Side Twist &)

14 Repeat the last steps 11-13 until the object reaches the end of the curve.
15 Click the Play button in the Playback Controls to view your path animation.

Tip e You can avoid having to repeatedly set a key for the U Value
attribute in the Channel Box if you turn Auto Key on.

e You can use the same workflow if you want to animate the
banking of the object by using the front twist handle of the
manipulator.

Animate an object along a surface

A path animation can use a curve-on-surface as the path curve. The workflow is
identical to that when the curve is in world space; however, there is extra
flexibility in controlling the “up” orientation of the object.

1 Select Create > NURBS Primitives > Plane.
A NURBS plane appears in the scene view.

2 Select Modify > Transformation Tools > Proportional Modification Tool.
This tool is used to introduce contours on the plane.

3 Select Modify > Make Live, and then draw a curve on the plane.

4 Select the object you want to animate along the path, and Shift-click the
curve-on-surface.

The object and curve-on-surface are now selected.
5 Select Animate > Motion Paths > Attach to Motion Path > .

The Attach to Motion Path Options window appears. See "Animate > Motion
Paths > Attach to Motion Path” on page 272.

6 Ensure that either Follow or Parametric Length is on, and set the Up Direction
to Normal so that the object will stay normal to the surface.

7 Do one of the following:

e C(Click Attach to bind the current object to the selected curve-on-surface
with the current Attach Motion Path options.

The Attach Motion Path Options window closes.

e Click Apply to bind the current object to the selected curve-on-surface
with the current Attach Motion Path options.

The Attach Motion Path Options window remains open.
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e Click Close to disregard any changes made to the Attach Motion Path
options and close the window.

Note You may also wish to turn on the Inverse Up option, depending on
the direction of the normals to the surface, and which side of the
surface you want your object to be animated along. If you don’t
know which side the surface’s normals point, you can always turn
the Inverse Up option of the motion path on or off after the path
animation is created.

8 Click Play in the Playback Controls to view your animation.

You can make the animation even more complex by animating the CVs of the
curve-on-surface or by creating a lattice or cluster deformer on the surface
and animating this deformer object. The object animated by the path
animation will stay normal to the surface at all times.

Note If your surface was made 'live', it will not appear shaded, even if
Smooth Shade All is turned on. The surface must be made ‘unlive’
to appear shaded. See Modify > Make Live.

To position an object on a path

1 Select the object you want to move along the path curve.

Rotate pivot manipulator

2 Press the Insert (Linux and Windows) or Home (Mac OS X) key to select the
rotate pivot of the current object.

3 Drag the rotate pivot and position it on the object where you want it to attach
to the motion path curve.
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Press the Insert (Linux and Windows) or Home (Mac OS X) key again to exit
from the rotate pivot selection and return to object selection.

You can now attach your object to a curve to create your path animation. See
"To create a motion path by attaching an object to a curve” on page 261.

Note If you forget to position the rotate pivot on your object before

creating your path animation, you can always repeat these steps
after the path animation has been created.

The positioning may not seem intuitive, however, as it will appear
as if the object is moving instead of the rotate pivot, as you move
the rotate pivot. This is because the motion path is continually
recomputing and repositioning the object so that the rotate pivot
will stay on the path curve.

Orient an object on a path

1
2
3

Select the object you want to move along the path curve.

Change the selection mode from object to component.

Click Select by component type in the maya tool bar.

Maya switches to component selection mode.

Click Select by component type: Miscellaneous to display local rotation axes.

mﬁﬁ§2-o¢®f@+g

Local rotation axis

Select the rotate tool, and select the local rotation axis of the object.

Rotate this axes so that one axis points in the direction of the front of your
object, and another axis points in the up direction of the object.

Shift-click the curve.

Select Animate > Motion Paths > Attach to Motion Path > (3.
The Attach to Motion Path Options window appears.

Turn Follow on.
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When Follow is on, the Front Axis and Up Axis options determine which of the
three local rotation axes sets the front and up of the object respectively. See
"Follow” on page 273.

10 Select the axis you chose to represent the front of your object in step 6 as

the Front Axis, and select the axis you chose to represent the up direction of
your object in step 6 as your Up axis.

11 Click Select by object type in the maya tool bar.

Maya switches to object selection mode.

12 With the object selected, Shift-click the curve in your scene that you want as

your motion path.

13 You can now click Attach in the Attach to Motion Path Option window to

create your path animation. See "To create a motion path by attaching an
object to a curve” on page 261.

Deform an object along a motion path curve

1 Select the object you want to animate using a motion path.

2 Shiftclick the curve to include it in your selection.

3 Select Animate > Motion Paths > Attach to Motion Path.

The object snaps the motion path and a motion path marker appears at each
end of the curve.

4 With the object selected, select Animate > Motion Paths > Flow Path Object.

A lattice appears around the object on the motion path.

Note The lattice created from a Paths > Flow Path Object will ignore
effects introduced by any motion path orientation markers. To
enhance the front, up, side twist of a path animation with flow,
animate the rotation of the flow lattice rather than using orientation
markers for the path animation.

5 Click Play to view the animation.

The lattice moves along the motion path curve with the object, changing
shape as the path’s curvature changes. The lattice causes the object to
deform so that it follows the contours of the path curve.
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You can also flow an object around a path curve and build the lattice around
the curve. In this case, the object flows through the lattice surrounding the
curve, causing the object to deform as it passes through parts of the lattice.
To flow an object with a lattice around the curve, select Animate > Motion
Paths > Flow Path Object > 0 and turn on Lattice Around: Curve. See "Curve”
on page 278.

Set motion path markers

Set motion path markers

To create a position marker

Set a key on the U Value attribute of the motion path node.

To set orientation markers

1 Select the motion path animated object, and Shift-click its path curve.
2 Select Animate > Motion Paths > Attach to Motion Path > .
The Attach to Motion Path Options window appears. See "Animate > Motion
Paths > Attach to Motion Path” on page 272.

3 Set the Time Range to Time Slider and turn the Follow option on.
See "Follow” on page 273.

4 Click Attach to create the path animation.

Note Notice the playback of the animation smoothly animates along the
path curve. To make the object appear as if its path was bumpy,
animate the side twist attribute of the motion path, which is the
rotation around the side axis of the object.

5 Drag the Time Slider to the first time of the path animation.

6 Click the motion path node in the Channel Box to view its attributes, and

select the side twist attribute.

7 In the Channel Box, select Channels > Key Selected to key this attribute.

You have now created an orientation marker. The orientation marker is
represented in the view by a small triangle with a number next to it.

Orientation marker
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Note Keying the front, side, or up twist attributes of the motion path
node creates orientation markers.

8 Drag in the time slider further along in time.
9 Click in the numeric field of the side twist attribute in the Channel Box.

10 Middle-click and drag in the scene view to adjust the side twist of the motion
path node.

11 When you are satisfied with the amount of twist, click the side twist attribute
in the Channel Box, and select Channels > Key Selected.

12 Repeat steps 8-11 until you have reached the end of the path curve.

Note If you are not satisfied with the twist adjustment at one of the
orientation markers, you can select the orientation marker and use
the Rotate Tool to rotate the orientation marker the amount you
want.

To reposition a marker

1 Select the marker you want to reposition.
2 Use the Move Tool to reposition the marker along the curve.

To change the timing of a marker

1 Select the marker for which you want to change the time.

2 Open the Attribute Editor (Window > Attribute Editor) and click in the Time
field to change the time of the marker.

To delete a marker

e Select the marker in the scene view and press Delete.
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Menus

Animation menu set
Animate >

Motion Paths >

Animate > Motion Paths > Set Motion Path Key

Adds a motion path marker to the selected motion path curve at the current time.

Animate > Motion Paths > Attach to Motion Path

Places and links the selected object to the current curve. The current curve
becomes the motion path.

Animate > Motion Paths > Attach to Motion Path > o
Start Time

Specifies the start time of the motion path animation. Only available when
Start or Start/End in Time Range is on.

End Time

Specifies the end time of the motion path animation. Only available when
Start/End in Time Range is on.

Parametric Length

Specifies the method Maya uses to position an object as it moves along a
curve. There are two methods: the parametric space method and the
parametric length method.

In the parametric space method, the markers represent positions in the U-
parameter space of the curve. In the parametric length method, the markers
represent positions as a percentage of the total curve length. The parametric
length method is also known as the “fraction mode” method because the
evaluation of the path is based on a fraction of the length of the path curve.

To understand the difference between the two methods, consider a curve that
has uniform parameterization and unevenly spaced CVs.
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The curve above was created with five CVs and uniform knot spacing. The
beginning of the curve is at U=0.0 and the end of the curve is at U=2.0. The
cone was animated with path animation from time 1 to 30.

If the path animation for the cone is created with the parametric length
method, the cone will move evenly along the curve from times 1 to 30.

If the path animation for the cone is created with the parametric space
method, the cone moves quickly from the first to the second CV, then slowly
through the second to fourth CV, then quickly again from the fourth to fifth
CV. This is because the second and fourth CVs are positioned at
approximately U=0.5 and U=1.5 parameterization points of the curve. These
points take up half the total parameterization of the curve.

In parameter space, the object moves smoothly from U=0.0 to U=2.0. In
world space, there is little movement of the object from (roughly) times 8 to
23, which coincide with the large parameter distance that must be covered in
the correspondingly small curve length.

The advantage of using the parametric space method is that if you have
spent time adjusting the timing of the object’s movement along the curve,
CVs can be added to the beginning or end of the curve without affecting the
timing of the motion on the existing part of the curve.

The advantage of using the parametric length method is that it is easy to
obtain smooth timing of the object’s motion without having to insert timing
markers to refine the timing of the object along the path curve.

Turning off Parametric Length selects the parametric space method. Turning
on Parametric Length selects the parametric length method.

Follow

If on, Maya computes the object’s orientation as it moves along the curve. It
is on by default.

Maya uses a front vector and an up vector to compute the orientation of the
object. Maya aligns the object’s local axes with the front vector and the up
vector so that it knows how the object should be pointing upwards and
frontwards as it moves along the curve.

At any point along the curve, the front vector aligns with the tangent to the
curve, pointing in the direction of movement. The up vector is perpendicular
to the tangent, but you must still tell Maya which perpendicular direction from
the tangent is the up direction that you want. To do so, you specify a world
up vector with which the up vector aligns. Use the World Up Type, World Up
Vector, and World Up Object options to specify the world up vector.
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You need to tell Maya which of the object’s local axes should be aligned with
the front vector, and which should be aligned with the up vector. To view the
object’s local axes, select the object and select Display > Component Display
> Local Rotation Axes. Next, specify which local axis aligns with the front
vector with Front Axis. Also specify which local axis aligns with the up vector
with Up Axis. Finally, you specify the type of world up vector (World Up Type)
with which the up vector itself aligns.

The world up vector gives you the ability to control what the up vector
considers to be the up direction. One benefit of this is that you can correct
any sudden flipping problems as the object moves along the curve. For
example, you can have the world up vector be the local axis of some other
object such as a locator. You can then directly control the orientation of the
world up vector by manipulating the locator.

When attaching an aimed camera to a curve as a motion path, turn
off the Follow option.

Front Axis

Specifies which of the object’s local axes aligns with the front vector. This
specifies the frontwards orientation of the object as it travels along the curve.

X aligns the local X axis with the front vector, specifying the X axis as the
forward facing axis of the object.

Y aligns the local Y axis with the front vector, specifying the Y axis as the
forward facing axis of the object.

Z aligns the local Z axis with the front vector, specifying the Z axis as the
forward facing axis of the object.

Up Axis

Specifies which of the object’s local axes aligns with the up vector. This
specifies the upwards orientation of the object as it travels along the curve.
The up vector aligns with the world up vector specified by the World Up Type.

X aligns the local X axis with the up vector, specifying the X axis as the
upward facing axis of the object.

Y aligns the local Y axis with the front vector, specifying the Y axis as the
upward facing axis of the object.

Z aligns the local Z axis with the front vector, specifying the Z axis as the
upward facing axis of the object.

World Up Type

Specifies the type of world up vector that the up vector aligns with.
Selections include Scene Up, Object Up, Object Rotation Up, Vector, and
Normal.
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specifies that the up vector try to align with the scene’s
up axis instead of the world up vector. The world up
vector is ignored. You can specify the scene’s up axis in
the Preferences window. The default scene up axis is the
world space positive Y-axis.

specifies that the up vector try to aim at the origin of a
specified object instead of aligning with the world up
vector. The world up vector is ignored. The object whose
origin the up vector tries to aim at is called the world up
object. You can specify the world up object with the
World Up Object option. If no world up object is
specified, the up vector tries to aim at the origin of the
scene’s world space.

specifies that the world up vector is defined relative to
some object’s local space instead of the scene’s world
space. The up vector tries to align with the world up
vector after transforming it relative to the scene’s world
space. The object whose origin the up vector tries to aim
at is called the world up object. You can specify the
world up object with the World Up Object option.

specifies that the up vector tries to align with world up
vector as closely as possible. The world up vector is
defined relative to the scene’s world space. (This is the
default.) Use World Up Vector to specify the direction of
the world up vector relative to the scene’s world space.

specifies that the axis specified by Up Axis will try to
match the normal to the path curve. The interpretation of
the curve normal is different depending on whether the
path curve is a curve in world space, or a curve on
surface curve.

If the path curve is a curve in world space, then the
normal of the curve is the direction that points to the
center of curvature of the curve at any point on the
curve. This is best illustrated by the arrows in the
diagram below, which indicate the normal to the curve at
various points:
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Note that the normal to a curve will flip 180 degrees
when the curve changes from a convex to concave (or
vice versa) shape. This makes the Normal option for the
Up Direction not very desirable when using a world-space
curve in your path animation.

If the path curve is a curve-on-surface, then the normal
to the curve is the normal to the surface at that point on
the curve. The Normal option will give the most intuitive
results when the path curve is a curve-on-surface.

World Up Vector

Specifies the direction of the world up vector relative to the scene’s world
space. Because Maya’s world space is “Y-up” by default, the default world up
vector points in the direction of the world space’s positive Y-axis (0.0000,
1.0000, 0.0000).

World Up Object

Specifies the object the world up vector tries to align with if World Up Type is
set to Object Up or Object Rotation Up. For example, you could specify the
world up object as a locator that you can rotate as needed to prevent any
sudden flipping problems as the object moves along the curve.

Inverse Up
If this option is on, Up Axis tries to align itself with the inverse of up vector.
Inverse Front

Reverses the frontwards direction an object is pointing along the curve. This
is especially useful when you are trying to orient a camera so that it points
frontwards along a curve. For example, you have got the camera pointing
backwards along the curve, but are having difficulty getting the camera to
point frontwards. By clicking Inverse Front on, you can have the camera point
forwards along the curve as desired.



4 | Path Animation
Reference > Animate > Motion Paths > Flow Path Object

Bank

Banking means the object will lean in towards the center of the curvature of
the curve that it travels along (like a motorcycle going around a corner). The
bank option is only available if the Follow option is on, as banking also
affects the rotations of the object.

The path animation automatically computes how much banking should occur
depending on how curved the path curve is. You can adjust the banking using
Bank Scale and Bank Limit.

Bank Scale

If you increase the Bank Scale, then the banking effects will be more
pronounced. For example, if the Bank Scale is set to 2, then the object will
bank twice as much as the default that is computed.

Note You can enter a negative number for Bank Scale. This will cause
the object to lean out, away from the center of the curvature of the
curve, rather than in towards the curvature. For example, you could
use this in animating characters thrown from side to side in a roller
coaster.

Bank Limit

The Bank Limit lets you restrict the amount of leaning. For example, the Bank
Scale may be increased to obtain pronounced effects, but then this may
cause the object to lean too much where the curve is very curved. This option
will limit the leaning to the given amount.

Note No banking occurs where the curve is a straight line.

Animate > Motion Paths > Flow Path Object

Creates a flow path along the current motion path or around the current object.

Note The lattice created from a Paths > Flow Path Object will ignore
effects introduced by any motion path orientation markers. To
enhance the front, up, side twist of a path animation with flow,
animate the rotation of the flow lattice rather than using orientation
markers for the path animation.
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Animate > Motion Paths > Flow Path Object > 0
Divisions
These values represent the number of lattice sections that will be created.

The Front, Up, and Side correspond to the axes that were specified when the
path animation was created.

For example, if the path animation was created with the Front Axis set to Z,
and the Up Axis set to Y (in the Attach to Motion Path Options window). The
Side Axis is therefore the remaining axis, that is, the X axis. Then, the Front
Divisions will be the number of divisions in the lattice along the Front
direction, which in this case will be the object’s Z local rotation axis. Similarly
for the Up and Side Divisions.

Lattice Around
Object Creates the lattice around the object.
Curve Creates the lattice around the path curve.
Local Effect

This option is most useful when the you create the lattice around the curve. If
the lattice is large, you probably don’t want to have the lattice points at one
end of the lattice affect the object when it is close to the other end of the
lattice.

For example, if the Lattice Around Curve option is chosen, and the Front
Divisions is set to 30, this means that there will be 30 subdivisions of the
lattice from end-to-end of the path animation curve. As the object moves
through the lattice, it may only be surrounded by 4 or 5 divisions in the front
direction at any one time. If Local Effect is off, then all the lattice points in
the 30 subdivisions will affect the deformation of the object. This could
cause the object to “drift” out of the lattice since it is being influenced by
lattice points that are very distant from the object.

The two diagrams below show Local Effect for a Lattice Around Curve. In the
first diagram, Local Effect is on; in the second one it is off.

s

In general, if Local Effect is on, the Local Effect Divisions should be set to
approximately the number of divisions of the lattice that the object will cover.

Tip If you are using the Lattice Around Object option and set the
number of Divisions to a large number in order to have more
precise control over the object’s deformation, it may be a good idea
to set the Local Effect Divisions to cover a smaller part of the
object.
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Nodes

Animation nodes

motionPath

Many of the attributes on the motionPath nodes are the same as the options in
the Attach to Motion Path Options window. For all motionPath node attributes that
are not included in the following section, see "Animate > Motion Paths > Attach
to Motion Path” on page 272.

U Value

Displays where the motion path object is located in the parametric space of
the curve. This field is read-only.

Front Twist

Specifies the degrees of front axis rotation for the objects attached to the
motion path curve. This value is dependent on the current Front Axis.

Up Twist

Specifies the degrees of up axis rotation for the objects attached to the
motion path curve. This value is dependent on the current Up Axis.

Side Twist

Specifies the degrees of side axis rotation for the objects attached to the
motion path curve. The side axis is orthogonal to the front axis.
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About

Motion Capture Animation

Motion capture lets you generate large amounts of complex motion data that you
can use to animate your characters. You must plan your motion capture
animations meticulously and set them up very carefully. This chapter contains
information on working with motion capture data in Maya.

Note The Maya Device Editor is not available in Maya 7 for Mac OS X.

Motion capture devices

Motion capture devices

The motion capture device samples motion and records it. With a motion capture
device, you can achieve real-time monitoring and recording of data.

Device vendors provide servers for the data-server devices supported by Maya.
You can also write servers for custom devices using the Maya Motion Capture
Developer’s Tool Kit.

The mouse and keyboard are not motion capture devices.

Server

A server is a stand-alone program that communicates with a device. Maya can
talk to the server to get device data. Devices that require servers are called data-
server devices.

Example: mayaClockServer

To help you learn about motion capture, we’ve provided an example motion
capture server, the mayaClockServer program. This program reads the system
clock and outputs three rotation values in radians: the angle of the second hand,
minute hand, and hour hand. You don’t need special hardware. The
mayaClockServer can be found in the following location:

(Linux) /usr/aw/maya7.0/bin
(Windows) Drive:\Program Files\Alias\Maya7.0\bin

(Mac OS X) Doesn’t exist for the Mac. Its operating system has a .c file in
devkit/mocap.

To view mayaClockServer options, enter the following command from the
command prompt of the preceding directory:

mayaClockServer -h
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We’ve also included an example script for using mayaClockServer. To see a demo
of the clock, enter the following in the Maya Script Editor:

mayaClockDemo

The script launches mayaClockServer using the MEL system command, defines a
device named “clock,” creates three analog clock hands, and connects the
geometry to the clock.

Note If you have already defined the clock device, undefine it and flush
the undo queue before running the demo script.

Axis

A motion capture device provides information on different axes, arranged in a
hierarchy. Axes give important information such as if the data is a rotation value,
a translation value, or just a number. An axis can be connected (or attached) to
an attribute in a Maya scene.

Button

Some motion capture devices have buttons. A button can execute a command or
act as a clutch for an axis. However, button presses cannot be recorded as
motion capture data.

Attachments

The connection between a device axis and an object’s attribute is called an
attachment. The attachment informs the device which attribute in the scene you
want to change.

Since devices are not defined as dependency graph nodes, their definitions,
attachments, and mappings are not saved in Maya files.

Creating an attachments script lets you reload the attribute attachments,
command attachments, and mappings when you need them. This saves you
having to attach the device to each of its target attributes every time you load a
file. You must define the device before running the attachment script.

The MEL script will remake all attribute attachments, command attachments, and
mappings, provided the device is defined and the target attributes and nodes
have the same names as when you saved the script.

When an attribute attachment is formed, a node (blendDevice) is attached to the
target attribute. The blendDevice node determines whether you will view live
device data (Enable Monitor) or the animation curve that is attached to the
attribute.
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In this form, the data is stored in the blendDevice node. Playing over the
recorded time range will show the newly recorded data, leaving any animation
curves unchanged.

Warning It is possible to create multiple identical device attachments.
During a large motion capture, this can really slow Maya down.
Also, removing one of them will remove all of them. Do not create
the same attachments multiple times.

Virtual devices

It is not practical to connect a motion capture device to every machine on which
you want to view captured motions. Instead, you use a virtual device. A virtual
device behaves like a real device in review mode. You can make the same
attachments to a virtual device as to a real device. You can read take data into a
virtual device and apply it to the target attributes. Virtual devices cannot have
buttons.

Multiple devices

You can record and work with many devices simultaneously.

Use the Controls tab to set recording options for each device. To view a device’s
current settings, select the device name in the Device Outliner, then select the
Options tab.

e |f you do not want to record data for a device, turn off Enable Record in the
Controls tab.

e |f you do not want to apply data to the target attributes of a device, turn off
Enable Apply Take under the Controls tab.

Motion capture systems

The most important task of any motion capture is to plan every step in advance.
This is especially true for a large project.

Optical capture system

If you use an optical system, just bring the data into Maya. You will need to make
a virtual device to read in the motion. See Help > MEL Command Reference
documentation for information on the defineVirtualDevice command.

We recommend using a single format for all of the motion you import into Maya.
You can write a MEL script to define the virtual device that matches the data.
With this method, you have to explicitly define the virtual device only once; other
times you can run the script that calls the virtual device definition.
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If no filtering is needed, try using the MEL movin command. This does not require
the construction of a virtual device.

To use all of the take management features and filters, you must define a virtual
device and make attachments to it. Since most optical systems let you solve for
joint angles, you can use forward kinematics. For a skeleton constructed with the
same orientation as the solved optical skeleton, just attach the device to the
rotations of the joints.

Magnetic capture system

For a magnetic capture system, connecting the sensor axes to handles of RP of
MC IK solvers works well.

Motion capture process

Motion capture process

For each motion sequence you want to capture, there are three different phases
of the capture process: rehearse, record, and review. For each of these steps,
you use the Device Editor’s Controls tab.

Rehearsing the motion

You may want to have the performer rehearse the motion you're interested in
before you record. If the scene is simple, you may be able to view the motion in
real time.

Any animation curves attached to the target attributes are not affected by the
Rehearse mode.

Recording the motion

Use the Control tab in the device editor to record your motion capture data. See
"Controls tab” on page 304 and "To record motion” on page 295.

Defining devices

Most motion capture devices are data-server devices. To use a data-server device,
you need a server. For more information on using the server for a specific device,
see the documentation provided by the device vendor.

An important interaction exists between defining and un-defining data servers and
the undo queue.
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When you undo a defineDataServer command, the connection with the data-server
device does not break until the defineDataServer command is off the undo queue.
When you undo an undefine of a data server, the connection with the server does
not break until the command is off the undo queue. The easiest way to remove
the command from the undo queue is to use the flushUndo MEL command.

Mapping device data

Sometimes the data coming from the device is in the wrong unit system or needs
an adjustment to its scale or offset. You can modify the scale and offset values
for incoming device data using the Mapping tab of the Device Editor.

There are two types of mappings: attachment and device mappings. Both affect
the scale and offset of the device data. The device data is multiplied by the scale
term and then the offset is added.

e Attachment mappings apply to attribute attachments. These mappings are
recommended for motion capture work. You can undo them. See ”Attachment
tab” on page 299.

e Device mappings apply to axes. You cannot undo them.

Using device and attachment mapping together is error-prone and may produce
unintentional results.

Reviewing the motion

In the review phase, Maya applies the motion data you have recorded to the
target attributes. Your preview data is applied to all devices and axes that have
Apply Take enabled (as indicated by Enable Apply Take). Animation curves that
are attached to the target attributes are not affected at this time.

During the review phase, you can click Preview to view the take in a preview form;
this does not change the data.You can also click Apply Take to convert the take
to animation curves in the review phase.

Previewing a take

A preview is done automatically when you enter the review phase. This lets you
review the newly captured motion faster than by using Apply Take and leaves the
animation curves unchanged. Preview data is not visible in the Graph Editor.

Numbering takes

A particular motion may require three takes or more. Because it's hard to know
which take is best as you record and because creating unique names for each
version of the same move may cause errors, Maya provides an easy way to
number your takes.

Take numbering inserts a number between the move name and its extension (by
default, .mov). This number can be incremented to form a take number for that
move. The take filename is constructed by inserting the value of the Number box
before the extension of the name in the Take box.
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For example, if the Take box displays clock.mov and the Number box displays a
value of 2, the file is saved as clock.002.mov.

Converting a take to animation curves
Under the Controls tab, click Apply Take.

When you convert the take to animation curves, the new data replaces any
existing animation curves. Older data outside of the newly recorded time range
still exists, but any old data within the recorded time range does not.

When the take is converted to either preview form or animation curves, all device
mappings, attachment mappings, filters, and resamplers are applied to the take
data.

Filters and Resamplers

You can use filters and resamplers to affect your motion capture data. Filters and
resamplers let you achieve effects such as cleaning Euler angles or resampling
data to a specific frequency with a given kernel. You use the Filters tab to create
filters and resamplers.

Filters and resamplers are applied when you create a Preview, Apply Take, or
Review. You cannot apply filters and resamplers while you monitor devices, only
when you convert your data to animation curves using the Apply Take button or
convert it to blendDevice nodes using the Preview button.

A resampler may change the temporal values of the data; a filter will not.

Saving files to disk

You can write out a take as an ASCII file, then read the file back into the scene
and review it later.

Motion capture files use the .mov file format. This file format is called “move” in
the file browser. It is not related to any movie file format. For more information on
file formats, see “Supported file formats” in the Files Management chapter in the
Basics guide.

Since a single scene may have dozens of motions, you probably do not want to
save each move as a separate Maya file, especially after you have selected the
final versions of the motion. It is much easier to save only the motion as a
separate file.

Motion capture tips

Tips for full-body motion capture

With full-body motion capture, carefully thought-out sensor placement and
skeletal design are essential. For information on working with full-body motion
capture data in Maya, see "Create full body motion capture” on page 287.
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Tips for working with the data

You can create a character based on the actor’s body. If you are using a
magnetic system, you can place sensors on opposite sides of each of the actor’s
joints and record the sensor’s location at each placement. You can construct a
skeleton that has joints located between opposing sensor positions. If magnetic
noise is not a problem, this will produce an accurate representation of the actor’s
skeleton.

If this is not possible or the character is dissimilar to the actor, create a skeleton
based on the actor and solve for that skeleton. You can use constraints,
expressions, and connections to map joint rotations and the root position from
the actor skeleton to a character.

When you select a device using the Device Outliner, the Controls tab will show
the take information for that device.

It is worth taking extra time to ensure that your data is as clean as possible. For
optical systems, this mean rigorous calibration of both the space and the actor.
For magnetic systems, the freer the space of magnetic noise, the better the
result.

Create motion capture animation

Create full body motion capture

To create a full-body motion capture sequence

1 Select a motion capture device. The device can be real or virtual. See "To
define motion capture devices” on page 289.

2 Select a method for calculating the motion.

The method is device-dependent and may use inverse kinematics, forward
kinematics, constraints, or a combination of the three.
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Constraints method

Build a skeleton based on the actor’s proportions. If possible, digitize the
actor’s joint positions with your motion capture device.

Attach the performance skeleton to the device. See "To attach an attribute to
a device axis” on page 290.

Connect the performance skeleton to the character skeleton.
Rehearse the actions that you want to record.

Record the motion. See "To record motion” on page 295.
Review the recorded motion and insert it into your scene.

You can use the options in the Device Editor’s Control tab to review your
motion take.

To insert the motion data into your scene, select File > Import and select your
motion data file (.mov) from the file browser that appears.

Create simple motion capture

To create a simple motion capture sequence

1
2

3

'

Create a target geometry in Maya.

Attach the geometry to the motion capture device. See "To attach an attribute
to a device axis” on page 290.

Rehearse the motion for the actions that will be performed.
Record the motion. See "To record motion” on page 295.
Review the recorded motion and insert it into your scene.

You can use the options in the Device Editor’s Control tab to review your
motion take.

To insert the motion data into your scene, select File > Import and select your
motion data file (.mov) from the file browser that appears.
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Set devices

To define motion capture devices

1 Start the device server.

2 For data-server devices, use the defineDataServer command to define the
device in Maya.

3 Enter the following command in Maya’s Script Editor:
defineDataServer -device <deviceName> -server <serverName>;
Where:

e <deviceName> is a unique device name. Choose one that will be easy for
you to remember later.

e <serverName> is the name of the communication interface defined to
talk to the server, as defined in the server setup.

For example, if you started the clock device but it did not appear in the
Device Editor, you would enter:

defineDataServer -device clock -s mayaClockServer

To undefine a device

Use the following syntax:

defineDataServer -device <deviceName> -undefine;

Use the Device Editor

To expand or collapse an item

Click the arrow to the left of the item in the device outliner.

To expand or collapse all of the item’s children
Shift-click the arrow to the left of the item in the device outliner.
Example: Listing the mayaClock device

If you ran the mayaClockDemo MEL script, the clock name (clock) should be listed
in the left column in the Device Outliner. (If it is not, follow the directions in "To
expand or collapse an item” on page 289.)

To show all of the device’s children

Shift-click the arrow to the left of the clock name.

The first level of children in the clock are the three axes: hours, minutes, and
seconds.

For complex devices, an indented list of axes is displayed, each with its own
children. Eventually a device listing ends with attribute attachments. The
attachments describe how the device is connected to Maya attributes.
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Create attachments

To attach an attribute to a device axis

Warning It is possible to create multiple identical device attachments.
During a large motion capture, this can really slow Maya down.
Also, removing one of them will remove all of them. Do not create
the same attachments multiple times.

1 Select the Maya object.
In the device outliner, select the axis you want to attach.
3 Do one of the following:

e Under the Attachment tab, type the name of the Maya node that has the
attribute to attach in the Node box.

e Rightclick in the Node box to display a pop-up menu that lists all of the
selected nodes and pick the node you want.

4 Do one of the following:
e Type the name of the attribute in the Attribute box.

e Right<click in the Attribute box to display a pop-up menu that lists all of
the keyable attributes for the specified node and select an attribute.

5 Specify whether you want to make the attachment per Selection or per
Object.

6 If a device has a button, you can specify that a button acts as a clutch that
makes the connection only while the button is pressed. Select a button name
using the Clutch menu.

You cannot record a button press as motion capture data.

N

7 Click Add to make the attachment between the device axis and the attribute.
See "Attachments” on page 282.

To attach a command to a button

You can use command attachments with devices that have buttons. When you
press the button, the command associated with the button executes.

1 In the device outliner, select a button.

2 Under the Attachment tab, type the command you wish to execute in the
Command box.

3 Do one of the following:

e Turn Continuous on. When this option is on, the command executes
repeatedly when the button is pressed.

e Turn Continuous off. When this option is on, the command executes once
when the button is pressed.
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Note You can also execute a command every time any button is pressed
or released, or if any axis changes on a specified device. The
device must have at least one button.

To attach a command to a device value

1 In the device outliner, select a device with at least one button.

2 Under the Attachment tab, enter the command you want to execute whenever
any button on the device you selected is pressed or released, or whenever
any axis on the device changes value.

Edit attachments

To modify existing attachments

1 In the device outliner, select the attachment.
2 Change the attachment values.
3 Under the Attachment tab, click Update.

To delete a command attachment or an attribute attachment

1 In the device outliner, select the attachment.
2 Under the Attachment tab, click Delete.

Note Remember, a single axis may have more than one attachment. If
you accidentally delete an attachment, you can always undo the
deletion.

Prepare motion capture data

Prepare motion capture data

To specify how Maya interprets incoming take data
e Use the Options tab to set the units used in the take and time-stamping of
the data.

e |f a take has time-stamp data, turn on Time Stamps in the Read Take
Options section.

e |f you want to ignore time-stamp information, select Use Frequency in the
Read Take Options section and type a value in the Frequency box, in Hertz.
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e Since the .mov file format does not contain information about how data is to
be interpreted, the order of data in the take file is important. The order of
columns of data in the file must match the order of axes in the device.

e If you are creating a virtual device by hand, the order of definition is extremely
important and must match your data.

e |f time stamps were used with the write take, the first column of data is the
time-stamp information. The take is applied with the starting time as the
starting time of the recording.

e |f you turn on Use Current Time As Apply Take Start Time under the Controls
tab, Maya uses the current time as the start time for the take when you click
Preview or Apply Take.

Rehearse motion

To rehearse the motion

1 Select Enable Monitor to specify that the target attributes are receiving live
data from the device.

2 Under the Controls tab, select Rehearse.

Note When you switch from other phases, this step is performed
automatically for all devices.

Create attachments script

To create an attribute attachments script

1 In the device outliner, select the device, its axes, or its attachments.
2 Under the Controls tab, click Save Attachments.

3 Select a path and name for the attachments MEL script.

4

Save the script to your scripts path so Maya can see it when you want to re-
attach your scene.

Click OK.

The next time you load the scene, define the device, if needed, and run the
attachments script from the Script Editor.

» <

Create a filter or resampler

To create a filter or resampler

The following procedure applies to both filters and resamplers.

1 Rightclick the Active or Inactive Filters (or Resamplers) list and select the
filter (or resampler) name in the list to create it.
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The filter or resampler name appears in the Active or Inactive Filters list.

2 To view or change the attributes of a filter or resampler, double-click its name
in the list.

The Attribute Editor for the filter appears.

3 Rightclick the Active or Inactive Filters boxes and select the Euler filter. For
more information on the Euler filter, see “Graph Editor overview” in the
Keyframe Animation chapter of the Animation guide.

4 Right-click the Active or Inactive Filters boxes and select Simplify, Closest
Sample, Linear Interpolation, Box, Tent, or one of the Gaussian filters.

The selected resamplers are now listed in the box in the attribute Editor.

To make a resampler active

Click the resampler’s name in the Inactive Resamplers list and click the <<
button.

To make a resampler inactive

Click the resampler’s name in the Active Resamplers list and click the >> button.

Set virtual devices

To define a virtual device based on a real device

1 Select the real device in the device outliner.
2 Under the Controls tab, click Save Virtual Device.

3 Select the path where you saved the virtual device and specify a MEL script
name.

When you execute the MEL script, a virtual device is defined with the same
name as the real device. If you have attachment scripts, they will work with
the virtual device without any changes.

You can use virtual devices to import numeric data into Maya. In many cases,
you can use the movin command. However, if you are using filters or
resamplers, we recommend using a virtual device.

For more information, search the Help > MEL Command Reference
documentation for the defineVirtualDevice command.

To read data into a virtual device

Note Reading data into a virtual device is the same as reading data into
a real device.

1 Under the Controls tab, click Take File.
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4

The File browser appears.

Select the take you want read.

Click Read Take.

The take loads.

Click Preview or Apply Take to make the data visible in your animation.

Number takes

To number your takes

1

Under the Options tab, select Numbered Takes.

Whenever the Take box changes, the Number box is reset to the value in
Starting Take.

If you want to automatically increment the take number whenever a take is
written, also select Auto-Increment.

When your motion data looks good and you want to convert it to animation
curves, click the Apply Take under the Controls tab.

View takes

To view numbered takes

1

(2]

Click the Take File button and select a take file using the take browser that
appears.

Under the Controls tab, click Read Take to read the takes into the device.
Click Preview or Apply Take to view the first take.

To view the next take, change the value in the Number box to 2, click Read
Take and Preview.

To view the rest of the takes, repeat step 4 while increasing the number in
the Number box.

To view a take in preview form

1

2

Click the Take File button and select a take file using the take browser that
appears.

Under the Controls tab, click Preview.

Save preview data

To save preview data

Under the Controls tab, click the Write Take button (as described in "To save
a take to disk” on page 296).
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Warning If you save your scene to a Maya file, preview data is not saved as
part of the scene.

If you are doing a batch render, be sure to save the motion as
animation curves (using Apply Take). Otherwise the motion will not
be part of the render.

Create motion capture data

Record motion data

To record motion

1 Under the Controls tab, turn on Enable Record for each device you want to
record.

2 Make sure the Recording Duration box contains enough recording time (in
seconds) for your planned motion.

Tip It’s best to add a few more seconds to the duration. Also, start
recording before the actor begins a move.

3 Select Record.

All the record-enabled devices begin recording data, using the current time as
a start time for the recording.

Tip The recording frequency is determined by the device, not by the
frame rate of Maya.

Once the duration is met, the recording stops and advances to the review
phase. At this point, the data is not yet part of your Maya animation and is
not saved to a Maya file.

Data that you can preview or convert into animation curves is called a take.

Animation
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Tip

To stop a recording before the duration expires, select either
Rehearse or Review under the Controls tab.

Review takes you to the review mode, the same as if the duration
expired.

Rehearse doesn’t bring the device data into Maya.

If you accidentally chose Rehearse and want to see the motion in
your scene, click the Preview or Apply Take buttons. Click Preview
to create a preview version of the take; click Apply Take to make an
animation curve version of the take.

4 When you are ready to convert the take to animation curves, click Apply Take.

Warning If a device has a take and you select Record, that take is lost

unless you first click Write Take to save it or Apply Take to convert
it to animation curves.

To record multiple devices

1 Under the Controls tab, turn on Write Take on Review.
2 Specify a take name for each device.
3 Under the Options tab, select Numbered Takes and Auto-Increment.
With this method, each device automatically saves unique files for each take
and you don’t have to manually change the take number and take names.
Save takes

To save a take to disk

1 Under the Controls tab, click Take File.
A file browser appears.

2 If this is a new file, specify a path and a filename.
The base filename appears in the box. From now on, if the Take box changes,
the path stays the same and only the filename changes.

3 Once you have specified a valid filename, click Write Take to save the take to
disk.
A take name is required for each device.

Note If you want to save a take every time you enter the review phase,

select Write Take on Review under the Controls tab.
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Edit motion capture data

Edit motion capture data

To modify the scale or offset of your motion capture data
1 In the Device Outliner, select the axis or attachment you want to modify.
Select an axis if you want the Mapping tab to control a device mapping.

Select an attachment if you want the Mapping tab to control an attachment
mapping.

2 Under the Mapping tab, select Absolute or Relative mapping. See "Mapping
tab” on page 300.

3 If you are working with device mapping, select World space or View mode.
See "World” on page 301 or "View” on page 301.
To change the attachment and device mappings

You can change the scale and offset values in a mapping without affecting the
preview data or animation curves by doing the following:

1 Change the scale and offset values using the Mapping tab (as described in
"To modify existing attachments” on page 291).

2 Re-apply the take by clicking Preview or Apply Take.
To free the take data for all devices

After applying the recorded data, the take data is still in the take buffer. For small
takes this may not be a problem, but for large takes you may want to free this
memory.

e Under the Controls tab, click Clear.
You cannot undo this action.

Windows and Editors

Device Editor

Device Editor

The Maya’'s Device Editor lets you control the motion capture process. To display
the Device Editor, select Window > Animation Editors > Device Editor.

Animation
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Write Take Options

T —
Precision - Time Stamps

Numbered Takes Auto-Increment E Starting Take -

Read Take Opti

N ———
Time Stamps Use Frequency Frequency -

e "Device outliner” on page 298
e "Tab sections” on page 299
e "Resamplers” on page 305

Device outliner

The top section of the Device Editor is the device outliner. The device outliner
lists the defined devices, the device structures, and what the devices are
attached to. For information on how to use the device outliner, see "To expand or
collapse an item” on page 289.

ﬂ nayal lockserver

This is the only way to view how devices attach to their target attributes. Since
devices are not normal Maya dependency graph nodes, they do not appear in the
regular Outliner or in the Hypergraph.

The devices and their attachments appear in the following order:

e The left-most items in the device outliner are the devices.

Animation
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e The next level shows the axes, indented to indicate their positions in the
device hierarchy.

e The final level shows the attachments between the device and an attribute.

Tab sections

The lower section provides several tabs that allow you to work with devices and
manage motion capture data.

Attachment tab

The Attachment tab lets you create attachments. See "Create attachments” on
page 290.

/" attachment ™ Mapping X Rilters X Options X Controls

Device  [ayaciockServer | s

ez

Ll s
Selection > Object

There are two types of attachments: attribute attachments and command
attachments. An attribute attachment is a connection between an attribute and a
device axis. A command attachment is a command that is issued when a button
is pressed.

Device

Specifies the server name for the current motion capture device. See
"Server” on page 281.

Axis

Specifies the motion capture data type for the current device. See "Axis” on
page 282.

Clutch

Lists all available clutches for the current axis. The selected clutch acts as a
connection between a specified button and the axis.

Animation
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Node

Lists all available nodes for the current object. This list is unavailable when in
selection mode.

Attribute

Lists all keyable target attributes for the selected node. This attribute
attaches to the device specified by the current server.

Selection

Turns selection mode on or off. Select Selection if you want to make the
connection only for the currently selected object. This is useful when you are
interactively manipulating objects with an input device, but not for basic
motion capture work.

Object

Turns object mode on or off. Select Object for most motion capture purposes.
When you connect the device to a target attribute, that connection always
takes effect.

Mapping tab

The Mapping tab provides settings for modifying attribute attachments as
described in "Edit attachments” on page 291.

_/ attachment Y Mapping  Filters Y Options " Controls ™\

Device mayat lockServar Axis hours

Scale 1.86688 Offset 5.0088
Abzolute <> Relative

|

Warld & view

| kap I | Clear I

Device

Specifies the server name for the current motion capture device. See
"Server” on page 281.

Axis

Specifies the motion capture data type for the current device. See "Axis” on
page 282.
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Scale

Sets the increment at which the motion capture data is scaled.
Offset

Sets the offset of the motion capture data.
Absolute

Turns the Absolute motion capture data mapping type on or off. With absolute
mapping, motion is scaled and offset with respect to the origin. If you move a
device a foot away from the origin, the target attribute also changes its value
to be one foot away from the origin. Absolute mapping is useful for motion
capture.

Relative

Turns the Relative motion capture data mapping type on or off. With relative
mapping, motion is adjusted relative to the last device position without
regard to the origin. If you move a device one foot to the right, the target
attribute moves one foot to the right. Relative mapping is useful for desktop
input devices that always return to some resting position.

World

Turns World space device mapping on or off. We recommend world mode for
motion capture work.

View

Turns View mode device mapping on or off. If on, the device coordinates are
translated into the space of the active camera.

Filters tab

The Filters tab lets you define filters and resamplers that you can use when
previewing motion data or converting it to animation curves. See "To create a
filter or resampler” on page 292.
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Active Filters

Lists all the active filters for the current motion capture data. See "Filters
and Resamplers” on page 286.

Inactive Filters
Lists all the inactive filters for the current motion capture data.
Active Resamplers

Lists all the active resamplers for the current motion capture data. See
"Filters and Resamplers” on page 286.

Inactive Resamplers

Lists al the inactive resamplers for the current motion capture data.

Options tab

The Options tab has various options for writing and reading takes. See "To
number your takes” on page 294, "To view numbered takes” on page 294, and
"To record multiple devices” on page 296.
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_/ attachment Y Mapping ¥ Filters ¥ Options " Controls ™\

Write Take Opti
e i —
Precision Time Stamps [¥]

Numbered Takes [¥]  Auto-Increment [#]  Starting Take

Read Take Opti

Linar unt Pogutr s
Time Stamps [¥]  Use Frequency [¥]  Frequency | 30,8888

| Reset

I | Save I

Write Take Options

Linear Units
Angular Units
Precision
Time Stamps

Numbered
Takes

Auto Increment
Starting Take

Read Take Options

Linear Units
Angular Units
Time Stamps

Use Frequency

The take data is saved to disk in the specified 2
dimensional units.

The take data is saved to disk in the specified 3
dimensional units.

Sets the precision level of the units used to write the
current take.

If on, the take data is stamped with the current time
when it is saved to disk.

If on, the take data is assigned a number when it is
saved to disk.

If on, the takes that are saved to disk are automatically
incremented.

Specifies from what take to saved the motion capture
data.

The take data is saved to disk in the specified 2
dimensional units.

The take data is saved to disk in the specified 3
dimensional units.

If on, the take data is stamped with the current time
when it is saved to disk.

Sets the frames per second at which the data is written.
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Controls tab

The Controls tab provides the settings for rehearsing, recording, and reviewing
your motion capture sequences. These procedures are described in "Create
motion capture data” on page 295.

_/ attachment Y Mapping ¥ Filters ¥ Options Y Controls

<> Rehearse Recording Duration
<> Record Use Current Time As Apply Take Start Time E
Review | Freview I | Apply Take I | Clear I

Enable Monitor [_|  Enable Record [¥]  Enable Apply Take [+]

Play While Recording E | Save atftachments I | Save Virual Device I
= ReadWrite Take Controls
Take wanber [£7]
Write Take on Review (¥ [ wiitetake | [ ReadTake |

Rehearse

If on, sets the motion capture session to Rehearse mode. In rehearse mode
you can view the motion in real time before you record.

Recording Duration

Sets the length of time for your motion capture recording session. This field
uses the same units as those specified in your user maya environment
preferences.

Record

If on, sets the motion capture session to Record mode. In record mode, all
the record-enabled devices begin recording data, using the current time as a
start time for the recording.

Review

If on, you can preview, apply, or close the motion capture session. If you click
Apply Data, Maya applies the motion data you have recorded to the target
attributes and your preview data is applied to all devices and axes that have
Apply Take enabled (as indicated by Enable Apply Take).

Enable Monitor

If on, sets the target attributes to receive live data from the current device
when it is recorded.

Enable Record

If on, data is recorded for the device when Apply Takes is clicked.
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Enable Apply Take

If on, data is not applied to the target attributes of the device when Apply
Takes is clicked.

Play While Recording
The preview take plays while it records.
Save Attachment

Saves the device, axes, and attachments that are selected in the Device
outliner.

Save Virtual Device
Saves the real device selected in the Device outliner as a virtual device.
Read/Write Take Controls

Take Specifies the name of the current take.
Number Specifies the number of the current take.
Write Take on
Review Saves the current take to disk upon review.
Resamplers
Resamplers

With resamplers, you can resample data to a specific frequency with a given
kernel. You can also use resamplers to change the temporal values of your data.

simplify

Resamples groups of nearly colinear samples into two linear samples.
closest

Resamples samples at a fixed output rate using the closest sample.
linear Interpolation

Resamples based on a linear interpolation between two closest samples.
box

Resamples based on a moving average of the samples.
tent

Resamples based on a weighted moving average from the following formula:

1=
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gaussianSqrt

Resamples based on a weighted moving average from the following formula:
525

GaussianHalf

Resamples based on a weighted moving average from the following formula:

2
5 (-4x%)
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keys to a curve 109
sound 43
adding tracks to characters 220
aligning animation 259
Animated Sweep 26
Construction History 49
enabling 49
using 47
animation
basics 19
blending 212
controls, overview 32, 49
curve segments 71
cycle curves 125
cycle with offset curves 126
driven key, overview 19
hotkeys 175
keyframe, overview 19
motion capture, overview 19
moving 33
muting 23
nonlinear, overview 19
path, overview 19
playback 20
Playblast 41
previewing 20
scaling 33
sound 24

animation curves
constant 126
Graph Editor 71
linear 126
oscillate 126
post 125, 147
pre 125, 147
tangents 71
Animation End Time 51
animation preferences
editing 31
Animation Snapshot
Construction History 27
enabling 49
generated geometry 26
using 46
Animation Start Time 51
Apply Take button 286, 294, 296
Attach to Motion Path 261
attaching
commands to buttons 290
attachments
creating 290
mappings 285
modifying 291, 297
motion capture 282
saving 292
script 282, 292
Attribute box 290
audio files
deleting 45
importing 43
playing 44
audio nodes
sound options 45
audio playback
settings 45
Auto Frame 122, 147
Auto Key 67
using 89
Auto Load 139
Auto-Increment option 294, 296
axes
motion capture 282

Animation
307



Index

B By time option 170
bake channel 127, 148
Bake Simulation c
by time 170 Center Current Time 122

disable implicit control 171 Dope Sheet 147
Keep Unbaked Keys 170

Change Rotation Interp 129, 148
Sparse Curve Bake 171

changing

bakrg o current time 32
?)’SI . s device mapping 297
simulations playback range 33
Bank 277

channel offsets

Bank Limit 277 how to set 210

Bank Scale 277

channels
basics copy settings 158, 163, 166, 168, 169
animation 19 Driven Channels 170
blending Graph Editor 143
clips 212 muting in Dope Sheet and Graph Editor 99
bookmarks 139, 152 unlocking 77
break tangents 134 character sets
Breakdown, convert to 90 creating from the Trax Editor 193
Breakdowns Character(s) Clips & Poses
convert to 90 Visor 191
creating 90 Chord Length
options 90 knot spacing, for Loft 64
overview 69 clamped tangents 137
setting 90 Clear button 297
buffer curves Clip Time 122
show 123 Clipboard Start
buttons Paste 231
attaching commands 290 clips
motion capture 282 copying 199
By Attribute Name Creating 196
Export Character Map 229 Cycle attribute 257
Paste 230 disabling 208
By Attribute Order duplicating 200
Export Character Map 229 editing animation curves 218, 220
Paste 231 Enable attribute 254
By Character Map importing 223
Paste 231 merging 207
By Current Map Paste Clip 249
Export Character Map 229 splitting 206
By Node Name clips, creating a group 221
Export Character Map 229 clock server 289
Paste 231
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Draw Style 62

Driven Channels 170

driven keys 69
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Flow Path Object 259

Lattice Around 278

limitations
curve normalization 128

Linear 237
Blend 236

linear setting
animation curves 126

linear tangent 136
linking

multiple attributes 69
List menu 139
Local Effect 278
Lock 240
lock tangent weight 134
locking tracks 240

mangled animation curves 71, 100

Map Method
Export Character Map 229
mapping 285
absolute 301
attachments 285
changing 297
device 286, 297
devices 285
handler 286
relative 301
tab 297
mayaClockServer program 289
modifying
key attributes 74



motion capture 71, 100

animation overview 19
attachments 282

axes 282

buttons 282

creating attachments 290
description 281

Device Editor 289, 297
editing data 297

file format 286
full-body capture 287
magnetic 284

multiple devices 283
numbering takes 285
optical 283

preparing data 291
previewing 285
process 284

recording 297
recording motion 284
rehearsing 284
resamplers 286, 305
reviewing motion 285
saving files to disk 286
servers 281

setting devices 289
stopping recording 296
systems 283

tips 286

virtual devices 283, 293

motion path

animating along 263

animating along a surface 266

animation overview 259
creating 261

deforming an object 269
deleting 262

editing 262
manipulator tool 264
markers 270

orienting an object 268

Motion Trails

creating 36
overview 22
snapping to 37

Index

Move Nearest Picked Key Tool 139
Dope Sheet 153

Move Tool 144

Dope Sheet 157
moving keys on a curve 109
mp3 audio files 25
multiple devices

motion capture 283
Mute 240
Mute All 23
mute node 23

turning on or off 36
Mute Selected 23
muting

examples 23
muting animation 23
muting channels in Dope Sheet and Graph Editor 99
muting tracks 240

Name

Merge 232
Node box 290
nodes 282

motionPath 279

mute 23

nonlinear animation 254
nondestructive animation 216, 217
nonlinear

animation overview 19
Normal 275

normalize
curve limitations 128

Numbered Takes option 294, 296

numbering
takes 285

NURBS
path animation 259

o

Object option 300

Animation
313



Index

Object Rotation Up 275
Object Up 275
objects

Dope Sheet 155
offset values

mapping 285, 297
Once selection 55
opening

Set Driven Key 91
optical systems 283
options

set key 74

Unghost Selected 61
Options menu

Dope Sheet 151

Graph Editor 139
oscillate

animation curves 126
Oscillate selection 55
out tangent

Select menu 125
Outliner

Device 298
outliner

Dope Sheet 155
outliner separator 143
outliner split control 143
overview

animation controls 49

Breakdowns 69

driven key animation 19

driven keys 68

ghosting 20

Inbetweens 70

keyframe animation 19

motion capture animation 19

Motion Trails 22

nonlinear animation 19

path animation 19

P

Parametric Length 272
parametric length method 272

Animation
314

parametric space method 272
Paste
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QuickTime 57

sound 42
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post
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pre
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preferences

animation 31
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Preview button 294
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Read Take button 294
Record button 295, 296
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Rehearse button 292
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summary
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