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Reading for Lab 8:  

• Chapter 2 of Computer Programming Fundamentals with Applications 
in Visual Basic 6.0 (p. 27-50) 

• Chapter 3 of Computer Programming Fundamentals with Applications 
in Visual Basic 6.0 (p. 59-67) 
 

• OR  
 
Chapter 3: Performing Operations and Storing the results from The 
Visual Basic Coach.  This is on e-Reserve at the library: 
https://eres.lib.washington.edu/coursepage.asp?cid=1113&page=01 

 
We will be placing readings for labs on electronic reserve.  When they are 
available, a link will be placed on the lab pages as well as on the Readings 
page of the course site.  The books are also on reserve at Odegaard for 
student use. 
 
Introduction: 
The purpose of this lab is to introduce you to the VB Integrated Design 
Environment (IDE) and to create a simple VB project. The IDE is the 
programming environment where you create applications. A VB project is the 
collection of files created when you are working on an application. Your TA will 
go through this environment with you in lab. 
   
Objectives: 

1. To become familiar with the development environment for Visual Basic 
2. To work with programming objects and be able to identify them by 

their name properties. 
3. To create a simple working program. 

 
To Do: 

1. Create a New Project and Form 
A. Open Windows Explorer.  Create a folder called Lab8_yourname 

on the Desktop 
 



B. Open up Visual Basic 6.  
Start>Program Files>Microsoft Visual Studio 6.0>Microsoft 
Visual Basic 6.0   
When you start VB you will be presented with a “New Project” 
dialog box. Select the default project type, “Standard EXE”.  

 
 
 
 
 
 

 
 

C. Rename your project:  
Each time you begin a project, the default name, Project1, appears at 
the top of the form. To change the name, choose  
Project> Project1 Properties,  
and then type in your name as the new project name.  

 
D. Rename the form:  

To change the form name, click on the Properties window (or press F4) 
to bring it into focus. Name is the very first property. Select this 
property field and type in “frmFirst”.  
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The Visual Basic Integrated Development Environment (IDE) 
The IDE typically contains the menu bar, the tool bar, the toolbox, 
and three other tool windows: Form, Project, and Properties. 

 

**NOTE**  
When working with objects in VB, it is important to realize that there are 
many properties associated with them. Even the form on which you 
design your application is an object (and has over 50 properties that can 
be set). 



 
 
 
 
 
 

E. Notice that the title bar of the form still says “Form1”. To change this 
text, select the Caption property and type in “My First VB Program”.  

 
F. Make the form a little bigger on you screen by clicking on one of the 

corners and dragging outwards. 
 

2. Add Objects to the Form and Name Them 
A. Use the toolbox to add the following objects to your form: 

• A Text Box 
• A Label  
• (4) Command Buttons 

 
 
 
 
 
  
 

To add each object, click once on the tool in the tool box.  Then go to 
the form and hold down the left mouse button as you “draw” the 
object onto the form. 
 

B. Following the same directions for changing the form name, change the 
NAMES of each of the objects and their captions.   
 

• Name the Text Box: txtATextBox  
Change the Text to: This is a text box 
 

• Name the Label lblALabel: 
Change the Caption to: This is a label 
 

• Name the first Command Button: cmdClick  
Change the Caption to:  This is what you click! 
 

• Name the second Command Button: cmdGreen  
Change the Caption to:  Green! 
 

• Name the third Command Button: cmdYellow 
Change the Caption to:  Yellow! 
 

• Name the fourth Command Button: cmdVisible 
Change the Caption to:  Visible! 

 
3. Manipulate Object Properties 

A. Go through the properties of each object, including the Form, and 
change the background colors.  Use the Backcolor property and work 

**WARNING**  
Do NOT create a controlled array!  If you create one  
command button and then copy and paste it onto the form,  
the question of creating a controlled array will pop up.  Say No. 



with the Palette tab to select a color. 
 

• Make the frmFirst form blue 
 

• Make the cmdClick button purple (NOTE: You must first 
change the Style property to Graphical) 
 

• Make the cmdGreen button green (NOTE: You must first 
change the Style property to Graphical) 
 

• Make the cmdYellow button yellow (NOTE: You must first 
change the Style property to Graphical) 
 

• Make the cmdVisible button lilac (NOTE: You must first 
change the Style property to Graphical) 
 

• Make the lblALabel label red 
 

B. Using the Font property, change the font style of each object that has 
a caption to something different (use your favorite font on all of 
them). 

 
C. Now that you have added all of these objects to your form, let’s “run” 

the program to see what it looks like. 
• Click on the Run icon on the Tool Bar, or go to Run>Start… 

on the menu bar. 
 

  
 
• Try clicking the cmdClick button.  Notice that you can click 

the button, but nothing happens.  That is because we have 
not added any code into our program so that something will 
happen when a user clicks the button.  You will learn more 
about the event handler procedures that are used to control 
a program in the next lab. 

 
D. Click on the Stop button to end the program. 

 

 
 

 



4. Saving the Project and Form 
A. Before we proceed, save your project to the Lab8_yourname folder on 

the C drive so you can ftp it later). Notice that you are prompted to 
save not just the form, but the project as well. 

 
• Since you already named our form frmFirst, you can just 

click OK to save it. 
 

• You have named your project with your name.  Your name 
should come up in the window.  Click OK to save it. 
 

• Your entire project, consisting of the form and the project 
space, is now saved.  You will have 2 files associated 
with your project.  One for the form and one for the 
project.  The extension on a form file is .frm and the 
extension for a project file is .vbp. 

 
 
 
 
 
 
 
 
B. Close the frmFirst form. 

 
 

5. Creating ExactTime 
Now that you have had time to get familiar with forms and other objects in the Visual Basic 
IDE, we’ll create a little program that uses a bit of code to do display the date and time in 
our form. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

**NOTE**  
You will use this project in your next lab, so make sure you ftp 
your work to your Dante account, or save it to disk.  I would 
suggest that you simply upload the entire Lab8 folder you 
created to hold this work to your Labs folder on Dante. 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A. Open a New Project in Visual Basic: 
• File>New Project…(your first project, that you have saved, 

will now be closed.  Select yes to save changes) 
• Double click on Standard EXE 

 
B. Change the Project name to ExactTime  (go to Project> Project1 

Properties).   
 

C. Change the form name.  This time (no pun intended), change the 
name property for the form to frmClock.   
 
Do not change the caption property right now-we’ll deal with that in a 
moment. 

 
D. Use the Tool Box to place a label on the form.  Name the label 

lblTime.  
• Select a better font, and enlarge it to approximately 20 

points. 

A digital clock with the date on the window bar: 
 

This Time. This is a simple digital clock program with the date on the 
window bar. Your goal with the digital clock is to create a simple VB6 
program. The essential features are: 
 

• Change the form name.  
• Change the caption on the window bar.  
• Place and use a label control.  
• Place and use a timer control.  
• Customize the window to be attractive.  
• Save the project and form files. 

 
Each of these features will be discussed below. The ExactTime application 
has the following window interface: 

 

 
 

The VB environment allows you to change the properties for each object in 
the properties window.  However, if you just use the properties window to 
make those changes (i.e. changing the background color, etc.) your program 
won’t be very exciting.  We can attach code to a particular object event so 
that at run-time (when the program is executed by a user), it will react in 
pre-coordinated ways. 
 
There are many properties and events associated with objects in VB.  One of the events 
that occur whenever someone opens up a form and runs it is the FORM LOAD event.   



 
E. To change the caption of the form, you will do something a little 

different than just changing text in the properties window.  
 
The caption on the form’s window bar is to be assigned the current 
date at the time the window is loaded. Therefore, the "Form_Load" 
event should be customized to assign the date to the caption. The 
following code will do that (add this code after following steps 6A and 
6B: 

 
Private Sub Form_Load() 

 
frmClock.Caption = Date 

 
End Sub 

 
  
 
 
 
 
  

6. Attaching code to an object 
 

A. To open the code window for the form, go to View>Code.  Or, simply 
double click on the Form object. 
 

 
 
 
 
 
 
 

**NOTE**  
Your code window will look similar to the above graphic.  The drop 
down menu on the left allows you to select the object you wish to 
work with (your form). 
 
Objects will usually be listed by their Name property EXCEPT the 
form object, which will always be identified as Form. 

 
The drop down menu on the right is the list of events and procedures that can 
be associated with the various objects in your program.   

Date is a function that returns the current system date in 
the default format mm/dd/yy. When the form is loaded, the 
current date will appear on the window bar. 

 



 
 
 
 
 
 
 
  

 
B. Select the Form object from the left drop down menu and the Load 

event from the right drop down menu. 
 

 

 
 
 
 

C. Save your project to the Lab8_yourname folder.  You already named 
the project and form so you should be able to click OK to save both 
with the correct names:  
  
ExactTime for the project 
frmClock for the form 
 
You are prompted to save the form first, and then the project.  When 
you have saved both, two files are created:  ExactTime.vbp and 
frmClock.frm. 
 

D. Run your program to see if the date shows up in the form caption.  
When you see that it works, stop the program to add more objects. 

 
7. Adding a Clock/Timer Object and Using the Timer Event 

A. Use the Tool Box to place a Timer somewhere on the form (it will be 
hidden when you run your program).   
 

B. Change the Name property of this control to tmrTime. 
  

C. Set the interval property to 1000, i.e. the timer should "go off" every 
1000 milliseconds (1 second).  

 

**NOTE**  
Once you select each of these options from the 
list, the following text appears.  This is standard 
in VB.  By default, when you select an object 
and select an event procedure, the first and last 
lines of code that you need to have for that 
procedure are added in for you.  You will type in 
all relevant code between those lines.  Now, add 
in the code that you need from step 5E. 



D. Go to the code window and select the tmrTime object from the left 
drop-down menu and the Timer event from the right.   
 
The time event should cause the caption on the label to be set to the 
computer’s time. Add the following code to do that: 

 
Private Sub tmrTime_Timer() 
 

lblTime.Caption = Time 
 

End Sub 
 

REMEMBER!!!! VB adds in the start and end lines of code for the 
event, so you should only have to type one line of code!!! 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

E. Change the properties of the window to be attractive. This includes: 
• Change the form’s background color.  
• Shrink the window so that it nicely frames the time symbols.  
• Change the background color of the label to match the 

background of the window.  
• Change the color of the font of the label (ForeColor Property) to 

be attractive and to contrast nicely with the window’s 
background.  

• Set the starting position property of the form to be the center 
of the screen. (Use the Form Window in the lower right of your 
screen) 

 
F. Save your project again.  
 
G. When completed, compile your program.  Go to File>Make 

ExactTime.exe. That operation will make another file in the directory 
where you have stored your ExactTime project.  
 
This is the ExactTime.exe file. To run your program, go to Windows 
Explorer, to the Lab 8 folder where it is saved and double click on the 
ExactTime.exe. 

 

Time is like Date, a function that returns a variant indicating 
the computer system time in HH:MM:SS format.  
 
What happens is this:  
 

The timer "goes off" every second. That event causes 
the procedure "tmrTime" to be called. It changes the 
caption of the label to the current time. Whenever 
anything on the form is changed, the window is 
"repainted," i.e. redisplayed. Since most of the 
information is unchanged and remains in a fixed 
position, the clock appears to be ticking. 

 



H. SFTP your work to a folder on your Dante account.  You DO NOT need 
to put these projects inside your public_html folder.  They can go in a 
folder that you designate for Lab work or Project work. 

 
I. Show your executable to your Instructor before leaving or at the 

beginning of the next lab. 
 

J. Remember to log off the machine as you leave. 
 

 
 

8. Lab Notebook Questions 
A. Write an explanation, as best you can, of what an event is in the real world and how 

events are used in the computer world. 
 

B. What is the difference between the Name of an object and its caption? 
 
C. Why are names so important when programming? 

 
 


