Table of Contents

1 Introducing Fur. ......................................................... 11
   About Fur ............................................................... 11
      Fur Overview ....................................................... 11
      Related topics .................................................... 11
      Fur workflow overview .......................................... 12
      Preparing the scene .............................................. 12
      Creating and attaching fur to models ....................... 13
      Modifying fur attributes ....................................... 13
      Animating fur attributes ...................................... 13
      Adding movement to fur ....................................... 14
      Setting up shading effects .................................... 14
      Rendering the scene ........................................... 14
      Refining settings ............................................... 14
      Fur Presets ....................................................... 14
      Related topics ................................................... 14
   How do I? Simulate fur ............................................. 17
      Load Fur ............................................................ 17
      Related topics ................................................... 18

2 Creating and modifying fur ...................................... 19
   About Fur ............................................................... 19
      Preparing polygon and subdivision surface models for fur . 19
      Related topics .................................................... 20
   How do I? Simulate fur ............................................. 20
      Create and modify fur .......................................... 20
      Create fur ......................................................... 20
      Use Fur Presets .................................................. 22
      Related topics ................................................... 22
      Delete fur .......................................................... 24
      Attach and detach fur ......................................... 24
Table of Contents

Select the surfaces a fur description is attached to ..................... 25
Select which UV set to use for Fur (polygons only) .................... 25
Preview fur using fur feedback ............................................. 26
    Hiding and showing fur feedback ..................................... 27
    Define fur feedback attributes ..................................... 28
Reverse fur normals ........................................................... 29
Offset the direction fur grows ............................................. 30
Change fur attributes .......................................................... 31
    Edit fur descriptions ..................................................... 31
    Paint fur attribute values ............................................. 33
    Map fur attribute values .............................................. 40
    Update fur maps .......................................................... 46
    Remove maps from fur attributes ..................................... 47
Make fur clump together ...................................................... 47
Copy fur descriptions into other scenes .................................. 49
    Related topics .............................................................. 49

Nodes ....................................................................................... 50
Fur nodes .................................................................................. 50
    Fur Feedback Shape node ................................................ 50
    Related topics ................................................................. 50
    Render Stats. ................................................................. 52
Fur Description node ............................................................. 53
    Related topics ................................................................. 53
    Details .............................................................................. 65

Menus ....................................................................................... 66
Rendering menu set .................................................................... 66
Fur ......................................................................................... 66
    Fur > Attach Fur Description ............................................... 66
    Fur > Edit Fur Description .................................................. 66
    Fur > Paint Fur Attributes Tool .......................................... 66
        Fur > Paint Fur Attributes Tool > .................................. 66
    Fur > Update Fur Maps ...................................................... 67
    Fur > Fur Description (more) ............................................... 67
Table of Contents

Fur > Reverse Fur Normals ..................................................... 68
Fur > Offset Fur Direction by .................................................. 68

3 Animating fur attributes ..................................................... 69
   How do I? Simulate fur ......................................................... 69
   Animate fur attributes ....................................................... 69
   Make fur grow ................................................................. 70
   Make fur spread using animated file textures ......................... 72

4 Adding movement to fur ..................................................... 75
   How do I? Simulate fur ......................................................... 75
   Add movement to fur ......................................................... 75
   Add movement to fur ......................................................... 75
   Create attractors ............................................................. 76
   Create a grid of attractors on a surface ................................. 77
   Create a single attractor at the selected point(s) or face(s) ........ 78
   Create a single attractor at the origin .................................. 80
   Create an empty attractor set ............................................. 82
   Delete attractors and attractor sets ..................................... 83
   Attach and detach attractor sets ......................................... 83
   Select the surfaces an attractor set is attached to ..................... 83
   Display feedback for the attractor set .................................. 84
   Select attractors ............................................................... 84
   Add attractors to a set ....................................................... 84
   Remove attractors from a set .............................................. 85
   Change attractor set attributes .......................................... 85
   Edit attractor sets ........................................................... 85
   Paint attractor set attribute values ..................................... 86
   Map attractor set attribute values ...................................... 88
   Manually keyframe fur movement ....................................... 89
   Keyframe simple chain attractors with linked joint rotations ..... 89
   Keyframe IK chain attractors .............................................. 92
   Make fur move using dynamics ........................................... 96
   Move attractors by connecting forces to attractor particles ....... 97

Fur
5
Move attractors by moving the surface they are attached to . . . . . . . 101

### Reference

**Nodes** .......................................................... 105  
**Fur nodes** .................................................... 105  
Fur Attractors node ........................................... 105  
Details .............................................................. 108  
Related topics .................................................... 109  

**Menus** ............................................................. 109  
**Rendering menu set** ........................................... 109  
**Fur** ................................................................. 109  
Fur > Create Attractor .......................................... 109  
Related topics .................................................... 110  
Fur > Edit Attractor Set ......................................... 110  
Fur > Enable Feedback for ...................................... 111  
Fur > Attractor Set (more) ..................................... 111  

### 5 Adding fur shading effects .................................. 113

#### About

**Fur** ................................................................. 113  
Adding fur shading effects .................................... 113  
Fur shading with the mental ray for Maya renderer .......... 113  
Fur shading with the Maya Software renderer ................. 113  
No shadows or shading ........................................... 114  
Simple fur shading ................................................. 114  
Fur depth map shadows .......................................... 115  
Related topics .................................................... 116  

#### How do I?

**Simulate fur** .................................................. 116  
Create fur shading and shadows using the mental ray for Maya renderer .......................................... 116  
Create fur shading and shadows using the Maya Software renderer ................................................. 117  
Adjust the light intensity on fur ................................ 118  
Remove fur shadowing attributes from a light ............... 119  

### Reference

**Nodes** .......................................................... 120  
**Fur nodes** .................................................... 120  

---

Fur

6
### Table of Contents

light Shape node .................................................. 120
Fur Shading/Shadowing attributes .................................. 120
Related topics .................................................. 121

**Menus** .......................................................... 124
**Rendering menu set** ........................................... 124
**Fur** ............................................................. 124
Fur > Fur Shadowing Attributes .................................. 124
Related topics .................................................. 124

**6 Rendering scenes with fur** .................................... 125

**About**

**Fur** ............................................................. 125
Rendering scenes with fur ......................................... 125
  Advanced fur rendering .................................. 125
  Rendering fur in the Maya software renderer vs. mental ray for Maya . 126

**How do I?**

**Simulate fur** .................................................. 127
**Render scenes with fur** ........................................ 127
Set up Fur Render Globals before rendering .................. 127
  Setting up Render Stats for each fur description ........ 128
Render scenes with fur ......................................... 128
  Render a single frame with fur ........................... 129
  Render an animation with fur ............................. 129
  Render using distributed render ........................... 131
Build fur files separately (Maya Software renderer only) .. 131
Build equalizer maps separately ............................... 132
Build shadow maps and fur images separately
  (Maya Software renderer only) ............................. 133
Invoke Advanced Fur Rendering from the Script Editor or
  MEL prompt .................................................... 133

**Reference**

**Windows and Editors** ........................................ 135
Fur Globals .................................................. 135
  Related topics ............................................. 135
  Fur Render Options ...................................... 135
  Reference Paths ........................................... 140
# Table of Contents

- Advanced Fur Rendering .................................................. 142
- Related topics ................................................................. 144

## Nodes ................................................................. 144

### Fur nodes ............................................................... 144
- Fur Feedback Shape node .................................................. 144
- Render Stats. ................................................................. 144
- mental ray ................................................................. 145

## Menus ................................................................. 146

### Rendering menu set ................................................... 146

## 7 Fur samples and techniques. ........................................ 149

### How do I? Simulate fur .................................................. 149

#### Create body fur, whiskers, eyelashes and other Fur effects .. 149
- Create body fur, whiskers, and eyelashes ............................. 149
- Add body fur ............................................................... 149
- Add whiskers .............................................................. 153
- Add eyelashes ............................................................. 155

#### Part fur .................................................................. 158

#### Work on an animation project ....................................... 159

## 8 Troubleshooting Fur ................................................... 161

### How do I? Troubleshoot Fur ............................................ 161

#### Troubleshoot general Fur issues ..................................... 161
- When I comb my Fur, nothing happens ............................... 161
- I painted Direction and now I want to reset it to the default, but I can't find a Direction map to delete! ....................... 161
- When painting direction on polygons, sometimes the Fur does not follow the direction of my brush ............................. 161
### Table of Contents

When I execute a distributed render, or render my sequence in sections, the Fur seems to shift slightly between the sections. ................. 162

I mapped an attribute in the fur description and baked it, then I broke the connection, but the fur still renders as though the map is connected. 162

Fur seems to be flipping or crawling on my deforming polygon surface. . 162

My disk is filling up with zillions of fur files - what can I do? . . . . . 163

Fur seems to be flipping, crawling or is incorrectly placed on my animated trimmed surface. ................................................... 163

My rendered fur does not follow the contours of a surface that has a displacement map applied. .............................................. 163

I can't seem to paint values such as length to be greater than 1. . . . 163

Troubleshoot rendering Fur in the Maya Software renderer ........ 164

When I render, if I zoom in, I can sometimes see a tiny gap in the alpha channel where the Fur grows out of the surface. ................. 164

When I render, there is a faceted gap between the edge of my NURBS surface and the hair growing out of it. .............................. 164

When a non-furry object passes in front of a furry object, there is a fringing effect around the foremost object. ............................. 164

My Fur render is extremely slow - is there anything I can do to speed it up? ............................................................... 165

How can I render Fur through refractive material - for example, an eyebrow and eyelashes through spectacles? ...................... 165

I can only use Advanced Fur Rendering within the interactive package. Can I render just the fur images using the batch renderer? 165

I'm running out of memory when using Fur. Is there anything I can do to optimize memory usage? ............................ 166

My Fur seems way too bright, especially the specular highlights. Can I fix this? .......................................................... 166

Troubleshoot rendering Fur in mental ray for Maya ................. 166

I have the same fur description applied to multiple patches on a model, but the density appears uneven across the various patches in the render. Can I fix this? ........................................ 166

When I render in mental ray, the quality of Fur is very poor compared to the Maya software renderer. ............................... 167

### Index

169
1 Introducing Fur

Fur Overview

Fur is a component of Maya Unlimited that you use to create realistic, self-shadowing fur and short hair on multi-surface NURBS, polygonal and subdivision surface models. You can set fur attributes, such as color, width, length, baldness, opacity, scraggle, curl, and direction globally, or map them on a local basis.

Using Maya Artisan, you can paint most fur attributes directly onto the surface and actually comb the fur and make clumps.

Using an attractor system, you can also keyframe fur movement, or have fur react to dynamic forces within Maya.

Fur commands are located in the Rendering menu set in the Fur menu. There is also a Fur shelf available that contains “Fur Presets”.

To get started quickly using Maya Fur, do the lessons in the Fur chapter of Getting Started with Maya Unlimited.

Related topics
- “Load Fur”
- “Fur workflow overview”
Fur workflow overview

To add realistic looking fur to your models, you would perform the following basic steps:

• prepare the scene
• create and attach fur to models
• modify fur attributes
• if you are animating the scene, animate fur attributes
• if you are animating the scene, add movement to fur
• set up fur shading effects
• render the scene
• refine settings and render again

Preparing the scene

Prepare your scene as you would any scene you render, keeping in mind the following:

• You can put fur on all surfaces: NURBS, polygonal and subdivision surfaces.

  To put fur on a polygonal or subdivision surface, the surface must have good UVs (non-overlapping, and between 0 and 1 in the texture space). See “Preparing polygon and subdivision surface models for fur” on page 19.

  There are some limitations with fur on subdivision surfaces:
  • Direction painting does not work correctly. Paint the Polar attribute instead.
  • There is no color feedback for subdivision surfaces in the Paint Fur Attributes Tool.
  • You cannot attach a grid of attractors to a subdivision surface. You can, however, attach attractors to selected subdivision surface faces.

  Due to these limitations, for major character work involving fur, you may want to convert your subdivision surfaces to polygons.
  
  • Trimmed surfaces take longer to render.
  • The scene uses the default light if there are no other lights in the scene. You may need to modify the lighting in your scene to achieve the fur effects you want. For example, you must modify the lights to create fur shading effects. See ”Adding fur shading effects” on page 113.
If you want to be able to have people work on a character’s fur and animation simultaneously, you may want to reference your models. This must be done before you start the project. See “Work on an animation project” on page 159.

Creating and attaching fur to models

You typically create fur by attaching a new fur description to selected surfaces. A fur description defines all the attributes for a particular type of fur, for example, fur color, width, length, baldness, opacity, scraggle, curl, density, and so on. You can also create unattached fur descriptions and attach them manually. And you can use “Fur Presets”.

You can attach one fur description to many surfaces, which is a good idea when you have many surfaces with a similar fur type. You can make adjustments to the fur attributes using the Paint Fur Attributes Tool or by mapping. See “Paint fur attribute values” on page 33 and “Map fur attribute values” on page 40. For example, for a model of a cat you could apply a fur description called bodyFur to all the surfaces making up the cat’s body, legs and head, and paint or map attribute values to make the fur longer, shorter, or more scraggly, on specific areas.

You can also attach more than one fur description to a surface. In the cat model example, you could add an additional fur description to the surfaces around the cat’s nose for its whiskers.

For details on creating and attaching fur, see “Create fur” on page 20.

For examples on creating fur, whiskers, and other Fur effects, see Chapter 7, “Fur samples and techniques.”

Modifying fur attributes

You can modify fur description attributes so that all surfaces with the fur description attached have the new attributes. You can also style a fur description, such as shorten or lengthen the fur on some parts of the model, by mapping attribute values, or by painting fur attribute values directly on the model using Maya Artisan. When you apply fur attribute value maps or paint fur attribute values, the global fur description attributes do not change.

For details on modifying fur attributes, see “Change fur attributes” on page 31.

Animating fur attributes

You can keyframe the changes you make to fur attributes, and thus animate effects like growing fur or changing fur color.

See “Animate fur attributes” on page 69.
Adding movement to fur
If you are animating your scenes, you can add movement to fur for a more natural effect. Using attractors, you can manually keyframe fur movement, or using Dynamics, you can make the fur react to forces (for example, wind and gravity) or have fur react to the movement of the surface the fur is attached to (for example, a shaking dog).

See “Adding movement to fur” on page 75.

Setting up shading effects
To create more realistic looking fur, you can create fur shading and shadowing effects. Do this by adding fur light attributes to the lights in your scene.

See “Adding fur shading effects” on page 113.

Rendering the scene
To see the fur effects on your models, you must render the scene. By default, the renderer composites the rendered fur with the rendered models, distributing the fur evenly across each surface (even where the parameterization is uneven, for example, at the poles of a sphere).

See “Rendering scenes with fur” on page 125.

Refining settings
After rendering your scene, you may have to adjust the lighting and fur attributes to achieve the effect you want. Re-render after making changes.

For suggestions on refining fur effects, see “Troubleshooting Fur” on page 161.

Fur Presets
Maya includes a set of fur description presets that you can use as a starting point for various fur types.

Related topics
- “Use Fur Presets” on page 22
<table>
<thead>
<tr>
<th>Fur Preset</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bear</td>
<td><img src="image1.png" alt="Bear Fur Sample" /></td>
</tr>
<tr>
<td>Bison</td>
<td><img src="image2.png" alt="Bison Fur Sample" /></td>
</tr>
<tr>
<td>Calico Cat</td>
<td><img src="image3.png" alt="Calico Cat Fur Sample" /></td>
</tr>
<tr>
<td>Dreadlocks</td>
<td><img src="image4.png" alt="Dreadlocks Fur Sample" /></td>
</tr>
<tr>
<td>Duckling</td>
<td><img src="image5.png" alt="Duckling Fur Sample" /></td>
</tr>
<tr>
<td>Gorilla</td>
<td><img src="image6.png" alt="Gorilla Fur Sample" /></td>
</tr>
<tr>
<td>Fur Preset</td>
<td>Sample</td>
</tr>
<tr>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>Grass</td>
<td><img src="image1" alt="Grass Sample" /></td>
</tr>
<tr>
<td>Lion mane</td>
<td><img src="image2" alt="Lion Mane Sample" /></td>
</tr>
<tr>
<td>Llama</td>
<td><img src="image3" alt="Llama Sample" /></td>
</tr>
<tr>
<td>Mouse</td>
<td><img src="image4" alt="Mouse Sample" /></td>
</tr>
<tr>
<td>Polar bear</td>
<td><img src="image5" alt="Polar Bear Sample" /></td>
</tr>
<tr>
<td>Porcupine</td>
<td><img src="image6" alt="Porcupine Sample" /></td>
</tr>
<tr>
<td>Punk</td>
<td><img src="image7" alt="Punk Sample" /></td>
</tr>
</tbody>
</table>
How do I? Load Fur

To start using Maya Fur it must be loaded. Maya Fur loads automatically when you install Maya Unlimited, however, if you should need to load it, use the following procedure.

**To load Maya Fur**

1. Start Maya.

<table>
<thead>
<tr>
<th>Fur Preset</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Raccoon</td>
<td><img src="image1" alt="Sample" /></td>
</tr>
<tr>
<td>Sheep</td>
<td><img src="image2" alt="Sample" /></td>
</tr>
<tr>
<td>Squirrel</td>
<td><img src="image3" alt="Sample" /></td>
</tr>
<tr>
<td>Wet Labrador (dog)</td>
<td><img src="image4" alt="Sample" /></td>
</tr>
<tr>
<td>Wet Otter</td>
<td><img src="image5" alt="Sample" /></td>
</tr>
</tbody>
</table>
Introducing Fur | 1
Load Fur >

2 Select Window > Settings/Preferences > Plug-in Manager. The Plug-in Manager window opens.

3 Locate Fur.so (IRIX and Linux) or Fur.mll (Windows), and turn on loaded. Maya loads Fur and adds the Fur menu to the Rendering menu set.
   To load Fur automatically every time you start Maya, turn on auto load.

4 Click Close.
   You can access Maya Fur features from the Fur menu in the Rendering menu set or from the Hotbox (rendering menus).

Related topics
- “Fur workflow overview”
- “Fur Presets”
- “Preparing polygon and subdivision surface models for fur”
- “Create fur”
Creating and modifying fur

About

Preparing polygon and subdivision surface models for fur

Applying fur to a polygon or subdivision surface model is similar to applying textures in that the geometry needs a specific arrangement of UVs so that the fur looks correct when applied to the model. (UVs are points that correspond to polygon/subdivision surface vertices and provide the information needed to map fur to the object.) For details on creating UVs, see the Polygonal Modeling guide or the Subdivision Surfaces Modeling guide.

The UVs must be laid out so they are non-overlapping between 0 and 1 in the texture space. To achieve this you can use one of the following to instantly lay out your UVs:

- Automatic Mapping
- Layout UVs menu item in the UV Texture Editor

By default, Fur uses the UV layout in UV set map1 to map fur descriptions to polygons and subdivision surfaces, but you can change this in the Relationship Editor. For details, see “Select which UV set to use for Fur (polygons only)” on page 25.

Related topics

- Edit Polygons > Texture > Layout UVs
- Subdiv Surfaces > Texture > Layout UVs
How do I? Create and modify fur

Create fur

You create fur by creating fur descriptions. A fur description defines all the attributes for a particular type of fur. These attributes include fur color, width, length, baldness, opacity, scraggle, curl, density, and more. For details of fur attributes, see page 31. You can also use any of the Fur Presets to get started; see “Use Fur Presets” on page 22.

You can attach a fur description to any single or multi-surface NURBS, polygonal or subdivision surface model. You can then style the fur, such as shorten or lengthen the fur on some parts of the model, using attribute value maps, or by painting fur attribute values directly on the model using Maya Artisan. When you apply fur attribute value maps, or paint fur attribute values, the global fur description attributes do not change. For information on styling fur, see “Paint fur attribute values” on page 33 and “Map fur attribute values” on page 40.

There are four ways to create fur descriptions:

- Create the fur description and automatically attach it to a selected surface.
- Create a fur description without attaching it to a surface.
- Duplicate an existing fur description.
- Apply a Fur Preset to the selected surface. (See “Use Fur Presets”.)

To create and attach a fur description

1. Select the surface(s) to apply fur to.
2. In the Rendering menu set select Fur > Attach Fur Description > New.
Maya Fur creates a fur description and attaches it to the selected surfaces. Fur feedback automatically displays on the selected surfaces, providing you with a visual representation of the default fur attributes for the fur description. For information about fur feedback, see “Preview fur using fur feedback” on page 26.

3 Change the name of the fur description to something meaningful (for example, bodyFur or beardFur) and edit the fur description attributes. For details, see “Edit fur descriptions” on page 31.

**To create an unattached fur description**

1 In the Rendering menu set select Fur > Fur Description (more) > Create Unattached. Maya Fur creates a fur description called FurDescription. The new fur description is now available to attach to surfaces. For details, see ”Attach and detach fur” on page 24.

2 Change the name of the fur description to something meaningful (for example, bodyFur or beardFur) and edit the fur description attributes. For details, see ”Edit fur descriptions” on page 31.

**To duplicate a fur description**

1 In the Rendering menu set select Fur > Fur Description (more) > Duplicate > FurDescriptionName, where FurDescriptionName is the name of the fur description you are duplicating. Maya Fur creates an identical fur description with the name FurDescriptionName1.

2 Change the name of the fur description to something meaningful (for example, bodyFur or beardFur) and edit the fur description attributes. For details, see ”Edit fur descriptions” on page 31.
Use Fur Presets

Maya includes a set of fur description presets that you can optionally use as a starting point for various fur types. Click the Preset button at the top of the fur description Attribute Editor or open the default Fur shelf (Windows only) to access these presets.

In addition you can save the attribute settings of a fur description as a Fur Preset using the Preset button in the Attribute Editor. External connections to the node (such as maps applied to attributes) are not saved.

You can load Fur Preset settings into any fur description, and blend Fur Presets to get new variations. You can only delete Fur Presets you have created, not any of the Fur Presets that ship with Maya.

See "Fur Presets" on page 14 for a complete list of available Fur Presets and sample images.

Note
After you apply a Fur Preset, if the scale of the fur does not match your scene, adjust the Global Scale value accordingly.

Related topics

“Fur Presets” on page 14

To apply a Fur Preset

1 Select the surface(s) to apply fur to.
2 Do one of the following:
   - (Windows) From the Fur shelf, click the desired Fur Preset button.
   - Attach a fur description (Fur > Attach Fur Description > New), click the Presets button in the Attribute Editor, select the desired Fur Preset from the pop-up menu and then click Replace.
3 Change the name of the fur description to something meaningful (for example, bodyFur) and edit the fur description attributes. For details, see “Edit fur descriptions” on page 31. Read the Notes section for useful information about the Preset.
Creating and modifying fur | 2
Use Fur Presets >

To blend a Fur Preset

1. Select the object and then in the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName, where FurDescriptionName is the name of the Fur Description you want to blend with a Preset.

2. Click the Preset button in the Attribute Editor.

3. From the pop-up menu select the desired Fur Preset and then select the percentage of blending.

The Squirrel Fur Preset was applied to the sphere below. The Squirrel Fur attributes to the left can be seen in the fur description (Fur > Edit Fur Description).
Creating and modifying fur | 2
Delete fur |

**To save a fur description as a Preset**

1. Select the fur object and then in the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName, where FurDescriptionName is the name of the Fur Description you want to save as a Preset.
2. Click the Preset button in the Attribute Editor and from the pop-up menu select Save FurDescription Preset.
3. Type a name in the Preset Name text box and then click Save Attribute Preset.

**To delete a Fur Preset**

1. Select the object and then in the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName, where FurDescriptionName is the name of a Fur Description.
2. Click the Preset button in the Attribute Editor and select Edit Preset from the pop-up menu.
   The Edit FurDescription Presets window appears.
3. Select the Fur Preset that you want to delete and click Delete.
4. Click Close.

**Delete fur**

You delete fur by deleting fur descriptions.

**To delete a fur description**

In the Rendering menu set select Fur > Fur Description (more) > Delete > FurDescriptionName, where FurDescriptionName is the name of the fur description you are deleting.

**Attach and detach fur**

You can attach fur to surfaces automatically when you create the fur description or you can attach it manually after you create a description.

You can attach more than one fur description to selected surfaces. You may want to do this if, for example, your model requires fur with different lengths or textures. For example, a horse’s body hair is shorter and stiffer than the hair on its mane.

**To attach a fur description**

1. Select the surface(s) you want to attach a fur description to.
Creating and modifying fur | 2

Select the surfaces a fur description is attached to

2 In the Rendering menu set select Fur > Attach Fur Description > FurDescriptionName, where FurDescriptionName is the name of the fur description you want to attach.

| Note | If you attach more than one fur description to a surface, only the feedback for the last assigned fur description displays. For details on switching fur feedback, see “Hiding and showing fur feedback” on page 27. |

To detach a fur description

1 Select the surface you want to detach a fur description from.
2 In the Rendering menu set select Fur > Fur Description (more) > Detach > FurDescriptionName, where FurDescriptionName is the name of the fur description you want to detach.

| Note | Detaching a fur description does not delete it—it merely removes its association with the selected surface. |

Select the surfaces a fur description is attached to

You can quickly select the surfaces a fur description is attached to. This is useful, for example, if you want to add attractors to the surfaces with a certain fur description. (For information on attractors, see “Adding movement to fur” on page 75.)

To select the surfaces a fur description is attached to

In the Rendering menu set select Fur > Fur Description (more) > Select Surfaces Attached to > FurDescriptionName, where FurDescriptionName is the name of the fur description attached to the surfaces you want to select.

Select which UV set to use for Fur (polygons only)

By default Fur uses UV set map1, but you can link your fur descriptions to different UV sets on your polygonal surface. For example, if you have different UV sets defined for different projections, you can link the fur descriptions to the UV set that gives the best fur result.

When you link a fur description to a UV set, all the fur descriptions attached to the polygon are linked. You cannot link individual fur descriptions to different UV sets.
Creating and modifying fur | 2
Preview fur using fur feedback

To link attached fur descriptions to a different UV set
1 Select the object with the fur description(s) you want to link.
2 Select Window > Relationship Editors > UV Linking > Fur/UV to open the Relationship Editor.
   The left panel lists all the fur descriptions that are attached to the selected polygon.
   The right panel lists mesh nodes with UV sets for the selected polygon. If more than one polygon is selected, only the last selected polygon is listed.
3 In the left panel, click a fur description. All the fur descriptions attached to the polygon become selected and in the right panel the UV set the fur descriptions are linked to becomes highlighted.
4 In the right panel, click the UV set you want to link the fur description(s) to.

To create a new unattached fur description from the Relationship Editor
In the Fur Descriptions panel of the Fur/UV Linking Relationship Editor, select Edit > Create Unattached Fur.

To duplicate fur descriptions from the Relationship Editor
1 Select the object with the fur description(s) you want to duplicate.
2 In the Fur Descriptions panel of the Fur/UV Linking Relationship Editor, select a fur description. All the fur descriptions attached to the selected surface become highlighted.
3 Select Edit > Duplicate All Highlighted Fur. All the highlighted fur descriptions are duplicated, but they are not attached to the object.

To delete fur descriptions from the Relationship Editor
1 Select the object with the fur description(s) you want to delete.
2 In the Fur Descriptions panel of the Fur/UV Linking Relationship Editor, select a fur description. All the fur descriptions attached to the selected surface become highlighted.
3 Select Edit > Delete All Highlighted Fur. All the highlighted fur descriptions are deleted.

Preview fur using fur feedback
Fur feedback provides you with a representation of the fur description on your model while you work.
Creating and modifying fur | 2

Preview fur using fur feedback

When you attach a fur description to a surface, fur feedback appears automatically on the surface. If a surface has more than one fur description attached to it, you can select which fur feedback displays, or display no fur feedback. For details, see “Hiding and showing fur feedback” on page 27.

You can also define fur feedback attributes. For details, see “Define fur feedback attributes” on page 28.

Hiding and showing fur feedback

By default, all Fur Feedback is displayed, which means you can display Fur Feedback for multiple fur descriptions at the same time. To help you see what fur is displayed, Color Feedback Enabled is turned on by default (located in the FurFeedback node). Also, the default value for Fur Accuracy is 1. (Each fur description has its own Fur Feedback.)

To see just the Fur Feedback for only one fur description (for speed or clarity), you can select and hide the others. You can also quickly hide all fur in a scene.

You can select all fur in a scene quickly by selecting Edit > Select All by Type > Fur.

Hidden fur does not render.

To hide all fur
Select Display > Hide > Fur.

To show all fur
Select Display > Show > Fur.

To hide fur for fur description(s)

1 Select the FurFeedback(s).
2 Do one of the following:
Creating and modifying fur | 2

Preview fur using fur feedback >

- Select Display > Hide > Hide Selected.
- Press Ctrl + h.

**To show the last hidden fur description**

Do one of the following:

- Select Display > Show > Show Last Hidden.
- Press Ctrl + Shift + h.

**Define fur feedback attributes**

You can modify the following fur feedback attributes:

- the number of U and V samples on the surface (which determines how many feedback hairs display)
- the fur feedback accuracy (how closely the fur feedback resembles the final rendered fur)
- the fur feedback color (make it the same as either the locator color or the fur color)
- if you added attractors, the display of attractor feedback

**To define fur feedback attributes**

1. Select the fur feedback you want to modify by selecting one of the feedback hairs.
2. Select Window > Attribute Editor. The Attribute Editor opens.
3. Modify the feedback attributes. For descriptions of these attributes see “Fur Feedback Shape node” on page 50.

**Tip**

You can also use the Channel Box to change fur feedback attributes (SHAPES section) with the exception of the Attribute Map Width and Height attributes.

3. Modify the feedback attributes. For descriptions of these attributes see “Fur Feedback Shape node” on page 50.

**To change fur feedback attributes for more than one surface**

1. Select all the fur feedback nodes in Outliner (Window > Outliner).
2. Open the Attribute Spread Sheet (Window > General Editors > Attribute Spreadsheet).
3. Click the Shape Keyable tab and change the desired fur feedback attributes: U and V Samples, Fur Accuracy and Color Feedback.

**Related topics**

- “Fur Feedback Shape node” on page 50
Reverse fur normals

By default, when you attach fur to a model, each hair making up the fur points in a direction normal (perpendicular) to the surface. This direction is called the fur normal.

(Punk) Fur is growing normal (perpendicular) to the surface of the polygon sphere

If your model appears to have very short fur after you attach a fur description to it, it could be because the fur normal is pointing in a negative direction (the fur appears to be attached to the inside surface). To remedy this you reverse the fur normals. This makes the fur point out from the model rather than into the model.

Before modifying your fur description and adding attractors, check that the fur on all surfaces making up the model “grows” out from the surface, rather than into the surface. Reverse fur normals on any surface with fur growing in.

To reverse fur normals

1. Select the surface that has fur growing inside rather than outside.
2. In the Rendering menu set select Fur > Reverse Fur Normals.
Offset the direction fur grows

The direction fur “grows” (or the “nap”) is determined by:

- the Inclination of the fur (rotation about the U axis, which determines how much the fur lies down),
- the Polar of the fur (rotation around the fur normal),
- and the Roll of the fur (rotation around surface V axis).

For details, see “Inclination” on page 58, “Polar” on page 59, and “Roll” on page 58.)

When you add fur to a model and adjust the inclination, polarity, and roll, you may find that the fur grows in different directions for some of the surfaces. This is dependent upon the UV direction of surfaces.

You could adjust this by mapping different polar values to the surfaces in question, or by combing the fur in the direction you want it to grow. Another quick way to do this is by offsetting the fur direction. You can roughly offset the fur direction by 0, 90, 180, and 270 degrees from the Fur menu.

**To offset the fur direction**

Offset Fur Direction affects all attached fur descriptions on a surface, unless their Polar attribute has already been painted or mapped.

1. Select the surfaces with fur growing in the wrong direction.
2. In the Rendering menu set select Fur > Offset Fur Direction By > *OffsetValue*, where *OffsetValue* is 0, 90, 180 or 270 Degrees.
Change fur attributes

After you create a fur description, you can edit the fur attributes at any time. There are three ways to change fur attributes:

- Change the attributes for the fur description so they are applied to all surfaces to which the fur descriptions are assigned. See “Edit fur descriptions” on page 31.
- Selectively paint or “comb” specific attributes on fur without changing the global attributes of the fur description attached to the surface. See ”Paint fur attribute values” on page 33.
- Map values for each fur attribute. See “Map fur attribute values” on page 40.

Edit fur descriptions

When you edit a fur description, any changes you make to the fur attributes apply to all surfaces to which the fur descriptions are assigned.

To edit a fur description

1. In the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName to display the Attribute Editor, where FurDescriptionName is the name of the fur description you are editing.
2. Modify the fur description attributes. For descriptions of these attributes see “Fur Description node” on page 53.

Randomly vary fur attribute values

For a more natural effect, you can randomly vary the attribute values of each hair making up a fur description using noise amplitude and noise frequency. Noise amplitude refers to the variance of an attribute, and noise frequency refers to the amount of variance over a distance or area. You can set noise amplitude and noise frequency for all attributes.

For example, if you add noise to fur Length, each hair making up the fur randomly has a different length relative to the noise frequency. If the noise frequency is low, the length variance occurs over a larger area. If the noise frequency is high, the length variance occurs over a smaller area, producing a more ragged effect.
Creating and modifying fur | 2
Change fur attributes >

As another example, consider adding noise to the Base and Tip Color. If the color noise frequency is low, the color is patchy. If the color noise frequency is high, the color is more mottled.

To set noise amplitude and noise frequency

1. In the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName to display the Attribute Editor, where FurDescriptionName is the name of the fur description you are editing.
2. Go to the Details section and then go to the section for the attribute you want to change noise values for.
3. Modify the Noise Amplitude and Noise Frequency values. For more information see “Details” on page 65.

Change attribute map value ranges

An attribute map is a two-dimensional image with values that correspond, or map, to attributes of points on a three-dimensional surface. This mapping is relative to the UV parameterization of the surface. Attribute map values are represented by grayscales, with black representing a value of 0 and white representing a value of 1.

Attribute map values are located in the Details section of the fur description Attribute Editor. By default, attribute map value ranges are defined between 0 and 1. You only need to change value ranges when you want to paint or map values other than those defined in this range. For example, you could change the range from 0.2 to 0.5, 2.0 to 3.0, or more.
commonly, from 0 to 5. For information on painting values, see “Paint fur attribute values” on page 33. For information on mapping values, see “Map fur attribute values” on page 40.

You can set value ranges for all fur attributes except color attributes.

**To change attribute map value ranges**

1. In the Rendering menu set select Fur > Edit Fur Description > *FurDescriptionName* to display the Attribute Editor, where *FurDescriptionName* is the name of the fur description you are editing.
2. Go to the Details section, then go to the section for the attribute you want to change value ranges for.
3. Modify the Map Offset and Map Multiplier attributes. For more information see “Details” on page 65.

**Map Offset**

Set the factor you want to offset the attribute value by. For example, if you want to change the range of values for fur Length from the default 0-1 to 4-5, set the offset to 4.

**Map Multiplier**

Set the factor you want the value multiplied by. For example, if you want to change the range of values for fur Length from the default, 0-1, to 0-10, set the multiplier to 10.

**Paint fur attribute values**

Using Maya Artisan, you can paint fur attribute values on an area of fur without changing the fur description for the entire surface. For example, you can paint length values on part of a surface to make the painted patch of fur longer than the rest of the fur. You can also comb fur in the direction you want the fur to lie; for details, see “Comb fur” on page 36.

When you paint fur attribute values on a surface, Maya creates a map of the values for each of the fur description attributes that you change. These maps are located in the fur description Attribute Editor (Details > *AttributeName* > Maps).

You can also paint values on the Equalizer Map, a map automatically generated by the renderer to ensure that fur is distributed evenly over surfaces with uneven parameterization. For details, see “Paint equalizer maps” on page 39.
If you paint fur attributes in scenes that are referenced or you paint fur attributes outside of the Paint Fur Attributes Tool, such as in the Paint Effects canvas, or in an external application, such as Photoshop, you can quickly update all fur maps in a scene. See “Update fur maps” on page 46.

### Notes
- You cannot use Artisan to mask selected vertices.
- Direction painting is not supported on subdivision surfaces.
- Paint the Polar attribute instead.

### Tips for using Maya Artisan (Paint Fur Attributes Tool)
Before using Maya Artisan to paint fur attribute values, learn the Maya Artisan hotkeys for at least the following commands to increase your efficiency as you work with the Paint Fur Attributes Tool:

- press b and drag the mouse to change the brush size (Upper Radius)
- press n and drag the mouse to modify the Paint Value
- press Alt+f to Flood Surfaces with the current Value
- press/release Alt+a to turn Show Wireframe on and off
- press/release Alt+c to turn Color Feedback on and off
- press/release Alt+r to turn Reflection on and off
- press/release 0 to display the Paint Fur Attributes Tool Marking Menu

If these hotkeys do not work, set them by selecting Window > Settings/Preferences > Hotkeys and using the information below:

- Under the Brush Tools category, ModifyUpperRadius
- Under the Artisan category, ModifyPaintValue, FloodSurfaces, ToggleWireframeInArtisan, ToggleColorFeedback, and ToggleReflection
- Under the Fur category, PaintFurAttributesMarkingMenu

### To paint fur attributes using the Paint Fur Attributes Tool

1. Select the surface(s) or fur feedback you want to paint. Each selected surface must have a fur description assigned to it.

2. In the Rendering menu set select Fur > Paint Fur Attributes Tool > . The Paint Fur Attributes Tool Settings window opens, followed by the tool settings editor.

3. In the Paint Fur Attributes Tool Settings window set the following options:
Creating and modifying fur | 2
Change fur attributes >

- Fur Attribute - Select the attribute you want to paint values for on the surface. If you are painting attractor set values (see Attractor Set), select one of the Attractor attributes.
- Fur Description - Select the fur description you want to paint. Only the fur descriptions attached to at least one of the selected surfaces are available for selection; you can only paint on surfaces to which the selected fur descriptions are attached. You can only paint one fur description at a time.
- Attractor Set - Select the attractor set you want to paint. Only the attractor sets attached to the selected surfaces are available for selection. You can only paint one attractor set at a time.
- Attribute Map Height and Width - Specify a height and width value for the attribute map. The defaults are 256 and 256.

4 In the tool settings editor, select a Profile, Value, and Operation. For details, see Artisan Brush Tool Settings in the online Paint Effects, Artisan, and 3D Paint guide.

5 Drag the brush across the surface.

You can quickly restore fur attribute values to the prepainted values by deleting the attribute map created when you painted the fur. For details, see “To remove maps from an attribute” on page 47.

To paint attribute values greater than 1

1 Using the Paint Fur Attributes Tool flood the selected surface with an attribute value of 1:
   - Select the attribute from the Fur Attribute drop-down list.
   - Set the Value to 1.
   - Click the Flood button.

2 Set the attribute Map Multiplier to the number you want to paint. For example, for Length, go to the Details section of the fur description Attribute Editor and set the Length Map Offset and Length Map Multiplier attributes.

   For details, see ”Change attribute map value ranges” on page 32. You can now paint values between 0 and less than the value set for the Multiplier.

Map Offset

Set the factor you want to offset the attribute value by. For example, if you want to change the range of values for fur Length from the default 0-1 to 4-5, set the offset to 4.
Map Multiplier

Set the factor you want the value multiplied by. For example, if you want to change the range of values for fur Length from the default, 0-1, to 0-10, set the multiplier to 10.

Comb fur

When you paint Direction, you are really changing the Polar value to correspond with the direction you are painting. In effect, you are “combing” the fur.

Notes

Direction is represented in the polar attribute map. There is no direction attribute map.

Painting the Direction attribute is not supported on subdivision surfaces. Paint the Polar attribute instead.

To comb fur

1. Select the surface(s) or fur feedback you want to paint. Each selected surface must have a fur description assigned to it.

Note

If the inclination is set to 0 and the base curl, tip curl, and roll are set to 0.5, combing (or painting the direction) will have no effect.

2. In the Rendering menu set select Fur > Paint Fur Attributes Tool > . The Paint Fur Attributes Tool Settings window opens, followed by the tool settings editor.
3 In the Paint Fur Attributes Tool Settings window select Direction from the Fur Attribute drop-down list.

4 Select the fur description you want to comb.
   Only the fur descriptions attached to the selected surfaces are available.

5 Drag the brush across the surface in the direction you want the fur to lie.

To restore the fur direction to the fur description values
Delete the Polar attribute map created when you painted the direction. For details, see “To remove maps from an attribute” on page 47.

To fine tune the effects of your combing (for example, to smooth values)
Select Polar in the Paint Fur Attributes Tool Settings window and paint the surface using the appropriate tool settings.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Because the Polar values are affected only by the direction you comb in (paint Direction), when you comb hair, none of the settings in the Tool Settings editor are relevant. For example, using Smooth is the same as using Replace, and a Value of 1 is the same as a Value of 0. Color feedback is meaningless so you may want to turn it off.</td>
</tr>
</tbody>
</table>

View the attribute map while you paint
When you paint on a surface with an Artisan tool, such as the Paint Fur Attributes Tool, you can view the grayscale fur attribute value map on the surface as you paint. This provides useful feedback when the changes you are painting are not easily detected with the fur feedback. However, viewing the value map while you paint slows performance.
Creating and modifying fur | 2

Change fur attributes >

To view the value map while you paint

1. Select the surface or fur feedback you want to paint. The surface must have a fur description assigned to it.
2. In the Rendering menu set select Fur > Paint Fur Attributes Tool > . The Paint Fur Attributes Tool Settings window opens, followed by the tool settings editor.
3. In the tool settings editor, go to the Display section.
4. Turn on Color Feedback.

Notes
- Turn on Shading (Shading > Smooth Shade All) by pressing 5.
- When you paint Direction, the map values are meaningless. If you want to view and modify the map for Polar values, select Polar as the Fur Attribute in the Paint Fur Attribute Tool Settings window.
- Color Feedback does not work on subdivision surfaces.

To speed up painting when Color Feedback is turned on (NURBS only)

1. Press 1 (hotkey) to reduce display smoothness while you paint values.
2. When you are finished painting values, turn off Color Feedback, and press 3 (hotkey) to return to full display smoothness.

Notes
- Where the brush paints is where gray shading appears on the white surface. The degree of grayscale shading depends on the Value being painted. Black is 0 and white is 1.
Smooth values
You can smooth the values you paint using Artisan’s Smooth and Flood operations.

To smooth values
1 Select the surface or fur feedback you want to smooth.
2 In the Rendering menu set select Fur > Paint Fur Attributes Tool > .  
The Paint Fur Attributes Tool Settings window opens, followed by the tool settings editor.
3 In the tool settings editor, select the Smooth operation.
4 Click Flood. The painted values are smoothed.
Repeat to smooth more.

Tip You can see the effects of smoothing more easily when Color Feedback is turned on. For details, see “View the attribute map while you paint” on page 37.

Paint equalizer maps
Although you will not typically need to, you can modify the equalizer map that is automatically generated when you render by painting directly on the surface. When you modify the equalizer map, you modify the distribution of fur on the surface. For example, you can paint lower values in areas that are denser than you want. For more information, see “Equalizer Maps” on page 137.

To paint equalizer maps
1 Select the surface(s) or fur feedback you want to paint. Each selected surface must have a fur description assigned to it.
2 In the Rendering menu set select Fur > Paint Fur Attributes Tool > . 
The Paint Fur Attributes Tool Settings window opens, followed by the tool settings editor.
3 In the Paint Fur Attributes Tool Settings window select Equalizer Map from the Fur Attribute drop-down list.
4 Select the fur description you want to paint.
Only the fur descriptions attached to the selected surfaces are available for selection.
5 If you don’t see the equalizer map, go to the Display section of the tool settings editor and turn on Color Feedback.
In the tool settings editor, select an appropriate Value, Profile, and Operation. For details, see *Artisan Brush Tool Settings* in the online Paint Effects, Artisan, and 3D Paint guide.

Decreasing the Value makes the fur appear more sparse where you paint, while increasing the Value makes the fur more dense.

Drag the brush across the surface.

If you’ve painted a Custom Equalizer Map, when you render the scene, the Fur Globals automatically use the custom map. To defer to the default equalizer map, in the Fur Globals, go to the Fur Render Options and select Default Equalizer Map from the Equalizer Maps drop-down list. For more information, see “Equalizer Maps” on page 137.

**Map fur attribute values**

Attribute maps are represented by grayscales, with black representing a value of 0 and white representing a value of 1. When you paint a fur attribute on a surface using the Artisan Paint Fur Attributes Tool, Maya creates a map for the painted attribute and associates it with the fur description and the surface the fur description is assigned to. These maps ensure that the attribute values you paint are applied to the surface every time you open the scene.

You can also import value maps for each attribute. Since you cannot paint color attributes on fur, mapping is a particularly useful technique for applying multiple colors to fur, for example, leopard skin. You can create a color attribute map using the 3D Paint Tool and map it to the Base Color and Tip Color attributes by dragging and dropping the switch nodes generated by the 3D Paint Tool. For details, see “To apply multiple textures to attributes on multi-surface objects (using the 3D Paint Tool)” on page 44. Because Fur can use only simple file texture maps, every texture you import must be “baked” to convert it to a file texture.

You can import and export maps in file formats supported by Maya.

Find out how to:
“Apply a single texture to objects” on page 41
“Apply multiple textures to multi-surface objects” on page 42
“Remove maps from fur attributes” on page 47
“Use an alternate mapping method” on page 45
“Apply animated file textures to objects” on page 46
“Update fur maps” on page 46

Apply a single texture to objects
If you are mapping a single texture to a single surface or to a multi-surface object, use the following procedure.

To map a single texture to an attribute
1 In the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName, where FurDescriptionName is the name of the fur description you want to edit.
2 Do one of the following:
   • If you are mapping a texture to a color attribute, click the Map button beside the attribute in the Attribute Editor. The Create Render Node dialog appears. Click the Textures tab, click the texture you want to map (for example, Ramp) and adjust the settings in the Attribute Editor. (To map an existing file, click File and select the file.)
   • Right-click the attribute field and select Create New Texture. The Create Render Node dialog appears. Click the Textures tab, click the texture you want to map (for example, Ramp) and adjust the settings in the Attribute Editor. (To map an existing file, click File and select the file.)
   • Create a texture in Hypershade. Drag and drop the texture node onto the fur attribute you want to apply the texture to.

Note The Connection Editor may open when you drag and drop a texture.
   • If you are mapping to a color attribute, select Out Color as the Output and select the color attribute(s) you are mapping to as the Inputs.
   • If you are mapping any other attribute, select Out Alpha as the Output and select the attribute(s) you are mapping to as the Inputs.
Creating and modifying fur | 2
Change fur attributes >

3 In the Attribute Editor, set Bake Attribute to the attribute you are mapping to, or set it to All to bake all mapped attributes.

| Tip | If you have many surfaces, baking All attributes may take longer. To save time, select the individual attribute you want to bake. |

4 Click the Bake button. The fur feedback will not reflect the mapped attributes until you bake.

5 If you edit the texture after baking, bake the texture again, or your changes will not take effect. The old texture will be overwritten.

Notes
- For information on changing the attribute map value ranges, see “Change attribute map value ranges” on page 32.
- For information on removing mapped textures from attributes, see ”To remove maps from an attribute“ on page 47.

Apply multiple textures to multi-surface objects

Suppose you create a spotted color texture for a model of a leopard with a the 3D Paint Tool and want to map it to the Base Color and Tip Color attribute of the fur description attached to the leopard. Each surface making up the model has a separate file texture. To map each file texture to the Base Color and Tip Color you need a way to select the appropriate surfaces for the texture.

The following procedures describe the recommended methods of applying file textures to multi-surface objects.

- ”To apply multiple textures to attributes on multi-surface objects (in general)“ on page 42
- ”To apply multiple textures to attributes on multi-surface objects (using the 3D Paint Tool)“ on page 44

For another method, see ”Use an alternate mapping method“ on page 45.

**To apply multiple textures to attributes on multi-surface objects (in general)**

1 Create a material in Hypershade. (For details, see the online Shading guide.)

2 Select all the surfaces and assign the material to them.

3 Open the Attribute Editor for the material.
4 Click the Map button for the Color attribute. The Create Render Node dialog box opens.

5 Click the Utilities tab.

6 Under Switch Utilities, click Triple Switch. The attributes for the triple shading switch display in the Attribute Editor.

7 Under the Switch Attributes section of the Attribute Editor, click Add Surfaces to add the surfaces assigned to the material to the shading switch.

8 Map each surface to the appropriate texture, as follows:
   - Under inShape, click the surface name to select it.
   - Click the Map Item button. The Create Render Node dialog box appears.
   - Click the texture you want to map (for example, Ramp) and adjust the settings in the Attribute Editor. (To map an existing file, click File and select the file.)
   - Select the tripleShadingSwitch node in Hypershade to see it in the Attribute Editor.

9 Repeat step 8 for each surface.

10 Select Fur > Edit Fur Description and then select the desired fur description to see its attributes in the Attribute Editor.

11 Drag and drop the triple switch node from Hypershade onto the fur attribute in the Attribute Editor you want to apply the texture to.

---

**Note** The Connection Editor may open when you drag and drop a texture.

- If you are mapping to a color attribute, select Out Color as the Output and select the color attribute(s) you are mapping to as the Inputs.
- If you are mapping any other attribute, select Out Alpha as the Output and select the attribute(s) you are mapping to as the Inputs.

---

12 In the Attribute Editor, set Bake Attribute to the attribute you are mapping to, or set it to All to bake all mapped attributes.

   If you have many surfaces, baking All attributes may take longer. To save time, select the individual attribute you want to bake.

13 Click the Bake button. The fur feedback will not reflect the mapped attributes until you bake.
If you edit the texture after baking, bake the texture again, or your changes will not take effect. The old texture will be overwritten.

---

**Notes**
- For information on changing the attribute map value ranges, see “Change attribute map value ranges” on page 32.
- For information on removing mapped textures from attributes, see “To remove maps from an attribute” on page 47.

---

**To apply multiple textures to attributes on multi-surface objects (using the 3D Paint Tool)**

1. Paint the Maya model using the 3D Paint Tool. For information on using the 3D Paint Tool, see “Paint Textures on 3D objects” in the online Paint Effects, Artisan, and 3D Paint guide.
2. Exit the 3D Paint Tool.
3. Drag and drop the switch node from Hypershade onto the fur attribute you want to apply the texture to.

---

**Note**
- The Connection Editor may open when you drag and drop a texture.
  - If you are mapping to a color attribute, select Out Color as the Output and select the color attribute(s) you are mapping to as the Inputs.
  - If you are mapping any other non-color attribute, select Out Alpha as the Output and select the attribute(s) you are mapping to as the Inputs.

---

4. In the Attribute Editor, set Bake Attribute to the attribute you are mapping to, or set it to All to bake all mapped attributes.
   - If you have many surfaces, baking All attributes may take longer. To save time, select the individual attribute you want to bake.
5. Click the Bake button. The fur feedback will not reflect the mapped attributes until you bake.
   - If you edit the texture after baking, bake the texture again, or your changes will not take effect. The old texture will be overwritten.
Notes

- For information on changing the attribute map value ranges, see “Change attribute map value ranges” on page 32.
- For information on removing mapped textures from attributes, see “To remove maps from an attribute” on page 47.

Use an alternate mapping method

When you paint attributes using the Artisan Paint Fur Attributes Tool or map file textures to attributes, the maps are listed under Maps in the Details section of the Attribute Editor. You can also map attributes from here (file textures only), although you are more likely to use the method described under “Apply a single texture to objects” on page 41 or “Apply multiple textures to multi-surface objects” on page 42.

To map fur value attributes to a surface
1. In the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName, where FurDescriptionName is the name of the fur description you want to edit.
2. In the Assigned Surfaces field, select the surface(s) you want to map values to.
3. In the Details section, go to the attribute you want to map values to (for example, Base Color).
4. Go to the Maps section.
5. Click Add Item. The Import dialog box opens.
6. Select the value map you want to map to the selected surface and click Import. The Surface name and assigned map appear in the map list.
7. Repeat steps 2 to 6 for each assigned surface you want to map values to.

To assign a different map to a mapped surface
1. In the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName, where FurDescriptionName is the name of the fur description you want to edit.
2. In the Details section, go to the attribute you want to assign the maps for.
3. Go to Maps.
4. Select the map you want to change.
5. Click Map Item. The File dialog box opens.
Creating and modifying fur | 2
Change fur attributes

Apply animated file textures to objects

Fur attributes can be mapped to animated file textures. Map the attribute in the normal way, animate the filename numbers and then click Bake.

You can apply a series of animated file textures to furry objects to make the fur appear animated. This is useful if you want to animate a character starting with no fur and growing full fur, such as a person turning into a werewolf. For an example, see “Make fur spread using animated file textures” on page 72.

For information on creating a series of animated file textures, see “To paint a series of textures” on page 72.

To apply animated file textures to an object

1 Map the texture to the desired fur attribute.
   • Right-click the attribute in the Fur Description node and select Create New Texture.
   • Select the File texture and specify the first texture in your sequence, for example, growFur.1.iff.

2 To animate the texture filename numbers automatically, turn on Use Image Sequence in the file node. This automatically sets keys for the file textures on a 1 to 1 basis. For more information about this option, see “Improved ability to use image sequences” in the Rendering What’s New.

3 In the Fur Description node, select the mapped attribute from the Bake Attribute drop-down list and then click the Bake button.

4 Play the animation to see the animated fur.

Update fur maps

You can quickly update all fur attribute maps in a scene. It’s useful to update attribute maps when you:

• map or paint fur attributes in scenes that are referenced
• paint fur attributes outside of the Paint Fur Attributes Tool, such as in the Paint Effects canvas, or in an external application, such as Photoshop

To update fur maps

Select Fur > Update Fur Maps.
Creating and modifying fur | 2
Make fur clump together >

Related topics
▶ “Paint fur attribute values” on page 33
▶ “Map fur attribute values” on page 40

Remove maps from fur attributes
To restore the fur attributes settings to the values defined for the fur description, you can break the connection to the attribute if it was baked or you can remove the maps from the attribute.

To break the connection to a baked attribute
1 In the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName, where FurDescriptionName is the name of the fur description you want to edit.
2 Right-click the baked attribute and select Break Connection from the pop-up menu. This disconnects the map from the attribute.
3 Click the Bake button to bake the attribute without the map.

To remove maps from an attribute
1 In the Rendering menu set select Fur > Edit Fur Description > FurDescriptionName, where FurDescriptionName is the name of the fur description you want to edit.
2 In the Details section, go to the attribute you want to remove the maps from.
3 Go to Maps.
4 Select the map you want to remove.
5 Click Remove Item.

Make fur clump together
You can create clumps of fur, such as wet or matted fur, for a whole range of fur looks.
In the Fur Description Attribute Editor there are three attributes to create and control clumping: Clumping, Clumping Shape, and Clumping Frequency. As with all Fur attributes, painting and mapping are supported.

In order to preview clumping accurately, the Fur Accuracy attribute must be set to 1 (default), which is in the shape node of the Fur Feedback Attribute Editor.

Clumping respects other attributes, including Inclination, Roll, and Polar. For example, if Inclination is set to 1 so the fur is lying flat, then the clumps lie flat too.

**Note**  
With clumping there may be the appearance of gaps between the clumps on the surface of the object. To correct this use one or more of the following solutions:

- Apply the same color to the shader that is applied to the Fur’s Base Color.
- Add an additional Fur Description of overall short fur that matches the color of the first Fur Description.
- Add some noise to Clumping, Clump Frequency, or other values.

**To create clumps of fur on part of an object, for example, on the chest fur of a cat**

1. Select the fur feedback or the surface with the fur on it.
2 In the Rendering menu set select Fur > Paint Fur Attributes Tool. The Paint Fur Attributes Tool Settings window appears.

3 Select Clumping from the Fur Attribute drop-down list.

4 In the Attribute Paint tool settings window set Value to 0 and then click Flood. This removes clumping from the object.

5 Set Value to 1 and paint on the object where you want clumps.

**To map or paint ranges that are greater than 0 to 1, such as Clumping Frequency**

Set the attribute’s Map Multiplier value to the maximum value of the range. In the case of Clumping Frequency, this value would be 100.

Now you can paint or map the attribute as usual. White will represent the Multiplier value (100), black will represent 0, and grayscale values will be distributed evenly between.

**To map or paint ranges that can be negative, such as Clump Shape**

1 Set the attribute’s Map Offset value. For example, set the Map Offset to -10 for Clump Shape.

2 Set the attribute’s Map Multiplier Value. For Clump Shape this would be 20 so the black to white map would represent the full range of -10 to 10.

**Copy fur descriptions into other scenes**

After you create a fur description, you can “copy” it into other scenes by saving the fur description as a Fur Preset and then applying that Fur Preset to fur descriptions in other scenes.

**Related topics**

- “To save a fur description as a Preset” on page 24
- “To apply a Fur Preset” on page 22
- “Fur Presets” on page 14
- “Use Fur Presets” on page 22
Creating and modifying fur | 2
Fur Feedback Shape node >

Reference  Fur Feedback Shape node

Below are descriptions of the attributes in the Fur Feedback Shape node.
To see these attributes, select the fur on the object’s surface and open the Attribute Editor (Ctrl+a).

Related topics

❖ “Preview fur using fur feedback”

U Samples, V Samples

Set the number of U Samples and V Samples to define how many fur feedback hairs display on the surface. This does not change how many hairs actually render on the surface, only the number of fur feedback hairs that appear on the surface while you are working on it.

![Surface with fur feedback U Samples and V Samples set to 4](image1)
![Same surface rendered with fur Density set to 3000](image2)

You may want to decrease the U and V Samples on very small surfaces so you can see the effect of fur attributes more clearly while you work.

![32 samples in U and V](image3)
![8 samples in U and V](image4)

Note  Read the following about U and V Sample if you map a texture or use the Artisan Paint Fur Attributes Tool to paint fur attribute values.
The number of U Samples and V Samples define where the sample hairs are. When you paint fur attribute values on a surface, only the values for fur represented by the feedback change to the painted values. The values for hairs growing between fur feedback hairs are interpolated and blend automatically.

The following example shows a profile of rendered fur where the fur length in the fur description is 1 with a fur length of 5 painted using the Paint Fur Attributes Tool. The same brush stamp (size and shape) was used in both images.

The first image was created with 40 U and V Samples. The second image was created using only 4 U and V Samples.

If you increase the number of U and V Samples, ensure that the Attribute Map Height and Width are larger (as a rule of thumb, the Attribute Map should be at least twice as large) to account for the change in the level of detail. Otherwise, you will lose detail for attributes you painted using the Paint Fur Attributes Tool.

**Fur Accuracy**

Set how closely the fur feedback resembles the appearance of the final rendered fur. This is particularly useful for representing scraggle and curl. Fur accuracy ranges from 0 to 1. A value of 0 represents the hairs as straight lines, regardless of any curl, scraggle, or attraction. A value of 1 uses the same number of segments for each hair in the fur feedback that will be used for the actual render, but significantly slows interaction. A value of 0.5 uses half the number of segments in the fur feedback that will be used in the actual render, and is often sufficient to give a good indication of what the final fur render will look like.

The default value for Fur Accuracy is 1, but you can turn it down to speed up interaction.
Fur Feedback Shape node

Color Feedback Enabled
Sets the color of the fur feedback to be the same as the actual fur color for the fur description.

Draw Attractors
Turn this on to display the actual attractor curves used by the fur (as opposed to just the mechanisms used to generate these curves).

Render Stats
These are descriptions of the attributes in the Render Stats section. These render settings are unique to each fur feedback node.

Primary Visibility
When on, the fur is visible in the view and renders.

| Tip | A fur shadow will render if its Primary Visibility is off and Cast Shadows is on. This also applies to reflections and refractions. |

Casts Shadows
Turns on the shadow casting ability of the fur. To make shadows render faster, for fur that does not need to cast shadows, turn off Casts Shadows.

Receive Shadows (mental ray)
Turns on the shadow-catching ability of the fur. Works only when using the mental ray for Maya renderer.

Motion Blur (mental ray)
Turns on motion blur for the fur. You must also turn on Motion Blur in the Render Global Settings window. Works only when using the mental ray for Maya renderer.
Visible in Reflections (mental ray)

When on, the fur reflects in reflective surfaces. Works only when using the mental ray for Maya renderer.

Visible in Refractions (mental ray)

When on, the fur refracts in transparent surfaces. Works only when using the mental ray for Maya renderer.

**Fur Description node**

Below are descriptions of the attributes in the Fur Description node.

**Related topics**

- “Change fur attributes”
- “Make fur clump together”
- “Use Fur Presets”
- “Copy fur descriptions into other scenes”

**FurDescription**

Replace the default name for the fur description with something meaningful (for example, eyebrowFur).

**Light Model**

Select the light model you want applied to the fur description.

- Ambient Only: Only the Base Ambient Color and Tip Ambient Color of the fur are used in the final color calculation.
- Ambient + Diffuse: The Base Ambient Color and Tip Ambient Color values are added to the Base Color and Tip Color values respectively.
- Ambient + Diffuse + Specular: The Base Ambient Color and Tip Ambient Color values are added to the Base Color and Tip Color values respectively, and the Specular values are added to the hairs according to the Specular Sharpness.
- Specular Only: Only the specular lights (highlights) for the fur are rendered.
Creating and modifying fur | 2

Density

Type the number of hairs you want distributed either across all surfaces the fur description is attached to or on each surface the fur description is attached to.

To distribute the hairs across all surfaces the fur description is attached to, set the Calc. Area Values fur render option to Globally. The hairs for each fur description are distributed evenly over all surfaces with fur descriptions attached, regardless of which fur description is attached.

To distribute the hairs on each surface the fur description is attached to so that the distribution of hairs for one fur description does not affect the distribution for another fur description, set the Calc. Area Values fur render option to Per Fur Description.

For details, see ”Set up Fur Render Globals before rendering” on page 127. Per Fur Description is the default.

To use the given density value on each surface the fur description is attached to, you must set the Calc. Area Values fur global option to Off.

Global Scale

Use this setting to adjust the Base Width, Tip Width, Length, and Offset values by a common factor (including mapped values). This scales the hairs uniformly.

Assigned Surfaces

Lists the surfaces that have the current fur description assigned to them.
Creating and modifying fur | 2
Fur Description node >

Bake Attribute

You can map textures to attributes, but the maps must be simple file textures. The Fur renderer only understands simple file textures. You can map any shading network including procedural textures to a fur attribute, but you must convert them into file textures by baking them.

If you map attribute values using the method available by going to the Details section of the Attribute Editor, you can only map file textures, and therefore do not need to bake them.

If you map values using any other method, (or example, drag and drop, or the Map button, you must bake the map.

In the Bake Attribute drop-down list, select the attribute for which you want to convert maps to file textures and click the Bake button. Fur saves the map in .IFF format in the furAttrMap directory. If you rebake an attribute the old map is overwritten.

For details about mapping attributes, see “Map fur attribute values” on page 40.

Map Width, Map Height

These are the width and height values for attribute maps you create using Bake Attribute and the Bake button. Also when you paint fur attributes on a surface using the Paint Fur Attributes Tool, Fur creates value grids the size of which are defined by the number of U and V Samples. When you render a scene, Fur exports these values to maps that the renderer can use. You can define the size of the exported map. (These values are not used if you import value maps in the fur description.)

These values set the width and height of the attribute map to be used by the renderer. The default is 256x256.

Base Color

Defines the color of the fur base. Use the slider to adjust the value. Click the Base Color box and select the fur base color from the Color Chooser.

Use the Map button to map a file texture to the base color. You must bake the map to convert it to a file texture. See “Bake Attribute”.

| Tip | Make the base color of the fur the same as the surface’s material color. |
Creating and modifying fur | 2

Fur Description node >

Tip Color

Defines the color of the fur tip. Use the slider to adjust the value. Click the Tip Color box and select the fur tip color from the Color Chooser.

Use the Map button to map a file texture to the tip color. You must bake the map to convert it to a file texture. See “Bake Attribute” on page 55.

Tip

For more realistic looking fur, start by making the Tip Color the same as the Base Color. Then reduce the color Saturation and increase the Value so the tip is slightly lighter than the base.

Base Ambient Color

Defines the ambient color of the fur base. This color is added to the Base Color to produce the effect of ambient lighting. Use the slider to adjust the value. Click the Base Ambient Color box and select the base ambient color from the Color Chooser.

This option only has an effect if the selected Light Model includes Ambient.

Note

True ambient lights do not affect the fur color. In Maya, an ambient light with the Ambient Shade attribute set to 0 is a true ambient light. If the Ambient Shade attribute of an ambient light is greater than 0, then the light does affect the fur color.

By default, the Base Ambient Color is black (value of 0), which means the Base Color is not affected. As you lighten the Base Ambient Color (increase the color value), the Base Color becomes lighter.

Use the Map button to map a file texture to the base ambient color. If the map you apply is not a file texture, you must bake the map to convert it to a file texture. See “Bake Attribute” on page 55.

Tips

- Start by making the Base Ambient Color a darker shade of the Base Color.
- If the color of the rendered fur appears too rich, try reducing the color Saturation to make the Base Ambient Color more gray.
Tip Ambient Color

Defines the ambient color of the fur tip. This color is added to the Tip Color to produce the effect of ambient lighting. Use the slider to adjust the value. Click the Tip Ambient Color box and select the tip ambient color from the Color Chooser.

This option only has an effect if the selected Light Model includes Ambient.

By default, the Tip Ambient Color is black (value of 0), which means the Tip Color is not affected. As you lighten the Tip Ambient Color (increase the color Value), the Tip Color becomes lighter.

Use the Map button to map a file texture to the tip ambient color. You must bake the map to convert it to a file texture. See “Bake Attribute” on page 55.

<table>
<thead>
<tr>
<th>Tips</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Start by making the Tip Ambient Color a darker shade of the Tip Color.</td>
</tr>
<tr>
<td>• If the color of the rendered fur appears too rich, try reducing the color Saturation to make the Tip Ambient Color more gray.</td>
</tr>
</tbody>
</table>

Specular Color

Defines the color of shiny highlights on the fur. Use the slider to adjust the specularity value. Click the Specular Color box and select the specular color from the Color Chooser.

This option only has an effect if the selected Light Model includes Specular.

Use the Map button to map a file texture to the specular color. If the map you apply is not a file texture, you must bake the map to convert it to a file texture. See “Bake Attribute” on page 55.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start by using the default Specular Color (gray).</td>
</tr>
<tr>
<td>If the rendered fur appears too shiny, reduce the value of the Specular Color and try increasing Specular Sharpness.</td>
</tr>
</tbody>
</table>

Specular Sharpness

Defines the sharpness of the fur highlight. A larger number yields a sharper (smaller) specular highlight.
Creating and modifying fur | 2
Fur Description node

This option only has an effect if the selected Light Model includes Specular.

Tip
Start by using the default Specular Sharpness value (50). If the rendered fur appears too shiny, reduce the value of the Specular Color and try increasing Specular Sharpness.

Length
Defines the fur length in world units. Use the slider to adjust the length.

Note
If you want to paint fur length when the fur description length is greater than 1, do the following:
- Use the Artisan Paint Fur Attributes Tool to flood the selected surface with a Length value of 1.
- Then set the Length Map Multiplier to the desired number, for example, 3. For details, see “Change attribute map value ranges” on page 32. You can now paint values between 0 and the value set for the Multiplier.

Baldness
Defines how much fur is on the surface. Use the following settings as guidelines:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>Full fur</td>
</tr>
<tr>
<td>0.0</td>
<td>Total baldness</td>
</tr>
</tbody>
</table>

Note
You can paint or map 256 levels of baldness, but fur feedback can display only 16 different levels.

Tip
Use Baldness when you have areas on a model that require a different fur description (for example, a beard, or eyebrows). Attach a new fur description to the surface with the Baldness set to 0 and either map higher Baldness values or use the Artisan Paint Fur Attributes Tool to paint higher Baldness values on the surface. For an example of this workflow, see “Add whiskers” on page 153.
Inclination

Sets the amount of inclination (slope). Use the following settings as guidelines:

0.0  No inclination. The fur is fully erect (normal to the surface). This is the default.
0.5  Partial inclination.
1.0  Fully inclined. The fur lies flat (tangent to the surface at the root).

Roll

Rotates the fur about the surface V axis. You can achieve almost any fur angle using Polar and Inclination, so use this option only when the fur has curl and you want the curls to lie flat. Use the following settings as guidelines:

0.0  -90 degree rotation.
0.5  No rotation. This is the default.
1.0  90 degree rotation.

In the following examples, the Inclination is set to 0.

Polar

Rotates the fur about the surface normal. Use the following settings as guidelines:

0.0  -180 degree rotation.
0.5  No rotation. This is the default.
1.0  180 degree rotation.
Creating and modifying fur | 2
Fur Description node >

Note  If the inclination is set to 0 and the base curl, tip curl, and roll are set to 0.5, the fur is actually on the surface normal, so changes you make to the polar setting will have no apparent effect (and therefore “combing” will have no apparent effect). For information on combing, see “Comb fur” on page 36.

In the following examples, the Inclination is set to 1.0.

Value 0.5  Value 0.75  Value 1.0

Tips  • You can “comb” fur using the Paint Fur Attributes Tool. The direction you comb sets the polar values.
• To quickly change the direction the fur lies in, select Fur > Offset Fur Direction By and select the appropriate option. For more information, see “Offset the direction fur grows” on page 30.

Base Opacity
Defines the opacity of the fur base. Use the following settings as guidelines:

0.0  Completely transparent base.
1.0  Completely opaque base.

Tip Opacity
Defines the opacity of the fur tip. Use the following settings as guidelines:

0.0  Completely transparent tip.
1.0  Completely opaque tip.

Tip  For more realistic looking fur, make the tip slightly transparent (try a value of 0.7).
Base Width

Defines the width of each hair at the base, in world units.

<table>
<thead>
<tr>
<th>Tip</th>
<th>To ensure full coverage of the underlying skin without increasing density (and render time), make the Base Width wider than the Tip Width.</th>
</tr>
</thead>
</table>

Tip Width

Defines the width of each hair at the tip, in world units.

Base Curl

Defines the amount of curl at the base of the fur. The fur tip is not influenced by this value. Use the following settings as guidelines:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.0</td>
<td>Half-circle curl to one side.</td>
</tr>
<tr>
<td>0.5</td>
<td>No curl.</td>
</tr>
<tr>
<td>1.0</td>
<td>Half-circle curl to the other side.</td>
</tr>
</tbody>
</table>

Tip

For a curly effect, make the base curl and tip curl values greater than 1. In the following example, Length=15, Base Curl=10, Tip Curl=5, Scraggle=0.1, and Segments=100. Polar and Inclination are both set to 1.0.
Creating and modifying fur | 2  
Fur Description node >

**Tip Curl**

Defines the amount of curl at the tip of the fur. The fur base is not influenced by this value. Use the following settings as guidelines:

- **0.0** Half-circle curl to one side.
- **0.5** No curl.
- **1.0** Half-circle curl to the other side.

<table>
<thead>
<tr>
<th>Value 0.0</th>
<th>Value 0.5</th>
<th>Value 1.0</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Value 0.0" /></td>
<td><img src="image2" alt="Value 0.5" /></td>
<td><img src="image3" alt="Value 1.0" /></td>
</tr>
</tbody>
</table>

**Tip**  For a curly effect, make the base curl and tip curl values greater than 1. See “Base Curl”.

**Scraggle**

Defines how crooked the fur is. Use the following settings as guidelines:

- **0.0** No scraggle.
- **1.0** Full scraggle. This is defined by the Scraggle Frequency.

<table>
<thead>
<tr>
<th>Value 0.0</th>
<th>Value 0.25</th>
<th>Value 0.5</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image4" alt="Value 0.0" /></td>
<td><img src="image5" alt="Value 0.25" /></td>
<td><img src="image6" alt="Value 0.5" /></td>
</tr>
</tbody>
</table>

**Note**  A small scraggle value produces a more realistic fur effect.
Creating and modifying fur | 2
Fur Description node >

Scraggle Frequency

Defines the amount of change over each length of hair. The higher the value, the more changes there will be along each length of hair (the hair becomes more deformed).

| Note | You may need to increase the number of Segments to accurately reflect the detail produced by a high frequency. See “Segments” on page 64. |

Scraggle Correlation

Defines how the scraggle of each hair relates to each other hair. Use the following settings as guidelines:

- **0.0**: No correlation, so each hair has a unique scraggle.
- **1.0**: Total correlation, so all hair “scraggles” in exactly the same way.

Clumping

The degree to which the hairs are pulled in towards the centre of the clump. The higher the clumping value, the more the hairs are pulled in. The range is from 0 to 1. The default is 0, which is no clumping.

Clumping Frequency

Controls how many clumps occur across the surface. The higher the frequency, the greater the number, and therefore the smaller the size of the clumps. The range is from 0 to 100. The default is 5.

As you increase the Clumping Frequency, the rendering time increases.

Unlike other Fur attributes, the number of feedback hairs (samples) affects the Clumping Frequency. For example, at a frequency of 100 there will be 1 clump for every feedback hair.
Creating and modifying fur | 2

Fur Description node >

Clump Shape

Controls the shape of the curve of the hair as it is attracted to the center of the clump. Negative values create a concave shape and positive values create a convex shape. The range is from -10 to 10.

Segments

Defines the number of segments each fur is comprised of. For smoother curves, use more segments. The longer the fur, the more segments you need to produce a smooth result.

Attraction

Defines the amount of attraction this fur description has towards attractors. (Attractors are used to add movement to fur. For details, see “Adding movement to fur” on page 75.) Use the following settings as guidelines:

0.0      No attraction.
1.0      Full attraction.

You can use this attribute to balance how multiple fur descriptions are attracted towards the same set of attractors.

Offset

Defines how much to offset the fur description (in world units) from the surface it is attached to. When the Offset value is 0, the roots of the fur hairs start growing from the surface. When the value is less than zero, the roots start growing from inside the surface. When the value is greater than zero, the roots start growing from outside the surface. You can paint, map, and animate Offset.
Creating and modifying fur | 2

Fur Description node >

Custom Equalizer

This option is available if you select Custom Equalizer Maps in the Fur Globals (Fur > Fur Globals). You can paint or map this attribute like any other fur description attribute. For more information, see “Equalizer Maps” on page 137.

Details

For each Fur Description attribute there is a corresponding subsection in the Details section. Here you can define additional values for that attribute. For more information see “Randomly vary fur attribute values” on page 31 and “Change attribute map value ranges” on page 32.

Map Offset

Set the factor you want to offset the attribute value by. For example, if you want to change the range of values for fur Length from the default 0-1 to 4-5, set the offset to 4.

Map Multiplier

Set the factor you want the value multiplied by. For example, if you want to change the range of values for fur Length from the default, 0-1, to 0-10, set the multiplier to 10.

Noise Amplitude

Set the noise value for the attribute. A value of 0 produces no noise or variation.

Noise Frequency

Set the noise frequency for the attribute. The larger the Noise Frequency, the more variation over distance or area.
Creating and modifying fur | 2
Fur Description node >

Fur > Attach Fur Description
Use this to attach a new or existing fur description to the selected surface(s). For more information see “Create fur” on page 20 and “Attach and detach fur” on page 24.

Fur > Edit Fur Description
Use this to select a fur description and view its Attribute Editor. For more information, see “Edit fur descriptions” on page 31.

Fur > Paint Fur Attributes Tool
This opens the Paint Fur Attributes Tool Settings window and turns the mouse pointer into a brush, as with all Artisan tools. Use the Paint Fur Attributes Tool to paint attributes of a fur description. For more information, see “Paint fur attribute values” on page 33.

Fur > Paint Fur Attributes Tool >
This opens the Paint Fur Attributes Tool Settings window and the tool settings editor (Paint Scripts Tool since Fur is a plug-in). Below are descriptions of the options in the Paint Fur Attributes Tool Settings window. For descriptions of the attributes in the Paint Scripts Tool Settings editor, see “Common Artisan Brush Tool Settings” in the online Paint Effects, Artisan, and 3D Paint guide. See also “Artisan Brush Tool Settings” and “How Artisan brush tools work” in the Paint Effects, Artisan, and 3D Paint guide.

Fur Attribute
Select the attribute you want to paint values for on the surface. If you are painting attractor set values (Attractor Set) select one of the Attractor attributes.

Fur Description
Select the fur description you want to paint. Only the fur descriptions attached to the selected surfaces are available for selection.

Attractor Set
Select the attractor set you want to paint. Only the attractor sets attached to the selected surfaces are available for selection.

Attribute Map Width
Attribute Map Height
When you paint fur attributes on a surface using the Paint Fur Attributes Tool, Fur creates value grids the size of which are defined by the number of U and V Samples. When you render a scene, Fur...
exports these values to maps that the renderer can use. You can define the size of the exported map. (These values are not used if you import value maps in the fur description.)

These values set the width and height of the attribute map to be used by the renderer. The default is 256 x 256. The attribute map should be larger than the number of U and V Samples (as a rule of thumb, the attribute map should be at least twice as large) or you will lose detail for attributes you paint using the Paint Attributes Tool. If your surface has fewer CVs in U and V than the map, increasing the map size has no effect.

**Fur > Update Fur Maps**

Use this to update attribute maps when you:

- map or paint fur attributes in scenes that are referenced
- paint fur attributes outside of the Paint Fur Attributes Tool, such as in the Paint Effects canvas, or in an external application, such as Photoshop

For more information, see “Update fur maps” on page 46.

**Fur > Fur Description (more)**

Use this to:

- create an unattached fur description (see “To create an unattached fur description” on page 21)
- detach a fur description (see “To detach a fur description” on page 25)
- duplicate a fur description (see ”To duplicate a fur description” on page 21)
- delete a fur description (see ”Delete fur” on page 24)
- select the surfaces attached to a fur description (see ”Select the surfaces a fur description is attached to” on page 25)

**Fur > Reverse Fur Normals**

Use this to reverse the direction fur points from the surface (inside versus outside). For more information, see ”Reverse fur normals” on page 29.

**Fur > Offset Fur Direction by**

Use this to change the direction (angle) fur grows. For more information, see ”Offset the direction fur grows” on page 30.
3 Animating fur attributes

How do I? Animate fur attributes

You can animate most fur attributes to achieve special effects. For example, you can animate fur length so that fur appears to grow, or you can animate fur inclination so that a character’s fur stands on end.

Density is one fur attribute that cannot be animated. However, animating Baldness will give the same effect as animating Density.

Animate fur attributes by keying the changes you make to the attributes. The following procedure describes just one way of keyframing. For other methods, refer to Animation in Maya in the Animation guide.

To key fur attributes

1 Attach a fur description to the surface. For details, see “Create fur” on page 20.

2 Turn on Auto Key by clicking at the bottom-right corner of the Maya main window and move to the first frame. For other methods, refer to Animation in Maya in the Animation guide.

3 Do one of the following:
   - Select the fur feedback and in the INPUTS section of the Channel Box, select the appropriate fur description.
   - Select Fur > Edit Fur Description > FurDescriptionName to open the Attribute Editor.

4 Select the attribute you want to animate, right-click it and select one of the following:
   - If you are in the Channel Box, select Key Selected.
   - If you are in the Attribute Editor, select Set Key.

5 Move to another frame and edit the fur description attributes. For details, see “Change fur attributes” on page 31.

6 Repeat step 6 as required.

7 Click the Play Forward button to check that the attributes are behaving the way you want them to.

8 Render the animation. See “Render an animation with fur” on page 129.
Make fur grow

The following example illustrates how you can animate fur attributes by keyframing them. In this example, length is animated to produce the effect of grass growing. (Notice that Maya Fur can also be used for non-fur effects, like grass or wheat.)

To animate grass growing

1. Create a plane and add lights to the scene.

2. Add a texture to the plane to make it look like earth.

3. Attach a fur description to the surface and name it. For details, see "Create fur" on page 20.

4. Set the fur attributes in the Attribute Editor (Fur > Edit Fur Description > FurDescriptionName).
• Map a texture to the fur base and tip color to make it look more realistic. Try green marble for grass. For details, see “Map fur attribute values” on page 40.

• Add Scraggle. Try a value of 0.3.

• Map a texture or file to the Baldness attribute. In this example, the following file texture was used:

![Texture Image]

• Bake the Baldness attribute.

The surface remains bald (no grass will grow) where the map is black (value of 0). For details, see ”Map fur attribute values” on page 40.

5 Turn on Auto Key by clicking 

6 at the bottom-right corner of the Maya main window and move to the first frame.

6 Set the fur Length to 0.

7 In the Attribute Editor, right-click the Length field and select Set Key.

8 Move to the last frame and make the fur longer. Try a Length of 4.

9 Click the Play Forward button to check that the attributes are behaving the way you want them to.
10 Render the animation. For details, see “Render an animation with fur” on page 129.

Make fur spread using animated file textures

The following example illustrates how you can animate fur attributes by mapping animated file textures to them. In this example, baldness is animated to produce the effect of fur sprouting and spreading across a character, like a werewolf. For information on creating a series of animated file textures, see “To paint a series of textures.”

To paint a series of textures

1 Switch to the Paint Effects panel and select Paint > Paint Canvas.
2 Change the size of the canvas to 256 x 256.
   • Select Canvas > Set Size.
   • Set both the X Size and Y Size to 256 and click Set Size, and then click Close.
3 Set the canvas color to black if you want the value of the mapped attribute to be 0, or to white so the value is 1.
4 Either leave the canvas black for the first file texture or paint a little bit. Then save the first texture in the sequence:
   • Select Canvas > Save As.
   • Go to the textures directory.
   • Type a filename with a frame number, such as, spreadFur.1.iff, and click Save.
5 Paint the canvas a little more and then save the next texture in the sequence.
6 Repeat step 5 until you’ve finished creating all the sequences for the animated file texture.
To animate fur spreading across a character like a werewolf

1. Create a plane and add lights to the scene.
2. Add a texture to the plane to make it look like skin.
3. Attach a fur description to the surface and name it. For details, see "Create fur" on page 20.
4. Apply the Llama fur preset to the Fur Description (Fur > Edit Fur Description > FurDescriptionName).
   - Click the Presets button in the Fur Description, select Sheep and then select replace.
5. Map an animated file texture to the Baldness attribute:
   - Right-click Baldness and select Create New Texture. For details, see "Apply animated file textures to objects" on page 46.
   - Select File from the Create Render Node window.
   - Make sure you are at frame 1.
   - In the file node, click the folder button to browse for the following animated file texture in the textures directory, spreadFur.1.iff, then click Open. (This is the first texture file in the sequence.)
   - Turn on Use Image Sequence. This automatically keys each frame with the numbered texture file on a 1 to 1 basis.
6. Bake the Baldness attribute.
   - In the Fur Description select Baldness from the Bake Attribute drop-down list and click Bake.

   The surface remains bald where the map is black (value of 0) and grows where the surface becomes white (value of 1). For details on painting a sequence of textures, see "To paint a series of textures" on page 72.
7. Click the Play Forward button to check that the attributes are behaving the way you want them to.
8 Render the animation. For details, see “Render an animation with fur” on page 129.
4 Adding movement to fur

How do I? Add movement to fur

Add movement to fur

If you are animating your scenes, you can create more natural looking fur by making it react to movement and forces. For example, when you shake your head, your hair does not typically stay in one place (unless it is very short)—it follows the movement of your head. Similarly, your hair does not stay in place on a windy day. You add movement to fur using attractors, which are joint chains that “attract” the hairs making up the fur. When you move the attractors the fur follows that movement according to the attributes you define.

The basic workflow for adding movement to fur is as follows

1. Add fur to the surface. For details, see “Creating and modifying fur” on page 19.
2. Create attractors and attach them to the surface. For details, see “Create attractors” on page 76.

Note An attractor can only have three joints (two bones). Editing an attractor joint chain to contain more joints will cause erroneous results in the rendering, which may not match the fur feedback.

3. Modify attractor set attributes. For details, see ”Change attractor set attributes” on page 85.
4. Animate the movement of the attractors. There are four ways to do this:
Adding movement to fur | 4

Create attractors >

- Manually keyframe and rotate the base of a simple chain with linked joint rotations. For details, see “Keyframe simple chain attractors with linked joint rotations” on page 89.
- Manually keyframe and move the positions of the IK handles. For details, see ”Keyframe IK chain attractors” on page 92.
- Using Dynamics, add forces (for example, wind and gravity) to the scene and connect them to the particles on the attractors. For details, see “Move attractors by connecting forces to attractor particles” on page 97.
- Using Dynamics, animate the movement of the surface. The attractors will react appropriately in response to the movement. For details, see “Move attractors by moving the surface they are attached to” on page 101.

5 Render the frames that make up the animation. For details, see “Render an animation with fur” on page 129.

Create attractors

When you create attractors, they are added to an attractor set. An attractor set is collection of attractors that have the same attributes.

There are three ways to create attractors. For details, see:
- ”Create a grid of attractors on a surface” on page 77
- ”Create a single attractor at the selected point(s) or face(s)” on page 78
- “Create a single attractor at the origin” on page 80.

You can create attractors on multiple surface points/faces/surfaces simultaneously for both NURBS and polygons. You can also delete attractors and attractor sets. For details, see “Delete attractors and attractor sets” on page 83.

You can also create an empty attractor set attached to the selected surface(s) and then add attractors afterwards. You might want to do this if you decide to separate some attractors into a different set (which can have different attribute settings) after they have been created. See “Create an empty attractor set” on page 82.

Note

An attractor can only have three joints (two bones). Editing an attractor joint chain to contain more joints will cause erroneous results in the rendering, which may not match the fur feedback.
Create a grid of attractors on a surface

This is an efficient way of adding many attractors to the surface or multiple surfaces at once. Some effects work better the more attractors you have on the surface (for example, a wheat field blowing in the wind).

**Note** Creating a grid of attractors does not work on subdivision surfaces.

To create and attach a grid of attractors to a surface

1. Check that the fur on the surface(s) you are adding attractors to “grows” out from the surface. Reverse fur on any surface with fur growing in. For details, see “Reverse fur normals” on page 29.

2. Select the surface(s) with fur on it and click the Select Tool.

3. In the Rendering menu set select Fur > Create Attractor. The Create Attractor dialog box opens.

4. Select Create: A grid of attractors on the selected surface(s).

5. Specify the number of attractors you want placed along the U and V parameters of the grid.

6. In the Attractor length field, type the length of the attractors. The length of the attractor is mapped to the length defined by the Start Length and End Length attractor set attributes. See “Start Length” on page 107 and “End Length” on page 108.
Adding movement to fur | 4
Create attractors >

7 Select what type of attractors you want to create. The type you select determines how you can animate.
   • Simple chain with linked joint rotations
   • Dynamic chain
   • IK chain
For descriptions of the types, see “Fur > Create Attractor” on page 109.

| Note | You cannot change this setting after creating the attractors. |

8 Select which attractor set you want to place the attractors into. By default, the first time you create attractors in your scene, Fur creates an attractor set called FurAttractors1 and places the new attractors in it. To change the name, you must modify the attractor set attributes. For details, see ”Change attractor set attributes” on page 85.

| Notes | • You only need to create more than one attractor set if you want different attractors to have different attributes (for example, power, influence, threshold).  
       • You can add selected attractors to an attractor set at any time. For details, see ”Add attractors to a set” on page 84. |

9 Ensure that Attach attractor set to selection is turned on. This is the default. If you do not attach the attractor set to the selection, the attractors will have no effect on the fur attached to the selected surface.

10 Click Create. Fur adds the attractors to the surface.

| Note | An attractor can only have three joints (two bones). Editing an attractor joint chain to contain more joints will cause erroneous results in the rendering, which may not match the fur feedback. |

Create a single attractor at the selected point(s) or face(s)
This method is useful for filling in areas on a surface grid where there are no attractors, or for adding movement to a very localized patch of fur (for example, a tuft on the top of a head). This is also useful for adding to selected faces on subdivision surfaces.
Adding movement to fur

You can have multiple surface points or faces selected for this operation. Hold the Shift key while making the selections.

To create and attach a single attractor at the selected point(s) or face(s)

1. Check that the fur on the surface(s) you are adding the attractor to “grows” out from the surface. Reverse fur on any surface with fur growing in. For details, see “Reverse fur normals” on page 29.

2. Select the surface(s) with fur and click the Select Tool .

3. Right-click the surface(s) and select Surface Point or Face.

4. Click the point/face on the surface where you want to add an attractor. Shift-click to select multiple surface points/faces.

5. In the Rendering menu set select Fur > Create Attractor. The Create Attractor dialog box opens.

6. Select Create: One attractor at the selected point(s)/face(s).

7. In the Attractor length field, type the length of the attractors. The length of the attractor is mapped to the length defined by the Start Length and End Length attractor set attributes. See “Start Length” on page 107 and “End Length” on page 108.
Adding movement to fur | 4
Create attractors >

8 Select which type of attractor you want to create. The type you select determines how you can animate.
   - Simple chain with linked joint rotations
   - Dynamic chain
   - IK chain

For descriptions of the types, see “Fur > Create Attractor” on page 109.

Note You cannot change this setting after creating the attractor.

9 Select which attractor set you want to place the attractor into. By default, the first time you create attractors in your scene, Fur creates an attractor set called FurAttractors1 and places the new attractors in it. To change the name, you must modify the attractor set attributes. For details, see “Change attractor set attributes” on page 85.

Notes
   - You only need to create more than one attractor set if you want different attractors to have different attributes (for example, power, influence, threshold).
   - You can add selected attractors to an attractor set at any time. For details, see ”Add attractors to a set” on page 84.

10 Ensure that Attach attractor set to selection is turned on. This is the default. If you do not attach the attractor set to the selection, the attractors will have no effect on the fur attached to the selected surface.

11 Click Create. Fur creates the attractor at the selected point.

Note An attractor can only have three joints (two bones). Editing an attractor joint chain to contain more joints will cause erroneous results in the rendering, which may not match the fur feedback.

Create a single attractor at the origin

If you choose to have all hairs mimic the attractors (see “Attractor Model” on page 105), you only need to have one attractor affect the fur. Placing this attractor at the origin makes it easy to locate.
To create a single attractor at the origin

1. Check that the fur on the surface(s) you are adding the attractor to “grows” out from the surface. Reverse fur on any surface with fur growing in. For details, see “Reverse fur normals” on page 29.

2. Select the surface with fur on it and click the Select Tool .

3. In the Rendering menu set select Fur > Create Attractor. The Create Attractor dialog opens.

4. Select Create: One attractor at the origin.

5. In the Attractor Length field, type the length of the attractors. The length of the attractor is mapped to the length defined by the Start Length and End Length attractor set attributes. See “Start Length” on page 107 and “End Length” on page 108.

6. Select which type of attractor you want to create. The type you select determines how you can animate.
   - Simple chain with linked joint rotations
   - Dynamic chain
   - IK chain
   For descriptions of the types, see “Fur > Create Attractor” on page 109.

Note You cannot change this setting after creating the attractor.
Adding movement to fur | 4
Create attractors >

7 Select which attractor set you want to place the attractor into. By default, the first time you create attractors in your scene, Fur creates an attractor set called FurAttractors1 and places the new attractors in it. To change the name, you must modify the attractor set attributes. For details, see “Change attractor set attributes” on page 85.

| Notes | • You only need to create more than one attractor set if you want different attractors to have different attributes (for example, power, influence, threshold).
• You can add selected attractors to an attractor set at any time. For details, see “Add attractors to a set” on page 84. |

8 Ensure that Attach Attractor Set to Selection is turned on. This is the default. If you do not attach the attractor set to the selection, the attractors will have no effect on the fur attached to the selected surface.

9 Click Create. Fur creates the attractor at the origin.

| Note | An attractor can only have three joints (two bones). Editing an attractor joint chain to contain more joints will cause erroneous results in the rendering, which may not match the fur feedback. |

Create an empty attractor set
You can create an empty attractor set and add attractors afterwards. You might want to do this if you decide to separate some attractors into a different set (which can have different attribute settings) after they have been created. You have the option of the set being attached to the surface(s).

To create an empty attractor set
1 Select the surface(s) with fur.
2 Select Fur > Attractor Set (more) > Create > ☐. The Create Attractor Set Options window appears.
3 As desired, turn on or off the Assign to Selected Surfaces option.
4 Click Apply and Close.
   To add attractors to the set see, “Create attractors” on page 76 and “Add attractors to a set” on page 84.
Delete attractors and attractor sets

You can delete individual attractors and you can delete entire attractor sets.

To delete an attractor set

In the Rendering menu set select Fur > Attractor Set (more) > Delete > AttractorSetName, where AttractorSetName is the name of the attractor set being deleted.

To delete individual attractors

1. Select Window > Outliner and click the attractor name.
2. Press the Delete key on your keyboard.

Attach and detach attractor sets

Attaching an attractor set to a surface associates the attractors in the set with the surface so that they affect the fur descriptions attached to them.

If you have already created an attractor set, you can attach the set to any selected surface. You may have created the attractor set without attaching it to the surface, or attached it to other surfaces when you created it.

To attach an attractor set to a surface

1. Select the surface you want to attach attractors to. You can attach more than one attractor set to a surface.
2. In the Rendering menu set select Fur > Attractor Set (more) > Attach to Selected > AttractorSetName, where AttractorSetName is the name of the attractor set you want to attach.

To detach an attractor set

1. Select the surface you want to detach an attractor set from.
2. In the Rendering menu set select Fur > Attractor Set (more) > Detach From Selected > AttractorSetName, where AttractorSetName is the name of the attractor set you want to detach.

Select the surfaces an attractor set is attached to

You can quickly select the surfaces an attractor set is attached to. This is useful, for example, if you want to detach the attractors.
Display feedback for the attractor set

You can preview the effect an attractor set has on fur before you render by enabling fur feedback for the attractor set.

To display feedback for an attractor set

1. Select the surface(s) you want to display attractor set feedback for.
2. In the Rendering menu set select Fur > Enable Feedback for > AttractorSetName, where AttractorSetName is the name of the attractor set for which you want to preview the effect.

Select attractors

You can select attractors individually or you can select all the attractors belonging to a set (for example, if you want to keyframe them or add them to another set).

To select individual attractors

Select Window > Outliner and click the attractor name.

To select all the attractors in a set

In the Rendering menu set select Fur > Attractor Set (more) > Select Attractors in Set > AttractorSetName, where AttractorSetName is the name of the attractor set from which you want to select attractors.

Add attractors to a set

There are two ways to add attractors to a set.

- You can add them to a set when you create the attractors (see “Create attractors” on page 76).
- You can add existing attractors to a set.

To add existing attractors to a set

1. Select the attractors you want to add to a set. For details, see “Select attractors” on page 84.
2 In the Rendering menu set select Fur > Attractor Set (more) > Add Attractor to Set > AttractorSetName, where AttractorSetName is the name of the attractor set you want to add the selected attractors to.

Remove attractors from a set
You can also remove attractors from a set.

To remove attractors from a set
1 Select the attractors you want to remove from a set. For details, see “Select attractors” on page 84.
2 In the Rendering menu set select Fur > Attractor Set (more) > Remove Attractor From Set > AttractorSetName, where AttractorSetName is the name of the attractor set you want to remove the selected attractors from.

Note Removing an attractor from a set does not delete it. For details on deleting attractors, see “Delete attractors and attractor sets” on page 83.

Change attractor set attributes
After you create an attractor set, you can edit the attributes of the set at any time. The attributes define how the attractors in the set relate to the hairs making up the fur. There are three ways to change attractor set attributes:

- Change the attributes for the attractor set so they are assigned to all surfaces that have the attractor set attached. See “Edit attractor sets” on page 85.
- Selectively paint specific attributes on attractors without changing the attributes of the attractor set attached to the surface. See “Paint attractor set attribute values” on page 86.
- Map values for each attractor set attribute. See “Map attractor set attribute values” on page 88.

Edit attractor sets
When you edit an attractor set, any changes you make apply to all surfaces that are assigned to that attractor set. The attributes are applied to each attractor in the set.
Adding movement to fur | 4
Change attractor set attributes >

To edit an attractor set

In the Rendering menu set select Fur > Edit Attractor Set > AttractorSetName to display the Attribute Editor and then modify the attribute settings. For descriptions of the attributes, see “Fur Attractors node” on page 105.

Randomly vary attractor set attribute values

You can randomly vary attractor set attribute values for a more natural effect using noise amplitude and noise frequency. Noise amplitude refers to the variance of an attribute, and noise frequency refers to the amount of variance over a distance or area.

To set noise amplitude and noise frequency

1. Edit the attractor set. For details, see “Change attractor set attributes” on page 85.
2. Go to the Details section, then go to the attribute you want to change noise values for.
3. Modify the Noise Amplitude and Noise Frequency values. For more information see “Details” on page 108.

Change attribute map value ranges

By default, attribute map value ranges are defined to be between 0 and 1. You only need to change value ranges when you want to paint or map values other than those defined in this range. For example, you could change the range from 0.2 to 0.5, 2.0 to 3.0, or commonly, from 0 to 5. For information on painting values, see “Paint attractor set attribute values” on page 86. For information on mapping values, see “Map attractor set attribute values” on page 88.

You can set value ranges for all attractor set attribute values.

To change attribute map value ranges

1. Edit the attractor set. For details, see “Change attractor set attributes” on page 85.
2. Go to the Details section, then go to the attribute you want to change value ranges for.
3. Modify the Map Offset and Map Multiplier attributes. For more information see “Details” on page 108.

Paint attractor set attribute values

Just as you can paint fur attribute values (see “Paint fur attribute values” on page 33), you can paint attractor set attribute values on an area without changing the attractor set attributes for the entire surface.
When you paint values on a surface, Maya creates a map of the values for each of the attractor set attributes that you change.

You can paint the following attractor set attributes: Attractor Radius, Attractor Power, Attractor Influence, Attractor Start Length, Attractor End Length, and Attractor Threshold Length. For information about these attributes, see "Fur Attractors node" on page 105.

**Note** You cannot use Artisan to mask selected vertices.

---

**Tip**

Before using Maya Artisan to paint fur attribute values, set and learn the Maya hotkeys for at least the following commands:

- Under the Brush Tools category, ModifyUpperRadius.
- Under the Artisan category, ModifyPaintValue, FloodSurfaces, ToggleWireframeInArtisan, ToggleColorFeedback, and ToggleReflection.

You will find these commands increase your efficiency as you work with the Paint Fur Attributes Tool.

### To paint attractor set values

1. Select the surface(s) you want to paint. Each selected surface must have an attractor set assigned to it.

2. In the Rendering menu set select Fur > Paint Fur Attributes Tool > . The Paint Fur Attributes Tool Settings window opens, followed by the Attribute Paint editor.

   ![Paint Fur Attributes Tool Settings](image)

3. In the Paint Fur Attributes Tool Settings window, modify the following settings:
   - Fur Attribute - Select the attractor set attribute you want to paint values for on the surface.
   - Fur Description - Attractor sets are not connected to fur descriptions, so this automatically displays None when you select an attractor set attribute. You cannot change this setting.
**Adding movement to fur | 4**  
Change attractor set attributes >

4 In the Attribute Paint editor, select an appropriate Value, Profile, and Operation. For details, see *Artisan Brush Tool settings* in the Paint Effects, Artisan, and 3D Paint guide.

5 Drag the brush across the surface.

| Tip | You can quickly restore attractor set attribute values to the prepainted values by deleting the attribute map created when you painted the fur. For details, see ”To remove maps from an attribute” on page 47. |

**To paint attribute values greater than 1**

1 Use the Artisan Paint Fur Attributes Tool to flood the selected surface with an attribute value of 1.
   - Select the attribute from the Fur Attribute drop-down list.
   - Set the Value to 1.
   - Click the Flood button.

2 Set the attribute Map Multiplier to the number you want to paint. For details, see “Change attribute map value ranges” on page 86. You can now paint values between 0 and less than the value set for the Multiplier.

**Map Multiplier**

Set the factor you want the value multiplied by. For example, if you want to change the range of values for fur Length from the default, 0-1, to 0-10, set the multiplier to 10.

**Map attractor set attribute values**

Just as you can map fur attribute values, you can map values for each attractor set attribute by importing file textures. To map attractor set attributes, follow the procedures for mapping fur attribute values, editing the attribute set instead of the fur description. For details, see ”Map fur attribute values” on page 40.

Remember that because Fur can use only simple file texture maps, every texture you import must be “baked” to convert it to a file texture.

**Related topics**

- ”Map fur attribute values” on page 40
Manually keyframe fur movement

If you want more control over fur movement, you can keyframe attractors manually, as long as they are either simple chain attractors, or IK chain attractors.

Keyframe simple chain attractors with linked joint rotations

Simple chain attractors have linked joint rotations. When you rotate the base joint the middle joint will start rotating after a delay of a specified number of frames, causing the tip joint to follow, like the tip of a whip. The effect is a very natural waving motion.

The following procedure describes just one method of keyframing. For more information about keyframing, see Keyframe Animation in the Animation guide.

To manually keyframe simple chain attractors with linked joint rotations

1. Create simple chain attractors with linked joint rotations and attach them to the surface with fur on it. For details, see “Create attractors” on page 76.
2. Modify the attractor set attributes, as required. For details, see “Change attractor set attributes” on page 85.
3. Turn on Auto Key by clicking at the bottom-right corner of the Maya main window.
4. Move to the first frame.
5. Select the base joint of the attractor you want to keyframe.
6. In the Channel Box select the Rotate X, Rotate Y, and Rotate Z fields.
7. Right-click one of the selected fields and select Key Selected.
8. Move to another frame and rotate the base joint to the desired position.
9. Repeat step 8 as required.
10. Click the Play Forward button to check that the attractors are moving the way you want the fur to move.
11. Fine-tune the movement of the attractors, if necessary.
12. Show the fur feedback (in the Rendering menu set select Fur > Switch Feedback To > FurDescriptionName), and click the Play Forward button to check that the fur is moving the way you want it to.
Adding movement to fur | 4
Manually keyframe fur movement >

13 Render the animation. See “Render an animation with fur” on page 129.

Example of “seaweed” moving in water
The following example illustrates how you can make fur move by rotating the base joints of simple chain attractors with linked joint rotations.

To create “seaweed” in water
1 Make a plane and add lights to the scene. For a sea-bed effect, sculpt the plane using the Artisan Sculpt Surfaces or Sculpt Polygons Tool, and apply a file texture.

2 Add fur to the plane. We changed the attributes as follows:
**Adding movement to fur | 4**  
Manually keyframe fur movement >

Base Color = mapped a green fractal file texture  
Tip Color = mapped a green fractal file texture  
Baldness = mapped a brownian file texture  
Base Width Noise Amplitude = 0.02  
Tip Width Noise Amplitude = 0.015  
Length = 3  
Segments = 30

3. Hide the fur feedback so you can see the next steps more clearly (in the Rendering menu set select Fur > Switch Feedback To > None).

4. Add an attractor at the origin. (See "Create a single attractor at the origin" on page 80.) Make sure you select Simple Chain with linked joint rotations as the attractor Type.

5. Modify the attractor set attributes (in the Rendering menu set select Fur > Edit Attractor Set > AttractorSetName). In this example, the Attractor Model is Local, the Radius is 30, and all other attributes are the default.

6. Turn on Auto Key by clicking at the bottom-right corner of the Maya main window.

7. Move to the first frame.

8. Select the base joint of the attractor.

9. In the Channel Box select the Rotate X, Rotate Y, and Rotate Z fields.

10. Right-click one of the selected fields and select Key Selected.

11. Rotate the base joint to the desired position, then move to another frame.
Adding movement to fur | 4
Manually keyframe fur movement >

12 Repeat steps 10 and 11 as required.

13 Click the Play Forward button to check that the attractors are moving the way you want the fur to move.

14 Fine-tune the movement of the attractors, if necessary.

15 Show the fur feedback (in the Rendering menu set select Fur > Switch Feedback To > FurDescriptionName), and click the Play Forward button to check that the fur is moving the way you want it to.

16 Render the animation. See “Render an animation with fur” on page 129.

Keyframe IK chain attractors

You can make fur move by manually keyframing the IK handles of the attractors attached to the surface with fur on it, then rendering each of the frames in the sequence.

The following procedure describes just one method of keyframing. For more information about keyframing, see Keyframe Animation in the Animation guide.
To manually keyframe IK chain attractors

1. Create IK chain attractors and attach them to the surface with fur on it. For details, see "Create attractors" on page 76.

2. Modify the attractor set attributes, as required. For details, see "Change attractor set attributes" on page 85.

3. Turn on Auto Key by clicking at the bottom-right corner of the Maya main window.

4. Move to the first frame.

5. Select the IK handles of the attractors you want to keyframe.

6. In the Channel Box select the Translate X, Translate Y, and Translate Z fields.

7. Right-click one of the selected fields and select Key Selected.

8. Move to another frame and drag the IK handles to the new position.

9. Repeat step 8 as required.

10. Click the Play Forward button to check that the attractors are moving the way you want the fur to move.

11. Fine-tune the movement of the attractors, if necessary.

12. Show the fur feedback (in the Rendering menu set select Fur > Switch Feedback To > FurDescriptionName), and click the Play Forward button to check that the fur is moving the way you want it to.

13. Render the animation. See "Render an animation with fur" on page 129.

Example of parting fur or hair

The following example illustrates how you can make fur react to the movement of attractors that have been animated by moving IK handles.
**To make fur part**

1. Make a plane and add lights to the scene.
   Change the color of the plane and store it in the Color Chooser.

   ![Image of a plane with lights](image1)

2. Add fur to the plane. We changed the attributes as follows:
   - Base Color = same color as the plane
   - Tip Color = same color as the plane (increased value, lower saturation)
   - Specular Sharpness = 100
   - Tip Width = 0.01
   - Length = 4

   ![Image of a plane with fur](image2)

3. Hide the fur feedback so you can see the next steps more clearly (in the Rendering menu set select Fur > Switch Feedback To > None).

4. Add an attractor where you want the part to be. (See “Create a single attractor at the selected point(s) or face(s)” on page 78.) Make sure you select IK Chain as the attractor Type.

   ![Image of an attractor on a plane](image3)
5 Add another attractor adjacent to the first attractor and belonging to the same attractor set. For details, see “Create a single attractor at the selected point(s) or face(s)” on page 78. Make sure you select IK Chain as the attractor Type.

6 Modify the attractor set attributes (in the Rendering menu set select Fur > Edit Attractor Set > AttractorSetName).

In this example, the Attractor Model is Local, and the Radius is 20. For a smoother parting, the Influence was keyframed (move to the first frame, right-click in the Influence field and select Set Key, move to the last frame and change the influence value to 5).

7 Turn on Auto Key by clicking  at the bottom-right corner of the Maya main window.

8 Move to the first frame.

9 Select the IK handle of the first attractor you want to keyframe.

10 In the Channel Box select the Translate X, Translate Y, and Translate Z fields.

11 Right-click one of the selected fields and select Key Selected.

12 Move to another frame and drag the IK handle to the new position.

13 Repeat steps 9 through 12 for the second attractor.
Adding movement to fur | 4
Make fur move using dynamics

14 Repeat steps 12 and 13 as required.

15 Click the Play Forward button to check that the attractors are moving the way you want the fur to move.

16 Fine-tune the movement of the attractors, if necessary.

17 Show the fur feedback (in the Rendering menu set select Fur > Switch Feedback To > FurDescriptionName), and click the Play Forward button to check that the fur is moving the way you want it to.

18 Render the animation. See “Render an animation with fur” on page 129.

Make fur move using dynamics

Using Dynamics, you can make fur move in either of the following ways:

- Add forces (for example, wind and gravity) to the scene and connect them to the particles on the attractors. See “Move attractors by connecting forces to attractor particles” on page 97.
- Animate the movement of the surface and the attractors will react appropriately. See “Move attractors by moving the surface they are attached to” on page 101.

To make fur move using dynamics, the attractors you use must be dynamic chain attractors.

For more information about dynamics, see the Dynamics guide.
Move attractors by connecting forces to attractor particles

By connecting forces to attractor particles, the attractors will move appropriately in reaction to the forces. In turn, the fur will react to the movement of the attractors.

To move attractors by connecting forces to attractor particles

1. Create dynamic chain attractors and attach them to the surface with fur on it. For details, see "Create attractors" on page 76.
2. Use the Dynamics pick mask to select the attractors you want to react to forces.
3. Add forces to the scene (for example, wind and turbulence). For details, see the Dynamics guide.
4. Modify forces and spring attributes, as required. For details, see the Dynamics guide.
5. Modify attractor set attributes, as required. For details, see "Change attractor set attributes" on page 85.
6. Click the Play Forward button to check that the attractors are moving the way you want the fur to move.
7. Fine-tune the movement of the attractors, if necessary.
8. Show the fur feedback (in the Rendering menu set select Fur > Switch Feedback To > FurDescriptionName), and click the Play Forward button to check that the fur is moving the way you want it to.
9. Render the frames that make up the animation. For details, see "Render an animation with fur" on page 129.

Example of a 'wheat field' blowing in the wind

The following example illustrates how you can make fur react to dynamic forces. By adding wind and turbulence to the scene, you can produce an effect similar to a wheat field blowing in the wind.
Adding movement to fur | 4
Make fur move using dynamics >

To make a ‘wheat field’ blow in the wind

1 Make a plane and add lights to the scene.

2 Add fur to the plane. We changed the attributes as follows:
   Base Color = wheat color
   Tip Color = wheat color
   Density = 5000
   Length = 6
   Segments = 100
   Scraggle = 0.1
   Polar Noise Amplitude = 0.1
   Length Noise Amplitude = 0.5
   Baldness Noise Amplitude = 0.2
Adding movement to fur | 4
Make fur move using dynamics >

3 Hide the fur feedback so you can see the next steps more clearly (in the Rendering menu set select Fur > Switch Feedback To > None).

4 Add a 5 by 5 grid of attractors. For details, see “Create a grid of attractors on a surface” on page 77. Make sure you select Dynamic Chain as the attractor Type.

Note On subdivision surfaces, you cannot create a grid of attractors automatically. Create your grid by creating single attractors at the origin and moving them. For details, see “Create a single attractor at the origin” on page 80.

5 Fill in random areas on the grid by adding individual Dynamic Chain attractors at the selected points or faces. For details, see “Create a single attractor at the selected point(s) or face(s)” on page 78.

6 Add wind. We added it as follows:
**Adding movement to fur | 4**

Make fur move using dynamics 

- Use the pick mask to select the particles on all of the attractors.

- In the Dynamics menu set (press F4), select Fields > Create Air.
- In the Channel Box change the Magnitude to 150.

**7** Add turbulence as follows:
- Use the pick mask to select the particles on all of the attractors.
- In the Dynamics menu set (press F4), select Fields > Create Turbulence.
- In the Channel Box change the following attributes:
  
  - Magnitude = 100
  - Frequency = 100

**8** Change the spring attributes. We changed them as follows:
- Use the pick mask to select the springs on all of the attractors.
- Open the Attribute Spreadsheet (Window > General Editors > Attribute Spreadsheet).
- Click the Shape Keyable tab and change the Stiffness to 5 for all the springs.

**9** Edit the attractor set (in the Rendering menu set select Fur > Edit Attractor Set > AttractorSetName). We changed the following attributes:

- Attractor Model = Global
- Attractors per Hair = 1
- Radius = 10
- Influence = 2
- End Length = 7
10 Click the Play Forward button to check that the attractors are moving the way you want the fur to move.

11 Fine-tune the movement of the attractors, if necessary.

12 Show the fur feedback (in the Rendering menu set select Fur > Switch Feedback To > FurDescriptionName) and click the Play Forward button to check that the fur is moving the way you want it to.

13 Render the frames that make up the animation. For details, see “Render an animation with fur” on page 129.

Move attractors by moving the surface they are attached to

By animating the movement of the surface, the attractors attached to the surface will react appropriately. In turn, the fur will react to the movement of the attractors.

To move attractors by moving the surface they are attached to

1 Create dynamic chain attractors and attach them to the surface with fur on it. (See “Create attractors” on page 76.)

2 Modify the attractor set attributes as required. (See “Change attractor set attributes” on page 85.)

3 Keyframe the movement of the surface as follows. (This is just one method of keyframing. For more information about keyframing, see Keyframe Animation in the Animation guide.)
   • Turn on Auto Key by clicking at the bottom-right corner of the Maya main window.
   • Move to the first frame and select Animate > Set Key.
   • In the Channel Box select the Rotate X, Rotate Y, and Rotate Z fields, or Translate X, Translate Y, and Translate Z fields.
   • Right-click one of the selected fields and select Key Selected.
   • Move to another frame and change the Rotate or Translate values.
   • Repeat the previous step as required.

4 Modify the attractor set attributes as required. (See “Change attractor set attributes” on page 85.)

5 Click the Play Forward button to check that the attractors are moving the way you want the fur to move.

6 Fine-tune the movement of the attractors, if necessary.
Adding movement to fur | 4
Make fur move using dynamics >

7  Show the fur feedback (in the Rendering menu set select Fur > Switch Feedback To > FurDescriptionName) and click the Play Forward button to check that the fur is moving the way you want it to.

8  Render the frames that make up the animation. For details, see "Render an animation with fur" on page 129.

Example of an animal shaking
The following example illustrates how you can make fur react to the motion of the object it’s attached to. For example, when an animal shakes its body, its fur reacts to the motion. For simplicity, we’ve used a cylinder to represent the body of the animal.

To make fur react to motion
1  Make a cylinder and add lights to your scene.
2 Add fur to the cylinder. We changed the attributes as follows:

- Base Color = gray-brown
- Tip Color = gray-brown
- Density = 5000
- Length = 4.5
- Specular Sharpness = 50
- Scraggle = 0.2
- Polar = mapped value
- Inclination Noise Amplitude = 0.1
- Polar Noise Amplitude = 0.2
- Length Noise Amplitude = 0.3
Adding movement to fur | 4
Make fur move using dynamics

3 Hide the fur feedback so you can see the next steps more clearly (Fur > Switch Feedback To > None).

4 Add a 3 by 6 grid of attractors. (See “To create and attach a grid of attractors to a surface” on page 77. Make sure you select Dynamic Chain as the attractor Type.)

5 Keyframe the movement of the cylinder as follows:
   • Turn on Auto Key by clicking at the bottom-right corner of the Maya main window.
   • Move to the first frame and select Animate > Set Key.
   • In the Channel Box select the Rotate X, Rotate Y, and Rotate Z fields.
   • Right-click one of the selected fields and select Key Selected.
   • Move to another frame and change the Rotate values.
   • Repeat the previous step as required.

6 Edit the attractor set (in the Rendering menu set select Fur > Edit Attractor Set > AttractorSetName). We changed the following attributes:
   Attractor Model = Global
   Attractors per Hair = 1
   Radius = 10
   Influence = 0.5
   End Length = 5
   Threshold Length = 0.33

7 Click the Play Forward button to check that the attractors are moving the way you want the fur to move.
8 Fine-tune the movement of the attractors, if necessary.
9 Show the fur feedback (in the Rendering menu set select Fur > Switch Feedback To > FurDescriptionName) and click the Play Forward button to check that the fur is moving the way you want it to.
10 Render the frames that make up the animation. For details, see “Render an animation with fur” on page 129.

Reference Fur Attractors node

These are the descriptions of the attributes in the Fur Attractors node. For more information, see “Change attractor set attributes” on page 85 and “Fur > Edit Attractor Set” on page 110.

FurAttractors
Replace the default name for the fur attractor set with something meaningful (for example, windAttractors).

Attractor Model
Select the type of attractor you want.

Local Each hair mimics the closest attractor(s) (see “Attractors Per Hair” on page 106) within the defined radius (see “Radius” on page 106).

Global Each hair grows towards the closest attractor(s) (see “Attractors Per Hair” on page 106) within the defined radius (see “Radius” on page 106).
Adding movement to fur | 4
Fur Attractors node

Attractors Per Hair
Type the number of attractors a hair should be influenced by. Use the following attributes as guidelines:

1  Every hair is influenced by the attractor closest to it.
2  Every hair is influenced by the two closest attractors.
3  Every hair is influenced by the three closest attractors.

Global Scale
Use this setting to adjust the Radius, Power, Influence, and Length values by a common factor (including mapped values).

Bake Attribute
Specify the attribute or all attributes to be baked.

Bake
Click this button to bake the attributes specified in the Bake Attribute drop-down list.

Radius
Set the radius in which to search for the closest attractors, in world units. This value can help prevent hairs from being influenced by attractors that are unreasonably far away.

Power
Set how the attractor will influence the hairs. The value you enter is the power to a falloff function that makes hairs become less influenced at the base of the hair than at the tip.

0.0  The entire length of the hair is influenced.
1.0

Hair is much less influenced at the base.

**Influence**

Set how much influence the attractor will have on the hairs. The value you enter linearly increases or decreases the influence over the length of the hair. Use the following attributes as guidelines:

- 0.0: No influence.
- 1.0: Standard influence.

For more influence, use a higher value.

**Start Length**

Set the point along the hair, in world units, at which the hair will start being influenced. In general, this value should be 0.0, unless you want the hair to grow in its normal direction up to a point along the hair.

**End Length**

Set the point along the hair, in world units, at which the hair will no longer be influenced. For the best effect, this should be at least as large as the longest hair length. With smaller values the tips of the hairs will not be influenced.
Adding movement to fur | 4
Fur Attractors node >

**Note**  If you add Fur Length Noise to your fur description, the End Length should be longer than the fur length to account for the extra length created by the noise.

<table>
<thead>
<tr>
<th>Fur Length value of 5.0</th>
<th>End Length value of 5.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fur Length value of 5.0</td>
<td>End Length value of 3.0</td>
</tr>
</tbody>
</table>

Threshold Length

Hairs shorter than this value will not be influenced at all. Use this value to prevent short hairs from being influenced while long hairs are influenced.

**Details**

For each Fur Attractor attribute there is a corresponding subsection in the Details section. Here you can define additional values for that attribute. For more information see “Randomly vary attractor set attribute values” on page 86 and “Change attribute map value ranges” on page 86.

**Map Offset**

Set the factor you want to offset the attribute value by. For example, if you want to change the range of values for fur Length from the default 0-1 to 4-5, set the offset to 4.

**Map Multiplier**

Set the factor you want the value multiplied by. For example, if you want to change the range of values for fur Length from the default, 0-1, to 0-10, set the multiplier to 10.

**Noise Amplitude**

Set the noise value for the attribute. A value of 0 produces no noise or variation.
Noise Frequency

Set the noise frequency for the attribute. The larger the Noise Frequency, the more variation over a distance or area.

Related topics

- “Create attractors”
- “Delete attractors and attractor sets”
- “Attach and detach attractor sets”
- “Select the surfaces an attractor set is attached to”
- “Display feedback for the attractor set”
- “Select attractors”
- “Add attractors to a set”
- “Remove attractors from a set”
- “Change attractor set attributes”
- “Manually keyframe fur movement”
- “Make fur move using dynamics”

Fur > Create Attractor

This opens the Create Attractor dialog box. These are descriptions of the options in the Create Attractor dialog box.

Create

Select one of the create options: One attractor at the selected surface point(s)/face(s), A grid of attractors on the selected surface(s), or One attractor at the origin.

Type

Select which type of attractor you want to create. The type you select determines how you can animate.

Simple chain with linked joint rotations

Creates simple chain attractors with linked joint rotations. When you keyframe the rotation of the base joint, the middle joint will begin rotating after the number of frames you set in the Delay frames field. For details, see “Keyframe simple chain attractors with linked joint rotations” on page 89.

Dynamic chain

Creates dynamic chain attractors. Using Dynamics you can add dynamic movement to fur. For details, see “Make fur move using dynamics” on page 96.
Adding movement to fur | 4

Fur Attractors node >

IK chain

Creates IK chain attractors. You can keyframe the IK handles. For details, see “Keyframe IK chain attractors” on page 92.

Place attractors into

By default the attractors are put in a New Attractor Set, unless you specify an existing set in the drop-down list.

Attach attractor set to selection

Turn this on to attach the attractors to the selection.

Related topics

- “Create attractors”
- “Delete attractors and attractor sets”
- “Attach and detach attractor sets”
- “Select the surfaces an attractor set is attached to”
- “Display feedback for the attractor set”
- “Select attractors”
- “Add attractors to a set”
- “Remove attractors from a set”
- “Change attractor set attributes”
- “Manually keyframe fur movement”
- “Make fur move using dynamics”

Fur > Edit Attractor Set

Use this to open the Fur Attractors node in the Attribute Editor for the selected Attractor Set. For more information, see “Change attractor set attributes” on page 85 and “Fur Attractors node” on page 105.

Fur > Enable Feedback for

Use this to preview the effect the selected attractor set has on the fur feedback. For more information, see “Display feedback for the attractor set” on page 84.

Fur > Attractor Set (more)

Use this to:

- create an attractor set (see “Create attractors” on page 76)
• attach an attractor set to selected surfaces (see “Attach and detach attractor sets” on page 83)
• detach an attractor set from selected surfaces (see “Attach and detach attractor sets” on page 83)
• delete an attractor set (see “Delete attractors and attractor sets” on page 83)
• select surfaces attached to an attractor set (see “Select the surfaces an attractor set is attached to” on page 83)
• add attractors to an attractor set (see “Add attractors to a set” on page 84)
• remove attractors from an attractor set (see “Remove attractors from a set” on page 85)
• select attractors in an attractor set (see “Select attractors” on page 84)
Adding movement to fur | 4
Fur Attractors node >
5 Adding fur shading effects

About

Adding fur shading effects

How you add fur shading effects depends on which renderer you’re using: mental ray for Maya or the Maya Software renderer.

- “Fur shading with the mental ray for Maya renderer” on page 113
- “Fur shading with the Maya Software renderer” on page 113
- “Rendering fur in the Maya software renderer vs. mental ray for Maya” on page 126

Fur shading with the mental ray for Maya renderer

If you’re using the mental ray for Maya renderer, you can set up fur self-shading and shadowing using either Depth Map Shadows or Ray Traced Shadows.

- “Create fur shading and shadows using the mental ray for Maya renderer” on page 116

Fur shading with the Maya Software renderer

If you’re using the Maya Software renderer, to create more realistic looking fur with self-shading and shadows, you must first add fur light attributes. Then you can set up one of the following effects per light:

- No shadows, no shading (less realistic)
- No shadows, simple shading (relatively realistic)
- (Depth Map) Shadows (most realistic, but longer rendering time)
Adding fur shading effects | 5
Fur shading with the Maya Software renderer >

No shadows or shading
Without fur shadows or shading the fur will look less realistic. The rendering time is the same for simple shading, but shorter than with fur shadows. If you do not want fur shadows or shading in your scene, do one of the following:

- Do not add fur light attributes to the lights in your scene.
- If you have already added fur light attributes to a light, remove them, or set the Fur Shading Type to No Shading. For details, see “Remove fur shadowing attributes from a light” on page 119.

Simple fur shading
To shade fur that is relatively realistic and takes no longer to render than no shading, set Auto-Shading as the Fur Shading Type in the Fur Shading/Shadowing section of the light’s Attribute Editor. There are two aspects to Auto-Shading lights:

- Self-shading
- Back shadows

Self-shading
Most fur roots are not exposed to light. Self-shading simulates this effect by lighting the tips of the fur, and making the roots dark.
Back shadows
Fur on the side of an object, away from a light doesn’t receive as much light. Back shadows simulate this effect.

Related topics
- “To set up a light for simple fur shading for use with the Maya Software renderer” on page 118
- “Rendering fur in the Maya software renderer vs. mental ray for Maya” on page 126

Fur depth map shadows
To generate realistic shadows onto fur and geometry, you create fur shadow maps. A fur shadow map represents depth information generated from the position and orientation of a shadow map light. Maya uses this depth information when rendering fur to create two types of shadowing: fur shadowing (fur casts shadows on itself) and geometry shadowing (fur casts shadows on geometry). Only a spot light can be used for shadow maps with the Maya Software renderer.
When you render fur, Maya creates a shadow map for each shadow map light. Be aware that although generating several fur shadow maps may produce more realistic results, it takes time and slows rendering. In general, one shadow map takes twice as long to render as no shadow maps and two shadow maps take three times as long to render.

The following example shows fur rendered without fur shadow map lights (and no Fur Shading), and fur rendered with one fur shadow light.

Related topics
- “To set up a light for fur shadow maps for use with the Maya Software renderer” on page 118
- “Rendering fur in the Maya software renderer vs. mental ray for Maya” on page 126

How do I? Create fur shading and shadows using the mental ray for Maya renderer

The mental ray renderer supports both Depth Map Shadows and Ray Traced Shadows on Fur.

To set up a light for fur self-shading and shadows for the mental ray renderer

1. Select the light you want to set up and open the light’s Attribute Editor (Ctrl+a).
2. To cast fur shadows on geometry and vice versa, go to the Shadows section and do one of the following:
Adding fur shading effects | 5

Create fur shading and shadows using the Maya Software renderer

- Under Depth Map Shadow Attributes, turn on Use Depth Map Shadows and then turn off Use Dmap Auto Focus. Then go to the mental ray section and under Shadow Maps, make sure Shadow Map is turned on.
- Under Raytrace Shadow Attributes, turn on Use Ray Trace Shadows.

3 If you make any changes to settings in the Shadows section for either Depth Map Shadows or Ray Trace Shadows, be sure to click the Take Settings from Maya button in the mental ray Shadow Maps section.

| Tip | For precision, increase the Samples value in the mental ray Shadow Maps section of the light’s Attribute Editor. |

| Note | When rendering fur using mental ray for Maya, it helps to select PreviewFur as the Quality Preset in the mental ray tab of the Render Global Settings window. |

Create fur shading and shadows using the Maya Software renderer

In the Maya Software renderer, you create fur shading and shadows by adding fur light attributes to the lights in your scene. A light with fur light attributes can either be an Auto-Shade light for simple shading and less expensive rendering, or a Shadow Map light for more realistic fur shadows (to cast fur shadows on geometry and vice versa). The Maya Software renderer supports only Depth Map Shadows for fur and only spot lights for fur shadow maps.

True ambient lights do not affect fur. In Maya, an ambient light with the Ambient Shade attribute set to 0 is a true ambient light. If the Ambient Shade attribute of an ambient light is greater than 0, then the light does affect fur. Use the Base Ambient Color and Tip Ambient Color fur attributes to create ambient shading effects. For details, see Base Ambient Color and Tip Ambient Color.

For more information about the fur shading options, see:

- “No shadows or shading” on page 114
- “Simple fur shading” on page 114
- “Fur depth map shadows” on page 115
Adding fur shading effects | 5
Create fur shading and shadows using the Maya Software renderer

To set up a light for simple fur shading for use with the Maya Software renderer

1 Select the light you want to set up.
   For information on adding lights to your scene, see Create a Maya light source in the Lighting guide.

2 In the Rendering menu set select Fur > Fur Shadowing Attributes > Add to Selected Light.

3 Open the light’s Attribute Editor (Ctrl+a).

4 Go to the Fur Shading/Shadowing section and select Auto-Shading from the Fur Shading Type drop-down list.

5 Adjust the Self Shade and Back Shade settings as desired. For descriptions of these attributes, see “Fur Shading/Shadowing attributes” on page 120.

To set up a light for fur shadow maps for use with the Maya Software renderer

Note You can only use a spot light for fur shadow maps when using the Maya Software renderer.

1 Select the spot light you want to set up.
   For information on adding lights to your scene, see Create a Maya light source in the Lighting guide.

2 In the Rendering menu set select Fur > Fur Shadowing Attributes > Add to Selected Light.

3 Open the light’s Attribute Editor (Ctrl+a).

4 Go to the Fur Shading/Shadowing section and select Shadow Maps from the Fur Shading Type drop-down list.

5 Go to the Shadows section and under Depth Map Shadow Attributes, turn on Use Depth Map Shadows and also turn off Use Dmap Auto Focus.

Adjust the light intensity on fur

Note This applies only to lights set up to render Fur with the Maya Software renderer.

If the fur appears too brightly lit, you can adjust the intensity of the light on the fur, even if your fur lights are set to have no shading.
Adding fur shading effects | 5

Create fur shading and shadows using the Maya Software renderer >

**To adjust the light intensity on Fur**

1. Select the fur light you want to adjust.
   - The light must have Fur Shadowing Attributes. If it doesn’t then in the Rendering menu set select Fur > Fur Shadowing Attributes > Add to Selected Light.
2. Open the light’s Attribute Editor (Ctrl+a) and go to the Fur Shading/Shadowing section.
3. Set the Intensity Multiplier value, which is the factor by which you want to multiply the light intensity on the fur.
   - For example, if the light intensity is 0.8 and the Intensity Multiplier is 0.5, the light will have an intensity of 0.8 on geometry, but 0.4 on fur.

**Remove fur shadowing attributes from a light**

| Note | This applies only to lights set up to render Fur with the Maya Software renderer. |

Adding lights with fur shading/shadowing attributes increases render time. Therefore the more lights that have fur shading/shadowing attributes, the longer the scene takes to render. Including many lights that have fur shading/shadowing attributes may not noticeably improve the look of the fur. Experiment with the number of lights with fur shading/shadowing you need to achieve the effect you want and optimize render time.

You can easily remove fur shading/shadowing attributes from a light. However they only exist on a light if you’ve previously assigned them.

**To remove fur light attributes from a light**

1. Select the light you want to remove fur light attributes from.
2. Select Fur > Fur Shadowing Attributes > Remove from Selected Light.
Adding fur shading effects | 5
light Shape node

Notes
- You can temporarily remove light attributes from a light by setting the Fur Shading Type to No Shading (for example, when you need to quickly render a scene, and are not concerned with the shadow effects). You can restore the fur light attributes simply by changing the Fur Shading Type back to Auto-Shading or Shadow Maps. You do not need to reset the attributes.
- You can also render a scene as if the lights in the scene have no fur shadowing attributes using the Enable Fur Shading/Shadowing option. For information, see “To set up Fur Render Globals” on page 127 and “Fur Globals” on page 135.

Reference
light Shape node
In the light shape node for the selected light, there are various sections with attributes. When working with Fur, attributes in the Fur Shading/Shadowing section can be set.

Note
This applies only to lights set up to render Fur with the Maya Software renderer.

Fur Shading/Shadowing attributes
Below are descriptions of the Fur Shading/Shadowing attributes for the selected light’s “lightShape” node in the Attribute Editor. To see these attributes, select the light and open the Attribute Editor (Ctrl+a). If there are no attributes in this section and you are rendering with the Maya Software renderer, you must add Fur Shading/Shadowing attributes (select Fur > Fur Shadowing Attributes > Add to Selected Light).

Note
If rendering with mental ray for Maya, these attributes are ignored. You do not need to remove them from the light(s).

Related topics
- “Fur shading with the Maya Software renderer” on page 113
- “Create fur shading and shadows using the Maya Software renderer” on page 117
Adding fur shading effects

Select the type of fur shading you want the light to create.

**No Shading**
Disables fur shading effects without removing fur light attribute settings from the light. For information, see “No shadows or shading” on page 114.

**Auto-Shading**
The light creates simple fur shading effects. For information, see “Simple fur shading” on page 114.

**Shadow Maps**
(For spot lights only.) The light creates more realistic shadowing effects on fur and geometry. For information on shadow maps, see “Fur depth map shadows” on page 115.

**Self Shade**
For Auto-Shading type only. Set how far from the root the fur should be shaded. Use the following settings as guidelines:

- 0.0: No self-shading.
- 0.0001: Shadow at the root, linearly progressing to no shading at the tip of the fur.
- 0.5: Full shadow in the lower half, with the upper half linearly progressing to no shading at the tip of the fur.
- 1.0: Full shadow on the entire fur.

**Self Shade Darkness**
For Auto-Shading type only. Set the darkness of the self-shaded area. Use the following settings as guidelines:

- 0.0: No shadow, all fur color.
- 0.5: 50% black, 50% fur color.
- 1.0: Fully black, no fur color.
Adding fur shading effects | 5
light Shape node >

Back Shade Factor
For Auto-Shading type only. Set the power of the falloff curve between lit hairs and non-lit hairs. Use the following settings as guidelines:

0.0  No falloff.
1.0  Slow falloff.
2.0  More natural falloff.
3.0  Sharp falloff.

Back Shade Darkness
For Auto-Shading type only. Set the darkness of the back shadow area. Use the following settings as guidelines:

0.0  No shadow.
0.5  50% black, 50% fur color.
1.0  Fully black shadow, no fur color.
Threshold

For Shadow Maps only. Set how much of the pixel must be covered by hair before hair depth information is stored in the shadow map. Use this option to prevent very fine hairs from showing up in the shadow map (although it is rare, fine hairs can sometimes cast thick shadows). Use the following settings as guidelines:

- 0.0: Stores a depth value for each pixel of hair that exists in that pixel, no matter how fine the hair.
- 0.5: Only stores hair depth information for pixels that are covered 50% or more by hair.

Sublight Density

For area lights only. This option defines the number of point lights that make up an area light. Change this option only if the area lighting on the fur does not match the area lighting on the geometry. This will happen rarely, if ever and typically only with a long, skinny light.

Intensity Multiplier

Set the factor by which you want to multiply the light intensity on the fur. For example, if the light intensity is 0.8 and the Intensity Multiplier is 0.5, the light will have an intensity of 0.8 on geometry, but 0.4 on fur. This option is useful for adjusting fur that is too brightly lit.

Note: This Intensity Multiplier option is available even if Fur Shading Type is set to No Shading.

Fur > Fur Shadowing Attributes

Use this to add to or remove from a light’s Attribute Editor the Fur Shading/Shadowing attributes.
Adding fur shading effects | 5
light Shape node >

Note  This applies only to lights you want to set up to render Fur with the Maya Software renderer.

Related topics

- “Create fur shading and shadows using the Maya Software renderer” on page 117
- “light Shape node” on page 120
6 Rendering scenes with fur

About Rendering scenes with fur
The final stage in adding fur to your models is to render the scene. You can render Fur using the Maya Software renderer or the mental ray for Maya renderer.

Related topics
- “Rendering fur in the Maya software renderer vs. mental ray for Maya” on page 126
- “Set up Fur Render Globals before rendering” on page 127
- “Render scenes with fur” on page 128

Advanced fur rendering

Note Advanced Fur Rendering does not apply to the mental ray for Maya renderer; however, if you created equalizer maps using the Advanced Fur Renderer then mental ray uses them.

When you render a scene, Fur automatically builds and renders files that are used in the final render. Typically, this automatic process will meet your needs. In rare situations (for example, if you are using a proprietary render farm or need to composite elements later), you may want to build and render these files separately:

- Fur files
- Equalizer maps
- Shadow maps
- Fur images

Note Building files separately may require several passes (for example, to build shadow maps, the fur files and equalization maps must already be created).

Related topics
- “Build fur files separately (Maya Software renderer only)”
- “Build equalizer maps separately”
- “Build shadow maps and fur images separately (Maya Software renderer only)”
Rendering fur in the Maya software renderer vs. mental ray for Maya

Refer to the following table for the differences between rendering Fur in the Maya software renderer and mental ray for Maya. For mental ray specific Fur render settings, see "Render Stats" on page 144 and "mental ray" on page 145.

See also see mental ray for Maya renderer in the online Rendering guide.

<table>
<thead>
<tr>
<th>Fur item</th>
<th>Maya software renderer</th>
<th>mental ray for Maya</th>
</tr>
</thead>
<tbody>
<tr>
<td>Support for reflections</td>
<td>None</td>
<td>Fur shows up in reflective material, but is not reflective itself</td>
</tr>
<tr>
<td>Support for refractions</td>
<td>None</td>
<td>Fur is refracted through refractive material, but is not refractive itself</td>
</tr>
<tr>
<td>Support for colored shadows</td>
<td>Supports only black shadows</td>
<td>Yes</td>
</tr>
<tr>
<td>Support for correct penumbra and drop off</td>
<td>Not accurate</td>
<td>Yes</td>
</tr>
<tr>
<td>Support for correct DOF composition</td>
<td>Not accurate</td>
<td>Yes</td>
</tr>
<tr>
<td>Support for transparency</td>
<td>Fur can be transparent, but is not visible through transparent material (can render in layers and composite)</td>
<td>Fur is able to be transparent and to show up through transparent material</td>
</tr>
<tr>
<td>Advanced Fur Render</td>
<td>Can be used to generate fur files, equalizer maps, shadows and images</td>
<td>Can be used to generate equalizer maps only</td>
</tr>
<tr>
<td>Support for motion blur</td>
<td>3D only</td>
<td>Yes.</td>
</tr>
<tr>
<td>Need to add Fur Shadowing Attributes to lights to shadow Fur</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>
Set up Fur Render Globals before rendering >

Fur render globals are the attributes that define how the fur renders. In addition to the render globals you would normally define (see *Render Globals Settings window* in the Rendering guide), you must define fur-specific render globals before rendering.

**To set up Fur Render Globals**

In the Rendering menu set select Fur > Fur Globals and set the appropriate fur render options. For descriptions of these options see ”Fur Globals” on page 135.

<table>
<thead>
<tr>
<th>Fur item</th>
<th>Maya software renderer</th>
<th>mental ray for Maya</th>
</tr>
</thead>
<tbody>
<tr>
<td>Support for fast fake Back and Root Shading (AutoShade)</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Support for ray-traced shadows</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Support for depth-map shadows</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Fur integrated into scene</td>
<td>As a post process via z-depth composite</td>
<td>Fully integrated</td>
</tr>
<tr>
<td>Support for area value calculations (Fur Globals &gt; Calc. Area Values)</td>
<td>Yes</td>
<td>Currently not possible</td>
</tr>
<tr>
<td>Support for 16 bit rendering</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Support for texture-mapped lights</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Setting up Render Stats for each fur description

To specify render settings for each fur description, use the Render Stats settings in the FurFeedbackShape node of that fur description. Some settings are used only for rendering with mental ray for Maya.

**To set up Render Stats for Fur Feedback**

1. Select the FurFeedbackShape node in the Attribute Editor that corresponds to the fur description. If the FurFeedbackShape node is not displayed press Ctrl+a.
2. In the FurFeedbackShape node, go to the Render Stats section and turn on or off the desired settings. For descriptions of these settings, see “Render Stats” on page 144.

Render scenes with fur

After you set up your render globals and fur render globals you are ready to render the scene. You can render using the Maya Software renderer and the mental ray for Maya renderer.

Related topics:

- “Rendering fur in the Maya software renderer vs. mental ray for Maya” on page 126
- “Set up Fur Render Globals before rendering” on page 127

You can render either a single frame, or render an animation by performing a batch render. For information, see the following:

- “Render a single frame with fur” on page 129
- “Render an animation with fur” on page 129

About rendering fur using the Maya Software renderer

When you render a scene with fur using the Maya Software renderer, Maya creates fur files and stores them in the furFiles directory. To ensure that files do not overwrite each other during a distributed render, a process ID is added to the filename prefix of the fur files. For example, if you rendered a scene called furryscene, Maya would create the following fur files:

furryscene278_1_1.0001.sbs, furryscene278_1_1.ass

---

**Note** Some Fur Globals options are only supported by the Maya Software renderer. In these cases, this is indicated in the option’s description.
Furryscene278_1_1.hair, furryscene278_1_1.shadow
furryscene278_1_1_equal.0001.sbs

where 278_1_1 is the process ID.

Render a single frame with fur
Use the following procedure to render a single frame with fur in it.

To render a scene
1 Set up Render Globals. For information, see the Rendering guide. If you haven’t specified a renderer, you can do so in the Render Globals Settings window.
   If you’re rendering fur using mental ray for Maya, then select the PreviewFur Quality Preset in the mental ray tab of the Render Global Settings window.
2 Set up Fur Render Globals. See “To set up Fur Render Globals” on page 127.
3 In the Rendering menu set select Render > Render Current Frame. The image is rendered using the selected renderer and appears in Render View.

Render an animation with fur
Use the following procedure if you are animating scenes with fur. If you are animating fur attributes (see “Animate fur attributes” on page 69) or adding movement to fur using attractors (see “Adding movement to fur” on page 75), this is the final step.

To render an animation with fur
1 Set up Fur Render Globals. See “To set up Fur Render Globals” on page 127.
2 Modify Render Globals for animation as follows:
   • Select Windows > Rendering Editors > Render Globals and go to the Common tab.
   • In the File Name Prefix field, type the prefix you want to use for the rendered images.
   • In the Frame/Animation Ext field, select name.ext.#.
   • In the Start Frame and End Frame fields, type the first and last frames in the sequence you want to render.
   • If you haven’t specified a renderer, select Render > Render Using > and then select a renderer.
Rendering scenes with fur

If you’re rendering fur using mental ray for Maya, then select the PreviewFur Quality Preset in the mental ray tab of the Render Global Settings window.

Optionally, go to the renderer-specific tab and turn on Motion Blur in the Motion Blur section.

Note

The animation will take longer to render with Motion Blur turned on. If rendering a scene with motion blur using mental ray, use the following guidelines:

- For moving objects with fur or moving fur (attractors), set Motion Blur to “Exact” in the mental ray tab of the Render Global Settings window.
- If the camera is moving, set Motion Blur to either “Linear” or “Exact” in the mental ray tab of the Render Global Settings window.
- If the Segments attribute is keyframed, motion blur won’t work in mental ray.

Do one of the following:

- Select Render > Batch Render.
- Select Render > Batch Render > . The Batch Render Animation window appears. Change the options if desired and click Batch Render.

To view your rendered animation, launch Fcheck and then open the rendered.iff file. For more information on viewing the animation, see the Rendering guide.

To cancel a batch render

Select Render > Cancel Batch Render.

To render only the fur images of an animation

This applies only to the Maya Software renderer. This is helpful for users who want to generate only fur images and not use cycles to render geometry.

1 Select Fur > Fur Globals and in the Advanced Options section, turn on Disable Maya Rendering (batch only).
2 Select Render > Batch Render.

To cancel a render of only the fur images of an animation

Select Fur > Cancel Advanced Fur Render.
Render using distributed render

If you are performing a distributed render (for example, using Dispatcher), or if you are splitting up the render for any reason, you must pre-generate the equalization maps. For details, see “Build equalizer maps separately” on page 132. Sometimes it is also helpful to pre-generate the fur files when rendering in sections using the Maya Software renderer.

Build fur files separately (Maya Software renderer only)

Fur files are the files used to describe the geometry, lights and fur descriptions that exist in the Maya scene to the fur renderer. These files are created automatically when you render the scene using the Maya Software renderer, and also (for one frame only) when you create equalizer maps.

Occasionally, you might want to build the fur files separately, and then read them back in later on - for example, you might want to change some aspect of the scene so that the state of the geometry passed to the fur renderer is different from the state of the geometry used in the main Maya render pass. The most common use of pre-generating fur files is when you intend to render the scene in sections - if you have Calculate Area Values turned on, these are re-calculated for each section you render, and can cause the fur to shift or jump between sections. By pre-generating the fur files for the entire sequence, you avoid this problem entirely.

Fur creates the following fur files:

- SceneName.0001-x.sbs (one for each frame)
- SceneName.ass
- SceneName.hair
- SceneName.shadow
- SceneName_FurDescriptionName_AttributeName.crv (one for each animated or mapped attribute, where FurDescriptionName is the name of the fur description, and AttributeName is the name of the painted or mapped attribute)
- SceneName_equal.0001-x.sbs (one for each frame)

By default, fur files are stored in the furFiles directory and are prefaced with the scene name.
To build fur files separately

1. Set the Start Frame and End Frame in the Common tab of the Render Globals Settings window. (Window > Rendering Editors > Render Globals)

| Note | By Frame increments must be set to 1. |


3. Select Fur Files and select the appropriate options. For descriptions of these options see "Advanced Fur Rendering" on page 142.

4. Click Create Files. Fur creates the files and puts them in the specified paths.

Build equalizer maps separately

Equalizer maps define the density of fur so that the distribution of fur is even across the surface, even where parameterization is uneven. You must pre-generate these files to do a distributed render or if you split the render up for any reason.

By default, equalization maps are stored in the furEqualMap directory and have the file prefix equal.

| Note | Turning on Read Equalizer Maps in Fur Globals automatically generates equalizer maps, eliminating the need to use Advanced Fur Rendering. |

To build equalizer maps separately


2. Select Equalizer Maps then click Create Files. Fur creates the .iff files and puts them in the specified path. For descriptions of the Equalizer Map options see "Advanced Fur Rendering" on page 142.
Build shadow maps and fur images separately (Maya Software renderer only)

Shadow maps are the files that contain shadow images only. These maps are used to create the final fur image files. If you are rendering different views of your scene, you can save rendering time by reusing the existing shadow maps. By default, shadow maps are stored in the furShadowMap directory and are prefaced with the scene name.

Fur images are the rendered fur image files. By default, fur images are stored in the furImages directory and are prefaced with the scene name.

Tip You can render a separate shadow pass for fur using Use Background Shader.

To build shadow maps separately

To create shadow maps and fur images, you must already have created fur files and equalizer maps, if used. For details, see “Build fur files separately (Maya Software renderer only)” on page 131.

1 Select Fur > Advanced Fur Rendering. The Advanced Fur Rendering window opens.
2 Set the frame range in the Time Slider.
3 In the Advanced Fur Rendering window select Shadow Maps and Fur Images and then select the appropriate options. For descriptions of these options see “Advanced Fur Rendering” on page 142.
4 Click Create Files. Fur creates the .smap files (a file for each shadow map light) and puts them in the specified path.

Invoke Advanced Fur Rendering from the Script Editor or MEL prompt

In addition to building the various Fur files separately using the Advanced Fur Rendering window, you can also invoke these processes from the Script Editor or MEL prompt (using the Maya Software renderer).

You can use the following steps to create fur files in batch mode so they can be passed to a render farm.
To build fur files in batch mode

1. Type the following in the Script Editor or at the MEL prompt:
   
   ```mel
   buildFurImages -f $furFilesPath $equalizerMapsPath
   ```

   where `$furFilesPath` is the path where the fur files are stored, and
   `$equalizerMapsPath` is the path where the equalizer maps are stored.

   Your newly created fur files are located in your project’s FurFiles directory, for example, `batchtest.0002.sbs`.

2. In the Fur Globals (Fur > Fur Globals), go to the Advanced Options section, and in the Reference Paths section, turn on Read Fur Files and set the path to the first part of the prefix, excluding the frame number. Using the example in step 1, this would be `fur/furFiles/batchtest`.

3. Render.

To build fur files from the Script Editor or the MEL prompt

Type the following in the Script Editor or at the MEL prompt:

```mel
buildFurImages -f $furFilesPath $equalizerMapsPath;
```

where `$furFilesPath` is the path where the fur files are stored, and
`
$equalizerMapsPath` is the path where the equalizer maps are stored.

To create equalizer maps from the Script Editor or the MEL prompt

Type the following in the Script Editor or at the MEL prompt:

```mel
buildFurImages -e $equalizerMapsPath;
```

where `$equalizerMapsPath` is the path where the equalizer maps are stored.

To build fur image files from the Script Editor or the MEL prompt

Type the following in the Script Editor or at the MEL prompt:

```mel
buildFurImages -i $furFilesPath $shadowPath $imagePath 0 1
```

where `$furFilesPath` is the path where the fur files are stored,
`
$shadowPath` is the path where the fur shadow maps are stored, and
`
$imagePath` is the path where the fur images are stored.

To build fur shadow maps from the Script Editor or the MEL prompt

Type the following in the Script Editor or at the MEL prompt:

```mel
buildFurImages -i $furFilesPath $shadowPath $imagePath 1 0
```
where $furFilesPath is the path where the fur files are stored, $shadowPath is the path where the fur shadow maps are stored, and $imagePath is the path where the fur images are stored.

To build fur image files and shadow maps from the Script Editor or the MEL prompt
Type the following in the Script Editor or at the MEL prompt:

```
buildFurImages -i $furFilesPath $shadowPath $imagePath 1 1
```

where $furFilesPath is the path where the fur files are stored, $shadowPath is the path where the fur shadow maps are stored, and $imagePath is the path where the fur images are stored.

Reference

Fur Globals
These are descriptions of the options in the Fur Globals window (Fur > Fur Globals). All options are used by the Maya Software renderer when rendering Fur. However, some options are not required when rendering Fur in mental ray for Maya, since mental Fur is not a post-process pass. If an option is only used by the Maya Software renderer, it’s indicated in the option’s description.

Related topics
- “Set up Fur Render Globals before rendering”
- “Render scenes with fur”
- “Build fur files separately (Maya Software renderer only)”
- “Build equalizer maps separately”
- “Build shadow maps and fur images separately (Maya Software renderer only)”

Enable Fur
Renders fur when you render a scene. If you do not turn this option on, the scene renders but the fur is completely ignored (no Fur calculations are performed) so the fur image files are not created.

Fur Render Options
These are the options in the Fur Render Options section of the Fur Globals window.
Calc. Area Values

(This is only used by the Maya Software renderer.) Select how you want hair distributed across surfaces.

If you select Globally or Per Fur Description, hairs are distributed evenly across furry surfaces by taking the largest piece of furry geometry in the scene, assigning it a value of 1, then calculating values proportional to that surface for all the other furry surfaces in the scene. Then each surface receives a proportion of the density value set in the fur description assigned to the surface, based on the calculated area value.

For example, if the Density is set to 10,000, the largest furry surface will receive 10,000 hairs, whereas a surface in the scene that is half that size will receive 5,000 hairs.

Off Each surface receives the same number of hairs specified by the Density value for the fur description. This works if your character is made up of a single surface, or distinctly different surfaces. In these cases, you can use Baldness to roughly control relative densities within a single fur description.

Globally This option is the equivalent of turning on Area Value in previous versions of Fur. For models made up of multiple patches, this gives an even distribution on hairs across different sized surfaces.

The density of each fur description is distributed evenly over all surfaces with fur descriptions attached, regardless of which fur description is attached.

Per Fur Description Distributes hairs evenly across multiple different sized surfaces. The distribution of hair for one fur description does not affect the distribution for another fur description, unlike the Globally option. This is the default.

Comp. Fur

(This is only used by the Maya Software renderer.) Creates a composite of the rendered fur and the rendered models. The fur and the models render separately, but if you turn this option off they are not composited.
Keep Temp Files

(This is only respected by the Maya Software renderer.) Keeps the intermediate fur files built by Fur in the process of creating the final fur images. These intermediate files (fur files and shadow maps) are in the furFiles directory and the furShadowMap directory.

If you turn this option off, the intermediate files are deleted when the render is complete.

Note  The equalizer maps are not deleted.

Keep Fur Images

(This is only used by the Maya Software renderer.) Keeps the fur image files created by Fur. These files are useful when you turn on Comp. Fur, but still want to see the rendered fur without the model.

Copy Attr Maps

Select how Maya saves fur maps when you save a scene.

Unless Referenced  Saves fur maps only if the fur character is not referenced. When this option is selected, Maya uses the fur maps from the referenced file, even if you save the scene with a new name. If the character is not referenced and you save a copy of the scene with this option selected, Maya creates a copy of the fur maps.

Always  Saves different versions of the fur maps when you save different versions of a scene. Use this setting if you are working on different iterations or versions of the fur.

Never  Does not save a new fur map. Use this setting if you are no longer changing the fur and want to continue to use the saved fur maps, even if you save the scene with a new name.

Equalizer Maps

Select which equalizer maps you want to use for this render. An equalizer map compensates for the uneven distribution of fur caused by uneven parameterization so that fur is evenly distributed across the surface.
Rendering scenes with fur | 6

Fur Globals >

No Equalizer Maps
Uses no equalizer maps. Fur is distributed according to the parameterization of the surface. If the parameterization is uneven (for example, at the poles of a sphere), the distribution will not be even.

Default Equalizer Maps
Uses the equalization maps automatically created by fur.

Read Equalizer Maps
You can modify the equalization map using the Artisan Paint Fur Attributes Tool (see “Paint fur attribute values” on page 33) or pre-generate it using Advanced Fur Rendering (see “Build equalizer maps separately” on page 132). If you have done so and want to use the modified map in this render, select this option.

If you select Read Equalizer Maps, and a map has not already been generated through Advanced Fur Rendering, you are prompted with the following dialog box if you want to generate a default map. Otherwise you would choose your own map.

![Read Equalizer Map dialog box]

Custom Equalizer Maps
If you select Custom Equalizer Maps, you can see the Custom Equalizer attribute that appears in each fur description at the bottom of the list of attributes in the Attribute Editor. This attribute is grayed out when the Custom Equalizer Maps option is not selected.

The Custom Equalizer attribute can be mapped or painted like any other fur description attribute. If you don’t make any changes to a particular fur description, the default equalizer map is generated and used. When you paint the attribute for the first time, the map is initially set to the default equalization. That’s because when you select Custom Equalizer Maps, default equalizers are automatically generated and a copy is saved for
each fur description. The path of the Custom Equalizer Map files is displayed in the Fur Description in Details > Maps.

| Note | Custom Equalizer Maps are generated for each fur description, allowing you to have different equalization for different fur types. |

Equalizer Map Width
- Defines the width of the equalizer map. The default is 256.

Equalizer Map Height
- Defines the height of the equalizer map. The default is 256.

Advanced Options
These are the options in the Advanced Options section (subsection of Fur Render Options section) of the Fur Globals window.

Enable Fur Image Rendering
- (This is only used by the Maya Software renderer.) Turn this option off to render only the geometry and fur shadows on geometry (no fur images).

Enable Fur Shading/Shadowing
- (This is only used by the Maya Software renderer.) Turn this option off to render the fur and geometry as if the lights in the scene had no fur shadowing attributes.

Disable Maya Rendering (batch only)
- (This is only used by the Maya Software renderer.) Turn this option on if you are using a distributed or batch renderer and want to render only the fur images.

Auto Back Shade Spotlights
- (This is only used by the Maya Software renderer.) This controls whether or not fur growing on the side of objects away from spotlights is automatically excluded from the lighting effect, regardless of any Fur Shading applied to the light. The default is off.

NURBS Tessellation
- (This is only used by the Maya Software renderer.) The tessellation factor Fur uses for NURBS surfaces is sometimes higher than the default tessellation factor used by Maya for the NURBS surface. This sometimes results in mismatched composites.
Rendering scenes with fur | 6
Fur Globals >

Use this option to set the tessellation factor of the NURBS surface used by the Fur renderer.

Fur Image Rendering
These are the options in the Fur Image Rendering section (subsection of Advanced Options section) of the Fur Globals window. These options are only used by the Maya Software renderer.

Hairs/Pixel
Specify the number of hairs per pixel that are tracked for fur images. Lower values use less memory while higher values produce better quality renders. The upper limit for this option is 10.

Use Fur Shading/Shadowing on Fur
Turn this option off to cast fur shadows on geometry but not on fur for shadow map lights.

Shadow Map Rendering
These are the options in the Shadow Map Rendering section (subsection of Advanced Options section) of the Fur Globals window. These options are only used by the Maya Software renderer.

Hairs/Pixel
Specify the number of hairs per pixel that are tracked for shadow maps. Lower values use less memory while higher values produce better quality renders. The upper limit for this option is 10.

Reference Paths
These are the options in the Reference Paths section of the Fur Globals window. Use these options to render using existing files created using Advanced Fur Rendering. If you want to use fur files created during an actual render, the Keep Temp Files Fur Render option must be on when
you perform the render. These options are only used by the Maya Software renderer, with the exception of Equalizer Maps, which mental ray for Maya supports.

**Read Fur Files**

For use with the Maya Software renderer only. Turn this option on to read the fur files created using Advanced Fur Rendering rather than creating new ones at the time of rendering. See “Build fur files separately (Maya Software renderer only)” on page 131.

**Fur Files Path**

For use with the Maya Software renderer only. When you create fur files using Advanced Fur Rendering, this field automatically displays the path where the fur files were stored. This is where the fur files are read from when you turn on Read Fur Files.

To read fur files created when you perform an actual render, you must type the location (the subdirectory of the current project) and filename and process ID of the files in this field. For example, if you rendered a scene called furryscene that created the fur files called furryscene278_1_1.0001.sbs, furryscene278_1_1.ass, furryscene278_1_1.hair, furryscene278_1_1.shadow, furryscene278_1_1_equal.0001.sbs, you would type the following in the Fur Files Path field:

furFiles/furryscene278_1_1

**Read Equalizer Maps**

This option is automatically turned on if you selected Read Equalizer Maps from the Equalizer Maps drop-down list in the Fur Render Options section.

This option and the path are grayed out if any of the other three Equalizer Maps options are selected (No, Default, Custom).

**Equal Maps Path**

When you create equalizer maps using Advanced Fur Rendering or if you generate equalizer maps using the Equalizer Maps drop-down list in the Fur Globals, this field automatically displays the path where the equalizer maps were stored. This is where the equalizer maps are read from when you turn on Read Equalizer Maps.

**Read Shadow Maps**

For use with the Maya Software renderer only. Turn this option on to read the shadow maps created using Advanced Fur Rendering rather than creating new ones at the time of rendering. If you are rendering
different views of your scene, you can save rendering time by reusing the existing shadow maps. See “Build shadow maps and fur images separately (Maya Software renderer only)” on page 133.

**Shadow Maps Path**

For use with the Maya Software renderer only. When you create shadow maps using Advanced Fur Rendering, this field automatically displays the path where the shadow maps were stored. This is where the shadow maps are read from when you turn on Read Shadow Maps.

To read shadow maps created when you perform an actual render, you must type the location (the subdirectory of the current project) and prefix of the shadow map file in this field. For example, if you rendered a scene that created the shadow map file called furryscene_spotLightShape1.0001.smap, you would type the following in the Shadow Maps Path field:

```
furShadowMap/furryscene
```

**Read Fur Images**

For use with the Maya Software renderer only. Turn this option on to read the fur images created using Advanced Fur Rendering rather than creating new ones at the time of rendering. See “Build shadow maps and fur images separately (Maya Software renderer only)” on page 133.

**Fur Images Path**

For use with the Maya Software renderer only. When you create fur images using Advanced Fur Rendering, this field automatically displays the path where the fur images were stored. This is where the fur images are read from when you turn on Read Fur Images.

To read fur images created when you perform an actual render, you must type the location (the subdirectory of the current project) and prefix of the fur image file in this field. For example, if you rendered a scene that created the fur image files called furryscene.0001.iff and furryscene_z.0001.iff, you would type the following in the Fur Images Path field:

```
furImages/furryscene
```

**Advanced Fur Rendering**

These are the options in the Advanced Fur Rendering window (Fur > Advanced Fur Rendering) and is used only by the Maya Software renderer.
Fur Files

Select this option to render Fur files separately and then specify the Fur Files options as described below.

**Put Fur Files Here**
Displays the default path where fur files are stored (furFiles) and the default file name prefix (SceneName). Change this path only if absolutely necessary.

**Equalizer Map**
Turn on Equalizer Map if you want to flag the fur files to use equalizer maps. This doesn’t actually create equalizer maps. The default equalizer map is created during the render process.

**Calculate Area Values**
Select how you want fur distributed over the surfaces that have fur descriptions attached to them: Per Fur Description, Globally, or Off.

**Equalizer Map Path**
If the Equalizer Map check box is turned on, then Equalizer Map Path displays the default path (furEqualMap) where equalizer maps are stored and the default file prefix name (equal). Change this path only if absolutely necessary.

Equalizer Maps

Select this option to build equalizer map files separately and then specify the Equalizer Map options as described below.

**Equalizer Map Path**
Displays the default path (furEqualMap) where equalizer maps are stored and the default file prefix name (equal). Change this path only if absolutely necessary.

**Equalizer Map Width**
Defines the width of the equalizer map. The default is 256.

**Equalizer Map Height**
Defines the height of the equalizer map. The default is 256.

Shadow Maps and Fur Images

Select this option to build shadow map files and fur image files separately. The corresponding options are described below.
Rendering scenes with fur | 6

Fur Feedback Shape node

Read Fur Files from
Displays the default path where fur files are stored (furFiles) and the default file name prefix (SceneName). Change this path only if absolutely necessary.

Create these files
Select one of Shadow Maps, Fur Images, or Both. Both creates both shadow maps and images files.

Put Shadow Maps Here
Displays the default path where shadow maps are stored (furShadowMap) and the default file name prefix (SceneName). Change this path only if absolutely necessary.

Put Fur Images Here
Displays the default path where fur images are stored (furImages) and the default file name prefix (SceneName). Change this path only if absolutely necessary.

Related topics
- “Set up Fur Render Globals before rendering”
- “Render scenes with fur”
- “Build fur files separately (Maya Software renderer only)”
- “Build equalizer maps separately”
- “Build shadow maps and fur images separately (Maya Software renderer only)”

Fur Feedback Shape node

Render Stats
These are descriptions of the options in the Render Stats section of the FurFeedbackShape node.

Primary Visibility
When on, the fur is visible in the view and renders.

Casts Shadows
Turns on the shadow casting ability of the fur. To make shadows render faster, for fur that does not need to cast shadows, turn off Casts Shadows.
Receive Shadows (mental ray)

Turns on the shadow-catching ability of the fur. Works only when using the mental ray for Maya renderer.

Motion Blur (mental ray)

Turns on motion blur for the fur. You must also turn on Motion Blur in the Render Global Settings window. Only applies to the mental ray for Maya renderer.

Visible in Reflections (mental ray)

When on, the fur reflects in reflective surfaces. Works only when using the mental ray for Maya renderer.

Visible in Refractions (mental ray)

When on, the fur refracts through transparent surfaces. Works only when using the mental ray for Maya renderer.

**mental ray**

These are descriptions of the options in the mental ray section of the FurFeedbackShape node. These mental ray settings are used when Fur is rendered in mental ray.

**Override Caustics Settings**

Turn this on to override the Caustics settings for Fur only. Then set the values for Caustic Accuracy and Caustic Radius. For descriptions of these attributes and for more information about Caustics, see Caustics and Global Illumination in the onlineLighting guide. See also Global illumination and caustics workflow in the onlineLighting guide.

**Override Global Illumination Settings**

Turn this on to override the Global Illumination settings for Fur only. Then set the values for Global Illum Accuracy and Global Illum Radius. For descriptions of these attributes and for more information about Global Illumination, see Caustics and Global Illumination in the onlineLighting guide. See also Global illumination and caustics workflow in the onlineLighting guide.

**Override Final Gather Settings**

Turn this on to override the Final Gather settings for Fur only. Then set the following options: Final Gather Rays, Final Gather Min Radius, Max Radius, Final Gather View, and Final Gather Filter. For descriptions of these attributes and for more information about Final Gather, see Final Gather in the onlineLighting guide. See also Render with final gather in the onlineLighting guide.
Number of Samples

These settings relate to anti-aliasing when rendering with mental ray. For more information, see *Anti-aliasing and flicker* in the Rendering guide.

<table>
<thead>
<tr>
<th>Note</th>
<th>These per object sampling settings must lie within the range of the mental ray global sampling settings, otherwise they will be clipped.</th>
</tr>
</thead>
</table>

Min Sample Level This is the guaranteed minimum number of samples per pixel used when processing an image. Based on Contrast Threshold (adaptive) settings, mental ray for Maya will increase these samples as needed.

Max Sample Level This is the absolute maximum number of samples per pixel used when processing an image.

**Fur > Fur Globals**

Opens the Fur Globals window. Use this to set options for the Fur renderer. For more information, see “Set up Fur Render Globals before rendering” on page 127 and “Fur Globals” on page 135.

**Fur > Advanced Fur Rendering**

Opens the Advanced Fur Rendering window. Use this to create Fur Files, Equalizer Maps, and Shadow Maps and Fur Images. For more information, see:

- ”Advanced fur rendering” on page 125
- ”Render scenes with fur” on page 128
- ”Build fur files separately (Maya Software renderer only)” on page 131
- ”Build equalizer maps separately” on page 132
- ”Build shadow maps and fur images separately (Maya Software renderer only)” on page 133
- ”Advanced Fur Rendering” on page 142

**Fur > Cancel Advanced Fur Render**

Use this to cancel the rendering process if you invoked it using the Advanced Fur Rendering window. For more information, see ”Render scenes with fur” on page 128.
Fur samples and techniques

How do I? Create body fur, whiskers, eyelashes and other Fur effects

Create body fur, whiskers, and eyelashes

Add body fur

As a starting point, you can add fur to your model and set global fur attributes so that the fur is even and grows in approximately the desired direction. See “To add body fur” on page 149.

After adding fur and setting global fur attributes, you can use Maya Artisan to paint most fur attributes locally. See the following:

- “To make the nose bald” on page 152
- “To change the fur length around the muzzle” on page 152
- “To comb the fur” on page 152

To add body fur

1. Select all surfaces you want to have fur.
2. Attach fur to the surfaces (Fur > Attach Fur Description > New).
3. Select the fur feedback (click a feedback hair) and in the INPUTS section of the Channel Box, change the name of the fur description from FurDescription1 to something meaningful (for example, bodyFur).
4. Change the length of the fur, if necessary.
5 If the fur appears to be growing inwards (or appears bald) on some surfaces, reverse the fur normals on these surfaces:
   - Select the fur feedback or the surfaces where fur appears to grow inward (or appears bald).
   - Reverse fur normals (Fur > Reverse Fur Normals).

6 To get more feedback on surfaces (for example, on large surfaces), increase the number of sample hairs:
   - Select the fur feedback on the surface where you want more feedback.
   - In the SHAPES section of the Channel Box, set the U Samples and V Samples to a higher value.

7 Make the fur lie flatter to the skin of the animal by increasing the Inclination value.
8 If the fur grows in a different direction on some surfaces, offset the polar direction for these surfaces.
   - Select the fur feedback or the surfaces where fur is growing in a different direction.
   - Select Fur > Offset Fur Direction By > 90 Degrees.

9 Set the fur color by doing one of the following:
   - Edit the fur description in the Attribute Editor (Fur > Edit Fur Description > FurDescriptionName) and set the Base Color and Tip Color of the fur to match the skin color.
   - Edit the fur description in the Attribute Editor (Fur > Edit Fur Description > FurDescriptionName) and map a file texture to the Base Color and Tip Color. For details, see “Map fur attribute values” on page 40.

10 For more natural looking fur, add some Scraggle to the fur.
To make the nose bald

1. Select the surfaces that make up the nose.
2. Select Fur > Paint Fur Attributes Tool > .
3. In the Paint Fur Attributes Tool Settings window, select Baldness from the Fur Attribute drop-down list.
4. In the Tool Settings editor, set the Value to 0.
5. Dolly in on the nose and carefully paint away the hairs.

To change the fur length around the muzzle

1. Select the body surface.
2. Select Fur > Paint Fur Attributes Tool > .
3. In the Paint Fur Attributes Tool Settings window, select Length from the Fur Attribute drop-down list.
4. In the Tool Settings editor, set the Value to be less than 1 (how much less depends on how short you want the fur).
5. Paint around the muzzle to shorten the fur.

To comb the fur

1. Select the fur feedback or the surface with fur you want to comb.
2. Select Fur > Paint Fur Attributes Tool > .
3. In the Paint Fur Attributes Tool Settings window, select Direction from the Fur Attribute drop-down list.
4. Brush along the fur. The fur is combed in the direction of your brush stroke.
Add whiskers
Use this technique to add whiskers to your models.

To add whiskers

1. Select the surface you want to put whiskers on.
2. Select Fur > Attach Fur Description > New.
3. Select the fur feedback and change the name from FurDescription1 to something meaningful (for example, whiskers) in the INPUTS section of the Channel Box.
4. Reduce the number of whiskers:
   - Select the surface you want to put whiskers on (not the feedback).
   - Select Fur > Paint Fur Attributes Tool > .
   - In the Paint Fur Attributes Tool Settings window, select Baldness from the Fur Attribute drop-down list.
   - In the Tool Settings editor, set the Paint Operation to Replace, the Value to 0, and click the Flood button. All the fur disappears.
   - Set the Value back to 1.
   - In the Stroke section, turn on Reflection (normally it would be X).
   - Paint whiskers back onto the muzzle.

5. Make the new fur description look more like whiskers:
   - Select the whiskers feedback and in the Channel Box, set the Fur Accuracy to 1.
• Select Fur > Edit Fur Description > FurDescriptionName to open the Attribute Editor.
• Set the Length value to 0.8, the Base Curl value to 0.9, and the Tip Curl value to 0.
• Set the Scraggle value to 0.3 and the Scraggle Frequency value to 2.0.
• Set the Polar value to 0.75.
• Go to the Details section.
• Go to the Length section and set the Length Noise Amplitude value to 0.5.
• Go to the Polar section and set the Polar Noise Amplitude value to 0.2.

The Polar value makes whiskers grow downwards on one side and upwards on the other because of the UV direction of the surface. To fix this:

• Select the surface the whiskers are attached to.
• Select Fur > Paint Fur Attributes Tool. In the Paint Fur Attributes Tool Settings window, select Polar from the Fur Attribute drop-down list.
• In the Tool Settings editor, set the Paint Operation to Replace and the Value to 0.25.
• In the Stroke section, turn off Reflection.
• Paint the side of the muzzle where the whiskers are growing upwards.
Add eyelashes
Use this technique to put eyelashes on an eyelid.

To add eyelashes
1. Select the surface you want to put eyelashes on.
2. Select Fur > Attach Fur Description > New.
3. Select the fur feedback and change the name from FurDescription1 to something meaningful (for example, eyelashes) in the INPUTS section of the Channel Box.
4. Set the number of U and V Samples on the surface high so you can paint hairs more precisely.
Fur samples and techniques | 7
Create body fur, whiskers, and eyelashes >

5 Reduce the number of eyelash hairs:
- Select the surface you want to put eyelashes on.
- Select Fur > Paint Fur Attributes Tool >.
- In the Paint Fur Attributes Tool Settings window, select Baldness from the Fur Attribute drop-down list.
- In the Tool Settings editor, set the Operation to Replace, the Value to 0, and click the Flood button.

6 Paint eyelashes back onto the eyelid.
- Set the Value back to 1 and paint eyelashes carefully along the edge.

7 Trim the eyelash to the shape you want it:
- Progressively paint length values, such as 0.3 at the edges, 0.5, 0.8 and then 1.0 for the longest lashes at the center.
Set the value to 1 and Operation to Smooth, then Flood until the lash length looks smooth.

8 Make the new fur description look more like eyelashes:

- Select the eyelashes feedback and in the Channel Box, set the Fur Accuracy to 1.
- Select Fur > Edit Fur Description > FurDescriptionName to open the Attribute Editor.
- Set the Length value to 0.8, the Base Curl value to 0.9, and the Tip Curl value to 1.
- Set the Scraggle value to 0.3 and the Scraggle Frequency value to 2.0.
- Go to the Details section.
- Go to the Length section and set the Length Map Multiplier to 1.2 and the Length Noise Amplitude value to 0.325.
- Go to the Polar section and set the Polar Noise Amplitude value to 0.0325.
- Go to the Base Curl section and set the Base Curl Noise Amplitude value to 0.05.
- Go to the Tip Curl section and set the Tip Curl Noise Amplitude value to 0.115.
Part fur

Use this technique to quickly put a part in fur.

To part fur

1. Edit the fur description (either in the Channel Box or Attribute Editor).
2. Make sure the fur has an Inclination value greater than 0.
3. Right-click the Polar field, and select Create New Texture. The Create Render Node window appears.
4. Click the Ramp button.
5. In the Ramp Attributes section change Interpolation to None.
6. Modify the ramp so that one side of the part has a value of 0.5 (gray) and the other has a value of 1.0 (white), as in the following illustration. Position the part where you want it. (In this example, the part is in the middle of the surface.)

Tip

Suppose you want to render the eyelashes through spectacles (refractive material).

- Render the full scene with the fur, but with the spectacle lenses hidden.
- Next, create an image plane (Display Mode RGB, Fit to Resolution Gate) using the rendered image.
- Turn on Visible in Refractions, and interactively change the Depth value until the image plane sits just behind the backmost part of the lenses. (You could set up an expression to accurately track this, if needed.)
- Render the scene again with only the raytraced spectacle lenses and frame and the image plane (hide everything else and turn off Fur rendering). The image plane containing the fur will be refracted through the lenses.
Switch back to the fur description in the Attribute Editor and click the Bake button.

---

**Work on an animation project**

If you want one team to work on animation while another works on the furry models in the scenes there are two approaches you can take:

- "To reference a non-furry model" on page 160
- "To reference a furry model" on page 160

You cannot start these methods mid-project.

For more information, search the online help for import or reference data in an external file.

---

**Note**

In Maya 6, we added the ability to have multiple fur feedbacks per surface. Previously, you could only show the feedback from one fur description at a time. One consequence of this is that if you are referencing a pre-6.0 scene that has multiple fur descriptions into 6.0, the extra feedback nodes are created dynamically, and are not part of the reference. This is harmless.
**To reference a non-furry model**

1. If the animator does not have Fur, unload the Fur plug-in and create the model.
2. Save the scene using a name that identifies it as the model without fur (for example, noFurModel).
3. Create a new scene and reference the scene with the model without fur (File > Create Reference).
4. Save this new scene using a name that identifies it as the model with fur (for example FurModel).
5. Send the non-fur scene to the animator.
6. Attach fur to the fur scene and modify it as desired.
7. When the animator has finished animating the non-furry model, replace the original scene with no fur with the animator’s updated scene. The fur in the scene with fur will now be applied to the animated model.

**To reference a furry model**

1. Create the model in its base pose.
2. Attach fur to the model and modify it as desired.
3. Save this scene using a name that identifies it as the model with fur (for example BaseFurModel).
4. Create a new scene and reference the scene with the model with fur (File > Create Reference).
5. Animate the new scene and save it using a name that identifies it as the animated scene (for example AnimFurModel).
6. Repeat steps 4 and 5 for any other scenes using the furry model.
7. When you modify the fur on the base pose model, the models in the animated scenes will be updated.
8. If you intend to reference the furry scene into a different project, in both scenes select Custom Equalizer Maps in the Fur Globals. Then select Fur > Update Fur Maps in the referencing scene. This ensures the maps are found.
8 Troubleshooting Fur

How do I? Troubleshoot Fur

To achieve the fur effects you want, you may have to experiment with the number of lights in the scene, the types of lights, the light attributes, the location of lights, and fur attributes. Use these suggestions to troubleshoot Fur, and to fine tune the fur effects in your scenes. Specifically, see:

- “Troubleshoot general Fur issues” on page 161
- “Troubleshoot rendering Fur in the Maya Software renderer” on page 164
- “Troubleshoot rendering Fur in mental ray for Maya” on page 166

Troubleshoot general Fur issues

When I comb my Fur, nothing happens

Combing the Fur (painting Direction) basically changes the Polar value of the hairs, effectively rotating them on their axis. If you have no Inclination, and no Curl, all that combing will do is to spin the hairs around on their axis, so you will see no effect.

Solution: Set the Inclination to a value greater than 0 - e.g. 0.5. You will immediately see the results of your previous and future combing.

I painted Direction and now I want to reset it to the default, but I can’t find a Direction map to delete!

Painting Direction writes out a Polar map based on the interpreted values of the brush direction, since it would be extremely difficult to represent a Direction map.

Solution: To reset the direction of the hairs, delete the Polar map by selecting it from the Details section and selecting Remove Item. You can also apply global changes to the Direction by flooding the Polar map in Artisan - for example, selecting Smooth and Flood to even out your combing.

When painting direction on polygons, sometimes the Fur does not follow the direction of my brush.

If your UV map is not one contiguous piece, your brush may be crossing a UV seam. When this happens, the UV pieces may be orientated differently in texture space, and it is impossible to determine the correct direction for all of the fur under the brush.
Solution: Display your UV borders when painting (Display -> Custom Polygon Display -> Texture Borders). When painting close to the seams, make your brush small enough so that it doesn’t paint on both sides of a seam at the same time.

When I execute a distributed render, or render my sequence in sections, the Fur seems to shift slightly between the sections.

By default, Fur uses something called an Equalizer Map to even out the distribution of hair across an unevenly parameterized surface. So for example, the equalizer will compensate for the squeezing together of parameter space at the pole of a sphere. The equalizer map is normally created at the first frame of the render. If the geometry is deforming, the equalizer map could be different according to where you start the render.

Solution: If you intend to render in sections, or do a distributed render, you MUST pre-render the equalizer map. To do this, simply select Create Equalizer Maps from the Advanced Fur Rendering dialog. This will automatically turn on Read Equalizer Maps in the Fur Globals. Save the scene, and you’re ready to render. A similar issue can be caused with Calculate Area Values when you render in sections - in this, you should also pre-render the Fur Files through Advanced Fur Renderer.

I mapped an attribute in the fur description and baked it, then I broke the connection, but the fur still renders as though the map is connected.

Once an attribute map has been baked, you have to rebake to remove it after breaking the connection.

Solution: Break the connection, then select the required attribute in the ‘Bake Attribute’ pop-up and hit Bake.

Fur seems to be flipping or crawling on my deforming polygon surface.

Fur is placed on the surface according to UVs. If your UVs are changing over time, the Fur will appear to crawl over the surface. This can happen if you have your UV projection after a deformer, for example.

Solution: If possible, delete the history on your UV operations, or make sure they are upstream of the deformer. One way to remove the history on the UVs without losing the animation is to duplicate the mesh, delete the UV projection nodes on the original, and then use Polygons -> Transfer to transfer the UVs back from the duplicate.
My disk is filling up with zillions of fur files - what can I do?

Once your render is complete, you can delete anything in your furFiles directory, furShadowMap directory, and furEqualMap directory - these are recreated each time you render, unless you are using an Advanced Fur Rendering technique. Do not delete the contents of furAttrMap which are prefixed by any scene name you still require - these are your Artisan and baked maps, and are needed to define the Fur. If you are happy with your final composite, you can also delete the contents of your furImages directory - otherwise you may want to keep these to use separately in a compositing application.

Solution: To have these files deleted automatically when no longer needed, turn off "Keep Temp Files" (off by default) and/or "Keep Fur Images" (on by default) in Fur Globals. The deletion takes place after each frame is completed.

Fur seems to be flipping, crawling or is incorrectly placed on my animated trimmed surface.

Fur does not understand trimmed surfaces per se, so they must be tessellated into polygons before being passed to the Fur Renderer. Unfortunately, if the trimmed surface is animated, the tessellation of that surface can change from frame to frame, causing the fur to flip or crawl. mental ray also does not deal well with Fur on animated trims.

Solution: Convert the trimmed surface to polygons, or model without trims.

My rendered fur does not follow the contours of a surface that has a displacement map applied.

Displacement is only calculated at render time, so fur is not aware of it.

Solution: Apply the same map used for displacement to the Offset attribute the fur description.

I can't seem to paint values such as length to be greater than 1.

Because the Paint Fur Attributes tool uses grayscale maps to represent values, those values are always initially mapped to the 0 to 1 range.

Solution: Begin by flooding the surface with a value of 1. Then change the Map Multiplier and/or Offset values under the Details section for the appropriate attribute. For example, to paint Length values in the range of...
Troubleshooting Fur | 8
Troubleshoot rendering Fur in the Maya Software renderer

0 to 5, set the Length Map Multiplier to 5. You can now paint length values in this range - for example, mid gray with a value of 0.5 will produce a length of 2.5.

Troubleshoot rendering Fur in the Maya Software renderer

When I render, if I zoom in, I can sometimes see a tiny gap in the alpha channel where the Fur grows out of the surface.

This problem is caused by the Fur growing out of the edge of the geometry, which is anti-aliased - there is a one pixel area of anti-aliasing before the Fur alpha begins. This gap is not usually noticeable unless the Fur is very sparse and/or the background color is very contrasted to the fur color.

Solution: Set the Offset value for the Fur Description to be a small negative number. This will cause the Fur to grow from slightly inside the geometry, eliminating the gap.

When I render, there is a faceted gap between the edge of my NURBS surface and the hair growing out of it.

The Fur renderer uses a default tessellation factor for NURBS which is quite high. If the geometry is tessellated at a lower tessellation, you may see a mismatch in the final composite.

Solution: Increase the tessellation on the geometry, or decrease the tessellation used by Fur (Fur Globals -> Advanced Options).

When a non-furry object passes in front of a furry object, there is a fringing effect around the foremost object.

In the Maya software renderer, Fur is composited with the geometry internally using Z-depth information. Because Z buffers are not anti-aliased, in certain cases, fringing can result when there is geometry in front of the fur.

Solution: Render at double size and then scale down the image, or render in separate passes and then composite using alpha channels. Also remember that mental ray renders will not exhibit this problem.
My Fur render is extremely slow - is there anything I can do to speed it up?

Fur render times increase linearly with the number of hairs used - rendering 10,000 hairs will take twice as long as rendering 5,000 hairs. Shadow map calculations take as much time as the render itself for EACH light which Shadow Maps turned on for Fur - so for using two shadow maps will cause your render to take three times as long as using no shadow maps. Conversely, Auto Shading is virtually free, and gives realistic back and root shading.

Solution: Try using fewer hairs with a broader base width to get good surface coverage. Limit the number of Fur Shadow Maps you use to 1 or 2 at most, and instead use Auto Shading or No Shading for most of the lights.

How can I render Fur through refractive material - for example, an eyebrow and eyelashes through spectacles?

In the Maya software renderer, Fur does not show up in raytraced refractions and reflections, but it is possible to fake some effects, including this one. Note that the following technique will work equally well for Paint Effects.

Solution: Render the full scene with the Fur, but with the spectacles lenses hidden. Next, create an image plane (Display Mode RGB, Fit to Resolution Gate) using the above image, toggle on Visible in Refractions, and interactively change the Depth value until the image plane sits just behind the backmost part of the lenses (you could set up an expression to accurately track this if needed). Render the scene again with only the raytraced spectacle lenses and frame, and the image plane (hide everything else and turn off Fur rendering). The image plane containing the Fur will be refracted through the lenses. Also remember than Fur will refract and reflect correctly in single render pass within mental ray.

I can only use Advanced Fur Rendering within the interactive package. Can I render just the fur images using the batch renderer?

You can disable the Maya renderer and render just the fur images with the batch renderer.

Solution: Set up your scene as usual, and then turn on Disable Maya Rendering under the Advanced Options of Fur Globals.
I'm running out of memory when using Fur. Is there anything I can do to optimize memory usage?

You can control the number of hairs tracked per pixel for both the fur images and the shadow maps. This is trade-off between quality and memory usage. You can also reduce the size of shadow maps used for Fur, since using large shadow maps is extremely memory intensive.

Solution: Reduce the Hairs/Pixel value for both Fur Image Rendering and Shadow Map Rendering (where applicable) under the Advanced Options of Fur Globals, especially in scenes where your character is the distance. Don't use a larger shadow map for Fur than you require, and use Auto Shading instead wherever possible.

My Fur seems way too bright, especially the specular highlights. Can I fix this?

Firstly, you need to understand how the Fur color is calculated. Fur adds together the color, the ambient color and the specular color (depending on your light model), and multiplies the result by all of the light intensities. So if you have several lights with intensities higher than one, you will quickly see very bright highlights.

Solution: To compensate for this, set the specular color to very dark. To break up the highlight, map the specular color to a fractal or brownian, again using dark colors. Don't forget to Bake when you are satisfied. If the specular highlight is too large, set the Specular Sharpness to a high value - 200 or more is fine. If you can't resolve the lighting which looks right for your Fur and the lighting with looks best for your geometry, you can use the Intensity Multiplier value to change the effect of the lights on the Fur only. The Intensity Multiplier value is part of the Fur Shadowing Attributes which can be added to any light (Fur -> Fur Shadowing Attributes -> Add to Selected Light). Note that you can set the Fur Shading Type to No Shading, and still adjust the Intensity Multiplier.

Troubleshoot rendering Fur in mental ray for Maya

I have the same fur description applied to multiple patches on a model, but the density appears uneven across the various patches in the render. Can I fix this?

mental ray doesn't currently support Calculate Area Values, which is the mechanism normally used to compensate for varying patch size.
Solution: Convert to a single polygon mesh. If this is not possible, the only way to compensate is to apply different baldness values to each patch - for example, apply 50% baldness to a patch that has half the surface area of the largest patch.

When I render in mental ray, the quality of Fur is very poor compared to the Maya software renderer.

A: Since mental ray is a point sampler it has to be tuned with higher sampling settings and lower contrast values to catch very fine details and thin geometry, like hairs.

Solution: Use the Preview Fur quality setting in the mental ray tab in Render Globals as a good starting point, then increase the Number of Samples on the Fur Feedback node; make sure that the overall sampling range is as large as the sampling setting in the fur feedback, otherwise these per object values will be clipped.
Troubleshooting Fur | 8
Troubleshoot rendering Fur in mental ray for Maya >
### Index

- **attractors** .................................................. 14
  - adding to set ........................................... 84
  - creating .................................................. 76
  - creating a single at the origin .................. 80
  - defined .................................................. 75
  - deleting ................................................ 83
  - grid ....................................................... 77
  - modifying .............................................. 75
  - removing from set ................................ 85
  - selecting ............................................... 84
  - single at origin ........................................ 80
- **Attractors Per Hair attractor set attribute** ............ 106
- **Attribute Map Height**
  - Paint Fur Attributes Tool ............................... 67
- **Attribute Map Width**
  - Paint Fur Attributes Tool ............................... 67
  - attribute maps
    - value ranges ......................................... 32, 86
  - attribute values
    - painting ............................................... 50
    - varying .............................................. 31, 86
  - **auto load** ........................................... 17
- **Auto-Shading** ............................................ 121

#### B

- **Back Shade Darkness fur shading attribute** ........... 122
- **Back Shade Factor fur shading attribute** ............ 122
- **Back shadows** .......................................... 115
- **Bake**
  - attractor set attribute ................................ 106
- **Bake Attribute**
  - attractor set attribute ................................ 106
  - Bake Attribute fur attribute ......................... 55
  - baldness ............................................... 29
- **Baldness fur attribute** .................................. 58
- **Base Ambient Color fur attribute** ....................... 56
- **Base Color fur attribute** ................................ 55
- **Base Curl fur attribute** ................................ 61
- base joint rotations, keyframing ......................... 110
- **Base Opacity fur attribute** .............................. 60
- **Base Width fur attribute** ................................ 61
- **blowing fur** ........................................... 97

#### C

- **Calc. Area Values fur global** ........................... 54, 136
- **Cancel Advanced Fur Render menu item** .............. 130
- **Cancel Batch Render menu item** ....................... 130
- **chain attractors**
  - animating .............................................. 97, 101
  - keyframing ............................................ 89, 92
- **Channel Box** ............................................ 28
- **Color Feedback Enabled fur feedback attribute** .... 52
- **combing fur** ........................................... 31, 36
- **Comp. Fur fur global** .................................. 136
- **Connection Editor** ....................................... 41, 43, 44
- **Copy Attr Maps fur global** .............................. 137
- **copying**
  - fur descriptions ......................................... 21
  - to other scenes ......................................... 49
- **Create a grid of attractors on the selected surface option** ........................... 77
- **Create Attractor dialog box** ........................... 77, 81
- **Create Attractor menu item** ............................ 77, 81
- **Create one attractor at the origin option** ........... 81
- **Create one attractor at the selected UV point(s) or face(s) option** ......................... 79
- **Create Render Node dialog box** ....................... 41
- **Create Unattached menu item** ......................... 21
- **curl**
  - displaying ............................................... 51
  - hair base .............................................. 61
  - hair tip ................................................ 62
  - CVs, masking ............................................ 34, 87

#### D

- **Delete menu item** ......................................... 24
- **deleting fur descriptions** .............................. 24
- **Density**
  - fur attribute ........................................... 54
- **Detach from Selected menu item** ....................... 83
- **Detach Fur Description menu item** .................... 25

---

**Fur**  

170
Index

detaching fur descriptions .......................... 25
direction
  offsetting ....................................... 30
  painting ........................................ 36, 38
Direction fur attribute ........................... 36
Disable Maya Rendering (batch only) fur global 139
Dispatcher ........................................ 131
distributed render ................................. 131
distributing fur .................................... 54
Duplicate menu item ................................ 21
duplicating fur descriptions ........................ 21
Dynamic Chain attractors ......................... 96
  animating ....................................... 97, 101
  creating ....................................... 110
dynamic forces .................................... 14
dynamic fur movement .............................. 96
Dynamics ........................................... 76, 96, 110

E
Edit Fur Description menu item ....................... 31
Enable Feedback For menu item ..................... 84
Enable Fur fur global ............................... 135
Enable Fur Image Rendering fur global ............. 139
Enable Fur Shading/Shadowing fur global ........... 139
End Length attractor set attribute .................. 108
Equalizer Maps
  advanced fur rendering option .................... 132
  building separately ............................ 132
  fur global ...................................... 137
  painting ........................................ 39
  using existing .................................. 140

examples
  'seaweed' in water ............................... 90
  'wheat field' blowing in wind ................... 97
adding body fur .................................... 149
adding eyelashes ................................... 155
adding whiskers ................................... 153
animating fur ...................................... 72
combing fur ....................................... 152
growing fur ....................................... 70
making a nose bald ................................ 152
parting fur ....................................... 93
shaking animal .................................... 102

F
feedback ............................................... 26
  attractor sets .................................... 84
  attributes, defining ................................ 28
  displaying ..................................... 27
  hiding ........................................... 27
file textures
  baking ........................................... 55
  mapping single .................................. 41
  mapping to multi-surface objects ............... 42
  removing ....................................... 47
flooding values .................................... 39
forces .............................................. 14
  applying to fur .................................. 96
  frizz, adding to fur ............................. 62
Fur Accuracy fur feedback attribute ................ 51
Fur Attribute
  Paint Fur Attributes Tool ....................... 66
  Fur Attribute paint attribute .................. 87
Index

fur attributes
  animating ........................................ 13, 69
  Assigned Surfaces .............................. 54
  Attraction ....................................... 64
  Bake Attribute ................................ 55
  Baldness ........................................ 58
  Base Ambient Color ............................. 56
  Base Color ...................................... 55
  Base Curl ........................................ 61
  Base Opacity .................................... 60
  Base Width ...................................... 61
  changing ......................................... 31
  color .............................................. 55
curl ................................................. 61
  Density .......................................... 54
  Direction ........................................ 36
  FurDescription .................................. 53
  Inclination ...................................... 59
  keyframing ..................................... 69
  Length .......................................... 58
  Light Model ...................................... 53
  Map Mult. ......................................... 33, 36, 65, 88, 108
  Map Offset ....................................... 33, 35, 65, 108
  map value ranges ................................ 32
  mapping ......................................... 40
  modifying ....................................... 13, 31
  Noise Amplitude ................................ 65
  Noise Frequency ................................ 65
  Offset ............................................ 64
  opacity .......................................... 60
  painting ......................................... 33, 34, 50
  Polar ............................................. 59
  Scraggles ....................................... 62
  Scraggle Correlation ............................ 63
  Scraggle Frequency .............................. 63
  Segments ......................................... 64
  Specular Color .................................. 57
  Specular Sharpness ............................. 57
  Tip Ambient Color ............................... 57
  Tip Color ........................................ 56
  Tip Curl .......................................... 62
  Tip Opacity ...................................... 60
  Tip Width ........................................ 61
  varying values ................................... 31
  width .............................................. 61

fur depth map shadows ............................ 115

Fur Description
  Paint Fur Attributes Tool ....................... 66
  Fur Description paint attribute ............... 87
fur descriptions
  attaching ......................................... 13, 24
  changing ......................................... 31
  copying to other scenes ....................... 49
  creating ......................................... 13, 20
  deleting ......................................... 13, 24
detaching ......................................... 25
duplicating ....................................... 21
  editing .......................................... 31
  selecting attached surfaces ................... 25
fur direction, offsetting ......................... 30
fur feedback ........................................ 26
fur files
  building separately ............................ 131
  using existing ................................... 140
  Fur Files advanced fur rendering option ..... 132
  Fur Files Path .................................. 141
fur globals
  Area Value ........................................ 136
  Comp Fur ......................................... 136
defining ......................................... 127
  Equalizer Maps .................................. 137
  Keep Fur Images .................................. 137
  Keep in Intermediate Files ..................... 137
  Read Fur Files .................................... 141
  Read Fur Files Path .............................. 141
  Read Fur Image ................................... 142
  Read Fur Image Path ............................. 142
  Read Shadow Map ................................ 141
  Read Shadow Map Path ........................... 142
  Render Fur ....................................... 135
  Fur Globals menu item ......................... 127

Fur

172
Index

fur images
  building separately ........................................ 133
  using existing ............................................. 140
Fur Images Path .............................................. 142
Fur Length Noise ............................................... 108
fur light attributes .......................................... 14
  removing ..................................................... 119
fur models, referencing ........................................ 12
fur normals, reversing ......................................... 29
fur shading ...................................................... 113
  creating ......................................................... 117
  Maya Software renderer ........................................ 117
  mental ray for Maya ........................................... 116
  none ............................................................ 114
  simple ......................................................... 114
fur shading attributes
  Fur Back Shade Darkness ....................................... 122
  Fur Back Shade Factor ......................................... 122
  Fur Shading Type ............................................... 121
  removing ......................................................... 119
  Self Shade Darkness ........................................... 121
Fur Shading Type attribute ..................................... 121
fur shadow maps ................................................ 115
  creating ......................................................... 117
  none ............................................................ 114
Fur workflow overview ......................................... 12
Fur.so .................................................................. 17
FurAttractors attractor set field ............................... 105
FurDescription fur attribute .................................... 53

G
Global attractor model ........................................... 106
Global Scale
  attractor set attribute ......................................... 106
  fur attribute ....................................................... 54
gravity ............................................................... 14, 96
grid of attractors, creating ..................................... 77
growing fur .......................................................... 70

H
Hairs/Pixel fur global ............................................. 140
hiding fur feedback ................................................ 27
highlights ............................................................ 57
hotkeys ............................................................... 87

I
IK Chain attractors
  animating .......................................................... 92
  creating ........................................................... 110
Inclination fur attribute .......................................... 59
inclusion, changing ................................................ 30
Influence attractor set attribute ................................ 107
Intensity Multiplier
  fur shading attribute ........................................... 118
  Intensity Multiplier fur shading attribute ................. 123
joint chains .......................................................... 75

K
Keep Fur Images fur global .................................... 137
Keep Temp Files fur global ...................................... 137
keyframing
  fur attributes ..................................................... 69
  fur movement ..................................................... 14, 89
  IK chain attractors ............................................... 92
  simple chain attractors with linked joint rotations ....... 89
kinks, adding to fur ................................................. 62

L
Length
  animating .......................................................... 70
  fur attribute ....................................................... 58
light attributes ..................................................... 14
Light Model fur attribute ........................................ 53
lights ................................................................. 12, 14
  changing intensity for fur .................................... 118
loading Fur .......................................................... 17
Local attractor model ............................................ 105

Fur
173
Index

M
Map Mult.
  fur attribute .................................. 33, 36, 65, 88
Map Offset
  fur attribute .................................. 33, 35, 65
mapping
  fur attribute values ............................. 31
  multiple textures to multi-surface objects ... 42
  single textures ................................ 41
maps
  baking ........................................... 55
  removing ....................................... 47
  value ranges .................................. 32, 86
masking vertices ................................ 34, 87
Maya Artisan ................................... 33
Maya FX ......................................... 14
motion blur ..................................... 130
movement, adding to fur ......................... 14, 75
multi-surface objects, mapping to ............. 42

N
nap, fur direction ................................. 30
Noise
  fur attribute .................................. 31
Noise Amplitude
  attractor set attribute ......................... 109
  fur attribute .................................. 65
Noise Frequency
  attractor set attribute ......................... 109
  fur attribute .................................. 65
normals, fur ..................................... 29
NURBS surfaces, fur ............................. 12
NURBS Tessellation fur global .................. 139

O
Offset Fur Direction By menu item ................ 30
opacity, fur ..................................... 60
origin, creating single attractor at .............. 80
overview, Fur workflow ........................... 12

Fur
174
### Index

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Triple Shading Switch</td>
<td>43</td>
</tr>
<tr>
<td><strong>U</strong></td>
<td></td>
</tr>
<tr>
<td>U Samples fur feedback attribute</td>
<td>50</td>
</tr>
<tr>
<td>unattached fur description, creating</td>
<td>21</td>
</tr>
<tr>
<td>unmapping attributes</td>
<td>47</td>
</tr>
<tr>
<td>Use Background Shader</td>
<td>133</td>
</tr>
<tr>
<td>Use Depth Map Shadows option</td>
<td></td>
</tr>
<tr>
<td>fur shading</td>
<td>117, 118</td>
</tr>
<tr>
<td>Use Fur Shading/Shadowing on Fur fur global</td>
<td>140</td>
</tr>
<tr>
<td>Use Ray Trace Shadows option</td>
<td></td>
</tr>
<tr>
<td>fur shading</td>
<td>117</td>
</tr>
<tr>
<td>UV point, creating attractor at</td>
<td>78</td>
</tr>
<tr>
<td>UV Texture Paint mode</td>
<td>34</td>
</tr>
<tr>
<td><strong>V</strong></td>
<td></td>
</tr>
<tr>
<td>V Samples fur feedback attribute</td>
<td>50</td>
</tr>
<tr>
<td>value ranges</td>
<td>32, 86</td>
</tr>
<tr>
<td>values</td>
<td></td>
</tr>
<tr>
<td>flooding</td>
<td>39</td>
</tr>
<tr>
<td>smoothing</td>
<td>39</td>
</tr>
<tr>
<td>vertices, masking</td>
<td>34</td>
</tr>
<tr>
<td><strong>W</strong></td>
<td></td>
</tr>
<tr>
<td>width, fur</td>
<td>61</td>
</tr>
<tr>
<td>wind</td>
<td>14, 96</td>
</tr>
</tbody>
</table>

**Fur**

176