# Table of Contents

1  **Introducing Fluid Effects** ................................................. 11
   
   About
      Fluids .............................................................................. 11
      Introducing Fluid Effects .................................................. 11
      Fluid Effects Overview ..................................................... 11
      Types of fluids .................................................................... 12
      Getting started with Fluid Effects ..................................... 13
   
   2  **Creating Fluid Effects** ................................................... 15
      
      About
         Fluids .............................................................................. 15
         Creating fluid effects ...................................................... 15
            What are the components of a fluid? ............................... 15
            Defining the contents of a fluid container ....................... 19
            Fluid examples .................................................................. 22
         
      How do I?
         Simulate fluids ................................................................. 22
         Create fluid effects .......................................................... 22
            Import Fluid examples .................................................... 22
            Create dynamic fluid effects .......................................... 23
            Create non-dynamic fluid effects .................................... 24
            Create fluid containers ................................................... 25
            Add properties to fluid containers ................................. 26
            Add properties as predefined gradients ......................... 26
            Emit fluid properties into grids ...................................... 27
            Paint fluid properties into grids ..................................... 30
            Add color to fluids .......................................................... 36
            Display fluid container contents .................................... 37
            Display subvolumes of 3D containers ............................. 37
            Emit fluids from objects .................................................... 41
            Set Contents with Curve .................................................. 41
            Add predefined initial states to fluid containers ................ 43
Table of Contents

Reference

Menus ................................................................. 44
Dynamics menu set ............................................. 44
Fluid Effects ........................................................ 44
Fluid Effects > Create 3D Container ....................... 44
Fluid Effects > Create 2D Container ....................... 45
Add/Edit Contents > .............................................. 45
Fluid Effects > Add/Edit Contents > Emitter ............ 45
Fluid Effects > Add/Edit Contents > Emit from Object 45
Fluid Effects > Add/Edit Contents > Gradients .......... 45
Fluid Effects > Add/Edit Contents > Paint Fluids Tool 46
Fluid Effects > Add/Edit Contents > With Curve ....... 50
Fluid Effects > Add/Edit Contents > Initial States ...... 51
Fluid Effects > Create 3D Container with Emitter .... 52
Fluid Effects > Create 2D Container with Emitter .... 54

3 Modifying fluids .................................................. 55

About

Fluids ................................................................. 55
Modifying fluids .................................................. 55
Modifying fluids .................................................. 55
Changing fluid container size .............................. 55
Change fluid resolution ....................................... 57
Convert fluids to polygons .................................. 57

How do I?

Simulate fluids .................................................... 57
Modify fluids ....................................................... 57
Change the size of a fluid container .................... 57
Change the resolution of a fluid ......................... 58
Change dynamic fluid behavior ......................... 58
Change fluid behavior at the container boundaries 59
Convert fluids to polygons ................................. 60
Modify fluid attributes ..................................... 60
Use fluid attribute presets ................................. 61

Reference

Menus ................................................................. 61
Dynamics menu set ............................................. 61
Fluid Effects > Extend Fluid ........................................... 61
Fluid Effects > Edit Fluid Resolution .............................. 62

Nodes ........................................................................... 62
Fluid Effects nodes ....................................................... 62
fluidShape ................................................................ 62
fluidEmitter ............................................................... 98

4 Object interaction with dynamic fluids ......................... 103

About
Fluids ........................................................................... 103
Object interaction ......................................................... 103
Object interaction ......................................................... 103

How do I?
Simulate fluids ............................................................ 103
Make objects interact with dynamic fluids ....................... 103
Make fluids collide with geometry ................................ 103
Move geometry with the force of a fluid ......................... 106
Move cloth with the force of a fluid ............................... 106
Move particles with the force of a fluid ......................... 107
Modify geometry with the force of a fluid ..................... 108
Motion fields ................................................................ 109
Work with motion fields .............................................. 109
Create motion field ..................................................... 109

Reference
Menus ........................................................................... 110
Dynamics menu set ..................................................... 110
Fluid Effects > ............................................................ 110
Fluid Effects > Make Collide ....................................... 110
Fluid Effects > Make Motion Field ............................... 110

Nodes ........................................................................... 111
Fluid Effects nodes ....................................................... 111
motionField .............................................................. 111

5 Playing fluids .............................................................. 113
## Table of Contents

### About
- Fluids playback ............................................. 113
- Fluids initial state ......................................... 113
- Caching fluids ................................................ 114

### How do I?

#### Simulate fluids ......................................... 118
- Set the initial state of a fluid .......................... 118
- Delete the initial state of a fluid ....................... 119
- Save the current state of a fluid ....................... 119
- Delete the initial state of a fluid ....................... 120
- Save the current state of a fluid ....................... 120
- Create fluids cache files ................................. 122
- Create a One Frame per File fluids cache ........... 123
- Append cache files ......................................... 124
- Delete and truncate cache files ....................... 124
- Load cache files ........................................... 125
- Replace the fluids cache at the current frame ...... 125
- Speed up playback .......................................... 126
- Disable the solver .......................................... 126
- Disable fluids collisions, emissions, and fields .... 126
- Disable display options .................................... 126
- Control the creation of temporary fluids cache files ........................................................................ 127

#### Fluid Effects ............................................. 127
- Maya cannot read the fluids cache ...................... 127
- Maya cannot find the current fluids cache .......... 128
- Maya is unable to create a playback cache for the current fluid .................................................. 129

### What went wrong?

#### Reference

#### Menus ...................................................... 130
- Dynamics menu set .......................................... 130
  - Fluid Effects > ............................................. 130
    - Fluid Effects > Set Initial State .................... 130
    - Fluid Effects > Clear Initial State ................ 130
    - Fluid Effects > Save State As ...................... 130
    - Fluid Effects > Create Cache ...................... 131
    - Fluid Effects > Append to Cache ................... 132

Fluid Effects

6
# Table of Contents

Fluid Effects > Replace Cache Frame .................................. 133
Fluid Effects > Truncate Cache ........................................ 133
Fluid Effects > Delete Cache ........................................... 133

**Nodes** ........................................................................... 133

**Fluid Effects nodes** ....................................................... 133
cache\_fluidShape ............................................................. 133

---

## 6 Open water effects ................................................. 135

### About

**Fluids** ........................................................................... 135

**Open water effects** ....................................................... 135
Open water effects .......................................................... 135
Oceans ............................................................................. 135
Ponds ............................................................................. 136
Wakes .............................................................................. 137
Floating objects ............................................................... 137

---

### How do I?

**Simulate fluids** ........................................................... 138

**Create ocean effects** .................................................... 138
Create ocean effects using example oceans ....................... 138
Create new oceans ......................................................... 139
Preview a patch of ocean ................................................ 139
Convert wave displacement to polygons ......................... 140
Add locators ................................................................. 141
Add a buoy to an ocean .................................................. 141
Make objects float .......................................................... 142
Make boats float ............................................................ 143
Create an Interactive boat simulation ............................... 145

**Create ponds** ............................................................... 146
Create Ponds ................................................................. 146

**Create wakes** ............................................................. 147
Create Pond wakes ....................................................... 147
Create an Ocean wake .................................................... 147

---

### Reference

**Menus** ........................................................................... 148
# Fluid Effects

## Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamics menu set</td>
<td>148</td>
</tr>
<tr>
<td>Fluid Effects &gt;</td>
<td>148</td>
</tr>
<tr>
<td>Ocean &gt;</td>
<td>148</td>
</tr>
<tr>
<td>Fluid Effects &gt; Ocean &gt; Create Ocean</td>
<td>148</td>
</tr>
<tr>
<td>Fluid Effects &gt; Ocean &gt; Add Dynamic Locator</td>
<td>149</td>
</tr>
<tr>
<td>Fluid Effects &gt; Ocean &gt; Add Boat Locator</td>
<td>149</td>
</tr>
<tr>
<td>Fluid Effects &gt; Ocean &gt; Add Dynamic Buoy</td>
<td>149</td>
</tr>
<tr>
<td>Fluid Effects &gt; Ocean &gt; Float Selected Objects</td>
<td>149</td>
</tr>
<tr>
<td>Fluid Effects &gt; Ocean &gt; Make Boats</td>
<td>150</td>
</tr>
<tr>
<td>Fluid Effects &gt; Ocean &gt; Make Motor Boats</td>
<td>150</td>
</tr>
<tr>
<td>Fluid Effects &gt; Ocean &gt; Create Wake</td>
<td>150</td>
</tr>
<tr>
<td>Pond &gt;</td>
<td>161</td>
</tr>
<tr>
<td>Fluid Effects &gt; Pond &gt; Create Pond</td>
<td>151</td>
</tr>
<tr>
<td>Fluid Effects &gt; Pond &gt; Create Wake</td>
<td>151</td>
</tr>
<tr>
<td>Nodes</td>
<td>152</td>
</tr>
<tr>
<td>Fluid Effects nodes</td>
<td>152</td>
</tr>
<tr>
<td>oceanPreviewPlane</td>
<td>152</td>
</tr>
<tr>
<td>locator (Fluid Effects)</td>
<td>152</td>
</tr>
<tr>
<td>oceanShader / ocean (texture)</td>
<td>154</td>
</tr>
</tbody>
</table>

## 7 Texturing and shading fluids

### About

- Fluids [167](#)
- Texturing and shading fluids [167](#)
  - Fluid effect texturing and shading [167](#)
  - Texturing fluids [167](#)
  - Fluids as textures [167](#)
  - Fluids as materials [168](#)
  - Fluid Shape shader as a particle shader [169](#)
  - Ocean shader and texture [169](#)

### How do I?

- Simulate fluids [170](#)
  - Use fluids as textures [170](#)
  - Texture a fluid [170](#)
  - Apply a fluid texture to an object [170](#)
## 8 Rendering Fluids

### About
- **Fluids**
- Rendering fluids

### How do I?
- **Simulate fluids**
- **Render fluids**
- Prepare to render fluids
- Cast fluid shadows onto objects
- Cast shadows onto fluids (fluids receive shadows)
- Set the properties of rendered images
- Render scenes with fluid effects
- Optimize rendering times
- Improve the render quality of fluids

### ACache Format

### About
- **Fluids**
- Cache format

### Index
Table of Contents
1 Introducing Fluid Effects

Note Fluid Effects is only available in *Maya Unlimited*.

About Fluids

Introducing Fluid Effects

Fluid Effects Overview

Maya Fluid Effects is a technology for realistically simulating and rendering fluid motion. Fluid Effects lets you create a wide variety of 2D and 3D atmospheric, pyrotechnic, space, and viscous liquid effects.

You can use the Fluid Effects *solvers* to simulate these effects, or you can use fluid *animated textures* for more unique, distinguishing effects.

Fluid Effects also includes an *ocean shader* for creating realistic open water. You can float objects on the ocean surface and have those objects react to the motion of the water.

You can create the following types of effects with Fluid Effects:

| Realistic atmospheric effects, such as clouds, mist, fog, steam, and smoke. | Pyrotechnics, such as fire, explosions, and nuclear blasts. |
Introducing Fluid Effects

Types of fluids

In Maya, there are three basic types of fluid effects:

**Dynamic fluid effects**

Dynamic fluid effects behave according to the natural laws of fluid dynamics, a branch of physics that uses mathematical equations to calculate how things flow. For dynamic fluid effects, Maya simulates fluid motion by solving the Navier-Stokes fluid dynamics equations at each time step. You can texture dynamic fluids, apply forces to them, and have them collide with and move geometry, affect soft bodies, and interact with particles.

**Related topics**

- “Create dynamic fluid effects” in Chapter 2
- “Change dynamic fluid behavior” in Chapter 3
- “Playing fluids” chapter

<table>
<thead>
<tr>
<th>Viscous fluids, such as molten lava and mud.</th>
<th>Open water, such as calm or rough oceans with white caps and foam.</th>
</tr>
</thead>
</table>

**Note** The effects you can produce in this version of Maya are *single-fluid effects*, which means you cannot have two or more fluids interacting to produce liquid-like effects (for example, pouring water, where water and air are the two fluids).
Non-dynamic fluid effects

3D fluids inherently require extra data to define them, which can make them very large. This extra data can slow a dynamic simulation exponentially because more calculations (solving) must be performed at every step of the simulation. For a less memory intensive effect, you can use a 2D fluid (with less data), or you can create a non-dynamic fluid.

Non-dynamic fluid effects do not use the fluid solvers to simulate fluid motion. For non-dynamic fluid effects, you create the look of a fluid using textures and you create fluid motion by animating (keyframing) texture attributes.

Since Maya doesn’t solve the fluid dynamics equations for non-dynamic fluids, rendering this type of fluid is much faster than rendering a dynamic fluid.

Related topics
- “Create non-dynamic fluid effects” in Chapter 2
- “Fluids as textures” in Chapter 7
- “Fluids as materials” in Chapter 7
- “Ocean shader and texture” in Chapter 7

Oceans and Ponds

You can create Ocean and Pond fluids to simulate large realistic water surfaces, such as stormy oceans with foam and swimming pools. Oceans are NURBS planes with ocean shaders assigned to them. Ponds are 2D fluids that use a spring mesh solver and a height field. Also, you can add Wakes to Oceans and Ponds to create boat wakes, add additional turbulence, or generate bubbling and ripples.

Related topics
- “Oceans” in Chapter 6
- “Ocean shader and texture” in Chapter 7
- “Ponds” in Chapter 6

Getting started with Fluid Effects

Fluid examples

To assist you in creating your own fluid effects, a set of example fluid files is included with Maya. These files contain the fluids, geometry, shaders, lights, and environments that let you quickly create the effects you want. Also included with the example fluid files are predefined initial states (or caches) that describe the initial starting point of fluid simulations (for
example, a cloud) and attribute presets that define the attribute settings for specific effects. You can import these example files into your scene, play them, and render them without alteration, or you can modify them to customize the effects.

To access the example fluid files, initial states, and presets, select Fluid Effects > Get Fluid Example.

**Fluid tutorials**

To help you learn Fluid Effects, a Fluids Effects tutorial is included with Maya. The Fluid Effects tutorial is one of the many comprehensive tutorials in the *Getting Started with Maya Unlimited* book.

To access the Fluid Effects tutorial, select Help > Tutorials.
2 Creating Fluid Effects

About Fluids

Creating fluid effects

What are the components of a fluid?

Fluid containers

A fluid container is a rectangular 2D or 3D boundary that defines the space in which the fluid exists. Fluid effects cannot exist outside a container. The fluid container is the principle component for any dynamic or non-dynamic fluid effect. Open water effects do not require containers. For details, see “Open water effects” on page 135.

Fluid containers are divided into three dimensional grids, and each unit of one of these grids is called a voxel.

When you first create a fluid container, it’s empty. To create a fluid effect, you need to add contents to the container and then modify the look and behavior of the fluid by modifying the container attributes. See “Defining the contents of a fluid container” on page 19.

3D fluids can be very large, making the solve for their dynamic fluid behavior very slow. This is due to all the extra data required to define them. In many cases, the effect you want can be achieved using simpler, less memory intensive 2D fluids.

---

| Note | Fluid containers can be placed within each other, but the fluids will not interact with each other. |

For information on creating fluid containers, see ”Create fluid containers” on page 25.
For information on modifying fluid containers, see the “Modifying fluids” chapter on page 15.

2D containers
A 2D fluid container is a 3D fluid container with a depth of one voxel. The size of that voxel is determined by the Z size of the container.

As the Z size gets bigger, any Density in it becomes more opaque. By animating the Z size you can mimic the 3D effect of an object moving through the fluid without the extra rendering time it would take to have a full-fledged 3D fluid.

3D containers
A 3D fluid container is a fluid container with a depth of two or more voxels.
Fluid emitters
You can add fluid properties (Density, Temperature, Fuel, and Color) to a fluid container using a fluid emitter. A fluid emitter creates fluid property values and populates the voxels of a grid with those values as a simulation plays. The fluid emitter must be within the bounds of the fluid container to emit.

Container contents
You define a fluid effect by putting values for any or all of the following fluid properties into its container: Density, Velocity, Temperature, Fuel, and Color.

You can use different methods to define these properties, depending on the effect you want and whether the effect is dynamic or non-dynamic. See “Defining the contents of a fluid container” on page 19.

Density
Density represents the material property (the substance) of the fluid in the real world. Think of density as the geometry of the fluid. Where the Density values are highest, the Density appears more opaque. You can create a non-dynamic fluid effect using only Density, or you can combine Density with Velocity and other properties to create dynamic simulations.

Velocity
Velocity affects the behavior of dynamic fluids by moving Density, Temperature, Fuel, and Color values inside the container. Velocity has both magnitude and direction values. Direction defines the moving fluid values’ path.
For dynamic simulations, Maya calculates the Velocity values based on the forces you apply to the simulation. However, you can also set a fixed Velocity path, using Velocity as a force to push property values around in the container.

Velocity is required for dynamic fluid simulations.

**Temperature**

Temperature affects the behavior of a dynamic fluid, causing it to rise or react.

**Fuel**

For dynamic fluids, Fuel combined with Density creates a fluid where a reaction can take place. Density values represent the substance being reacted, and Fuel values describe the state of the reaction. Temperature can ignite Fuel to start a reaction (for example, an explosion effect). During the course of the reaction, the Density and Fuel values get smaller until the reaction is complete.

**Color**

This property applies color to Density. Color appears only where there is Density.

**Example**

This example combines Density, Temperature, Fuel, and Velocity values to create a dynamic simulation of a flame.

There are two ways to color fluids:

- Using the built-in shader color
  
  The shader is built into the fluid making this an efficient way to color your fluids.
- Using grids
Grids give you control over where color is placed in each voxel. You can also make color behave dynamically, which means you can make colors interact and mix.

Combining fluid properties to create dynamic effects

While non-dynamic effects only use properties defined as gradient or static grid (the values cannot change), dynamic effects combine fluid properties defined by gradients with fluid properties defined by dynamic grids.

For example, you could set Density to use a Dynamic Grid, but add a constant Velocity in a single direction to affect the movement of the Density. The magnitude and direction of the Velocity would remain unchanged as the simulation progresses, but the Density values would change as a result of the solving.

Defining the contents of a fluid container

There are two ways you can define a fluid property for a fluid container:

- Define it as a preset gradient
- Define it as a grid

Preset gradients

You can set the property values of a fluid container as predefined gradients. Predefined gradients are sets of values in the form of gradients that are provided with Maya. Predefined gradient property values stay constant over time and they require no calculations at render time; making them render more quickly than dynamic grid fluid properties. You can not change preset gradient values, but you can scale the values for the entire container.

The following example of a 3D fluid in shaded display mode shows Density defined as a Y gradient. The effect looks like ground fog, with Density values gradually getting smaller along the Y axis. By applying a texture to it, you can give it a more realistic look. By animating (keyframing) the texture, you can make the fog appear to move without using dynamics.
You can also produce some interesting effects by applying textures to gradients and then animating the textures. See “Texturing fluids” on page 167.

### Grids

When you define a fluid property as a grid, you can place different property values in each individual grid unit called a *voxel* (volume pixel). Grids give you precise control over what the values are in the container. There are two types of grids: *dynamic* and *static*.

You place values in a grid by emitting them (similar to emitting particles), painting them, or by adding a predefined initial state cache. See “Add properties to fluid containers” on page 26.

The following example of a 2D fluid shows Density in a grid. The image on the left shows the image in shaded display mode. The image on the right shows what the actual Density values are in each voxel.
Increasing the number of voxels that comprise a fluid container increases the quality of the rendered fluid image, but also increases the time it takes to render.

**Dynamic Grids**

You use dynamic grids to simulate dynamic fluid behavior. At each step of the simulation, Maya recalculates the values in each voxel using the fluid dynamics solver and replaces the values with the newly calculated ones. This is what creates the dynamic motion of the fluid.

For dynamic fluid simulations, Density must be set to *Dynamic Grid*. Also, you cannot turn off Velocity because it is what moves the property values around inside the grid.

**Static Grids**

You use static grids to define specific values in the grid. Once you place values in a static grid, the values cannot be changed by the result of the solve. Static grids are useful when you want control over values in specific areas of the container, but you do not want those values to change over time.

**Paint fluid properties into grids**

You can use the Paint Fluids Tool to place values in precise locations in a fluid grid, and with each brush stroke you can edit existing values by scaling, smoothing, replacing, or adding to existing values. The Paint Fluids Tool is an Artisan brush tool and therefore works like the other Artisan tools. For more information on Artisan Brush Tools, see *How Artisan brush tools work* in the Paint Effects, Artisan, and 3D Paint guide.
Fluid examples

Maya provides example files of complete fluid effects. Each example file includes the fluids, geometry, shaders, lights, cache files, and environments required for the effect. You can quickly import them into your scene, play, and render them without alteration. See “Import Fluid examples” on page 22.

How do I? Simulate fluids

Create fluid effects

Import Fluid examples

Maya provides example files of complete fluid effects. Each example file includes the fluids, geometry, shaders, lights, cache files, and environments required for the effect. You can quickly import them into your scene, play, and render them without alteration.

Modify these files to customize the effects, use them as learning tools to understand how to create your own effects, or use them simply for ideas.

To import a fluid effect example

1 In the Dynamics menu set, select Fluid Effects > Get Fluid Example. Visor opens to the Fluid Examples tab.

2 Click the folder containing the example you want to import, and with the middle mouse button, drag the preset icon from Visor onto the scene. Maya imports the example scene into your scene.

3 Select the fluid container and open the Attribute Editor.

The Notes section at the bottom of the Attribute Editor provides information about the fluid effect, pointing out the key aspects of its construction.

In many cases, example scenes include a dedicated perspective camera. To render your scene as it appears in the Visor swatch you need to use that camera. For example, the example scene Perlin3DCloud.ma uses the camera Perlin3DCloudCam. In Render View, select Render > Render > Perlin3DCloudCam instead of persp and render.
Create dynamic fluid effects

When you play the simulation, Maya applies the fluid dynamics solver to the values in the container, calculating new values at each time step and replacing old values in the grid with the new ones.

Explosions, flames, smoke, and lava are examples of effects you could create as dynamic fluid effects.

For examples of basic dynamic fluid effects, see Fluid Effects Lessons one and three in Getting Started with Maya Unlimited. Also look at the fluid examples in Visor. For details, see “Fluid examples” on page 22.

To create a dynamic fluid effect:

1. Create a fluid container.
   See “Fluid containers” on page 15.

2. Add Density values to a dynamic grid. See “Add properties to grids” on page 26.

3. Select the container, and click the fluidShape tab in the Attribute Editor:

4. Set the Contents Method for Velocity to any setting but Off.
   - Set it to Dynamic Grid to allow internal forces to affect the Velocity at each time step.
   - Set it to Gradient to make the Velocity values remain constant at each time step, and select which gradient of values you want to use.
   - Set it to Static Grid to define a specific velocity path that remains constant at each time step and then add the velocity values to the grid. See “Add properties to grids” on page 26.

5. Add Temperature and Fuel values to the container, if you are using them in the simulation. (Temperature and Fuel can be used for explosion and burning effects.)

6. Add color to the fluid. See “Add color to fluids” on page 36.
7 Play the simulation using the playback controls at the bottom of the Maya window.

If you are in wireframe mode, the fluid displays as particles by default. To view the simulation as it would render, switch to shaded display mode and in the Display area of the fluidShape Attribute Editor, change Shaded Display to As Rendered.

For information on speeding up the playback, see “Caching fluids” on page 114.

8 Modify the appearance and behavior of the fluid. See “Modifying fluids” on page 55.

You can make the fluid collide with and move geometry, affect soft bodies, and interact with particles. For details, see “Object interaction with dynamic fluids” on page 103.

Create non-dynamic fluid effects

In non-dynamic fluid effects the fluid property values are predefined within Maya and stay constant over time, which means they don’t have to be recalculated. You create the appearance of the fluid by texturing a special fluid shader that is built-in to the fluid. This shader is built into the fluid for better performance. If you want the fluid effect to have motion, you can animate (keyframe) the texture attributes. Because Maya doesn’t solve the fluid dynamics equations, rendering this type of fluid is much quicker than rendering a dynamic fluid.

Clouds, fog, space, and other more abstract effects are good candidates for non-dynamic effects.

For an example of a basic non-dynamic fluid effect, see Fluid Effects Lesson two in Getting Started with Maya Unlimited. Also look at the fluid examples in Visor. For details, see “Fluid examples” on page 22.

To create a non-dynamic fluid effect

1 Create a fluid container.
   See “Fluid containers” on page 15.

2 Add Density values to the container that cannot change over time. Do one of the following:
   • Add them as a predefined gradient of values.
     See “Add properties as predefined gradients” on page 26.
   • Add them to a Static Grid.
     See “Add properties to grids” on page 26.

3 Add color to the container using the built-in fluid shader.
See “Color fluids using shading color” on page 36.

4 Texture the contents of the fluid using the built-in fluid texturing capabilities.
See “Texturing fluids” on page 167.

5 To create motion, keyframe the “Texture Time” attribute in the Textures section of the fluidShape Attribute Editor.
For information on keyframing attributes, see Animation.

Create fluid containers

To create an empty fluid container

1 In the Dynamics menu set:
   • For a 3-dimensional fluid, select Fluid Effects > Create 3D Container >.
   • For a 2-dimensional fluid, select Fluid Effects > Create 2D Container >.

The Fluid Effects > Create 3D Container window appears.

2 Modify options defining the size and resolution of the fluid container, if required, then click Apply and Close.

Maya creates the fluid container. By default, Density and Velocity are set to Dynamic Grid with their values set to 0 in each of the voxels. Temperature and Fuel are set to Off.

If you play the simulation, nothing will happen. You must put fluid property values in the container simulate fluid behavior.

For details on adding property values to containers, see “Add properties to fluid containers” on page 26.

For details on modifying containers, see “Modifying fluids” on page 55.

| Tip | You can create a fluid container and connect a fluid emitter to its origin at the same time. For details, see “To create a fluid container with a fluid emitter automatically connected to its center” on page 28. |

Changing the container boundary display

You can change the way the container boundaries display in your scene, or choose not to display them, by modifying the Boundary Draw setting in the Display section of the fluidShape Attribute Editor. For more information, see “Boundary Draw” on page 68).
Add properties to fluid containers

There are two basic ways to add Density, Velocity, Temperature, and Fuel properties to fluid containers. You can use any combination of these methods to create fluid effects.

Color is treated differently. For details, see “Add color to fluids” on page 36.

Add properties as predefined gradients
See “Add properties as predefined gradients” on page 26.

Add properties to grids
Set the Contents Method for the property to Dynamic Grid or Static Grid in the fluidShape Attribute Editor and add property values using any of the following techniques:

- Emit fluid properties into a fluid container with fluid emitters. See “Emit fluid properties into grids” on page 27.
- Paint fluid properties into a fluid container. For details, see “Paint fluid properties into grids” on page 30.
- Use initial state caches to put predefined properties into a fluid container. “Add predefined initial states to fluid containers” on page 43
- Emit fluid properties from an object. “Display fluid container contents” on page 37.

Add properties as predefined gradients
You can set the property values in a fluid container as predefined gradients with values that never change. Because gradients are defined within Maya, no calculations are required at render time making them render more quickly than dynamic grid fluid properties.

A gradient-type fluid property can have a constant value of 1 throughout the container (no gradient), or it can have a gradient of values from 0 to 1 along the X, Y, or Z axis or from the outside of the container to the center of the container. You can scale these values, but otherwise, you cannot change them.

To add gradient contents to a container:

1. With the fluid container selected, select Fluid Effects > Add/Edit Contents > Gradients > □.

The “Fluid Effects > Create 3D Container with Emitter” window appears.
2 Turn on the properties you want to be represented by gradients, select a gradient, then click Apply and Close.

Alternatively:
Add gradient contents to a container from the fluidShape Attribute Editor. Under Contents Method, change the method for the property (for example, Density) to Gradient, and then change the property Gradient to the desired type of gradient.

**Note** If you want a property to behave dynamically, the Contents Method for that property must be defined as Dynamic Grid, not Gradient or Static Grid, and the Contents Method for Velocity cannot be Off.

**Emit fluid properties into grids**
You can add fluid properties (Density, Temperature, Fuel, and Color) to a fluid container using a fluid emitter. A fluid emitter creates fluid property values and populates the voxels of a grid with the values as a simulation plays. The fluid emitter must be within the bounds of the fluid container to emit.

When you emit fluid properties into a Dynamic Grid, Maya creates the property values and solves them to create the fluid motion.

When you emit fluid properties into a Static Grid, Maya creates the property values, but no solving takes place so only the voxels within the emitter Max Distance range are populated.

You can:
- Emit from multiple fluid emitters in a container.
- Remove Density, Heat, and Fuel from a fluid container using a fluid emitter with negative emission values.
- Keyframe the fluid emitter position within the container the same as for any other object. See *Animation* for information on setting keys.

For information on emitting Color into a container, see “Add color to fluids” on page 36.

**Create a fluid container with a fluid emitter**
You can create a fluid container and add an emitter to it at the same time using the following procedure. The emitter is automatically parented to the container so they move together when you move the container.
To create a fluid container with a fluid emitter automatically connected to its center

1 For a 3-dimensional fluid, select Fluid Effects > Create 3D Container with Emitter.
   For a 2-dimensional fluid, select Fluid Effects > Create 2D Container with Emitter.
   The Create Container with Emitter Options window appears.

2 Modify options defining the size and resolution of the fluid container, if required. For information on the container options, see “Fluid Effects > Create 3D Container” on page 44.

3 Modify options defining the basic emitter attributes, if required. For information on the emitter options, see “Fluid Effects > Create 3D Container with Emitter” on page 52.

4 Click Apply and Close.

   Maya creates the fluid container and fluid emitter, parenting the fluid emitter to the container. By default, Density and Velocity are set to Dynamic Grid with their values set to 0 in each of the voxels. Temperature and Fuel are set to Off.

5 In the Playback area, click the Play button to view the fluid simulation.

   If you are in wireframe mode, the fluid displays as particles by default.

   To view the simulation as it would render, switch to shaded mode and in the Display area of the fluidShape Attribute Editor, change Shaded Display to As Rendered.

6 Move the emitter (keeping it inside the fluid container), as appropriate, and modify fluid container and fluid emitter attributes to achieve the effect you want.

   • For details on modifying fluid container (fluidShape) attributes, see “Modify fluid attributes” on page 60.
Add fluid emitters to containers

Use this procedure to add a fluid emitter to an existing fluid container. The emitter is automatically parented to the container so they move together when you move the container.

You can add multiple emitters to a container.

**To add a fluid emitter to a container:**

1. Select the fluid container and then select Fluid Effects > Add/Edit Contents > Emitter > .

   The “Fluid Effects > Create 3D Container with Emitter” window appears.

2. Modify options defining the basic attributes of the emitter, if required, then click Apply and Close.

   Maya creates a fluid emitter at the center of the fluid container and parents it to the container.

3. In the Playback area, click the Play button to view the fluid simulation.

   If you are in wireframe mode, the fluid displays as particles by default.

   To view the simulation as it would render, switch to shaded mode and in the Display area of the fluidShape Attribute Editor, change Shaded Display to As Rendered.

4. Move the emitter (keeping it inside the fluid container), as appropriate, and modify fluid container and fluid emitter attributes to achieve the effect you want.

   For details on modifying fluid container (fluidShape) attributes, see “Modify fluid attributes” on page 60.
2 | Creating Fluid Effects
How do I? > Paint fluid properties into grids

- For details on modifying fluid emitter (fluidEmitter) attributes, see “fluidEmitter” on page 98.

Paint fluid properties into grids

You can use the Paint Fluids Tool to place values in precise locations of a fluid grid, and you can edit existing values by scaling, smoothing, replacing, or adding to existing values with each brush stroke. The Paint Fluids Tool is an Artisan brush tool and therefore works like the other Artisan tools. For details, see How Artisan brush tools work in the Paint Effects, Artisan, and 3D Paint guide.

To paint fluid property values, the Contents Method for the property must be defined as Static Grid or Dynamic Grid.

Paint in a 2D container

Painting property values in a 2D container is like painting on a canvas. Move the brush over the plane representing the container and drag to place property values in the grid.

To paint a fluid property in a 2D fluid container:

1. Select the fluid container.
2. Select the Paint Fluids Tool and open the Tool Settings window (Fluid Effects > Add/Edit Contents > Paint Fluids Tool > boxshadowup).
3. If you are painting in a Dynamic Grid, make sure “Auto Set Initial State” is turned on in the Paint Attributes section of the Tool Settings window.

   This option saves the values you paint to an initial state cache file so that when you rewind to the first frame of a simulation after playing it, your original painted values are restored. The values are saved when you quit the Paint Fluids Tool, when you change the current time, and when you change your selection. For information on initial states, see “Set the initial state of a fluid” on page 118.
4 Beside Paintable Attributes, select the fluid property you want to paint. For details, see “Paintable Attributes” on page 47.
   If the selected fluid property is not set to Dynamic or Static Grid, you are prompted to set it.

5 Modify any Paint Attributes settings.
   See “Paint Attributes” on page 46.

6 Select a brush Profile, Paint Operation and Value. For details, see “Fluid Effects > Add/Edit Contents > Paint Fluids Tool” on page 46.

7 Drag across the fluid container to paint.

Paint in a 3D container

To paint in a 3D container you actually paint in two dimensions on “slices” of the container. A slice is a plane in X, Y, or Z that represents where you paint. (You could think of a slice as the canvas.) You paint each slice individually, but the accumulative effect of adjacent slices is a 3D fluid.

When you first select the Paint Fluids Tool, a paint slice displays at the origin of the fluid container. The slice is represented by a plane with dotted edges and fluid subvolume manipulators at one corner. When you move the pointer over the slice the pointer changes to a brush indicating that you can paint on the slice.

You control the location and thickness of the slices you paint using the fluid manipulators that appear at a corner of the slice. For details, see “Display subvolumes of 3D containers” on page 37.
To paint a fluid property in a 3D fluid container

1. Select the fluid container.

2. Select the Paint Fluids Tool and open the Tool Settings window (Fluid Effects > Paint Fluids Tool > 🗼).

3. If you are painting in a Dynamic Grid, make sure “Auto Set Initial State” is turned on in the Paint Attributes section of the Tool Settings window.

   This option saves the values you paint to an initial state cache file so that when you rewind to the first frame of a simulation after playing it, your original painted values are restored. The values are saved when you quit the Paint Fluids Tool, when you change the current time, and when you change your selection. For information on initial states, see “Fluids initial state” on page 113.

4. Beside Paintable Attributes, select the fluid property you want to paint. For details, see “Paintable Attributes” on page 47.

   If the selected fluid property is not set to Dynamic or Static Grid, you are prompted to set it.

5. Modify any Paint Attributes settings.

   See “Paint Attributes” on page 46 “Paint Attributes” on page 46.

6. Select a brush Profile, Paint Operation and Value. For details, see “Fluid Effects > Add/Edit Contents > Paint Fluids Tool” on page 46.

7. Move the paint slice to the slice you want to paint.

   See “Move the paint slice or subvolume” on page 40.

   The help line displays the location of the paint slice. For example:

   Fluid Slice Location: 4.000

   The number of slices along each axis corresponds with the resolution of the fluid container. The numbering starts at 0. So if the resolution of the container is 10 10 10, then the slices are numbered from 0 to 9.

8. If you want your strokes to affect only a portion of the container, display the subvolume you want them to affect. See “Change the thickness of the subvolume” on page 39.
To paint through multiple slices, in the Stroke section of the Paint Fluids Tool Settings editor, increase the Stamp Depth (3D) to a value large enough to paint through the slices. The brush provides feedback indicating how deep the stroke will paint on either side of the paint slice.

If you make the brush depth thicker than the depth of a displayed subvolume, only the subvolume will be painted.

10 Drag the brush across the paint slice.
11 Move the paint slice and paint. Repeat until you’ve painted all the values you want in the container.

Tips
- Tumble to change the view axes when you paint slices. Painting properties relative to different axes is good practice to ensure there are no gaps between slices when the fluid is viewed from different angles.
- Lock the view axes to prevent the paint slice from switching to another axis as you paint.
- For details, see “Display subvolumes of 3D containers” on page 37.
Flood a container with values

Flooding a container is like taking a huge brush and applying its settings to all the voxels in the container or selected subvolume. When you flood a fluid container, the voxel values for the selected fluid property change according to the value and operation set for the tool.

**To flood a container:**

1. Follow the first 5 steps under “To paint a fluid property in a 2D fluid container:”.
2. Display the slices you want to flood and click the Flood button (hotkey: Alt+f):
   - To flood the entire container, set the target manipulator to its default position,
   - To flood a subvolume, display the subvolume.

   For details, see ”Display subvolumes of 3D containers” on page 37.

| Tip | To smooth the transition between values, select the Smooth paint operation and flood the container or subvolume. |

Paint during playback

You can paint a fluid while playback is running to get a feel for the dynamics. For example, you can paint Density and watch it the simulation run as you paint Velocity.

You are not prompted to save your initial state when you start paint during playback. Anything painted during playback will be lost. (If Auto Save Initial State is on, the results of your last painted stroke will still be saved as your initial state.)

Map values to container voxels

You can map image values into container voxels. The settings for the Paint Fluids Tool are applied to the voxels using the mapped values.

When you import an image into a 3D fluid, the values are mapped to the subvolume slices indicated by the subvolume manipulator.

When you export an image from a 3D fluid, the values that are exported are the values on the paint slice.

The values import/export as follows:

- Density, Temperature, and Fuel
Values map to each of the RGB channels. For example, a Density value of 0.2 exports to RGB (.2, .2, .2)

- Color
  RGB values map directly to the RGB channels.
- Density and Color
  Color maps directly to the RGB channels and Density maps to the Alpha channel.
- Density and Fuel
  Density maps to R and Fuel maps to G.
- Velocity
  The X, Y, Z direction of the velocity maps to RGB, respectively, and the velocity magnitude maps to the Alpha channel. To accommodate negative velocities, Velocity values are mapped as follows:

  export color R = (velocity X + 1.0)/2
  import Velocity X = (2.0 * color R - 1.0)

  For details on mapping, see Map attributes in the Paint Effects, Artisan, and 3D Paint guide.

### Note

If you import a map with no Alpha channel (RGB data only) for properties expecting an Alpha channel (Density and Color, or Velocity) the result will be the Alpha being equal to luminance (RGB). Imported/exported Alpha values are remapped into/from the Min Value to Max Value range in the Paint Fluid Tool Settings.

**Display painted values**

You can select how you want the property values to display in shaded display mode as you paint. By default, only the values for the property you are painting display, but you can change this to display all the properties in the container as they would render. For details, see “Display” on page 49.

**Reset the Paint Fluids Tool**

Click the Reset Tool button in the Tool Settings window to reset the Paint Fluids Tool to its default settings.
Undo paint strokes
You can undo as many paint strokes as defined in the Undo category of
the Preferences window (Window > Settings/Preferences > Preferences).

Paint Fluids Tool settings
Before you paint attributes, set options for the Paint Fluids Tool in the
Tool Settings editor (Fluid Effects > Add/Edit Contents > Paint Fluids
Tool > r).

The settings in the Paint Attributes section determine the effect you will
achieve when you paint with the tool. These settings are described in
"Paint Attributes" on page 46.

For information on the other settings, see “Fluid Effects > Add/Edit
Contents > Paint Fluids Tool” on page 46.

Add color to fluids

Color fluids using shading color
The fluid container has a built-in shader that you can use to modify the
color, texture, and other attributes of the container to give the fluid a
particular look.

To color a fluid using shading color:
1 Select the fluid container.
2 In the Contents Method section of the fluidShape Attribute Editor, set
the Color Method to Use Shading Color (the default).
3 Open the Shading section of the Attribute Editor, and in the Color
section select a “Color Input” and set the ramp colors.

The ramp colors map to the values of the “Color Input” you select. Colors at the far left of the ramp (position 0) map to input values of 0. Colors to the far right of the ramp (position 1), map to input values of 1.

For details, see “Color” on page 83.

You can also set the “Incandescence” and “Opacity” of the fluid using
the built-in shader.

Color fluids using grids
As with other fluid properties, adding color to a grid gives you control
over the precise color values placed in each voxel.
The default grid color is green/brown (close to RGB 0.4 0.4 0.3) to minimize fringing when you add color. If this is not an acceptable grid color, flood the color grid with the color you want and set it as your initial state, see “Flood a container with values” on page 34 and “Fluids initial state” on page 113.

When you add color to a dynamic grid, the color values are solved using the fluid dynamics equations.

You can add Color to grids as follows:
- Painting (see “Paint fluid properties into grids” on page 30)
- Adding predefined initial state caches (see “Add predefined initial states to fluid containers” on page 43)
- Emitting (dynamic grid only)

**To emit color into a container**

1. Add a fluid emitter to the container. See “Add fluid emitters to containers” on page 29.
2. In the Fluid Attributes section of the fluidEmitter Attribute Editor, turn on Emit Fluid Color.
   - If the “Color Method” is not set to Dynamic Grid, you are prompted to set it.
3. Click the Fluid Color box to open the Color Chooser and select the color you want to emit.
4. Play the simulation using the playback controls at the bottom of the main Maya window.

**Note** If Color Method is set to Dynamic Grid, any emitters in the container that are emitting Density values, but are not emitting Color will take on the default grid color (green/brown) because those values are already in the grid.

---

**Display fluid container contents**

Use the options in the Display section of the fluidShape Attribute Editor to affect the fluid display in your scene. For details, see “Display” on page 66.

**Display subvolumes of 3D containers**

You can view isolated subvolumes of 3D fluid containers using the Show Manipulator Tool (default hotkey: t) or the Paint Fluids Tool.
2 | Creating Fluid Effects
How do I? > Display subvolumes of 3D containers

When you select a 3D container and either of these tools, a paint slice displays at the origin of the fluid container. The slice is represented by a plane with dotted edges and fluid subvolume manipulators at one corner.

Change the paint slice or subvolume axis
The axis for the slice is relative to your view. Tumble to change the axis for the slices you are displaying. The color of the manipulators corresponds with the color of the axis in the View or Origin axes. Tumbling to change the axis is good practice to see how the fluid appears from different angles.

Lock the paint slice or subvolume axis
Click the lock/unlock slice axis icon to lock the axis so that when you tumble, the slice does not switch to another axis. By default, the slice axis is unlocked.
Change the thickness of the subvolume

You control the thickness of the slices you display and paint using the manipulators that appear at a corner of the slice.

The default target position displays the contents of the entire container. (Which values display depends on the Shaded Display setting in Display section of the fluidShape Attribute Editor, or the Paint Fluids Tool Settings window.)

When you paint, the brush stamp centers on the slice represented by this plane. If you increase the “Stamp Depth (3D)” setting, voxels on either side of this plane are affected.

When you flood in this mode, all slices in the container are flooded.

Click the target icon once to switch to a scaling mode where you can increase the width of the subvolume.

The manipulator changes to include scaling boxes at the ends of the move arrows. Drag the scaling boxes to increase or decrease the width of the subvolume. In this mode, you can only see values within the subvolume.
If you are painting, only the slices in the subvolume are affected by paint strokes. To paint through the entire subvolume, you must increase the brush “Stamp Depth (3D)” setting.

Click the target icon twice to switch to a mode where the slice represented by the plane is the only slice in which you can see values.

If you paint property values on this slice when the Stamp Depth for the Paint Fluids Tool is greater than 0.5, only the displayed slice is affected. Click the target icon once more to return to the default target position.

**Move the paint slice or subvolume**

You control the location of the paint slice or subvolume using the manipulators that appear at a corner of the paint slice.

Drag the move arrows along the axis to move the location of the paint slice or subvolume.

Alternatively, you can use the Increment/Decrement Fluid Center Fluid Effects shortcut keys (Alt+Shift+s and Alt+Shift+a) to move the subvolume along the selected axis.

---

**Tip**

As with all manipulators, when a handle is active (yellow), dragging in the model view with the middle mouse button acts as a virtual slider for that handle.
Emit fluids from objects

You can emit fluid from any polygon or NURBS surface that is inside a fluid container. The fluid emits from the surface towards the closest voxels.

For closed objects (for example, spheres), the fluid emits from the external surface only, which means you cannot emit into the object using this technique. (You could emit into an object using a volume or omni fluid emitter.)

**To create a fluid by emitting from an object into a fluid volume**

1. Create a container.
   See “Fluid containers” on page 15.
2. Create the polygon or NURBS object you want to emit fluids.
3. Move the object or container so that the object is completely inside the fluid container. (An object can emit fluid only when it is inside a fluid container.)
4. Select both the object and the container.
5. Select Fluid Effects > Add/Edit Contents > Emit from Object. Maya creates a surface fluid emitter and connects it to the object and the fluid container.
6. Modify emitter attributes as appropriate. For details, see ”Modify fluid attributes” on page 60.
7. Modify fluid attributes as appropriate. For details, see ”fluidEmitter” on page 98.

**Set Contents with Curve**

Set Contents with Curve lets you use a curve to define where contents are added to a fluid container. Like a painted fluid stroke, the curve does not emit the fluid but instead inserts fluid samples into the fluid container.
When setting fluid contents from a curve, the container’s fluid Content Methods must be set to dynamic or static. See “Create dynamic fluid effects” on page 23 or “Create non-dynamic fluid effects” on page 24.

**To add fluid contents with a curve**

1. Create a 2D or 3D fluid container with or without an emitter. See “Create a fluid container with a fluid emitter” on page 27.
2. Draw a curve within the fluid container. For more information, search the online help for Drawing Curves.

<table>
<thead>
<tr>
<th>Note</th>
<th>If the curve extends past the boundaries of the container, fluid contents are added to the container only where the curve is within its boundaries, and the number of fluid samples are calculated for the entire curve.</th>
</tr>
</thead>
</table>

3. Select the curve and the container, and then select Add/Edit Contents > With Curve > r from the Fluid Effects menu. The Set Fluid Contents From Curve Options window appears.
4. Set the options for the fluid contents that are placed in the container by the curve. See ”Fluid Effects > Add/Edit Contents > With Curve” on page 50.
5. Click one of the following:
   - Choose **Apply and Close** to apply the defined fluid settings to the fluid contents that are inserted by the curve. The Set Fluid Contents From Curve Options window closes.
   - Choose **Apply** to apply the defined fluid settings to the fluid contents that are inserted by the curve. The Set Fluid Contents From Curve Options window remains open.
   - Choose **Close** to disregard any additions or changes to the fluid settings. The Set Fluid Contents From Curve Options window closes.
6. Set the initial state of your fluid. See “Set the initial state of a fluid” on page 118. You must set the initial state of your fluid to retain the contents added to your fluid container by the curve.

| Note | You now have the option to delete the curve. This will not affect the contents of the container. |
Add predefined initial states to fluid containers

An initial state describes the grid property values at the starting frame of a fluid simulation. You define the grid property values you want a simulation to start with and then set the initial state of the fluid. For information on setting initial states, see “Fluids initial state” on page 113.

If you want to use existing grid properties as the basis for other fluid effects (for example, a company logo, a spiral of velocity, a cloud), you can save the grid property values, and later add them to existing fluid containers in a scene. Maya includes an assortment of predefined initial states that you can use as examples. For information on creating your own predefined initial states, see “Save the current state of a fluid” on page 120.

**To add a predefined initial state to a fluid container:**

1. Select the fluid container.
2. Select Fluid Effects > Add/Edit Contents > Initial States. The Visor opens to the Fluid Initial States tab.
3. Click the folder containing the initial state you want to add to the container. If the fluid is a 2D fluid, select the 2D subfolder. If the fluid is a 3D fluid, select the 3D subfolder.

   You can only add initial states created in 2D containers to 2D containers. Similarly you can only add initial states created in 3D containers to 3D containers.

4. With the middle mouse button, drag the preset icon from Visor onto the selected fluid container. Any grid values already in the container are replaced with the initial state values.

   If the resolution of your container is different from the resolution of the container used to create the initial state, the resolution of your container changes to the resolution of the initial state container, and once the values are in place, changes back to your original resolution.
Reference Menus

Dynamics menu set

Fluid Effects >

Fluid Effects > Create 3D Container

Creates a container for fluids.

Fluid Effects > Create 3D Container > □

X, Y, Z Resolution

Define the resolution of the fluid in voxels (volume pixels). Higher resolutions produce finer detail, but increase rendering time and slow the interactive simulation.

The default resolution of a 3D container is 10, 10, 10.

The default resolution of a 2D container is 40, 40.

Even if you do not use any grids to define property values (you use all gradient style values), increasing the resolution increases the quality of the render.

X, Y, Z Size

Define the physical dimensions of the fluid container in the working units set for Maya. The default size of a 3D fluid container is 10, 10, 10.

The default size of a 2D container is 10, 10, 0.25.

Tips

- Make the Size proportional to the grid Resolution, even if you do not use any grids to define property values (you use all gradient style values). For example, if the size is 10.0 5.0 2.0, then a valid resolution would be 40 20 8. If the size is not proportional to the resolution, then the voxels will not be square causing the quality to be higher looking down one axis than another.

- A 2D fluid with a depth (Z Size) of 0 will not render as a volume, but it might do something reasonable as a height field (see ”Use Height Field” on page 64) or surface render (see ”Surface Render” on page 78).
Fluid Effects > Create 2D Container

- “Fluid Effects > Create 3D Container” on page 44

Add/Edit Contents >

Fluid Effects > Add/Edit Contents > Emitter

These options are the same as the ones found in the following section:
- “Fluid Effects > Create 3D Container with Emitter” on page 52

Fluid Effects > Add/Edit Contents > Emit from Object

These options are similar to the ones found in the following section:
- “Fluid Effects > Create 3D Container with Emitter” on page 52

However, only the following attributes and groups of attributes apply:

- Emitter Name
- Basic Emitter Attributes
- Distance Attributes

Fluid Effects > Add/Edit Contents > Gradients

Density/Velocity/Temperature/Fuel

Turn on the properties you want to be represented by gradients. You must select at least one property. When a property is turned off, the default method is applied (for Density and Velocity, Dynamic Grid, and for Temperature and Fuel, Off (zero)).

Density/Velocity/Temperature/Fuel Gradient

Select which predefined set of values you want to place in the container:
**Fluid Effects > Add/Edit Contents > Paint Fluids Tool**

**2D** (in XY)
- **Constant**
- **X Gradient**
- **Y Gradient**
- **Z Gradient**

**3D**
- **Constant**
- **X Gradient**
- **Y Gradient**
- **Z Gradient**
- **Center Gradient**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constant</td>
<td>Sets the value to 1 throughout the fluid.</td>
</tr>
<tr>
<td>X Gradient</td>
<td>Sets a ramp of values from 1 to 0 along the X axis.</td>
</tr>
<tr>
<td>Y Gradient</td>
<td>Sets a ramp of values from 1 to 0 along the Y axis.</td>
</tr>
<tr>
<td>Z Gradient</td>
<td>Sets a ramp of values from 1 to 0 along the Z axis.</td>
</tr>
<tr>
<td>-X Gradient</td>
<td>Sets a ramp of values from 0 to 1 along the X axis.</td>
</tr>
<tr>
<td>-Y Gradient</td>
<td>Sets a ramp of values from 0 to 1 along the Y axis.</td>
</tr>
<tr>
<td>-Z Gradient</td>
<td>Sets a ramp of values from 0 to 1 along the Z axis.</td>
</tr>
<tr>
<td>Center Gradient</td>
<td>Sets a ramp of values from 1 at the center, to 0 along the edges.</td>
</tr>
</tbody>
</table>

**Fluid Effects > Add/Edit Contents > Paint Fluids Tool**

Lets you paint to place values in precise locations of a fluid grid. See "Paint fluid properties into grids" on page 30. See also “How Artisan brush tools work” in the Paint Effects, Artisan, and 3D Paint guide.

**Fluid Effects > Add/Edit Contents > Paint Fluids Tool > □**

Lets you specify the settings for the Paint Fluids Tool in the Tool Settings editor. There are attributes unique to the Paint Fluids Tool in the Paint Attributes, Stroke, and Display sections. These unique attributes are described below. For descriptions of all other attributes in all other sections, see “Common Artisan Brush Tool Settings” in the Paint Effects, Artisan, and 3D Paint guide.

**Paint Attributes**

These are descriptions of the attributes in the Paint Attributes section.
Auto Set Initial State

When this option is on (the default), the current state of the fluid (any Density, Velocity, Temperature, Fuel, Color, or Texture Coordinate values in dynamic grids) is saved automatically when you quit the Paint Fluids Tool, change the current time, or change your selection. If this option is off and you do not set the initial state of the fluid before playing or stepping through a simulation, the original painted values are lost.

You can manually set the initial state at any time by selecting Fluid Effects > Set Initial State, and you can clear it by selecting Fluid Effects > Clear Initial State. For more information, see "Fluids initial state" on page 113.

Paintable Attributes

Select which property you want to paint.

Because Density is required to for Fuel to have an effect, you can simultaneously paint Density and Fuel values.

Similarly, because Color only displays in a grid where there is Density, you can simultaneously paint Density and Color values.

If you select Color, or Density and Color, be aware that the default grid color is green/brown (close to RGB 0.4 0.4 0.3). If this is not an acceptable grid color, flood the color grid with the color you want and set it as your initial state, see "Flood a container with values" on page 34 and "Fluids initial state” on page 113.

By default, when you paint a property value, only that value displays. You can view all values in the container as they will render by changing “Shaded Display” in the Display section to As Render.

Color Value

This setting is available only when Color, or Density and Color are selected as the Paintable Attribute. Click the Color Value box to open the Color Chooser and select the color you want to paint.

Velocity Direction

Velocity has both magnitude and direction. The Value setting defines the magnitude of the velocity you paint. Select how to define the direction of painted velocity strokes using the Velocity Direction setting. Velocity vectors display as you paint Velocity (Draw Velocity is turned on in the Display section of the Tool Settings window).

From Stroke The direction of the velocity vector value comes from the direction of the brush along the current paint slice.
As Specified
The direction of the velocity vector value comes from the Specified X, Y, and Z boxes that become available when you select this option.

Paint Operation
Select an operation to define how you want painted values to be affected.

Replace
Replaces the values you paint over with the specified Value and Opacity.

Add
Adds the specified Value and Opacity to the current voxel values you paint over.

Scale
Scales the values you paint over by the Value and Opacity factors.

Smooth
Changes the values to be the average of the surrounding values.

Value
Set the value to apply when you perform any of the painting operations.

Min/Max Value
Set the minimum and maximum possible paint values. By default, you can paint values between 0 and 1. Setting the Min/Max Values you can extend or narrow the range of values. Negative values are useful for subtracting values. For example, if you set Min Value to -1, Value to -0.5, and select Add for the operation, you would subtract 0.5 from the values you paint. Positive values are used as multipliers.

Tip
To help you differentiate paint values when you paint with ranges greater than 0 to 1 (for example, -5 to 5), and to maximize the range of values that display when you paint values with ranges between 0 to 1 (for example, 0.2 to 0.8), set Min Color and Max Color (in the “Display” section) to correspond with the Min/Max values.

Clamp
Select whether you want to clamp the values within a specified range, regardless of the Value set when you paint.
**Lower**

Turn this on to clamp the lower value to the specified Clamp Value. For example, if you clamp Lower and set the lower Clamp Value to 0.5, the values you paint will never be less than 0.5, even if you set the Value to 0.25.

**Upper**

Turn this on to clamp the upper value to the specified Clamp Value. For example, if you clamp Upper, set the upper Clamp Value to 0.75, and set Value to 1, the values you paint will never be greater than 0.75.

**Clamp Values**

Set the Lower and Upper values for clamping.

**Flood**

Click Flood to apply the brush settings to all the attribute values on the selected node. The result depends on the brush, value, paint operation, and other brush settings defined when you perform the flood.

**Stroke**

The stroke settings define how the brush moves across the selected surface. In addition to the standard Artisan stroke settings, the Paint Fluids Tool has the following option.

**Stamp Depth (3D)**

Increases the depth of the brush to paint through multiple slices in a single stroke.

**Display**

Use the settings in this section to define how the brush and property values display. In addition to the standard Artisan stroke settings, the Paint Fluids Tool has the following options.

**Shaded Display**

Select how you want the property values to display when in shaded display mode.

**Current Attribute**

Displays only the values for the property selected in Paintable Attributes.
If you paint Density and Fuel at the same time, Density values are represented by the opacity of the shaded values, while Fuel values are represented by a ramp of colors from blue (values of 0) to yellow (values of 1).

If you paint Density and Color at the same time, Density values are represented by the opacity of the shaded values, while Color is represented by the Color Value.

**As Render**
Displays the fluid as it will render. This is the same as setting the Shaded Display attribute in the Attribute Editor to As Render. See "Shaded Display" on page 66.

**Draw Velocity**
Turn this option on to display velocity vectors. This is the same as turning on Velocity Draw in the Attribute Editor. See "Velocity Draw" on page 70. Draw Velocity is turned on by default when you paint velocity.

**Fluid Effects > Add/Edit Contents > With Curve**

**Density**
Sets the density value of the fluid contents that are inserted by the curve. The default amount of density is 1.000.

**Velocity**
Sets the velocity value (magnitude and vector) for the fluid contents that are inserted by the curve. The default value is 1.000.

**Temperature**
Sets the temperature value of the fluid contents that are inserted by the curve. The default temperature value is 1.000.

**Fuel**
Sets the fuel value of the fluid contents that are inserted by the curve. The default fuel value is 1.000.

**Color**
Sets the color value of the fluid contents that are inserted by the curve. The default color is red.

**Operation**
Lets you Add to or Replace the contents of the affected voxels. Replace is on by default.
Number Of Curve Samples
Sets the number of samples that are calculated along the curve. For example, if you set the number of curve samples to 1, only one fluid sample on one voxel is generated. For best results, set the number of samples to a number that is greater than the number of voxels you want to affect. The maximum number of samples is 1000.

Radius
Defines the radius in which the fluid contents are inserted along the curve. The radius is measured in the same units as those set in your global user defined preferences. For more information, search the online help for Working Units.

Curve-Based Velocity
Sets the velocity of the fluid contents inserted along the curve to the value specified in the Velocity field of the Set Fluid From Curve options. When this attribute is on, the velocity’s magnitude decreases at high curvature points along the curve and increases at low curvature points. When this attribute is off, the velocity is stabilized at the specified velocity value and the velocity draw arrows all appear the same length. Curve-Based Velocity is off by default.

Set Initial State
Sets the selected fluid container’s Initial State when the contents are applied.

Fluid Effects > Add/Edit Contents > Initial States

Fluid Resolution

As Is
Sets the fluid example’s resolution to that of the current fluid container’s initial state.

From Initial State
Sets the current fluid container’s resolution to that of the fluid example’s initial state.
Fluid Effects > Create 3D Container with Emitter

Creates a container for fluids with an Emitter.

**Emitter Name**

Type a name for the emitter.

**Parent to Container**

Turn this option on to parent the emitter to the container. When the emitter is parented to the container, selecting the container automatically selects the emitter automatically.

- If you intend to put your emitter on a motion path, you should create or add it unparented.
- To unparent an emitter, select the emitter then choose Edit > Unparent.

**Basic Emitter Attributes**

**Emitter Type**

- **Omni**
  - Sets the emitter type to an omnidirectional point emitter. Fluid property values emit in all directions.
- **Volume**
  - Emits fluid property values from a closed volume. You pick the shape from the “Volume Shape” option.

**Density Rate (/Voxel/Sec)**

Sets the average rate at which Density values are emitted into the grid voxels per second. Negative values remove Density from the grid.

**Heat Rate (/Voxel/Sec)**

Sets the average rate at which Temperature values are emitted into the grid voxels per second. Negative values remove heat from the grid.

---

**Note**

If you select Volume, make sure the emitter is bigger than one voxel.
Fuel Rate (/Voxel/Sec)

Sets the average rate at which Fuel values are emitted into the grid voxels per second. Negative values remove Fuel from the grid.

Fluid Dropoff

Sets the dropoff value for fluid emission. For Volume emitters the dropoff specifies how much the emission drops off as you move away from the volume axis (dependent on the volume shape). For Omni emitters the drop off is based on the emission point and radiates out from “Min Distance” to “Max Distance”.

Cycle Emission

Cycling emission restarts the random number stream after an interval in frames, specified by the “Cycle Interval” attribute.

Setting “Cycle Emission” to Frame and Cycle Interval to 1 causes the random stream to restart every frame. Cycle Interval values greater than 1 can be used to generate cycles for games work.

This resets only the random stream used by the emitter. It does not reset the random number stream used by MEL, shaders, and so on. Note also that the Frame option resets at most once per frame. However, over sampling does not affect the results.

Cycle Interval

Specifies the number of frames between restarts of the random number stream. See “Cycle Emission”. Has no effect if Cycle Emission is set to None.

Distance Attributes

Max Distance

Maximum distance at which new property values are created from emitter. Not used for volume emitters.

Min Distance

Minimum distance at which new property values are created from emitter. Not used for volume emitters.

Volume Emitter Attributes

Volume Shape

Sets the shape of volume the emitter will use if the emitter is of volume type. Has an effect only if emitter type is Volume. Otherwise volume controls are disabled.
**Volume Offset X, Y, Z**

This is the parent attribute for the translational offset of the emission volume's center from the emitter's origin.

**Volume Sweep**

The arc of the volume emission. Used for sphere, cone, cylinder and torus.

**Section Radius**

Applies to torus volumes only. Defines the radius of a section of the torus.

**Fluid Effects > Create 2D Container with Emitter**

- See “Fluid Effects > Create 3D Container with Emitter” on page 52.
3 Modifying fluids

About Fluids

Modifying fluids

You can modify fluid behavior and appearance by modifying the attributes of the container, modifying the attributes of any fluid emitters in the container, and by converting the fluid to polygon geometry.

Changing fluid container size

You can change the size of fluid containers by:

- **Changing container dimensions** – This method changes the size of the voxels and proportionally changes the contents of the voxels.
- **Scaling containers** – This method changes the size of the voxels, but does not change the contents of the voxels.
- **Extending container boundaries** – With this method, you add voxels to the boundaries of the container, maintaining the size and contents of each voxel.

Changing container dimensions

The dimensions (physical size) of the fluid container are defined in the working units set for Maya. Increasing or decreasing the dimensions of a container while keeping the resolution unchanged increases or decreases the voxel size, respectively, and proportionally changes the voxel contents.

For example, if you increase the size of a container with Density, the Density increases proportionally, appearing thicker than the Density in the container before it was resized.
3 | Modifying fluids
About > Changing fluid container size

Scaling containers

Scaling fluid containers using the Scale transform increases the size of the container without scaling the properties inside the container.

For example, if you increase the scale of a container with Density, the density appears thinner because the amount of density in each voxel is redistributed to fill the larger voxel size.

Tip

To optimize render times, scale proportionally in X, Y, and Z. To size a container non-proportionally, use the Size attribute.

Extending container boundaries

You can extend the boundaries of an existing fluid container by adding voxels to any of the sides of the container. This increases the resolution of the fluid (the number of voxels defining the fluid) without affecting the size or the contents of the voxels. (Voxel size is determined by the fluid container size and the initial resolution of the fluid container. To maintain the voxel size while extending the fluid container, Maya scales the fluid container.)

The contents of the voxels remain intact. For properties defined as Gradient, the gradient values are applied to the entire container.
Change fluid resolution

The resolution of a fluid is defined in voxels (volume pixels). Higher resolutions produce finer detail, but increase rendering time. (Performance may be affected for resolutions over 10000.)

Changing the fluid resolution affects the properties currently defined in the container.

Convert fluids to polygons

You can convert a fluid to a polygonal mesh, which you can then treat like any other polygon.

- “Convert fluids to polygons” on page 60

How do I? Simulate fluids

Modify fluids

Change the size of a fluid container

To change the size of a fluid container

1. Select the fluid container.
2. In the Container Properties section of the fluidShape Attribute Editor, change the “Size” attribute.

Tips

- Make the size proportional to the grid resolution, even if you do not use any grids to define property values (you use all gradient style values). For example, if the size is 10.0 5.0 2.0, then a valid resolution would be 40 20 8. If the size is not proportional to the resolution, then the quality will be higher looking down one axis than another.

- A 2D fluid with a depth (Z Size) of 0 will not render as a volume, but it might do something reasonable as a height field (see "Use Height Field" on page 64) or surface render (see "Surface Render" on page 78).
3 | Modifying fluids
How do I? > Change the resolution of a fluid

To scale a fluid container

To extend a fluid container

1 Select the fluid container.
2 Select Fluid Effects > Extend Fluid > or click .
   The “Fluid Effects > Extend Fluid” window appears.
3 In the appropriate fields, enter the number of voxels you want to extend the container by in each direction and click Apply and Close.

| Tip | You can shorten the fluid container boundaries by using negative numbers. |

Change the resolution of a fluid

To change the resolution of a fluid

1 If property values exist in static or dynamic grids, save the scene before changing the resolution.
2 Select the fluid container.
3 Select Fluid Effects > Edit Fluid Resolution > or click .
   The Edit Fluid Resolution Options window appears.
4 In the appropriate fields, enter the number of voxels to define the resolution for the fluid container and click Apply and Close.
   For 3D fluids, the default is 10 10 10, for 2D fluids, the default is 40 40 0.1.

| Tip | Even if none of the fluid properties are defined as grids, increasing the resolution increases the quality of the rendered fluid. |

Change dynamic fluid behavior

You can create a dynamic fluid simulation by applying forces to the fluid. You can use forces that are built into the fluid (most efficient method), or external forces (fields).

Using forces built into the fluid

Using the forces built into the fluid is an efficient way to modify the way dynamic fluids move. Because they are built into the fluid, they compute more quickly than forces applied externally.
Density and Velocity must be set to Dynamic Grid to use the internal forces.

You can modify “Gravity” and “Friction” forces acting on the fluid in the “Dynamic Simulation” section of the fluidShape Attribute Editor.

Density and Temperature both have Buoyancy attributes you can modify in the Contents Details section of the Attribute Editor.

In the Contents Details section you can also add “Turbulence”, and “Velocity” swirl and damping.

**Using fluid Velocity as a force**

Velocity can be used as a force to move values around in the dynamic grid. The velocity “Swirl” attribute built into the fluid is particularly useful for creating swirl motion in small grids.

**Using external forces (fields)**

Dynamic fields (in the Fields menu) affect fluid motion. Using the Gravity and Turbulence forces built into the fluid is more efficient than using external forces, but using external forces gives you control over the origin of the forces.

**To connect external fields to a fluid:**

1. Select the fluid container.
2. Select Fields >fieldname.
3. Play the simulation.

**Change fluid behavior at the container boundaries**

The boundaries of a fluid container not only define where the fluid can exist, but for dynamic fluids, they affect the behavior of the fluid.

By default, all the boundaries of a fluid container affect dynamic behavior in the same way a container would in the physical world. For example, Density emitting towards a boundary collides with the boundary just as smoke rising to a ceiling collides with the ceiling.

You can define the boundaries so they have no effect on fluid behavior. For example, if you set a boundary to have no effect, Density emitting towards it would not collide with it but continue as though the boundary were not there. Even though the fluid appears to leave the container, it doesn’t. Fluid can only exist inside a container.

You can also define the boundaries so that the fluid wraps for continuous behavior along the boundary.
3 | Modifying fluids
How do I? > Convert fluids to polygons

To define fluid behavior at the container boundaries
1 Select the fluid container.
2 In the fluidShape Attribute Editor, modify the “Boundary X, Y, Z” settings in the Container Properties section.

Convert fluids to polygons
You can convert a fluid to a polygonal mesh, which you can then treat like any other polygon.

To convert a fluid to polygons:
1 Select the fluid container.
2 Select Modify > Convert > Fluid To Polygons.

Modify fluid attributes
The attributes for the fluid container (fluidShape, fluidTexture2DShape, and fluidTexture3DShape) define the way a fluid looks and behaves.

To modify fluid attributes:
1 Select the fluid container.
2 In the Attribute Editor, click the fluidShape tab and modify the settings.
3 Modify the attribute settings.
Use fluid attribute presets

A fluid attribute preset is a saved collection of fluid node attribute settings that you can apply to other fluid nodes at any time.

Maya ships with a set of fluid attribute presets which you can use as a starting point for various fluid types. You can also create your own attribute presets. You can replace the attribute settings in a fluid container with preset attributes settings, and blend presets with current attribute settings to get new variations.

Select the fluid container, then click and hold the Presets button at the top of the fluidShape Attribute Editor to view a list of available presets.

For information on creating and applying presets, see “Attribute Presets” in the “Using Maya Editors” chapter of the Basics guide.

| Note | If you apply an attribute preset created with a 2D fluid to a 3D fluid, the fluid becomes a 2D fluid. Similarly a 2D fluid becomes a 3D fluid when you apply a 3D fluid preset to it. |

Reference

Menus

Dynamics menu set

Fluid Effects >

Fluid Effects > Extend Fluid

Rebuild Initial State

After extending the fluid container, reset the initial state, saving the dynamic fluid properties in the initial state cache file. For information on initial states, see “Fluids initial state” on page 113.

Extend -X By

Set the number of voxels to extend the fluid container by in the -X direction.

Extend X By

Set the number of voxels to extend the fluid container by in the X direction.
Fluid Effects

Reference > Fluid Effects > Edit Fluid Resolution

Extend -Y By
Set the number of voxels to extend the fluid container by in the -Y direction.

Extend Y By
Set the number of voxels to extend the fluid container by in the Y direction.

3D only:
Extend -Z By
Set the number of voxels to extend the fluid container by in the -Z direction.

Extend Z By
Set the number of voxels to extend the fluid container by in the Z direction.

Fluid Effects > Edit Fluid Resolution

Rebuild Initial Conditions
Turn this option on to reset the initial state after changing the fluid resolution, saving the dynamic grid fluid properties in the initial state cache file. For information on initial states, see “Fluids initial state” on page 113.

X, Y Resolution
Set the X and Y resolution, in voxels.

3D only:
Z Resolution
For 3D fluids only, set the Z resolution, in voxels.

Nodes

Fluid Effects nodes

fluidShape

Container Properties
The attributes in this section define the basic characteristics of the fluid container.
Resolution

Defines the resolution of the fluid container in voxels (volume pixels).

The default resolution is for 3D fluids is 10 10 10.

The default for 2D fluids is 40 40.

Higher resolutions produce finer detail, but increase rendering time.

Tip

Even if none of the fluid properties are defined as grids, increasing the resolution increases the quality of the rendered fluid.

Size

Defines the size of the fluid container in world space units.

Tips

- Make the size proportional to the grid resolution, even if you do not use any grids to define property values (you use all gradient style values). For example, if the size is 10.0 5.0 2.0, then a valid resolution would be 40 20 8. If the size is not proportional to the resolution, then the quality will be higher looking down one axis than another.

- A 2D fluid with a depth (Z Size) of 0 will not render as a volume, but it might do something reasonable as a height field (see “Use Height Field” on page 64) or surface render (see “Surface Render” on page 78).

Boundary X, Y, Z

The boundary attributes control the way the solver treats property values at the boundaries of the fluid container.

For each boundary select one of the following boundary definitions:
Modifying fluids
Reference > fluidShape

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Makes all boundaries of the fluid container open so that fluid behaves as though the boundary isn’t there.</td>
</tr>
<tr>
<td>Both Sides</td>
<td>Closes both boundaries of the fluid container so they act like walls.</td>
</tr>
<tr>
<td>-X, -Y, or -Z Side</td>
<td>Closes the -X, -Y, or -Z boundary, respectively, so it acts like a wall.</td>
</tr>
<tr>
<td>X, Y, or Z Side</td>
<td>Closes the X, Y, or Z boundary, respectively, so it acts like a wall.</td>
</tr>
<tr>
<td>Wrapping</td>
<td>Causes the fluid flowing off one side of the fluid container to enter at the opposite side. This can be useful if you want to have a windy fog, but you do not want to continually replenish the Density at the in-flowing regions.</td>
</tr>
</tbody>
</table>

**Note**

The fluid does not actually leave the container where there are no boundaries. It just appears to. Fluid can only exist inside a container.

**Use Height Field**

(For 2D containers only.) Turn this option on to draw a 2D surface as a height field rather than a flat plane. This is useful for generating effects such as foam on a cappuccino or boat wakes.

This option affects both surface shaded renders as well as normal volume renders. (Remember that 2D fluids are really 3D fluids. The dynamic grid and textures are defined in 2D and projected onto the 3D volume.)

When Use Height Field is on, Opacity is reinterpreted to mean the height of a uniform opacity. This offset is in the Z axis coming out of the fluid. An Opacity value of 0.0 means a height of 0 and an Opacity value of 1 means the fluids fills up to the maximum Z boundary. The Z size of the 2D fluid is defined by the “Size” attribute.

The playback speed for “Surface Render” of 2D fluids is much faster if Use Height Field is on.
Contents Method

For each of the fluid properties, select which method to use to populate the fluid container with property values. For each property, you can scale the values in the container to uniformly increase or decrease them. See “Contents Details” on page 72.

Density/Velocity/Temperature/Fuel

- **Off (zero)**: Sets the property value to 0 throughout the fluid. When set to Off, the property has no effect on dynamic simulations.

- **Static Grid**: Creates a grid for the property that lets you populate each voxel with specific property values (using fluid emitters, the Paint Fluids Tool, or initial state caches). While these values can be used in dynamic simulations, they cannot change due to any dynamic simulation.

- **Dynamic Grid**: Creates a grid for the property that lets you populate each voxel with specific property values (using fluid emitters, the Paint Fluids Tool, or initial state caches) for use in any dynamic simulation.

- **Gradient**: Uses the selected gradient to populate the fluid container with property values. Gradient values are predefined in Maya without the use of a grid. Gradient values are used in calculations for dynamic simulations but the values cannot change because of the simulation. They render more quickly than grid values because no calculations are required for simulation.

Density/Velocity/Temperature/Fuel Gradient

Select which predefined set of values you want to place in the container:

- **Constant**: Sets the value to 1 throughout the fluid.

- **X Gradient**, **Y Gradient**, **Z Gradient**, **Center Gradient**: These gradients are used to distribute the property values across the fluid container in different ways.

Fluid Effects
X Gradient Sets a ramp of values from 1 to 0 along the X axis.
Y Gradient Sets a ramp of values from 1 to 0 along the Y axis.
Z Gradient Sets a ramp of values from 1 to 0 along the Z axis.
-X Gradient Sets a ramp of values from 0 to 1 along the X axis.
-Y Gradient Sets a ramp of values from 0 to 1 along the Y axis.
-Z Gradient Sets a ramp of values from 0 to 1 along the Z axis.
Center Gradient Sets a ramp of values from 1 at the center, to 0 along the edges.

Color Method
Color displays and renders only where Density is defined. Select which method to use to define color.

Use Shading Color Defines color using the Color ramp attribute in the “Shading” section of the Attribute Editor.

Static Grid Creates a color grid which you can populate with specific color values (using fluid emitters, the Paint Fluids Tool, or initial state caches). While these values can be used in dynamic simulations, they cannot change due to any dynamic simulation.

Dynamic Grid Creates a color grid which you can populate with specific color values (using fluid emitters, the Paint Fluids Tool, or initial state caches) for use in a dynamic simulation.

For Static and Dynamic Grids, the default grid color is green/brown (close to RGB 0.4 0.4 0.3) to minimize fringing where any colored Density you add meets voxels with no Density values. If this is not an acceptable grid color, flood the color grid with the color you want and set it as your initial state, see “Flood a container with values” on page 34 and “Fluids initial state” on page 113.

Display
The Display options affect how the fluid displays in the modeling view. They do not affect the final rendered image.

Shaded Display
Defines which fluid properties display in the fluid container when Maya is in shaded display mode. If Maya is in wireframe mode, the “Wireframe Display” options apply to the selected property.

Select Off to display nothing in the fluid container when in shaded display mode.
Select As Render to display the fluid as close as possible to the final software render.

Isolating the display of a specific property of the fluid (for example, Fuel) is particularly useful when painting the property with the Paint Fluids Tool or adjusting settings for it. Tweak the Opacity Preview Gain to map the selected property to a useful range of opacity in the grid.

For display options combining Density with another property (for example, Density And Temp), color differentiates the two properties.

**Opacity Preview Gain**

Adjusts the Opacity of the hardware display when the Shaded Display is not As Render. This is useful when painting values into the grid to help differentiate values that are very close together.

**Slices per Voxel**

Defines the number of slices displayed per voxel when Maya is in shaded display mode. A slice is a display of values on a single plane. Higher values produce more detail but reduce the speed of the screen draw. The default is 2. The maximum value is 12.

The orientation of the slices is determined by the voxel most aligned with the view plane.

**Voxel Quality**

If Voxel Quality is set to Better, the display quality is higher in hardware display. If it is set to Faster, the display quality is lower, but the draw is faster.
3 | Modifying fluids
Reference > fluidShape

Boundary Draw

Defines how the fluid container displays in 3D views. The grid corresponds with the “Resolution” settings.

**Bottom**  
The fluid container displays as a bounding box with a detailed grid on the bottom side. For 2D fluids, this setting displays a detailed grid.

**Reduced**  
The fluid container displays as a bounding box, with a detailed grid on the sides furthest away from the camera. For 2D fluids, this setting displays a detailed grid.

**Outline**  
The fluid container displays as a bounding box, with a detailed grid on all six sides. For 2D fluids, this setting displays a detailed grid.

**Full**  
The fluid container displays as a bounding box, with full grid lines representing each voxel. For 2D fluids, this setting displays a detailed grid.

**Bounding box**  
The fluid container displays as a bounding box only.

**None**  
The fluid container does not display, however, any visible properties do display.

Numeric Display

Displays numeric values for the selected property (Density, Temperature, or Fuel) in each voxel of a Static or Dynamic Grid. The numbers that display represent the values before the Scale is applied. For example, if the Density value in a voxel is 0.2 and the Density Scale is 0.5, the number that displays in the voxel is 0.2, not 0.1. No numeric values display when this option is set to Off or when the Contents Method for the selected property is set to Gradient.

Numeric Display can be used in both shaded and wireframe display modes.
Wireframe Display

If the Contents Method is set to Gradient for the property selected for Shaded Display, this option defines how to represent the opacity of the property when Maya is in wireframe display mode.

If Contents Method is set to Static or Dynamic Grid for the property selected for Shaded Display, this option defines how to represent the values of the property when Maya is in wireframe display mode.

- Off: Displays nothing in the fluid container.

- Rectangles: Displays rectangles on the grid lines of the fluid container. Larger rectangles represent areas with higher values or opacity.

- Particles: Displays particles to represent values or opacity. Areas with denser particles represent areas with higher values or opacity.
3 | Modifying fluids
Reference > fluidShape

Velocity Draw

Turn this option on to display velocity vectors for the fluid. Velocity vectors represent the magnitude and direction of the Velocity in the container. Velocity vectors help you visualize the motion path of the fluid.

Draw Arrowheads

Turn this option on to display arrow heads on the velocity vectors. Turn this option off to speed drawing and reduce visual clutter.

Velocity Draw Skip

Increase this value to reduce the number of velocity arrows that are drawn. If the value is 1 then every other arrow is omitted (or skipped). If it is zero then all arrows are drawn. Increase this number on grids with a high resolutions to reduce visual clutter.

Draw Length

Defines the length of the velocity vectors (a factor applied to the magnitude of the velocity). The larger the value, the longer the velocity segments or arrows. For simulations with very low force, the velocity field might be very small in magnitude. In this case, increasing the value will help to visualize the velocity flow.

Dynamic Simulation

To simulate flow for a fluid property, the Contents Method for that property must be set to Dynamic Grid and Velocity cannot be Off. During simulation, the values in the container are solved using the Navier-Stokes
fluid dynamics equations (solvers) and replaced with the new values to create the fluid motion. Use the attributes in this section to define the information used by the solvers.

Gravity

The Gravity setting is a built-in gravitational constant that simulates the gravitational attraction of the mass of the world in which the simulation is occurring. Negative values cause a downward pull (relative to the world coordinate system).

If Gravity is zero, Density “Buoyancy” and Temperature “Buoyancy” have no effect.

Viscosity

Viscosity represents the resistance of the fluid to flow, or how thick, and non-liquid the material is. When this value is high, the fluid flows like tar. When this value is small, the fluid flows more like water.

(When Viscosity is 1, the material Reynolds Number is 0; when it is 0, the Reynolds Number is 10000. The Reynolds Number is a parameter used in solving the fluid dynamics equations that is proportional to the viscosity of the fluid.)

Friction

Defines internal friction used in Velocity solving.

Damp

Defines the amount the Velocity solution is damped towards zero at each time step. At a value of 1, the flow is totally suppressed. Small amounts of damping can be useful when boundaries are open to keep strong winds from building up and leading to instability.

Grid Interpolator

Select which interpolation algorithm to use to retrieve values from points within a voxel grid.

- **linear**: Interpolate the values linearly. This is the faster of the two methods.
- **hermite**: Use a hermite curve to interpolate the fluid. This method causes less diffusion than linear, but makes the simulation run several times more slowly, especially when the fluid is colliding with geometry. Use hermite if you want Friction to be computed by the solver at the boundaries.
Start Frame

Sets the frame after which the fluid simulation will start. The default is 1.0. Nothing will play back for this object prior to this frame. You could use this attribute to delay the effect of a field on a fluid until the frame of your choice.

**Note!** If you change the Time units setting (Window > Settings/Preferences > Preferences), you must set the Start Frame to the correct initial value so that Maya computes the start time again.

Simulation Rate Scale

Scales the time step used in emission and solving.

Disable Evaluation

Turn this option on to turn off memory allocation, solving, and contents draw during interactive playback, but allow for batch rendering.

Conserve Mass

Turn this option on to conserve mass when updating the Density values during solving.

Use Collisions

Turn this option off to disable the collision of fluid with collision geometry in the container.

Use Emission

Turn this option to off to ignore all connected fluid emitters during simulation.

Use Fields

Turn this option to off to ignore all connected external fields during simulation.

Contents Details

The attributes in this section are specific to each fluid property.

Density

Density represents the material property of the fluid in the real world. You could think of it as the geometry of the fluid. If you compare it to a normal sphere, the volume equivalent of the sphere’s surface is the distribution of the Density inside the container.
Density Scale

Multiplies the Density values in the fluid container (whether they are defined in grids, or defined by preset gradients) by the scale value. Using a Density Scale of less than 1 makes the Density appear more transparent. Using a Density Scale greater than 1 makes the Density appear more opaque.

In the following example, Density is set to Constant, which means it has a value of 1 throughout the fluid container. As you scale the Density values with a Density Scale less than 1, notice that the Density becomes less opaque and you can see the red ball contained in the fluid.

In the next example, Density is set to Dynamic Grid and the Density values are less than 1. As you scale the Density values with a Density Scale value greater than 1, notice that the Density becomes more opaque and the red ball contained in the fluid becomes more and more obscured by it.
Buoyancy

Dynamic Grid only. Simulates a difference in mass density between the regions with Density values and the regions without. If the Buoyancy value is positive the Density represents a substance that is lighter than the surrounding medium, like bubbles in water, and will thus rise. Negative values cause the Density to fall.

Dissipation

Defines the rate at which the Density gradually vanishes in a grid. At each time step Density is removed from each voxel (the Density value becomes smaller). In the following example, the Dissipation value is set to 1.

Note

Dissipation in Fluid Effects is not the same as Lifespan with particles. Lifespan describes an on/off state (you are either alive or dead). Dissipation is a gradual fading out—it’s not absolute. The effective lifespan of Density in a grid is relative to the emission Density, motion within the grid, Diffusion, and the Transparency of the fluid.

Diffusion

Defines the rate at which Density spreads into adjacent voxels in a Dynamic Grid. In the following example, the Diffusion value is set to 2.
Velocity

Velocity Scale X, Y, Z

Scales the velocity relative to the fluid.

Multiplies the Velocity values within the fluid container by the Scale value. Scaling does not affect the direction.

Swirl

Defines the amount of swirliness in the Velocity solution. This attribute is useful for defining a swirl effect in fluid containers with low resolution.

Turbulence

Strength

Increase this value to increase the amount of force applied by the turbulence.

Frequency

Lowering Frequency makes the turbulence vortices larger. This is a spatial scale factor on the turbulence function and has no effect if the turbulence strength is zero.

Speed

Defines the rate at which the turbulence pattern changes over time.

Temperature

Temperature Scale

Multiplies the Temperature values defined in the container.

Buoyancy

Defines built-in buoyancy strength for Temperature solving.

Dissipation

Defines the rate at which the Temperature gradually dissipates in a grid. At each time step, Temperature is removed from each voxel (the Temperature value becomes smaller).
3 | Modifying fluids
Reference > fluidShape

Diffusion
Defines the rate at which the Temperature diffuses between voxels in a Dynamic Grid.

Turbulence
Multiplier on the turbulence applied to the Temperature.

Fuel
Fuel combined with Density defines a situation in which a reaction can take place. Density values represent the substance being reacted, and Fuel values describe the state of the reaction. Temperature can “ignite” Fuel to start a reaction (for example, an explosion effect). As the reaction progresses, the value of the fuel changes from unreacted (value 1) to fully reacted (value 0).

Fuel burns at temperatures greater than the Ignition Temperature.

Fuel Scale
Multiplies the Fuel values defined in the container.

Reaction Speed
Reaction Speed defines how quickly the reaction converts from a value of 1 to zero when the temperature is at or above the Max Temperature value. A value of 1.0 results in an instantaneous reaction.

Ignition Temperature
Ignition Temperature defines the lowest temperature at which a reaction will occur. The reaction rate is zero at this temperature, increasing to the value defined by the Reaction Speed at the Max Temperature.

Max Temperature
Max Temperature defines the temperature beyond which a reaction occurs at the fastest speed.

Heat Released
Heat Released defines how much heat is released into the Temperature grid by a total reaction. This is how many reactions sustain themselves after an initial spark of ignition. The amount of heat added in a given step is proportional to the percentage of reacted material. You need to have the Temperature Method set to Dynamic Grid to use this option.
Light Released

Light Released defines how much light is released by the reaction. This is directly added into the final incandescent intensity of the shading and does not input into any grids.

Light Color

Light Color defines the color of the light released by the reaction. The Light Released attribute along with the amount of Density reacted in a given time step scales the overall brightness of this light.

Color Grid

Color Dissipation

Defines the rate at which the Color dissipates in a grid.

Color Diffusion

Defines the rate at which Color diffuses into adjacent voxels in a Dynamic Grid.

Grids Cache

Select which grid caches to read when playing a dynamic simulation.

Read Density

If the cache contains a Density grid, read the Density values from the cache.

Read Velocity

If the cache contains a Velocity grid, read the Velocity values from the cache.

Read Temperature

If the cache contains a Temperature grid, read the Temperature values from the cache.

Read Fuel

If the cache contains a Fuel grid, read the Fuel values from the cache.

Read Color

If the cache contains a Color grid, read the Color values from the cache.

Read Texture Coordinates

If the cache contains texture coordinates, read them from the cache.
Surface

Select how you want the surface of the fluid to render.

Volume Render

Software render the fluid as a volumetric cloud.

Surface Render

Software render the fluid as a surface. The surface is formed by thresholding the Density values in the fluid container. Where the Density is greater than the “Surface Threshold” you are inside the medium, where it is less than this value you are outside the medium. (Surface Render combines blobby style surface rendering with normal soft volume style rendering.)

To see the surface in hardware display, “Shaded Display” must be set to As Render or the outMesh must have a connection. The surface location is determined by the current Opacity setting combined with the “Surface Threshold”.

- **Hard Surface**
  Turn Hard Surface on to make the transparency of the material constant inside the material (like glass or water). This transparency is determined solely by the “Transparency” attribute and the distance travelled through the substance.

- **Soft Surface**
  Turn Soft Surface on to evaluate the changing Density based on the Transparency and Opacity attributes. The shadows tend to be softer and thin areas appear fuzzy.

  For the light/normal shading Maya relaxes the angle of cutoff similar to the way Ambient Shade works in ambient lights.

  For thick clouds like nuclear bombs, using Soft Surface can result in faster render times for a self shadowed effect, and unlike the Hard Surface render, you can have soft fuzzy areas.

**Tip**

For a better rendered look, set “Render Interpolator” to Smooth in the Shading Quality section of the Attribute Editor.

Surface Threshold

Threshold value used to create the implicit surface.
Surface Tolerance

Determines how close points sampled for a surface lie to the exact “Surface Threshold” Density. The tolerance value is defined relative to the “Quality” setting. The Quality determines the uniform step size, so that the actual distance this defines is equal to the step size Surface Tolerance.

Make the Quality setting just high enough so that you do not miss regions containing the surface. The render then further refines the surface using this tolerance.

If the Surface Tolerance is high then the surface will look dotty and of poor quality. Very low values result in longer render times and better quality.

In practical terms, Surface Tolerance helps better define the surface normal, because the local gradient used for the normal can vary quite a bit if the samples are not all close to the surface.

If your surfaces look grainy try lowering this value a bit (this is more critical when your Density is not smooth but very sharply defined, like with a thresholded texture, however a better solution is to make your Density smoother). If the graininess is due to missing the surface (that is, little holes) rather than noisy normals, then increasing the Quality is better.

Specular Color

Controls the amount of light emitted from regions of Density due to self illumination.

Cosine Power

Control the size of the specular highlights (also called “hot spots”) on the surface. The minimum value is 2. The higher the value, the more tightly focussed (smaller) is the highlight.

Environment

The Environment ramp defines a simple sky to ground environmental reflection on a surface. The left of the ramp represents the top of the sky and the right represents the bottom.
You define the reflection colors between the top and bottom of the sky by adding position markers to the ramp and changing the color at the markers.

- To select a position on the ramp, click the dot indicating the marker. The selected marker has a white outline around the dot.
- To add a marker, click on the ramp.
- To move a marker, drag the marker dot left or right, or select the marker and type the destination position in the Selected Position box.
- To delete a marker, click the square x at the marker position.

**Selected Position**

This value indicates the position of the selected color on the ramp (between 0 on the left to 1 on the right).

**Selected Color**

Indicates the color on the ramp at the selected position. To change the color, click the Selected Color box and select a new color from Color Chooser.

**Interpolation**

Controls the way colors blend between positions on the ramp. The default setting is Linear.

- **None**
  - There is no interpolation between colors. Each color is distinct.
- **Linear**
  - The values are interpolated with a linear curve in RGB color space.
- **Smooth**
  - The values are interpolated along a bell curve so that each color on the ramp dominates the region around it, then blends quickly to the next color.
- **Spline**
  - The values are interpolated with a spline curve, taking the colors at neighboring position markers into account for a smoother transition.
Refractive Index

Index of refraction. This attribute affects how reflectivity changes with viewing angle. It makes use of Fresnel’s law. Materials with a low refractive index are generally only reflective at glancing angles. This is useful for a wet look or for water, because water has a lower refractive index than most solids. At a refractive index of 1.0 the material is considered to be the same as the medium, and theoretically there should be no specularity in this case (as with a cloud). However, for convenience, there is full specularity in this case (no view angle modulation).

Shading

Use the attributes in this section to apply built-in shading effects to the fluid.

Note

Mapping attributes in the Shading section

In most cases, it’s better to use the built-in texturing (in the “Textures” section), however normal texturing works and should have good results in the case of 2D fluids. For 3D fluids, the textures will map to the entry points of the volume samples. To make a solid texture better represented within the volume, you can increase the volume samples using Volume Samples Override in the Render Stats section of the Attribute Editor.

Transparency

Transparency combined with “Opacity” determines how much light can penetrate the defined Density. Transparency scales the single channel Opacity value. Using Transparency you can adjust the Opacity and also set its color.

You could adjust the Opacity of a fluid by moving the Transparency slider, ignoring all the other controls.
Glow Intensity

Controls the brightness of the glow (the faint halo of light around the fluid). Glow Intensity is 0 by default, so no glow is added to the fluid. As you increase the Glow Intensity, the apparent size of the glow effect increases.

Glow Intensity is different from the “Incandescence” attribute in two important ways:

- Glow is added as a post-process at the end of rendering. (Incandescence just makes the surface appear brighter.)
- Glow Intensity adds a halo. Incandescence does not.

Dropoff Shape

Defines a shape to use to define an outer boundary for creating a soft edged fluid.

![Dropoff Shapes]

Edge Dropoff

Defines the rate at which the Density values drop off towards the edges defined by the Dropoff Shape. A value of 0.0 results in no dropoff. As the value increases, the Density fades smoothly from the center to the edge of the dropoff shape.

Note

A transparency of 0.5 0.5 0.5 may render slightly faster than other values.
Color

The Color ramp defines a range of color values used to render the fluid. The particular colors selected from this range correspond with the values for the selected “Color Input”. Color Input values of 0 map to the color at the left of the ramp, Color Input values of 1 map to the color at the right of the ramp, and values between 0 and 1 map to the color corresponding with the position on the ramp (relative to the “Input Bias”). The color represents how much incoming light is absorbed or scattered. If it is black, all light is absorbed, while white fluids scatter all incoming light.

You define the colors on the ramp by adding position markers to the ramp and changing the color at the markers.

- To select a position on the ramp, click the dot indicating the marker. The selected marker has a white outline around the dot.
- To add a marker, click on the ramp.
- To move a marker, drag the marker dot left or right, or select the marker and type the destination position in the Selected Position box.
- To delete a marker, click the square x at the marker position.

For example, suppose the Color Input is Density, and the color ramp ranges from blue on the far left to green on the far right.

In a 2D container with Density values ranging from 0 to 1, the color of the Density would range from blue to green.
Selected Position

This value indicates the position of the selected color on the ramp (between 0 on the left to 1 on the right).

Selected Color

Indicates the color on the ramp at the selected position. To change the color, click the Selected Color box and select a new color from Color Chooser.

Interpolation

Controls the way colors blend between positions on the ramp. The default setting is Linear.

- **None**: There is no interpolation between colors. Each color is distinct.
- **Linear**: The values are interpolated with a linear curve in RGB color space.
- **Smooth**: The values are interpolated along a bell curve so that each color on the ramp dominates the region around it, then blends quickly to the next color.
- **Spline**: The values are interpolated with a spline curve, taking the colors at neighboring position markers into account for a smoother transition.

Color Input

Defines the attribute used to map the color value.

- **Constant**: Sets the color in the entire container to the color at the end of the ramp (1.0).
X, Y, Z, and Center Gradient

Sets the color in the entire container to a gradient corresponding with the ramp colors (from 1 to 0).

The other options all set the Color Input to the color corresponding with the value from the grid. For example if Density is the Color Input, the color at the start of the color ramp is used for Density values of 0 and the color at the end of the ramp for Density values of 1.0. Midrange values map according to the Input Bias.

Input Bias

Color Input Bias adjusts the sensitivity of the selected Color Input. Input values of 0 and 1 always map to the start and end of the ramp, while the bias determines where in the ramp a value of 0.5 maps. If the Input Bias is 0.0 then a Color Input value of 0.5 maps to the exact middle of the color ramp. Instead of values that are very close using the color at one part of the ramp, you can use the full range of colors to represent the values.

For example, if Density is the Color Input and the Density values in the container are all close to 0.1, you can use the Input Bias to shift the ramp color range so the Density values around 0.1 can be differentiated using the full range of colors on the ramp. If you do not change the Input Bias, the differences in color for values close to 0.1 could be indistinguishable.

Incandescence

Incandescence controls the amount and color of light emitted from regions of Density due to self illumination. The particular colors selected from this range correspond with the values for the selected “Incandescence Input”. Incandescent emission is not affected by illumination or shadowing.

The Incandescence ramp defines a range of incandescent color values. The particular colors selected from this range correspond with the values for the selected “Incandescence Input”. Incandescence Input values of 0 map to the color at the left of the ramp, Incandescence Input values of 1 map to
the color at the right of the ramp, and values between 0 and 1 map to the color corresponding with the position on the ramp (relative to the “Input Bias”).

You define the colors on the ramp by adding position markers to the ramp and changing the color at the markers.

- To select a position on the ramp, click the dot indicating the marker. The selected marker has a white outline around the dot.
- To add a marker, click on the ramp.
- To move a marker, drag the marker dot left or right, or select the marker and type the destination position in the Selected Position box.
- To delete a marker, click the square x at the marker position.

Selected Position

This value indicates the position of the selected color on the ramp (between 0 on the left to 1 on the right).

Selected Value

Indicates the color on the ramp at the selected position. To change the color, click the Selected Color box and select a new color from Color Chooser.

Interpolation

Controls the way colors blend between positions on the ramp. The default setting is Linear.

- **None**: There is no interpolation between colors. Each color is distinct.
- **Linear**: The values are interpolated with a linear curve in RGB color space.
- **Smooth**: The values are interpolated along a bell curve so that each color on the ramp dominates the region around it, then blends quickly to the next color.
- **Spline**: The values are interpolated with a spline curve, taking the colors at neighboring position markers into account for a smoother transition.
Incandescence Input

Defines the attribute used to map the incandescence color value.

Constant
Sets the incandescence color in the entire container to the color at the end of the ramp (1.0).

X, Y, Z, and Center Gradient
Sets the incandescence color in the entire container to a gradient corresponding with the ramp colors (from 1 to 0).

The other options all set the Incandescence Input to the color corresponding with the value from the grid. For example if Temperature is the Incandescence Input, the color at the start of the incandescence ramp is used for Temperature values of 0 and the color at the end of the ramp for Temperature values of 1.0. Midrange values map according to the Input Bias.

Input Bias

Incandescence Input Bias adjusts the sensitivity of the selected Incandescence Input. Input values of 0 and 1 always map to the start and end of the ramp, while the bias determines where in the ramp a value of 0.5 maps. If the Input Bias is 0.0 then an Incandescence Input value of 0.5 maps to the exact middle of the color ramp. Instead of values that are very close using the color at one part of the ramp, you can use the full range of colors to represent the values.

For example, if Temperature is the Temperature Input and the Temperature values in the container are all close to 0.1, you can use the Input Bias to shift the ramp color range so the Temperature values around 0.1 can be differentiated using the full range of colors on the ramp. If you do not change the Input Bias, the differences in color for values close to 0.1 could be indistinguishable.
Opacity

Opacity represents how much the fluid blocks light. The Opacity curve defines a range of opacity values used to render the fluid. The particular opacity values selected from this range are determined by the selected Opacity Input.

The vertical component represents the Opacity values from 0 (totally transparent) to 1 (totally opaque), the horizontal component represents Opacity Input values from 0 to 1. By clicking on the graph and dragging the points, you make a curve that defines what the opacity is for any input value. The default is a linear 1-1 relationship—input values (for example, Density) of 0 have no opacity, values of 0.5 have an opacity of 0.5, values of 1 have an opacity of 1.

To select a position on the curve, click the dot indicating the marker. The selected marker has a white outline around the dot.

To add a marker, click on the graph.

To move a marker, drag the marker dot left or right, up or down, or select the marker and type the destination position in the Selected Position box.

To delete a marker, click the square x at the marker position.

Density is the default Opacity Input, and the default linear curve makes the Opacity exactly equal to the Density. Given that you cannot get more opaque than 1.0, Densities greater than 1.0 are totally opaque. This simulates the total saturation of a fluid (that is, so much smoke you have a block of solid carbon).

To give Density hard edges, like the edges on thick clouds, you can edit the Opacity curve to threshold out the thin Density (low Density values) and define a hard falloff. If you are dealing with very thin Density, positioning the markers on the curve for the desired falloff might involve
the markers being very close together all the way to one edge of the curve. The “Input Bias” attribute allows you to define the general look of the function with an easy-to-read layout (that is, without crowding the values), and then affect the input range to map it to the desired part of the function.

Texturing is also applied to the inputs to opacity rather than the output. This allows you to use the Opacity curve to apply hard edges to the texture, rather than texturing a hard edged Density. The gain on the texture is simply how the texture affects opacity—small gain, small effect.

You could adjust the opacity of a fluid by moving the “Transparency” slider, ignoring all the other controls.

**Selected Position**

This value indicates the position of the selected Opacity Input marker on the ramp (between 0 on the left to 1 on the right).

**Selected Value**

Indicates the opacity value on the ramp at the selected position. To change the value, drag the marker dot up or down, or type the value in this box.

**Interpolation**

Controls the way values blend between position markers on the curve. The default setting is Linear.

- **None**
  - There is no interpolation between values.
- **Linear**
  - The values are interpolated with a linear curve.
- **Smooth**
  - The values are interpolated along a bell curve so that each value on the graph dominates the region around it, then blends quickly to the next value.
- **Spline**
  - The values are interpolated with a spline curve, taking the values at neighboring position markers into account for a smoother transition.

### Opacity Input

Defines the property used to map the opacity value.
3 | Modifying fluids
Reference > fluidShape

Constant
Sets the opacity in the entire container to the opacity at the far right of the curve (Opacity Input value 1).

X, Y, Z, and Center Gradient
Sets the opacity in the entire container to a gradient corresponding with the curve (from Opacity Input value 1 to 0).

The other options all set the Opacity Input value to the corresponding opacity value on the curve. For example if Density is the Opacity Input, the opacity value at the start of the curve is used for Density values of 0 and the opacity value at the end of the curve is used for Density values of 1.0. Midrange values map according to the “Input Bias”.

Input Bias
Opacity Input Bias adjusts the sensitivity of the selected Opacity Input used.

Input values of 0 and 1 always map to the start and end of the opacity curve, although the bias determines where in the curve a value of 0.5 maps. For example if you used Density as an input, and you want the fluid to become opaque at a Density of 0.001, then the Density bias can be used to shift most of the curve into this Density range. Instead of cramming several values at the beginning of the ramp you can use the full range. If the Input Bias is 0.0 then a value of 0.5 maps to the exact middle of the Opacity curve.

Matte Opacity
The attributes in this section control how this fluid shows up in the matte (alpha channel or mask) when you render with one. This is useful if you will be compositing your rendered images.

Matte Opacity Mode
Select how Maya uses the “Matte Opacity” value.

Black Hole
The Matte Opacity value is ignored, and all the matte for this fluid is set to be transparent. Use this option when you use substitute geometry in a scene to stand in for objects in a background image that you will be compositing with later. Your stand-in objects will ‘punch a hole’ in the matte. This allows other computer-generated geometry to pass behind your stand-in objects. Later, when foreground and background are composited, the results will be correct, with the background object showing through the ‘black hole’ areas.
Solid Matte  The entire matte for the fluid is set to the value of the “Matte Opacity” attribute. This option is like “Opacity Gain”, except that the normally-calculated matte values are ignored in favor of the Matte Opacity setting. If there are transparent areas on the object, the transparency in these areas is ignored in the matte. Use this setting to composite an object with transparent areas, when you don’t want the background to show through them.

Opacity Gain  Matte values are calculated based on the transparency of the object then multiplied by the Matte Opacity value. With Opacity Gain, you can animate the Matte Opacity value to change the overall transparency of the object when it is later composited.

Matte Opacity has a default value of one, so by default Solid Matte and Opacity Gain have no effect.

Matte Opacity  Matte Opacity is used with Matte Opacity Mode to affect how the matte (alpha channel or mask) for this fluid is calculated.

Shading Quality

Quality  (Not available on fluid texture.) Increase this value to increase the number of samples per ray used in the render, thereby increasing the shading quality of the render.

By mapping a texture to this attribute, you could define exactly which regions of a fluid got the highest shading quality (although the slowdown due to texturing might negate any benefits).

Contrast Tolerance  (Not available on fluid texture.) Defines the maximum contrast in the effective transparency of a volume span allowed by the Adaptive subdivisions sample method. When the contrast between two spans is greater than this value Maya subdivides the span. The contrast is defined as the effective difference in accumulated transparency from the viewpoint.

If this value is high, then the sampling will look like Uniform sampling. If the Contrast Tolerance is low then the quality improves and the render time increases, although you will not require as many samples as uniform sampling for a given render quality.
The “Quality” setting should be just high enough that you do not miss dense regions altogether (this creates artifacts like dotty fringes around clouds).

Sample Method
(Not available on fluid texture.) Controls how the fluid is sampled during rendering. Jitter avoids banding artifacts, but adds noise to the final image unless the Quality is set high.

Render Interpolator
Select the interpolation algorithm to use when retrieving values from fractional points within a fluid voxel when shading a ray. Sharply contrasting densities may show grid artifacts (like a mesh with no normal smoothing) with Linear interpolation. Smooth interpolation renders slower, but eliminates these problems.

Textures
Using the textures that are built into the fluidShape node you can increase the sampling time for high quality rendering. The sampling for the built-in textures is adaptive.

Texture Color
Turn this option on to apply the current texture (defined by “Texture Type”) to the “Color Input” value for the color ramp.

Texture Incandescence
Turn this option on to apply the current texture (defined by “Texture Type”) to the “Incandescence Input” values.

Texture Opacity
Turn this option on to apply the current texture (defined by “Texture Type”) to the “Opacity Input” values.

Texture Type
Select how to texture the Density in the container. The texture center is the center of the fluid.

- Perlin Noise: The standard 3D noise used in the solidFractal texture.
- Billow: Has a puffy, cloud-like effect. Billow is computationally intensive and therefore slow.
- Volume Wave: A sum of 3D waves in space.
- Wispy: A Perlin Noise that uses a second noise as a smear map. This makes the noise stretch out in places, creating a streaky, wispy effect.
Space Time

A 4-dimensional version of Perlin Noise, where time is the 4th dimension.

Coordinate Method

Select how to define the texture coordinates.

- **Fixed**: Sets the values to equal the object space coordinate system (0-1 for the container in X, Y and Z).
- **Grid**: Uses a grid of points and interpolates to define in between values. The coordinate values move using the Density solver. This makes the texture to move with the movement of the Density, rather than appearing fixed in space.

Coordinate Speed

Scales how fast coordinates are moved by Velocity when the “Coordinate Method” is Grid.

When Coordinate Speed is 1.0 the coordinates move through the volume at the same speed as the other properties (for example, Density). However this tends to result in the texture smearing out after a few steps.

Lower values tend to preserve the character of the texture and can look more natural.

Animating this value can be useful in some situations, such as when you do not want the texture to deform before a certain point (keyframe it to zero until the desired start point).

Color Tex Gain

Determines how much the texture affects the “Color Input” value. If the color range is red to blue, then texturing causes red to blue variations. When Color Tex Gain is zero there is no color texturing.
Incand Tex Gain

Determines how much the texture affects the “Incandescence Input” value. If the incandescence range is red to blue, then texturing causes red to blue variations. When Incand Tex Gain is zero there is no incandescence texturing.

Opacity Tex Gain

Determines how much the texture affects the “Opacity Input” value. For example, if the opacity curve goes from 0.0 to 0.6, then texturing causes variations between these values. When Opacity Tex Gain is zero there is no opacity texturing.

Threshold

The number added to the whole fractal, making it uniformly brighter. If some parts of the fractal are pushed up out of range (greater than 1.0), they are clipped to 1.0.

Amplitude

A scaling factor applied to all the values in the texture, centered around the texture’s average value. When you increase Amplitude, the light areas get lighter and the dark areas get darker.

If you set Amplitude to a value greater than 1.0, then those parts of the texture that scale out of range are clipped.

Ratio

Controls the frequency of the fractal noise. Increase this value to increase the fineness of detail in the fractal.

Frequency Ratio

Determines the relative spacial scale of the noise frequencies.

Depth Max

Controls how much calculation is done by the texture. Since the Fractal texture process produces a more detailed fractal, it takes longer to perform. By default, the texture chooses an appropriate level for the volume being rendered. Use Depth Max to control the maximum amount of calculation for the texture.

Invert Texture

Turn Invert Texture on to reverse the range of the texture so that dense regions become thin and thin become dense. If it is on, then

\[
texture = 1 - \text{texture.}
\]
Inflection

Turn Inflection on to apply a kink in the noise function. This is useful for creating puffy or bumpy effects.

Texture Time

Use this attribute to animate the texture. You can keyframe the Texture Time attribute to control the rate and amount of change of the texture.

Type the expression "= time" into the edit cell to cause the texture to billow when rendered in an animation. Type "= time * 2" to make it billow twice as fast.

Frequency

Determines the fundamental frequency for the noise. As this value increases the noise becomes more detailed. It has the inverse effect of the Texture Scale attribute.

Texture Scale

Determines the scale of the noise in the local X, Y and Z directions. The effect is similar to scaling the transform node for the texture.

When you increase Texture Scale in any direction, the fractal detail seems to smear out in that direction.

Texture Origin

The zero point for the noise. Changing this value moves the noise through space.

The origin is relative to the noise Frequency. So if the noise is really stretched out in Y (larger Y-scale) the same offset will move it more in Y than the other directions. An advantage to this is that the noise loops when you offset the origin by 1.0.

Implode

Warps the noise function in a concentric fashion about a point defined by the Implode Center. When the Implode value is zero there is no effect. When the value is 1.0 it is a spherical projection of the noise function, creating a starburst effect. Negative values can be used to skew the noise outward instead of inward.

Tip

Noise textures are too uniform for explosion and starburst animations. Adjust and keyframe this attribute for a starburst effect in an explosion. Adjust the Implode Center attribute to place the origin of the effect.
Implode Center X, Y, Z

Defines the center point about which the implode effect is defined.

Billow Density

Controls how many cells there are imbedded in the medium used by the “Billow” texture type. When Billow Density is 1.0, the medium is completely packed with cells. Reduce this value to make the cells more sparse.

Spottyness

Controls the randomization of the density of the individual cells used by the “Billow” texture type. When Spottyness is close to 0, all the cells have the same density. As you increase Spottyness, some cells become denser or thinner than others, in a random fashion.

Size Rand

Controls the randomization of the size of the individual blobs used by the “Billow” texture type. When Size Rand is close to 0, all the cells have the same size. As you increase Size Rand, some cells become smaller than others, in a random fashion.

Randomness

Controls how the cells for the Billow noise type are arranged relative to one another. Set Randomness to 1.0 to get a realistic random distribution of cells, as would be found in nature. If you set Randomness to 0, all the spots are laid out in a completely regular pattern. This can provide interesting effects when used as a bump map.

Falloff

Controls the way intensity falls off for individual blobs for the Billow noise type.

**Linear**
A uniform falloff from the center to a value of zero at the edges of the blobs.

**Smooth**
More natural looking, using a gaussian falloff.

**Fast**
Focuses the intensity more towards the center of the blobs.

**Bubble**
Uses a reverse falloff, fading to zero at the blob center.

Number of Waves

Determines how many waves to generate for the “Volume Wave” texture type. The larger this number the more random looking and slower the texture.
Color Balance
(Available for fluid textures only)
Corrects the color or intensity of a texture.

Default Color
If you map a texture to a material in such a way that it does not cover the entire surface, the file node's Default Color shows through. To select a different color, click the color bar to open the Color Chooser. To change the texture's coverage, use the placement options.

Alpha Gain
Only has an effect if the texture is used as a bump or displacement. Scaling factor applied to the texture's outAlpha channel. The default value is 1 (no effect).

Alpha Offset
Only has an effect if the texture is used as a bump or displacement. Offset factor applied to the texture's outAlpha channel. For example, if the Alpha Gain value is -1 and the Alpha Offset value is 1, the outAlpha channel is inverted. The default value is 0 (no effect).

Lighting
(Not available on fluid texture.)

Self Shadow
Turn this option on to compute self-shadowing. A single directional light at -1,-1,-1 is used to compute self-shadowing.

Hardware Shadow
Turn this option on to self-shadow the fluid (the fluid casts shadows on itself) during the simulation (hardware draw). Shading > Hardware Texturing must be turned on to see this effect.

Hardware Shadow off
Hardware Shadow on
Shadow Opacity

Use this attribute to brighten-up or darken shadows cast from the fluid.

When Shadow Opacity is 0.5, the shadows are attenuated in exact proportion to the transparency of the fluid.

When Shadow Opacity is zero, no shadowing occurs.

When Shadow Opacity is 1.0, shadows are completely black and the fluid is totally in shadow.

Values less than 0.5 can help make thick clouds appear more translucent.

Values greater than 0.5 make the clouds unnaturally opaque to lights, but may be useful to accentuate self shadowing.

Real Lights

Turn Real Lights on to use the lights in your scene.

Turn off Real Lights ignore the lights in the scene and instead use a single built-in directional light. The simple built-in lighting is faster, especially for self shadowing. It does not cast shadows or light onto other objects. Fluids using the built-in light do not receive shadows from other objects.

Directional Light

Set the X, Y, and Z components of the internal directional light used when Real Lights is off.

Render Stats

For details, see the Rendering guide.

Not available on fluid texture or shader.

Object Display

For details, see the Basics guide.

Node Behavior

For details, see Node Behavior in the Basics guide.

fluidEmitter

The emitter attributes in the Fluid Attributes section of the emitter Attribute Editor are described below.

For details on the standard emitter attributes, see the Dynamics guide.
Basic Emitter Attributes

Emitter Type

- **Omni**: Sets the emitter type to an omnidirectional point emitter. Fluid properties emit in all directions.
- **Surface**: Emits fluid properties from randomly distributed positions on or near a NURBS or polygonal surface. When you emit from an object, the emitter is a surface emitter. For information, see “Display fluid container contents” on page 37.
- **Curve**: Emits fluid properties from randomly distributed positions on or near a curve.
- **Volume**: Emits fluid properties from a closed volume. You pick the shape from the “Volume Shape” option.

| Note | If you select Volume, make sure the emitter is bigger than one voxel. |

Cycle Emission

Cycling emission restarts the random number stream after an interval in frames, specified by the “Cycle Interval” attribute.

Setting “Cycle Emission” to Frame and Cycle Interval to 1 causes the random stream to restart every frame. Cycle Interval values greater than 1 can be used to generate cycles for games work.

This only resets the random stream used by the emitter. It does not reset the random number stream used by MEL, shaders, and so on. Note also that the Frame option resets at most once per frame. However, oversampling does not affect the results.

Cycle Interval

Specifies the number of frames between restarts of the random number stream. See Cycle Emission. Has no effect if Cycle Emission is set to None.

Max Distance

Maximum distance at which new property values are created from emitter. Not used for volume emitters.

Min Distance

Minimum distance at which new property values are created from emitter. Not used for volume emitters.
Fluid Attributes

Density/Voxel/Sec
Sets the average rate at which Density values are emitted into the grid voxels per second. Negative values remove Density from the grid.

Heat/Voxel/Sec
Sets the average rate at which Temperature values are emitted into the grid voxels per second. Negative values remove heat from the grid.

Fluid/Voxel/Sec
Sets the average rate at which Fuel values are emitted into the grid voxels per second. Negative values remove Fuel from the grid.

Fluid Dropoff
Sets the dropoff value for fluid emission. For Volume emitters the dropoff specifies how much the emission drops off as you move away from the volume axis (dependent on the volume shape). For Omni, Surface, and Curve emitters the drop off is based on the emission point and radiates out from “Min Distance” to “Max Distance”.

Emit Fluid Color
Turn this option on to emit color into the fluid color grid. The grid must be dynamic.

Fluid Color
Click the color swatch and select the emitted fluid color from the Color Chooser. This color is used only when Emit Fluid Color is turned on.

Fluid Emission Turbulence

Turbulence Type
Select the type of turbulence to apply to fluid emission.

Gradient
Applies turbulence that ranges smoothly through space.

Random
Applies random turbulence.

Turbulence
The intensity of a force simulating a turbulent wind that evolves over time.
Turbulence Speed

The rate of change of the turbulence over time. The turbulence loops seamlessly every 1.0/Turbulence Speed seconds. To animate this rate attach a new time node to the time input and animate the time value on the time node.

Turbulence Freq

Controls how many repeats of the turbulence function fit inside the bounding volume of the emitter. Low values create a very smooth turbulence.

Turbulence Offset

Use this option to translate the turbulence within the volume. Animating it can simulate blowing turbulent wind.

Detail Turbulence

The relative intensity of a second higher frequency turbulence. This can be used to create fine features in large scale flows. Both the speed and the frequency on this second turbulence are higher than the primary turbulence. When the Detail Turbulence is non-zero the simulation may run a bit slower, due to the computation of a second turbulence.

Volume Emitter Attributes

Volume Shape

Indicates the shape of volume the emitter will use if the emitter is of volume type. Has an effect only if emitter type is Volume. Otherwise volume controls are disabled.

Volume Offset X, Y, Z

This is the parent attribute for the translational offset of the emission volume's center from the emitter's origin.

Volume Sweep

The arc of the volume emission. Used for sphere, cone, cylinder and torus.

Section Radius

Applies to torus volumes only. Defines the radius of a section of the torus.

Object Display

For details, see the Basics guide.
Extra Attributes

For details, see the Basics guide
4 Object interaction with dynamic fluids

About Fluids

Object interaction

You can make NURBS and polygonal objects interact with dynamic fluids to achieve the following effects:

- The object remains stationary and the fluid collides with it behaving appropriately (collision)
- "Make fluids collide with geometry” on page 103
- The object moves with the force of the fluid (rigid body)
- “Move geometry with the force of a fluid” on page 106
- "Move cloth with the force of a fluid” on page 106
- "Move particles with the force of a fluid” on page 107
- The object changes shape with the force of the fluid (soft body)
- "Modify geometry with the force of a fluid” on page 108

How do I? Simulate fluids

Make objects interact with dynamic fluids

Make fluids collide with geometry

You can make fluids collide rather than pass through polygonal or NURBS surfaces. Either the fluid or object, or both can be moving at the moment of collision. Fluids cannot collide with other fluids.
To collide fluids with geometry

1. Create a dynamic fluid.
   For details, see “Dynamic Grids” in Chapter 2.

2. Move the geometry you want the fluid to collide with inside the fluid container. The geometry must be inside the container to be affected by the fluid.

3. Select both the fluid container and the geometry (order doesn’t matter).

4. Select Fluid Effects > Make Collide > or click .
   The Make Collide Options window appears.

5. Change the Tessellation Factor if necessary and click Apply and Close.
   Maya internally converts NURBS objects to polygons before it animates the simulation. The Tessellation Factor sets the number of polygons created during the conversion. Lower numbers create coarser geometry and lessen animation accuracy (which means more fluid will appear to pass through the geometry), but increase the playback speed and processing time.

   The default Tessellation Factor is 200. Try doubling the value as many times as necessary to get the desired smoothness. (Select the geometry and click the geoConnector tab in the Attribute Editor.)

6. Play the simulation using the playback controls at the bottom of the Maya window.
Disable a collision effect
You can temporarily disable a collision effect to speed playback

To temporarily disable a collision effect
1 Select the fluid container.
2 In the Dynamic Simulation section of the fluidShape Attribute Editor, turn off Use Collisions.

To disable a collision effect
1 Select the fluid container.
2 Select Window > Relationship Editors > Dynamic Relationships to open the Dynamic Relationships Editor.
3 In the Selection Modes section, select Collisions.
   The left column highlights the colliding fluid object. The right column highlights the collision objects.
4 In the right column, click the highlighted collision object.
You can also in Hypergraph (Window > Hypergraph), delete the geoConnector nodes linked to the fluid and the collision object.
The item is no longer highlighted, which means it’s disconnected. For details on using the Dynamic Relationships Editor, see Dynamics.

Tips
- To minimize the jagged effect where the fluid contacts the object, Maya redistributes the fluid into adjacent voxels and at render time, softens the jagged edges. The redistribution of fluid can result in some fluid passing, or “seeping” through the object. The seeped fluid won’t be noticeable if you use closed, opaque collision objects. Setting the “Render Interpolator” attribute to linear should minimize the amount of seeped fluid at render time.

- Using NURBSs for collision geometry (especially with trims, or other construction history) will impact performance.

- If the mesh of your collision object has complicated concave faces, try triangulating larger faces to prevent interior areas from being filled in by the fluid. Perform a Delete Edge on all the edges, to remove small interior faces, then triangulate the it, and quadrangulated it, to give lighter geometry.

- To avoid a triangle appearance around the edges of the geometry, subdivide the faces that are causing the most problems.
Move geometry with the force of a fluid

You can move NURBS or polygonal geometry with the force of a fluid by making the geometry an active rigid body.

To move geometry with the force of a fluid

1. Create a dynamic fluid. For details, see “Dynamic Grids” in Chapter 2.
2. Move the geometry inside the fluid container. The geometry must be inside the container to be affected by the fluid.
3. Make the geometry an active rigid body (select the geometry and select Soft/Rigid Bodies > Create Active Rigid Body). For more information on creating rigid bodies, see Dynamics.
4. In the Attribute Editor for the rigidBody, under Performance Attributes, set the Apply Force At option to centerOfMass to ensure that the force of the fluid affects the rigid body as expected.
5. Select both the fluid container and the geometry (order doesn’t matter).
6. Select Fields > Affect Selected Object(s).
7. Play the simulation using the playback controls at the bottom of the Maya window.
8. Modify the effect, as required:
   - For details on rigidBody attributes, see Dynamics.
   - For details on modifying the fluid see “Modifying fluids” on page 55.

Move cloth with the force of a fluid

You can move cloth with the force of a fluid.
To move cloth with the force of a fluid

1. Create a dynamic fluid.
   For details, see “Dynamic Grids” in Chapter 2.
2. Move the cloth object inside the fluid container.
   The cloth object must be inside the container to be affected by the fluid. For details on creating cloth objects, see Cloth.
3. On the cloth object, select the vertices you want the fluid to affect.
4. With the vertices still selected, select the fluid container.
5. In the Cloth menu set, select Constraints > Field to apply the fluid as a field to the cloth.
6. Select the cloth object.
7. In the Cloth menu set, select Simulation > Properties > cpDefaultProperty.
8. In the Attribute Editor, click the cpDefaultProperty tab and modify the following settings:
   • Lower the U and V Bend Resistance values (for example to 2).
   • Lower the U and V Stretch Resistance values (for example, to 10).
9. In the Attribute Editor, click the cpSolver tab and change the Gravity to 0.
10. Delete the cloth cache (select Simulation > Delete Cache).
11. Play the simulation using the playback controls at the bottom of the Maya window.
12. Modify the effect, as required:
    For details on the cloth solver and default property attributes, see Cloth.
    For details on modifying the fluid see “Modifying fluids” on page 55.

Move particles with the force of a fluid

You can move particles with the force of a fluid.
4 | Object interaction with dynamic fluids
How do I? > Modify geometry with the force of a fluid

For an example of this technique, select Fluid Effects > Get Fluid Example and in the Techniques folder, look at WhirlyParticle.ma. For information on importing fluid examples, see “Fluid examples” on page 22.

To move particles with the force of a fluid

1. Create a dynamic fluid. For details, see “Dynamic Grids” in Chapter 2.
2. Move the particle shape inside the fluid container. The particles must be inside the container to be affected by the fluid. For details on creating particles, see Dynamics.
3. Select both the fluid and the particle shape.
4. Select Fields > Affect Selected Object(s).
5. Play the simulation using the playback controls at the bottom of the Maya window.
6. Modify the effect, as required:
   - For details on particle shape attributes, see Dynamics.
   - For details on modifying the fluid see “Modifying fluids” on page 55.

Modify geometry with the force of a fluid

By making your geometry a soft body, you can cause it to change shape with the force of a fluid.
To deform geometry with the force of a fluid

1. Create a dynamic fluid. For details, see “Dynamic Grids” in Chapter 2.
2. Move geometry inside the fluid container. The geometry must be inside the container to be affected by the fluid.
3. Make the geometry a soft body with goal weights (select the geometry and select Soft/Rigid Bodies > Create Soft Body).
4. Set goal weights for the soft body. For details on setting goal weights, see “Editing goal attributes” in Dynamics.
5. Select both the fluid and the geometry (order doesn’t matter).
6. Select Fields > Affect Selected Object(s).
7. Play the simulation using the playback controls at the bottom of the Maya window.
8. Modify the effect, as required:
   - For details on soft body attributes, see Dynamics.
   - For details on modifying the fluid, see “Modifying fluids” on page 55.

Motion fields

Work with motion fields

With Make Motion Field, you can accurately simulate objects moving through a fluid. This new field applies a force to its parent object, so that the object then appears to move or push the fluid.

| Note | Motion fields can only be used with 2D and 3D fluids. |

Create motion field

To create a motion field

1. Create a fluid container with an emitter.
2. Select the fluid, and then the object that you want to move the fluid.
3. Select Fluid Effects > Make Motion Field.
   - The Motion field appears, and is automatically parented to the object.

Workflow

1. Create a Motion field.
2 In the Volume Control Section of the Motion field’s attributes, select a Volume Shape that closely matches that of the object to which it is parented.

3 If necessary, transform the motion field to match the shape of its parent object.

4 Set the Push Intensity in the Motion field attributes.
   The Push Intensity slider is located in the Extra Attributes section under the motionField tab.

Reference Menus

Dynamics menu set

Fluid Effects >

Fluid Effects > Make Collide

Tessellation Factor

Maya internally converts NURBS objects to polygons before it animates the simulation. The Tessellation Factor sets the number of polygons created during the conversion. Lower numbers create coarser geometry and lessen animation accuracy (which means more fluid will appear to pass through the geometry), but increase the playback speed and processing time.

The default Tessellation Factor is 200. Try doubling the value as many times as necessary to get the desired smoothness. (Select the geometry and click the geoConnector tab in the Attribute Editor.)

Fluid Effects > Make Motion Field

Example

For the animation of a boat pulling a water-skier through a fluid, you can apply a motion field to the boat and the water-skies so that they appears to push through the water while they are in motion.
Nodes

Fluid Effects nodes

motionField

Fluid Motion fields have all the same attributes as regular Uniform Fields in Maya, with the exception of Push Intensity.

For more information, see Uniform Field Attributes in the Dynamics book.

Push Intensity

Sets the magnitude of the Motion field. The greater the Push Intensity, the greater the amount of fluid that is pushed or moved by the Motion field’s parent object.

| Note | The Push Intensity of a Motion field automatically increases and decreases according to the speed of its parent object. |
4 | Object interaction with dynamic fluids
Reference > motionField
About

Fluids playback
Maya calculates dynamic fluid simulations from frame to frame. The fluid property values in a container at each frame are derived from the values in the previous frame using fluid solvers. The speed of a fluid’s playback depends on the amount and magnitude of the fluid container’s contents (values) and the length (number of frames) of the fluid simulation. The greater the length and amount of contents for a fluid, the longer it takes for the fluid solver to calculate the fluid simulation.

You can speed-up your fluid’s playback by doing one of the following:
- Store the results of your fluids simulation in cache files
- Disable your fluids solver, collisions, emissions, fields, objects, or display options.

You can change the state of a fluid container’s contents at the first frame of its simulation by setting its initial state. An initial state is like a snapshot (similar to an animation pose) of the state of a fluid container’s contents at any point during its animation. When you set an initial state for a fluid, you are replacing the contents of its fluid container at the first frame of its simulation with the state of its contents at another frame in the fluid’s animation.

Related topics
- “Caching fluids” on page 114
- “Fluids initial state” on page 113

Fluids initial state
The state of a fluid is the collection of its grid property values (the values in the Density, Velocity, Temperature, Fuel, Color, and Texture Coordinate grids). The state of an uncached dynamic fluid at any frame other than the first is based on its state in the prior frame. Maya calculates dynamic fluid effects sequentially starting at the first frame.

The grid property values defined in a fluid container at the first frame of its simulation is the fluid’s initial state. You can play a simulation up to any frame, and then set the current state at that frame as the initial state for the fluid.

For example, if you had a fluid simulation that you wanted to begin with a fluid already present in the container; then you would add a fluid emitter to the container, play and stop the simulation at a frame with the
desired emitted fluid, and then set the emitted fluid values as the initial state. When you would then play the fluid simulation, the fluid’s animation would start with the grid property values that were stored in its initial state.

**Note** When you paint fluid property values into a grid, you must set the initial state of the fluid. Otherwise, when you play the simulation, the initial values you paint will be lost when you go back to the first frame. For information on painting fluid values, see “Paint fluid properties into grids” on page 30.

**Related topics**
- “Set the initial state of a fluid” on page 118
- “Fluid Effects > Set Initial State” on page 130

**Caching fluids**

You can speed-up the playback of your fluid effect by creating a fluids cache. A fluids cache file stores the resulting data from a solved fluid simulation. When you playback a cached fluid, Maya no longer has to take the time to solve the fluid simulation. Instead, Maya reads in the data contained in the specified fluids cache file and plays the fluid effect rather than re-calculating the fluid simulation. Caching your fluid effect has the following benefits:

- You can play the simulation more quickly and scrub back and forth through the fluid effect’s animation using the Time Slider
- You can re-use caches so that you do not have to solve at render time

Fluids cache files are disk files with the extension .mcfp that are stored in your project’s data directory. By default, when you open a scene file, Maya creates copies of a scene’s fluids cache files and places them in your system’s temporary file directory.

**Note** You can use the `diskCache -tmp` MEL command to determine the location of your temporary disk cache files.

These temporary files are used to store any changes to your fluids cache that occur between file saves (File > Save Scene) and are required for you to be able to edit your fluids cache.
You can use the Copy Cache File Locally attribute to turn off the creation of these local copies for any fluids playback cache file. This is useful if you are low on disk space or are using a network for distributed rendering. See “Copy Cache File Locally” on page 134 and “Control the creation of temporary fluids cache files” on page 127.

When creating your fluids cache, you can choose from the following cache file formats:

- “Single file fluids cache”
- “One File per Frame (OFpF) fluids cache”
- “Segmented fluids cache”

**Note**

- You cannot change the Cache File Format once a cache has been created. You must first delete the existing cache and recreate it using the desired format.
- Over and Under sampling are only available for caches created in the Single File format.

**Single file fluids cache**

Single file fluids caches are fluid cache files that contain all the simulation data for a single fluid. Single File is the default fluids cache format.

If the size of your fluid effect is greater than the limit set by your system (for example, 2 GB), then you can create the cache for your fluid using the One File per Frame or Segmented formats. See “One File per Frame (OFpF) fluids cache” on page 115 and “Segmented fluids cache” on page 117.

**One File per Frame (OFpF) fluids cache**

By default, Maya creates one cache file per fluid. However, some systems impose a limit on the maximum size a file can have. The size of a fluids cache file depends on the resolution of the fluid being cached and the properties (density, velocity, and so on) stored in the cache. Large fluid caches can sometimes exceed a system’s file size limit.

When you have a large fluid, you can decrease its playback time by saving its fluid cache in the One File per Frame (OFpF) format. The OFpF format creates one cache file for each frame specified in Cache Time Range. The One File per Frame option is located in the Create Cache Options window. See “Fluid Effects > Create Cache” on page 131.
Limitations

Single fluids cache files are first stored in the disk cache temp directory and are only copied over to your project’s disk cache data directory when you save your file. Since OFpF fluids cache files are created and stored directly in your project's disk cache data directory, you need to consider the following limitations:

- Your scene must first have a name before you can create an OFpF fluids cache. You can name your scene by selecting File > Save As or by using the file -rename MEL command.
- Since OFpF caches are written directly into the project data directory, Maya cannot always determine when it's safe (for example, whether or not a disk cache file in the project data directory may be referenced by an unopened scene) to delete the cache file from the disk. Therefore, it is up to you to remove any unneeded cache files from the data directory.
- Since OFpF caches always copy the cache file for the current frame to the temporary directory (MEL: diskCache -tmp) control over the creation of the temporary file copies is disabled for OFpF caches.

Tip

If a cache node is named cache_fluidShape1, the name of this intermediate file is available via the MEL command:

```
getAttr cache_fluidShape1.hiddenCacheName.
```

The location of this file is the diskCache -tmp directory.

Example

For a fluids cache for frames 1 to 5, One File per Frame creates 5 different fluids cache files. Each file is named according to the following naming scheme:

```
segmentPrefix%N_fluidShapeName__%F.mcfp
```

Where %N is the uniqueness identifier for segmentPrefix chosen by the system to guarantee unique file names among all diskCache nodes in the file scene and %F is the start frame for data in the cache file.

If the 5 frame cache in this example has been created for scene file joe.mb, the OFpF fluids cache files might be named:

```
joe.mb_fluidShape12_1.mcfp    (frames 1)
joe.mb_fluidShape12_2.mcfp    (frames 2)
joe.mb_fluidShape12_3.mcfp    (frames 3)
joe.mb_fluidShape12_4.mcfp    (frames 4)
joe.mb_fluidShape12_5.mcfp    (frames 5)
```
Segmented fluids cache

In addition to OFpF fluids caching, you can use the MEL command `doFluidsDiskCache` to segment your fluids cache. A segmented cache is a fluids cache that is broken-up into multiple segments or chunks, where each segment contains a specified number of frames. Segmented caches can be used to split a large cache into smaller, more manageable files.

Since One File per Frame (OFpF) caches are a special type of a segmented cache (with a segment size of one), any limitations listed in the OFpF section also apply to segmented caches. See “One File per Frame (OFpF) fluids cache” on page 115.

When you create any segmented cache for a fluid, the dynamic attribute `Segment Start Frame` is added to the `diskCache` node. This attribute connects to an expression node called `%N_currentSegment` (where `%N` is the segment naming prefix) which uses an animation curve to determine the appropriate segmentStartFrame value for the disk cache at the current time.

**Note** Segment Start Frame cannot be modified directly in the Attribute Editor.

Maya uses the segmentStartFrame value to generate the name of the segment file containing the cache data for the fluid at the current time. This cache file is then copied from the project’s data directory to the `diskCache -tmp` directory as needed.

The MEL procedure `doFluidsDiskCache` takes two arguments:

```mel
doFluidsDiskCache (int $version, string $args[])
```

where `$version` is 2 for Maya 6.0 and `$args` is a string array. The string array’s values are mapped as follows:

```mel
string   $cacheType = $args[0];
int      $rangeMode = $args[1];
int      $sampling = $args[2];
float    $diskCacheStartTime = $args[3];
float    $diskCacheEndTime   = $args[4];
int      $samplingRate      = $args[5];
int      $cacheDensity      = $args[6];
int      $cacheVelocity     = $args[7];
int      $cacheTemperature  = $args[8];
int      $cacheFuel         = $args[9];
int      $cacheColor        = $args[10];
int      $cacheDensity      = $args[11];
int      $doSegment         = $args[12];
string   $namingPrefix      = $args[13];
int      $segmentSize       = $args[14];
```
The last three elements of the $args array relate to segmented cache files:

- $doSegment must be 1 to create segmented of OFpF caches
- $namingPrefix is a user-specified string to identify the cache files and expression nodes created in this operation
- $segmentSize is used to specify how many frames are stored in each cache file segment.

Example

The following command creates a segmented fluid cache from frame 1 to frame 100, with a segment size of 30:

```
doFluidsDiskCache 2 { "mcfp", 3, 1, 1, 100, 1, 1, 1, 1, 1, 1, 1, 1, "joe.mb", 30 };
```

Since segmented fluids cache names depend on the name of the fluidShape being cached, the files created in your disk cache data directory might be named as follows:

- joe.mbl_fluidShape12_1.mcfp
- joe.mbl_fluidShape12_31.mcfp
- joe.mbl_fluidShape12_61.mcfp
- joe.mbl_fluidShape12_91.mcfp

At frame 10, the segmentStartFrame attribute of the diskCache node has a value of 1 because the first cache segment contains the cache information for frame 10, and segmentStartFrame has a value of 61 at frame 75 because the third cache segment contains cache information for frames 61 to 90. Note that the last file created only contains cache information for frames 91 to 100.

**How do I? ** Simulate fluids

**Set the initial state of a fluid**

**To set a fluid’s current dynamic grid property values as the initial state**

1. Add the property values to the fluid container.
   
   See “Add properties to fluid containers” on page 26.

2. Play and stop the simulation at the frame with the fluid property values you want to set (save) as the initial state, if necessary.

3. Select the fluid container.
How do I? > Delete the initial state of a fluid

See “Add properties to fluid containers” on page 26.

1. Play and stop the simulation at the frame with the fluid property values you want to set (save) as the initial state, if necessary.

2. Select the fluid container.

3. Select Fluid Effects > Set Initial State or click.

   Maya creates an initial state cache node and places a hidden initial state cache file in the Temp directory. When you save the scene, Maya copies the cache file to the project’s data directory.

   - The initial state cache file is named `filename_fluidShape.mcfi`.
   - The node is named `initialState_fluidShape`.

Delete the initial state of a fluid

To delete the initial state of a fluid

1. Select the fluid container.

2. Select Fluid Effects > Clear Initial State or click.

   Maya deletes the `initialState_fluidShape` node but does not delete the initial state cache file (in case it is being used by another scene). When you go to the start of the simulation, the contents of the container will be empty.

Save the current state of a fluid

You can save the grid property values for a fluid at any frame in a simulation and then add the saved state to another fluid container.

For example, you could create your company logo in a dynamic grid with Density values and save the current state to Visor. Any time you want to create a different fluid effect with your logo, you can add the values for the saved logo to a new container and modify the container attributes.

Grid properties saved in 2D containers can only be added to 2D containers. Similarly, grid properties defined in 3D containers can only be added to 3D containers.

To save the current state of a fluid to Visor

1. Add the property values to the fluid container. See “Add properties to fluid containers” on page 26.

2. Play and stop the simulation at the frame with the fluid property values you want to save, if necessary.

3. Select the fluid container.
4 Select Fluid Effects > Set Initial State.

Maya creates a hidden initial state cache node in the Temp directory. When you save the scene, Maya creates an initial state cache node and a disk cache file and stores the file in the project’s data directory.

- The initial state cache file is named `filename_fluidShape.mcfi`.
- The node is named `initialState_fluidShape`.

Delete the initial state of a fluid

**To delete the initial state of a fluid**

1 Select the fluid container.

2 Select Fluid Effects > Clear Initial State or click .

Maya deletes the `initialState_fluidShape` node but does not delete the initial state cache file (in case it is being used by another scene). When you go to the start of the simulation, the contents of the container will be empty.

Save the current state of a fluid

You can save the grid property values for a fluid at any frame in a simulation and then add the saved state to another fluid container.

For example, you could create your company logo in a dynamic grid with Density values and save the current state to Visor. Any time you want to create a different fluid effect with your logo, you can add the values for the saved logo to a new container and modify the container attributes.

Grid properties saved in 2D containers can only be added to 2D containers. Similarly, grid properties defined in 3D containers can only be added to 3D containers.

**To save the current state of a fluid to Visor**

1 Add the property values to the fluid container. See “Add properties to fluid containers” on page 26.

2 Play and stop the simulation at the frame with the fluid property values you want to save, if necessary.

3 Select the fluid container.

4 Select Fluid Effects > Save State As.

The Save window opens to:

(Windows)
5 | Playing fluids

How do I? > Save the current state of a fluid

drive:\Program Files\Alias\Maya6.0\presets\fluids\initialStates
(IRIX and Linux)
/usr/aw/maya6.0/presets/fluids/initialStates

5 Expand the folder where you want to save the fluid state in Visor and then select a subfolder:

- If the fluid is a 2D fluid, select the 2D folder.
- If the fluid is a 3D fluid, select the 3D folder.

---

**Note** You can save to any directory with write permissions accessible in Visor.

6 Type the name of the current state file in the File name box and click Save.

Maya does the following:

- Creates a cache file (.mfci extension) in the following location:
  (Windows)
  drive:\Program Files\Alias\Maya6.0\presets\fluids\.mayaData
  (IRIX and Linux)
  /usr/aw/maya6.0/presets/fluids/.mayaData

  (If, in step 5, you browsed to a location not under the Maya installation directory, Maya creates a .mayaData directory in that location and creates the cache there.)

- Creates a MEL file in the Visor location you selected. The MEL file simply packages the current state cache file so you can access it from Visor.

- Assigns the default Maya logo swatch to the current state icon in the Fluid Initial States tab in Visor.

You can now add this current state to any fluid container that has the same dimension (2D or 3D) as the container the current state was created from. For details, see "Add predefined initial states to fluid containers" on page 43.
To create a custom swatch in Visor for a saved current state

1. Render the example in Render View.
2. In Render View, select View > Grab Swatch to Hypershade/Visor.
3. Drag a square to select the part of the image you want as your swatch.
4. Open Visor and on the Fluid Initial States tab, open the folder where you saved the current state.
5. With the middle mouse button, drag the selection onto the current state swatch. The swatch is saved in the .mayaSwatches subfolder of the folder where you saved the state. For example:

   (Windows)
   drive:\Program Files\Alias\Maya6.0\presets\fluids\initialStates\Miscellaneous\2D\.mayaSwatches

   (IRIX and Linux)
   /usr/aw/maya6.0/presets/fluids/initialStates/Miscellaneous/2D/.mayaSwatches

Create fluids cache files

You can specify which fluid properties are saved in the cache file: Density, Velocity, Temperature, Fuel, and Color. You can only cache properties that use the Static or Dynamic grid method. You can also cache grid Texture Coordinates. This ensures that the texture renders appropriately if you use the playback cache to render.

To create a fluids cache

1. Select the fluid container.
2. Select Fluid Effects > Create Cache > .
   The “Fluid Effects > Create Cache” window appears.
How do I? > Create a One Frame per File fluids cache

Set creation options, if necessary, and then click the Create button.

Maya creates a fluids playback cache file for the selected fluid container. The file is in the current project’s data folder, and named `scenename_fluidShapen.mcfp`.

Usually you do not need to know the location of the files. However, if you move the scene to a different project, you must also move the fluids cache file to the corresponding data folder of that project so that the scene plays or renders using the cache.

---

**Note** When you save an existing scene with a new name, Maya makes a copy of the fluids cache files and renames them to correspond with the new scene name.

---

Create a One Frame per File fluids cache

**To create a OFpF fluids cache**

1. Save your scene.
2. Select the fluid for which you want to create a segmented cache.
3. If your fluid already has a cache, delete its current cache by selecting Fluid Effects > Delete Cache.
4. Select Fluid Effects > Create Cache > Create Cache.

The Create Cache Options window appears.

5. In the Cache File Format section, turn on One File per Frame.
6. Click Create or Apply to create a cache for each frame of your fluid. If you clicked Create, the Create Cache Options window closes. If you clicked Apply, the Create Cache Options window remains open.

---

**Warning** Be aware that caching a fluid effect—especially a large fluid—may tie-up your system for an extended period of time and this operation cannot be interrupted.

Maya creates one cache file for each frame of your fluid.

7. Save your Maya scene.
Append cache files

Append Cache adds the frames you specify to the existing cache. If the range of frames you specify occurs earlier than the last frame in the cache, the overlapping frames are overwritten.

**To append to a cache file**

1. Select the fluid container.
2. Select Fluid Effects > Append to Cache > 
   - The “Fluid Effects > Append to Cache” window appears. See “Fluid Effects > Append to Cache” on page 132
3. Set the append options and then click the Append button.
   - Maya appends the new cache information to the existing cache file for the fluid according to the options you set.

Delete and truncate cache files

You may want to delete or truncate your cache for one of the following reasons:

- If you modify a dynamic fluid simulation after caching, for example, by moving an emitter or changing the Swirl attribute value, you must disable or delete the cache so that the modifications appear when you play the fluid’s animation.
- You must re-create the cache before you render your fluid
- You can delete the cache to free up disk space

To delete a cache, you can use one of two methods:

- Delete Cache
  - Deletes the entire cache for the fluid.
- Truncate Cache
  - Deletes the cache from the current frame forward.

Be aware that if you disable the fluid solver (rather than the cache), you also disable playback of the cache and will not be able to create a cache for your fluid.

**To delete a cache**

1. Select the fluid container with the cache you want to delete.
2. Select Fluid Effects > Delete Cache or click 
   - Maya deletes the entire cache for the fluid.
To truncate a cache
1. Select the fluid container with the cache you want to truncate.
2. Move to the frame where you want to truncate the cache.
3. Select Fluid Effects > Truncate Cache or click .

Maya deletes the cache from the next frame forward. For example, if you truncate a 1-100 frame cache at frame 20, then frames 21-100 are deleted.

Load cache files
You can save different cache files for the same scene. For example, if you are experimenting with different property values, you can save the cache using one set of values, change the values, re-run the simulation, and save the cache under a new name. You can load a cache file that has already been created.

To load a cache file
1. Select the fluid container, and in the Attribute Editor, click the cache_fluidShape tab.
2. Click the folder button next to the Cache File Name box.
3. In the browser, select the .mfci or .mfcp cache file you want to load.
   Files with an .mfci extension are initial state caches.
   Files with an .mfcp extension are caches used for playback and rendering.
4. Click the Assign button. The cache file loads into the fluid container.

Note: Only values turned on in the “Grids Cache” section of the fluidShape Attribute Editor are read from the cache.

Replace the fluids cache at the current frame
To replace the fluids cache at the current frame
1. Make sure that your fluid has an OFpF cache.
   See “To create a OFpF fluids cache” on page 123.
2. Click-drag the current time indicator in the Time Slider to the frame you’d like to replace in the cache.
3. Modify the contents of the fluid. For example, you can use the Paint Fluids tool or the setFluidAttr MEL command.
5 | Playing fluids
How do I? > Speed up playback

4. Select Fluid Effects > Replace Cache Frame.
   The current contents of the fluid is saved into your fluids cache at the current time and replaces the previous cache contents.

Speed up playback
You can speed up playback by disabling the solver, disabling fluids collisions, emissions, and fields, disabling display options, and by caching your fluid.

Related topics
- “Disable the solver” on page 126
- “Disable fluids collisions, emissions, and fields” on page 126
- “Caching fluids” in Chapter 5

Disable the solver
The calculations that take place during solving slow down playback. To temporarily disable the fluid solver to speedup the playback of the rest of your animation, change the “Contents Method” of the fluid properties from Dynamic Grid to Off in the fluid container attribute editor. The contents of the grid are not lost when you do this.

Alternatively, turn on “Disable Evaluation” in the Dynamic Simulation section of the fluid container Attribute Editor.

Disable fluids collisions, emissions, and fields
To speed up playback, you can temporarily disable collision of fluids with attached geometry, ignore all connected emitters, or ignore all connected fields. In the “Dynamic Simulation” section of the fluid container attribute editor, turn off the Use Collisions, Use Emission, and Use Fields options, respectively.

Disable display options
Turning off the “Shaded Display” option or setting “Boundary Draw” to None in the Display section of the fluid container Attribute Editor can speed up playback.
Control the creation of temporary fluids cache files

To turn off the creation of local temporary fluids cache files

1. Save your scene.
   This copies over your temporary cache file to your project data directory.

2. Select the cached fluid in your scene and open the Attribute Editor.

3. In the cache_fluidShape tab, expand the Caching Node section.

4. Turn off Copy Cache File Locally.

5. Save your scene once again.

Now when you open your scene, Maya does not copy your fluids cache to the temporary directory, and when you save your scene, Maya does not copy your fluids cache from the temporary directory to the permanent location.

What went wrong?

Fluid Effects

Maya cannot read the fluids cache

The following sections apply to both playback and initial state fluids caches.

There is not enough space in your temp directory

Maya cannot read the cache for the current fluid because your default temp directory does not have enough space. You can either make space on the drive where your temp directory is located, or you can change the path of your temp directory by editing your TEMP environment variable definition.

The default temp directories are:

(Windows)  username\Local Settings\Temp
(Mac OS X)  /Users/username/Documents/temp
(IRIX and Linux)  /usr/tmp
5 | Playing fluids
What went wrong? > Maya cannot find the current fluids cache

Note If your temp directory is set to something other than the default, you can still locate your temporary disk cache files using the diskCache -tmp MEL command.

To make space in your temp directory
1 Browse to your temp directory.
2 Delete any nonessential files to free-up space on the disk where the directory is located.
3 Check that there is now enough space in your temp directory for your fluids cache.

To change the temp directory folder
1 Do one of the following:
   (Windows) Open the Control Panel and select System > Advanced > Environment Variables. Select TEMP from the list of user (not system) variables and click Edit. Enter a new system path for the TEMP environment variable and click OK.
   (Mac OS X) In the Maya.env file, type TEMP = path to define a new path for your temp directory. Save and close the Maya.env file.
   (IRIX and Linux) In a UNIX shell type: setenv TMPDIR path and press Enter. path is the new path for the temp folder.
2 If Maya is running, restart Maya.

To turn off the creation of temporary cache files
See “To turn off the creation of local temporary fluids cache files” on page 127.

The fluids cache is on a remote network drive that you are unable to access
Maya cannot read the current fluid’s cache because the cache is located on a remote network drive that does not have shared permissions. If this occurs, you need to make the file available again.

Maya cannot find the current fluids cache
When a Maya file and a fluids cache are copied to a new location, the path from the Maya file to its fluids cache may break. If this occurs, you need to re-establish the connection between the fluid and its cache.
What went wrong? > Maya is unable to create a playback cache for the current fluid

**To re-establish the link between a fluid and its cache data**

1. Open your Maya file, select the fluid whose cache cannot be found, and then open the Attribute Editor.
2. In the Attribute Editor, select the cache or initial state node.
3. Click the folder button next to the Cache File Name field to browse (locally or over the network) for the current fluid’s cache.
4. Select the cache and click Assign to re-establish the connection between the current fluid and its cache.

**To re-establish the link between a fluid and its segmented cache data**

Make sure that your segmented cache files are located in the folder specified in the *Disk Cache* field of your current project’s settings. To view or change the contents of your current project’s Disk Cache field, go to File > Project > Edit Current.

---

**Warning**  
The Disk Cache field specifies the destination for all your current project’s cache files. For example, fluids caches, jiggle caches, hair caches and so on.

---

Maya is unable to create a playback cache for the current fluid

There is not enough space on the specified disk

The temp folder that you have designated as the destination for your fluids playback cache is on a disk that does not have enough space for the cache data.

**To make more space on the disk**

- Delete any unnecessary or non-essential files from the temp folder’s disk to free-up space for the fluids playback cache.
- Change the destination of the fluids playback cache data. For example, you can specify a new temp folder on a different disk as the destination for the fluids playback cache.

**To turn off the creation of local temp fluids cache files**

See “Control the creation of temporary fluids cache files” on page 127.
When saving fluids caches on Windows or Linux systems, the resulting files are incomplete or contain blank frames.

The size of the cache file cannot exceed 2 gigabytes (GB). Cache files larger than 2GB will fail to write out completely. When saving a fluids cache file, Maya writes out up to the 2GB limit and then ignores the rest of the cache. You can work around this limitation by creating your fluids cache as segments (for example, 500MB mini caches). Each cache segment can then be rendered separately. To segment your fluids cache, see “One File per Frame (OFpF) fluids cache” on page 115 or “Segmented fluids cache” on page 117.

Reference Menus

Dynamics menu set

Fluid Effects >

Fluid Effects > Set Initial State

Fluid Effects > Set Initial State > □

With the Initial State Options window, you can set the contents of a fluid’s initial state. The contents checked on in the Set Initial State Options window are set in the initial state. By default, all initial state content options are on.

The initial state of a fluid is created from the dynamic or static grid contents. When setting the initial state, if a content method has dynamic or static grid attributes but is not checked in the Set Initial State Options window, a warning appears and you are prompted to either include the grid attributes or omit them from the cache.

Fluid Effects > Clear Initial State

Deletes the current fluid effects initial state and replaces it with .

Fluid Effects > Save State As

Lets you save out the current state of your fluid as a .ma, .mb, or .mov file.
Fluid Effects > Create Cache

Fluid Effects > Create Cache > □

Cache Time Range

Specifies which frames are cached. It is easiest to cache the entire frame range of the Time Line. However, you can create smaller cache files to conserve disk space by caching only the frames where fluids are solved.

- **Render Globals**: Caches the frame range specified in the Image File Output section of the Render Globals window. (Select Window > Rendering Editors > Render Globals.)
- **Time Slider**: Caches all frames of the Playback Start/End range.
- **Start/End**: Caches a frame range you specify in the Start Time and End Time boxes.
- **Start/End boxes**: Specifies the Start Time and End Time values for use with the Start/End Cache Time Range option.

Cache

Select which fluid properties to save with the cache. The properties are saved in the cache only if they are set to Dynamic Grid. For more information on these properties, see “Container contents” in Chapter 2.

Cache File Format

- **Single File One**: Creates a single cache file for the current fluid. See “Single file fluids cache” on page 115 and “Create fluids cache files” on page 122.
- **File per Frame**: Creates a single cache file for each frame of the current fluid. See “One File per Frame (OFpF) fluids cache” on page 115 and “Create a One Frame per File fluids cache” on page 123.

Sampling Method

Oversampling and undersampling specify how often Maya calculates the fluid simulation per frame.

- **Over**: A Rate value of 2 or larger increases the precision of the cached fluid but slows down the caching.
5 | Playing fluids
Reference > Fluid Effects > Append to Cache

Under
A Rate value of 2 or larger decreases the precision of the cached fluid, but quickens the caching operation. For example, if the Under Sampling Rate is 2, Maya calculates the simulation once every two frames. The resulting contents of the fluid between these two frames will be interpolated from the values stored in the cache.

Sampling Rate
Set an integer value for the Over Sampling or Under Sampling.

Fluid Effects > Append to Cache
Append Time Range
Specify the range of frames you want to append to the existing cache.
Current Time
Current Time to Time Slider End
Append to the cache the frames between the current time and the end of the time slider.
Time Slider
Append to the cache the frames between the Playback Start and End Times.
Start/End
Set the Start and End frames between which to append to the cache.
Start/End boxes
Specifies the Start Time and End Time values for use with the Start/End Append Time Range option.

Sampling
Oversampling and undersampling specify how often Maya calculates the fluid simulation per frame.
Over
A Rate value of 2 or larger increases the precision of the cached fluid, but slows down the caching.
Under
A Rate value of 2 or larger decreases the precision of the cached fluid, but quickens the caching operation. For example, if the Under Sampling Rate is 2, Maya calculates the simulation once every two frames.

Rate
Set an integer value for the Over Sampling or Under Sampling.
Fluid Effects > Replace Cache Frame

Replace cached data for the selected fluid with the contents of the fluid at the current time.

Only available for fluid caches created with the One Frame per File cache format. See “One File per Frame (OFpF) fluids cache” on page 115.

Fluid Effects > Truncate Cache

Deletes the frames of the fluids cache from the Time Slider’s current frame forward in time. For example, if your fluids cache lasts from frames 1-10 and your Time Slider is positioned at frame 5, then frames 6-10 of the fluids cache will be deleted when you select Fluid Effects > Truncate Cache.

Fluid Effects > Delete Cache

Deletes the current fluid’s cache file.

If you want to create a new fluids cache for your fluid effect, you must first delete its current cache file.

Also, dynamic fluids require a cache file to be able to display any changes to its contents during playback.

Nodes

Fluid Effects nodes

cache_fluidShape

Fluid Cache Attributes

Cache File Name

Lets you specify or browse (locally or over the network) for a cache file for the current fluid.

This field is read-only when the current fluid has a One File per Frame (OFpF) or Segmented cache.

Start Time

Displays the start time for the current fluids cache. This field is read-only.
End Time
Displays the end time for the current fluids cache. If your fluids cache is One File per Frame, the Start Time and End Times for your fluids cache are the same. This field is read-only.

Sampling Type
Oversampling and undersampling specify how often Maya calculates the fluid simulation per frame. These Fields are read-only.

Over See “Over” on page 131.
Under See “Under” on page 132.

Sampling Rate
An integer value for the Over Sampling or Under Sampling. This field is read-only.

Cache Contents at Current Time
Displays which of the fluids’ attributes have been included in the current disk cache file. These checkboxes are read-only.

Caching Node
Disk Cache
Displays the name of the current fluid disk cache file. This field is read-only.

Copy Cache File Locally
Lets you turn on or off the creation of the local copies for any fluids playback cache file. This is useful if you are low on disk space or are using a network for distributed rendering.

Warning When the Copy Cache File Locally attribute is off, you cannot append or truncate your fluids cache.

Node Behavior
See “Node behavior” in Chapter 6 of the Basics guide.

Extra Attributes
For details, see the Basics guide.
Open water effects

With Fluid Effects you can easily create realistic water surfaces—from stormy oceans with foam to swimming pools. You can achieve these open water effects using ocean or pond fluids.

Oceans

An ocean is defined by a flat surface with an ocean shader assigned to it. Fluid Effects simplifies the process of creating an ocean by providing a single command that creates a plane that is optimized for best results and an ocean shader, with appropriate connections.

The ocean plane is a NURBS plane with more detail concentrated in the center so you can have the ocean extend to the horizon, but see a reasonable resolution locally.
Since interactive shading would slow down playback, the shading is turned off for the surface. You need a preview plane to see displacement and shading in hardware display.

Related topics
- “Create new oceans” in Chapter 6
- “Fluid Effects > Ocean > Create Ocean” in Chapter 6

Ponds
Ponds are 2D fluids that use a spring mesh solver and a height field. With the pond options and attributes, you can set the size and color of your fluid surface.

You can generate waves, bubbles, and ripples in the fluid surface using Wakes. See “Create wakes” on page 147. Increasing the size of your pond extends the range of your waves and ripples.

The Pond menu items function in almost the same manner as the Ocean menu items. For information on Pond menu items and attributes, search the online help for Ocean menu items and attributes.

Related topics
- “Create Ponds” in Chapter 6
- “Fluid Effects > Pond > Create Pond” in Chapter 6
Wakes

With Wakes you can create boat wakes, add additional turbulence to an ocean, or generate bubbling and ripples.

A Wake is a fluid container with a Spring Mesh solver. Wake fluids do not use the Navier Stokes solver like regular fluids, but use the new Spring Mesh solver. A fluid emitter is used to drive the motion of the Wake fluid.

Note

You can use Wakes with only Ponds or Oceans.

Ocean Wakes differ from Pond Wakes. For Oceans, a Wake is a fluid texture with a Spring Mesh solver that adds additional displacement and/or foam to the Ocean shader. For Ponds, a Wake is a 2D fluid with a Spring Mesh solver that is rendered directly as a fluid.

Related topics

- “Create an Ocean wake” in Chapter 6
- “Create Pond wakes” in Chapter 6
- “Fluid Effects > Ocean > Create Wake” in Chapter 6
- “Fluid Effects > Pond > Create Wake” in Chapter 6

Floating objects

You can float objects in your Oceans and Ponds using fluid locators. You can add these locators to objects individually, or you can use commands in the Ocean or Pond menus to quickly create a buoy, float an object, or make a boat.

When an object is parented to one of these locators, the object responds appropriately to the motion of the waves. Fluid locators are connected to the displacement channel of fluid waves and are controlled by predefined expressions. These expressions define the attributes that control the movement of the target object.

You can connect the following types of locators to objects:

- Ocean Surface locators that follow the motion of the ocean in the Y direction only.
- Dynamic locators that follow the motion of the ocean in the Y direction and also react to dynamic attributes such as buoyancy, gravity, and damping.
- Boat locators that behave like dynamic locators and also rotate in X and Z.
Motor boat locators that behave like boat locators and also include throttle, rudder, and roll attributes to realistically reproduce the motion of a motor boat.

**Note** The water line does not respect the external shape of floating objects, so the water line might be visible where the internal shape is below the water line. For example, if the object is an open row boat, the boat may look like it’s flooding. In these situations, render your object and ocean separately and composite or use render layers.

**Related topics**
- “Add locators” in Chapter 6
- “Add a buoy to an ocean” in Chapter 6
- “Make objects float” in Chapter 6
- “Make boats float” in Chapter 6
- “Fluid Effects > Ocean > Add Dynamic Locator” in Chapter 6
- “Fluid Effects > Ocean > Add Boat Locator” in Chapter 6
- “Fluid Effects > Ocean > Float Selected Objects” in Chapter 6
- “Fluid Effects > Ocean > Make Boats” in Chapter 6
- “Fluid Effects > Ocean > Make Motor Boats” in Chapter 6

**How do I? Simulate fluids**

**Create ocean effects**

Create ocean effects using example oceans

Fluid Effects comes with ocean example files that include all the components and settings for complete ocean effects. You can quickly import them into your scene, play, and render them without alteration.

Modify these files to customize the effects, use them as learning tools to understand how to create your own effects, or use them simply for ideas.

**To create an ocean effect using an example file:**

1. In the Dynamics menu set, select Fluid Effects > Get Ocean/Pond Example.
The Visor opens to the Ocean Examples tab.

2 With the middle mouse button, drag the icon representing the example you want to use onto your scene.

Maya imports all the objects making up the effect into your scene (the lights, geometry, ocean shader, cameras, etc.).

3 Modify any objects or attributes to customize the effect.

The Notes section at the bottom of the Attribute Editor provides information about the ocean effect, pointing out the key aspects of its construction.

For information on modifying ocean shader attributes, see “Fluid Effects nodes” on page 152.

For information on modifying fluid attributes, see “Modify fluid attributes” on page 60.

Create new oceans

Use the Create Ocean command to quickly create an ocean. Maya creates a customized NURBS plane to represent the ocean surface and assigns an ocean shader to it.

To create an ocean effect

1 In the Dynamics menu set, select Fluid Effects > Ocean > Create Ocean > □. The Fluid Effects > Ocean > Create Ocean window appears.

2 Select the desired options and click Create Ocean. Maya does the following:
   • Creates a surface that has been optimized to create an efficient, realistic ocean effect.
   • Attaches an ocean shader to the plane.

3 For best resolution, translate the plane so that the center is just in front of the view.

4 Scale the surface as small as is acceptable, based on the horizon.

5 Modify ocean shader settings to achieve the desired affect. For details, see “Fluid Effects nodes” on page 152.

Preview a patch of ocean

You can see the displacement of the waves without rendering by adding a preview plane to the ocean shader. The preview plane does not appear in renders, but provides interactive feedback as you work in your scene.

Translate and scale it to preview different parts of the ocean.
The preview plane is actually a height field—a plane with the Displacement mapped to the wave height of the Ocean shader. For information on height fields, see the Maya Rendering Guide.

Note
If you create an Ocean preview plane from the Ocean menu, the Y scale is already locked, and you get the desired scaling behavior. If you create a height field utility node directly, and connect it to the ocean shader, the y scale is not locked, and scaling in Y will cause incorrect displacement.
For more information on the height field node, see Help > Node and Attribute Reference.

To add a preview patch of ocean

1 Select the ocean plane.
2 Select Fluid Effects > Ocean > Add Preview Plane. Maya creates a preview plane called oceanPreviewPlane.
3 In the Attribute Editor, modify “oceanPreviewPlane”, if necessary.
4 Translate or scale the plane to preview different parts of the ocean.

Convert wave displacement to polygons

You can create geometry that represents the wave height by converting the displacement to polygons.
6 | Open water effects
How do I? > Add locators

To convert wave displacement to polygons

1. Select the ocean surface.
2. Select Modify > Convert > Displacement to Polygons. Maya creates a poly plane (oceanplanename_displacement) with the displacement represented by the geometry.

Add locators

You can add locators to points on the ocean and use them as constraints or connect them to other attributes. For example, you can add individual locators and constrain them to the oars of a boat so they are affected by the motion of the water independently of the boat.

Ocean Surface locator

Ocean surface locators follow the motion of the ocean in the Y direction only.

To add an ocean surface locator

- Select Fluid Effects > Ocean > Add Ocean Surface Locator.

Dynamic locator

Dynamic locators follow the motion of the ocean in the Y direction, but additionally react appropriately to dynamic attributes (in the Extra Attributes section of the Attribute Editor).

To add a dynamic locator

- Select Fluid Effects > Ocean > Add Dynamic Locator > □.
  The Create Dynamic Locator window appears.
  If you want to move the position of the locator interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

Add a buoy to an ocean

With a single command, you can add a NURBS sphere (a buoy) to your ocean and make it bob up and down in the water. The motion is restricted to the Y direction.

Note
This procedure works for any geometry with displacement mapping.
To add a dynamic buoy

1. If the scene has more than one ocean, select the ocean you want the buoy to float in.

2. Select Fluid Effects > Ocean > Add Dynamic Buoy > .
   The Create Dynamic Locator window appears.
   By default, locators are connected directly to the expression, enabling you to rename locators without breaking the expression.
   If you want to move the position of the locator interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

3. Click Create Dynamic Buoy. Maya creates a NURBS sphere and connects a dynamic locator to it.

4. In the Extra Attributes section of the locatorShape Attribute Editor, modify the options to simulate dynamic effects (see “Dynamic locator”). These serve as inputs to the expression.

5. Play the animation using the playback controls at the bottom of the Maya window.

Make objects float

You can make an object float by adding a dynamic locator to it. Dynamic locators follow the motion of the ocean in the Y direction and also react to dynamic attributes such as buoyancy, gravity, and damping.

To make objects float

1. Select the objects you want to float, and if the scene has more than one ocean, select the ocean you want the object(s) to float in.

2. Select Fluid Effects > Ocean > Float Selected Objects > .
   The Float Selected Objects window appears.
   By default, locators are connected directly to the expression, enabling you to rename locators without breaking the expression.
Make boats float

You can make an object float like a boat by adding a boat locator to it. Standard boat locators behave like dynamic locators, but also rotate in X and Z. Motor boat locators include throttle, rudder and roll attributes to realistically simulate the motion of a motor boat.

For an example of a boat in an ocean, select Fluid Effects > Get Ocean/Pond Example and on the Ocean Examples tab, look at boatSky.ma. For information on importing ocean examples, see “Create ocean effects using example oceans” on page 138.

For an example of interactively playing a motor boat simulation, see “Create an Interactive boat simulation” on page 145.

To make a boat

1 Select the object you want to make a boat, and if the scene has more than one ocean, select the ocean you want the boat to float in.

2 Select Fluid Effects > Ocean > Make Boats > □.

The Make Boats window appears.

By default, locators are connected directly to the expression, enabling you to rename locators without breaking the expression.
If you want to move the position of the locator interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

3 Click Make Boats.
Maya connects the object to a boat locator that has predefined expressions connected to it.

4 In the Extra Attributes section of the locatorShape Attribute Editor, modify the options to simulate buoyancy effects (see “Dynamic locator” and “Boat locator”). These serve as inputs to the expression.

5 Play the animation using the playback controls at the bottom of the Maya window.

To make a motor boat

1 Select the object you want to make a boat, and if the scene has more than one ocean, select the ocean you want the boat to float in.

2 Select Fluid Effects > Ocean > Make Motor Boats > ❯. The Make MotorBoats window appears.

By default, locators are connected directly to the expression, enabling you to rename locators without breaking the expression.

If you want to move the position of the locator interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

3 Click Make Boats.
Maya connects the object to a boat locator that has predefined expressions connected to it.

4 In the Extra Attributes section of the locatorShape Attribute Editor, modify the options to simulate buoyancy effects (see “Dynamic locator” and “Boat locator”). These serve as inputs to the expression.

5 Play the animation using the playback controls at the bottom of the Maya window.

Boat locator

Boat locators follow the motion of the ocean in the Y direction, but additionally rotate in X and Z to allow the boat to pitch and roll in the waves.

To add a boat locator

- Select Fluid Effects > Ocean > Add Boat Locator > ❯. The Create Boat Locator window appears.
If you want to move the position of the locator interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

**Create an Interactive boat simulation**

You can create an interactive motor boat simulation by combining an ocean, a motor boat, and some hotkeys to drive the boat.

2. Turn on Attach to Camera and Create Preview Plane, and then click Create Ocean.
3. Select the boat geometry.
4. Select Fluid Effects > Ocean > Make Motor Boats. Maya attaches a locator to the boat with built-in expressions to simulate buoyancy effects.
5. Select the perspective camera (persp) and select Edit > Group. This creates a group and puts the perspective camera in it.
6. In Connection Editor (Window > General Editors > Connection Editor), do the following:
   - Connect the boat locator (created in step #4) Translate x and Translate z attributes to the transform (ocean height field) Translate x and Translate z attributes respectively.
   - Connect the locator Translate x and Translate z attributes to the camera group (created in step #5) Translate x and Translate y attributes.
   This connects the movement of the boat along the ocean plane to the ocean and to the movement of the camera.
7. Select the boat locator and in the Attribute Editor open the Extra Attributes section.
8. Switch to shaded mode.
9. Playback the scene and adjust the throttle and rudder settings.

To speed up the simulation, you can make the Wave Turbulence zero on the ocean shader and instead increase Num Frequencies. Increasing the Wave Height also makes the simulation more dramatic.

**Hotkeys**

Create hotkeys for the following commands and use them to drive the boat.
Stop Boat Key
setAttr locator1.throttle 0
setAttr locator1.rudder 0

Increase Throttle
float $t = `getAttr locator1.throttle`;
setAttr locator1.throttle ($t + 0.5);

Decrease Throttle
float $t = `getAttr locator1.throttle`;
$t -= 0.5;
if( $t < 0 ) $t = 0.0;
setAttr locator1.throttle $t;

rudder Left
float $t = `getAttr locator1.rudder`;
$t += 2.0;
if( $t > 20 ) $t = 20;
setAttr locator1.rudder $t;

rudder Right
float $t = `getAttr locator1.rudder`;
$t -= 2.0;
if( $t < -20 ) $t = -20;
setAttr locator1.rudder $t;

Create ponds

Create Ponds

To create a Pond fluid

1 Select Fluid Effects > Pond > Create Pond > □.
   The Create Pond window appears.
2 Set the Pond options. See “Fluid Effects > Pond > Create Pond” on page 151.
3 Do one of the following:
   • Click Create Pond to insert a pond fluid container with the defined size into your scene.
      The Create Ponds window closes.
   • Click Apply to insert a pond fluid container with the defined size into your scene.
      The Create Ponds window remains open.
   • Click Close to disregard any change to the pond size and close the Create Pond menu.
Create wakes

Create Pond wakes

To place a Wake fluid in a Pond
1 Create a Pond fluid by selecting Fluid Effects > Pond > Create Pond. A pond appears in your scene view.
2 Select the Pond or an object you want to link to the Wake fluid.
3 Create a wake by selecting Fluid Effects > Pond > Create Wake. The Create Wake options window appears.
4 Set the wake options. See “Fluid Effects > Pond > Create Wake” on page 151.
5 Do one of the following:
   • Click Create Wake to place a Wake fluid emitter in the current pond, or to place the Wake fluid emitter in your scene and parent it to a selected object.
   The Create Wake options window closes.
   • Click Apply to place a Wake fluid emitter in the current pond, or to place the Wake fluid emitter in your scene and parent it to a selected object.
   The Create Wake options window remains open.
   • Click Close to disregard any changes made to the Create Wake options, and close the Create Wake options window.
6 Set the Wake attributes.

For more information, search the online help for Fluid Emitter attributes.

Create an Ocean wake

To place a Wake fluid in an Ocean
1 Create an Ocean by selecting Fluid Effects > Ocean > Create Ocean. An Ocean appears in your scene view.
2 Create a wake by selecting Fluid Effects > Ocean > Create Wake. The Create Ocean Wake options window appears.
3 Set the wake options. See “Fluid Effects > Ocean > Create Wake” on page 150.
4 Do one of the following:
   • Click Create Ocean Wake to place a Wake fluid container in the current Ocean.
The Create Ocean Wake options window closes.

- Click Apply to place a Wake fluid container in the current Ocean. The Create Ocean Wake options window remains open.
- Click Close to disregard any changes made to the Create Ocean Wake options, and close the Create Ocean Wake options window.

5  Set the Wake attributes.

For more information, search the online help for Fluid Emitter attributes.

---

Reference Menus

Dynamics menu set

Fluid Effects >

Ocean >

Fluid Effects > Ocean > Create Ocean

Creates an ocean.

Fluid Effects > Ocean > Create Ocean > □

Sets the options for creating an ocean. They are listed below.

Attach to Camera

Turn this option on to attach the ocean to the camera. Attaching the ocean automatically scales and translates the ocean based on the camera, thus maintaining an optimum amount of detail for the given point of view.

Create Preview Plane

Turn this option on to create a preview plane that shows a shaded patch of the ocean with displacement in shaded display mode. You can scale and translate it to preview different parts of the ocean. This plane is for preview only and will not render.

If you do not create this plane at the time you create the ocean, you can create the plane later by selecting the ocean plane and then selecting Fluid Effects > Ocean > Add Preview Plane.
Preview Plane Size

Set how much you want to scale the preview plane in X and Z. The default is 10. Increase the size to see more detail, lower it for faster playback.

Fluid Effects > Ocean > Add Dynamic Locator

Dynamic locators follow the motion of the ocean in the Y direction, but additionally react appropriately to dynamic attributes (in the Extra Attributes section of the Attribute Editor).

Fluid Effects > Ocean > Add Dynamic Locator > □
If you want to move the position of the locator interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

Fluid Effects > Ocean > Add Boat Locator

Boat locators follow the motion of the ocean in the Y direction, but additionally rotate in X and Z to allow the boat to pitch and roll in the waves.

Fluid Effects > Ocean > Add Boat Locator > □
If you want to move the position of the locator interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

Fluid Effects > Ocean > Add Dynamic Buoy

With a single command, you can add a NURBS sphere (a buoy) to your ocean and make it bob up and down in the water. The motion is restricted to the Y direction.

Fluid Effects > Ocean > Add Dynamic Buoy > □
If you want to move the position of the buoy interactively, the buoy cannot be connected directly to the expression. In this case, turn on Free Transform.

Fluid Effects > Ocean > Float Selected Objects

You can make an object float by adding a dynamic locator to it. Dynamic locators follow the motion of the ocean in the Y direction and also react to dynamic attributes such as buoyancy, gravity, and damping.
Fluid Effects > Ocean > Float Selected Objects > □

If you want to move the position of the object interactively, the object cannot be connected directly to the expression. In this case, turn on Free Transform.

Fluid Effects > Ocean > Make Boats

You can make an object float like a boat by adding a boat locator to it. Standard boat locators behave like dynamic locators, but also rotate in X and Z.

Fluid Effects > Ocean > Make Boats > □

If you want to move the position of the boat interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

Fluid Effects > Ocean > Make Motor Boats

You can make an object float like a boat by adding a boat locator to it. Standard boat locators behave like dynamic locators, but also rotate in X and Z. Motor boat locators include throttle, rudder and roll attributes to realistically simulate the motion of a motor boat.

Fluid Effects > Ocean > Make Motor Boats > □

If you want to move the position of the boat interactively, the locator cannot be connected directly to the expression. In this case, turn on Free Transform.

Fluid Effects > Ocean > Create Wake

Fluid Effects > Ocean > Create Wake > □

Wake Size

For Oceans, Wake Size sets the size attribute (located in the fluid shape container properties) of the Wake fluid. For Ponds, the size of the Wake fluid is determined by the size attribute of the Pond fluid container.

Wake Intensity

This value determines the magnitude of the wakes. In the fluid emitter attributes, this value is Density/Voxel/Second. The default intensity is 5.00.
6 | Open water effects
Reference > Fluid Effects > Pond > Create Pond

## Foam Creation

This value determines the amount of foam generated by the fluid emitter. In the fluid emitter attributes, this value is the Heat/Voxel/Second. For Oceans, this value directly affects the foam. For Ponds, this value corresponds with the temperature input on the shading ramp attributes. The default amount of foam is 0.00.

### Note

A negative Wake Intensity value pushes the fluid surface down while a positive value pushes the surface up.

### Pond

Fluid Effects > Pond > Create Pond

#### Fluid Effects > Pond > Create Pond > □

**Size**

Defines the size of your Pond fluid. The size of the Pond can be modified by using the container properties of the Pond fluid shape. The default size is 20.000.

### Fluid Effects > Pond > Create Wake

Fluid Effects > Pond > Create Wake > □

#### Wake Size

For Oceans, Wake Size sets the size attribute (located in the fluid shape container properties) of the Wake fluid. For Ponds, the size of the Wake fluid is determined by the size attribute of the Pond fluid container.

#### Wake Intensity

This value determines the magnitude of the wakes. In the fluid emitter attributes, this value is Density/Voxel/Second. The default intensity is 5.00.

### Note

A negative Wake Intensity value pushes the fluid surface down while a positive value pushes the surface up.

Fluid Effects

151
Foam Creation

This value determines the amount of foam generated by the fluid emitter. In the fluid emitter attributes, this value is the Heat/Voxel/Second. For Oceans, this value directly affects the foam. For Ponds, this value corresponds with the temperature input on the shading ramp attributes. The default amount of foam is 0.00.

Nodes

Fluid Effects nodes

oceanPreviewPlane

The oceanPreviewPlane is a height field with the following attributes.

Resolution

Defines the number of samples relative to the largest side of the plane. Increase the resolution to see more detail on the surface. Lower the resolution for faster playback speed.

Color

Defines the color of the preview plane surface. You can map the color to a surface texture or an Ocean shader. The mapping always uses the outColor from the connected node, regardless of the actual attribute connected.

Displacement

Sets the height of the plane. Displacement is mapped to the Ocean shader. The mapping always uses the outAlpha from the connected node, regardless of the actual attribute connected. This does an optimized evaluation of the texture which ignores added shading engine inputs.

Height Scale

Scales the input displacement. As this value increases, the displacement is more pronounced.

locator (Fluid Effects)

Start Frame

Sets the frame after which the dynamic behavior of the locator begins.
Buoyancy
   The default buoyancy of 0.5 floats the object half in and half out of the water.

Water Damping
   Models the effects of friction and viscosity of the water on the object’s motion.

Air Damping
   Models the effects of friction and viscosity of the air on the object’s motion.

Object Height
   Set this to the height of the floating object with the object center at the locator position. The bottom of the object then sits on top of the water if the buoyancy is near 1.0 (like a beach ball) and hovers just below the water surface if the buoyancy is near zero. It sinks when the buoyancy is less than zero.

Gravity
   Sets the force of gravity exerted on the floating object.

Scene Scale
   For natural motion relative to the water, set the this option to match the “Scale” on the ocean shader, and leave Gravity at the default setting, 9.8.

Start Y
   Sets the Y translation value for the locator at the Start Frame. You could use a positive Start Y value to drop an object into the water

Notes
   Includes notes describing the locator attributes.

Boat locator Attributes

Start Rot X
   Sets the X rotation value for the locator at the Start Frame.

Start Rot Z
   Sets the Z rotation value for the locator at the Start Frame.

Boat Length
   Defines the length of the boat in world space units. For natural motion, make this value the same as the length of the boat geometry.
Open water effects

Boat Width
Defines the width of the boat in word space units. For natural motion, make this value the same as the width of the boat geometry.

Roll
Sets the rolling motion of the boat from side to side.

Pitch
Sets the pitching motion of the boat so that the front end rises or falls in relation to the back end.

Motor boat locator attributes
Motor boat locators additionally have the following attributes.

Start X
Sets the X translation value for the locator at the Start Frame.

Start Z
Sets the Z translation value for the locator at the Start Frame.

Start Rot Y
Sets the Y rotation value for the locator at the Start Frame.

Throttle
Sets the velocity of the boat, comparable to opening or closing the throttle in a boat.

Rudder
Sets the angle of the rudder to make the boat turn.

Throttle Pitch
Sets how much the front of the boat rises when the throttle is “open.”

Turn Roll
Sets how much the boat rolls to the side as it turns.

OceanShader / ocean (texture)
The Ocean texture can be used to simulate a range of water wave patterns, from small scale waves in a bathtub to large stormy sea swells. It is designed to be used as a displacement map.

Turn off feature based displacement on objects that are assigned the shader before applying as a displacement. This sets up a bump node in addition to the displacement, allowing you to keep the number of
triangles low. To see wave motion, animate the Time attribute. This
texture is defined internally (procedural) using Perlin noise and sine
waves that are driven by the Time attribute.

The Ocean shader simulates the way color changes with light and view
angle for an ocean effect.

**Ocean Attributes**

**Scale**

Controls the size in meters that corresponds to the 0 to 1 texture space
in UV (for default texture placement settings).

**Time**

Use this attribute to animate the Ocean texture. You can keyframe the
Time attribute to control the rate and amount of change of the ocean
texture in your scene. This value represents seconds for a water
surface at the given scale value. Type the expression "= time" into
the Time box to create approximately correct animation speed relative
to the scale.

**Wind UV**

Controls the (average) direction that the waves will travel, simulating
the effect of wind. This is expressed as U and V values, in the UV
texture space.

| Note | Animating Wind UV causes unnatural motion, and should be avoided. |

**Wave Speed**

Defines how fast waves move. It scales the input time used to
determine wave movement.

When Wave Speed is 1.0 Maya creates the correct speeds for open
ocean waves at the scale determined by the Maya units and the
“Scale” attribute. For example, if the scale is 10 and the wave speed 1,
1 unit represents 10 meters and the waves will move at the correct
speed.

To freeze the waves, make the speed zero.

You cannot change the speed over time using this attribute. You need
to change the animation on the “Time” attribute instead.
Observer Speed

Observer Speed cancels out transverse wave motion by moving a simulated observer. This is similar to animating the UV Offset of the texture relative to the wind direction.

When Observer Speed is 1.0 the primary waves do not appear to travel because the viewer is moving at the same speed as the waves. The secondary waves still move relative to the primary ones.

Num Frequencies

Controls the number of interpolated frequencies between “Wave Length Min” and “Wave Length Max”.

Note

The higher this value, the longer this texture takes to compute.

If this value is not an integer, then the number of created frequencies is the rounded up value, but the amplitude for the extra frequency is proportional to the remainder (for example, 0.25 for 8.25) This allows this attribute to be smoothly animated.

Wave Dir Spread

Defines the variance in wave direction with respect to the wind direction.

If it is zero, then all waves travel in the same direction.

If it is one, then waves travel in random directions.

Inconsistency of the wind direction along with other effects like wave refraction tend to cause a natural variation in wave direction.

Wave Length Min

Controls the minimum length of waves in meters. This is either the upper or the lower wavelength bound.

Wave Length Max

Controls the maximum length of waves in meters. This is either the upper or the lower wavelength bound.

Wave Height

Controls the size of waves relative to their wave length.
The left edge of the graph represents waves with the shortest wavelengths and the right edge represents waves with the longest wavelengths (as determined by Wave Length Min and Wave Length Max).

If the value is 1.0, then the waves are half as tall as they are long.
If the graph is a horizontal line, then all waves will be exactly the same height proportional to their length.

**To create the curve**

- To select a position on the curve, click the dot indicating the marker. The selected marker has a white outline around the dot.
- To add a marker, click on the graph.
- To move a marker, drag the marker dot left or right, up or down, or select the marker and type the destination position in the Selected Position box.
- To delete a marker, click the square x at the marker position.

**Selected Position**
This value indicates the position of the selected marker on the ramp (between 0 on the left to 1 on the right).

**Selected Value**
Indicates the value on the ramp at the selected position. To change the value, drag the marker dot up or down, or type the value in this box.

**Interpolation**
Controls the way values blend between position markers on the curve. The default setting is Linear.

- **None** There is no interpolation between values.
6 | Open water effects
Reference > oceanShader / ocean (texture)

Linear
The values are interpolated with a linear curve.

Smooth
The values are interpolated along a bell curve so that each value on the graph dominates the region around it, then blends quickly to the next value.

Spline
The values are interpolated with a spline curve, taking the values at neighboring position markers into account for a smoother transition.

Wave Turbulence
Controls the amount of turbulence at different wave frequencies.

The left edge of the graph represents waves with the shortest wavelengths and the right edge represents waves with the longest wavelengths (as determined by Wave Length Min and Wave Length Max).

For values of 1.0 the wave motion will be completely turbulent at the defined frequency.

For each wave frequency, the turbulence wave component consists of multiple sine waves at that frequency. This is the most computationally expensive attribute. Making it zero will speed up renders significantly, although it is important for simulations of stormy or windy water. The “Wave Peaking” attribute only affects the turbulent wave layer, so there will be no affect from the “Wave Peaking” attribute wherever this value is zero.

For details on creating the curve, see “To create the curve” on page 157.

Wave Peaking
Controls the amount of crest formation for waves across the range of wave frequencies. Wave Peaking simulates a side to side sloshing of waves, as opposed to up-down motion. “Wave Turbulence” must be non-zero for this attribute to have an effect, as it is only applied to the turbulent waves.
When this attribute is non-zero many more evaluations of the noise function are performed, and thus the computation speed will be affected.

For details on creating the curve, see ”To create the curve” on page 157.

Wave Height Offset
(Shader only) Simple offset on the overall displacement of the ocean. When textured this is useful for adding custom waves and boat wakes.

Foam Emission
Controls the density of foam generated above the “Foam Threshold”. The Foam Emission value is output to the outFoam attribute, which can be used to define opacity of a layered foam shader.

Foam Threshold
Controls the Wave Amplitude required to generate foam and how long the foam will last.

Foam Offset
Adds a uniform foam everywhere. It is useful when you need to add a custom foam texture.

Bump Blur
Defines the separation of samples (relative to the smallest wavelength) used in computing the bumped normal for shading. Larger values have the effect of making small waves and peaks smoother.

Color Mode
(Texture only) Select what to output to the color channel, the normalized Wave Height, Foam, or Foam on Waves (Wave Height in blue-green with white foam).

Common Material attributes
Water Color
Defines the basic color of the surface.

Foam Color
Defines the color of the foam layer. Part of the simulated foam might be considered submerged, in which case the color is blended with the material color.
Transparency

Controls how transparent or opaque the material is. Black means completely opaque (the default), and white means completely transparent. You can set it to any level in between. You can also control transparency on a per-channel basis; for example, if you set this to red, then only the red channel will be transparent.

Note

If this material has specular highlights (for example, if this is a Phong or Blinn shader), the transparency setting does not affect the highlights. So if you are trying to make an object disappear by animating the transparency attribute, you might also have to animate the specular highlight attributes.

Refractive Index

Defines how much a ray of light will bend when it passes through an object. This attribute only works if your material is partially or completely transparent (see “Transparency”), refractions are turned on (see “Refractions”), and you are rendering using Ray Tracing (set in Render Globals).

If the Refractive Index is set to 1.0, then light does not bend when it passes through the object. Here are some other useful values for Refractive Index:

- Air: 1.0
- Water: 1.33
- Gasoline: 1.45
- Crystal: 2.00
- Glass: 1.5
- Ice: 1.309
- Quartz: 1.6
- Ruby: 1.77
- Sapphire: 1.77
- Salt: 1.54
- Alcohol: 1.329
- Emerald: 1.57
- Polystyrene: 1.55

Note

If you make an object transparent, objects that are seen through it will be refracted only if their Visible In Refractions attribute is turned on.
Incandescence

Makes a material appear opalescent, as if it were emitting light itself, such as lava or a phosphorescent moss. A slight touch of incandescence on vegetable matter, for example, can make the vegetation look alive.

By default, the color is black, which has no effect on the surface.

---

**Note**

Although incandescence makes a surface appear to glow, it does not actually act as a source of light in the scene.

See also “Glow Intensity” on page 163.

Ambient Color

Ambient Color is black by default, which means it does not affect the material’s over-all color. As the ambient color becomes brighter, it affects the material’s color by lightening it and blending the two colors.

If there are ambient lights in the scene, then the color and brightness of those lights are used to control how much the ambient color contributes to the final color of the material.

Diffuse

Controls how much of the light in the scene is scattered from the object. Most materials absorb some of the light falling on them, and scatter the rest.

Trough Shadowing

Darkens the diffuse color in the wave troughs. This can simulate certain lighting conditions where wave peaks are brighter, scattering light. This attribute works well when the wave color is in a blue-green range.

Translucence

Simulates the way light diffusely penetrates through translucent objects. This means that when light shines on one side of the object, the other side is partially illuminated. This can be used for effects such as clouds, fur, hair, marble, jade, wax, paper, leaves, etc.

If Translucence is set to 0 (the default) then no light shows through the object. If it is set to 1, all the light shows through.
Translucence Focus

Simulates the way light scatters more in a forward direction through translucent objects. Thin objects like a leaf, or low density objects like a cloud tend to scatter more in a forward direction.

When the Translucence Focus is 0.0, translucent light is scattered in all directions. As the focus value is raised the translucent light is scatter more in the light direction. This makes the backlit side of a leaf glow more than the front lit side. At high focus values you will see a halo or glow around the light source when seen through a translucent object.

Translucence Depth

Defines the depth of penetration into an object at which translucence decays to nothing.

When Translucence Depth is 0, translucence does not decay with respect to the distance light travels through the object.

Specular Shading

Specularity

Controls how bright the specular highlights are. It is a multiplier of the specular color.

Eccentricity

Controls how big the specular highlights (hot spots) are.

Specular Color

Defines the color of the specular highlights on the material. The final color of a specular reflection is a combination of the Specular Color and the color of the light.

By making the Specular Color brighter or dimmer, you can control the brightness of the specular reflections on an object.

Tip

To make a material look more plastic, use white for the specular color. To make a material look more metallic, make the specular color similar to the surface color.

Reflectivity

Use Reflectivity to make an object reflect light like a mirror.
Set this to 0 if you don’t want your material to reflect at all. Increase the value to make brighter reflections. Note that brighter reflections hide more of the base surface color. This attribute is only meaningful if there is a reflection map, or if you are Ray Tracing.

Here are some useful values for Reflectivity:

- Car Paint: 0.4
- Glass: 0.7
- Mirror: 1.0
- Chrome: 1.0

**Note**

If you are Ray Tracing, and you want other objects in the scene to be seen in reflections, then the Visible In Reflections attribute for those objects must be turned on (the default).

**Environment**

Defines a simple sky to ground environmental reflection using a ramp. The left of the ramp is the top of the sky and the right is the bottom. For details, see “Environment” on page 79.

**Glow**

**Glow Intensity**

Controls the brightness of the glow (the faint halo of light around the material). Glow Intensity is 0 by default, meaning that no glow is added to the material. As you increase the Glow Intensity, the apparent size of the glow effect increases.

Glow Intensity is different from the “Incandescence” attribute in two important ways:

- Glow is added as a post-process at the end of rendering. (Incandescence just makes the surface appear brighter.)
- Glow Intensity adds a halo. Incandescence does not.

**Specular Glow**

Works the same way as Glow Intensity, only it makes specular highlights glow. It is useful for effects like twinkling highlights on water.

**Matte Opacity**

The attributes in this section control how this fluid shows up in the matte (alpha channel or mask) when you render with one. This is useful if you will be compositing your rendered images.
Matte Opacity Mode

Select how Maya uses the “Matte Opacity” value.

Opacity Gain Matte values are calculated based on the transparency of the object then multiplied by the Matte Opacity value. With Opacity Gain, you can animate the Matte Opacity value to change the overall transparency of the object when it is later composited.

Solid Matte The entire matte for the fluid is set to the value of the Matte Opacity attribute. This option is like “Opacity Gain”, except that the normally-calculated matte values are ignored in favor of the Matte Opacity setting. If there are transparent areas on the object, the transparency in these areas is ignored in the matte. Use this setting to composite an object with transparent areas, when you don’t want the background to show through them.

Black Hole The Matte Opacity value is ignored, and all the matte for this fluid is set to be transparent. Use this option when you use substitute geometry in a scene to stand in for objects in a background image that you will be compositing with later. Your stand-in objects will ‘punch a hole’ in the matte. This allows other computer-generated geometry to pass behind your stand-in objects. Later, when foreground and background are composited, the results will be correct, with the background object showing through the ‘black hole’ areas.

Matte Opacity has a default value of one, so by default Solid Matte and Opacity Gain have no effect.

Matte Opacity

Matte Opacity is used with Matte Opacity Mode to affect how the matte (alpha channel or mask) for this fluid is calculated.

Raytrace Options

Refractions

Turn on Refractions to make your material refract light when you are rendering with Ray Tracing. You will not see a difference unless Refractive Index is set to a value other than 1.0. (See the “Refractive Index” attribute for more details.) Refractions are turned off by default.
Refraction Limit
Ray depth limit.

Shadow Attenuation
(Fake Refraction Caustics)
Shadow Attenuation causes shadows of transparent objects to be brighter in the center, simulating the focusing of light. A value of 0 gives constant intensity shadows, 1 gives shadows focused in the center.

Reflection Limit
Reflected ray depth limit.

Reflection Specularity
Controls the contribution of the specular component when dealing with reflection rays for ray tracing (the specular contribution when seen as a mirror reflection).
6 | Open water effects
Reference > oceanShader / ocean (texture)
Texturing and shading fluids

Fluids

Texturing and shading fluids

Fluid effect texturing and shading

Built-in texturing gives you control over the look of your fluids, while the texture and shading features of Fluid Effects extend the use of fluids for a whole different range of effects. You can:

- Add texture to fluids using the texturing capabilities of the built-in shader.
- Create 2D and 3D fluid textures.
- Create fluid shaders and assign them to volume primitives.
- Use fluids as particle shaders.

Fluid Effects also includes an Ocean texture and Ocean shader for open water effects. See the “Open water effects” chapter in the Fluid Effects guide.

Texturing fluids

Procedural texturing capabilities are built into the fluid container. (You can texture using normal methods, but sampling can get slow for high quality rendering and it is not adaptive.) You can apply the built-in noise textures to both dynamic and non-dynamic fluid effects.

By animating textures set for non-dynamic fluids, you can produce beautiful effects that take much less time to render than dynamic effects. This is an efficient way to create cloud effects, for example.

- "Texture a fluid” on page 170

Fluids as textures

You can create 2D and 3D fluid textures and map them to surface shaders. The fluid can be dynamic or non-dynamic.

2D fluid textures

Mapping a 2D fluid texture to a surface shader creates the fluid pattern on the surface.
3D fluid textures

When you map a 3D fluid texture to a surface shader, the geometry that the surface is assigned to must be inside the fluid container for the texture to render. The texture renders only where Density contacts the surface geometry.

Fluids as materials

You can create a fluidShape in Hypershade and assign it to any volume primitive node (such as a sphere or cone) using the volumetric Fluid Shape material. This is possible because a fluidShape is actually both a volume shader and a volume shape node. (When you create a fluid container from the Fluid Effects menu, Maya creates the fluid shape node, then assigns it to itself.)
Fluid Shape shader as a particle shader

The Fluid Shape shader is the only volumetric shader other than the Particle Cloud shader that works with particles.

Ocean shader and texture

Use the Ocean shader to create open water effects. For details, see "Open water effects" on page 135.

The Ocean texture can by used to texture surface shaders.

For information on the Ocean texture and shader attributes, see "Fluid Effects nodes" on page 152.
How do I? **Simulate fluids**

**Use fluids as textures**

**Texture a fluid**

To texture a fluid

1. Select the fluid container.
2. In the fluidShape Attribute Editor, expand the Textures section and turn on the attributes you want to texture: “Texture Color”, “Texture Incandescence”, and “Texture Opacity”.
3. Select the type of texture you want to apply.
   - You cannot apply different textures to each of Color, Incandescence, and Opacity. The texture type you select applies to all the attributes you are texturing.
4. Select the coordinate method you want to use: The texture can be fixed in space (“Fixed”), or it can move dynamically with the fluid (“Grid”).
5. If you select Grid, as the Texture Method, set a “Coordinate Speed”.
6. Modify the texture attributes until you achieve the desired effect. For details, see “Textures” on page 92.
7. Keyframe the “Texture Time” attribute to animate the texture. For information on keyframing, see the *Animation* guide.

**Apply a fluid texture to an object**

To apply a 2D fluid texture to an object

1. Create the object and assign a surface shader to it (for example, Blinn). For information on assigning surface shaders, see the *Rendering* guide.
2. In the Attribute Editor for the shader, click the map button beside the attribute you want to map the fluid texture to (for example, Color). The Create Render Node window appears.
3. On the Textures tab, click Fluid Texture 2D.
   - Maya creates a 2D fluid container (fluidTexture2DShape node) and a place2DTexture node.
4. If necessary, move the fluid container so you can see it in the scene.
5. Add Density to the container. For details, see “Add properties to fluid containers” on page 26.
6. Modify the fluid attributes. For details, see “Modify fluid attributes” on page 60.
7 | Texturing and shading fluids

How do I? > Apply a fluid texture to an object

---

**Note**  
If the Color Method for the fluid texture is Using Shading Color, change the Color Input to Density and change the ramp to have at least two colors in the Shading section of the fluidTexture2DShape Attribute Editor.  
The surface shader uses the color at the 0 position on the ramp.  
The Density values use the colors corresponding with the position on the ramp.

7  
Turn on Hardware Texturing (Shading > Hardware Texturing) and if the fluid is dynamic, play the simulation.  
The fluid container does not appear in the software render.

---

**Note**  
When you drag and drop a fluid texture onto a shader, the Default connection connects to Color.

---

**To apply a 3D fluid texture to an object**

1. Create the object and assign a surface shader to it (for example, Blinn).
2. In the Attribute Editor for the shader, click the map button beside the attribute you want to map to (for example, Color). The Create Render Node window appears.
3. On the Textures tab, click Fluid Texture 3D.  
Maya creates a 3D fluid container (fluidTexture3DShape node). The fluid container functions as the placement node, so no place3DTexture node is created.
4. Add Density to the container. For information on adding Density, see “Add properties to fluid containers” on page 26.
5. If Density is defined as Dynamic Grid, resize and move the fluid container so that the object is inside it. The texture will only render where the Density contacts the surface of the geometry.  
If Density is defined as Gradient, move the fluid container so you can see both the container and the geometry.
6. Modify the fluid attributes. For details, see “Modify fluid attributes” on page 60.
Assign a fluid shape material to a volume shape

To assign a fluid shape material to a volume shape

1. Create the volume shape. (Select Create > Volume Primitives and then the shape you want.)
2. Press the right mouse button on the shape and from the pop-up menu, select Materials > Assign New Material > Fluid Shape. Maya creates a fluid shape node and assigns it to the volume primitive.
3. Add contents to the container. For information on adding contents, see "Add properties to fluid containers" on page 26.
4. Modify the fluid attributes. For details, see “Modify fluid attributes” on page 60.
5. Render the volume to see the effect. (There is no hardware draw for volume primitives.)
Shade particles using the fluid shape shader

To use the fluid shape shader to shade particles

1. Create a Cloud (s/w) particle system. For details, see the Dynamics guide.

2. Press the right mouse button on the particle shape and from the pop-up menu, select Materials > Assign New Material > Fluid Shape. Maya creates a fluid container (fluidShape node). (The container displays in the scene, but renders only on the particles.)

3. Add contents to the container. For information on adding contents, see “Add properties to fluid containers” on page 26.

4. Modify the fluid attributes. For details, see “Modify fluid attributes” on page 60.

Tips

- Set the “Dropoff Shape” to Sphere so that the particles do not have hard edges.
- Reduce the “Quality” value initially to decrease render time and raise it only if needed.

5. Render the scene.

6. Modify the look of the particles based on age (in much the same way as with a normal particle shader):

   Create a Particle Sampler utility (particleSamplerInfo) and connect the desired per-particle attribute (such as normalizedAge) to any Shading attribute on the fluidShape that you want to control. (Shift+middle-drag the particleSamplerInfo node onto the fluidShape node and use the Connection Editor).

   You can connect to any attributes on the fluidShape node that appear in the Shading, Lighting, and Texture sections in the Attribute Editor. Other attributes, such as Density Scale or Viscosity, do not get evaluated per pixel, and so will not work with the particle SamplerInfo.

   In this manner you can make the texture placement, colors, opacity and so on, vary from particle to particle and change based on a particle’s age.

   You can make each fluid particle internally self shadowed, simply by turning on “Self Shadow” on the fluidShape node.

   If you want particles to cast shadows onto other particles then you must use raytracing and also set a flag on a hidden attribute on the particleShape:
setAttr particleShape1.ignoreSelfShadowing 1

This will avoid a particle from being computed in its own shadow feelers (this is already computed in a more efficient manner when “Self Shadow” is turned on for the fluid).

The Render Stats that are active for the render are the ones on the particleShape, not on the fluidShape, because the particleShape is the one used to define the geometry whereas the fluid functions only a shader.
## 8 Rendering fluids

### About

**Fluids**

**Rendering fluids**

The final stage in creating Fluid Effects is to render the scene. Fluid effects render seamlessly with the rest of your scene. There are some special settings you need to be aware of when rendering fluids.

- “Prepare to render fluids” on page 175
- “Cast fluid shadows onto objects” on page 176
- “Cast shadows onto fluids (fluids receive shadows)” on page 176
- “Set the properties of rendered images” on page 177
- “Render scenes with fluid effects” on page 177
- “Optimize rendering times” on page 178
- “Improve the render quality of fluids” on page 178

### How do I?

**Simulate fluids**

**Render fluids**

**Prepare to render fluids**

Before you render a scene with Fluid Effects, you must light the scene, and select the properties that the rendered images will have.

**Light the scene**

You can use the lights in your scene to illuminate fluids (real lights), or you can use a Fluid Effects directional light that only affects the fluid and nothing else in the scene. If the fluids in your scene use real lights (see...
“Real Lights” on page 98), your scene must have a light to render the fluid. For information on adding lights to your scene, see the Lights and Cameras guide.

Fluid Effects supports light linking.

Add shadows

Fluids can be self shadowed and they can cast and receive shadows.

Self shadowing

The fluidShape node has a “Self Shadow” option under Lighting in the Attribute Editor. This is a special fast shadowing that is totally internal to the fluids node. Turning Self Shadow on causes self shadowing, even if Cast Shadows and Receive Shadows are turned off in the Render Stats section of the Attribute Editor.

All lights in the scene contribute to self shadowing, regardless of their shadow settings. If you do not want lights to affect the self shadowing, use light linking.

Cast fluid shadows onto objects

Fluids can only cast raytraced shadows onto objects.

To cast raytraced shadows onto objects:

1 Select the fluid container for the fluid you want to cast shadows.
2 Turn on Cast Shadows in the Render Stats section of the fluidShape Attribute Editor.
3 Select the light you want to cast shadows.
4 In the Attribute Editor for the light, expand Shadows and under Raytrace Shadow Attributes, turn on Use Ray Trace Shadows.
5 Select the object and turn on Receive Shadows in the Render Stats section of the object’s Attribute Editor.

Cast shadows onto fluids (fluids receive shadows)

Fluids can receive raytraced shadows and depth map shadows.

A fluid can receive raycast shadows and self shadow without requiring raytracing.

To receive shadows from other objects:

1 Select the fluid container for the fluid you want to receive shadows.
Set the properties of rendered images

During rendering, Maya generates a two-dimensional image, or series of images, from a specific view of a three-dimensional scene, and saves it as an image file. You can control the properties of rendered image files according to your post-production and presentation requirements.

To set the properties of rendered images:

- Select Window > Rendering Editors > Render Globals and set appropriate render globals.
  
  For details, see the Rendering guide.

Render scenes with fluid effects

Fluid Effects render seamlessly with the rest of your scene.

You can render a scene either from within Maya or from a UNIX shell or DOS window. Before rendering, close all applications (including Maya, if you are rendering from a UNIX shell or DOS window) to maximize the amount of memory available for rendering.

Note Fluid Effects does not support 2D or 3D motion blur.

To render a scene with fluid effects:

1. Set up your lights and render options. For details, see “Prepare to render fluids” on page 175.

2. Create a fluid cache, especially if you will be rendering across multiple machines. For information on creating fluids cache files, see “Caching fluids” on page 114.

3. Render the scene as you would any Maya scene.
   - For information on rendering a single frame, see “Rendering a frame” in the Rendering guide.
   - For information on rendering an animation, see “Rendering an animation” in the Rendering guide.
After rendering an image or an animation, you will want to view the result. For information, see “Viewing Rendered Images” in the Rendering guide.

---

**Optimize rendering times**

Here are some suggestions for optimizing rendering times:

- Use the internal light on the fluid instead of a Maya light, especially if you have a lot of lights, or you are using expensive light types (like area lights). To use the internal light, turn Real Lights off in the Lighting section of the fluidShape Attribute Editor.
- Lower the “Quality” setting as needed to speed up preview renders. In general, lower the Quality until you see dotty artifacts, especially along the fluid edges, then increase it a bit. You can then try increasing the Contrast Tolerance. A low adaptive tolerance is useful when you have a fluid with sudden boundaries. Both Quality and Contrast Tolerance affect the shadow quality.
- Raytracing with Receive Shadows turned on in the Render Stats section of the fluidShape Attribute Editor can increase rendering time.
- Avoid the Billow “Texture Type”. Use Perlin Noise instead, with “Inflection” turned on.
- Try using the Shading Samples Override attribute in the Render Stats section of the Attribute Editor of the fluid. This may work well when you have a soft edged fluid (a hard edge will need anti aliasing). The fluid might look acceptable with Shading Samples and Max Shading Samples both set to 1. In some cases, this could half the render time.

---

**Improve the render quality of fluids**

Here are some suggestions for improving the quality of your fluids renders:

- Under Shading Quality, set “Render Interpolator” to smooth for a better rendered look.
- If you see chatter when rendering an animation, increase the “Quality” attribute until the chatter goes away (expect renders in the order of 40 minutes for NTSC frames).
To eliminate software render artifacts, lower the “Density Scale” until the artifacts are no longer completely opaque, and adjust the “Opacity” curve so that the relative densities of the different parts of the fluid are satisfactory.
8 | Rendering fluids
How do I? > Improve the render quality of fluids
A Cache Format

About Fluids

Cache format

The cache format includes one cache header block and multiple fluid blocks.

FOR4 CACH

. STIM startTime (TanimTime)
. ETIM endTime (TanimTime)
. TYPE isOverSampling (Tboolean)
. RATE samplingRate (TuInt32)

// block #1
FOR4 FLUD

. TIME currentTime (TanimTime)
. WRES widthRes (Tint32)
. HRES heightRes (Tint32)
. DRES depthRes (Tint32)
. NUMD numDensVal (Tint32)
. DENS densities (Tfloats)
. NMVX numVelX (Tint32)
. NMVY numVelY (Tint32)
. NMVZ numVelZ (Tint32)
. VELX xVelocities (Tfloats)
. VELY yVelocities (Tfloats)
. VELZ zVelocities (Tfloats)
. NUMT numTemperature (Tint32)
. TEMP temperatures (Tfloats)
. NUMR numReaction (Tint32)
. REAC reactions (Tfloats)
. NUMC numColors (Tint32)
. COLR RedColors (Tfloats)
. COLB BlueColors (Tfloats)
. COLG GreenColors (Tfloats)
. NUMU numTexCoord (Tint32)
. TEXU uCoords (Tfloats)
. TEXV vCoords (Tfloats)
. TEXW wCoords (Tfloats)

// block #2
FOR4 FLUD

........

Note:

TanimTime: an unsigned int, units are 1/6000 second
Tfloats: an array of floats, the count is specified by the preceding "num" tag.
Index

Numerics
2D containers ........................................ 16
2D fluid textures .................................. 167
3D fluid textures .................................. 168

A
Add Boat Locator .................................... 144
Add Dynamic Buoy .................................. 141
Add Dynamic Locator Free Transform .......... 141
Add operation
  Paint Attributes Tool .............................. 48
Add Preview Plane ................................. 139
Add Surface Locator ............................... 141
Affect Selected Object(s) ......................... 106, 107, 108
Air Damping attribute (dynamic locator) .... 153
Ambient Color attribute ......................... 161
Amplitude attribute ................................ 94
Append Time Range attribute .................... 132
Attach to Camera option ......................... 148
attribute presets .................................. 61
Auto Set Initial State option ..................... 47

B
Billow Density attribute .......................... 96
Boat Length attribute (boat locator) .......... 153
Boat locator ........................................ 143, 144
Boat Width attribute (boat locator) .......... 154
boats
  floating .......................................... 143
  interactive simulation .......................... 145
boundaries, displaying ............................ 25
Boundary attribute ................................ 63
Boundary Draw attribute ......................... 25, 68
Bump Blur attribute ............................... 159
buoy, adding to ocean ............................ 141
Buoyancy attribute ............................... 74, 75, 153

C
Cache attribute ..................................... 131
cache files
  appending to .................................... 124
  current state .................................... 119, 120
  deleting ......................................... 124
  loading ......................................... 125
  truncating ....................................... 124
cache format ....................................... 181
Cache Time Range attribute ..................... 131
cDefaultProperty .................................. 106
Clamp settings
  Paint Fluids Tool ................................. 48
Clamp Value setting
  Paint Fluids Tool ................................. 49
cloth .................................................. 106
collisions
  disabling ......................................... 105, 126
  fluid ............................................. 103
  fluids ............................................ 103
color
  emitting into fluid container .................. 36
  fluids ............................................. 17, 36
Color attribute .................................... 83
Color attribute (height field) ................... 152
Color Diffusion attribute ......................... 77
Color Dissipation attribute ...................... 77
Color Input attribute ............................. 84
Color Method attribute ........................... 66
Color Mode attribute ............................. 159
Color Tex Gain attribute ......................... 93
Conserve Mass attribute ......................... 72
### Index

<table>
<thead>
<tr>
<th>containers</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>2D</td>
<td>16</td>
</tr>
<tr>
<td>adding emitters to</td>
<td>29</td>
</tr>
<tr>
<td>adding properties</td>
<td>26</td>
</tr>
<tr>
<td>attributes</td>
<td>60</td>
</tr>
<tr>
<td>boundaries</td>
<td>56, 59</td>
</tr>
<tr>
<td>contents of</td>
<td>17</td>
</tr>
<tr>
<td>creating</td>
<td>27</td>
</tr>
<tr>
<td>dimensions, changing</td>
<td>55</td>
</tr>
<tr>
<td>displaying contents</td>
<td>37</td>
</tr>
<tr>
<td>extending</td>
<td>55</td>
</tr>
<tr>
<td>flooding</td>
<td>34</td>
</tr>
<tr>
<td>fluid</td>
<td>15</td>
</tr>
<tr>
<td>initial states, adding</td>
<td>43</td>
</tr>
<tr>
<td>resolution, changing</td>
<td>57</td>
</tr>
<tr>
<td>scaling</td>
<td>56</td>
</tr>
<tr>
<td>size, changing</td>
<td>55</td>
</tr>
<tr>
<td>Contents Method attributes</td>
<td>65</td>
</tr>
<tr>
<td>Contrast Tolerance attribute</td>
<td>91</td>
</tr>
<tr>
<td>Convert Displacement to Polygons</td>
<td>140</td>
</tr>
<tr>
<td>Convert Fluid to Polygons</td>
<td>57, 60</td>
</tr>
<tr>
<td>Coordinate Method attribute</td>
<td>93</td>
</tr>
<tr>
<td>Coordinate Speed attribute</td>
<td>93</td>
</tr>
<tr>
<td>Cosine Power attribute</td>
<td>79</td>
</tr>
<tr>
<td>Create 2D Container with Emitter</td>
<td>27</td>
</tr>
<tr>
<td>Create 3D Container with Emitter</td>
<td>27</td>
</tr>
<tr>
<td>Create Ocean</td>
<td>139</td>
</tr>
<tr>
<td>Create Preview Plane option</td>
<td>148</td>
</tr>
<tr>
<td>current state caches, fluid</td>
<td>119, 120</td>
</tr>
<tr>
<td>Cycle Emission attribute</td>
<td>99</td>
</tr>
<tr>
<td>Cycle Interval attribute</td>
<td>99</td>
</tr>
<tr>
<td>Detail Turbulence attribute</td>
<td>101</td>
</tr>
<tr>
<td>Diffuse attribute</td>
<td>161</td>
</tr>
<tr>
<td>Diffusion attribute</td>
<td>74, 76</td>
</tr>
<tr>
<td>Directional Light attribute</td>
<td>98</td>
</tr>
<tr>
<td>Disable Evaluation</td>
<td>126</td>
</tr>
<tr>
<td>Disable Evaluation attribute</td>
<td>72</td>
</tr>
<tr>
<td>displacement</td>
<td>140</td>
</tr>
<tr>
<td>converting to polygons</td>
<td>140</td>
</tr>
<tr>
<td>Displacement attribute (height field)</td>
<td>152</td>
</tr>
<tr>
<td>Displacement to Polygons</td>
<td>140</td>
</tr>
<tr>
<td>Dissipation attribute</td>
<td>74, 75</td>
</tr>
<tr>
<td>Draw Arrowheads attribute</td>
<td>70</td>
</tr>
<tr>
<td>Draw Length attribute</td>
<td>70</td>
</tr>
<tr>
<td>Draw Velocity setting</td>
<td>50</td>
</tr>
<tr>
<td>Dropoff Shape attribute</td>
<td>82</td>
</tr>
<tr>
<td>during playback</td>
<td>34</td>
</tr>
<tr>
<td>dynamic fluids</td>
<td>140</td>
</tr>
<tr>
<td>boundaries</td>
<td>59</td>
</tr>
<tr>
<td>changing behavior</td>
<td>58</td>
</tr>
<tr>
<td>cloth, moving</td>
<td>106</td>
</tr>
<tr>
<td>geometry</td>
<td>103</td>
</tr>
<tr>
<td>collision</td>
<td>103</td>
</tr>
<tr>
<td>moving</td>
<td>106</td>
</tr>
<tr>
<td>particles, moving</td>
<td>107</td>
</tr>
<tr>
<td>dynamic grids</td>
<td>21</td>
</tr>
<tr>
<td>caching</td>
<td>119, 120</td>
</tr>
<tr>
<td>emitting fluids into</td>
<td>27</td>
</tr>
<tr>
<td>flooding</td>
<td>34</td>
</tr>
<tr>
<td>painting</td>
<td>21, 30</td>
</tr>
<tr>
<td>dynamic locators</td>
<td>141</td>
</tr>
<tr>
<td>boat</td>
<td>144</td>
</tr>
<tr>
<td>Dynamic Simulation</td>
<td>70</td>
</tr>
</tbody>
</table>

### D

|Damp attribute| 71|
|Delete Cache| 124|
|Density attribute| 65|
|Density Gradient attribute| 45, 65|
|Density Scale attribute| 73|
|Density, fluid| 17|
|Density/Voxel/Sec attribute| 100|
|depth map shadows| 176|
|Depth Max attribute| 94|

### E

|Eccentricity attribute| 162|
|Edge Dropoff attribute| 82|
|Edit Fluid Resolution| 57|
|emissions, disabling| 126|
|Emit Fluid Color attribute| 100|
|Emit from Object| 41|
|Emitter Type attribute| 99|
Fluid Effects

Index

Fuel Gradient attribute .......................... 45, 65
Fuel Scale attribute .............................. 76
Fuel/Voxel/Sec attribute ......................... 100

G
geometry, deforming .............................. 108
Get Fluid Example ................................. 22
Get Ocean Shader Example ...................... 138
Glow Intensity attribute ......................... 82, 163
Gradient attributes .............................. 45, 65
gradients
fluid properties .................................. 26
fluids ................................................ 19
Gravity attribute .................................. 71
Gravity attribute (dynamic locator) ............ 153
Grid Interpolator attribute ....................... 71
grids
dynamic ............................................. 21
fluid properties .................................. 20
static ............................................... 21

H
Hard Surface attribute ............................ 78
Hardware Shadow attribute ...................... 97
Heat Released attribute ......................... 77
Heat/Voxel/Sec attribute ......................... 100
height field ........................................ 152
Height Scale attribute (height field) ......... 152

I
Ignition Temperature attribute ................. 76
Implode attribute .................................. 95
Implode Center attribute ......................... 96
importing fluid examples ....................... 22
Incand Tex Gain attribute ....................... 94
Incandescence attribute ......................... 85, 161
Incandescence Input attribute ................. 87
Inflection attribute .............................. 95
initial state caches
adding .............................................. 43
saving ............................................. 119, 120
Input Bias attribute ............................. 85, 87, 90
Interpolation attribute .......................... 80, 86, 89, 157
Invert Texture attribute ......................... 94

L
Light Color attribute ............................. 77
Light Released attribute ......................... 77
lighting ............................................. 175
locators
boat ............................................... 144
dynamic .......................................... 141
ocean .............................................. 141
ocean surface .................................... 141

M
Make Boats ....................................... 143
Make Collide ...................................... 103
Make Motor Boats ................................ 143
manipulators
fluid subvolume .................................. 37
mapping
fluid property values ............................ 34
materials
Fluid Shape ........................................ 168, 169
Matte Opacity attribute ......................... 90, 91, 164
Matte Opacity Mode attribute ................. 90, 164
Max Distance attribute ......................... 99
Max Temperature attribute ..................... 76
Min Distance attribute .......................... 99
Min/Max Value setting........................... 48
motion blur ......................................... 177
motor boats ....................................... 143
locators ............................................ 144
multiprocess render ............................. 178
Refraactive Index attribute ............................................................ 81, 160
render globals, setting ................................................................. 177
Render Interpolator attribute .......................................................... 92
rendering
  multiprocess ............................................................................... 178
  optimizing time ........................................................................... 178
  quality, improving ...................................................................... 178
rendering, fluids ........................................................................... 177
Replace operation
  Paint Fluids Tool ....................................................................... 48
resolution
  fluid, changing ........................................................................... 57
Resolution attribute ......................................................................... 63
Resolution attribute (height field) .................................................... 152
rigid bodies, fluids ......................................................................... 106
Roll attribute (boat locator) .............................................................. 154
Rudder attribute (motor boat locator) ................................................ 154
Sample Method attribute .................................................................. 92
Sampling attribute .......................................................................... 131, 132
Save State As .................................................................................. 119, 120
Scale attribute ................................................................................ 155
Scale operation
  Paint Attributes Tool ................................................................... 48
scaling values ................................................................................ 48
Scene Scale attribute (dynamic locator) ............................................ 153
Section Radius attribute ................................................................... 101
Selected Color attribute ................................................................... 80, 84
Selected Position attribute ............................................................... 80, 84, 86, 89, 157
Selected Value attribute ................................................................... 86, 89, 157
Self Shadow attribute ......................................................................... 97
self shadowing ................................................................................ 176
Shaded Display attribute ................................................................... 66
Shaded Display setting ....................................................................... 49
shaders
  fluidShape ................................................................................ 168, 169
shading ........................................................................................... 167
shading color
  fluids .......................................................................................... 36
Shadow Attenuation attribute ............................................................ 165
Shadow Opacity attribute .................................................................. 98
shadows .......................................................................................... 176
Simulation Rate Scale attribute ......................................................... 72
Size attribute ................................................................................... 63
Size Rand attribute .......................................................................... 96
Slices per Voxel attribute ................................................................... 67
Smooth operation
  Paint Attributes Tool ................................................................... 48
smoothing values ............................................................................. 48
soft bodies
  deforming ................................................................................. 108
  fluids ......................................................................................... 108
Soft Surface attribute ......................................................................... 78
solver
  disabling ..................................................................................... 126
Specular Color attribute .................................................................... 79, 162
Specular Glow attribute ..................................................................... 163
Specularity attribute ......................................................................... 162
Speed attribute ................................................................................ 75
Spottyness attribute .......................................................................... 96
Stamp Depth (3D), Paint Fluids Tool .................................................. 49
Start Frame attribute ......................................................................... 72
Start Frame attribute (dynamic locator) .............................................. 152
Start Rot X attribute (boat locator) ................................................... 153
Start Rot Y attribute (motor boat locator) ............................................ 154
Start Rot Z attribute (boat locator) ................................................... 153
Start X attribute (motor boat locator) ................................................ 154
Start Y attribute (dynamic locator) .................................................... 153
Start Z attribute (motor boat locator) ................................................ 154
static grids ...................................................................................... 21
  flooding .................................................................................... 34
  painting ..................................................................................... 21, 30
Strength attribute .............................................................................. 75
subvolume
  displaying ................................................................................... 37
  manipulators .............................................................................. 37
Surface Render attribute ...................................................................... 78
Surface Threshold attribute ................................................................ 78
Surface Tolerance attribute ................................................................ 79
swatches, saving .............................................................................. 122
Swirl attribute .................................................................................. 75
Fluid Effects
188
T
Temperature attribute .............................. 65
Temperature Gradient attribute ................. 45, 65
Temperature Scale attribute .......................... 75
Temperature, fluid ............................. 17
texture
  fluid ........................................ 168
Texture Color attribute .......................... 92
Texture Incandescence attribute .......................... 92
Texture Opacity attribute .......................... 92
Texture Origin attribute .......................... 95
Texture Scale attribute .......................... 95
Texture Time attribute .......................... 95
texture Type attribute .......................... 92
textures
  fluid ........................................ 167, 168
  Ocean ........................................ 169
texturing ..................................... 167
  procedural .................................. 167
Threshold attribute ............................. 94
Throttle attribute (motor boat locator) .......... 154
Throttle Pitch attribute (motor boat locator) .......................... 154
Time attribute ............................. 155
Translucence attribute .......................... 161
Translucence Depth attribute .......................... 162
Translucence Focus attribute .......................... 162
Transparency attribute .......................... 81, 160
Trough Shadowing attribute .......................... 161
Truncate Cache .................................. 124
truncating cache files .................................. 124
Turbulence attribute .................................. 76, 100
Turbulence Freq attribute .......................... 101
Turbulence Offset attribute .......................... 101
Turbulence Speed attribute .......................... 101
Turbulence Type attribute .......................... 100
Turn Roll attribute (motor boat locator) .......... 154

U
Use Collisions attribute .......................... 72, 126

V
value range
  Paint Fluids Tool .................................. 48
Value setting
  Paint Fluids Tool .................................. 48
Velocity attribute ............................. 65
Velocity Direction setting .......................... 47
Velocity Draw attribute .......................... 70
Velocity Draw Skip attribute .......................... 70
Velocity Gradient attribute .......................... 45, 65
Velocity Scale attribute .......................... 75
Velocity, fluid .................................. 17
Viscosity attribute ............................. 71
Volume Offset attribute .......................... 101
Volume Render attribute .......................... 78
volume shader
  fluidShape .................................... 168, 169
Volume Shape attribute .......................... 101
Volume Sweep attribute .......................... 101
Voxel Quality attribute .......................... 67
voxels ........................................ 20

W
Water Color attribute .......................... 159
Water Damping attribute (dynamic locator) .... 153
Wave Dir Spread attribute .......................... 156
Wave Height attributes .......................... 156
Wave Height Offset attribute .......................... 159
Wave Length Max attribute .......................... 156
Wave Length Min attribute .......................... 156
Wave Peaking attributes .......................... 158
Wave Speed attribute .......................... 155
Wave Turbulence attributes .......................... 158
Wind UV attribute ............................. 155
Wireframe Display attribute .......................... 69
Index

X
X, Y Resolution option .................................. 62

Z
Z Resolution option ..................................... 62