# Table of Contents

1  **Exporter tutorial** ................................................. 7  
   About  
   Maya 3D Shockwave Exporter ..................................... 7  
   Tutorial .............................................................. 7  
   Tutorial introduction .............................................. 7  
   Loading Maya Shockwave 3D exporter ............................. 7  
   The nickel tour ..................................................... 7  
   Modeling for export ............................................... 10  
   Duplication tip .................................................... 13  
   Animating for export ............................................. 14  
   Export and preview the animation ............................... 15  
   Shading for export ................................................ 16  
   Map a file texture for the sky ................................... 17  
   Director, here we come ......................................... 20  

2  **Maya Shockwave 3D Exporter** .................................. 21  
   Maya Shockwave 3D Exporter .................................... 21  
   Introduction ....................................................... 21  
   Loading the Exporter plug-in ................................... 21  
   Preparing 3D content for Shockwave ............................ 22  
   Setting check/optimize options .................................. 23  
   About Exporting .................................................. 23  
   Exporting animation .............................................. 23  
   Guidelines for exporting animated skinned characters ...... 24  
   Exporting selected objects ...................................... 25  
   What happens when you export .................................. 26  
   Exporting a Maya scene file ..................................... 26  
   Rebuilding the export database .................................. 28  
   Setting export options .......................................... 28  
   Basic Export Options ............................................. 28  
   Optimization Options ............................................. 29  
   Download (Streaming) .............................................. 29  
   Playback Speed .................................................... 30
# Table of Contents

Geometry Resolution Options ........................................... 31
Preview Options .......................................................... 33
Advanced Export Options .................................................. 34
Output and Scene Manifest Options ...................................... 35
Previewing exported content ............................................... 37
Viewing your scene ......................................................... 37
Setting views ................................................................... 38
Preview modes ................................................................... 38
Using the Preview window .................................................... 38
Common questions about export .......................................... 41
Why do I have holes in an object after I export it? ................. 41
Why is my scene so dark after I export it? How can I lighten it up? 42
How can I achieve the best run-time performance in Shockwave? 42
How do I include shadows in my exported scene? ............... 43
How do I export single-sided or double-sided geometry? ....... 43
Why do rigid body animations look jittery? ....................... 43
How do I automatically update Director with a change in Maya? 44
What if the export fails? ..................................................... 44
Customizing Maya Shockwave 3D Exporter ......................... 44
Adding custom optimization presets .................................... 44
Adding custom error checks ............................................... 44
Batch exporting ................................................................ 45

## 3 How Maya Shaders Export To Shockwave ........................... 47

**Shader export to Shockwave** ........................................... 47

Introduction ................................................................. 47
Basic shader properties .................................................... 47
  - Color ..................................................................... 47
  - Diffuse .................................................................. 48
  - Transparency ........................................................ 48
  - Ambient ............................................................... 49
  - Incandescence ....................................................... 49
  - Translation of Lambert shader attributes .................... 50
Texture mapping ............................................................ 50
## Table of Contents

- Color ................................................................. 51
- Incandescence .................................................. 51
- Assignment of texture maps to Shockwave texture layers .... 52
- Transparency ..................................................... 52
- Blinn and Phong shaders ....................................... 52
- Specular Color .................................................... 52
- Reflection ............................................................ 54
- Shader names ....................................................... 55
<table>
<thead>
<tr>
<th>Table of Contents</th>
</tr>
</thead>
</table>

Maya 3D Shockwave Exporter
6
1 Exporter tutorial

About

Maya 3D Shockwave Exporter

Tutorial

Tutorial introduction

Note Please note that Maya 3D Shockwave Exporter is available on the Windows platform only.

Great graphics and fast interaction—these are the goals when creating 3D content on the Web. This tutorial describes how to balance these goals when using Maya’s Shockwave 3D Exporter.

This tutorial assumes you have Maya experience, but not Macromedia Director 8.5 experience. Do not expect great art from this tutorial; the focus is on learning the exporter and optimizing your scenes for export.

Loading Maya Shockwave 3D exporter

Before you begin, load the Maya Shockwave 3D Exporter plug-in.

1 Start Maya.

2 Select Window > Settings/Preferences > Plug-in Manager. The Plug-in Manager window opens.

3 Locate MayaShockwave3DExporter.mll and turn on Loaded. Maya loads Maya Shockwave 3D Exporter and adds the Maya Shockwave 3D Exporter menu to all menu sets.

To load Maya Shockwave 3D Exporter automatically every time you start Maya, turn on Auto Load.

4 Click Close.

You can now access Maya Shockwave 3D Exporter features from the Maya Shockwave 3D Exporter menu (any menu set), or from the Hotbox (common menus).

The nickel tour

You’ll start with the basic export steps.

1 Create a new Maya scene, and save it in any project as exporterTour.
In general, saving the scene is not required, but Maya will use your scene name as the name of the file that you export (a Director .w3d file).

2 Create a polygonal cube (Create > Polygon Primitives > Cube). Maya’s Shockwave 3D Exporter can only export polygons (or surfaces converted to polygons), since that is the only type of model the Shockwave player can show. The exporter also limits what you can export for animation and shading to conform with Shockwave’s capabilities.

3 As you work, you should routinely check your scene for elements that will not export. To do this, select Maya Shockwave 3D Exporter > Check All. A warning box appears that states: “No light in the scene.” Close the warning box.

As with any rendering, you’ll typically want lights in the scene. This warning is just an example of many that might occur. Use the check operation to learn with what you can and cannot export. Note that the check operation also has an options window, where you can specify the types of warnings you receive.

4 Create two directional lights (select Create > Lights > Directional Light). Rotate at least one of them to light the scene from another angle.

5 Before you export, take a moment to scan the Maya Shockwave 3D Exporter menu items, as shown in following illustration:

Export Express: Used for all regular exports. It only exports the changed scene elements after the initial export.

Export Force Rebuild: Used infrequently (such as when you don’t see a change take effect or when you are explicitly told to in an error message).
6 Choose Export Express - All. Maya opens a Preview window that shows you the scene as it will look in Director when you import it. You can export as often as you like and use the Preview window to view the result until you are satisfied with it.

At the bottom of the preview image are controls for viewing the exported content. To the right side are statistics about the exported file. Both of these will be covered later in the tutorial.

Note The dolly, track, and tumble commands will not work if the Preview window has Interactive Mode in the title bar. This mode is for use with the Real-Time Author plug-in.

If in Interactive Mode, close the Preview window, open the export options window (Export Express - All > ), find the Preview Options heading, and set Preview Mode to Non-Interactive. To verify, click Export All and tumble the view.

7 Close the Preview window.
Modeling for export

The simpler your models, the better the performance in Shockwave. Next, you’ll create a simple flying saucer to see how to balance between having smooth edges and keeping a low polygon count.

1 In Maya, turn on construction history if it is not already on. Construction history will be used later in the tutorial to illustrate a point.

2 Select the cube and scale it to 200 for X, Y, and Z. Later, the cube will become the space background for the flying saucer. For now, hide it (Display > Hide > Hide Selection) so it is out of the way.

3 We’ve prepared a curve for you to use in creating the flying saucer model. Choose File > Import and choose the file named saucerCurve from the location specified in the following table:

<table>
<thead>
<tr>
<th>Maya Package</th>
<th>File Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any purchased Maya package</td>
<td>Go to the installation directory:</td>
</tr>
</tbody>
</table>

When the file opens, notice the small detail in the curve. When revolved to create a surface, this detail will create a small ridge around the flying saucer.

4 Select the curve and choose Surfaces > Revolve > (from the Modeling menu set). In the options window, choose Edit > Reset Settings, and click Polygons next to Output Geometry.

5 Click Revolve.
6 Choose Export Express - All again so you can preview the result. This time, the export time is longer because you have added a significant amount of geometry.

If you receive a warning, “Cannot export NURBS surfaces,” it is because you did not set the Output Geometry to polygons. Redo the revolve.

7 When the Preview window appears, notice the following warning above the file statistics on the right:

This mesh has polygons which are too small to export. We are removing them.

The small detail in the curve you revolved created very small faces. Shockwave does not allow very small faces relative to the local object space. To prevent errors in Shockwave, Maya’s exporter deletes these faces. However, you should avoid this error by simplifying the model. You’ll do this in a later step.

8 On the far left of the Preview window, notice the Refresh Rate.

The Refresh Rate is the rate that the screen is refreshed, that is, how often the entire scene is rendered to the screen. In most cases, you’ll want a rate at least in the 30’s. Below this rate, the animation may appear jumpy. For example, if you create animation of a ball falling for two seconds, a low refresh rate doesn’t mean the ball will take longer than two seconds; it means the ball’s movement may appear to jump ahead, instead of moving fluidly.

In this case, the model has so many faces that it takes a long time to draw them all, which brings the rate down on most machines. (The actual rate you see is based on your machine’s capabilities, which may be different than the machines for your target audience.)

To improve the Refresh Rate, Director has controls for the geometry resolution, that is, the number of faces. You can preview different resolutions by moving the Manual Resolution slider.

9 Slide the Manual Resolution slider to the left to increase the Refresh Rate.

The more you decrease resolution, the more the surface of the model becomes rough. To see this even more clearly, turn on View > Render Mode > Wireframe from the menu at top, and slide the resolution some more.
You can get better results and do not have to decrease resolution, by changing the model to have fewer faces. You’ll do this next.

10 Close the Preview window and select the saucer.

11 In the Channel Box, click nurbsTesselate1 and change Format to Count and change Polygon Count to 3000.

As you can see in the scene view, these tessellation values create a surface that has a better balance between smoothness and the number of faces.
What about the small ridge that was part of the original revolved surface? If small details like this are needed, you can still maintain a low number of faces overall by creating a separate model and combining it with the saucer. In this case, a thin torus would suffice. See the following figure. (You do not need to actually do this for the tutorial.)

![Original ridge and Replacement ridge (using a torus)](image)

**Duplication tip**

1. Now that the model is complete, delete the NURBS curve. In general, remove extra objects in your scene, because they add inefficiencies in Shockwave.

2. With the model selected, open the duplicate options window (Edit > Duplicate > [Box shadow up]), choose Edit > Reset Settings, and click Duplicate. By using the default settings, the Duplicate operation creates a separate copy of the geometry instead of an instance. The exporter does not allow instanced objects. However, this doesn’t matter, because the exporter treats duplicated objects as if they were one instanced object. (In Director’s terminology, they share the same model resource.)

**Tip**

Suppose you wanted to tweak the vertices on the duplicated saucer so that the saucer had a different look. The problem is, once you change the topology, Shockwave can no longer treat the duplicate and the original as one instanced object. For maximum efficiency, leave a duplicate’s topology the same as the original and limit changes to translate, rotate, and scale.

3. As preparation for animation, move the duplicated saucer along the X axis, away from the original model. Tumble the view so you can see both saucers (the Z axis should be facing you).
Animating for export

Shockwave can only play animations of object transformations (move, rotate, scale). For example, to show a ball bouncing, you can move it and change its scale, but you cannot use a deformer, such as Squash, because that animates the ball’s components. Also, you cannot animate the ball’s color changing, because animation is limited to move, rotate, and scale.

Next, you’ll practice animating the saucer. This example will also introduce the exporter’s automatic resolution settings.

1. Set the frame range to 100 and go to frame 1.
2. Select one of the saucers and set a key (shortcut: s) for its current position.
3. For the rest of the animation, set the following keys for the same saucer:

<table>
<thead>
<tr>
<th>At frame...</th>
<th>...Change the following attribute and set a key</th>
</tr>
</thead>
<tbody>
<tr>
<td>40</td>
<td>Translate Z to 30</td>
</tr>
<tr>
<td>60</td>
<td>Translate Z to 0</td>
</tr>
<tr>
<td>100</td>
<td>Translate Z to 50</td>
</tr>
</tbody>
</table>
4 Play the animation. You’ll see the saucer fly toward the camera, backward, and then forward again, assuming your camera view is looking down the Z axis. The purpose of this animation is to illustrate a point when you next export.

Along with keyframing, you can use various other animation methods, provided they do not animate object components. The details are provided in “Exporting animation” on page 23.

Export and preview the animation

To keep playback fast, Shockwave includes an automatic level-of-detail (LOD) feature, which adjusts the level of detail for the models in the scene depending on their distance from the camera.

By default, the Preview window shows you manual resolution, not the automatic LOD, so you will change the exporter’s options in the next step.

1 Open the export options window (Export Express - All > boxshadowup). In the Geometry Resolution Options section, turn off Manual Resolution Control. Click Export All.

The manual resolution, which you used in earlier steps, is meant primarily to export a static model. Manual resolution does not change as the model moves toward or away from the camera.

By turning off manual resolution, the exporter uses Shockwave’s automatic LOD instead, which adjusts resolution depending on distance from the camera. (Actually, Shockwave bases resolution on rendered screen size; the further away an object appears, the smaller its screen size, and so the lower its resolution will be.)

2 In the Preview window, click the play button, and then experiment with moving the Automatic Resolution slider.

This time, the resolution slider controls how much the automatic LOD changes with distance. By reducing the resolution, you can increase the Refresh Rate. If you have a fast machine, the Refresh Rate will likely be at the maximum (66), even without changing resolution.
force the Refresh Rate down, try duplicating one of the saucers a few more times and exporting again. The more geometry in your scene, the slower the Refresh Rate will be.

3 In the Preview window, set Automatic Resolution to about 0.1. At this setting, the resolution is too low and the faces on the saucer’s surface appear abruptly as it moves, instead of making a smooth transition from one level of detail to another.

Find a resolution setting that avoids the abrupt level transitions. (In your own projects, these abrupt changes in the surface are not always avoidable.)

4 The resolution value you set in the Preview window is not saved to the exported file—you must make the change in the export options window. Do this now by closing the Preview window and, in the export options window that is still open, enter the Resolution value you found works best (or just take a guess). Resolution is under the Geometry Resolution Options.

Click Save Settings so the next time that you export, Maya will use the resolution setting you specified. You can close the exporter options window now.

Shading for export

Like modeling and animation, the shading in your scene must conform to Shockwave’s limits. Maya warns you if you use shading features that will not export. For example, Shockwave does not support advanced shading features like bump maps, layering, and color-per-vertex.

Next, you’ll create basic shading for the saucer and for the space background.

1 In Hypershade (Window > Render Editors), create a Blinn material and assign it to one of the saucer models. (Leave the other with the default shading as a comparison.)

2 Double-click the material swatch to open the Blinn material’s attributes. Choose your favorite metallic color and set the Eccentricity to 0.15 for smaller highlights, which will make the surface look shinier.

3 Choose Export Express - All. As you play the animation, notice the smaller highlights on the surface, as shown in the following illustration.
In general, the exporter handles most of the common material attributes as well as specular highlights. For complete information on which material attributes are supported, see Chapter 3, “How Maya Shaders Export To Shockwave.”

4 Close the Preview window.

Map a file texture for the sky

To create a background of stars for the flying saucer, you’ll shade the cube you created earlier. This exercise introduces a technique for minimizing lighting. You’ll also learn about exporter options related to shading.

1 Display the cube again (choose Display > Show > Show Geometry > Polygonal Surfaces).

2 With the cube selected, choose Polygons > Smooth (from the Modeling menu set) so that the surface is closer to a spherical shape. (You could have used a sphere instead of a cube, but the texture would appear pinched at the poles of the sphere, unless you rearranged the UVs.)

3 Create and assign a Lambert material to the cube.

If you export, just one side will be lit. See the following figure.
For the background, you’ll want even lighting, which you could achieve by adding more lights. However, adding too many lights to a scene can result in slower performance in Shockwave. Also, keep in mind that Shockwave does not support light Intensity settings above 1.0 for directional lights. (For point and spot lights, you can use Intensity settings above 1.0 and they’ll look as they do in Maya’s scene view.)

As an alternative, you’ll map the background texture to the Incandescence attribute instead of Color. Incandescence controls the self-illumination of an object, so you can avoid using lights on the background by mapping to this attribute.

4 In the Lambert material’s attributes, slide the Color bar completely to the left so the color is black. The color should be black so it doesn’t interfere with the Incandescence attribute.

5 named stars from the location specified in the following table:

<table>
<thead>
<tr>
<th>Maya Package</th>
<th>File Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any purchased Maya package</td>
<td>Go to the installation directory:</td>
</tr>
</tbody>
</table>
Choose Export Express - All and tumble the view to see the stars texture.

By default, the texture exports with the best quality. However, using the best quality adversely impacts file size and interactive performance. In your projects, you'll need to balance between image quality and performance.

Next, you'll reduce the image quality by changing the export options.

Close the Preview window and choose Export Express - All > boxshadowup. In the options window, change Presets (under Optimization Options) to: Balance Speed/Size and Quality.

This preset changes various settings for you. In particular, it increases Texture Compression from 0 to 0.5.

Click Export All and examine the stars texture.

There is less precision in the image this time; for example, the large stars appear fuzzy. However, you'll see smaller file sizes under the File Statistics on the right of the Preview window. In particular, the Textures statistic now reads 14K, down from 77K. This is a measurement of how much the total file size consists of texture data.

In general, keeping texture sizes to a minimum is important, not only for reducing file size, but also for ensuring good interactive performance. In this case, the stars.iff texture file is 256x256, which is generally a good size to use—although the smaller, the better.

Textures also contribute to the size of the Initial load segment (ILS), which appears at the bottom of the File Statistics. ILS is the part of the Shockwave file that must finish streaming before the movie becomes visible. In general, it is best to make this as small as possible.

Take a moment to skim the rest of the information on the right of the Preview window.

There are several “palette” headings. A palette lists the items that can be accessed and controlled in Director, using Lingo code. For example, suppose the Lingo programmer wanted to switch the color of the saucer. They could find the number of the material assigned to the saucer by looking under the Node Palette, which is a list of all exported nodes:

3: revolvedSurface1 (mesh)
0: lambert1 (shader)

Then, under the Shader Palette, they could get the number of another material, and write code that would switch the two.

All of this information is saved in a scene manifest file, such as exporterTour.w3d.manifest.txt (the name and location appears at the top of this information). You can give this file to the Director user and Lingo programmer along with the .w3d file.

Maya 3D Shockwave Exporter
1 | Exporter tutorial
About > Director, here we come

Tip
Another convenient tool for examining and editing the contents of the .w3d file is 3DPI, a publicly available Xtra for Director 8.5. It gives you a Property inspector for 3D cast members. Search for “3DPI” on the internet.

Director, here we come

If you have a copy of Director 8.5, you can now view the results of your work. If you do not have a copy, simply skim this section.

Since you just exported in the prior step, your work is ready to be imported. (Saving the Maya scene is not required.)

1 In a new Director movie, choose File > Import.
2 Browse to the w3d directory in your project and select exporterTour.w3d.
3 Drag the 3D cast member, exporterTour, onto the Stage.
4 Play the movie to see the saucer fly. To see it play in a browser, save the file in Director and choose File > Publish.
Maya Shockwave 3D Exporter

Introduction

The Maya Shockwave 3D Exporter provides you with a fast and efficient way to get your Maya content into Macromedia® Director®. Your content exports in a form that can be authored for use with an interactive experience (for example, a simple spinning animation for a Web page, or on the other end of the spectrum, a full-on adventure game) and played on the Macromedia Director Shockwave® player. You can create content to use with Director on your own computer system or to hand off to someone else.

Maya Shockwave 3D Exporter (version 1.2 or higher) also works together with Maya Real-Time Author™. The exporter lets you preview the interactions you create. The Exporter also outputs your scene to Macromedia Director so that you can create Shockwave files that include your interactions.

With its numerous error-checking features, Maya Shockwave 3D Exporter helps you prepare your content, warning you of any unsupported features and providing you with the information you need to optimize your content for export. Maya Shockwave 3D Exporter also includes many internal optimizations to package your content in the best way possible for Macromedia Director when you do export it.

Maya Shockwave 3D Exporter streamlines the iterative process inherent in preparing content for final production. It includes a Shockwave 3D previewer, so you can prepare your content, export it, and view how your results will look in Shockwave 3D without ever leaving Maya. And each time you re-export the content with changes, Maya’s “express” export only has to convert the changes. For large, complex content, this can save you hours a day.

Loading the Exporter plug-in

Maya Shockwave 3D Exporter must be loaded for you to use it.
To load Maya Shockwave 3D Exporter

1. Start Maya.
2. Select Window > Settings/Preferences > Plug-in Manager. The Plug-in Manager window opens.
3. Locate MayaShockwave3DExporter.mll and turn on Loaded. Maya loads Maya Shockwave 3D Exporter and adds the Maya Shockwave 3D Exporter menu to all menu sets.
   To load Maya Shockwave 3D Exporter automatically every time you start Maya, turn on Auto Load.
4. Click Close.

You can now access Maya Shockwave 3D Exporter features from the Maya Shockwave 3D Exporter menu (any menu set), or from the Hotbox (common menus).

Preparing 3D content for Shockwave

To prepare your 3D content for export, optimize it regularly as you create it by checking it with Maya Shockwave 3D Exporter. When you check your content, Maya warns you of any unsupported features used.

| Note | You cannot export Fluid Texture 2D. You must convert the fluid texture to an image file and map it back onto the geometry before you export. |

To prepare 3D content for Shockwave:

1. Check either the entire scene, or selected components in the scene:
   - To check the entire scene, select Maya Shockwave 3D Exporter > Check All. The exporter analyzes the entire scene.
   - To check selected components only, select the components and then select Maya Shockwave 3D Exporter > Check Selected. The exporter analyzes only the selection. If you select a surface, Maya analyzes the geometry, its shaders, and animation.

   For details on customizing the checks Maya performs, see “Setting check/optimize options,” below.

| Note | To interrupt the error checking, press the Esc key. |

2. Follow the instructions provided to fix the problem. Fine-tune your scene.
Setting check/optimize options

To select which checks you want Maya to perform during optimization, select Maya Shockwave 3D Exporter > Check All > or Check Selected > and change the following options in the Maya Shockwave 3D Check/Optimize Options window.

Error Checks by Category

Geometry
Turn this option on to check for non-exportable geometry.

Shaders/Textures
Turn this option on to check shaders and textures.

Lights
Turn this option on to check for non-exportable light features.

Cameras
Turn this option on to check for non-exportable camera features.

Animation
Turn this option on to check for non-exportable animation features, including potential problems with pivots.

Transform
Turn this option on to check for non-exportable features of the basic transform attributes.

About Exporting

Before you start your Maya scene, read the following tips and precautions. You'll learn about the Maya elements you can export.

Exporting animation

You can export animations on an object’s translation, rotation, and scale. In Maya, you can use any method you want to animate the translation, rotation, and scale, including:

- keys (on transforms only, including joints)
- motion paths
- inverse or forward kinematics
- constraints
- expressions (on transforms only, including joints)
- set driven key (on transforms only, including joints)
rigid bodies
• animation clips (see “Exporting clip animation,” below)

If you use a procedural method of animation, such as expressions or rigid bodies, the exporter converts the animation to keyframes within Shockwave, because Shockwave only supports keyframe animation. The motion in Shockwave will match the playback in Maya. If you need to change the expression or rigid body, you can still do so in Maya and export again.

The exporter does not support vertex/CV animation, deformers, blend shapes, particles/soft bodies, or any animation on any attributes other than translate, rotate, scale. However, you can use any of these techniques to animate geometry that controls animation on a transform, such as a motion path, and the path animation is evaluated and baked out correctly.

For example, suppose you have a NURBS curve that is acting as a motion path, and you animate the CVs of the path. While the exporter does not recognize the CV animation itself, it does recognize the effect those animated CVs have on the motion path and any objects moving along that path. That effect is reproduced as keyframes on the objects when the file is exported.

Exporting clip animation

You can export clip animation. The clips must be applied to an object and appear in the Trax Editor’s timeline. Source clips will not export. The exporter treats clips the same as keyframes and combines them with any other animation on the object. The animation plays the same in Shockwave as in Maya.

Tip
If you want to play segments of your animation separately in Shockwave, you can do so using Real-Time Author. For example, you could set up a ball to bounce, move forward, or bounce and move forward, depending on what the end user triggers. See the online help for Real-Time Author.

Guidelines for exporting animated skinned characters

The exporter lets you export animated skinned characters. This feature uses the skinning capabilities that come with Macromedia Shockwave.

Because you are limited to Shockwave’s capabilities, there are certain Maya skinning features that will not export. Follow these guidelines to keep your animation compatible with Shockwave.
When setting up skeletons

- Have a single root joint for each character with as many joint chains and branches as needed. (Note that with Real-Time Author you can trigger animation only on the root joint.)
- Create continuous joint chains with no group nodes between joint chains.
- Use any joint orientation.
- Note that you can scale bones along the joint axis (however, you cannot animate the scaling).

When binding skin

- Use smooth bind only, not rigid bind.
- Do not use influence objects.
- Use polygonal surfaces only, not NURBS or subdivision surfaces.
- Do not use deformers of any kind (blend shape, lattices, and so on).
- Note that you can parent surfaces to joints without skinning them (for example, you can parent a helmet or holster so it follows the character but does not deform).

When animating joints and using Real-Time Author

- Use any form of animation on the skeleton, including: inverse or forward kinematics, the Trax editor, expressions, and set driven key.
- Do not animate individual vertices or cluster points.
- Do not animate joint length.
- If you use Real-Time Author, note that you can trigger animation only on the root joint and not part of the skeleton. For more information on triggering skinned characters, see the Real-Time Author online help.

When exporting

For the Collapse Hierarchies option, use the Fastest Export setting to give greater control of your characters using Lingo programming. For example, a typical character setup includes group nodes above the skeleton so you can animate the character moving or rotating as a whole. The Fastest Export setting keeps any group nodes segregated so the Lingo programmer can manipulate them. On the other hand, the Fastest Playback setting means the group nodes would collapse and the Lingo programmer could not access those nodes.

Exporting selected objects

You can export the entire scene (including geometry, assigned shaders/textures, active lights, and animations) or you can export selected objects only. If you export selected objects, note the following:
By default, if you select geometry, any shaders/textures attached to that geometry also export. If you do not want to export attached shaders/textures, turn off “Export Shaders Assigned to Selected Objects” in the Advanced Export Options section of the Export Options window.

By default, all active lights are always exported, even if you did not select them. If you do not want to export all active lights, turn off “Export All Lights” in the Advanced Export Options section of the Export Options window.

If you select only shaders and/or textures, then they export by themselves, independent of geometry. Note that procedural textures are dependent on the geometry, and therefore, cannot be exported separately.

If you select “Preview Exported Scene” in the Preview Options section of the Export Options window (the default), your chosen preview camera always exports (see “Camera For Previewing” on page 33). If you are not previewing, only selected cameras are exported.

What happens when you export

The first time you export a scene or selected objects in a scene, Maya builds a database of all the components and export data. The next time you export that same scene or selected objects, only the changed items in the database are exported. This “express” method of exporting is a great time saver when you are working with large, complex models, refining and exporting repeatedly to fine tune your results. (Note that the database is automatically flushed any time you select File > New or load a new scene.)

The Maya Shockwave 3D Exporter exports your content into a Macromedia Shockwave W3D file, which can then be imported into Macromedia Director Shockwave Studio 8.5. The exporter also creates a scene manifest file which summarizes the content of the W3D file for the Lingo programmer (the person in charge of using Macromedia Director to create a Shockwave movie). You do not need to have Macromedia Director installed on your system to create or preview these files; however, you do need it to publish the files to a web page.

Exporting a Maya scene file

You can export the entire scene or selected elements of the scene.

To export a Maya scene file:

1. Optimize the selected components. For details, see “Preparing 3D content for Shockwave” on page 22.
2 Set the export options. See “Setting export options” on page 28.

3 Choose one of the following to export your scene:

- To export the entire scene, select Maya Shockwave 3D Exporter > Export Express - All.
- To export selected components, select the components in the scene you want to export, and select Maya Shockwave 3D Exporter > Export Express - Selected.

The first time you export the scene, the exporter builds the database before exporting. Subsequent exports export only the changed items in the database. If you want to rebuild the database, see “To export (rebuilding the entire export database):”

By default, the exporter checks for unsupported features. (If you do not want to check for unsupported features, turn off “Check Unsupported Features” in the Advanced Export Options section of the Export Options window.)

4 If the exporter detects unsupported features, a window opens prompting you to confirm that you want to continue to export. Click Yes to export anyway. Click No to cancel the export. Skip to step #6.

If no unsupported features are detected, the selection exports. This can take several minutes the first time you export the scene.

By default, a preview Macromedia Shockwave render displays. Also, the Export Results are displayed in the Preview window providing the results of your export. If you do not want to view export results, turn off “Display Export Results” in the “Output and Scene Manifest Options” section of the Export Options window.

If you are exporting animation, you can play the animation in the Preview window. For more information, see “Previewing exported content” on page 37.

5 Close the Preview window.

6 Modify the scene as required and repeat the steps until you are satisfied with your results. Subsequent exports will run faster in most cases, because the exporter only exports your changes since the first export.

7 Give the W3D file to your Lingo programmer, along with the scene manifest file generated for you at export (MayaExportedFileName.w3d.manifest.txt).
Rebuilding the export database

Sometimes you may get an error or warning message telling you to rebuild the entire export database. Or you may observe a problem after an express export. In that case, you can force a rebuild of the entire database when you export the entire scene or when you export only selected components of the scene.

**To export (rebuilding the entire export database):**

- To export the entire scene, select Maya Shockwave 3D Exporter > Export Force Rebuild - All.
- To export only selected components in the scene, select the components and select Maya Shockwave 3D Exporter > Export Force Rebuild - Selected.

For information on setting export options, see “Setting export options” on page 28.

Setting export options

To specify how you want Maya to build the W3D file, select the option box (☐) for one of the export operations under the Maya Shockwave 3D Exporter menu.

Basic Export Options

Macromedia Shockwave 3D File

Type the name of the exported file. By default, the scene name is used. You do not need to type the .w3d extension. Maya provides it automatically.

When you export, Maya checks for an existing export file. If the name in the Macromedia Shockwave 3D File box has changed since the last export, or what you are exporting has changed (All versus Selected), then Maya confirms whether you want to overwrite the file. This ensures that you do not accidentally overwrite a scene that contains a different export.

By default, Maya stores the W3D file in the w3d subdirectory of the current project directory.

**To change the default location for storing Macromedia Shockwave files:**

- In the Maya command line, enter the following command:

  `workspace -fileRule "Macromedia Shockwave3D" "NewPathHere";`
Optimization Options

Presets

Select a preset for the desired combination of speed and quality for the export. You can see the effects of these options by reviewing the file size information in the Preview window after export. See also “Specular Color” for information on how the presets affects highlights.

Balance Speed/Size and Quality
Makes the smallest, fastest file possible with a high image quality. This option sets Geometry Compression to 0.5, Texture Compression to 0.5, Animation Compression to 0.5, Maximum Texture size to 256, and turns on Export Smoothing Data.

Best Speed/Size
Makes the file as small as possible (so it will download quickly) and run quickly once downloaded. This option sets Geometry Compression to 1, Texture Compression to 1.0, Animation Compression to 1, Maximum Texture size to 64, and turns off Export Smoothing Data.

Best Quality
Makes the highest quality image possible, without regard to file size or speed. The resulting file will be larger and run more slowly than with other options. This option sets Geometry Compression to 0, Texture Compression to 0, Animation Compression to 0, Maximum Texture size to 512, and turns on Export Smoothing Data.

Note
You can modify the existing presets or create your own by modifying the s3dCreateUI.mel script. For details, see “Adding custom optimization presets” on page 44.

Download (Streaming)

Geometry Compression
A high setting reduces the download time, at a cost of making geometry appear blurred or distorted. Some data compression occurs at all settings.
Texture Compression
High settings improve download time but reduce the visual quality. The exporter uses JPEG compression to compress textures. JPEG compression is lossy, which means it discards some of the data in the image in order to improve compression ratios. Some minimal compression occurs at all settings.

Animation Compression
High settings improve download time but animations loose quality. High settings also reduce the number of bits used for animation. Some data compression occurs at all settings, except 0.

Maximum File Texture Size
Textures greater than the specified size are scaled to fit the selected size. A low setting reduces the download time, at the cost of making the texture appear mottled or irregular. Lower settings reduce the number of bits used to store texture data. This does not affect the original texture file.

Procedural Texture Size
Generates Shockwave textures from procedural textures at the size you specify. Smaller textures give better performance.

Export Smoothing Data
Turn this option on to export additional data required for Shockwave to do adaptive smoothing on geometry (a form of subdivision surface technology). This data adds to the size of the W3D file and to the streaming time.

Playback Speed
Collapse Hierarchies
Select how you want to optimize the playback speed in Shockwave.

Fastest Export
Does not combine objects that are in hierarchies, so exporting is much faster. When hierarchies are not collapsed, the playback can be slower in Shockwave. However, because the objects are not combined, the Lingo programmer can manipulate individual objects.

Fastest Playback
Combines object meshes that are in hierarchies into single mesh objects in Shockwave. This can improve playback speed. For example, it would improve speeds if you had several different objects in a
hierarchy that all share the same material because the shader information would be handled more efficiently by Shockwave.

The only potential drawback to this setting is that the separate meshes cannot be individually animated in Director because, in effect, they become one mesh.

The following items are not combined, even when Fastest Playback is set:

- If a transform is animated, Maya always puts that transform and everything beneath it into a separate mesh. The nodes beneath it use the criteria listed here to determine if they are combined with the transform.
- Objects that are geometrically identical are not combined so Shockwave can treat them as instances.
- Transparent objects are not combined to avoid depth sort problems when rendered in Shockwave.
- Cameras or lights are not combined with mesh objects into the same Shockwave “node.”

When the export is complete, Maya displays the Preview window, which lists all the combining it did. Maya also writes this information to the scene manifest file.

**Geometry Resolution Options**

These options control Macromedia Shockwave’s automatic LOD (level-of-detail) feature, which adjusts the level of detail for the objects in the scene depending on their distance from the camera.

Shockwave’s LOD features have no connection with Maya’s LOD features.

**Manual Resolution Control**

If this option is turned on (the default), the Resolution setting determines the level of detail of objects in the Preview. Objects are displayed at a fixed resolution regardless of the object’s distance from camera.

If this option is turned off, the Resolution setting determines how geometry resolution drops with distance using Shockwave’s automatic geometry resolution functions. You can see the effect as you zoom the camera in and out in the Preview window. Objects change resolution automatically with distance.
Regardless of the setting you choose here, automatic level of detail (LOD) is always turned on in the actual W3D file. The Lingo programmer can turn it off by setting LOD.auto to false.

**Resolution**

Shockwave has a built-in level of detail technology called “multi-resolution mesh.” This is used to adjust the level of detail of objects both with respect to camera position, and as they stream over the net.

When “Manual Resolution Control” is turned on, Resolution sets the initial fixed level of detail of objects in the Preview window. This value is also written to the file, regardless of what you do with the Manual Resolution slider in the Preview window.

You can view how different settings look using the Manual Resolution slider in the Preview window. For details, see “Manual Resolution/Automatic Resolution” on page 39.

To set the manual resolution in Director, the Lingo programmer can set the LOD.level. See the scene manifest file for the specific Lingo code for setting resolution in Director.

When “Manual Resolution Control” is turned off, Resolution sets the speed with which level of detail reduces with distance. The lower the value, the quicker polygons disappear from the object as it moves away from the camera. If you want an object to keep its details as it moves away from the camera, set Resolution to a higher value.

You can view how different settings look using the Automatic Resolution slider in the Preview window. For details, see “Manual Resolution/Automatic Resolution” on page 39.

The automatic resolution factor in the exporter corresponds to LOD.bias in Director. A value 0 in the exporter corresponds to a value of 1000 in Director.

(Automatic level of detail is always turned on in the actual W3D file unless the Lingo programmer turns it off by setting LOD.auto to false.)

**Automatic Smoothing During Reduction**

Turn this option on to automatically smooth objects with LOD. If you do not turn on this option, your object will look faceted as the geometry is reduced. If you turn on this option, the faceting is smoothed out automatically. Turn this option on to correct problems with sudden light/dark changes. Using this option increases your file size, but improves the look of your objects.

**Hard/Soft Edge Threshold**

Set a threshold value for smoothing of objects. Edges with normals that differ by a value greater than this value will have a hard edge.
Preview Options

Preview Exported Scene

Turn this option on to display a preview of the exported scene using Shockwave 3D rendering. For more information on previewing the exported scene, see “Previewing exported content” on page 37.

Preview Width/Preview Height

Lets you specify the viewing size of the Preview window. By setting this to the size you intend for final publication, you can better evaluate how the performance will be. This setting only affects the Preview window and not the exported scene itself.

Camera For Previewing

Select which camera you want to use as the default in both the Preview window and the exported file. By default, the exporter uses the current camera in the Maya scene view.

Rename as Default View

Turn this option on to rename the camera to default_view in the Macromedia Shockwave 3D file. This is used as the default view for the cast member. When this option is off, the camera used for previewing is exported under its original Maya name, but previewing inside Director will not work without some additional Lingo programming. You can preview in Maya regardless of this setting.

Preview Mode

Specifies whether you want to preview in interactive or non-interactive mode. The title bar in the Preview window displays which mode is operating.

If you have Real-Time Author loaded, the Preview Mode is Interactive by default.

Non-Interactive

Use this mode for examining the scene without the interference of interactions. Use the standard Maya camera controls to tumble, pan, and dolly.

Interactive

Use this mode to view interactions created with Real-Time Author. You can enable the standard Maya camera controls by clicking the stop play button. Otherwise, only authored interactions work in the Preview window.
Advanced Export Options

Check Unsupported Features

Check the scene or selected components for unsupported features before exporting. Maya reports any unsupported features and provides suggestions for optimizing the content for export. To control which features Maya checks, use the settings in the Check/Optimize Options window. For details, see “Setting check/optimize options” on page 23. Turning this off will speed up performance.

Export All Lights

This option is available only when exporting selected components. Turn it on to export all active lights to the Macromedia Shockwave 3D file, regardless of what you have selected.

This ensures that your objects have the same light sources in Shockwave that they do in Maya. Typically, you would turn this option off only when exporting selected pieces of a scene to separate files.

Export Shaders Assigned to Selected Objects

This option is available only when exporting selected components. Turn it on to automatically export the assigned shaders whenever exporting selected geometry, even if the shaders are not explicitly selected.

Turn this option off to export selected geometry only with selected shaders. The geometry appears with the default Shockwave shader (a checkerboard texture).

Export Animation

Turn on this option to export animations on translation, rotation, and scale. In Maya, you can use any method you want to animate the translation, rotation, and scale, including: keys (on transforms and joints only), motion paths, forward or inverse kinematics, constraints, expressions (on transforms/joints only), set driven key (on transforms/joints only), and rigid bodies.

If you use a procedural method of animation, such as expressions or rigid bodies, the exporter converts the animation to keyframes within Shockwave, because Shockwave only supports keyframe animation. The motion in Shockwave will match the playback in Maya. If you need to change the expression or rigid body, you can still do so in Maya and export again. See “Exporting animation” on page 23.

Material Highlights

Select how you want to represent highlights (specularity) for Blinn and Phong shaders.
Best Lighting  Use both a generated texture map and Shockwave
specularity for the best quality but the slowest
performance.

Best Highlights Use only Shockwave specularity for fastest
performance. The color of the light is respected, but
the quality is lower.

Output and Scene Manifest Options

Write Scene Manifest

Turn this option on to write a “scene manifest” file summarizing the
contents of the W3D file. The scene manifest file contains the same
information you see displayed in the Preview window. The manifest
shows how the hierarchy was changed as a result of mesh combinations. It
lists all the objects.

The manifest is intended mainly for the Director user who is not also the
Maya artist. The artist gives the manifest file and the W3D file to the Lingo
programmer. The manifest has the same name as the W3D file, with the
further extension .manifest.txt appended (for example,
globe.w3d.manifest.txt). Maya saves it in the same directory as the W3D
file.

The manifest shows how the hierarchy was changed as a result of mesh
combinations. It lists all the objects.

If you turn on the Texture, Shader, Node, and Animation Palettes option,
the scene palettes also get written to the scene manifest file.

Display Export Results

Turn this option on to display the export results in the Preview window.
The Preview window displays the following:

- A list of objects with ignored polygons. In some cases, polygons in
  your models are ignored during export, typically because the
  polygons are too small for Shockwave. When polygons are ignored,
  you may see tiny holes or cracks in the exported image.

By default, the window also summarizes file statistics, scene
modifications, and polygon counts, although you can suppress this
information from displaying. See the next section.

Show

Select which information you want displayed in the Preview window and
the manifest file.
Export Warnings

Lists the warnings that were generated at export time in the Preview window. We recommend that you leave this option on unless you are familiar with the export warnings the file is generating. Turning off the export warnings reduces the “clutter” in the information but does not speed up performance.

File Statistics

Turn this option on to display file statistics in the Preview window. The statistics include the following information:

- Total file size
- Percentages of the file occupied by mesh data, textures, animations, shaders, and node overhead.
  “Mesh data” and “Textures” are the actual mesh and texture data, whereas “Node overhead” refers to overhead for the nodes in the scene graph. For example, if you had 500 polygonal objects each using an identical geometry of 10 polygons, the overhead for the 500 objects would count as nodes, whereas the vertex and normal data for the 10 polygons would count as meshes.
- Size of the initial load segment (ILS). This is the part that must finish streaming before your user sees anything. It is best to make this as small as possible.
- Total runtime memory requirement for your textures.
- A list of all meshes combined. See ”Collapse Hierarchies” on page 30.
- A list of all animations converted.
- Net triangle count for each Shockwave 3D mesh object, after mesh combination and tessellation.

Model Resource Palette and Triangle Counts

Turn this option on to display:

- list of the Shockwave 3D mesh objects.
- the total polygon count for each Shockwave 3D mesh object, in addition to the count for each (after mesh combination and tessellation).

Interaction Data

Displays a listing of the interactions created by Real-Time Author in the Preview window.
Scene Hierarchy

Displays the scene hierarchy information in the exported file. Depending on what export settings you chose, that might not be the same as the Maya hierarchy. If an object is indented in this section, it means it is parented to object listed above it that is not indented.

Texture, Shader, Node, and Animation Palettes

Turn on this option to display in the Preview window a list of all the textures, shaders, nodes and animation in the scene. This information is also written to the scene manifest file.

A Lingo programmer can use this information to manipulate the contents of a scene.

The Maya artist can use the palette as a summary of the contents of the scene, which can be helpful for reducing file size. You want to reuse your assets as much as possible.

Previewing exported content

To preview the exported scene as a Shockwave 3D render, turn on Preview Exported Scene in the Preview Options section of the Export Options window.

Viewing your scene

You can track, dolly, and tumble the view using the Maya track, dolly, and tumble mouse controls.

<table>
<thead>
<tr>
<th>Hold</th>
<th>Drag</th>
<th>To . . .</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt key</td>
<td>Left mouse button</td>
<td>Tumble</td>
</tr>
<tr>
<td>Alt key</td>
<td>Middle mouse button</td>
<td>Track</td>
</tr>
<tr>
<td>Alt key</td>
<td>Left and middle mouse button</td>
<td>Dolly</td>
</tr>
</tbody>
</table>

When you dolly the camera, the polygon faces change in appearance. This is the effect of Shockwave’s automatic LOD (level-of-detail) feature. To disable the feature, turn off Automatic Geometry Reduction for Preview in the Export Options window.
Setting views

To restore your camera view to the home view:

- Select View > Restore View.

To set the home view to the current camera view:

- Select View > Save View.

To set the render mode:

1. Select View > Render Mode.
2. Select Smooth, Wireframe, or Points.

Preview modes

You can preview in interactive or non-interactive mode, depending how you set the Show Interactive data options in the Export options window. The title bar in the Preview window displays the mode that is operating. If you have Real-Time Author loaded, the Preview Mode is Interactive by default.

Non-Interactive

Use this mode for examining the scene without the interference of interactions. Use the standard Maya camera controls to tumble, pan, and dolly.

Interactive

Use this mode to view interactions created with Real-Time Author. You can enable the standard Maya camera controls by clicking the stop play button. Otherwise, only authored interactions work in the Preview window.

Using the Preview window

The Preview window offers lots of controls and feedback about your exported scene, depending on what options you selected in the Export Options window.

Scene Stats

Refresh Rate

Displays the number of times per second that the Shockwave Preview window gets re-rendered or “refreshed.” This is a measure of how well your scene will perform in Shockwave. It’s not connected in any way with the Maya frame rate. The actual rate you see is based on...
your machine’s capabilities, which may be different from the machines for your target audience. In most cases, you’ll want a rate at least in the 30’s. Below this rate, the animation may appear jumpy.

Renderer

Displays the rendering method. Currently, this displays OpenGL unless you are on a machine that does not support OpenGL for Shockwave, in which case it defaults to Software. (Most laptop machines fall into this category.)

Total Triangles

Displays the total number of triangles in the exported scene.

Reduced Triangles

Displays the number of triangles at your current resolution setting. If you adjust the Geometry Resolution slider, the number of Reduced Triangles changes.

Scene Controls

Manual Resolution/Automatic Resolution

If Manual Resolution Control is turned on when you export the scene, you’ll see a slider labeled Manual Resolution. This lets you preview the scene at a fixed resolution (Resolution setting).

If Manual Resolution Control is turned off when you export the scene, you’ll see a slider labeled Geometry Reduction. This lets you preview how Shockwave displays your scene at different resolution settings, which sets the speed with which level of detail reduces with distance.

The difference between manual and automatic mode is that in manual mode, if you increase resolution you see the same effect, immediately, no matter where the object is. In automatic mode, Shockwave determines the resolution according to the object’s position. The resolution value in this case is simply an input to Shockwave’s computation—specifically, it controls how fast the resolution decreases as a function of distance. Moving this slider bar to the right always increases the resolution of the geometry.

The value of the slider is not saved with the file—it is for previewing only. You must change the “Resolution” option in the Export Options window and re-export it.

Current Camera

Lets you select a camera from which to preview the scene. If you have created a camera and exported the entire scene, that camera will appear in the pulldown menu.
Animation controls

Use these controls to play the animation in a loop, stop the animation and rewind.

Maya Frame

Displays the Maya frame number for the animation you are playing back.

Export Results

Exported file

Displays the name and location of the exported file. By default, the scene name is used, but you can specify a name in the Export Options window.

By default, Maya stores the W3D file in the wd3 subdirectory of the current project directory. You can change the default location for storing Macromedia Shockwave files (see “To change the default location for storing Macromedia Shockwave files:” on page 28).

Scene manifest file

Displays the name and location of the scene manifest file. The scene manifest file contains the same information you see displayed in the Preview window. It shows how the hierarchy was changed as a result of mesh combinations. It lists all the objects.

The manifest is intended mainly for the Director user who is not also the Maya artist. The artist gives the manifest file and the W3D file to the Lingo programmer. The manifest has the same name as the W3D file, with the further extension .manifest.txt appended (for example, globe.w3d.manifest.txt). Maya saves it in the same directory as the W3D file.

File Statistics

Total file size

Displays the size of your exported W3D file. The percentages in the five categories that follow indicate what proportion of the file is devoted to each of the categories of information. See “File Statistics” on page 36. Totals will not add up to 100% because the file contains a small amount of other information (not under your control) that doesn’t fall into any of these categories.

How big your file can be depends on your application and target audience. If you are targeting people with high-speed DSL connections, you can afford bigger files than if your target audience has 28.8 modems.
Initial load segment (ILS)

Displays the size of the initial load segment, which is the portion of the file that must be downloaded before anything becomes visible. In other words, until the initial load segment downloads, your audience will be viewing the Macromedia logo, which is displayed when Shockwave is invoked. The percentage figure shows the size of the ILS as a proportion of the total file. You should try to make the ILS as small as possible. A smaller ILS helps your scene stream faster when downloaded.

Runtime texture memory usage

This shows how much memory will be required for the textures in your scene. You get the best performance on systems that can put all the textures in the on-board memory of their display boards. This again depends on what level system you are targeting.

Triangle Counts Per Model Resources

Displays the number of triangles for each object in your exported scene.

Texture, Node, Shader, Animation Palettes

Display a list of all the textures, shaders, nodes and animation in the scene. This information is also written to the scene manifest file. A Lingo programmer can use this information to manipulate the contents of a scene. See “Shader names” on page 55 for information on shader names when shading switches are used.

The Maya artist can use the palette as a summary of the contents of the scene, which can be helpful for reducing file size. You want to reuse your assets as much as possible.

Scene Hierarchy

Displays the scene hierarchy information in the exported file. Depending on what export settings you chose, that might not be the same as the Maya hierarchy. If an object is indented in this section, it means it is parented to object listed above it that is not indented.

Common questions about export

Why do I have holes in an object after I export it?

This is probably because some of the polygons in your object are made up of very small triangles. All of the polygons in the scene get triangulated before they are exported. The Shockwave architecture has a minimum triangle size, so the exporter removes triangles that are too small. If this is the problem, you’ll get an output warning saying so.
Try combining some of the smaller polygons into larger polygons. When you combine, avoid extraneous vertices because they can result in small polygons when Shockwave triangulates the surface. Also, if you convert a NURBS surface to a polygon, adjust the tessellation options so there are fewer polygons. For example, set the Format option to Count.

**Why is my scene so dark after I export it? How can I lighten it up?**

- You may have forgotten to add a light to the scene. If there is a light, make sure it is facing toward the objects in the scene. Check the value of the intensity and color.
- For point lights and spot lights, you can increase the Intensity attribute, but for directional lights, you cannot (Shockwave does not support it). You can try changing a directional light to a spot light and move it far away to simulate a directional light.
- For backgrounds, you’ll typically want even lighting, which you could achieve by adding more lights. However, adding too many lights to a scene can result in slower performance in Shockwave. There are two alternatives. You can set the Background Color in the camera attributes. Also, for background objects, change the material’s Incandescence attribute instead of Color. Incandescence controls the self-illumination of an object, so you can avoid using lights. Make sure the Color attribute is black so it doesn’t interfere with the Incandescence attribute.

**How can I achieve the best run-time performance in Shockwave?**

- Avoid using complex models with numerous faces in your scene. Complex models impair performance, and typically don’t run at full resolution. The best way to ensure you have a light model is to create it that way from scratch.
- Avoid using large texture files in your scene. Large texture files impair performance. Most graphics cards can’t render large textures, and will trim the textures anyway. You can use the Maximum File Texture Size option in the Export Options window to reduce the size of the exported textures.
- Reduce the number of nodes in your scene. The Fastest Playback option collapses hierarchies as much as possible to minimize the number of nodes. If your model is made of numerous objects, use Polygons > Combine so there are fewer objects and fewer nodes. (However, do not combine any transparent objects, such as windows,
because they will not appear correctly in Shockwave.) Also, delete construction history when finished with modeling to eliminate all the history nodes.

- If you duplicate objects, leave a duplicate's topology the same as the original. For example, to create a pile of rocks from one rock model, simply vary the location, rotation, and scale of the duplicates. In this case, the exporter treats all the duplicates as instances and writes out the geometry once. If you change a duplicate object's topology, that duplicate counts as another object.

How do I include shadows in my exported scene?
Because Shockwave cannot compute shadows, you must bake them into the materials you have assigned to floors and walls. First create shadows using Depth Map Shadow attributes on one or more lights. Then, select the objects and materials that you want to have shadows and choose Edit > Convert to File Texture in Hypershade.

How do I export single-sided or double-sided geometry?
You can export single-sided or double-sided geometry from Maya to Shockwave. Single-sided geometry displays more quickly because only the side with the normals pointing toward the camera is displayed. In general, you should use single-sided geometry in your scene to increase playback speed. If you need to display both sides of an object, like an open box or a flag, use double-sided geometry.

**To create single-sided or double-sided geometry:**

1. Select the geometry.
2. In the Attribute Editor, display the Render Stats.
3. To create double-sided geometry, turn on Double Sided.
4. To create single-sided geometry, turn off Double Sided.
5. To display the opposite side of single-sided geometry (reverse the normals), turn on Opposite.

Why do rigid body animations look jittery?
With the default export settings, rigid body animations can appear to jitter instead of moving smoothly. To resolve this problem, lower the Animation Compression setting in the export options window. However, lowering this compression increases the file size and download time. Find a compression setting that gives you a balance between smooth play and efficiency.
How do I automatically update Director with a change in Maya?

In Director’s Import Files window, set the Media option at the bottom to “Link to External File.” By importing files as an external link, you can make a change in Maya, export the scene again, and the change will appear in Director when you reopen the Director movie file. Note that Director saves the link with an absolute path, which affects how you’ll publish the movie.

What if the export fails?

• Try using Export Force Rebuild.
• Exit Maya and reload the plug-in. Report the problem by email to maya_sw3d@listserv.aliaswavefront.com.

Customizing Maya Shockwave 3D Exporter

You can customize the exporter by:

• “Adding custom optimization presets”
• “Adding custom error checks”

Adding custom optimization presets

You can create your own custom optimization presets or modify the standard ones provided. To do this, edit the script s3dCreateUI.mel as follows:

1. In the s3dCreateExportOptionBox routine, look for this statement:
   
   ```mel
   optionMenuGrp -l "Presets"
   ```

   The menuItem statements immediately following are the entries in the preset menu. Add new ones or change the existing ones.

2. Edit the s3dPresetCallback routine. This callback is invoked when the user makes a choice from the menu. For each new preset, add a new branch to the existing if-else statement. You can set the values of any UI controls you want. You can also edit the existing presets.

Adding custom error checks

You can add your own custom error checks to the standard ones the exporter runs. To do this, edit the script s3dCreateUI.mel, as follows:

1. In the s3dCustomErrorChecks routine, code your custom error checks using MEL. This routine is invoked after the standard s3dCheck command runs.
2 Append any error strings to the $errors array passed to the routine. These strings are displayed in the Check/Optimize Results window. Note that some of Maya’s standard error checks are performed inside this routine already. Use these as examples of how to write your own.

**Batch exporting**

**To batch export:**

Type the following on a command line:

```
s3dExport <options>
```

For a list of all the options and brief description of what they do, on the command line, type:

```
s3dExport -help
```

You must provide the command with the full path name of the file you want to export to, including the .w3d extension.

The export command returns an array of strings with the results of the export. (When you export from Maya, this information is displayed in the Check/Optimize Results window.) Look for the routine s3dExportAll (in s3dCreateUI.mel) to see how the results of the command are processed.

**Example:**

To export a file called `myfile` using all the default options, type:

```
s3dExport -f "D:/maya/projects/s3dExport/w3d/myFile.w3d" -p -c persp -an -ami 1 -ama 118 -man -al -opc -ofs -osm -do -rdv -sm -eas -mrs -res 1 -hse -hst 75 -gc 0.5 -tc 0.5 -ac 0.5 -ts 256 -pts 256 -pw 640 -ph 480 -useSpecularColor;
```

**To check/optimize:**

Type the following on a command line:

```
s3dCheck <options>
```

For a list of all the options and brief description of what they do, on the command line, type:

```
s3dCheck -help
```

The check command returns an array of strings with all the error information. Look for the routine s3dCheckCallback (in s3dCreateUI.mel) to see how to use this command in your scripts.
2 | Maya Shockwave 3D Exporter

> Batch exporting
How Maya Shaders Export To Shockwave

Shader export to Shockwave

Introduction

| Note | Please note that Maya 3D Shockwave Exporter is available on the Windows platform only. |

Maya Shockwave 3D Exporter tries to duplicate the look of the Maya shader as close as possible in Shockwave. While there may be differences between the software rendered look in Maya and the hardware rendered look in Shockwave, you can try new settings and quickly re-export using Export Express until you get the look you want.

For more information, search the online help for Shading.

Basic shader properties

Maya’s Lambert shader is the simplest shader to export. It includes all the basic material shader information for Shockwave shaders. This information includes color, diffuse, transparency, ambient color, and incandescence.

Color

In the following example, the Color value on the Maya shader is set to red (R = 1, G = 0, B = 0).
3 | How Maya Shaders Export To Shockwave
> Basic shader properties

**Diffuse**

By decreasing the Diffuse value of the shader, the diffuse light that the sphere reflects becomes darker. For example, if you take the same shader seen above and change its Diffuse value to 0.4 you get the following rendering.

**Transparency**

Changing the Transparency value of this same shader makes the object appear less opaque. The smaller sphere in the following image is intersecting the sphere that has transparency.
**Ambient**

The Ambient Color value has a different meaning in Maya than in Shockwave. In Shockwave, the Ambient Color value is the color that is reflected from an ambient light. You must have at least one ambient light in the scene to see the effect of ambient light. If you use a point light instead of an ambient light, the exporter informs you that you need to export an ambient light to see the shader in Shockwave. In the following images, the Ambient Color value is set to blue (R = 0, G = 0, B = 1) and the Color value is set to black. In the first image, the scene uses a point light, but no ambient light. In the second image, the scene uses an ambient light.

![With point light (no ambient light)](image1)

![With ambient light](image2)

**Incandescence**

Incandescence is the self illuminating color of the shader. This value maps to the Emissive attribute in Shockwave. In the following image, the shader has a Color value of black and an Incandescence value of red (R = 1, G = 0, B = 0). The scene does not have a light in it.

The shader can self-illuminate even with no light in the scene (objects without incandescence must have a light to preview in Shockwave). When the Incandescence value is used with a light and a color value, the Incandescence value is added to the color value. In the following image, the shader has a Color value of blue (R = 0, G = 0, B = 1) and an Incandescence value of green (R = 0, G = 1, B = 0).
3 | How Maya Shaders Export To Shockwave

> Texture mapping

Where the light shines on the object the Color value and the Incandescence value are added to show the cyan color. Where the light does not shine, only the Incandescence value is being used because it is being added to black.

Translation of Lambert shader attributes

The exporter translates the Maya Lambert shader attributes to the following Shockwave shader attributes:

<table>
<thead>
<tr>
<th>Maya attribute</th>
<th>Shockwave attribute</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Maya Color x Maya Diffuse)</td>
<td>Diffuse</td>
</tr>
<tr>
<td>(1 - (transparency.r + transparency.g + transparency.b) / 3)</td>
<td>Opacity</td>
</tr>
<tr>
<td>Ambient</td>
<td>Ambient</td>
</tr>
<tr>
<td>Incandescence</td>
<td>Emissive</td>
</tr>
</tbody>
</table>

Texture mapping

If you map a texture to the shader Color or Incandescence attributes, Shockwave uses the texture instead of a color for the attributes.

You can use file textures and the procedural textures provided in Maya (for example, checker, fractal). When you export an object with a shader, the exporter converts each distinct procedural texture mapped to one or more shader attributes to a separate 2D texture (procedural textures upstream of the procedural texture nodes are collapsed into the converted textures). The exporter also creates separate 2D textures for each object that shader is assigned to. This means that several 2D textures could be created for each procedural texture if the shader is assigned to several objects in the scene. The conversion requires each object to have associated...
UV coordinates. The greater the resolution of the 2D texture, the more precise the approximation. Note that the conversion of the procedural textures to 2D textures can slow down your export.

You can also create a very complex shading network that is baked at export time. You can map the following basic shader attributes and see the results in Shockwave: color, incandescence, and transparency.

| Note | You cannot export Fluid Texture 2D. You must convert the fluid texture to an image file and map it back onto the geometry before you export. |

**Color**

When you map Color, Shockwave uses the UV values from the surface to position the texture. The following image shows a sphere with the Color attribute mapped with a file texture.

**Incandescence**

Mapping Incandescence produces a glowing effect. The mapped incandescence texture is visible everywhere on the surface even where it is not lit. Where the surface is lit, the incandescence texture adds to the current value of the sample. The following image has a Color map and an Incandescence map. Notice that the texture is still visible where there is no light.
Assignment of texture maps to Shockwave texture layers

The following table shows which attribute texture maps are assigned to which texture layer in Shockwave.

<table>
<thead>
<tr>
<th>Maya attribute</th>
<th>Shockwave texture layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>1 - Base</td>
</tr>
<tr>
<td>Incandescence</td>
<td>2 - Diffuse</td>
</tr>
<tr>
<td>Reflected color</td>
<td>3 - Reflection</td>
</tr>
</tbody>
</table>

Transparency

By mapping Transparency, you can make parts of the surface transparent. When you map the Transparency, the Luminance values of the map are used as an alpha channel on the color map. The following image has a color texture and a grayscale version of the color texture mapped to the Transparency attribute. Where the alpha values are 1, the surface appears transparent.

Blinn and Phong shaders

Maya’s Blinn and the Phong shaders have the same attributes as the Lambert shader but with additional attributes for specularity and reflection.

Specular Color

Specular Color is the color of the highlight reflected by a light on a surface. Shockwave can handle specular color in two ways: as an RGB value on the material or as a texture. If you use the RGB value to generate the specular highlight, the highlight respects the position of the light and the color of the light. However, the quality of this highlight is very low. If
you generate the highlight as a texture, you can get a very good quality highlight but the map does not respect the color or position of the light. You select which one of these highlights to use in the Export Options window when you export. In the Optimization Options section, select the preset with the balance of speed and quality you want. The following images illustrate the differences between Best Speed/Size and Best Quality.

Non-textured specular highlights have the advantage of being fast to display and don’t require extra space, but they are limited to displaying grayscale rather than color. Textured specular highlights can use any color, and generally look much better (as seen above), but may not be appropriate for animations. The following table summarizes the differences between non-textured and textured highlights.

<table>
<thead>
<tr>
<th></th>
<th>Non-textured highlight</th>
<th>Textured highlight</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Display speed</strong></td>
<td>Faster display speed</td>
<td>Slower display speed</td>
</tr>
<tr>
<td></td>
<td>Doesn’t take any extra space</td>
<td>Takes some texture space</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>Limited to shades of gray</td>
<td>Can be any color</td>
</tr>
<tr>
<td></td>
<td>Respects the light’s color</td>
<td>Doesn’t respect the light’s</td>
</tr>
<tr>
<td></td>
<td>and position</td>
<td>color and position</td>
</tr>
<tr>
<td><strong>Preset to use</strong></td>
<td>Best Speed/Size</td>
<td>Best Quality</td>
</tr>
</tbody>
</table>

On the Phong shader, the Cosine Power attribute defines the size of the highlight. As the value decreases, the size of the highlight increases. In the following image, the Phong shader has a Cosine Power value of 5.0.
On the Blinn shader, the Eccentricity attribute defines the size of the highlight. As the value increases, the size of the highlight increases. In the following image, the Blinn shader has an Eccentricity value of 0.75.

The Blinn shader has another attribute that affects the highlight: Specular Roll Off. This value defines the amount of light reflected by the highlight. As the value decreases, less light reflects from the highlight. The following image has a Blinn shader with a Specular Roll Off value of 0.10.

Reflection
Use the Reflectivity attribute to give the surface the appearance of reflecting its surroundings. By mapping an image, texture, or environment map to the Reflected Color you can create “fake” reflections. The Reflectivity attribute decides how reflective the shader actually is. The smaller the Reflectivity value, the less reflective the shader is.
A reflection map on the following image makes the surface appear very shiny.

![Reflection Map Example](image)

### Shader names

Shader names are written to the exported file the same as in Maya except when Maya Switch Utilities are used to apply different textures to the same shader. If a shading switch is used in the shader, a differentiating string is appended to the name to prevent slightly different shaders from being collapsed into one shader by Shockwave.

This differentiating string consists of the name of the attribute that is textured, followed by a unique texture name. The unique texture name consists of the name of the texture, followed by the name of the shape to which this particular instance of the shader is applied.

We recommend that you always write palettes to the scene manifest file so the Lingo programmer has all the texture names (see “Texture, Shader, Node, and Animation Palettes” on page 37).
3 | How Maya Shaders Export To Shockwave
> Shader names
Index

A
Advanced Export Options 34
Ambient shader attribute 47
animation and export 23
Animation Compression option 30
Animation controls 40
Animation option 23
Automatic Geometry Reduction for Preview option 31
Automatic Resolution 39
Automatic Smoothing During Reduction option 32

B
Balance Speed/Size and Quality preset 29
Basic Export Options 28
batch exporting 45
Best Quality
  Material Highlights option 34
  optimization preset 29, 52
Best Speed
  Material Highlights option 34
  Best Speed/Size preset 29, 52
bind skin for export 25
Blinn shaders 52

C
Camera For Previewing option 33
camera view 38
Cameras option 23
cancelling
  check 22
Check All command 22
Check Selected command 22
Check Unsupported Features option 34
check/optimize options 23
checking 3D content 22
clips 24
Collapse Hierarchies option 30
Color shader attribute 47
compression
  animation 30
  geometry 29
texture 30
constraints 23
Cosine Power shader attribute 53
Current Camera 39
customizing
  error checks 44
  optimization presets 44

d
Diffuse shader attribute 47
Director and RTA 21
Display Export Results option 35
double-sided geometry 43
Download (Streaming) options 29

E
Eccentricity shader attribute 54
Emissive shader attribute 50
Error Checks by Category options 23
error checks, customizing 44
Export All Lights option 34
Export Animation 34
Export Force Rebuild commands 26, 28
Export Shaders Assigned to Selected Objects option 34
Export Smoothing Data option 30
Export Warnings 36
exporting
  batch 45
  express 26
  options 28
  preparing content 22
  preview 37
  rebuild export database 28
  expressions 23

Maya 3D Shockwave Exporter 57
Index

F
Fastest Export option ............................................. 30
Fastest Playback option ........................................... 30
File Statistics option .............................................. 36
file textures .......................................................... 50
forward kinematics export ...................................... 23
frame number ........................................................ 40

G
geometry
  single- or double-sided .......................................... 43
Geometry Compression option ................................... 29
Geometry option .................................................... 23

H
Hard/Soft Edge Threshold option .............................. 32
highlights .............................................................. 52

I
ignored polygons ..................................................... 35
Incandescence shader attribute ................................ 47
Interaction Data .................................................... 36
interrupting
  check ................................................................. 22
inverse kinematics export ....................................... 23

J
joints and export ..................................................... 25
JPEG compression .................................................. 30

K
keys ................................................................. 23

L
Lambert shader ...................................................... 47
  Shockwave 3D attributes ...................................... 50
  level-of-detail .................................................... 37
  Lights option ..................................................... 37
  loading Maya 3D Shockwave Exporter .................... 21
  LOD ................................................................. 37

M
Macromedia Shockwave 3D File option ..................... 28
manifest file ........................................................ 35
Manual Resolution ................................................ 39
Manual Resolution Control ..................................... 31
mapping ............................................................... 50
Material Highlights option ...................................... 34
Maximum File Texture Size option .......................... 30
Maya Frame ........................................................ 40
Model Resource Palette and Triangle Counts option ...... 36
motion paths ........................................................ 23
MRM (multi-resolution mesh) ................................. 37

O
optimization ........................................................ 22
opt Options .......................................................... 29
presets .................................................................. 29
presets, customizing .............................................. 44
options
  check/optimize ................................................... 23
  exporting ............................................................ 28
Output Options ..................................................... 35

P
Palettes
  outputting .......................................................... 37
Phong shaders ....................................................... 52
Playback Speed options ......................................... 30
plug-in, loading .................................................... 21
Points ................................................................. 38
polygons, ignored .................................................. 35
Presets
  optimization ....................................................... 44
  option .............................................................. 29
Index

Maya 3D Shockwave Exporter
60