Subdivision Surface Modeling

Version 6
# Table of contents

## 1 Background ................................. 7

About
- Subdivision surfaces ........................................ 7
- Subdivision surfaces ........................................ 7
- Standard mode and polygon proxy mode ................. 8
- Basic subdivision surface modeling workflow .......... 9

## 2 Converting to subdivision surfaces ............... 11

How do I?
- Create and edit models .................................... 11
- Convert geometry from one type to another .......... 11
- Prepare polygons for conversion to a subdivision surface .......... 11
- Prepare a NURBS surface for conversion to a subdivision surface .......... 13
- Convert a NURBS or polygonal surface to a subdivision surface .......... 14
- Convert a subdivision surface to polygons .......... 14
- Convert a subdivision surface to NURBS .......... 16

Reference
- Menus ....................................................... 17
- Modify ....................................................... 17
- Modify > Convert > NURBS to Subdiv, Polygons to Subdiv .......... 17
- Modify > Convert > Subdiv to Polygons .......... 18
- Modify > Convert > Subdiv to NURBS .......... 20

## 3 Editing subdivision surfaces ...................... 21

How do I?
- Create and edit models .................................... 21
- Reshape subdivision surfaces ......................... 21
- Use transformation tools with subdivision surface components .......... 21
- Increase performance while reshaping subdivision surfaces .......... 21
- Create a new level to increase available control points in a region .......... 22
- Switch to a different subdivision level ................... 23
- Add or remove a crease ................................... 25
- Reshape a subdivision surface using polygon tools .......... 26
- Reshape a subdivision surface using Soft Modification .......... 27

Create and edit models ................................. 28
Combining or splitting subdivision surfaces .......... 28

Subdivision Surface Modeling 3
Table of Contents

Attach subdivision surfaces ........................................ 28

**Clean up subdivision surfaces** .............................. 29
Reduce the number of levels in a subdivision surface .... 29
Make subdivision surfaces more efficient ..................... 30

Reference

**Menus** ................................................................. 31

**Modeling menu set.** .............................................. 31

**Subdiv Surfaces** ................................................... 31

Subdiv Surfaces > Attach ......................................... 31
Subdiv Surfaces > Collapse Hierarchy ......................... 32
Subdiv Surfaces > Mirror ......................................... 32
Subdiv Surfaces > Match Topology ............................... 33

4  **Mapping and editing UVs.** .................................. 35

About **Subdivision surfaces** .................................... 35
UVs ................................................................. 35
Mapping ............................................................ 36
Guidelines for UV arrangement .................................. 36

How do I? **Apply colors, shading, and textures** .............. 37

**Map UVs to subdivision surfaces.** ......................... 37
Edit UVs in Polygon Proxy Mode ............................... 37
Map UVs onto a subdivision surface ......................... 38
Edit subdivision surface UVs .................................... 41

Reference

**Menus** ................................................................. 42

**Modeling menu set.** .............................................. 42

**Subdiv Surfaces** ................................................... 42
Subdiv Surfaces > Texture > Planar Mapping ............... 42
Subdiv Surfaces > Texture > Automatic Mapping .......... 44
Subdiv Surfaces > Texture > Layout UVs .................... 46

5  **Tips for working with subdivision surfaces.** ............ 49

About **Tips** ............................................................ 49

**Character setup** ................................................. 49
Bind subdivision surfaces to skeletons ...................... 49
Apply a deformer to a subdivision surface. ......................... 49

**Rendering** ............................................................... 51

Render subdivision surfaces ........................................ 51
1 Background

About Subdivision surfaces

Subdivision surfaces

Modeling with subdivision surfaces is an easy way to create intricate objects such as human hands. It combines the best features of NURBS and polygonal modeling.

Subdivision surfaces allow you to use a single surface to model complex shapes. A single subdivision surface can have different levels of detail in different regions. That is, a region that has a complex shape can have more control points to allow finer detail, while a simple or flat region needs fewer control points.

How it works

Subdivision surfaces get their name from this dividing into regions of greater detail. You start with a base mesh and divide and subdivide regions into finer and finer detail, with each subdivision giving greater control in that area.

You reshape subdivision surfaces by modifying control points at the different levels of the hierarchy. The base mesh (or “level 0” mesh) allows you to reshape large areas of the overall surface. The subdivided levels allow finer control in specific regions of the surface.

Advantages

• Subdivision surfaces allow higher level control over shape than polygons.
• They allow you to only use complex geometry in the complex regions of your model.
• They allow creases (sharp edges) and arbitrary topology (not just four-sided sheets).
• The continuity of subdivision surfaces eliminates many of the problems that can occur at seams when you animate NURBS surfaces.
• You can bind subdivision surfaces to skeletons at a coarse level and the effects will translate smoothly to the finer levels.
Standard mode and polygon proxy mode

Standard mode

In Standard mode, you can increase the number of components (refine areas) where you need more detail in your model. You can then manipulate components (move, rotate, or scale) and keyframe the changes. You can also crease edges and vertices.

You can switch to this mode from the Polygon Proxy mode at any stage of modeling. When you switch to Standard mode, Maya deletes any extrude, deformation, or other construction history you’ve created while in Polygon Proxy mode.

In Standard mode, the components are segregated into different levels. Level 0 is the coarsest level, also called the base mesh. Level 1 and higher are finer levels, where you can create finer details on the model.

Polygon proxy mode

Switching to Polygon Proxy mode creates a polygon that matches the base mesh (level 0) of the subdivision surface. This polygon object is only temporary; Maya deletes it when you switch back to Standard mode.

In Polygon Proxy mode, you can use polygon tools and functions to indirectly modify the base mesh (level 0) of the subdivision surface. For example, if you create a model in Standard mode and then decide you need to extrude or delete a face, you can switch to the Polygon Proxy mode, extrude or delete the face, then return to Standard mode. The Standard mode edits are maintained, unless they overlap the affected face.
You can switch to Polygon Proxy mode at any stage of modeling. However, if you’ve used deformers or created other construction history while in Standard mode, you cannot switch to Polygon Proxy mode until you delete construction history. Delete construction history on the object with Edit > Delete by Type > History, and then switch to Polygon Proxy mode.

Basic subdivision surface modeling workflow

Create a rough, minimum polygon mesh that captures the basic shape of the model you want to build. This model will determine the base topology and control points of the subdivision surface when you convert it. Subdivision surfaces are very effective at creasing and refining edges so you don’t need to put a lot of effort into capturing those types of features in the polygon mesh.

You can use Polygons > Smooth Proxy to get an idea of how the rough polygon model will convert to a subdivision surface as you work on it. You can also convert to subdivision surface to check the conversion and then undo back to the polygon model.

After you convert the polygon mesh to a subdivision surface, tweak the shape of the subdivision surface by pushing and pulling control points. Where you find you need more control or sharp shape changes, create a new level. Switch back to polygon proxy mode to make topological changes to the surface (for example, splitting a face).

Related topics

- “Standard mode and polygon proxy mode” on page 8
- “Prepare polygons for conversion to a subdivision surface” on page 11
- “Use transformation tools with subdivision surface components” on page 21
- “Increase performance while reshaping subdivision surfaces” on page 21
- “Add or remove a crease” on page 25
<table>
<thead>
<tr>
<th>Background</th>
</tr>
</thead>
<tbody>
<tr>
<td>About &gt; Basic subdivision surface modeling workflow</td>
</tr>
</tbody>
</table>

- “Reshape a subdivision surface using polygon tools” on page 26
How do I? > Prepare polygons for conversion to a subdivision surface

2 Converting to subdivision surfaces

How do I? Create and edit models

Convert geometry from one type to another

Prepare polygons for conversion to a subdivision surface

A common way to start a subdivision surface is to create a simple “rough sketch” of the shape with polygons and convert that to the base mesh of a subdivision surface. Keep the following in mind when you create a polygon mesh.

When you are ready to convert a polygon mesh to a subdivision surface, see “Convert a NURBS or polygonal surface to a subdivision surface” on page 14.

Start with as few faces as possible

A dense subdivision base mesh wastes control points and will reduce performance.

If you want to convert an existing mesh, try using Polygons > Reduce to reduce the number of faces in the mesh.

Use mostly 4-sided polygons (quads)

While subdivision surfaces can handle up to 256 sided polygons, you will get best results from using mostly 4-sided polygons.

When modeling subdivision surfaces, try to avoid faces with more or less than 4 sides, and vertices with more or less than 4 adjacent faces.

When a face or patch on the original surface is not 4-sided, an extraordinary vertex (a vertex with less than or more than 4 adjacent faces) is created at level 0 of the subdivision surface. This affects the
Converting to subdivision surfaces

How do I? > Prepare polygons for conversion to a subdivision surface

Parameterization of the subdivision surface and might make the surface bumpy (the bigger the quads relative to the model, the less this is a problem).

Put vertices and edges in the polygon mesh where you want them in the subdivision surface

If you can plan out where you want vertices and edges in the model, it will help you produce the results you want when modeling and binding the surface to joints.

For example, edges must be present where you want to create a partial or full crease, and as with polygonal and NURBS surfaces, edges should circle the eyes and mouth on the model of a head.

Watch out for polygons that will not convert

You cannot create subdivision surfaces from the following types of polygonal surfaces.

- Nonuniform topology.

Use Polygons > Cleanup to correct nonmanifold geometry.

- Lamina topology (faces are on top of each other sharing more than two vertices or more than one edge).

Use Polygons > Cleanup to correct lamina geometry.

- Free points or floating edges.

- Interior vertices with two incident edges.

- Inconsistent normals.
2 | Converting to subdivision surfaces

How do I? > Prepare a NURBS surface for conversion to a subdivision surface

One way to correct inconsistent normals is to use Edit Polygons > Normals > Conform.

Related topics
- “Prepare a NURBS surface for conversion to a subdivision surface” on page 13
- “Convert a NURBS or polygonal surface to a subdivision surface” on page 14

Prepare a NURBS surface for conversion to a subdivision surface

When you are ready to convert a NURBS surface to a subdivision surface, see “Convert a NURBS or polygonal surface to a subdivision surface” on page 14.

Watch out for NURBS properties that will not convert

If you create subdivision surfaces from the following types of NURBS surfaces, you may get unexpected results.

- Degrees other than 3 (cubic) will not convert.
- Rational geometry (weighted CVs) is ignored.
- Trims are ignored.

Consider converting to a polygon mesh first

A subdivision base mesh created from NURBS will probably be too dense, and NURBS models are typically made of different surfaces that must be converted individually and then attached.

By using Modify > Convert > NURBS to Polygons first, you can reduce and attach the polygon mesh before converting to a subdivision surface.

Use the following options with Modify > Convert > NURBS to Polygons > □ to convert NURBS surfaces to a polygon mesh suitable for use as a subdivision base mesh:

- Set Type to Quads.
- See Tessellation Method to General.
- Set U Type and V Type to Per Surf # of Isoparms in 3D.
- In the Number U and Number V boxes, try to find the lowest numbers that roughly approximate the shape of the surface.
2 | Converting to subdivision surfaces
How do I? > Convert a NURBS or polygonal surface to a subdivision surface

If you converted multiple NURBS surfaces, use Polygons > Combine to merge them into a single polygon mesh. Then use Edit Polygons > Merge Multiple Edges or Edit Polygons > Merge Edge Tool to merge internal border edges. To show border edges clearly, choose Display > Custom Polygon Display and turn on Border Edges.

Related topics
- “Prepare polygons for conversion to a subdivision surface” on page 11
- “Convert a NURBS or polygonal surface to a subdivision surface” on page 14

Convert a NURBS or polygonal surface to a subdivision surface

Convert an existing surface to a subdivision surface

1. Select a NURBS or polygonal surface.
2. Choose Modify > Convert > NURBS to Subdiv or Modify > Convert > Polygons to Subdiv.

What if...?

My polygon mesh will not convert or results in a hard-to-use subdivision surface?
- “Prepare polygons for conversion to a subdivision surface” on page 11

My NURBS surface will not convert or results in a hard-to-use subdivision surface?
- “Prepare a NURBS surface for conversion to a subdivision surface” on page 13
- “Convert a subdivision surface to polygons” on page 14
- “Convert a subdivision surface to NURBS” on page 16
- “Modify > Convert > NURBS to Subdiv, Polygons to Subdiv” on page 17

Convert a subdivision surface to polygons

Although you can use subdivision surfaces up to the completion of your project, you may need to convert them to polygons after you have finished modeling. For example, if you’re creating characters for a game, the game engine often requires the models to be polygons.

Maya offers two ways to convert subdivision surfaces to polygons:
2 | Converting to subdivision surfaces
How do I? > Convert a subdivision surface to polygons

- Tessellating creates a polygon surface that matches the contours of the subdivision surface.
- Extracting vertices creates a simpler, less dense polygon that matches the control vertices, not the contours, of the subdivision surface.

![Subdivision surface](image1)
![Tessellated surface](image2)
![Extracted polygon](image3)

Subdivision surface at level 2.
Tessellated surface. Polygon surface corresponds with subdivision surface.
Extracted polygon at level 2. Vertices correspond with subdivision surface vertices.

To convert to a close approximation of your subdivision surface

1. Select the subdivision surface and choose Modify > Convert > Subdiv to Polygons > .
2. Make sure Vertices is not on.
3. Click Convert.

If the subdivision surface you tessellate has creases, the polygon edges that result at the creases are not automatically made hard.

Convert to a rough approximation of the subdivision surface by matching vertices

For example, you can create a polygon mesh that can be converted to another subdivision surface with the same shape as the original.

1. Select the subdivision surface and choose Modify > Convert > Subdiv to Polygons > .
2. Click Vertices and choose which level you want to use the vertices from.
3. Click Convert.
2 | Converting to subdivision surfaces
How do I? > Convert a subdivision surface to NURBS

Related topics
- “Convert a NURBS or polygonal surface to a subdivision surface” on page 14
- “Convert a subdivision surface to NURBS” on page 16
- “Modify > Convert > Subdiv to Polygons” on page 18

Convert a subdivision surface to NURBS
Select the subdivision surface and choose Modify > Convert > Subdiv to NURBS.
Maya creates NURBS surfaces corresponding to the subdivision surface and groups them.

To manipulate the resulting group of NURBS surfaces
- Use Edit NURBS > Stitch > Global Stitch.

Stitching makes the patches deform as one surface, but the patches are still regarded as separate surfaces when you assign materials. You can also use the other stitching operations under the Stitch submenu.
2 | Converting to subdivision surfaces

Reference > Modify > Convert > NURBS to Subdiv, Polygons to Subdiv

- Use **Edit NURBS > Attach Surfaces**.
  Attaching creates a new continuous surface and is regarded as one surface when you assign materials. You must apply Attach Surface repeatedly, one patch at a time. Be aware that the order you attach patches affects the placement of any textures you might apply to the surface.

**Notes**

- The Subdiv to NURBS conversion does not convert the UVs of the subdivision surface.
- When a shader is assigned to a subdivision surface and the Subdiv to NURBS operation is applied, the shaders are not transferred to the resulting surface.

**Related topics**

- “Convert a NURBS or polygonal surface to a subdivision surface” on page 14
- “Convert a subdivision surface to polygons” on page 14
- “Modify > Convert > Subdiv to NURBS” on page 20

**Reference Menus**

**Modify**

Modify > Convert > NURBS to Subdiv, Polygons to Subdiv

Both conversion operations (NURBS to Subdiv and Polygons to Subdiv) have the same options in the options window.

**Maximum Base Mesh Faces**

Set the maximum number of faces the original surface can have to successfully convert it to a subdivision surface.

For example, if the original surface has 900 faces and the Maximum Base Mesh Faces value is 1000, the conversion will succeed, but if the surface has 1200 faces, the conversion will fail.

Depending on the complexity of the original object, the resulting surface may be represented with fewer faces.
Subdivision Surface Modeling

2 | Converting to subdivision surfaces
Reference > Modify > Convert > Subdiv to Polygons

Maximum Edges Per Vertex
Set the maximum number of edges each vertex in the original surface can have to successfully convert it to a subdivision surface.

Keep Original
Keeps the original object when creating the subdivision surface. When Keep Original is turned on, you can select the initial editing mode for the subdivision surface. When this option is off, the original object is replaced by the subdivision surface.

Subdivision Surface Mode
These options are available only when Keep Original is turned on. Select the initial editing mode for the subdivision surface.

Hotkeys

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>'</code> (left single quote beside the 1 key)</td>
<td>Turns on/off the display of the original surface or the converted subdiv surface.</td>
</tr>
<tr>
<td>Shift + `'</td>
<td>Displays both the original surface and the converted subdiv surface.</td>
</tr>
</tbody>
</table>
| Alt + `' | If a NURBS surface is selected: Modify > Convert > NURBS to Subdiv  
If a polygonal surface is selected: Modify > Convert > Polygons to Subdiv |
| Alt + Shift + `' | If a NURBS surface is selected: Modify > Convert > NURBS to Subdiv > ☐  
If a polygonal surface is selected: Modify > Convert > Polygons to Subdiv > ☐ |
| Page Up | Increases the Display Level of the subdiv surface (when in subdivision surface standard mode). |
| Page Down | Decreases the Display Level of the subdiv surface (when in subdivision surface standard mode). |

Modify > Convert > Subdiv to Polygons

Tessellation Method
Select one of the following tessellation methods.
### Converting to subdivision surfaces

Reference > Modify > Convert > Subdiv to Polygons

<table>
<thead>
<tr>
<th>Uniform</th>
<th>Uniform tessellation produces a polygon with an equal number of faces for each of the subdivision surface’s base mesh faces (faces at level 0).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Poly Count</td>
<td>Polygon Count is the same method as Uniform, but with a threshold value beyond which the conversion fails. Use Maximum Number of Polygons to set this value. The resulting polygon will have at most this many polygons, but there is no guarantee that the number will be exact.</td>
</tr>
<tr>
<td>Adaptive</td>
<td>Adaptive tessellation produces a polygon with an equal number of faces for each of the finest level faces on the subdivision surface. The more refinement you’ve made to a region of the subdivision surface, the more faces the resulting polygon will have for that same region. Use Divisions Per Face to control the number of faces produced for each finest level face.</td>
</tr>
<tr>
<td>Vertices</td>
<td>Produces a polygon that matches the vertices on the subdivision surface. The polygon matches vertices to the level specified in the Level option.</td>
</tr>
</tbody>
</table>

#### Level

If you are using the Uniform option, set the level to determine how many faces are to be used in the tessellation. For example, if Level is 3, the faces at level 3 are used in the tessellation.

#### Divisions Per Face

Specify how many times each face should be divided when performing a Uniform or Adaptive tessellation. Increasing this value smooths the polygonal surface.

#### Maximum Number of Polygons

Sets the threshold number of polygons used by Polygon Count tessellation.

#### Original Object

Select what you want done with the original selected object after tessellation. Use the Original Object settings to maintain a form of construction history, as these override the global construction history settings.

| Replace | The subdivision surface is deleted when the polygonal surface is created. This is the default. |
2 | Converting to subdivision surfaces

Reference > Modify > Convert > Subdiv to NURBS

Hide
Hide keeps the subdivision surface, but hides it when the polygonal surface is created. The source object can be viewed in the Hypergraph and Outliner (select Input and Output Connections), and made visible in the modeling view by using Display > Show > Show Selection or All.

Show
Show keeps the subdivision surface and keeps it visible in the modeling view.

Share UVs
With this option turned on, the resulting polygon will maintain existing UV mesh borders. If this option is off, UV borders are created for each polygonal face.

Modify > Convert > Subdiv to NURBS

Original Object
Specifies what happens to the source object after conversion.

Replace
Deletes the original object, leaving only the original transform node. To maintain the scene hierarchy, Maya keeps the original transform node and makes the resulting NURBS patches children of it.

Hide and Show
These options keep the original object. If you have construction history turned on, you can still edit the original subdivision surface to change the resulting NURBS patches. With Hide, the original is hidden from view. If you later want to display and edit the original, select it in the Outliner and choose Display > Show > Show Selection.

Output Type
Instead of NURBS, you can choose to create a Bezier surface by turning on the Bezier option. You can export Bezier surfaces for use with some game engines.

If you perform operations from the Edit NURBS menu, such as inserting an isoparm, the surface will switch from Bezier to NURBS. To switch back to Bezier, use Edit NURBS > Rebuild Surfaces.
3 Editing subdivision surfaces

How do I? Create and edit models

Reshape subdivision surfaces

Use transformation tools with subdivision surface components

Keep the following in mind when transforming subdivision surface components.

- Use the Modify > Transformation Tools > Move Normal Tool on individual vertices one at time. Adjacent vertices on a subdivision surface may not have common UV directions.
- For best results, make large scale changes at coarser (lower-numbered) levels and small-scale changes at finer levels.
- To line up vertices, rotate an edge in the camera plane while approximating it to be tangent to the surface.
- To remove standard mode edits (transformations) on a vertex, select the vertex and press the Delete key. This does not actually remove the vertex, but moves it back to its original position.

Increase performance while reshaping subdivision surfaces

To improve interactive performance with subdivision surfaces, follow these tips:

- Edit components in Standard mode rather than Polygon Proxy mode.
- Keep the base mesh (level 0) simple. Add all detail by creating finer levels.
- While modeling, turn off the creation of UVs (No UVs on Subd option on the polyToSubd node) to improve performance.
3 | Editing subdivision surfaces
How do I? > Create a new level to increase available control points in a region

- If you’re making a number of tweaks to control points at once, you can set the node’s state to Blocking to prevent updates, make the changes, then set the node’s state back to Normal so the surface recalculates all at once.
- Use the Clean Topology operation to remove components that were created but not edited. See “Make subdivision surfaces more efficient” on page 30.
- When binding a skeleton to a model, bind to a coarse level, such as level 0 or 1. See “Bind subdivision surfaces to skeletons” on page 49.

Related topics
❖ “Create a new level to increase available control points in a region” on page 22
❖ “Reduce the number of levels in a subdivision surface” on page 29
❖ “Make subdivision surfaces more efficient” on page 30

Create a new level to increase available control points in a region

Subdivision surfaces allow you to have different levels of detail in different regions of the same surface. Increasing the number of available control points (and the level of detail possible) in a region is called refining.

While you can refine to 13 (0 to 12) levels of detail, try to only go to a finer level when you cannot achieve the shape using coarser level vertices. Editing at levels 3 and higher increases the complexity and decreases performance.

To refine a region
1. Select one or more components where you want more detail.
2. Select Subdiv Surfaces > Refine Selected Components.
A level of refinement is added to the subdivision surface. Each time you refine, a new level is added.

**To expand a refined region**

After refining an area, you can spread the level of refinement to adjacent areas. In the following example the center vertex is selected and expanded.

1. Select one or more components in the area you want more detail.
2. Select **Subdiv Surfaces > Expand Selected Components** to spread the level of refinement to adjacent areas.

**What if...?**

**I want to undo a refinement?**

You cannot undo a refinement. However, you can use **Subdiv Surfaces > Clean Topology** to remove refined components that you created but did not edit.

**Related topics**

- "Switch to a different subdivision level” on page 23
- "Reshape a subdivision surface using polygon tools” on page 26
- "Reduce the number of levels in a subdivision surface” on page 29

**Switch to a different subdivision level**

There are several ways to switch to editing a different level of refinement on a subdivision surface.
### How do I? > Switch to a different subdivision level

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Edit a specific level. | Press the right mouse button on the subdivision surface and choose Display Level, then the level you want to edit.  
or  
In the attribute editor for the subdivision surface (the shape node), open the Subdiv Surface Display section and set the Display Level attribute. |
| Edit the next finer (higher numbered) level from the current level. | Press the right mouse button on the subdivision surface and choose Finer.  
or  
Choose Subdiv Surfaces > Component Display Level > Finer. |
| Edit the next finer level, creating a refinement if a finer level does not already exist. | Select components on the subdivision surface and press Ctrl + Down. |
| Edit the next courser (lower numbered) level from the current level. | Press the right mouse button on the subdivision surface and choose Courser.  
or  
Choose Subdiv Surfaces > Component Display Level > Courser.  
or  
Select components on the subdivision surface and press Ctrl + Up. |
Add or remove a crease

A full crease is a hard or sharp edge created at the selected edges, or a sharp point created at the selected vertex. The surface moves very close or exactly to the edge or vertex to form the crease.

A partial crease moves the surface closer to the selected edges or vertices without ever reaching them. Partial creasing is useful when you want a softer edge effect, such as at the edge of a character’s lips.

Maya displays creased edges as dashed lines to help you identify which edges have been creased.
3 | Editing subdivision surfaces
How do I? > Reshape a subdivision surface using polygon tools

To... | Do this
--- | ---
Create a full crease. | Select the edge or vertices where you want the crease and choose **Subdiv Surfaces > Full Crease Edge/Vertex.**

Create a partial crease. | Select the edge or vertices where you want the crease and choose **Subdiv Surfaces > Partial Crease Edge/Vertex.**

Remove a crease. | Select the edge or vertices with the crease and choose **Subdiv Surfaces > Uncrease Edge/Vertex.**

Related topics

- **“Reshape a subdivision surface using polygon tools”** on page 26

Reshape a subdivision surface using polygon tools

In addition to working on a subdivision surface as a subdivision surface (“standard mode”), Maya lets you work on a subdivision level as if it were a polygon mesh by creating a proxy mesh for you to edit (“polygon proxy mode”). This lets you use the full power of the polygon editing tools to reshape your subdivision surface.

<table>
<thead>
<tr>
<th>Surface in Standard mode.</th>
<th>Same surface in Polygon Proxy mode.</th>
<th>Face deleted and another extruded on polygon proxy.</th>
<th>Edited surface in Standard mode.</th>
</tr>
</thead>
</table>

To... | Do this
--- | ---
Switch to polygon proxy mode. | Choose **Subdiv Surfaces > Polygon Proxy Mode.** Maya creates polygonal mesh proxy from the current subdivision level. Use the polygon tools to edit the proxy.
3 | Editing subdivision surfaces

How do I? > Reshape a subdivision surface using Soft Modification

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch back to standard mode.</td>
<td>Choose Subdiv Surfaces &gt; Standard Mode.</td>
</tr>
<tr>
<td></td>
<td>Maya applies changes you made to the proxy to the subdivision surface.</td>
</tr>
</tbody>
</table>

Notes

- The proxy mesh has no shading so you can see the resulting subdivision surface.
- Boolean, Bevel, and Reduce operations will not maintain standard mode edits.
- Some polygonal operations (for example, Combine) create a new polygonal surface which has no subdivision surface associated with it. You will have to create a new subdivision surface from the resulting polygonal surface.
- Some polygonal operations modify your Standard mode edits. For example, when subdividing a face in polygon proxy mode, the original standard mode edits are copied onto each of the new faces. Edits and creases away from the modified area are not affected.
- Avoid changing the topology, such as subdividing a face, in areas where you’ve edited components in Standard mode. Doing this can alter the surface in unexpected ways. This is not a problem for edits to level 0 components, only at finer levels.

What if...?

I can’t switch to polygon proxy mode?

If you’ve used deformers, mapped UVs with history, or created other construction history while in Standard mode, you cannot switch to Polygon Proxy mode.

First delete construction history on the object (Edit > Delete by Type > History), then try switching to Polygon Proxy mode.

Reshape a subdivision surface using Soft Modification

See Use the Soft Modification Tool in the Character Setup book.

Related topics

- Soft Modification tool

Subdivision Surface Modeling

27
Subdivision Surface Modeling

3 | Editing subdivision surfaces
How do I? > Attach subdivision surfaces

- Deform > Soft Modification
- Use the Soft Modification Tool

Create and edit models

Combine or split subdivision surfaces

Attach subdivision surfaces

The edges of the surfaces will attach only if each surface has the same number of polygonal edges at the base mesh level (level 0). If the surface does not have the same number of edges, the objects are grouped, but the vertices and edges of the surfaces do not merge.

Before Attach

After Attach

Attaching will destroy any deformer weighting on the selected surfaces.

To prepare subdivision surfaces to be attached

- Make sure the two surfaces you want to attach each have the same number of polygonal edges at the base mesh (level 0). If they do not have the same number of edges, the surfaces will be grouped, but will not merge.

  Use Split Polygon or Delete Edge on the polygon proxy to create or remove edges.

- Switch to Standard mode if you are not already in it (Subdiv Surfaces > Standard Mode).
How do I? > Reduce the number of levels in a subdivision surface

- If you are merging mirrored surfaces, delete the history on the mirror copy.
- **Subdiv Surfaces > Attach** requires surfaces with consistently oriented normals.
  If one of the surfaces you wish to attach has its normals facing the wrong direction, **Edit > Duplicate** it, **Subdiv Surfaces > Mirror** it in the opposite direction, and then **Modify > Freeze Transformations** on the mirrored object.

To attach subdivision surfaces
1. Select the surfaces you want to attach.
2. Select **Subdiv Surfaces > Attach**.

Notes
- The edges of the surfaces will attach only if each surface has the same number of polygonal edges at the base mesh level (level 0).
  If the surface does not have the same number of edges, the objects are grouped, but the vertices and edges of the surfaces do not merge.
- Attaching will destroy any deformers weighting on the selected surfaces.

Related topics
- “Subdiv Surfaces > Attach” on page 31

Clean up subdivision surfaces

Reduce the number of levels in a subdivision surface

You can remove a number of levels from a subdivision surface. This keeps the shape of the surface, but moves edits from finer levels to coarser levels, making the coarser levels more dense.

You may want to do this, for example, to make a topology change to a finer level face, such as using the **Edit Polygons > Split Polygon Tool**. Topology changes can only be made on a level 0 face, so you would collapse the finer level to level 0, then switch to Polygon Proxy mode, and make the edit there.

To collapse levels
1. Select the subdivision surface.
2. Choose **Subdiv Surfaces > Collapse Hierarchy > □**.
Subdivision Surface Modeling

3 | Editing subdivision surfaces

How do I? > Make subdivision surfaces more efficient

3 Set the number of levels to collapse.
   For example, if you collapse two levels, previous level 2 vertices become level 0 vertices, level 3 vertices become level 1 vertices, and so on.

4 Click Collapse.

Related topics

- “Create a new level to increase available control points in a region” on page 22
- “Make subdivision surfaces more efficient” on page 30
- “Subdiv Surfaces > Collapse Hierarchy” on page 32

Make subdivision surfaces more efficient

You can use this action at any time to remove components that were created but not used. Removing the extra, unused components makes Maya faster and helps to reduce file size.

To make subdivision surface models as efficient as possible

Choose Subdiv Surfaces > Clean Topology.

For example, you may have refined some faces, but moved only a few of the vertices created by the refinement. In this case, Clean Topology would remove the vertices you did not transform.

Notes

- Clean Topology only removes a component if it meets all three of the following requirements:
  - No edits to the position of the component
  - No mapping or edits to the UV associated with a vertex
  - No crease applied to the vertices or edges
There may be some vertices that Clean Topology cannot remove, even
if they meet these requirements, because the vertices are required for
surface topology.

- If you use **Subdiv Surfaces > Clean Topology** after creating a Blend
  Shape or other deformation, you might get areas on the surface that
  have no UVs. These areas are the result of vertices created when you
  weight the deformer while the Clean Topology node still exists in
  construction history.

  Avoid using Clean Topology after creating deformers. Also delete
  history after using Clean Topology so that it does not interfere with
  the creation of deformers.

**Related topics**

- “Reduce the number of levels in a subdivision surface” on page 29
- “Increase performance while reshaping subdivision surfaces” on
  page 21

**Reference Menus**

**Modeling menu set**

**Subdiv Surfaces**

**Subdiv Surfaces > Attach**

Merges two subdivision surfaces to create a new subdivision surface.

**Related topics**

- “Attach subdivision surfaces” on page 28

**Subdiv Surfaces > Attach > □**

**Merge UVs Also**

Merges the UVs shared by the edges that you attach. If turned off, the
UVs are not merged and can be manipulated and edited independent
of each other.
Threshold

Any vertices further apart than this distance will not be attached. Set this value carefully. If it’s too small, no vertices will attach. If it’s too large, the operation may attach vertices that you do not want attached.

Keep Originals

Controls whether Maya keeps the original surfaces you are attaching.

Subdiv Surfaces > Collapse Hierarchy

Set the number of levels to collapse and click Collapse or Apply. For example, if you enter 2, level 2 edits become level 0 edits.

Related topics

- “Reduce the number of levels in a subdivision surface” on page 29

Subdiv Surfaces > Mirror

Turn on the axes you want to mirror the surface along and click Mirror or Apply. By default, Maya duplicates and flips the surface along the X axis.

If you transform the surface and then freeze the transformation (Modify > Freeze Transformation) before mirroring, the surfaces will mirror relative to the axis of choice.

If you intend to merge surfaces after mirroring them, line up the original surface to the origin, freeze the transform, then perform the mirror.
Subdiv Surfaces > Match Topology

Match Topology works in conjunction with Deform > Create Blend Shape. Ordinarily, you do not need to run Match Topology, because the blend shape operation does it automatically.

Match Topology prepares multiple subdivision surfaces to be blended, such as copies of a character's head in different poses. In order to blend subdivision surfaces, the surfaces must have the same vertices at all levels. Match Topology adds vertices as needed to make the vertices match on all selected objects.

You do not need to do Match Topology yourself, because the Create Blend Shape operation does it automatically. Do it only if you want to see the results before the blend shape operation. Note, however, that doing Match Topology yourself will lead to slower system performance when you blend shapes.

Subdivision Surface Modeling
If you do Match Topology, first select two or more surfaces in any order. The surfaces must have the same number of faces on level 0. They do not necessarily need to have the same number of levels.

Match Topology only adds vertices. It does not match the vertex position edits or creases from one surface to another.
Mapping and editing UVs

About Subdivision surfaces

UVs

UVs are points that provide the information needed to apply textures to the surface. Subdivision surfaces, like polygons, require specific arrangement of the UVs so that textures look correct when applied to the surface material.

Although Maya creates UVs by default, in many cases, you’ll need to rearrange UVs because the default arrangement will not match the modeling changes you make. Typically, you arrange UVs after you have completed your modeling and before you assign textures to the model.

UVs are arranged in a 2D coordinate system called texture space. You can see the texture space coordinates in Maya’s UV Texture Editor (formerly called Texture View). For example, the following illustration shows the default UV arrangement for the model of a fish. When a texture is assigned using this default UV arrangement, the result is haphazard.

In this example, you can use Maya operations to rearrange the UVs into a pattern that more closely resembles the fish model. The new arrangement applies the texture more evenly around the model. See the following illustration.
4 | Mapping and editing UVs
About > Mapping

Mapping

To begin rearranging UVs, you first need to assign them to the surface, known as mapping UVs. You’ll learn how to map UVs in this chapter.

Subdivision surfaces have their own mapping and editing operations, separate from the polygon operations. (It’s also possible to map UVs with the polygon operations; see “Edit UVs in Polygon Proxy Mode” on page 37.)

There are two subdivision surface mapping operations available, Planar and Automatic, under the Subdiv Surfaces > Texture menu. They are equivalent to Planar and Automatic mapping on the polygon texture menu. However, one key difference is that the Subdiv Surfaces operations use only one UV set, whereas polygons can have multiple UV sets.

To create a UV mapping arrangement that works best for your model, you may need to map several times, until you find a mapping arrangement that is suitable. See the following guidelines.

Guidelines for UV arrangement

Knowing how to arrange UVs is somewhat of an art form. The arrangement largely depends on the types of textures you will apply and also on whether you are creating rendered images or models for interactive games. A full description of UV arrangement is out of the scope of this guide. At a minimum, though, you should adhere to these guidelines:

Keep UVs within the 0 to 1 texture coordinates

The UV Texture Editor displays a grid marking the coordinates for UVs. You should keep UVs within the 0 to 1 coordinates because Maya automatically fits textures into these coordinates. If UVs extend beyond

UVs rearranged for model
New texture appearance
the 0 to 1 range, the texture will appear to repeat around the corresponding vertices. The exception is when you want the texture to repeat on the surface, such as a brick texture along the model of a wall.

By default, the UV mapping operations automatically fit UVs within the 0 to 1 coordinates.

Avoid overlapping UV pieces

As the prior illustration of the fish model shows, UV points have interconnecting lines that form a shape, called a UV piece. If pieces overlap in the UV Texture Editor, the texture will appear to repeat on the corresponding vertices. In general, you should avoid overlapping UVs, unless you want the texture to repeat. For example, if you want the arms of a character to share the same texture pattern, you can place the UV piece corresponding to one arm on top of the piece corresponding to the other arm, using the Move tool.

The Planar Mapping operation often results in overlapping UV pieces, but you can easily separate the pieces using the Layout UVs operation, as described in “Map UVs onto a subdivision surface” on page 38.

How do I? Apply colors, shading, and textures

Map UVs to subdivision surfaces

Edit UVs in Polygon Proxy Mode

You can choose to create and edit UVs in either Polygon Proxy Mode or Standard Mode.

Using Polygon Proxy Mode, you have more UV editing features available. However, because the UVs apply to the base mesh faces, textures might appear twisted, especially in areas that are significantly more refined than the base mesh. Editing UVs in Standard Mode (the default) ensures the best visual results for textures.

To use UVs from polygon proxy mode

1 Switch to Polygon Proxy Mode (right click the subdivision surface and choose Polygon).
2 Show the attribute editor and click the polyToSubdiv tab.
3 Set the UV treatment attribute:
   • To use the UVs from standard mode, choose Keep Subd UVs.
How do I? > Map UVs onto a subdivision surface

- To use UVs you edit while in polygon proxy mode, choose Inherit UVs from Poly. The UVs will be copied back to the surface when you exit polygon proxy mode.
- To not have UVs on this surface at all, choose No UVs on Subd. This removes any existing UVs on the surface.

The UV treatment attribute defaults back to Keep Subd UVs if you switch to Standard Mode and then switch back to Polygon Proxy Mode. If you want to edit UVs in polygon proxy mode again, you will need to change the UV treatment attribute again.

Related topics
- “Reshape a subdivision surface using polygon tools” on page 26
- “Edit subdivision surface UVs” on page 41

Map UVs onto a subdivision surface

To select faces for mapping

1. In Standard Mode, select a Display Level for the subdivision surface.

   - “Switch to a different subdivision level” on page 23
   - Switch to a level that contains the faces you want to map. For example, if you want to map the entire surface, switch to level 0 so you can select faces across the entire surface.
   - For whichever level you choose, Maya converts the faces you select down to the finest level and applies the mapping to those faces.
   - For example, if a face at level 0 has refinements to level 3, the mapping is applied to level 3 faces. If there are no finer levels, the mapping is applied to faces you selected on the current level.

2. Select some or all of the faces on the surface.

   - If faces are not selected, no mapping occurs. Maya does not automatically change to the face component mode, as it does when you try to map polygons.

To map UVs with Planar Mapping

Planar Mapping assigns UVs to the surface by projecting them in a single direction. Where the projection intersects the surface, Maya assigns UVs.

This mapping technique keeps the amount of UV pieces low. However, it usually results in UV pieces that overlap because the projected UVs strike both sides of the surface. As a result, you’ll probably need to separate the overlapping UVs using Layout UVs.

4 | Mapping and editing UVs
How do I? > Map UVs onto a subdivision surface

2 Set the options. In most cases, you’ll need to at least change the Mapping direction. Mapping direction controls the orientation of the mapping plane.

3 Click Project.

To map UVs with Automatic Mapping
To avoid overlaps, Automatic Mapping assigns UVs to the surface by projecting them inward from multiple planes simultaneously. Where the projections intersect the surface, Maya assigns UVs.

1 Select Subdiv Surfaces > Texture > Automatic Mapping > □.
2 Set the options.
3 Click Project.

Although this mapping technique avoids overlapping UVs, it usually creates many small UV pieces. As a result, you may want to combine the small UV pieces into larger pieces, for example, combining pieces that correspond to fingers together with the piece corresponding to the palm.

It’s easier to create textures for the model when the UVs of adjacent faces are combined in a logical way. To combine UV pieces, you use Merge and Sew UVs.

To resize or rotate the projection plane
You should see the mapped UVs in the UV Texture Editor (Window > UV Texture Editor).

Use the projection manipulator on the surface:
• Drag the corners to resize the plane.
• Click the red lines to show a transform manipulator tool, then use it to rotate or flip the plane.

If the manipulator doesn’t appear, select subdPlanarProj in the Channel Box.

Examples

Manipulator
If you map a model of a long fish, the UV piece will be stretched by default to fit in a square (see the following illustration). The stretched shape could result in a texture that looks stretched on the model.

To avoid this problem, you can resize the projection manipulator until the UV piece becomes more oblong, like the long fish model.
Selecting faces

In the figure on the left, level 0 faces were selected to be mapped. The resulting UV piece is round, but there are also lines in the shape of an upside-down T. These other lines correspond to the faces that were selected on level 0. They appear only because those faces are still selected; select elsewhere and they no longer appear.

In the right figure, level 2 faces were selected to be mapped. The resulting UV piece is orange (meaning it’s selected) and is shaped like an arc. There is also a UV piece in the shape of an upside-down T, with a section missing. This UV piece corresponds to the level 1 faces. It still has the default UV arrangement (an upside-down T), because it was not actually mapped; only level 2 faces were mapped.

Related topics

- “Edit subdivision surface UVs” on page 41
- “Subdiv Surfaces > Texture > Planar Mapping” on page 42
- “Subdiv Surfaces > Texture > Automatic Mapping” on page 44
Edit subdivision surface UVs

In the UV Texture Editor (Window > UV Texture Editor), there are separate menus for polygons and subdivision surfaces. Use the menu items under the Subdivs menu, not the Polygons menu.

The items in the UV texture editor’s Subdivs menu work the same as the corresponding items in the editor’s Polygons menu.

You can use all other menu items, except the following:

- View > View Contained Faces and View > View Connected Faces
- Image > UV Sets

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show UV borders more clearly in the texture editor.</td>
<td>Select Display &gt; Subdiv Surface Components &gt; UV Borders (Texture Editor).</td>
</tr>
<tr>
<td>Separate a UV piece into smaller pieces.</td>
<td>In the UV Texture Editor, select edges along the new border you want to create and choose Subdivs &gt; Cut UVs.</td>
</tr>
<tr>
<td>Attach separate UV pieces manually.</td>
<td>In the UV Texture Editor, select the common edges of separate UV pieces and choose Subdivs &gt; Move and Sew UVs &gt; . Turn off Limit Piece Size and click Apply.</td>
</tr>
<tr>
<td>Attach separate UV pieces automatically.</td>
<td>In the UV Texture Editor, select all edges of all UV pieces and choose Subdivs &gt; Move and Sew UVs &gt; . Turn on Limit Piece Size and set Number of Faces to the minimum number of faces a UV piece can have. For example, if you set 2, only pieces with a number of faces equal to or less than 2 will be moved and sewn. Click Apply.</td>
</tr>
<tr>
<td>Create a snapshot of the UV layout on which to paint a texture.</td>
<td>In the texture editor, choose Subdivs &gt; UV Snapshot. The options are the same as for Polygons &gt; UV Snapshot.</td>
</tr>
</tbody>
</table>
Tip
After performing a Move and Sew operation, you can select the history node (subdMapSewMove) in the Channel Box and adjust the Number of Faces until you achieve the results you want.

Related topics
- “Subdiv Surfaces > Texture > Layout UVs” on page 46

Reference Menus

Modeling menu set

Subdiv Surfaces

Subdiv Surfaces > Texture > Planar Mapping
Maps UVs onto a subdivision surface by projecting along a direction.

Related topics
- “Map UVs onto a subdivision surface” on page 38

Subdiv Surfaces > Texture > Planar Mapping > □

By default, Smart Fit is turned on, which automatically positions the projection manipulator. If you prefer to specify exact values for the projection manipulator, you can turn off Smart Fit and change the values in the Projection Center, Rotation, Width, and Height settings instead.

Fit to Best Plane

If you want to map UVs for a portion of the object’s faces, you can turn on Fit to Best Plane and the projection manipulator snaps to an angle and rotation aimed directly at the selected faces.

Fit to Bounding Box

This option works best when you are mapping UVs to all or most of an object’s faces. It snaps the projection manipulator to fit within the object’s bounding box. With this option on, you must choose one of the Mapping direction options to establish the orientation of the projection manipulator.
4 | Mapping and editing UVs
Reference > Subdiv Surfaces > Texture > Planar Mapping

Mapping direction

Choose an axis so that the projection manipulator is aimed at the majority of the object’s faces. For example, a turtle model sitting on the grid would have most of its faces pointing toward the Y axis, while a horse model standing on the grid would have most of its faces pointing toward the X or Z axis.

If most of the model’s faces point somewhere that is not directly along the X, Y, or Z axis, you can choose Camera. This option positions the projection manipulator based on the current active view.

Insert Before Deformers

The Insert Before Deformers option is relevant when the object has a deformation applied to it. If the option is turned off and the deformation is animated, the texture placement is affected by the change in vertex positions. This leads to “swimming” textures.

Turning this option on applies the texture placement to the object before the deformation is applied to it. Basically, the texture placement dependency graph node is inserted before the deformer dependency graph nodes and the texture “sticks” to the geometry even after the deformation.

Image Center

This value represents the center of the projected UVs. Changing this value translates the center accordingly.

Image Rotation

This value changes the angle at which UVs are rotated in the 2D window. Drag the slider or enter a value to rotate the image.

Image Scale

This value represents the width (U) or the height (V) of the 2D map relative to the 2D center point.

Keep Image Ratio

Turn this option on to retain the width to height ratio of the image so that the image does not distort. Turn it off so that the mapped UVs fill the 0 to 1 coordinates in the UV Texture Editor.

If Smart Fit is turned off, you can enter values to change the Projection Center, Rotation and Scale.

After you project a texture, you can change these values from the Channel Box or the Attribute Editor, or use the corresponding manipulator handles to interactively adjust the map.
4 | Mapping and editing UVs
Reference > Subdiv Surfaces > Texture > Automatic Mapping

Projection Center
The projection center defines the point of origin in the X, Y, or Z axis from where you can project a texture map. By default, this is the center of the selected faces in the X, Y, or Z axis.

Projection Rotation
Type a value to rotate the projection in the 3D view around the X, Y, or Z axis which subsequently rotates the texture.

Projection Scale
Scaling a projection enlarges or reduces the height (V) and width (U) of the projection relative to the 3D projection axis.

Subdiv Surfaces > Texture > Automatic Mapping
Maps UVs onto a subdivision surface by projecting from multiple directions.

Related topics
❖ “Map UVs onto a subdivision surface” on page 38

Subdiv Surfaces > Texture > Automatic Mapping > □
Planes
Select the number of planes you are projecting from. The more planes used, the less distortion occurs and the more pieces created. You can choose a projection based on shapes with 4, 5, 6, 8 or 12 planes.

Optimize
Select how you want the projection optimized.

Less Distortion
Projects all planes equally. While this method provides the best projection for any face, you may end up with more pieces. It is particularly useful if you have a symmetrical model and you want the pieces of the projection to be symmetrical.
4 | Mapping and editing UVs
Reference > Subdiv Surfaces > Texture > Automatic Mapping

Fewer pieces
Projects each plane until the projection encounters a projection angle that is not ideal. This can result in larger pieces, and fewer of them.

Layout
Select where you want the UV pieces to lie in the texture space.
Along U
Positions the pieces along the U axis.
Into Square
Positions the pieces within the 0 to 1 texture space.

Scale
Select how you want the UV pieces scaled within the texture space.
None
Performs no scaling.
Uniform
Scales the pieces to fit the 0 to 1 texture space without changing the aspect ratio.
Stretch to Square
Stretches the pieces to fit the 0 to 1 texture space. The pieces may become distorted.

Spacing Presets
Maya puts a bounding box around each piece and lays out the pieces so that the bounding boxes are very close together. If the pieces end up positioned exactly next to each other, two UVs on different pieces can share the same pixel and when texture painting, overscanning can also cause the paint to spill onto the adjacent piece).

To avoid this situation, ensure that there is at least a pixel between the bounding boxes by selecting a spacing preset from this menu. Select a preset that corresponds to your texture map size. If you don’t know the size, select a smaller map, which will result in a larger spacing between adjacent pieces in UV space. (The smaller your map in pixels, the bigger the UV spacing must be between bounding boxes.)

Select Custom to set the size of the space as a percentage of the map size (in the Percentage Space box).
Percentage Space

If you select Custom beside Spacing Presets, enter the size of the space between bounding boxes as a percentage of the map size.

Note

After performing an Automatic Mapping projection, you can modify the Planes, Optimize, Layout, and Scale settings for the projection in the Channel Box. However, do not modify these settings after painting a texture—the UVs may change drastically.

Subdiv Surfaces > Texture > Layout UVs

The Layout UVs action automatically moves UVs so they don’t overlap in texture space.

It is not absolutely necessary to keep UV pieces separate. For example, you may want to overlap UVs so different faces use the same region of a texture. In general however you should keep pieces separate for convenience and clarity.

Related topics

- “Edit subdivision surface UVs” on page 41

Subdiv Surfaces > Texture > Layout UVs

The default settings give the best results in most situations.

Separate

Select how you want to separate overlapping UV pieces.

Off

Does not separate overlapping pieces. Only the Scale option has an effect.

Folds

Separates only pieces where the surface normals of overlapping pieces point opposite directions. This method is faster, especially for larger models, however, you may be left with overlapping UVs.

All Intersecting

Separates all pieces where the UVs overlap.

Flip Reversed

Turn this option on to flip pieces that have normals pointing in opposite directions.
4 | Mapping and editing UVs
Reference > Subdiv Surfaces > Texture > Layout UVs

Tip
If your model is symmetrical (for example, a character’s face), you can save texture space by turning this option off and superimposing the UV pieces so they occupy the same texture space.

Layout
Select where you want the UV pieces to lie in the texture space.
- **None**: Does not lay out pieces after they have been cut. Some pieces may lie on top of others.
- **Along U**: Positions the pieces along the U axis.
- **Into Square**: Positions the pieces within the 0 to 1 texture space.

Scale
Select how you want the UV pieces scaled within the texture space.
- **None**: Performs no scaling.
- **Uniform**: Scales the pieces to fit the 0 to 1 texture space without changing the aspect ratio.
- **Stretch to Square**: Stretches the pieces to fit the 0 to 1 texture space. The pieces may become distorted.

Spacing Presets
Maya puts a bounding box around each piece and lays out the pieces so that the bounding boxes are very close together. If the pieces end up positioned exactly next to each other, two UVs on different pieces can share the same pixel and when texture painting, overscanning can also cause the paint to spill onto the adjacent piece.

To avoid this situation, ensure that there is at least a pixel between the bounding boxes by selecting a spacing preset from this menu. Select a preset that corresponds to your texture map size. If you don’t know the size, select a smaller map, which will result in a larger spacing between adjacent pieces in UV space. (The smaller your map in pixels, the bigger the UV spacing must be between bounding boxes.)
Select Custom to set the size of the space as a percentage of the map size (in the Percentage Space box).

**Percentage Space**

If you select Custom beside Spacing Presets, enter the size of the space between bounding boxes as a percentage of the map size.
5 Tips for working with subdivision surfaces

About

Tips

Character setup

Bind subdivision surfaces to skeletons

For optimal performance, bind subdivision surfaces at a coarser level, and only to one level. This usually results in adequate shape changes as the deformers and joints move, and gives you fewer vertices to weight while maintaining smooth interpolation.

The detail edits on finer levels tend to float or ride on the bound coarser level, which helps skin details such as wrinkles and spots blend smoothly. For example, as a finger joint bends, the wrinkles riding on top, modeled at a finer level, stretch out.

Before you bind:

- Freeze the transform on the subdivision surface to avoid unusual distortions after the bind caused by non-uniform scaling of the subdivision surface.
- Delete the history, especially if the subdivision surface has been bound before.
- Make sure you’re in Standard Mode.

Apply a deformer to a subdivision surface

When you apply a deformer to a subdivision surface selected as an object, the deformer applies to the base (level 0) vertices. To apply the deformer to a different level, select the vertices at that level and then apply the deformer. You can assign blend shapes to vertices at any level.
Tips for working with subdivision surfaces

About > Apply a deformer to a subdivision surface

- If you delete a deformer and cannot switch to Polygon Proxy mode, delete the history or find the input geometry in the dependency graph and delete it.
- Be careful if you have deformers on the same part of the surface at different levels. Without parenting, deformer bases can produce double transforms.
- Avoid having different levels of vertices in the same deformer. For example, if you create a full crease at level 1 and apply a wire close to the object surface (level 0), then move the wire or its vertices, the effect is very different than if you apply the wire to level 1 vertices.
- If the resulting deformation is undesirable, unbind, delete history, and rebind at a finer level.
- You may find that not all vertices are moved by a skeleton bound to a subdivision surface at a level finer than 1 because all vertices at the level were not selected or created before binding. To be sure all vertices are selected, go to level 0 or 1, select all vertices, then refine to the required level and select all.
- A deformer at level 2 can override the deformation done at level 1. For example, if you have a weighted cluster at level 1 and a blend shape at level 2, the cluster deformation will disappear when the blend shape weight is set to one. Try putting the blend shape at the finest level or on the same level as the other deformers. You can also try changing the order of the deformations.
- A deformer at level 1 can move the surface out of a deformer at a finer level (for example, lattices over the same parts of the surface at levels 2 and 3 and in the case of level 2 lattices, it pulls it out of the range of the lattice at level 3).
- Switching to Polygon Proxy mode when you have deformers and skeletons on the subdivision surface unbinds the surface and loses weighting.

Creating blend shape and cluster deformers for subdivision surfaces

To create a blend shape for subdivision surfaces, you can either select the object or select vertices on a given level. If you select the object, Maya blends all vertices at all levels of the surface. If you select vertices of a specific level, Maya blends only those vertices.

To create a cluster for subdivision surfaces, you need an extra row of vertices completely surrounding the vertices you want in the cluster. These extra vertices should not be in the cluster itself, but they must exist on the surface. Without the extra row, you will experience problems weighting the vertices in the cluster.
If the extra row does not exist, select the vertices and select Subdiv Surfaces > Expand Selected Components.

**Rendering**

**Render subdivision surfaces**

You can fine-tune the quality of the rendered surface by adjusting the settings in the Tessellation section of the subdivision surface Attribute Editor. Subdivision surfaces also support displacement mapping.

You can potentially create very finely tessellated polygons. As an extreme example, a Uniform tessellation of a 10 quad base mesh, with Depth and Sample Count set to 10 will produce about a billion triangles.

**Format**

Select one of the tessellation methods.

- **Uniform**
  Uniform tessellation produces a polygon with an equal number of faces for each of the subdivision surface’s base mesh faces (faces at level 0).

- **Adaptive**
  Adaptive tessellation produces a polygon with an equal number of faces for each of the finest level faces on the subdivision surface. The more refinement you’ve made to a region of the subdivision surface, the more faces the resulting polygon will have for that same region. Use Sample Count to increase the tessellation.

- **Depth**
  For Uniform tessellation only, set the level to determine how many faces are to be used in the tessellation. For example, if Depth is 3, the number of faces at level 3 are used in the tessellation.

- **Sample Count**
  Specify how many times each face should be divided. Increasing this value smooths the polygonal surface.
5 | Tips for working with subdivision surfaces
About > Render subdivision surfaces
Index

Numerics
4-sided polygons (quads), using ..................... 11

A
Adaptive tessellation method
  when converting to polygons .................... 19
  when rendering ................................ 51
Attach (Subdiv Surfaces menu) .................... 31
attach subdivision surfaces ....................... 28
automatic mapping ................................ 39
Automatic Mapping (Subdiv Surfaces > Texture) 44

B
base mesh ........................................... 8
binding skeletons to subdivision surfaces ...... 49
binding, tips ....................................... 49
blend shape, creating ............................ 50

clean up subdivision surfaces .................... 29
cluster deforming, creating ....................... 50
Collapse Hierarchy (Subdiv Surfaces menu) .... 32
collapse levels .................................... 29
combine subdivision surfaces .................... 28
control points
  increase ........................................... 22
corner conversion of polygons, prepare for .... 11
Convert (Modify menu) ............................ 17
crease
  add or remove .................................. 25
cylindrical mapping
  image center, changing ......................... 43
  image rotation angle, change ................. 43
  image scale (width, height), change ........ 43

dashed lines representing creases ............... 25
deformer
  apply to a subdivision surface ............... 49
deformer dependency graph nodes
  texture placement before deformation ....... 43
Depth tessellation method
  when rendering .................................. 51
Divisions Per Face tessellation option .......... 19

E
edges
  attaching ........................................ 28
  create ............................................ 25
dashed lines representing creases ............ 25
  put in mesh ..................................... 12
edit
    UVs ............................................. 41
efficiency of subdivision surfaces, improve ... 30

F
faces
  select for mapping ............................ 38
  selecting ....................................... 40
  use as few as possible ......................... 11
Fit to Best Plane
  planar mapping option .......................... 42
Fit to Bounding Box
  planar mapping option .......................... 42
flip a surface ................................... 32
Flip Reversed layout UVs option ............... 46
floating edges .................................... 12
Format option ..................................... 51
free points ....................................... 12
full crease, create ................................ 25

g
geometry
  convert to subdivision surfaces ............. 11
guidelines for UV arrangement .................. 36

H
Hide and Show option ............................. 20
history, deleting .................................. 49

Subdivision Surface Modeling
53
Index

<table>
<thead>
<tr>
<th>Subdivision Surface Modeling</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum Base Mesh Faces option</td>
</tr>
<tr>
<td>Maximum Edges Per Vertex option</td>
</tr>
<tr>
<td>Maximum Number of Polygons tessellation option</td>
</tr>
<tr>
<td>mesh put in vertices and edges</td>
</tr>
<tr>
<td>Mirror (Subdiv Surfaces menu)</td>
</tr>
<tr>
<td>modeling workflow</td>
</tr>
<tr>
<td>modes, about</td>
</tr>
<tr>
<td>Modify menu</td>
</tr>
<tr>
<td>Convert</td>
</tr>
<tr>
<td>moving a planar projection</td>
</tr>
<tr>
<td>nonmanifold topology</td>
</tr>
<tr>
<td>normals inconsistent</td>
</tr>
<tr>
<td>NURBS</td>
</tr>
<tr>
<td>convert subdivision surface to</td>
</tr>
<tr>
<td>prepare surface for conversion</td>
</tr>
<tr>
<td>Optimize automatic mapping option</td>
</tr>
<tr>
<td>Original Object</td>
</tr>
<tr>
<td>Subdiv to NURBS conversion option</td>
</tr>
<tr>
<td>tessellation option</td>
</tr>
<tr>
<td>Output Type</td>
</tr>
<tr>
<td>Subdiv to NURBS option</td>
</tr>
<tr>
<td>overlapping</td>
</tr>
<tr>
<td>avoiding</td>
</tr>
<tr>
<td>UV pieces</td>
</tr>
<tr>
<td>partial crease, create</td>
</tr>
<tr>
<td>Percentage Space</td>
</tr>
<tr>
<td>automatic mapping option</td>
</tr>
<tr>
<td>layout UVs option</td>
</tr>
<tr>
<td>performance</td>
</tr>
<tr>
<td>increase with reshaping</td>
</tr>
<tr>
<td>planar mapping</td>
</tr>
<tr>
<td>Planar Mapping (Subdiv Surfaces &gt; Texture)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image Center</td>
</tr>
<tr>
<td>cylindrical, spherical mapping option</td>
</tr>
<tr>
<td>Image Rotation</td>
</tr>
<tr>
<td>cylindrical, spherical mapping option</td>
</tr>
<tr>
<td>Image Scale</td>
</tr>
<tr>
<td>cylindrical, spherical mapping option</td>
</tr>
<tr>
<td>Inherit UVs from Poly</td>
</tr>
<tr>
<td>Insert Before Deformers</td>
</tr>
<tr>
<td>correct swimming textures</td>
</tr>
<tr>
<td>interactive performance, improve</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keep Image Ratio</td>
</tr>
<tr>
<td>Planar mapping option</td>
</tr>
<tr>
<td>Keep Original option</td>
</tr>
<tr>
<td>Keep Subd UVs</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>L</th>
</tr>
</thead>
<tbody>
<tr>
<td>lamina topology</td>
</tr>
<tr>
<td>Layout</td>
</tr>
<tr>
<td>automatic mapping option</td>
</tr>
<tr>
<td>layout UVs option</td>
</tr>
<tr>
<td>Layout UVs (Subdiv Surfaces &gt; Texture)</td>
</tr>
<tr>
<td>Level tessellation option</td>
</tr>
<tr>
<td>levels</td>
</tr>
<tr>
<td>create new</td>
</tr>
<tr>
<td>defined</td>
</tr>
<tr>
<td>keeping the same when deforming</td>
</tr>
<tr>
<td>reduce number</td>
</tr>
<tr>
<td>switch</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>M</th>
</tr>
</thead>
<tbody>
<tr>
<td>mapping</td>
</tr>
<tr>
<td>about</td>
</tr>
<tr>
<td>automatic</td>
</tr>
<tr>
<td>planar</td>
</tr>
<tr>
<td>Mapping direction</td>
</tr>
<tr>
<td>planar mapping option</td>
</tr>
<tr>
<td>Match Topology (Subdiv Surfaces menu)</td>
</tr>
</tbody>
</table>
plane
  for projecting UVs, resizing .................................. 39
  projection, resize or rotate .................................... 39
Planes option .......................................................... 44
points
  sharp, create ....................................................... 25
Poly Count tessellation method
  when converting to polygons ....................................... 19
polygon mesh
  converting to ....................................................... 13
  put in vertices and edges .......................................... 12
polygon model
  checking how it will convert ...................................... 9
polygon proxy mode
  about ................................................................. 8
  edit UVs in .......................................................... 37
  for polygon tools ................................................... 26
  use UVs ............................................................... 37
polygons
  convert subdivision surface to .................................. 14
  non-convertible ..................................................... 12
  prepare ............................................................... 11
  tools for reshaping surfaces ...................................... 26
projection
  multiple planes, UV assigned by .................................. 39
  plane, resize and rotate ............................................ 39
  snap to best plane .................................................. 42
  snap to bounding box .............................................. 42
  UV assigned by .......................................................... 38
Projection Center
  planar mapping option .............................................. 44
Projection Rotation
  planar mapping option .............................................. 44
Projection Scale
  planar mapping option .............................................. 44
proxy mode, polygon ................................................... 8
Q
quads, using ............................................................. 11
R
refined region
  create ................................................................. 22
  expand ................................................................. 23
region
  add control points ................................................... 22
rendering subdivision surfaces ....................................... 51
Replace option .......................................................... 20
reshaping with polygon tools ......................................... 26
S
Sample Count tessellation method
  when rendering ....................................................... 51
Scale
  automatic mapping option ........................................... 45
  layout UVs option ..................................................... 47
scaling
  a planar projection .................................................. 44
selecting
  faces ................................................................. 40
Separate layout UVs option ............................................ 46
sharp point, create ..................................................... 25
skeletons, binding to subdivision surfaces ......................... 49
smooth proxy ............................................................ 9
Spacing Presets
  automatic mapping option ........................................... 45
  layout UVs option ..................................................... 47
spherical mapping
  change image center .................................................. 43
  change image rotation angle ........................................ 43
  change image scale (width, height) ................................ 43
standard mode
  about ................................................................. 8
Subdiv Surfaces menu
  Attach ................................................................. 31
  Collapse Hierarchy ................................................... 32
  Match Topology ........................................................ 33
  Mirror ................................................................. 32
  Texture ............................................................... 42
Index

subdivision surface
  about ........................................... 7
  advantages of .................................. 7
  apply deformer to ............................... 49
  attach ........................................... 28
  bind to skeletons ................................ 49
  clean up ........................................ 29
  convert geometry to .............................. 11
  convert to NURBS ................................. 16
  convert to polygons .............................. 14
  creating blend shapes, cluster deformers for .... 50
  duplicate and flip ................................ 32
  edit UVs ......................................... 41
  levels of detail ................................ 22
  make more efficient .............................. 30
  map UVs to ........................... 35
  mapping operations .............................. 36
  modeling workflow ............................... 9
  prepare for blending ........................... 33
  prepare NURBS surface for ..................... 13
  reduce number of levels ......................... 29
  rendering ....................................... 51
  reshape ......................................... 21
  reshaping with polygon tools .................. 26
  switch levels .................................. 23
  tips for working with .......................... 49
  UV projection ................................ 38
  UV projection from multiple planes .......... 39
Subdivision Surface Mode option .................... 18
swimming textures
  correct ......................................... 43
topology
  clean ........................................... 30
  match ........................................... 33
  transformation tools ........................... 21

U
Uniform tessellation method
  when converting to polygons .................... 19
  when rendering .................................. 51
UVs
  about ........................................... 35
  borders ......................................... 41
  creating ........................................ 35
  edit .............................................. 41
  guidelines for arrangement .................... 36
  mapping, about ................................ 36
  mapping, how to ................................ 38
  pieces, overlapping ............................. 37
  treatment in polygon proxy mode ............. 38

V
vertices
  adding with Match Topology .................... 34
  during deformation ............................... 50
  put in mesh ..................................... 12
Vertices tessellation method
  when converting to polygons .................... 19

tessellation methods
  for conversion to polygons.................... 18
  for rendering ................................ 51
texture
  coordinates .................................... 36
  mapping ....................................... 35
  placement before deformation ................ 43
  swimming, correcting ........................ 43
  twisted in polygon proxy mode .............. 37
Texture (Subdiv Surfaces menu) .................. 42