Polygonal Modeling
Version 6
# Table of contents

1 Background ...................................................... 13

About
- Polgons ........................................... 13
- Polygons ........................................... 13
- Normals ........................................... 13
- Meshes and shells ...................................... 15
- 2-manifold, non-manifold, and invalid polygonal geometry ...... 15
- Planar and non-planar polygons .......................... 16
- Polygon component display .............................. 17
- Polygon component selection ............................ 17

2 Selecting polygons ............................................. 19

How do I?
- Select .............................................. 19
- Select certain components in a mesh based on criteria ........ 19

Reference
- Menus .............................................. 20
- Modeling menu set ..................................... 20
- Edit Polygons ........................................ 20
- Edit Polygons > Selection > Select Contiguous Edges ......... 20
- Edit Polygons > Selection > Selection Constraints .......... 21

3 Create and Reshape polygons ................................. 31

About
- Polgons ........................................... 31
- Polgons ........................................... 31
- Smoothing methods ..................................... 31

How do I?
- Create and edit models ................................ 32
- Create and reshape polygons .......................... 32
- Create a single faced polygon mesh ...................... 32
- Transform polygon components ........................ 34
- Move vertices along their normals ...................... 37
- Smooth polygons ..................................... 37
- Work on a simple model while a high density version
  automatically updates ................................ 39
- Extrude a vertex, edges, or faces ...................... 42
- Extrude polygons in an arc (wedge) .................... 46

Polygon Modeling
3
Table of Contents

Model one half of an object and mirror the other half ............ 46
Model an object symmetrically .................................. 47
Duplicate faces .................................................. 49
Bevel edges ...................................................... 51
Chamfer a vertex ................................................ 52
Fill gaps with polygons .......................................... 52
Reshape a polygonal surface using Soft Modification .......... 53

Convert geometry from one type to another ...................... 53
Convert NURBS to polygons .................................... 53

Menus ............................................................. 55
Modify ............................................................ 55
Modify > Convert > NURBS to Polygons ......................... 55
Create ........................................................... 59
Create > Polygon Primitives .................................... 59

Modeling menu set .............................................. 66
Polygons .......................................................... 66
Polygons > Create Polygon Tool ................................ 66
Polygons > Append to Polygon Tool .............................. 68
Polygons > Average Vertices .................................... 71
Polygons > Mirror Geometry .................................... 72
Polygons > Mirror Cut .......................................... 74
Polygons > Smooth .............................................. 75
Polygons > Smooth Proxy ....................................... 78
Polygons > Unmirror Smooth Proxy .............................. 83

Edit Polygons .................................................... 83
Edit Polygons > Move Component ............................... 83
Edit Polygons > Extrude Face, Extrude Edge .................... 86
Edit Polygons > Extrude Vertex ................................ 89
Edit Polygons > Wedge Faces ................................... 90
Edit Polygons > Duplicate Face ................................ 90
Edit Polygons > Chamfer Vertex ................................. 93
Edit Polygons > Bevel ........................................... 93

4 The Sculpt Polygons tool ........................................ 97

Polygons Modeling
# About Polygons

The Sculpt Polygons tool ........................................... 97

# How do I?

## Create and edit models ........................................ 100

- Reshape polygons with the Sculpt Polygons tool ............. 100
  - Push or pull a mesh with the Sculpt Polygons tool ........ 100
  - Smooth a mesh with the Sculpt Polygons tool ............. 101
  - Selectively erase back to a previous state with the Sculpt Polygons tool ........................................... 101
  - Sculpt according to an attribute map .......................... 102
  - Keyframe sculpting changes .................................... 103

## Reference

- **Menus** .......................................................... 103
- **Modeling menu set** .......................................... 103
  - **Polygons** .................................................. 103
  - **Edit Polygons > Sculpt Polygons Tool** ................... 103

# 5 Combining, separating, and splitting .......................... 109

## How do I?

### Create and edit models ...................................... 109

### Combine, separate, or split polygons ....................... 109

- Merge vertices, edges, or faces into one vertex ............ 109
- Merge edges ....................................................... 110
- Combine separate meshes into one new mesh ................. 112
- Automatically separate polygon shells into individual meshes .................................................. 113
- Combine meshes using boolean operations .................... 113
- Edit the original objects after a boolean operation ....... 115
- Split shared vertices ............................................. 117
- Disconnect faces from their shared edges (extract) ....... 117
- Split a face into multiple faces ................................ 119
- Split faces into triangles or quadrangles ...................... 120
- Split a face and move the new center vertex (poke) ....... 121
- Subdivide faces by painting .................................... 122
- Split an edge into segments ..................................... 123
- Cut faces with a plane .......................................... 123

## Reference

- **Menus** .......................................................... 124
Table of Contents

<table>
<thead>
<tr>
<th>Modeling menu set.</th>
<th>..................................................</th>
<th>124</th>
</tr>
</thead>
<tbody>
<tr>
<td>Polygons</td>
<td>...........................................................................</td>
<td>124</td>
</tr>
<tr>
<td>Polygons &gt; Combine</td>
<td>.........................................................................</td>
<td>124</td>
</tr>
<tr>
<td>Polygons &gt; Booleans</td>
<td>........................................................................</td>
<td>125</td>
</tr>
<tr>
<td><strong>Edit Polygons</strong></td>
<td>...........................................................................</td>
<td>125</td>
</tr>
<tr>
<td>Edit Polygons &gt; Separate</td>
<td>........................................................................</td>
<td>125</td>
</tr>
<tr>
<td>Edit Polygons &gt; Poke Faces</td>
<td>........................................................................</td>
<td>125</td>
</tr>
<tr>
<td>Edit Polygons &gt; Merge Vertices</td>
<td>.......................................................................</td>
<td>125</td>
</tr>
<tr>
<td>Edit Polygons &gt; Collapse</td>
<td>..........................................................................</td>
<td>126</td>
</tr>
<tr>
<td>Edit Polygons &gt; Merge Edge Tool</td>
<td>.......................................................................</td>
<td>126</td>
</tr>
<tr>
<td>Edit Polygons &gt; Merge Multiple Edges</td>
<td>......................................................................</td>
<td>127</td>
</tr>
<tr>
<td>Edit Polygons &gt; Subdivide</td>
<td>...............................................................................</td>
<td>128</td>
</tr>
<tr>
<td>Edit Polygons &gt; Split Polygon Tool</td>
<td>........................................................................</td>
<td>129</td>
</tr>
<tr>
<td>Edit Polygons &gt; Cut Faces</td>
<td>...............................................................................</td>
<td>130</td>
</tr>
<tr>
<td>Edit Polygons &gt; Extract</td>
<td>...............................................................................</td>
<td>131</td>
</tr>
</tbody>
</table>

6 Editing polygons ....................................................... 135

How do I? Create and edit models ........................................ 135

**Edit polygons** ......................................................... 135

Convert polygons to triangles or quadrangles ....................... 135
Flip triangle edges ................................................................ 135
Transfer vertex positions (shape), UVs, or vertex color
between meshes ................................................................ 136
Reverse polygon normals ...................................................... 136
Make a hole in a face ............................................................ 138
Manipulate vertex normals to affect shading of polygons ......... 139
Transfer vertex information between meshes with
identical topology ............................................................... 142

Reference

**Menus** ............................................................................ 143

**Modeling menu set.** ...................................................... 143

**Polygons** ...................................................................... 143

Polygons > Quadrangulate ................................................... 143
Polygons > Transfer ............................................................ 143

**Edit Polygons** ............................................................. 144
7  Clean up ......................................................... 151

How do I?  
Create and edit models  ............................. 151
Clean up or simplify polygons .................... 151
Delete polygon vertices and edges ............... 151
Clean up, simplify, or validate meshes .......... 153
Reduce the number of faces in a mesh .......... 153

Reference  
Menus ..................................................... 155
Modeling menu set.  ................................. 155
Polygons ................................................... 155
Polygons > Cleanup ........................................ 155
Polygons > Reduce ....................................... 157

8  Viewing and evaluating  ............................... 161

How do I?  
View the scene and change the display ........ 161
Show polygon counts in the heads-up display ... 161

Reference  
Menus ..................................................... 163
Display ...................................................... 163
Display > Custom Polygon Display ............... 163

9  Coloring polygons ....................................... 167

About  
Polygons ................................................... 167
Coloring polygons ........................................ 167
Prelighting .................................................. 167

How do I?  
Apply colors, shading, and textures ............ 168
Apply colors to polygons ......................... 168
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make vertex colors visible</td>
<td>168</td>
</tr>
<tr>
<td>Assign colors to vertices</td>
<td>169</td>
</tr>
<tr>
<td>Assign colors to vertices by painting</td>
<td>170</td>
</tr>
<tr>
<td>Assign colors to vertices based on their rendered look (prelight)</td>
<td>170</td>
</tr>
<tr>
<td>Animate vertex colors</td>
<td>171</td>
</tr>
<tr>
<td>Remove colors/prelighting from vertices</td>
<td>172</td>
</tr>
</tbody>
</table>

## Reference

<table>
<thead>
<tr>
<th>Category</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Menus</strong></td>
<td>173</td>
</tr>
<tr>
<td><strong>Modeling menu set.</strong></td>
<td>173</td>
</tr>
<tr>
<td><strong>Edit Polygons</strong></td>
<td>173</td>
</tr>
<tr>
<td><strong>Edit Polygons &gt; Colors &gt; Apply Colors</strong></td>
<td>173</td>
</tr>
<tr>
<td><strong>Edit Polygons &gt; Colors &gt; Paint Vertex Color Tool</strong></td>
<td>174</td>
</tr>
<tr>
<td><strong>Edit Polygons &gt; Colors &gt; Prelight</strong></td>
<td>175</td>
</tr>
</tbody>
</table>

## 10 Projecting and mapping UVs

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Texturing polygons</td>
<td>179</td>
</tr>
<tr>
<td>UVs and mapping</td>
<td>179</td>
</tr>
<tr>
<td>Guidelines for UV arrangement</td>
<td>181</td>
</tr>
<tr>
<td>The texture editor</td>
<td>181</td>
</tr>
</tbody>
</table>

### How do I?

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Apply colors, shading, and textures</strong></td>
<td>182</td>
</tr>
<tr>
<td><strong>Map UVs to polygons</strong></td>
<td>182</td>
</tr>
<tr>
<td>Project UVs onto polygons from a plane</td>
<td>182</td>
</tr>
<tr>
<td>Project UVs onto polygons from a cylinder or sphere</td>
<td>185</td>
</tr>
<tr>
<td>Map UVs onto polygons automatically</td>
<td>186</td>
</tr>
<tr>
<td>Map to a smoothed model and then transfer back to the original</td>
<td>189</td>
</tr>
</tbody>
</table>

## Reference

<table>
<thead>
<tr>
<th>Category</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Menus</strong></td>
<td>189</td>
</tr>
<tr>
<td><strong>Modeling menu set.</strong></td>
<td>189</td>
</tr>
<tr>
<td><strong>Edit Polygons</strong></td>
<td>189</td>
</tr>
<tr>
<td><strong>Edit Polygons &gt; Texture &gt; Planar Mapping</strong></td>
<td>189</td>
</tr>
<tr>
<td><strong>Edit Polygons &gt; Texture &gt; Create UVs Based on Camera</strong></td>
<td>192</td>
</tr>
<tr>
<td><strong>Edit Polygons &gt; Texture &gt; Cylindrical Mapping,</strong></td>
<td>192</td>
</tr>
<tr>
<td><strong>Spherical Mapping</strong></td>
<td>192</td>
</tr>
<tr>
<td><strong>Edit Polygons &gt; Texture &gt; Automatic Mapping</strong></td>
<td>194</td>
</tr>
</tbody>
</table>
# Table of Contents

Edit Polygons > Texture > Best Plane Texturing Tool  

## 11 Texture editor

### How do I?

- Apply colors, shading, and textures  
- Edit UVs visually in the texture editor  
- Select UV components  
- Set up the texture editor display  
- Show the texture image in the UV texture editor  
- Show only a subset of all UVs  
- Transform UVs in the texture editor  
- Set up the texture editor grid and snapping  
- Separate and attach UV pieces  
- Automatically sort out overlapping texture pieces  
- Untangle border UVs  
- Spread out and untangle interior UVs  
- Save a snapshot of the UV layout to paint on  
- Flip texture placement by flipping or rotating UVs  
- Copy UVs, colors, and shaders between polygons  
- Delete UVs  

### Tools

- Toolbox  
- Move tool (in UV texture editor)

### Menus

- Modeling menu set  
- Edit Polygons  
- Edit Polygons > Texture > Normalize UVs  
- Edit Polygons > Texture > Unitize UVs  
- Edit Polygons > Texture > Flip UVs  
- Edit Polygons > Texture > Rotate UVs  
- Edit Polygons > Texture > Map UV Border  
- Edit Polygons > Texture > Straighten UV Border  
- Edit Polygons > Texture > Relax UVs  
- Edit Polygons > Texture > Grid UVs

---

Polygonal Modeling
## Table of Contents

- Apply blind data to components ........................................ 251
- Make blind data visible. .................................................. 252

**Reference**

- Windows and editors .................................................. 254
- Blind Data Editor ....................................................... 254

**14 Customizing** .......................................................... 263

**How do I?**

- Customize Maya ......................................................... 263
- Customize polygonal modeling ....................................... 263
- Change how you select faces ....................................... 263
- Change polygon tool settings ...................................... 263

**Reference**

- Menus ................................................................. 266
- Modeling menu set. .................................................... 266
  - Polygons .......................................................... 266
    - Polygons > Tool Options > Keep New Faces Planar ........ 266
    - Polygons > Tool Options > Keep Faces Together .......... 267
    - Polygons > Tool Options > Create Meshes Single Sided .. 267
    - Polygons > Tool Options > Convert Selection ............ 267
    - Polygons > Tool Options > Smart Command Settings .... 267
    - Polygons > Tool Options > Reset to Default Settings ... 267

---

Polyonal Modeling

11
About > Polygons

Polygons

A polygon is an n-sided shape, defined by its corners (vertices) and the straight lines between them (edges). When you model with polygons you usually use triangles or quadrilaterals (“quads”), although Maya supports polygons with more sides. An individual polygon is often called a face, and is thought of as the filled area defined by its vertices and edges.

Normals

The order of vertices around the face determine the direction of the face (whether a side of the polygon is the front or the back). This can be important because technically polygons are only visible from the front,
though by default Maya automatically makes all polygons double-sided so you can see them from the back. You can turn this double-sided behavior off for meshes.

The front of a polygon’s face is graphically represented using a vector called the polygon’s normal. A normal is a line representing the direction perpendicular to a polygonal surface.

When you shade or render polygons, the normals determine how light reflects from the surface.

**Vertex normals**

Vertex normals represent the visual smoothing between polygon faces. Unlike face normals, they are not intrinsic to the polygon, but rather reflect how Maya renders the polygons in smooth shaded mode.

Vertex normals appear as lines projecting from the vertex, one for each face that shares the vertex.

- When the vertex normals all point in the same direction (called soft or shared vertex normals), there is a softer transition between the faces in smooth shaded mode.

- When the vertex normals point in the same directions as their faces (called hard vertex normals), the transition between faces is hard, creating a faceted appearance.

You can manually manipulate normals to create the appearance of hard edges (creases) and shadows without using additional geometry.
Meshes and shells

Polygons can share vertices and edges with other polygons. You can use a large number of connected polygons to form shapes. A mesh is a collection of polygons (a mesh is also sometimes called a polyset or a polygonal object). A mesh can contain different types of polygons (triangles, quads, n-sided).

Often a mesh consists only of connected polygons, however it can also be several disjoint sets of connected polygons, called shells.

Edges that are not shared (they are on the outside edge of a shell) are called border edges.

2-manifold, non-manifold, and invalid polygonal geometry

2-manifold topology basically means you can unfold the geometry so that it lies flat without overlapping pieces.

Non-manifold geometry cannot be unfolded into a continuous flat piece. Some tools and actions cannot work with non-manifold geometry, including Boolean operations and Reduce.

- In the first example (the “T” shape), more than two faces share an edge. This is known as multiply connected geometry.
1 | Background
About > Planar and non-planar polygons

- In the second example (the “bowtie” shape), two faces share a single vertex without also sharing an edge. This shape is also possible where two three-dimensional shapes share a vertex (such as two cubes meeting at a single point).
- In the third example, a single shape has non-contiguous normals (without border edges). This is a less obvious example of nonmanifold geometry.

The following operations can produce nonmanifold geometry:
- Extrude Edge.
- Normals > Reverse (without extracting geometry).
- Merge Vertices.
- Delete Face.
- Collapse (Face or Edge).

You can automatically make nonmanifold geometry 2-manifold (including the less obvious case of adjacent faces with opposite normals) using Polygons > Cleanup.

Invalid geometry
Invalid geometry includes vertices that are not on an edge and edges that are not part of a face.

Related topics
- “Clean up, simplify, or validate meshes” on page 153

Planar and non-planar polygons
A polygon is planar if all its points lie in a certain plane. A triangle is always planar, because its three points define a plane.

A polygon is non-planar if it has more than three vertices, and any of those vertices are not in the same plane.
In general planar polygons are preferable to non-planar. Maya has options that keep you from creating non-planar polygons (Polygons > Tool Options > Keep New Faces Planar), tools to “fix” non-planar polygons (Edit Polygons > Split Polygons Tool), and display options that can identify non-planar polygons (in Display > Custom Polygon Display).

### Related topics

- “Clean up, simplify, or validate meshes” on page 153

### Polygon component display

Maya’s default display of polygon components uses different colors and sizes to help you identify different types of selected and unselected components.

<table>
<thead>
<tr>
<th>Component</th>
<th>Unselected</th>
<th>Selected</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertex</td>
<td>Small purple box.</td>
<td>Yellow.</td>
</tr>
<tr>
<td>Edge</td>
<td>Light blue.</td>
<td>Light orange.</td>
</tr>
<tr>
<td>Border edge</td>
<td>Thicker line.</td>
<td></td>
</tr>
<tr>
<td>Face</td>
<td>Blue dot in center.</td>
<td>Light orange tint.</td>
</tr>
<tr>
<td>UV</td>
<td>Medium purple box.</td>
<td>Bright green.</td>
</tr>
</tbody>
</table>

You can change the default colors using Window > Settings/Preferences > Colors.

### Polygon component selection

See Select objects or components in the Basics book.
**Note**  When you choose a polygon action, Maya automatically converts the selection to the component type expected by polygon action in most cases. If Maya converts from vertices to edges or faces, or edges to faces, the converted selection contains every component that touches the original selection.

For example, if you select an edge and try to delete vertices, Maya automatically selects the two end-vertices of the edge and deletes them. However, if you select those two end-vertices and try to delete edges, Maya selects all edges that touch either of the two vertices and deletes them.
Selecting polygons

How do I? Select

Select certain components in a mesh based on criteria

The selection constraints action lets you select all polygon components that satisfy various criteria. To learn how to select components using the Select tool, see the Basics guide.

To select by constraints

1. Select a polygonal object and make sure you are in a component selection mode.
2. Choose Edit Polygons > Selection > Selection Constraints.
3. Do one of the following:
   - To apply these constraints to the next selection you make, click Next Selection. This lets you limit the effects of your selections.
   - To apply these constraints to the current selection and your next selection, click Current and Next. This is useful for modifying the selection you’ve already made.
   - To select all components on the selected object that meet these constraints and your next selection, click All and Next. This option automatically updates the selection as you change the options in the window.
4. Open the sections to set various selection constraints and conditions.
   Each section represents a limit on the components that will be selected. Turn on the Activate checkbox at the top of a section to apply its limit.
5. Click one of the Close buttons.

Tip

The Nothing option makes the selection constraints window options have no effect. This is just a convenience to let you keep the window open without it affecting your selections.
To quickly turn off all selection constraint options

In the selection constraint window, open the Reset menu and choose Disable All.

Reference **Menus**

Modeling menu set

**Edit Polygons**

**Edit Polygons > Selection > Select Contiguous Edges**

Max 2D Angle,
Max 3D Angle

These settings determine how far the selection continues based on the angles between edges. If Maya is considering an edge for selection and it exceeds the specified angles, automatic selection stops.

The 2D angle refers to angles made by the surface topology, regardless of the surface’s shape. The 3D angle refers to angles made by the surface’s shape, as measured in world or local space. The following example illustrates how the combination of these settings control the selection.

- **Max 2D = 30, Max 3D = 90**: The Max 2D Angle is too small for this topology and prevents full selection.
- **Max 2D = 60, Max 3D = 90**: The Max 2D Angle is too large and causes selection of unwanted edges.
- **Max 2D = 45, Max 3D = 90**: The Max 2D Angle is just right.

**Edge Count, Edges Either Side**

Turn on Edge Count to set the Edges Either Side option. Edges Either Side is the number of edges that Maya will select on either side of your original selection. For example, you can avoid selecting too many edges by adjusting these settings.
many edges by setting Edges Either Side to a low number and applying Select Contiguous Edges several times until enough edges are selected.

**Edit Polygons > Selection > Selection Constraints**

Lets you select polygons based on a configurable filter.

**Related topics**

- “Select certain components in a mesh based on criteria” on page 19

**Edit Polygons > Selection > Selection Constraints > □**

At the very top of the window in the Constraint list, you set up conditions to filter your selection actions in different ways. These options apply to all component modes. Click the option to make your selection. Which constraints will be applied, and to what settings, is determined by the options you set. There are four different modes:

- **Nothing**
  - When on, no selection constraints are used.

- **Next Selection**
  - When on, the constraints affect only the next selection mode with a technique such as holding the Shift key and clicking the left mouse button.

- **Current and Next**
  - When on, Maya applies the constraint to whatever has already been selected, plus whatever selection you make next.

- **All and Next**
  - When on, Maya applies the constraints to the entire object automatically, plus whatever group you select next.

**Constraint Properties options**

The following section describes the options you can set for selected components in the properties section of the window.

**Generic Location properties**

The following options are applicable to all component types.
2 | Selecting polygons
Reference > Edit Polygons > Selection > Selection Constraints

Location
Off
If selected, this constraint is not taken into account. The Off option means the same for every option in the Properties section.

OnBorder
If on, the selection constrains to only the items on the perimeter of the current objects.

Inside
This is the default setting for Location properties. Maya selects only the items on the inside of the current objects. It has the reverse effect of On Border.

![On Border](image1)
![Inside](image2)

Smoothing properties (for edges only)
If you select edges, Smoothing options are made available. These Properties options do not display for any other component type.

Smoothing
Hard/Smooth
Click one of these options to constrain the selection to either hard or soft edges.

![Smooth edges](image3)
![Hard edges](image4)

Constraint Properties for faces
In addition to the properties that all component modes share, when you are in the face component mode, Maya provides numerous face-specific properties. For example, you can set options to select faces according to order, planarity, and shape—if a polygon is concave instead of convex—as well as mapping and topology.

These are described next.
**Order**

Order options are used to set a valid range for the shape of the faces. If the following options are on, Maya constrains the selection to what you specify.

- **Triangles**
  - Maya only selects faces with three edges.

- **Quads**
  - Maya only selects faces with four edges.

- **Nsided**
  - Maya only selects faces other than triangles or quads (faces that have more than four edges).

**Planarity**

- **Planar/Non-planar**
  - Planar selects only planar faces. Non-planar selects only non-planar faces.
Convexity

Concave/Convex

Concave selects polygons that have at least one interior angle greater than 180 degrees. Convex selects polygons whose interior angles are all less than or equal to 180 degrees.

Domains

Holed/Non-holed

If you select non-holed, only faces that do not have holes are selected. If you select Holed, only faces in which holes have been created (using the Edit Polygons > Make Hole Tool) are selected.

Mapping

Depending on what you choose, only mapped or unmapped faces are selected. Mapped faces are faces with texture (UV) coordinates—unmapped faces do not have texture (UV) coordinates.

Topology

Lamina

A group of faces glued on top of each other are selected. For example, two faces whose normals face each other.

Non-triangulable

Lets you select faces that cannot be triangulated. Use this constraint option to select these problem faces, then repair them using the Split Polygon Tool (Edit Polygons > Split Polygon Tool). See “Combining, separating, and splitting” on page 109 for details.

Note

Maya considers faces with holes to be concave.
Geometry options

Changing Min and Max values

The Min and Max values for most of the Geometry options correspond to the units of a polygonal face. The values you set constrain the selection to the size of the face that corresponds to those units. The default unit size is in centimeters by default. You can change this in the Preferences window (Window > Settings/Preferences > Preferences, then click the Settings category).

In this example, each face of a polygonal primitive plane is four units. You can determine this by looking at the squares of the grid within each face.

When you scale some of the faces and subdivide others, the topology changes as do the Min and Max values you can enter to constrain the selection area.

Try setting different Min and Max values for the Area option for faces, for example, to determine which faces fall within the Min/Max criteria determined by the unit size.
2 | Selecting polygons
Reference > Edit Polygons > Selection > Selection Constraints

If you set the Area criteria to a Min value of 0 and a Max value of 7, all faces are selected because there are no faces with a unit area less than 0 or greater than 7.

Important tip
If you want to constrain the selection for a unit area that is very small, such as the area under the eyes on a polygonal modeled face, set the Min and Max values to a small value. The opposite is true if you want to set the constraint area to the cheeks of the face where the faces cover more unit space.

Options common to all Geometry sections (Activate and Off)
Each section contains an Activate switch or an Off option.

- Click Activate (to turn it on) to tell Maya to acknowledge these option settings when making your selections.
- Click Off (to turn it on) to tell Maya not to acknowledge these option settings when making your selections.

Setting Area options for faces

![Area options for faces](image-url)
Maya selects the faces with an area that is within the range specified in the Min and Max boxes. See “Changing Min and Max values” on page 25 for details about using these values.

Setting Neighbors options for vertices and UVs

Maya selects the vertices with no fewer than the Min number of edges connected to them and no more than the Max number of edges connected to them.

| Min=1, Max=0 | Min=1, Max=3 | Min=4, Max=7 |

Setting Length options for edges

Maya selects the edges whose lengths are within the range specified in the Min and Max boxes.

Tip
Use this selection constraint option after collapsing edges (Edit Polygons > Collapse) to remove the extra tiny edges sometimes produced as a result of converting a NURBS object.

Setting Angle options for edges, vertices, and UVs

In the case of edges, Maya selects them according to the Min and Max range you set for the angle between them.
In the case of vertices, Maya selects them according to the range you set for the angle between the edges joining them.

In the case of UVs, Maya selects them according to the range set for the angle between the edges joining the UVs corresponding to vertices.

<table>
<thead>
<tr>
<th>Tip</th>
<th>This option works only for non-border edges.</th>
</tr>
</thead>
</table>

**Setting Mapped Area options**

These options are used to control the area range of components that are flattened out in the UV Texture Editor window.

**Unsigned**

If on, Maya selects all faces whose flattened areas (whether they are positive or negative) are within the minimum and maximum values you set. Unsigned tells Maya to ignore the direction the face normal is facing.

**Signed**

If on, Maya selects all faces whose normals are pointing in the same direction and whose flattened areas are within the minimum and maximum values you set.

**Min/Max values**

You can enter the minimum (Min) and maximum value (Max) for this area which lies in the UV plane. The mapped area of a flattened component can be positive or negative. It is positive if the face is seen from the front and negative if seen from the back.

**Setting Distance options**

These options are used to set a reference point and a valid range for the distance between the component, (such as the face center) and the point you specify.

**Point**

The Point option determines whether Maya acknowledges the distance to the origin you specify (the P, or PointX, PointY, or PointZ values).

**Axis**

The Axis option determines whether Maya acknowledges the distance to the line defined by its origin (P) and its axis (V).
2 | Selecting polygons

Reference > Edit Polygons > Selection > Selection Constraints

Plane

The Plane option determines whether Maya acknowledges the distance to the plane defined by its origin (P) and its normal (V).

Px, Py, Pz

These values are used to define the location of the point from which you want the selection to extend.

Vx, Vy, and Vz

If Axis is selected, these values define the axis along which the selection is made. If Plane is selected, these values define the normal vector along which the selection is made.

Setting Orientation options for faces, edges, and vertices

Orientation

The Orientation option determines whether Maya uses the orientation of the component for the selection.

Direction

The Direction option determines whether Maya uses the direction of the component or the selection. Using this option, even two faces facing opposite each other can be selected.

Vx, Vy, and Vz

These values define the axis along which the selection is made.

Setting Visibility options for faces, edges, and vertices

These options are used to set a target point and a focal angle for your selections. Maya selects a component if the target point can be viewed from the center of a face with its normal as the viewing axis (the Px, Py, and Pz values) and the angle as the field of vision.

Angle

This value determines a focal angle for selected components.

Px/Py/Pz

The Px value determines the location of the target point in the X axis, the Py value for the Y axis, and the Pz value for the Z axis.

Random option

Ratio

This value determines how many components to randomly select according to the ratio value you set within the face units. For example, 0=no faces, 1=all faces, or 0.5=50% of the faces.
Propagation options
You can extend your selection using the propagation options at the bottom of the window.

Off
This option is on by default. That means that no extensions are performed.

Shell
Select Shell to extend the selection up to the border of the individual piece within which the selection has been made. This option is useful for objects made from a series of individual pieces such as those produced when you use Polygons > Combine.

Border
Choose Border to select the border of the current selection only.

Tip
With Constrain set to All Next, select Inside as the Properties Location and Propagation Shell at the bottom of the Constraints window, then click a single face to selects all the faces that are inside your object.

Grow Selection Region, Shrink Selection Region, Select Selection Boundary buttons
These buttons work the same way as the corresponding Edit Polygons > Selection menu items.

• Click Grow Selection Region to increase the number of components you initially selected.

• Click Shrink Selection Region to decrease the number of components you have selected. This button can be useful if you want to shave off one face around every face in the current selection.

• Click Select Selection Boundary to define the boundary of the current selection region. This is a quick way to select the boundaries of whatever is currently selected (faces, vertices, edges, or UVs).
3 Create and Reshape polygons

About Polygons

Smoothing methods

Maya has several methods for smoothing polygons:

- Polygons > Smooth. Maya modifies the topology by smoothing out vertices and their connected edges.
- Polygons > Smooth Proxy. The same as Polygons > Smooth, but with a proxy of the original object that you can use to model and animate more easily.
- Polygons > Average Vertices. Maya averages the values of the vertices to produce a smoother surface without modifying the topology.
- Smooth option of the Sculpt Polygons Tool. The Sculpt Polygons Tools does not modify the topology.

Related topics

- "Smooth polygons" on page 37
How do I?  Create and edit models

Create and reshape polygons

Create a single faced polygon mesh

To create a new polygon

1  Select Polygons > Create Polygon Tool.
2  Click to place the first vertex.
   Maya places vertices on the ground plane unless you snap them to existing geometry.
3  Click to place the next vertex. Maya creates an edge between the first point and the last point you placed.
4  Place another vertex. A dashed edge connects the three vertices.
5  Do any of the following:
   •  Press Enter to finish the polygon.
   •  Press Delete to delete the last point you placed.
   •  Press Y to start a new polygon.
• Continue placing vertices to create a quad or n-sided polygon.
• To switch to editing vertices, press Home or Insert. A manipulator appears on the previous vertex. Use the manipulator to move the vertex, press Delete to delete a segment, or click another vertex to edit it. Press Home or Insert again to finish.

To add a connected polygon to an existing polygon

1 Select the polygon you want to append to.
2 Select Polygons > Append to Polygon Tool.
The border edges highlight and appear thicker.
3 Click the border edge you want to append to. The edge you select is the first edge of the new face. Arrows indicate the edge direction.
4 Click to place a vertex of the new polygon. You can also click another border edge to use it in the new polygon.
A new vertex appears with a line connecting it to the last point of the selected face edge.
5 Do any of the following:
• Continue placing vertices or selecting edges.
• To remove the last vertex you placed, press Delete.
• To switch to editing vertices, press Home or Insert. A manipulator appears on the previous vertex. Use the manipulator to move the vertex, press Delete to delete a segment, or click another vertex to edit it. Press Home or Insert again to finish.
• Press Enter to finish the polygon.
• Press Y to start a new polygon.

Note
Polygons > Append to Polygon Tool will not let you append to a non-boundary face.
If you want to append a face to a single non-boundary edge, use Edit Polygons > Extrude Edge, then modify the new face as desired.

To create a hole in a polygon as you draw it

1 Place the points of the polygon.
3 | Create and Reshape polygons
How do I? > Transform polygon components

2 Hold Ctrl and click the first point of the hole. You can then click the rest of the points without Ctrl held down.

3 Press Enter to finish the polygon.

You can also make a hole in an existing face with the Make Hole tool.

Related topics
- “Make a hole in a face” on page 138
- “Create > Polygon Primitives” on page 59
- “Polygons > Create Polygon Tool” on page 66
- “Polygons > Append to Polygon Tool” on page 68

Transform polygon components

You can use Maya’s Move, Rotate, and Scale tools to transform any objects and components, including polygon components.

For polygons, you can also use Edit Polygons > Move Component to create a history node to record moves, rotations, and scaling you apply to selected components.

You can select the transform node for subsequent operations without having to tediously reset the transform values.

Move Component also has additional constraints that Maya’s generic transformation tools do not have, such as moving perpendicular along normals.
3 | Create and Reshape polygons

How do I? > Transform polygon components

Notes
Avoid tweaks (moving CVs, moving polygon components with Move, Rotate or Scale) on objects with history. If you tweak an object with history, the tweak is applied to a specific component ID. Subsequent changes to the object’s history can cause the component IDs to change, altering the effect of the tweak.

For example, if you revolve a curve to create a surface, then tweak CV number 3 on the surface, the tweak will always apply to CV number 3. If you later change the revolve node attributes to reduce the number of segments on the surface, the CV that you tweaked will now have a new number, and the tweak will no longer be applied to it. The tweak will be applied to the CV that is now number 3, which may be in a different location on the surface.

Note
Deleting history on a polygonal object with animated vertex tweaks will result in the loss of the animation on the tweaks.

To create a history node to transform components

1. Select the components you want to move.
2. Select Edit Polygons > Move Component.
   Maya creates a transformation node (polyMoveComponentType) and automatically switches to the Show Manipulator tool, allowing you to edit the node.

3. Drag the manipulator handles to move, rotate, or scale the components, or change the settings in the Attribute Editor or the Channel Box.

Polygonal Modeling
35
3 | Create and Reshape polygons
How do I? > Transform polygon components

The manipulator is a standard move/rotate/scale combined manipulator, with an extra handle to switch between Local axes and World axes. Moving components along their local Y can be very useful to move components “inward” or “outward”.

![Manipulator](image)

**Move Vertex (local mode)**  
**Move Vertex (world mode)**

**Move Faces**  
**Move Edges**

When moving UVs
- The manipulator does not display if you use Move Component on UVs in the 3D view, but it does display in the UV Texture Editor.
- Local coordinate mode is not applicable for UVs.
- A texture must be assigned to the object to see the results in the 3D view.

Once you select the UVs on the object, use the options window or the Channel Box to change the settings and transform the UVs within the area you selected.

Use the UV Texture Editor window if you want more control when transforming UVs.

**Related topics**
- “Edit Polygons > Move Component” on page 83
Move vertices along their normals

1. Select the vertices.
2. Double click the Move tool to show its options panel.
3. In the options panel, set Move to Normal and turn on Update (UVN) Triad.
4. Drag the UVN manipulator to move the selected vertices.

Note  Avoid tweaks (moving CVs, moving polygon components with Move, Rotate or Scale) on objects with history. If you tweak an object with history, the tweak is applied to a specific component ID. Subsequent changes to the object’s history can cause the component IDs to change, altering the effect of the tweak.

For example, if you revolve a curve to create a surface, then tweak CV number 3 on the surface, the tweak will always apply to CV number 3. If you later change the revolve node attributes to reduce the number of segments on the surface, the CV that you tweaked will now have a new number, and the tweak will no longer be applied to it. The tweak will be applied to the CV that is now number 3, which may be in a different location on the surface.

Related topics
- “Transform polygon components” on page 34

Smooth polygons

To smooth by adding polygons

1. Select the mesh or just the faces you want to smooth.
2. Select Polygons > Smooth.
3 | Create and Reshape polygons
How do I? > Smooth polygons

To smooth by moving vertices
1 Select the mesh or just the vertices you want to smooth.
2 Select Polygons > Average Vertices.

You can apply this action repeatedly to smooth more and more (use the ‘g’ hotkey to repeat the last action), or you can choose Polygons > Average Vertices > and set the number of iterations to smooth.

To smooth by painting

“Smooth a mesh with the Sculpt Polygons tool” on page 101

What if...?

Polygons > Smooth works strangely or not at all?
Smoothing works with convex and even star-shaped concave faces. However, it can give unwanted results with concave faces where the center point is not inside the face.

To fix a concave faces, use Edit Polygons > Split Polygon Tool or Polygons > Triangulate.
Work on a simple model while a high density version automatically updates

You can reshape and animate a rough model (with fewer components to worry about) while seeing what the smoothed mesh will look like.

To set up a smooth proxy

1 Select the mesh.
   You must select the mesh object. Unlike with Polygons > Smooth, you cannot use Smooth Proxy on specific faces.

2 Select Polygons > Smooth Proxy.
   Maya creates a copy of the mesh and smooths it. The original polygon is the proxy mesh and the new, smooth polygon is the smooth mesh. Maya also creates a new group containing the smooth and proxy meshes, and a new layer for each mesh.

3 As you model the proxy mesh, the smooth mesh automatically updates.

Tip You can use Edit Polygons > Bevel on the proxy mesh to control the shape of the smooth mesh at a corner.
To control the visibility of the proxy and smooth mesh

- You can move the proxy mesh so it is beside the smooth mesh, letting you see both at once. However, do not rotate the proxy mesh (see notes).
- Maya adds both meshes to the Layer Editor. You can click the visibility icon next to their names to quickly show or hide each mesh.

To make either mesh partially transparent in shaded mode, assign a new material to the mesh, open its material node in the attribute editor, and change the transparency attribute.

To crease selected edges

1. Select the edges.
2. Use Edit Polygons > Normals > Soften/Harden > □ to harden the edges.
3. Select the Smooth Proxy node and set the Subdivision Method attribute to Exponential and turn on the Hard Edge attribute.

To map UVs onto the smooth mesh

You can use either the proxy or smooth mesh to edit UVs. For some UV mapping, such as Planar Mapping, you’ll get a more accurate outline of the surface with the smooth mesh.

1. Select the shape node of the smooth mesh.
2. In the attribute editor, open the Mesh Controls section and turn on the Allow Topology Mod attribute.
   As a precaution, turn the attribute off again after you have finished editing the smooth mesh.

To model an object symmetrically using Smooth Proxy

See “Model an object symmetrically” on page 47.

Notes

- In most cases you should only edit the proxy mesh, not the smooth mesh. If you edit the smooth mesh, further changes to the proxy mesh can interact with the edits to the smooth mesh to produce strange surface shapes.
The proxy mesh is part of the construction history input for the smooth mesh. All changes to the proxy mesh can affect the smooth mesh.

Rotating the proxy mesh can change the smooth surface in unexpected ways when you edit the proxy mesh. Instead, rotate the group that contains both meshes.

You cannot use either Polygons > Combine or Polygons > Boolean operations on a proxy mesh. These operations create new surfaces and therefore break the connection between the proxy and smooth meshes. If you need to use these operations, do so before using Smooth Proxy, or when you no longer want the proxy.

You can keep the proxy and smooth meshes connected throughout animation. The advantage is that you’ll have fewer components to manipulate. You may want to turn off the visibility of the smooth mesh layer in the Layer Editor.

High values in the Subdivision Levels attribute can slow Maya down. Try keeping Subdivision Levels low while modeling and increasing it just before rendering.

To do this automatically for a given object, open the Render Globals window, display the Render Options, and add the following command to Pre Render MEL:

```
setAttr polySmoothFace.X.divisions Y;
```

...where X is your object’s Smooth Proxy node number and Y is the high number of subdivisions, the maximum being 4.

Then, add the same command to Post Render MEL, but with Y as a low number of subdivisions.

The proxy mesh will render unless you hide it (using the ` hotkey), turn off Proxy Mesh Renderable, delete it, or put it on a hidden render layer (if you don’t want it to show up in rendered images).

What if...?

**Maya will not let me edit the smooth proxy?**

In most cases should only edit the proxy mesh, not the smooth mesh (see notes above). However, in some cases you can subdivide and edit components on a few faces, or soften or harden a few edges. Wait until the model’s topology is finalized before editing the smooth mesh.

Maya has two safeguards that prevent you from editing the smooth mesh directly. To disable them:
3 | Create and Reshape polygons
How do I? > Extrude a vertex, edges, or faces

1 In the Layer Editor, click the R box next to the smooth proxy to turn off the Reference setting for the layer. (Reference keeps you from editing a layer.)

2 Select the shape node of the smooth mesh.

3 In the attribute editor, open the Mesh Controls section and turn on the Allow Topology Mod attribute.
   As a precaution, turn the attribute off again after you have finished editing the smooth mesh.

Related topics
- “Model an object symmetrically” on page 47
- “Polygons > Smooth Proxy” on page 78

Extrude a vertex, edges, or faces

To extrude faces

1 Select the edges/or faces you want to extrude.

2 Select Edit Polygons > Extrude Face or Edit Polygons > Extrude Edge.
   The action creates an extrude node and switches to the Show Manipulator tool.

3 Do any of the following:
   - Use the manipulator to control the direction and distance of the extrusion. Remember that you can also change the pivot by pressing Insert or Home. Click the circle handle attached to the manipulator to switch between local and world axes.
3 | Create and Reshape polygons

How do I? > Extrude a vertex, edges, or faces

Use the controls in the attribute editor or channel box to edit the extrusion. See “Edit Polygons > Extrude Face, Extrude Edge” on page 86.

You can scale and rotate the extrusion along its length to create interesting effects.

Note Extruding edges can make your mesh non-manifold. Use Polygons > Cleanup to fix non-manifold geometry.

Extrude edges or faces along a path curve

1 Select the edges/or faces you want to extrude and the curve you want to extrude along.

2 Choose Edit Polygons > Extrude Face □ or Edit Polygons > Extrude Edge □.

3 Turn on the Use selected curve for extrusion option.

4 Click Extrude.
3 | Create and Reshape polygons
How do I? > Extrude a vertex, edges, or faces

5 Use the controls in the attribute editor or channel box to edit the extrusion. See “Edit Polygons > Extrude Face, Extrude Edge” on page 86.

For example, increase Divisions so the extruded polygons better match the shape of the curve.

Reduce Taper so the extruded polygons gradually become narrower along the curve. (You can also use the Taper Curve controls to create more complex tapers.)

Adjust Twist so the extruded polygons rotate along the curve.
Extrude a vertex

Extrudes the selected vertex along its vertex normal, creating additional faces for each face that shares the vertex.

1 Select the vertex you want to extrude.
2 Choose Edit Polygons > Extrude Vertex > □.
3 Set the length to extrude the vertex and click Extrude.

Keep faces together attribute

The Keep Faces Together attribute controls how Maya treats the edges of adjacent faces. When Keep Faces Together is on, the faces expand so their edges stay connected. When Keep Faces Together is off, Maya creates new polygons along the edges of the faces as they extrude.

Note When Keep Faces Together is off, each face becomes a separate mesh.

Related topics

- “Extrude polygons in an arc (wedge)” on page 46
- “Edit Polygons > Extrude Face, Extrude Edge” on page 86
- “Edit Polygons > Extrude Vertex” on page 89
Extrude polygons in an arc (wedge)

You can use Edit Polygons > Wedge Faces to quickly create:

- arches in buildings
- knees and elbows in characters
- curved sections of roads or tunnels

To extrude wedges

1. Select a face, then select the edge or edges the wedges will pivot around.

   For best results, select only one edge or edges in a straight line.

2. Select Edit Polygons > Wedge Faces.

Related topics

- “Extrude a vertex, edges, or faces” on page 42
- “Edit Polygons > Wedge Faces” on page 90

Model one half of an object and mirror the other half

You can duplicate and flip geometry across its bounding box. You can also merge the duplicated polygons with the original mesh.

To mirror polygons across the edges of their bounding box

1. Select the polygons and choose Polygons > Mirror Geometry > □.
2 Choose the direction to mirror the polygons and whether to merge the duplicated polygons into the original mesh.

3 Click Mirror.

**To mirror polygons across their pivot point**

1 Select the polygons and choose Edit > Duplicate > □.
2 Set the Translate and Rotate values to 0.
3 Set the scaling to -1 for the axis (X, Y, or Z) across which you want to mirror the polygons.
4 Click Duplicate.

**Related topics**

- "Duplicate faces" on page 49
- "Polygons > Mirror Geometry” on page 72

**Model an object symmetrically**

You can model an object symmetrically using:

- Polygons > Mirror Cut
- Polygons > Smooth Proxy with Mirror option

**To model an object symmetrically with Mirror Cut**

1 Select a mesh.
2 Select Polygons > Mirror Cut.

3 Use the manipulator to adjust the plane of symmetry.
3 | Create and Reshape polygons
How do I? > Model an object symmetrically

To model an object symmetrically with Smooth Proxy

1  Select a mesh.

2  Select Polygons > Smooth Proxy > □, set Mirror Behavior to Full, set the Mirror Direction, and click Smooth. The original mesh is mirrored along the Mirror Direction.

3  Modify one half of the smooth proxy (for example, using Edit Polygons > Extrude Face). The modification automatically updates on the opposite half of the smooth proxy.

Notes
• If you position the plane of symmetry so it is beyond the positive edge of the original object, then both the original object and its mirror image will disappear (except for one face on each). If you want to mirror the object in the direction of its positive edge, then move the symmetry plane so it intersects the original object and rotate the symmetry plane 180 degrees.
• When you delete history of an object on which you have applied Polygons > Mirror Cut, the plane of symmetry is not deleted. You must manually delete the plane of symmetry.
Note  Mirroring only works across the world axes. Mirroring an object that has been arbitrarily rotated may produce unexpected results; some geometry may be overlapping.

Note  If you modify the mirrored half of the smooth proxy in object space mode, dragging a manipulator in one direction will modify the proxy in the opposite direction.

If you modify the mirrored half of the smooth proxy in world space mode, dragging a manipulator in one direction will modify the proxy in the same direction.

If you modify the original half of the smooth proxy, in object space or world space mode, dragging a manipulator in one direction will modify the proxy in the same direction.

Tip  After you have created a symmetrical model using Polygons > Smooth Proxy (with Mirror Behavior set to Full), use Polygons > Unmirror Smooth Proxy to remove the smooth mesh. Then use Polygons > Smooth Proxy (with Mirror Behavior set to None) to create a smooth mesh that you can animate non-symmetrically.

Related topics
- “Model one half of an object and mirror the other half” on page 46
- “Work on a simple model while a high density version automatically updates” on page 39
- “Polygons > Mirror Cut” on page 74
- “Polygons > Smooth Proxy” on page 78
- “Polygons > Unmirror Smooth Proxy” on page 83

Duplicate faces

To duplicate faces

1  Select the faces you want to duplicate and choose Edit Polygons > Duplicate Face > □.
3 | Create and Reshape polygons
How do I? > Duplicate faces

2 If you want the duplicate faces to become their own mesh, turn on Separate. Turn off Separate to make the duplicated faces part of the existing mesh.

If you know the exact transformation values you want to use, you can enter them in the option box, otherwise you can specify them interactively later.

3 Click Duplicate.

The action creates a node and switches to the Show Manipulator tool.

4 Do any of the following:
   • Use the manipulator to control the direction and distance of the duplication. Remember that you can also change the pivot by pressing Insert or Home. Click the circle handle attached to the manipulator to switch between local and world axes.

   • Use the controls in the attribute editor or channel box to edit the duplicates.

Keep faces together attribute
The Keep Faces Together attribute controls how Maya treats the edges of adjacent faces. When Keep Faces Together is on, the faces expand so their edges stay connected.
**3 | Create and Reshape polygons**

How do I? > Bevel edges

---

**Duplicate Face**

Keep Faces Together  off

Keep Faces Together  on

---

**Note**  
When Keep Faces Together is off, each face becomes a separate mesh.

**Related topics**

- “Transform polygon components” on page 34
- “Disconnect faces from their shared edges (extract)” on page 117

**Bevel edges**

Beveling expands each vertex and each edge into a new face. You can position these faces at an offset or scale them towards the original face center using the Bevel options.

**Note**  
Bevel your object before you assign a texture to it. You will lose the texture coordinates and face material assignments if you bevel a textured object.

**To bevel edges**

1. Select a the mesh or edges you want to bevel.  
   If you select a mesh object, Maya will bevel every edge in the mesh.

2. Select Edit Polygons > Bevel.
You can edit the bevel in the channel box or the attribute editor after you perform the operation.

What if...?

**Bevel works strangely or not at all?**

Bevel works with convex and even star-shaped concave faces. However, it can give unwanted results with concave faces where the center point is not inside the face.

To fix a concave faces, use Edit Polygons > Split Polygon Tool or Polygons > Triangulate.

**Related topics**

- “Chamfer a vertex” on page 52
- Edit Polygons > Bevel

**Chamfer a vertex**

Removes a vertex and creates a chamfered corner.

1. Select the vertex you want to chamfer.
2. Choose Edit Polygons > Chamfer Vertex.

**Notes**

Because of the way Chamfer Vertex works internally, the node it creates has Length and Divisions attributes. These attributes are locked and are not meaningful to edit.

**Related topics**

- “Bevel edges” on page 51

**Fill gaps with polygons**

You can use Fill Hole to create a face to fill a closed border edge.
3 | Create and Reshape polygons

How do I? > Reshape a polygonal surface using Soft Modification

This tool can be especially useful when importing foreign polygonal models that may have holes, or to correct and rebuild models that have been damaged when importing.

**To fill holes in polygons**

1. Select the border edge you want to fill.
2. Select Edit Polygons > Fill Hole.

This action creates a node called polyCloseBorder.

| Tip | To highlight border edges, select Display > Polygon Components > Border Edges. |

Reshape a polygonal surface using Soft Modification

See *Use the Soft Modification Tool* in the Character Setup book.

**Related topics**

- Soft Modification tool
- Deform > Soft Modification
- *Use the Soft Modification Tool*

**Convert geometry from one type to another**

**Convert NURBS to polygons**

You can convert any NURBS surfaces created in or imported into Maya, including trimmed surfaces.
How do I? > Convert NURBS to polygons

If the NURBS surface has a texture applied to it, this texture is assigned to the new polygonal object. The NURBS to Polygons action bakes the NURBS UV values onto the corresponding polygonal vertices.

**To convert NURBS to polygons**

1. Select the NURBS surface and choose Modify > Convert > NURBS To Polygons. A polygonal representation of the surface is created at the same position as the NURBS surface.

If you convert the NURBS surface with construction history on, you can edit the NURBS surface and the polygonal surface will be recreated to match.

**Notes**

- If a NURBS surface is converted into a polygonal object using NURBS To Polygons functionality, and if the history of the NURBS surface is modified to generate an invalid (Null) NURBS surface, the following warning message displays:


  and the NURBS To Polygons operation will not be successfully performed. The resulting polygonal object will continue to be the last valid (computed) polygonal surface that was visible.

- In some cases when converting multiple NURBS patches to a single polygonal mesh you may notice strange shading effects on the mesh. This is because of the normals. To correct the shading due to normals, see “Manipulate vertex normals to affect shading of polygons” on page 139.

**Related topics**

- “Modify > Convert > NURBS to Polygons” on page 55
Reference  Menus

Modify

Modify > Convert > NURBS to Polygons

Converts the selected NURBS objects to polygons.

Related topics

✓ “Convert NURBS to polygons” on page 53

Modify > Convert > NURBS to Polygons > □

Attaching multiple output meshes

Attach Multiple Output Meshes

Produces a single mesh, even if the original NURBS object consists of separate surfaces.

For example, if you convert a NURBS cube (which consists of six separate faces) with Attach Multiple Output Meshes on, the resulting polygon cube will consist of a single mesh. If Attach Multiple Output Meshes is off, the polygon cube will consist of six separate meshes.

Merge Tolerance

Controls how close vertices must be in order to be merged into a single mesh (when Attach Multiple Output Meshes is on).

Outputting to triangles or quads

Type

Select the type of polygons to use when you convert NURBS geometry to polygonal data.

If you select Triangle (the default), 3-sided polygons are created. If you select Quads, 4-sided polygons are created.
Choosing a tessellation method

Tessellation means that you create a set of polygons from NURBS geometry. Each tessellation method provides you with options that let you control the resulting polygonal surface.

There are four tessellation methods: “Standard fit”, “General”, “Count”, and “Control Points”.

**Standard fit**

Standard Fit is the default tessellation method. It is “adaptive” tessellation, meaning that the following options are used to determine when to stop the tessellation.

For example, the tessellation stops at the Fractional Tolerance value you set. If there is an edge shorter than the Minimal Edge Length, the tessellation stops on that edge. If the surface is flat enough within the edge (the specified chord/height ratio is small enough), the tessellation stops there.

**Chord Height Ratio**

The Chord Height Ratio is the ratio between the maximum distance of the curve from the polygon edge used to approximate it and the chord length. The chord length is the linear distance between two polygon vertices.

Valid values range between 0 and 1, where larger values result in fewer polygon vertices.

For example, the default value, 0.1, means that the height must be larger than 1/10 of the chord length before additional edit points are created.
3 | Create and Reshape polygons
Reference > Modify > Convert > NURBS to Polygons

Fractional Tolerance
The Fractional Tolerance value determines the degree of accuracy maintained between the original surface and the interpolated polygonal surfaces. The default is to be accurate to within 0.01 units, where a unit refers to the current unit of linear measure (the default unit of measure is centimeters). Therefore, at no point will the polygonal surface be more than the tolerance distance away from the original NURBS surface.

In this next example, notice how you can enhance the polygonal surface’s accuracy when you change the Fractional Tolerance value from 1 to 0.01.

Minimal Edge Length
Enter a value or use the Minimal Edge Length slider to set the minimum length of the edges of the triangles or quads that are created.

3D Delta
The 3D Delta value determines the 3D spacing for U and V isoparms on a surface that makes up the initial grid for the tessellation. In the following example, the 3D Delta value is changed from the default 0.1 to 1.0.

General
Set the Tessellation Method to General to display the following options.
**3 | Create and Reshape polygons**
Reference > Modify > Convert > NURBS to Polygons

Setting the initial tessellation controls
Unless Use Chord Height or Use Chord Height Ratio is turned on, a uniform tessellation is performed. Each span/surface is split into a number of polygons depending on the Number U and V values you set.

**U Type/V Type**
The U Type and V Type pop-up menu items let you specify whether you want to split the surface based on where the spans are (then split each span), or based on the parameterization of the whole surface.

![Per Surf U value = 3](image1)
![Per Surf U value = 20](image2)

**Number U/Number V**
Each span or surface is split into the number of polygons you specify here.

![Per Span U = 20](image3)
![Per Span V = 20](image4)

**Specifying the secondary tessellation controls**
If Use Chord Height or Use Chord Height Ratio is turned on, you can set a specific value for both the Chord Height and the Chord Height Ratio. A value greater than 0 results in fewer polygon vertices if the ratio on the curve is greater than the current value. For example, the default value, 0.1, means that the height must be larger than 1/10 of the chord length before additional edit points are created.

Turn Edge Swap on to produce triangles with the opposite orientation for the final quadrilateral.
Count
Set the Tessellation Method to Count to display the following slider.

Count slider
Use the Count slider to determine how many polygons the surface can be tessellated into. See the following examples.

Control Points
This tessellation method converts the NURBS model to polygons while matching the CVs of the original NURBS surface. There are no other options for this operation.

Notes
When you use the Control Points Tessellation Method:

- The Type option you set is ignored and the resulting polygon is in Quads by default.
- If you convert trimmed NURBS surfaces the surfaces convert as though they were not trimmed.

Create
Create > Polygon Primitives
Creates a polygon-based geometric primitive at the origin. You can then move, scale, rotate, and reshape the new object using the standard tools and polygon menu items.
Create > Polygon Primitives > (shape) > □

**Radius**

The Radius value specifies the distance from the center of the primitive in all directions. Polygonal primitives that have this option include Spheres, Cylinders, Cones, and Tori.

Adjusting the Radius for these primitives is like changing the width for primitives that do not have circumference (like primitive planes and cubes).

<table>
<thead>
<tr>
<th>Default=1.0</th>
<th>Radius=2.0</th>
<th>Default=1.0</th>
<th>Radius=2.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sphere</td>
<td>Cylinder</td>
<td>Cone</td>
<td>Torus</td>
</tr>
</tbody>
</table>

**Section Radius (torus)**

The Section Radius option value specifies the size of the sections that make up a Torus. Change this value to increase or decrease the radius of these sections.

<table>
<thead>
<tr>
<th>Section Radius=0</th>
<th>Section Radius=1</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Twist (torus)**

The Twist option value specifies the twist angle of the torus. Change this value to adjust the distance around the Torus in all directions.

**Subdivisions**

The values you enter in these boxes change the primitive by adding or taking away faces of the polygon.
For primitives without caps (or sides) you can only subdivide in the X and Y direction. These include Spheres, Planes, and Tori.

For primitives with caps, you can subdivide in all three directions, X, Y and Z. These include Cones, Cubes and Cylinders.

**Subdivisions Axis**

For spheres, cylinders, cones, and tori, this option defines the number of subdivisions there are around the axis defined by the Axis option. This option is also called Subdivisions Axis in the Channel Box and the Attribute Editor.

Increase or decrease this value to add or take away faces around the axis defined by the Axis option.

**Subdivisions Height**

This option defines the number of subdivisions there are along the axis defined by the Axis option. Height is equivalent to the Y direction by default. This option is also called Subdivisions Height in the Channel Box and the Attribute Editor. Increase or decrease this value to add or take away faces in the Axis direction.
Subdivisions along Depth

When Axis is set to X or Y, depth is equivalent to the Z direction for polygonal cubes. When Axis is set to Z, depth is equivalent to the Y direction. This option is also called Subdivisions Depth in the Channel Box and the Attribute Editor. Increase or decrease this value to add or take away faces along the depth.

Subdivisions on Caps

Caps are the tops, bottoms, or sides of Cones and Cylinders. This option defines the number of subdivisions around the origin of the primitive caps. This option is also called Subdivisions Cap in the Channel Box and the Attribute Editor. Increase or decrease this value to add or take away faces around the caps.

Width and Height

Enter values or use the slider to specify the height or width of a primitive. For polygonal primitive Cones and Cylinders, the Radius value is like the Width of the primitive so only the Height option applies. For primitive Planes and Cubes, both Width and Height values can be adjusted.

For a primitive plane, the Width value increases or decreases the plane along the X axis while the Height value increases or decreases the plane along the Z axis.
Changing a primitive’s orientation

By default, a primitive is created along the Y axis. You can change a primitive’s default orientation before you create it by changing the Axis option.

You cannot change the orientation for a new primitive from the Channel Box, but you can enter values in the Axis boxes in the Attribute Editor.

Preparing a primitive for texture mapping

By default, UV values are assigned for texture mapping. If you do not plan to map textures on a polygonal primitive, you can turn off the Texture option in the options window. Texture is on by default.

Important note about UVs

It is important to make sure UVs are present on an object or you cannot see the mapped textures in the view. This can happen if you inadvertently create a primitive object with the Texture option turned off or set to None.

To correct the problem, select the faces of the primitive and use any of the mapping items in the Edit Polygons > Texture sub-menu.

You can then use the UV Texture Editor to view the created UVs. Select the object and use any of the UV creation or editing Texture menu items.

Texture mapping options for primitive Cubes and Cylinders

The options window for a polygonal Cube and Cylinder primitive includes a Texture pop-up menu where you can select how you want the texture to cover the primitive when you assign it. This pull-down menu is also available from the Attribute Editor.

None

Selecting None is like turning Texture off for polygonal primitive Spheres, Cones, or Tori.

Normalize the whole object/object

The default setting maps the texture over each face of the primitive and normalizes it so that it covers the entire object.
3 | Create and Reshape polygons
Reference > Create > Polygon Primitives

Normalize each face separately/face
If you select this option, Maya maps the texture to each face separately.

Normalize the caps separately/face
For cylinders only. If you select this option, Maya maps the texture separately to each cap of the cylinder.

Texture mapping options for primitive Planes
The options window for a polygonal Plane primitive includes a Texture pop-up menu where you can select an item to specify how you want the texture to behave when you transform the plane after it is created. This pop-up menu is also available from the Attribute Editor.
3 | Create and Reshape polygons
Reference > Create > Polygon Primitives

Selecting None is like turning Texture off for polygonal primitive Spheres, Cones, or Tori.

Stretch to fit object/Stretch to fit

This is the default setting. When you change the shape of the primitive plane by adjusting the options in the option window or by adjusting the Width and Height in the Channel Box, the texture stretches to fit within the plane’s transformed shape.

The following example shows a rock texture mapped to a plane whose Width has been changed to 3.

Preserve Aspect ratio/Preserve Aspect Ratio

If you select this option, when you change the Width of the primitive plane, the texture fits uniformly to the new dimensions of the object.
Modeling menu set

Polygons

Polygons > Create Polygon Tool

Lets you create polygons by placing vertices in the view windows.

Related topics

* “Create a single faced polygon mesh” on page 32

Polygons > Create Polygon Tool > □

Subdivisions

Use the slider or enter a value to change the number of subdivisions that are distributed along the edges of the polygon being created. The default is 1. Extra vertices are created along the edges. You can manipulate these vertices in subsequent operations.

This is not the same as subdividing polygons using Edit Polygons > Subdivide. When using the Subdivide operation, new faces are created by default. To create new vertices, you have to subdivide the edges specifically (see “Split faces into triangles or quadrangles” on page 120 for details).

![Newly created polygon, Subdivisions = 1.](image1)

![Same polygon subdivided using Edit Polygons > Subdivide, Subdivisions = 1.](image2)

Limit Points To

This value specifies how many vertices the new polygon will have. The polygon closes automatically after you place the number of points specified here and you can continue to click to create new polygons in the view without re-selecting the tool.

Ensure Planarity

By default, any faces you add are in the same plane as the polygonal object you append to. Turn off Ensure Planarity if you want to add faces in another plane using Append to Polygon or if you select the Append Operation.
Changing Texture options

Select a how texture coordinates (UVs) are created for the new polygon.

Normalize/Unitize

If Normalize is selected, the texture coordinates are scaled to fit into the 0 to 1 texture space.

If Unitize is selected, the texture coordinates are placed on the corners and boundary of the 0 to 1 texture space. A polygon with three vertices will have a triangular UV texture map (with sides of equal length), while a polygon with more than three vertices will have a square UV texture map.

Switching between operations

Create is the default Operation. Select Append if you want to add to the newly created polygon and click to place points on the border edge. Press to complete the polygon.
3 | Create and Reshape polygons
Reference > Polygons > Append to Polygon Tool

Subdivision
Use the slider or enter a value to change the number of subdivisions that are distributed along the edges of the newly created polygon. The default is 1.

Vertices
These values represent the position of the vertices you placed when creating the polygon. For example, if you placed three vertices (as in the example in the Attribute Editor), only three sets of values display. Change these values and press to move the vertices and change the shape of the polygon.

Polygons > Append to Polygon Tool
Lets you draw new polygons starting with an edge from an existing polygon.

Related topics
“Create a single faced polygon mesh” on page 32

Polygons > Append to Polygon Tool > □
Use these sliders and select from the Texture menu options to adjust the final outcome of the texture coordinates (UVs) on the new polygon.

You can set these options before you create your polygon, or you can always change the options as you work.

Subdivisions
Use the slider or enter a value to change the number of subdivisions that are distributed along the edges of the polygon being appended. The default is 1. Extra vertices are placed along the edges to create the subdivisions.

The following example shows the appended polygon subdivided with a setting of 4.
3 | Create and Reshape polygons
Reference > Polygons > Append to Polygon Tool

Limit Points To
The value you specify here indicates how many vertices are allowed on the new polygon. If set to 3 or more, you can create polygonal strips. Using this option, you can continue to append to polygons without re-selecting the tool.

Rotation Angle
This option becomes available while you are placing points to append to the polygon. Use the slider to rotate the new points before you complete the append operation.

The newly created face rolls around the first edge you selected. If all the edges can be set on a hinge, the face turns around the reference line. If the edges you select are not aligned, the face will not turn around this reference line.

Ensure Planarity
By default, any faces you add are in the same plane as the polygonal object you append to. Turn off Ensure Planarity if you want to add faces in another plane.
3 | Create and Reshape polygons
Reference > Polygons > Append to Polygon Tool

When you turn on or off Ensure Planarity, Maya also turns on or off the global setting Polygons > Tool Options > Keep New Faces Planar. The setting is saved to the preferences file when you exit Maya. It applies to all new objects until you change the setting.

Changing Texture options
Select how texture coordinates (UVs) are created for the appended polygon.

Normalize/Unitize
If Normalize is selected, the texture coordinates are scaled to fit into the 0 to 1 texture space, maintaining the shape of the face.

If Unitize is selected, the texture coordinates are placed on the corners and boundary of the 0 to 1 texture space. A polygon with three vertices will have a triangular UV texture map (with sides of equal length), while a polygon with more than three vertices will have a square UV texture map.
3 | Create and Reshape polygons
Reference > Polygons > Average Vertices

Switching between operations
Append is the default Operation. Select Create if you want to create a new polygon.

Poly Append History
Subdivision
Use the slider or enter a value to change the number of subdivisions that are distributed along the edges of the polygon being appended. The default is 1.

Vertices
These values represent the position of the vertices you placed when appending to the polygon. For example, if you placed three vertices (as in the example of the Attribute Editor), only three sets of values display. Change these values and press to move the vertices and change the shape of the appended polygon.

Polygons > Average Vertices
Smoothes the polygon mesh by moving vertices. Unlike Polygons > Smooth, this does not increase the number of polygons in the mesh.

Related topics
◆ “Smooth polygons” on page 37
Polygons > Average Vertices > □

Iterations
Maya applies smoothing to the selection this many times for every time you choose Polygons > Average Vertices or click the Apply button. Increase this number to smooth by large amounts quickly.

Polygons > Mirror Geometry
Quickly creates a duplicate of the selected polygons mirrored across an axis.

Related topics
❖ “Model one half of an object and mirror the other half” on page 46

Polygons > Mirror Geometry > □

Mirror direction
Select the direction in which direction you want Maya to mirror the selected polygonal object. By default, the direction is positive X.
Change these options and click Mirror if you want to mirror the object in another direction.

**Merge with the Original**

When turned off, Maya duplicates and flips the original polygon but does not merge the separate shells.

When turned on (the default setting), Maya duplicates and flips the original polygon and merges the duplicate polygon with the original polygon. This makes the new polygonal object one shell. Select how you want the polygons to merge.

**Merge Vertices**

Select this option to merge adjacent vertices, creating a single shell.
Connect Border Edges

Select this option to connect the original polygon with the mirrored polygon at the all border edges, filling in faces to create a closed shape.

Polygons > Mirror Cut

Polygons > Mirror Cut creates a plane of symmetry that mirrors the selected object. You can position the symmetry plane using the manipulator. Changes that you make to the original object are then updated on the mirrored object. This can make symmetrical modeling of certain types of objects much easier (for example, creating an environment with streets, creating a skateboard park).

Related topics

- “Model an object symmetrically” on page 47
Polygons > Mirror Cut > □

Cut Along

The pair of axes to mirror the object across: YZ, XZ, or XY.

Combine Meshes

Combines the original object and the mirrored object into a single mesh. Changes that you then make to the original object are not updated on the mirrored object.

Merge Vertex Tolerance

Vertices within this distance of each other will be merged. This option is only available when Combine Meshes is on.

Polygons > Smooth

Smooths the selected polygon mesh by adding polygons.

Related topics

❖ "Smooth polygons" on page 37

Polygons > Smooth > □

Tip

You can repeatedly smooth selected polygonal faces if you keep clicking the Smooth or Apply button in the options window.

Subdivision Method

The Exponential and Linear smoothing algorithms both smooth equally, but they offer different controls for the resulting topology. For example, Exponential has an option to maintain soft and hard edges, while Linear has options to better control the number of resulting faces.

You can switch between the two methods by changing the Method attribute on the polySmoothFace node.

Exponential Smoothing Controls

The following options are available when you choose Exponential as the Subdivision Method.
Subdivision Levels

Use the slider or type a number in the Subdivision Levels box to increase or decrease the number of times Maya performs the smoothing operation. This also increases or decreases the object’s smoothness. The Divisions range is from 1 to 4. The higher the value, the smoother the object.

Select several faces.  Division set to 1.  Division set to 2.

Continuity

The value you enter here determines the degree of smoothness.

Continuity set to 0.0.  Continuity set to 0.2.  Continuity set to 0.5.

Smooth UVs

Applies the same smoothing operation to the UVs as to the vertices. Smooth UVs is on by default, providing better results for UVs.

Turn off Smooth UVs if you want to maintain compatibility with scenes created in older versions of Maya, or if the UVs do not need to be smoothed and you want to improve performance.

Preserve Properties

Keep Geometry Borders

When turned on (the default), this option preserves the properties of the border edges of the geometry.
Keep Selection Borders

When turned on (the default), this option preserves the properties of the edges bordering the selected and non-selected faces.

Keep Hard Edges

If you have changed the hardness or softness of edges (Edit Polygons > Normals > Soften/Harden), turn this option on to maintain those settings.

Keep Tessellation

Turn this option on so that when changes are made to the history nodes, the smooth node does not redo the tessellation, but just repositions the generated vertices.

Keep Map Borders

Controls how borders are smoothed when Smooth UVs is on.

None          Borders are not smoothed.
Internal      Internal borders are smoothed.
All           All borders are smoothed.

Linear Smoothing Controls

The following options are available when you choose Linear under Subdivision Method. The Linear smoothing method gives you more control over the number of faces resulting from the smooth, especially the “Divisions Per Face” attribute.
Do not use the Linear method on a surface with faces that have over four edges. The resulting smooth surface will be uneven. Use Polygons > Triangulate or Polygons > Cleanup before performing the smooth.

**Subdivision Levels**

The number of times Maya performs smoothing. The higher the value, the smoother the object and the more faces are generated.

**Note** Changing both Subdivision Levels and Divisions Per Face can create an extreme number of faces, causing interactive performance to drop dramatically.

**Divisions Per Face**

Increases the number of faces in smaller increments than Subdivision Levels. Using this option, you can more easily achieve a balance between smoothness and a low polygon count.

The face count increases as a result of dividing each face. Maya divides each face by splitting the existing edges. The value you set is the number of splits Maya makes. A value of 1 means Maya splits each edge once, a value of 2 means Maya splits each edge twice, and so on.

**Push Strength**

Controls the overall volume of the resulting smooth surface. Use higher values to scale outward or lower values to scale back.

**Roundness**

Creates a bulge in the surface by scaling vertices around the center of the original faces. Use higher values to scale these vertices outward or lower values to scale them back. For Roundness to have an effect, Push Strength must be greater than zero.

**Polygons > Smooth Proxy**

**Related topics**

- “Work on a simple model while a high density version automatically updates” on page 39
- “Model an object symmetrically” on page 47
- “Polygons > Unmirror Smooth Proxy” on page 83
Hotkeys

<table>
<thead>
<tr>
<th>Hotkey</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>` (left single quote beside the 1 key)</td>
<td>Turns on/off the display of the proxy mesh or the smooth mesh.</td>
</tr>
<tr>
<td>Shift + `</td>
<td>Displays both the proxy mesh and the smooth mesh.</td>
</tr>
<tr>
<td>Ctrl + `</td>
<td>Polygons &gt; Smooth Proxy</td>
</tr>
<tr>
<td>Ctrl + Shift + `</td>
<td>Polygons &gt; Smooth Proxy &gt; □</td>
</tr>
<tr>
<td>Page Up</td>
<td>Increases the denseness of the smooth mesh.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Decreases the denseness of the smooth mesh.</td>
</tr>
</tbody>
</table>

**Polygons > Smooth Proxy > □**

For information on options that are not in the Setup or Display Settings sections, see Polygons > Smooth.

**Setup**

**Mirror Behavior**

Controls how the smooth mesh and proxy mesh are mirrored and/or located relative to each other.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>The smooth mesh is created within the proxy mesh.</td>
</tr>
<tr>
<td>Full</td>
<td>The smooth mesh is created within the proxy mesh, and both the proxy mesh and the smooth mesh are mirrored about the Mirror Direction. Adjustments that you make to one half of the proxy mesh are automatically mirrored onto the other half, making symmetrical modeling much easier.</td>
</tr>
<tr>
<td>Half</td>
<td>The smooth mesh is created adjacent to the proxy mesh (based on the Mirror Direction). This allows you to modify the proxy mesh and clearly see the result on the smooth mesh.</td>
</tr>
</tbody>
</table>
3 | Create and Reshape polygons
Reference > Polygons > Smooth Proxy

Note
You would usually use mirroring for modeling an object, not animating it. Otherwise, the object’s animation would be symmetrical.

After you have finished modeling an object with mirroring, use Polygons > Unmirror Smooth Proxy to remove the smooth mesh. Then create a new smooth proxy (with Mirror Behavior set to None) for animating the object.

Note
If you modify the mirrored half of the smooth proxy in object space mode, dragging a manipulator in one direction will modify the proxy in the opposite direction.

If you modify the mirrored half of the smooth proxy in world space mode, dragging a manipulator in one direction will modify the proxy in the same direction.

If you modify the original half of the smooth proxy, in object space or world space mode, dragging a manipulator in one direction will modify the proxy in the same direction.
3 | Create and Reshape polygons
Reference > Polygons > Smooth Proxy

Mirror Direction
The direction that the selected mesh will be mirrored.

Smooth Proxy will mirror the proxy mesh at the extent of its bounding box in the Mirror Direction.

Merge Vertex Tolerance
When a vertex on the original mesh and its corresponding mirrored vertex are closer than the Merge Vertex Tolerance, then they will be merged into a single vertex.

Share Transform Node
Controls whether the smooth mesh is transformed when you transform the proxy mesh.

For example, you may prefer to move the proxy mesh away from the smooth mesh in order to adjust the proxy mesh and clearly see the effect on the smooth mesh. In this case, turn off Share Transform Node.

Or you may prefer to keep the proxy mesh and smooth mesh together. In this case, turn on Share Transform Node.

On If you transform the proxy mesh, the smooth mesh will also be transformed.

Off If you transform the proxy mesh, the smooth mesh will not be transformed.

Note Mirroring only works across the world axes. Mirroring an object that has been arbitrarily rotated may produce unexpected results; some geometry may be overlapping.

Tip When working with Smooth Proxy, you can save the lo-res mesh and use it for fast interactive playback.

Use Polygons > Smooth Proxy with Share Transform Node turned off. Bind the proxy mesh to a skeleton, and hide the smooth mesh using the hotkey ` (left open quote beside the 1 key). The low res mesh will provide fast interactive playback. To display the smooth mesh (for example, for rendering), press the ` hotkey again. (Or turn off the Proxy Mesh Renderable option so the proxy mesh is not rendered.)
3 | Create and Reshape polygons
Reference > Polygons > Smooth Proxy

Note
If you create a smooth proxy with Share Transform Node turned on, and then delete history on the proxy mesh, the proxy mesh and smooth mesh will appear to become a single object. This is because they share a transform node. To select either the proxy mesh or the smooth mesh (for example, in order to delete one of them), press the down arrow key and then press either the left or right arrow key.

Display Settings
Smooth Proxy Shader
Controls the appearance of the proxy mesh’s material to best suit the way you like to work. Transparency assigns a new Lambert material with partial transparency to the proxy mesh. Remove eliminates the connection between the proxy mesh and its material. Keep maintains the original connection between the proxy mesh and its material. If you choose Keep, you’ll need to move the proxy and smooth mesh side-by-side.

Proxy Transparency
Sets the Transparency attribute of the proxy mesh material. This material is created by the Smooth Proxy operation.

Proxy Mesh Renderable
Controls whether the proxy mesh is rendered (on) or not (off).

Proxy Mesh In Layer
When on, Maya adds the proxy mesh to a new layer so you can control the visibility of the proxy mesh. When off, no layer is created. For example, if the object is already in another layer, you might want to turn off this option so that the proxy mesh only belongs to one layer and not two.
Smooth Mesh In Layer
Determines whether or not Maya adds the smooth mesh to a layer in the Layer Editor.

Smooth Layer Display
Sets the default state for the smooth mesh layer: Normal, Template, or Reference. The default is Reference because this restricts you from editing the smooth mesh directly.

Polygons > Unmirror Smooth Proxy
Removes the smooth mesh created by Polygons > Smooth Proxy (with Mirror Behavior set to Full) and combines the two halves of the proxy mesh (the original mesh and the mirrored mesh) into a single mesh (similar to using Polygons > Mirror Geometry on the original mesh).

Adjustments that you make to one half of the mesh will no longer be automatically mirrored onto the other half.

After you have created a symmetrical model using Polygons > Smooth Proxy (with Mirror Behavior set to Full), use Polygons > Unmirror Smooth Proxy to remove the smooth mesh. Then use Polygons > Smooth Proxy (with Mirror Behavior set to None) to create a smooth mesh that you can animate non-symmetrically.

Related topics
❖ “Work on a simple model while a high density version automatically updates” on page 39
❖ “Model an object symmetrically” on page 47
❖ “Polygons > Smooth Proxy” on page 78

Polygons > Unmirror Smooth Proxy > □

Unmirror Direction
The direction that the original proxy mesh will be mirrored. (Set Unmirror Direction to the same setting you used for Mirror Direction with Polygons > Smooth Proxy.)

Edit Polygons

Edit Polygons > Move Component
Lets you transform polygon components while creating a construction history node.
Related topics

- "Transform polygon components” on page 34

Edit Polygons > Move Component

The options windows for selected components contain most of the same options. For instance, Global Values and Other Values are included in each options window for each selected component.

If an option is different for a particular component, it is described separately.

Local Values for selected faces

Offset

The Offset option is only available for selected faces. Enter a value to offset the edges of transformed faces. This option can be used to produce a bevel effect. In effect, using this option uniformly scales a face.

Note

The options window for selected UVs does not contain Local Values.

Translate

This value moves the component locally along the X, Y, or Z axis. Positive or negative values indicate how far the components are moved locally.

Tip

The path you transform along can be perpendicular, or at any other angle to the transformed face. To transform along a face normal, set the Z value for Local Values Translate to 1, and then click the Move Face button.

Rotate

This value sets the angle at which you want to rotate the components locally around the X, Y, or Z axis.

Scale

This value scales the components locally along the X, Y, or Z-axis.
3 | Create and Reshape polygons
Reference > Edit Polygons > Move Component

Direction
Enter a value to set the location of the X, Y, or Z point in the local axis. Notice how the manipulator handles change accordingly when you change the Y direction value to 4.0.

Global Values
Translate
This value moves the components along the X, Y, or Z axis.

Scale
Enter a value to scale the components along the X, Y, or Z axis.

Rotate
This value sets the angle by which you want to rotate the components around the X, Y, or Z axis.

Other Values
Random
Enter a value to transform the components randomly varying from a value of 0 to 1.

World Space Coords
Turn on the World Space Coords to use the world coordinate system when you change values randomly. See the Basics guide for information about World Space coordinates.

Move Vertex Options — Translate along normal
Instead of the generic Translate, Rotate, and Scale transformation values, vertices can be moved along the vertex normals. The value in this box indicates how far the vertices move along the Z axis (or normal).

Move Edge Options — Local center
Selecting an item from the Local center pull-down menu repositions the manipulator along the selected edge. Depending on which item you select, all subsequent transforms derive from that position. The default is middle.
3 | Create and Reshape polygons
Reference > Edit Polygons > Extrude Face, Extrude Edge

Edit Polygons > Extrude Face, Extrude Edge
Pulls new polygons out from existing faces or edges, with options to transform and reshape the new polygons as they move out from the originals.

Related topics
❖ “Extrude a vertex, edges, or faces” on page 42

Edit Polygons > Extrude Edge/Face > □
Twist and Taper are only available when extruding along a curve.

Twist
Rotates the extruded polygons as they travel along the curve.

Taper/Taper Curve
Scales the extruded polygons as they travel along the curve.
To control the taper exactly, open the Taper Curve section and use the graph control to set scaling along the length of the curve.
3 | Create and Reshape polygons
Reference > Edit Polygons > Extrude Face, Extrude Edge

Local Values
Offset

Enter a value to offset the edges of the extruded, extracted, or duplicated faces.

This option can be used to produce a bevel effect for extrusions, cut-outs around faces using Extract, and to uniformly scale duplicated faces.

Extrude offset of 0.2. Extract offset of 0.2. Duplicate offset of 0.04.
Translate

This value moves the extrusion or duplicated face locally along the X, Y, or Z-axis. Positive or negative values indicate how far the extruded or duplicated faces are moved locally.

Rotate

This value sets the angle at which you want to rotate the extruded or duplicated faces locally around the X, Y, or Z-axis.

Scale

This value scales the extrusion or duplicated faces locally along the X, Y, or Z-axis.

Direction

Enter a value to set the location of the X, Y, or Z-point in the local axis. Notice how the manipulator handles change accordingly when you change the Y direction value to 4.0.

Default values.  Direction changed to 4.0 in Y.

Global Values

Translate

This value moves the extruded or duplicated faces along the X, Y, or Z-axis.

Rotate

This value sets the angle by which you want to rotate the extruded or duplicated faces around the X, Y, or Z-axis.

Scale

Enter a value to scale the extrusion or duplicated faces along the X, Y, or Z-axis.

Divisions

The number of subdivisions along the length of the extrusion.
Random

Enter a value to extrude faces or edges in random directions, with a value of 0 to 1. Lower values are closer to the specified direction. Higher values are more randomized.

In the following example, faces were extruded with random values of 0, 0.5, and 1.

World Space Coords

Turn on the World Space Coords to use the world coordinate system when you change values randomly.

Keep Faces Together

When this attribute is off, Maya extrudes each face separately. When this option is on, Maya extrudes the faces as a whole.

Edit Polygons > Extrude Vertex

Creates a new pyramid of polygons from an existing vertex.

Related topics

- “Extrude a vertex, edges, or faces” on page 42

Edit Polygons > Extrude Vertex > □

Extrude Width

Controls the width of the base of the polygons created by the extrusion.
3 | Create and Reshape polygons
Reference > Edit Polygons > Wedge Faces

Extrude Length
The distance to move the extruded vertex along its normal.

Divisions
Controls number of sections along the extrusion.

Edit Polygons > Wedge Faces
Pulls an arc of new polygons from existing faces.

Related topics
• “Extrude polygons in an arc (wedge)” on page 46

Edit Polygons > Wedge Faces > □
Wedge Angle
The degrees of rotation around the pivot edge(s).

Wedge Divisions
The number of subdivisions around the rotation.

Edit Polygons > Duplicate Face
Creates new, disconnected faces from the selected faces.

Related topics
• “Duplicate faces” on page 49
Edit Polygons > Duplicate Face > □

Separate Duplicate Faces

This option is available only for Duplicate Face. Turn it on to separate faces automatically after they are duplicated. This is the default. If this option is turned off, you’re in component selection mode with all the duplicated faces selected.

Local Values

Offset

Enter a value to offset the edges of the extruded, extracted, or duplicated faces.

This option can be used to produce a bevel effect for extrusions, cut-outs around faces using Extract, and to uniformly scale duplicated faces.

offset of 0.2. Extract offset of 0.2. Duplicate offset of 0.04.

Translate

This value moves the extrusion or duplicated face locally along the X, Y, or Z-axis. Positive or negative values indicate how far the extruded or duplicated faces are moved locally.

Rotate

This value sets the angle at which you want to rotate the extruded or duplicated faces locally around the X, Y, or Z-axis.

Scale

This value scales the extrusion or duplicated faces locally along the X, Y, or Z-axis.

Direction

Enter a value to set the location of the X, Y, or Z-point in the local axis. Notice how the manipulator handles change accordingly when you change the Y direction value to 4.0.

Polygonal Modeling

91
3 | Create and Reshape polygons
Reference > Edit Polygons > Duplicate Face

Global Values

Translate
This value moves the extruded or duplicated faces along the X, Y, or Z-axis.

Rotate
This value sets the angle by which you want to rotate the extruded or duplicated faces around the X, Y, or Z-axis.

Scale
Enter a value to scale the extrusion or duplicated faces along the X, Y, or Z-axis.

Other Values

Random
Enter a value to duplicate faces in random directions, with a value of 0 to 1. Lower values are closer to the specified direction. Higher values are more randomized.

In the following example, faces were extruded with random values of 0, 0.5, and 1.

World Space Coords
Turn on the World Space Coords to use the world coordinate system when you change values randomly.
Keep Faces Together

When this attribute is off, Maya duplicates each face separately. When this option is on, Maya duplicates the faces as a whole.

Duplicate

Turn this attribute on to extract the faces instead of duplicating them.

Edit Polygons > Chamfer Vertex

Replaces a vertex with a flat polygon face.

Related topics

▶ "Chamfer a vertex" on page 52

Edit Polygons > Chamfer Vertex > □

Delete Faces

When this option is on, Maya does not fill the chamfered area with new faces.

Width

Controls how far back from the current position of the vertex the chafer is created.

Edit Polygons > Bevel

Creates bevel polygons along the selected edges.

Related topics

▶ "Bevel edges” on page 51
▶ "Chamfer a vertex” on page 52

Edit Polygons > Bevel > □

Offset Type

Fractional  The bevel will not be greater than the shortest edge (to prevent inside-out bevels).

Absolute  Polygon Bevel behaves the same as it did in Maya 5.0 and earlier.

Offset Space

Determines whether a bevel applied to a scaled object will also be scaled.
3 | Create and Reshape polygons
Reference > Edit Polygons > Bevel

World

If you bevel a scaled object, the offset will ignore the scaling. This is now the default setting.

Local

Polygon Bevel behaves the same as it did in Maya 5.0 and earlier. If you bevel a scaled object, the offset is also scaled.

Offset Distance

Controls the distance between the original edge and the center of the offset face.

When Offset Type is Absolute, Offset Distance is the distance between the original edge and the offset face measured in the scene’s linear unit. This is like the radius of the bevel. A large Offset Distance can produce inside-out bevels.

When Offset Type is Fractional, Offset Distance is a value from 0 to 1 that controls the distance between the original edge and the center of the offset face. When Offset Distance is 1, the distance will be the maximum possible that will not produce an inside-out bevel. An Offset Distance greater than 1 will produce inside-out bevels.
Values range from 0.2 to 10.0, although smaller values produce better results if World Space is turned off.

Roundness

By default, Maya automatically adjusts the rounding to bevel an object based upon the object's geometry. If you select Auto Fit, this option is dimmed. If Auto Fit is not selected, use the slider or enter a value to round the bevel edges.

You can set the Roundness to a negative number to create inward bevels.

Segments

The Segments value determines the number of segments created along the edges of the beveled polygon. Use the slider or enter a value to change the number of segments. The default is 1.

Auto Fit

If you select Auto Fit, Maya automatically determines how the bevel fits the object. If selected, you cannot change the Roundness value.

World Space

If turned on (the default), the specified Offset Distance value is the distance between edges in world space. When turned off, the Offset Distance value is the distance between edges in local space.

polyBevel node

Angle Tolerance

Polygon Bevel uses this angle to decide whether it needs to insert extra edges. If your model still has unwanted edges, try increasing this value to remove them.
3 | Create and Reshape polygons
Reference > Edit Polygons > Bevel

If your model has unwanted edges...

...try increasing Angle Tolerance
The Sculpt Polygons tool

About Polygons

The Sculpt Polygons tool

Using the Sculpt Polygons Tool, you can move vertices quickly with the stroke of a brush. You simply paint the mesh with the Sculpt Polygons tool to push and pull vertices to achieve the shape you want.

You can perform four different operations using the Sculpt Polygons Tool: push, pull, smooth, and erase.

Push/pull

You can push or pull a mesh in a configurable direction in the shape of the tool.

Reference surface

All sculpting you do pushes or pulls vertices from their initial positions on the reference surface. The Maximum Displacement options controls how far vertices can get from the reference surface.

In this example, the two strokes both raise the surface to the maximum displacement distance, but not beyond it.
If you update the reference surface, the current state becomes the reference, and further sculpting will displace vertices from it.

In this example, after the first stroke, the user updates the reference surface. The second stroke then applies the maximum displacement to it, going over the first stroke, which is now “baked onto” the reference surface.

You can update the reference surface manually, or set the Update on Each Stroke option to bake each stroke onto the reference as you finish the stroke.

**Smoothing**

You can paint over bumps to smooth them out.

**Erasing**

You can save the state of a surface and then later “erase” changes to the surface back to the saved state.
You can also turn on an option to save erase state after every stroke, which allows you to erase only the last stroke you made.

**Surface density**

Generally you should try to minimize the number of polygons in your surfaces. However, when using the Sculpt tool, the more polygons a surface has, the more precisely it can deform to the shape of the sculpting brush.

![Low subdivision density](image1) ![High subdivision density](image2)

**Sculpting and construction history**

- When you sculpt polygons that have construction history, Maya’s performance can slow down.
- Editing the history of a surface that has been sculpted can give unexpected results.

If you don’t need to keep the history of the surface, consider deleting the history (select the surface and choose Edit > Delete by Type > History).

The Sculpt Polygons tool does not create construction history of its own.

**Related topics**

- “Push or pull a mesh with the Sculpt Polygons tool” on page 100
- “Smooth a mesh with the Sculpt Polygons tool” on page 101
- “Selectively erase back to a previous state with the Sculpt Polygons tool” on page 101
- “Sculpt according to an attribute map” on page 102
- “Keyframe sculpting changes” on page 103
How do I? **Create and edit models**

**Reshape polygons with the Sculpt Polygons tool**

Push or pull a mesh with the Sculpt Polygons tool

**To sculpt polygons by pushing and pulling vertices with a brush**

1. Select the mesh, meshes or vertices you want to sculpt.
2. Choose Edit Polygons > Sculpt Polygons Tool > □.
3. Under Operation, click Push or Pull.
4. Use the options under Sculpt Parameters to control how brushing pushes or pulls the mesh.
5. Do any of the following:
   - Brush across the mesh to push or pull vertices.
   - Hold b and drag left or right to change the brush radius.
   - Hold m and drag left or right to change how far the tool moves the mesh.

**To apply a push/pull action to the entire mesh at once**

1. In the Sculpt Polygons option panel, set the options you want to apply to the entire mesh.
2. Under Sculpt Parameters, click the Flood button.

**Tips**

- To retain control while sculpting, keep the Opacity and Max Displacement low and build up sculpting gradually.

**Related topics**

- “The Sculpt Polygons tool” on page 97
- “Selectively erase back to a previous state with the Sculpt Polygons tool” on page 101
- “Edit Polygons > Sculpt Polygons Tool” on page 103
Smooth a mesh with the Sculpt Polygons tool

To smooth meshes with a brush

1. Select the mesh, meshes or vertices you want to sculpt.
2. Choose Edit Polygons > Sculpt Polygons Tool > □.
4. Use the options under Sculpt Parameters to control how brushing smooths the mesh.
5. Do any of the following:
   - Brush across the mesh to push or pull vertices.
   - Hold b and drag left or right to change the brush radius.
   - Hold m and drag left or right to change how much the tool moves the mesh as it smooths.

To apply a smooth action to the entire mesh at once

1. In the Sculpt Polygons option panel, set the options you want to apply to the entire mesh.
2. Under Sculpt Parameters, click the Flood button.

Tips

- To progressively smooth a model, use the Flood button with Smooth as the selected operation, and set the opacity low.

Related topics

- “The Sculpt Polygons tool” on page 97
- “Smoothing methods” on page 31
- “Smooth polygons” on page 37
- “Edit Polygons > Sculpt Polygons Tool” on page 103

Selectively erase back to a previous state with the Sculpt Polygons tool

To save a state and then erase back to it

1. Make sure the Update on Each Stroke option next to Erase Surface (at the bottom of the Sculpt Parameters section) is off.
2. When you want to save the current state of a sculpted mesh, click the Update button next to Erase Surface.
When you want to paint back to the saved state, set Operation to Erase.

**To be able to paint out only the effects of your last stroke**

1. Turn on the Update on Each Stroke option next to Erase Surface (at the bottom of the Sculpt Parameters section).
2. When you want to paint out part of the last stroke, set Operation to Erase.

**Related topics**

- “The Sculpt Polygons tool” on page 97
- “Edit Polygons > Sculpt Polygons Tool” on page 103

**Sculpt according to an attribute map**

When you import an attribute map to a mesh using the Sculpt Polygons tool, Maya applies the tool settings to the vertices, mapping the greyscale values to the Opacity value set for the tool.

In the following example, the Sculpt Polygons Tool is set to Pull with a stroke displacement of 2.

**Related topics**

- “The Sculpt Polygons tool” on page 97
- “Smooth a mesh with the Sculpt Polygons tool” on page 101
- “Edit Polygons > Sculpt Polygons Tool” on page 103
Keyframe sculpting changes

1. Select the vertices you want to keyframe.
2. Rewind to the first frame of the animation.
3. In the Preferences window (Window > Settings/Preferences > Preferences), click the Keys category and turn on Auto Key.
4. Set a key.
5. Move to the end frame of the sculpting animation.
6. Select the mesh and choose Edit Polygons > Sculpt Polygons Tool. Sculpt the surface into the shape you want. The Auto Key option will set keyframes for the vertices the Sculpt Polygons tool moves.

You can repeat this process at other frames to morph from one sculpted state to another.

Related topics
- “The Sculpt Polygons tool” on page 97
- “Edit Polygons > Sculpt Polygons Tool” on page 103
Polygons > Sculpt Polygons Tool

This tool lets you specify the settings for the Sculpt Polygons Tool in the Tool Settings editor. There are attributes unique to the Sculpt Polygons Tool in the Sculpt Parameters sections. These unique attributes are described below. For descriptions of all other attributes in all other sections, see “Common Artisan Brush Tool Settings” in the Paint Effects, Artisan, and 3D Paint guide.

Sculpt Parameters
These are descriptions of the attributes in the Sculpt Parameters section.

Operation
Select Push, Pull, Smooth, or Erase. A letter appears within the brush stamp to reflect the operation: Ps (Push), Pl (Pull), Sm (Smooth) or E (Erase).

To remove the letters from the brush stamp, open the Sculpt Surface Tool Settings window, click the Display section, and turn off Draw Brush Feedback.

Tip: To select a brush operation from a marking menu, press your keyboard’s u key while dragging the mouse.

Auto Smooth
If you selected Push or Pull as the brush operation, turn Auto Smooth on to smooth the surface automatically after every brush stroke.

Auto Smooth Strength
If you turned Auto Smooth on, type the smooth strength in the Strength box. This is the number of times the Sculpt Surface Tool smooths the surface for each push, pull, or smooth stroke. The higher the number, the more smoothing takes place for each brush stroke.

Reference Vector
In the Sculpt Variables section, select the reference vector. The reference vector controls the direction the vertices move when you push or pull. The brush arrow represents the reference vector.

Normal
The vertices move in the direction of the surface normal.
First Normal

The vertices move in the direction established by the surface normal at the beginning of the stroke.

View

The vertices move parallel to the camera view direction.

X Axis

The vertices move in the direction of the X axis only. They do not move along the Y or Z axis.

Y Axis

The vertices move in the direction of the Y axis only. They do not move along the X or Z axis.
The Sculpt Polygons tool

Reference > Edit Polygons > Sculpt Polygons Tool

Z Axis

The vertices move in the direction of the Z axis only. They do not move along the X or Y axis.

Max Displacement

Type the maximum possible depth or height of the brush stroke, or use the slider to select it. (The actual displacement of the brush stroke is based on how hard you press with the stylus and on the Opacity value.)

Seam/Pole Tolerance

Set how close the vertices must be along an edge, and how close the edges on the same surface must be to each other before they are detected as common. This is most commonly used to detect poles on surfaces like spheres.

Flood

Applies the Operation to all selected vertices.

When Operation is Push or Pull, Flood applies the maximum displacement to all selected vertices.

When Operation is Smooth, Flood smooths all selected vertices.

When Operation is Erase, selected vertices are restored to their last saved state.
Reference Surface: update on each stroke

To “bake” or update the surface automatically on each stroke, turn Reference Srf: update on each Stroke on. For a description of reference surfaces, see ”Reference surface” on page 97. To update the reference surface manually, click Update.

Erase Surface: update on each stroke

To update the erase surface automatically on each stroke, turn Erase Srf: update on each Stroke on. To update the erase surface manually, click Update.
4 | The Sculpt Polygons tool
Reference > Edit Polygons > Sculpt Polygons Tool
5 | Combining, separating, and splitting
How do I? > Merge vertices, edges, or faces into one vertex

5 Combining, separating, and splitting

How do I? Create and edit models

Combine, separate, or split polygons

Merge vertices, edges, or faces into one vertex

To merge several vertices into a single vertex
When you merge vertices, coincident edges and their associated UVs are also merged automatically (within a specified threshold).

1. Select the vertices you want to merge.

2. Select Edit Polygons > Merge Vertices > □.
3. Set the Distance value to control how close vertices must be to merge.
4. Click the Merge Vertex button.
After you merge the vertices, you can edit the Distance attribute in the channel box or the attribute editor.

**To collapse edges or faces into a single vertex**

1. Select the edges or faces you want to collapse.
2. Select Edit Polygons > Collapse.

**Notes**

- Merging vertices can make your geometry nonmanifold. Use Polygons > Cleanup to fix nonmanifold geometry.
- When you merge vertices, Maya also attempts to merge the corresponding UVs. In some cases, such as UVs on separate UV pieces, Maya cannot merge UVs.

  You can merge the UVs in the texture editor using Edit Polygons > Texture > Merge UVs.

**Related topics**

- “Merge edges” on page 110
- “Split shared vertices” on page 117
- “Edit Polygons > Merge Vertices” on page 125
- “Edit Polygons > Texture > Merge UVs” on page 228

**Merge edges**

You can select boundary edges of a model and merge them (or sew them) to create one common edge.
Merging edges can reduce your polygon count. You can merge the boundary edges of a model and then delete the interior edges, resulting in fewer faces.

**To merge edges**

1. Select Edit Polygons > Merge Edge Tool.
2. Click the first border edge you want to merge. The next selectable edge displays in purple.
3. Click the second (purple) edge you want to merge. Do not Shift-click or drag out a selection box.
4. Do one of the following:
   - Press Enter to merge.
   - Press ‘y’ to merge and continue using the tool.
   - Press Delete to go back and select another edge.

You can edit the merge by selecting the merge node and changing the mode attribute.

**To merge multiple polygon edges**

1. Select the edges you want to merge and choose Edit Polygons > Merge Multiple Edges > .
2. Set the Threshold value to control how close edges must be to merge.
5 | Combining, separating, and splitting
How do I? > Combine separate meshes into one new mesh

3 Click Sew.

Notes
- To make it easier to distinguish between border edges and interior edges, choose Display > Custom Polygon Display > □ and turn on Highlight: Border Edges.
- You can only merge edges that are part of the same polygon mesh. If you want to merge edges from different mesh objects, you must merge the meshes into a new mesh first using Polygons > Combine.
- You can only merge border edges. You cannot merge non-border edges or non-manifold edges.

Related topics
- “Merge vertices, edges, or faces into one vertex” on page 109
- “Edit Polygons > Merge Edge Tool” on page 126
- “Edit Polygons > Merge Multiple Edges” on page 127

Combine separate meshes into one new mesh
Select the meshes you want to combine into a single object and choose Polygons > Combine.

Before Combine. After Combine.

When you combine meshes, you can get non-manifold geometry, where the normals of adjacent faces are pointing in opposite directions. To avoid this, use Edit Polygons > Normals > Conform to flip all normals in the combined mesh to the same side.

Related topics
- “Normals” on page 13
5 | Combining, separating, and splitting

How do I? > Automatically separate polygon shells into individual meshes

- “Automatically separate polygon shells into individual meshes” on page 113
- “Combine meshes using boolean operations” on page 113
- “Reverse polygon normals” on page 136

Automatically separate polygon shells into individual meshes

The Separate action makes each “island” of connected polygons in a mesh into their own mesh.

Select the mesh object and choose Edit Polygons > Separate.

Related topics

- “Combine separate meshes into one new mesh” on page 112

Combine meshes using boolean operations

Boolean operations use the volume of one shape to sculpt another.

Using a sphere to “carve” a cube using the Difference operation

Maya supports three boolean operations:

- Union combines the volumes of the two meshes you select.
- Difference subtracts the volume of the second mesh you select from the first.
- Intersection leaves the shared volume of the two meshes.

Boolean operations are very useful for trimming objects.
5 | Combining, separating, and splitting
How do I? > Combine meshes using boolean operations

Boolean operations generate a new shape node. If you keep construction history, the original shapes can still be selected in the Channel Box, Hypergraph, or Outliner and edited, with the boolean result automatically updating. You can even change which boolean operation to use to combine the objects.

To combine two meshes with a boolean operation

1 Select the meshes.
   For the Difference operation, select the mesh you want to subtract from first.
2 Select one of the actions in the Polygons > Booleans submenu.
   The faces of the objects are now connected and both original meshes act as one single object.

You can select the original objects using the outliner, hypergraph, attribute editor, or channel box. As long as construction history is on, when you edit the originals, the boolean result updates automatically.

For example, you can subtract a sphere from a cube using the Difference operation, then animate the original sphere to create an interesting effect:
5 | Combining, separating, and splitting
How do I? > Edit the original objects after a boolean operation

What if...?

Boolean operations produce unexpected results?

Boolean operations may sometimes not produce the expected results if the original objects are not closed volumes, or if they contain nearly coincident vertices.

Before applying the boolean operation, fill any openings in the original objects (for example, use Edit Polygons > Fill Hole), and use Merge Vertices with a suitably small Distance to merge vertices that are effectively coincident.

I can’t use the boolean operations on my meshes?

Booleans operations do not work on meshes that have zero (or very small) area faces. Before you use a boolean action, either enlarge these faces or remove them.

To select these faces:

1. Select the meshes.
2. Choose Edit Polygons > Selection > Selection Constraints.
3. Set Constrain to All Next
4. Expand the Geometry and Area sections.
5. Turn on Activate and set Min to 0 and Max to 0.0001.

You can now enlarge them or remove the faces.

Maya runs out of memory?

Using booleans on large polygonal objects is a memory intensive operation. Maya can run out of memory if this operation is performed many times on large polygonal objects.

Keep the undo queue length small or flush the undo queue every now and then when performing boolean operations on large polygonal objects.

Related topics

- “Combine separate meshes into one new mesh” on page 112
- “Edit the original objects after a boolean operation” on page 115

Edit the original objects after a boolean operation

The objects you combine in a boolean operation to create a union, subtraction, or intersection still exist in the scene, they are just hidden. You can select them, edit them, and make them visible again.
5 | Combining, separating, and splitting
How do I? > Edit the original objects after a boolean operation

To select an input object

If you want to transform the objects after a Boolean operation, you have to access the history of the objects from the Hypergraph, Outliner, Channel Box, or Attribute Editor. You can then use Maya's transformation tools or enter values to transform the objects.

After a boolean operation, select Windows > Hypergraph to open the Hypergraph.

The result of the boolean operation is a single node.

In the hypergraph, select the input object you want to transform.

In the view, the object changes color to indicate that you are now working on an object’s history nodes.

To make an input object visible

To display one of the input objects you used when performing the boolean operation, select the transform node for the input object in the Hypergraph, turn Visibility on in the transform node’s Attribute Editor. Select the object’s transform node, open the Display section, and turn on the Visibility checkbox.
Now you can see the input object as well as edit it. The Boolean operation constantly updates the original object based on the new transformed tool object.

Related topics

- “Combine meshes using boolean operations” on page 113

Split shared vertices

You can split a shared vertex into multiple vertices—one for each polygonal face that shares it. You can then perform independent operations on the split edges.

**To split a vertex**

1. Select the vertices.
   
   The action ignores selected vertices that are not shared.
2. Select Edit Polygons > Split Vertex.

Related topics

- “Merge vertices, edges, or faces into one vertex” on page 109

Disconnect faces from their shared edges (extract)

You can disconnect the selected faces from the original shape by duplicating the appropriate edges and vertices.

You can either make the extracted faces a new shell within the same mesh object, or create a new mesh from the extracted faces.
5 | Combining, separating, and splitting

How do I? > Disconnect faces from their shared edges (extract)

To extract faces

1. Select the faces you want to extract and choose Edit Polygons > Extract > .

2. If you want the extracted faces to become their own mesh, turn on Separate. Turn off Separate to make the duplicated faces part of the existing mesh.
   If you know the exact transformation values you want to use, you can enter them in the option box, otherwise you can specify them interactively later.

3. Click Extract.
   The action creates a node and switches to the Show Manipulator tool.

4. Do any of the following:
   - Use the manipulator to control the direction and distance to move the extracted faces. Remember that you can also change the pivot by pressing Insert or Home. Click the circle handle attached to the manipulator to switch between local and world axes.

   - Use the controls in the attribute editor or channel box to edit the extraction.
Keep faces together attribute

The Keep Faces Together attribute controls how Maya treats the edges of adjacent faces. When Keep Faces Together is on, the faces expand so their edges stay connected.

Note When Keep Faces Together is off and Separate is on, each face becomes a separate mesh.

Related topics

- “Automatically separate polygon shells into individual meshes” on page 113
- “Cut faces with a plane” on page 123

Split a face into multiple faces

You can draw a line across the face of a polygon to split it into two more new faces.

The split line must start and end on an edge. Each time it touches an edge will create a new face.

1 Select Edit Polygons > Split Polygon Tool.
2 Click a point on an edge to start the split.
3 Do any of the following:
   • Click more points to add them to the split line.
   • To move the previous point after you place it, drag the middle mouse button.
To finish the split, press the right mouse button or press y. (To finish the split and exit the tool, press Enter.) You can only split if the last point is on an edge.

To constrain the placement of split line points

Choose Edit Polygons > Split Polygon Tool > □ to show the tool’s options panel. There are several snapping options to make placing points easier:

- Snap to Edge constrains point placement to edges.
- Snap to Magnets snaps point placement to regular distances along an edge.
- Number of Magnets controls the number of magnet points inside edges.
- Magnet Tolerance controls how close the point must be to a magnet before the point snaps to it. Set this to 100 to constrain points to always be at magnet points.

To snap a point to the exact midpoint of an edge, turn on Snap to Magnets, set Number of Magnets to 1, and Magnet Tolerance to 100.

Related topics

- “Split faces into triangles or quadrangles” on page 120
- “Split a face and move the new center vertex (poke)” on page 121

Split faces into triangles or quadrangles

1. Select the edges or faces you want to subdivide and choose Edit Polygons > Subdivide > □.
2. Set Mode to triangles or quadrangles.
3. Subdivision Level lets you subdivide multiple times. A value of 1 subdivides once. A value of 2 subdivides once, then subdivides each of the new faces again, and so on.
4. Click Subdivide.
5 | Combining, separating, and splitting

How do I? > Split a face and move the new center vertex (poke)

You can select the polySubd node and change the subdivision values and modes in the channel box or attribute editor.

What if...?

A face will not subdivide?
You cannot subdivide faces with holes. Also, you cannot subdivide concave faces unless the center point is inside the face.

To subdivide a concave face into convex parts, use Edit Polygons > Split Polygon Tool or Polygons > Triangulate. You can also use Triangulate to remove holes.

Related topics
✓ “Split a face into multiple faces” on page 119
✓ “Split a face and move the new center vertex (poke)” on page 121
✓ “Edit Polygons > Subdivide” on page 128

Split a face and move the new center vertex (poke)
Poke Faces gives you a manipulator to move the newly created vertex or vertices.
**Combining, separating, and splitting**

How do I? > Subdivide faces by painting

1. Select one or more faces and choose Edit Polygons > Poke Faces.
2. Use the manipulator to move the new vertex or vertices. Remember that you can also change the pivot by pressing Insert or Home. Click the circle handle attached to the manipulator to switch between local and world axes.

Related topics
- “Split a face into multiple faces” on page 119
- “Split faces into triangles or quadrangles” on page 120

**Subdivide faces by painting**

You can use the Paint Selection tool to select and subdivide faces.

1. Select a mesh.
2. Select Edit > Paint Selection Tool >.
3. In the Paint Operations section, turn off Add to Current Selection.
4. Change the pick mask to Poly Faces.
5. In the Stroke section, Type the following in After Stroke Cmd:
   ```
polySubdivideFacet -dv 1 -m 0 -ch 1
   ```
6. Paint the faces you want to subdivide. Each painted face subdivides automatically you finish the stroke.
5 | Combining, separating, and splitting

How do I? > Split an edge into segments

Split an edge into segments

1. Select the edges you want to subdivide and choose Edit Polygons > Subdivide > □.
2. Set Subdivision Level to the number of interior segments you want to create.
3. Click Subdivide.

You can select the polySubd node and change the subdivision values and modes in the channel box or attribute editor.

Related topics

- “Merge vertices, edges, or faces into one vertex” on page 109
- “Merge edges” on page 110

Cut faces with a plane

Use Cut Faces to create edges... ...to extract faces, or... ...to delete faces.

With Cut Faces you can:

- Add edges where you want more bend in the surface, such as a character’s elbow or knee.
- Slice and delete a portion of model—this operation is like a Boolean subtraction.
- Prepare a model for mirroring by slicing away a portion to create a clean edge along the mirror axis.
5 | Combining, separating, and splitting
Reference > Polygons > Combine

To cut faces along a line you draw

1. Select a mesh or faces and choose Edit Polygons > Cut Faces > □.
2. Set the Cut Direction option to Interactive.
3. You can turn on Delete to delete the faces on one side of the cut, or Extract to disconnect the cut faces along the cut edges.
4. Drag a line in a view window to define the cutting plane.
   When the Delete option is on, a dotted line shows which side will be deleted.
5. Do one of the following:
   • Draw another line to cut the faces again.
   • Select another tool.

After you cut the faces, you can select the polyCut node and click the Show Manipulator tool to edit the cutting plane.

To cut faces along a defined plane

1. Select a mesh or faces and choose Edit Polygons > Cut Faces > □.
2. Choose a plane from the Cut Direction menu, or define a custom plane.
3. Click Cut.

Related topics
❖ “Disconnect faces from their shared edges (extract)” on page 117

Reference Menus

Modeling menu set

Polygons

Polygons > Combine
Combines the selected meshes into a single polygon mesh.

Related topics
❖ “Meshes and shells” on page 15
❖ “Combine separate meshes into one new mesh” on page 112
Polygons > Booleans
The items in this submenu let you combine polygon meshes to create a new shape:

- Union combines the volume of the meshes.
- Difference subtracts the first mesh from the second.
- Intersection leaves only the shared volume of the meshes.

Related topics
- “Combine meshes using boolean operations” on page 113

Edit Polygons
Edit Polygons > Separate
Separates all disconnected shells in a mesh into separate meshes.

Related topics
- “Automatically separate polygon shells into individual meshes” on page 113

Edit Polygons > Poke Faces
Splits the selected faces to let you push or pull the center of the original polygon.

Related topics
- “Split a face and move the new center vertex (poke)” on page 121

Edit Polygons > Merge Vertices
Merges vertices in the selection that are within the tolerance distance of each other.
Related topics

- "Merge vertices, edges, or faces into one vertex” on page 109

Edit Polygons > Merge Vertices

Distance

Vertices within this distance of each other will be merged.

Edit Polygons > Collapse

Merges edges or faces into a single vertex.

Related topics

- "Merge vertices, edges, or faces into one vertex” on page 109

Edit Polygons > Merge Edge Tool

Lets you merge edges by clicking them.

Related topics

- "Merge edges” on page 110

Edit Polygons > Merge Edge Tool > □

First

If you select First, the first edge you click becomes the new edge and the second edge you click is removed.
5 | Combining, separating, and splitting
Reference > Edit Polygons > Merge Multiple Edges

Middle

If you select Middle, the default, the new edge is equidistant between the first and the second edge and the first and second edges you click are removed.

Second/Last

If you select Second (or Last), the second or last edge you click becomes the new edge and the first edge you click is removed.

Edit Polygons > Merge Multiple Edges
Merges the selected edges into a single edge.

Related topics
❖ "Merge edges" on page 110
5 | Combining, separating, and splitting
Reference > Edit Polygons > Subdivide

Edit Polygons > Merge Multiple Edges > □
Merge UVs Also
Merges the UVs shared by the edges. If turned off, the UVs are not merged and can be manipulated and edited independent of each other.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you have a model that is mapped with different textures on either side of where the edges merge, it is a good idea to turn this option off.</td>
</tr>
</tbody>
</table>

Threshold
Any edges further apart than this distance will not be merged. Set this value carefully. If it’s too small, no edges will merge. If it’s too large, the operation may merge edges that you do not want attached.

World Space Coords
If turned on (the default), the specified Threshold value is the distance between edges in world space. When turned off, the Threshold value is the distance between edges in local space.

Edit Polygons > Subdivide
Subdivides the selected faces into triangles or quadrangles.

Related topics
“Split faces into triangles or quadrangles” on page 120

Edit Polygons > Subdivide > □
Subdivision Levels
For edges, enter the maximum number of vertices to be inserted in each edge.

For faces, enter the number of times each selected face is recursively subdivided. The number of faces created is proportional to \(3^{(x-1)}\) for triangles, or \(4^{(x-1)}\) for quads, where \(x\) is the number of subdivision levels. The number of edges on the original face determines the proportion.

Mode (for faces)
quads/triangles
Turn quads on to subdivide faces into quads or turn triangles on to subdivide faces into triangles. These options are only available for faces.
Minimum length
Sets the minimum length of each subedge created. This option is only available for edges.

Worldspace
This option is only available for edges. When turned on, the specified Subdivision value is the distance between vertices in world space. When turned off, the Subdivisions value is the distance between vertices in local space.

Edit Polygons > Split Polygon Tool
Lets you split a face into multiple faces by drawing boundaries across the face.

Related topics
- “Split a face into multiple faces” on page 119

Edit Polygons > Split Polygon Tool > □
Subdivisions
Drag the slider to change the number of subdivisions you want for each edge of the new face. Vertices are placed along the edge to create the subdivisions.

Subdivisions are not created if you split the polygon by placing the second point inside the original face. Your second point must be placed on another edge to create subdivisions.

Second point placed inside face.  Second point placed on edge.

Snap to Edge
Constrains point placement to edges.

Snap to Magnets
Snaps point placement to regular distances along an edge.

Number of Magnets
Controls the number of magnet points inside edges.
Magnet Tolerance

Controls how close the point must be to a magnet before the point snaps to it. Set this to 100 to constrain points to always be at magnet points.

Edit Polygons > Cut Faces

Splits all faces along a cut line.

Related topics

❖ "Cut faces with a plane" on page 123

Edit Polygons > Cut Faces > 

Cut Plane Center, Rotation, and Scale

These settings enable you to enter exact values for the orientation of the cutting line. You can change these settings before or after the cut. To change these settings in the options window, you must have Custom Cut specified for the Cut Direction.

Cut Direction

Specifies how you want to cut faces.

Interactive Cut Displays a cutting line that you can interactively drag into position along the surface.

Custom Cut Projects the cutting line according to specific values you enter in the Cut Plane Center, Rotation, and Scale options. Also displays a manipulator for you to position the cut.

Cut Along YZ, ZX, XY plane Projects the cutting line along a plane and displays a manipulator for you to position the cut.

Delete

Deletes the portion of the surface to one side of the cutting line. When using the Interactive Cut setting, the cut line shows a dotted line to indicate the side that will be deleted.
Extract

Extracts faces to one side of the cutting line.

Extract Offset

Specifies the distance between the main surface and the extracted piece. One practical use for this setting is to widen the model of a head. In this case, you would cut the model exactly down the center and use Extract Offset to position the extracted half further away, until the head seems wide enough. You would then fill in the gap to complete the head.

Edit Polygons > Extract

Disconnects the selected faces from the surrounding edges.

Related topics

❖ “Disconnect faces from their shared edges (extract)” on page 117

Edit Polygons > Extract > □

Separate Extracted Faces

Turn it on to separate faces automatically after they are extracted. This is the default. If this option is turned off, you’re in component selection mode with all the extracted faces selected.

Local Values

Offset

Enter a value to offset the edges of the extruded, extracted, or duplicated faces.

This option can be used to produce a bevel effect for extrusions, cut-outs around faces using Extract, and to uniformly scale duplicated faces.
Translate

This value moves the extrusion or duplicated face locally along the X, Y, or Z-axis. Positive or negative values indicate how far the extruded or duplicated faces are moved locally.

Rotate

This value sets the angle at which you want to rotate the extruded or duplicated faces locally around the X, Y, or Z-axis.

Scale

This value scales the extrusion or duplicated faces locally along the X, Y, or Z-axis.

Direction

Enter a value to set the location of the X, Y, or Z-point in the local axis. Notice how the manipulator handles change accordingly when you change the Y direction value to 4.0.

Global Values

Translate

This value moves the extruded or duplicated faces along the X, Y, or Z-axis.

Rotate

This value sets the angle by which you want to rotate the extruded or duplicated faces around the X, Y, or Z-axis.

Scale

Enter a value to scale the extrusion or duplicated faces along the X, Y, or Z-axis.

Random

Enter a value to duplicate faces in random directions, with a value of 0 to 1. Lower values are closer to the specified direction. Higher values are more randomized.

In the following example, faces were extruded with random values of 0, 0.5, and 1.
5 | Combining, separating, and splitting
Reference > Edit Polygons > Extract

World Space Coords
Turn on the World Space Coords to use the world coordinate system when you change values randomly.

Keep Faces Together
When this attribute is on, Maya extracts each face separately. When this option is off, Maya extracts the faces as a whole.

Duplicate
Turn this attribute on to duplicate the faces instead of extracting them.
5 | Combining, separating, and splitting
Reference > Edit Polygons > Extract
How do I? > Convert polygons to triangles or quadrangles

Edit polygons

Convert polygons to triangles or quadrangles

Converting faces to triangles is a quick way to ensure non-planar faces render properly. Converting faces to quads is a good way to clean up polygons or reduce the number of faces.

To convert faces to triangles or quadrangles

1. Select the faces.
2. Select Polygons > Triangulate or Polygons > Quadrangulate.

Related topics

- “Split faces into triangles or quadrangles” on page 120
- ”Polygons > Quadrangulate” on page 143

Flip triangle edges

You can switch the edge dividing two triangles so it connects the opposite corners. This can often make a difference in the shape of a low-polygon models.

For example, the placement or orientation of an edge on a polygonal face could determine the placement of the bridge of a nose or the placement of the cheeks.
6 | Editing polygons
How do I? > Transfer vertex positions (shape), UVs, or vertex color between meshes

To flip edges

1  Select one or more edges to flip.
   The edge should be a shared edge between two triangles.
2  Select Edit Polygons > Flip Triangle Edge.

| Tip | Flip Triangle Edge is sometimes called turn-edge, flip-edge, swap-edge, and rotate-edge. |

What if...?

I cannot flip an edge?

- You cannot flip edges that are texture borders in UV space.
- You cannot flip border edges, including hole borders.
- You cannot flip edges with zero length.

Transfer vertex positions (shape), UVs, or vertex color between meshes

You can transfer vertex positions, UV sets, and vertex colors between meshes that have the same topology.

To transfer components

1  Select the source object and then the destination object.
2  Select Polygons > Transfer > .
3  Select the types of information you want to transfer, then click Transfer.

Related topics

- ”UV sets” on page 239
- ”Coloring polygons” on page 167

Reverse polygon normals

Reversing the face normal switches the “front” and “back” of a face. Vertex normals are usually computed from the face normals, so they are affected as well.

There are three ways to reverse normals. You can:
To reverse face normals
1 Select the faces you want to reverse:
2 Select Edit Polygons > Normals > Reverse > /
3 Set the Mode option to one of the following:
   • To reverse the face normals of selected faces, choose Reverse.
   • To reverse face normals and vertex normals and then extract the vertices, choose Reverse and Extract.
   • To reverse face normals of all (selected or unselected) faces in the shell, choose Reverse and Propagate.
4 Click Reverse Normals.

Note The Reverse option can result in non-manifold geometry, where polygons that share an edge but have reversed normals. Some tools cannot work with non-manifold geometry. See “Clean up, simplify, or validate meshes” on page 153.
To avoid creating non-manifold geometry, use the Reverse and Extract option. This option will split vertices so as not to create non-manifold geometry.

To flip all normals to the same side
You can make all the normals of selected faces point in a consistent direction.
1 Select the faces.
2 Select Edit Polygons > Normals > Conform. The normals flip to the side shared by the majority of all faces.
6 | Editing polygons
How do I? > Make a hole in a face

Related topics
- “Manipulate vertex normals to affect shading of polygons” on page 139
- “Edit Polygons > Normals > Reverse” on page 147

Make a hole in a face
You can punch a hole in a selected face in the shape of a second face.
Making a hole in a face does not increase the number of faces in your polygonal model or change the component indexing for its vertices, edges, or faces. This can be especially important when applying colors-per-vertex, or when importing foreign polygonal objects.

You can also make a hole in a face as you draw it. See ”Create a single faced polygon mesh” on page 32.

To make a hole in the shape of a second face
1 Select Edit Polygons > Make Hole Tool. Click the face you want to make a hole in, then click the face you want to make the hole in the shape of.

2 Press to make the hole.
How do I? > Manipulate vertex normals to affect shading of polygons

Related topics

・ "Edit Polygons > Make Hole Tool" on page 148

Manipulate vertex normals to affect shading of polygons

To control vertex normal direction manually

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show vertex normals.</td>
<td>Select the mesh and choose Display &gt; Custom Polygon Display &gt; □.</td>
</tr>
<tr>
<td></td>
<td>Beside Vertices, turn on Normals, then click Apply.</td>
</tr>
<tr>
<td>Make edges appear sharp in shaded mode.</td>
<td>Select the edges and choose Edit Polygons &gt; Normals &gt; Soften/Harden &gt; □.</td>
</tr>
<tr>
<td></td>
<td>Click All Hard, then click Soft/Hard.</td>
</tr>
<tr>
<td>Make edges appear soft in shaded mode.</td>
<td>Select the edges and choose Edit Polygons &gt; Normals &gt; Soften/Harden &gt; □.</td>
</tr>
<tr>
<td></td>
<td>Click All Soft, then click Soft/Hard.</td>
</tr>
<tr>
<td>Lock or unlock vertex normals to their current direction.</td>
<td>Select the vertices and choose Edit Polygons &gt; Normals &gt; Set Vertex Normal &gt; □.</td>
</tr>
<tr>
<td></td>
<td>Turn on Lock Normals or Unlock Normals, then click Set Normal.</td>
</tr>
</tbody>
</table>

Note: If you want to make a hole using a shape face that is not in the same mesh as the face you’re making a hole in, you must combine the faces (select both meshes and choose Polygons > Combine) before using Make Hole.
## 6 | Editing polygons

How do I? > Manipulate vertex normals to affect shading of polygons

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force normals to point along a certain vector (by entering values numerically).</td>
<td>Select the locked vertices and choose Edit Polygons &gt; Normals &gt; Set Vertex Normal &gt; (\square). Turn off both Lock Normals and Unlock Normals. Use the text boxes to enter the X, Y, and Z rotation values for the vector, then click Set Normal.</td>
</tr>
<tr>
<td>Force normals to point along a certain vector (by adjusting a manipulator)</td>
<td>Select the vertices and choose Edit Polygons &gt; Normals &gt; Set Vertex Normal &gt; (\square). Use the manipulator to adjust the direction of the normals.</td>
</tr>
</tbody>
</table>

**Note**

The Polygon Edit > Normals actions create history nodes that actually change the normals. Therefore the correct way to reverse one of these actions is to delete the node.

Do not try to reverse the effects of one of these actions by applying the action again with the opposite setting. Doing so will probably not have the effect you want, and will just add another node to the dependency graph.

### To set vertex normals to the same direction as the face normals

This has the same effect as hardening the adjacent edge.

1. Select one or more vertices or vertex face components.
2. Select Edit Polygons > Normals > Set to Face > \(\square\).
How do I? > Manipulate vertex normals to affect shading of polygons

3 Set the options, then click Set to Face.

**Tip** Using Vertex/Face selection lets you set normals on a per-vertex per-face basis.

To average vertex normals

1 Select one or more vertices or vertex/face components.
2 Select Edit Polygons > Normals > Average Normals > □.
3 Set the options, then click Average Normals.

**Tip** Using Vertex/Face selection lets you set normals on a per-vertex per-face basis.

You can do any of the following:

- You can average the vertex-face normals at a single vertex.
- You can increase the tolerance and average the normals of several vertices in the same region to give the area a flattened look.
- You can pick vertices on opposite sides of a seam and average them to smooth across the seam.
- Using a small tolerance, you can select all the vertices along a seam, and each group of close-together vertices will be averaged separately.

**Notes**

- If these actions can achieve their effect using Soften/Harden they will, however they will usually force explicit normal directions.
- Average Normals works in object space, so if you want to average normals across two different shapes, make sure that the scene hierarchy for each shape has the same transforms.

**Related topics**

- “Reverse polygon normals” on page 136
- “Edit Polygons > Normals > Vertex Normal Edit Tool” on page 144
- “Edit Polygons > Normals > Set Vertex Normal” on page 145
- “Edit Polygons > Normals > Average Normals” on page 146
- “Edit Polygons > Normals > Set to Face” on page 147
- “Edit Polygons > Normals > Soften/Harden” on page 148
Transfer vertex information between meshes with identical topology

You can transfer vertex positions, UV sets, and vertex color between meshes with identical topology (generally, meshes that were created by duplication).

1. Select the source object and the destination object, in that order.
2. Select Polygons > Transfer > .
3. Choose the type of information you want to transfer (Vertices, UV Sets, Vertex Color), then click Transfer.

Smoothed Duplicate of complex model.

Complex model.

Planar projection of smoothed duplicate.

Good UVs created using Map UV Border and Relax UVs.

Good UVs transferred back to original model and smoothed duplicate deleted.
Reference Menus

Modeling menu set

Polygons

Polygons > Quadrangulate

Converts the selection to quadrangles.

Related topics

✓ "Convert polygons to triangles or quadrangles" on page 135

Polygons > Quadrangulate > □

Angle Threshold

Use the slider or type a value to set the limit beyond which two triangles are merged or not (where the limit is defined by the angle between the face normals of adjacent triangles). If Angle Threshold is 0, only co-planar triangles are merged. The maximum angle is 180 degrees. A value of 180 degrees means that all possible pairs of adjacent triangles are converted into four-sided faces.

Keep Face Group Border

Turn this option on to maintain the borders of face sets. If turned off, the borders of face sets can be modified. This option is on by default.

Keep Hard Edges

Turn this option on to maintain hard edges. If turned off, hard edges can be deleted between two triangles. This option is on by default.

Keep Texture Border

Maya maintains the borders of texture maps when this option is turned on. If off, the borders of texture maps can be modified. This option is on by default.

World Space Coords

If turned on (the default), the specified Angle Threshold value is the angle between the face normals of adjacent triangles in world space. When turned off, the Angle Threshold value is the angle between the face normals of adjacent triangles in local space.

Polygons > Transfer

Transfers vertex information between meshes.
Related topics
- "Transfer vertex positions (shape), UVs, or vertex color between meshes” on page 136

Polygons > Transfer > □
Choose what types of information you want to transfer between meshes:
- Vertex positions (Vertices).
- UV sets.
- Vertex colors.

Edit Polygons

Edit Polygons > Normals > Vertex Normal Edit Tool
Let's adjust the user-defined normal of a vertex (or several selected vertices) using a manipulator, for example, in order to make sharp corners appear smoother or to adjust the lighting on a polygonal object.

A cube with default vertex normals.  
A cube with vertex normals modified to simulate lighting.

Related topics
- "Manipulate vertex normals to affect shading of polygons” on page 139

Edit Polygons > Normals > Vertex Normal Edit Tool > □
Rotate Mode
- Local: Rotates the vertex normal about the object space axes.
- Global: Rotates the vertex normal about the world space XYZ axes.
Deformable

Allows user-defined vertex normals to be affected by skinning.

On  Vertex normals will be modified by the same weight skinning as the vertex.

Off  Vertex normals will remain in the original object space.

Edit Polygons > Normals > Set Vertex Normal

Controls the positions of vertex normals. This affects the appearance of shaded polygons.

Related topics

- “Manipulate vertex normals to affect shading of polygons” on page 139

Edit Polygons > Normals > Set Vertex Normal > Lock Normals

By default, Maya locks normals to their existing values.

Lock Normals

To change the X, Y, or Z values for normals, turn this option off. The normal values you specify (or if you use the default values) are fixed for each normal associated with the vertex or vertex/face component. This means that if you change a vertex position, normals do not change position.

Unlock Normals

Use this option to unlock locked normals. You can change the X, Y, and Z values, click the Set Normals button and transform the vertices.

X, Y, and Z Values

Enter a value or drag the slider to change the range of the normals associated with the vertices and faces. You can lock or unlock these values using the Lock Normals or Unlock Normals option.
6 | Editing polygons
Reference > Edit Polygons > Normals > Average Normals

Normalize Normal

Regardless of the current normal’s values, clicking this button sets the normals to unit length (or normalizes them).

The unit length of a normal is calculated by the point offset from the vertex. You may inadvertently change the X, Y, Z values to ones that change this unit length to something undesirable which could un-normalize the normals (for example, changing X to 1.11).

Edit Polygons > Normals > Average Normals

Controls the positions of vertex normals. This affects the appearance of shaded polygons.

Related topics

✓ “Manipulate vertex normals to affect shading of polygons” on page 139

Edit Polygons > Normals > Average Normals □

Pre-normalize Normals

Turn this option on so that all the normals in the calculation have a length of 1, and each one contributes equally to the average. This is on by default.

If this option is turned off, and if you explicitly set normals where the length is not equal to 1, then the contribution of these normals to the average is weighted by the length of the normal (the new normal will be closer in direction to the longer normals).

Distance Tolerance

The vertices within the distance you specify are considered as a group to share a normal which is the average of the normals in the group. So your selected vertices may be divided into several groups, and each group averaged separately.

Allow Zero Normals

If two normals of exactly opposite direction are averaged, the result will be a zero-length normal. While this is valid in Maya, it may not be what you want. If this option is turned off, the normals are replaced by user-specified value (see below).

Replace Zero Normals By

If Allow Zero Normals is on, this option is disabled. If Allow Zero Normals is off, the normals are replaced by the X, Y, and Z values you specify here.
Post-normalize Normals

If Pre-normalize Normals is off, you can keep the length of the normal that resulted from the calculation, or set the length to 1 by turning on Post-normalize Normals. The length may be significant in future invocations of Average Normals. If Pre-normalize Normals is on, this option is disabled, since the result will be automatically normalized.

Edit Polygons > Normals > Set to Face

Related topics

- “Manipulate vertex normals to affect shading of polygons” on page 139

Edit Polygons > Normals > Set to Face > □

Set User Normal

If turned on (the default), the vertex/face normal value is locked to its current face normal. Otherwise, the edges surrounding the vertex face are hardened if it is possible to do so, and the normals unlocked.

Edit Polygons > Normals > Reverse

Reverses the normals on the selected polygons.

Related topics

- “Normals” on page 13
- “Reverse polygon normals” on page 136

Edit Polygons > Normals > Reverse > □

Reverse

Maya reverses the normals on the selected faces.

Note

The Reverse option can result in non-manifold geometry, where polygons that share an edge but have reversed normals. Some tools cannot work with non-manifold geometry. See “Clean up, simplify, or validate meshes” on page 153.

To avoid creating non-manifold geometry, use the Reverse and Extract option. This option will split vertices so as not to create non-manifold geometry.
Reverse and Extract
Maya reverses the normals on the selected faces and then extracts, or splits the vertices.

Reverse and Propagate
Maya reverses the normals on all (selected or unselected) faces in the shell.

Edit Polygons > Normals > Soften/Harden
Manipulates vertex normals to change the appearance of shaded polygons.

Related topics
✓ “Manipulate vertex normals to affect shading of polygons” on page 139

Edit Polygons > Normals > Soften/Harden > □
Angle
Use the slider or enter a value to set the angle. Angles greater than the current value render hard; angles less than the current value render soft.

All Hard
Click this button to set the angle to 0, making all selected edges render hard.

All Soft
Click this button to set the angle to 180 degrees, making all selected edges render soft.

Edit Polygons > Make Hole Tool
Creates a hole in a polygon face, optionally in the shape of another face.

Related topics
✓ “Make a hole in a face” on page 138

Edit Polygons > Make Hole Tool > □
None
The stamp face projects directly onto the face plane you select. This is the default.
**First, Middle, and Last merge modes**

Using the First, Middle, and Last merge modes, the center of the stamp face is made to match with the center of the face the hole is made on.

**First**

The face selected second is transformed to make the centers match. The first selected face does not get transformed.

**Middle**

Both the first and the second faces are transformed to make their centers match.

**Second**

(Or last) The face selected first is transformed to make the centers match. The second selected face does not get transformed.

**Project Merge modes**

The Project Merge modes make the hole exactly where the stamp face resides. These modes do not center the hole but align the hole flat with the plane face. They also do not rotate the face to match the center as with the First, Middle, and Second (last) merge modes.

**Project First**

The second selected face is projected onto the first and the centers do not match. The face is not rotated, unlike the First merge mode where the face is rotated to match the center.

**Project Middle**

Both faces are projected onto a plane lying between them; their centers do not necessarily match.

**Project Second**

(or projLast) The first selected face is projected onto the second (last) selected face and the centers do not match.

**Merge mode examples**

The following examples show the difference between using the merge modes.
6 | Editing polygons
Reference > Edit Polygons > Make Hole Tool

None  First  Project First
Middle  Project Middle  Second (Last)  Project Second (ProjLast)
Clean up

How do I? Create and edit models

Clean up or simplify polygons

Delete polygon vertices and edges

Delete vertices

You cannot delete most polygon vertices with the Delete key. You must use Edit Polygons > Delete Vertex.

The faces surrounding a deleted vertex are replaced with a single n-sided polygon created from the vertices surrounding the deleted vertex. Maya does not use quads and triangles in the affected area in order to reduce the number of polygons.

This action is equivalent to selecting all the edges surrounding the vertex and deleting them.

**To delete vertices:**

Select one or more vertices and choose Edit Polygons > Delete Vertex.

**Notes**

- Deleting vertices will affect UVs, color, and blind data, and therefore the mesh’s appearance may change.
- Maya preserves shader and other set memberships based on vertices and faces.
- If you delete vertices from a polygonal instance, the geometry changes for all instances.

Delete edges

The Delete key deletes edges. To also delete the vertices shared at the ends of the edges, use Edit Polygons > Delete Edge.

**To delete unwanted vertices in addition to edges**

Select the edges you want to delete and choose Edit Polygons > Delete Edge.
7 | Clean up
How do I? > Delete polygon vertices and edges

What if...?

I cannot delete vertices with the Delete key?

If you try to delete interior vertices with Delete, Maya will tell you that it cannot delete “non-winged” vertices. “Non-winged” vertices are connected to more than two edges.

Select the vertices and choose Edit Polygons > Delete Vertex, or only select vertices that reside at a corner or are connected to two edges only (winged vertices).

I cannot delete edges?

If you select edges that are border edges, you cannot delete them. Select edges within the border edges to delete them.
Related topics

- "Clean up, simplify, or validate meshes” on page 153
- “Reduce the number of faces in a mesh” on page 153

**Clean up, simplify, or validate meshes**

Cleanup provides you with the ability to remove unwanted geometry such as zero area faces or zero length edges. You can also tessellate faces that may be valid in Maya, but not in your game engine, such as concave faces, or faces with holes.

**To clean up polygonal geometry**

1. Select the geometry.
2. Select Polygons > Cleanup.

**Related topics**

- “Polygons > Cleanup” on page 155

**Reduce the number of faces in a mesh**

Maya can automatically reduce the number of polygons in a mesh by some percentage you specify while attempting to retain the shape of the original. You can also paint to specify where on the model Maya can reduce more or less.

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reduce the number of faces in a mesh.</td>
<td>Select the faces you want to reduce, then choose Polygons &gt; Reduce &gt; □.</td>
</tr>
<tr>
<td>Keep the current polygon mesh so you can compare the original and reduced versions as you change options.</td>
<td>In the Polygon Reduce Options window, turn on the Keep Original option. The reduced mesh will appear next to the original along the X axis.</td>
</tr>
</tbody>
</table>

**To get finer control over which areas are reduced**

1. Select the faces you want to reduce.
2. Choose Polygons > Reduce > □.
Set the general reduction percentage and turn on Keep Original, then click Reduce.

The reduced mesh appears next to the original along the X axis.

Choose Edit Polygons > Paint Reduce Weights Tool.

Paint reduction values on the original.

Darker areas will be reduced more. Lighter areas will be kept as-is as much as possible.

As you paint on the original, the reduced version will update.

Notes

- You cannot paint reduce weights on the reduced version. You must use the Keep Original option and paint on the original object. If you try to paint reduce weights on the reduced version, Maya will automatically select the original instead.

- When you select faces to reduce (rather than reducing the entire mesh), faces bordering the selection may move or be reduced as well. You can avoid this effect by extracting the polygons from the mesh before reducing them. Turn on the Preserve Mesh Borders option so the extracted mesh can be reattached later.

- When you are painting reduce weights, the Paint Attributes tool’s default is to only update when you finish a stroke. This is because the reduce operation can take a noticeable amount of time on large meshes. If you want the reduced version to update as you paint, choose Modify > Attribute Paint > , open the Stroke section, and turn on Update Continuously.

- Reduce Weights are a bias, not an absolute control. In some extreme cases polygons that you painted white but are not needed will still be reduced to preserve shape elsewhere.

- Reduce works with quads and n-sided polygons, however:
  - Unless you really need to preserve non-triangles, leave the Triangulate option on for better reduction.
  - Non-planar polygons can become deformed and do not reduce well.

Related topics

- “Delete polygon vertices and edges” on page 151
- “Polygons > Reduce” on page 157
Reference Menus

Modeling menu set

Polygons

Polygons > Cleanup
Performs various operations on the selection to remove extraneous and invalid polygon geometry.

Related topics
❖ “Clean up, simplify, or validate meshes” on page 153

Polygons > Cleanup > □

General Options
Use these options to specify what parts of the polygonal geometry you want to clean up.

Operation
Select one of the following options.

Select and Cleanup
Use this option to repeatedly clean up the selected polygonal geometry using the same option settings. This is the default.

Select Geometry
Use this option to select geometry that meets the criteria you set, but do not do the clean up.

Select all Polygonal Objects
Turn this option on to clean up all polygonal objects in the scene. The default is off.

Construction History
Turn this option on to keep the construction history associated with the polygonal geometry you select.

Tessellate Geometry
Use these options to specify the types of faces you want to clean up by tessellating (triangulating).
When you create polygonal geometry and use some of the polygonal editing operations, Maya may create some faces with attributes you do not want.

The following illustrations show the kinds of problems you can encounter with polygonal faces.

**Other**

**Nonmanifold geometry**

Turn this option on to clean up nonmanifold geometry. Select one of the following options to control what happens to the resulting normals. For information on nonmanifold geometry, see “2-manifold, non-manifold, and invalid polygonal geometry” on page 15.

- **Normals and Geometry**
  - Turn on this option to conform normals when cleaning up nonmanifold vertices or edges.
- **Geometry Only**
  - Cleans up nonmanifold geometry without changing the resulting normals.

**Remove Geometry**

Select which geometry you want removed during cleanup and specify the tolerance within which the geometry must be to be removed. You can remove the following:

- edges within a defined length tolerance
• faces within a defined geometry area tolerance
• faces within a defined map area tolerance
• Lamina faces, which are faces that share all edges

When you select to remove faces within a set geometry area tolerance (for example, remove faces with areas between 0 and 0.0001), faces are removed by merging vertices. To ensure that this operation removes faces with areas within the defined tolerance, you must set the edge length tolerance for the edge vertices to be merged. If you do not otherwise want to remove edges within the length tolerance, you can turn off the Edges with zero length option after setting the tolerance.

When you select Lamina Faces for removal, Maya removes faces that share all edges. By removing these types of faces, you can avoid unnecessary processing time, especially when you export the model to a game engine.

You might inadvertently create faces with shared edges. For example, suppose you performed Edit Polygons > Duplicate Face with the Separate Duplicate Faces option turned off. You would have two faces on top of each other. If you later merge the vertices of the two faces, they would share the same edges. You could then remove the extra face using Cleanup with Lamina Faces turned on.

Poligons > Reduce

Reduces the number of polygons in the selection, optionally taking into account UVs and vertex colors as it chooses which areas to reduce.

Related topics
• “Reduce the number of faces in a mesh” on page 153
7 | Clean up
Reference > Polygons > Reduce

Polygons > Reduce > □

Reduce by (%)

Maya tries to reduce the number of polygons in the selected mesh or meshes by the specified percentage. The actual reduction may not match this number exactly.

Triangle Compactness

Controls the degree to which Maya sacrifices mesh shape accuracy to produce better triangles, as a number from 0 to 1.

0 means try to reproduce the original mesh shape as accurately as possible while reducing, no matter what kind of triangles are produced. 1 means sacrifice accuracy as much as possible to produce regular equilateral triangles.

Numbers closer to 0 can produce long skinny triangles that can be hard to work with. Numbers closer to 1 can produce reduced meshes that do not match the shape of the original.

Triangulate

Converts the polygons to triangles before reducing them.

Unless you really need to preserve non-triangles, leave this option on for better results.

Influence Reduce

These options take extra information (beside shape) into account when reducing the mesh.

UVs

Reduces polygons to preserve UV mapping as much as possible. Turning this option on will preserve texture placement between the original and reduced polygons.

Color per Vertex

Reduces polygons so that color per vertex data (such as prelighting and painting) is preserved as much as possible. Turning this option on will devote more polygons in the reduced mesh to areas with color changes, and fewer polygons to areas with flat color to preserve the look of the original.

Preserve Mesh Borders

Maya attempts to preserve the shape of polygon borders (edges that are not shared by other polygons).
UV Borders

Maya attempts to preserve the shape of UV borders as it reduces.

Turning this on can give unpredictable results if you have a lot of UV borders. Try sewing as many UV pieces together as possible before reducing.

| Note | If a polygonal surface has numerous UV seams on it and if the Polygons > Reduce operation is performed with UV Borders turned on, there is a good chance the object will not reduce at all, since the reduction algorithm is attempting to maintain the UV borders (seams) that are on the object. If you don’t mind losing your UV seams, turn off UV Borders to successfully reduce your polygonal surface. |

Hard Edges

Maya attempts to preserve the shape of edges marked “hard” as it reduces.

You can set edges on a mesh to be hard or soft using Edit Polygons > Normals > Soften/Harden > □. Marking edges as “hard” can result in more shape retention than painting reduction weights.

Compatibility with previous versions

Maya now uses an improved reduce method which gives better results and allows you to preserve important details in your model.

Scene files created with previous versions of Maya may contain reduce nodes created by the old reduce method. The nodes in these scenes will continue to use the old method. New reductions will use the new method.
7 | Clean up
Reference > Polygons > Reduce
How do I?  View the scene and change the display

Show polygon counts in the heads-up display

Turn on Display > Heads Up Display > Poly Count to show the number of polygon vertices, edges, faces, triangles, and UVs in the views.

<table>
<thead>
<tr>
<th>Column</th>
<th>Shows...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Total counts for all <em>visible</em> polygons.</td>
</tr>
<tr>
<td></td>
<td>![Left Column Image]</td>
</tr>
<tr>
<td>Middle</td>
<td>Counts for <em>selected</em> polygons.</td>
</tr>
<tr>
<td></td>
<td>![Middle Column Image]</td>
</tr>
</tbody>
</table>
### How do I? > Show polygon counts in the heads-up display

<table>
<thead>
<tr>
<th>Column</th>
<th>Shows...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right</td>
<td>Counts for selected <em>components</em> on objects that are partly visible in the view.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Verts</th>
<th>Edges</th>
<th>Faces</th>
<th>UVWs</th>
</tr>
</thead>
<tbody>
<tr>
<td>342</td>
<td>710</td>
<td>384</td>
<td>355</td>
</tr>
<tr>
<td>342</td>
<td>710</td>
<td>384</td>
<td>355</td>
</tr>
</tbody>
</table>

**Changing your view can affect the counts**

The numbers only count visible objects (whether they are selected or not). If you track the view so some objects are no longer visible, they will not be included in the counts.

The can be useful for games developers to get an idea of how many polygons a given view will require.
Reference Menus

Display

Display > Custom Polygon Display

Controls the display of polygons and polygon components in the view panels.

Display > Custom Polygon Display > □

Open the Custom Polygon Display options window to precisely set the size of normals and display them on faces and/or vertices as you work (Display > Custom Polygon Display > □). Turn on Normals for Vertices and/or Faces, set the Normals Size to what you want, and click the Apply button.

Using the Custom Polygon Display window, you can set how specific components of your polygons display to enhance the view while you work. For example, if you want to select edges to perform a merge edge operation, select the object, click an option to highlight the border edges, increase the size of the border width, then click the Apply button to enhance the display.

Select Display > Custom Polygon Display > □ to open the window.

Remember to click the Apply button each time you set one of the options for your active objects. If you want to return to the regular display, select Reset Settings from the windows Edit menu then press the Apply button.
Displaying vertices and normals display
Switch the display of vertices or normals on or off. You can change the size of the normals by setting the Normals Size value.

Setting the normals size
In the Normals Size box, enter a value or use the slider to specify the normals display size. The range is from 0.2 to 10.

Backculling
Backculling is used to select and only draw what is facing the camera in the 3D view. In effect, Maya displays vertices in areas where the normal is pointing away from the camera.

Displaying edges
Select to display all edges the same way (Standard), soft edges as dotted lines and hard edges as solid lines (Soft/Hard), or show hard edges only (makes soft edges invisible).

Highlighting borders
Select to make outside edges thicker (Border Edges) or to display a thick border to highlight the area a texture affects per-polygon or per-vertex.

Changing the border width
You can change the Border Width by dragging the slider or entering a value.

Setting the face display
Select to display a small square to indicate the face center (Centers), to show the normals at the center of each polygon (Normals), or select Triangles to show all polygons as triangles for display purposes.

Highlighting non-planar faces
Select Non-planar to highlight all non-planar faces.
Showing item numbers

Use the Show Item Numbers options to display index numbers on an object’s vertices, edges, faces, or UVs, depending on which component types you select. If you turn on UVs, the numbers appear in the UV Texture Editor only.

Displaying texture coordinates (UVs) and UV topology

Turn on the UV and UV Topology options to see the UVs on your object.

- If UVs are shared, they display as single purple dots.
- If unshared, multiple purple dots display close to the vertex to which a given UV belongs. When you select the UV in the UV Texture Editor, a line displays pointing to the face it belongs to.

Turn on the UV Topology option to display and be able to select unshared UVs.

Color operations

When Color in Shaded Display is on, you can see the effects of Apply Color, Prelighting, and the Paint Vertex Color Tool while in shaded mode. This option is turned on by default whenever you select these commands.
Select a Color Material Channel to refine your application. See Chapter 9, “Coloring polygons” for details about using these options and the Apply Color operation.

**Backface Culling**

Backface Culling is used to select and only draw what is facing the camera in the 3D view. Select one of the following options.

**Off**

Maya turns backface culling off. This is the default.

**On**

Maya displays backface culling, causing surfaces to appear invisible in areas where the normal points away from the camera. You can improve performance on some systems by toggling on Backface Culling.

**Keep Wire**

Maya sets backface culling for all surfaces except wireframe outlines.

**Keep Hard Edges**

Maya sets backface culling for soft edges only.
9 | Coloring polygons

About > Coloring polygons

9 Coloring polygons

About

Polysgons

Coloring polygons

You can assign a color to each vertex associated with a face. Even if a vertex is shared between faces, it has a color for each face that shares it. The colors at the vertices of a face are blended together across the face.

Related topics

- “Prelighting” on page 167
- “Make vertex colors visible” on page 168
- “Assign colors to vertices” on page 169

Prelighting

Prelighting stores the shading and lighting information from the rendered look of a mesh in its vertex colors.

This lets a simpler display device (such as a console game rendering engine) show the objects as though they were shaded and illuminated without actually having the shading, lights, or textures, and without doing the rendering calculations.

After you prelight you can simplify a scene by removing lights and shading, or simplify shading networks, since the final result is “baked on” the polygons.

Prelighting is also useful to export to a platform that does not support certain shading effects. For example, some graphic APIs only support a limited number of lights, and many platforms have a limited amount of texture memory available. If you prelight some lights and textures and bake their effects onto the geometry, they can then be removed from the scene.

Similarly, some platforms may be unable to fully achieve the effects available from Maya’s software rendering network. Prelighting removes the need to transfer the shading network functionality.
Sample storage

A sample can either be stored as color-per-vertex-per-face, or used to displace the position of a vertex.

If stored as a color-per-vertex-per-face color, RGB color and alpha (transparency) is stored. For displacement, the X,Y,Z coordinates of the vertex position changes. Since a sample contains four channels (RGBA), the displacement uses the luminance value of the color.

Related topics

- “Make vertex colors visible” on page 168
- “Assign colors to vertices based on their rendered look (prelight)” on page 170
- “Remove colors/prelighting from vertices” on page 172

How do I?  Apply colors, shading, and textures

Apply colors to polygons

Make vertex colors visible

The following conditions must be true for polygon colors to be visible in view panels. When you apply colors or prelighting, or paint vertex colors, Maya sets these conditions automatically as long as Edit Polygons > Color > Convert Display is on.

- You must be in a shaded mode.
  
  Select any of the shaded modes, such as Smooth Shade All, from the Shading menu in a view panel.

- In Display > Custom Polygon Display > □, you must have Color in Shaded Display turned on and have selected a Color Material Channel other than None.
  
  This option controls which material shader channel Maya overrides with the vertex color.

To avoid the interference of scene lighting with the display of vertex colors, turn on Lighting > Use No Lights.

The following illustration shows the difference made on a tower that has prelighting applied and green color-per-vertex near the base. The rock in the foreground has no prelighting, so it loses all shading and highlights.
**Assign colors to vertices**

To assign a color to vertices

1. Select the vertices and choose Edit Polygons > Colors > Apply Colors.
2. Do one of the following:
   - Click Replace to set the color for these vertices.
   - Click Add or Subtract to add or subtract the RGB values of the color you choose here to the current color of the vertices. This is useful for adding or subtracting white, red, green, blue, cyan, yellow, or magenta from a number of differently colored vertices at once.
3. Click the color swatch to edit the color in a color editor, or click the eyedropper button and then click any pixel on the screen to pick up its color.
4. Click Apply Color.
Assign colors to vertices by painting

To paint vertex colors

1. Select the mesh you want to paint on.
2. Select Edit Polygons > Colors > Paint Vertex Color Tool > ☐.
   The selected polygonal surface should display in black.
3. Click the color swatch to edit the color in a color editor.
4. Do any of the following:
   • Drag the brush across the mesh to color the vertices.
   • Hold / (slash) and click any pixel on the screen to switch to its color.
   • Click the Flood button to set all vertices to the current color and attributes in the tool options panel.

Related topics

❖ “Make vertex colors visible” on page 168
❖ “Assign colors to vertices” on page 169
❖ “Assign colors to vertices based on their rendered look (prelight)” on page 170
❖ “Remove colors/prelighting from vertices” on page 172
❖ “Edit Polygons > Colors > Apply Colors” on page 173

Assign colors to vertices based on their rendered look (prelight)

Prelighting stores the shading and lighting information from the rendered look of a mesh in its vertex colors.
**To prelight a scene**

1. Select the meshes or components you want to prelight.
2. Select Edit Polygons > Colors > Prelight (renderer) > □.
3. Set the prelight options and click Prelight.

**To save prelighting to a texture map**

1. Select the prelit mesh.
2. Select Edit Polygons > Colors > Paint Vertex Color Tool > □.
3. Open the Attribute Maps, Export section.
4. Set the attributes you want to export and click Export.

**Notes**

- The mesh must be illuminated by at least one light for prelighting to have any effect.
- Prelighting can be an iterative process. You may need to repeat the process to achieve the effect you want, tweaking the prelight options each time.

**Related topics**

- “Prelighting” on page 167
- “Make vertex colors visible” on page 168
- “Assign colors to vertices” on page 169
- “Edit Polygons > Colors > Prelight” on page 175

**Animate vertex colors**

You can animate vertex colors. For example, you can create an animation of blood color dripping down a wall or of a crystal changing from dull to glowing green.

**To animate vertex colors**

1. Before beginning, make sure the object has some construction history. If it does not have construction history, the colors per vertex feature will fail to set a key. You can quickly create history on a model by choosing Edit Polygons > Move Component, but moving nothing.

2. On a given frame, assign colors to selected vertices. The color assignment operations are under the Edit Polygons > Colors menu, such as Apply Color and the Paint Vertex Color Tool.

3. Choose Edit Polygons > Color > Set Vertex Color Key. (You cannot use any other keyframing method.)
To delete vertex color animation

- Delete the polyColorPerVertex node.
- If you delete construction history from the mesh (Edit > Delete by type > History), Maya also deletes the vertex color animation.

What if...?

Playback becomes slow after animating vertex colors?

Maya creates animation curves for each vertex per face. For this reason, playback performance slows down significantly if you animate too many vertices.

Try to limit the number of vertices you animate. Another alternative is to delete the static animation curves.

I get a warning “Active objects have no keyable attributes?”

You must first apply a color. You cannot set a keyframe if there is no color assigned.

I get a warning “Current manipulator and active objects have no keyable attributes?”

You must add construction history to the mesh. If the mesh does not have construction history, the vertex color change not set a key.

You can quickly create history on a model by using Edit Polygons > Move Component with translation set to 0.

Remove colors/prelighting from vertices

1. Select the vertices and choose Edit Polygons > Colors > Apply Colors.
2. Click Remove;
3. Click Apply Color.

Related topics

- “Make vertex colors visible” on page 168
- “Assign colors to vertices” on page 169
- “Assign colors to vertices based on their rendered look (prelight)” on page 170
- “Edit Polygons > Colors > Apply Colors” on page 173
Reference Menus

Modeling menu set

Edit Polygons

Edit Polygons > Colors > Apply Colors

Adds or removes colors on the selected vertices.

Related topics
- "Coloring polygons" on page 167
- "Make vertex colors visible” on page 168
- "Assign colors to vertices” on page 169
- "Remove colors/prelighting from vertices” on page 172

Edit Polygons > Colors > Apply Colors > □

Operation section

The selected option determines which operation is applied to the selected vertex or vertices.

Replace

 replaces the selection’s color with the color you define in the Color Value section. This is the default.

Add

 Adds the color you define in the Color Value section to the selection.

Subtract

 Subtracts the color you define in the Color Value section from the selection.

Remove

 Removes all vertex color from all vertices.

Color Value section

Color

 Click the swatch to display the Color Chooser. Use the slider to adjust the value of the swatch color.
9 | Coloring polygons
Reference > Edit Polygons > Colors > Paint Vertex Color Tool

Grab Color
Click the eyedropper button to enable the eyedropper, which lets you pick any color on your monitor to define the Color.

Selected Vertex Color
Click this button to change the Color to the color of the selection.

Alpha
Sets the alpha channel of the Color, which defines the object’s transparency.

Resulting Color
Displays the actual color that is applied to the selection, taking into account both the Color and the Alpha settings.

Color Channel Values section
Set Individual Color Channels
Turn this option on to make the Color Channel Values options available and the Color Value options unavailable.
You can set the red, green, blue, and alpha (RGBA) values individually by turning on the Set Red, Set Green, Set Blue, and Set Alpha options, respectively, and changing the corresponding values.

Edit Polygons > Colors > Paint Vertex Color Tool
Lets you set color-per-vertex on polygons by painting directly on the mesh with the stylus.

Related topics
❖ “Make vertex colors visible” on page 168
❖ “Assign colors to vertices by painting” on page 170
See also “How Artisan brush tools work” in the Paint Effects, Artisan, and 3D Paint guide.

Edit Polygons > Colors > Paint Vertex Color Tool > □
Lets you specify the settings for the Paint Vertex Color Tool in the Tool Settings editor. There are attributes unique to the Paint Vertex Color Tool in the Color sections. These unique attributes are described below. For descriptions of all other attributes in all other sections, see “Common Artisan Brush Tool Settings” in the Paint Effects, Artisan, and 3D Paint guide.
9 | Coloring polygons
Reference > Edit Polygons > Colors > Prelight

Color
These are descriptions of the attributes in the Color section.

Paint
- **Vertex**: All faces connected with the vertex you paint over gets the color.
- **Vertex face**: Only the face over which the brush is moving gets the color.

Channels
- **RGB**: Painting vertices applies the Color Value.
- **RGBA**: Painting vertices applies the Color Value (color) and Color Alpha (transparency).

Color Value
The color that painting will apply to vertices.

Color Alpha
The alpha value that painting will apply to vertices (when Channels is RGBA). Painting vertices with a Color Alpha of 0 makes them transparent. Painting vertices with a Color Alpha of 1 makes them opaque.

Flood
Sets all vertices to the current Color Value (and Color Alpha if Channels is RGBA).

**Edit Polygons > Colors > Prelight**
“Bakes” the rendered look (textures, lights, shadows) into polygon vertex colors.

Related topics
- “Prelighting” on page 167
- “Assign colors to vertices based on their rendered look (prelight)” on page 170

**Edit Polygons > Colors > Prelight > □**
By default all options are turned off, and the Sample scale factor is set to 1.0.
Sample selected faces only

You can select objects and or any type of polygonal component of an object. This includes vertices, edges, faces, and UV / map component types. By default Maya examines each component type to determine which vertices have been selected and the selected vertices are then sampled.

If Sample selected faces only is turned on, Maya examines each component type to determine which complete faces have been selected. The selected faces are then sampled.

For example, if a face has four vertices, and only three of them are selected:

- if Sample selected faces only is off, three vertices are used for sampling.
- if Sample selected faces only is on, no sampling will be performed since the face is considered to be only partially selected.

Sample using face normals

This option uses the corresponding face normals for sampling regardless of whether Sample selected faces only is off, or whether the edge is hard or soft.

Compute shadow maps

Turn this on if you want shadows to be computed. A software rendering Shadow Pass occurs, which outputs a set of depth shadow maps, and then uses these maps during a sample evaluation.

It is equivalent to doing the following in Maya rendering:

- Set Shadow Pass on in Render Globals.
- Select each light and turn Compute shadow maps on.
- Select each light and turn Write maps on, then turn Reuse and Read maps off.
- Perform a software render with the current active view camera.
- Select each light and turn Write and Reuse maps off, then turn Read maps on.
- Read in the shadow maps, and use them during sampling.

Override shadow map options on lights

This option is available only if Compute shadow maps is on. If Override shadow map options on lights is turned on, shadows will be computed for each light, even if Use Depth Map Shadows is turned off for the lights.
Reuse computed shadow maps
To re-use computed shadow maps, turn Compute shadow maps on. Turn this option on to skip the Shadow Pass computation (Compute Shadow maps above). This lets you use statically created shadows, and/or computes shadows just once for future adjustments of the prelight operation or the software rendering.

Ignore mapped channels on surface shaders
Turn this option on to turn on Ignore when Rendering for each channel of the surface shader.

Sample incoming illumination only
If this option is selected, only incoming illumination lighting is computed. This option is useful if you want to use this information for your own shading computations. It is also useful if you want to sample lighting effects, such as when a light’s color has been mapped.

Note that the lights in your scene must have a Decay Rate for this option to have an effect.

Displace geometry
Using sampled shading values to displace geometry is not a prelighting effect, but is related to using sampling data to modify attributes on an object’s geometry. The positions of the vertices selected to sample are displaced along their normals by the sampled data value amount. The normal used for displacement is the vertex normal used for rendering.

You can see this normal in a perspective view by turning on the Vertices Normals option in the Custom Polygon Display Options window (Display > Custom Polygon Display > □).

Notes
- Sample using face normals is disabled when this option is turned on. That is because performing a displacement for each face of a vertex cannot be done, which would be attempted if Sample using face normals was available.
- Rendering > Lighting/Shading > Displacement to Polygon achieves much the same effect (although it can only be applied to the entire object).

Store shared values
If there are multiple vertices are selected, turn this option on to average the values at the vertices and store the average value.
Sample scale factor

The scale factor is useful if you want to brighten or darken colors before storage, or to adjust the amount of displacement to be performed.

It is possible to scale the sample before applying it to the geometry (meaning, you can store color or displace a point). For colors, a negative scale factor is ignored. For geometric displacement, the scale factor is taken into consideration regardless of whether it is positive or negative.

| Note | A value between 0.0 and 1.0 is usually applied to each channel of a sample, though values greater than 1.0 can be used. |

Clamp minimum RGBA value, Clamp maximum RGBA value

Turn on these options to clamp the minimum and maximum RGBA values so that the values are forced to be within the range you set.

Color Blending, Alpha Blending

Control how the newly computed colors and transparency values affect the current colors/transparency on the vertices.

The minimum and maximum clamp options are applied after the operation.

- **Overwrite**
  The new value replaces the current value.

- **Add, Subtract, Multiply, Divide**
  Combines the current and new values with a mathematical operation.

- **Average**
  Averages the current value and the new value.

- **Don’t Overwrite**
  Won’t save the new value if the vertex has a current value.
About Polygons

Texturing polygons

Unlike NURBS surfaces, polygons do not have natural 2D coordinates you can use to specify a point on its surface. This becomes the central issue when you want to map a texture (usually an image) onto a mesh: how do you control which part of the image corresponds to which points on the mesh?

The solution is **UV mapping**. This means interactively specifying the correspondence (mapping) of the texture onto the polygons. You do this by moving, editing, rotating, and arranging a flattened (2D) representation of the polygons over the texture in the UV texture editor window.

UV mapping is not necessary for creating and reshaping polygons. You only need to do it if you want to apply a texture to polygons. Textures applied to polygons without mapped UVs do not render.

**UVs and mapping**

UVs are points that correspond to polygon vertices, but live in the 2D world of the texture. They control which points (pixels) on the texture correspond to which points (vertices) on the mesh.

Although Maya creates UVs by default, in many cases, you’ll need to rearrange UVs because the default arrangement will not match the modeling changes you make. Typically, you arrange UVs after you have completed your modeling and before you assign textures to the model.

UVs are arranged in a 2D coordinate system called texture space. You can see the texture space coordinates in Maya’s UV Texture Editor (formerly called Texture View). For example, the following illustration shows the default UV arrangement for the model of a fish. When a texture is assigned using this default UV arrangement, the result is haphazard.
In this example, you can use Maya operations to rearrange the UVs into a pattern that more closely resembles the fish model. The new arrangement applies the texture more evenly around the model. See the following illustration.

Mapping

To begin rearranging UVs, you first need to assign them to the surface, known as mapping UVs. You’ll learn how to map UVs in this chapter.

Polygonal surfaces have their own mapping and editing operations, separate from the subdivision surface operations. There are numerous mapping operations available, under the Edit Polygons > Texture menu.

To create a UV mapping arrangement that works best for your model, you may need to map several times, using various mapping operations, until you find a mapping arrangement that is suitable. See the following guidelines.
Guidelines for UV arrangement

Knowing how to arrange UVs is somewhat of an art form. The best arrangement depends on the types of textures you will apply and also on whether you are creating rendered images or models for interactive games. A full description of UV arrangement is out of the scope of this guide. At a minimum, though, you should consider these guidelines:

Keep UVs within the 0 to +1 texture coordinates

The UV Texture Editor displays a grid marking the coordinates for UVs. You should keep UVs within the 0 to 1 coordinates because Maya automatically fits textures into these coordinates. If UVs extend beyond the 0 to 1 range, the texture will appear to repeat around the corresponding vertices. The exception is when you want the texture to repeat on the surface, such as a brick texture along the model of a wall.

By default, the UV mapping operations automatically fit UVs within the 0 to 1 coordinates.

Avoid overlapping UV pieces

As the illustration of the fish model shows, UV points have interconnecting lines that form a shape, called a UV piece. If pieces overlap in the UV Texture Editor, the texture will appear to repeat on the corresponding vertices. In general, you should avoid overlapping UVs, unless you want the texture to repeat. For example, if you want the arms of a character to share the same texture pattern, you can place the UV piece corresponding to one arm on top of the piece corresponding to the other arm, using the Move tool.

The Planar Mapping operation often results in overlapping UV pieces, but you can easily separate the pieces using the Layout UVs operation, as described in Chapter 11, “Texture editor.”

The texture editor

The following topics explain the basic usage of the UV Texture Editor (Window > UV Texture Editor), which is the main tool for editing UVs.

There are separate menus for polygons and subdivision surfaces. Use the items in the Polygons menu, not the Subdivs menu. These items are also available in the Edit Polygons > Texture submenu.
10 | Projecting and mapping UVs
How do I? > Project UVs onto polygons from a plane

How do I? Apply colors, shading, and textures

Map UVs to polygons

Project UVs onto polygons from a plane

Planar mapping projects UVs onto a mesh through a plane. This projection is best for objects that are relatively flat, or at least are completely visible from one camera angle.

Planar mapping typically gives overlapping UV pieces. The UV pieces may be perfectly superimposed and look like a single UV piece. You should use Edit Polygons > Texture > Layout UVs after mapping to separate overlapping UVs.

To map based on the best fit plane of the selection

The Best Plane Texturing operation assigns UVs to the faces you select based on a plane computed from vertices you specify.

You can select the faces you want to map before you choose the Best Plane Texturing tool, or you can choose the tool and then click each face you want to map.

1. Select the faces you want to map UVs onto.
2. Select Edit Polygons > Texture > Best Plane Texturing Tool.
3. You click faces to add them to the selection.
4. Select one or more faces on which you want to map the texture. You cannot marquee-select the faces—you must select the faces one by one, or select the faces before using the operation.
5. Press Enter.
6. Select one or more vertices (press the right mouse button on the mesh and choose Vertex to switch to selecting vertices).
7. Press Enter.
10 | Projecting and mapping UVs

How do I? > Project UVs onto polygons from a plane

**To project from a plane defined by the view**

1. Select the faces you want to project UVs onto.
2. Tumble the perspective view, or track an orthographic view to look at the faces.
3. Select Edit Polygons > Texture > Create UVs Based on Camera.

**To map based on a manually positioned plane**

1. Select the faces you want to project UVs onto.
3. Turn on Automatically Fit the Projection Manipulator.
4. Choose the initial size and position of the projection manipulator:
   - Click Fit to Best Plane to position the manipulator based on the faces you selected.
   - Click Fit to Bounding Box to position the manipulator based on the bounding box of the mesh.
5. Click Project.
6. Use the manipulator to control how the plane distributes UVs.
You can also rotate the manipulator by clicking the red crossed lines, which reveals the Show Manipulator tool. Click the light blue circle around the Show Manipulator handle to activate the rotate handles.

**Notes**

- Planar mapping can create shared, overlapping UVs that can look like texture borders. Turn on texture border display (in Display > Custom Polygon Display > boxshadowup) to clearly show texture borders.

- Shared, overlapping UVs can create seam problems if you paint over them with the 3D Paint Tool. To avoid these problems, manually separate the UVs with Edit Polygons > Layout UVs > boxshadowup. Set Separate to Folds and the Layout option to Along U or Into Square.

- Projection mapping only works properly on a single object at a time. If you need to apply a projection to multiple polygonal objects in a single step, combine the objects into one, apply the projection, and then separate the parts back out. Otherwise, perform a projection on each object.

**Related topics**

- “UVs and mapping” on page 179
- “Project UVs onto polygons from a cylinder or sphere” on page 185
1 Projecting and mapping UVs

How do I? > Project UVs onto polygons from a cylinder or sphere

- “Map UVs onto polygons automatically” on page 186
- “Edit Polygons > Texture > Planar Mapping” on page 189
- “Edit Polygons > Texture > Create UVs Based on Camera” on page 192

Project UVs onto polygons from a cylinder or sphere

Cylindrical and Spherical mapping map UVs by projecting based on a cylindrical or spherical shape wrapped around the mesh. These projections are best for shapes which can be completely enclosed and visible within a cylinder or sphere, without projecting or hollow parts.

1. Select the faces you want to project UVs onto.
2. Select Edit Polygons > Texture > Cylindrical Mapping or Edit Polygons > Texture > Spherical Mapping.
3. Use the manipulator to change the position and size of the projection shape.
Notes

- Projection mapping only works properly on a single object at a time. If you need to apply a projection to multiple polygonal objects in a single step, combine the objects into one, apply the projection, and then separate the parts back out. Otherwise, perform a projection on each object.

Related topics

- “UVs and mapping” on page 179
- “Project UVs onto polygons from a plane” on page 182
- “Map UVs onto polygons automatically” on page 186
- “Edit Polygons > Texture > Cylindrical Mapping, Spherical Mapping” on page 192

Map UVs onto polygons automatically

Automatic mapping attempts to find the best UV placement by simultaneously projecting from multiple planes. This is useful for more complex shapes where the basic planar, cylindrical, or spherical projections to not place UVs well, especially around projecting or hollow parts.

Automatic mapping creates several UV map pieces in texture space. This is fine if you are using tools that deal with UVs automatically for you, such as standard (not combed) fur and the 3D Paint tool in projection mode. If you need to deal with the UVs manually, you’ll probably want to stitch the UV pieces back together in the texture editor by clicking the Move and Sew button in the toolbar.
10 | Projecting and mapping UVs
How do I? > Map UVs onto polygons automatically

Open the UV Texture Editor (Window > UV Texture Editor) so you can view the projection.

In a modeling view, select the faces you want to map (usually the entire mesh).

Select Edit Polygons > Texture > Automatic Mapping > .

Choose the number of planes to project from. The more planes you use, the less distortion in the UV layout but the more pieces are created.

If you will use the 3D Paint tool, turn on the Uniform option. This scales the UVs to within 0 and +1, which the 3D Paint tool requires.

Click Project.
10 | Projecting and mapping UVs
How do I? > Map UVs onto polygons automatically

Notes

- Projection mapping only works properly on a single object at a time. If you need to apply a projection to multiple polygonal objects in a single step, combine the objects into one, apply the projection, and then separate the parts back out. Otherwise, perform a projection on each object.

Related topics

- “UVs and mapping” on page 179
- “Project UVs onto polygons from a plane” on page 182
- “Edit Polygons > Texture > Cylindrical Mapping, Spherical Mapping” on page 192
- “Edit Polygons > Texture > Automatic Mapping” on page 194

Assign the default shader as you project UVs to check registration

If you turn on Edit Polygons > Textures > Assign Shader to Each Projection, Maya will assign a checkerboard shader to the mesh as you project UVs. This gives you quick visual indication of the UV placement.

You can use a different texture on the defaultPolygonShader. For example, if you’re going to be mapping a stone texture to many objects, edit the defaultPolygonShader to use a stone texture for previewing.

If you do not need to pre-adjust your texture maps, turn off Assign Shader to Each Projection. The option is off by default.

Related topics

- “UVs and mapping” on page 179
- “Project UVs onto polygons from a plane” on page 182
- “Project UVs onto polygons from a cylinder or sphere” on page 185
- “Map UVs onto polygons automatically” on page 186
Map to a smoothed model and then transfer back to the original

You can map your UVs to a smoothed version of your model, where it may be easier to get good UVs (for example, you can smooth out wrinkles which cause overlapping UVs). Then you can use the Transfer operation to copy the mapped UVs back onto the complex original model.

1. Duplicate your mesh.
2. On the duplicate, select the vertices you want to smooth.
3. Select Polygons > Average Vertices > [Box].
4. Enter the number of iterations then click Apply.
   More iterations give more smoothing. You can click Apply repeatedly to smooth repeatedly.
5. Project UVs onto the smoothed duplicate model using any of the actions in the Edit Polygons > Texture sub-menu.
6. Use Polygons > Transfer to copy the UVs from the smoothed duplicated back to the original mesh.

Related topics
- “Polygons > Average Vertices” on page 71
- “Polygons > Transfer” on page 143

Reference Menus

Modeling menu set

Edit Polygons

Edit Polygons > Texture > Planar Mapping
Maps UVs onto the selected mesh by projecting them along one direction.

Related topics
- “Project UVs onto polygons from a plane” on page 182
Edit Polygons > Texture > Planar Mapping > □

Smart Fit

The available options depend on the Smart Fit setting:

Automatically Fit the Projection Manipulator turned on

By default, Automatically Fit the Projection Manipulator is turned on, which automatically positions the projection manipulator.

If you prefer to specify exact values for the projection manipulator, you can turn off this option and change the values in the Projection Center, Rotation, Width, and Height settings instead.

Fit to Best Plane

If you want to map UVs for a portion of the object’s faces, you can turn on Fit to Best Plane and the projection manipulator snaps to an angle and rotation aimed directly at the selected faces.

Fit to Bounding Box

This option works best when you are mapping UVs to all or most of an object’s faces. It snaps the projection manipulator to fit within the object’s bounding box. With this option on, you must choose one of the Mapping direction options to establish the orientation of the projection manipulator.

Mapping direction

Choose an axis so that the projection manipulator is aimed at the majority of the object’s faces. For example, a turtle model sitting on the grid would have most of its faces pointing along the Y axis, while a horse model standing on the grid would have most of its faces pointing along the X or Z axis.

If most of the model’s faces point somewhere that is not directly along the X, Y, or Z axis, you can choose Camera. This option positions the projection manipulator based on the current active view.

Insert Before Deformers

The Insert Before Deformers option is relevant when the polygonal object has a deformation applied to it. If the option is turned off and the deformation is animated, the texture placement is affected by the change in vertex positions. This leads to “swimming” textures.

Turning this option on applies the texture placement to the polygonal object before the deformation is applied to it. Basically, the texture placement dependency graph node is inserted before the deformer dependency graph nodes and the texture “sticks” to the geometry even after the deformation.
10 | Projecting and mapping UVs

Reference > Edit Polygons > Texture > Planar Mapping

Image Center

This value represents the center of the projected UVs. Changing this value translates the center accordingly.

Image Rotation

This value changes the angle at which UVs are rotated in the 2D window. Drag the slider or enter a value to rotate the image.

Image Scale

This value represents the width (U) or the height (V) of the 2D map relative to the 2D center point.

Keep Image Ratio

Turn this option on to retain the width to height ratio of the image so that the image does not distort. Turn it off so that the mapped UVs fill the 0 to 1 coordinates in the UV Texture Editor.

Create New UV Set

Turn this option on to create a new UV set and place the UVs created by the projection in that set. Change the name in the UV Set Name box. For more information, see “Multitexturing” on page 239.

Automatically Fit the Projection Manipulator turned off

If Automatically Fit the Projection Manipulator is turned off, you can enter values to change the Projection Center, Rotation and Scale. These values correspond to the manipulator handles that display when you map your texture onto the polygon.

After you project a texture, you can change these values from the Channel Box or the Attribute Editor, or use the corresponding manipulator handles to interactively adjust the map.

Projection Center

The projection center defines the point of origin in the X, Y, or Z axis from where you can project a texture map. By default, this is the center of the selected faces in the X, Y, or Z axis.

Projection Rotation

Type a value to rotate the projection in the 3D view around the X, Y, or Z axis which subsequently rotates the texture.

Projection Scale

Scaling a projection enlarges or reduces the height (V) and width (U) of the projection relative to the 3D projection axis.
Edit Polygons > Texture > Create UVs Based on Camera

To create a new UV set with the UVs you create based on camera, select Edit Polygons > Texture > Create UVs Based on Camera > □, turn on Create New UV Set and type a new set name in the UV Set Name box, then click Apply.

Related topics
- “Project UVs onto polygons from a plane” on page 182
- “UV sets” on page 239

Edit Polygons > Texture > Create UVs Based on Camera > □

Create New UV Set

Turn this option on to create a new UV set on the object to hold the projected UVs.

UV Set Name

When Create New UV Set is on, enter a name for the new UV set in this box.

Edit Polygons > Texture > Cylindrical Mapping, Spherical Mapping

Maps UVs onto the selected objects by projecting them inward from an imaginary cylinder or sphere.

Related topics
- “Project UVs onto polygons from a cylinder or sphere” on page 185

Edit Polygons > Texture > Cylindrical/Spherical Mapping > □

Smart Fit on

Smart Fit is turned on by default. This automatically fits the texture and the manipulator onto the polygonal model.
10 | Projecting and mapping UVs
Reference > Edit Polygons > Texture > Cylindrical Mapping, Spherical Mapping

Insert Before Deformers

This option is turned on by default. The Insert Before Deformers option is relevant when the polygonal object has deformation applied to it. If the option is turned off and the deformation is animated, the texture placement is affected by the change in vertex positions. This leads to “swimming” textures.

Turning this option on applies the texture placement to the polygonal object before the deformation is applied to it. Basically, the texture placement dependency graph node is inserted before the deformer dependency graph nodes and the texture “sticks” to the geometry even after the deformation.

Image Center

This value represents the center of the projected UVs. Changing this value translates the center accordingly.

Image Rotation

This value changes the angle at which UVs are rotated in the 2D window. Drag the slider or enter a value to rotate the image.

Image Scale

This value represents the width (U) or the height (V) of the 2D map relative to the 2D center point.

Create New UV Set

Turn this option on to create a new UV set and place the UVs created by the projection in that set. Change the name in the UV Set Name box. For more information, see “Multitexturing” on page 239.

Smart Fit off

If Smart Fit is turned off, you can enter values to change the Projection Center, Rotation, Scale, or Scale Height. These values correspond to the manipulator handles that display when you map your texture onto the polygon.

After you project a texture, you can change these values from the Channel Box or the Attribute Editor, or use the corresponding manipulator handles to interactively adjust the map.

Projection Center

The projection center defines the point of origin in the X, Y, or Z axis which is the center of the application of the projection. By default, this is (0, 0, 0) if Smart Fit is not turned on.
10 | Projecting and mapping UVs
Reference > Edit Polygons > Texture > Automatic Mapping

Projection Rotation
Type a value to rotate the projection in the 3D view around the X, Y, or Z axis which subsequently rotates the texture.

Projection Horizontal Sweep
Use the slider or type a value to scale the projection around the polygonal object. This value corresponds to the Projection Scale Aperture handles on the manipulator. For instance, pull the Projection Scale Aperture handles all the way around the object until they meet. This is equivalent to entering 360 in the box.

Projection Height
Scaling a projection enlarges or reduces the height (V) of a map relative to the 3D projection axis.

Edit Polygons > Texture > Automatic Mapping
Projects UVs onto the selected object from multiple angles at once.

Related topics
❖  “Map UVs onto polygons automatically” on page 186

Edit Polygons > Texture > Automatic Mapping > □

Planes
Select the number of planes you are projecting from. The more planes used, the less distortion occurs and the more pieces created. You can choose a projection based on shapes with 4, 5, 6, 8 or 12 planes.

Optimize
Select how you want the projection optimized.

Less Distortion
Projects all planes equally. While this method provides the best projection for any face, you may end up with more pieces. It is particularly useful if you have a symmetrical model and you want the pieces of the projection to be symmetrical.
10 | Projecting and mapping UVs
Reference > Edit Polygons > Texture > Automatic Mapping

Fewer pieces
Projects each plane until the projection encounters a projection angle that is not ideal. This can result in larger pieces, and fewer of them. This is the default.

![Less distortion](image1) ![Fewer pieces](image2)

**Note**  In some cases, setting Optimize to Less Distortion can produce a slightly different UV layout when you open the same file on another operating system. If this happens you can either:
- Set Optimize to Fewer pieces.
- Keep the Less Distortion setting but delete history on the object (Edit > Delete by Type > History). This action assigns UVs directly to the surface.

**Layout**
Select where you want the UV pieces to lie in the texture space.

- **Along U** Positions the pieces along the U axis.
- **Into Square** Positions the pieces within the 0 to 1 texture space. This is the default.

![Along U](image3) ![Into Square](image4)

**Scale**
Select how you want the UV pieces scaled within the texture space.

- **None** Performs no scaling.
- **Uniform** Scales the pieces to fit the 0 to 1 texture space without changing the aspect ratio. This is the default.

Polygonal Modeling
195
10 | Projecting and mapping UVs
Reference > Edit Polygons > Texture > Automatic Mapping

Stretch to Square
Stretches the pieces to fit the 0 to 1 texture space. The pieces may become distorted.

Insert Before Deformers
The Insert Before Deformers option is relevant when the polygonal object has a deformation applied to it. If the option is turned off and the deformation is animated, the texture placement is affected by the change in vertex positions. This leads to “swimming” textures.

Turning this option on applies the texture placement to the polygonal object before the deformation is applied to it. Basically, the texture placement dependency graph node is inserted before the deformer dependency graph nodes and the texture “sticks” to the geometry even after the deformation.

Spacing Presets
Maya puts a bounding box around each piece and lays out the pieces so that the bounding boxes are very close together. If the pieces end up positioned exactly next to each other, two UVs on different pieces can share the same pixel and when painting with the 3D Paint Tool, overscanning can also cause the paint to spill onto the adjacent piece.

To avoid this situation, ensure that there is at least a pixel between the bounding boxes by selecting a spacing preset from this menu. Select a preset that corresponds to your texture map size. If you don’t know the size, select a smaller map, which will result in a larger spacing between adjacent pieces in UV space. (The smaller your map in pixels, the bigger the UV spacing must be between bounding boxes.)

Select Custom to set the size of the space as a percentage of the map size (in the Percentage Space box).
Percentage Space

If you select Custom beside Spacing Presets, enter the size of the space between bounding boxes as a percentage of the map size.

Create New UV Set

Turn this option on to create a new UV set and place the newly created UVs in that set. Type the name of the set in the UV Set Name box. For more information, see “Multitexturing” on page 239.

Edit Polygons > Texture > Best Plane Texturing Tool

Assigns UVs to the faces you select based on a plane computed from vertices you specify.

Related topics

- “Project UVs onto polygons from a plane” on page 182
10 | Projecting and mapping UVs
Reference > Edit Polygons > Texture > Best Plane Texturing Tool
11 Texture editor

How do I? Apply colors, shading, and textures

Edit UVs visually in the texture editor

Select UV components

Press the right mouse button on UVs in the texture editor to enter different component selection modes, just like in modeling windows.

For example, if you have faces selected, you can convert the selection to UVs to use the Move tool, which only works with UVs.

Use the items in the texture editor’s Select menu to select various components:

- Select Contained Faces
  Selects the faces bordered the selected UVs or edges.

- Select Connected Faces
  Selects the faces connected to the selected UVs or edges.

- Select Shell
  Select all UVs in the shell containing the current selection. This is useful to select the whole piece so you can move, scale, or rotate it.

- Select Shell Border
  Expands your selection to all UVs along the border of the UV piece.

- Convert Selection to Faces, Edges, Vertices, UVs
Converting the selection from one type of component to another connected type. For example, if you have faces selected and convert selection to vertices, all vertices connected to the faces are now selected.

### Set up the texture editor display

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the view of the UVs.</td>
<td>Use the camera move keys:</td>
</tr>
<tr>
<td></td>
<td>• alt + the middle mouse button to track</td>
</tr>
<tr>
<td></td>
<td>• alt + the right mouse button to dolly in and out</td>
</tr>
<tr>
<td>Zoom in/out to show all UVs.</td>
<td>In the texture editor, choose View &gt; Frame All.</td>
</tr>
<tr>
<td>Zoom in/out to show the selected UVs.</td>
<td>In the texture editor, choose View &gt; Frame Selection.</td>
</tr>
<tr>
<td>Make texture borders look thicker.</td>
<td>In the texture editor, click the Toggle Texture Borders button.</td>
</tr>
</tbody>
</table>

### Related topics

- “Show the texture image in the UV texture editor” on page 201
- “Set up the texture editor grid and snapping” on page 204
### How do I? > Show the texture image in the UV texture editor

**Show the texture image in the UV texture editor**

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the texture image</td>
<td>In the texture editor, click the Toggle Image button on the toolbar or select Image &gt; Display Image.</td>
</tr>
<tr>
<td>behind the UVs.</td>
<td></td>
</tr>
<tr>
<td>Set the image ratio.</td>
<td>In the texture editor, click the Toggle Image Ratio button on the toolbar or select Image &gt; Use Image Ratio.</td>
</tr>
<tr>
<td>Switch between blended</td>
<td>In the texture editor, click the Toggle Filtered Pixels button on the toolbar or select Image &gt; Display Unfiltered.</td>
</tr>
<tr>
<td>and sharp-edged pixels.</td>
<td></td>
</tr>
<tr>
<td>Switch between showing a</td>
<td>Select the mesh object to show a mesh texture, or faces to show per-face textures.</td>
</tr>
<tr>
<td>mesh texture and a per-face</td>
<td></td>
</tr>
<tr>
<td>texture.</td>
<td></td>
</tr>
</tbody>
</table>
11 | Texture editor
How do I? > Show only a subset of all UVs

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a texture to display (if more than one texture is applied to the mesh).</td>
<td>In the texture editor, select the texture you want to work on from the Image &gt; Selected Images sub-menu. Then, when you are in component selection mode, the Image &gt; Selected Images sub-menu lists shading groups assigned to the selected components. In object selection mode, the sub-menu lists all shading groups assigned to the entire mesh.</td>
</tr>
<tr>
<td>Crop the image within UV coordinates.</td>
<td>In the texture editor, choose Image &gt; Image Range.</td>
</tr>
</tbody>
</table>

If the texture quality is poor or if parts of the texture do not display correctly, you can modify the display quality with the Hardware Texturing settings in the Attribute Editor for the material node.

If you are using a file texture, the best display mode for the Texture quality setting is Default. (The other settings, such as High, are best for procedural textures.)

If you experience resolution or cropping problems in the Texture Image Display, use Image > UV Texture Editor Baking to bake the texture. You must rebake the texture (using Force editor texture rebake) after making changes to the texture (File node and place2dTexture node attributes) in order to see the effect of those changes.

Related topics
- “Set up the texture editor display” on page 200
- “Set up the texture editor grid and snapping” on page 204

Show only a subset of all UVs

Maya lets you switch the texture editor between showing all UVs in the current set and only showing a selected subset in isolation. This can make it easier to work on part of the model without disturbing or accidentally selecting other UVs.
Isolate a specific subset of UVs

1. If you already have a subset isolated, click the Remove all button on the toolbar, or choose View > Isolate Select > Remove All.
2. Select the UVs you want to isolate.
3. Click the Toggle isolate select button on the toolbar, or choose View > Isolate Select > View Set.
   
   To switch back to showing all UVs, click Toggle isolation again, or turn off the View > Isolate Select > View Set menu item.

Add to the isolated subset

1. Click the Toggle isolate select button on the toolbar, or choose View > Isolate Select > View Set to switch back to showing all UVs.
2. Select the UVs you want to add to the isolated subset.
3. Click the Add selected button on the toolbar, or choose View > Isolate Select > Add Selected.

Remove UVs from the isolated subset

1. Select the UVs you want to remove from the isolated subset.
2. Click the Remove from isolation button on the toolbar, or choose View > Isolate Select > Remove Selected.

Only show UVs that have the current image assigned

1. Show the texture (in the texture editor, choose Image > Display Image). If more than one texture is associated with the mesh, select the texture you want to work on with Image > Selected Images.
   
   When you are in component selection mode, the Image > Selected Images sub-menu lists shading groups assigned to the selected components. In object selection mode, the sub-menu lists all shading groups assigned to the entire mesh.
2. To only show faces with the current image assigned, in the texture editor turn on View > View Faces of Selected Images.
3. To show all faces again, turn off View > View Faces of Selected Images.

Only show faces inside the selected UVs or edges

1. Select UVs or edges to define a border.
2. In the texture editor, turn on View > Contained Faces.
3. To show all faces again, turn off View > Contained Faces.
**11 | Texture editor**  
How do I? > Transform UVs in the texture editor

**Only show faces that share the selected UVs or edges**

1. Select UVs or edges.
2. In the texture editor, turn on View > Connected Faces.
3. To show all faces again, turn off View > Connected Faces.

**Transform UVs in the texture editor**

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move, rotate, or scale UV positions.</td>
<td>Select the UVs and use the standard Move, Rotate, and Scale tools from the toolbox. Note: Scaling UVs of separate polygonal objects together in the Texture View produces unexpected results. Work on the UVs of one object at a time.</td>
</tr>
<tr>
<td>Rotate UVs by an exact number.</td>
<td>Select the UVs you want to rotate and choose Edit Polygons &gt; Texture &gt; Rotate UVs &gt; [ ] .</td>
</tr>
<tr>
<td>Flip UVs to flip the texture placement on the mesh.</td>
<td>Select the faces you want to flip texture placement on, then select Edit Polygons &gt; Texture &gt; Flip UVs &gt; [ ] .</td>
</tr>
<tr>
<td>Scale UVs to be within 0 to +1.</td>
<td>Select the faces and choose Edit Polygons &gt; Texture &gt; Normalize UVs &gt; [ ] .</td>
</tr>
<tr>
<td>Move UVs to (0,0), (1,1), (1,0), or (0,1) in texture space.</td>
<td>Select the faces and choose Edit Polygons &gt; Texture &gt; Unitize UVs &gt; [ ] .</td>
</tr>
</tbody>
</table>

**Set up the texture editor grid and snapping**

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or hide the grid.</td>
<td>In the texture editor, click the Toggle Grid button on the toolbar or choose View &gt; Grid.</td>
</tr>
</tbody>
</table>
texture editor

How do I? > Set up the texture editor grid and snapping

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the grid.</td>
<td>In the texture editor, right click the Toggle Grid button on the toolbar or choose View &gt; Grid &gt; □.</td>
</tr>
<tr>
<td>Snap UVs to the grid.</td>
<td>Use grid snapping (hold x).</td>
</tr>
</tbody>
</table>
| Change how UVs snap.   | Double-click the Move tool to open its options panel. Use the Retain Component Spacing option to control how UVs snap:  
                          - When off, all selected UVs will snap to the same point.  
                          - When on, selected UVs will keep their positions relative to each other as they move. |
| Snap UVs to pixels.    | In the texture editor, click the Toggle Snap to Pixel button in the toolbar, or choose Image > Pixel Snap.                                    |

To... Do this

- “Set up the texture editor display” on page 200
- “Show the texture image in the UV texture editor” on page 201

Related topics

Polygonal Modeling

205
**Separate and attach UV pieces**

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Separate a UV piece along the selected edges.</td>
<td>Select Edit Polygons &gt; Texture &gt; Cut UVs.</td>
</tr>
<tr>
<td>Attach UV pieces along the selected edges.</td>
<td>Select Edit Polygons &gt; Texture &gt; Sew UVs</td>
</tr>
<tr>
<td>Attach UV pieces along the selected edges and move the pieces together.</td>
<td>Select Edit Polygons &gt; Texture &gt; Move and Sew UVs. Turn off Limit Piece Size and click Apply.</td>
</tr>
<tr>
<td>Merge the selected UVs.</td>
<td>Select Edit Polygons &gt; Texture &gt; Merge UVs. Merge UVs only merges the UVs that share the same vertex. You can specify an option for the maximum distance Maya will move UVs to merge them.</td>
</tr>
</tbody>
</table>
How do I? > Automatically sort out overlapping texture pieces

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically attach and move small pieces.</td>
<td>Select all the pieces and choose Edit Polygons &gt; Texture &gt; Move and Sew UVs &gt; □. Turn on Limit Piece Size and set the maximum size (in number of faces) for UV pieces. Pieces larger than this number will not move. Click Apply.</td>
</tr>
</tbody>
</table>

After performing a Move and Sew operation, you can select the node (polyMapSewMove) and edit it in the attribute editor or channel box to adjust the Number of Faces.

Notes
• A single edge cannot be cut unless it touches a border.
• Use the Select > Select Shell in the UV Texture Editor to select a UV piece after cutting.

Related topics
❖ "Automatically sort out overlapping texture pieces” on page 207

Automatically sort out overlapping texture pieces

The Layout UVs action automatically moves UVs so they don’t overlap in texture space.

It is not absolutely necessary to keep UV pieces separate. For example, you may want to overlap UVs so different faces use the same region of a texture. In general however you should keep pieces separate for convenience and clarity.
You can also use Layout UVs to:

- Scale or stretch the UVs to fit within the 0 to 1 coordinates of the UV Texture Editor (as required for the 3D Paint Tool).
- Flip UV pieces that correspond to opposite sides of a model.

**To automatically lay out UV pieces**

1. Select all faces, or just the faces with overlapping UVs.
2. Select Edit Polygons > Texture > Layout UVs.
   In the texture editor you can choose Polygons > Layout UVs.

**Related topics**

- "Separate and attach UV pieces" on page 206

**Untangle border UVs**

Both of these operations are used in preparation for the Relax UVs operation, which works better if the texture border is untangled.

**Automatically move UV borders to the edges of 0 to +1 texture space**

You can move the UVs on the border of a UV piece out to the edges of the 0 to +1 square, or a circle inscribed in 0 to +1. You can optionally scale the edges proportionally as you move the border UVs.

This is useful for untangling borders before you use Relax UVs to untangle interior UVs.
How do I > Untangle border UVs

1 Select a UV on the border.
2 Select Edit Polygons > Texture > Map UV Border > □.
   In the UV Texture Editor, you can select Polygons > Map UV Border > □.
3 Set the options, then click Map.
   Remember that you are only moving the border. The interior UVs will still appear tangled. You can untangle them with Relax UVs.

**Straighten out borders**

Use Straighten UV Border to untangle the border of a UV texture shell, such as an edge that loops around itself.

Straighten UV Border provides more control than the Map UV Border operation.

1 Right click in the UV Texture Editor and choose UV.
How do I? > Spread out and untangle interior UVs

2 Select UVs around the tangled UV border.
   It doesn’t matter if you select interior UVs along with border UVs. Straighten UV Border only acts on the borders.
   In some cases, it is difficult to select the UVs you want to straighten without selecting other UVs you want to leave unaffected. In these cases, you can leave a gap in your selection and use the Fill Gaps in Selection option to straighten the UVs you could not select.

3 Choose Edit Polygons > Texture > Straighten UV Border.

4 Select the polyStraightenUVBorder node and edit the attributes in the attribute editor or channel box.

Related topics
✓ “Spread out and untangle interior UVs” on page 210

Spread out and untangle interior UVs

Use Relax UVs to automatically untangle and even out UVs. You can choose to pin the UV borders in the same position while relaxing other UVs, or pin the selected or unselected UVs while relaxing all others.

This is extremely useful for untangling UVs in combination with Edit Polygons > Texture > Map UV Border.

1 Select a UV within the UV piece.

2 Select Edit Polygons > Texture > Relax UVs > .
   In the texture editor you can choose Polygons > Relax UVs.

3 Select the options, then click Relax or Apply.
   You can apply Relax UVs more than once to move the UVs more.

Related topics
✓ “Untangle border UVs” on page 208

Save a snapshot of the UV layout to paint on

After you get a good UV layout in the Texture Editor, you can export an image of the UV pieces. Then you can open the snapshot in a Paint Effects canvas or a painting program such as Adobe Photoshop®, and paint a texture to match the UVs.

Before you save a snapshot, have the final UV arrangement complete and scaled inside the 0 to +1 coordinate range in texture space. The snapshot image is limited to this range.
To save a snapshot
1. Select the mesh or components.
2. In the texture editor, choose Polygons > UV Snapshot.
3. Set the filename to export to.
4. Set the size of the image.
5. The background of the image will be black. You can choose a color for the UV edges.
6. Choose an image format.
7. Click OK.

Flip texture placement by flipping or rotating UVs
1. Select the faces you want to flip the texture on.
2. Select Edit Polygons > Texture > Flip UVs > ![symbol].
   In the UV Texture Editor, you can select Polygons > Flip UVs > ![symbol].
   or
   Select Edit Polygons > Texture > Rotate UVs.
3. Choose the direction to flip, and whether to flip within the bounding box of the selection (local) or across the texture space axes (global).
4. Click Apply.

Copy UVs, colors, and shaders between polygons
1. Select the mesh or faces you want to copy from and choose Edit Polygons > Clipboard Actions > Copy > ![symbol].
2. Set the attributes you want to copy and click Apply and Close.
3. Select the mesh or faces you want to copy to and choose Edit Polygons > Clipboard Actions > Paste.

Note
You can also clear the attributes that are on the clipboard by choosing Edit Polygons > Clipboard Actions > Clear Clipboard.

Delete UVs
Use Delete UVs to remove UVs from a mesh. You can then re-create them using the UV mapping or projection operations.
11 | **Texture editor**
Reference > Move tool (in UV texture editor)

1. Select the faces for which you want to delete the UVs.

2. Select Edit Polygons > Texture > Delete UVs.
   In the UV Texture Editor you can select Polygons > Delete Mapping.

Because the selected faces have no UVs, textures cannot be applied to them until UVs are re-created.

Related topics
- “Edit Polygons > Texture > Delete UVs” on page 228

**Reference Tools**

**Toolbox**

**Move tool (in UV texture editor)**

The Move tool has different options when you work in the UV texture editor panel.

**Placement**

<table>
<thead>
<tr>
<th>Snap Corner</th>
<th>Snapping is to pixel corners.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snap Center</td>
<td>Snapping is to pixel centers.</td>
</tr>
</tbody>
</table>
Retain Component Spacing

When this option is off, if you snap to a point (with grid snapping, point snapping, or pixel snapping), all selected UVs snap to the same point, bunching them up.

When this option is on, if you snap to a point, the selected UVs keep their positions relative to each other.

Menus

Modeling menu set

Edit Polygons

Edit Polygons > Texture > Normalize UVs

Scales the UVs of the selected faces to within the 0 to 1 texture space.

Related topics

- "Transform UVs in the texture editor" on page 204
- "Edit Polygons > Texture > Unitize UVs" on page 214

Edit Polygons > Texture > Normalize UVs > □

Use the options in the option window to Normalize the texture coordinates (UVs).

Collectively

Select Collectively to normalize the UVs for all selected faces collectively. That means the texture coordinates for all selected faces are “collectively” fit to the 0 to 1 texture space. This is the default setting.
Each face separately

Select Each face separately to normalize the UVs for each selected face separately. That means the texture coordinates for each selected face are fit to a boundary of 0 to 1.

Preserve Aspect Ratio

Turn this option on to scale the UVs uniformly along U and V.

Turn this option off (the default setting) to stretch the texture to fit by scaling U and V non-uniformly.

When you normalize texture coordinates, you scale the UVs of the selected faces. If Preserve Aspect Ratio is on, the scaling is guaranteed to be uniform on both the U and V axes. If turned off, the scaling is different for the U and V axes.

Edit Polygons > Texture > Unitize UVs

Places the UVs of the selected faces on the boundary of the 0 to 1 texture space.

Related topics

- “Transform UVs in the texture editor” on page 204
- “Edit Polygons > Texture > Normalize UVs” on page 213
Edit Polygons > Texture > Unitize UVs

Create New UV Set

Turn this option on to create a new UV set on the object to hold the unitized UVs.

UV Set Name

When Create New UV Set is on, enter a name for the new UV set in this box.

Edit Polygons > Texture > Flip UVs

Flips the positions of the selected UVs.

Related topics

❖ “Flip texture placement by flipping or rotating UVs” on page 211

Edit Polygons > Texture > Flip UVs

Direction

Select which direction to flip the UVs of the selected faces: horizontally or vertically. Horizontal is the default.

Coordinate

Select Global to flip the UVs in global UV space in the 0 to 1 texture space axis. Select Local to flip the UVs within the bounding box of the selected faces. Local is the default.
**Texture editor**
Reference > Edit Polygons > Texture > Rotate UVs

Selected faces before flip.

UVs flipped Horizontal, Local.

UVs flipped Vertical, Local.

Selected faces before flip.

UVs flipped Horizontal, Global.

UVs flipped Vertical, Global.

Image Range in UV Texture Editor set to -1

**Edit Polygons > Texture > Rotate UVs**

Rotates the positions of the selected UVs.
Related topics

- “Flip texture placement by flipping or rotating UVs” on page 211

Edit Polygons > Texture > Rotate UVs

Rotation Angle

The angle by which to rotate the UVs. The UVs rotate around their average center.

Edit Polygons > Texture > Map UV Border

Move UV borders to the edges of 0 to +1 texture space.

You can move the UVs on the border of a UV piece out to the edges of the 0 to +1 square, or a circle inscribed in 0 to +1. You can optionally scale the edges proportionally as you move the border UVs.

This is useful for untangling borders before you use Relax UVs to untangle interior UVs.

Related topics

- “Untangle border UVs” on page 208
- “Edit Polygons > Texture > Straighten UV Border” on page 219

Edit Polygons > Texture > Map UV Border

Border Target Shape

Select the shape you want to map the UV border to (Circle or Square). The Square option makes best use of texture space, but can result in faces having zero or very little texture space around the UV border. The Circle option is less likely to produce this type of problem, but uses texture space less efficiently.
11 | Texture editor
Reference > Edit Polygons > Texture > Map UV Border

Preserve Shape Detail

Automatic

Turn on Automatic to map the UV border automatically using a Shape Detail value (see next) that approximates the best use the texture space while maintaining the world-space relationships between edges.

Shape Detail

Turn off Automatic and use the slider or enter a value between 0 and 1 to control the blend of the border with the specified shape. A value of 0 produces a border closest to the specified shape. A value of 1 produces a border that closely represents the world-space relationships between edges, but can result in concave areas along the border—these will produce overlapping interior UVs once relaxed.
Edit Polygons > Texture > Straighten UV Border

Untangles the border of a UV texture shell, such as an edge that loops around itself. Straighten UV Border provides more control than the Map UV Border operation.

Related topics
- “Untangle border UVs” on page 208
- “Edit Polygons > Texture > Map UV Border” on page 217
Edit Polygons > Texture > Straighten UV Border

Curvature

Pushes the selected border area outward or inward by the specified amount. A value of zero forces the edge to be straight. Each Curvature unit is .01 on the UV coordinate scale.

Maya curves the border outward or inward depending on whether the value is positive or negative. However, you cannot tell in advance whether to use positive or negative. With the polyStraightenUVBorder node opened in the Channel Box or Attribute Editor, try positive and negative values and check the results in the UV Texture Editor.

Preserve Length Ratio

Controls the size of UV texture edges when straightened. Set to one, Maya preserves the original edge lengths. Set to zero, Maya averages the lengths. Values between zero and one change the length proportionally.

Blend Original Shape

Affects the shape of the straightened border by blending it with the original border shape. You can use this setting to constrain the effect of the above two settings. Set to one, Maya keeps the original shape and overrides the other settings. Set to zero, Maya does not consider the original shape when straightening. Values between zero and one proportionally blend the original shape with the curvature created by the other settings.

Fill Gaps in Selection,
UV Gap Tolerance

These settings help you straighten UVs that are missing from your selection because they are difficult to select. The following illustration shows an example.
The UV Gap Tolerance setting is the threshold of when Maya selects and straightens the unselected UVs. For example, if there are three unselected UVs in the middle of two selected UVs, UV Gap Tolerance must be 3 or higher in order for Maya to select and straighten the middle UVs.

**Edit Polygons > Texture > Relax UVs**

Automatically untangles and evens out UVs. You can choose to pin the UV borders in the same position while relaxing other UVs, or pin the selected or unselected UVs while relaxing all others.

**Related topics**

- “Spread out and untangle interior UVs” on page 210

**Edit Polygons > Texture > Relax UVs > □**

**Edge Weights**

Select how the UV relax affects edges.

- **Uniform**: Attempts to make all of the edges the same length. This is the default.
- **World Space**: Attempts to retain the original world-space angles (subject to the restrictions of the pinned border).

**Pin UVs**

Use the following options to relax only selected parts of the UV piece.
11 | Texture editor
Reference > Edit Polygons > Texture > Relax UVs

Pin UV Border

Turn this option on to maintain the position of the border UVs. This is the default.

Pin Selected UVs

Turn this option on to maintain the position of selected UVs. For example, if you want more texture space for an area on a face with very dense UVs, you could select these UVs, scale them up, pin them, then relax the rest of the UVs to eliminate any overlapping you may have introduced during the scale.

Pin Unselected UVs

Turn this option on to maintain the position of the unselected UVs. This option is useful for relaxing only the selected UVs.

Stopping Conditions

Max Iterations

Enter the number of relaxation iterations that will be performed on the UVs—ideal UV relaxation is subjective and iterative.
Edit Polygons > Texture > Grid UVs

Moves every selected UV to its nearest grid intersection in texture space.

Related topics

- “Set up the texture editor grid and snapping” on page 204

Edit Polygons > Texture > Grid UVs > □

Map Size Presets

Sets the Grid U and Grid V options to common square texture sizes.

Change the Grid U or Grid V sliders or text boxes to use a different or non-square size.

Grid U

The number of grid lines horizontally (in the U dimension of texture space).

Grid V

The number of grid lines vertically (in the V dimension of texture space).

Move UVs to

- Pixel Border: Snaps UVs to the nearest grid intersection.
- Pixel Center: Snaps UVs to the nearest midpoint between grid lines.

Edit Polygons > Texture > Align UVs

Aligns the positions of the selected UVs.

Related topics

- “UV Texture Editor” on page 229
Edit Polygons > Texture > Align UVs

Choose whether to align the selected UVs to bottom (minimum V), top (maximum V), left (minimum U) or right (maximum U).

Edit Polygons > Texture > Layout UVs

Tries to move the UVs into a cleaner layout.

Related topics

- “Automatically sort out overlapping texture pieces” on page 207

Edit Polygons > Texture > Layout UVs

The default settings give the best results in most situations.

Separate

- Off: Does not separate overlapping UV pieces. Only the Scale option has an effect.
- Folds: Separates only pieces where the surface normals of overlapping pieces point opposite directions. This method is faster, especially for larger models, however, you may be left with overlapping UVs.
- All Intersecting: Separates all pieces where the UVs overlap. This is the default.

Flip Reversed

Turn this option on to flip UV pieces that have normals pointing in opposite directions.
### Rotate for Best Fit

When turned on, allows some UV pieces to be rotated by 90 degrees to maximize the space between the 0 to 1 coordinates. If turned off, Layout UVs does not rotate UV pieces.

### Layout

Select where you want the UV pieces to lie in the texture space.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Does not lay out pieces after they have been cut. Some pieces may lie on top of others.</td>
</tr>
<tr>
<td>Along U</td>
<td>Positions the pieces along the U axis.</td>
</tr>
<tr>
<td>Into Square</td>
<td>Positions the pieces within the 0 to 1 texture space.</td>
</tr>
</tbody>
</table>

### Scale

Select how you want the UV pieces scaled within the texture space.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Performs no scaling.</td>
</tr>
<tr>
<td>Uniform</td>
<td>Scales the pieces to fit the 0 to 1 texture space without changing the aspect ratio. This is the default.</td>
</tr>
<tr>
<td>Stretch to Square</td>
<td>Stretches the pieces to fit the 0 to 1 texture space.  The pieces may become distorted.</td>
</tr>
</tbody>
</table>
Map Size Presets

Maya puts a bounding box around each piece and lays out the pieces so that the bounding boxes are very close together. If the pieces end up positioned exactly next to each other, two UVs on different pieces can share the same pixel and when texture painting, overscanning can also cause the paint to spill onto the adjacent piece.

To avoid this situation, ensure that there is at least a pixel between the bounding boxes by selecting a spacing preset from this menu. Select a preset that corresponds to your texture map size. If you don’t know the size, select a smaller map, which will result in a larger spacing between adjacent pieces in UV space. (The smaller your map in pixels, the bigger the UV spacing must be between bounding boxes.)

Select Custom to set the size of the space as a percentage of the map size (in the Percentage Space box).

Space

If you select Custom beside Map Size Presets, enter the size of the space between bounding boxes as a percentage of the map size.

Edit Polygons > Texture > Cut UVs

Separates UVs along the selected edges, creating borders.

Related topics

- “Separate and attach UV pieces” on page 206
- “Edit Polygons > Texture > Merge UVs” on page 228

Edit Polygons > Texture > Sew UVs

Attaches UVs along the selected borders, but does not move them together in the texture editor view.
Related topics

- “Separate and attach UV pieces” on page 206
- “Edit Polygons > Texture > Move and Sew UVs” on page 227

Edit Polygons > Texture > Move and Sew UVs

Attaches UVs along the selected borders, and moves them together in the texture editor view.

Use Move and Sew UVs to sew together separate UV pieces by merging selected edges and moving one UV piece (the smaller one) to the other (the larger one). You can quickly join separate UV pieces produced by Automatic Mapping or Layout UVs back to their neighboring UVs.

There are two methods of moving and sewing UVs: manual and automatic. With the manual method, you must select the edges you want to join. With the automatic method, smaller pieces are moved and sewn automatically. You define how small the pieces should be.

Related topics

- “Separate and attach UV pieces” on page 206
- “Edit Polygons > Texture > Merge UVs” on page 228

Edit Polygons > Texture > Move and Sew UVs > □

Limit Piece Size

When this option is off, Move and Sew UVs only moves and sews the selected edges.

When this option is on, Move and Sew UVs automatically moves and sews together any selected pieces below the size set in Number of Faces.

Number of Faces

When Limit Piece Size is on, controls the maximum number of faces in each piece. Larger numbers result in fewer pieces.
After performing a Move and Sew operation, you can select the history node (polyMapSewMove) in the Channel Box and adjust the Number of Faces until you achieve the results you want.

**Edit Polygons > Texture > Merge UVs**

Use Merge UVs to merge together separate UV pieces. Merge UVs has a similar effect to Sew UVs. However, Merge UVs is better suited to merging shells when the polygon has nonmanifold geometry.

For example, suppose you have three UV pieces that all share an edge because the geometry is nonmanifold. Using Merge UVs, you can combine two of the UV pieces without affecting the other. If you used Sew UVs in this example, all pieces would be combined because they all share an edge.

**Related topics**

- “Separate and attach UV pieces” on page 206
- “Edit Polygons > Texture > Cut UVs” on page 226

**Edit Polygons > Texture > Merge UVs > □**

Turn on Use Distance Threshold and set Distance to the maximum distance between UVs, measured in UV units. Any UVs in your selection that exceed this distance will not be merged.

**Use Distance Tolerance**

Only merge UVs within the distance in the Distance option.

**Distance**

The maximum distance within which selected UVs will be merged.

**Edit Polygons > Texture > Delete UVs**

Removes the selected UVs from the mesh. You will need to re-map or re-project the UVs in order to map textures onto the affected areas.

**Related topics**

- “Delete UVs” on page 211
Windows and editors

UV Texture Editor

Lets you visually map the UVs of the selected polygon mesh or subdivision surface onto a texture.

Related topics
- “Select UV components” on page 199
- “Set up the texture editor display” on page 200
- “Show the texture image in the UV texture editor” on page 201
- “Show only a subset of all UVs” on page 202
- “Transform UVs in the texture editor” on page 204
- “Set up the texture editor grid and snapping” on page 204
- “Move tool (in UV texture editor)” on page 212

View

Use the standard camera move keys (alt + the middle mouse button and alt + the right mouse button) to move around the texture view.

Toolbar

Most of the items on the texture editor toolbar are shortcuts for actions in the menus. Right-click a button to show its options.

UV position buttons

<table>
<thead>
<tr>
<th>Flip UVs U, Flip UVs V</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Flip UVs U, Flip UVs V" /></td>
</tr>
<tr>
<td>Flips the positions of the selected UVs. Shortcuts for Edit Polygons &gt;Texture &gt;Flip UVs.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Rotate UVs clockwise, Rotate UVs counterclockwise</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Rotate UVs clockwise, Rotate UVs counterclockwise" /></td>
</tr>
<tr>
<td>Rotates the positions of the selected UVs by 45 degrees. Shortcuts for Edit Polygons &gt;Texture &gt;Rotate UVs.</td>
</tr>
<tr>
<td>Function</td>
</tr>
<tr>
<td>--------------------------</td>
</tr>
<tr>
<td>Cut UVs along selection</td>
</tr>
<tr>
<td>Sew UVs</td>
</tr>
<tr>
<td>Move and Sew UVs</td>
</tr>
<tr>
<td>Split selected UV</td>
</tr>
<tr>
<td>Layout UVs</td>
</tr>
<tr>
<td>Cycle U and V</td>
</tr>
<tr>
<td>Align Min U, Align Max U</td>
</tr>
<tr>
<td>Move UVs to grid</td>
</tr>
<tr>
<td>Relax UVs</td>
</tr>
</tbody>
</table>
Isolate Selection buttons
These buttons let you work on a subset of UV faces while hiding the rest.

- "Show only a subset of all UVs" on page 202

<table>
<thead>
<tr>
<th>Button Description</th>
<th>Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle isolation</td>
<td>View &gt; Isolate Select &gt; View Set</td>
</tr>
<tr>
<td>Add selected to isolation</td>
<td>View &gt; Isolate Select &gt; Add Selected</td>
</tr>
<tr>
<td>Removed selected from isolation</td>
<td>View &gt; Isolate Select &gt; Remove Selected</td>
</tr>
<tr>
<td>Remove all</td>
<td>View &gt; Isolate Select &gt; Remove All</td>
</tr>
</tbody>
</table>

View buttons

<table>
<thead>
<tr>
<th>Button Description</th>
<th>Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Texture image</td>
<td>Image &gt; Display Image</td>
</tr>
<tr>
<td>Image ratio</td>
<td>Image &gt; Use Image Ratio</td>
</tr>
<tr>
<td>Bake editor texture</td>
<td>Image &gt; UV Texture Editor Baking</td>
</tr>
</tbody>
</table>

Polygonal Modeling
231
11 | Texture editor
Reference > UV Texture Editor

---

**Force editor texture rebake**

Rebakes the texture. If you turn on Bake Editor Texture or Image > UV Texture Editor Baking, you must rebake the texture (using Force Editor Texture Rebake) after making changes to the texture (File node and place2dTexture node attributes) in order to see the effect of those changes.

---

**Toggle grid**

Shows or hides the grid. Shortcut for View > Grid.

---

**Toggle filtered pixels**

Switches the background image between hardware texture filtering and sharply defined pixels. Shortcut for Images > Unfiltered Image.

---

**Toggle snap to pixel**

Chooses whether to automatically snap UVs to pixel boundaries. Shortcut for Image > Pixel Snap.

---

**Toggle thick texture borders**

Chooses whether Maya draws UV borders with a thick line.

---

**Show image RGB/Show image Alpha**

These two buttons switch between showing the RGB (color) channels of the image and the Alpha (transparency) channel. Shortcuts for Image > Display RGB Channels and Image > Display Alpha Channels.

---

**UV edit buttons**

---

**U coordinate, V coordinate**

| 0.000 | 0.000 |

Show the coordinates of the selected UVs. Edit the text boxes and press Enter to move the points.

---

The UV coordinates in the text boxes on the toolbar do not update automatically as you move the selected UV point. Click the refresh button to update the values in the text boxes.
Copy/paste faces or UVs

Switches the Copy and Paste buttons on the toolbar between working on UVs and UV faces.

Copy

Copies the selected UV points or faces (depending on the Copy/paste faces or UVs button) to the clipboard.

Paste

Pastes UV points or faces (depending on the Copy/paste faces or UVs button) from the clipboard.

Paste U to selected UVs, Paste V to selected UVs

Paste only the U or V values on the clipboard onto the selected UV points.

Polygons menu

The Polygons menu largely duplicates the contents of the Edit Polygons > Texture submenu.

Polygons > UV Snapshot

Saves an image of the current UV layout that you can paint on in a painting program or image editor such as Adobe Photoshop.

“Save a snapshot of the UV layout to paint on” on page 210

File Name

You can save the file anywhere in or out of your project. Maya automatically assigns the file extension based on the image format you select.

Size X, Size Y

Sets the dimensions of the exported image. Use the same dimensions you want for the file texture you are about to create. If you are not sure, use the default size; you can scale the exported image later in your paint program.
Keep Aspect Ratio

The aspect ratio is the ratio of Size X to Size Y. With it turned on, you can change one size slider and Maya automatically adjusts the other size value to keep the same ratio. If you need to change the aspect ratio, turn off this option temporarily and adjust one of the sizes.

Color Value

Sets the color of the UV patches in the exported image. The background of the snapshot is black; therefore, the Color Value should be white or another contrasting color. You can click the box to open the Color Chooser.

Anti-alias Lines

Controls whether lines in the output image have anti-aliasing.

Image Format

Use an image format that your paint program can read. If you require an alpha channel while painting, use TIFF or a similar format.

Subdivs menu

The Subdivs menu duplicates the items in the Polygons menu that apply to Subdivision surfaces.

View menu

Isolate Select submenu

Lets you show only a subset of all UVs, with the ability to add to and subtract from the isolated subset.

- “Show only a subset of all UVs” on page 202

Grid

Shows or hides the texture coordinate grid. Choose View > Grid > □ to set the grid options.

- “Set up the texture editor grid and snapping” on page 204

Length and Width

Controls the overall size of the grid, measured in UV coordinates. The Length and Width is set to 1 (one) by default, because you typically want UVs to fit within the 0 to 1 range and this setting clearly shows the 0 to 1 range.
Grid Lines Every
Sets the spacing between grid lines. Grid lines appear in increments based on the decimal value you specify. This setting affects where UVs snap if you use the Snap to Grid feature.

Subdivisions
Sets the number of lines between each grid line. By default, subdivision lines do not show; you must turn on Subdivision Lines for them to appear.

Display Axes, Grid Lines, Subdivision Lines, Labels
Displays or hides items within the grid.

Toolbar
Shows or hides the texture editor toolbar. See the toolbar section below.

Frame All
Pans and zooms the texture editor view to show the entire UV set.

Frame Selection
Pans and zooms the texture editor to show the selected UVs.

Select menu
The items in this menu are also available on a marking menu. In the texture editor, press + the right mouse button.

Select Contained Faces
Selects the faces contained by the current selection of UVs, edges, or vertices.

Select connected faces
Selects all faces that share the currently selected UVs, edges, or vertices.

Select Shell
Selects the entire UV piece containing the current selection.

Select Shell Border
Selects the UVs along the border of the UV piece containing the current selection.

Convert Selection to Faces, Edges, Vertices, UVs
Selects the equivalent connected component type based on the current selection. For example, if you have faces selected and choose Convert to UVs, Maya will select all UVs connected to the selected faces.
Image menu

- “Show the texture image in the UV texture editor” on page 201

Image Range

Use the settings to change how much of the texture appears in the texture editor.

Minimum U/V and Maximum U/V

You can explicitly set the size of the image by setting these options, or you can select one of the presets.

Presets

Select one of the preset image ranges and click Apply.

- None: The texture space is defined by the Minimum and Maximum U and V values.
- Grid Size: The texture fills the extent of the grid (defined in the Grid Options window.) In the following example, the Extent value was set to 2 in the Grid Options window.
- Unit Size: The texture fills the 0 to 1 (or unit) texture space.

Display Image

Shows or hides the texture image.

UV Texture Editor Baking

Bakes the texture and stores it in memory.

Bakes the texture and stores it in memory. See also “Force editor texture rebake” on page 232.

Baked Texture Resolution

The resolution used when baking the texture.

Display Unfiltered

Turns off pixel blurring to show exact pixel boundaries.
Display RGB Channels, Display Alpha Channel
Switch between displaying the texture image and its alpha (transparency) channel.

Use Image Ratio
Switches between showing square texture space and texture space with the same ratio of width to height as the image.

Pixel Snap
Whether to automatically snap UVs to pixels. Snapping is to pixel corners or centers (see “Placement” on page 212).

Selected Images
Choose which texture to show in the texture editor.

UV Sets
Choose the UV set to edit in the texture editor.

“UV sets” on page 239
11 | Texture editor
Reference > UV Texture Editor
Multitexturing

About Polygons

UV sets

Sometimes an object requires different UV layouts for different textures (known as multitexturing). To accomplish this, Maya provides UV sets.

For example, if you create a brick wall and want to layer spray paint on top, you can use one texture for the bricks and one texture for the paint using a layered texture.

If the brick texture repeats but the paint texture doesn’t, you will want different UV layouts for each.

The main steps to set up multitexturing are:

- Assign multiple textures to an object’s material.
  These textures can be assigned to different material attributes, such as Color and Incandescence, or assigned to a single attribute using a Layered Texture node.
• Create UV sets with different layouts.
• Link each UV set to a given texture using the Relationship Editor.

Examples
The following examples show UV sets used to texture a brick wall. In both examples, the UV sets are:
• unitizedUVs—for the repeating brick texture.
• planarUVs—for the non-repeating texture.

UV sets for Color and Transparency
In this example, the UV sets are connected to textures on different attributes of the material—Color and Transparency.
UV sets for a Layered Texture

In this example, the UV sets are connected to layered textures.
**Related topics**

- "Create UV sets" on page 243
- "Switch between UV sets" on page 243
- "Duplicate, rename, or delete a UV set" on page 244
- "Assign a texture to a UV set" on page 244
- "Copy UVs from one UV set to another" on page 245
How do I? Apply colors, shading, and textures

Manage multiple UV sets

Create UV sets

- The quickest way to create UV sets is while you map UVs. When you map UVs, open the options window, turn on Create New UV Set, and type a name in the UV Set Name box.
  
  For example, if you create two planar mappings, one from the top and one from the side, type a new UV set name each time you map.

- If you prefer, you can start with an empty UV set and then create UVs.

  1. Select the object, then select Edit Polygons > Texture > Create Empty UV Set > □.
  2. In the Create UV Set Name box, type the name of the empty set and click Create.
  3. Select the new UV set (see “Switch between UV sets” on page 243).
  4. Create UVs with one of the mapping operations or by copying.

Related topics

- “UVs and mapping” on page 179
- “UV sets” on page 239
- “Switch between UV sets” on page 243
- “Edit Polygons > Texture > Create Empty UV Set” on page 246

Switch between UV sets

Do one of the following:

- In the UV Texture Editor, select Image > UV Sets > UVsetName.
- In the scene view, press the right mouse button on a mesh and choose UV Sets > UVsetName.
- Select Edit Polygons > Texture > Set Current UV Set. In the window, type the name of the UV set you want.

Related topics

- “UV sets” on page 239
- “Create UV sets” on page 243
- “Copy UVs from one UV set to another” on page 245
**Duplicate, rename, or delete a UV set**

Select the UV set you want to rename, copy from, or delete.

Do one of the following:

- **Edit Polygons > Texture > Copy UVs to UV Set**
  Copies the current UV set to a new UV set.
- **Edit Polygons > Texture > Rename Current UV Set**
  Type a new UV set name in the window.
- **Edit Polygons > Texture > Delete Current UV Set**

**Related topics**

- “UV sets” on page 239
- “Switch between UV sets” on page 243
- “Edit Polygons > Texture > Copy UVs to UV Set” on page 246

**Assign a texture to a UV set**

You assign textures to UV sets with the relationship editor.

Select Window > Relationship Editors > UV Linking > UV-Centric to open the relationship editor’s UV set editing view.

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>To assign a texture to a UV set.</td>
<td>Click the UV Set in the left column, then click the texture in the right column so it’s highlighted.</td>
</tr>
<tr>
<td>To remove a texture from a UV set.</td>
<td>Click the UV Set in the left column, then click the texture in the right column so it’s not highlighted.</td>
</tr>
<tr>
<td>Temporarily keep textures from appearing in software renders.</td>
<td>From the Edit menu above the list of textures, choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>- Ignore Texture: hides the selected texture.</td>
</tr>
<tr>
<td></td>
<td>- Use Texture in Render: uses the selected texture.</td>
</tr>
<tr>
<td></td>
<td>- Isolate Texture: hides all textures but the selected one.</td>
</tr>
<tr>
<td></td>
<td>- Use All Textures in Render.</td>
</tr>
</tbody>
</table>
How do I? > Copy UVs from one UV set to another

The Relationship Editor also gives you easy access to several the UV set editing operations in its Edit menu.

Related topics
- “UV sets” on page 239
- “Create UV sets” on page 243
- “Switch between UV sets” on page 243

Copy UVs from one UV set to another
1. In the texture editor, select the UVs you want to copy.
2. In the texture editor, open the Polygons > Copy UVs to UV Set submenu and choose a UV set.

Related topics
- “UV sets” on page 239
- “Duplicate, rename, or delete a UV set” on page 244
Reference Menus

Modeling menu set

Edit Polygons

Edit Polygons > Texture > Create Empty UV Set

Creates a new, empty UV set on the current object. You can then create the UVs in the set using one of the mapping/projection methods.

Related topics
- “UV sets” on page 239
- “Create UV sets” on page 243

Options

UV Set Name
Enter a name for the new UV set.

Edit Polygons > Texture > Copy UVs to UV Set

Use the items in this submenu to create a new UV set based on an existing UV layout or transfer a UV layout from one set to another.

Related topics
- “UV sets” on page 239
- “Copy UVs from one UV set to another” on page 245

Edit Polygons > Texture > Set Current UV Set

To choose a UV set from a list:
- In the UV Texture Editor, select Image > UV Sets > UVsetName.
- In the scene view, press the right mouse button on a mesh and choose UV Sets > UVsetName.

Related topics
- “UV sets” on page 239
- “Switch between UV sets” on page 243
Options
UV Set Name
   Type the name of the UV set you want to switch to.
12 | Multitexturing
Reference > Edit Polygons > Texture > Set Current UV Set
13 Blind data

About

Blind data

Blind data is information stored with polygons which is not used by Maya in any way, but is useful to the platform to which you export the polygons, such as a games engine.

An example of blind data is using Maya to create game levels. You can use blind data to specify which faces of the level are “solid” or “permeable” to the character, which faces are lava and hurt the character, and so on.

You can use Maya’s Blind Data Editor to define the blind data types you need, and then apply the blind data to objects or components in your scene.

The blind data editor also allows you to query your scene for blind data of a specific type or set of values and use false coloring to visualize what blind data is assigned to each objects.

You can also apply blind data to NURBS patches using “face”, but you cannot false color it.

Templates

A template is like a form that can be filled out for each component. It lists one or more attributes, their data types.

Possible data types for attributes are:

- int (integer numbers).
- float/double (real numbers).
- boolean (on/off).
- string (text).
- binary (raw data).

You can specify what components (faces, vertices, edges, or all types) the template applies to.
Each template needs a unique ID. Every attribute needs both long and short names for setting and retrieving the data.

When you create a template, you can also create one or more presets that will load pre-defined values into the attributes.

Related topics
- “Set up the structure of blind data” on page 250
- “Apply blind data to components” on page 251
- “Make blind data visible” on page 252
- “Blind Data Editor” on page 254

How do I? Create and edit models

Add blind data to polygons

Set up the structure of blind data

Before you add blind data to polygons, you must set up how the information is structured using a template. A template is a list of attributes and presets.

To define a new template
1. Select Window > General Editors > Blind Data Editor.
2. Click the Type Editor tab.
3. Click the New button below the list on the left side. You may need to resize the window to see it.
4. Enter an ID number and Name for the template, and set the Association Type to the component type this template is associated with (or All).
5. Enter the Long name, Short name, and Data type of the first attribute in the template.
6. For any additional attributes you want to add, click the New Attr button to add more fields.
7. You can define presets, which will load pre-defined values into each attribute. For any presets you want to create, click the New Preset button. Enter a Preset name and a value for each attribute.
8. Click the Save button below the list on the left side.
How do I? > Apply blind data to components

To edit an existing template
1. Select Window > General Editors > Blind Data Editor.
2. Click the Type Editor tab.
3. Click the name of the template in the list on the left.
4. Edit the fields to change the template’s Name, Association type, and Free Set values. You can also edit and add new presets.

Export a template to a file
You can save a template to a template file. This is useful if you want to use the same template in multiple scenes.
1. Select Window > General Editors > Blind Data Editor.
2. Click the Type Editor tab.
3. Click the Export button below the list on the left side.

Export a template to a text file
You can save a template to a text file. This is useful if you want to:
- Convert the template information to some other form, such as a program structure.
- Show the template to other people, such as a level designer.
1. Select Window > General Editors > Blind Data Editor.
2. Click the Type Editor tab.
3. Click the Text Dump button below the list on the left side.

Related topics
- “Apply blind data to components” on page 251
- “Make blind data visible” on page 252

Apply blind data to components
1. Select the components.

Note: If you are entering a new blind data type in the Blind Data Editor, and Save does not save the new type, (and there is no error message indicating that the type is invalid in some way, such as a duplicate id), select an existing type, press Save, perform New again and enter the new type. The editor may have been confused by an incomplete edit done earlier.
13 | Blind data

How do I? > Make blind data visible

2 Select Window > General Editors > Blind Data Editor.
3 Click the Apply tab.
4 Select the template from the list on the left.
5 Enter values for each attribute, or click the radio button for a preset.
6 Do one of the following:
   • Click the Apply button at the bottom of the window to apply the blind data value to all components.
   • Click the Paint values button to use the Edit > Paint Selection Tool to apply the blind data value to components by painting them.

Related topics
❖ “Set up the structure of blind data” on page 250
❖ “Make blind data visible” on page 252
❖ “Blind Data Editor” on page 254

Make blind data visible

View the actual blind data values on components
The View tab shows the data assigned to the lead component or object for all blind data types defined in your scene.
1 Select the component or mesh.
2 Select Window > General Editors > Blind Data Editor.
3 Click the View tab.
   The Name of the key component or object is at the top of the tab, followed by columns indicating the blind data ID, the name of each attribute and its value. If there is no data assigned to the component for a particular template the value is blank.

Visualize blind data with color
1 Select the component or mesh.
2 Select Window > General Editors > Blind Data Editor.
3 Click the Color/Query tab.
   Each row of controls can assign a color to different blind data.
4 Turn on the checkbox to the left of a row to activate the row.
5 Click the color swatch at the end of the row to edit the color.
6 Press the right mouse button in the Tag/ID field to choose a template. When the center checkbox is off, the color will simply show on any component that has this blind data template.
To further refine the display, turn on the center checkbox.

Do one of the following:
- To show this color for any blind data which match certain values, set the pop-up menu to Discrete Value and enter values for each attribute.
- To show this color for any blind data within a range of values, set the pop-up menu to Discrete Range, and enter a range in the form $[\text{low}, \text{high}]$ for each attribute.
- To show continuous shading based on blind data values, set the pop-up menu to Continuous, and for each attribute specify the minimum and maximum values and shades.

Click the Apply button at the bottom of the window.

Notes
- Although you can examine multiple types of blind data at one time, you are only allowed one type of Color/Query action. The possible types are:
  - Binary: either the data is assigned or not
  - Discrete: either a discrete value or discrete range
  - Continuous: use grayscale values for coloring
  - Hex: use bit operations on the values
If you have rows with different types, the operation will fail.
Association type and selection type are also important in this regard. If all the rows have Any as the Association Type, or if the rows do not match (one row’s blind data has Face Association Type and another’s Association Type is Vertex), the selection will not be converted and the components and objects selected are queried or colored in their present state.
- Blind Data false coloring does not show up in lighting mode.
Use Default Lights to see the Blind data false color.

Related topics
- “Set up the structure of blind data” on page 250
- “Apply blind data to components” on page 251
- “Blind Data Editor” on page 254
Reference  Windows and editors

Blind Data Editor

Lets you create, apply, edit, and view blind data.

Related topics

- “Blind data” on page 249
- “Set up the structure of blind data” on page 250
- “Apply blind data to components” on page 251
- “Make blind data visible” on page 252

Apply tab

Assoc Type

If the selected blind data type already has a particular association type assigned to it, then this option is available and the data will only be applied to that component type (or, if the type is object, to the whole object). Otherwise, if the type was Any, this option is not available and you should select the association type you want to apply your data to. The default is face.

Selected components are converted to the Assoc Type before the data is applied.

Apply Type

If the data types of the selected blind data type are not all either int or double, this menu is unavailable. Possible values are Absolute, Offset, and Scale.

Absolute  The value is applied to the data. If selected components or objects already have blind data of this type, the values are overwritten.

Offset  The values are added to the data that is assigned to the selected components or objects. If no data exists on a selected component or object, no data is applied. If the attribute being affected is Ranged, the values are clamped at the minimum and maximum values.

Scale  The existing data associated with the selected components or objects is multiplied by this value. If no data exists, none is applied. If the attribute is Ranged, the values will also be clamped.
Paint values

Selects the Edit > Paint Selection Tool and opens the Tool Settings window. This tool only works if you have a blind data type selected and if the association type is face or vertex. The component pick mask is switched to the association type selected for this blind data type, and the data is applied on every mouse release.

Color data on apply

When turned on, the selected components are false colored after the apply is done according to how you have color set up in the Query/Color tab.

Color/Query tab

Use this tab to false color and query polygonal objects and components based on criteria you set up. There are several levels through which you can look at the data.

The first is a high level view of what components or objects have the specified blind data assigned to them, regardless of value.

<table>
<thead>
<tr>
<th>Note</th>
<th>The colors show the sequence of queries that were performed, and do not get updated by subsequent changes to blind data. If the object’s topology changes, colors may no longer be accurate.</th>
</tr>
</thead>
</table>

Tag/Id

To complete the Tag/Id fields, right-click in the field to bring up a popup of the available types, or type in the fields.

Set Color

In the following illustration, Set Color goes through the selection list and colors components that have floorType blind data red, wallType blind data green, and ceilingType blind data blue. If any components have two or more of the specified types assigned, the components (or objects) are colored with the Clash Color, in this case, light blue. Components that have none of the specified types are colored with the None color, which is black in this case.

| Tip | To see the colors in the illustrations in this section, view the online help. |
Query

Click Query to select the components (or objects) which would be colored if you had chosen Set Color. Note that if any of the row conditions are satisfied, the component or object is selected.

Remove Color

Click Remove Color to remove color from the components that have the listed blind data types.

Select value options

When you enable the values for a row, this section displays below the row, providing you with the following options for the color or query action.

discrete value

Select this option to color or query one value for a particular type.

Note  To use a row in the Color/Query operation, turn on the check box to the left of the Tag/Id field. Disabling a row is useful if you do not want to use a particular type or value but may want it later.
discrete range

Select this option to color or query a range of values for a particular type.

In the following illustration, components with the blind data type floorType with a value of 0 (corresponding to preset: normal) are colored red. Components with blind data type damage and values between 75 and 100 are colored green. Components with both floorType and damage blind data are colored with the Clash color.

Continuous

Integer or double data can also be colored with grayscale values. Select continuous from the drop down menu, and select min and max values and colors to use in coloring the data.

In the following illustration, the blind data type floorRoughness is displayed. Components which have a value of 0 are colored black, those with values of 1 are colored white, and those in between will have the appropriate grayscale. Values less than 0 or greater than 1 are colored yellow, the Out of Range color. The None color is blue to differentiate between components with 0 floorRoughness and components that have no floorRoughness assigned at all.
When using the continuous type, query works as if discrete range were selected; any components that have blind data with values between the min value and the max values are added to the selection list.

Hex

You can also color and query with the hex type if the blind data type selected consists of hex data.
When the selected Compare Type is Set, components with the selected value(s) set are colored or selected. If it is Not Set, only components with the value not set are colored or selected. If set to Equal, only values which equal the selected value are colored or selected.

**Type Editor tab**

**Id**

Must be a unique integer which specifies which blind data type you’re working with.

**Note**

Subdivision surfaces use blind data to store hierarchical edit information when converting from a subdivision surface to a poly proxy object. The Id numbers between 65119000–65119999 are reserved for this purpose. Do not assign them to your blind data types.

**Name**

A word or string (with no spaces) that will help you remember what the blind data types are. It must be unique.
Association type

Describes what the blind data is attached to. Valid choices from this editor are Face, Vertex, Object, or Any. If you select Any you have to choose what you want to apply the data to when you are applying it. If you select Face, Vertex, or Object, the data is assigned only to that type of component or object (and selected objects/components are converted to this type).

If the component type you are going to be applying this data to is always going to be the same, it’s a good idea to select it here so that Maya will know how to treat your selection when applying, coloring, or querying components.

Free Set

Turn this option on if you want to be able to set the value manually (according to the appropriate data type). Turn it off to use only the values that have been explicitly defined as Presets.

New Attr

When you first enter a new type, only one attribute is presented to you. To create a blind data type that has more than one attribute (for example, two ints), click New Attr.

Long Name

Type the long name for the attribute you are defining, such as “message.” It can contain, but not start with, numeric characters.

Short Name

Type the short name for the attribute you’re defining, such as “msg” for message. This name must be 3 characters or less and can contain, but not start with, numeric characters.

For object blind data, choose unique long and short names for the blind data type, making sure they are different from any attribute name on the object to which you are going to apply the blind data. For component blind data, the names must be unique within the DG node.

To see all the long names of attributes on a shape, type:

```
listAttr pPlaneShape1;
```

To see all the short names of attributes on a shape, type:
Data Type

Select which type of data the attribute is. Valid choices are:

- **double**: A floating point decimal number. This choice is equivalent to a float type.
- **int**: An integer.
- **hex**: This is a special case of integer in which hex values are used to represent the data. Using this type, you can pack a large number of binary values into one integer.
- **boolean**: True or false (1 or 0) only.
- **string**: An ascii string of text.
- **binary**: An arbitrary stream of data, stored as text.

Ranged

This option is available only if you have a numeric data type selected (double, int, or hex) and if Free Set is turned on. Turn on Ranged to restrict the data to an upper and lower range. When you turn it on, the Min and Max boxes appear for you to specify the upper and lower range.

You use Presets to set up values you can quickly select by name instead of having to know which values to use. They provide a means for enumerating integral or (in the case of the hex type) flag values, that let you quickly set frequently-used data and, if Free Set is turned off, restricting what values you can apply to data.

New Preset

Click this button to create a new preset; when you do, several input boxes appear. There is one box for the Name of the preset and one box for each attribute in this blind data type. Click Delete to remove presets you do not want.

Once you have entered all of the data, click the Save button to save this blind data type to the scene so that you can apply data using it as a template.
13 | Blind data
Reference > Blind Data Editor

Polygonal Modeling
262
14 Customizing

How do I? Customize Maya

Customize polygonal modeling

Change how you select faces

The default in Maya is to click the dot in the center of a face to select it. You can set an option to let you click anywhere on a face to select it.

1 Choose Window > Settings/Preferences > Preferences, click the Selection category.

2 Set the Select Faces With option:
   - To select faces by clicking anywhere on the face, click Whole.
   - To select faces by clicking the dot in the center, click Center.

Related topics

* “Change polygon tool settings” on page 263

Change polygon tool settings

Keep new faces planar

Turn on Polygons > Tool Options > Keep New Faces Planar if you want to keep faces planar while using the Create Polygon Tool and Append to Polygon Tool.

Turning on Keep New Faces Planar has the same effect as turning on the Ensure Planarity option for either of these tools.

Keep faces together

Turn Polygons > Tool Options > Keep Faces Together on or off while you are extruding, extracting, or duplicating faces to specify whether you want to retain the edges of each face or the border edges.
When this option is on, Maya automatically sets the option in the Attribute Editor and Channel Box for Edit Polygons > Extrude Face, Extrude Edge, and Duplicate Face, and Edit Polygons > Extract.

**Keep faces together on**

If Keep Faces Together is on, only the border edges make walls as they are extruded, extracted, or duplicated. Faces connected by their edges create a single tube, with the connected faces as a single roof.

---

**Keep Faces Together off**

If Keep Faces Together is off, each edge makes a wall as it is extruded. Duplicated faces are duplicated separately, and extracted faces are extracted separately. The faces separate from each other and scale from their own center.
Create meshes single sided

Turn on Polygons > Tool Options > Create Meshes Single Sided if you want new polygonal meshes to be created single-sided.

When this is turned on, new polygonal meshes (for example, created by the polygon primitive tools or by polygonal operations) automatically have their Render Stats > Double Sided attribute turned off.

Convert the selection mode

When Polygons > Tool Options > Convert Selection is on (the default), Maya automatically converts an object selection to the appropriate component selection mode if an action requires works only on components.

For example, if you select a polygonal object and try to extrude faces, Maya will automatically select all the faces on the object and proceed.

When Convert Selection is turned off, operations work at the object level. If this is not appropriate for the operation, Maya will print the following message:

Warning: Try turning the Polygons->ToolOptions->ConvertSelection ON.
Smart Command Settings

If you turn on Polygons > Tool Options > Smart Command Settings (it is turned off by default), when you perform polygonal operations from the Polygons or Edit Polygons menu, Maya modifies settings based on the kind of action being performed:

- Sets display attributes to show components relevant to the action (for instance, displaying normals or border edges).
- Sets the selection mask to objects/components appropriate for the action.
- Sets selection constraints that make sense for the action.

After performing an operation, you can return to the previous state by selecting Polygons > Tool Options > Reset to Default Settings, or by performing another action.

Related topics

- “Change how you select faces” on page 263
- “Polygons > Tool Options > Keep New Faces Planar” on page 266
- “Polygons > Tool Options > Keep Faces Together” on page 267
- “Polygons > Tool Options > Create Meshes Single Sided” on page 267
- “Polygons > Tool Options > Convert Selection” on page 267
- “Polygons > Tool Options > Smart Command Settings” on page 267
- “Polygons > Tool Options > Reset to Default Settings” on page 267
Polygons > Tool Options > Keep Faces Together

Related topics
- “Change polygon tool settings” on page 263

Polygons > Tool Options > Create Meshes Single Sided

Controls whether new polygonal meshes are created single-sided or double-sided.

When this toggle is turned on, new polygonal meshes (for example, created by the polygon primitive tools or by polygonal operations) automatically have their Render Stats > Double Sided attribute turned off.

Related topics
- “Change polygon tool settings” on page 263

Polygons > Tool Options > Convert Selection

Related topics
- “Change polygon tool settings” on page 263

Polygons > Tool Options > Smart Command Settings

Related topics
- “Change polygon tool settings” on page 263

Polygons > Tool Options > Reset to Default Settings

Related topics
- “Change polygon tool settings” on page 263
14 | Customizing
Reference > Polygons > Tool Options > Reset to Default Settings
Index

**Numerics**

2-manifold geometry ........................................ 15
3D Delta tessellation method .................................. 57

A

Activate
toggle in Selection Constraint window .................. 26
adaptive tessellation ........................................... 56
Add color attribute ............................................. 173
after boolean operation ....................................... 116
Align UVs (Edit Polygons > Texture) .................... 223
All and Next constraint mode option ...................... 21
Allow Zero Normals attribute ................................. 146
Alpha Blending, prelight option ............................. 178
Alpha color attribute .......................................... 174
angle
Selection Constraint option ................................. 29
selection constraints ......................................... 27
Angle Threshold
Quadrangulate polygons option ............................ 143
Angle Tolerance ................................................ 95
animate vertex colors .......................................... 171
Append to Polygon Tool (Polygons menu) ............... 68
arc, extrude polygons in ..................................... 46
Attach Multiple Output Meshes ............................ 55
Attribute Editor
access history of objects ..................................... 116
attribute map, sculpting to .................................. 102
attributes
data types .................................................. 249
short names for ................................................. 260
Auto Fit
Bevel option, polygons ...................................... 95
Auto Smooth Strength
Sculpt Polygon Tool option ................................ 104
Auto Smooth, Sculpt Polygon Tool option .............. 104
automatic mapping ............................................ 186
Automatic Mapping (Edit Polygons > Texture) ........ 194
Average Vertices (Polygons menu) ....................... 71

Axis
selection constraint option ................................. 28
setting orientation for polygonal primitives ............ 63

B

backculling display ............................................. 164
backface culling
hard, polygons .................................................. 166
options ......................................................... 166
baking rendered look ......................................... 175
Best Plane Texturing Tool (Edit Polygons > Texture) 197
Bevel (Edit Polygons menu) ................................ 93
beveling ........................................................ 51
blending prelight options .................................... 178
blind data
add to components ............................................ 251
make visible ..................................................... 252
querying ........................................................ 255
visualize ........................................................ 252
Blind Data Editor ................................................ 249
controls .......................................................... 254
boolean operations
accessing original objects .................................... 115
use for meshes .................................................. 113
Booleans (Polygons menu) ................................ 125
Border selection constraint option ....................... 30
Border Target Shape map UV border option .......... 217
borders
display, changing .............................................. 164
straighten out .................................................. 209
boundary edges, merging ..................................... 110
bounding box
mirror polygons across ....................................... 46
bowtie shape ..................................................... 16
brush stamps
selecting ........................................................ 104
brushes
displacement for sculpting ................................... 106
painting out the effects of previous stroke .......... 102
stamps .......................................................... 104
using to push and pull vertices ......................... 100

Polygonal Modeling

269
Index

bumps
  painting over ........................................ 98

C
  center, move for split faces ......................... 121
  Chamfer Vertex (Edit Polygons menu) ............... 93
  chamfered corner, creating ......................... 52
  Channel Box
    access history of objects ......................... 116
  Chord Height Ratio (tessellation) .................. 56
  clean up meshes .................................... 153
  Cleanup (Polygons menu) ............................. 155
  Collapse (Edit Polygons menu) ...................... 126
  collapse edges or faces into a single vertex .... 110
  collectively normalize UVs ......................... 213
  color
    operations ........................................ 165
  Color Blending, prelight option .................... 178
  Color Chooser, display .............................. 173
  Color Material Channel
    options, Custom Polygon Display ................. 168
  colors
    add to polygons .................................. 168
    animate for vertices ............................ 171
    assign to vertices ................................ 169
    assigning to polygons ........................... 167
    copy between polygons ............................ 211
    make visible for vertices ......................... 168
    options, in Custom Polygon Display window .... 168
    paint on vertices ................................ 170
    remove from vertices ............................. 172
    rendered, assign to vertices ..................... 170
    use to visualize blind data ...................... 252
  Colors (Edit Polygons menu) ......................... 173
  Combine (Polygons menu) ............................. 124
  Combine Meshes .......................... 75
  components
    display of polygons .............................. 17
    displaying numbers ................................ 165
    mesh, selecting .................................. 19
    set selection constraints for transfer ......... 29
  Compute shadow maps, prelight option .......... 176
  constraints
    activate toggle .................................. 26
    modes ............................................ 21
    properties ....................................... 21
    see selection constraints ....................... 19
    selecting by ..................................... 19
    split line point placement ...................... 120
  construction history
    and sculpting ..................................... 99
    cleanup attribute ................................ 155
  Continuity, Smooth option, polygons ............. 76
  Control Points tessellation method .......... 59
  convert polygons to triangles or quadrangles .. 135
  Convert Selection, description ................. 265
  Convexity constraints ............................. 24
  coordinates
    displaying for textures ......................... 165
    texture .......................................... 67
  Copy UVs to UV Set (Edit Polygons > Texture) .... 246
  corner, chamfering ................................ 52
  count (polygons)
    display polygon count ............................ 161
  Count, tessellation method ......................... 59
  creases, creating .................................. 14
  Create Empty UV Set (Edit Polygons > Texture) .... 246
  Create menu
    Polygon Primitives ............................... 59
  Create Meshes Single Sided ......................... 267
  Create New UV Set
    automatic mapping option ....................... 197
    planar mapping option ........................... 191
    spherical mapping option ......................... 193
  Create Polygon Tool (Polygons menu) ............. 66
  Create UVs Based on Camera (Edit Polygons > Texture) ............. 197
    culling, backface ............................... 164
    Current and Next constraint mode option ....... 21
    Custom Polygon Display ......................... 164
    color per vertex ................................. 168
  Display menu ........................................ 163
  customize polygonal modeling ..................... 263
  Cut Along ........................................ 75

Polygonal Modeling

270
<table>
<thead>
<tr>
<th>Cut faces</th>
<th>123</th>
</tr>
</thead>
<tbody>
<tr>
<td>with a line</td>
<td>124</td>
</tr>
<tr>
<td>with a plane</td>
<td>123</td>
</tr>
<tr>
<td>Cut Faces (Edit Polygons menu)</td>
<td>130</td>
</tr>
<tr>
<td>Cut UVs (Edit Polygons &gt; Texture)</td>
<td>226</td>
</tr>
<tr>
<td>CVs</td>
<td></td>
</tr>
<tr>
<td>matching when tessellating</td>
<td>59</td>
</tr>
<tr>
<td>cylinder</td>
<td></td>
</tr>
<tr>
<td>use to project UVs</td>
<td>185</td>
</tr>
</tbody>
</table>

**D**

<table>
<thead>
<tr>
<th>Data Type attribute</th>
<th>261</th>
</tr>
</thead>
<tbody>
<tr>
<td>data types for attributes</td>
<td>249</td>
</tr>
<tr>
<td>default shader</td>
<td></td>
</tr>
<tr>
<td>assign during UV projection to check registration</td>
<td>188</td>
</tr>
<tr>
<td>delete</td>
<td></td>
</tr>
<tr>
<td>edges</td>
<td>151</td>
</tr>
<tr>
<td>vertices</td>
<td>151</td>
</tr>
<tr>
<td>Delete Edge</td>
<td>151</td>
</tr>
<tr>
<td>Delete UVs (Edit Polygons &gt; Texture)</td>
<td>228</td>
</tr>
<tr>
<td>Difference (Boolean operation)</td>
<td>125</td>
</tr>
<tr>
<td>Direction</td>
<td></td>
</tr>
<tr>
<td>Duplicate Face option</td>
<td>91</td>
</tr>
<tr>
<td>Move Component option</td>
<td>85</td>
</tr>
<tr>
<td>option for selection constraint</td>
<td>29</td>
</tr>
<tr>
<td>disconnect faces from their shared edges</td>
<td>117</td>
</tr>
<tr>
<td>displace</td>
<td></td>
</tr>
<tr>
<td>brush stroke, Sculpt Polygon Tool</td>
<td>106</td>
</tr>
<tr>
<td>geometry, prelight option</td>
<td>177</td>
</tr>
<tr>
<td>points, when prelighting</td>
<td>178</td>
</tr>
<tr>
<td>Display menu</td>
<td></td>
</tr>
<tr>
<td>Custom Polygon Display</td>
<td>163</td>
</tr>
<tr>
<td>display of components</td>
<td>17</td>
</tr>
</tbody>
</table>

**E**

<table>
<thead>
<tr>
<th>Distance options</th>
<th>28</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance Tolerance attribute</td>
<td>146</td>
</tr>
<tr>
<td>Divisions Per Face, linear smoothing property</td>
<td>78</td>
</tr>
<tr>
<td>Domains constraints</td>
<td>24</td>
</tr>
<tr>
<td>duplicate</td>
<td></td>
</tr>
<tr>
<td>and mirror an object</td>
<td>46</td>
</tr>
<tr>
<td>faces</td>
<td>49</td>
</tr>
<tr>
<td>Duplicate Face (Edit Polygons menu)</td>
<td>90</td>
</tr>
</tbody>
</table>

| Each face separately            |     |
| normalize UVs                   | 214 |
| edges                            |     |
| about                            | 13  |
| beveling edges                   | 51  |
| border                           | 15  |
| collapse into one vertex         | 110 |
| constrain properties for         | 22  |
| Count setting                    | 20  |
| crease                           | 40  |
| delete                           | 151 |
| disconnect faces from shared     | 117 |
| display, changing                | 164 |
| Either Side setting              | 20  |
| extrude along a path curve       | 43  |
| flip for triangles               | 135 |
| hard, keep when quadrangulating polygons | 143 |
| keep hard                        | 77  |
| merging                          | 110 |
| pull polygons out of             | 86  |
| selecting smooth only or hard only | 22 |
| set angular selection constraints for | 27 |
| set length selection constraints for | 27 |
| split into segments              | 123 |
| Swap tessellation                | 58  |
| Weights relax UVs option         | 221 |

Index

Polygonal Modeling

271
Index

Edit Polygons menu
   Bevel ............................................. 93
   Chamfer Vertex ..................................... 93
   Collapse .......................................... 126
   Colors ............................................ 173
   Cut Faces ......................................... 130
   Duplicate Face ..................................... 90
   Extract ........................................... 131
   Extrude Edge ....................................... 86
   Extrude Face ....................................... 86
   Extrude Vertex ..................................... 89
   Make Hole Tool ..................................... 148
   Merge Edge Tool .................................... 126
   Merge Multiple Edges ................................ 127
   Merge Vertices ..................................... 125
   Move Component .................................... 83
   Normals > Average Normals ......................... 146
   Normals > Reverse ................................ 147
   Normals > Set to Face ................................ 147
   Normals > Set Vertex Normal ....................... 145
   Normals > Soften/Harden ........................... 148
   Poke Faces ......................................... 125
   Sculpt Polygons Tool ................................ 103
   Separate ............................................ 125
   Split Polygon Tool .................................. 129
   Subdivide .......................................... 128
   Texture ............................................. 189
   Wedge Faces ......................................... 90

editors
   Relationship ......................................... 245
   UV Texture Editor .................................... 229

Ensure Planarity
   Append to Polygons option .......................... 69
   Create Polygon Tool option ........................ 66

erase
   back to a previous state ............................ 101
   brush stamp ......................................... 104
   changes to a surface ................................ 98
   sculpting polygons .................................. 107

Erase Srf update option, Sculpt Polygon Tool .... 107
Extrude (Edit Polygons menu) ......................... 131
extract faces ......................................... 117
Extrude Face (Edit Polygons menu) ................. 86
Extrude Vertex (Edit Polygons menu) ............... 89
eyedropper, use to assign color ....................... 169

faces
   about ............................................... 13
   change how to select ............................... 263
   collapse into one vertex ............................ 110
   concave/convex ..................................... 24
   cut with a line ...................................... 124
   cut with a plane .................................... 123
   cutting ............................................... 130
   disconnect from shared edges ...................... 117
   disconnecting from edges ......................... 131
   display, changing ................................... 164
   divisions per, smoothing setting .................. 78
   duplicate ............................................ 49, 90
   duplicate in random directions .................... 132
   extrude .............................................. 42
   extrude along a path curve ......................... 43
   filling holes in ...................................... 52
   highlight non-planar ................................ 164
   holed/non-holed ..................................... 24
   keep together ....................................... 45, 50, 119, 263, 264
   local values for selected ......................... 138
   making holes in ..................................... 84
   mapped/unmapped ................................... 24
   normals .............................................. 13
   planar, keeping ..................................... 263
   poke (split and move center) ....................... 121
   pull polygons out of ............................... 127
   reduce number in .................................... 153
   removing if all edges shared ....................... 157
   select from UV components ......................... 199
   set normals to ....................................... 147
   set selection constraints for ..................... 22, 28
   show those inside selected UVs or edges ........ 203
   split into quadrangles .............................. 120
   split into triangles ................................ 120
   subdivide by painting ................................ 122
   topology constraints ................................ 24

Fill Hole
   description .......................................... 52

First Normal, Sculpt Polygon Tool option .......... 105
Fit to Best Plane, planar mapping option .......... 190
Fit to Bounding Box, planar mapping option ..... 190
Flip Reversed layout UVs option ..................... 224
Flip Triangle Edge option ............................ 136

Polygonal Modeling

272
flip triangle edges .............................................. 135
Flip UVs (Edit Polygons > Texture) .................. 215
Fractional Tolerance tessellation method .......... 57

G
General tessellation method ......................... 57
general geometry ..................................... 15
duplicate and flip ........................................ 46
keep borders ............................................. 76
options ..................................................... 25
options for removing .................................. 156
during prelight ........................................... 177
tessellation cleanup option ............................ 155
global values
for extrude transformations ......................... 132
for Move Component .................................. 85
Grab Color attribute ................................ 174
Grid UVs (Edit Polygons > Texture) ............... 223
Grow Selection Region button .................... 30

H
hard edges
creating .................................................... 14
keep when quadrangulating polygons ............. 143
harden vertex normals ................................. 148
heads up display
show polygon counts .................................. 161
height, setting for polygonal primitives .......... 62
history node, create .................................. 35
holed faces ............................................... 24
holes
create in a polygon ................................... 33
filling ...................................................... 53
making ..................................................... 138
Hypergraph
access history of objects ........................... 116

I
Image Center, planar mapping option ............. 191
Image Rotation, planar mapping option .......... 191
Image Rotation, spherical mapping option ...... 193
Image Scale, planar mapping option .............. 191
Image Scale, spherical mapping option .......... 193

K
Keep Face Group Border
Quadrangulate polygon option ..................... 143
Keep Faces Together
description for polygon tools ...................... 264
for polygon tools ..................................... 263
when disconnecting faces ............................ 119
when duplicating faces ............................... 50
when extruding ......................................... 45
Keep Geometry Borders, smoothing setting ...... 76
Keep Hard Edges
Backface Culling option ............................. 166
Quadrangulate polygons option ................. 143
smoothing setting ..................................... 77
Keep Image Ratio, planar mapping option ....... 191
Keep New Faces Planar
description ............................................. 263
Keep Selection Borders, smoothing property .... 263
Keep Tessellation, smoothing setting ............. 77
Keep Texture Border
Quadrangulate polygons option ................. 143
Keep Wire
Backface Culling option ............................. 166
keyframing sculpting changes ..................... 103

L
lamina face removal .................................... 157
Lamina option ........................................... 24

Polygonal Modeling
273
Index

Layer Editor
  addition of meshes ................................. 40
layered texture, UV sets ............................. 241
layers
  proxy meshes in .................................. 82
  smooth display .................................... 83
  smooth mesh in .................................... 83
layout
  automatic mapping option ......................... 195
  of UVs, save snapshot ............................ 210
  UVs option ........................................ 225
Layout UVs (Edit Polygons > Texture) ............... 224
length
  options for selection constraints ................. 27
lighting
  sample incoming (prelight) ....................... 177
  storing information with prelighting ............. 167
Limit Points Specified To, Create Polygon Tool
  option ............................................ 66
Limit Points To, Append to Polygon option .......... 69
line
  draw across a face to split ...................... 119
  use to cut faces ................................ 124
Linear Smoothing Controls ............................ 77
Local Values options, for Move Component .......... 84
location constraints properties ...................... 21
long name ........................................... 260

M
magnets, control number when snapping ............. 129
Make Hole Tool (Edit Polygons menu) ................. 148
Map Size Presets
  layout UVs option ................................ 226
Map UV Border (Edit Polygons > Texture) ............ 217
Mapped Area options ................................ 28
Mapped constraints .................................. 24

mapping
  based on a plane ................................... 183
  change image scale (width, height) .............. 191
  image center, changing ........................... 191
  image rotation angle, change .................... 191
  to a smoothed model for transfer back .......... 189
  UVs .................................................. 180
  UVs automatically ................................ 186
Mapping direction
  planar mapping option ............................... 190
Max 2D, 3D Angle settings ............................ 20
Max Iterations relax UVs option ...................... 222
Max values ............................................ 25
merge
  edges ............................................... 110
  vertices into a single vertex .................... 109
Merge Edge Tool (Edit Polygons menu) ............... 126
Merge Multiple Edges (Edit Polygons menu) ........ 127
Merge Multiple Edges, Worldspace option ............ 128
Merge Tolerance ...................................... 55
Merge UVs ............................................ 228
Merge UVs (Edit Polygons > Texture) ................. 228
Merge Vertex Tolerance (Mirror Cut option) ........ 75
Merge Vertex Tolerance (Smooth Proxy option) .... 81
Merge Vertices
  UVs merged ......................................... 110
  Merge Vertices (Edit Polygons menu) ............. 125

Polygonal Modeling

274
### Index

#### meshes
- about ........................................ 15
- clean up, simplify, validate .............. 153
- combine into one new mesh ............... 112
- combine using boolean operations ....... 113
- combine with a boolean operation ...... 114
- create single-faced ......................... 32
- proxy ........................................ 40, 82
- pushing and pulling ......................... 97
- pushing and pulling all at once .......... 100
- reduce number of faces ................. 153
- reshape with Sculpt Polygons tool .... 100
- select components .......................... 19
- separate polygon shells into .......... 113
- smooth in layers ........................... 83
- smoothing with a brush ................. 101
- storing rendering information with prelighting. .. 167
- transfer information between, with identical topology ........ 142
- transfer vertex positions, UVs, vertex color between ........ 136
- Min values .................................. 25
- Minimal Edge Length tessellation method .... 57
- Minimum length
  - Subdivide (edges) option .............. 129
- Mirror Behavior ............................ 79
- Mirror Cut, Polygons ...................... 74
- Mirror Direction ............................ 81
- Mirror Geometry (Polygons menu) ........ 72
- Mirror Geometry option .................... 46
- mirror half an object ....................... 46
- model
  - create and edit ............................ 32
  - half an object ............................ 46
  - rough, using .............................. 39
  - smoothed, map to ......................... 189
- modeling
  - customize .................................. 263
- Modeling menu set ......................... 103
- Move and Sew UVs (Edit Polygons > Texture) .... 227
- Move Component (Edit Polygons menu) ......... 83
- Move Edge options
  - for Move Component ...................... 85
- move polygons ............................. 34
- Move tool
  - in UV texture editor ...................... 212
- Move Vertex options
  - for Move Component ...................... 85
- multiply connected geometry .............. 15
- multitexturing ............................. 239

#### N
- neighbors
  - options for selection constraints .......... 27
- Next Selection constraint mode option .... 21
- non-contiguous normals .................... 16
- non-holed faces .............................. 24
- nonmanifold geometry
  - cleanup option ............................ 156
  - description ............................... 15
  - custom polygon display option .......... 164
  - description ............................... 16
  - Non-triangulable option ................... 24
- normalize
  - caps ........................................ 64
  - each face separately ...................... 64
  - texture option ............................ 67
  - texture option, creating new polygons .... 70
  - the whole object .......................... 63
- Normalize UVs (Edit Polygons > Texture) ........ 213

---

Polygonal Modeling
275
Index

n-sided
  select only ........................................ 23
Number U tessellation .................................. 58
Number V tessellation .................................. 58
numbers
displaying on components ................................ 165
NURBS
  convert to polygons ................................... 53
  convert to polygons (options) ....................... 55
tessellation methods .................................... 56

objects, make visible ..................................... 116
Offset
  Duplicate Face option ................................ 91
  Extract option ....................................... 131
  Move Component option ............................... 84
offset
  extracted surface .................................... 131
Offset Distance
  Polygon Bevel attribute .............................. 94
Offset Space ............................................ 93
Offset Type ............................................. 93
OnBorder selection constraint ......................... 22

operations, switching between .......................... 67
Optimize, automatic mapping option ...................... 194
Order selection constraint options ....................... 23
orientation
  option for selection constraints...................... 29
setting for polygonal primitives ....................... 63
Outliner
  access history of objects ................................ 116

P
  paint
    colors on vertices .................................. 170
    selection tool ...................................... 122
Paint Vertex Color Tool .................................. 174
painting
  out only the effects of previous stroke ............... 102
  over bumps .......................................... 98
  subdivide faces by ................................... 122
Percentage Space, automatic mapping option ............. 197
Pin Selected UVs relax UVs option ....................... 222
Pin Unselected UVs relax UVs option ...................... 222
Pin UV Border relax UVs option ........................ 222
Pin UVs relax UVs options ................................ 221
pivot point
  mirror polygons across ................................ 47
Plan selection constraint option ......................... 28
planar
  keeping faces ........................................ 263
  keeping polygons ...................................... 16
planarity
  constraints .......................................... 23
  ensuring ............................................. 69
  ensuring (option) .................................... 66
plane
  use to cut faces ..................................... 123
  use to project UVs ................................... 182
Planes option ........................................... 194
Point selection constraint option ....................... 28
points
  split line, constrain placement....................... 120
Poke Faces (Edit Polygons menu) .......................... 125
Poly Mirror Cut ........................................ 74
polyBevel node .......................................... 95
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>polyColorPerVertex node</td>
<td>172</td>
</tr>
<tr>
<td>Polygon Primitives (Create menu)</td>
<td>59</td>
</tr>
<tr>
<td>polygon tool settings</td>
<td>263</td>
</tr>
<tr>
<td>polygonal modeling</td>
<td></td>
</tr>
<tr>
<td></td>
<td>customize</td>
</tr>
<tr>
<td>polygonal object</td>
<td></td>
</tr>
<tr>
<td></td>
<td>see mesh</td>
</tr>
<tr>
<td>polygonal primitives</td>
<td></td>
</tr>
<tr>
<td></td>
<td>setting radius for</td>
</tr>
<tr>
<td></td>
<td>setting subdivisions for</td>
</tr>
<tr>
<td></td>
<td>setting width and height for</td>
</tr>
<tr>
<td>polygons</td>
<td></td>
</tr>
<tr>
<td></td>
<td>add blind data to</td>
</tr>
<tr>
<td></td>
<td>add colors</td>
</tr>
<tr>
<td></td>
<td>backculling display</td>
</tr>
<tr>
<td></td>
<td>beveling</td>
</tr>
<tr>
<td></td>
<td>coloring</td>
</tr>
<tr>
<td></td>
<td>component display</td>
</tr>
<tr>
<td></td>
<td>concave/convex</td>
</tr>
<tr>
<td></td>
<td>connect</td>
</tr>
<tr>
<td></td>
<td>convert NURBS to</td>
</tr>
<tr>
<td></td>
<td>convert NURBS to (options)</td>
</tr>
<tr>
<td></td>
<td>convert to triangles or quadrangles</td>
</tr>
<tr>
<td></td>
<td>copy UVs, colors, shaders between</td>
</tr>
<tr>
<td></td>
<td>create and reshape</td>
</tr>
<tr>
<td></td>
<td>create holes</td>
</tr>
<tr>
<td></td>
<td>delete vertices and edges</td>
</tr>
<tr>
<td></td>
<td>extrude in an arc (wedge)</td>
</tr>
<tr>
<td></td>
<td>introduction</td>
</tr>
<tr>
<td></td>
<td>invalid geometry</td>
</tr>
<tr>
<td></td>
<td>manipulate vertex normals to affect shading</td>
</tr>
<tr>
<td></td>
<td>map UVs onto automatically</td>
</tr>
<tr>
<td></td>
<td>mirror duplicate and merge</td>
</tr>
<tr>
<td></td>
<td>planar and non-planar</td>
</tr>
<tr>
<td></td>
<td>project UVs from a cylinder or sphere</td>
</tr>
<tr>
<td></td>
<td>project UVs from a plane</td>
</tr>
<tr>
<td></td>
<td>pull out from faces or edges</td>
</tr>
<tr>
<td></td>
<td>reshape with the Sculpt Polygons tool</td>
</tr>
<tr>
<td></td>
<td>reverse normals</td>
</tr>
<tr>
<td></td>
<td>sculpt tool</td>
</tr>
<tr>
<td></td>
<td>set polygon count</td>
</tr>
<tr>
<td></td>
<td>show count</td>
</tr>
<tr>
<td></td>
<td>smoothing methods</td>
</tr>
<tr>
<td></td>
<td>split into two or more faces</td>
</tr>
<tr>
<td></td>
<td>tessellation methods</td>
</tr>
<tr>
<td></td>
<td>texturing</td>
</tr>
<tr>
<td></td>
<td>transform</td>
</tr>
<tr>
<td></td>
<td>units, constrain selection</td>
</tr>
</tbody>
</table>
Index

Polygons menu
  Append to Polygon Tool.................................................. 68
  Average Vertices.......................................................... 71
  Booleans........................................................................... 125
  Cleanup............................................................................ 155
  Combine............................................................................ 124
  Create Polygon Tool.......................................................... 66
  Mirror Geometry.................................................................. 72
  Quadrangulate.................................................................... 143
  Reduce............................................................................... 157
  Smooth.............................................................................. 75
  Smooth Proxy..................................................................... 78
  Transfer............................................................................. 143
  Unmirror Smooth Proxy...................................................... 83

polyset
  see mesh........................................................................... 15

Post-normalize Normals attribute......................................... 147

prelighting........................................................................... 167
  a scene............................................................................. 171
  assigning colors to vertices............................................. 170
  options............................................................................ 175
  remove from vertices ..................................................... 172
  save to a texture map..................................................... 171

Pre-normalize Normals attribute........................................... 146

Preserve Aspect Ratio
  normalize UVs .................................................................. 214

Preserve Aspect Ratio, texture mapping setting....................... 65

Preserve Shape Detail map UV border options.......................... 218

primitives
  polygonal, setting axis (orientation) for............................ 63
  polygonal, setting subdivisions for.................................... 61
  polygonal, setting texture mapping for.............................. 63
  setting height and width for polygonal............................. 62
  setting radius for............................................................ 60
  setting texture mapping.................................................... 63

projection
  snap to best plane............................................................ 190
  snap to bounding box....................................................... 190
  snapping to faces............................................................ 190

Projection Center
  planar mapping option..................................................... 191
  spherical mapping option............................................... 193

Projection Height, spherical mapping option.......................... 194

Projection Horizontal Sweep, spherical mapping option............. 194

Projection Rotation, spherical mapping option......................... 194

Propagation selection constraint options............................... 30

Proxy Mesh In Layer option................................................. 82

Proxy Mesh Renderable........................................................ 82

proxy mesh, move............................................................... 40

Proxy Transparency option................................................... 82

pull a mesh......................................................................... 97

Pull brush stamp.................................................................. 104

push a mesh......................................................................... 97

Push brush stamp.................................................................. 104

Push Strength, smoothing setting.......................................... 78

pushing and pulling vertices with a brush............................... 100

Px, Py, Pz
  Selection Constraint option.............................................. 29
  selection constraint options............................................ 29

pyramid of polygons, create.................................................. 89

Q

quadrangles
  about............................................................................... 13
  convert polygons to......................................................... 135
  converting NURBS to....................................................... 128
  option for subdividing faces.......................................... 128
  select only......................................................................... 23
  split faces into................................................................. 120

Quadrangulate (Polygons menu)............................................. 143

R

Random
  Duplicate Face option...................................................... 92
  Move Component option................................................... 85
  selection constraint option.............................................. 29

random directions, duplicating faces...................................... 132

Ratio
  Selection Constraint option.............................................. 29

Reduce (Polygons menu)...................................................... 157

reference surface.................................................................. 97

reference vector
  setting, sculpting polygons............................................. 104

registration, check by projecting UVs.................................... 188

Relationship Editor............................................................. 245

Polygons menu
  Append to Polygon Tool...................................................... 68
  Average Vertices................................................................ 71
  Booleans............................................................................ 125
  Cleanup............................................................................ 155
  Combine............................................................................ 124
  Create Polygon Tool.......................................................... 66
  Mirror Geometry.................................................................. 72
  Quadrangulate.................................................................... 143
  Reduce............................................................................... 157
  Smooth.............................................................................. 75
  Smooth Proxy..................................................................... 78
  Transfer............................................................................. 143
  Unmirror Smooth Proxy...................................................... 83

polyset
  see mesh........................................................................... 15

Post-normalize Normals attribute........................................... 147

prelighting........................................................................... 167
  a scene............................................................................. 171
  assigning colors to vertices............................................. 170
  options............................................................................ 175
  remove from vertices ..................................................... 172
  save to a texture map..................................................... 171

Pre-normalize Normals attribute........................................... 146

Preserve Aspect Ratio
  normalize UVs .................................................................. 214

Preserve Aspect Ratio, texture mapping setting....................... 65

Preserve Shape Detail map UV border options.......................... 218

primitives
  polygonal, setting axis (orientation) for............................ 63
  polygonal, setting subdivisions for.................................... 61
  polygonal, setting texture mapping for.............................. 63
  setting height and width for polygonal............................. 62
  setting radius for............................................................ 60
  setting texture mapping.................................................... 63

projection
  snap to best plane............................................................ 190
  snap to bounding box....................................................... 190
  snapping to faces............................................................ 190

Projection Center
  planar mapping option..................................................... 191
  spherical mapping option............................................... 193

Projection Height, spherical mapping option.......................... 194

Projection Horizontal Sweep, spherical mapping option............. 194

Projection Rotation, spherical mapping option......................... 194

Propagation selection constraint options............................... 30

Proxy Mesh In Layer option................................................. 82

Proxy Mesh Renderable........................................................ 82

proxy mesh, move............................................................... 40

Proxy Transparency option................................................... 82

pull a mesh......................................................................... 97

Pull brush stamp.................................................................. 104

push a mesh......................................................................... 97

Push brush stamp.................................................................. 104

Push Strength, smoothing setting.......................................... 78

pushing and pulling vertices with a brush............................... 100

Px, Py, Pz
  Selection Constraint option.............................................. 29
  selection constraint options............................................ 29

pyramid of polygons, create.................................................. 89

Q

quadrangles
  about............................................................................... 13
  convert polygons to......................................................... 135
  converting NURBS to....................................................... 128
  option for subdividing faces.......................................... 128
  select only......................................................................... 23
  split faces into................................................................. 120

Quadrangulate (Polygons menu)............................................. 143

R

Random
  Duplicate Face option...................................................... 92
  Move Component option................................................... 85
  selection constraint option.............................................. 29

random directions, duplicating faces...................................... 132

Ratio
  Selection Constraint option.............................................. 29

Reduce (Polygons menu)...................................................... 157

reference surface.................................................................. 97

reference vector
  setting, sculpting polygons............................................. 104

registration, check by projecting UVs.................................... 188

Relationship Editor............................................................. 245
Relax UVs (Edit Polygons > Texture) .......... 221
Remove color attribute .......................... 173
Remove Geometry options ....................... 156
rendering assign colors to vertices ............ 170
storing information with prelighting .......... 167
Replace color attribute .......................... 173
Replace Zero Normals By attribute ............. 146
Resulting Color attribute ....................... 174
Reuse computed shadow maps, prelight option 177
reverse polygon normals ....................... 136
RGB values, clamp ................................ 178
Rotate Duplicate Face option ..................... 91
rotate polygons .................................. 34
Rotate UVs (Edit Polygons > Texture) .......... 216
Rotation Angle, Append to Polygon option .... 69
Roundness Bevel option, polygons ............. 95
smoothing setting ............................... 78

S
sample data, when prelighting .................... 177
incoming illumination only, prelight option ... 177
scale factor, prelight option ...................... 178
selected faces only, prelight option ............ 176
shading values (prelighting) ...................... 177
storage ........................................ 168
using face normals, prelight option ............ 176
save a state and then erase back to it ......... 101
Scale automatic mapping option ................. 195
Duplicate Face option ............................ 91
factor for prelighting ............................ 178
layout UVs option ................................ 225
Move Component option ......................... 84
polygons ....................................... 34
scenes prelight .................................. 171
Sculpt Polygons tool
about ............................................. 97
Edit Polygons menu .............................. 103
reshape polygons with ......................... 100
sculpting and construction history .............. 99
keyframing changes .............................. 103
setting variables ................................ 104
surfaces options ................................ 107
to an attribute map ............................... 102
secondary tessellation controls ................. 58
section radius of torus ........................... 60
Segments Bevel option, polygons ................. 95
select keep borders ................................ 77
mesh components ................................. 19
Select Contiguous Edges ......................... 20
Select Selection Boundary button ............... 30
Selected Vertex Color attribute ................. 174
selection constraints
angular ............................................ 27
convexity ........................................ 24
distance .......................................... 28
for faces ......................................... 22
gometry options25
holed/non-holed .................................. 24
length ............................................ 27
location .......................................... 21
mapped .......................................... 28
mapping .......................................... 24
modes ............................................ 21
Neighbors options for vertices and UVs ....... 27
orientation ........................................ 29
planarity .......................................... 23
polygonal units .................................. 25
propagation ....................................... 30
random ........................................... 29
shape of faces .................................... 23
smoothing ........................................ 22
topology .......................................... 24
visibility ......................................... 29
Separate (Edit Polygons menu) ................. 125
Separate Duplicate Faces option ................. 91

Polygonal Modeling

279

Index
Index

Separate layout UVs option ........................................ 224
Set Current UV Set (Edit Polygons > Texture) ............ 246
Set Individual Color Channels attribute ....................... 174
Set User Normal attribute ........................................ 147
Set Vertex Color Key ................................................ 171
Sew UVs (Edit Polygons > Texture) ............................ 226
shaders assign default during UV projection to check registration .................................................. 188
copy between polygons ............................................. 211
shading affect by manipulating normals ....................... 139
storing information with prelighting ............................. 167
shadow maps compute, for prelighting ........................... 176
re-use, for prelighting ................................................ 177
shadows, creating ..................................................... 14
Shape Detail map UV border option ............................ 218
Share Transform Node ................................................ 81
shared vertex, split into multiple ................................. 117
Shell selection constraint option ................................. 30
shells about .................................................................. 15
select from UV components ....................................... 199
separate into individual meshes ................................. 113
short name for attributes .............................................. 260
Shrink Selection Region button ................................. 21
Signed options for selection constraints ....................... 28
single-faced polygon mesh, create ............................. 32
Smart Command Settings description ............................ 266
Smart Fit cylindrical, spherical mapping toggle .......... 192
planar mapping toggle ............................................... 190
snapping projection .................................................. 192
spherical mapping option ........................................... 193
smooth by adding polygons ........................................ 37
Smooth (Polygons menu) ............................................ 75
Smooth brush stamp .................................................. 104
Smooth Layer Display option ..................................... 83
smooth mesh
map UVs onto .......................................................... 40
Smooth Mesh In Layer option .................................... 83
Smooth Proxy (Polygons menu) ................................. 78
Smooth Proxy (Polygons menu) smooth proxy, set up ................................. 39
smoothed model
map to ......................................................... 189
smoothing by adding polygons .................................... 37
constraint properties ................................................... 22
degree of ..................................................................... 76
increasing ................................................................... 76
linear controls ............................................................ 77
methods ..................................................................... 31
Sculpt Surfaces Tool .................................................... 98
setting automatic ...................................................... 104
using rough model .................................................... 39
snapshot save of the UV layout, to paint on ................. 210
soften vertex normals ............................................... 148
Space
layout UVs option .................................................... 226
Spacing Presets, automatic mapping option .................. 196
sphere use to project UVs ............................................. 185
Split Polygon Tool (Edit Polygons menu) .................... 129
splitting faces by drawing a line ................................... 119
shared vertex ........................................................... 117
Standard Fit tessellation method ................................. 56
Stopping Conditions relax UVs options ....................... 222
storage of samples .................................................... 168
straighten out borders ............................................... 209
Straighten UV Border (Edit Polygons > Texture) ........ 219
Stretch to fit, texture mapping setting ........................ 65
Subdivide (Edit Polygons menu) .................................. 128
subdivide faces by painting ........................................ 122
Subdivision Levels linear controls ................................. 78
Smooth option, polygons ........................................... 76
subdivide polygons option .......................................... 128

Polygonal Modeling

280
Subdivisions
Append to Polygon option .................. 68
Append to Polygon Tool option ............. 71
Create Polygon Tool option ................ 66
setting for polygonal primitives ........... 60
Split Polygon Tool option .................. 129
Subdivisions along Depth option ........... 62
Subdivisions Axis option ................. 61
Subdivisions Height option ............... 61
Subdivisions on Caps option ............. 62
Subtract color attribute .................... 173
surfaces
density, for sculpt tool .................... 99
erase changes .............................. 98
erase, sculpting polygons .................. 107
options for Sculpt Polygon Tool .......... 107
reference .................................... 97
switching between operations .............. 67

tessellation methods
3D Delta .................................... 57
about ...................................... 56
Chord Height Ratio .......................... 56
cleanup option ............................... 155
Control Points ............................... 59
Count ........................................ 59
Edge Swap toggle ............................ 58
Fractional Tolerance ......................... 57
General ...................................... 57
Minimal Edge Length ......................... 57
Number U and Number V ..................... 58
secondary controls ......................... 58
smoothing setting ........................... 77
Standard Fit ................................ 56
U and V Type ................................ 58
text file, export template to ................ 251
texture
assign to a UV set ......................... 244
Insert Before Deformer option ............ 190
show image .................................. 201
Texture (Edit Polygons menu) ............. 189
texture border
keep when quadrilaterating polygons ...... 143
texture coordinates
displaying .................................... 165
setting ........................................ 67
setting for appending to polygons ........ 70
texture mapping
for primitive planes ......................... 64
options for polygonal primitives .......... 63
save prelighting ............................. 171
setting for polygonal primitives .......... 63
turning off .................................. 65
texture pieces
sort out overlapping ......................... 207
texture placement
flip ......................................... 211
Texture View (See UV Texture Editor) .... 179
texturing polygons ......................... 179
toolbox
in UV texture editor ....................... 212
topology
constraints .................................. 24
identical, transfer vertex information between meshes ........... 142
torus settings ................................ 60
Transfer (Polygons menu) .................. 143
transform polygons .......................... 34
Translate
along normal when moving components ... 85
Duplicate Face option ....................... 91
Move Component option .................... 84
transparency, proxy ......................... 82
triangles
about ....................................... 13
convert polygons to ......................... 135
converting NURBS to ....................... 55
flip edges ................................... 135
option for subdividing faces .............. 128
select only .................................... 23
split faces into ............................ 120

Polygonal Modeling
281
triangulatable faces ........................................ 24

twist of torus .................................................. 60

Type Editor ................................................... 259

U

U Type tessellation method .............................. 58

Union (Boolean operation) ............................... 125

Unitize

  texture option ............................................. 67
  texture option, creating new polygons .............. 70
  UVs (Edit Polygons > Texture) ......................... 214

units

  polygonal, constrain selection ....................... 25

Unmirror Direction ......................................... 83

Unmirror Smooth Proxy (Polygons menu) ............. 83

Unsigned options for selection constraints ........... 28

untangle border UVs ........................................ 208

UV components

  select .................................................... 199

UV mapping .................................................. 179

UV sets ...................................................... 239

  assign textures to .................................... 244
  copy UVs to another .................................... 245
  create .................................................... 243
  for a layered texture ................................... 241
  manage multiple .......................................... 243
  switch between ........................................... 243

UV Texture Editor

  about ...................................................... 181
  controls .................................................. 229
  edit UVs .................................................. 199
  set up display ........................................... 200
  set up grid and snapping ............................... 204
  show texture image ...................................... 201
  transform UVs .............................................. 204

UVs

  and Merge Vertices ..................................... 110
  and merging edges ....................................... 128
  arranging .................................................. 181
  copy between polygons ................................... 211
  delete ...................................................... 211
  displaying ................................................ 165
  edit visually ............................................. 199
  flip or rotate to flip texture placement ............. 211
  map onto polygons automatically ...................... 186
  map onto smooth mesh .................................. 40
  mapping .................................................... 179
  normalize, collectively ................................ 213
  normalize, per-face ...................................... 214
  normalize, preserve aspect ratio ...................... 214

  project onto polygons from a cylinder or sphere ... 185

  project onto polygons from a plane .................... 182

  project to check registration ........................... 188
  save snapshot of layout ................................ 210
  separate and attach pieces .............................. 206
  set angular selection constraints for ................ 27
  set selection constraints for ........................... 27
  setting .................................................... 67
  show a subset ............................................. 202
  show those with the current image assigned .......... 203
  spread out and untangle ................................ 210
  transfer between meshes ................................ 136
  transform in the UV texture editor .................... 204
  untangle border .......................................... 208

V

V Type tessellation ......................................... 58

variables

  for sculpting ............................................. 104

Vertex Normal Edit Tool ................................ 144
vertices
about ................................................. 13
animate colors ........................................ 171
append to polygon option, Attribute Editor ........ 71
assign color ........................................... 169
assign color by painting ................................ 170
assign rendered colors ................................ 170
average normals ....................................... 141
collapse edges or faces into .......................... 110
controlling movement with reference vector ......... 104
create polygon tool option ............................ 68
delete ................................................... 151
delete unwanted ........................................ 151
extrude .................................................. 45, 89
keyframing ............................................. 103
make colors visible ..................................... 168
manipulate normals to affect shading ................. 139
merge .................................................... 109
move along their normals ................................ 37
normals .................................................. 14
pushing and pulling with a brush ....................... 100
remove colors and prelighting ........................ 172
removing ................................................. 52
set angular selection constraints for .................. 27
set normals ............................................. 145
set selection constraints for ............................ 27
soften/harden normals .................................. 148
split into multiple ...................................... 117
storing color information with prelighting .......... 167
switch display .......................................... 164
transfer information between meshes with
identical topology ...................................... 142
transfer positions (shape) or color between
meshes .................................................... 136
winged .................................................... 152
View, Sculpt Polygon Tool option ...................... 105
Visibility
options for selection constraints ....................... 29
visible, make an input object .......................... 116
visualize blind data .................................... 252
Vx, Vy, Vz selection constraint options ............... 29
W
Wedge Angle, Wedge Faces setting ...................... 90
Wedge Faces (Edit Polygons menu) .................... 90
wedge, extrude polygons in ............................ 46
width, setting for polygonal primitives ................. 62
winged vertices ......................................... 152
wireframe outlines, keeping ........................... 166
World Space Coords
and merging multiple edges ........................... 128
duplicating faces option ............................... 92
when beveling polygons ............................... 95
when moving components ............................. 85
when quadrangulating polygons ....................... 143
when subdividing polygons ........................... 129
X
X Axis, Sculpt Polygon Tool option ..................... 105
Y
Y Axis, Sculpt Polygon Tool option ..................... 105
Z
Z Axis, Sculpt Polygon Tool option ..................... 106