Paint Effects, Artisan, and 3D Paint

Version 6
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>1  Painting in Maya</strong></td>
<td>17</td>
</tr>
<tr>
<td>About</td>
<td></td>
</tr>
<tr>
<td>Paint Effects, Artisan and 3D Paint</td>
<td>17</td>
</tr>
<tr>
<td>Painting in Maya</td>
<td>17</td>
</tr>
<tr>
<td>Maya Paint Effects</td>
<td>17</td>
</tr>
<tr>
<td>Artisan Brush Tools</td>
<td>17</td>
</tr>
<tr>
<td>3D Paint Tool</td>
<td>17</td>
</tr>
<tr>
<td>The paint tools</td>
<td>17</td>
</tr>
<tr>
<td>Paint Effects Tool</td>
<td>18</td>
</tr>
<tr>
<td>3D Paint Tool</td>
<td>18</td>
</tr>
<tr>
<td>Paint Selection Tool</td>
<td>18</td>
</tr>
<tr>
<td>Sculpt Surfaces Tool (for NURBS surfaces)</td>
<td>18</td>
</tr>
<tr>
<td>Sculpt Polygons Tool</td>
<td>18</td>
</tr>
<tr>
<td>Paint Vertex Color Tool (for polygons only)</td>
<td>18</td>
</tr>
<tr>
<td>Paint Scripts Tool</td>
<td>19</td>
</tr>
<tr>
<td>Paint Attributes Tool</td>
<td>19</td>
</tr>
<tr>
<td>Paint Cluster Weights Tool</td>
<td>19</td>
</tr>
<tr>
<td>Paint Jiggle Weights Tool</td>
<td>19</td>
</tr>
<tr>
<td>Paint Set Membership Tool</td>
<td>19</td>
</tr>
<tr>
<td>Paint Skin Weights Tool</td>
<td>19</td>
</tr>
<tr>
<td>Paint Soft Body Weights Tool</td>
<td>19</td>
</tr>
<tr>
<td>Paint Cloth Properties Tool (Maya Unlimited only)</td>
<td>20</td>
</tr>
<tr>
<td>Paint Collision Properties Tool (Maya Unlimited only)</td>
<td>20</td>
</tr>
<tr>
<td>Paint Fur Attributes Tool (Maya Unlimited only)</td>
<td>20</td>
</tr>
<tr>
<td>Paint Fluids Tool (Maya Unlimited only)</td>
<td>20</td>
</tr>
<tr>
<td>Paint Hair Tool (Maya Unlimited only)</td>
<td>20</td>
</tr>
<tr>
<td><strong>2  Maya Paint Effects</strong></td>
<td>23</td>
</tr>
<tr>
<td>About</td>
<td></td>
</tr>
<tr>
<td>Paint Effects, Artisan and 3D Paint</td>
<td>23</td>
</tr>
<tr>
<td>Paint Effects Overview</td>
<td>23</td>
</tr>
<tr>
<td>How the Paint Effects Tool works</td>
<td>24</td>
</tr>
</tbody>
</table>
Table of Contents

How do I?

Paint 2D and 3D objects in Maya ........................................... 27
Prepare to use Paint Effects ............................................. 27
Load Paint Effects ......................................................... 28
Load the Paint Effects shelf .......................................... 28
Save preset brushes to shelves ....................................... 29
Define Paint Effects hotkeys .......................................... 30

3 Painting in 2D .............................................................. 33

About

Paint Effects, Artisan and 3D Paint ................................. 33
Painting in 2D ............................................................. 33

How do I?

Paint 2D and 3D objects in Maya ........................................... 34
Paint in 2D ................................................................. 34
Display the Paint Effects canvas .................................... 34
Set up the canvas ......................................................... 35
Set the canvas size ....................................................... 35
Set canvas globals ......................................................... 35
Paint on the canvas ....................................................... 36
Flip Tube Direction ........................................................ 37
Erase paint from the canvas .......................................... 38
Smear and blur paint on the canvas ................................. 39
Paint pixels ................................................................... 40
Clear the canvas ............................................................ 41
Zoom and track ............................................................. 41
Create new images ......................................................... 42
Create seamless repeating textures ............................... 42
Roll the canvas ............................................................. 43
Modify textures applied to surfaces ................................ 45
Paint on existing images and textures ............................. 47
Save images ................................................................. 48
Table of Contents

Set save options ................................................. 49
Save after every stroke .................................... 49

Reference

Menus ......................................................... 50
Rendering menu set ....................................... 50
Paint Effects ................................................. 50
Paint Effects > Flip Tube Direction ................. 50
Paint Effects > Paint Effects Globals .......... 50
Canvas ....................................................... 50

4 Painting in 3D ............................................... 53

About

Paint Effects, Artisan and 3D Paint ............... 53
Painting in 3D ................................................. 53

How do I?

Paint 2D and 3D objects in Maya .................. 55

Paint in 3D .................................................. 55
Set up to paint in 3D .........................................
  Define global scene settings ......................... 55
  Define default stroke settings .................... 55
  Make the brush respond to stylus pressure ... 56
Paint in 3D ..................................................
  Paint in the modeling view ......................... 56
  Render strokes as you paint ...................... 57
  Paint on the grid plane of the perspective view 62
  Paint on objects ......................................... 63
  Paint on the view plane ............................. 66
  Reverse surface normals ............................ 68
Select which UV set to use for Paint Effects (polygons only) ... 69
Automatically paint multiple strokes on a surface .... 69

Modify existing strokes .................................. 70
  Modify stroke settings for existing strokes ... 71
  Copy brush settings from existing strokes to the template brush 73
  Apply brush settings to strokes .................... 74
  Make strokes share the same brush ............... 75
  Simplify stroke path curves ....................... 76
# Table of Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the shape of a stroke</td>
<td>76</td>
</tr>
<tr>
<td>Modify stroke pressure values interactively</td>
<td>78</td>
</tr>
<tr>
<td>Erase, smear, and blur paint</td>
<td>79</td>
</tr>
<tr>
<td>Select strokes</td>
<td>81</td>
</tr>
<tr>
<td>Delete strokes</td>
<td>82</td>
</tr>
<tr>
<td>Attach brushes to curves</td>
<td>82</td>
</tr>
<tr>
<td>Modify tube behavior using control curves</td>
<td>83</td>
</tr>
<tr>
<td>Hide and show strokes and curves</td>
<td>84</td>
</tr>
<tr>
<td>Modify stroke display quality</td>
<td>85</td>
</tr>
<tr>
<td>Convert Paint Effects to polygons</td>
<td>86</td>
</tr>
<tr>
<td>Optimizing Paint Effects Mesh quality</td>
<td>86</td>
</tr>
</tbody>
</table>

## Reference

**Menus**                                                                 | 87   |
**Rendering menu set**                                                  | 87   |
**Paint Effects**                                                        | 87   |
  * Paint Effects > Paint Effects Globals                                 | 87   |
  * Scene                                                                | 87   |
  * Paint Effects > Paint Effects Tool                                   | 89   |
     * Paint Effects > Paint Effects Tool > On                                                                 | 89   |
  * Paint Effects > Make Paintable                                       | 91   |
  * Paint Effects > Paint on Paintable Objects                           | 91   |
  * Paint Effects > Paint on View Plane                                  | 91   |
  * Paint Effects > Apply Settings to Last Stroke                        | 91   |
  * Paint Effects > Apply Settings to Selected Strokes                   | 91   |
  * Paint Effects > Get Settings from Selected Stroke                    | 92   |
  * Paint Effects > Share One Brush                                      | 92   |
  * Paint Effects > Remove Brush Sharing                                  | 92   |
  * Paint Effects > Select Brush/Stroke Names Containing                  | 92   |
  * Paint Effects > Auto Paint > Paint Grid                              | 92   |
     * Paint Effects > Auto Paint > Paint Grid > On                      | 92   |
  * Paint Effects > Auto Paint > Paint Random                            | 93   |
     * Paint Effects > Auto Paint > Paint Random > On                    | 94   |
  * Paint Effects > Curve Utilities > Simplify Stroke Path Curves         | 95   |
  * Paint Effects > Curve Utilities > Set Stroke Control Curves          | 95   |

Paint Effects, Artisan, and 3D Paint
6
Table of Contents

Paint Effects > Curve Utilities > Attach Brush to Curves  .......... 95
Paint Effects > Curve Utilities > Make Pressure Curve .......... 95
Paint Effects > Curve Utilities > Make Pressure Curve > ☐ .......... 95
Paint Effects > Paint Effects Mesh Quality .......................... 96
Modify ................................................................. 96
Modify > Convert > Paint Effects To Polygons ................. 96
Modify > Convert > Paint Effects To Polygons > ☐ .......... 96
Nodes ................................................................. 97
stroke Shape node .................................................. 97
Related topics ....................................................... 97
End Bounds ......................................................... 100
Normal Direction ................................................ 100
Pressure Mappings ................................................ 100
Input Curves ....................................................... 101
Mesh Output ....................................................... 101

5 Painting in the Paint Effects Panel .............................. 103
About
Paint Effects, Artisan and 3D Paint .......................... 103
Painting in the Paint Effects Panel ........................... 103
How do I?
Paint 2D and 3D objects in Maya ............................ 103
Paint in the Paint Effects panel ............................. 103
Switch between views ......................................... 103
Show and hide the Paint Effects panel toolbar ............. 104
Canvas toolbar ................................................... 105
Scene painting view toolbar .................................. 105
Save a snapshot of the Paint Effects panel view ............... 105
Save depth as grayscale values ................................ 106
Change the Brush Type ........................................ 107
Change the panel lighting ...................................... 107
Display RGB, luminance, or alpha channels .................. 107
Switch between a stylus and the mouse .................... 109

6 Working with brushes ............................................ 111
# Table of Contents

## About

**Paint Effects, Artisan and 3D Paint** .......................... 111

- Working with brushes .................................................. 111

## How do I?

**Paint 2D and 3D objects in Maya** ................................. 111

- **Work with brushes** .................................................... 111
  - Select preset brushes ................................................ 111
  - Define template brush settings .................................... 112
    - Select the brush type .............................................. 113
    - Set the global scale .............................................. 116
    - Set which channels are created and modified ................... 117
    - Set the brush profile ............................................ 117
    - Set Thin Line Multi Streaks ....................................... 117
    - Set mesh attributes .............................................. 117
    - Set shading attributes .......................................... 119
    - Set tube shading attributes ..................................... 120
    - Map textures to color and opacity ................................ 120
    - Illuminate stroke paint .......................................... 120
    - Create shadows and shading ...................................... 120
    - Make paint glow .................................................... 122
    - Create tubes ........................................................ 122
    - Define growth behavior .......................................... 123
    - Map value ranges to tube length .................................. 125
    - Use MEL scripts to apply custom effects ......................... 125
    - Create gaps in tubes .............................................. 126
    - Set flow animation attributes .................................... 127
    - Reset the template brush .......................................... 127
    - Create new brush presets ......................................... 127
    - Modify brush settings for existing strokes ....................... 129
    - Select brushes in your scene ...................................... 129
    - Map file textures to color and opacity .......................... 130
    - Blend preset brush settings ...................................... 133

## Reference

**Menus** ................................................................. 134

- **Rendering menu set** .............................................. 134
- **Paint Effects** ...................................................... 134

---

Paint Effects, Artisan, and 3D Paint

8
# Table of Contents

Paint Effects > Get Brush ............................................. 134  
Paint Effects > Template Brush Settings .......................... 135  
Paint Effects > Reset Template Brush ............................ 135  
Paint Effects > Preset Blending .................................... 135  
Paint Effects > Save Brush Preset ................................. 135  

**Windows and Editors** ............................................ 135

**Paint Effects Brush Settings** .................................. 135
Paint Effects Brush Settings ........................................ 135  
Channels ..................................................................... 137  
Brush Profile ................................................................ 138  
Thin Line Multi Streaks. .............................................. 141  
Mesh ......................................................................... 142  
Thorns on Mesh .......................................................... 143  
Mesh Environment Reflections ...................................... 144  
Shading ....................................................................... 144  
Tube Shading ............................................................... 146  
Texturing ..................................................................... 148  
Illumination .................................................................. 154  
Shadow Effects ............................................................ 156  
Glow .......................................................................... 158  
Tubes ......................................................................... 159  
Creation ...................................................................... 160  
Growth ....................................................................... 166  
Behavior ..................................................................... 187  
Displacement ............................................................... 187  
Forces ........................................................................ 191  
Turbulence .................................................................... 195  
Spiral .......................................................................... 196  
Bend ........................................................................... 197  
Twist .......................................................................... 197  
Length Mappings .......................................................... 198  
User MEL Scripts .......................................................... 199  
Gaps .......................................................................... 199
Table of Contents

7 Animating strokes ............................................. 205

How do I?

Paint 2D and 3D objects in Maya ......................... 205

Animate strokes ........................................... 205

Add spring behavior to strokes with tubes. ............ 205

Keyframe brush and stroke attributes. .................. 206

Animate tube growth, gaps, twist, and textures ...... 207

Animate the flow of gaps, twist, and/or textures ...... 207

Animate uniform tube growth ............................ 208

Animate the growth simulation ......................... 210

Animate tube death ........................................ 212

Animate the stroke path ................................... 213

Make tubes react to forces .............................. 214

Use brush settings to make tubes react to forces .... 214

Use control curves to make tubes react to forces .... 215

Create animated textures ................................. 215

Animate textures on strokes ............................. 216

Loop brush animations ..................................... 217

Reference

Menus ......................................................... 217

Rendering menu set ................................... 217

Paint Effects ............................................. 217

Paint Effects > Brush Animation > Bake Spring Animation .......................... 217

Paint Effects > Brush Animation > Bake Spring Animation .......................... 218

Paint Effects > Brush Animation > Make Brush Spring ......................... 218

Paint Effects > Brush Animation > Make Brush Spring ......................... 218

Paint Effects > Brush Animation > Loop Brush Animation .................. 218

Paint Effects > Brush Animation > Loop Brush Animation .................. 219

8 Paint Effects samples and techniques ................ 221

How do I?

Paint 2D and 3D objects in Maya ......................... 221

Create useful effects with Paint Effects .............. 221

Animate rain effects ...................................... 221
Table of Contents

Animate a plant growing up a column ........................................ 222
Animate a starfield ................................................................. 225
Create textures from painted 3D objects ................................. 226
Work on an animation project .................................................. 227

9 Rendering scenes with Paint Effects strokes ......................... 229

How do I? Paint 2D and 3D objects in Maya ....................... 229
Render scenes with Paint Effects ........................................... 229
Prepare to render ..................................................................... 229
Light the scene ........................................................................ 229
Set up the camera you are rendering from .............................. 230
Set the properties of rendered images ..................................... 231
Set up to render Paint Effects strokes ................................... 231
Render scenes with Paint Effects strokes ............................... 232
Render a scene with Paint Effects strokes ............................... 232
Create a composite of Paint Effects strokes and your scene .... 233

Reference
Windows and Editors ............................................................. 234
Render Global Settings window ................................................. 234
Paint Effects Rendering Options ............................................. 234

10 Troubleshooting ................................................................. 237

What went wrong? Troubleshooting Paint Effects ..................... 237
Painted strokes appear too dark ............................................. 237
Tubes appear too small in the scene ....................................... 237
Rendered strokes are made up of circles ................................. 237
Tubes appear jagged or segmented across curved sections .... 237
Feedback does not reflect rendered image ............................... 237
Canvas clears to black even though you changed the canvas color  . 237
Brush stroke appears to “leak” through joined edges of surface ... 238
The Global Scale brush setting appears to be ignored .......... 238
You attempt to share a brush, but the wrong brush is shared ... 238
Stroke texture colors do not match colors set for the texture ...... 238
Your Wacom stylus and tablet have no pressure sensitivity .... 238

Paint Effects, Artisan, and 3D Paint 11
# Table of Contents

You install a new tablet but Paint Effects doesn’t recognize it . . . . . . 239
Painted strokes look nothing like the selected brush preset. . . . . . . . 239
Tube growth and texture flow appear out of sync. . . . . . . . . . . . . . . . 239
You set a Start Time for your flow animation but tubes don’t appear. 239
A fringe appears around geometry where it overlaps with a stroke . . . . 240
You modify a texture applied to a surface, but the surface doesn’t update 240
The alpha plane for the scene painting view appears white. . . . . . . . 240
You attempt to paint on a surface but the stroke paints on the view plane 240
Strokes take a very long time to render . . . . . . . . . . . . . . . . . . . . . . . . 240
Strokes do not appear in raytraced reflections and refractions . . . . . 241
Paint Effects strokes render in the wrong order relative to other objects in 241
the scene . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 241
Staircased mesh brushes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 242
No shadows appear when only paint effects casts shadows . . . . . . . 242
Incorrect object shadows and self shadows onto paint effects. . . . . . 242

## 11 Using Artisan brush tools ........................................... 245

### About

Paint Effects, Artisan and 3D Paint .................................. 245
Using Artisan brush tools ............................................. 245
How Artisan brush tools work ......................................... 247
About Artisan brushes .................................................. 248
About brush values ...................................................... 249
About brush operations .................................................. 249

### How do I?

Paint 2D and 3D objects in Maya ................................. 249
Use Artisan brush tools ............................................... 249
Paint strokes ......................................................... 249
Snap an Artisan paint brush to an isoparm (NURBS surfaces only) . 250
Flood paint ............................................................. 251
Paint reflected .......................................................... 251
Restrict an area for painting ........................................ 252
Map attributes ........................................................ 253
Import attribute maps ................................................ 254
Table of Contents

Export attribute maps .............................................. 256
Set stylus pressure ............................................. 257
Change the brush outline color ................................. 257
Create an Artisan tool shelf ................................. 257
Define Artisan hotkeys ........................................ 258
Default hotkeys ................................................ 258
Use Artisan marking menus .................................. 260

12 Painting with MEL scripts and the Paint Scripts Tool .... 261

About

Paint Effects, Artisan and 3D Paint ...................... 261
Painting with MEL scripts and the Paint Scripts Tool .... 261
Painting with MEL scripts and the Paint Scripts Tool .......................................... 261
Related topics ............................................... 261
Overview of MEL script painting ............................. 261
Related topics ............................................... 262

How do I?

Paint 2D and 3D objects in Maya ............................. 262
Paint with MEL scripts and the Paint Scripts Tool .... 262
Script paint .................................................. 262
Paint Scripts Tool settings ................................ 264
Related topics ............................................... 264
Script paint on restricted surface areas ................... 264
Flood surfaces .............................................. 265
Write MEL Scripts for the Paint Scripts Tool .......... 265
Script Paint MEL procedures ................................. 265
Example Script Paint script ................................ 272

Reference

Menus .......................................................... 280
Modify ......................................................... 280
Modify > Paint Scripts Tool .................................. 280
Modify > Paint Scripts Tool >  ................................ 280
gometryPaint sample script settings ........................ 282
emitterPaint sample script settings ........................ 285

13 Painting attribute values ..................................... 289
# Table of Contents

## About
- **Paint Effects, Artisan and 3D Paint** ........................................... 289
- Painting attribute values ................................................................. 289
  - Related topics. .............................................................................. 289

## How do I?
- **Paint 2D and 3D objects in Maya** .................................................... 289
  - Paint attribute values ................................................................. 289
  - Paint attributes ............................................................................ 289
  - Restrict an area for painting. ......................................................... 290
  - Flood surfaces .............................................................................. 291
  - Map attributes .............................................................................. 291
  - Set Paint Attributes Tool settings ............................................... 291
  - Make an attribute paintable ........................................................... 291
  - Register a paintable attribute ......................................................... 292

## Reference
- **Menus** ............................................................................................ 293
- **Modify** .......................................................................................... 293
  - Modify > Paint Attributes Tool ..................................................... 293
    - Modify > Paint Attributes Tool > □ ......................................... 293
  - Paint Attributes ............................................................................ 293

## 14 Artisan Brush Tool Settings ............................................................... 297

### About
- **Paint Effects, Artisan and 3D Paint** ............................................. 297
  - Artisan Brush Tool Settings ............................................................ 297

### How do I?
- **Paint 2D and 3D objects in Maya** .................................................. 299
  - Reset Artisan brush tools ................................................................ 299

### Reference
- **Windows and Editors** ................................................................. 299
  - **Artisan Tool Settings editor** ....................................................... 299
    - Common Artisan Brush Tool Settings .......................................... 299
      - Brush section .......................................................................... 300
      - Stroke section .......................................................................... 301
      - Stylus Pressure section ............................................................ 303
      - Attribute Maps section ............................................................ 304
      - Display section ....................................................................... 305

## 15 Using the 3D Paint Tool ................................................................. 311

---

Paint Effects, Artisan, and 3D Paint

14
Table of Contents

Index ................................................................. 339
1 Painting in Maya

About

Painting in Maya
An extremely powerful feature in Maya is the ability to paint—paint textures, paint growing effects, paint to select, paint weights, paint set memberships, paint skin weights, paint vertex color, paint scripts, paint cloth properties, paint fur attributes, paint to sculpt surfaces, and more—the list gets larger with each release of Maya. Maya’s paint tools provide an intuitive, efficient way to get your work done.

This book describes how to paint in Maya. It’s divided into the following parts:

Maya Paint Effects
Paint Effects is a unique paint technology that lets you use brushes to paint real-time rendered strokes onto or between 3D objects or onto a 2D canvas. See “Paint Effects Overview” on page 23.

Artisan Brush Tools
Artisan is a set of brush tools with a common interface. The tools use an intuitive paint and sculpting-based interface to deliver high quality and otherwise complex results in minimal time. See “Using Artisan brush tools” on page 245.

3D Paint Tool
The 3D Paint Tool is a tool you can use to paint textures for renderable attributes such as color, bump, transparency, and specular color, on polygons, NURBS, and subdivision surfaces. You can also paint on existing file textures assigned to your objects. It’s a hybrid of Artisan and Paint Effects. See “Painting renderable attributes on 3D objects” on page 311.

To get started quickly using Maya’s paint features, see the Painting lessons in the Getting Started with Maya tutorials.

The paint tools
In Maya, there are several paint tools that all work like paint brushes. Typically, you create your model in Maya, then paint with these tools to detail and modify it. If you have a graphics tablet and stylus, you can use them for greater control when you paint.
Paint Effects Tool
Use the Paint Effects Tool to paint strokes on a 2D canvas to create 2D images or textures, or to paint strokes in a scene to create paint effects in true 3D space. The Paint Effects Tool works differently from the Artisan brush tools. ((Rendering menu set, Paint Effects > Paint Effects Tool)

3D Paint Tool
Use the 3D Paint Tool (Rendering menu set, Texturing > 3D Paint Tool) to paint texturable attributes, for example, color, transparency, incandescence, bump, specular color, reflectivity, ambience, diffusion, translucence, and reflected color. This tool operates similarly to other Artisan paint tools; however, some tool settings are unique, such as Blend Mode. For details, see “Using the 3D Paint Tool” on page 311.

Paint Selection Tool
Use the Paint Selection Tool (Edit > Paint Selection Tool) to select vertices by painting on the surface with the tool. This control quickly provides results that previously required painstaking manipulation of individual components. You can use the Paint Selection Tool to select faces and edges on polygons and subdivision surfaces. For details, see the online Basics guide. You can also use it to perform polygonal editing. For details, see the Polygonal Modeling guide.

Sculpt Surfaces Tool (for NURBS surfaces)
Use the Sculpt Surfaces Tool (Modeling menu set, Edit NURBS > Sculpt Surfaces Tool) to push and pull CVs on a NURBS surface. The effect is like sculpting clay—push and the surface depresses, pull and the surface raises. For details, see the NURBS Modeling guide.

Sculpt Polygons Tool
Use the Sculpt Polygons Tool (Modeling menu set, Edit Polygons > Sculpt Polygons Tool) to push and pull vertices on a polygonal surface. The effect is similar to sculpting clay. For details, see the Polygonal Modeling guide.

Paint Vertex Color Tool (for polygons only)
Use the Paint Vertex Color Tool (Modeling menu set, Edit Polygons > Colors > Paint Vertex Color Tool) to paint a specified color value and alpha onto polygon vertices. For details, see the Polygonal Modeling guide.
Paint Scripts Tool
Use the Paint Scripts Tool (Modify > Paint Scripts Tool) to paint a surface with an attribute defined in a Maya MEL script. For example, you can paint particle emitters on your surfaces like you would paint a color or texture in a painting program. Maya includes sample MEL paint scripts to apply to your surfaces. For details, see “Painting with MEL scripts and the Paint Scripts Tool” on page 261.

Paint Attributes Tool
Use the Paint Attributes Tool (Modify > Paint Attributes Tool) to paint any registered attributes on any object. For details, see “Painting attribute values” on page 289.

Paint Cluster Weights Tool
Use the Paint Cluster Weights Tool (Animation menu set, Deform > Paint Cluster Weights Tool) to paint weights on vertex clusters. For details, see the Character Setup guide.

Paint Jiggle Weights Tool
Use the Paint Jiggle Weights Tool (Animation menu set, Deform > Paint Jiggle Weights Tool) to paint jiggle weights on vertex clusters. For details, see the Character Setup guide.

Paint Set Membership Tool
Use the Paint Set Membership Tool (Animation menu set, Deform > Paint Set Membership Tool) to paint the set membership of vertices instead of individually selecting them. For details, see the Character Setup guide.

Paint Skin Weights Tool
By smooth binding skin to an object, you can create skin-like deformations. In effect, all the vertices belong to all the joint clusters. Use the Paint Skin Weights Tool (Animation menu set, Skin > Edit Smooth Skin > Paint Skin Weights Tool) to modify the weights of these clusters at the joints. For details, see the Character Setup guide.

Paint Soft Body Weights Tool
Use the Paint Soft Body Weights Tool (Dynamics menu set, Soft/Rigid Bodies > Paint Soft Body Weights Tool) to set the goal weights on a soft body by painting on the soft body surface. For details, see the Dynamics guide.
Painting in Maya | 1

The paint tools >

Paint Cloth Properties Tool (Maya Unlimited only)
Use the Paint Cloth Properties Tool (Cloth menu set, Simulation > Properties > Paint Cloth Properties Tool) to paint cloth property values on an area of cloth. For details, see the Cloth guide.

Paint Collision Properties Tool (Maya Unlimited only)
Use the Paint Collision Properties Tool (Cloth menu set, Cloth > Paint Cloth Properties Tool) to paint collision properties of cloth objects, specifically, the collision priority and the collision depth map offset. For details, see the Cloth guide.

Paint Fur Attributes Tool (Maya Unlimited only)
Use the Paint Fur Attributes Tool (Rendering menu set, Fur > Paint Fur Attributes Tool) to paint fur attribute values on an area of fur without changing the fur description for the entire surface. For details, see the Fur guide.

Paint Fluids Tool (Maya Unlimited only)
Use the Paint Fluids Tool (Dynamics menu set, Fluid Effects > Add/Edit Contents > Paint Fluids Tool) to paint fluid property values in 2D and 3D fluid containers. For details, see the Fluid Effects guide.

Paint Hair Tool (Maya Unlimited only)
Use the Paint Hair Tool (Dynamics menu set, Hair > Paint Hair Tool) to paint hair on a NURBS or polygon surface, or to modify follicle attributes of a hair system. For details, see the Hair and Dynamic Curves guide.
Maya Paint Effects

Part 1

Image by Terry Stoeger
Paint Effects Overview

Paint Effects is a component of Maya used to quickly and easily paint brush strokes and particle effects on a 2D canvas or on or between 3D geometry.

You can use Paint Effects as a traditional paint program to paint images on a canvas, or to paint repeatable textures that you can apply to geometry in your scenes.

But Paint Effects goes beyond traditional painting—you can paint entire particle effects on your canvas or scene with a single brush stroke. On a 2D canvas a single brush stroke can produce complex images, for example trees or flowers. In your scene, that same brush stroke produces these entities three-dimensionally. Imagine being able to paint an orchard in your scene where the painted trees exist as objects that your characters can move around. You can also apply dynamic forces to the effects you paint.
in your scenes and animate the display and movement of the effects. For example, you can make plants grow, make long hair blow in the wind, or make a river flow.

Note  Choose from one of the many preset brushes and paint realistic effects like plants, hair, fire, feathers, oil paints, pastels, and watercolors, or blend the preset brushes to create custom effects. Create your own brushes by setting shading, illumination, shadow, glow, tube, gap, and flow animation attributes or by modifying the attributes for the preset brushes.

You can get immediate high-quality feedback by rendering brush strokes while you paint. Paint Effects strokes render seamlessly with the rest of your scene during a post process in the final render.

How the Paint Effects Tool works

The Paint Effects Tool works like a paintbrush. When you drag with the Paint Effects Tool, you create a stroke. A stroke is a collection of curves with attributes that define how the paint is applied along the stroke path. You can paint strokes on a 2D canvas to create 2D images or textures, or you can paint strokes in a scene to create paint effects in true 3D space.

Brushes

The attribute settings that define the appearance and behavior of a stroke are collectively called a brush. When you paint a stroke, Paint Effects creates a new brush, copies the template brush settings to the new brush, then attaches the new brush to the stroke, giving the brush a unique name.

The template brush is simply the collection of attribute settings that define the brush to be attached to your next stroke. Think of it as your paint can—the place you mix your paint before applying it. Any changes you make to the paint in the can (the attribute settings in the template brush) affect what your next stroke looks like, but they do not affect any previous strokes made with paint from that can (the template brush).

You can save brushes so that specific combinations of attribute settings are available when you need them. Saved brushes are called preset brushes. When you select a preset brush, its settings are copied to the template brush, where you can tweak them before painting your stroke. Any tweaks or changes you make to the settings in the template brush are not made to the selected preset brush, unless you explicitly save them. You can create your own preset brushes or use the preset brushes that ship with Paint Effects.
Strokes
A Paint Effects stroke is a curve attached to a hidden underlying NURBS curve (or curves). The underlying NURBS curve defines the shape of the stroke path.

When you paint a stroke on a 2D canvas, Paint Effects applies paint along the stroke path according to the template brush attribute settings, then discards the stroke geometry. Because there is no geometry on the 2D canvas, you cannot modify the strokes or the attached brushes after you have painted them.

When you paint a stroke in a 3D scene, Paint Effects saves the stroke with the scene. Because strokes are geometry, they have construction history and they are editable. You can modify a stroke’s attributes, transform a stroke, change its shape, modify the number of CVs on the stroke path curve, and reset the attributes of the brush attached to the stroke. You can even attach brushes to existing NURBS curves to create strokes.

Although by default each stroke has a unique brush attached to it, you can force strokes to share a single brush. When strokes share a brush, any changes you make to the brush affect all the strokes that brush is attached to.

Types of strokes
There are two basic kinds of strokes: simple strokes and strokes that simulate growth.

Simple strokes
On simple strokes, paint is applied directly along the stroke path.

Strokes simulating growth
Strokes with tubes simulate organic growth. As you paint, tubes sprout from the stroke path, like plants growing from a path of seeds. The tubes grow, split, and expand in discrete steps along the stroke path, growing a segment longer at each step.
Here’s how it works. As you paint the stroke, Paint Effects samples points on the stroke path based on input from your mouse or stylus. When you paint the stroke quickly, the sample points are farther apart, when you paint the stroke slowly, the sample points are closer together. When it samples a point, Paint Effects plants new tubes along the path between the last sampled point and the current one, then grows the previously planted tubes one more segment. When you finish painting the stroke, the tubes will either continue growing until they reach the end of their life span (defined by the number of tube segments), or they will stop growing, so that tubes near the end of the stroke are less complete than the ones at the beginning.

Tubes can grow into an almost infinite variety of shapes and forms (for example, plants, hair, fire, and water) depending on the attributes you set for the stroke.

On the 2D canvas, strokes with tubes can quickly produce complex images. In a 3D scene, the tubes can grow into 3D space.

**How paint is applied to strokes**

Paint is applied to strokes in overlapping stamps when the stroke is rendered.

If the stroke is simple (it has no tubes), the stamps are applied along the stroke path.
If the stroke simulates growth (it has tubes), the stamps are not applied along the stroke path, but are applied along the tube paths.

![Stroke with tubes]

When you work on the 2D canvas, you immediately see the paint applied to the stroke. However, when you work in 3D in your scene, strokes are represented as wireframes. While a wireframe representation of a stroke provides quick, immediate feedback without diminishing performance, at times you will want to see what the stroke really looks like without having to do a post-process render. You can do this using an interactive stroke rendering mode in the Paint Effects panel called the *scene painting view*.

The Paint Effects scene painting view is a snapshot of the modeling view of your scene where you can view your strokes as wireframes, or you can apply paint to your strokes as you paint, in effect, rendering your strokes interactively.

![Stroke in wireframe mode](#)  ![Stroke in rendered mode](#)

**How do I?** Prepare to use Paint Effects

Paint Effects is a powerful and complex program. To ensure that your first experiences with Paint Effects are successful, go through the following checklist before you begin.

1. Load Paint Effects, if it is not already loaded. See “Load Paint Effects”.

Paint Effects, Artisan, and 3D Paint
Prepare to use Paint Effects

2 Load the Paint Effects shelf if it’s not already loaded. See “Load the Paint Effects shelf” on page 28.

3 [Optional] Drag and drop preset brushes to shelves, if they are not there already. See “Save preset brushes to shelves” on page 29.

4 If you are painting in a scene, note the following:
   Currently, you can only paint effects on the view plane (the plane that is ortho-normal to the camera view), the grid plane of the perspective view, or on NURBS or polygonal surfaces.
   Although you cannot paint 3D effects on subdivision surfaces, you can paint 2D effects on them using the 3D Paint Tool, or you can create textures using Paint Effects and apply them to the surfaces. You can also try the following workflows:
   • Place rough, invisible NURBS or polygonal geometry inside the subdivision surface and bind it to the same skeleton. Paint on the NURBS surface and the Paint Effects strokes will grow out the NURBS surface and through the subdivision surface.
   • Bind the CVs of some NURBS curves to vertices on the subdivision surface then convert the curves to strokes.

5 Refer to the lessons in “Painting” on page 529 of Getting Started with Maya for an introduction to Paint Effects.

Load Paint Effects

To start using Maya Paint Effects, it must be loaded. Paint Effects loads automatically when you install Maya, however, if you should need to load it, use the following procedure.

To load Maya Paint Effects

1 Start Maya.

2 Select Window > Settings/Preferences > Preferences and click the Modules category.

3 Turn on Paint Effects and click Save.

4 Restart Maya.
   Maya loads Paint Effects and the Paint Effects shelf, adds the Paint Effects menu to the Rendering menu set, and the Paint Effects panel to the Panels > Panel menu.

Load the Paint Effects shelf

The Paint Effects shelf contains a range of Paint Effects tools and brushes.
If you are new to Maya, the Paint Effects shelf, like the other Maya shelves, is loaded automatically on Windows and Mac OS X. The shelves are not loaded by default on IRIX and Linux because they can seriously impede the start up performance of Maya. To load these shelves on IRIX or Linux, follow the instructions in “Load the default shelves” in the Basics guide. To load only the Paint Effects shelf, follow the instructions below in “To load the Paint Effects shelf.”

**To load the Paint Effects shelf**

1. Open the Script Editor (Window > General Editors > Script Editor).
2. Copy and paste the following into the Script Editor:
   ```mel
   loadNewShelf "shelf_PaintEffects.mel";
   saveAllShelves $gShelfTopLevel;
   ```
3. Select Script > Execute.

**Save preset brushes to shelves**

Maya provides over 200 preset brushes in your `mayapath/brushes` (Windows, IRIX, and Linux) or `/Applications/Maya 6.0/Application Support/brushes` (Mac OS X) folder.

When you load Paint Effects for the first time, the preset brushes can be accessed from the Visor, while a small subset of preset brushes are available in the Paint Effects shelf. You may want to drag and drop these preset brushes to the Paint Effects shelf, or another shelf, so they are available for easy access.

**To save preset brushes to a shelf**

1. Open the Visor (Window > General Editors > Visor).
2. Click the Paint Effects tab and expand the brushes folder, if it is not already expanded.
3. Click the folder containing the preset brush(es) you want to save to a shelf.
4. [Optional] Create a new shelf for the preset brushes.
5. Do one of the following:
   - To save a single brush to a shelf, middle-click the brush icon and drag it to the Paint Effects shelf, another shelf, or the new shelf you created.
   - To save all brushes in a folder to a shelf, middle-click the open folder icon and drag it to the shelf.
6. Select Window > Settings/Preferences > Shelves and click Save All Shelves.
Define Paint Effects hotkeys

The following Paint Effects actions have hotkeys defined in the Hotkey editor (Window > Settings/Preferences > Hotkeys).

<table>
<thead>
<tr>
<th>Option or action</th>
<th>Default Hotkey</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Paint Effects Panel (PaintEffectsPanel)</td>
<td>8</td>
</tr>
<tr>
<td>Open Template Brush Editor (TemplateBrushSettings)</td>
<td>Ctrl-b (Windows, IRIX, and Linux)</td>
</tr>
<tr>
<td></td>
<td>Control-b (Mac OS X)</td>
</tr>
<tr>
<td>Modify Paint Effects Brush Scale (ModifyUpperRadius in Hotkey editor in Brush Tools category)</td>
<td>Press b and drag left or right, then release</td>
</tr>
<tr>
<td>Modify Brush Width (ModifyLowerRadius in the Hotkey editor in the Brush Tools category, default hotkey, B)</td>
<td>Press B and drag left or right, then release</td>
</tr>
<tr>
<td>Modify Paint Effect Surface Offset (ModifyDisplacement in Hotkey editor in the Brush Tools category)</td>
<td>Press m and drag left or right, then release</td>
</tr>
</tbody>
</table>

In addition to setting hotkeys for each of the items on the Paint Effects menu, you can set hotkeys (under Paint Effects Commands in the Hotkey editor) to do the following:

- Modify the brush width (ModifyLowerBrushRadius, in Brush Tools category)
- Clear the canvas (ClearPaintEffectsView)
- Undo the last canvas stroke (UndoCanvas)
- Switch the Tube Direction between Along Path and Along Normal (FlipTubeDirection). This is particularly useful when painting plants on the canvas.
- Switch Paint At Depth option on or off (TogglePaintAtDepth)
- Blend brush preset shading and shape (BrushPresetBlend)
- Blend brush preset shading (BrushPresetBlendShading)
- Blend brush preset shape (BrushPresetBlend Shape)
• Replace the shading values of the template brush (BrushPresetReplaceShading)
• Switch the Opposite option for the selected surface (ToggleOppositeFlagOfSelectedShapes)
• Display the Brush Animation marking menu (BrushAnimationMarkingMenu)
• Display the Curve Utilities marking menu (CurveUtilitiesMarkingMenu)
• Display the Auto Paint marking menu (AutoPaintMarkingMenu)
• Switch between the Paint Effects panel and the modeling view (PaintEffectPanel)
Maya Paint Effects | 2
Prepare to use Paint Effects >
At its most basic, Paint Effects is a traditional paint program that you can use to put paint on a 2D canvas. Paint Effects has many traditional preset brushes to choose from, including airbrushes, felt-tipped markers, oils, pastels, pencils, pens, and watercolors. They work like paintbrushes, leaving paint on the canvas along the stroke path.

When you paint with brushes that use tubes, paint appears to sprout from the stroke you draw, like plants growing from seeds. You can define how the tubes sprout to achieve very complex results with a single brush stroke.

You can use the provided preset brushes, or create your own custom brushes to paint images and textures.
Display the Paint Effects canvas

To paint in 2D, you use the Paint Effects canvas. The Paint Effects canvas is just a plane that is ortho-normal to the camera. When you paint a stroke on the canvas, Paint Effects applies the paint and discards the underlying stroke and attached brush, which means you cannot edit them.

To display the Paint Effects canvas

1. On the view menu bar, select Panels > Panel > Paint Effects to open the Paint Effects panel. The Paint Effects Tool is selected automatically.

2. Select Paint > Paint Canvas. The panel changes to a blank canvas, and the Canvas menu and toolbar become available.

Tips
As a shortcut, press the 8 hotkey to open the Paint Effects panel. For information on other Paint Effects hotkeys, see “Define Paint Effects hotkeys” on page 30.

You can open the Paint Effects panel as a separate window by selecting Window > Paint Effects.

For information on saving a snapshot of the canvas, saving the depth as grayscale, changing the lighting, or displaying the RGB, alpha, and luminance planes, see “Painting in the Paint Effects Panel” on page 103. These features are common to both canvas and scene views of the Paint Effects panel.
Set up the canvas

You can change the following canvas settings:

- canvas size (see “Set the canvas size” on page 35)
- canvas globals, which include lighting, canvas scale, and canvas wrapping options (see “Set canvas globals” on page 35)

Set the canvas size

You should set the canvas size before you begin painting. The canvas size is defined by the number of pixels along the height and width of the canvas. If you attempt to change the canvas size of an existing image, Paint Effects does not resample the image—instead, Paint Effects prompts you to save the image, then creates a new canvas of the specified size.

To set the canvas size

2. Enter the X Size (width) and Y Size (height) values.
3. Click Set Size.

Tip  To restore the zoom factor to 1.0 (actual pixel size), click the 1:1 button on the toolbar.

Set canvas globals

You can set canvas lighting, canvas scale, and canvas wrapping options from the Paint Effects Globals window.

To set canvas globals

2. Expand Canvas, then modify the global settings. For descriptions of these settings, see “Canvas” on page 50.

Tip  You can assign a hotkey to open the Paint Effects Globals window (under Paint Effects in the Hotkey Editor, define PaintEffectsGlobalSettings).
Paint on the canvas

When you display the Paint Effects canvas, the Paint Effects Tool is selected automatically. The cursor shows the width of the stroke path. For simple strokes, the brush width defines the paint stamp. For strokes with tubes, the brush width defines the stroke path boundary—tubes can start growing only within the path defined by the brush width.

To paint brush strokes on the canvas

1. Set up the canvas, if necessary. For information, see “Set up the canvas” on page 35.

2. Do one of the following:
   - If you use a stylus and tablet, modify pressure mappings, if desired (Paint Effects > Paint Effects Tool > boxshadowup). You can map up to three brush attributes to the stylus pressure. For information on modifying stylus pressure mappings, see “Make the brush respond to stylus pressure” on page 56.
   - If you want to ignore the pressure mappings, select Brush > Use Stylus Pressure to turn it off. You may want to ignore pressure mappings if you paint with a mouse rather than a stylus.

3. In the Visor (Brush > Get Brush), or on a shelf, click the brush preset you want to paint with. The selected brush settings are copied to the template brush.
   - If you do not select a preset brush, the next stroke you paint uses the current settings for the template brush.

4. Modify template brush settings, if necessary (Brush > Edit Template Brush). For information on modifying template brush settings, see “Define template brush settings” on page 112.

Tip

You can use hotkeys on the canvas to interactively change the Global Scale (ModifyUpperRadius under Brush Tools, default hotkey, b) and the Brush Width only (ModifyLowerRadius in the Hotkey editor under Brush Tools, default hotkey, B). For information on other Paint Effects hotkeys, see “Define Paint Effects hotkeys” on page 30.
If you are painting a seamless repeating texture, set the appropriate wrap and roll options. For information on wrapping textures, see “Create seamless repeating textures” on page 42.

Drag across the canvas.

**To undo the last stroke**

Select Canvas > Canvas Undo.

There is only one level of undo—you can only undo the last stroke.

---

**Tip**

You can define a hotkey to undo the last stroke (under Paint Effects in the Hotkey editor, define UndoCanvas). For information on other Paint Effects hotkeys, see “Define Paint Effects hotkeys” on page 30.

---

**Flip Tube Direction**

Use Flip Tube Direction to switch the direction of the current brush between Along Path (best for canvas painting of plants) and Along Normal (best for scene painting of plants).

---

**To flip the tube direction**

1. Do one of the following:
   - Click the Flip Tube Direction button on the Paint Effects panel toolbar.
   - Select Paint Effects > Flip Tube Direction.

---

**Note**

There is a *Force Tube Direction to be Along Path* checkbox in the Canvas section of the Paint Effects Globals. *Force Tube Direction to be Along Path* causes brushes with tubes whose elevationMin is greater than 0.5 to be drawn along the path rather than along the normal in Canvas mode. This has the effect of making plant brushes draw in the expected direction when painting in the canvas.
Erase paint from the canvas

You can erase paint from the canvas using any brush by setting the brush type to Erase. Painting over an image on the canvas with an Erase brush removes the color from the painted pixels, revealing the underlying canvas Clear Color and maintaining the shape of the brush. For example, if the brush has leaves, the color is removed where the leaves are painted. If you change the default clear color without applying it, the original clear color is revealed. Erasing also removes alpha.

![Simple Erase, clear color white](image1) ![Erase with tubes, clear color white](image2) ![Simple Erase, clear color green](image3)

**To erase brush strokes from the canvas**

1. Modify the canvas Clear Color, if necessary. For information on setting the canvas Clear Color, see “To set the default clear color of the canvas” on page 41.

2. Do one of the following:
   - If you use a stylus and tablet, modify pressure mappings, if desired (Brush > Tool Settings). You can map up to three brush attributes to the stylus pressure. For information on modifying stylus pressure mappings, see “Make the brush respond to stylus pressure” on page 56.
   - If you want to ignore the pressure mappings, select Brush > Use Stylus Pressure to turn it off. You may want to ignore pressure mappings if you paint with a mouse rather than a stylus.

3. In the Visor (Brush > Get Brush), or on a shelf, click the brush preset you want to erase with. The selected brush settings are copied to the template brush.


5. Beside Brush Type, select Erase.

6. Set Fake Shadows to None, if this is not already the setting.

7. Modify other template brush settings, if necessary. For information on modifying template brush settings, see “Define template brush settings” on page 112.

8. Drag across the area you want to erase.
Smear and blur paint on the canvas

You can smear and blur paint on the canvas using any brush by setting the brush type to Smear or Blur, respectively. Like Erase type brushes, Smear and Blur type brushes use the shape of the brush. For example, if the brush has leaves, the paint smears or blurs where the leaves are painted.

**To smear or blur paint on the canvas**

1. Do one of the following:
   - If you use a stylus and tablet, modify pressure mappings, if desired (Brush > Tool Settings). You can map up to three brush attributes to the stylus pressure. For information on modifying stylus pressure mappings, see “Make the brush respond to stylus pressure” on page 56.
   - If you want to ignore the pressure mappings, select Brush > Use Stylus Pressure to turn it off. You may want to ignore pressure mappings if you paint with a mouse rather than a stylus.

2. In the Visor (Brush > Get Brush), or on a shelf, click the brush preset you want to smear or blur with. The selected brush settings are copied to the template brush.


4. Beside Brush Type, select Smear or Blur.

5. Set Fake Shadows to None, if this is not already the setting.

6. Modify other template brush settings, if necessary. For information on modifying template brush settings, see “Define template brush settings” on page 112.

Tip: Any brush can become an erase brush by changing its Brush Type to Erase. Create some erase type brush presets and save them on a shelf for easy access. For information on storing brushes, see “Create new brush presets” on page 127.
Paint pixels

You can paint color, incandescence, and transparency values on individual pixels using the Pixel brush (useful if you are creating textures for games). Strokes painted with the Pixel brush are not anti-aliased.

To pixel paint on the canvas

1. Select Brush > Single Pixel Brush to turn the pixel brush on. The brush changes to a pointer.
2. Zoom into the area you want to pixel paint so you can see the pixels. To zoom, press the Alt (Windows, IRIX, and Linux) or Option (Mac OS X) key and drag using the left and middle mouse buttons together.
3. Modify the Color1, Incandescence1, and Transparency1 attribute values, as necessary (in the Shading section of the Paint Effects Brush Settings window or on the toolbar).
4. Click individual pixels, or drag over pixels to paint them.
5. When you are finished pixel painting, turn off Brush > Single Pixel Brush to switch to the Paint Effects Tool.

Clear the canvas

Clearing the canvas replaces the entire canvas with the default clear color. You can set this to be any color or change the color each time you clear.

To clear the canvas using the default clear color

Do one of the following:

- Select Canvas > Clear. The canvas clears to the default clear color.
- Click the Clear Canvas icon on the toolbar.

Tip
Create some smear and blur type brush presets and save them on a shelf for easy access. For information on storing brushes, see “Create new brush presets” on page 127.

7. Drag across the area you want to smear or blur.
Painting in 2D | 3

To set the default clear color of the canvas

2. Click the color box to open the Color Chooser.
3. Select the canvas color and click Accept. For information on using the Color Chooser, see the Basics guide.
4. Click Save to save the clear color. This does not clear the canvas.
　To clear the canvas to this color, click Apply.
　This saved color is now used when you use the Clear option.

Zoom and track

You can zoom and track the canvas just as you zoom and track any scene view.

- To zoom, press the Alt (Windows, IRIX, and Linux) or Option (Mac OS X) key and drag using the left and middle mouse buttons together.
  If the strokes appear “jagged”, restore the zoom factor to 1.0 (actual pixel size), by clicking the 1:1 button on the toolbar.
- To track, press the Alt or Option key and drag using the middle mouse button.

Create new images

To create a new image

2. Type a name for the new image in the Image name box or click the folder icon and select an existing texture. By default, the image will be stored in the sourceimages directory for the current project.
3. Set the canvas size, if necessary. For textures, you typically use a square canvas (for example, 256 x 256 pixels, or 512 x 512).
4. Click the Background color box to open the Color Chooser.

Tip
You can define a hotkey to clear the canvas (in the Paint Effects category in the Hotkey editor, define ClearPaintEffectsView).
For information on other Paint Effects hotkeys, see “Define Paint Effects hotkeys” on page 30.
5 Select the background color for the image and click Accept. For information on using the Color Chooser, see the Basics guide.

6 Click Apply Texture.

Create seamless repeating textures

A repeating texture is a texture created by tiling or repeating an image in a grid. A seamless repeating texture is one where you cannot see the border of each tile because the images match continuously at each tile edge (like aligning a wallpaper pattern at the edges of the paper).

You can create seamless repeating textures in Paint Effects using the wrap feature. The wrap feature enables you to paint across the edge of a canvas and have that stroke continue on the opposite edge, as if the canvas were wrapped into a cylinder and joined at the edges. You can wrap the canvas vertically, horizontally, or both.

To create a seamless repeating texture

1 Create a new file texture. For details, see the Shading guide.

2 Using the middle mouse button, drag the new file texture from Hypershade onto the canvas. The Paint Effects New Texture window opens.

3 Type a name for the new image in the Image name box or click the folder icon and select an existing texture. By default, the image will be stored in the sourceimages directory for the current project.

4 Set the canvas size, if necessary. For textures, you typically use a square canvas (for example, 256 x 256 pixels, or 512 x 512).

5 Click the Background color box to open the Color Chooser, select the background color for the image, and then click Accept. For information on using the Color Chooser, see the Basics guide.

6 Click Apply Texture.

7 Do one of the following:
Painting in 2D | 3
Create seamless repeating textures >

- In the Paint Effects Globals window (Paint Effects > Paint Effects Globals), make sure the appropriate Wrap options are turned on. Turn on Wrap H to wrap the canvas horizontally, Wrap V to wrap the canvas vertically.
- On the canvas toolbar, click the appropriate wrap button(s).

  - Wrap vertically
  - Wrap horizontally

8 Paint the canvas. For information on painting the canvas, see “Paint on the canvas” on page 36. When you paint over the wrapped edges, the brush stroke continues on the opposite edge.

9 Open the file texture in the Attribute Editor, click the place2dTexture node tab, then expand 2d Texture Placement Attributes.

10 Turn on Wrap U and Wrap V, as appropriate to replicate the texture outside the coverage area in the U or V directions, or both.

11 In the Repeat UV fields, type the number of copies of the texture map you want mapped within the coverage area along either the U or V parametric surface directions or both.

The texture will wrap seamlessly on any objects its shader is attached to.

Roll the canvas

If you wrap the canvas, you may want to display the area where the edges join. You can do this using the roll feature. The roll feature rolls the canvas as if it were wrapped into a cylinder, so that the images move continuously from left to right, or from top to bottom.
Painting in 2D | 3
Create seamless repeating textures >

This feature is also useful if you do not use the wrap function but want to correct any seams created at the edges of the canvas. In the following example, the canvas was rolled 50% vertically (top to bottom). The seam can now be corrected easily using an airbrush.
To roll the canvas

Select Canvas > Roll and select one of the following menu items:

50, 25 horizontal

Roll the canvas from left to right a distance 50% or 25% of the width of the canvas.

-25% horizontal

Roll the canvas from right to left a distance 25% of width of the canvas.

50, 25 vertical

Roll the canvas from bottom to top a distance 50% or 25% of the height of the canvas.

-25% vertical

Roll the canvas from top to bottom a distance 25% of the height of the canvas.

Modify textures applied to surfaces

Although you can use the 3D Paint Tool to modify a texture by painting directly on the surfaces the texture is applied to, you can also modify the texture in the canvas and immediately see the effects on the surfaces.
To modify a texture applied to a surface

1. Apply the file texture to the surface. For details, see the Shading guide.

2. Open Hypershade, if it is not already open (Window > Rendering Editors > Hypershade).

3. Using the middle mouse button, drag the applied file texture onto the canvas.

4. Select Canvas > Save > □ and turn off Save Alpha.

5. Set Paint Effects to save the canvas after each stroke (Canvas > Auto Save or click the folder icon on the toolbar).

6. Change your layout to display both the canvas and a view of your scene (for example, Panels > Layouts > 2 Side By Side).

7. In the scene view, turn on Hardware Texturing (Shading > Hardware Texturing).

Tip: To paint on Maya textures (for example, checker or fractal), select the surface the texture is on and in Hypershade, Shift-select the texture. Still in Hypershade, select Edit > Convert to File Texture. Now drag the converted file texture onto the canvas.
Paint on existing images and textures

You can open existing images (any file format supported by Maya) onto the canvas, then paint on them. For information on the file formats supported by Maya, see the Basics guide.

You can also use Paint Effects to modify existing textures.

To paint on an existing image

1. Select Canvas > Open Image. The Open (Windows and Mac OS X) or Open Image (IRIX and Linux) window appears.
2. To display image files with the file formats supported by Maya: (IRIX and Linux) Select image (UNIX format) beside Read as. (Windows) Select image (all formats) beside Files of type. (Mac OS X) Select image (all formats) beside Show.
3. Select the image you are importing onto the canvas.

Tip
To improve the display quality of the texture, open the Attribute Editor for the shader, expand Hardware Texturing, and change the Texture resolution to the desired setting. On Windows, you may need to set the quality to something other than Default to see the texture update.

Tip
You can paint attributes that you can’t see through Hardware Texturing (for example, bump, incandescence, transparency) and see the effect on the surface it’s applied to using IPR.

- Assign a texture to the required attribute of the shader and apply the shader to the surface. For details, see the Shading guide.
- In Hypershade, use the middle mouse button to drag the texture node onto the canvas.
- Set Paint Effects to save the canvas after every stroke.
- Do an IPR render of the surface and select the area you want to view. For details, see the Rendering guide.
- Paint on the canvas.

Paint on the canvas (see “Paint on the canvas” on page 36). The texture updates on the surfaces it is applied to each time you release the mouse button.
Painting in 2D | 3
Save images >

4 Click Open (Windows and Mac OS X) or Open Image (IRIX and Linux).

5 If there is already an image on the canvas with unsaved changes, you are prompted to save it.
   Click Yes to save the existing image. The Save Image (IRIX and Linux) or Save (Windows and Mac OS X) window opens. Type a name for the image, including the file extension (for example, forest.iff) and click Save Image (IRIX and Linux) or Save (Windows and Mac OS X).
   Click No to clear the canvas without saving, then open the imported image.

6 Paint on the image (see “Paint on the canvas” on page 36).

7 Save the image (Canvas > Save). Paint Effects saves the changes to the imported image.

To paint on an existing texture

1 Using the middle mouse button, drag the texture from Hypershade or Multilister onto the canvas.

2 If there is already an image on the canvas with unsaved changes, you are prompted to save it.
   Click Yes to save the existing image. The Save Image (IRIX and Linux) or Save (Windows and Mac OS X) window opens. Type a name for the image, including the file extension (for example, forest.iff) and click Save Image (IRIX and Linux) or Save (Windows and Mac OS X).
   Click No to clear the canvas without saving, then open the imported image.

3 Paint on the texture (see “Paint on the canvas” on page 36).

4 Save the texture (Canvas > Save). Paint Effects saves the changes to the image file that the texture references.

Save images

You can save the images you paint on the canvas in Maya image format (.iff) only.

To save the image

1 Select Canvas > Save.
   If you have specified a name for the image, Maya saves the image to that file.
   If you have not specified a name for the image, the Save Image (IRIX and Linux) or Save (Windows and Mac OS X) window opens.
2 Type the name of the new file, including the file extension (for example, forest.iff).

<table>
<thead>
<tr>
<th>Tip</th>
<th>If you plan to transfer files between IRIX/Linux and Windows, do not put spaces in the filenames.</th>
</tr>
</thead>
</table>

3 Click Save. Maya saves the contents of the image under the specified name.
   If you have specified a name for the image, Maya saves the image to that file.

**To rename an image**

1 Select Canvas > Save As. The Save Image (IRIX and Linux) or Save (Windows and Mac OS X) window opens.
2 Type the name of the new file, including the file extension (for example, forest.iff), then click Save. Maya saves the image under the specified name.

**Set save options**

You can set whether or not changes to the alpha channel are saved when you use Save and Save As.

**To set Save and Save As options**

1 Select Canvas > Save > □ or Canvas > Save As > □. The Save Image Options window opens.
2 Turn off Save Alpha if you do not want to save the alpha channel when you save the image.
3 Click Save Image to save the image or click Save to Save the settings only.

**Save after every stroke**

When you modify textures that are attached to surfaces in your scene, you may want to see the changes on the surface immediately. Whenever you save a texture in the canvas, the texture updates on all the surfaces it is attached to. You can see this update if you have hardware texturing turned on. To update the texture after every stroke, set Paint Effects to save the image after each stroke.

**To save after every stroke**

Do one of the following:
Painting in 2D | 3

Save images >

- Select Canvas > Auto Save to turn on auto save.
- Click the Auto Save icon on the Paint Effects toolbar.

Reference

Paint Effects > Flip Tube Direction

Use Flip Tube Direction to switch the direction of the current brush between Along Path (best for canvas painting of plants) and Along Normal (best for scene painting of plants). For more information, see “Flip Tube Direction” on page 37.

Paint Effects > Paint Effects Globals

These are the options in the Paint Effects Globals window.

Canvas

These are the Paint Effects Globals options in the Canvas section.

Canvas Scale

Set the factor you want the template brush global scale adjusted by when you paint on the canvas. For example, if the global scale for the template brush is set to 2, and you set the canvas scale to 0.5, the template brush will use a global scale of 1 when you paint on the canvas. For information on setting the global scale for a brush, see “Set the global scale” on page 116.

Wrap H, Wrap V

These wrap options are useful for creating seamless repeating textures. For information on creating seamless repeating textures, see “Create seamless repeating textures” on page 42.

Turn on Wrap H to “wrap” the canvas horizontally. Any strokes that go past the top or bottom of the canvas will continue on the opposite edge as if the canvas were joined along the left and right edges.

Turn on Wrap V to “wrap” the canvas vertically. Any strokes that go past the left or right of the canvas will continue on the opposite edge as if the canvas were joined along the top and bottom edges.
You can see where the wrapped edges join using the Canvas > Roll command. For details, see “Roll the canvas” on page 43.

You can also wrap the canvas using the wrap icons on the Paint Effects toolbar.

- **Wrap vertically**
- **Wrap horizontally**

**Use Canvas Light**

Because the canvas is just a plane that is ortho-normal to the camera, the lights in your scene affect the appearance of brush strokes on the canvas. You can use the lights in your scene to light the canvas, or you can use a canvas light. The canvas light is a directional light. You can rotate the light to a new position, but you cannot change any of its other attributes.

Turn this option on to use a global canvas light (directional) for brushes instead of using the lights in the scene.

**Light Direction**

If you turn on Use Canvas Light, specify the direction of the canvas light source in the x, y, and z boxes respectively.

**Flip Tube Direction to be Along Path**

When Flip Tube Direction to be Along Path is turned on (on by default), brushes with tubes whose elevationMin is greater than 0.5 will be drawn along the path rather than along the normal in Canvas mode. This has the effect of making plant brushes draw in the expected direction when painting in the canvas.
You can also flip the tube direction using the Flip the Tube Direction icon located on the Paint Effects panel toolbar.
Paint Effects goes beyond traditional paint in that the strokes are three dimensional and editable. Each stroke is an object in your scene. You can paint strokes on the grid plane of the perspective view or directly on other objects, then you can transform them, change their shapes, and change their attributes.

You can use the same traditional Paint Effects brush presets in 3D that you would use on a canvas (for example, airbrushes, felt-tipped markers, oils, pastels, pencils, pens, and watercolors). Just like painting on a canvas, these brushes leave paint along the stroke path. But better than painting on a canvas, the paint can be three-dimensional, like oil paint squeezed out of a tube. While a bumpmap texture applied to a surface only gives the illusion of three dimensions, the paint applied to Paint Effects strokes actually occupies 3D space.

But painting traditional brush strokes in 3D only touches on the capabilities of Paint Effects. Painting Strokes with tubes opens up a whole new world of possibilities. As you paint a stroke, tubes sprout from the stroke path, like plants growing from seeds. You can define how the tubes sprout to achieve very complex results with a single brush stroke.
While the stroke itself lies on a plane or on a surface, tubes can sprout from the stroke path into 3D space. You can tumble and view the tubes from another angle because they are not simply textures on a 2D plane.

In the following example, the trees were painted with a single stroke with tubes, yet each tree is distinctly defined in 3D space. The ribbon is a surface woven between the trees. The 3D nature of Paint Effects strokes makes this possible.

In 3D you can change how the paint is applied along the stroke path without having to repaint the stroke. For example, you can quickly change the look of an object without repainting it by changing the watercolor brushes attached to the strokes to oil paint brushes.

You can also apply dynamic forces to the effects you paint in your scenes and animate the display and movement of the effects. For example, you can make plants grow, make long hair blow in the wind, or make a river flow.
How do I? Set up to paint in 3D

Before you begin painting in 3D, you should define global scene settings and default stroke settings.

Define global scene settings

You can globally set scene lighting, scene scale, scene wrapping, and depth options from the Paint Effects Globals window. These settings are used when you paint in the scene painting view.

To set scene globals


2. Expand Scene, then modify the global settings. For descriptions of these settings, see “Scene” on page 87.

Define default stroke settings

The stroke settings you define for the Paint Effects Tool become the default for all new strokes you paint based on the depth of the surfaces you are painting on. You can set the display quality for the stroke, the distance the stroke is offset from the surface, and whether the stroke is painted at depth. If you use a stylus and tablet, you can also map the stylus pressure to up to three attributes. With the exception of the Paint at Depth option, these settings can all be modified for the stroke after it is painted.

To define default stroke settings

Select Paint Effects > Paint Effects Tool > and modify the default settings, including Paint at Depth, Display Quality and Surface Quality. For descriptions of these options, see “Paint Effects > Paint Effects Tool >” on page 89.

Make the brush respond to stylus pressure

With a real paint brush, pressing harder makes the brush wider and applies the paint more thickly. You can achieve the same effect with Paint Effects by specifying the effect of pressure on the stylus for each stroke.
and the threshold of response to pressure. You can map up to three values to stylus pressure. For example, if you map scale, tubes per step, and tube length to stylus pressure, increasing stylus pressure (pressing harder) increases the global scale for the brush, but it also increases the number of tubes “planted” per step and the length of the tubes. Most of the preset brushes have pressure settings defined.

You can change the Pressure Mapping, Pressure Min, and Pressure Max settings after painting the stroke. For more information, see “Modify pressure mappings for existing strokes” on page 73.

**Paint in 3D**

When you drag in a scene with the Paint Effects Tool, Paint Effects creates a curve and attaches a stroke and new brush to it which define the appearance and behavior of the paint applied along the stroke path.

Whether you paint in the modeling view or the scene painting view, you can paint strokes on the grid plane of the perspective view, directly on objects, and on the view plane.

**Paint in the modeling view**

When you paint in the modeling view, simple strokes display as curves. Strokes with tubes display as wireframe representations of the rendered stroke. Paint is not applied to the strokes until you do a post-process render, which makes painting in the modeling view very quick. It provides immediate feedback in enough detail to see what you’re doing. To improve redraw speed, you can adjust the display quality of the wireframe strokes, just as you can adjust the display quality of objects displayed as wireframe.
Paint in the modeling view when speed is an issue, but the final appearance of the strokes is not (for example, when you want to move strokes, or when you are painting many strokes with the same brush).

Render strokes as you paint
To see what strokes really look like before doing a post-process render, you can render them as you paint them in the Paint Effects scene painting view. The scene painting view is a snapshot of the modeling view. You can zoom, tumble, track, and dolly this view, and the scene painting view will update accordingly. You can render all the Paint Effects strokes or render them individually (no other objects in the scene render).

Paint in the scene painting view when you need to see what the strokes look like, but you don’t want to do a final render (for example, when you are defining new brush presets). You cannot use the transform tools, or any modeling tools in this view. Although you can select objects in the scene painting view and transform them in the Attribute Editor or Channel Box, it is best to use the modeling view for non-painting tasks.

To display the scene painting view
1 On the view menu bar, select Panels > Panel > Paint Effects to open the Paint Effects panel. The Paint Effects Tool is automatically selected.
Paint Effects, Artisan, and 3D Paint

2 Select Paint > Paint Scene. The Paint Effects scene painting view displays.

Tips
As a shortcut, press the 8 hotkey to open the Paint Effects panel in the workspace. For information on other Paint Effects hotkeys, see “Define Paint Effects hotkeys” on page 30.
You can open the Paint Effects panel as a separate window by selecting Window > Paint Effects.

For information on changing the display resolution of the scene and displaying the RGB display, alpha, and luminance planes, see “Painting in the Paint Effects Panel” on page 103. These features are common to both canvas and scene modes of the Paint Effects panel.

Refresh the scene painting view
Zooming, tumbling, tracking, or dollying the scene painting view takes a new snapshot of your scene, rendering strokes according to the options you select on the Stroke Refresh menu. These options include:

Off
Strokes display as wireframe at their display quality when you zoom, tumble, track, or dolly the view.

Wireframe
Strokes display as wireframe at 100% display quality when you zoom, tumble, track, or dolly the view.
Rendered

All strokes render when you zoom, tumble, track, or dolly the view.

Selected Only

Only selected strokes render when you zoom, tumble, track, or dolly the view. Unselected strokes display as Wireframe (100% display quality).

To render all strokes in the scene

Do one of the following:

- Click the Redraw button on the toolbar.
- Select Stroke Refresh > Rendered.

Tip

If you have complex strokes in the scene that are taking a long time to redraw, press the Esc key on your keyboard to stop the redraw.

Change the scene painting view camera

By default, the scene painting view uses the perspective camera (persp). Just like you can change the camera in the modeling view, you can change the camera for the scene painting view.

To change the scene painting view camera

From the Camera menu, select the camera name (persp, front, side, top). Changing the camera causes the view to redraw (the strokes are rerendered).

To change the camera for the modeling view, you select a camera from the Panels > Orthographic submenu.

Note

In this release of Paint Effects, only the perspective view (persp) produces predictable results.

Change the resolution of the scene painting view

Because the scene painting view is a snapshot of the scene view, you can set its display resolution. With lower resolutions, you will see pixelated effects, but the strokes will render more quickly when you refresh the view.
To change the resolution of the scene painting view, select the desired resolution from the Resolution menu. The final render is not affected by these settings.

**Full**

Fits the view to the available space and displays it at maximum pixel size (no zoom).

**75%, 50%, 25%, 15%**

Displays the view at the selected percentage of the full resolution, occupying the same the screen area by increasing the zoom level.

**Actual Size**

Displays the view at its actual pixel size (no zoom). You can also use the 1:1 button on the toolbar.

---

**Change object shading in the scene painting view**

Use the commands on the Object Shading menu to change the shading of objects in the scene painting view. These options include:

**Wireframe**

Draws edges for polygon meshes and isoparametric curves for surfaces. This is the default shading quality.

**Shaded**

Renders all surfaces, meshes, and particles as smooth-shaded objects.

**Textured**

Displays a hardware rendition of the texture applied to a material shading an object.

**Use Default Lighting**

Surfaces appear fully illuminated by the Paint Effects default light.

**Use All Lights**

Surfaces appear illuminated by all lights in the scene.

**Display fog**

In the real world, the atmosphere contains fine particles (fog, smoke, or dust). These particles affect the appearance of the atmosphere and the appearance of objects in the atmosphere.
In Maya, you can simulate the effect of atmospheric particles using environment fog. If you use Physical Fog in your scene, you can display it in the scene painting view to see how the Paint Effects strokes look in a rendered fog environment. For information on using Physical Fog, see the Shading guide.

To display fog in the scene painting view
Select Object Shading > Display Fog.

Paint on the grid plane of the perspective view
When you paint on the grid of the perspective view, the stroke lies on that plane.
To paint on the grid plane of the perspective view

1. Select Paint Effects > Paint on Paintable Objects.
2. Ensure there are no paintable objects in the scene. To do this, in the modeling view, deselect all objects by clicking anywhere on the scene that is not an object, then select Paint Effects > Make Paintable.
3. In the Visor (Paint Effects > Get Brush), or on a shelf, click the brush preset you want to paint with.
4. Modify stroke settings, if necessary (Paint Effects > Paint Effects Tool > boxshadowup). For information on modifying stroke settings, see “Define default stroke settings” on page 55.
5. Modify brush attributes, if necessary (Paint Effects > Template Brush Settings, or use the Ctrl-b (IRIX, Linux and Windows) or Control-b (Mac OS X) hotkey combination. For information on modifying brush attributes, see “Define template brush settings” on page 112.

Tip: You can use hotkeys on the canvas to interactively change the Global Scale (set ModifyUpperRadius, default hotkey, b), the Brush Width only (set ModifyLowerRadius), and Stroke Offset (set ModifyDisplacement, default hotkey, m) under Brush Tools in the Hotkey Editor. For information on other Paint Effects hotkeys, see “Define Paint Effects hotkeys” on page 30.

6. In either the modeling view or the scene painting view, drag across the plane.
For information on the scene painting view, see “Render strokes as you paint” on page 57. For information on working in the scene painting view, see “Automatically paint multiple strokes on a surface” on page 69.

Paint on objects

To paint on NURBS or polygonal objects, you must first make the objects paintable. When you paint directly on a paintable object, Paint Effects creates a curve on the surface along the stroke path and attaches the stroke and new brush to it. When you translate the object, the stroke moves with it. You can offset the brush from the surface.

As you paint, the stroke does not leave the surface unless you paint over another object that is paintable. If you do paint across another paintable object during the stroke, the stroke will continue on the other object, bridging the two objects.

**Note**  You can only paint on NURBS or polygonal objects.
Paint in 3D

To paint on objects

1 Select the NURBS or polygonal object(s) you want to paint on. If you are in the scene painting view, Ctrl-click (Windows, IRIX, and Linux) or Control-click (Mac OS X) on an object to select it.

2 Select Paint Effects > Make Paintable.

Notes

- Because the stroke attempts to stay on the surface, the result may be unexpected. For example, suppose you have a sphere intersecting a plane. If you start painting on the sphere, once the brush leaves the sphere, it looks for another surface to continue on, the plane in this case. However, if you start to paint on the plane, the brush never leaves the surface, so the stroke doesn’t continue on the sphere.

- When you paint across the joined edges of a surface (for example, the center line on a face created by duplicating half the face and attaching it to the first half), your brush stroke may appear to “leak” through the join. To remedy this, make the surface periodic in U and V.

- Duplicating objects with strokes does not duplicate the strokes.
Painting in 3D | 4
Paint in 3D

3 Select Paint Effects > Paint on Paintable Objects.

Note If there are no paintable objects in the scene, your strokes will lie on the grid plane of the perspective view.

4 In the Visor (Paint Effects > Get Brush), or on a shelf, click the brush preset you want to paint with.

5 Modify stroke settings, if necessary (Paint Effects > Paint Effects Tool > boxshadowup). For information on modifying stroke settings, see “Define default stroke settings” on page 55.

6 Modify brush attributes, if necessary (Paint Effects > Template Brush Settings). For information on modifying brush attributes, see “Define template brush settings” on page 112.

Tips

• You can use hotkeys on the canvas to interactively change the Global Scale (set ModifyUpperRadius, default hotkey, b), the Brush Width only (set ModifyLowerRadius), and Stroke Offset (set ModifyDisplacement, default hotkey, m) under Brush Tools in the Hotkey Editor. For information on other Paint Effects hotkeys, see “Define Paint Effects hotkeys” on page 30.

• You can set a hotkey to reverse the surface normal when you paint strokes on mirrored surfaces. For details, see “Reverse surface normals” on page 68.

7 In either the modeling view or the scene painting view, drag across the plane.

For information on the scene painting view, see “Render strokes as you paint” on page 57. For information on working in the scene painting view, see “Automatically paint multiple strokes on a surface” on page 69.
Paint on the view plane

The view plane is the plane ortho-normal to the camera. You can think of painting on the view plane as painting on a sheet of glass that is facing the camera and fixed to it. When you change the view (for example, when you tumble), the view plane changes (the sheet of glass moves with the camera).

You can only paint on the view plane in the scene painting view—not the modeling view. When you paint on the view plane in the scene painting view, each stroke renders on the view plane, as you would expect. However, the wireframe representation of each stroke displays between 0 and 1 in world space on the XY plane (near the origin). Although the wireframe representation of the strokes appear to overlap in this area, the rendered strokes display where you painted them.

Tip
To paint on the grid plane of the perspective view after painting on objects, in the modeling view, deselect all objects by clicking anywhere on the scene that is not an object, then select Paint Effects > Make Paintable.

Rendered stroke on view plane
To paint on the view plane

1 Select Paint Effects > Paint on View Plane.

2 Open the Paint Effects panel (Panel > Panels > Paint Effects) and switch to the scene painting view (Paint > Paint Scene).

3 In the Visor (Paint Effects > Get Brush), or on a shelf, click the brush preset you want to paint with.

4 Modify stroke settings, if necessary (Paint Effects > Paint Effects Tool > [ ]). For information on modifying stroke settings, see “Define default stroke settings” on page 55.

5 Modify brush attributes, if necessary (Paint Effects > Template Brush Settings, or use the Ctrl-b (IRIX, Linux and Windows) or Control-b (Mac OS X) hotkey combination). For information on modifying brush attributes, see “Define template brush settings” on page 112.
Drag across the plane.

For information on working in the scene painting view, see “Automatically paint multiple strokes on a surface” on page 69.

To remedy this, switch the Opposite flag for the surface before you paint on it (turn it on or off). Switching the flag for the surface after painting a stroke will have no effect on the existing stroke.
**To switch the Opposite flag**

1. Create a hotkey for Toggle Opposite Flag of Selected Shapes (select Window > Settings/Preferences > Hotkeys then click the Paint Effects category). For details on creating hotkeys, see the Basics guide.
2. Select the surface.
3. Press the hotkey to switch the flag.

**Select which UV set to use for Paint Effects (polygons only)**

By default Paint Effects uses UV set map1, but you can link your Paint Effects strokes to different UV sets on your polygonal surface. For example, if you have different UV sets defined for different projections, you can link the Paint Effects strokes to the UV set that gives the best result.

When you link Paint Effects strokes to a UV set, all the strokes attached to the polygon are linked. You cannot link individual strokes to different UV sets.

**To link attached Paint Effects strokes to a different UV set**

1. Select the object with the Paint Effects stroke(s) you want to link.
2. Select Window > Relationship Editors > UV Linking > Paint Effects/UV to open the Relationship Editor.
   - The left panel lists all the Paint Effects strokes that are attached to the selected polygon.
   - The right panel lists mesh nodes with UV sets for the selected polygon. If more than one polygon is selected, only the last selected polygon is listed.
3. In the left panel, click a Paint Effects stroke. In the right panel the UV set the Paint Effects stroke is linked to becomes highlighted.
4. In the right panel, click the UV set you want to link the Paint Effects stroke to.

**Automatically paint multiple strokes on a surface**

You can quickly fill a surface with strokes without painting them individually or copying and pasting them. There are two ways you can do this:

- Automatically paint multiple strokes on a surface in a grid layout.
- Automatically paint multiple strokes on a surface in a random layout.
Modify existing strokes

When you paint a stroke, the template brush attributes are copied to a new brush, which is attached to the stroke. To change the look and behavior of the stroke, you can do the following:

To automatically paint multiple strokes on a surface in a grid layout

1. Select the brush you want to paint with.
2. Select the NURBS or polygonal surface you want to paint strokes on automatically.
3. Select Paint Effects > Auto Paint > Paint Grid.
4. Set the appropriate options and click Paint Strokes. For descriptions of the Auto Paint Grid options, see “Paint Effects > Auto Paint > Paint Grid” on page 92.

To automatically paint multiple strokes randomly on a surface

1. Select the brush you want to paint with.
2. Select the NURBS or polygonal surface you want to paint strokes on automatically.
4. Set the appropriate options and click Paint Strokes. For descriptions of the Auto Paint Random options, see “Paint Effects > Auto Paint > Paint Random” on page 93.

Note: If you have been using the paintGrid and paintRandom MEL scripts to automatically paint multiple strokes, delete them before using Paint Grid and Paint Random commands in Maya.
### You can... | For details, see...
---|---
Modify stroke settings in the Attribute Editor or Channel Box. | ”Modify stroke settings for existing strokes“ on page 71
Modify the settings of the brush in the Attribute Editor or Channel Box. | ”Modify brush settings for existing strokes“ on page 129
Copy the brush settings for the stroke to the template brush. | ”Copy brush settings from existing strokes to the template brush“ on page 73
Apply the brush settings from an existing brush, brush preset, or the template brush to the stroke brush. | ”Apply brush settings to strokes“ on page 74
Make strokes share the same brush. | ”Make strokes share the same brush“ on page 75
Remove brush sharing. | ”To remove brush sharing“ on page 75
Simplify stroke path curves (remove irrelevant CVs). | ”Simplify stroke path curves“ on page 76
Change the shapes of strokes. | ”Change the shape of a stroke“ on page 76
Modify the pressure mappings along the stroke by modifying the stroke pressure curve. | ”Modify stroke pressure values interactively“ on page 78
Erase, smear, or blur existing strokes. | ”Erase, smear, and blur paint“ on page 79

### Modify stroke settings for existing strokes
After painting a stroke, you can change the stroke settings defined for the Paint Effects Tool (display quality, surface offset, pressure mappings), but you can also change a number of other settings.
To modify stroke settings for an existing stroke

1  Select the stroke. For details, see “Select strokes” on page 81.

2  Do one of the following:
   •  In the Attribute Editor, click the strokeShape tab and modify the
     settings.
   •  In the Channel Box, click the strokeShape node (under SHAPES)
     and modify the settings.

For descriptions of the strokeShape attributes, see “stroke Shape
node” on page 97.

Tip  To modify settings for several strokes at the same time (for
example to change the Display Percent), select all the strokes
(Edit > Select All By Type > Strokes), open the Attribute
Spreadsheet, click the Shape Keyable tab, then modify the
settings. For information on using the Attribute Spreadsheet to
modify settings, see the Basics guide.

Modify stroke end bounds

You can reveal a segment of a stroke by “clipping” the stroke end bounds
in the End Bounds section of the strokeShape Attribute Editor. Only the
portion of the stroke within the range defined by the Min Clip and Max
Clip values displays. You can use these options to animate the stroke (for
example, a trickle of water, a burning fuse, a vine growing over an object).
Painting in 3D | 4
Modify existing strokes

Min Clip - Specify the point along the stroke that defines the beginning of the stroke segment. When the Min Clip value is 0, the beginning of the stroke is not clipped.

![Beginning of stroke clipped](image)

Max Clip - Specify the point along the stroke that defines the end of the stroke segment. When the Max Clip value is 1, the end of the stroke is not clipped.

![End of stroke clipped](image)

Modify the direction of the normal
On strokes with tubes, the tubes grow along the normal. You can define the direction of the normal in the Normal Direction section of the strokeShape Attribute Editor. For descriptions of these attributes, see “Normal Direction” on page 100.

Modify pressure mappings for existing strokes
If you use a stylus with pressure mappings when you create a stroke, Paint Effects assigns pressure values to UV points along the underlying stroke path curve. These mappings and values are stored with the stroke and can be modified. You can adjust the Pressure Map, Pressure Min and Pressure Max settings, (for details, see ”Make the brush respond to stylus pressure” on page 56), but you can also adjust the pressure values in the Pressure Mappings section of the strokeShape Attribute Editor. Pressure values range from 0 to 1, where 1 is the maximum pressure.

It is not uncommon for a stroke to have more than 100 pressure values. Although you could individually adjust each value in this pressure array, you can also use a pressure curve to quickly adjust them. For details, see ”Modify stroke pressure values interactively” on page 78.

Copy brush settings from existing strokes to the template brush
You can copy the brush settings of any stroke to the template brush. Once the settings are in the template brush, you can modify them before painting your next stroke, or apply them to other existing strokes.
**Paint Effects, Artisan, and 3D Paint**

**Painting in 3D**

Modify existing strokes >

---

**To copy settings from a stroke to the template brush**

1. Select the stroke you want to copy brush settings from.
2. Select Paint Effects > Get Settings from Selected Stroke. The brush settings are copied to the template brush.

---

**Apply brush settings to strokes**

You can apply brush settings to a stroke from an existing brush (one that is attached to another stroke), a brush preset, or the template brush.

When you apply brush settings to strokes, the brushes attached to each of the strokes remain unique, even though they have the same settings—changes to one do not affect any other. If you want the strokes to share the same brush, use the Paint Effects > Share One Brush option. For details, see “Make strokes share the same brush” on page 75.

---

**To apply preset brush settings to the last stroke**

1. In the Visor (Paint Effects > Get Brush), or on a shelf, click the brush preset with the settings you want to apply to the last painted stroke.
2. Modify brush attributes, if necessary (Paint Effects > Template Brush Settings or use the Ctrl-b (IRIX, Linux and Windows) or Control-b (Mac OS X) hotkey combination). For information on modifying brush attributes, see “Define template brush settings” on page 112.
3. Select Paint Effects > Apply Settings to Last Stroke. The template brush settings are copied to the last painted stroke, replacing its current settings.

---

**To apply preset brush settings to selected strokes**

1. Select the strokes you want to apply brush settings to. For details, see “Select strokes” on page 81.
2. In the Visor (Paint Effects > Get Brush), or on a shelf, click the brush preset with the settings you want to apply to the selected strokes.
3. Modify brush attributes, if necessary (Paint Effects > Template Brush Settings). For information on modifying brush attributes, see “Define template brush settings” on page 112.
4. Select Paint Effects > Apply Settings to Selected Strokes. The template brush settings are copied to the selected strokes, replacing their current settings.

---

**To copy settings from one stroke and apply them to another**

1. Select the stroke you want to copy brush settings from.
2. Select Paint Effects > Get Settings from Selected Stroke. The brush settings are copied to the template brush.
3 Modify brush attributes, if necessary (Paint Effects > Template Brush Settings or use the Ctrl-b (IRIX, Linux and Windows) or Control-b (Mac OS X) hotkey combination). For information on modifying brush attributes, see “Define template brush settings” on page 112.

4 Select the strokes you want to apply the template brush settings to.

5 Select Paint Effects > Apply Settings to Selected Strokes. The template brush settings are copied to the selected strokes, replacing their current settings.

Make strokes share the same brush

Although by default each stroke has a unique brush attached to it, you can force strokes to share a single brush. When strokes share a brush, any changes you make to the brush affect all the strokes that brush is attached to. This is particularly useful if you have many strokes sharing the same look and behavior, for example, the strokes used for hair on a head.

When you attempt to share a brush with several strokes, the stroke attached to that brush must have been the last stroke selected. (The stroke last selected is also called the primary selection object and highlights green by default.) For example, if you want to share the brush attached to strokeFern1 with strokeGrass2, strokeGrass3 and strokeGrass4, you must first select the three Grass strokes, then select strokeFern1.

To make strokes share the same brush

1 Select the strokes you want to share the same brush, but do not select the stroke with the brush you are sharing.

2 Shift-click to select the stroke with the brush you are sharing. This ensures that it is the last selected stroke.

3 Select Paint Effects > Share One Brush. The strokes share the brush of the stroke selected last (the one selected in step #2).

When you modify the attributes of this brush for any one stroke, the changes are reflected on all the strokes sharing that brush.

To remove brush sharing

1 Select the strokes you want to remove brush sharing from.

2 Select Paint Effects > Remove Brush Sharing.

Paint Effects creates a new brush for each stroke using the settings of the shared brush. For example, if you remove brush sharing from three strokes sharing a brush named ferns1, the first created stroke retains the brush named ferns1, and new brushes named ferns2 and ferns3 are created and attached to the other two strokes.
Paint Effects, Artisan, and 3D Paint

Modify existing strokes >

Simplify stroke path curves

The stroke path is defined by an underlying stroke path curve which is comprised of CVs. Just like using the Pencil Curve Tool, painting a stroke can create irrelevant or too many CVs. You can simplify the curve by removing misplaced CVs, making the path through the CVs smoother.

Simplifying stroke path curves using the following method is not the same as rebuilding the curve. The following method attempts to preserve the appearance of the stroke and its tube, while the rebuilding method does not.

| Note | Simplifying the stroke curve removes CVs from the curve. You can also smooth the curve without removing CVs using the Smoothing attribute in the stroke’s strokeShape node. For details, see “Modify stroke settings for existing strokes” on page 71. |

To simplify a stroke curve

1. Select the stroke.

To check that the stroke curve has few CVs

1. Select the stroke.
2. Show the underlying stroke path curve (select Display > Show > Show Geometry > Stroke Path Curves).
3. Select the stroke path curve. For details, see “Define global scene settings” on page 55.
4. Go into CV selection mode. For details, see “Limiting selection by component type” in the Basics guide. Notice the number of CVs on the curve.
5. Hide the underlying stroke path curve (select Display > Hide > Hide Geometry > Stroke Path Curves).
6. Return to object selection mode.

Change the shape of a stroke

You can change the shape of Paint Effects strokes by transforming the CVs on the underlying stroke path curve.
To change the shape of a stroke

1. Select the stroke.

2. Show the underlying stroke path curve (select Display > Show > Show Geometry > Stroke Path Curves).

3. Select the stroke path curve.

4. Go into CV selection mode. For details, see “Limiting selection by component type” in the Basics guide.

5. Select the CVs and translate them.

6. Hide the underlying stroke path curve (select Display > Hide > Hide Geometry > Stroke Path Curves).

7. Return to object selection mode.

Tip Before changing the shape of a stroke, simplify the stroke curve to reduce the number of CVs on the stroke path curve. For details, see “Simplify stroke path curves” on page 76.
Modify stroke pressure values interactively

If you use a stylus with pressure mappings when you create a stroke, Paint Effects assigns pressure values to UV points on the underlying stroke path curve. These values are stored with the stroke. You can adjust each value individually in the Attribute Editor (see “Modify pressure mappings for existing strokes” on page 73), however, this could prove unwieldy given that strokes commonly have more than 100 pressure values.

Alternatively, you can interactively modify the pressure values using stroke pressure curves. A stroke pressure curve is a visual representation of the pressure values along the stroke. By moving control points of the pressure curve towards or away from a stroke, you change the pressure values on the stroke.

In the following example, Tube Length is mapped to pressure for the stroke. A pressure curve for the stroke was edited to produce new pressure values, and therefore new tube lengths.

To modify pressure values interactively

1. In the modeling view, select the stroke.
2  Create the pressure curve as follows:
   • Select Paint Effects > Curve Utilities > Make Pressure Curve > boxshadowup.
     The Make Pressure Curve Options window appears. For descriptions of these options, see “Paint Effects > Curve Utilities > Make Pressure Curve > boxshadowup” on page 95.
   • Set how many control points you want along the pressure curve. The more control points, the smoother the transition between pressure points. Pressure points in between these points are linearly interpolated.
   • Set how far the pressure curve should be offset from the stroke. This has no effect on the pressure values—it just controls the position of the pressure curve, so you can set the scale according to your scene.
   • Click Create. Paint Effects creates the pressure curve on top of the stroke, then offsets the curve in a direction normal to the curve, based on the pressure values multiplied by the offset scale.
     An expression is also created when you create the curve.

3  Edit the pressure curve as follows:
   • Go into CV selection mode
   • Select CVs on the pressure curve and translate them to new pressure values. The distance of the pressure curve from the stroke in 3D affects the pressure values.

4  When you are satisfied with the new pressure values, you can remove the pressure curve. It is no longer needed.
   • Go back into component mode.
   • Select the pressure curve and delete it.

Erase, smear, and blur paint

You can erase, smear, and blur paint in your scene using any brush by setting the brush type to Erase, Smear or Blur, respectively. These brushes affect existing strokes using the shape of the brush you erase, smear, or blur with. For example, if the brush has leaves, the paint smears, blurs, or erases where the leaves are painted.

Erase brushes paint alpha values of 0. The stroke will appear black in the scene painting view and in the final render, which may not produce an erased effect. However, the stroke will create a “hole” in the alpha matte, which may be useful for some compositing workflows.
Paint Effects, Artisan, and 3D Paint

To erase, smear, or blur paint in the scene painting view

1. Switch to the scene painting view (press the 8 hotkey and select Paint > Paint Scene).

2. Do one of the following:
   - If you use a stylus and tablet, modify pressure mappings, if desired (Brush > Tool Settings). You can map up to three brush attributes to the stylus pressure. For information on modifying stylus pressure mappings, see “Make the brush respond to stylus pressure” on page 56.
   - If you want to ignore the pressure mappings, select Brush > Use Stylus Pressure to turn it off. You may want to ignore pressure mappings if you paint with a mouse rather than a stylus.

3. In the Visor (Brush > Get Brush), or on a shelf, click the brush preset you want to erase, smear, or blur with. The selected brush settings are copied to the template brush.

4. Select Brush > Tool Settings and turn on Paint at Depth.


6. Beside Brush Type, select Erase, Smear, or Blur.

7. Under Channels, turn off Depth and make sure Force Depth on is turned off in the Paint Effects Globals.

8. Set Fake Shadows to None, if this is not already the setting.

9. Modify other template brush settings, if necessary. For information on modifying template brush settings, see “Define template brush settings” on page 112.

10. Drag across the area you want to erase, smear or blur.

    Tip: Create some smear and blur type brush presets and save them on a shelf for easy access. For information on storing brushes, see “Create new brush presets” on page 127.
Select strokes

There are a number of ways to select strokes in the modeling and scene painting views. (You cannot select strokes on the Paint Effects canvas.)

**To select strokes in the modeling view**
Click the stroke to select it. Drag to marquee-select more than one stroke.

**To select only strokes in the modeling view**

1. Click the Select by object type icon on the Status Line.
2. Click the Object selection mask down arrow icon on the Status Line and select All Objects Off from the pop-up menu.
3. Right-click the Curves icon and turn on Paint Effects Strokes.
4. Select the desired strokes. You can only select Paint Effects strokes.
5. To return to the default selection mask, click the Selection mask down arrow (left-most) icon on the Status Line and choose Initial Default.

For more information about setting and clearing selection masks, see “Select only certain types of objects or components (selection masks)” on page 48 in the Basics guide.

**To select strokes in the scene painting view**

Ctrl-click (IRIX, Linux and Windows) or Control-click (Mac OS X) on the stroke to select it. Ctrl-Shift-click (IRIX, Linux and Windows) or Control-Shift-click (Mac OS X) to select additional strokes.

**To select strokes by name**

1. Select a stroke.
2. Select Paint Effects > Select Brush/Stroke Names Containing.
3. In the Name Fragment text box, type the name of the stroke, for example, daisy.
4. Click Select Strokes. The strokes of that name are selected.

**To select all strokes in the scene**

In the modeling view or the scene painting view, select Edit > Select All by Type > Strokes.
Delete strokes

When you delete selected strokes using the Backspace (IRIX, Linux and Windows) or Delete (Mac OS X) key on your keyboard, or by selecting Edit > Delete, only the stroke node is deleted—the underlying stroke path curve is not. To delete strokes and their underlying stroke path curves, use the following procedures.

**To delete selected strokes**

1. Select the strokes you want to delete.
2. Open the Outliner or Hypergraph.
3. Shift-click to select the curves associated with each selected stroke.
4. Press the Backspace or Delete key, or select Edit > Delete.

**To delete all strokes**

Do one of the following:

- In the modeling view or the scene painting view, select Edit > Delete All By Type > Strokes.
- Click the Delete All Strokes icon on the toolbar.

Attach brushes to curves

You can manually attach brushes to existing CV or EP curves, in effect, turning the curves into Paint Effects strokes. This is a convenient way to convert existing curves into strokes. Laying the stroke path using a curve may also give you better control over the stroke path (for example, if you want a single stroke to wrap continuously around a 3D object).

**To attach a brush to curves**

1. Do one of the following:
   - Select the brush preset you want to apply to the curves.
   - Get brush settings from an existing stroke. (Select the stroke and select Paint Effects > Get Settings from Selected Stroke.)
2. Modify brush attributes, if necessary (Paint Effects > Template Brush Settings or use the Ctrl-b (IRIX, Linux and Windows) or Control-b (Mac OS X) hotkey combination). For information on modifying brush attributes, see “Define template brush settings” on page 112.

Note Selecting all strokes in the scene also selects hidden strokes.
Modify tube behavior using control curves

You can modify the behavior of Paint Effects tubes using a system of control curves. Control curves are CV or EP curves that are associated with strokes. You can set stroke tubes to follow control curves and you can set them to be attracted to them.

If you are animating your scenes, you can use control curves to make tubes react to movement. When you keyframe the movement of the control curves, the stroke tubes react to that movement according to the tube settings for the stroke. For more information, see “Use control curves to make tubes react to forces” on page 215.

To create stroke control curves

1. Create the curves, making sure the curves start near the stroke and work away from it. The order that the curve CVs are created affects the behavior of the tubes the curves control.

2. Select the curves and the stroke you want to associate them with.


4. Define how the tubes react to control curves using the Curve options in the brush node for the stroke. For details, “Set force attributes” on page 124.
Hide and show strokes and curves

You can hide and show all the strokes, stroke path curves (underlying curves of strokes), and control curves in the scene.

You may want to hide strokes if the wireframe stroke feedback is cluttering your view while you work on other objects in the scene. Although you could change the display quality for the strokes, you would have to do so on a stroke-by-stroke basis.

By default, stroke curves are hidden. You may want to show stroke curves to see the CVs making up the curves. You can then translate the CVs to change the stroke shape.

Control curves influence tube behavior. Hiding control curves will allow you to see the tubes unobstructed in wireframe mode. For information on control curves, see “Modify tube behavior using control curves” on page 83.

**To hide strokes and curves**

Select Display > Hide > Hide Geometry and select what you want to hide:

**Strokes**

Hides all strokes in the scene.

**Stroke Path Curves**

Hides curves associated with the strokes in the scene.

**Stroke Control Curves**

Hides Paint Effects control curves.

**To show strokes and curves**

Select Display > Show > Show Geometry and select what you want to show:

**Strokes**

Shows all strokes in the scene.

**Stroke Path Curves**

Shows curves associated with the strokes in the scene.

**Stroke Control Curves**

Shows Paint Effects control curves.
Modify stroke display quality

When you work in wireframe mode, Paint Effects provides a wireframe representation of the stroke. You can set how closely the wireframe representation resembles the appearance of the rendered stroke by changing the stroke display quality. Display quality ranges from 0 to 100%, with the default being 100%. The lower the display quality, the faster Maya performs.

![Wireframe display quality examples](image)

You can control how the display quality is affected when you reduce it. When simplifying the wireframe display (setting display quality to less than 100%), you can reduce the tubes per step, the segments, or both. The default simplification method is both tubes per step and segments.

For example, if your stroke paints trees, reducing the tubes per step reduces the number of trees along the path, reducing segments reduces the detail of each tree, and reducing both reduces both the number of trees and the detail on each tree.

To modify the display quality of an existing stroke

1. Select the stroke.

2. [Optional] In the Tubes > Creation section of the brush node for the stroke, select the method you want to use to simplify the wireframe representation of the stroke. The default is Tubes and Segments. For details, see “Simplify Method” on page 165.

3. Do one of the following:
   - In the Channel Box, click the stroke shape and change the Display Percent.
   - In the Attribute Editor, click the strokeShape tab and change the Display Quality.
   - Select Display > Stroke Display Quality and select a display percent, or select Custom.
To modify the display quality of the next stroke

1. Select Paint Effects > Paint Effects Tool > 
2. In the Display Quality box, set the display quality. The next stroke you paint will display with this setting.

Convert Paint Effects to polygons

You can convert Paint Effects strokes to polygonal meshes, including construction history, using Modify > Convert > Paint Effects To Polygons. This allows you to:

- render in any renderer, including the Maya Software renderer, mental ray for Maya, the Hardware renderer, and the Vector renderer (For more information, see the Rendering guide.)
- have Paint Effects show up in reflections, refractions and through transparent objects (For more information, see the guides Lights and Cameras, and Shading.)
- use other polygon editing tools on them (For more information, see the Polygonal Modeling guide.)

You can edit brush attributes and see the effect on the output mesh. Shaders that closely match the look of the Paint Effects render are automatically generated and assigned to the resulting meshes. You can optionally choose to output color per vertex and also to bake lighting onto the mesh.

Note  To optimize converting Paint Effects to polygons, see “Optimizing Paint Effects Mesh quality” on page 86.

For descriptions of the options in the Paint Effects To Polygons Options window, see “Modify > Convert > Paint Effects To Polygons > 

Optimizing Paint Effects Mesh quality

When converting Paint Effects to polygons, you can optimize the conversion by keeping some attribute values as low as possible, such as Segments, Leaf Segments, Petal Segments, Sub Segments, Split Max Depth, and Tube Sections. Also the Flatness value should be exactly 1 on leaves and petals as this can dramatically reduce the number of triangles if the Tube Sections value is large.
All the attributes mentioned above are located in different sections of the Paint Effects Brush Settings editor, so it can be time consuming to find and modify them for each brush you want to edit. To save time, we’ve added a Paint Effects Mesh Quality window (Paint Effects > Paint Effects Mesh Quality).

The Paint Effects Mesh Quality window is a collection of attributes from the selected brush and, where indicated, stroke. It refers to the first valid selection found and only represents one brush at a time. The brush may be selected indirectly through a stroke, a surface that was painted on or a mesh that resulted from converting Paint Effects to polygons.

Changing the segments, Leaf Segments and Petal Segments may change the overall shape of the tubes. You can compensate for this somewhat on leaves and petals by adjusting the leaf and petal Stiffness, which also appear in this window. For segments you may need to modify Force attributes in the Paint Effects Brush Settings editor.

You can increase the number of sub segments without affecting the tube shape, although this will not remove nickeling as the sub segments are linearly interpolated between the main segments. Sub segments are most useful if the brush has displacement turned on and you want to better resolve the displacement texture with more triangles, but don’t want to affect the overall shape of the tubes. There may be other situations where more triangles are desired, but you don’t want to affect the overall tube shape.

Paint Effects Mesh Settings can be useful in simplifying both normal Paint Effects strokes as well as strokes that have been converted to polygons.

**Reference**

**Paint Effects > Paint Effects Globals**

**Scene**

These are the Paint Effects Globals options in the Scene section.

**Scene Scale**

Set the factor you want the template brush global scale adjusted by when you paint in the scene. For example, if the global scale for the template brush is set to 2, and you set the scene scale to 0.5, the template brush will use a global scale of 1 when you paint in the scene. For information on setting the global scale for a brush, see “Set the global scale” on page 116.
Scene Wrap H, Scene Wrap V

These wrap options are useful for creating seamless repeating textures that are animated. For information, see ”Create animated textures” on page 215.

You can also use them in 3D to make a cartoon-like repeating environment (for example, a tree that moves horizontally across the scene as a cartoon character runs past, then repeats the movement).

Although the strokes do not appear to wrap in wireframe, they will wrap when you render the scene.

Turn on Wrap H to “wrap” the scene view plane horizontally. Any strokes that go past the top or bottom of the view plane will continue on the opposite edge as if the view plane were joined along the left and right edges.

Turn on Wrap V to “wrap” the scene view plane vertically. Any strokes that go past the left or right of the view plane will continue on the opposite edge as if the view plane were joined along the top and bottom edges.

Force Real Lights

When a stroke brush has “Real Lights” turned on, the shading and specular highlights on the paint are determined by the lights that are actually in the scene. Turn on Force Real Lights to force the Real Lights option on for all new strokes, regardless of the template brush setting. This means your scene must have lights, or the paint will not be illuminated. After painting the stroke, you can turn off Real Lights in the brush node for the stroke.

Force Depth

Turn this option on to force the Depth option on for all new strokes, regardless of the template brush setting. This is useful if you are painting in a scene using depth, and want to ensure that all your strokes use depth, even if the brushes you paint with do not. See ”Depth” on page 137.

Paint Effects > Paint Effects Tool

This allows you to paint strokes with Paint Effects brushes. For more information, see ”Painting in 3D” on page 53.

Paint Effects > Paint Effects Tool > □

These are the options in the Paint Effects settings editor that you can use to define Stroke Settings.
Paint at Depth

When Paint at Depth is off, the depth values of the paint change as you drag the brush into the scene. If the stroke has tubes, the tubes “grow” from the surface you paint. This is the default.

When Paint at Depth is on, the depth value of the stroke is determined when you first click the brush, and is then fixed at that value. If the stroke has tubes, the tubes “grow” from the plane orthogonal to the path at each step. This is useful for creating effects where you want tubes to sprout out from the path (for example, a fountain, smoke from a chimney, or a tail). The Paint Effects Tool cursor changes to project ortho-normal to the view, to indicate you are painting at depth.

You cannot change this setting after painting the stroke.

Display Quality

Set the display quality of the wireframe for the next stroke. The higher the percentage, the more closely the stroke wireframe represents the rendered stroke. The results of this option depends on the Simplify Method defined for the template brush. You can select to have the display percent affect the number of tubes per step, the number of segments, or both.

You can change this setting after painting the stroke. For more information, see “Modify stroke display quality” on page 85.

Surface Offset

Set the distance (in world units) you want the next stroke offset from the object or plane you paint the stroke on. Offsetting the stroke is not the same as translating it. When you offset the stroke, the stroke is created normal to and a uniform distance from the stroke path, so if the surface is convex, the stroke will be bigger than the stroke path. Similarly, if the surface is concave, the stroke will be smaller than the stroke path. The cursor changes to reflect the displacement value.
Paint Effects, Artisan, and 3D Paint

Painting in 3D | 4
Optimizing Paint Effects Mesh quality

Stroke offset by 0.5
Stroke offset by -0.5

Tip
You can change this setting after painting the stroke. For more information, see “Modify existing strokes” on page 70.

Pressure Mapping 1, 2, and 3
Select which value you want to map to pressure. You do not need to map all three brush attributes to stylus pressure. Select Off for no pressure sensitivity.

Pressure Min 1, 2, and 3
Set the minimum pressure at which the pressure mapping will start to take effect. The minimum attribute value that you can paint is determined by multiplying the Pressure Min by the value set for the mapped attribute. For example, if you map Tube Length to pressure, and the tube length for the stroke is 3, and the Pressure Min is 0.5, no matter how lightly you press on the stylus, the tube length will never be less than 3 x 0.5, or 1.5. Use the lowest minimum pressure possible to increase the range of the mapping.

Pressure Max 1, 2, and 3
Set the maximum pressure at which the pressure mapping will take effect. The maximum attribute value that you can paint is determined by multiplying the Pressure Max by the value set for the mapped attribute. For example, if you map Tube Length to pressure, and the tube length for the stroke is 3, and the Pressure Max is 2, when you press as hard as possible, the tube length will be 3 x 2, or 6.
Paint Effects > Make Paintable

Allows you to paint the selected NURBS or polygonal objects. To paint on NURBS or polygonal objects, you must first make the objects paintable. For more information, see “Paint on objects” on page 63.

Paint Effects > Paint on Paintable Objects

By default this is on and allows you to paint on the paintable objects. If you want to paint on the grid plane in Perspective view instead, then select Paint on View Plane (see “Paint Effects > Paint on View Plane”). These two menu items - Paint on Paintable Objects and Paint on View Plane - are toggles; when one is selected, the other is turned off.

If this is on (check mark beside the menu item) and there are no paintable objects in the scene, your strokes will lie on the grid plane of the perspective view.

Paint Effects > Paint on View Plane

This allows you to pain on the grid plane in the Perspective view. For more information, see “Paint on the grid plane of the perspective view” on page 62. This menu item and the menu item “Paint on Paintable Objects” are toggles; when one is selected, the other is turned off. (See “Paint Effects > Paint on Paintable Objects.”)

Paint Effects > Apply Settings to Last Stroke

Applies brush settings from the specified brush to the last stroke. For more information, see “Apply brush settings to strokes” on page 74.

Paint Effects > Apply Settings to Selected Strokes

Applies brush settings from the specified brush to the selected strokes. For more information, see “Apply brush settings to strokes” on page 74.

Paint Effects > Get Settings from Selected Stroke

Copies the brush settings of the selected stroke to the template brush. For more information, see “Copy brush settings from existing strokes to the template brush” on page 73.
Paint Effects > Share One Brush

Forces the selected strokes to share the brush of the last selected stroke. When strokes share a brush, any changes you make to the brush affect all the strokes that brush is attached to. For more information, see "Make strokes share the same brush" on page 75.

Paint Effects > Remove Brush Sharing

Removes brush sharing from the selected strokes. For more information, see "Make strokes share the same brush" on page 75.

Paint Effects > Select Brush/Stroke Names Containing

Selects the brushes/strokes containing the name specified in the Name Fragment text box. For more information, see "To select strokes by name" on page 81 or "To select multiple brushes by name" on page 130.

Paint Effects > Auto Paint > Paint Grid

Use this to paint multiple strokes in a grid on a NURBS or polygonal surface. The grid settings are based on the options specified below. For more information, see "Automatically paint multiple strokes on a surface" on page 69.

Paint Effects > Auto Paint > Paint Grid > □

These are the options in the Auto Paint Grid window.

Spans U, Spans V

Sets the number of lines to draw in U and V to define the grid.

Curve Degree

Defines the degree of curve on surfaces generated. The higher the degree, the smoother and tighter the curve.

Strokes Per Span

Sets the number of strokes to create along each grid line.

Points Per Curve

Sets the number of points on each stroke path curve (curve on surface) created.
Grid Smear
Sets the amount of displacement of the lines using a 2D noise function. When this option is 1.0 the lines are randomized to the full width of their row or column.

Smear Frequency
Sets the frequency of the noise applied with Grid Smear. Lower values create a smoother noise offset.

Sample Density
Sets the Sample Density attribute of the created strokes. Higher values result in smoother strokes and a greater tube density. For more information see “Modify existing strokes” on page 70.

Surface Offset Min, Max
Sets a range of Surface Offset values. The Surface Offset for created strokes is randomized between these values. You could use this, for example, to create a cloud of strokes about a surface. For details on Surface Offset, see “Set up to paint in 3D” on page 55.

Edge U, Edge V
Turn these options on to create the boundary lines of the grid in U and V. When these options are turned off, strokes are not created along the boundary lines.

Equalization
Modulates the Sample Density for the created strokes based on the length of the stroke path curves (curves on surface). This helps keep tubes more evenly distributed.

Share One Brush
Turn this option on to make all strokes share one brush. When this brush is off, a separate brush is created for each stroke. For information on brush sharing, see “Make strokes share the same brush” on page 75.

Paint Effects > Auto Paint > Paint Random
Use this to paint multiple strokes randomly on a NURBS or polygonal surface. The random settings are based on the options specified below. For more information, see “ Automatically paint multiple strokes on a surface” on page 69.

Paint Effects > Auto Paint > Paint Random > □
These are the options in the Auto Paint Random window.
Painting in 3D | 4
Optimizing Paint Effects Mesh quality >

Spans U, Spans V
Sets the number of lines to draw in U and V to define the grid.

Random Offset
Set a value to randomize the offset for the stroke from the grid center. A value of 1.0 makes the offset totally random within the grid.

Stroke Length
Set the length of the strokes relative to the grid. A value of 1.0 is the size of a grid cell.

Sample Density
Sets the Sample Density attribute of the created strokes. Higher values result in smoother strokes and a greater tube density. For more information see “Modify existing strokes” on page 70.

Surface Offset Min, Max
Sets a range of Surface Offset values. The Surface Offset for created strokes is randomized between these values. You could use this, for example, to create a cloud of strokes about a surface. For details on Surface Offset, see “Set up to paint in 3D” on page 55.

Clip Edges
Turn this option on to clip the strokes to the surface. When this option is off, the strokes can go outside the boundaries of the grid.

Equalization
Modulates the Sample Density for the created strokes based on the length of the stroke path curves (curves on surface). This helps keep tubes more evenly distributed.

Share One Brush
Turn this option on to make all strokes share one brush. When this brush is off, a separate brush is created for each stroke. For information on brush sharing, see “Make strokes share the same brush” on page 75.

Paint Effects > Curve Utilities > Simplify Stroke Path Curves
You can simplify the curve by removing misplaced CVs, making the path through the CVs smoother. For more information, see “Simplify stroke path curves” on page 76.
Paint Effects > Curve Utilities > Set Stroke Control Curves

You can modify the behavior of tubes using a system of control curves. For more information, see “Modify tube behavior using control curves” on page 83.

Paint Effects > Curve Utilities > Attach Brush to Curves

You can manually attach brushes to existing CV or EP curves, in effect, turning the curves into Paint Effects strokes. For more information, see “Attach brushes to curves” on page 82.

Paint Effects > Curve Utilities > Make Pressure Curve

This lets you create a stroke pressure curve, which is a visual representation of the pressure values along the stroke. For more information, see “Modify stroke pressure values interactively” on page 78.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>When you have finished editing with a pressure curve it is a good idea to delete it. Pressure curves have an associated expression and this should also be deleted. You can find the expression using the Expression Editor and listing expressions by name. It is safest to delete the expression before deleting the pressure curve.</td>
</tr>
</tbody>
</table>

Paint Effects > Curve Utilities > Make Pressure Curve > □

These are the options in the Make Pressure Curve Options window.

Control Points

Set how many control points you want along the pressure curve. The more control points, the smoother the transition between pressure points. Pressure points in between these points are linearly interpolated.

Offset Scale

Set how far the pressure curve should be offset from the stroke. This has no effect on the pressure values—it just controls the position of the pressure curve, so you can set the scale according to your scene.
Paint Effects > Paint Effects Mesh Quality

This opens the Paint Effects Mesh Quality window. Depending on the mesh brush stroke(s) selected, different attributes appear in this window. For more information, see “Optimizing Paint Effects Mesh quality” on page 86.

Modify > Convert > Paint Effects To Polygons

This converts the selected Paint Effects strokes to poly meshes, and it includes construction history. For more information, see “Convert Paint Effects to polygons” on page 86.

Modify > Convert > Paint Effects To Polygons > □

These are descriptions of the options in the Paint Effects To Polygons Options window.

Vertex Color Mode

The default is None. Other options include Color and Illuminated.

Quad Output

Turn this on to output to quads. The default is off, defaulting output to triangles.

Hide Strokes

Turn this on to hide the Paint Effects strokes once they’re converted to Polygons. Even if a stroke is hidden, its attributes can still be updated and will affect the polygon mesh. The default is on.

Poly Limit

This value indicates that when converting the Paint Effects stroke to polygons, it should stop after it has reached approximately this number of faces. This can be used to avoid creating excessively large meshes that could cause you to run out of memory. The default is 100 000. A value of 0 indicates no limit.

stroke Shape node

These are the attributes in the strokeShape node you set when working with Paint Effects.

Related topics

- “Paint in 3D” on page 56
stroke Shape node

Contains the default name of the stroke shape node.

Position Stroke

This option is only useful on strokes painted on objects. It has no effect on strokes painted on the view plane or grid plane of the perspective view. You can use it to create textures from strokes painted on 3D objects (for details, see “Create textures from painted 3D objects” on page 226). Select one of the following:

- in 3D Displays the stroke on the surface, as painted.
- on View Plane Displays the stroke between 0 and 1 in world space on the XY plane (near the origin). Think of this space as a texture map—each point on the texture corresponds, or maps, to a point on the paintable surface. Any strokes on the surface are drawn in this area. However, when you do a post-process render, the strokes render on the view plane.

Sample Density

As you paint, Paint Effects samples points on the stroke. At each sample point, Paint Effects “plants” tubes, grows previously planted tubes by a segment, and applies paint stamps to the stroke. You can adjust the number of sample points after painting the stroke by changing the Sample Density. The default density is 1. Increasing the density increases the number of samples.

For example, suppose you have two strokes painted with the same template brush settings, the first which was painted very quickly, and therefore has few sample points, and the second which was painted very slowly, and therefore has many sample points. The strokes will look quite different. You could make the first stroke more similar to the second by increasing its sample density.
Seed

This option sets the sequence of random numbers used for brush attributes that are randomized (for example, tube length and width, and HSV values). By default, each stroke you paint has a different seed number to ensure that strokes with identical attributes and randomization values look different. Setting a different seed number for a stroke will apply a different set of random numbers to the randomized attributes, making the stroke look different. To make otherwise identical strokes look the same, use the same seed number.

Draw Order

Set the order that strokes paint in the scene. You may want to change the draw order to layer different types of strokes (for example, you could paint opaque strokes first, then transparent strokes). Strokes with lower numbers draw first, followed by strokes with larger numbers. By default, all strokes have a draw order of 0.

Surface Offset

Set the distance (in world units) you want to offset the stroke from the object or plane it’s painted on. For more information, see “Surface Offset” on page 90 in the Paint Effects Tool settings.

Smoothing

The path of a stroke is defined by an underlying stroke path curve which is comprised of CVs. Just like using the Pencil Curve Tool, painting a stroke can create irrelevant CVs. Use this option to dampen the effects on the stroke path curve of spurious or misplaced CVs by recalculating the smoothest path through the CVs.

Specify the amount of smoothing to be calculated. A Smoothness setting of 0 causes no smoothing.

You can also use smoothing to soften the transition between multiple surfaces.
Motion Blurred

When you render an animation, motion blur gives the effect of speed and movement by blurring objects in the scene. When Motion Blurred is turned on, the stroke will appear blurred. If Motion Blurred is turned off, it will appear sharp. You must also turn on Motion Blur in the Motion Blur section of the Render Globals window. For details, see the Rendering guide.

Primary Visibility

When Primary Visibility is turned on, the stroke is visible in the view and renders. When its turned off, the stroke is visible in the view but it does not render. If Primary Visibility is turned off and Cast Shadows is turned on (see “Cast Shadows” on page 158), the stroke’s shadow renders.

End Bounds

These are the stroke Shape attributes in the End Bounds section.

Min Clip

Specify the point along the stroke that defines the beginning of the stroke segment. When the Min Clip value is 0, the beginning of the stroke is not clipped.

Max Clip

Specify the point along the stroke that defines the end of the stroke segment. When the Max Clip value is 1, the end of the stroke is not clipped.

Normal Direction

These are the stroke Shape attributes in the Normal Direction section.

Use Normal

Turn on Use Normal to use the normal defined by the coordinates set below the option. If Use Normal is off, strokes painted on objects use the surface normals, strokes not painted on objects use stroke path curve normals.
Normal

Specify the direction of the normal. This normal is used only when Use Normal is turned on.

Pressure Mappings
These are the stroke Shape attributes in the Pressure Mappings section.

Pressure Mapping 1, 2, and 3
Select which value you want to map to pressure. You do not need to map all three brush attributes to stylus pressure. Select Off for no pressure sensitivity.

Pressure Min 1, 2, and 3
Set the minimum pressure at which the pressure mapping will start to take effect. The minimum attribute value that you can paint is determined by multiplying the Pressure Min by the value set for the mapped attribute. For example, if you map Tube Length to pressure, and the tube length for the stroke is 3, and the Pressure Min is 0.5, no matter how lightly you press on the stylus, the tube length will never be less than 3 x 0.5, or 1.5. Use the lowest minimum pressure possible to increase the range of the mapping.

Pressure Max 1, 2, and 3
Set the maximum pressure at which the pressure mapping will take effect. The maximum attribute value that you can paint is determined by multiplying the Pressure Max by the value set for the mapped attribute. For example, if you map Tube Length to pressure, and the tube length for the stroke is 3, and the Pressure Max is 2, when you press as hard as possible, the tube length will be 3 x 2, or 6.

Input Curves
These are the stroke Shape attributes in the Input Curves section.

Path Curve
This contains an array of curves to use as the stroke path, along with a number of points to sample along each curve. The curves are sampled in the order they appear in this list to produce a single set of output points and normals which define a poly line path for the Paint Effects stroke. By default the resulting points will correspond to the list of points sampled while you painted the stroke. If the stroke crossed multiple surfaces there will be a separate curve created each time you paint across a surface boundary.
Mesh Output

These are the stroke Shape attributes in the Mesh Output section.

Color Per Vertex

Use this to control the color per vertex. The default is None. Other options in the drop-down list include Color and Illuminated.

Hard Edges

When turned on, this affects the lighting of the object and makes the edges around tubes hard when using the Mesh Brush Type. For more information, see the Mesh Brush type.

Output Quads

Output to quads or triangles. The default is off, defaulting output to triangles.

Poly Limit

This value indicates that when converting the Paint Effects stroke to polygons, it should stop after it has reached approximately this number of faces. This can be used to avoid creating excessively large meshes that could cause you to run out of memory. The default is 100 000. A value of 0 indicates no limit.

Camera Point

If Forward Twist is turned on, then when you convert Paint Effects to polygons the perspective camera is connected to this attribute so you can maintain the twist on the polygons when the view changes.

Mesh Vertex Details

These are the stroke Shape attributes in the Mesh Vertex Details subsection of the Mesh Output section.

Main Vertex Buffer, Leaf Vertex Buffer, Flower Vertex Buffer

These attributes keep track of how many vertices were created the last time the polygon mesh was evaluated. They are used to preallocate the right amount of memory.
Painting in 3D | 4
stroke Shape node >
Painting in the Paint Effects Panel

About

There are some things you can do in the Paint Effects panel that are common to the canvas view and to the scene painting view, including how to:

- "Switch between views" on page 103
- "Show and hide the Paint Effects panel toolbar" on page 104
- "Save a snapshot of the Paint Effects panel view" on page 105
- "Save depth as grayscale values" on page 106
- "Change the Brush Type" on page 107
- "Change the panel lighting" on page 107
- "Display RGB, luminance, or alpha channels" on page 107
- "Switch between a stylus and the mouse" on page 109

For information on painting in the canvas view, see "Painting in 2D" on page 33.

For information on painting in the scene painting view, see "Automatically paint multiple strokes on a surface" on page 69.

How do I?

Switch between views

You will want to switch between the following three views while working in Paint Effects:

- the modeling view
- the canvas (Paint Effects panel)
- the scene painting view (Paint Effects panel)

The canvas and scene painting views are in the Paint Effects panel. You can open the Paint effects panel in the workspace area, or as a separate window.

To open the Paint Effects panel in the workspace area

Select Panels > Panel > Paint Effects.
To open the Paint Effects panel as a separate window
Select Window > Paint Effects.

To switch from the canvas to the scene painting view
In the Paint Effects panel, select Paint > Paint Scene.

To switch from the scene painting view to the canvas
In the Paint Effects panel, select Paint > Paint Canvas.

To switch between the Paint Effects panel in the workspace and the modeling view
Do one of the following:
• Press the space bar on your keyboard.
• Press the 8 hotkey.

Show and hide the Paint Effects panel toolbar
The Paint Effects panel toolbars provide shortcuts to common actions. The canvas and the scene painting view have different toolbars.

To show/hide the toolbar
Select Display > Toolbar.
Save a snapshot of the Paint Effects panel view

Saving a snapshot is like taking a photograph of the panel and saving it as an image that you can view or modify. You can save snapshots of the canvas and the Paint Effects scene painting view.

**To save a snapshot**

1. Select Paint > Save Snapshot or click the Save Snapshot icon on the toolbar.

   The Save Image (IRIX, Linux) or Save (Windows and Mac OS X) window opens.

2. Type the name of the snapshot, including the file extension (for example, forest.iff).
Save depth as grayscale values

When you paint with brushes that have the Depth setting turned on (see "Depth" on page 137) or the Paint EffectsGlobals depth override turned on (see "Force Depth" on page 88), Paint Effects records the distance of the paint from the camera in the depth channel (or Zdepth or Zbuffer channel). You can save the depth values as grayscales for later use (for example, as a bumpmap).

Tip

If you plan to transfer files between IRIX, Linux and Windows, do not put spaces in the filenames.

3 Click Save. Maya saves the contents of the image in Maya image format (.iff) under the specified name (regardless of the specified file type).
To save depth as grayscale values
Select Paint > Save Depth as Grayscale.

Change the Brush Type
You can change the Brush Type for the selected brush (template brush) to Paint, Smear, Blur, or Erase from the Brush menu. No other brush attributes are affected. For information on Brush Type, see “Select the brush type” on page 113.

Change the panel lighting
Use the lighting commands on the Object Shading menu to select which lights to use in the canvas or scene. These options include:

- Use Default Lighting
  Surfaces appear fully illuminated by the Paint Effects default light.

- Use All Lights
  Surfaces appear illuminated by all lights in the scene.

Display RGB, luminance, or alpha channels
Each pixel in a color rendered image consists of three values or channels. Each of the three channels represents the amount of red, green, or blue in the image. Maya image files also contain an alpha channel (or mask channel) which represents the presence and opaqueness of objects, and a luminance channel which represents the intensity or brightness of the image.

You can display each of these channels individually as planes using the options on the Display menu. If you are in the scene painting view, the values that display are for the snapshot of the view, not just the rendered strokes.

- Red Channel
  Display the red values channel for the image.

- Green Channel
  Display the green value channel for the image.

- Blue Channel
  Display the blue value channel for the image.

- All Channel
  Display the red, green, and blue channel planes.
Display RGB, luminance, or alpha channels

You can also use the Display RGB Channels icon on the toolbar.

Luminance

Display the luminance values channel for the image.

Alpha Channel

Display the alpha values channel for the image.
You can also use the Display Alpha Channel icon on the toolbar.

Note  Alpha channels for the scene painting view are completely white. To see the alpha of the scene painting view, render the scene (Render > Render Current Frame) and in the Render View, select the Display > Alpha Channel.

Switch between a stylus and the mouse

By default, Paint Effects is set up to use a stylus and tablet when you paint in the Paint Effects panel. If you paint in the Paint Effects panel with a mouse, you must select Brush > Use Stylus Pressure to turn the option off.
Switch between a stylus and the mouse >
6 Working with brushes

About Working with brushes

You can create an unlimited variety of strokes by modifying brush settings. Specifically, you can:

- “Select preset brushes” on page 111
- “Define template brush settings” on page 112
- “Reset the template brush” on page 127
- “Create new brush presets” on page 127
- “Modify brush settings for existing strokes” on page 129
- “Select brushes in your scene” on page 129
- “Map file textures to color and opacity” on page 130
- “Blend preset brush settings” on page 133

How do I? Select preset brushes

Paint Effects includes hundreds of saved brushes called preset brushes. These are stored in the your mayapath/brushes folder. You can also create your own preset brushes and store them either to a shelf or to a Visor subdirectory.

When you select a preset brush, its settings are copied to the template brush where you can tweak them before painting your stroke.

If you do not select a brush preset before painting, the next stroke you paint uses the current settings for the template brush.

To select a brush preset

In the Visor or on a shelf, click the icon for the brush preset you want to paint with.

To open the Visor, select Window > General Editors > Visor, or in the Paint Effects panel, click the Get Brush button on the toolbar.

If you select the preset brush in the Visor, the icon becomes highlighted with a yellow border, indicating that the brush settings were copied to the template brush.
Define template brush settings

Each time you paint a stroke, Paint Effects creates a new brush and attaches it to the stroke. The template brush settings define the initial settings for this brush. Any changes you make to the template brush settings affect what the next stroke looks like, but they do not affect any previously painted strokes.

To define template brush attributes

1. Select the brush preset you want to base the next stroke on. The settings for the selected brush are copied to the template brush. If you do not select a brush preset, the default brush settings are used.

2. To open the Paint Effects Brush Settings window, do one of the following:
   - In the scene view, select Paint Effects > Template Brush Settings.
   - In the Paint Effects panel, click the Edit Template Brush button on the toolbar.
   - Use the Ctrl-b (Windows, IRIX, and Linux) or Control-b (Mac OS X) hotkey combination.

3. Define the desired template brush settings:
   - “Select the brush type” on page 113
   - “Set the global scale” on page 116
   - “Set which channels are created and modified” on page 117
   - “Set the brush profile” on page 117
   - “Set Thin Line Multi Streaks” on page 117
   - “Set mesh attributes” on page 117
   - “Set shading attributes” on page 119
   - “Set tube shading attributes” on page 120
   - “Map textures to color and opacity” on page 120
   - “Illuminate stroke paint” on page 120
   - “Create shadows and shading” on page 120
   - “Make paint glow” on page 122
   - “Create tubes” on page 122
   - “Define growth behavior” on page 123
   - “Map value ranges to tube length” on page 125
   - “Use MEL scripts to apply custom effects” on page 125
   - “Create gaps in tubes” on page 126
   - “Set flow animation attributes” on page 127
Select the brush type

Select the type of brush you want to paint with. All brush types use the shape defined by the brush attributes. For example, if you paint over a stroke with a Blur brush that has tubes, blurring occurs where the tubes cross over the paint, not along the Blur stroke path.

For more information, see “Paint Effects Brush Settings” on page 135, specifically “Brush Type.”

Note You can also paint using textures. See “Texture Type” on page 149.

ThinLine brush type

The ThinLine brush allows you to render large numbers of fine tubes much more quickly than the Paint brush type. It uses a direct anti-aliased line draw rather than a series of brush stamps. A new Multi Streak method is also available when this Brush Type is used. In combination with the Multi Streak method, the ThinLine Brush Type can be up to 100 times faster for hair than the Paint Brush Type with better line detail. In addition, new looks are possible using the Multi Streaks, such as wet clumping hair.

Note When using a large value for Tube Width with the ThinLine brush type, this may result in artifacts.
Mesh brush type

The Mesh type of brush renders Paint Effects using triangulated tubes instead of brush stamps. This results in accurate conical geometry with textures that correctly map on the surface. Flat surfaces are rendered more accurately than when the Paint Brush Type is used. While the Paint Brush Type is generally better when representing soft, fuzzy volumes, the Mesh Brush Type is better at hard surfaces.
The Mesh Brush Type allows for the creation of Paint Effects trees and plants that are convincingly realistic from both a distance and close-up. This is achieved through the use of hard-edged geometry (such as buildings) and per-pixel lighting on the mesh, including specular highlights. A built-in environment map on the brush facilitates the simulation of reflective surfaces (see "Set mesh environment reflections" on page 118). Displacement and bump mapping are also incorporated to enhance the detail of the mesh surface (see "Set mesh displacement/bump mapping" on page 119). The triangles representing the mesh are dynamically generated at render time, enabling the use of a large number of triangles without exceeding memory constraints.

Another feature enabled by the mesh representation is the conversion of Paint Effects to Polygons. For more information, see "Convert Paint Effects to polygons" on page 86.

Example of tree created using the Mesh Brush Type
Image courtesy of Duncan Brinsmead
**Set the global scale**

Use the Global Scale setting to adjust brush attribute values by a common factor. This scales the paint effect uniformly so you can paint the same effect, but in different sizes.

| Global Scale = 1 | Global Scale = 2 |

**Tip** You can use the b hotkey to interactively change the global scale. For information on other Paint Effects hotkeys, see “Define Paint Effects hotkeys” on page 30.
Set which channels are created and modified

Each pixel in a (color) rendered image consists of three values or channels. Each of the three channels represents the amount of red, green, or blue in the image.

Some image files can also contain a fourth or fifth channel of information. An alpha channel (or mask channel) represents the presence and opaqueness of objects. A depth channel (or Z depth or Z buffer channel) represents the distance of objects from the camera. These two channels are used by compositing software (for example, Maya Composer or Maya Fusion). For example, you can use the alpha channel of an image as a matte to composite an object (without its background) with another image, or you can use the depth channel to correctly composite several transparent objects over each other.

By default, Paint Effects generates an image file of the strokes in the scene with three color channels and an alpha channel. You can specify whether Paint Effects saves depth information (creates a depth channel), and whether the individual channels are updated with the stroke information in the Channels section of the Paint Effects Brush Settings window. For descriptions of the Channel options, see “Channels” on page 137.

Set the brush profile

Use the settings in the Brush Profile section of the Paint Effects Brush Settings window to define the brush profile. For descriptions of the Brush Profile options, see “Brush Profile” on page 138.

Set Thin Line Multi Streaks

Use the settings in the Thin Line Multi Streaks section of the Paint Effects Brush Settings window to define the Thin Line Multi Streaks. For descriptions of the Thin Line Multi Streaks options, see “Thin Line Multi Streaks” on page 141.

Set mesh attributes

Use the settings in the Mesh section of the Paint Effects Brush Settings window to define the mesh brush. For descriptions of the Mesh options, see “Mesh” on page 142.

Set mesh thorn attributes

Large numbers of thorns may be generated off the surfaces of the triangles created when using the Mesh Brush Type. These thorns are drawn using the rendering method associated with the ThinLine Brush Type and render quickly. They are single segment tubes, and do not appear in the
wireframe representation of the strokes. You can use these to add thorns and prickles to plants or to create furry or fuzzy tubes. For descriptions of these options information, see “Thorns on Mesh” on page 143.

| Note | Thorns on Mesh are only created at render time. |

Example of thorns on mesh

Set mesh environment reflections

A simple ramp-based environment may now be used in conjunction with the Mesh Brush Type. This can be used to create looks such as chrome, water, glass, shiny paint, etc. For descriptions of these options, see “Mesh Environment Reflections” on page 144.
Set mesh displacement/bump mapping

In the Texturing section of the Brush Settings window, you can apply displacements to the triangles created when using the Mesh Brush Type. If Per Pixel Shading is used, then a bump map is also applied along with the triangle displacement.

The options used to control the mesh displacement/bump mapping are: Map Displacement, Displacement Scale, Displacement Offset, Bump Intensity, Bump Blur, and Use Luminance. For descriptions of these options, see “Texturing” on page 148.

Set shading attributes

Use the settings in the Shading section of the Paint Effect Brush Settings window to define shading brush attributes. For simple strokes, these settings define the shading of the paint applied along the stroke path. For strokes with tubes, these settings define the shading of the paint applied to the tube roots. For descriptions of these attributes, see “Shading” on page 144.
Set tube shading attributes

The settings in the Tube Shading section of the Paint Effects Brush Settings window apply to brushes with tubes only. Use them to define shading of the paint applied to the tube tips. For descriptions of these attributes, see “Tube Shading” on page 146.

Map textures to color and opacity

Although in Maya, you can typically right-click a color box and select Create New Texture to map a texture to it, this is not the case in Paint Effects. To map textures to tube Color and Opacity, you must use the options in the Texturing section of the Paint Effects Brush Settings window. For descriptions of these attributes, see “Texturing” on page 148.

Illuminate stroke paint

When light shines on an object, it illuminates the object’s surface. Without light, you could not see surfaces. The paint on a stroke behaves like a surface, and therefore requires light for you to see it.

You can use the lights in your scene to illuminate paint (real lights), or you can use a Paint Effects light that only affects the stroke paint and nothing else in the scene.

Note

If you are using the Paint Effects light, make sure Force Real Lights is turned off in Paint Effects Globals (Paint Effects > Paint Effects Globals > Scene).

Create shadows and shading

When light shines on a surface, parts of the surface facing towards the light source are illuminated, and the parts of the surface facing away from the light source appear shaded. If one surface is located between a second surface and the light source, then the first surface will cast a shadow onto the second surface. By default, Paint Effects strokes do not cast shadows or produce shading effects, however, you can create them. You can create several types of shadows and shading:

- fake shadows (which are not true shadows, but are very quick to render)
- back shadows (which shade the back side of an object) and center shadows (which shade the center area of a patch of tubes)
tube root shadows (which shade tubes at the root)
depth map shadows (strokes cast shadows on surfaces)

Notes
- You can use both depth map shadows and fake shadows (see “Fake Shadow” on page 156). They do not interfere with each other.
- Strokes do not cast raytraced shadows, only depth map shadows.

Use the options in the Shadow Effects section of the Paint Effects Brush Settings window to create these shading effects. For descriptions of these attributes, see “Shadow Effects” on page 156.

Fake shadows
Instead of using depth map shadows to cast shadows on surfaces, you can use “fake” shadows, which take less time to render and are sufficiently realistic on strokes that are on flat surfaces. See “Fake Shadow” on page 156.

Back and center shading
Both of these shading techniques are quick to render. See “Back Shadow” and “Center Shadow” on page 157.

Tube root shading
Tube roots are not typically exposed to light (think of grass or fur), which means the tips are illuminated and the roots are shaded.

The following shadowing options simulate this effect by shading the roots. This shading technique is particularly effective for shading plant stems. See “Depth Shadow Type,” “Depth Shadow,” and “Depth Shadow Depth” on page 158.

Cast shadows on objects (depth map shadows)
This is the most realistic shadowing technique, but takes longer to render. Using depth map shadows, the stroke can cast shadows on other surfaces, but it can also cast shadows on its own surfaces (tubes can cast shadows on other tubes in the same stroke). Objects can also cast shadows on strokes. See “Cast Shadows” on page 158.

This technique works only if the stroke uses Real Lights (see page 154).
Make paint glow
You can add two types of glow effects to paint: standard Glow and Shader Glow. Add these effects in the Glow section of the Paint Effects Brush Settings window. For descriptions of these attributes, see “Glow” on page 158.

Create tubes
When you paint with tubes, Paint Effects plants tubes along the stroke path. These tubes can grow into an almost infinite variety of shapes and forms, depending on the settings you define in the Creation, Growth, Behavior, Length Mappings, and User MEL Scripts sections. Tube settings are in the Tubes section of the Paint Effects Brush Settings window. For descriptions of these attributes, see “Tubes” on page 159.

Tube creation attributes
The settings in the Tubes > Creation section of the Paint Effects Brush Settings window define how tubes are initially created. For descriptions of these attributes, see “Creation” on page 160.

Set growth attributes
As part of the growth simulation, tubes can sprout branches, twigs, leaves, flowers, and buds. Although you can apply these settings literally to simulate plant growth, you can also use the growth pattern to create other interesting effects. For example, a dripping watercolor effect can be achieved using branches.

Use the options in the Tubes > Growth section of the Paint Effects Brush Settings window to select what grows off of tubes. For descriptions of these attributes, see “Growth” on page 166.
Set branch attributes
The following settings are available only when “Branches” is turned on under Tubes > Growth (see “Set growth attributes” on page 122). They define how tubes split into branches. For descriptions of these attributes, see “Branches” on page 167.

Set Twig attributes
The following settings are available only when “Twigs” is turned on under Tubes > Growth (see “Set growth attributes” on page 122). They define how twigs sprout from tubes or branches. For descriptions of these attributes, see “Twigs” on page 170.

Set leaf attributes
The following options are available only when “Leaves” is turned on under Tubes > Growth (see “Set growth attributes” on page 122). They define how leaves sprout from tubes or branches. For descriptions of these attributes, see “Leaves” on page 175.

Set flower attributes
The following settings are available only when “Flowers” is turned on under Tubes > Growth (see “Set growth attributes” on page 122). They define how flowers sprout from tubes or branches. For descriptions of these attributes, see “Flowers” on page 181.

Set bud attributes
The following settings are available only when “Buds” is turned on under Tubes > Growth (see “Set growth attributes” on page 122). They define the size and color of bud. For descriptions of these attributes, see “Buds” on page 187.

Define growth behavior
You can make your tubes grow into more interesting shapes by applying forces and displacements to them in any combination.
Set displacement attributes
When you apply displacement, you can displace the final position of completely-grown tubes in the stroke, warping them into new shapes. You can apply noise, wiggle, and curl displacements. You can also apply turbulence as a displacement. For information on turbulence, see “Set turbulence attributes” on page 124.

Use the options in the Tubes > Behavior > Displacement section of the Paint Effects Brush Settings window to displace tubes. For descriptions of these attributes, see “Displacement” on page 187.

Set force attributes
You can apply forces to the tubes while they grow, at each step in the growth cycle. These small, cumulative changes affect the shape of the whole tube in a more systemic way, to produce different kinds of effects. You can apply spiral forces, gravity, wind, turbulence, and a repelling force that keeps tubes from passing through the ground. Because of the cumulative nature of growth, forces tend to have a greater effect at the tips of tubes than they do at the roots.

Use the settings in the Tubes > Behavior > Forces section of the Paint Effects Brush Settings window to apply forces to stroke tubes. Certain forces, such as Path Attract and Path Follow, do not apply to leaves or flowers. For descriptions of these attributes, see “Forces” on page 191.

Set turbulence attributes
Turbulence causes irregularities (or noise) in the motion of tubes. Use the settings in the Tubes > Behavior > Turbulence section of the Paint Effects Brush Settings window to define the turbulence force to apply to tubes. Turbulence can be applied as either a force or a displacement, depending on the Turbulence Type. For descriptions of these attributes, see “Turbulence” on page 195.

Set spiral attributes
Spiraling occurs when tubes are wrapped around the stroke normal. Use the settings in the Tubes > Behavior > Spiral section of the Paint Effects Brush Settings window to create spiral effects. For descriptions of these attributes, see “Spiral” on page 196.

Set bend attributes
Bend can be used to curl up leaves and flowers, as well as to make the overall branches bend in the U direction (along the length). You can create natural looking flower petals and plants, such as fiddle head ferns. It is automatically animated in growth animations if non-zero. You can use the Curl attribute to bend leaves and petals in the V direction (along the...
width). Use the settings in the Tubes > Behavior > Bend section of the Paint Effects Brush Settings window to create bend effects. For descriptions of these attributes, see “Bend” on page 197.

Set twist attributes
When tubes have some flatness or texture (see “Flatness1, Flatness2” on page 139 and “Map textures to color and opacity” on page 120), you can twist them to produce effects like a twisted ribbon. Use the settings in the Tubes > Behavior > Twist section of the Paint Effects Brush Settings window to create twist effects. For descriptions of these attributes, see “Twist” on page 197.

Map value ranges to tube length
You can map tube length to color, transparency, incandescence, tube width, and split length value ranges so that every tube uses the entire range, or only the longest tubes use the entire range. Use the settings in the Tubes > Length Mappings section of the Paint Effects Brush settings window to map these attributes. For descriptions of these attributes, see “Length Mappings” on page 198.

Use MEL scripts to apply custom effects
You can write MEL scripts that apply effects during the growth simulation of the brush. There are two types of scripts: creation scripts and runtime scripts.

Typically, you’ll want to modify the sample scripts provided in the Maya scripts directory. To do this:

1. Copy the MEL file for the desired function from the Maya scripts directory:
   (Windows, IRIX, and Linux) `mayapath/scripts/paintEffects`
   (Mac OS X) `/Applications/Maya 6.0/Applications Support/scripts/paintEffects`

2. Paste the file to your local scripts directory and rename it.

3. Modify the function. Change the function name to match the file name prefix (for example, leafDroop). Do not modify the declaration of the function (its list of input arguments).

Creation scripts
Creation scripts override the normal tube creation routine (and therefore many of the controls). The following sample creation script is provided in your Maya scripts directory:

- `paintCreateFunc.mel` – Mimics normal tube creation.
Runtime scripts

Runtime scripts are called every time a new segment is added to a tube. Typically, most things you will want to do will use runtime scripts. The following sample runtime scripts are provided in your Maya scripts directory, which is located at:

(Windows, IRIX, and Linux) `mayapath/scripts/paintEffects`
(Mac OS X) `/Applications/Maya 6.0/Applications Support/scripts/paintEffects`

- `paintRuntimeFunc.mel` – Creates two leaves at the base of the tubes and applies a random wiggle.
- `paintCollideFunc.mel` – Collides the tubes with a two unit sphere placed at 0, 1, 0. You could use this function to create a new function that binds the position of the sphere to some object in the scene.
- `leafDroop.mel` – Makes all the leaves droop downwards. You could make the gravity on a tree negative so that the tree always grows upwards, yet has the leaves growing downwards. (If you are not generating secondary branches, this function is the simplest one to use as a template for new functions.)
- `widthNoise.mel` – Makes the width along a tube vary in a random manner. It only affects base tubes and twigs, not leaves or flowers.

Notes

Creation scripts do not work as runtime scripts, and vice versa. When you use a runtime function, wireframe redraw may be slower for complex objects because the function is called for every tube segment.

Use the Tubes > User MEL Scripts section of the Paint Effects Brush Settings window to use a script. For descriptions of these attributes, see "User MEL Scripts" on page 199.

Create gaps in tubes

You can create gaps in your tubes, and animate them using the settings in the Gaps section of the Paint Effects Brush Settings window. This is useful for creating effects like fire and rainfall. For descriptions of these attributes, see "Gaps" on page 199. You may need to increase the tube segments to see the gap effects; see “Segments” on page 161.
Set flow animation attributes
Use the settings in the Flow Animation section of the Paint Effects Brush Settings window to animate tube growth, and the flow of gaps, twists, and textures along each tube. For descriptions of these attributes, see “Flow Animation” on page 201.

For more information, see “Animate tube growth, gaps, twist, and textures” on page 207.

Reset the template brush
To restore the template brush settings to the default brush settings, select Paint Effects > Reset Template Brush, or in the Paint Effects panel, select Brush > Reset Template Brush.

Create new brush presets
You can create your own customized brush presets by saving the template brush settings.

To create a new brush preset
1. Do one of the following:
   - If you are basing the new brush on existing brush settings, select the brush on the Shelf or Visor.
   - If you are creating a brush from an existing stroke, select the stroke and select Paint Effects > Get Settings from Selected Stroke.
   - If you are creating the brush from scratch, select Paint Effects > Reset Template Brush.
2. Select Paint Effects > Template Brush Settings and modify the brush attributes. For details, see “Define template brush settings” on page 112.
3. When you are satisfied with your settings, select Paint Effects > Save Brush Preset. The Save Brush Preset window opens.
4. In the Label box, type a name for the brush preset. If you save the brush to a shelf, this name appears only if the Icon Style is Icon/Text (Window > Settings/Preferences > Shelves). If you save the brush to the Visor, this name appears below the icon for the preset.
5. In the Overlay Label box, type an overlay label for the brush preset. The overlay label appears as part of the brush icon on the shelf.
6. Select where you want to store the preset brush: To Shelf or To Visor. If you save the brush To Shelf, it’s stored in the currently selected shelf.
If you save the brush to Visor, you must specify the Visor directory (which must be writable by you). You can drag brushes from the Visor to a Shelf.

**Tip** If you are the only one using the brushes, save the brush to a Shelf. If you want to share your brushes, or if the brushes have file textures, save the brush to the Visor.

7 If you selected to save the preset to Visor, type a brushes subdirectory location in the Visor Directory box. For example, if you type mybrushes, Maya attempts to save the brush in the mybrushes subfolder (which must be writable) of the brushes folder in the Visor.

**Note** The Visor brushes folder is typically not writable. To save brushes to the Visor, create a writable folder in the brushes folder and specify this directory.

8 Create an icon to represent the brush, as follows:
   - In the Paint Effects Panel, paint an area on the canvas or in the scene with the brush. If you are in the scene, render the strokes (Stroke Refresh > Rendered, or click the Refresh button), if necessary.
   - In the Save Brush Preset window, click the Grab Icon button.
   - In the Paint Effects Panel, drag to select a painted area that represents the brush stroke. The selected area displays in the window. If you are not satisfied with the icon, click the Grab Icon button again and reselect the image until you are.

**Note** You can only grab icons in the Paint Effects panel.

9 Click Save Brush Preset to save the brush.

**Note** If you are rendering on multiple machines and your brushes use file textures, you must copy your /brushes and /brushImages directories to every machine you render on if they do not share the same disk.
Modify brush settings for existing strokes

You can only modify brush settings for strokes in the 3D scene. You cannot modify brush settings for strokes painted on the Paint Effects canvas.

To modify brush attributes for an existing stroke

1. Select the stroke. For details, see “Select strokes” on page 81.
2. Do one of the following:
   - In the Attribute Editor, click the brush tab (for example, tree2).
   - In the Channel Box, click the brush name under INPUTS.
3. Modify the settings. You can change the name of the brush attached to the stroke. This does not change the name of the preset brush used to paint the stroke. For details on the remaining brush attributes, see “Define template brush settings” on page 112.

Select brushes in your scene

You can select all the brushes in your scene and view them in the Attribute Editor or Attribute Spread Sheet.

You can also select brushes with names containing a specified string of characters. For example, suppose you paint several strokes using the brush preset called grass. By default, each of these strokes has the brush name, grass1, grass2, grass3, and so on. You could select all brushes with names containing “grass” and quickly change the color for all of them in the Attribute Spread Sheet.
To select all brushes in the scene

Select Edit > Select All By Type > Brushes.

To select multiple brushes by name

2. In the Name fragment box, type the characters contained in the brush names you want to select.
3. Click Select Brushes. Open the Attribute Editor to view each of the selected brushes or use the Selected menu in the Attribute Editor.

Tip

To select all strokes that were painted with the same brush, you can use the select command on the command line. For example, to find all strokes painted with the grass brush, type the following in the command line and press Enter (Windows, IRIX, and Linux) or Return (Mac OS X):

```
select "strokeShapegrass*"
```

Map file textures to color and opacity

You can map textures to tubes, leaves, and flowers. The procedures that follow use the file texture and tree shown below to illustrate the effects of mapping. The file texture has alpha.
Working with brushes | 6
Map file textures to color and opacity >

To map a file texture to tubes and branches

1 In the Paint Effects Brush Settings window, or the brush Attribute Editor, expand Shading then expand Texturing.

2 Turn on Map Color to map the color to the texture, and adjust the scale and offset if necessary. For details, see “Map Color” on page 148

3 Turn on Map Opacity to map the opacity (or alpha), and adjust the scale and offset if necessary. For details, see ”Map Opacity” on page 148

4 Beside Texture Type, select File.

5 In the Image Name box, type the name of the image file you want to use for the file texture, or click the folder icon and select it.

To map a file texture to leaves

1 In the Paint Effects Brush Settings window, or the brush Attribute Editor, expand Shading then expand Tubes > Growth > Leaves.

2 Turn on Leaf Use Branch Tex to use the file texture applied to the tubes and branches.
When turned on, the texture that is applied to the tubes and branches (in this example, the arrow), continues onto the leaves. When turned off, the texture is mapped to the UV coordinates of the leaf. Opacity (or alpha) is mapped automatically.

3 In the Image Name box, type the name of the image file you want to use for the file texture, or click the folder icon and select it.

To map a file texture to flowers

1 In the Paint Effects Brush Settings window, or the brush Attribute Editor, expand Shading then expand Tubes > Growth > Flowers.

2 Turn on Flower Use Branch Tex to use the file texture applied to the tubes and branches. The texture that is applied to the tubes and branches (in this example, the arrow), will continue onto the flowers. When turned off, the texture is mapped to the UV coordinates of the flower. Opacity (or alpha) is mapped automatically.

3 In the Image Name box, type the name of the image file you want to use for the file texture, or click the folder icon and select it.
Blend preset brush settings

By blending the tube shading and shape attributes of two preset brushes, you can create new and interesting (sometimes unexpected) effects.

For example, suppose you like the shading used for one brush, but you like the shape of another. You can blend the brushes so that the new brush uses 100% of the shading of the first brush, and 100% of the shape of the other.

For more interesting effects, you can change the percentage of the shading and shape of each brush used in the blended brush.

**To blend preset brush settings**

1. Select the preset that you want to form the basis for the stroke. Paint Effects copies the preset brush settings to the template brush.
Working with brushes | 6
Blend preset brush settings >

2 Select Paint Effects > Preset Blending > □. The Brush Preset Blend window opens.

3 Set how much you want the first stroke to be influenced by the Shading and Shape setting of the next brush preset you select.

4 Select the brush preset you want to blend with the template brush. Paint Effects blends shape and shading values of the selected brush preset according to the proportions defined in step #2, then copies the resulting settings to the template brush.

5 Drag to paint the stroke.

6 Repeat steps #3 - #5 until you get the desired effect. If you close the window, preset blending is still on. To turn preset blending off select Paint Effects > Preset Blending (this removes the check mark from the menu item).

Note While the Brush Preset Blend window is open, each time you select a brush preset, its shading and shape values will be blended with the values of the template brush.

Tip You can set hotkeys to turn brush preset blending on and off (set BrushPresetBlend, BrushPresetBlendShading, BrushPresetBlendShape, and BrushPresetReplaceShading under Paint Effects in the Hotkey editor). Press and hold the Preset Blend hotkey to turn blending on, select the preset brush and paint, then release the hotkey to turn blending off.

Reference

Paint Effects > Get Brush
Opens the Visor so you can select a preset brush. For more information, see “Select preset brushes” on page 111.

Paint Effects > Template Brush Settings
Lets you edit the template brush settings in the Paint Effects Brush Settings window. For more information about this window, see “Define template brush settings” on page 112 or “Paint Effects Brush Settings” on page 135.
Paint Effects > Reset Template Brush

Restores the template brush settings to the default brush settings. For more information, see "Reset the template brush" on page 127.

Paint Effects > Preset Blending

Select this to turn Preset Blending on and off. When it’s on and you select Paint Effects > Preset Blending > □, the Preset Blending window opens. Then you can set how much you want the first stroke to be influenced by the Shading and Shape setting of the next brush preset you select. For more information, see "Blend preset brush settings” on page 133.

Paint Effects > Save Brush Preset

The Save Brush Preset window opens. For more information, see “Create new brush presets” on page 127.

Paint Effects Brush Settings

These are the attributes in the Paint Effects Brush Settings window.

Brush Type

Select the type of brush you want to paint with. All brush types use the shape defined by the brush attributes.

Paint

Applies paint to the stroke path according to the defined attributes.

Smear

Distorts paint already applied to the canvas or scene. If the stroke uses fake shadowing (see “Fake Shadow” on page 156), the shadows also smear.

Blur

Softens the look of paint already applied to the canvas or scene. If the stroke uses fake shadowing (see ”Fake Shadow” on page 156), the shadows also blur.

Erase

In the canvas, the Erase brush removes the color from the painted pixels, revealing the underlying canvas Clear Color and maintaining the shape of the brush. For details, see “Erase paint from the canvas” on page 38.

In the scene painting view, the Erase brush replaces the pixel color of the paint stamps it overlaps with black (alpha 0).
When you erase, the alpha values are lowered, rather than increased, which means you can use the Erase brush to erase holes in a texture or scene.

**ThinLine**

The ThinLine type of brush allows you to render large numbers of fine tubes much more quickly than the Paint brush type. It uses a direct anti-aliased line draw rather than a series of brush stamps. The Multi Streak method is also available when the ThinLine brush type is used. In combination with the Multi Streak method, the ThinLine brush type can be up to 100 times faster for hair than the Paint brush type with better line detail. In addition, new looks are possible using the Multi Streaks, such as wet clumping hair.

| Note | When using a large value for Tube Width with the ThinLine brush type, this may result in artifacts. |
|------|-------------------------------------------------------------------------------------------------

**Mesh**

Renders Paint Effects using triangulated tubes instead of brush stamps. This results in accurate conical geometry with textures that correctly map on the surface. Flat surfaces are rendered more accurately than when the Paint Brush Type is used. While the Paint Brush Type is generally better when representing soft, fuzzy volumes, the Mesh Brush Type is better at hard surfaces.

With the Mesh Brush Type you can create Paint Effects trees and plants that are convincing not just from a distance, but also close-up. You can also create shapes, such as hard-edged geometry (buildings) and do per-pixel lighting on the mesh (including specular highlights). There is also a built-in environment map on the brush that is useful when simulating reflective surfaces (see “Mesh Environment Reflections” on page 144). We’ve added displacement and bump mapping to enhance the detail of the mesh surface (see “Set mesh displacement/bump mapping” on page 119). The triangles are not kept in memory, but rather generated at render time. As a result, you can use a lot of triangles without running out of memory.
Global Scale

Use the Global Scale setting to adjust brush attribute values by a common factor. This scales the paint effect uniformly so you can paint the same effect, but in different sizes.

Channels

These are the Paint Effects Brush Settings in the Channels section.

Depth

Turn on Depth to create a depth channel. Strokes appear on top of previously painted strokes when Depth is off.

In the scene, turn on Depth for more realistic natural effects (for example, for plants, fire, water). This should also prevent unusual results. By default, depth is forced on in the scene (see “Force Depth” on page 88).

Modify Depth

Depth must be turned on to use this option. Turn on Modify Depth to paint to the depth channel. If a stroke has a depth channel, but Modify Depth is off, the stroke appears behind strokes that are nearer in the scene and strokes that were created after it, as shown in the following example.

Note  Paint Effects may run slightly faster when Depth is turned off.
**Working with brushes | 6**

**Brush Profile**

These are the Paint Effects Brush Settings in the Brush Profile section.

**Brush Width**

Defines the width of the brush in Maya working units. For simple strokes, the brush width defines the width of the paint stamps applied along the stroke path. For strokes with tubes, the brush width defines the stroke path boundary—tubes can start growing only within the path defined by the brush width. The Paint Effects Tool cursor is a brush stamp outline. The Brush Width is represented by the diameter of this outline.

---

**Modify Color**

Turn on Modify Color to paint to the color channel.

**Modify Alpha**

Turn on Modify Alpha to paint to the alpha (mask) channel. If you plan on compositing your Paint Effects strokes, you should turn this option on. Turning off Modify Alpha changes the way the color displays.

---

**Tip**

When painting in fog, turn off Modify Depth for a more realistic effect.
**Softness**

Defines how soft, or blurry you want the paint to be along the edges of the stroke path (for simple strokes) or along the edges of tubes (for strokes with tubes). Higher values make the edge more blurry.

![Softness examples](image)

**Flatness1, Flatness2**

For simple strokes, Flatness1 defines how flat the paint lies along the stroke path. When Flatness1 is 0, the paint is applied to the stroke as if you squeezed it out of the tube. The stroke appears raised from the side. When Flatness1 is 1, the paint lies flat on the surface as if you removed the excess paint.

**Top view**

- Flatness = 0
- Flatness = 0.5
- Flatness = 1.0

**Side view**

- Flatness = 0
- Flatness = 0.5
- Flatness = 1.0

For strokes with tubes, Flatness1 and Flatness2 define how flat each tube is at its base and at its tip, respectively. The values between the base and tip are linearly interpolated.
Twist

Tubes can twist around their own axes as they grow. The Twist attribute defines the initial twist value. Twist is only noticeable when the tubes have some flatness or texture (Flatness1 and Flatness2 values are greater than 0).

See also “Twist Rate” on page 198.

Forward Twist

When Forward Twist is turned on, the broad or flat side of tubes are always oriented towards the camera. Textures are similarly affected so that they always face the camera. This is particularly useful when the Flatness is 1, as you can use billboard textures to minimize geometry. For leaves, you could use a texture of a large clump of leaves with alpha on flat leaves. Turning on Leaf Forward Twist would ensure that the broad side of the textured leaf clump is rotated towards the view so it always looks full. Another example might be to use the image of an apple with alpha on a flat flower petal. Turning on Petal Forward Twist twists the petal to face the view so the apples do not look flat from some angles. The simplest way to represent a tree is an image of a tree with alpha textured to a billboard facing the camera.

The following settings can be used to set up this type of billboard:

- Brush Type = Mesh
- Forward Twist = on
- Flatness1 = 1.0
- Flatness2 = 1.0
- Map Opacity = on
- Map Color = on
- Texture Type = File
- Image Name "yourTreeWithAlpha"
- Tube = on
- Segments = 1
• Tube Length1, 2 = 0.5
• Tube Width1, 2 = 0.5

Stamp Density

Paint is applied to strokes in overlapping stamps. If the stroke is simple (it has no tubes), the stamps are applied along the stroke path. If the stroke has tubes, the stamps are not applied along the stroke path, but are applied along the tube paths. Stamp Density defines the number of stamps to apply along the paths, relative to the Brush Width or Tube Width. For example, if you set Brush Width to 2, and Stamp Density to 8, then every two units of path would have 8 stamps on it (as long as the brush width remains constant). Similarly, if you set Tube Width2 to 2, and Stamp Density to 8, then every two units of tube would have 8 stamps on it (as long as the tube width remains constant).

If you set Stamp Density to 1, the paint path will look like a line of circles that just touch on the edge. If you set Stamp Density to be greater than one, the circles will overlap by a factor of their width (for example, if Stamp Density is 2, the stamps will overlap by half their width). If you set Stamp Density to be less than one, there will be spaces between the stamps.

![Diagram of stamp densities](image)

Stamp Density = 0.5  Stamp Density = 1.0  Stamp Density = 2.0  Stamp Density = 8.0

Screenspace Width

Turn this option on to maintain the brush width at all depths in the scene. This option is useful in scenes where you want cartoon-like outlines that retain a fixed width. The width value used is the same as the width used when you paint on the canvas. This option has no effect when you paint on the canvas.

Thin Line Multi Streaks

These are the Paint Effects Brush Settings in the Thin Line Multi Streaks section. For more information, see “Set Thin Line Multi Streaks” on page 117.

Multi Streaks

The number of additional tubes or hairs to create around the original tube.
Multi Streak Spread1
The maximum offset at the tube base for the streaks.

Multi Streak Spread2
The maximum offset at the tube tip for the streaks.

Diffuse Random
Amount to randomize the brightness of each offset tube.

Specular Random
Amount to randomize the specular brightness of each offset tube.

Light All Streaks
Compute lighting for each added tube.

**Mesh**

These are the Paint Effects Brush Settings in the Mesh section. For more information, see “Set mesh attributes” on page 117.

**Tube Sections**
The number of points in the circle that is swept along the tube.

**Sub Segments**
The number of cross sections per segment of the tube.

**Single Sided**
Cull away facing triangles.

**Per Pixel Lighting**
Light each pixel, as opposed to each vertex.

**End Caps**
This adds end cap geometry to tubes when using the Mesh Brush Type.

**Hard Edges**
This affects the lighting of the object and makes the edges around tubes hard when using the Mesh Brush Type. For example, if the tube sections are set to 4 and Hard Edges is turned on, it will make the tube shade as if the 4 sides are flat, rather than trying to simulate a rounded tube. For bends in the direction of the tube, for example, due to changes in the Width Scale, the bend angle across a given must be sufficiently large to make the angle hard. The number of segments...
used can affect whether a given region on the tube becomes hard edged or not. This attribute adjusts the normals used for shading and does not alter the shape of the tube. This is off by default.

**Thorns on Mesh**

The Thorns on Mesh section is a subsection of the Mesh section. These are the Paint Effects Brush Settings in the Thorns on Mesh section that can be used to control the look and size of the thorns. For more information, see “Set mesh thorn attributes” on page 117.

**Branch Thorns**

Enable thorns on base tubes, including when tubes are off.

**Twig Thorns**

Enable thorns on twigs.

**Leaf Thorns**

Enable thorns on leaves.

**Flower Thorns**

Enable thorns on flowers.

**Thorn Density**

The number of thorns relative to the overall tube.

**Thorn Elevation**

The rotation of the thorns relative to the base tube's surface normal.

**Thorn Length**

Length of the thorn relative to the average tube width.

**Thorn Base Width**

The width of the thorn at the base (relative to average tube width).

**Thorn Tip Width**

The width of the thorn at the tip (relative to average tube width).

**Thorn Specular**

Specular highlight intensity (using an anisotropic model).

**Thorn Base Color**

Color at thorn base.

**Thorn Tip Color**

Color at thorn tip.
Mesh Environment Reflections

The Mesh Environment Reflections section is a subsection of the Mesh section. These are the Paint Effects Brush Settings in the Mesh Environment Reflections section. For more information, see “Set mesh environment reflections” on page 118.

Branch Reflectivity

The amount the environment is reflected on base tubes, including the stroke when tubes are turned off.

Leaf Reflectivity

The amount of environment reflection on leaves.

Flower Reflectivity

The amount of environment reflection on flowers.

Environment

The ramp represents the reflected color of a spherical placement: the left side of the ramp is the color at the bottom of the spherical reflection and the right side of the ramp is the color at the top of it.

Reflection Rolloff

Represents the reflectivity with changing view angle (facing ratio).

Shading

These are the Paint Effects Brush Settings in the Shading section.

Color1

On simple strokes, Color1 defines the basic color of the paint. On strokes with tubes, Color1 defines the color of the tube roots. Click the Color1 color box and select the stroke color from the Color Chooser. Use the slider to adjust the color value. Color1 is used only if “Map Color” (under Texturing) is turned off.

See also “Color Length Map” on page 198.

| Tip | If you are painting in the Paint Effects panel (canvas or scene painting view), you can change the Color1 setting from the toolbar by clicking the C color box and selecting the color from the Color Chooser. Adjust the color value using the slider. |
Incandescence1

Makes the paint look incandescent—as if it were illuminated from its own internal light. On simple strokes, this attribute defines the incandescence for the stroke. On strokes with tubes, this attribute defines the incandescence of the tube roots.

Click the Incandescence1 color box and select the incandescence color from the Color Chooser. Use the slider to adjust the incandescence value. The higher the value, the more incandescent the paint is. When the value is 0 (black), there is no incandescent effect, when the value is 1 (white) or the color is pure, the effect is strongest.

See also “Incand Length Map” on page 199.

Transparency1

Defines the opacity of the paint. On simple strokes, Transparency1 defines the opacity for the stroke. On strokes with tubes, Transparency1 defines the opacity of the tube roots.

Click the Transparency1 color box and select the transparence color from the Color Chooser. Use the slider to adjust the transparency value. The higher the value, the more transparent the paint is.

When the value is 0 (black), the paint is fully opaque, or “solid”. When the value is 1 (white), or a pure color with a value of 1, the paint is transparent.

Transparency1 is used only if “Map Opacity” (under Texturing) is turned off.

See also “Transp Length Map” on page 198.

| Tip | If you are painting in the Paint Effects panel (canvas or scene painting view), you can change the Transparency1 setting from the toolbar by clicking the T color box and selecting the color from the Color Chooser. Adjust the color value using the slider. |

Blur Intensity

This option is available only when Brush Type is set to “Blur”. It defines the blurring effect of the brush.
Working with brushes | 6

Shading

Edge Antialias

Turn this option off to “step” the edges of the brush stroke. Brush “Softness” (under Brush Profile) must be set to 0 for this option to have any effect. Turn this option on, unless you do not want smooth lines. Antialiasing does not affect brush draw performance.

Tube Shading

The Tube Shading section is a subsection of the Shading section. These are the Paint Effects Brush Settings in the Tube Shading section.

Color2

Color2 defines the color of the tube tips. Click the Color2 color box and select the tube tip color from the Color Chooser. Use the slider to adjust the color value. Color2 is used only if Map Color (under Texturing) is turned off.

See also “Color Length Map” on page 198.

Incandescence2

Makes the paint on tube tips look incandescent—as if it were illuminated from its own internal light.

Click the Incandescence2 color box and select the incandescence color from the Color Chooser. Use the slider to adjust the incandescence value. The higher the value, the more incandescent the paint is. When the value is 0 (black), there is no incandescent effect, when the value is 1 (white) or the color is pure, the effect is strongest.

See also “Incand Length Map” on page 199.
Transparency2

Defines the transparency (or opacity) of the tube tips. This is a color, so you can set the transparency of the R, G, and B channels separately. The closer to black each channel is, the more opaque it is.

Click the Transparency2 color box and select the transparency color from the Color Chooser. Use the slider to adjust the transparency value. The higher the value, the more transparent the paint is.

When the value is 0 (black), the paint is fully opaque, or “solid”. When the value is 1 (white), or a pure color with a value of 1, the paint is transparent.

Transparency2 is used only if Map Opacity (under Texturing) is turned off.

See also “Transp Length Map” on page 198.

---

Tip

If you are painting in the Paint Effects panel (canvas or scene painting view), you can change the Transparency2 setting from the toolbar by clicking the T2 color box and selecting the color from the Color Chooser. Adjust the color value using the slider.

---

Hue Rand, Sat Rand, Val Rand

These attributes define how much random variation Maya applies to tube colors when creating new tubes. When the values are low, all tubes are created using colors very close to Color1 and Color2. Increasing these values causes more random variation. You can control randomness of the Hue, Saturation, and Value individually.

Brightness Rand

Defines how much random variation in tube brightness there is. If the value is 0, all the tubes are created at the same brightness. As this value increases, the tubes are randomly assigned different brightnesses, with the amount of variation increasing. This is useful for creating effects like hair, where the individual strands should have some variation in brightness as they shadow each other.

Root Fade, Tip Fade

Makes the root end or the tip of the tubes transparent, in effect “fading” the root or tip. The transparency changes linearly between the center of the tube and the root or tip.
Texturing

These are the Paint Effects Brush Settings in the Texturing section.

Map Color

By default, Color1 and Color2 are used to apply color along the stroke path or to tubes. To use a texture instead, turn Map Color on and define the texture using the attributes that follow.

Tex Color Scale

Defines the scaling factor applied to Color1 and Color2 saturation values before they are used to define the texture output color.

A scaling factor of 1 multiplies the texture output color by the brush’s untextured color, while a scale factor of 0 uses only the texture color.

Tex Color Offset

Defines the amount the texture’s color is added into the output color.

Map Opacity

By default, Transparency1 and Transparency2 are used to define opacity. Turn this option on to apply a texture to the opacity using the current texture. See “Texture Type” on page 149.

Tex Opacity Scale

Defines the amount by which the texture’s alpha values multiply the Transparency1 and Transparency2 values.

Tex Opacity Offset

Defines the amount by which the textures’s alpha values are added to the output opacity.

Map Displacement

Turn on for displacement of triangles using texture.

Displacement Scale

Amount of displacement relative to tube width.

Displacement Offset

Amount of displacement independent of local tube width.
Bump Intensity

Strength of the added bump effect (if Per Pixel Shading is on).

Bump Blur

Controls separation of samples used in bump mapping.

Use Luminance

Use color brightness instead of the alpha for displacement.

Texture Type

This option is used only when Map Color or Map Opacity is turned on. Select the type of texture you want mapped to Color and Opacity. You can map Checker, U Ramp, V Ramp, Fractal, and File type textures. For more information on mapping file type textures, see “Map file textures to color and opacity” on page 130.

If you select Fractal, you can set the “Fractal Amplitude”, “Fractal Ratio”, and “Fractal Threshold” in this section.

If you select File, you can select the file in the “Image Name” box and select “Frame Extension” and “Fringe Removal” options.

Map Method

Select how the UV coordinates are defined for the stroke:
The texture fits to the view. Painting tubes “reveals” the texture.
Brush Start

The mapping is in “eyespace,” similar to Full View, but the position, scale, and offset of the texture is based on where the brush stroke starts. This texturing technique works best in scenes with Paint at Depth turned on for the brush. If the brush stroke starts far away in the scene, the texture is small. The closer the brush stroke starts, the larger the texture.

Tube 2D

The mapping is in worldspace, but always centered on the tube such that there is never a visible seam.

The texturing follows the flow of the stroke path (U is the direction along the path, and V is the direction across the path).

Tube 3D

The texture is fully mapped in 3D around the tube, with a seam that is visible from some views. The texture appears correctly when you animate the viewpoint.

Tex Uniformity

The setting is used only when the Map Method is set to 2D. If Tex Uniformity is 0, the textures are stretched along the path based on how quickly the different parts of the path were drawn (or where the stroke path curve CVs are). If Tex Uniformity is 1, the texture is mapped evenly along the path.

Tex Color1

Defines the first color/transparency used by the selected Texture Type. For example, this could be one of the checker colors, or the color at the start of a ramp.

This texture color value is multiplied by the brush color value, Color1. So if Color1 is black (value 0), Tex Color1 will paint as black. To ensure that the painted texture colors match the texture colors set for the brush, set the brush color (Color1) to white (value 1) or set Tex Color Scale to 0.

Tex Color2

Defines the second color/transparency used by the selected Texture Type. For example, this could be one of the checker colors, or the color at the start of a ramp.

This texture color value is multiplied by the tube tip color value, Color2. So if Color2 is black (value 0), Tex Color2 will paint as black. To ensure that the painted texture colors match the texture colors set for the brush, set the tube tip color (Color2) to white (value 1).
Working with brushes | 6
Texturing >

Tex Alpha1
Defines the alpha value (opacity) for pixels where the texture has its maximum value.

Tex Alpha2
Defines the alpha value (opacity) for pixels where the texture has its minimum value.

Repeat U
Defines the number of times the texture is repeated in the U direction.

Repeat V
Defines the number of times the texture is repeated in the V direction.

Offset U
Defines how much the texture is offset in the U direction.

Offset V
Defines how much the texture is offset in the V direction.
Blur Mult

Defines how much anti-aliasing is applied. Set this value to 0 to turn off anti-aliasing. A value of 1 produces good anti-aliasing, while higher numbers produce blurrier results.

Smear

Defines the frequency of the noise used to smear the texture. Increasing this value makes the smear finer and bumpier. Typically, if you increase this value, you will want to correspondingly decrease Smear U and Smear V.

Smear U

Defines how much to smear the texture in the U direction. Increase this value to make the texture smear more in the U direction. A value of 0 produces no smearing.

Smear V

Defines how much to smear the texture in the V direction. Increase this to make the texture smear more in the V direction. A value of 0 produces no smearing.

Image Name

Type the name of the image file you want to use for the file texture, or click the folder icon and select it.

Use Frame Extension

Turn this option on when you are animating a texture. Paint Effects replaces the frame number in the image name with the frame number in the Frame Extension box. For details, see “Animate textures on strokes” on page 216.

Note

This value is randomized by the Gap Rand value, even if the Gap Size is set to 0.
Frame Extension
This option is available only when Use Frame Extension is turned on. Type the frame number you want to replace the frame number in the Image Name. Keyframe this attribute when you want to use a sequence of files as a file texture.

Fringe Removal
Corrects dark fringes along file texture alpha boundaries. If the background (alpha value zero) of an image is light or white, turn this option off. To get fringe-free alpha effects from a texture, create the texture against a black background and turn this option on.

Fractal Amplitude
This setting is used only when Texture Type is set to Fractal. Higher values increase the intensity or contrast of the fractal.

Fractal Ratio
This setting is used only when Texture Type is set to Fractal. Higher values make the fractal appear rougher.

Fractal Threshold
This setting is used only when Texture Type is set to Fractal. Increasing this value increases the amount of Tex Color 1 in the fractal, making it appear to “spread.”

Illumination
These are the Paint Effects Brush Settings in the Illumination section.

Illuminated
Turn on Illuminated so that lighting has an effect on the appearance of the stroke paint. You can use the lights in your scene to illuminate strokes or you can use a Paint Effects light. See “Real Lights”, next.

If Illumination is turned off, then strokes are painted in the colors you specify, with no shaded areas or specular highlights, even if there are lights in the scene.

By default, Illuminated and Real Lights are forced on in the scene in the Paint Effects Globals (see “Force Real Lights” on page 88).

Real Lights
This option is available only when Illuminated is turned on. Turn on Real Lights to use the lights in the scene to determine the position of shading and specular lights on the paint.
Turn off Real Lights to use a directional Paint Effects light. You can define its direction in the Light Direction attribute, but you cannot modify any other attributes (for example, intensity). When this option is turned off, lights in the scene have no effect on the paint.

By default, Illuminated and Real Lights are forced on in the scene in the Paint Effects Globals (see “Force Real Lights” on page 88).

| Note | There is currently no way to link lights to strokes—all non-exclusive lights in the scene will illuminate the strokes if Real Lights is on. |

**Light Direction**

These settings are available only when Illuminated is turned on and Real Lights is turned off. They define the direction of the Paint Effects light.

**Translucence**

This setting is available only when Illuminated is turned on. The Translucence value controls how much the paint transmits and diffuses light. Light shining on the back of translucent paint can light up the front, although you still may not be able to see through it. To make the paint completely opaque, set this to value 0. To allow more light to diffuse through, set the value closer to 1.

**Specular**

This setting is available only when Illuminated is turned on. The Specular value controls the brightness of the shiny highlights on illuminated paint. A value of 0 produces no highlights, while higher values produce brighter highlights.

**Specular Power**

This setting is available only when Illuminated is turned on. The Specular Power value controls how focused the specular highlights are. Lower values spread the highlight over a larger area. Higher values focus the highlight into a small dot.

**Specular Color**

This setting is available only when Illuminated is turned on. It defines the color of the specular highlights on your paint. Use the slider to adjust the specular color value. Click the Specular Color color box and select the specular color from the Color Chooser.
Shadow Effects

These are the Paint Effects Brush Settings in the Shadow Effects section.

Fake Shadow

Select one of the following fake shadow types:

None | No fake shadows.
2D Offset | Draws a shadow stamp offset in screen space (or drop shadow).
3D Cast | Defines a flat surface beneath the stroke then casts the shadow on that imaginary plane.

The following examples all use 2D Offset fake shadows.

Shadow Diffusion

Controls the softness of the fake shadows. Higher values make the shadow edge softer.

![Diffusion = 0](image1)
![Diffusion = 0.5](image2)
![Diffusion = 1](image3)

Shadow Offset

This setting is available only when Fake Shadow is set to 2D Offset. It controls how far the shadow is offset from the casting stroke.

![Offset = 0](image4)
![Offset = 0.5](image5)
![Offset = 1](image6)

Shadow Transparency

This setting controls how transparent the shadows are. Higher values make the shadows lighter. Lower values make them darker.

![Transparency = 0](image7)
![Transparency = 0.95](image8)
![Transparency = 0.99](image9)
Back Shadow

The back side of an object doesn’t receive light, and is therefore not illuminated. Back Shadowing simulates this effect by shading the paint farthest away from the light. Higher values make the shading darker.

![Back Shadow = 0](image1)
![Back Shadow = 0.5](image2)

Center Shadow

By default, all tubes are painted at the same brightness. This setting shades tubes closest to the centre of the stroke path, simulating the effect of a clump of plants where the plants on the outside are illuminated, but the plants on the inside are shaded because the light is blocked by the outside plants. Higher values make the shading darker.

![Center Shadow = 0](image3)
![Center Shadow = 0.5](image4)

Depth Shadow Type

This setting is used only when Depth Shadow is greater than 0. Select one of the following options:

- **SurfaceDepth**: Each point on the tube is shadowed according to how close it is to the surface on which it was created. The closer the point is to the surface, the darker it gets. This is useful for trees and reeds.

- **PathDist**: Each point on the tube is shadowed according to how close it is to the current point on the path. This is useful for things like bushes, which have a shadowed interior.
Depth Shadow

Depth Shadow darkens (shades) the color along a tube based on its distance from the surface or path (depending on the Depth Shadow Type setting). If Depth Shadow is set to 0, there is no effect. If it is set to 1, the most shadowed parts of the tubes are black.

Depth Shadow Depth

Depth Shadow Depth defines the maximum distance over which the Depth Shadow can be applied.

Objects farther than this distance from the surface or path (depending on the Depth Shadow Type setting) will not be shaded at all.

Cast Shadows

Turn on Cast Shadows to make strokes cast shadows. Then select the light in the scene that you want to produce the shadows and in the Depth Map Shadow Attributes section of the light’s Attribute Editor, turn on Use Depth Map Shadows. The shadows will not appear when you refresh the scene painting view. They are created when you do a post-process render of the scene.

Note  Strokes cannot cast raytraced shadows.

Glow

These are the Paint Effects Brush Settings in the Glow section.

Glow

Defines the brightness of the standard glow, which is produced by applying paint stamps. A value of 0 produces no glow. Higher values add more glow. This glow effect is less effective on strokes with textures, but adequately adds glow to effects like stars. For more realistic glow, see “Shader Glow.”

Glow Color

Defines the color of the standard glow. If the color value is 0 (black), there is no glow effect.
Glow Spread

Defines how much the glowing halo of a standard glow spreads past the paint. This number is a factor of the width. A value of 1.0 produces no spreading. A value of 1.5 makes a halo 1.5 times as big as the width of the stamp.

Shader Glow

Defines the brightness of the Shader Glow. It is more realistic than standard glow, and appears only when you perform a post-process render. It is useful for strokes with textures and effects like fire. To modify the Shader Glow attributes, double-click the shaderGlow icon in the Post Process folder of Hypershade. For information on these attributes, right-click the down arrow on the node icon and select Help on “shaderGlow”.

Tubes

These are the Paint Effects Brush Settings in the Tubes section.

Tubes

Turn on Tubes to “plant” tubes along the stroke path. When Tubes is turned off, paint is applied along the stroke path to create a simple stroke.
Tube Completion

As you paint the stroke, Paint Effects samples points on the stroke path based on input from your mouse or stylus. When it samples a point, Paint Effects plants new tubes along the path between the last sampled point and the current one, then grows the previously planted tubes one more segment. When you finish painting the stroke, one of two things happens:

- If Tube Completion is turned on, the tubes continue growing until they reach the end of their life span. The life span is defined by the number of segments (see "Segments" on page 161).
- If Tube Completion is turned off, the tubes stop growing, so that the tubes near the end of the stroke are less complete than the ones at the beginning.

Creation

These are the Paint Effects Brush Settings in the Tubes > Creation section.

Tubes Per Step

Defines the number of new tubes that are planted at each step in the growth simulation (each time Paint Effects samples a new point along the stroke path). The tubes are planted along the stroke path segment between the two sample points defining the step.
**Tube Rand**

Randomizes the position of tubes along the path. The lower the value, the more orderly the tubes appear. This attribute does not randomize emitter positions.

**Start Tubes**

Defines the number of tubes that are planted at the first point of each path you draw. If you set Tubes Per Step to 0, you can use this setting to create a single object along the path. For example, set Tubes Per Step to 1 to form the trunk of only a single tree for every stroke, or set it to 100 to create a sunrise or spot glow effect.

**Segments**

Defines the maximum number of segments a tube can have. Since tubes each grow one segment during each step in the growth simulation, the number of segments defines the “life span” of the tube. If you increase Segments, the tube length remains the same, but the segments making up each tube become smaller. Segments are straight, therefore more segments make the tubes appear smoother and less jointed.

**Length Min, Length Max**

These settings define the range of possible lengths for tubes (when they have completed growing). Paint Effects will create tubes with random lengths between the Length Min and Length Max values. If Tube Completion is off, the tubes may not reach the Min or Max values.

---

**Tip**

If you are painting in the Paint Effects panel (canvas or scene painting view) with a brush that has tubes. You can adjust the Tubes Per Step setting from the toolbar by changing the number in the TS box.
**Working with brushes | 6**

**Tubes >**

**Tube Width 1, Tube Width 2**

These settings define the width of the tubes at the base (Width 1) and at the tip (Width 2). The tube width changes linearly between these two values.

See also “Width Rand” and “Width Bias”, and ”Width Length Map” on page 199.

![Tube Width 1 = 0.02, Tube Width 2 = 0.001](image)

**Width Rand**

Randomizes the width of tubes along the stroke path. If the value is 0, all tubes will be the width specified by Tube Width 1 and Tube Width 2. The higher the value, the larger variation there is between the Tube Width values.

![Width Rand = 0, Width Rand = 0.5, Width Rand = 1](image)

**Width Bias**

This setting is used only when Width Rand is greater than 0. It defines how the random widths are distributed. If Width Bias is 0, then there will be just as many wider tubes as there are thinner tubes. If Width Bias is a positive value, then there will be more wider tubes created than thinner ones. If Width Bias is a negative value, then there will be more thinner tubes created than wider ones. If you are creating plants, negative values give the most realistic results. (For each larger plant, there are usually a number of smaller plants.)

![Width Bias = -0.5, Width Bias = 0, Width Bias = 0.5](image)
Segment Length Bias

Defines how segments are distributed by length. If Segment Length Bias is 0, all tube segments are the same length. If the value is positive, segments closer to the base are longer. If the value is negative, segments closer to the tip are longer. The value represents the proportion of segments that are longer.

If Length Flex (see “Length Flex” on page 195) is set to 1, the segments are infinitely stretchy, therefore this setting has no effect.

Segment Width Bias

Defines how segment width affects segment length. If Segment Width Bias is 0, width of a segment has no effect on its length. If the value is positive, wider segments are longer. If the value is negative, wider segments are shorter.

Width Scale

This allows you to use a graph to control the width from base to tip of tubes, rather than using a simple linear interpolation between two values. When combined with the Mesh Brush Type you can define shapes like spheres, as well as control the profile of a tube. Width Scale is applied as a scale to the current width and defaults to 1.0 so that previous presets work with it.
Tube Direction

Select what you want the primary axis to be to generate tubes.

Along Normal  Tubes are generated along the surface normal or the normal defined for the stroke (see "Use Normal" on page 100).

Along Path  Tubes are generated along the path of the stroke (tangent to the stroke path curve).

Elevation Min, Elevation Max

Imagine you are standing on a paint path, pointing straight ahead in the direction of the path. Moving your pointing hand straight up and down is like changing the elevation of your arm. These attributes define the range of possible elevations for tubes to lie. When both values are 1, tubes stand straight up (90 degrees, normal to the surface). When both values are 0, tubes lie flat along the path (0 degrees, tangent to the surface). When both values are 2, tubes lie flat along the path opposite to the path direction (180 degrees, tangent to the surface).

Elevation is the same as Inclination in Maya Fur.
Azimuth Min, Azimuth Max

As with Elevation, imagine standing on the paint path, pointing straight ahead in the direction of the path. Rotating your body left and right is like changing the azimuth of your arm. These attributes define the range of possible angles for tubes to rotate around the normal axis. When both values are 0, tubes point along the path direction. If Elevation is 1, Azimuth values have no effect.

Azimuth is the same as Polar in Maya Fur.

Simplify Method

You can simplify the wireframe display of a stroke by decreasing the display quality. Use this option to select what aspect of the stroke you want the display quality to affect. Display Quality does not affect the rendered strokes—only the quality of the wireframe representation.

- **Tubes Per Step**: The display quality only affects the number of tubes.
- **Segments**: The display quality only affects the number of segments along the tubes.
- **Tubes and Segments**: The display quality affects the number of tubes and the number of segments.

Display Quality 100%
**Growth**

These are the Paint Effects Brush Settings in the Tubes > Growth section.

**Branches**

Turn this option on to split tubes into branches. See “Set branch attributes” on page 123.

**Twigs**

Turn this option on to grow twigs on tubes or branches. See “Set Twig attributes” on page 123.

**Leaves**

Turn this option on to grow leaves along tubes or branches. See “Set leaf attributes” on page 123.

**Flowers**

Turn this option on to grow flowers along tubes or branches. See “Set flower attributes” on page 123.
Buds

Turn this option on to grow buds at the tips of branches and leaves. See “Set bud attributes” on page 123.

Branches

These are the Paint Effects Brush Settings in the Tubes > Growth > Branches section.

Start Branches

Defines the number of branches at the root of the tube.

Num Branches

Defines the number of branches created at each split. See also “Branch Dropout” on page 168.

Split Max Depth

Defines the maximum number of times a tube can branch. See also “Split Length Map” on page 199.
Branch Dropout

Defines the proportion of branches that are randomly “pruned” to give a more natural look. If Branch Dropout is 0, then each split produces exactly the number of branches defined by “Num Branches”.

If Branch Dropout is 1, all branches are pruned.

Split Rand

Randomizes the spacing between branching points. If Split Rand is 0, branching occurs at equal intervals along the tube. Higher values cause the spacing between branching points to become more random.

Split Angle

Defines the angle that the branch splits from its original path.

Split Twist

Defines how much branches twist when they split, relative to their root. A positive value twists counter-clockwise while a negative value twists clockwise. If Split Twist is 1, the branches twist 360 degrees.
Split Size Decay

Defines the tube size factor applied at each branching. If the value is 1, then the branches are the same size as the branch they branched from. If the value is less than 1, the branches are smaller than the branch they branched from (like on a real tree). If the value is greater than 1, the branches are larger than the branch they branched from.

Min Size

Defines the minimum size a tube must be to be “pruned.” If a tube is smaller than this size, it will not be pruned. See “Branch Dropout” on page 168.
Middle Branch

Turn this option on to continue growing the main tube of each branch at the split point (add a middle branch between the split branches).

Twigs

These are the Paint Effects Brush Settings in the Tubes > Growth > Twigs section.

Twigs In Cluster

When twigs are created, they are created in radial clusters at one position around a branch or tube. This setting defines how many twigs are in each cluster.

Num Twig Clusters

Defines the number of radial twig clusters created between the “Twig Start” and the end of each branch or tube.
Twig Dropout

Defines the proportion of twigs that are randomly “pruned” to give a more natural look. If Twig Dropout is 0, Paint Effects produces exactly the same number of twigs each time it creates them. If Twig Dropout is 1, all twigs are pruned.

Twig Dropout = 0

Twig Dropout = 0.5

Twig Dropout = 0.75

Twig Length

Defines the length of each twig.

Twig Base Width, Twig Tip Width

These settings define the width of the twigs at the base and tip, respectively. The twig width changes linearly between these two values.

Twig width is a factor of the width of the branch that the twig grew from. For example, if you set Twig Base Width to 0.8, then the width of the base of the twig will be 0.8 times the width of the branch at the point where the twig emerged.

Twig Start

Defines the point along a tube where twigs first appear. For example, if Twig Start is set to 0.5, then twigs appear half way up the tube (measured in segments). Decreasing this value pushes the twigs towards the base of the tubes.
**Twig Angle 1, Twig Angle 2**

These settings define the range of angles that the twigs will make with their source branch. The first twig cluster created (closest to the root) uses Twig Angle 1, and the last twig cluster created (closest to the tip) uses Twig Angle 2. The angles of the twig clusters change linearly in between these two clusters.

**Twig Twist**

Defines how much twigs twist around their source branch. If the value is 0, all the twig clusters emerge in a straight line along the branch. Positive or negative values make successive clusters emerge from points twisting around the source branch.
Twig Stiffness

This controls how much twigs are affected by forces such as turbulence, gravity, random and spiral. At a value of one these brush forces will not have an effect. The default is 0.5.

Branch After Twigs

Turn this on to put branches on twigs rather than twigs on branches. If Branch After Twigs is turned on, then twigs are evenly distributed along the main trunk and branches split after the twig. The splitting defined by the branch attributes will occur on the twigs. This is useful in helping define many common tree shapes, such as pines. You can have a central trunk with multiple branches splitting off of it. You can also use Twig Length Scale to adjust the overall profile of the tree. From the twigs’ starting point, it controls the density of the twigs and branches along the main trunk. Shorter twigs are adjusted to have fewer branching events and segments.
Twig Length Scale

The base length of twigs is defined by the Twig Length attribute. However you might want twigs at the tip of a trunk to be shorter than ones at the base. The Twig Length Scale attribute allows you to scale the Twig Length: when it is set to 1.0 then the twigs will equal the Twig Length value, when it is set to 0.5 the twigs will be half the Twig Length value, etc. The horizontal dimension of the graph corresponds to the position from root to tip of the tube from which the twigs sprout.
Leaves

These are the Paint Effects Brush Settings in the Tubes > Growth > Leaves section.

Leaves In Cluster

When leaves are created, they are created in radial clusters at one position around a branch or twig. This setting defines how many leaves are in each cluster.

Num Leaf Clusters

Defines the number of leaf clusters created between Leaf Start and the end of the tube or branches.
Leaf Dropout

Defines the proportion of leaves that are randomly “pruned” to give a more natural look. If Leaf Dropout is 0, then Paint Effects produces exactly the same number of leaves each time it creates them. If Leaf Dropout is 1, all leaves are pruned.

Leaf Length

Defines the length of each leaf, in worldspace units.

Leaf Base Width, Leaf Tip Width

These settings define the width of the leaf at its base and tip, respectively. The leaf width changes linearly between these two values.

Leaf Width Scale

This allows you to use a graph to control the width from base to tip of leaves, rather than using a simple linear interpolation between two values. When combined with the Mesh Brush Type you can define shapes like spheres, as well as control the profile of a leaf. Width Scale is applied as a scale to the current width and defaults to 1.0 so that previous presets work with it.
Leaf Start

Defines the point along the tube where leaves first appear. For example, if Leaf Start is set to 0.5, then leaves appear halfway up the tube (measured in segments). Decreasing this value pushes the leaves towards the base of the tubes.

Leaf Angle 1, Leaf Angle 2

These settings define the range of angles that the leaves will make with their source branch. The first leaf cluster created (closest to the root) uses Leaf Angle 1, and the last leaf cluster created (closest to the tip) uses Leaf Angle 2. The angles of the leaf clusters change linearly in between these two clusters.
Leaf Twist

Defines how much leaves twist around their source branch. If the value is 0, all the leaf clusters emerge in a straight line along the branch. Positive or negative values make successive clusters emerge from points twisting around the source branch.

Leaf Forward Twist

Turn this check box on so the broad or flat side of a leaf is always oriented towards the camera. Textures are similarly affected so that they always face the camera. For more information, see “Forward Twist” on page 140.

Leaf Bend

Defines the amount of bend that is used to curl up leaves in the U direction (along the length).

Leaf Curl

Use the Curl attribute to bend leaves in the V direction (along the width). This is perpendicular to the Leaf Bend direction. Create and move points along the ramp to define the curl of the leaf. The ramp controls the curl from root to tip of the leaf. The left side of the ramp is the base of the leaf and the right is the tip. Controlling the curl from base to tip can help define the natural shape of leaves, as well as prevent interpenetration within a cluster. The mid line value on the
ramp (0.5) represents zero curvature. Many leaf shapes have curvature that is constantly changing. For example, iris petals or mistletoe leaves can be simulated by a wavy curl ramp.

Leaf Twirl

This controls the initial rotation of a leaf relative to the branch. For example, by default a group of leaves at the top of a palm tree would twist sideways. With Twirl you can rotate them to a proper orientation with the flat side facing the ground.

Leaf Segments

Defines the number of segments in the leaf. If a leaf has multiple segments it can bend in response to forces.

Leaf Flatness

Defines how flat the leaves are. If Leaf Flatness 0, the leaves are tubes. If it is 1, the leaves are completely flat.

Leaf Size Decay

Defines the size factor applied to each leaf. If the value is 1, all leaves are the same size. As this value decreases, leaves towards the tips of branches are smaller. If you set the value to be greater than 1, the leaves towards the tops are larger.
Leaf Stiffness

Force attributes may affect leaves either too strongly or too weakly. The number of segments in a leaf relative to the base segment count determines how much forces will affect the shape. The Stiffness attribute gives you an independent way of controlling how much the forces, such as Gravity, Random, and Turbulence, affect leaves. Stiffness affects the way forces act on the leaf. If the Stiffness is set to 1, forces have no effect. If Stiffness is set to 0.5 (the default), forces have the same effect per segment that they do on the main branches. If Stiffness is set to 0, forces totally affect the leaf like a limp spaghetti noodle. If you have no forces, such as Spiral and Twist, Stiffness will have no effect.

Leaf Translucence

This setting is available only when Illuminated is turned on (see “Illuminated” on page 154). The Translucence value controls how much the leaves transmit and diffuse light. Light shining on the back of translucent leaves can light up the front, although you still may not be able to see through them. To make the leaves completely opaque, set this to 0. To allow more light to diffuse through, set the value closer to 1.

Leaf Specular

This is the specular intensity value exclusively for leaves and it controls the brightness of the shiny highlights on illuminated paint. A value of 0 produces no highlights, while higher values produce brighter highlights. This setting is available only when Illuminated is turned on. See Specular in “Illumination” on page 154.

Leaf Color 1, Leaf Color 2

The colors for the base and the tip of the leaves, respectively. Colors in between are linearly interpolated.

**Tip**

If you are painting in the Paint Effects panel (canvas or scene painting view), you can change the Leaf1 and Leaf2 settings from the toolbar by clicking the L1 and L2 color boxes and selecting the color from the Color Chooser. Adjust the color values using the sliders.
Leaf Hue Rand, Leaf Sat Rand, Leaf Val Rand

These attributes define how much random variation Maya applies to leaf colors when creating new tubes. Low values ensure that all leaves are created using colors very close to Leaf Color 1 and Leaf Color 2. Increasing these values causes more random variation. You can control randomness of the Hue, Saturation, and Value individually.

Leaf Use Branch Tex

Turn this option on to apply the same texture used on branches to the leaves. Turn this option off to apply a different texture to the leaves.

Image Name

Type the directory location and name of the image you want applied to leaves or click the folder icon and select the image. The alpha of the image is used. The texture will fit the bounds of the leaf exactly.

Terminal Leaf

Turn this option on to add a single additional leaf to the ends of each branch and twig.

Flowers

These are the Paint Effects Brush Settings in the Tubes > Growth > Flowers section.

Petals In Flower

When flower petals are created, they are created in radial clusters (flowers) at one position around a branch or twig. This setting defines how many petals are in each cluster. You can bunch multiple flowers together to make more interesting flowers.
**Working with brushes | 6**

Tubes >

- **Num Flowers**
  - Defines the number of flowers created between “Flower Start” and the end of the tube’s lifespan.

- **Petal Dropout**
  - Defines the proportion of petals that are randomly “pruned” to give a more natural look. If Petal Dropout is 0, then Paint Effects produces exactly the same number of petals each time it creates them. If Petal Dropout is 1, all petals are pruned.

- **Petal Length**
  - Defines the length of the individual petals, in world space.

- **Petal Base Width, Petal Tip Width**
  - These settings define the width of the flower petals at their base and tip, respectively. The petal width changes linearly between these two values.
Petal Width Scale

This allows you to use a graph to control the width from base to tip of petals, rather than using a simple linear interpolation between two values. When combined with the Mesh Brush Type you can define shapes like spheres, as well as control the profile of a petal. Width Scale is applied as a scale to the current width and defaults to 1.0 so that previous presets work with it.

Flower Start

Defines the point along a tube where flowers first appear. For example, if Flower Start is set to 0.5, then flowers appear halfway along the length of the tube (measured in segments). Increasing this value pushes the flowers toward the tips of the tubes.

Flower Angle 1, Flower Angle 2

These settings define the range of angles that the flowers will make with their source branch. The first flower created (closest to the root) uses Flower Angle 1, and the last flower created (closest to the tip) uses Flower Angle 2. The angles of the flowers change linearly in between them.
**Flower Twist**

Defines how much flower petals twist around their source branch. If the value is 0, all the flowers emerge in a straight line along the branch. Positive or negative values make successive flowers emerge from points twisting around the source branch.

![Flower Twist](image)

Flower Twist = 0  
Flower Twist = 0.75  
Flower Twist = 1

**Petal Forward Twist**

Turn this check box on so the broad or flat side of a petal is always oriented towards the camera. Textures are similarly affected so that they always face the camera. For more information, see “Forward Twist” on page 140.

**Petal Bend**

Defines the amount of bend that is used to curl up petals in the U direction (along the length).

**Petal Curl**

Use the Curl attribute to bend petals in the V direction (along the width). This is perpendicular to the Petal Bend direction. Create and move points along the ramp to define the curl of the petal. The ramp controls the curl from root to tip of the petal. The left side of the ramp is the base of the petal and the right is the tip. Controlling the curl from base to tip can help define the natural shape of petals, as well as prevent interpenetration within a cluster. The mid line value on the ramp (0.5) represents zero curvature. Many petal shapes have curvature that is constantly changing. For example, iris petals or mistletoe leaves can be simulated by a wavy curl ramp.
Petal Twirl

This controls the amount of rotation or twirl of a petal about its primary axis (relative to the stem). This can be used to make petals better face a certain direction, or to twist a bit so as not to self intersect when forming a flower.

Petal Segments

Defines the number of segments in the flower petals. If a petal has multiple segments it can bend in response to forces.

Petal Flatness

Defines how flat the flower petals are. If Petal Flatness 0, the petals are tubes. If it is 1, the petals are completely flat.

Flower Size Decay

Defines the size factor applied to each flower petal. If the value is 1, all petals are the same size. As this value decreases, petals towards the tips of branches are smaller.
Flower Stiffness

This controls how much flowers are affected by forces such as turbulence, gravity, random and spiral. At a value of one these brush forces will not have an effect. The default is 0.5.

Flower Translucence

This setting is available only when “Illuminated” is turned on (see “Illuminated” on page 154). The Translucence value controls how much the petals transmit and diffuse light. Light shining on the back of translucent petals can light up the front, although you still may not be able to see through them. To make the petals completely opaque, set this to 0. To allow more light to diffuse through, set the value closer to 1.

Flower Specular

This is the specular intensity value exclusively for flowers and it controls the brightness of the shiny highlights on illuminated paint. A value of 0 produces no highlights, while higher values produce brighter highlights. This setting is available only when Illuminated is turned on. See Specular in “Illumination” on page 154.

Petal Color 1, Petal Color 2

The colors for the base and the tip of the flower petals, respectively. Colors in between are linearly interpolated.

Tip

If you are painting in the Paint Effects panel (canvas or scene painting view), you can change the Petal Color1 and Petal Color2 settings from the toolbar by clicking the P1 and P2 color boxes and selecting the color from the Color Chooser. Adjust the color values using the sliders.
Flower Hue Rand, Flower Sat Rand, Flower Val Rand

These attributes define how much random variation Maya applies to flower petal colors when creating new tubes. Low values ensure that all petals are created using colors very close to Petal Color 1 and Petal Color 2. Increasing these values causes more random variation. You can control randomness of the Hue, Saturation, and Value individually.

Flower Use Branch Tex

Turn this option on to apply the same texture used on branches to the flower petals. Turn this option off to apply a different texture to the flower petals.

Image Name

Type the directory location and name of the image you want applied to flower petals or click the folder icon and select the image. The alpha of the image is used. The texture will fit the bounds of the flower petals exactly.

Buds

These are the Paint Effects Brush Settings in the Tubes > Growth > Buds section.

Bud Size

Defines the size of the buds, in world space units.

Bud Color

Defines the color of the buds.

**Tip**

If you are painting in the Paint Effects panel (canvas or scene painting view), you can change the Bud Color setting from the toolbar by clicking the B color box and selecting the color from the Color Chooser. Adjust the color value using the slider.

Behavior

These are the Paint Effects Brush Settings in the Tubes > Behavior section.

Displacement

These are the Paint Effects Brush Settings in the Tubes > Behavior > Displacement section.
Displacement Delay

Defines the point along the tubes (from the base) where the
displacement takes its full effect. The displacement values ramp to
this point. If the value is 0, the displacement starts to take full effect at
the base of the tubes. If the value is set to 0.5, then the displacement
begins to take full effect halfway along the length of the tube
(measured in segments). If the value is 1, the displacement starts to
take full effect at the maximum tube length.

Noise

Defines how much random variation to apply to the position of tube
segments. The tubes must have a lot of segments for you to see the
effect (20 segments in the following example). See “Segments” on
page 161.

Noise Frequency

Defines the amount of variance in the positions of the segments over
the maximum length of the tubes.
Noise Offset

Defines the translation of noise displacement down the tubes. This setting is useful for animating lightening effects.

Wiggle

Defines the amount of “wiggle” to apply to tubes. Wiggle is defined by a repeating wave curve. The Wiggle value defines the amplitude of the wave.

The tubes must have a lot of segments for you to see the effect (100 segments in the following example). See “Segments” on page 161.

Wiggle Frequency

Defines the number of wiggles applied over the maximum length of the tubes. The higher the value, the more “wiggles” along the length of the tube.
Wiggle Offset

Defines where along the wave the wiggle begins. You can animate this parameter to make waves appear to travel down the length of a tube.

![Wiggle Offset Examples](image)

Curl

Defines how wide to make the tube curls. The higher the value, the wider the curl. The tubes must have a lot of segments for you to see the effect (200 segments in the following example). See “Segments” on page 161.

![Curl Examples](image)

Curl Frequency

Defines the number of curls applied over the maximum length of the tubes. If you increase the curl frequency, you may also need to increase the number of segments in the tubes to get smooth results. See “Segments” on page 161.
Curl Offset

A curl is a repeating pattern. Curl Offset defines where in the pattern the curl begins. You can animate Curl Offset to make curls travel down the length of a tube.

Forces

These are the Paint Effects Brush Settings in the Tubes > Behavior > Forces section.

Path Follow

Defines the magnitude of the force that attempts to make tubes grow in the same direction as their corresponding points on the stroke path. If the value is 0, no force is applied to the tubes. As the value increases, the tubes follow the path more closely. A positive value follows the stroke path (like combing the tubes in the direction of the stroke path) while a negative value follows the reverse stroke path (like combing the tubes against the direction of the stroke path).

Path Attract

Defines the magnitude of the force that attracts tubes to the stroke path at each step of the growth simulation. If the value is 0, no force is applied to the tubes. As the value increases, the tubes converge onto the path. A positive value attracts tubes while a negative value repels them.
Behavior >

**Curve Follow**

You can make tubes follow control curves that are associated with strokes. For details, see “Modify tube behavior using control curves” on page 83. The Curve Follow setting defines the magnitude of the force that tries to make tubes grow in the same direction as the associated control curves. A positive value attracts tubes while a negative value repels them.

**Curve Attract**

You can make tubes attract to control curves that are associated with strokes. For details, see “Modify tube behavior using control curves” on page 83. The Curve Attract setting defines the magnitude of the force that attracts tubes to the associated control curves. A positive value attracts tubes, while a negative value repels them.
Curve Max Dist

This setting has an effect only if Curve Attract or Curve Follow is on. It defines the maximum distance (in world units) from which a curve can exert a force on a tube. If Curve Max Dist is set to 0, there is no maximum.

Random

Defines the magnitude of a force with a random direction and intensity, applied in the local space of each tube. If the value is 0, no force is applied. As the value increases, the force increases. This value is useful for making trees and bushes appear gnarly.

Uniform Force

Defines the magnitude of a basic directional force to apply to tubes. the x, y, and z world space coordinates. If a value is 0, no force is applied from that direction.
Gravity

Defines the magnitude of a downward force (relative to the up axis). If the value is 0, no gravity is applied.

Deflection

Turn on Deflection to apply a force that stops tubes from passing through the surface or plane they are growing from (for example, when gravity pulls branches down). The force pushes upwards and is stronger closer to the surface or plane.

Note

Deflection uses an approximation of the surface to do the deflection (a plane), so deflection will work best for short tubes or relatively flat surfaces. To deflect longer tubes, use control curves with negative Curve Attract settings (see “Curve Attract” on page 192).

Deflection Min, Deflection Max

These settings are available only if Deflection is turned on. They define the range over which the deflection force is applied. Deflection Min is the closest distance (in world units) that the tube can get to the ground before the force becomes effectively infinite. Deflection Max is the distance from the ground where approaching tubes are first influenced by deflection.
Momentum

Defines the magnitude of the force that slows down growth over the course of the growth simulation.

Length Flex

Defines how much tube segments can stretch in response to forces. If the value is 0, no stretching occurs. If the value is 1, tubes stretch just as far as required to match the force.

Turbulence

These are the Paint Effects Brush Settings in the Tubes > Behavior > Turbulence section.

Turbulence Type

Defines which type of turbulence is created, and how it is applied to the tubes. You can select from the following types:

- **Off**: No turbulence is applied.
- **Local Force**: Turbulence is applied as a force in the local space of the tubes.
- **World Force**: Turbulence is applied as a force in world space. World Force is better than Local Force for groups of strokes that you want to share a continuous turbulence.
- **Local Displacement**: Turbulence is applied as a displacement in the local space of the tubes.
- **World Displacement**: Turbulence is applied as a displacement in world space.
Grass Wind  Turbulence is applied as a world space force. The force applied to the tips of the tubes is delayed from that applied at the roots, resulting in motion similar to grass blowing in the wind.

Tree Wind  Turbulence is applied as a world space force. The force applied to the outermost branches is stronger than that applied to the parts closer to the root, resulting in motion similar to a tree blowing in the wind.

Interpolation
Defines the mathematical method used to smooth the values (and therefore the motion) in the turbulence calculations. Select from Linear, Smooth over Time, or Smooth over Time and Space.

For a more realistic effect this should typically be set to Smooth over Time and Space. If the highest speed is more desirable than motion quality, select either Smooth over Time or Linear.

Turbulence
Defines the air speed due to turbulence. If the value is 0, no turbulence is applied.

Frequency
Defines the amount of variance in the turbulence (either displacement or force) in space (or the size of the eddies).

Turbulence Speed
Defines how quickly the turbulence changes over time.

Turbulence Offset
Offsets the position of the turbulence by the defined x, y, and z values.

Spiral
These are the Paint Effects Brush Settings in the Tubes > Behavior > Spiral section.

Spiral Min, Spiral Max
Defines the minimum and maximum amount of spiraling that occurs around the stroke normal. Paint Effects randomly chooses values within this range for newly created tubes.
Spiral Decay

Defines how the amount of spiraling (tightness) decays from the beginning to the end of a tube. If the value is 0, the spiral is constant. Values greater than 0 produce tighter spirals, Values less than 0 produce looser spirals.

Bend

These are the Paint Effects Brush Settings in the Tubes > Behavior > Bend section.

Bend

Defines how much bend is applied to base tubes. Bend can be used to curl up leaves and flowers, as well as to make the overall branches bend in the U direction (along the length). See also Leaf Bend and Petal Bend.

Bend Bias

Controls how far down the stroke the bend starts. With a value of 0, the bend starts at the base. With a value of 1, there is no bend. High values cause a faster bending near the tip.

Twist

These are the Paint Effects Brush Settings in the Tubes > Behavior > Twist section.
**Twist Rate**

Defines how much tubes twist along their length. Twist is noticeable only when the tube has some flatness or texture (see “Flatness1, Flatness2” on page 139 and “Map textures to color and opacity” on page 120.)

![Twist Rate = 1](image1)  ![Twist Rate = 2](image2)  ![Twist Rate = 3](image3)

**Twist Rand**

Defines how randomly the “Twist” value is applied to tubes. If Twist Rand is 0, all tubes start at the Twist value. As this value increases, the twist assigned to new tubes becomes more random, but centered on the Twist value.

**Length Mappings**

These are the Paint Effects Brush Settings in the Length Mappings section.

**Color Length Map**

Affects how much of the color range (between “Color1” and “Color2”) is used. If this is set to Length, then every tube uses the whole range. If this is set to maxLength, then only the longest tubes use the whole range. Shorter tubes start at Color 1, but end before they make it to Color 2.

**Transp Length Map**

Affects how much of the transparency range (between “Transparency1” and “Transparency2”) is used. If this is set to Length, then every tube uses the whole range. If this is set to maxLength, then only the longest tubes use the whole range. Shorter tubes start at Transparency 1, but end before they make it to Transparency 2.
Incand Length Map

Affects how much of the color range (between “Incandescence1” and “Incandescence2”) is used. If this is set to Length, then every tube uses the whole range. If this is set to maxLength, then only the longest tubes use the whole range. Shorter tubes start at Incandescence 1, but end before they make it to Incandescence 2.

Width Length Map

Affects how much of the width range (between Tube Width1 and Tube Width2) is used. If this is set to Length, then every tube uses the whole range. If this is set to maxLength, then only the longest tubes use the whole range. Shorter tubes start at Tube Width1, but end before they make it to Tube Width2.

Split Length Map

If this is set to Length, then every tube splits the number of times specified in “Split Max Depth”. If this is set to maxLength, only the longest tubes split that often. Shorter tubes split a fewer number of times.

User MEL Scripts

These are the Paint Effects Brush Settings in the User MEL Scripts section. For more information, see ”Use MEL scripts to apply custom effects” on page 125.

Creation Script

Type the directory location and name of the MEL script to use to generate tubes.

Runtime Script

Type the directory location and name of the MEL script that defines the flow and behavior of the tubes at each step of the growth simulation.

Gaps

These are the Paint Effects Brush Settings in the Gap section.

Gap Size

Defines the size of the gap, relative to the Gap Spacing. If the Gap Size is 0, there are no gaps. If the value is 1, there is nothing but gap.
Gap Spacing

Defines the space between gaps, expressed as a proportion of the length of the tube. For example, if Gap Spacing is 0.33, then the gaps divide the tubes into 3 parts.

Gap Rand

Randomizes the positions of the gaps for each tube. If Gap Rand is 0, all the gaps occur at the same positions for each tube. As this number increases, the spacing becomes more random between tubes.

Gap Rand also randomizes the position of textures applied to tubes, leaves, or flowers, even if Gap Size is set to 0.
Flow Animation

These are the Paint Effects Brush Settings in the Flow Animation section.

Flow Speed

Defines the speed (in cycles per second) and direction that gaps, twists, and textures move (or flow) along animated tubes. Positive numbers make them flow from base to tip. Negative numbers make them grow and flow from tip to base.

For example, if the flow speed is two, the gap, twist, or texture pattern cycles (flows back to the starting pattern) twice in one second. So if your units are defined to be 24 frames per second, the pattern made by the gap, twist, or texture pattern will be identical on the 12th frame and the 24th frame.

If you turn on the Time Clip or Stroke Time options, it also defines the speed that tubes grow.

Texture Flow

This moves the texture with flow as defined by Flow Speed. In general this is best turned off for growth animations (growth with time clipping) because the textures will not move during the plant growth. But this is useful when you want a texture, particularly a displacement, to flow down the tubes. This is on by default.

Stroke Time

This option has no effect unless Time Clip is on. Turn on Stroke Time to animate tube growth and flow from the beginning of the growth simulation to the end of the growth simulation.

Time Clip

Turn on Time Clip so that animated tubes first appear and begin to flow at the time set by Start Time, and die at the time set by End Time.

Note

This value randomizes Offset V for textures (see “Offset V” on page 152), even if the Gap Size is set to 0.
If Time Clip is on, but Stroke Time isn’t, tubes along the stroke path are already planted, which means the tube growth is uniform.

If Time Clip is off, the tubes display at the end of their lifespan along the stroke, the growth simulation having completed. In this case, only gap, twist, or texture flow are animated.

**Start Time**

This option has no effect unless Time Clip is on. Start Time defines the time when tubes first appear (or are “born”).

**Note**

Start Time is measured in seconds. So if your Time unit is set to 24 fps, for example (Window > Settings/Preferences > Preferences, then click the Settings category), and the Start Time is 1, then tubes will first appear on frame 24.

If you know what frame you want tubes to appear on, divide this frame number by the frames per second defined by your Time unit to determine what value to enter in the Start Time box. For example, if you want your tubes to appear on frame 60 and your Time unit is set to NTSC (30 fps), divide 60 frames by 30 frames per second, for a Start Time of 2 seconds.

You can perform this calculation by creating an expression in the field. Type an equals sign (=) followed by the calculation. In the previous example, you would type:

```
=60.0/30
```

Notice that the time must have a floating point decimal.

**End Time**

This option has no effect unless Time Clip is on. End Time defines the time when tubes “die.” If you think of a tube as a particle emitter that emits tube segments, the End Time is the point in time when the emitted segments die, or disappear. If the growth simulation is not yet complete, segments will continue to be emitted after the End Time until they reach their lifespan.

If you are animating growth, set this value to occur at the same frame as your end frame or later. With growth, you typically do not want tubes to die before the animation is complete.

To create “bursting” effects, use values that occur at frames before the end frame.
Time

Use this option to keyframe time. For example, if you are animating the growth of a tree, you can make the tree remain a sapling for the first 100 frames of the animation, then have the tree grow from a sapling to a full grown tree in the next 100 frames.

To keyframe time, first right-click in the Time box and select Break Connection. Set keys at the frames you want to control growth (go to the frame, right-click in the Time box and select Set Key). Open the Graph Editor (Window > Animation Editors > Graph Editor) and edit the animation curve to set the desired values. For details, see the Animation guide.
7 Animating strokes

How do I? Add spring behavior to strokes with tubes

You can easily add springs to strokes with tubes to give the tubes reactive, interconnected motion. By animating the movement of the surface with the springed tubes on it, the tubes will react appropriately.

When you add spring behavior to a stroke, Paint Effects creates an expression that makes the tubes behave like springs. You can edit this expression in the Expression editor.

To add spring behavior to brushes

1. Select the stroke. The stroke must be on a paintable surface. For details, see “Paint on objects” on page 63.

2. Select Paint Effects > Brush Animation > Make Brush Spring > □. The Make Brush Spring Options window opens (see “Paint Effects > Brush Animation > Make Brush Spring > □” on page 218).

   To see the effect of the spring, move to a frame after the Start Frame (at least two frames after) and transform the object. For example, if the Start Frame is set to 2, move to frame 5.

3. Switch to the modeling view, if you are not already in it, and keyframe the movement of the surface. For details, see the Animation guide.

4. Click the Play Forward button to check that the tubes are behaving the way you want them to.

5. Render the animation. See “Render a scene with Paint Effects strokes” on page 232.

To edit spring settings

1. Select the stroke.
**Animating strokes**

Keyframe brush and stroke attributes

1. Select Paint Effects > Brush Animation > Make Brush Spring > 🗑️. The Make Brush Spring Options window opens. For descriptions of these options, see “Paint Effects > Brush Animation > Make Brush Spring > 🗑️” on page 218.

2. Modify the settings and click Create. Paint Effects replaces the existing expression with a new one using the modified settings.

**To remove spring behavior from a stroke**

1. Select the stroke.

2. Open the Expression editor (Window > Animation Editors > Expression Editor).

3. Apply the Expression Name filter (Select Filter > By Expression Name).

4. Under Expressions, select the expression for the stroke.

5. Click the Delete button.

**To bake the spring animation**

1. Select Paint Effects > Brush Animation > Bake Spring Animation > 🗑️. The Bake Brush Spring Animation window opens.

2. In the Start Frame box, enter the first frame to bake in the animation.

3. In the End Frame box, enter the last frame to bake in the animation.

4. Click Bake. Paint Effects bakes the expression for each frame in the specified range so the spring behavior will render properly.

**Keyframe brush and stroke attributes**

You can keyframe brush and stroke attributes to achieve special effects. For example, you can animate tube curl, so that hair goes from straight to curly over time. You can animate elevation so that a character’s hair stands on end. You can animate brush width or global scale so that flames appear to grow and spread. The possibilities are endless.

The following procedure describes just one way of keyframing. For other methods, refer to the Animation guide.

**To keyframe brush attributes**

1. Turn on Auto Key (click the key icon at the bottom right corner of the Maya main window) and move to the first frame.

2. Select the brushes you are animating. For details, see “Select brushes in your scene” on page 129.

3. In the Attribute Spreadsheet, select the attribute values you are keyframing and select Key > Key Selected.
4 Move to another frame and edit the attribute value.
5 Repeat step #4 as required.
6 Switch to the modeling view, if you are not already in it, and click the Play Forward button to check that the attributes are behaving the way you want them to.
7 Render the animation. See “Render a scene with Paint Effects strokes” on page 232.

Animate tube growth, gaps, twist, and textures
Using the Paint Effects flow animation feature you can animate the following:
- the flow of gaps, twist, and/or textures
- uniform tube growth
- the growth simulation
- tube death

Animate the flow of gaps, twist, and/or textures
If tubes have gaps, twist, and/or textures applied to them, you can animate the pattern they create “flowing” or cycling along the length of the tubes as if the tubes were joined at the ends.

By animating the flow of gaps, you can create effects such as rainfall. By animating the flow of twist, you can get a spiraling effect. The following images show a texture flowing one complete cycle from root to tip.

To make gaps, twist, and textures flow
1 Select the stroke.
2 In the Attribute Editor, click the brush tab.
3 Set the desired gap, twist, and/or texture settings. For details, see “Create gaps in tubes” on page 126, “Set twist attributes” on page 125, and “Map textures to color and opacity” on page 120, respectively.
**Animating strokes | 7**

Animate tube growth, gaps, twist, and textures >

4 Expand Flow Animation and set a “Flow Speed” for the gaps, twist, or texture. Positive numbers make them flow from tube base to tip. Negative numbers make them flow from tip to base.

The Time Clip and Stroke Time options also animate tube growth when turned on. For information, see “Animate uniform tube growth” on page 208, “Animate the growth simulation” on page 210, and “Animate tube death” on page 212.

You can use the Time setting to animate flow over time. For more information, see “Time” on page 203.

5 If you are animating gap flow, you can check that the flow is as you want it before rendering the animation by clicking the Play Forward button in the modeling view.

| Tip | You can loop the brush animation smoothly. For details, see “Loop brush animations” on page 217. |

6 Render the animation. See “Render a scene with Paint Effects strokes” on page 232.

**Animate uniform tube growth**

You can animate the tubes along the stroke path growing at the same time, as if they were all “planted” simultaneously. Any gaps, twist, and/or texture applied to the tubes will flow along the length of the tubes as the tubes grow.

**To animate all the tubes along the stroke growing at the same time**

1 Select the stroke.

2 In the Attribute Editor, click the brush tab.

3 Expand Flow Animation and set a “Flow Speed”. (If you have gaps, twist, or textures applied to the tubes, the flow speed also defines the speed that they flow along the tube.)

4 Turn on Time Clip.
5 Set the Start Time (the time in the animation that the tubes will first appear) and the End Time (the time in the animation when tubes first begin to die).

Set the End Time to end at the same frame your animation ends or later. This ensures that the tubes do not die before the animation is complete. For details on making tubes die, see “Animate tube death” on page 212.

You can use the Time setting to animate growth over time. For more information, see “Time” on page 203.

Note  
Start Time and End Time are measured in seconds. So if your Time unit is set to 24 fps, for example (Window > Settings/Preferences > Preferences, then click the Settings category), and the Start Time is 1, then tubes will first appear on frame 24.

If you know what frame you want tubes to appear on, divide this frame number by the frames per second defined by your Time unit to determine what value to enter in the Start Time box. For example, if you want your tubes to appear on frame 60 and your Time unit is set to NTSC (30 fps), divide 60 frames by 30 frames per second, for a Start Time of 2 seconds.

You can perform this calculation by creating an expression in the field. Type an equals sign (=) followed by the calculation. In the previous example, you would type:

\[=60.0/30\]

Notice that the time must have a floating point decimal.

6 In the modeling view, click the Play Forward button to check that the growth is as you want it.

Tip  
You can loop the brush animation smoothly. For details, see “Loop brush animations” on page 217.

7 Render the animation. See “Render a scene with Paint Effects strokes” on page 232.
**Animating strokes | 7**

Animate tube growth, gaps, twist, and textures >

---

Note If you are simultaneously animating tube growth and texture flow (for example, the growth of a textured tree), the texture may appear to flow faster than the tree grows. To remedy this, select the strokes and run the script `freezeBrushTexture.mel` on the command line (stored in your `Applications/Maya 6.0/Applications Support/scripts/paintEffects` (Mac OS X) or `mayapath/scripts/paintEffects` (Windows, IRIX, and Linux) directory).

---

**Animate the growth simulation**

You can animate the growth simulation. Tubes “planted” at the beginning of the stroke start growing at the beginning of the stroke path and continue to grow as new tubes start growing in steps along the path. Any gaps, twist, or texture applied to the tubes will flow along the length of the tubes as the tubes grow.

---

**To animate all the growth simulation**

1. Select the stroke.
2. In the Attribute Editor, click the brush tab.
3. Expand Flow Animation and set a Flow Speed. (If you have gaps, twist, or textures applied to the tubes, the flow speed also defines the speed that they flow along the tube.)
4. Turn on Time Clip.
5. Turn on Stroke Time.
6. Set the Start Time (the time in the animation that the tubes will first appear) and the End Time (the time in the animation when tubes first begin to die).

   Set the End Time to end at the same frame your animation ends or later. This ensures that the tubes do not die before the animation is complete. For details on making tubes die, see “Animate tube death” on page 212.

   You can use the Time setting to animate growth over time. For more information, see “Time” on page 203.
In the modeling view, click the Play Forward button to check that the growth is as you want it.

8 Render the animation. See “Render a scene with Paint Effects strokes” on page 232.

If you know what frame you want tubes to appear on, divide this frame number by the frames per second defined by your Time unit to determine what value to enter in the Start Time box. For example, if you want your tubes to appear on frame 60 and your Time unit is set to NTSC (30 fps), divide 60 frames by 30 frames per second, for a Start Time of 2 seconds.

You can perform this calculation by creating an expression in the field. Type an equals sign (=) followed by the calculation. In the previous example, you would type:

=60.0/30

Notice that the time must have a floating point decimal.

Tip You can loop the brush animation smoothly. For details, see “Loop brush animations” on page 217.

Note Start Time and End Time are measured in seconds. So if your Time unit is set to 24 fps, for example (Window > Settings/Preferences > Preferences, then click the Settings category), and the Start Time is 1, then tubes will first appear on frame 24.

If you are simultaneously animating tube growth and texture flow (for example, the growth of a textured tree), the texture may appear to flow faster than the tree grows. To remedy this, select the strokes and run the script freezeBrushTexture.mel (stored in your Maya scripts directory) on the command line.

Animate tube death

You can animate special effects, like tubes “bursting” from the stroke path, by setting birth and death times that define when tubes start growing in the animation, and when they begin to disappear.

When the animation reaches the death time, segment at the tube roots disappear (or die) while segments continue to be added at the tube tips. When the tube reaches its life span, the segments continue to disappear from the root to the tip until the tube completely disappears.

Note Start Time and End Time are measured in seconds. So if your Time unit is set to 24 fps, for example (Window > Settings/Preferences > Preferences, then click the Settings category), and the Start Time is 1, then tubes will first appear on frame 24.

If you know what frame you want tubes to appear on, divide this frame number by the frames per second defined by your Time unit to determine what value to enter in the Start Time box. For example, if you want your tubes to appear on frame 60 and your Time unit is set to NTSC (30 fps), divide 60 frames by 30 frames per second, for a Start Time of 2 seconds.

You can perform this calculation by creating an expression in the field. Type an equals sign (=) followed by the calculation. In the previous example, you would type:

=60.0/30

Notice that the time must have a floating point decimal.
**Animating strokes | 7**  
Animate tube growth, gaps, twist, and textures >

Any gaps, twist, or texture applied to the tubes will flow along the length of the tubes as the tubes grow.

**To animate tube death**

1. Select the stroke.
2. In the Attribute Editor, click the brush tab.
3. Expand Flow Animation and set a Flow Speed. (If you have gaps, twist, or textures applied to the tubes, the flow speed also defines the speed that they flow along the tube.
4. Turn on Time Clip.
5. Turn on Stroke Time.
6. Set the Start Time (the time in the animation that the tubes will first appear) and the End Time (the time in the animation when tubes first begin to die).

You can use the Time setting to animate tube death over time. For more information, see "Time" on page 203.

**Note**  
Start Time and End Time are measured in seconds. So if your Time unit is set to 24 fps, for example (Window > Settings/Preferences > Preferences, then click the Settings category), and the End Time is 4, then tubes start to die on frame 96.

If you know what frame you want tubes to begin to die on, divide this frame number by the frames per second defined by your Time unit to determine what value to enter in the End Time box. For example, if you want your tubes to begin to die on frame 120 and your Time unit is set to NTSC (30 fps), divide 120 frames by 30 frames per second, for an End Time of 4 seconds.

You can perform this calculation by creating an expression in the field. Type an equals sign (=) followed by the calculation. In the previous example, you would type:

```plaintext
=120.0/30
```

Notice that the time must have a floating point decimal.

7. In the modeling view, click the Play Forward button to check that the animation is as you want it.
8 Render the animation. See "Render a scene with Paint Effects strokes" on page 232.

### Animate the stroke path

You can animate the stroke path being painted (or revealed) by keyframing the Max Clip value.

The following procedure describes just one way of keyframing. For other methods, refer to the Animation guide.

**To keyframe the stroke being painted (or revealed)**

1. Turn on Auto Key (click the key icon at the bottom right corner of the Maya main window) and move to the first frame.
2. Select the stroke you are animating.
3. In the Attribute Editor, click the strokeShape tab and expand End Bounds.
4. Right-click the Min Clip and Max Clip boxes and select Set Key.
5. Set both the Min Clip and Max Clip values to 0.
6. Move to the last frame and set the Max Clip value to 1.
7. In the modeling view click the Play Forward button to check that the animation is working the way you want it to.
8. Render the animation. See “Render a scene with Paint Effects strokes” on page 232.

**Tip** You can loop the brush animation smoothly. For details, see “Loop brush animations” on page 217.

**Note** You can achieve other effects by keyframing different permutations of the Min Clip and Max Clip values. For example, you could animate a stroke gradually or disappearing from the beginning of the stroke, or from both ends of the stroke.
Make tubes react to forces

There are two ways to make tubes react to forces:

- define Paint Effects brush forces
- apply forces to stroke control curves

Use brush settings to make tubes react to forces

You can make strokes react to forces such as gravity, deflection, and momentum by applying the settings under Tubes > Behavior > Forces. For details, see ”Set force attributes” on page 124. Keyframe these settings to make the tubes move dynamically in reaction to the forces.

You can also add turbulence to brushes. Simply turn turbulence on for a stroke, and Paint Effects automatically animates the reaction of the tubes.

To apply turbulence to brushes

1. Select the stroke.
2. In the Attribute Editor, expand Tubes > Behavior > Turbulence.
3. Change the Turbulence Type from off to any of the other options, then define the turbulence settings you want applied to the stroke tubes. For details, see ”Set turbulence attributes” on page 124.
4. In the modeling view, click the Play Forward button to check that the effect is as you want it. You can tweak the turbulence settings while playing.

Tip: You can loop the brush animation smoothly. For details, see ”Loop brush animations” on page 217.

Use control curves to make tubes react to forces

If you want stroke tubes to react to forces other than the forces available in the Paint Effects brushes (or in addition to), you can do so by creating control curves and making the control curves react to the forces in your scene. This is an effective technique, for example, for making long hair move naturally or for adding localized forces to trees.

To animate tube behavior by applying forces to control curves

1. Create the control curves. For details, see ”Modify tube behavior using control curves” on page 83.
2 Select the stroke(s) you want controlled by the control curves and set the “Curve Follow” and/or “Curve Attract” to values for the stroke(s) to be other than 0.

3 Make the control curves into soft bodies as follows:
   • Select the control curves.
   • In the Dynamics menu set, select Soft/Rigid Bodies > Create Soft Body.

4 Add the desired force fields to the scene (for example, select Fields > Vortex) and position them to affect the control curves.

5 In the modeling view, click the Play Forward button to check that the effect is as you want it.

6 Render the animation. See “Create a composite of Paint Effects strokes and your scene” on page 233.

Create animated textures

Using the Paint Effects view plane you can create animated textures. For example, you could create a texture that has vines growing on it, or create a texture that changes color, then apply the animated texture to surfaces.

To create an animated texture

1 [Optional] For a seamless repeating texture, turn wrap on as follows:
   • Select Paint Effects > Paint Effects Globals. The Paint Effects Globals window opens.
   • Expand Scene and turn on Scene Wrap H and Scene Wrap V. This causes strokes in the scene to wrap over the edges of the view plane, as if the view plane were a canvas.

2 Select Paint Effects > Paint on View Plane.

3 Go to the scene painting view if you are not already in it (press the 8 hotkey to open the Paint Effects panel and select Paint > Paint Scene) and paint your strokes on the view plane. Although the stroke wireframes display between 0 and 1 in world space, the strokes will render on the view plane.

4 Animate the strokes using the techniques described in this chapter.

5 Render the animation. See “Create a composite of Paint Effects strokes and your scene” on page 233.
**Animating strokes** | 7

Animate textures on strokes

You can apply animations as textures to simple strokes and strokes with tubes. For example, suppose you have an animation of a swimming fish. You could apply the animation as a texture on a simple stroke. The fish would appear to swim along the stroke path.

**To animate a texture applied to strokes**

1. Select the stroke you want to apply the animation to.
2. In the Attribute Editor, expand Shading, then Texturing.
3. Turn on Map Color.
4. To map the alpha, turn on Map Opacity.
5. Beside Texture Type, select File.
6. In the Image Name box, select the image of the first frame in the animation (for example fishswim.iff.1).
7. Turn on Use Frame Extension.
8. In the Frame Extension box, type the number of the first frame in the animation you are applying as a texture.
9. Go to the first frame in your scene animation and turn on Auto Key.
10. Right-click in the Frame extension box and select Set Key.
11. Go to the last frame in your animated sequence and change the Frame Extension to the last frame of the animation you are applying as a texture (for example, if the last frame is fishswim.iff.24, enter 24).
12. Render the animation. See “Create a composite of Paint Effects strokes and your scene” on page 233.

**Loop brush animations**

You can make brush animations loop continuously using the loop feature. Looping adjusts the speed of the turbulence and flow so that particles at the beginning of the loop are at the same spot as the particles at the end of the loop at the same time. The result is a smooth loop without any jumping as the animation repeats.

**To loop brush animations**

1. Select Paint Effects > Brush Animation > Loop Brush Animation > □. The Loop Brush Animation window opens. For descriptions of these options, see “Paint Effects > Brush Animation > Loop Brush Animation > □” on page 219.
2. Beside Cycle Frames, set how many frames you want to loop through the brush animation.
3 If the brush has turbulence, set the Turbulence SpeedMult value to increase the turbulence speed.
   Similarly, if the brush has flow animation, set the Flow SpeedMult value to make the flow faster.
   In general, if you need to increase both these speeds (make the values greater than 1), the loop can be made smaller.

4 Click Loop.

5 In the modeling view, click the Play Forward button to check that effect is as you want it.

Reference

Paint Effects > Brush Animation > Bake Spring Animation
This lets you bake the expression for each frame in the specified range so the spring behavior will render properly.

Paint Effects > Brush Animation > Bake Spring Animation > □
These are the options in the Bake Brush Spring Animations window.

Start Frame
   Specify the first frame to be baked in the animation.

End Frame
   Specify the last frame to be baked in the animation.

Paint Effects > Brush Animation > Make Brush Spring
This lets you add springs to strokes with tubes to give the tubes reactive, interconnected motion. By animating the movement of the surface with the springed tubes on it, the tubes will react appropriately.

Paint Effects > Brush Animation > Make Brush Spring > □
These are the options in the Make Brush Spring Options window.

Spring Stiffness
   Defines the rigidity of the brush spring. If you increase the stiffness too much, the brush spring might stretch and contract excessively.
Spring Damp

Defines a damping value to mute the spring action. A high value causes the spring length to change more slowly. A low value causes the length to change quickly.

Spring Travel

Defines how far the stroke tubes can swing.

Start Frame

Sets the frame in which the spring behavior begins.

Paint Effects > Brush Animation > Loop Brush Animation

This lets you make brush animations loop continuously. For more information, see ”Loop brush animations” on page 217.

Paint Effects > Brush Animation > Loop Brush Animation

These are the options in the Brush Animation Looping Options window.

Cycle Frames

Indicates how many frames you want to loop through the brush animation.

Turbulence SpeedMult

If the brush has turbulence, set the Turbulence SpeedMult value to increase the turbulence speed.

Flow SpeedMult

If the brush has flow animation, set the Flow SpeedMult value to make the flow faster.
8 Paint Effects samples and techniques

How do I? Animate rain effects

Using the Water preset brushes you can quickly animate rain and snow in your scenes. These brushes have flow animation settings.

To animate rain
1. Add a light to the scene.
2. In the Visor or from a shelf, select the rain preset brush (in the weather folder).
3. Paint strokes on the grid plane of the perspective view. Paint each stroke in the same direction so the rainfall comes from the same direction.
In the modeling view click the Play Forward button to check that the animation is working the way you want it to.

5 Render the animation. See “Render a scene with Paint Effects strokes” on page 232.

Animate a plant growing up a column

Using the plant presets and flow animation, you can make plants grow up a column.

To animate a plant growing up a column

1 Select the column.
2 Create a curve that spirals around the surface as follows:
   • Make the column live.
   • Select the CV Curve Tool.
   • Click points on the column, tumbling the view to click points around the column.

3 Select the curve.

4 In the Visor, or on the shelf, select a plant preset brush (for example, ferns1 in the plants folder).

5 Select Paint Effects > Curve Utilities > Attach Brush to Curve.

6 Select Display > Stroke Display Quality > 75% to improve the wireframe display quality.

7 With the new stroke still selected, open the Attribute Editor and click the brush tab.

8 Modify the brush settings until you are satisfied:
   • Increase the Global Scale.
   • Under Tubes > Creation, increase the Tubes Per Step.
Paint Effects samples and techniques | 8

Animate a plant growing up a column >

9 Press the 8 hotkey to switch to the Paint Effects panel and select Paint > Paint Scene.

10 Click the Redraw icon on the toolbar to render the stroke.

11 Animate the growth as follows:
   - In the Attribute Editor, click the brush tab.
   - Expand Flow Animation.
   - Turn on Time Clip, then change the Flow Speed value. In this example, we used 1.0.
   - In the modeling view, set the Playback End Time to 100 and click the Play Forward button.
   - Now in the Attribute Editor, turn on Stroke Time.
   - Go to the first frame and click the Play Forward button.
Animate a starfield

Using the star and space brush presets you can quickly paint a starfield and animate flying through it.

To animate a starfield

1. Change your scene color to black (Window > Settings/Preferences > Colors).
2. Switch to the scene painting view (press the 8 hotkey to open the Paint Effects Panel, and select Paint > Paint Scene).
3. Select Brush > Tool Settings and turn on Paint At Depth.
4. In the Visor (Brush > Get Brush), or on a shelf, click the brush preset you want to paint with (in the galactic folder).
5. Drag to paint stars.

Paint Effects paints the strokes on the view plane at the depth determined when you clicked in the scene to start the stroke. If you start your stroke near the front of the grid plane of the perspective view, the stars will be very close. If you start your stroke near the back of the grid plane of the perspective view, the stars will be very far.

12 Render the animation. See “Render a scene with Paint Effects strokes” on page 232.
Paint Effects samples and techniques | 8
Create textures from painted 3D objects

6 Repeat steps #4 and #5 until your starfield looks the way you want it to. Make sure you start your brush strokes at different depths so that there are stars to "fly" through. Also, change the brush occasionally to add a galaxy or space glow.

7 Move to the first frame and turn on Auto Key.

8 Switch to the modeling view (Panels > Perspective > persp) and select the camera (View > Select Camera).

9 In the channel box, select the Translate boxes, right-click and select Key Selected.

10 Move to the last frame in the animation and dolly into the scene.

11 In the modeling view, click the Play Forward button to check that effect is as you want it.

12 Render the animation. See “Render a scene with Paint Effects strokes” on page 232. Glow brushes do not require lights to render.

Create textures from painted 3D objects

After painting strokes on an object, you can convert the strokes into a texture, which you can then reapply to the object. You may want to do this if you need to render the images outside of Maya (for example, in a game engine).

This technique remaps the strokes painted on the object to the same UV space in the texture.

To create a texture map from a painted 3D object

1 Paint the strokes on a paintable object. For details, see “Paint on objects” on page 63.

2 Select all the strokes on the object.

3 In the Attribute Spread Sheet, click the Shape Keyable tab.

4 Select all the values under the Perspective column and change them to off. (Changing Perspective to off is the same as selecting Position Stroke on View Plane.)

5 Select Window > Rendering Editors > Render Globals, and set the render resolution to be square (for example, 320 x 320).

6 Hide the object you painted on so that it does not render.

7 Perform a test render of the scene (Render > Render Current Frame).

8 Modify the Global Scale of the strokes, if necessary.
   • Select all the brushes.
   • In the Attribute Spread Sheet, click the Keyable tab.
• Under the Global Scale column, adjust the scale appropriately for each brush.

9 Render the scene (Render > Render Current Frame).

10 Save the rendered image. You can now create a texture from this image and reapply it to the object.

Work on an animation project

If you want one team to work on animation while another works on a model with Paint Effects strokes on it (for example a head of hair), there are two approaches you can take:

• “To reference a model with no Paint Effects on it” on page 227
• “To reference a model with Paint Effects” on page 227

You cannot start these methods mid-project.

To reference a model with no Paint Effects on it

1 If the animator does not have Paint Effects, unload Paint Effects and create the model.

2 Save the scene using a name that identifies it as the model without Paint Effects strokes on it (for example, noPaintEffectsModel).

3 Create a new scene and reference the scene with the model without Paint Effects strokes (File > Create Reference).

4 Save this new scene using a name that identifies it as the model with Paint Effects Strokes (for example, PaintEffectsModel).

5 Send the non-paint effects scene to the animator.

6 Paint strokes on the Paint Effects scene and modify them as desired.

7 When the animator has finished animating the non-paint effects model, replace the original scene with no Paint Effects strokes with the animator’s updated scene. The strokes in the scene with Paint Effects will now be applied to the animated model.

Note

The parameterization of the model must not change.

To reference a model with Paint Effects

1 Create the model in its base pose.

2 Paint strokes on the model and modify them as desired.

3 Save this scene using a name that identifies it as the model with Paint Effects strokes (for example, BasePaintEffectsModel).
4 Create a new scene and reference the scene with the model with Paint Effects strokes (File > Create Reference).

5 Animate the new scene and save it using a name that identifies it as the animated scene (for example, AnimPaintEffectsModel).

6 Repeat steps 4 and 5 for any other scenes using the model with Paint Effects strokes.

When you modify the strokes on the base pose model, the models in the animated scenes will be updated.
9 Rendering scenes with Paint Effects strokes

How do I? Prepare to render

Before you render a scene with Paint Effects strokes, you must light the scene, set up the camera you are rendering from, and select the properties that the rendered images will have. You might also want to set up your scene so that you can render Paint Effects strokes separately from other elements in the scene and later composite them together. For details on performing these tasks, see:

- “Light the scene” on page 229
- “Set up the camera you are rendering from” on page 230
- “Set the properties of rendered images” on page 231
- “Set up to render Paint Effects strokes” on page 231

Light the scene

When light shines on an object, it illuminates the object’s surface. Without light, you could not see surfaces. The paint on a stroke behaves like a surface, and therefore requires light for you to see it.

You can use the lights in your scene to illuminate paint (real lights), or you can use a Paint Effects light that only affects the stroke paint and nothing else in the scene. If the stroke brushes use real lights (see “Real Lights” on page 154), your scene must have a light to render the strokes. For information on adding lights to your scene, see the Lights and Cameras guide.

By default, your scene is forced to use real lights in the Paint Effects Globals (see “Force Real Lights” on page 88).

Note There is currently no way to link lights to strokes—all non-exclusive lights in the scene will illuminate the strokes if Real Lights is on. A workaround for this is to link all lights you do not want to shine on Paint Effects.
Rendering scenes with Paint Effects strokes | 9
Prepare to render >

Add shadow effects
If you illuminate your strokes (see "Illuminate stroke paint" on page 120), you can create the following types of shadow effects for each brush:

- fake shadows (for details, see "Fake shadows" on page 121)
- back and center shadows (for details, see "Back and center shading" on page 121)
- depth shadows (for details, see "Tube root shading" on page 121)

These shadow effects do not depend on the lights in your scene. In fact, if the strokes do not use Real Lights, these shadow effects will still render.

If you use real lights in your scene, you can also make strokes cast shadows (depth map shadows) on objects.

To cast shadows on objects

1. Select the stroke you want to cast shadows on objects.
2. In the Attribute Editor, click the brush tab and expand Shadow Effects.
3. Turn on Cast Shadows.
4. Select the light you want to cast shadows.
5. In the Attribute Editor for the light, expand Shadows and under Depth Map Shadow Attributes:
   - Turn on Use Depth Map Shadows.
   - Turn off Use Mid Dist Dmap.

Note
Strokes do not cast raytraced shadows, only depth map shadows.

Set up the camera you are rendering from
To ensure that the strokes in your scene render well with fog and geometry, you must modify a couple of camera settings before you render.

To set up the camera

1. Select the camera you are rendering from.
2. In the Attribute Editor, expand Output Settings and turn on Depth, then set the Depth Type to Furthest Visible Depth. This prevents “fringing” around geometry.
If you must set the Depth Type to Closest Visible Depth, and you are rendering with Physical fog, turn on Transparency Based Depth and make sure the Threshold is less than 1 (but not 0). (Threshold defines how transparent an object must be before it is ignored for the depth buffer.) If you do not do this, Paint Effects strokes will ignore their depth settings and render in front of all your geometry.

Set the properties of rendered images

During rendering, Maya generates a two-dimensional image, or series of images, from a specific view of a three-dimensional scene, and saves it as an image file. You can control the properties of rendered image files according to your post-production and presentation requirements.

**To set the properties of rendered images**

Select Window > Rendering Editors > Render Globals and set appropriate render globals. For details, see the Rendering guide.

| Note | Strokes are always antialiased, regardless of the Render Globals Quality setting. |

Set up to render Paint Effects strokes

By default, Paint Effects strokes render with the rest of your scene.

You can set up render globals to render Paint Effects strokes separately from other elements in the scene and later composite the scene and strokes together.

**To set up to render Paint Effects strokes**

1. Select Window > Rendering Editors > Render Globals and set appropriate render globals. For information about these settings, see “Render Global Settings window” in the Rendering guide.

2. Expand Paint Effects Rendering Options and select the appropriate Paint Effects render options. For descriptions of these options, see “Paint Effects Rendering Options” on page 234.

Render scenes with Paint Effects strokes

Paint Effects strokes render seamlessly with the rest of your scenes. They are affected by motion blur, depth of field, and fog.

- “Render a scene with Paint Effects strokes” on page 232
- “Create a composite of Paint Effects strokes and your scene” on page 233
Render a scene with Paint Effects strokes

You can render a scene either from within Maya or from an IRIX/Linux shell, or DOS window, or Terminal. Before rendering, close all applications (including Maya, if you are rendering from a IRIX/Linux shell, or DOS window, or Terminal) to maximize the amount of memory available for rendering.

To render a scene with Paint Effects strokes

1. Set up your lights, render camera, render options, and Paint Effects render options. For details, see “Prepare to render” on page 229.
2. Render the scene as you would any Maya scene.
   - For information on rendering a single frame, see “Rendering a frame” in the Rendering guide.
   - For information on rendering an animation, see “Rendering an animation” in the Rendering guide.

After rendering an image or an animation, you will want to view the result. For information, see “Viewing Rendered Images” in the Rendering guide.

Note

Paint Effects uses the depth buffer generated by the scanline render to determine occlusion. For rendered effects where multiple surfaces are visible within a single pixel (such as transparency, antialiased edges, motion blur, light fog, and volume densities) this creates problems, as we only have one depth value and one color per pixel to composite Paint Effects into.

You can affect how the renderer decides how to reduce multiple depth values visible within a pixel to the single output depth value using the camera depthType. Using “closest visible” picks the surface nearest the camera within the pixel; a transparent surface or motion blurred streak will totally obscure any Paint Effects elements behind them. If “furthest visible” is used instead, then Paint Effects elements lying behind these elements will punch through as if they were totally in front. The best solution in these situations often requires rendering the Paint Effects separately and compositing.

Alternatively, you can convert Paint Effects strokes to polygonal meshes, including construction history, using Modify > Convert > Paint Effects To Polygons. See “Convert Paint Effects to polygons” on page 86.
Create a composite of Paint Effects strokes and your scene

You can render Paint Effects strokes independently of the rest of your scene, then composite the resulting images.

To create a composite

1. Render the scene or animation without Paint Effects strokes as follows:
   - Select Window > Rendering Editors > Render Globals.
   - If you are compositing an animation, beside Frame/Animation Ext, select name.#.ext.
   - Image formats which are .iff or .rla will have embedded depth information. Other formats will create a separate .iff file containing the depth information. This depth file would normally be written to the projects depth directory. For this example render the images as .iff.
   - In the Image File Output section, turn on Depth Channel (Z Depth) beside Channels.
   - In the Paint Effects Rendering Options section, turn off Enable Stroke Rendering.
   - Render the scene or animation (for example, rainyday). For details, see the Rendering guide.

2. Save the scene using a different file name to ensure that the rendered images do not overwrite each other (for example, rainydaywithstrokes).

3. Render the strokes with the scene as follows:
   - Make sure the camera and the lights are set up to match the camera and lights in step #1.
   - Select Window > Rendering Editors > Render Globals.

**Note**

Paint Effects renders are always multiprocessed. To turn off multiprocessing, do the following:

- Exit Maya (or stop your batch render).
- Set the MAYA_PAINT_EFFECTS_THREADS environment variable to a value between 1 and 3, for the number of processors you want to use.
- Start Maya (or restart your batch render).
- Re-render your scene.
Rendering scenes with Paint Effects strokes | 9
Paint Effects Rendering Options >

- If you are compositing an animation, beside Frame/Animation Ext, select name.#.ext.
- In the Paint Effects Rendering Options section, turn on Enable Stroke Rendering and Only Render Strokes.
- Beside Read This Depth File, type the location and name of the depth file for the image you rendered in step #1. Make sure it is an absolute path name (for example, /home/pearce/rainyday.iff or c:\pearce\rainyday.iff).

If you are rendering an animation, use the file name format name.#.iff (for example, rainyday.#.iff).
- Render the scene or animation. For details, see the Rendering guide.

Output images are created and named using the format name.#.iff (for example rainydaywithstrokes.5.iff).

Reference Paint Effects Rendering Options

These are the options in the Paint Effects Rendering Options section of the Render Global Settings window, Maya Software tab. These options are only available when using the Maya Software renderer.

Enable Stroke Rendering

Turn this option on to render the Paint Effects strokes in your scene. If this option is off, the scene renders without strokes. This option is turned on by default.

Oversample

Renders the Paint Effects at double resolution for better anti-aliasing.

Oversample Post Filter

Applies a weighted filter to the oversampled image for better smoothing.

Note The Oversample and Oversample Post Filter options are particularly useful when rendering Paint Effects fur or hair. Also the new Mesh Brush Type requires oversample be used to anti-alias the tube edges if you don’t convert the Paint Effects to polygons.
Only Render Strokes

Turn this option on to render only the Paint Effects strokes in your scene. You may want to render the strokes separately from the rest of your scene, then composite the strokes with the scene. For details, see “Create a composite of Paint Effects strokes and your scene” on page 233.

Note

When you render strokes only, you must also specify an .iff file in the Read This Depth File field. The file can be empty. It does not have to have depth.

Read This Depth File

If you are compositing your rendered scene with rendered Paint Effects strokes, type the location and name of the depth file for the rendered scene. Use the absolute path name, for example:

/h/username/rainyday.iff (IRIX and Linux)
c:\username\rainyday.iff (Windows)
/username/rainyday.iff (Mac OS X)

If you are rendering an animation, and have an animated input file, place the # character where the frame number is in the source input files. For example, for files foo1.iff, foo2.iff, and so on, enter foo.#.iff. For files foo1, foo2, and so on, enter foo.#. When you render, the # character is replaced with the current frame number.

For more information, see “Create a composite of Paint Effects strokes and your scene” on page 233.

Note

It is best to supply a depth file and allow Maya Paint Effects to do the compositing rather than attempt to composite Paint Effects as a post process using a compositor. Maya Paint Effects uses a multi-layer depth and RGB buffers to perform the compositing with the scene and can achieve a much better composite than a post process compositor can achieve.

Also, if you do not supply a depth file (an .iff file with depth information), Paint Effects strokes that are behind objects in your scene will be rendered. Maya will not overwrite your existing images supplied as a depth file—the output will be named as shown at the top of the Render Globals window.
Rendering scenes with Paint Effects strokes | 9
Paint Effects Rendering Options >
Troubleshooting Paint Effects

Here are solutions to problems you may encounter when using Paint Effects. These problems include:

**Painted strokes appear too dark**
Do one of the following:
- Add a light to the scene.
- Turn off Real Lights in the Illumination section of the brush Attribute Editor.
- If the brush color is textured, check that stroke Color1 value is not black and if the texture is a file texture, check that the image file can be found.

**Tubes appear too small in the scene**
Increase the Global Scale for the brush or increase the Scene Scale.

**Rendered strokes are made up of circles**
Increase the Stamp Density for the brush in small increments to avoid setting the value excessively high.

**Tubes appear jagged or segmented across curved sections**
Increase the number of tube segments (Tubes > Creation) for the brush.

**Feedback does not reflect rendered image**
Increase the Display Quality or ensure that you are in the scene painting view.

**Canvas clears to black even though you changed the canvas color**
You could be viewing the alpha plane. Select Display > All Channels and clear again.
Troubleshooting | 10
Troubleshooting Paint Effects >

Brush stroke appears to “leak” through joined edges of surface
You paint across the joined edges of a single surface (for example, the center line on a face created by duplicating half the face and attaching it to the first half) and your brush stroke appears to “leak” through the join and jump to the back of the head.

Make sure the surface is periodic in U and V.

The Global Scale brush setting appears to be ignored
Check the Paint Effects Globals. The Global Scale for the next brush preset you select is multiplied by the Canvas Scale or Scene Scale value, depending on where you are painting.

You attempt to share a brush, but the wrong brush is shared
When you select Paint Effects > Share Brush, the selected strokes share the brush of the stroke that was selected last (called the primary selection object, which highlights green by default).

Stroke texture colors do not match colors set for the texture
You map a texture to the brush color, but when you paint the stroke, the texture colors do not match the colors you set for the texture.

When you map a texture to the brush color, the texture color values (Tex Color1 and Tex Color2) are multiplied by the brush color value (Color1). To ensure that the painted texture colors match the texture colors set for the brush, set the brush color to white (value 1).

Your Wacom stylus and tablet have no pressure sensitivity
When you paint strokes in Paint Effects on IRIX and Linux, your Wacom stylus and tablet have no pressure sensitivity.

Select an Artisan tool (for example, the Paint Selection Tool) and open the Tool Settings editor. Expand the Stylus Pressure section. If the Stylus Pressure options are grayed, Maya cannot find your Wacom tablet. Your tablet may be installed under the generic name “tablet.”

To fix this, search the /Users/username/Library/XII/input/config/wacom file (Mac OS X) or /usr/lib/X11/input/config/wacom file (Windows and IRIX) for a “tablet” entry. Change it to “wacom” and restart the machine. To fix this on Linux, go to the Wacom web site (www.wacom.com) and read product support information for Linux.
You install a new tablet but Paint Effects doesn’t recognize it

You installed a new tablet, but now pressure sensitivity does not work in Paint Effects.

To remedy this, reset the brush (Paint Effects > Reset Template Brush).

Painted strokes look nothing like the selected brush preset

You select a brush preset then paint a stroke, but the resulting strokes do not use the values defined for the brush preset.

The Brush Preset Blend window may be open. When this window is open, each time you select a brush preset, the shading and shape values for the selected brush preset are blended with the values in the template brush according to the blend settings.

To avoid this happening again, set hotkeys for blending (Brush Preset Blend, Brush Preset Blend Shape, Brush Preset Blend Shading).

To blend, set the shading and shape proportions in the Brush Preset Blend window, then close the window. Select the first brush, press and hold the blend hotkey, then select the brush preset you want to blend. While the hotkey is pressed, each time you click a preset, the values are blended with the template brush values. Release the hotkey to stop blending.

Tube growth and texture flow appear out of sync

You simultaneously animate tube growth and texture flow (for example, the growth of a textured tree), and the texture appears to flow faster than the tree grows.

To remedy this, select the strokes and turn on Texture Flow in the Flow Animation section of the Paint Effects Brush Settings window.

You set a Start Time for your flow animation but tubes don’t appear

Start Time and End Time are measured in seconds, so if you set the Start Time to 60, for example, and your Time units are 24 fps (Window > Settings/Preferences > Preferences, then click the Settings category), then the animation will not start until frame 1440.

If you know what frame you want tubes to appear on, divide this frame number by the frames per second defined by your Time unit to determine what value to enter in the Start Time box. For example, if you want your tubes to appear on frame 60 and your Time unit is set to NTSC (30 fps), divide 60 frames by 30 frames per second, for a Start Time of 2 seconds.
You can perform this calculation by creating an expression in the field. Type an equals sign (=) followed by the calculation. In the previous example, you would type:

\[=60.0/30\]

Notice that the time must have a floating point decimal.

**A fringe appears around geometry where it overlaps with a stroke**

In the camera’s Attribute Editor, expand Output Settings, turn on Depth, then set the Depth Type to Furthest Visible Depth.

**You modify a texture applied to a surface, but the surface doesn’t update**

In the canvas, make sure Auto Save is turned on. If you are using Windows, you may also have to change the Hardware Texture Quality (in the shader Attribute Editor) to something other than Default.

**The alpha plane for the scene painting view appears white**

Alpha planes for the scene painting view are completely white. To see the alpha of the scene painting view, render the scene (Render > Render Current Frame) and in the Render View, select Display > Alpha Channel.

**You attempt to paint on a surface but the stroke paints on the view plane**

Turn off Paint At Depth (Paint Effects > Paint Effects Tool > Paint At Depth).

**Strokes take a very long time to render**

You have a scene with dozens of strokes created with the same brush (for example, a corn field) and it takes a very long time to render.

Try simplifying the brush by lowering the number of Segments, Leaf Segments, and Petal Segments.

You could also try using a texture on the brush to provide the detail instead of tubes. For example, if you are painting a corn field, render a tall skinny image of a single corn stalk (with alpha against black) that just fits a single tube and use this as a texture on a brush with single tubes. (Look at the pineTextured brush for an example of this technique.) You could use this method for stalks that are not in close-up shots. Randomize the wiggle of the tubes to make the stalks look different. For variety, you could also use different brushes with different textures.
Strokes do not appear in raytraced reflections and refractions

Do a multipass render, reflecting or refracting the Paint Effects portion off of an image plane rendered in an earlier pass.

**For example, if you wanted to refract Paint Effects eyelashes in spectacle lenses, you would do the following**

1. Render the full scene with the Paint Effects strokes, but with the spectacle lenses hidden.
2. Create an image plane (Display Mode RGB, Fit to Resolution Gate) in the scene, turning on Visible in Refractions, and interactively changing the Depth value until the image plane sits just behind the backmost part of the lenses.
3. Render the scene again with only the raytraced spectacle lenses and frame, and the image plane (hide everything else and turn off Paint Effects rendering).

   The image plane containing the Paint Effects strokes is refracted through the lenses.

**Paint Effects strokes render in the wrong order relative to other objects in the scene**

Paint Effects uses the depth buffer generated by the scanline render to determine occlusion. For rendered effects where multiple surfaces are visible within a single pixel (such as transparency, antialiased edges, motion blur, light fog, and volume densities) this creates problems, as there is one depth value and one color per pixel to composite paint effects into.

You can affect how the renderer decides how to reduce multiple depth values visible within a pixel to the single output depth value using the camera Depth Type (in the Output Settings section of the Attribute Editor).

Closest Visible Depth picks the surface nearest the camera within the pixel. Thus a transparent surface or motion blurred streak will totally obscure any Paint Effects elements behind them.

With Furthest Visible Depth, Paint Effects elements lying behind these elements will punch through as if they were totally in front.

The best solution in these situations often requires rendering the Paint Effects separately and compositing.
**Staircased mesh brushes**

Mesh brushes will have staircased (aliased) edges unless Paint Effects Oversample is turned on. (Paint Effects Rendering section in the Maya Software tab of the Render Global Settings window)

**No shadows appear when only paint effects casts shadows**

Shadow maps are not generated when only Paint Effects elements are casting shadows. To ensure that the maps are generated you can create a small piece of shadow casting geometry. A mesh with a single small triangle will do, as long as it is within the field of the shadow map. Point lights have 6 axis aligned shadow maps. Each map needs shadow casting geometry (other than Paint Effects) within its frustum in order to be generated.

**Incorrect object shadows and self shadows onto paint effects**

Mid Dist maps must be disabled on lights for depth map shadows to work correctly with Paint Effects. Otherwise Paint Effects will not self shadow well and shadows from objects onto Paint Effects may appear to be offset from the shadow casting surface. When Mid Dist maps are disabled you should adjust the Dmap Bias in order to avoid self shadow artifacts on surfaces yet maintain tight shadows.
Artisan Brush Tools

Part 2
11 Using Artisan brush tools

About

Using Artisan brush tools

Artisan tools use an intuitive paint and sculpting-based interface to accomplish a variety of modeling, animation, rendering, and effects tasks and deliver high quality and otherwise complex results in minimal time.

This chapter provides an overview of the Artisan tools.

There are several Artisan brush tools that all work like paint brushes. Typically, you create your model in Maya, then paint with these tools to detail and modify it. You can use your graphics tablet and stylus for greater control when you paint.

Sculpt Surfaces Tool (for NURBS surfaces)

Use the Sculpt Surfaces Tool (Modeling menu set, Edit NURBS > Sculpt Surfaces Tool) to push and pull CVs on a NURBS surface. The effect is like sculpting clay—push and the surface depresses, pull and the surface raises.

Sculpt Polygons Tool

Use the Sculpt Polygons Tool (Modeling menu set, Edit Polygons > Sculpt Polygons Tool) to push and pull vertices on a polygonal surface. The effect is similar to sculpting clay.

Paint Vertex Color Tool (for polygons only)

Use the Paint Vertex Color Tool (Modeling menu set, Edit Polygons > Colors > Paint Vertex Color Tool) to paint a specified color value and alpha onto polygon vertices.

Paint Set Membership Tool

Use the Paint Set Membership Tool (Animation menu set, Deform > Paint Set Membership Tool) to paint the set membership of vertices instead of individually selecting them.

Paint Scripts Tool

Use the Paint Scripts Tool (Modify > Paint Scripts Tool) to paint a surface with an attribute defined in a Maya MEL script. For example, you can paint geometry or particle emitters on your surfaces like you would paint a color or texture in a painting program. Maya includes sample MEL paint scripts to apply to your surfaces. For details, see “Paint Scripts Tool settings” on page 264.
Using Artisan brush tools

Paint Selection Tool
Use the Paint Selection Tool (Edit > Paint Selection Tool) to select vertices by painting on the surface with the tool. This control quickly provides results that previously required painstaking manipulation of individual components. You can use the Paint Selection Tool to select faces and edges on polygons and subdivision surfaces. You can also use it to perform polygonal editing.

Paint Attributes Tool
Use the Paint Attributes Tool (Modify > Paint Attributes Tool) to paint any registered attributes on any object. For details, see “Painting attribute values” on page 289.

Paint Cluster Weights Tool
Use the Paint Cluster Weights Tool (Animation menu set, Deform > Paint Cluster Weights Tool) to paint weights on vertex clusters.

Paint Jiggle Weights Tool
Use the Paint Jiggle Weights Tool (Animation menu set, Deform > Paint Jiggle Weights Tool) to paint jiggle weights on vertex clusters.

Paint Soft Body Weights Tool
Use the Paint Soft Body Weights Tool (Dynamics menu set, Soft/Rigid Bodies > Paint Soft Body Weights Tool) to paint the goal weights on a soft body.

Paint Skin Weights Tool
By smooth binding skin to an object, you can create skin-like deformations. In effect, all the vertices belong to all the joint clusters. Use the Paint Skin Weights Tool (Animation menu set, Skin > Edit Smooth Skin > Paint Skin Weights Tool) to modify the weights of these clusters at the joints.

Paint Fluids Tool (Maya Unlimited only)
Use the Paint Fluids Tool (Dynamics menu set, Fluid Effects > Add/Edit Contents > Paint Fluids Tool) to paint fluid property values in a fluid container.

Paint Fur Attributes Tool (Maya Unlimited only)
Use the Paint Fur Attributes Tool (Rendering menu set, Fur > Paint Fur Attributes Tool) to paint fur attribute values on an area of fur without changing the fur description for the entire surface.
Paint Cloth Properties Tool (Maya Unlimited only)
Use the Paint Cloth Properties Tool (Cloth menu set, Simulation > Properties > Paint Cloth Properties Tool) to paint cloth properties and wrinkling effects across the surface of a garment without changing the properties for each entire panel.

Paint Cloth Collision Properties Tool (Maya Unlimited only)
Use the Paint Collision Properties Tool (Cloth menu set, Cloth > Paint Collision Properties Tool) to paint collision properties of cloth objects, specifically, the collision priority and the collision depth map offset.

Paint Hair Tool (Maya Unlimited only)
Use the Paint Hair Tool (Dynamics menu set, Hair > Paint Hair Tool) to paint follicle attributes on the hair system, or to remove, trim, or extend hair.

How Artisan brush tools work
The Artisan brush tools work like paint brushes—paint a stroke with an Artisan brush tool and the attributes of the brush are applied to the surface along the stroke.

When you select an Artisan tool, the Maya pointer changes to a paint brush. Move the pointer over a surface and Maya displays a brush outline. The brush outline defines the area affected by the tool. Clicking the brush on a surface creates a stamp. A stroke (created by dragging across the surface) is made up of many overlapping stamps.
About Artisan brushes

Artisan brushes have the following modifiable characteristics:

- “Brush radius”
- “Brush shape (or profile)”
- “Brush opacity”

Brush radius

By increasing or decreasing the radius of a brush stamp, you increase or decrease its area of influence.

If you use a pressure sensitive graphics tablet and stylus, you can set an upper and lower range for the radius. No matter how much pressure you apply to the stylus, the brush radius will not be larger or smaller than the set limits. For information on changing brush size (radius), see “Radius (U) value (upper brush radius)” on page 259 and “Radius (L) value (lower brush radius)” on page 259.

Brush shape (or profile)

You can select a brush shape to provide flexibility as you paint. The area affected by the stamp corresponds with the selected shape. The shape of the brush outline does not change to reflect your selection. For example, if the brush shape is square, the brush outline remains circular, but the area influenced is square.

Brush opacity

Brush opacity refers to the fraction of the maximum displacement or brush value (depending on the selected tool) to apply to each brush stamp within a stroke.
About brush values
Brush value refers to something different for each Artisan tool. For example, for the Paint Cluster Weights Tool, value refers to vertex weight. For the Paint Fur Attributes Tool, it could refer to the amount of curl.

About brush operations
For each Artisan brush you can select a paint operation that defines the behavior of the brush when you paint. For example, the Sculpt tools have Push, Pull, Smooth, and Erase operations. The Paint Cluster Weights Tool has Replace, Add, Scale, and Smooth operations. The operation is also used when flooding and when importing maps.

How do I?
Paint strokes
Painting a stroke with an Artisan brush tool is much like painting a stroke with a paint brush. Select a canvas (select a surface), select a brush (select an Artisan Tool), apply paint to the brush (define tool settings), and finally drag your brush across the canvas (surface).

To paint with an Artisan brush
1 Select the surface you want to paint.
2 Select the Artisan brush tool and open the Tool Settings editor (Tool > 
3 Select a paint Operation and Value and define other tool specific settings as required. For details, refer to the documentation specific to the Artisan tool.

Tip You can use Artisan marking menus and hotkey combinations to change most of the settings without opening the Tool Settings editor. For details, see “Define Artisan hotkeys” on page 258 and “Use Artisan marking menus” on page 260.

4 Define any common settings, if required. See “Common Artisan Brush Tool Settings” on page 299 for details.
5 Drag the brush across the surface.
Snap an Artisan paint brush to an isoparm (NURBS surfaces only)

You can make more accurate brush strokes on a NURBS surface, or have an effect on the same surface’s area again and again by snapping the cursor to the curve or a curve on the surface.

**To snap the brush to an isoparm**

1. Select the surface you want to paint.
2. Select the Artisan brush tool.
3. Press and hold down the c key on your keyboard while you do the following:
   - Move the center of the brush outline directly over the path you want the brush to snap to.
   - Drag the brush in the direction you want to paint.

**Note** The c key is the default hotkey for the SnapToCurve command (under Status Line in the Hotkey Editor).

**To snap the brush to a curve**

1. Create the curve on the surface as follows:
   - Select the surface you want to paint with an Artisan brush tool.
   - Click the Make Live button on the Status Line to make the surface live.
   - Select the appropriate curve tool (for example, CV Curve Tool) and create the curve on the surface.
   - Click the Make Live button on the Status Line again.
2. Select the surface.
3. Select the appropriate Artisan brush tool.
4. Press and hold down the c key on your keyboard while you do the following:
   - Move the center of the brush outline directly over the path you want the brush to snap to.
• Drag the brush in the direction you want to paint.

Flood paint

Flooding a surface with values is like taking a huge brush and applying its settings to the entire surface. The result depends entirely on the brush operation and other settings defined when you perform the flood.

For example, flooding a surface with the Operation set to Replace, replaces all the values on the selected surface with the Value you set, whereas, with if the Operation is set to Add, flooding adds the Value you set to all the values on the selected surface.

To flood a surface

1 Select the surface.
2 Select the Artisan tool and open the Tool Settings editor.
3 Define the brush Operation, Value, and Opacity as necessary.
4 Click the Flood button.

Paint reflected

You can set Artisan tools so that your brush strokes are mirrored or reflected in the axis of your choice as you paint. This is useful when you want to create a symmetrical effect.
Using Artisan brush tools | 11

Restrict an area for painting

Note

When you reflect paint on a surface, it may appear as though the reflection is not symmetrical...

...but in fact, the brush is reflected on the other side of the object.

Reflection is through the X, Y, and Z axes, which are based on the center of the selection's bounding box.

To reflect your brush stroke

1. Select the surface to paint.
2. Select the Artisan tool you want to use and open the Tool Settings editor.
3. Open the Stroke section and select an axis for reflection—X, Y, or Z, or any combination of these.
   Notice there are now two, four, or eight brush outlines on the surface (depending on the number of reflection axes you selected).
4. Paint the surface. Your painted strokes are reflected in the selected axes.

Restrict an area for painting

You can block off an area on a surface so it is not affected by the Artisan operations you apply to it. Unselected vertices act as a block.

To restrict an area for painting

1. Select the vertices you want to paint. For details, see the Basics guide.
2. Select an Artisan tool.
3. Paint the surface with the selected Artisan tool. Any brush strokes you make over the selected vertices affect only the selected vertices. Unselected vertices are masked and are unaffected by your painting, as shown in the following example.
Map attributes

An attribute map is a two-dimensional image with values that correspond, or map, to attributes of points on a three-dimensional surface. This mapping is relative to the U/V parameterization of the surface.

You can import image files created in other programs and use their alpha channel values or luminance values as attribute maps. The alpha channel is the channel in an image that contains the opacity information. Not all images have an alpha channel. Luminance refers to the intensity or brightness of the image.

Attribute map values are represented by grayscales, with black representing a value of 0 and white representing a value of 1.

You can also export the values on your Artisan surfaces into image files. You can import and export attribute maps in any file format supported by Maya. For a list of these file formats, see the Basics guide.
Import attribute maps

The Artisan brush tool you select, and its settings, determine the result you get when you import an attribute map to a surface. Artisan maps the attribute values onto the surface vertices relative to the U/V surface direction and applies the Artisan tool settings to the vertices using the mapped values.

To import an attribute map

1. Select the surface or surfaces you want to apply the map to.
2. Select the Artisan brush tool and open the Tool Settings editor.
3. Select an Operation and set an Opacity value, and change any other settings, as required.
4. Open the Attribute Maps section and then the Import section.
5. Select the “Import Value”. The default is Luminance.
6. If you selected the Paint Selection Tool, enter a value for the “Threshold”. This threshold defines the minimum value to be affected by the tool selection type.
7. If you are importing a map that was created in Artisan from multiple surfaces, turn on Reassign Attribute Maps. For details, see “Import Artisan attribute maps to multiple surfaces” on page 255.
8. Click the Import button.
   The Import window opens.
9. On IRIX and Linux, to preview the image before importing it, select it, then click the See Image button. The grayscales represent the values, where white represents a value of 1 and black represents a value of 0.
10. Select the image and click the Import button. Artisan applies the values to the selected surface(s) using the selected tool settings.

Note
Make sure that the surfaces have UVs before importing or exporting attribute maps. You can create UVs for polygonal or subdivision surfaces. See “Mapping UVs for polygonal surfaces” in the Polygonal Modeling guide, or see “Mapping UVs for subdivision surfaces” in the Subdivision Surface Modeling guide.
Import Artisan attribute maps to multiple surfaces

If the attribute map was created from multiple surfaces in Artisan (see page 256) and you want to import the map for these surfaces back to the same surfaces, the file names of the attribute map must match the surface file names. Also, you must turn on Reassign Attribute Maps when you import.

For example, suppose you create the following two surfaces and export the attribute map, calling it xando.

```
| nurbsPlaneShape1 | nurbsSphereShape1 |
```

Artisan creates two files, xando_nurbsPlane1_nurbsPlaneShape1 and xando_nurbsSphere1_nurbsSphereShape1. It saves the attribute maps separately for each surface in these files.

To import these maps back to the same surfaces, follow steps 1 through 6 under “To import an attribute map” on page 254. For step 7, import either the base file (xando) or one of the files associated with the surface (xando_nurbsPlane1_nurbsPlaneShape1 or xando_nurbsSphere1_nurbsSphereShape1). Artisan automatically maps each file to the appropriate surface.

In the following example, the attribute was imported with the Sculpt Surfaces Tool selected and set to Push.

```
| nurbsSphereShape1 | nurbsPlaneShape1 |
```

If you do not turn Reassign Attribute Maps on, the imported file maps to each selected surface.
Export attribute maps

You can export attribute maps created with the Paint Selection, Paint Scripts, Paint Vertex Color, Paint Attributes, Paint Cluster Weights, Paint Jiggle Weights, Paint Soft Body Weights, Paint Fluids, Paint Fur Attributes, and Paint Hair Tools. The values you paint with these tools become either the luminance values or alpha values in the attribute map (except for the Paint Vertex Color Tool, from which you can export RGB and RGBA values).

To export an attribute map


2. Select the surface or surfaces with values you want to export, then open the Tool Settings editor.

3. Open the Attributes Map then Export sections.

4. Select the “Export Value”.

5. Set the Map Size in the X and Y direction. The default is 256 pixels.

6. Turn Keep Aspect Ratio on to maintain the height to width ratio of the attribute map when you export it.

7. Select the format you want to save the image in.

8. Click the Export button.

The Export window opens.

9. In the Export window, select the directory location, type the file name, then click the Export button.

If you select more than one surface in step 2, Artisan concatenates the name you type with each surface name and creates a file for each surface.

For example, suppose you select two surfaces called `nurbsSphereShape1` and `nurbsSphereShape2`, and type `checker` for the map name. Artisan saves the attributes of `nurbsSphereShape1` in the file `checker_nurbsSphere1_nurbsSphereShape1` and the attributes of `nurbsSphereShape2` in the file `checker_nurbsSphere2_nurbsSphereShape2`. If you include the file name extension (for example, `checker.rgb`) Artisan appends the extension to the concatenated names (for example, `checker_nurbsSphereShape1.rgb` and `checker_nurbsSphereShape2.rgb`).

To import these attribute files, the surfaces you import them to must have the same name as the surfaces with the original attributes.

For more information on importing attribute maps, see “Import Artisan attribute maps to multiple surfaces” on page 255.
Set stylus pressure

With a real paint brush, pressing harder makes the brush wider and applies the paint more thickly. You can achieve a similar effect with a stylus in Artisan by specifying the effect of pressure on the tool.

To set stylus pressure

1. Select the Artisan tool you want to define the stylus pressure for.
2. Open the Tool Settings editor and open the “Stylus Pressure section”.
3. Select the pressure option you want to use.

Change the brush outline color

By default, the brush outline color is red. You can change the color to one that provides the best contrast with the surface you are painting.

To change the brush outline color

1. Select Window > Settings/Preferences > Colors. The Colors window opens.
2. Click the Active tab and expand Artisan Brushes.
3. Click the color you want on the Active Index palette or drag the Index slider to select it.

For more information on changing colors, see the Change user interface colors in the Basics guide.

Create an Artisan tool shelf

To make your Artisan tools more convenient to access, you can create an Artisan shelf and put the Artisan tools on it. Tools on the shelf are saved with your specific tool settings which means you can save multiple versions of the same tool. For example, you could add a Sculpt Surfaces Tool with the Push operation selected and another Sculpt Surfaces Tool with the Pull operation selected.

To save your specific tool settings to a shelf

1. Select the Artisan tool.
2. Modify the tool settings.
3. Using the middle mouse button, drag the tool from the Tool Box to the shelf.
4. Save the shelf.

For details on shelves, see Shelves in the Basics guide.
Define Artisan hotkeys

You can use hotkeys to change some Artisan tool settings without opening the Tool Settings editor.

You can set hotkeys that display marking menus (see "Use Artisan marking menus" on page 260).

You can set hotkeys that select options or actions. These hotkeys are straightforward—press the key to turn an option on or off or to select an option or action.

Using the activate/deactivate pairs listed in the Hotkeys editor, you can set hotkeys that change option settings when you drag or use the arrow keys (for example the brush stamp radius or displacement). These hotkeys work by pressing the hotkey and doing one of the following:

- dragging left or right, or up and down
  The setting appears as part of the brush outline and changes as you drag. For example, the following brush outline appears when you use an interactive hotkey to modify the brush stamp radius.

- selecting an item from a marking menu
  A marking menu appears when you press the hotkey and left mouse button. Select the menu item and release the left mouse button. See "Use Artisan marking menus" on page 260.

- clicking a cluster, set, or surface area using the arrow pointer

Default hotkeys

The following hotkeys are already set in Maya. You can change them and create other Artisan hotkeys in the Artisan and Brush Tools categories of the Hotkey editor. For information on defining hotkeys, see the Basics guide.

<table>
<thead>
<tr>
<th>Action</th>
<th>Default Hotkey</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flood surface with the current value</td>
<td>Press Alt-f (Windows, IRIX and Linux)</td>
</tr>
<tr>
<td></td>
<td>Press Option-f (Mac OS X)</td>
</tr>
<tr>
<td>Action</td>
<td>Default Hotkey</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Turn Show Wireframe display option on/off</td>
<td>Press Alt-a (Windows, IRIX and Linux)</td>
</tr>
<tr>
<td></td>
<td>Press Option-a (Mac OS X)</td>
</tr>
<tr>
<td>Turn Color Feedback display option on/off</td>
<td>Press Alt-c (Windows, IRIX and Linux)</td>
</tr>
<tr>
<td></td>
<td>Press Option-c (Mac OS X)</td>
</tr>
<tr>
<td>Turn Reflection stroke option on/off (original architecture)</td>
<td>Press Alt-r (Windows, IRIX and Linux)</td>
</tr>
<tr>
<td></td>
<td>Press Option-r (Mac OS X)</td>
</tr>
<tr>
<td>Radius (U) value (upper brush radius)</td>
<td>Press b and drag with the left mouse button</td>
</tr>
<tr>
<td>Radius (L) value (lower brush radius)</td>
<td>Press B and drag with the left mouse button</td>
</tr>
<tr>
<td>Value (in the Tool Settings editor)</td>
<td>Press n and drag with the left mouse button</td>
</tr>
<tr>
<td>Maximum Displacement value (for Sculpt Tools) or Change the Paint Effects Surface Offset value</td>
<td>Press m and drag with the left mouse button</td>
</tr>
<tr>
<td>Pick a color</td>
<td>Press the / key and then release it when done.</td>
</tr>
<tr>
<td>Pick a set to modify</td>
<td></td>
</tr>
<tr>
<td>Pick an attribute value</td>
<td></td>
</tr>
<tr>
<td>(Use with the Paint Color Per Vertex, Paint Set Membership, Paint Attribute, Paint Cluster Weights, Paint Jiggle Weights, and Paint Soft Body Weights, and Paint Fluids Tools.)</td>
<td></td>
</tr>
</tbody>
</table>
Use Artisan marking menus

Artisan marking menus give you quick access to tools and actions normally accessed from the Tool Settings editor.

- By default, the hotkey combination $u + \text{left mouse button}$ displays a marking menu that includes paint operation and reflection options for the selected Artisan tool.

- If you are running out of available hotkeys, or you have created too many hotkeys to remember, you can consolidate your Artisan shortcuts into a single marking menu. Create a hotkey for ModifyTargetMarking Menu and another for ModifyTargetPress/ModifyTargetRelease in the Artisan category of the Hotkey editor.

- You can define your own marking menus. For example, you could define a marking menu with each of the Artisan tools on it. For details on defining marking menus, see the Basics guide.
12 Painting with MEL scripts and the Paint Scripts Tool

About Painting with MEL scripts and the Paint Scripts Tool

Learn how to paint with MEL scripts using the Paint Scripts Tool. This tool involves setting up custom MEL scripts. For information on setting up the MEL scripts for these tools, see “Write MEL Scripts for the Paint Scripts Tool” on page 265.

Related topics
- “Overview of MEL script painting” on page 261
- “Script paint” on page 262
- “Script paint on restricted surface areas” on page 264
- “Flood surfaces” on page 265
- “Write MEL Scripts for the Paint Scripts Tool” on page 265

Overview of MEL script painting

A MEL script is a file that contains MEL commands, MEL procedures, or both. Typically, you use a MEL script to create custom effects. Using the Artisan Paint Scripts Tool, you can paint these effects on your surfaces the same way you paint weights. There are three sample scripts for you to try:

- **spherePaint** – Use this script to paint spheres on a selected NURBS surface. It is included as an example just to help you write your own MEL scripts.
- **geometryPaint** – Use this script to select predefined objects in your scene and then paint them on a selected surface. For example, if the object is a cone, you can paint cones on the surface using the geometryPaint script. The Paint Scripts Tool settings determine the size, position, angle, and density of the cones.
- **emitterPaint** – Use the emitterPaint script to paint emitters on surfaces. Emitters generate particles. The attributes of the emitter control the position, direction, quantity, and initial velocity of the emitted particles when they are born. After the particle is born, the attributes
Painting with MEL scripts and the Paint Scripts Tool | 12

Script paint >

of the particle object that the emitter is connected to control the particle’s appearance. For more details about emitters, see the Dynamics guide.

These scripts are stored on the following directories:

(Windows) \Program Files\Alias\Maya6.0\scripts\others
(IRIX and Linux) mayapath/scripts/others
(Mac OS X) /Applications/Maya6.0/Application Support/scripts/others

You might find these examples helpful when you are writing your own MEL scripts. These scripts have not been thoroughly tested and therefore are not supported. For details on creating your own scripts, see the MEL and Expressions guide.

Related topics

- “Script paint” on page 262
- “Script paint on restricted surface areas” on page 264
- “Flood surfaces” on page 265
- “Write MEL Scripts for the Paint Scripts Tool” on page 265

How do I?  Script paint

You script paint by selecting a script and painting strokes on the surface with the Paint Scripts Tool.

To script paint

1. Make sure that the script you want to paint with is in your script directory:

   (Windows)  Documents and Settings\username\My Documents\maya\6.0\scripts
   (IRIX and Linux)  ~username/maya/6.0/scripts
   (Mac OS X)  In your Home folder, in /Applications/Maya 6.0/ Applications Support/scripts/others (Mac OS X) or mayapath/scripts/ paintEffects (Windows, IRIX and Linux).
Painting with MEL scripts and the Paint Scripts Tool

Paint Scripts Tool settings

2 Select the surface you want to script paint on.

Note The sample scripts are in:
(Windows) \Program Files\Alias\Maya6.0\scripts\others
(IRIX and Linux) mayapath/scripts/others
(Mac OS X) Applications/Maya6.0/Application Support/scripts/others
You do not need to move them to your personal scripts directory, however, any new scripts you create should be stored there.

3 Select the Paint Scripts Tool (Modify > Paint Scripts Tool) and define tool settings, if required. For details on defining tool settings, see “Paint Scripts Tool settings” on page 264.

4 Go to the Setup section.

5 In the Tool Setup Cmd box, type the name of the MEL script (without the .mel extension), and then press Enter (Windows, IRIX, and Linux) or Return (Mac OS X). This box is case sensitive.

For example, for the sample scripts type geometryPaint, spherePaint, or emitterPaint.

A script window may open, depending on the script. Entries may also appear in the boxes in the Setup section. These are MEL procedures and come from the script. You do not need to modify them. For more information on these procedures, see “Script Paint MEL procedures” on page 265.

6 Change any settings in the script window then drag the brush across the surface. For details on the settings in the sample script windows, see “geometryPaint sample script settings” and “emitterPaint sample script settings” on page 285.

Paint Scripts Tool settings

Before you script paint, set options for the Paint Scripts Tool in the Tool Settings editor (Modify > Paint Scripts Tool > ).
The settings in the Paint Scripts Tool Settings editor determine the effect you will achieve when you paint with the tool. For descriptions of these settings, see “Common Artisan Brush Tool Settings” on page 299.

The Setup section in the Paint Scripts Tool Settings editor is unique to this tool. Use it to specify which scripts you want to paint with.

Related topics
- “Overview of MEL script painting” on page 261
- “Script paint” on page 262
- “Script paint on restricted surface areas” on page 264
- “Flood surfaces” on page 265
- “Write MEL Scripts for the Paint Scripts Tool” on page 265

Tips
- You can define hotkey combinations to change most of the settings without opening the Tool Settings editor. For details on setting hotkey combinations, see ”Define Artisan hotkeys” on page 258.
- You can save your tool settings by adding the tool to a shelf. For details, see “Create an Artisan tool shelf” on page 257.

Script paint on restricted surface areas
You can block off an area on a surface so it is not affected by the script painting you do. When you apply brush strokes over the area, the vertices on the area remain unchanged, regardless of the script paint operation.

For details, see “Restrict an area for painting” on page 252.

Flood surfaces
Flooding a surface is like taking a huge brush and applying its settings to the entire surface. The result depends entirely on the brush settings defined when you perform the flood.

For details, see “Flood paint” on page 251.

Write MEL Scripts for the Paint Scripts Tool

Note
This section assumes knowledge of MEL scripting and programming. For more information about MEL, see the MEL and Expressions guide.
The Paint Scripts Tool is based on the concept of a two-dimensional array of numeric values super-imposed on a NURBS or polygonal surface. This array is either defined by the vertex positions of the surface or an arbitrary 2D grid that is evenly spaced in the surface parameter space. Think of this array of numbers as a 2D grayscale image, where each pixel corresponds to an array position and the grayscale value corresponds to the number associated with that array position. The scripts associated with the Paint Scripts Tool determine how Artisan interprets this array of numbers. Artisan calls the script when it needs to know the number assigned to one of the array positions as described above. Artisan also calls the script when it changes a number assigned to one of the array positions.

Script Paint MEL procedures

The Paint Scripts Tool is defined by a set of MEL procedures. The names of the MEL procedures display in the Setup section of the Tool Settings editor. You can also set up the MEL procedures using the `artUserPaintCtx` MEL command. This chapter describes the following Artisan MEL procedures:

- "Tool Setup Command (-tsc “ToolSetupCommand”)" on page 266
- "Tool Cleanup Command (-tcc “ToolCleanupCommand”)" on page 266
- "Get Array Attribute Command (-gac “GetArrayAttributeCommand”)" on page 267
- "Initialize Command (-ic “InitializeCommand”)" on page 267
- "Finalize Command (-fc “FinalizeCommand”)" on page 269
- "Set Value Command (-svc “SetValueCommand”)" on page 270
- "Get Value Command (-gvc “GetValueCommand”)" on page 270
- "Get Surface Command (-gsc “GetSurfaceCommand”)" on page 271
- "Change Grid Size" on page 280
- "Paint Cones instead of Spheres” on page 280
- "Jitter the Grid” on page 280

In the following descriptions, the `artUserPaintCtx` flag used to set the command, is in brackets.

**Tool Setup Command (-tsc “ToolSetupCommand”)**

If defined, `ToolSetupCommand` is called just after the Paint Scripts Tool is selected (either by using the Modify > Paint Scripts Tool menu item or selecting it from the Tool Box or the shelf). This procedure is often used to set up all the other Artisan MEL procedures. Define this procedure as follows:
Paint Effects, Artisan, and 3D Paint

Painting with MEL scripts and the Paint Scripts Tool | 12
Write MEL Scripts for the Paint Scripts Tool

```
global proc ToolSetupCommand {
    string $toolContextName
}
{
    // This is an example artUserPaintCtx command that
    // would setup
    // the following Artisan procedures. This is not a
    // realistic
    // example because you would never have all the
    // procedures
    // defined.
    //
    artUserPaintCtx -e
    -tcc "ToolCleanupCommand"
    -gac "GetArrayAttributeCommand"
    -ic "InitializeCommand" -fc "FinalizeCommand"
    -svc "SetValueCommand" -gvc "GetValueCommand"
    -gsc "GetSurfaceCommand"
    $toolContextName;
}

... where $toolContextName is the name of the tool context that was
selected. It is meant to be used as the final argument to the artUserPaintCtx
command.

Tool Cleanup Command (-tcc "ToolCleanupCommand")

If defined, ToolCleanupCommand is called just before a Paint Scripts Tool is
exited. Define this procedure as follows:

```

```

... where $toolContextName is the name of the tool context that is exited.

Get Array Attribute Command (-gac "GetArrayAttributeCommand")

If you define this command, any commands defined for the Initialize
Command, Finalize Command, Set Value Command and Get Value Command
are ignored.

If defined, GetArrayAttributeCommand is called once for every surface that
is selected for painting. This procedure returns a string, which is
interpreted as a list of names referring to double array attributes on some
dependency node. Define this procedure as follows:

```

```

Paint Effects, Artisan, and 3D Paint

266
Painting with MEL scripts and the Paint Scripts Tool

Write MEL Scripts for the Paint Scripts Tool

string $surfaceName
)
{
  string $arrayAttributes

  // determine array attributes that correspond to
  // $surfaceName
  ...

  return $arrayAttributes;
}

... where $surfaceName is the name of the surface which will be associated
with the returned array attributes. If more than one array attribute is
returned, the first one is read when Artisan requires a value but all of
them are written by Artisan.

Initialize Command (-ic “InitializeCommand”)
If defined, InitializeCommand is called once per paintable surface before the
beginning of every stroke. Define this procedure as follows:

global proc string InitializeCommand(
  int $surfaceName
)
{
  string $flags;

  // build up $flags
  //
  ...}

  return $flags;
}

...where $surfaceName is the name of the surface. For examples, see
spherePaint.mel and geometryPaint.mel in the following directories:
(Windows) \Program Files\Alias\Maya6.0\scripts\others
(IRIX and Linux) mayapath/scripts/others
(Mac OS X) Applications/Maya6.0/Application Support/scripts/others

This procedure should:

- determine a unique integer surface ID for this surface. This ID is
  passed to future invocations of SetValueCommand,GetValueCommand
  and FinalizeCommand associated with this surface. If your script
  maintains per surface information, it is convenient to make this ID an
  array index, which can be used to easily access the per surface
  information.
Painting with MEL scripts and the Paint Scripts Tool | 12
Write MEL Scripts for the Paint Scripts Tool >

- determine what sort of information is required by future invocations of SetValueCommand associated with this surface.
- determine whether to paint on the surface vertices or on an evenly spaced grid in the surface’s parameter space.

All of this information is passed back to Artisan via the $flags variable passed back from the procedure. This is a string that contains a sequence of flags and arguments very similar to the flags and arguments that can be passed to standard MEL procedures. These are the flags that are understood by the Paint Scripts Tool. Each flag has a short and long version (that is, -short/long) plus some arguments:

- **-id/identifier int**
  This flag indicates the integer surface ID that is to be used for this surface. If this flag is not specified, the surface ID for this surface is -1.

- **-uv/uvlong string**
  This flag indicates whether the (U,V) location should be sent to SetValueCommand. The possible values for this are none, surface or normalized. The default is none.

- **-p/position string**
  This flag indicates whether the (x,y,z) position should be sent to SetValueCommand. The possible values for this are none, local or world. The default is none.

- **-n/normal string**
  This flag indicates whether the (nx,ny,nz) normal should be sent to SetValueCommand. The possible values for this are none, local or world. The default is none.

- **-g/grid int1 int2**
  This flag indicates that painting should occur on an evenly spaced grid in parameter space of size int1 in the surface’s U direction and int2 in the surface’s V direction. If this flag isn’t specified, painting occurs on an array defined by the surface’s vertices.

- **-j/jitter boolean**
  This flag is only valid in conjunction with the -grid flag. If it is true, the grid positions are jittered before they are passed to the SetValueCommand. The default value is false.

- **-d/dither boolean**
  This flag is only valid in conjunction with the -grid flag. If it is true, Artisan uses a 16x16 dithering matrix to determine whether SetValueCommand should be called for it.

- **-dt/directionType string**
This flag indicates whether the (U,V,W) stroke direction should be sent to `SetValueCommand`. The possible values for this are none, screenV (a vector in screen space) or worldV (a vector in world space). The default is none. For projection painting, both screenV and worldV return a vector in screen space. The direction option is not supported for reflection painting. The third value (W) will be invalid if the user has requested direction as screen vector.

- `-sp/stampPosition string`

This flag indicates whether the (spX, spY, spZ) stamp position should be sent to `SetValueCommand`. The possible values for this are none, local or world. The default is none.

**Finalize Command (`-fc "FinalizeCommand"`)**

If defined, `FinalizeCommand` is called once per paintable surface after the end of every stroke. Define this procedure as follows:

```
global proc FinalizeCommand(
    int $surfaceID
)
{
    ...
}
```

... where `$surfaceID` is the surface identifier assigned to the surface by this surface's corresponding `InitializeCommand`.

**Set Value Command (`-svc "SetValueCommand"`)**

If defined, `SetValueCommand` is called when Artisan has set the value associated with a particular “location” on the surface. This procedure is called once per location. Therefore, if some Artisan painting operation changes the values at 10 locations on a surface, `SetArrayAttributeCommand` is called 10 times. Define this procedure as follows:

```
global proc SetValueCommand(
    int $surfaceID,
    int $index,
    float $value,
    // The following arguments are only passed if requested by
    // InitializeCommand. However this is the order that they
    // will be passed in.
    // float $u,  // ($u,$v) is UV location on surface
    float $v,
```

Paint Effects, Artisan, and 3D Paint

Painting with MEL scripts and the Paint Scripts Tool | 12
Write MEL Scripts for the Paint Scripts Tool >

```mel
float $px, // ($px,$py,$pz) is position on
       surface
float $py,
float $pz,
float $nx, // ($nx,$ny,$nz) is surface
       normal
float $ny,
float $nz
}
{
  ...
}

... where:

- `$surfaceID` is the surface identifier assigned to the surface by this
  surface’s corresponding `InitializeCommand`
- `$index` is the vertex or grid index
- `$value` is the value to be assigned to the passed index

The extra arguments passed to this procedure depend on what was
returned from the surface’s `InitializeCommand`.

Get Value Command (`-gvc “GetValueCommand”`)

If defined, `GetValueCommand` is called when Artisan wants the value
associated with a particular “location” on the surface. Define this
procedure as follows:

```mel
global proc float GetValueCommand(
  int $surfaceID,
  int $valueIndex
)
{
  float $value

  // determine the value associated with $valueIndex
  location
  // on surface $surfaceID
  //
  ...

  return $value;
}
```

... where:

- `$surfaceID` is the surface identifier assigned to the surface by this
  surface’s corresponding `InitializeCommand`
$\textit{valueIndex}$ is the index for the “location” for which Artisan requires the value.

**Get Surface Command** \(-\textit{gsc “GetSurfaceCommand”}\)

This command is rarely defined. If it is defined, \textit{GetSurfaceCommand} is called once for every dependency node on the selection list, whenever Artisan processes the selection list. This usually occurs whenever the Paint Scripts Tool is selected. Define this procedure as follows:

```mel
global proc string GetSurfaceCommand (string $selectedDependencyNode)
{
    string $surface;
    // Set $surface based on $selectedDependencyNode.
    // Set $surface to NULL string (**“”**), if no surface
    // is to be painted because of $selectedDependencyNode.
    //
    return $surface;
}
```

This procedure overrides Artisan default handling of the selection list.

**Example Script Paint script**

This section explains the overall script layout and gives an annotated script example.

**Overall script layout**

The scripts used for the Paint Scripts Tool can be arranged in many ways. This example script layout is used in the sample Artisan scripts available in:

(Windows) \Program Files\Alias\Maya6.0\scripts\others

(IRIX and Linux) mayapath/scripts/others

(Mac OS X) Applications/Maya6.0/Application Support/scripts/others

The layout keeps all the MEL procedures in one file and allows all the scripts to be defined by only filling in the Tool Setup Cmd box in the Setup section of the Tool Settings window. This procedure sets up all the other MEL procedures using the \textit{artUserPaintCtx} command. Here is a very high-level view of this:
Painting with MEL scripts and the Paint Scripts Tool | 12
Write MEL Scripts for the Paint Scripts Tool

// Define global variables used throughout the script
//
global ...;

// Define the Tool Setup Cmd procedure. This procedure will
// setup all the other MEL procedures used by the Paint
// Scripts tool.
//
// "spherePaint" would be entered into the Tool Setup Cmd field in
// the Setup section of the tool settings window.
//
global proc spherePaint( string $context )
{
    artUserPaintCtx -e
    -ic "initSpherePaint"
    -fc "finishSpherePaint"
    -svc "setSpherePaintValue"
    -gvc "getSpherePaintValue"
    -gsc ""
    -gac ""
    -tcc ""
    $context;
}

// Define various procedures that were mentioned in the Tool
// Setup Cmd procedure above. All the procedures defined by
// the artUserPaintCtx command have to be global.
//
global proc string initSpherePaint( string $surfaceName )
{
    ...
}

spherePaint.mel
This is an annotated version of the spherePaint.mel file supplied on:

mayapath/scripts/others (IRIX and Linux)
/Applications/Maya6.0/Application Support/scripts/others (Mac OS X)

This script works on NURBS surfaces only.

//
// This is a simple example script for the Artisan Paint
// Scripts tool. It will paint spheres onto the selected
// surfaces. The size of the spheres are controlled by the
// painted values.
//
// Usage:
Painting with MEL scripts and the Paint Scripts Tool

Write MEL Scripts for the Paint Scripts Tool

// 1) Place this script into your scripts directory (usually the maya/scripts directory in your home directory
// 2) Select the Paint Scripts Tool (Modify > Paint Scripts Tool) and bring up the Tool Settings window
// 3) Go to the Setup section and enter “spherePaint” into the “Tool Setup Cmd” field and hit enter
// 4) Paint Geometry

// Tips:
// Once you have the Geometry Paint Tool setup you may want to it from the toolbar to the shelf so that it is always accessible

These global variables are used to determine how many surfaces are being painted and to determine surface IDs. $sphereNamePrefix is an array of strings, one string per active surface. If an entry is the empty string, it means that it’s array index is available to be used as a surface ID. If the entry is non-empty, this string is used as a prefix when creating the spheres. $spherePaintFreeSlot is the first free entry in $sphereNamePrefix and $spherePaintSlots is the current size of $sphereNamePrefix. This approach of using arrays indexed by the surface ID to store per surface information is used heavily in some of the other sample Artisan scripts.

// These are global variables used to keep track of multiple surfaces and the name prefixes used for the spheres on each surface
//
global string $sphereNamePrefix[];
global int $spherePaintFreeSlot = 0;
global int $spherePaintSlots = 0;

spherePaint is the procedure that initializes the Paint Scripts Tool by telling it what procedures should be called under various circumstances.

// This procedure should be set as the “Tool Setup Cmd” in the Setup section of the Maya Artisan Paint Scripts Tool’s tool settings
// window. The tool context is supplied as an argument.
//
global proc spherePaint( string $context )
{
    // initialize all the other commands in this scriptable
    // paint tool context.
Painting with MEL scripts and the Paint Scripts Tool | 12
Write MEL Scripts for the Paint Scripts Tool

// This is the “Initialize Cmd”. This procedure is called once
// for every selected surface when an initial click is received
// on any surface. The argument is the name of the surface. This
// procedure returns a string which indicates to the scriptable
// tool how to behave for the duration of the stroke.
//
// global proc string initSpherePaint( string $name )
//
// The first thing to do is determine a surface ID to associate with this
// surface. This is done by going through the $sphereNamePrefix array,
// looking for the first free entry. Once it finds an entry, the entry index is
// used as the surface ID ($slot).

// find a free slot for this surface in the global arrays
//
// for ( $slot = $spherePaintFreeSlot; $slot < $spherePaintSlots; $slot++ )
//
// if ( $sphereNamePrefix[$slot] == "" ) {
// break;
// }
//
// if ( $slot == $spherePaintSlots ) {
// $spherePaintSlots++;

// This is the “Initialize Cmd”. This procedure is called once
// for every selected surface when an initial click is received
// on any surface. The argument is the name of the surface. This
// procedure returns a string which indicates to the scriptable
// tool how to behave for the duration of the stroke.
//
// global proc string initSpherePaint( string $name )
//
// The first thing to do is determine a surface ID to associate with this
// surface. This is done by going through the $sphereNamePrefix array,
// looking for the first free entry. Once it finds an entry, the entry index is
// used as the surface ID ($slot).

// find a free slot for this surface in the global arrays
//
// for ( $slot = $spherePaintFreeSlot; $slot < $spherePaintSlots; $slot++ )
//
// if ( $sphereNamePrefix[$slot] == "" ) {
// break;
// }
//
// if ( $slot == $spherePaintSlots ) {
// $spherePaintSlots++;

// This is the “Initialize Cmd”. This procedure is called once
// for every selected surface when an initial click is received
// on any surface. The argument is the name of the surface. This
// procedure returns a string which indicates to the scriptable
// tool how to behave for the duration of the stroke.
//
// global proc string initSpherePaint( string $name )
//
// The first thing to do is determine a surface ID to associate with this
// surface. This is done by going through the $sphereNamePrefix array,
// looking for the first free entry. Once it finds an entry, the entry index is
// used as the surface ID ($slot).

// find a free slot for this surface in the global arrays
//
// for ( $slot = $spherePaintFreeSlot; $slot < $spherePaintSlots; $slot++ )
//
// if ( $sphereNamePrefix[$slot] == "" ) {
// break;
// }
//
// if ( $slot == $spherePaintSlots ) {
// $spherePaintSlots++;

// This is the “Initialize Cmd”. This procedure is called once
// for every selected surface when an initial click is received
// on any surface. The argument is the name of the surface. This
// procedure returns a string which indicates to the scriptable
// tool how to behave for the duration of the stroke.
//
// global proc string initSpherePaint( string $name )
//
// The first thing to do is determine a surface ID to associate with this
// surface. This is done by going through the $sphereNamePrefix array,
// looking for the first free entry. Once it finds an entry, the entry index is
// used as the surface ID ($slot).

// find a free slot for this surface in the global arrays
//
// for ( $slot = $spherePaintFreeSlot; $slot < $spherePaintSlots; $slot++ )
//
// if ( $sphereNamePrefix[$slot] == "" ) {
// break;
// }
//
// if ( $slot == $spherePaintSlots ) {
// $spherePaintSlots++;

// This is the “Initialize Cmd”. This procedure is called once
// for every selected surface when an initial click is received
// on any surface. The argument is the name of the surface. This
// procedure returns a string which indicates to the scriptable
// tool how to behave for the duration of the stroke.
//
// global proc string initSpherePaint( string $name )
//
// The first thing to do is determine a surface ID to associate with this
// surface. This is done by going through the $sphereNamePrefix array,
// looking for the first free entry. Once it finds an entry, the entry index is
// used as the surface ID ($slot).

// find a free slot for this surface in the global arrays
//
// for ( $slot = $spherePaintFreeSlot; $slot < $spherePaintSlots; $slot++ )
//
// if ( $sphereNamePrefix[$slot] == "" ) {
// break;
// }
//
// if ( $slot == $spherePaintSlots ) {
// $spherePaintSlots++;

// This is the “Initialize Cmd”. This procedure is called once
// for every selected surface when an initial click is received
// on any surface. The argument is the name of the surface. This
// procedure returns a string which indicates to the scriptable
// tool how to behave for the duration of the stroke.
//
// global proc string initSpherePaint( string $name )
//
// The first thing to do is determine a surface ID to associate with this
// surface. This is done by going through the $sphereNamePrefix array,
// looking for the first free entry. Once it finds an entry, the entry index is
// used as the surface ID ($slot).

// find a free slot for this surface in the global arrays
//
// for ( $slot = $spherePaintFreeSlot; $slot < $spherePaintSlots; $slot++ )
//
// if ( $sphereNamePrefix[$slot] == "" ) {
// break;
// }
//
// if ( $slot == $spherePaintSlots ) {
// $spherePaintSlots++;
The next thing to do is determine whether the passed in $name corresponds to a NURBS surface. If it does, a prefix is generated for the painted spheres and stored into the appropriate entry in the $sphereNamePrefix array.

```maya
if ( `nodeType $name` == "nurbsSurface" ) {
    // save the name of the parent of this shape as well
    // as a prefix to use when creating the spheres
    // string $parent[] = `listRelatives -p $name`;
    $sphereNamePrefix[$slot] = $parent[0] + "Sphere";
}
```

The final function for the initialize procedure is to return a string which indicates to Artisan how to handle this surface. The string is a sequence of special flags and their arguments, as described earlier. In this case, the string includes flags telling Artisan:

- what surface ID should be used for this surface
- that painting should occur on a 20x20 grid, evenly spaced in the surface’s parameter space
- that the world space position should be passed to setSpherePaintValue whenever it is called.

```maya
// Return an argument string which:
// - tells the tool what surface ID to use for this surface
// - indicates that values should be distributed on a 20x20 grid on the surface
// - indicate that the associated world space position
//   should also be passed to the "Set Value Cmd".
// return ( \\
//          "-id " + $slot
//          + " -grid 20 20"
//          + " -position world" );
```

// This is the “Finalize Cmd”. This procedure is called at the
global proc finishSpherePaint( int $slot )
{

This is called at the end of the stroke. Use $slot to clear out this surface’s corresponding entry in $sphereNamePrefix. Also update $spherePaintFreeSlot with $slot, if $slot is earlier in the array.

    global string $sphereNamePrefix[];
    global int $spherePaintFreeSlot;

    // clear out the slot that was used for this surface
    // $sphereNamePrefix[$slot] = "";
    if ( $slot < $spherePaintFreeSlot ) {
        $spherePaintFreeSlot = $slot;
    }
}

// This is the “Set Value Cmd”. It is called everytime a value
// on the surface is changed. A surface ID, a grid index
// on the surface and the value associated with that grid
// index is passed. There can be additional arguments depending on
// the
// options generated by the return value of the "Initialize
// Cmd".
// In this case the (x,y,z) surface position for this grid
// point
// is also passed.
//
// global proc setSpherePaintValue(
//    int $slot,
//    int $index,
//    float $val,
//    float $x,
//    float $y,
//    float $z
//)
//{
    global string $sphereNamePrefix[];

Determine if $slot is a valid surface ID by checking if the corresponding entry in $sphereNamePrefix is not the empty string.
if ( $sphereNamePrefix[$slot] != "" ) {

All the painted spheres have a unique name which combines the $sphereNamePrefix for this surface plus the grid index. This is how this script determines whether something has already been painted at this location. One disadvantage to this method is that it is sensitive to the grid size specified in initSpherePaint. For example an index of 44 would correspond to grid position (4,4) on a 10x10 grid. However if the grid size was changed to 20x20, index 44 would now correspond to grid position (2,4).

// determine the name of the sphere associated with this grid location
//
// string $objname = $sphereNamePrefix[$slot] + $index;
if ( `objExists $objname` ) {

In this case the sphere already exists. Therefore, the passed value, $val, is used as the overall scale factor for the spheres. As a special case, if the value is less than or equal to 0, the corresponding sphere is removed.

    // if the sphere already exists, use the value to adjust the size of the sphere. If the value is 0, the sphere is deleted
    //
    if ( $val > 0 ) {
        scale $val $val $val $objname;
    } else {
        delete $objname;
    }
} else if ( $val > 0 ) {

In this case, there is no painted sphere corresponding to this grid location. Create a sphere using the sphere MEL command using the -name option to give the newly created sphere the desired name. Once the sphere is created, uniformly change the sphere’s scale factor to the passed in value ($val). At this point the sphere is also positioned so that it appears at the right place by moving it from the origin (this is where spheres are created by default) to the world space position that was passed into this procedure ($x,$y,$z).
// the sphere doesn’t exist
//
string $sname[];

// create a sphere with the proper
name, scale it by
// the passed value and parent the
sphere to the same
// parent as the surface we are
painting on

// parent as the same

$sname=`sphere -ch off -name $objname`;
if ( $sname[0] != $objname ) {
print ("SPHERE NAME FAILED:"

+ $objname + " got " +

$sname[0] + ",n");
}
scale $val $val $val;
move $x $y $z;
}

// This is the “Get Value Cmd”. It is called everytime a
value
// on the surface is needed by the scriptable paint tool. A
// surface ID and a grid index is passed in. This procedure
should
// return the value for this grid location on the specified
surface.
// global proc float getSpherePaintValue( int $slot, int $index )
{
    global string $sphereNamePrefix[];

    if ( $sphereNamePrefix[$slot] != "" ) {
        // if this slot is valid, generate the name
        for the
        // sphere at this grid index
        //
        string $objname = $sphereNamePrefix[$slot] +
        $index;

    }

This procedure is called whenever Artisan needs a value corresponding to
a specific grid location. In this script, the values are the sphere’s scale
factor.
if (`objExists $objname`) {

If a sphere has been painted at the location referenced by $index, then the sphere’s X scale factor is returned. There is nothing magical about the X scale factor. It could just as easily have been the Y or Z scale factor, or the average of all scale factors for that matter. It is entirely up to the script.

    // if the sphere exists, return the X scale factor
    // as the value for this grid location
    //
    return `getAttr ($objname + ".sx")`;

} else {

If there is no sphere at this location, just return 0.0 as the value for this location.

    // the sphere doesn’t exist, therefore
    return 0 as
    // the value for this grid location
    //
    return 0.0;
}

Here are some experiments you can try on this script to get an idea of how it works.

Change Grid Size
Change line 89 from:

```
+ " -grid 20 20"
```

to:

```
+ " -grid 40 30"
```

Paint Cones instead of Spheres
Change line 154 from:

```
$sname=`sphere -ch off -name $objname`;
```

to:

```
$sname=`cone -ch off -name $objname`;
```
Jitter the Grid
Add the line:

```
+ " -jitter true"
```

before line 90.

**Reference**

**Modify > Paint Scripts Tool**

Lets you use the Paint Scripts Tool to paint MEL scripts. For more information, see “Script paint” on page 262. See also “How Artisan brush tools work” on page 247.

**Modify > Paint Scripts Tool > □**

Use this to specify the settings for the Paint Scripts Tool in the Tool Settings editor.

For information about the settings in the other sections, including the Setup section, see “Common Artisan Brush Tool Settings” on page 299.

**Paint Attributes**

These are the settings in the Paint Attributes section of the Tool Settings editor for the Paint Scripts Tool.

**Paint Operation**

Notice that the brush stamp changes to indicate which operation is selected.

- **R** Replace
- **A** Add
- **Sc** Scale
- **Sm** Smooth

To remove the letters and gradient marking from the brush stamp, open the Tool Settings editor, click the Display tab and turn Draw Brush Feedback off.

**Replace**

For the geometryPaint and spherePaint scripts, replaces the values you paint over with the specified Value and Opacity.
For the emitterPaint script, replaces the values for the selected attribute of the painted emitter with Value and Opacity settings and replaces the painted emitters with emitters that have these new attributes. For example, if the selected operation is to Modify the Speed emitter attribute, the emitter speed is replaced by the Value and Opacity settings.

Add

For the geometryPaint and spherePaint scripts, adds the specified Value and Opacity to the current values you paint over. If the Paint Offset is negative, the value actually decreases.

For the emitterPaint script, adds to the values for the selected attribute of the painted emitters by the Value and Opacity factors.

Scale

For the geometryPaint and spherePaint scripts, scales the current values you paint over by the Value and Opacity factors.

For the emitterPaint script, scales the values for the selected attribute of painted emitters by the Value and Opacity factors.

Smooth

For the geometryPaint and spherePaint scripts, changes the values to be the average values of the surrounding vertices.

For the emitterPaint script, changes the values for the selected attribute of the painted emitters to be the averages of the values for the surrounding emitters.

Value

Set the value to apply when you perform any of the script painting operations. The value has a different meaning depending on the script. For example:

For the geometryPaint and spherePaint scripts, Value refers to the size of the geometry when the Control is set to Scale. The original geometry size has a value of 1.

For the emitterPaint script, Value refers to the percentage of the selected script operation.

Min/Max Value

Set the minimum and maximum possible paint values. By default, you can paint values between 0 and 1. Setting the Min/Max Values you can extend or narrow the range of values. Negative values are useful.
for subtracting weight. For example, if you set Min Value to -1, Value to -0.5, and select Add for the operation, you would subtract 0.5 from the weight of vertices you paint. Positive values are used as multipliers.

Clamp Lower, Clamp Upper

Select whether you want to clamp the values within a specified range, regardless of the Value set when you paint. You can set clamping to Lower, Upper, or both.

For example, if you clamp Lower and set Clamp Value Lower to 0.5, the values you paint will never be less than 0.5, even if you set Value to 0.25. Similarly, if you clamp Upper and set Clamp Upper to 0.75, the values you paint will never be greater than 0.75, even if you set Value to 1.

geometryPaint sample script settings

Geometry

Type the names of the objects you want to paint, separating each with a space. The objects must be in your scene at the origin. If you type more than one object name, Maya paints them randomly.

Identifier

Type a name to identify the layer the painted objects belong to. By painting on different layers, you can modify the objects on one layer without affecting the objects on a different layer. For example, if you type Layer1 in this box and paint cones, then type Layer2 in the box and paint spheres, when you go back to Layer1 and paint, the spheres in Layer2 will be unaffected.

If you cannot remember a layer name, or identifier, open the Outliner and select an object belonging to the layer. The identifier name is part of the object name.

Operation

Create/Modify

Creates new objects, and modifies the objects you paint over using the settings in this window and on the Paint Scripts tab.

Modify

Modifies the objects you paint over using the settings in this window and on the Script Paint tab.

Remove

Removes the objects you paint over.
Grid

Turn Grid on to use the grid you set in the U Grid Size and V Grid Size boxes to place the geometry. If you do not turn Grid on, Maya uses the vertex position to place geometry.

For each surface you paint, do not change the grid size. Changing the grid size while you paint produces undesirable results.

Also, keep in mind that your grid settings are interpreted in part by the UV mapping technique used on the surface. Make sure the UVs are correctly projected on the surface.

Jitter Grid

Turn Jitter Grid on to randomize the position of the painted objects on the grid.

U Grid Size, V Grid Size

Select the desired U and V Grid Size. Artisan paints the geometry on the grid point of the U and V grid you specify here, regardless of the isoparm density you set for the surface. The larger the grid size, the denser the geometry.

In the following example, the isoparm density of the surface is 10, but the U and V Grid Size are both set to 5 in the Geometry Paint Settings window.

Control

These controls define how painted objects are transformed. Do not select both scale and rotation controls at the same time.

X, Y and Z Scale

Scales object values by the factor set in the Value box of the Script Paint tab.

X, Y and Z Rot

Rotates objects based on the Value set in the Script Paint tab. A Value of 1 rotates objects 360 degrees.
Painting with MEL scripts and the Paint Scripts Tool | 12
Write MEL Scripts for the Paint Scripts Tool

X, Y and Z
  Trans  Moves objects along the surface in the X, Y, and/or Z direction based on the Value set in the Script Paint tab. A Value of 1 moves objects 1 grid position.

Options
  Proportional  Distributes changes proportionally across all painted attributes rather than replacing them all with the new value.
  Attach  Attaches the objects to their position so they move with the surface when you modify the surface (for example, when you sculpt or translate it).
    This option works only on NURBS surfaces.
  Duplicate  Creates copies rather than instances of the original objects.
  Group  Groups the painted objects together on one identifier, or layer.
  Isolate  Isolates scale, rotate, and translate transformations, so they remain independent of each other. With Isolate turned on, you can return objects to a base position by selecting the control and flooding with a Value of 0 for rotation and translation, or 1 for scale.
  Align  Aligns objects along the surface normal.

Jitter value
  Enter a jitter value to apply to the selected controls when Jitter Grid is turned on, where 0 results in no jitter, and 1 results in maximum jitter.
emitterPaint sample script settings

U Grid Size, V Grid Size

Select the desired U and V Grid Size. Artisan paints the emitters on the grid points of the U and V grid you specify, regardless of the isoparm density you set for the surface. The larger the grid size, the denser the emitters.

Grid Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jitter</td>
<td>Randomizes the position of the painted emitters.</td>
</tr>
<tr>
<td>Dither</td>
<td>Concentrates emitters at the center of the brush stamp, with few emitters at the edge. If you do not turn this option on, the emitters concentrate uniformly on the stamp.</td>
</tr>
</tbody>
</table>

Operation

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create</td>
<td>Creates emitters.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes emitters.</td>
</tr>
</tbody>
</table>

Emitter Attr. Modify

Changes the value of the selected attribute (Rate, Spread, Speed, Min Dist, or Max Dist) to the value set under Creation Options.

Modify Particle Attr.

Changes the value of the selected attribute (Lifespan, Opacity, Point Size, Line Width, Tail Fade, Tail Size, Radius, Multi Count, Multi Radius) to the value set under Stamp Profile on the Script Paint tab.

Modify Render Type

Changes the particle render type to the selected type (Multi-Point, Multi-Streak, Numeric, Points, Spheres, Sprites, Streak, or Blobby (s/w)).

Creation Options

Type

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Omni-directional</td>
<td>Sets the type of emitter to be an omnidirectional point emitter. This emits particles in all directions.</td>
</tr>
<tr>
<td>Directional</td>
<td>Sets the type of emitter to be a directional point emitter.</td>
</tr>
</tbody>
</table>

Rate

Set the rate at which particles are emitted. The rate is particles per unit of time.
Painting with MEL scripts and the Paint Scripts Tool | 12
Write MEL Scripts for the Paint Scripts Tool >

Speed
Set the speed multiple of the emission. The velocity of the emitted particles is multiplied by this amount.
You can enter a value of 0 or greater.

Spread
Set the spread angle for the emitted particles, along the specified emission direction. Particles are randomly distributed within the spread angle and around the base of a cone between 0 and 360 degrees. This option is valid for directional emitters only.
You can enter a value between 0 and 1. A value of 1 means 180 degrees.

Min Dist
Set the minimum distance from the emitter at which emission starts.
You can enter a value of 0 or greater.
Particles get emitted at a random distance uniformly distributed between the Min Distance and Max Distance.

Max Dist
Set the maximum distance from the emitter at which emission ends.
You can enter a value of 0 or greater.

Particles
Turn on Per Emitter to create a separate particle shape for each emitter. Turn this option off to share one particle shape between all emitters. Per Emitter must be turned on to paint Particle Attr. or Render Type.
13 Painting attribute values

About Painting attribute values

Use the Paint Attributes Tool to paint generic per vertex attributes. You can use the Paint Attributes Tool to paint any paintable attribute value on a surface. A paintable attribute is one that has been registered in Maya. Cluster weights, jiggle weights, soft body particle attributes (goal weights), and fluid property attributes are already registered as paintable. For information on making an attribute paintable, see “Make an attribute paintable” on page 291.

Related topics

- “Paint attributes” on page 289
- “Restrict an area for painting” on page 290
- “Flood surfaces” on page 291
- “Map attributes” on page 291
- “Set Paint Attributes Tool settings” on page 291
- “Make an attribute paintable” on page 291

How do I? Paint attributes

Note

The Paint Attributes Tool has been redesigned to improve performance and usability. The Paint Cluster Weights, Paint Jiggle Weights, Paint Soft Body Goal Weights, and Paint Fluids Tools are actually customized versions of the Paint Attributes Tool. For details about these tools, see the Character Setup guide, the Dynamics guide, and the Fluid Effects guide.

You paint attributes by selecting surfaces with nodes that have paintable attributes (attributes that are registered in Maya), selecting which paintable attribute you want to paint, and then painting strokes on the node with the Paint Attributes Tool.

To paint attributes

1. Select the surface you want to paint attribute values on.
Painting attribute values | 13
Restrict an area for painting

2 Select the Paint Attributes Tool and open the Tool Settings editor (Modify > Paint Attributes Tool > ).

The Paint Attributes Tool automatically detects paintable nodes and attributes on the surface, even ones you register yourself. For information on making an attribute paintable, see “Make an attribute paintable” on page 291.

3 In the Paint Attributes section of the Tool Settings window, click the List of Paintable Attributes button and select the node, then the attribute you want to paint. After you select an attribute, the name of the node and attribute displays on the button.

You can define which paintable attributes display in the Paintable Attributes list by clicking the Filter button and selecting the appropriate display filter.

4 If you are painting a three channel attribute (RGB or XYZ), beside Vector Index, select the channel you want to paint. If you are painting a single channel attribute, you can use any setting.

5 Select a paint operation and value and define other Paint Attributes Tools settings as required. See “Paint Attributes” on page 293

6 Define common tool settings (brush, stroke, stylus pressure, attribute maps, and display), if required. For details, see “Common Artisan Brush Tool Settings” on page 299.

7 Drag the brush across the surface.

Restrict an area for painting

When you paint values over selected vertices, your strokes are applied only to the attributes corresponding with the selected vertices. In effect, the unselected vertices act as a mask, where only selected vertices are affected by any painting or flooding you do.

For details, see “Restrict an area for painting” on page 252

Tip
If you are painting on a single surface, you can skip step 2 and select the node and attribute without opening the Tool Settings editor by right-clicking the surface and selecting Paint > paintableNode > paintableAttribute.
Flood surfaces

Flooding a surface is like taking a huge brush and applying its settings to all the vertices on the surface. When you flood a surface, the weight of each vertex in the node changes according to the value and operation set for the tool.

To flood a node, follow the steps under ”To paint attributes” on page 290, but instead of painting in step 7, click the Flood button or use the hotkey Alt-f (Windows, IRIX, and Linux) or Option-f (Mac OS X).

| Tips | To smooth the transition between cluster weights, select the Smooth paint operation and flood the soft body. |

Map attributes

Using the Paint Attributes Tool you can map attribute values onto surface vertices relative to the UVs. The settings for the tool are applied to the vertices using the mapped values.

For details on mapping, ”Map attributes” on page 253.

Set Paint Attributes Tool settings

Before you paint attributes, set options for the Paint Attributes Tool in the Tool Settings editor (Modify > Paint Attributes Tool > ).

The settings in the Paint Attributes section determine the effect you will achieve when you paint with the tool. These settings are described in ”Modify > Paint Attributes Tool” on page 293.

For information on the settings in the other sections (common to all Artisan tools with the new architecture), see ”Common Artisan Brush Tool Settings” on page 299.

Make an attribute paintable

A paintable attribute is a node attribute that has been registered as paintable through the makePaintable command in Maya. When you register an attribute, it is stored in your user preferences and stays paintable between Maya sessions, and between each separate use of the Paint Attributes Tool. You only need to register an attribute as paintable once. After an attribute is made paintable, the Paint Attributes Tool automatically finds it on the selected surface.
Register a paintable attribute

Use the following command to register an attribute as paintable:

```
makePaintable -e [flags] <nodeType> <attrName>
```

- **nodeType**
  - The name of the node type containing the attribute to be made paintable.

- **attrName**
  - The name of the attribute to be made paintable.

- **flags**
  - `-sm/shapeMode string`
    - This flag defines a function which is called when the matching between the paintable node depends on the painted shape. It is used for attributes of type multi where the first multi corresponds to the shape index (for example, cluster nodes). Currently only one function is supported: deformer. By default this flag is empty, which means that there is a direct indexing of the paintable attribute with respect to vertices on the shape.

  - `-aa/altAttribute string`
    - Defines an alternate attribute that receives the same values. You can use this flag more than once.

  - `-ui/uiName string`
    - Defines the name for the new paintable attribute that will appear the Paint Attributes Tool Settings editor and right-click menu. The default is the attribute name.

  - `-at/attrType string`
    - Defines the paintable attribute type. Supported types are: doubleArray, multiVector, multiDblArray.

- **Examples**
  - Make particle.mass paintable.
    ```
    makePaintable -attrType "doubleArray" "particle" "mass";
    ```
  - Make particle.goalPP paintable with a user interface name of myGoalPP. Also make the goalPP0 attribute simultaneously paintable.
    ```
    makePaintable -ui "myGoalPP" -altAttribute "goalPP0" -attrType "doubleArray" "particle" "goalPP";
    ```
  - Make weightGeometryFilter.weights paintable. Define weightGeometryFilter as a deformer node.
Painting attribute values
Make an attribute paintable

makePaintable -sm "deformer" "weightGeometryFilter" "weights";

Reference
Modify > Paint Attributes Tool

Modify > Paint Attributes Tool

Use this to specify the settings for the Paint Attributes Tool in the Tool Settings editor. In the Paint Attributes section there are some attributes unique to the Paint Attributes Tool. These unique attributes are described below along with some of the common attributes, and how they apply to this tool. For descriptions of all other attributes in all other sections, see "Common Artisan Brush Tool Settings" on page 299.

Paint Attributes
These settings apply to the Paint Attributes as well as the Paint Cluster Weights, Paint Jiggle Weights, and Paint Soft Body Weights Tools.

List of paintable attributes
If the surface has no paintable nodes or attributes, the button name is *No attribute selected*. Otherwise, the button name is a node and node attribute detected on the surface. Click this button and select the name of the node and node attribute you want to paint. The Paint Attributes Tool automatically detects paintable nodes and attributes on the surface, (even ones you register yourself) and lists them for selection, according to the selected filter.

Filter
Click this button and select which paintable nodes display when you click the List of Paintable Attributes button. When you select a filter, the button name changes to indicate the attribute you are filtering. You can select from any paintable node. For example, if the filter is set to all, all paintable nodes and attributes are listed. If the filter is set to cluster, only cluster nodes are listed.

Paint Operation
Select an operation to define how you want painted values to be affected.
**Painting attribute values | 13**

Make an attribute paintable >

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace</td>
<td>Replaces the values you paint over with the specified Value and Opacity.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the specified Value and Opacity to the current vertex values you paint over. If the Min or Max Value is negative, the value actually decreases.</td>
</tr>
<tr>
<td>Scale</td>
<td>Scales the values you paint over by the Value and Opacity factors.</td>
</tr>
<tr>
<td>Smooth</td>
<td>Changes the values to be the average of the surrounding values.</td>
</tr>
</tbody>
</table>

**Value**

Set the value to apply when you perform any of the painting operations.

**Min/Max Value**

Set the minimum and maximum possible paint values. By default, you can paint values between 0 and 1. Setting the Min/Max Values you can extend or narrow the range of values. Negative values are useful for subtracting weight. For example, if you set Min Value to -1, Value to -0.5, and select Add for the operation, you would subtract 0.5 from the weight of vertices you paint. Positive values are used as multipliers.

---

**Tip**

To help you differentiate paint values when you paint with ranges greater than 0 to 1 (for example, -5 to 5), and to maximize the range of values that display when you paint values with ranges between 0 to 1 (for example, 0.2 to 0.8), set Min Color and Max Color (in the “Display section”) to correspond with the Min/Max values.

**Clamp**

Select whether you want to clamp the values within a specified range, regardless of the Value set when you paint.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lower</td>
<td>Turn this on to clamp the lower value to the Clamp Value specified below. For example, if you clamp Lower and set the lower Clamp Value to 0.5, the values you paint will never be less than 0.5, even if you set the Value to 0.25.</td>
</tr>
</tbody>
</table>
Painting attribute values | 13

Make an attribute paintable >

Upper

Turn this on to clamp the upper value to the Clamp Value specified below. For example, if you clamp Upper, set the upper Clamp Value to 0.75, and set Value to 1, the values you paint will never be greater than 0.75.

Clamp Values

Set the Lower and Upper values for clamping.

Flood

Click Flood to apply the brush settings to all the attribute values on the selected node. The result depends on the brush, value, paint operation, and other brush settings defined when you perform the flood. See “Flood surfaces” on page 291.

Vector Index

If you are painting a three channel attribute (RGB or XYZ), select the channel you want to paint. If you are painting a single channel attribute, you can use any setting.
Painting attribute values | 13
Make an attribute paintable >
Artisan Brush Tool Settings

About

Artisan uses the Maya Tool Settings editor to set tool properties. The most common ways to open the Tool Settings editor are:

- Click the box beside the tool on its menu (for example, Edit > Paint Selection Tool > box).
- Double-click the selected tool in the Tool Box.
Artisan Brush Tool Settings >

Tips

Leave the Tool Settings editor open as you work in Artisan. When you switch tools, the settings change to reflect the selected tool.

If you do not want to leave the Tool Settings editor open, define hotkeys or use the Artisan marking menus to change commonly used settings for each of the tools. For details, see “Define Artisan hotkeys” on page 258 and “Use Artisan marking menus” on page 260.

Tailor the settings for your tools and save them to a shelf for easy access. For details, see “Create an Artisan tool shelf” on page 257.

All Artisan tools share common options, which are described in “Common Artisan Brush Tool Settings” on page 299.

For each Artisan tool, the Tool Settings editor contains a section with settings that are specific to that tool. This unique section appears after the Brush section and its unique settings are described where the tool is described, as follows:

- Paint Selection Tool – See Edit > Paint Selection Tool in the Basics guide.
- Paint Attributes Tool – See “Paint Attributes” on page 293.
- Paint Cluster Weights Tool - See Deform > Paint Cluster Weights Tool in the Character Setup guide.
- Paint Jiggle Weights Tool - See Deform > Paint Jiggle Weights Tool in the Character Setup guide.
- Paint Skin Weights Tool – See Skin > Edit Smooth Skin > Paint Skin Weights Tool in the Character Setup guide.
- Paint Fluids Tool – See Fluid Effects > Add/Edit Contents > Paint Fluids Tool in the Fluid Effects guide.
- 3D Paint Tool – See “Texturing > 3D Paint Tool” on page 327.
- Paint Vertex Color Tool – See Edit Polygons > Colors > Paint Vertex Color Tool in the Polygonal Modeling guide.
- Paint Scripts Tool – See “Painting with MEL scripts and the Paint Scripts Tool” on page 261.
- Sculpt Surfaces Tool - See Edit NURBS > Sculpt Surfaces Tool in the NURBS Modeling guide.
Artisan Brush Tool Settings

Reset Artisan brush tools

How do I?

Reset Artisan brush tools
Maya remembers any changes made for the selected tool, even between Maya sessions. If you do not want to keep the changes you made to the settings, click the Reset Tool button in the Tool Settings editor. This returns all the tool settings for the selected tool to their default values.

Reference

Common Artisan Brush Tool Settings
Refer to the following sections for information on tool settings common to all the tools with the new architecture.

Note
In the former Artisan architecture (pre Maya 6) there were options in the Mask tab for setting selection masks. In the new, standard Artisan architecture for all Artisan tools, there are no Mask options; you must select the vertices you want to affect before entering the tool.

Brush section
Use the settings in this section to define the brush stamp shape, size, orientation.

- Sculpt Polygons Tool - See Edit Polygons > Sculpt Polygons Tool in the Polygonal Modeling guide.
- Paint Set Membership Tool - See Deform > Paint Set Membership Tool in the Character Setup guide.
- Paint Fur Attributes Tool (Maya Unlimited only) - See Fur > Paint Fur Attributes Tool in the Fur guide.
- Paint Cloth Properties Tool (Maya Unlimited only) - See Simulation > Properties > Paint Cloth Properties Tool in the Cloth guide.
- Paint Collision Properties Tool - See Cloth > Paint Collision Properties Tool in the Cloth guide.
- Paint Hair Tool - See Hair > Paint Hair Tool in the Hair and Dynamic Curves guide.
Artisan Brush Tool Settings | 14

Common Artisan Brush Tool Settings

Brush settings

Radius (U)
If you are using a stylus, set the upper or maximum possible radius for the brush. No matter how hard you press the stylus, the brush radius will not exceed this radius. If you are not using a stylus, this setting defines the radius for the brush.

Radius (L)
If you are using a stylus, set the lowest or smallest possible radius for the brush when pressure is applied to the stylus. If you are not using a stylus, this setting is not used.

Opacity
Using the Opacity setting, you can produce more gradual changes to achieve more subtle effects. When you set Opacity to 0, your brush stroke has no effect.

Profile
Click a brush profile. This determines the shape of the area affected by the selection.

In addition to the four preset brush profiles, you can select an image to define the brush stamp profile. Maya provides 40 additional brush shapes in your mayalocation/brushShapes (Windows, IRIX, and Linux) or /Applications/Maya 6.0/Applications Support/brushShapes (Mac OS X) directory. You can create your own shapes using any file format supported by Maya. Maya uses the luminance values of the image and scales the image to 256x256.

To select an image, click the Browse button, select the shape and click Open. Adjust the “Stamp Spacing” to get the effect you want.

To select the last opened image, click the icon to the left of the Browse button. If you select an image file provided with Maya in the brushShapes directory, this icon changes to show what the shape is.
Rotate To Stroke

Determines the alignment of brush shapes that are not uniformly round. Turn this option on to align the stamp shape relative to the direction you move the brush. Turn this option off to align the stamp shape relative to the up vector. The stamp shape retains its orientation when you change the view.

Screen Projection

When this option is off (the default), the brush is oriented along the surface. When this option is on, the brush is oriented on the view plane and the stamp is projected on the selected surface.

Stroke section

Use the options in this section to define how brush stamps are applied when you paint a stroke

Screen Projection

When this option is off (the default), the brush is oriented along the surface. When this option is on, the brush is oriented on the view plane and the stamp is projected on the selected surface.

You will typically want to leave this option off if you are using an Artisan brush. You may want to turn it on when using an Artisan brush if the surface is very convoluted.

If you are using a Paint Effects brush (3D Paint Tool only), turn it on if:

- the surface has seams
- the UVs are cut up
- there are multiple surfaces
- the surface has uneven parameterization
Artisan Brush Tool Settings | 14
Common Artisan Brush Tool Settings >

Using Screen Projection may produce smearing where the surface is nearly perpendicular to the screen and performance may be slower. Simply tumble to make the surface approximately parallel to the screen.

Reflection X, Y, Z

Turn on the checkbox for the axis you want to reflect in. The origin for reflection is the center of the selection's bounding box.

Invert Reference Vector

This is available for the Sculpt Surfaces and Sculpt Polygons Tools only. Turn Invert Reference Vector on to invert the direction of the reference vector of the reflected brush. For details on setting reference vectors, refer to the sculpting information in the NURBS Modeling and the Polygonal Modeling guides.

Stamp Spacing

Clicking the brush on a surface creates a stamp. A brush stroke is made up of many overlapping stamps. You can set how the stamps overlap. If you set Stamp Spacing to 1, the edges of each stamp just touch each other. If you set the spacing to be greater than one, there will be spaces between the stamps. If you set the spacing to be less than one, the stamps will overlap.

Stamp Depth

The Stamp Depth value determines how far the stamp is projected. For example, when you are painting with the 3D Paint Tool where there are folds in the surface, decrease the Stamp Depth value so the paint does not run into other areas of the surface. The default setting is 0.5.
Before Stroke Cmd

For the Paint Selection Tool and Sculpt Surfaces/Polygons Tools only. Type the MEL command and parameters you want to run when you begin a stroke, before the stroke actually starts. For example, for the Sculpt Surfaces Tool, you can specify a command that changes the display smoothness for the selected object to fine:

\[ \text{displaySmoothness \ -full \ -du 2 \ -dv 2 \ -pw 16 \ -ps 4} \]

After Stroke Cmd

For the Paint Selection Tool and Sculpt Surfaces/Polygons Tools only. Type the MEL command and parameters you want to run immediately after completing a stroke. For example, you can specify a command that subdivides faces after you paint-select them, as follows:

1. Select a polygon.
2. Select Edit > Paint Selection Tool > \( \square \).
3. In the Paint Operations section, turn off Add to Current Selection.
4. On the Maya status line, change the pick mask to Poly Faces.
5. Open the Stroke section of the Tool Settings editor and in the After Stroke Cmd box, enter:

\[ \text{ppolySubdivideFacet \ -dv 1 \ -m 0 \ -ch 1} \]
6. Paint the faces you want to subdivide. Each painted face subdivides automatically into four faces when you release the mouse button.

Stylus Pressure section

Use the settings in this section to define the effects of stylus pressure on your strokes when you use a stylus and pressure sensitive tablet. For details on setting stylus pressure, see “Set stylus pressure” on page 257.

Stylus Pressure

Turn this on to activate the effect of pressure on your stylus.

Pressure Mapping/Artisan Pressure

Select which Artisan brush attribute you want affected by stylus pressure. Adding pressure to the stylus increases values for the selected attribute. You can affect Opacity, Radius, or Both.

Paint Effects Pressure (for 3D Paint Tool only)

Use these settings to affect stylus pressure when you are using a Paint Effects brush with the 3D Paint Tool. For details, see “Make the brush respond to stylus pressure” on page 56.
Attribute Maps section

Use the settings in the Attribute Maps section to import and export attribute value maps. For details on mapping, see “Map attributes” on page 253.

| Note | You cannot use the Paint Skin Weights Tool to import and export skin weight maps. Instead, use the Import Skin Weight Maps and Export Skin Weight Maps commands on the Skin > Edit Smooth Skin menu. |

Import section

Use the options in this section to import attribute maps. For more details, see “Import attribute maps” on page 254.

Map Name

Click Import and select the image you want to map values to.

Reassign Attribute Maps

If you are importing a map that was created in Artisan from multiple surfaces, turn on Reassign Attribute Maps.

Import Value

Select which channel of the imported image you want to use for values.

<table>
<thead>
<tr>
<th>Channel</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Luminance</td>
<td>Use the luminance values of the map you are importing.</td>
</tr>
<tr>
<td>Alpha</td>
<td>Use the alpha channel values of the map you are importing.</td>
</tr>
<tr>
<td>Red, Green, Blue</td>
<td>Use only the Red, Green, or Blue values of the map you are importing.</td>
</tr>
<tr>
<td>RGB</td>
<td>For the Paint Vertex Color Tool only, import each of the RGB channel values.</td>
</tr>
<tr>
<td>RGBA</td>
<td>For the Paint Vertex Color Tool only, import the RGB and alpha channel values.</td>
</tr>
</tbody>
</table>

Threshold

For the Paint Selection Tool only. Defines the minimum value to be affected by the tool selection type. For example, if you set the selection type to be Select and the Threshold to be 0.5, Artisan selects vertices that are mapped with an imported value equal to or greater than 0.5.
Export section

Use the options in this section to export attribute values (created with the following tools) to an attribute map: Paint Selection, Paint Attributes, Paint Cluster Weights, Paint Jiggle Weights, Paint Soft Body Weights, Paint Fluids, Paint Vertex Color Tool, Paint Fur Attributes, Paint Cloth Properties, Paint (Cloth) Collision Properties and Paint Hair Tools. For more details, see “Export attribute maps” on page 256.

Map Name

Click Export to select a location for the image you want to export paint values to and enter the name of the exported file.

Export Value

Select which image values you want the attribute values exported to.

- **Luminance**: Export to the luminance values of the map.
- **Alpha**: Export to the alpha channel values of the map.
- **RGB**: Export to each of the RGB channel values.
- **RGBA**: Export to the RGB and alpha channel values.

Image Format

Select the format you want to save the image in. You can save the image in any image format supported by Maya. For details, see the Basics guide.

Keep Aspect Ratio

Turn Keep Aspect Ratio on to maintain the height to width ratio of the attribute map when you export it.

Map Size X, Y

Set the Map Size in the X and Y direction. The default is 256 pixels.

Display section

Define how the brush and surface display.
**Artisan Brush Tool Settings | 14**

Common Artisan Brush Tool Settings >

---

**Draw Outline**

Displays the brush stroke outline when you move the pointer on the selected surface. If you do not turn this option on, you only see the brush pointer and you will not be able to draw brush feedback while painting. You can change the outline color to one that provides the best contrast with the surface you are painting. For details, see “Change the brush outline color” on page 257.

---

**Draw Outline while Painting**

Turn this on to display the paint tool’s outline as you paint a stroke. Turn it off, to display only the paint cursor. If you notice slow interaction while you paint, try turning this option off. By default, the brush outline in Artisan is not drawn when painting. This greatly improves performances on graphic cards without overlay planes.

---

**Draw Brush Feedback**

Displays additional information on the brush outline indicating the operation the brush is set to perform.

---

**Show Wireframe**

Displays the wireframes on the selected surfaces.

---

**Color Feedback**

For Paint Attributes, Paint Cluster Weights, Paint Jiggle Weights, Paint Skin Weights, Paint Soft Body Weights, Paint Fluids, Paint Set Membership, Paint Fur Attributes, and Paint Hair Tools only. Turn this option on to display surface attributes as grayscale values. This helps you see the area as you paint and helps identify what the values are (smaller values are darker, larger values are lighter). To display color feedback, you must turn on smooth shading in Maya.
Min Color
For Paint Attributes, Paint Cluster Weights, Paint Jiggle Weights, Paint Skin Weights, Paint Soft Body Weights, Paint Fluids, Paint Fur Attributes, and Paint Hair Tools only. Sets the value at which the minimum color displays. This is useful if your attribute values are very close to each other, making the color feedback display too subtle to detect.

Max Color
For Paint Attributes, Paint Cluster Weights, Paint Jiggle Weights, Paint Skin Weights, Paint Soft Body Weights, Paint Fluids, Paint Fur Attributes, and Paint Hair Tools only. Sets the value at which the maximum color displays. This is useful if your attribute values are very close to each other, making the color feedback display too subtle to detect.

Display Active Vertices
For the Paint Set Membership Tool only, turn this option on to display the active vertices of a selected set. If this option is turned off, when you select a set on the SetMembership tab, the vertices for that set will be active, but you will not be able to see that they are.

Setup section
This section is unique to the Paint Scripts Tool. For more information, see “Paint Scripts Tool settings” on page 264 or see artUserPaintCtx in the MEL Command Reference.

Note
The Setup section also appears in the Paint Fur Attributes Tool and Paint Hair Tool because both these tools use the Paint Scripts Tool editor. Do not edit Setup entries for these tools.
Artisan Brush Tool Settings | 14
Common Artisan Brush Tool Settings >
Using the 3D Paint Tool

Painting renderable attributes on 3D objects

Using the 3D Paint Tool you can paint textures directly on models in 3D space using both Artisan and Paint Effects brushes. You can paint renderable attributes such as color, bump, transparency, and specular color on polygons, NURBS, or subdivision surfaces. You can also paint on file textures created outside the 3D Paint Tool.

Related topics

- “How the 3D Paint Tool works” on page 311
- “Preparing your model for the 3D Paint Tool” on page 312

How the 3D Paint Tool works

When you paint on a model, you actually paint on a file texture that has been assigned to the model. You can assign a file texture in Hypershade, or you can create and assign it from the 3D Paint Tool.

When you select the 3D Paint Tool, Maya checks to see if there are any file textures already assigned to the selected surfaces for the current attribute (such as color or bump maps). If any of the surfaces do not have file textures assigned, Maya prompts you to assign textures to them. Maya creates the textures, assigns them to the surfaces, names the new textures based on the current scene, shape and attribute names, and places them in a subdirectory of the current project’s 3dPaintTextures directory.

If there are existing file textures, Maya checks to see if their names match the current shape, scene and attribute names. If they do not, Maya copies the textures to the correct names. This prevents you from overwriting existing file textures, and makes it easier for the tool to keep track of the textures.

When you Assign Textures you can save the file in any of the following formats:

(Windows, IRIX, and Linux) Maya IFF (the default) Alias PIX, EPS, GIF, JPEG, RLA, SGI, SoftImage, Targa, and Tiff.

(Mac OS X) Maya IFF (the default), Windows Bitmap, JPEG, MacPaint, Photoshop, PNG, QuickDraw, QuickTime Image, Targa, SGI, and Tiff.

Preparing your model for the 3D Paint Tool

Before you begin painting, consider the following:
Using the 3D Paint Tool | 15

Paint Textures on 3D objects

- Polygonal and subdivision surfaces must have non-overlapping UVs that fit within 0 to 1 in the texture space. In general, Automatic Mapping produces UVs that can be used for painting. For details, see the Polygonal Modeling and the Subdivision Surface Modeling guides.

- NURBS models are usually made up of multiple patches, whereas polygonal and subdivision surface models are often only made from a single mesh. When textures are assigned, each NURBS patch receives one texture, but by default a polygon or subdivision surface receives only one texture for the entire mesh. This can result in there being insufficient texture resolution to get fine detail on a polygonal or subdivision surface mesh. Increasing the texture size to the maximum will result in slower performance, and may still not give sufficient resolution.

One solution is to partition the model by assigning several materials (for example, one for the head, one for the torso, one for the limbs). Each material on the mesh then receives its own texture. This has the added benefit of allowing you to work on part of the mesh at one time. To do this, right-click the material in Hypershade and select Assign Material to Selection. In this way you can also assign different size textures to different parts of the model if desired.

How do I?

Paint Textures on 3D objects

You can paint textures with the 3D Paint Tool using two types of brushes: Artisan brushes and Paint Effects brushes.

Artisan brushes use grayscale images to define the brush profile (or shape). You can select from 40 predefined brush shapes, or you can create your own shapes using any image format supported by Maya. You can paint, erase and clone textures using Artisan brushes.

Paint Effects brushes are defined by specific combinations of attribute settings and can be simple (like pen, pastel, oil paint, and pencil brushes) or they can simulate growth to get their look (like flowers, feathers, hair, and fire brushes). You can select the default Paint, Smear, or Blur brush to paint with, or you can select any preset brush from Visor or your shelves.
To paint on a 3D object

1 Select the surface(s) you want to paint on.

2 Select the 3D Paint Tool and open the Tool Settings editor (Rendering menu set, Texturing > 3D Paint Tool > ). For information on tool settings, see “Texturing > 3D Paint Tool” on page 327.

3 Click Reset Tool to reset the tool settings. Resetting the tool is good practice to ensure you get expected results when you paint.

4 Beside Attribute to Paint (in the File Textures section of the Tool Settings editor), select the attribute you want to paint. The default is Color.

   • If you have not previously painted or assigned file textures to one or more of the surfaces, the following warning appears on the Command Feedback line:

     Warning: Some surfaces have no file texture assigned to the current attribute.

     Also, the brush outline displays an X across it when you move the brush over the surface to indicate that you are unable to paint on the selected attribute texture.

   • If you have previously painted or assigned file textures, you do not get the warning and the brush displays without the X, so you are ready to paint. Skip to step #7.
Paint Textures on 3D objects


6. Enter a size for the texture in the Size X and Size Y boxes and click Assign/Edit Textures. The Keep Aspect Ratio option ensures that the proportions of the image are maintained. Turn this option off if you want the width and the height of the texture to be different. The texture size is currently limited to 2048 x 2048 and must be a power of 2 in each dimension. Larger textures require more memory. Textures larger than 512 will yield slower performance.

7. Set a base color for the model and save the texture. This establishes the texture you will erase back to. To do this, click the Flood Color swatch in the Flood section and select a color from the Color Chooser. Set the Paint Operations to Artisan Paint, click Flood Paint, and then click the Save Textures button in the File Textures section.

8. Select a brush to paint, erase, clone, smear or blur. For details, see “Select a brush” on page 315.

9. Modify any other settings as required and drag on the model to paint. For information on these settings, see “Texturing > 3D Paint Tool > □” on page 327.

   If you are painting “Single Channel” (grayscale) attributes such as bump, or diffuse, the color you paint is automatically converted to grayscale.

10. Once you have finished painting one attribute, you can paint another attribute without leaving the tool by selecting the attribute beside Attribute to Paint. The first time you paint an attribute, you will have to assign a texture for it, unless a texture was already assigned in Hypershade.

Note: Be sure to assign a new shader before painting your object, otherwise you will modify the default shader. If this happens, the painted texture will be assigned to any new objects you create in your scene.

Tip: To assign different-sized textures to different surfaces, select each surface or group of surfaces separately and assign textures to them. Once the textures have been assigned, you can select any combination of surfaces to paint on.
Select a brush

The brush operation you select defines whether you are going to apply paint to the texture, or whether you are going to erase, clone, smear, or blur paint already applied to the surface.

You can apply paint to the texture using Artisan Paint Brushes or Paint Effects Paint brushes. To erase or clone you use Artisan brushes. To smear or blur you use Paint Effects brushes.

To select an Artisan brush to Paint, Erase, or Clone

1. In the Paint Operations section, select Artisan Paint, Erase, or Clone. Maya automatically selects the brush profile selected when you last used the Artisan Paint brush. (If the last profile was a custom brush, the operation remembers only that it was a custom brush, not which custom brush. If the custom brush was changed for either the Erase or Clone operations, it changes for the Paint operation and for any other operation with the custom brush profile selected.) Use the Rotate To Stroke option to change the orientation of brush profiles that are not uniformly round. This option is not available for the Clone operation.

2. If you want to use a different brush profile, click the profile shape beside Artisan in the Brush section, or click Browse to select a custom profile. When you select one of the custom profiles provided with Maya, the Last Image File icon changes to show which image you selected.

3. If you selected Erase or Clone skip to step #5.

4. In the Color section, select a Color. If you are painting “Single Channel” (grayscale) attributes such as bump, or diffuse, the color you paint is automatically converted to grayscale.

5. Select an Opacity, if necessary.

6. In the Paint Operations section, select a Blend Mode, if necessary.

7. In the Brush section, modify the brush Radius (U) (Artisan), if necessary.

8. If the surface is very convoluted, you may prefer to turn “Screen Projection” on.

To select a Paint Effects brush to Paint, Smear, or Blur

1. Select a Paint Effects brush using any of the following methods:
   - In the Paint Operations section, select a Paint Effects operation. If you select:
Paint - The brush becomes the last selected Paint Effects brush with a Brush Type set to Paint. If no Paint brush was previously selected, the default Paint Effects paint brush is used.

Smear - The brush becomes the last selected Paint Effects brush with a Brush Type set to Smear. If no Smear brush was previously selected, the default Paint Effects smear brush is used.

Blur - The brush becomes the last selected Paint Effects brush with a Brush Type set to Blur. If no Blur brush was previously selected the default Paint Effects blur brush is used.

- Click the Get Brush icon and select the brush from Visor. The Paint Operation changes to Paint Effects Paint, Smear, or Blur, depending on the Brush Type defined for the brush preset. Paint Effects Erase is not supported.
- Click a Paint Effects brush on a shelf. The Paint Operation changes to Paint Effects Paint, Smear, or Blur, depending on the Brush Type defined for the brush preset.

2 In the Brush section, modify the brush Scale (PFX) and Width (PFX) settings, if necessary.

3 Click the Edit Template brush icon and make the changes to the brush settings in the Paint Effects Brush Settings window. Any changes you make to the settings are remembered the next time you select the Paint Effects Paint brush.

You can save these settings as a new preset by following the instructions under “Create new brush presets” on page 127, starting at step #3. To create the icon for preset (step #8), go into canvas mode, paint a stroke, grab the icon and return to the modeling view without leaving the 3D Paint Tool.

4 Turn on “Screen Projection” in the Stroke section if the surface has seams, the UVs are cut up, you are painting across multiple surfaces, or the surface has uneven parameterization.

To select the last selected Paint Effects brush

Click the Last brush icon and paint. The Paint Operation changes to Paint Effects Paint, Smear, or Blur, depending on the Brush Type defined for the last selected brush preset.

Erase paint

You can erase the strokes you paint by painting over them with the Artisan Erase brush. When you erase, you remove the color from the painted pixels, revealing the last saved texture.
To set the background texture to erase to, turn off “Update on Stroke” and click the “Save Textures” button. Flooding with the operation set to Erase restores the texture to its last saved version. You cannot erase when Update on Stroke is turned on, since the texture is constantly saved.

| Note | Paint Effects brushes with a Brush Type of Erase are not supported in the 3D Paint Tool. |

**Clone paint**

You can clone an area of the texture (duplicate it) and then paint that sample elsewhere on the texture or on other textures. There are two cloning approaches: dynamic and static.

With dynamic cloning, the clone source moves as you paint. In the following Dynamic Clone example, a small area of the top eye was set as the clone source. Painting below the eye gradually reproduced the top eye. In the Static Clone example, the pupil was cloned and stamped.

**To clone an area of the texture and paint with it**

1. In the Paint Operations section, click Reset Tool to reset the brush settings. Resetting the tool is good practice to ensure you get expected results when you paint.

2. In the Paint Operations section, select the Artisan Clone option. The brush outline displays an X across it when you move the brush over the surface to indicate that you are unable to paint on the selected attribute texture until you set a clone source.

   Maya automatically selects the brush profile selected when you last used the Clone operation. However if the last profile was a custom brush, the operation remembers only that it was a custom brush, not which custom brush. Changing the custom brush for one operation changes it for any other operation with the custom brush profile selected.

3. Select a Clone Brush Mode: Dynamic or Static.
By default, the Clone Brush Mode is set to Dynamic. With dynamic cloning, the cloned area changes as you paint, moving alongside your stroke and maintaining a constant distance from the stroke path. This is an effective way to copy areas from existing textures.

Select Static to keep the clone source stationary.

4 Click Set Clone Source and click an area where you want to clone the texture. A brush outline stays on the area where you clicked.

5 If the Clone Brush Mode is set to Dynamic, click another area on the texture to define the offset between the clone source and your paint stroke.

6 Paint on the model where you want the cloned texture to appear. As you paint, the clone source moves alongside the stroke, maintaining the offset defined by your second click.

If you paint over the clone source during a stroke, the original paint sample is used for the rest of the stroke, but the next stroke uses the updated clone source paint sample.

Smear and blur paint

Smearing with a Paint Effects Smear brush blends adjacent colors together along the stroke path.

Blurring with a Paint Effects Blur brush softens the edges of adjacent colors by averaging their color values.

You can use the default Paint Effects Smear or Blur brushes or select any Paint Effects brush with a Brush Type set to Smear or Blur. To select the default Smear or Blur brushes, click “Reset Brushes” and in the Paint Operations section, select Paint Effects Smear or Blur, as appropriate. Use the Blur Intensity option to adjust the blur effect.

Set an image to erase back to

Using the Set Erase Image button you can set the current paint layer as what to erase back to.
Example of using Set Erase Image

1. Paint a base layer, such as a layer of dirt.
2. Click the Set Erase Image button.
3. Flood the layer with a color, such as grey.
4. Erase patches and the dirt layer shows through.

Reset brushes

You can reset the Artisan and Paint Effects brushes to their default profiles and settings by clicking the Reset Brushes button. The default brushes will now be used the next time you select these operations.

Undo brush strokes

You can undo as many strokes as defined in the Undo category of the Preferences window (Window > Settings/Preferences > Preferences).

Restrict the paint area on polygons

When painting on polygons, you can paint only selected faces, blocking off the rest of the faces and protecting them from the paint. You can also flood your selection with paint (see “Flood selected polygon faces” on page 320).

To paint only selected polygonal faces

1. Select the faces you want to paint. The texture must already be assigned to the surface.
2. Select the 3D Paint Tool. An outline displays around the selected faces.
3. Select a brush and paint on the selected faces. If you are painting with a Paint Effects brush, Screen Projection must be turned on.
   If your strokes extend to unselected faces, the unselected faces are unaffected.
Flood the surface

Using the Flood All button, you can quickly apply a single color to the entire texture without painting individual strokes. You can also use it to erase everything painted on the texture since the last time you saved it.

Using the Flood Selected button, you can flood selected faces on polygons.

Flood the entire texture

To flood paint the entire texture
1. Specify a Color and Opacity value in the Flood section.
2. Select Flood All.
3. Click the Flood Color button.

To flood erase the entire texture
1. Specify an Opacity value in the Flood section.
2. Select Flood All.
3. Click the Flood Erase button.

Flood selected polygon faces

To flood paint selected faces
1. Select the faces you want to paint. The texture must already be assigned to the surface.
2. Select the 3D Paint Tool. An outline displays around the selected faces.
3. Specify a Color and Opacity value in the Flood section.
4  Select Flood Selected.
5  Click Flood Paint.

To flood erase selected faces
1  Select the faces you want to erase. The texture must already be assigned to the surface.
2  Select the 3D Paint Tool. An outline displays around the selected faces.
3  For a more gradual, or subtle erase, in the Flood section, set the Opacity. To completely erase everything painted since the last time you saved, leave the Opacity setting at 1.
4  Select Flood Selected.
5  Click Flood Paint.

Reflect paint
You can reflect your painted strokes along any axis so that when you paint, the stroke is mirrored on the opposite side of the axis. The reflection axis is based on the center of the selection’s bounding box. Reflection is useful for creating symmetrical effects.

To reflect paint
1  Open the Stroke section and select an axis for reflection—X, Y, Z, or any combination of these. Notice there are now two, four, or six brush outlines on the surface, depending on the number of selected axes.
2  Paint the surface. Your painted strokes are reflected in the selected axes.

Paint over existing textures
If your model has already been textured outside of the 3D Paint Tool, you can add paint to those textures using the 3D Paint Tool.
Using the 3D Paint Tool | 15

Paint attributes not seen in hardware texturing >

If file textures were used, the 3D Paint Tool automatically detects them. You can paint over them immediately without assigning textures. The textures are copied automatically and sized to the nearest power of 2. The originals are not overwritten.

If non-file textures were used, or if the texture placement was edited, you must first convert the texture to a file texture.

![Assigned file texture](image1)
![Converted checker texture](image2)
![Converted repeating texture](image3)

To convert the texture to a file texture

1. Select your model, and then in Hypershade, Shift-click the shader attached to the model to select it too.

2. In Hypershade, select Edit > Convert to File Texture. Maya converts the texture to a file texture and automatically assigns it to the shader. You can now select the 3D Paint Tool and paint on the file texture.

For details on Convert to File Texture, see the Rendering guide.

Paint attributes not seen in hardware texturing

Attributes such as bump, transparency, and incandescence paint as grayscale values—you must do a software render to see their effect. While this is to be expected, there may be times when you want to see the effects of your brush strokes as you paint them. You can do this using IPR.

To preview painting in IPR

1. Turn on Update on Stroke in the File Textures section of the 3D Paint Tool Settings editor.

2. Start an IPR render of the model. For details, see the Rendering guide.

3. Start painting. As you paint, the image will refresh to show the rendered effect of your last painted stroke.
Layer painted textures

By systematically saving your texture, painting over it, then erasing back to reveal the underlying strokes, you can create interesting layered effects.

1. Make sure “Update on Stroke” is turned off in the File Textures section of the 3D Paint Tool Settings editor. This option saves the texture after every paint stroke.

2. Paint a basic texture (or map an existing file texture to the surface) and click “Save Textures”.

3. In the Color section, select a Flood Color and click Flood All to flood the surface with another color.

4. Change the Paint Operation to Artisan Erase.

5. In the Color section, change the Opacity to be less than 1 (or if you have a stylus and tablet, use pressure sensitivity—see next step). The lower the opacity, the less paint will be removed when you erase.

6. Paint on required areas, modifying the Opacity value where necessary to subtly erase back through to the first layer.

Notes

You cannot erase with Update on Stroke turned on. If you need to erase, simply click Save Textures whenever you want to update the IPR image.

You can use the 3D Paint Tool while High Quality Rendering is turned on; this enables you to preview attributes such as bump and transparency while painting them, however you cannot see the stroke itself while it is being painted, since the texture is updated only at the end of each stroke.
By default, when you paint with Artisan brushes with a stylus and table, Opacity is affected by the pressure you apply to the stylus—the harder you press, the more opaque the stroke. For more information, see “Set stylus pressure” on page 257.

7 When you are satisfied with the effect, click Save Textures. You can continue to build layers of paint by repeating these steps.

Save textures

Save your texture at any time while you work by saving the scene or clicking the Save Textures button in the File Textures section of the Tool Settings editor.

When Maya creates the textures, it names the new textures based on the current scene, shape, and attribute names, and places them in a subdirectory of the current project’s 3dPaintTextures directory.

Example

Scene name: myPaintScene

Shape names: ballShape, planeShape

Attributes: color, transparency

Resulting texture names:

projectdirectory\3dPaintTextures\myPaintScene\ballShape_color.iff
projectdirectory\3dPaintTextures\myPaintScene\ballShape_transparency.iff
projectdirectory\3dPaintTextures\myPaintScene\planeShape_color.iff
projectdirectory\3dPaintTextures\myPaintScene\planeShape_transparency.iff

.iff is the default file format.

Notes

• A bump map attribute displays as normalCamera in the scene name.

• If the original textures were not a power of 2 in each dimension (such as 512 x 512, 256 x 128), Maya resizes the copies to the nearest power of 2. This makes the 3D Paint Tool more efficient.

• If you change the shape or scene name, for example by renaming a surface, or by saving the scene as a new name, the next time you enter the 3D Paint Tool, the textures are copied to the new name.
Using the 3D Paint Tool | 15

Save textures >

You can define how Maya saves file textures created with the 3D Paint Tool when you save a scene. Before saving, select from the following options in the Save Scene As Options window (File > Save Scene As > □).

Copy Texture Maps on Save Scene As

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always</td>
<td>Saves different versions of the file textures when you save different versions of a scene. Use this setting if you are working on different iterations or versions of the file texture.</td>
</tr>
<tr>
<td>Unless Referenced</td>
<td>Saves file textures only if the painted character is not referenced. When this option is selected, Maya uses the file textures from the referenced file, even if you save the scene with a new name. If the character is not referenced and you save a copy of the scene with this option selected, Maya creates a copy of the file textures.</td>
</tr>
<tr>
<td>Never</td>
<td>Does not save a new file texture. Use this setting if you are no longer changing the file textures and want to continue to use the saved file textures, even if you save the scene with a new name. This prevents multiple copies of the textures from accumulating.</td>
</tr>
</tbody>
</table>

Update and save textures automatically after each stroke

You can update the texture automatically after each stroke, and you can save it automatically after each stroke.

You can update the texture automatically after each stroke by turning on the Update on Stroke option in the File Textures section of the Tool Settings editor. Turn this option on when IPR rendering. As you release the mouse (or stylus) at the end of each stroke, the texture updates and the IPR render refreshes to reflect your changes. When this option is on, you must save your scene for the updates to the file texture to be saved permanently.

Notes

You cannot erase with Update on Stroke turned on.

You can use the 3D Paint Tool while High Quality Rendering is turned on; this enables you to preview attributes such as bump and transparency while painting them, however you cannot see the stroke itself while it is being painted, since the texture is updated only at the end of each stroke.
To save each stroke to the file texture you are editing, turn on Save Texture on Stroke. The changes remain even if you do not save the scene. When this option is off (the default), you must save your scene for changes to the file texture to take effect.

Paint attributes not shown in the Texture list

You can paint attributes not shown in the texture list by painting on a single channel (grayscale) texture that is in the list, and then connecting the texture to the shader attribute not in the list. For example, Eccentricity on a Blinn shader.

Switch nodes and painted textures

When you paint on a single surface, Maya does not create a switch node. When you paint on multiple surfaces with the same material assigned, Maya creates a switch node for each painted attribute. Maya creates:

- a tripleShadingSwitch for each full color (RGB) attribute, such as Color, Transparency, and Incandescence.
- a singleShadingSwitch node for each single channel attribute, such as BumpMap, Diffuse, and Translucence. If you paint color on one of these attributes, it automatically displays as grayscale.

Switch nodes allow multiple surfaces mapped with the same texture to be assigned to a single material. For details about using switch nodes, see the Rendering guide.
Reference

Texturing > 3D Paint Tool

Lets you use the 3D Paint Tool to paint in 3D space. For more information, see “Paint Textures on 3D objects” on page 312.

Texturing > 3D Paint Tool > □

Lets you specify the settings for the 3D Paint Tool in the Tool Settings editor.

Brush section

Define the brush profile (or shape) using the settings in this section.

Radius (U) (Artisan)

Displays when an Artisan brush is selected. If you are using a stylus and have Radius or Both selected for the Pressure Mapping, set the upper or maximum possible radius for the brush. No matter how hard you press the stylus, the brush radius will not exceed this radius. If you are not using a stylus, this setting defines the radius for the brush.

Radius (L) (Artisan)

Displays when an Artisan brush is selected. If you are using a stylus, set the lowest or smallest possible radius for the brush when pressure is applied to the stylus. If you are not using a stylus, this setting is not used.

Scale (PFX)

Displays when a Paint Effects brush is selected. This setting corresponds with the Paint Effects Global Scale setting, which adjusts the brush attribute values by a common factor. This scales the paint effect uniformly so you can paint the same effect, but in different sizes.

Width (PFX)

Displays when a Paint Effects brush is selected. This setting corresponds with the Paint Effects “Brush Width” setting, which defines the width of the brush in Maya working units.

Artisan

Select which Artisan brush profile to use when the Paint Operation is Artisan Paint, Erase, or Clone. Artisan profiles are defined by grayscale images. You can select from 40 predefined brushes in your /Applications/Maya 6.0/Applications Support/brushShapes (Mac OS X) or mayapath/scripts/paintEffects (IRIX and Linux) or mayalocation/brushShapes (IRIX and Linux) directory, including the following four common ones.
Using the 3D Paint Tool | 15
Switch nodes and painted textures >

You can create your own shapes using any file format supported by Maya. Maya uses the luminance values of the image and scales the image to 256x256.

To select an image, click the Browse button, select the shape and click Open. Adjust the “Stamp Spacing” to get the effect you want when you paint.

To select the last opened image, click the icon to the left of the Browse button. If you select an image file provided with Maya in the brushShapes directory, this icon changes to show what the shape is.

Paint Effects

Select which Paint Effects brush you want to paint with when the Paint Operation is Paint Effects Paint, Smear, or Blur. Paint Effects brushes are defined by specific combinations of attribute settings and can be simple (like pen, pastel, oil paint, and pencil brushes) or they can simulate growth to get their look (like flowers, feathers, hair, and fire brushes).

Click the Last Brush button to pick the last selected Paint Effects brush. The Paint Operation changes to Paint Effects Paint, Smear, or Blur, depending on the Brush Type defined for the last selected brush preset.

Click the Edit Template Brush button to open the Paint Effects Brush Settings window for the selected brush. Any changes you make to these settings are applied to your next Paint Effects stroke.

Click the Get Brush button to open Visor where you can select a Paint Effects brush. When you select a brush, the Paint Operation changes to Paint Effects Paint, Smear, or Blur, depending on the Brush Type defined for the brush preset. (Paint Effects Erase is not supported in 3D Paint.)
Rotate To Stroke

Determines the alignment of brush shapes that are not uniformly round. Turn this option on to align the stamp shape relative to the direction you move the brush. Turn this option off to align the stamp shape relative to the up vector. The stamp shape retains its orientation when you change the view.

Color section

Use the settings in this section to define the brush color and opacity.

Color

Click the Color box to open the Color Chooser and select the color you want to paint with. If you select a Paint Effects brush, this color represents the Paint Effects “Color1” setting. For details on using the Color Chooser, see the Basics guide. Use the Color Value slider to change the color value (from 0 to 1).

Opacity

Set the fraction of the Color value to apply to each brush stamp within a stroke. Values build up when stamps overlap. Stamps overlap when you paint over the same area. Using the Opacity setting, you can produce more gradual changes to achieve more subtle effects. When you set Opacity to 0, your brush stroke has no effect. Opacity has no effect on Paint Effects brushes.

Flood section

Use the settings in this section to define the color and opacity to flood the texture with the set color or to erase.
Using the 3D Paint Tool | 15

Switch nodes and painted textures >

Color

Click the Color Value box to open the Color Chooser and select the color you want to flood with.

Opacity

Set the fraction of the Color value to apply when you flood. Opacity has no effect on Paint Effects brushes.

Flood Paint

Click this button to flood paint the set color.

Flood Erase

Click this button to erase as either Flood All or Flood Selection.

Flood

- **All**: Floods the entire texture with the Flood Color and the Opacity value. You can only flood the surface when the Paint Operation is set to Paint or Erase. When you flood Erase, the texture is restored to its last saved version.
- **Selected**: Floods only the selected faces of the polygon or subdivision surface with the Flood Color and Opacity value. You must exit the 3D Paint Tool to select the faces.

Paint Operations section

Select the paint operation and blend mode want to use.

Artisan

Select one of the following Artisan brush operations. Maya uses the last Artisan brush profile selected for that operation. However, if the last profile was a custom profile, Maya remembers only that it was a custom brush, not which custom brush. This means that changing the custom brush for one operation changes it for any other operation with the custom brush profile selected.
Using the 3D Paint Tool | 15
Switch nodes and painted textures >

Paint
Applies paint to the surface according to the defined settings.

Erase
Removes the color from the painted pixels, revealing the last saved texture. To set the background texture to erase to, turn off “Update on Stroke” and click the “Save Textures” button. Flooding with the operation set to Erase restores the texture to its last saved version. See “Erase paint” on page 317.

Clone
Clones a sample of the paint already applied to the surface. You can then paint that sample elsewhere on the surface or on other surfaces. You cannot flood with the operation set to Clone. See ”Clone paint” on page 317.

Paint Effects
Select one of the following Paint Effects brush operations. When you select a Paint Effects brush from Visor or your shelves, the 3D Paint Tool automatically sets the operation to correspond with the Brush Type setting of the brush. (Brushes with an Erase brush type are not supported by the 3D Paint Tool.)

The 3D Paint Tool uses the last Paint Effects brush selected for that operation. If no Paint brush was previously selected, the default Paint Effects paint brush for that operation is used.

Paint
Applies paint to the surface according to the defined settings for the selected Paint Effects brush. Maya uses the Flood Color when you flood with Paint Effects Paint selected.

Smear
Blends adjacent colors together along the stroke path. You cannot flood with the operation set to Smear.
Using the 3D Paint Tool | 15

Switch nodes and painted textures >

| Paint Effects Paint | Paint Effects Smear | Paint Effects Blur |

Blur

Blurring with a Paint Effects brush softens the edges of adjacent colors by averaging their color values. You control the blur using the “Blur Intensity” slider. You cannot flood with the operation set to Blur.

All brush types use the shape defined by the brush attributes. For example, if you paint over a stroke with a Blur brush that has tubes, blurring occurs where the tubes cross over the paint, not along the Blur stroke path.

For more information about Paint Effects brushes, see the Paint Effects section in this book.

Set Erase Image

Click this button so you can set the current paint layer as what to erase back to.

Reset Brushes

Click Reset Brushes to restore the Artisan brush profile for each operation to the default (Soft Brush Profile, softBrush.jpg), and to restore the Paint Effects brush settings for each operation to the default for that operation.

Blend Mode

Select how you want to alter the way paint is applied to the texture. These blend modes are a subset of those available in popular paint packages. The base color is the color you are painting on.

Note

Blend Modes are used only when the brush is an Artisan brush.
Default

Paints each pixel to make it the resulting color. This is the default mode.

Lighten

Uses the base or paint color, whichever is lighter, as the resulting color. Replaces pixels darker than the paint color, and leaves pixels lighter than the paint color unchanged.

Darken

Uses the base or paint color, whichever is darker, as the resulting color. Replaces pixels lighter than the paint color, and leaves pixels darker than the paint color unchanged.

Multiply

Multiplies the base color by the paint color. The resulting color is always a darker color. Multiplying any color with black (value of 0) produces black. Multiplying any color with white (value of 1) leaves the color unchanged. When you’re painting with a color other than black or white, each overlapping stroke produces progressively darker colors.

Screen

Multiplies the inverse of the paint and base colors. The resulting color is always a lighter color. Screening with black leaves the color unchanged. Screening with white produces white.

Overlay

Multiplies the colors, depending on the base color. Patterns or colors overlay the existing pixels while preserving the highlights and shadows of the base color. The base color is mixed with the paint color to represent the lightness or darkness of the original color.

Clone Brush Mode

Select Dynamic to move the clone source (the area the paint is sampled from) as you move the destination brush.

Select Static to keep the clone source stationary.
Set Clone Source

Click this button and then click an area on the surface to set that area as the source, or area where the paint sample is cloned from. If you paint over the clone source during a stroke, the original paint sample is used for the rest of the stroke, but the next stroke uses the updated clone source paint sample.

Blur Intensity

Defines the blurring effect of the brush. The higher the value, the more diffuse the blurring effect.

File Textures section

To paint an attribute directly on a model, the surfaces making up the model must have a file texture assigned to it for the attribute. You can create the file texture and assign it to the selected surfaces in this section, or you can do it in Hypershade.

Attribute to Paint

Select the material attribute you want to paint. Available attributes vary depending on the material type. For example, Specular Color is not available for a Lambert material. If you want to paint other attributes, assign a material to your model that has the available attribute. For details on these attributes, see Common Material Attributes in the Rendering guide. You can select from the following RGB and single channel attributes.

<table>
<thead>
<tr>
<th>RGB</th>
<th>Single Channel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>BumpMap</td>
</tr>
<tr>
<td>Transparency</td>
<td>Reflectivity</td>
</tr>
<tr>
<td>Incandescence</td>
<td>Diffuse</td>
</tr>
<tr>
<td>Specular Color</td>
<td>Translucence</td>
</tr>
<tr>
<td>Ambient</td>
<td></td>
</tr>
<tr>
<td>Reflected Color</td>
<td></td>
</tr>
</tbody>
</table>

Image Format

Select the image format you want the file texture saved in. You can save the texture in any of the following file formats:
Using the 3D Paint Tool | 15

Switch nodes and painted textures

(Mac OS X) Maya IFF (the default), Windows Bitmap, JPEG, MacPaint, Photoshop, PNG, QuickDraw, QuickTime Image, Targa, SGI, and Tiff.

(Windows, IRIX, and Linux) Maya IFF (the default) Alias PIX, EPS, GIF, JPEG, RLA, SGI, SoftImage, Targa, and Tiff.

Assign/Edit Textures

Use this to edit both the size and file format of existing 3D Paint textures and to assign textures.

If you have not previously painted or assigned file textures to the selected surfaces, a warning displays in the Command Feedback line:

Some surfaces have no file texture assigned to the current attribute.

Also, the brush outline displays an X across it when you move the brush over the surface to indicate that you are unable to paint on the selected attribute texture.

To assign a file texture, select the attribute you want to paint and then click this button.

| Note | Be sure to assign a new shader before painting your object, otherwise you will modify the default shader. If this happens, the painted texture will be assigned to any new objects you create in your scene. |

Save Textures

Click the Save Textures button at any time to save the texture.

Reload File Textures

Use this button to update the 3D Paint texture if it has been modified in some other paint package (for example, Paint Effects). If you do not reload a file texture after making changes to it in another program, the changes might not be recognized by 3D Paint.

Update on Stroke

Turn this option on to save the texture after each stroke you paint.

Turn this option on when IPR rendering. As you release the mouse (or stylus) at the end of each stroke, the texture updates and the IPR render refreshes to reflect your changes.
Notes
You cannot erase with Update on Stroke turned on.

You can use the 3D Paint Tool while High Quality Rendering is turned on; this enables you to preview attributes such as bump and transparency while painting them, however you cannot see the stroke itself while it is being painted, since the texture is updated only at the end of each stroke.

Save Texture on Stroke

Turn this option on to save each stroke to the file texture you are editing. The changes remain even if you do not save the scene. When this option is off (the default), you must save your scene for changes to the file texture to take effect.

Extend Seam Color

This option ensures a smooth transition between texture attributes at UV shell borders when you render. When this option is on, Maya extends the color you paint into the background past the shell and averages the painted and background colors at the border. This option is off by default.

Stroke section

For details, see “Stroke section” on page 301.

Stylus Pressure section

For details, see “Stylus Pressure section” on page 303.

Display section

For details, see “Display section” on page 305.
Index

Numerics
-25% horizontal and vertical Roll options ........ 43
2D painting ..................................... 33
overview ...................................... 33
setting up ....................................... 35
3D Paint Tool .................................. 311
blurring ........................................ 318
cloning ......................................... 317
erasing .......................................... 317
resetting brushes ................................ 319
smearing ........................................ 318
textures directory .............................. 324
3D painting ..................................... 53
overview ...................................... 53
setting up ....................................... 55
3dPaintTextures directory ...................... 324
50, 20 horizontal and vertical Roll options .... 43

A
Add operation
  Paint Attributes Tool ......................... 294
After Stroke Cmd option ..................... 303
All Planes option ............................. 107
alpha channel ................................ 253
Alpha Channel option ....................... 108
Ambient Color
  painting ...................................... 311, 334
animating
  flow of gaps ................................ 207
growth simulation ............................ 210
loopping ....................................... 217
plant growing up column (example) ........ 222
rain (example) ................................ 221
starfield (example) .......................... 225
stroke endbounds ............................ 213
strokes ........................................ 205
tube death .................................... 212
tube growth (uniform) ....................... 208
Apply Settings to Last Stroke option ........ 74
Apply Settings to Selected Strokes option .... 74
Artisan
  brush shape options ....................... 328
  brushes ..................................... 248
Clone operation .............................. 315, 317, 330
Erase operation ............................... 315, 317, 323, 330
exporting attribute maps ................... 256
hotkeys ........................................ 30, 258
how tools work ................................ 247
importing attribute maps ................... 255
mapping attributes .......................... 253
marking menus ................................ 260
Paint operation ................................ 315, 330
paint tools ...................................... 17
Pressure option ............................... 303
resetting tools ................................ 299
snap brush to curve ........................... 250
snap brush to isoparm ....................... 250
strokes ........................................ 249
stylus pressure ................................ 257
tool shelf ...................................... 257
tools ............................................ 245
Assign Textures button ....................... 335
Attach Brush to Curves option ............... 82
attribute maps ................................. 253
Attribute to Paint option .................... 334
attributes
  exporting maps (Artisan tools) ............. 256
  flooding values ............................ 291
  importing maps (Artisan tools) .......... 254
  making paintable ........................... 291
  mapping textures to ....................... 253
  mapping values ............................ 291
  masking .................................... 290
  painting .................................... 289, 311, 334
Auto Save option ............................ 46, 49
axes, reflected painting ..................... 251
Azimuth Min/Max attributes
  Paint Effects Brush Settings window ...... 165

B
Back Shadow attribute
  Paint Effects Brush Settings window ...... 157
Bake Spring Animation option ............... 206

Paint Effects, Artisan, and 3D Paint
339
baking spring animation  ........................................ 206
Before Stroke Cmd option ..................................... 303
bend attributes .................................................... 124
Blend Mode option
  3D Paint Tool ................................................ 332
blending brush presets .......................................... 133
Blue Plane option ................................................ 107
Blur brush type .................................................. 39, 80, 136
Blur Intensity attribute
  Paint Effects Brush Settings window ...................... 145
Blur Intensity option ........................................... 334
Blur Mult attribute
  Paint Effects Brush Settings window ...................... 153
Blur operation .................................................... 315, 318
blurring paint
  3D paint .......................................................... 318
  in scene ........................................................ 79
  on canvas ...................................................... 39
Branch After Twigs attribute ................................ 173
Branch Dropout attribute ..................................... 168
Branches attribute .............................................. 166
Brightness Rand attribute
  Paint Effects Brush Settings window ...................... 147
Brush Animation submenu .................................... 205, 206, 217
Brush Preset Blend window .................................... 133
brush size .......................................................... 248
Brush Start map method
  Paint Effects Brush Settings window ...................... 151
Brush Type attribute ........................................... 38, 39, 80, 113
Brush Type option
  Paint Effects Brush Settings window ...................... 135
Brush Width attribute
  Paint Effects Brush Settings window ...................... 138
brushes .................................................................. 111
alignment ........................................................... 301
animations, looping ............................................... 217
Artisan ............................................................... 248
attaching to curves ............................................... 82
attributes .......................................................... 112
attributes, animating ............................................ 206
copying settings from ........................................... 74
creating .............................................................. 127
defined ............................................................... 24
flow animation ..................................................... 207
forces ................................................................. 214
how they work ..................................................... 247
opacity, Artisan ................................................... 248
operations .......................................................... 249
outline color ......................................................... 257
presets ............................................................... 24
presets, blending .................................................. 133
presets, creating ................................................... 127
profile ............................................................... 248, 300
profile attributes .................................................. 117
radius, Artisan ..................................................... 248
resetting ............................................................. 299, 319, 332
saving ................................................................. 127
saving to shelves ................................................... 29, 257
selecting ............................................................. 129, 315
selecting all ........................................................ 130
selecting by name .................................................. 130
settings, applying to strokes ................................... 74
shape ................................................................. 248, 300
springs, editing ..................................................... 206
stroke settings ...................................................... 297
strokes ............................................................... 249
template ............................................................. 24
tools ................................................................. 245, 257
undoing strokes .................................................... 319
value, Artisan ...................................................... 249
brush shapes directory .......................................... 328
Brushstroke Pressure Adjustment Tool window ........... 78
Brushstroke Spring Simulation window .................... 206
Bud Color attribute .............................................. 187
Bud Size attribute ................................................. 187
Buds attribute ...................................................... 167
bump .................................................................. 47
painting .............................................................. 322
Index

Bump Blur attribute
   Paint Effects Brush Settings window ........... 149
Bump Intensity attribute
   Paint Effects Brush Settings window ........... 149
BumpMap
   painting ......................................... 311, 334

C

camera
   changing in scene painting view ............... 59
   setting up ................................... 230
Camera Point
   stroke Shape node ............................... 102
canvas
   clearing ........................................ 41
   displaying ................................... 34
   erasing paint from .............................. 38
   global settings ................................ 35
   lighting ...................................... 35
   painting on ................................... 36
   rolling ....................................... 43
   size, setting .................................. 35
   switching to ................................... 103
   toolbar ....................................... 104
   tracking ...................................... 41
   zooming ...................................... 41
Canvas Scale
   Paint Effects Globals ............................. 50
Canvas Undo option ................................ 37
Cast Shadows attribute
   Paint Effects Brush Settings window .......... 158
Center Shadow attribute
   Paint Effects Brush Settings window .......... 157
   channel attributes ............................. 117
Clamp settings
   Paint Attributes Tool ............................ 294
Clamp Value setting
   Paint Attributes Tool ............................ 295
Clear Color window ................................ 41
clear color, setting ................................ 41
clearing the canvas ................................ 41
Clip Edges option
   Auto Paint Random ............................... 94

Clone Brush Mode option .......................... 317, 333
Clone operation ..................................... 315, 317, 330
cloning, 3D paint .................................. 317
Color Feedback option, Artisan tool (new
   architecture) .................................... 306
Color Length Map attribute
   Paint Effects Brush Settings window .......... 198
Color option
   3D Paint Tool .................................... 329
Color Per Vertex
   stroke Shape node ................................ 101
Color1 attribute
   Paint Effects Brush Settings window .......... 144
Color2 attribute
   Paint Effects Brush Settings window .......... 146
construction history ................................ 25
control curves ...................................... 83
   applying forces to ............................... 215
   hiding .......................................... 84
Convert Paint Effects to Polygons ................. 96
Convert To File Texture command ................. 322
Copy Texture Maps on Save Scene As option .... 325
copying brush settings .............................. 74
Creation Script attribute ............................ 199
Curl attribute ...................................... 190
Curl Frequency attribute ............................. 190
Curl Offset attribute ................................ 191
Curve Attract attribute ................................ 192
Curve Degree option
   Auto Paint Grid .................................. 92
Curve Follow attribute ............................... 192
Curve Max Dist attribute ............................. 193
Curve Utilities submenu .............................. 76, 78, 82, 83
curves ............................................. 25
   attaching brushes to ............................ 82
   controlling tube behavior with ................. 83
   simplifying .................................... 76
Cycle Frames option ................................ 217

D

Darken Blend Mode, 3D Paint Tool ................. 333
Default Blend Mode, 3D Paint Tool ................. 333

Paint Effects, Artisan, and 3D Paint
341
Index

Deflection attribute ......................................... 194
Deflection Min/Max attributes ............................ 194
Delete All by Type Strokes option ........................ 82
deleting strokes ............................................. 82
Depth attribute
   Paint Effects Brush Settings window ............... 137
Depth Shadow attribute
   Paint Effects Brush Settings window ............... 158
Depth Shadow Depth attribute
   Paint Effects Brush Settings window ............... 158
Depth Shadow Type attribute
   Paint Effects Brush Settings window ............... 157
depth, saving as grayscale values ...................... 106
Diffuse painting ............................................. 311, 334
Displacement Decay attribute ............................ 188
Displacement Offset attribute
   Paint Effects Brush Settings window ............... 148
Displacement Scale attribute
   Paint Effects Brush Settings window ............... 148
Display Active Vertices option ........................... 307
Display Fog
   Object Shading menu .................................. 61
Display Fog option .......................................... 61
Display menu, Paint Effects panel ....................... 104, 107
Display Percent option .................................... 85
Display Quality
   Paint Effects Tool option .............................. 89
display quality ............................................ 165
   strokes .................................................... 85
Draw Brush Feedback option .............................. 306
Draw Order stroke option ................................ 98
Draw Outline option ....................................... 306
duplicating objects with strokes on them ............ 64
dynamic cloning ............................................ 317, 333

E

Edge Antialias attribute
   Paint Effects Brush Settings window ............... 146
Edge U, V options
   Auto Paint Grid .......................................... 93
edges
   painting across ........................................ 64
Edit Template Brush button ............................. 328
Edit Template icon ........................................ 316
Elevation Min/Max attributes
   Paint Effects Brush Settings window ............... 164
emitterPaint script ........................................ 261
Enable Stroke Rendering render option ............... 234
end bounds of stroke, modifying ....................... 72
End Frame option .......................................... 206
End Time attribute ......................................... 202
Equalization option
   Auto Paint Grid .......................................... 93
   Auto Paint Random ..................................... 94
Erase brush type ............................................ 38, 80
   operation ................................................ 315, 317, 323, 330
Erase brush type ............................................ 136
   erasing .................................................... 323
   3D paint ................................................ 317
   flood .................................................... 320
   from canvas ............................................ 38
   from scene ............................................. 79
Export Value option ........................................ 305
exporting
   attribute maps (Artisan tools) ....................... 256
   Extend Seam Color option ............................ 336
F

faces
   painting .................................................... 319
   subdividing automatically after selection .......... 303
Fake Shadow attribute
   Paint Effects Brush Settings window ............... 156
file formats ................................................ 47
Filter button
   Paint Attributes Tool ................................ 293
Flatness1 attribute
   Paint Effects Brush Settings window ............... 139
Flatness2 attribute
   Paint Effects Brush Settings window ............... 139
Flip Tube Direction ....................................... 37
Paint Effects, Artisan, and 3D Paint
342
<table>
<thead>
<tr>
<th>H</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Hard Edges</td>
<td>stroke Shape node</td>
<td>101</td>
</tr>
<tr>
<td>Hardware Texturing option</td>
<td></td>
<td>46</td>
</tr>
<tr>
<td>height and width of canvas, setting</td>
<td></td>
<td>35</td>
</tr>
<tr>
<td>Hide Strokes</td>
<td>Paint Effects to Polygons</td>
<td>96</td>
</tr>
<tr>
<td></td>
<td>horizontal wrap</td>
<td>42</td>
</tr>
<tr>
<td></td>
<td>hotkeys</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>Artisan .</td>
<td>258</td>
</tr>
<tr>
<td></td>
<td>brush tools</td>
<td>258</td>
</tr>
<tr>
<td>Hue Rand attribute</td>
<td>Paint Effects Brush Settings window</td>
<td>147</td>
</tr>
<tr>
<td>I</td>
<td>iff format</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>Illuminated attribute</td>
<td>154</td>
</tr>
<tr>
<td></td>
<td>illumination attributes</td>
<td>120</td>
</tr>
<tr>
<td></td>
<td>Image Format option</td>
<td>305, 335</td>
</tr>
<tr>
<td></td>
<td>Image Name attribute</td>
<td>181, 187</td>
</tr>
<tr>
<td></td>
<td>Paint Effects Brush Settings window</td>
<td>153</td>
</tr>
<tr>
<td></td>
<td>images</td>
<td></td>
</tr>
<tr>
<td></td>
<td>creating</td>
<td>42</td>
</tr>
<tr>
<td></td>
<td>format</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>importing</td>
<td>47</td>
</tr>
<tr>
<td></td>
<td>modifying</td>
<td>47</td>
</tr>
<tr>
<td></td>
<td>renaming</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>saving</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>saving after every stroke</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>Import Image option</td>
<td>47</td>
</tr>
<tr>
<td></td>
<td>Import Value option</td>
<td>304</td>
</tr>
<tr>
<td></td>
<td>importing</td>
<td></td>
</tr>
<tr>
<td></td>
<td>attribute maps (Artisan tools)</td>
<td>254, 255</td>
</tr>
<tr>
<td></td>
<td>importing images</td>
<td>47</td>
</tr>
<tr>
<td></td>
<td>Incand Length Map attribute</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Paint Effects Brush Settings window</td>
<td>199</td>
</tr>
<tr>
<td></td>
<td>Incandescence</td>
<td></td>
</tr>
<tr>
<td></td>
<td>painting</td>
<td>322, 334</td>
</tr>
<tr>
<td></td>
<td>Incandescence1 attribute</td>
<td>145</td>
</tr>
<tr>
<td></td>
<td>Paint Effects Brush Settings window</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Incandescence2 attribute</td>
<td>146</td>
</tr>
<tr>
<td></td>
<td>Paint Effects Brush Settings window</td>
<td></td>
</tr>
<tr>
<td>Interpolation (Turbulence) attribute</td>
<td></td>
<td>196</td>
</tr>
<tr>
<td>IPR</td>
<td></td>
<td>322</td>
</tr>
<tr>
<td></td>
<td>painting textures</td>
<td>325</td>
</tr>
<tr>
<td>K</td>
<td>Keep Aspect Ratio option</td>
<td>305</td>
</tr>
<tr>
<td></td>
<td>keyframing brush and stroke attributes</td>
<td>206</td>
</tr>
<tr>
<td>L</td>
<td>Last Brush icon</td>
<td>328</td>
</tr>
<tr>
<td></td>
<td>Last Selected icon</td>
<td>316</td>
</tr>
<tr>
<td></td>
<td>Leaf Angle1 attribute</td>
<td>177</td>
</tr>
<tr>
<td></td>
<td>Leaf Angle2 attribute</td>
<td>177</td>
</tr>
<tr>
<td></td>
<td>Leaf Base Width attribute</td>
<td>176</td>
</tr>
<tr>
<td></td>
<td>Leaf Bend attribute</td>
<td>178</td>
</tr>
<tr>
<td></td>
<td>Leaf Color1 attribute</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Leaf Color2 attribute</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Leaf Curl attribute</td>
<td>178</td>
</tr>
<tr>
<td></td>
<td>Leaf Dropout attribute</td>
<td>176</td>
</tr>
<tr>
<td></td>
<td>Leaf Flatness attribute</td>
<td>179</td>
</tr>
<tr>
<td></td>
<td>Leaf Forward Twist attribute</td>
<td>178</td>
</tr>
<tr>
<td></td>
<td>Leaf Hue Rand attribute</td>
<td>181</td>
</tr>
<tr>
<td></td>
<td>Leaf Length attribute</td>
<td>176</td>
</tr>
<tr>
<td></td>
<td>Leaf Sat Rand attribute</td>
<td>181</td>
</tr>
<tr>
<td></td>
<td>Leaf Segments attribute</td>
<td>179</td>
</tr>
<tr>
<td></td>
<td>Leaf Size Decay attribute</td>
<td>179</td>
</tr>
<tr>
<td></td>
<td>Leaf Specular attribute</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Leaf Specular attribute</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Leaf Start attribute</td>
<td>177</td>
</tr>
<tr>
<td></td>
<td>Leaf Stiffness attribute</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Leaf Tip Width attribute</td>
<td>176</td>
</tr>
<tr>
<td></td>
<td>Leaf Translucence attribute</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Leaf Twirl attribute</td>
<td>179</td>
</tr>
<tr>
<td></td>
<td>Leaf Twist attribute</td>
<td>178</td>
</tr>
<tr>
<td></td>
<td>Leaf Use Branch Tex attribute</td>
<td>181</td>
</tr>
<tr>
<td></td>
<td>Leaf Val Rand attribute</td>
<td>181</td>
</tr>
<tr>
<td></td>
<td>Leaf Width Scale attribute</td>
<td>176</td>
</tr>
<tr>
<td></td>
<td>Leaves attribute</td>
<td>166</td>
</tr>
<tr>
<td></td>
<td>Leaves In Cluster attribute</td>
<td>175</td>
</tr>
<tr>
<td></td>
<td>Leaf Translucence attribute</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Leaf Tip Width attribute</td>
<td>176</td>
</tr>
<tr>
<td></td>
<td>Leaves attribute</td>
<td>166</td>
</tr>
<tr>
<td></td>
<td>Leaves In Cluster attribute</td>
<td>175</td>
</tr>
<tr>
<td></td>
<td>Length Flex attribute</td>
<td>195</td>
</tr>
</tbody>
</table>

Paint Effects, Artisan, and 3D Paint

344
Length Max attribute
  Paint Effects Brush Settings window ........ 161
Length Min attribute
  Paint Effects Brush Settings window ........ 161
Light Direction
  Paint Effects Globals ........................ 51
Light Direction attribute
  Paint Effects Brush Settings window .......... 155
Luminance option ............................. 108
  channel, displaying .......................... 107
Lighten Blend Mode ............................ 333
loading Paint Effects .......................... 28
Local Displacement option ...................... 195
Local Force option ............................. 195
Loop Brush Animation option ..................... 217
Loop button .................................... 217
marking menus
  Artisan ......................................... 260
  brush tools .................................... 260
mask
  Artisan tools .................................. 299
mask channel .................................... 107
masked surfaces
  painting attributes ............................ 290
masking
  3D Paint ....................................... 319
  Paint Scripts Tool ............................. 264
Max Clip option .................................. 100
Max Color option ................................ 307
Maya Paint Effects
  described ....................................... 23
  loading ......................................... 28
  MAYA_PAINT_EFFECTS_THREADS environment variable ........ 233
MEL
  Paint Scripts Tool ............................. 261
  procedures, script paint ....................... 265
  script painting ................................ 262
MEL scripts
  painting ......................................... 261
Middle Branch attribute ......................... 170
Min Clip option .................................. 100
Min Color option ................................ 307
Min Size attribute ................................ 169
Min/Max Value setting
  Paint Attributes Tool .......................... 294
Min/Max Values .................................. 282
  Paint Scripts Tool ............................. 282
mirrored painting ................................ 251
Modify Alpha attribute
  Paint Effects Brush Settings window .......... 138
Modify Color attribute
  Paint Effects Brush Settings window .......... 138
Modify Depth attribute
  Paint Effects Brush Settings window .......... 138
Momentum attribute .............................. 195
Motion Blurred stroke option ..................... 99
mouse, switching to ............................. 109
Multiply Blend Mode option ....................... 333

Paint Effects, Artisan, and 3D Paint

345
multiprocess render ............................................ 233

N
Noise attribute ................................................. 188
Noise Frequency attribute ................................. 188
Noise Offset attribute ........................................ 189
normal
direction ....................................................... 73
reversing ......................................................... 68
Normal stroke option .......................................... 100
Num Branches attribute ...................................... 167
Num Flowers attribute ........................................ 182
Num Leaf Clusters attribute ............................... 175
Num Twig Clusters attribute ............................... 170

O
Object Shading menu, Paint Effects panel ............. 60
objects, painting on ........................................... 63
Offset U attribute
Paint Effects Brush Settings window .................. 152
Offset V attribute
Paint Effects Brush Settings window .................. 152
Only Render Strokes render option ...................... 235
opacity
Artisan brush ................................................... 248
Opacity option
3D Paint Tool ................................................... 329
outline color, brush ............................................ 257
Output Quads
stroke Shape node ............................................ 102
Overlay Blend Mode, 3D Paint Tool ...................... 333

P
Paint at Depth
Paint Effects Tool option .................................... 89
Paint Attributes Tool .......................................... 289
making attributes paintable .................................. 291
settings .......................................................... 291
Paint brush type ................................................ 135
Paint Canvas command ......................................... 34
Paint Canvas option ............................................ 103
Paint Effects ....................................................... 23
Blur operation .................................................... 315, 318, 331
brush options, 3D Paint Tool ........................... 328
Convert Paint Effects to Polygons ...................... 96
operations, 3D Paint Tool ..................................... 331
Paint operation ................................................. 315, 331
Smear operation ................................................ 315, 318, 331
Paint Effects Brush Settings window .................. 112
Paint Effects Globals .......................................... 55
Paint Effects Globals window ............................. 35
Paint Effects option (General Preferences) .......... 28
Paint Effects panel ............................................. 34
lighting ............................................................ 107
painting in ......................................................... 103
Paint Effects Pressure option .............................. 303
Paint Effects render globals ................................ 231
Paint Effects Set Size window ............................ 35
Paint Effects Tool
described .......................................................... 24
settings ............................................................ 55
Paint menu, Paint Effects panel .......................... 105, 106, 109
Paint on Paintable Objects option ...................... 62, 63
Paint on View Plane option ............................... 66
Paint operation ................................................... 315, 330
Paint Effects ....................................................... 331
paint operations ................................................ 249
Paint Attributes Tool .......................................... 294
Paint Scene option ............................................. 103
Paint Scripts Tool
MEL scripts, writing .......................................... 265
settings ............................................................ 264
value ............................................................... 282
paint tools ........................................................ 245
brush stroke settings ......................................... 297
how they work ................................................... 247
reflected painting .............................................. 251
resetting ........................................................... 299
stylus pressure .................................................. 257
paint, applying to strokes .................................... 26

Paint Effects, Artisan, and 3D Paint
346
### Index

- painting ........................................ 311
- 3D ........................................ 311
- Artisan ........................................ 249
- blurring ....................................... 318
- bump ........................................ 322
- erasing ........................................ 323
- flooding, Artisan ................................ 251
- incandescence ................................ 322
- IPR ........................................ 322
- layers ........................................ 323
- multiple surfaces, switch nodes .............. 326
- non-file textures ................................ 322
- on grid plane .................................. 62
- previewing .................................... 322
- reflecting, 3D Paint Tool ...................... 321
- reflecting, Artisan ............................. 251
- renderable attributes ......................... 311
- restricting area ................................ 319
- RGB attributes ................................ 334
- saving textures ................................ 324
- single channel attributes .................... 334
- smearing ....................................... 318
- snap brush .................................... 250
- textures, existing ............................. 322
- transparency .................................. 322
- undoing, 3D paint .............................. 319
- panel, Paint Effects ........................... 34, 103
- Panels menu, Paint Effects Panel ............. 59
- Particle Instancer .............................. 28
- Path Attract attribute ......................... 191
- Path Follow attribute ......................... 191
- periodic surfaces .............................. 64
- Petal Base Width attribute .................... 182
- Petal Bend attribute ........................... 184
- Petal Color 1 attribute ....................... 186
- Petal Color 2 attribute ....................... 186
- Petal Curl attribute .......................... 184
- Petal Dropout attribute ....................... 182
- Petal Flatness attribute ....................... 185
- Petal Forward Twist attribute ................. 184
- Petal Length attribute ....................... 182
- Petal Segments attribute ..................... 185
- Petal Tip Width attribute ..................... 182
- Petal Twirl attribute ........................ 185
- Petal Width Scale attribute ................ 183
- Petals In Flower attribute .................... 181
- pixel painting in canvas ...................... 40
- plant growth, animating (example) ........... 222
- Points Per Curve option ........................
  - Auto Paint Grid ................................ 93
- Poly Limit
  - Paint Effects to Polygons .................. 97
  - stroke Shape node .......................... 102
- polygons
  - Convert Paint Effects to Polygons .......... 96
  - painting on .................................. 28
  - Position Stroke stroke option .............. 97
  - Preset Blending option ...................... 133
- preset brushes
  - defined ...................................... 24
  - location ..................................... 29
  - saving to shelves ............................ 29
- Pressure Mapping
  - Paint Effects Tool option ................... 90
  - stroke Shape node .......................... 100
- Pressure Mapping option ...................... 303
- pressure mappings ............................ 36
  - modifying .................................... 73
  - modifying interactively .................... 78
- Pressure Max
  - Paint Effects Tool option ................... 91
  - stroke Shape node .......................... 101
- Pressure Min
  - Paint Effects Tool option ................... 90
  - stroke Shape node .......................... 101
- pressure, stylus .............................. 257
- Primary Visibility stroke option ............ 100
- problems and solutions ....................... 237

**Q**

- Quad Output
  - Paint Effects to Polygons .................. 96

**R**

- radius
  - Artisan ...................................... 248
Index

Radius options .................................. 300, 327
rain, animating (example) ....................... 221
Random attribute ................................ 193
Random Offset option
Auto Paint Random .............................. 94
raytraced reflections and refractions ........... 241
Read This Depth File render option ........... 235
Real Lights attribute
Paint Effects Brush Settings window .......... 154
Reassign Attribute Maps ........................ 304
Red Plane option ................................. 107
redrawing scene painting view ................... 58
referencing models ................................ 227
reflect painting .................................... 321
Reflected Color
painting ........................................... 334
reflected painting ................................ 251
Artisan ............................................. 251
non-symmetrical .................................. 252
Reflection options ................................ 302
reflections and refractions ....................... 241
Reflectivity
painting ........................................... 311, 334
refreshing scene painting view ................... 58
Reload File Textures button ....................... 336
render globals, setting ......................... 231
Rendered option ................................... 59
rendering
interactive ....................................... 57
multiprocess ...................................... 233
preparing to ..................................... 229
scenes with strokes ................................ 229
strokes (refresh) .................................. 58
Repeat U attribute
Paint Effects Brush Settings window .......... 152
Repeat V attribute
Paint Effects Brush Settings window .......... 152
repeating textures, creating .................... 42
Replace operation
Paint Attributes Tool ............................ 294
Reset Brushes button ........................... 319
3D Paint Tool ..................................... 332
Reset Template Brush option .................... 127

Paint Effects, Artisan, and 3D Paint

Resolution menu, Paint Effects panel ............ 60
resolution, scene painting view ................. 60
RGB
attributes, painting ................................ 334
channel, displaying ............................... 107
Roll option ....................................... 43
rolling the canvas ................................ 43
Root Fade attribute
Paint Effects Brush Settings window .......... 147
Rotate To Stroke option ......................... 301, 329
Runtime Script attribute ......................... 199

S
Sample Density option ........................... 98
Auto Paint Grid ................................... 93
Auto Paint Random ................................ 94
Sat Rand attribute
Paint Effects Brush Settings window .......... 147
Save As option ................................... 49
Save Brush Preset option ......................... 127
Save Brush Preset window ....................... 127
Save Depth as Grayscale option ................. 106
Save Image Options window ..................... 49
Save option ....................................... 48, 49
save options, setting ............................. 49
Save Snapshot option ............................ 105
Save Texture on Stroke .......................... 325
Save Texture on Stroke option ................... 336
Save Textures button ............................ 317, 335
saving images ..................................... 48
after every stroke .................................. 49
Scale (PFX) option, 3D Paint Tool ............... 327
Scale operation
Paint Attributes Tool ............................ 294
scaling
canvas ............................................ 35
scene ............................................. 55
scaling values ..................................... 294
Index

scene .................................................. 62
blurring paint in ................................... 79
erasing paint from .................................. 79
globals .................................................. 55
lighting ................................................. 55, 229
painting in ............................................. 53
settings .................................................. 55
smearing paint in ..................................... 79
scene painting view .................................. 57
camera, changing ...................................... 59
defined .................................................. 27
fog, displaying ........................................ 61
painting on view plane ................................. 66
refreshing ............................................... 58
resolution, changing .................................. 60
shading, changing ...................................... 60
switching to .......................................... 103
toolbar .................................................... 104
Scene Scale global setting ......................... 88
Scene Wrap H global option ....................... 88
Scene Wrap V global option ....................... 88
Screen Blend Mode, 3D Paint Tool ............... 333
screen captures ....................................... 105
Screen Projection option ......................... 316
Artisan tools (new architecture) ................. 301
Screenspace Width attribute ........................
Paint Effects Brush Settings window .......... 163
Script Paint Tool ..................................... 261
add operation ........................................ 281
flooding ............................................... 265
replace operation .................................... 281
scale operation ....................................... 281
smooth operation ..................................... 282
value .................................................... 282
script painting ......................................... 262
restricted areas ....................................... 264
scripts
sample Artisan spherePaint script .......... 272
writing for Paint Scripts Tool .................. 265
seamless repeating textures, creating .......... 42
seams, painting across .............................. 64
Seed stroke option .................................... 98
Segment Length Bias attribute ..................
Paint Effects Brush Settings window .......... 163
Segment Width Bias attribute ....................
Paint Effects Brush Settings window .......... 163
Segments attribute ....................................
Paint Effects Brush Settings window .......... 161
Select All by Type Strokes option ............... 81
Selected Color
painting ................................................. 334
Selected Only option ................................ 59
selecting
brush presets ......................................... 111
brushes ............................................... 129
brushes by name ..................................... 130
strokes ............................................... 81
strokes by name ..................................... 81
Set Clone Source option ......................... 317, 334
Set Erase Image ......................................
3D Paint Tool ......................................... 319
Set Erase Image button ........................... 332
3D Paint Tool ......................................... 332
Set Size option ........................................ 35
Set Stroke Control Curves option ............... 83
Shaded
Object Shading menu ................................ 60
Shader Glow attribute .............................
Paint Effects Brush Settings window .......... 159
shading
brush attributes ..................................... 119
object (in Paint Effects panel) ..................... 60
Shading menu, Paint Effects panel ............... 61, 107
Shadow Diffusion attribute .......................
Paint Effects Brush Settings window .......... 156
shadow effects ........................................ 230
Shadow Offset attribute ...........................
Paint Effects Brush Settings window .......... 156
Shadow Transparency attribute ..................
Paint Effects Brush Settings window .......... 156
shadows and shading attributes ................ 120
shape
Artisan tools ......................................... 248, 300
Share One Brush option ............................ 75
Auto Paint Grid ....................................... 93
Auto Paint Random ................................... 94
shelves, saving preset brushes to ............... 29
Show Wireframe option ......................... 306

Paint Effects, Artisan, and 3D Paint
349
simple strokes ........................................ 25
Simplify Method attribute
  Paint Effects Brush Settings window ........ 165
Simplify Stroke Path Curves option ..........  76
single channel attributes
  painting ........................................... 334
Single Pixel Brush option ......................... 40
singleShadingSwitch node, painted textures ... 326
size, Artisan brush .................................. 248
Smear attribute
  Paint Effects Brush Settings window ........  153
Smear Frequency option
  Auto Paint Grid ..................................  93
Smear operation .................................... 315, 318
Smear operation Blur operation ................ 331
Smear U attribute
  Paint Effects Brush Settings window ........  153
Smear V attribute
  Paint Effects Brush Settings window ........  153
smearing paint
  3D paint ........................................... 318
  in scene .........................................  79
  on canvas .......................................  39
Smooth operation
  Paint Attributes Tool ............................. 294
Smoothing stroke option ......................  99
smoothing values ................................ 294
snap brush to curve ............................  250
snap brush to isoparm .........................  250
snapshots ........................................... 105
SnapToCurve command ............................. 250
Softness attribute
  Paint Effects Brush Settings window .... 139
solutions to problems .......................... 237
Spans U, V options
  Auto Paint Grid ..................................  92
  Auto Paint Random ..............................  94
Specular attribute
  Paint Effects Brush Settings window .... 155
Specular painting ................................ 334
Specular Color attribute
  Paint Effects Brush Settings window .... 155
Specular Power attribute
  Paint Effects Brush Settings window .... 155
spherePaint script ............................. 261, 272
spiral attributes ................................ 124
Spiral Decay attribute ......................... 197
Spiral Min/Max attributes .................... 196
Split Angle attribute ............................ 168
Split Bias attribute .............................. 169
Split Length Map attribute
  Paint Effects Brush Settings window .... 199
Split Max Depth attribute ..................... 167
Split Rand attribute .............................. 168
Split Size Decay attribute .................... 169
Split Twist attribute ............................ 168
spring behavior
  adding to strokes ............................... 205
  baking animation ............................... 206
  removing from strokes ....................... 206
Spring Damp option ............................. 218
Spring Stiffness option ......................... 218
Spring Travel option ............................ 218
stamp .................................................. 247
  profile ......................................... 300
  profile, 3D Paint Tool ......................... 327
Stamp Density attribute
  Paint Effects Brush Settings window .... 141
Stamp Depth options, Artisan tools (new architecture) ...................... 302
Stamp Spacing option, Artisan tools (new architecture) ...................... 302
stamps ................................................. 26
starfield, animating (example) ............... 225
Start Branches attribute ....................... 167
Start Frame option .............................. 206, 218
Start Time attribute ............................ 202
Start Tubes attribute ............................ 28
static cloning ..................................... 317, 333

Paint Effects, Artisan, and 3D Paint 350
Index

stroke ........................................... 247
reflected ..................................... 251
settings, paint tools ....................... 297
Stroke Display Quality option ............ 85
Stroke Length option
  Auto Paint Random ....................... 94
stroke option
  stroke Shape node ....................... 97
stroke path curves
  shape, changing .......................... 76
  showing .................................. 76
  showing and hiding ....................... 84
  simplifying ................................ 76
stroke path, animating .................... 213
Stroke Refresh menu, Paint Effects panel 58
Stroke Time attribute ...................... 201

strokes .......................................... 249
  animating ................................ 205
  animating attributes .................... 206
  animating textures on ................... 216
  applying brush settings to .............. 74
  applying paint to ....................... 26
  default settings ........................ 55
deleting ...................................... 82
described .................................... 25
display quality, modifying .............. 85
de and bounds ................................ 72
hiding ........................................ 84
illuminating ................................ 120
modifying .................................... 70
modifying using control curves .......... 83
normal, modifying ........................ 73
path curves, simplifying ................. 76
pressure mappings, modifying ........... 73
pressure mappings, modifying interactively 78
rendered, refreshing ..................... 58
rendering as you paint .................. 57
saving after .................................. 49
selecting ...................................... 81
selecting by name ......................... 81
settings, modifying ....................... 71
shape, changing ............................ 76
sharing the same brush .................. 75
showing ....................................... 84
simple ......................................... 25
simulating growth ........................ 25
spring behavior ............................ 205
types of ..................................... 25
undoing in canvas ......................... 37
wireframe representation of ............. 27
with tubes .................................... 25

Strokes Per Span option
  Auto Paint Grid ......................... 92
strokeShape node, editing .............. 71
stylus
  pressure mappings ....................... 36, 257
  switching to .............................. 109
stylus pressure ............................ 257
Stylus Pressure option, Artisan tools .. 303
subdivisions
  faces, automatically after selection .. 303

Paint Effects, Artisan, and 3D Paint

351
## Index

**Surface**
- normals, reversing ........................................... 68
- textures, modifying ............................................ 45
**Surface Offset**
- Paint Effects Tool option .................................. 90
**Surface Offset Min, Max option**
- Auto Paint Grid ................................................. 93
**Surface Offset Min, Max options**
- Auto Paint Random ............................................. 94
**Surface Offset option** ........................................... 99

**Textures**
- animating flow .................................................. 207
- animating on strokes ........................................... 216
- creating animated ............................................. 215
- creating from strokes on objects ............................ 226
- dragging onto canvas ......................................... 48
- modifying ......................................................... 48
- painting in 3D .................................................... 311
- painting layers .................................................. 323
- saving painted ................................................. 324
- saving painted automatically ................................ 325
- seamless repeating ............................................ 42
- updating .......................................................... 325
**Textures directory, 3D Paint Tool** .......................... 324

**Threshold option** ............................................. 304

**Time attribute** ................................................... 203

**Time Clip attribute** ............................................ 201

**Tip Fade attribute** ..............................................
- Paint Effects Brush Settings window ..................... 147

**Toolbar option** ................................................... 104

**Tools**
- Artisan ............................................................. 17
- paint .............................................................. 17
- saving to shelves .............................................. 257

**Translucence**
- painting .......................................................... 311, 334
- attribute .......................................................... 155
- attribute .......................................................... 155
- attribute .......................................................... 155

**Transparency**
- painting .......................................................... 322, 334
- attribute .......................................................... 145
- attribute .......................................................... 147

**Tree Wind option** .............................................. 195

**Troubleshooting** .................................................. 237

**Template Brush Settings option** ............................ 112

**Terminal Leaf attribute** ....................................... 181

**Text Color Offset attribute** ................................... 148

**Texture Flow attribute** ......................................... 201

**Texture Opacity Offset attribute** .............................. 148

**Texture Opacity Scale attribute** ............................... 148

**Texture Uniformity attribute** .................................. 151

**Texture Type attribute**
- Paint Effects Brush Settings window ..................... 149

**Textured**
- Object Shading menu ........................................... 60
- attribute .......................................................... 311
Index

value, Artisan brush ........................................... 249
values
  Script Paint Tool ........................................... 282
Vector Index setting
  Paint Attributes Tool ...................................... 295
Vertex Color Mode
  Paint Effects to Polygons .................................. 96
vertical wrap ......................................................... 42
view plane, painting on ........................................ 66
Visor, saving preset brushes to shelves .................. 29

W
Width (PFX) Tool, 3D Paint Tool ......................... 327
width and height of canvas, setting ....................... 35
Width Bias attribute
  Paint Effects Brush Settings window .................. 162
Width Length Map
  Paint Effects Brush Settings window .................. 199
Width Rand attribute
  Paint Effects Brush Settings window .................. 162
Width Scale attribute ........................................... 163
Wiggle attribute .................................................. 189
Wiggle Frequency attribute .................................. 189
Wiggle Offset attribute ........................................ 190
Wireframe
  Object Shading menu ....................................... 60
wireframe
  display ......................................................... 58
  show ......................................................... 306
  strokes ....................................................... 27
Wireframe option
  Stroke Refresh menu ....................................... 59
World Displacement option ................................. 195
World Force option ............................................ 195
Wrap buttons ..................................................... 42
Wrap H
  Paint Effects Globals ....................................... 50
Wrap H global option .......................................... 42
Wrap V
  Paint Effects Globals ....................................... 50
Wrap V global option .......................................... 42

wrapping
  canvas ......................................................... 35, 42
  scene ......................................................... 55

X
X Size option ..................................................... 35

Y
Y Size option ..................................................... 35

Z
zooming the canvas .......................................... 41

Paint Effects, Artisan, and 3D Paint
354