Things to keep in mind during this tutorial:

- If you have trouble reading this version, there is a hard copy in the lab in the red “Learning Maya” book.
- In the actual assignment you will be completing after this tutorial, you will be asked to animate the motion of REAL bouncing balls. Remember that this is different than animating a CHARACTER ball, as this tutorial teaches. (Specifically, the stretch portion for a real ball occurs just as the ball leaves the ground. A character ball, on the other hand, stretches at the top of its arc, as if it is reaching upward.)
Bouncing a Ball

This lesson teaches you how to build and animate a simple bouncing ball that jumps through a hoop. You will explore Maya’s user interface as you learn how to build and develop an animated scene.

A bouncing ball

In this lesson you will learn the following:

- How to create primitive objects
- How to move objects in 3D space
- How to use Maya’s view tools
- How to change the display of your objects
- How to set keys on your objects
- How to playback animated sequences
Setting up Maya

Before beginning, install Maya 3.0, and add the Learning Maya support files to your projects directory. These can be found on the Learning Maya 3 CD-ROM.

If you have been working with Maya 3.0 and have changed any of your user interface settings, you may want to delete your preferences in order to start with the default Maya configuration. To do this while saving your existing preferences, see Appendix A: File Management.

If you are running multiple versions (v2, v1.5 etc.) of Maya on the same machine, you should also backup and delete the preference files for those versions. Otherwise, Maya 3.0 will use these preferences when it first launches and some of the new marking menu and hotkey settings will not be available. You can replace them later when you know that your Maya 3.0 prefs have been created.

Creating a new project

Maya uses the concept of a project to organize files. You can create project directories that contain sub-directories for storing your files. You will be saving your work into scene files.

1 Launch Maya

   To get started, you need to launch Maya:
   - Double-click the Maya icon.
   - Or
     - Enter `maya` in a shell window in IRIX or in the command window in Windows NT.

2 Set the courseware project

   To manage your files, you can set a project directory that contains sub-directories for different types of files that relate to your project.
   - Go to the File menu and select Project → Set...
     - A window opens that points you to the Maya projects directory.
   - Open the folder named `learningMaya`.
   - Click on the folder named `projectOne` to select it.
   - Click on the OK button.

This sets the `learningMaya` directory as your current project.

- Go to the File menu and select Project → Edit Current...

Make sure that the project directories are set up as shown below. This ensures that Maya is looking into the proper subdirectories when it opens up scene files.

- If any of the entries are incorrect, edit them to match the preceding image shown above.
3 Make a new scene
   - Select File → New Scene.
   
   This makes sure that your current scene is part of the new project.

Tip: If you would like to learn more about how Maya organizes files and directories, see Appendix A: File Management.

BUILDING OBJECTS

Every scene you create in Maya will begin with objects. These objects can include things like surfaces, deformers, skeleton joints or particle emitters. For this scene, you will build a ball and a floor surface.

Creating the ball

To start, you will build a few simple objects that you will animate, texture and render. The first object is a primitive sphere which will act as the ball.

1 Change menu sets

There are four main menu sets in Maya: Animation, Modeling, Dynamics and Rendering. These menu sets are used to access related tool sets.

   - From the pop-up menu at the left edge of the Status line, select Modeling.
   
   As you change menu sets, the first seven menus remain the same while the remaining menus change to reflect the chosen menu set.

2 Create a NURBS sphere

A primitive sphere will be used for the ball. It will be built using non-uniform rational b-spline (NURBS) geometry. In later lessons, you will learn more about this geometry type.

   - From the Create menu, select NURBS Primitives → Sphere.
   
   A sphere is placed at the origin.

Perspective view of sphere

3 Change the ball's radius

The sphere is a procedural model. This means that it is broken down into parts called nodes. One node contains its positioning information, one contains its shape information and another contains input information that defines the sphere's construction history using attributes such as radius, sweep, and degree. You can edit...
LESSON 1
Moving the ball

this input node’s attributes in the Channel box in order to edit the sphere’s shape. The Channel box is found at the right side of the screen and lets you make changes to key attributes very easily.

- From the channel box’s Inputs section, click on makeNurbSphere.

  This will make several new attributes available for editing.

- Click on the Radius attribute name.

- Type 2 in the entry field then press the Enter key.

Now the sphere is double the size in the perspective view.

4 Rename the ball node
You should rename the existing transform node to make it easier to find later.

- Click on the nurbsSphere name at the top of the Channel box to highlight it.

- Type the name ball then press the Enter key.

Renaming the node in the Channel box

Moving the ball
You will now use the Move tool to reposition the ball. This will involve the use of manipulator handles that let you control where you move your object.

1 Position the ball
You can now use the Move tool to reposition the sphere above the working grid.

- Select the Move tool.

  A transform manipulator appears centered on the object.

- Click-drag on the green manipulator handle to move the sphere along the Y-axis.

  The manipulator handle turns yellow to indicate that it is active.

Note: Another method for increasing the size of the sphere would be to scale it. In Maya, you can often achieve the same visual results using many different methods. Over time, you will begin to choose the techniques that best suit a particular situation.
Tip: The transform manipulator has three handles which let you constrain your motion along the X, Y, and Z axes. These are labeled using red for the X-axis, green for the Y-axis and blue for the Z-axis. In Maya, the Y-axis points up by default. This means that Maya is “Y-up” by default.

2 Create four view panels
By default, a single perspective window is shown in the workspace. To see other views of the scene, you can change your panel layout.

- At the top of the Perspective view panel, go to the Panels menu and select Layouts → Four.
You can now see the sphere using three orthographic views – Top, Side, and Front – which show you the model from a projected view. You can also see it in a Perspective view that is more like the 3D world we see every day. This multiple view set-up is very useful when positioning objects in 3D space.

3 Reposition the ball
When moving in an orthographic view, you can work in two axes at once by dragging on the center of the manipulator or constraining the motion along a single axis using the handles.

- In the Front view, click-drag on the square center of the manipulator to move the sphere along both the X and the Y axes.

- Use the manipulator in the various view windows to position the sphere on top of the ground plane as shown below.
Lesson 1
Create a floor surface

Be sure to refer to all four view windows to verify that the object is positioned properly.

Start position of the ball

Note: If you click-drag on the center of the manipulator in the Perspective view, you will notice that it doesn’t move along any particular axis. It is actually moving along the camera’s view plane.

Create a floor surface
To create a floor surface, a primitive plane is used. This plane using polygonal geometry which is different from the sphere which uses NURBS geometry. You can use the hotbox as an alternative method for accessing tools.

1 Create a polygonal plane
   - In a view panel, press and hold the spacebar to display the hotbox.
   - In the hotbox, select Create → Polygon Primitives → Plane.
     A plane is placed at the origin.

Tip: You can access all functions in Maya using either the main menus or the hotbox. As you become more familiar with the hotbox, you can use the user interface options found in the Options menu to turn off the panel menus and therefore reduce screen clutter.

2 Change construction history
Just like the sphere, you can edit the plane using its input node. You will increase the size of the plane, then reduce the number of subdivisions to simplify the plane. Since the floor will not be deformed, the extra polygons are not required.

   - In the Channel box shown at the right side of your screen, click on the polyPlane Input node.

   - Set the following:
     Width to 40;
     Height to 40;
     Subdivisions X to 1;
     Subdivisions Y to 1.
Rename the Plane Node

It is a good idea to rename the existing transform node to make it easier to find later.

- Click on the polyPlane node's name in the top of the channel box.
- Enter the name floor.

Create a Ring

You are now going to add a NURBS torus to the scene that will act as a hoop for the ball to bounce through when you animate it bouncing.

Create a NURBS Torus

The torus offers a shape that is perfect for the ring. You will create the torus, and then size and position it to get the ring.

- From the Create menu, select NURBS Primitives → Torus.
- In the Channel box, click on the makeNurbsTorus Input node.
- Set the following attributes:
  - Radius to 5;
  - Sections to 16;
  - Height Ratio to 0.05.

2 Position the Torus

- In the nurbsTorus section of the Channel box, set the following attribute:
  - Rotate Z to 90.
- Rename this node to ring.
- With your middle mouse button click in the perspective view then press the w key to select the Move tool.
- Move the ring up so that it sits above the ground plane. Its Translate Y attribute should read about 10.

Ring in place
Lesson 1

Viewing the scene

When you work in 3D space, it is important to see your work from different angles. The different view panels let you see your work from the Front, Top, Side and Perspective.

You can also use Maya’s view tools to change the views to reposition how you see your scene. In some cases, a view change is like panning a camera around a room, while in other cases a view change might be like turning an object around in your hand to see all the sides. These view tools can be accessed using the Alt key in combination with various mouse buttons.

1 Edit the Perspective view

You can use the Alt key with either your left mouse button (LMB), your middle mouse button (MMB) or the two together to tumble, track and dolly in your Perspective view.

- Change your view using the following key combinations:
  - Alt + LMB to tumble;
  - Alt + MMB to track;
  - Alt + LMB & MMB to dolly.

You can also use the Ctrl key to create a bounding box dolly, where the view adjusts based on a bounding box:

  - Ctrl + Alt + LMB to box dolly.

Click-drag to the right to dolly in and to the left to dolly out.

You can also undo and redo view changes using the following keys:

  - [ to undo views; and
  - ] to redo views.

2 Edit the view in the Side view

Orthographic views use similar hot keys — except that you cannot tumble an orthographic view.

- In the Side view, change your view using the following key combinations:
  - Alt + MMB to track;
  - Alt + LMB & MMB to dolly

- Keep working with the orthographic views until they are set up as shown in the following.
Setting display options

The view panels let you interactively view your scene. By default, this means viewing your scene as a wireframe model. To better evaluate the form of your objects, you can activate hardware shading and increase the sphere's smoothness.

1 Turn on Hardware shading
   To help visualize your objects, you can use hardware rendering to display a shaded view within any panel.
   - From the Perspective view's Shading menu, select Smooth Shade All.
   
   This setting affects all of the objects within the current view panel.

Tip:  You can also turn on smooth shading by moving your cursor over the desired panel, clicking with your middle mouse button and pressing the 5 key. The 4 key can be used to return the panel to a wireframe view.

2 Hide the grid
   You can hide the grid to simplify your view using one of two options:
   - From the Perspective view panel's Show menu, select Grid to hide the grid for that view only.

   OR
   - From the Display menu, deselect Grid to hide the grid for all views.

3 Adjust the sphere's smoothness
   To better evaluate the sphere's surface qualities, you can increase the smoothness.
   - Select the ball.
   - From the main Display menu, select NURBS Smoothness → Fine.
This setting affects how selected NURBS objects are displayed in all view panels.

4 Adjust the ring’s smoothness
Maya also includes some hotkeys for setting surface smoothness.
- Select the ring.
- Press the 3 key.

The smoothness setting allows you to see your objects at various degrees of complexity without actually altering the geometry.

Next, you will add in the peaks and valleys of the bouncing.

Setting keys
To animate the ball, you must define its position at certain points in time. This is accomplished by setting keys. As you playback the animation, Maya reads these key positions and interpolates the position of the ball in between the keyframes.

1 Position the ball
- Select the ball.
- Move the ball along the X axis to the edge of the floor. Use the Red manipulator handle to constrain along X.

2 Set a start key on the ball
You will use the current position to set a key for frame 1.
- Select the ball.
- Make sure that the current time is set to 1 in the time slider.
- Press F2 to select the animation menu set.

ANIMATING THE BALL
You now have your scene set up and ready to animate. Using the ball node, you will start by keying the overall translation of the ball.
From the **Animate** menu, select **Set Key**.

This places a key at frame 1 for all of the ball’s transform attributes.

**Tip:**
The menu sets can be changed using the following hotkeys:
- **F2** - Animation
- **F3** - Modeling
- **F4** - Dynamics
- **F5** - Rendering

3 **Set end key on the ball**
A new position for the ball can be set for frame 60.

- In the Time slider, change the end time and the playback end time to 60 and press **Enter**.

  **Start Time** | **End Time**
  --------------|------------
  1.00           | 60.00

  **Playback Start Time** | **Playback End Time**
  -----------------------------------
  1.00 | 60.00

**Time slider frame range settings**
This changes the range of the animation to 60 frames.

- Move the Time slider to frame **60**.

**Current time indicator**

![Image of time slider at frame 60]

- Click-drag on the X-axis handle on the sphere to move it forward.

**Tip:**
The **s** key is a hotkey for the **Set Key** command.

- Playback the results using the Playback controls which are located in the lower right corner.

**Playback controls**

- **Last frame**
- **Next frame**
- **Next key**
- **Play**
- **Backward**
- **Forward**

**Note:**
Playback will only be visible in the view panel that is highlighted. If you are not seeing any playback then be sure to click in the perspective panel with your middle mouse button.
4 Add intermediate keys

To make the ball hit the ground four times, you will need two more key positions set at frames 20 and 40.

Any time you want to make sure an object is at a certain place at a certain time, set a key.

- Drag the Time slider to frame 20.
  The ball is positioned based on existing keys.
- Press the s key to Set Key.
- Drag the Time slider to frame 40.
- Press the s key to Set Key.

You now have keys set at the following frames:

1  20  40  60

Diagram of initial keys

Tip: Every time you set a key, a red mark is placed in the Time slider to help you identify where your keys are.

5 Add more intermediate keys

To create the peaks of the bounce, you need to set new keys at frames 10, 30 and 50. These keys will require that you move the ball into a new position along the Y-axis.

- Move the Time slider to frame 30.
- Click-drag on the green Y-axis manipulator to move the sphere up along the Y-axis until it sits inside the ring.
- Press the s key to Set Key.

Move up, then set key

Y-axis move

- Move the Time slider to frame 10.
- Click-drag on the Y-axis manipulator to move the sphere up along the Y-axis. Don’t raise it as high as you did for frame 30.

This will put emphasis on the bounce at frame 30 where the ball is jumping through the ring.
- Press the s key to Set Key.

Move up, then set key

Y-axis move
Repeat these steps to create the last bounce at frame 50. Don't forget to set a key after placing the ball.

6 Set the playback speed

- Click the Animation Preferences button found at the right side of the Time slider.

  This opens a window that lets you set various animation and playback options. Currently, the scene is playing back as fast as it can. Since you only have two objects, playback is a little too fast.

- In the Playback section, set the following:
  
  Playback Speed to Normal.

- Click the Save button.

- Playback the results using the Time slider controls.

Save your work

- From the File menu, select Save Scene As...

  In IRIX, enter the name bounce_01 at the end of the file's path.

  In Windows NT, enter the name bounce_01 in the File name box.

Windows NT Save As dialog box

- Press the Save button or press the Enter key.

  Make sure you save this file since you will be continuing with it in the next lesson.

**Note:** Throughout this book, you will be using the final saved file from one lesson as the start file for the next. Save your work at the end of each lesson to make sure that you have the start file ready.

**Conclusion**

Congratulations. You have completed your first exercise using Maya. In the next lesson, you will take this simple bouncing ball and refine the motion for more dramatic results.
Adding Character

In the last lesson, you built and animated a bouncing ball. As you playback the bounce, you can see that the ball seems to float and is not bouncing in a convincing manner. In this lesson, you will begin to edit the quality of the original animation to add character to the bounce.

This lesson will begin to layer the animation with secondary motion such as *squash and stretch*. In Maya, you can create these effects using non-linear deformers, that allow you to reshape the ball as it animates.

*Adding squash and stretch*

In this lesson you will learn the following:

- How to refine animated channels with the Graph Editor
- How to create a bend and a squash deformer
- How to set keyable and non-keyable channels
- How to use Set Driven Key
- How to use Auto Key
- How to create expressions
- How to edit an animation’s timing using the Dope sheet
Lesson 2
Refining the animated channels

Refining the animated channels
In the last lesson, the bouncing ball does not appear to bounce properly. It seems to float as it touches the ground instead of hitting hard as you would expect. To edit the quality of the bounce, you can use the Graph Editor to work with the animation channels.

1 Select the ball
   If you are continuing straight from Lesson 1, the ball may already be selected. If not, then you must select this object to work with the animated channels.
   - If the ball is not selected, then select it in one of the view panels.

2 Create a new panel layout
   You can switch the contents of a panel to other panel types such as lists or graphs.
   - In the perspective view panel’s Panels menu, select Saved Layouts → Persp/Graph.
     This places a perspective view panel above a Graph editor panel.
   - Click-drag down on the bar that separates the two panels to make the new perspective panel larger.
   - From the Graph Editor’s View menu, select Frame All.
     Now you can see all of the animation curves for the ball.

Tip: Remember that you can also access the View menu from the hotbox by pressing and holding the spacebar.

3 Focus on the Translate Y channel
   To focus on the up and down motion of the ball, you need to focus on the Translate Y channel.
   - Click on the Translate Y channel. Now only its curve is shown in the graph.
   - Press the Alt key and click-drag with the left and middle mouse buttons to dolly into the graph.
   - Press the Shift and Alt keys and click-drag up and down with the left and middle mouse buttons to dolly only along the Y-axis.
   - Press the Shift and Alt keys and click-drag up and down with the middle mouse button to track along the Y-axis.

42 Learning Maya
4 Edit the shape of the curve

The floating effect as the ball touches the ground is a result of the smoothing of the curve as it approaches a value of 0. This smoothing is created by the curve tangents. The tangents define the motion in between the keys. By editing the tangents, you will change how the ball moves between the keys.

- Click-drag over all of the points at the bottom of the bounce to select the keys.
- Press the Linear Tangents button to make the curve tangents meet at a point.

Tip: The same view tools used in the modeling views apply to other panel types. The Shift key constraint works in all view panels and with tumbling and tracking.

5 Edit the tangents at the keys

To accentuate the bounce even further, you can edit the actual tangents to make the curve steeper as it approaches the ground.
Press the **Break Tangents** button to break the connection between the opposite tangents at the key.

- Click-drag a selection box around the tangent handle on the first key.
- Make sure that you select only the tangent handle and not the key itself.
- Make sure that the **Move** tool is active.
- Click-drag with your middle mouse button to edit the curve’s tangent until it is almost vertical and you don’t get a bump at the next key.

*Action curve with keys highlighted*

- Playback the results in the Perspective view.

*Diagram of edited bounce*

The bounce is much more sharp and appears to be affected by gravity.

**Cleaning up your curves**

Now that the quality of the motion has been set, you can look for ways to clean up your animation curves so that unnecessary information is removed. For this scene, the extra curves will have little influence, but in larger scenes they can add up and affect performance.

1. **Remove static channels**

If an action curve is flat along its whole length then its value is not changing. This means that it is not being animated.
These curves should be removed to reduce the amount of data in the scene.

- In the name list, press the Ctrl key and click on the following channel names:
  
  * Translate Z;
  * Rotate X, Y and Z;
  * Scale X, Y and Z;
  * Visibility.

The Translate X and Translate Y should remain unselected.

2 Remove extra keys
In some cases, you may have keys on animated channels that don't contribute to the results. These keys are found when a straight line can be drawn from the key before to the key after.

- In the name list, click on the Translate X channel.
- Select View → Frame All.
- Use the Alt key to track and dolly so you can see the whole curve.

You will see that there are five redundant keys on this curve. Since you want the ball to move along a straight path, these keys are not required.

- Click-drag a selection box around the five middle keys.

![Static channels](image)

- From the Graph Editor's Edit menu, select Delete.

This removes the selected curves from your scene.

![Extra keys](image)

- Press the Delete key to remove the keys.

The resulting curve would now be easier to edit because there are no intermediate keys.

---

**Note:**
In the Channel box, you will see that the remaining input fields – Translate X and Translate Y – use a different background color (green on IRIX, orange on Windows NT). This color helps you distinguish channels which have been keyed.
LESSON 2
Adding a squash deformer

SQUASH AND STRETCH
One of the best methods to infuse your animation with life is to add *squash and stretch*. This traditional animation technique helps you avoid a rigid looking animation as the ball hits the ground with more emphasis and seems to soar as it leaps into the air. In Maya, you can create this effect using a squash deformer.

Adding a squash deformer
A deformer is a special object type that lets you reshape a surface or group of surfaces. By using deformers to change the shape of the object over time, you can create a more visually appealing animation.

1 Set up a front view
   - Go to frame 1.
     This will place the ball at its starting point.
   - In the perspective view’s Panels menu, select Panels → Orthographic → Front.
     This gives you a view of the ball looking down the Z-axis.
   - Dolly and track the view until you are looking at the side of the ball.

2 Add the squash to the ball
   - Select the *ball*.
   - Press F2 to go to the Animation menu set.
   - From the Deform menu, select Create Nonlinear → Squash.
   - This adds the squashHandle to the ball. You do not see any deformation yet since the squash attributes have not been edited.

3 Move and Scale the deformer
   - Move the squashHandle so that the manipulator is at the base of the ball.
   - Scale the squashHandle until the handle appears at the top of the ball.
     Now the squash will occur from the base of the ball instead of in its middle. This ensures that the bottom of the ball doesn’t leave the ground during the squash.
4 Test the squash’s Factor attribute
   - In the Channel box, click on the squash input node.
   - Select the Show Manipulator tool.
   - Click-drag on the middle manipulator handle to squash and stretch the ball.
   - When you are finished check the channel box and make sure that the Factor attribute is set to about 0.4 to give the ball a little stretch.

5 Test the playback of the ball
   - Dolly out of the view so that you can watch the whole bouncing motion.
   - Playback the animation.
     The ball animates but the deformation of the ball only works properly at frame 1. This is because the deformer is not moving with the ball.

6 Parent the deformer
   To make the deformer move with the ball, you need to parent the deform handle to the ball.
   - Go back to frame 1.
   - Select the squashHandle then press the shift key and select the ball.
   - Select Edit → Parent.
     You could also press the p key to parent the handle to the ball.
   - Playback the animation.
     Now the deformer moves with the ball.
Animate the squash

To animate the ball's squash and stretch, you could set keys, but if you later edited the timing of the ball's bouncing then these keys would have to be reset. For this reason, you will use a reactive animation technique called Set Driven Key.

This technique allows you to have one attribute drive another attribute. Since you know that you want the ball to squash when it touches the ground and stretch when it is in the air, you can use the ball's Y translation to drive the squash's factor attribute. Therefore if you later edit the timing of the ball's bouncing or change its Y translation, the squash will react appropriately and squash on cue.

1 Load the Set Driven Key window

The Set driven key window lets you choose which attribute will be the driver and which attribute(s) will be driven.

- From the Animate menu, select Set Driven Key \(\rightarrow\) Set - to open the Set Driven Key window.

Note: When you want to open an option window, you need to select the menu item then move your cursor over the square icon – .

- Select the ball.
- Click on the Load Driver button in the Set Driven Key window.
- In the right hand column of the Driver section, click on translate Y.

This sets up translate Y as the attribute that will drive the action.

Driver attribute highlighted

- Select the squashHandle.
- Highlight the squash input node in the Channel box.
- Click on the Load Driven button in the Set Driven Key window.

Both the squash input node and the squashHandle node are loaded. You will only be using the squash node.

- In the left hand column of the Driven section, click on squash.
- Click on factor in the right hand column to highlight it as the driven attribute.

Driven attribute highlighted
2 Key the initial position
- Go to frame 1.
- Again highlight the squash input node in the Channel box.
- Set the squash node’s factor attribute to show the ball in a squashed position.
  The image below shows a value of about -0.5.
  You can either use the Channel box or the Show Manipulator tool.
- Click on the Key button in the Set Driven Key window.

3 Key the second position
- Go to frame 30.
- Set the squash node’s factor attribute to show the ball in a stretched position.
- Click on the Key button in the Set Driven Key window.

4 Edit the Animation curve
- Select the squashHandle.
- In the Graph editor, click on the attribute labelled > ball.translate Y.
- From the editor’s View menu, select Frame all.
  Now you can see a straight line mapping the ball’s translate Y attribute to the squash’s factor attribute.
- Edit the curve as shown in the following image.
  Now the ball will have a more subtle squash when it is near the ground and an exaggerated stretch when it is high in the air.

The stretched ball

The squashed ball
2 Parent the deformer

To make the deformer move with the ball, you need to parent the deform handle to the ball.

- From the Window menu, select Outliner.

This window offers you a listing of all the objects in the scene.

With your middle mouse button drag the bendHandle onto the ball node.

Bending the ball

As the ball goes into and out of a bounce, it might be helpful to have it lean forward as it bounces up and lean back as it falls. You can do this with a second deformer. This time you will use a bend deformer.

This will help give the appearance that the ball is propelling itself forward each time it hits the ground. This will give the ball a life of its own as it bounces along.

1 Add a Bend deformer

- Go to frame 1.

- Select the ball.

- From the Deform menu, select Create Nonlinear → Bend.

Just like the Squash deformer, the Bend adds a bendHandle and a bend node to the ball. The bendHandle node is currently highlighted.

Parenting the bendHandle

- Click on the plus sign next to the ball node to open up the hierarchy.

Now you can see that the ball is the parent of the two deformer handles.

Viewing the hierarchy

- Close the outliner window.
3 Key the bend node’s curvature
The bend node has an attribute called curvature that is used to control how much bending will occur. This is the attribute that you will set keys on in order to animate the bending of the ball.

- In the Channel box, click on the bend Input node to open it up.
- Click on the Curvature attribute’s name to highlight it.
- From the Channel box’s Channels menu, select Key Selected.
This sets a start key for the curvature attribute.

4 Turn on Auto Keying
To set more keys for the curvature, you will use Auto key. This method of keying lets you set keys by simply changing the attribute value.

- Turn on Auto Key.
Now when you update an attribute that has existing keys, a key will be set automatically.

5 Edit the bend’s boundary
- Go to frame 5.
- Make sure that the bend input node’s name is highlighted in the channel box.
- Select the Show Manipulator tool.
This tool displays some handles that let you edit the attributes of the bend deformer. This gives you interactive control over the deformer’s attributes.

- Click drag on the top manipulator to extend the high bound of the deformer.
This will ensure that the bending works properly when the ball is fully stretched.

6 Edit the curvature
- Click-drag to the right on the center manipulator handle to edit the bend node’s curvature. Stop when the ball is bending forward. The value in the Channel box should read about 0.5.
A new key has been set. Auto Key creates the new key when you adjust the curvature attribute.

Bending forward
LESSON 2
Editing timing

7 Set another key
- Go to frame 15.
- Drag to the left on the center manipulator handle to bend the ball back. This will set the node’s curvature to about -0.6.
Another key is set by Auto Key.
You can edit the timing of your keys in the Graph Editor.

Earlier, you edited the quality of the animation using the Graph Editor. To edit the timing of the bouncing, you can also use the Dope sheet. The Dope sheet lets you focus on timing without having to look at all of the curve information.

1 Select keys in the Dope sheet
- Make sure the bendHandle node is selected and the bend node is not highlighted in the Channel box.
- In the Graph editor panel’s Panels menu, select Panel → Dope Sheet.
This window shows each channel as a series of ticks on a long bar which represent frames. Some of these are highlighted with color bars that show you where keys have been set. The top bar shows a summary of the keys while each channel of the selected nodes has its own bar.
- Click on the plus sign next to the bendHandle node that is in the square.
- Click on the second plus sign next to the bendHandleShape node that is in the circle.
- With the left mouse button, click on the key at frame 15.
It will be the only key highlighted in yellow.
- Press the Shift key and click with the left mouse button on the keys at frames 35 and 55.

8 Continue animating the bending
- Use the Auto key method to set new keys for the bend node’s curvature so that the ball bends back at frames 25 and 45 and forward at frames 35 and 55.
- Go to frame 60 and change your curvature to 0.
- Change the front view panel back to a perspective panel.
- Playback the results.

Editing timing
To give the impression that the ball is pushing off as it bounces, you will have to edit the timing of the bend action. The goal is to move the bend action closer to the bounce of the ball to make it appear more immediate.
2 Move the ball shear keys

- Select the Move tool.
- With the middle mouse button, click-drag to the right in the Dope sheet until the first key is at about frame 19.

3 Edit the shape of the curve

While editing the timing of the bending in the dope sheet helps a bit, you may not be getting the look that you want. To edit how the curve reacts between the keys, you can edit the shape of the curve in the Graph editor.

- In the Dope Sheet’s Panels menu, select Panel → Graph Editor
- Use the techniques learned earlier in the lesson to reshape the curve as shown below:

Reshaped curve

The key is that when the ball hits the ground, the bending changes sharply to emphasize the bounce.
- Playback the results.

4 Save your work

- From the File menu, select Save Scene As...
- Enter the name bounce_2 next to the file’s path.
- Press the Save button or press the Enter key.

Tip: It is a good idea to give your file a new name after significant changes have been made. The different files give you a record of past stages in case you want to go back. Once you have saved a few versions, you can clear earlier files to help conserve disk space.
LESSON 2
Conclusion

You have now added some character to the bouncing ball. In the next lesson, you will learn how to texture and light your scene in order to begin creating rendered animations.

If desired, you could now use the Dope sheet or the Graph editor to further refine the quality and timing of the various channels to achieve a bounce with different kinds of character. You might want the ball to bounce higher or the bending to be more subtle.

This refinement is ultimately your role as an animator. While the actual work of setting keys is finished, you will find that the refinement stage could become the most time-consuming, and yet the most rewarding. Since this book is focused on technique, the refinement will be left up to you to add at the end of each lesson.